Cisco ONS 15454 SONET/SDH ML シリーズ マルチレイヤ イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド
インターフェイスの設定
インターフェイスの設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

インターフェイスの設定

インターフェイス設定

MAC アドレス

インターフェイス ポート ID

インターフェイスの設定方法

インターフェイスについて

ファーストイーサネット インターフェイスの設定(ML100T-12)

ギガビットイーサネット インターフェイスの設定(ML1000-2)

ファーストイーサネット インターフェイスとギガビットイーサネット インターフェイスのモニタリング操作

ML シリーズ カード上の POS

ML シリーズ SONET/SDH の伝送速度

SONET フレームの基本

C2 バイト

C2 バイトとスクランブリング

サード パーティ製 POS インターフェイス

ML シリーズ POS インターフェイスの設定

POS インターフェイスと POS コントローラでのモニタリング操作

その他の設定

MTU サイズの設定

フレーム同期の設定

POS SPE スクランブリングの設定

SONET/SDH アラームの設定

SONET/SDH 遅延トリガーの設定

一般的な ML シリーズ POS 設定

ML シリーズ カード同士

ML シリーズ カードと Cisco 12000 GSR シリーズ ルータ

ML シリーズ カードと G シリーズ カード間

インターフェイスの設定

この章では、ML シリーズ カードをアップして実行するための ML シリーズ カードの基本インターフェイスの設定について説明します。この章で使用する Cisco IOS コマンドの詳細については、『 Cisco IOS Command Reference 』を参照してください。

この章の内容は次のとおりです。

「インターフェイス設定」

「インターフェイスの設定方法」

「インターフェイスについて」

「ML シリーズ カード上の POS」

「ML シリーズ POS インターフェイスの設定」

「一般的な ML シリーズ POS 設定」


) ML シリーズ カードの初期設定が完了してからインターフェイスを設定してください。


インターフェイス設定

ML シリーズ カードの主な機能はデータ リンク間でパケットを中継することです。したがって、パケットを送受信するインターフェイスの特性を設定する必要があります。インターフェイスの特性には IP アドレス、ポートのアドレス、データ カプセル化方式、およびメディア タイプなどがあります。

多数の機能がインターフェイスごとに有効にされます。インターフェイス設定モードには、イーサネット ポートなどのインターフェイスの動作を修正するコマンドがあります。interface コマンドを入力する場合は、インターフェイスのタイプと番号を指定する必要があります。

次の一般的なガイドラインは、すべての物理インターフェイスと仮想インターフェイスの設定に当てはまります。

すべてのインターフェイスに名前があります。名前はインターフェイス タイプ(ワード)とポート ID(番号)から成ります。例としては、ファーストイーサネット 2 があります。

それぞれのインターフェイスは、ブリッジ グループ、または IP アドレスと IP サブネット マスクを使用して設定します。

VLAN はサブインターフェイスを使用することによりサポートされます。サブインターフェイスとは、関連付けられた物理インターフェイスとは別に設定された論理インターフェイスです。

それぞれの物理インターフェイスと内部 packet-over-SONET/SDH(POS)インターフェイスには、MAC アドレスが割り当てられています。

MAC アドレス

イーサネット ネットワークに接続するポートまたは装置ごとに MAC アドレスが必要です 。ネットワークの他の装置が、特定のポートをネットワーク内で検索したり、ルーティング テーブルとデータ構造を作成および更新したりするために MAC アドレスを使用します。

装置の MAC アドレスを検索するには、 show interfaces コマンドを次のように使用します。

Router# sh interfaces fastEthernet 0
FastEthernet0 is up, line protocol is up
Hardware is epif_port, address is 0005.9a39.6634 (bia 0005.9a39.6634)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, Auto Speed, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:18, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
11 packets input, 704 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast
0 input packets with dribble condition detected
3 packets output, 1056 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

インターフェイス ポート ID

インターフェイス ポート ID によって、ML シリーズ カードのインターフェイスの物理的な位置が指定されます。この ID は、設定しているインターフェイスを特定する名前です。システム ソフトウェアは、インターフェイス ポート ID によって ML シリーズ カードのアクティビティが制御され、ステータス情報が表示されます。インターフェイス ポート ID は、ネットワークの他の装置が使用することはなく、個々の ML シリーズ カードおよびその内部のコンポーネントとソフトウェアに固有です。

12 個のファーストイーサネット インターフェイスの ML100T-12 ポート ID は 0 ~ 11 です。2 個のギガビットイーサネット インターフェイスの ML1000-2 ポート ID は 0 ~ 1 です。どちらの ML シリーズ カードも 2 個の POS ポートを使用します。2 個の POS インターフェイスの ML シリーズ ポート ID は POS 0 と POS 1 です。ユーザ定義省略形を使用できます。たとえば、12 個のファーストイーサネット インターフェイスの設定には f0 ~ f11、2 個のギガビットイーサネット インターフェイスの設定には gi0 または gi1、および 2 個の POS ポートの設定には POS0 と POS1 です。

Cisco IOS show コマンドを使用すると、ML シリーズ カードの任意またはすべてのインターフェイスに関する情報を表示できます。


注意 g0 または g1 は、ギガビットイーサネットのユーザ定義省略形として使用しないでください。使用すると、サポートされないグループ非同期インターフェイスが作成されます。

インターフェイスの設定方法

次の一般的な設定方法は、すべてのインターフェイスに当てはまります。インターフェイスを設定する前に、ブリッジまたはルーティングされるネットワークの計画を作成しておいてください。

インターフェイスを設定するには、次の手順を実行します。


) ルータまたはスイッチは、マニュアルでは一般的な言葉として使用しています。お使いの装置に読み替えてください。



ステップ 1 特権 EXE プロンプトで configure EXEC コマンドを入力してグローバル設定モードを開始します。

Router> enable
Password:
Router# configure terminal
Router(config)#
 

ステップ 2 interface コマンド、インターフェイス タイプ(fastethernet、gigabitethernet、pos など)、インターフェイス ポート ID(「インターフェイス ポート ID」を参照)の順に入力します。

たとえば、ギガビットイーサネット ポートを 1 つ設定するには、次のコマンドを入力します。

Router(config)# interface gigabitethernet number
 

ステップ 3 それぞれの interface コマンドの後に、設定するインターフェイスに必要なインターフェイス設定コマンドを入力します。

入力するコマンドによって、インターフェイス上で起動するプロトコルとアプリケーションが定義されます。ML シリーズ カードは、別の interface コマンドまたはインターフェイス設定コマンド以外のコマンドが入力されるまでは、コマンドを集め、 interface コマンドに適用します。 end を入力して特権 EXEC モードに戻ることもできます。

ステップ 4 EXEC の show interface コマンドを入力して設定したインターフェイスのステータスを確認します。

Router# sh interface fastEthernet 0
FastEthernet0 is up, line protocol is up
Hardware is epif_port, address is 0005.9a39.6634 (bia 0005.9a39.6634)
MTU 1500 bytes, BW 100000 Bit, DLY 100 use,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, Auto Speed, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:18, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
11 packets input, 704 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast
0 input packets with dribble condition detected
3 packets output, 1056 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 


 

インターフェイスについて

ML シリーズ カードは、ファーストイーサネット、ギガビットイーサネット、および POS の各インターフェイスをサポートします。ここでは、すべてのインターフェイス タイプの設定例をいくつか説明します。

ファーストイーサネット、ギガビットイーサネット、または POS のインターフェイス上で IP アドレスまたはブリッジ グループ番号を設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface type number

インターフェイス設定モードを起動して、ギガビットイーサネット インターフェイス、ファーストイーサネット インターフェイス、または POS インターフェイスのいずれかを設定します。

ステップ 2

Router(config-if)# { ip address ip-address subnet-mask | bridge-group bridge-group-number }

インターフェイスに割り当てる IP アドレスと IP サブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスを有効にします。

ステップ 4

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 5

Router# copy running-config startup-config

(オプション)設定の変更をタイミング制御用カード(TCC2)のフラッシュ データベースに保存します。


) ステップ 1 ~ 3 までを繰り返して ML シリーズ カードの他のインターフェイスを設定します。


ファーストイーサネット インターフェイスの設定(ML100T-12)

ファーストイーサネット インターフェイス上で IP アドレスまたはブリッジ グループ番号、自動ネゴシエーション、およびフロー制御を設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface fastethernet number

インターフェイス設定モードを起動してファーストイーサネット インターフェイスを設定します。

ステップ 2

Router(config-if)# { ip address ip-address subnet-mask | bridge-group bridge-group-number }

インターフェイスに割り当てる IP アドレスと IP サブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# [ no ] speed { 10 | 100 | auto }

伝送速度を 10 または 100 MBps に設定します。speed または duplex を auto に設定した場合、システムで自動ネゴシエーションが有効になり、ML シリーズ カードはパートナー ノードの speed および duplex モードと一致します。

ステップ 4

Router(config-if)# [ no ] duplex { full | half | auto }

全二重モード、半二重モード、または自動ネゴシエーション モードを設定します。

ステップ 5

Router(config-if)# flowcontrol send { on | off | desired }

(オプション)インターフェイスのフロー制御値送信を設定します。フロー制御は、ポートレベルのポリシングを使用した場合にのみ機能します。

ステップ 6

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスを有効にします。

ステップ 7

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 8

Router# copy running-config startup-config

(オプション)設定の変更を TCC2 フラッシュ データベースに保存します。

例4-1に、IP アドレス、自動ネゴシエーション速度、および自動ネゴシエーション二重を使用したファーストイーサネット インターフェイスの初期設定方法を示します。

例4-1 ファーストイーサネット インターフェイスの初期設定

Router(config)# interface fastethernet 1
Router(config-if)# ip address 10.1.2.4 255.0.0.0
Router(config-if)# speed auto
Router(config-if)# duplex auto
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config
 

ギガビットイーサネット インターフェイスの設定(ML1000-2)

ギガビットイーサネット インターフェイス上で IP アドレスまたはブリッジ グループ番号、自動ネゴシエーション、およびフロー制御を設定するには、最初にグローバル設定モードで次の手順を実行します。


) ネゴシエーション モードのデフォルト設定は、ギガビットイーサネットおよびファーストイーサネットのインターフェイスの場合は auto です。ギガビットイーサネット ポートは、常に全二重モードの 1000 MBps で動作します。


 

コマンド
目的

ステップ 1

Router# interface gigabitethernet number

インターフェイス設定モードを起動してギガビットイーサネット インターフェイスを設定します。

ステップ 2

Router(config-if) # { ip address ip-address subnet-mask | bridge-group bridge-group-number }

IP アドレスおよびサブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# [ no ] negotiation auto

ネゴシエーション モードを auto に設定します。ギガビットイーサネット ポートはリンクとパートナー ポートのネゴシエーションを試行します。

パートナー ポートの設定に関係なくポートによってリンクアップを強制的に起動する場合は、ギガビットイーサネット インターフェイスを no negotiation auto に設定します。

ステップ 4

Router(config-if)# flowcontrol { send | receive } { on | off | desired }

(オプション)インターフェイスのフロー制御値の送信または受信を設定します。フロー制御は、ポートレベルのポリシングを使用した場合にのみ機能します。

ステップ 5

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスを有効にします。

ステップ 6

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

Router# copy running-config startup-config

(オプション)設定の変更を TCC2 フラッシュ データベースに保存します。


) ステップ 1 ~ 4 を繰り返して他のギガビットイーサネット インターフェイスを設定します。


例4-2に、自動ネゴシエーションと IP アドレスを使用したギガビットイーサネット インターフェイスの初期設定方法を示します。

例4-2 ギガビットイーサネット インターフェイスの初期設定

Router(config)# interface gigabitethernet 0
Router(config-if)# ip address 10.1.2.3 255.0.0.0
Router(config-if)# negotiation auto
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config
 

ファーストイーサネット インターフェイスとギガビットイーサネット インターフェイスのモニタリング操作

ファーストイーサネット インターフェイスを設定した後に設定を確認するには、show interface コマンドを入力します。

例4-3に show interface コマンドの出力を示します。ポート速度と二重の動作を含むファーストイーサネット インターフェイスのステータスが表示されます。

例4-3 show interface コマンドの出力

Router# show interface fastEthernet 0
FastEthernet0 is up, line protocol is up
Hardware is epif_port, address is 0005.9a39.6634 (bia 0005.9a39.6634)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:23, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast
0 input packets with dribble condition detected
4 packets output, 1488 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

ファーストイーサネット コントローラ チップに関する情報を表示するには、show controller コマンドを入力します。

例4-4に、show controller コマンドの出力を示します。初期化ブロック情報、送信リング、受信リング、およびエラーの情報などが含まれる統計情報が表示されます。

例4-4 show controller コマンドの出力

Router# show controller fastEthernet 0
IF Name: FastEthernet0
Port Status DOWN
Send Flow Control : Disabled
Receive Flow Control : Enabled
MAC registers
CMCR : 0x0000042D (Tx Enabled, Rx Disabled)
CMPR : 0x150B0A80 (Long Frame Disabled)
FCR : 0x0000A00B (Rx Pause detection Enabled)
MII registers:
Control Register (0x0): 0x4000 (Auto negotiation disabled)
Status Register (0x1): 0x7809 (Link status Down)
PHY Identification Register 1 (0x2): 0x40
PHY Identification Register 2 (0x3): 0x61D4
Auto Neg. Advertisement Reg (0x4): 0x1E1 (Speed 100, Duplex Full)
Auto Neg. Partner Ability Reg (0x5): 0x0 (Speed 10, Duplex Half)
Auto Neg. Expansion Register (0x6): 0x4
100Base-X Aux Control Reg (0x10): 0x2000
100Base-X Aux Status Register(0x11): 0x0
100Base-X Rcv Error Counter (0x12): 0x0
100Base-X False Carr. Counter(0x13): 0x0
 

ファーストイーサネット インターフェイスの設定に関する情報を表示するには、show run interfaces fastEthernet 0 コマンドを入力します。複数のインターフェイスがあり、特定のインターフェイスの設定を表示する場合にこのコマンドは便利です。

例4-5に、show controller コマンドの出力を示します。IP または IP アドレスの不足、およびインターフェイスの状態に関する情報が含まれます。

例4-5 show controller コマンドの出力

daytona# show run interface fastEthernet 0
Building configuration...
 
Current configuration : 56 bytes
!
interface FastEthernet0
no ip address
shutdown
 
end
 

ML シリーズ カード上の POS

Packet over SONET/SDH(POS)は、2 つのポイント間で IP トラフィックを高速転送する方式です。このテクノロジでは、Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)および SONET インターフェイスと SDH インターフェイスを組み合わせています。SONET は、ANSI 標準(T1.105.1988)によって規定された光デジタル伝送のオクテット同期多重化方式です。ETS によって規定されている SDH も同様です。

ML シリーズ SONET/SDH の伝送速度

SONET 伝送速度は 51.840 MBps の整数倍です。 表 4-1 に、サポートされる伝送の倍数を示します。

 

表 4-1 ML シリーズ カードによってサポートされる伝送の倍数

トポロジ
サポートされるサイズ

両方の終端が ML シリーズ カードの回線

STS-1、STS-3c、STS-6c、STS-9c、STS-12c、および STS-24c(SONET)、あるいは VC4、VC4-2c、VC4-3c、VC4-4c、および VC4-8c(SDH)

終端が G シリーズ カードと ML シリーズ カードの回線

STS-1、STS-3c、STS-6c、STS-9c、および STS-12c(SONET)、あるいは VC4、VC4-2c、VC4-3c、VC4-4c、および VC4-8c(SDH)

終端が ML シリーズ カードと外部 POS 装置の回線

STS-3c および STS-12c(SONET)、あるいは VC4 および VC4-4c(SDH)

SONET フレームの基本

SONET はレイヤ化されたアーキテクチャを使用するレイヤ 1 プロトコルです。図 4-1に、SONETの 3 つのレイヤであるセクション、ライン、およびパスを示します。section overhead(SOH; セクション オーバヘッド)と line overhead(LOH; ライン オーバヘッド)は transport overhead(TOH; トランスポート オーバヘッド)を構成し、path overhead(パス オーバヘッド)と実際の ペイロード(ペイロード キャパシティ)は synchronous payload envelope(SPE; 同期ペイロード エンベロープ)を構成します。各レイヤは多数のオーバヘッド バイトを SONET フレームに追加します。

図 4-1 SONET の 3 つのレイヤ

 

C2 バイト

SONET フレーム内のオーバーヘッド バイトの 1 つに C2 バイトがあります。SONET 規格では、C2 バイトをパス信号ラベルとして定義しています。このバイトの目的は、SONET Framing Overhead(FOH; フレーミング オーバーヘッド)でカプセル化されているペイロード タイプをやり取りすることです。C2 バイトの機能は、EtherType および Logical Link Control(LLC; 論理リンク制御副層)/Subnetwork Access Protocol(SNAP; サブネットワーク アクセス プロトコル)のヘッダー フィールドと似ていますが、C2 バイトでは単一のインターフェイスで複数のペイロード タイプを同時に送信できます。 表 4-2 に、C2 バイトの 16 進数値を示します。

 

表 4-2 C2 バイトの共通値

16 進数値
SONET ペイロードのコンテンツ

00

未実装

01

実装。不特定のペイロード

02

Virtual Tributary(VT; 仮想トリビュタリ)の内部(デフォルト)

03

ロック モードの VT(現在はサポート対象外)

04

非同期 DS-3 マッピング

12

非同期 DS-4NA マッピング

13

Asynchronous Transfer Mode(ATM; 非同期転送モード)セル マッピング

14

Distributed Queue Dual Bus(DQDB; 分散型キュー二重バス)プロトコル セル マッピング

15

非同期 Fiber Distributed Data Interface(FDDI; ファイバ分散データ インターフェイス)マッピング

16

PPP 内部の IP、スクランブリングを使用

CF

PPP 内部の IP、スクランブリングを使用しない

FE

テスト信号マッピング(TU-T G.707 を参照)

C2 バイトとスクランブリング

表 4-2 に示すように、POS インターフェイスは ATM 形式のスクランブリングが有効かどうかに応じて iC2 バイトに 0x16 または 0xCF の値を使用します。PPP over SONET を規定する RFC 2615 では、C2 バイト値をスクランブリング設定に基づいて使用することを義務付けています。RFC では、C2 バイト値を次のように定義しています。
「X^43+ 1 スクランブリング [4] を使用する PPP を示す場合は、22(16 進数)の値を使用します。RFC 1619(STS-3c-SPE/VC-4 のみ)との互換性を維持するために、スクランブリングがオフに設定されている場合は、値 207(CF 16 進数)をパス信号ラベルに使用し、スクランブリングされていない PPP を示します。」

つまり、次のようになります。

スクランブリングが有効になっている場合は、POS インターフェイスは C2 値として 0x16 を使用します(PPP および high-level data link control (HDLC; 高レベル データリンク制御) カプセル化)。

スクランブリングが無効になっている場合は、POS インターフェイスは C2 値として 0xCF を使用します(PPP および HDLC カプセル化)。

LEX カプセル化はスクランブリング設定に関係なく 0x01 の C2 値を使用します。

デフォルト C2 値である 0x16 (10 進数では 22)を使用しているほとんどの POS インターフェイスでは、設定に pos flag c2 22 コマンドが挿入されています。ただし、この行はデフォルトであるために設定実行時に表示されません。デフォルトを変更するには、例4-6に示すpos flag c2 コマンドを使用します。

例4-6 pos fag c2 コマンド

Router(config-if)# pos flag c2 ?
<0-255> byte value, default 0x16
 

) C2 値をデフォルト値から変更しても POS スクランブリング設定には影響しません。


変更を確認するには、show run コマンドを使用します。show controller pos コマンド(例4-7)は受信値と送信値および C2 値を出力します。したがって、ローカル エンドで値を変更しても show controller コマンドの出力値は変わりません。

例4-7 show controller pos コマンド

Router# sh controllers pos 0
Interface POS0
Hardware is Packet/Ethernet over Sonet
PATH
PAIS = 0 PLOP = 0 PRDI = 0 PTIM = 0
PPLM = 0 PUNEQ = 0 PPDI = 0
BER_SF_B3 = 0 BER_SD_B3 = 0 BIP(B3) = 14 REI = 155
NEWPTR = 0 PSE = 0 NSE = 0
 
Active Alarms : None
Demoted Alarms: None
Active Defects: None
Alarms reportable to TCC/CLI: PAIS PRDI PLOP PUNEQ PPLM PTIM PPDI BER_SF_B3 BER_
SD_B3
Link state change defects: PAIS PLOP PRDI PPDI BER_SF_B3
Link state change time : 200 (msec)
 
DOS FPGA channel number: 0
Starting STS (0 based) : 0
Circuit size : STS-24c
RDI Mode : 1 bit
C2 (tx / rx) : 0x01 / 0x01
Framing : SONET
 
Path Trace
Mode : off
Buffer : Unstable
Remote hostname :
Remote interface:
Remote IP addr :
 
B3 BER thresholds:
SFBER = 1e-5, SDBER = 1e-7
 
 
1106 total input packets, 80059 post-HDLC bytes
0 input short packets, 80714 pre-HDLC bytes
0 input long packets , 205 input runt packets
17 input CRCerror packets , 0 input drop packets
0 input abort packets
1107 input packets dropped by ucode
 
 
0 total output packets, 0 output pre-HDLC bytes
0 output post-HDLC bytes
 
Carrier delay is 200 msec
 

show interface pos0 コマンドによってスクランブリングが表示されます。

daytona# show interface pos0
POS0 is up, line protocol is up
Hardware is Packet/Ethernet over Sonet, address is 0005.9a3b.bf90 (bia 0005.9a3b.bf90)
MTU 1500 bytes, BW 1244160 Kbit, DLY 100 usec,
reliability 243/255, txload 1/255, rxload 166/255
Encapsulation ONS15454-G1000, crc 32, loopback not set
Keepalive set (10 sec)
Scramble enabled
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 2385314109 bytes
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 parity
2839625 input errors, 2839625 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
9 packets output, 3393 bytes, 0 underruns
0 output errors, 0 applique, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
 

サード パーティ製 POS インターフェイス

サード パーティ製装置と接続したときにシスコ社の POS インターフェイスがアップしない場合は、スクランブリング設定、cyclic redundancy check(CRC; サイクリック冗長性検査)設定、および C2 バイトでアドバタイズされた値を確認します。Juniper Networks 製ルータでは、RFC 2615 モードを設定すると、次の 3 つのパラメータが設定されます。

スクランブリングの有効化

C2 値の 0x16

CRC-32

従来は、スクランブリングが有効化されていると、サード パーティ製装置が 0xCF の C2 値を使用し続けるため、スクランブルされたペイロードが適切に反映されませんでした。

ML シリーズ POS インターフェイスの設定

POS インターフェイスを設定するには、最初にグローバル設定モードで次の手順を実行します。POS ポートでカプセル化を変更できるのは、インターフェイスが手動でシャットダウン(ADMIN_DOWN)されているときだけです。

 

コマンド
目的

ステップ 1

Router(config)# interface pos number

インターフェイス設定モードを起動して POS インターフェイスを設定します。POS インターフェイスは、SONET/SDH 回線の作成後に作成されます。

ステップ 2

Router(config-if) # { ip address ip-address subnet-mask | bridge-group bridge-group-number }

IPアドレスおよびサブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if) # shutdown

インターフェイスを手動でシャット ダウンします。POS ポートでカプセル化できるのは、インターフェイスがシャットダウン(ADMIN_DOWN)されているときだけです。

ステップ 4

Router(config-if)# encapsulation type

カプセル化のタイプを設定します。有効な値は次のとおりです。

hdlc:Cisco HDLC

lex:(デフォルト)Cisco ONS G シリーズ イーサネット ライン カードと併用するための LAN 拡張、特殊なカプセル化

ppp:ポイントツーポイント プロトコル

ステップ 5

Router(config-if)# pos flag c2 byte value

(オプション)C2 バイト値を設定します。有効な値は、0 ~ 255(10 進数)です。LEX のデフォルト値は 0x01(16 進数)です。

ステップ 6

Router(config-if) # no shutdown

シャットダウン インターフェイスを再起動します。

ステップ 7

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 8

Router# copy running-config startup-config

(オプション)設定の変更を NVRAM に保存します。


) POS インターフェイスは、SONET STS または SDH STM 回線が作成されてから表示されます。


POS インターフェイスと POS コントローラでのモニタリング操作

例4-8に、show interface コマンドの出力を示します。この出力には POS インターフェイスのステータスとグローバル パラメータが表示されます。

例4-8 show interfaceコマンド

Router# show interface pos 0
POS0 is up, line protocol is up
Hardware is Packet/Ethernet over Sonet, address is 0005.9a39.6630 (bia 0005.9a
39.6630)
MTU 1500 bytes, BW 311040 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ONS15454-G1000, crc 32, loopback not set
Keepalive set (10 sec)
Scramble enabled
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:02:34, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1107 packets input, 11267427 bytes
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 parity
1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 applique, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
 

例4-9に、show controllers コマンドの出力を示します。この出力には POS コントローラが表示されます。

例4-9 show controllers コマンド

Router# show controllers pos 0
Interface POS0
Hardware is Packet/Ethernet over Sonet
PATH
PAIS = 1 PLOP = 0 PRDI = 0 PTIM = 0
PPLM = 0 PUNEQ = 0 PPDI = 0
BER_SF_B3 = 0 BER_SD_B3 = 0 BIP(B3) = 2975 REI = 7
NEWPTR = 1 PSE = 0 NSE = 0
 
Active Alarms : None
Demoted Alarms: None
Active Defects: None
Alarms reportable to CLI: PAIS PRDI PLOP PUNEQ PPLM PTIM PPDI BER_SF_B3 BER_
3
Link state change defects: PAIS PLOP PRDI PPDI BER_SF_B3
Link state change time : 200 (msec)
 
DOS FPGA channel number: 0
Starting STS (0 based) : 0
Circuit size : STS-6c
RDI Mode : 1 bit
C2 (tx / rx) : 0x01 / 0x01
Framing : SONET
 
Path Trace
Mode : off
Buffer : Unstable
Remote hostname :
Remote interface:
Remote IP addr :
 
B3 BER thresholds:
SFBER = 1e-5, SDBER = 1e-7
 
1107 total input packets, 11267259 post-HDLC bytes
0 input short packets, 11267427 pre-HDLC bytes
0 input long packets , 0 input runt packets
1 input CRCerror packets , 0 input drop packets
0 input abort packets
945 input packets dropped by ucode
 
 
0 total output packets, 0 output pre-HDLC bytes
0 output post-HDLC bytes
 
Carrier delay is 200 msec
 

その他の設定

遠端のインターフェイスのプロパティと一致させるために追加のプロパティを設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config-if)# no keepalive

キープアライブ メッセージをオフにします。キープアライブ メッセージは必須ではありませんが、推奨されています。

ステップ 2

Router(config-if)# crc { 16 | 32 }

CRC 値を設定します。POS モジュールに接続している装置がデフォルト CRC 値の 32 をサポートしない場合は、16 の値を使用するように両方の装置を設定します。

MTU サイズの設定

maximum transmission unit(MTU; 最大伝送ユニット)サイズを設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface pos number

インターフェイス設定モードを開始し、設定する POS インターフェイスを指定します。

ステップ 2

Router(config-if)# mtu bytes

最大 9000 バイトまでの MTU サイズを設定します。表 4-3を参照してください。

表 4-3 に、デフォルト MTU サイズを示します。

 

表 4-3 デフォルト MTU サイズ

カプセル化タイプ
デフォルト サイズ

LEX(デフォルト)

1500

HDLC

4470

PPP

4470

フレーム同期の設定

Cisco IOS 設定は必要ありません。フレーム同期タイプは、回線設定時に決定されます。

POS SPE スクランブリングの設定

POS SPE スクランブリングを設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface pos number

インターフェイス設定モードを開始し、設定する POS インターフェイスを指定します。

ステップ 2

Router(config-if)# no pos scramble-spe

ペイロード スクランブリングをインターフェイス上で無効にします。ペイロード スクランブリングはデフォルトでは有効に設定されています。

ステップ 3

Router(config-if)# no shutdown

以前の設定を使用してインターフェイスを有効にします。

SONET/SDH アラームの設定

SONET/SDH アラームを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface pos interface

インターフェイス設定モードを開始し、設定する POS インターフェイスを指定します。

ステップ 2

Router(config-if)# pos report { b1-tca | b2-tca | b3-tca | lais | lrdi | pais | plop | prdi | plm-p | ptim | sd-ber | sf-ber | uneq-p }

選択した SONET/SDH アラームのコンソール ロギングを許可します。

アラームは次のとおりです。

pais (パス アラーム表示信号)

plop (パス ポインタ異常)

prdi (パス リモート障害表示)

plm (ペイロード ラベル、C2 ミスマッチ)

ppdi (パス ペイロード障害表示)

ptim (パス トレース ID ミスマッチ)

sd-ber-b3 (PBIP BER SD しきい値超過)

sf-ber-b3 (PBIP BER SF しきい値超過)

uneq-p (パス ラベルゼロ障害 )

POS インターフェイスで報告するアラームを決定して bit error rate(BER; ビット誤り率)しきい値を表示するには、 show controllers pos コマンドを使用します。「POS インターフェイスと POS コントローラでのモニタリング操作」を参照してください。 pos report コマンドの詳細については、『 Cisco IOS Interface Command Reference 』を参照してください。


) Cisco IOS アラーム報告コマンドは、Cisco IOS CLI にのみ適用されます。TCC2 に報告される SONET/SDH アラームは影響を受けません。


SONET/SDH 遅延トリガーの設定

トリガーとは、アサートされたときライン プロトコルをダウンさせる可能性があるアラームです。 表 4-4 に、パス アラームを示します。パス アラームはトリガーとして設定でき、遅延を指定することもできます。

表 4-4 設定可能なパス アラームのトリガー

アラーム
内容

all

すべてのリンク ダウン アラーム障害

ber_sd_b3

PBIP BER SD しきい値超過障害

ber_sf_b3

PBIP BER SD しきい値超過障害 <デフォルト>

pais

パス アラーム表示信号障害 <デフォルト>

plop

パス ポインタ異常障害 <デフォルト>

ppdi

パス ペイロード障害表示障害(LEX カプセル化ではデフォルトで設定)

prdi

パス リモート障害表示障害

ptim

パス トレース ID ミスマッチ

puneq

パス ラベル ゼロ障害

表 4-4 に示すパス アラームをトリガーとして設定するには、 pos trigger defects コマンドを入力します。トリガによってインターフェイスのライン プロトコルがダウンします。パス アラームをトリガーとして設定する場合は、pos trigger delay コマンドを使用してトリガーの遅延を同時に指定できます。遅延は 200 ~ 2000 ミリ秒に設定できます。間隔を指定しないと、遅延はデフォルトの 200 ミリ秒に設定されます。

インターフェイスのライン プロトコルのダウンをトリガーする遅延を設定するには、最初にグローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# interface pos interface

インターフェイス設定モードを開始し、設定する POS インターフェイスを指定します。

ステップ 2

Router(config-if)# pos trigger delay millisecond

インターフェイスのライン プロトコルのダウンのトリガーを遅らせます。遅延は 200 ~ 2000 ミリ秒に設定できます。間隔を指定しないと、遅延はデフォルトの 200 ミリ秒に設定されます。

一般的な ML シリーズ POS 設定

ここでは、一般的な ML シリーズ カード POS 設定について説明します。

ML シリーズ カード同士

図 4-2に、2 枚の ML シリーズ間の POS 設定を示します。

図 4-2 ML シリーズ カード間の POS 設定

 

例4-10に、ルータ A の設定に関連するコードを示します。

例4-10 ルータ A の設定

hostname Router_A
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
!
interface POS0
ip address 192.168.2.1 255.255.255.0
crc 32
pos flag c2 1
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
 

例4-11 に、ルータ B の設定に関連するコードを示します。

例4-11 ルータ B の設定

hostname Router_B
!
interface FastEthernet0
ip address 192.168.3.1 255.255.255.0
!
interface POS0
ip address 192.168.2.2 255.255.255.0
crc 32
pos flag c2 1
!
router ospf 1
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!

ML シリーズ カードと Cisco 12000 GSR シリーズ ルータ

図 4-3に、ML シリーズ カードと Cisco 12000 GSR シリーズ Gigabit Switch Router(GSR; ギガビット スイッチ ルータ)間の POS 設定を示します。

図 4-3 ML シリーズ カードと Cisco 12000 シリーズ ルータ間の POS 設定

 

例4-12に、ルータ A の設定に関連するコードを示します。

例4-12 ルータ A の設定

hostname Router_A
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
!
!
interface POS0
ip address 192.168.2.1 255.255.255.0
encapsulation ppp
crc 32
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
 

例4-13 に、GSR-12000 の設定に関連するコードを示します。

例4-13 GSR-12000 の設定

hostname GSR
!
interface FastEthernet1/0
ip address 192.168.3.1 255.255.255.0
!
interface POS2/0
ip address 192.168.2.2 255.255.255.0
crc 32
encapsulation PPP
pos scramble-atm
!
router ospf 1
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!

) ML シリーズ カードの場合、デフォルトのカプセル化は LEX です。対応するデフォルト MTU は 1500 バイトです。外部 POS 装置と接続している場合は、表 4-5に示すパラメータが ML シリーズ スイッチと外部装置の両方に対して同じ設定であることを確認してください。


 

表 4-5 Cisco 12000 GSR シリーズ ルータに接続する場合の ML シリーズ のパラメータ設定

コマンド
パラメータ
Router(config-if)# encapsulation ppp
 

次の入力も有効です。

Router(config-if)# encapsulation hdlc

カプセル化:デフォルトのカプセル化は GSR では HDLC です。ML シリーズ カードでのデフォルトのカプセル化は LEX です。

Router(config-if)# show controller pos

C2 バイト:show controller pos コマンドを使用して送信と受信の C2 値が同じであることを確認します。

Router(config-if)# pos flag c2 value

C2 バイト値を設定します。有効な値は、0 ~ 255(10 進数)です。LEX のデフォルト値は 0x01(16 進数)です。

ML シリーズ カードと G シリーズ カード間

図 4-4に、ML シリーズ カードと G シリーズ カード間の POS 設定を示します。

図 4-4 ML シリーズ カードと G シリーズ カード間の POS 設定

 

例4-14に、ルータ A の設定に関連するコードを示します。

例4-14 ルータ A の設定

hostname Router_A
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
!
interface POS0
ip address 192.168.2.1 255.255.255.0
crc 32
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0