CiscoWorks Interface Configuration Manager ユーザ ガイド Software Release 1.0
FAQ と使用のシナリオ
FAQ と使用のシナリオ
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 780KB) | フィードバック

目次

FAQ と使用のシナリオ

CiscoWorks ICM の FAQ

一般的な使用のシナリオ

NAC Readiness Report を実行し、アップグレードの必要があるデバイスに NAC をサポートするイメージを展開する

すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する

ICM Aware Devices Report を実行する

ICM Audit Report を実行する

ネットワーク上の Building X のアクセス ポートに NAC L2 802.1x を展開する

ネットワーク上の Building X のアクセス ポートに NAC L2 IP を展開する

Device and Port Group に RADIUS Server アトリビュートを展開する

ポートのセットにポート速度を設定する

デバイスとポートのセットで VLAN を作成し、割り当てる

デバイスのセットで PBACL を作成し、ポートのセットに割り当てる

別のアクセス ポートのセットに 802.1、NAC L2 IP、または RADIUS を展開しなおす

アプリケーションのトラブルシューティング:デバッグ用に適切なログ レベルを設定する

FAQ と使用のシナリオ

この章では、CiscoWorks Interface Configuration Manager(CiscoWorks ICM)の機能に関する FAQ を示します。

また、ネットワークの NAC コンフィギュレーションおよび展開の要件に合わせて CiscoWorks ICM を使用する方法を示す使用のシナリオも示します。

次の項を参照してください。

CiscoWorks ICM の FAQ

一般的な使用のシナリオ

詳細については、次の項も参照してください。

CiscoWorks ICM の用語と定義

始める前に

CiscoWorks ICM タスクのオプション マッピング:クイック リファレンス テーブル

CiscoWorks ICM の FAQ

この項では、次の項目に関する FAQ を示します。

CiscoWorks ICM と他の LMS アプリケーションとの対話

CiscoWorks ICM と Campus Manager の統合

Device and Port Group

コンフィギュレーション インスタンス、サービス、展開

Job Approval

Admin

次も参照してください。

一般的な使用のシナリオ

CiscoWorks ICM と他の LMS アプリケーションとの対話

Q. CiscoWorks ICM をインストールするために必要な LMS の最小バージョンはどれですか。

A. LMS 2.5 です。詳細については、『Installation and Setup Guide for Interface Configuration Manager』を参照してください。

Q. CiscoWorks ICM に必要な他の LMS アプリケーションの情報は何ですか。

A. すべての LMS バンドル アプリケーションのうち、CiscoWorks ICM が対話するアプリケーションは Common Services、Resource Manager Essentials、および Campus Manager だけです。詳細については、図5-1を参照してください。

CiscoWorks ICM を機能させるには、RME(結果として Common Services も)インストールする必要があります。Campus Manager のインストールはオプションです。

Common Services:CiscoWorks ICM は、Tomcat、Apache、backup/restore などのインフラストラクチャ ピースに依存します。Common Services のインストールは、ICM を機能させるために必須です。

RME:インベントリ情報が収集され、RME データベースに格納されます(特に、ポート情報)。CiscoWorks ICM はこの情報を使用します。RME のインストールは、ICM を機能させるために必須です。

Campus Manager:CiscoWorks ICM は、VLAN 情報を取得します。Campus Manager のインストールは、CiscoWorks ICM の観点からはオプションです。

図5-1 CiscoWorks ICM と他の LMS アプリケーション(Common Services、Resource Manager Essentials、および Campus Manager)との対話

 

CiscoWorks ICM と Campus Manager の統合

Q. 選択したインターフェイスの VLAN 情報が表示されないのはなぜですか。

A. CiscoWorks ICM は、Campus Manager から取得した VLAN 情報を利用します。VLAN 機能は、Campus Manager もインストールされている場合にのみ機能します。VLAN 情報を取得するには、Campus Manager がインストールされていることを確認してください。

Q. CiscoWorks ICM は、Campus からのデータだけを必要としますか。それとも、RME と対話しますか。

A. CiscoWorks ICM を機能させるには、RME を同じマシンにインストールする必要があります。CiscoWorks ICM は、RME で使用できるインベントリ情報(ポート、デバイスなど)に依存します。ただし、Campus Manager のインストールはオプションです。

Campus Manager も同じマシンにインストールされている場合、CiscoWorks ICM は Campus からの VLAN データを利用できます。Campus がインストールされていない場合、CiscoWorks ICM で VLAN 統合機能を使用することはできません。

Device and Port Group

Q. Device Selector での CiscoWorks ICM Device and Port Group と OGS Device Group との違いは何ですか。

A. 違いの一例を示します。

Device and Port Group は、デバイス グループから作成される別のエンティティです。Device and Port Group グループは、デバイスとポートの集合です。一方、OGS Device Group は、デバイスの集合です。

Device and Port Group グループ作成時のデバイス選択処理で、OGS グループ セレクタを使用します。

Device and Port Group グループのデバイスは、OGS グループのデバイスのサブセットです。

Device and Port Group グループのデバイスは、ルール ベースではなく、デバイスの列挙型リストとして格納されます。

CiscoWorks ICM の Device Port Group は、CiscoWorks ICM でのみ使用できます。その他の LMS アプリケーションでは使用できません。

Q. CiscoWorks ICM がサポートするデバイス ファミリはどれですか。

A. CiscoWorks ICM は、次のデバイス ファミリをサポートします。

 

デバイス ファミリ
デバイス モデル
スーパーバイザ モデル
OS タイプ
サポートされる
最小 OS バージョン

Catalyst 6000/6500 シリーズ スイッチ

6513

6509

62509-NEB

6506

6503

6006

6009

SUP 720

SUP 2

SUP 1

SUP 32

CAT OS

8.5(1)

Catalyst 3550

3550 48 EMI

3550 48 SMI

3550 24 DC SMI

3550 24 EMI

3550 24 FX

なし

IOS

12.2(25)SEC

Catalyst 3560

3560-24PS

3560-48PS

3560G-24TS

3560G-48TS

3560G-24PS

3560G-48PS

なし

IOS

12.2(25)SEC

Catalyst 3750

3750-48TS

3750-24TS

3750G-24T

3750G-24TS

3750G-12S

なし

IOS

12.2(25)SEC

Catalyst 44xx

4503

4506

4507R

4510R

IV、V、および V-10GE

IOS

12.2(25)SG

Catalyst 49xx

4948

なし

IOS

12.2(25).

詳細については、Cisco.com の「Supported Devices Table for CiscoWorks Interface Configuration Manager」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cwicm/cwicm10/index.htm

Q. デバイスが選択された後、CiscoWorks ICM はどのようにして、選択用に表示するインターフェイスを認識しますか。

A. CiscoWorks ICM は、RME データベースのインベントリを検索し、選択されたデバイスのイーサネット、ファースト イーサネット、またはギガビット イーサネット インターフェイスを選択します。

Q. ポートを選択するにはどうすればよいですか。

A. 目的のポートは、Device and Ports Groups ウィザードの Select Ports ダイアログボックスの Filter Source オプションを使用して選択できます。このウィザードにアクセスするには、次の手順を実行します。

a. Interface Configuration Manager > Configuration > Device and Port Groups の順に選択します。

Device and Port Groups ダイアログボックスが表示されます。

b. Create をクリックすると、Device and Ports Groups ウィザードが起動します。3 番目のオプションである Select Ports で、目的のポートを選択できます。

次の方法で、ポート選択形式を使用できます。次の例を参考にしてください。

a. Filter Source フィールドで、Port Name を選択し、Gi2/1, Fa2/1, Fa2/6 のようにテキスト フィールドにフィルタ値をカンマで区切って入力します。

b. Filter をクリックします。

ポート Gi2/1、Fa2/1、Fa2/6 の詳細が表示されます。

または

a. Filter Source フィールドで、Port Name Range を選択し、テキスト フィールドに Gi2/1/2-5, Fa2/1-6 のようにフィルタ値( xxxx /from-to)をカンマで区切って入力します。

このフィールドは、大文字と小文字を区別しません。ただし、範囲を指定するときに、ワイルドカードはサポートされません。

b. Filter をクリックします。

インベントリに存在する場合、次のポートの詳細が表示されます。

Gi2/1/2、Gi2/1/3、Gi2/1/4、Gi2/1/5(ポートの範囲が 2~5)。

Fa2/1、Fa2/2、Fa2/3、Fa2/4、Fa2/5、Fa2/6(ポートの範囲が Fa2/1~6)。

Q. CiscoWorks ICM のすべての Filter フィールドでサポートされるワイルドカードは、 ? と * だけです。これらのワイルドカードを使用して、情報をフィルタリングする例を示してください。

A. はい。このフィールドでサポートされるワイルドカードは、 ? と * だけです。 ? は 1 文字を表し、 * は 0 個以上の文字を表します。

たとえば、フィルタ値 ?roupN?me は、 GroupName XroupYam e になりますが、 GGroupName GroupNName にはなりません。

Filter フィールドは、複数の条件をサポートします。カンマで区切ってください。

たとえば、?roupName, Nam* などを使用できます。このフィールドは大文字と小文字を区別しません。ただし、範囲を入力する場合は、ワイルドカードを使用できません。

Q. デバイスをインポートしたり、新しいデバイスを CiscoWorks ICM に追加するにはどうすればよいですか。

A. デバイスは自動的に Device and Credential Repository にインポートされ、NAC 対応デバイスは CiscoWorks ICM の Device Selector に表示されます。ただし、デバイスを DCR で選択できるようになるまで、最大 10 分かかることがあります。

Q. CiscoWorks ICM からデバイスを削除するにはどうすればよいですか。

A. RME/DCR からデバイスを削除すると、自動的に CiscoWorks ICM からデバイスが削除されます。また、CiscoWorks ICM 内にある既存のすべての DP グループからも削除されます。

Q. CiscoWorks ICM Device Selector でデバイスがグレー表示されるのはなぜですか。

A. CiscoWorks ICM Device Selector では、1 つ以上の NAC 機能をサポートするデバイスのみを選択できます。NAC 機能をサポートしないデバイスはディセーブルになり、選択できません。

Q. NAC 対応機能はどのようにして判断されますか。

A. NAC 対応機能は、デバイス OS(IOS/CatOS)のバージョンとデバイス タイプに基づいて判断されます。デバイス情報は、RME インベントリから取得されます。

コンフィギュレーション インスタンス、サービス、展開

Q. コンフィギュレーション インスタンスの作成中、サービスを設定するときに、対応するサービス ダイアログボックスに値を追加しても次のメッセージが表示されます。

Please configure at least one service.
 

A. このメッセージは、Configuration Instances ウィザードで、先に Services ダイアログボックスの変更を保存せずに間違えて Next ボタンをクリックした場合に表示されます。

これは、コンフィギュレーション インスタンスを作成し、そのインスタンスに最初のサービスを追加するときに起きることがあります。ほとんどのサービス ダイアログボックスにはスクロール バーがあり、スクロール ダウンしてダイアログボックスの Save ボタンをクリックしてから、ウィザードの Next ボタンをクリックする必要があります。

Q. デバイスにコンフィギュレーションをダウンロードするとき、CiscoWorks ICM はどの順序で転送プロトコルを使用してダウンロードを行いますか。

A. デバイスにコンフィギュレーションをダウンロードするとき、CiscoWorks ICM は Resource Manager Essentials(RME)から転送プロトコルの順序設定を取得し、同じ順序を使用します。

RME では、Config Transport Settings ダイアログボックス( Resource Manager Essentials > Admin > Config Mgmt > Archive Management )を使用して、転送プロトコルの順序を指定できます。Config Transport Settings ダイアログボックスで、Archive Management アプリケーションを選択していることを確認してください。詳細については、『User Guide for Resource Manager Essentials』を参照してください。

Q. Adhoc サービスは、いつ使用すればよいですか。

A. Adhoc service ダイアログボックスは、デバイス グローバル レベルまたはインターフェイス レベルで任意のコンフィギュレーション コマンドを自由に入力できる自由形式のテキスト エントリ フィールドです。

ここに入力したコマンドは、構文チェックなしにデバイスに送信されます。そのため、IOS または CatOS(Catalyst 6500 ファミリに属するデバイスの場合)のコマンド構文が正しいことを確認してください。

Adhoc サービスを作成し、コンフィギュレーション インスタンス(CI)と関連付けた後、NAC L2 802.1x や NAC L2 IP などその他のサービスと同じ方法で、CI の Device Port Group に展開されます。

Adhoc サービスは、他のサービスと同じように、いつでも変更または削除できます。

Q. コンフィギュレーション インスタンス ウィザードに PBACL サービスが表示されません。なぜですか。

A. コンフィギュレーション インスタンスのサービスは文脈依存です。コンフィギュレーション インスタンスの一部として Catalyst 6500 シリーズのデバイスが選択されていない場合、PBACL サービスは表示されません。

Q. Available VLANs リストは、どのようにしてサービス画面で事前選択されていますか。

A. オプション Available VLANs は、CI で選択されているすべてのデバイスで使用できる VLAN のセットです。つまり、VLAN の(結合セットに対する)共通部分のセットです。

このフィールドは、Campus Manager をインストールした場合にのみ表示されます。CiscoWorks ICM は Campus Manager とシームレスに統合します。統合のために追加の手順を実行する必要はありません。Campus Manager と統合すると、CiscoWorks ICM は、すべてのデバイスに共通の VLAN についての情報を取得し、Available VLAN フィールドに表示します。

Q. Clean up Port Configuration First オプションは、何をするオプションですか。

A. ポートのコンフィギュレーションを事前決定したデフォルトの状態に変更する場合に、このオプションを選択します。たとえば、IOS の場合、このオプションを使用して、ポートで default interface ifname コマンドを適用した後のデフォルトの状態は、工場出荷時のデフォルトです。CatOS の場合、使用するコマンドは clear config mod/port です。

CatOS コマンドは対話コマンドで、ユーザ プロンプトを待ちます。そのため、このオプションを使用すると、展開の動作の速度が遅くなることがあります。このオプションを使用すると、デバイスで展開の動作の速度が遅くなることがあります。

Q. コンフィギュレーション インスタンスを展開するジョブをスケジューリングするときに、Job Schedule and Options ダイアログボックスの Clean up Port Configuration First オプションがグレー表示されるのはなぜですか。

A. コンフィギュレーション インスタンスのジョブ ポリシーのデフォルト オプションは、管理者が Configuration Instance Job Policy ダイアログボックス( Interface Configuration Manager > Admin > Configuration > Set Job Policy )を使用して指定できます。このタスクには管理者権限が必要です。

このオプションが選択済みでディセーブルになっている場合、Configuration Job Policy ダイアログボックス( Interface Configuration Manager > Admin > Configuration > Set Job Policy )で、管理者権限のあるユーザがこのオプションを設定したという意味です。ジョブをスケジューリングする際に、これを変更することはできません。

このオプションが選択されておらずディセーブルになっている場合、Configuration Job Policy ダイアログボックス( Interface Configuration Manager > Admin > Configuration > Set Job Policy )で、管理者権限のあるユーザがこのオプションを設定しなかったという意味です。ジョブをスケジューリングする際に、これを選択することはできません。

Q. コンフィギュレーション インスタンスを展開するジョブをスケジューリングするときに、Job Schedule and Options ダイアログボックスで、Job Option ペインの下のオプションがランダムに選択済みでディセーブルになっていたり、単純にディセーブルになっていることがあります。なぜですか。

A. コンフィギュレーション インスタンスのジョブ ポリシーのデフォルト オプションは、管理者が Configuration Instance Job Policy ダイアログボックス( Interface Configuration Manager > Admin > Configuration > Set Job Policy )を使用して指定できます。このタスクには管理者権限が必要です。

オプションを選択し、ユーザによる設定を可能にすることができます。つまり、ジョブをスケジューリングするときに、使用するかどうかを決定できます。オプションが選択され、User Configurable フィールドが設定されていない場合は、ジョブをスケジューリングするときに変更することはできません。

また、管理者は、ジョブ オプションを選択または指定し、ユーザによる設定を不可能にすることができます。この場合、ジョブをスケジューリングするときに、このオプションをオフにすることはできません。

これらのオプションの詳細については、「CiscoWorks ICM を使用した NAC コンフィギュレーション」の章の「コンフィギュレーション インスタンスの展開」を参照してください。

Job Approval

Q. Job Approval をイネーブルにできる CiscoWorks ICM のジョブはどれですか。

現在は、コンフィギュレーション インスタンス ジョブに対して承認をイネーブルにできます。 Interface Configuration Manager > Admin > Approval ページのオプションを使用します。

Q. 自分の CI ジョブに対して Job Approval をイネーブルにするにはどうすればよいですか。

A. Approval Policy ダイアログボックスを使用して、コンフィギュレーション インスタンス ジョブに対して Job Approval をイネーブルにできます( Interface Configuration Manager > Admin > Approval > Set Approval Policy )。ただし、まず、アプルーバの詳細を入力し、アプルーバ リストを作成する必要があります。

ジョブ承認の設定とイネーブル化の詳細については、「CiscoWorks ICM の管理」の章の「ジョブの承認のイネーブル化」を参照してください。

Q. ジョブを承認するにはどうすればよいですか。

A. Job Approval ダイアログボックスを使用して、ジョブを承認できます( Interface Configuration Manager > Configuration > Configuration Instance Jobs > Job Approval )。詳細な手順については、「CiscoWorks ICM を使用した NAC コンフィギュレーション」の章の「ジョブの承認または拒否」を参照してください。

Q. CiscoWorks ICM の Admin タブで Job Approval オプションを設定しているとき、Approver Details や Create/Edit Approver Lists などのオプションを設定しているときに、気づかないうちに RME アプリケーションが起動していました。なぜこのようなことが起きるのですか。

A. Approver Details と Create/Edit Approver Lists の 2 つの Admin オプションでは、CiscoWorks ICM が既存の RME 機能を使用します。これは正常な動作です。ただし、これらのダイアログボックスに値を入力した後は、値を保存し、RME ダイアログボックスを閉じ、 Interface Configuration Manager > Admin > Approval ページに戻る必要があります。

Q. Approver Details や Create/Edit Approver Lists などのオプションを設定する場合、CiscoWorks ICM が RME アプリケーションを起動します。RME アプリケーションを使用している間、RME オプション(Approval Policies)で CiscoWorks ICM の承認ポリシーも設定できますか。

A. いいえ。RME Approval Policies オプションを使用して CiscoWorks ICM 承認ポリシーを設定しないでください。RME を使用して Approver Details または Create/Edit Approver Lists オプションを設定した後、ダイアログボックスを閉じ、 Interface Configuration Manager > Admin > Approval ページに戻る必要があります。

このページで、Set Approval Policy オプションを使用し、CiscoWorks ICM コンフィギュレーション インスタンス ジョブのジョブ承認ポリシーを設定する必要があります。

Admin

Q. ログインしたときに、Admin タブが表示されません。なぜですか。

A. ユーザが実行できるタスクは、ユーザのロールに基づきます。Admin タブは、ヘルプ デスク オペレータ ロールのユーザには表示されません。自分の権限をチェックするには、Permission Report( Common Services > Server > Reports )を表示します。

Q. CiscoWorks ICM 固有のプロセスはありますか。ある場合、その依存性はどうなっていますか。

A. CiscoWorks ICM 固有のプロセスは、DPGroupServer だけです。このプロセスは、Device Port Group の取得、作成、編集、削除を行う機能です。このプロセスは、RMEDbMonitor プロセスと RMECSTMServer プロセスに依存します。

Q. CiscoWorks ICM のログ ファイルは、どこにありますか。

A. CiscoWorks ICM のログ メッセージは次の場所にあります。

Windows の場合、 NMSROOT /log/cwicm.log。 NMSROOT は CiscoWorks インストール フォルダです。

Solaris の場合、/var/adm/CSCOpx/log/cwicm.log。

Q. トラブル シューティングの目的で、CiscoWorks ICM のさまざまなモジュールのログ レベル設定を変更するにはどうすればよいですか。

A. Set Log Levels オプションを使用して、コンフィギュレーション インスタンス、Device and Port Group、レポート、Job Approval など、CiscoWorks ICM のさまざまな機能のログ レベル設定を選択できます( Interface Configuration Manager > Admin > System Preferences > Set Log Levels )。

詳細については、「CiscoWorks ICM の管理」の章の「ログ レベルの設定」を参照してください。

一般的な使用のシナリオ

この項では、一般的なタスクの実行方法を示し、CiscoWorks Interface Configuration Manager(CiscoWorks ICM)1.0 の主なワークフローについて説明します。

ただし、始める前に、CiscoWorks Interface Configuration Manager を使用するためのすべての前提条件を満たしていることを確認してください。詳細については、「概要」の章の「始める前に」を参照してください。

この項には、次のワークフローがあります。

NAC Readiness Report を実行し、アップグレードの必要があるデバイスに NAC をサポートするイメージを展開する

すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する

ICM Aware Devices Report を実行する

ICM Audit Report を実行する

ネットワーク上の Building X のアクセス ポートに NAC L2 802.1x を展開する

ネットワーク上の Building X のアクセス ポートに NAC L2 IP を展開する

Device and Port Group に RADIUS Server アトリビュートを展開する

ポートのセットにポート速度を設定する

デバイスとポートのセットで VLAN を作成し、割り当てる

デバイスのセットで PBACL を作成し、ポートのセットに割り当てる

別のアクセス ポートのセットに 802.1、NAC L2 IP、または RADIUS を展開しなおす

アプリケーションのトラブルシューティング:デバッグ用に適切なログ レベルを設定する

CiscoWorks ICM の FAQ も参照してください。

NAC Readiness Report を実行し、アップグレードの必要があるデバイスに NAC をサポートするイメージを展開する

NAC Readiness Report は、ネットワーク上にある NAC をサポートできるデバイスと、それらがサポートする技術を判断するために役立ちます。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 NAC アイコンから NAC Readiness Report ハイパーリンクをクリックします。

NAC Readiness Report (Immediate Report) が表示されます。

このレポートには、RME インベントリに存在する、NAC Phase II テクノロジー(NAC L2 802.1x、NAC L2 IP など)で展開できるデバイスが表示されます。

ステップ 4 RME Software Management アプリケーションを使用して、サポートされるイメージをデバイスに展開します。サポートされるイメージについては、「CiscoWorks ICM がサポートするデバイス ファミリはどれですか。」のトピックを参照してください。

詳細については、『User Guide for Resource Manager Essentials』も参照してください。


 

すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する

この使用のシナリオでは、Device and Port Group を作成する手順について説明します。

Device and Port Group は、デバイスと選択されたインターフェイスの名前付きセットです。コンフィギュレーション インスタンスを作成するときに使用します。

コンフィギュレーション インスタンス Device and Port Group などの定義については、「概要」の章の「CiscoWorks ICM の用語と定義」を参照してください。

Device and Port Group を作成するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configuration > Device and Port Groups の順に選択します。

Device and Port Groups ダイアログボックスに、既存の Device and Port Groups のリストが表示されます。

ステップ 4 Create をクリックします。

Device and Port Group Properties ダイアログボックスが表示されます。

ステップ 5 作成する Device and Port Group の名前と説明を入力し、Next をクリックします。

Select Devices ダイアログボックス(または Device Selector)が表示されます。

ステップ 6 NAC 用に設定するデバイスを選択します。

これは Device Group Selector で、Device and Port Group(DPG)セレクタではありません。Device Group Selector を使用して、すべての LMS アプリケーションで使用できるデバイス グループを選択します。DPG は、CiscoWorks ICM にのみ関係があるデバイスとポートのグループです。

ステップ 7 Next をクリックします。

Select Ports ページに、選択したデバイスのすべてのポートのリストが表示されます。

ステップ 8 設定するファースト イーサネット インターフェイスを選択します。

表の上のフィルタを使用して、検索文字列を入力し、すべてのファースト イーサネット インターフェイスを検索します。必要に応じて、単一文字または複数文字と一致する「?」や「*」などの正規表現ワイルドカードを使用できます。

ステップ 9 Next をクリックします。

Summary ウィンドウが表示されます。

ステップ 10 Finish をクリックして、Device and Port Group を作成します。

新しく作成された Device and Port Group が、新しいエントリとして、Device and Port Group の表に表示されます(ステップ 4 を参照)。


 

ICM Aware Devices Report を実行する

CiscoWorks ICM を使用して設定できるデバイスのセットは、RME Inventory データベースで使用できます。ただし、CiscoWorks ICM は、Device and Port Group(DPG)に使用された場合にのみ、これらのデバイスを認識します。

ICM Aware Devices Report には、CiscoWorks ICM の DPG に使用されているかどうかにかかわらず、RME に存在するデバイスが表示されます。

ICM Aware Devices Report を実行するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Reports > Report Generator を選択します。

Reports Generator ダイアログボックスが表示されます。

ステップ 4 Select a Report ドロップダウン リストで、ICM Aware Devices を選択します。

Report Generator ダイアログボックスがリフレッシュされ、Scheduling グループと Job Info グループが表示されます。

ステップ 5 Submit をクリックして、レポートを作成します。

ICM Aware Devices Report が表示されます。


 

ICM Audit Report を実行する

ICM Audit Report には、コンフィギュレーション インスタンスの作成日、作成者、含まれる Device and Port Group など、コンフィギュレーション インスタンスの詳細が表示されます。

ICM Audit Report を実行するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Reports > Report Generator を選択します。

ステップ 4 Select a Report ドロップダウン リストで、ICM Audit Report を選択します。

Report Generator ダイアログボックスがリフレッシュされ、Scheduling グループと Job Info グループが表示されます。

ステップ 5 Submit をクリックして、レポートを作成します。

ICM Audit Report が表示されます。


 

ネットワーク上の Building X のアクセス ポートに NAC L2 802.1x を展開する

CiscoWorks ICM を使用して、ネットワーク上の指定したビルディングのアクセス ポートに NAC L2 802.1x を展開できます。このシナリオでは、対象のビルディングを Building X と呼びます。NAC L2 802.1x を展開するには、次の手順を実行します。

NAC L2 802.1x を展開するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configure > Configuration Instance Browser の順に選択します。

Configuration Instance Browser ダイアログボックスが表示されます。

ステップ 4 Create をクリックします。

Configuration Instance Properties ダイアログボックスが表示されます。

ステップ 5 コンフィギュレーション インスタンスの適切な名前と説明を入力します。

このインスタンスは、ネットワーク上の Building X のデバイスとポートのセットに NAC L2 802.1x コンフィギュレーション コマンドを展開するために使用するインスタンスです。

ステップ 6 Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが表示されます。

ステップ 7 Building X のデバイスとポートに対応する DPG を選択します。

このようなグループが存在しない場合、DPG テーブルの Create ボタンを使用して DPG を作成します。必要なデバイスとポートの DPG の作成方法については、「すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する」の手順を参照してください。

ステップ 8 Next をクリックします。

Configure Services ダイアログボックスにサービスのリストが表示されます。

ステップ 9 Dot1x Global を選択します。

ステップ 10 Config をクリックします。

Dot1x Global Configuration - Basic ダイアログボックスが表示されます。

ステップ 11 必要な NAC L2 802.1x パラメータを入力します(Dot1x Global Configuration - Advanced ダイアログボックスにパラメータを入力するには、 Advanced をクリックします)。

ステップ 12 値を入力後、Save をクリックします。

ダイアログボックスが閉じます。Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 13 Configure Services ダイアログボックスから Dot1x Interface を選択し、ステップ 9ステップ 10 を繰り返します。

ステップ 14 Next をクリックします。

要約ウィンドウには、コンフィギュレーション インスタンスの詳細が表示されます。

ステップ 15 Finish をクリックします。

新しく作成したコンフィギュレーション インスタンスとともに、Configuration Instance Browser ページが再度表示されます。

ステップ 16 作成した Configuration Instance を選択し、Deploy をクリックします。

CiscoWorks ICM が生成した CLI コマンドがデバイスに展開されている間に、経過表示バーが表示されます。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

ネットワーク上の Building X のアクセス ポートに NAC L2 IP を展開する

CiscoWorks ICM を使用して、ネットワーク上の指定したビルディングのアクセス ポートに NAC L2 IP を展開できます。このシナリオでは、対象のビルディングを Building X と呼びます。

NAC L2 IP を展開するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configure > Configuration Instance Browser の順に選択します。

ステップ 4 Create をクリックします。

Configuration Instance Properties ダイアログボックスが表示されます。

ステップ 5 コンフィギュレーション インスタンスの名前と説明を入力します。このインスタンスは、ネットワーク上の Building X のデバイスとポートのセットに NAC L2 IP コンフィギュレーション コマンドを展開するために使用するインスタンスです。

ステップ 6 Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが表示されます。

ステップ 7 Building X のデバイスとポートに対応する DPG を選択します。

このようなグループが存在しない場合、DPG テーブルの Create ボタンを使用して DPG を作成します。必要なデバイスとポートの DPG の作成方法については、「すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する」の手順を参照してください。

ステップ 8 Next をクリックします。

Configure Services ダイアログボックスにサービスのリストが表示されます。

ステップ 9 NAC L2 IP Global を選択します。

ステップ 10 Config をクリックします。

NAC L2 IP Global Configuration - Basic ダイアログボックスが表示されます。

ステップ 11 必要な NAC L2 IP パラメータを入力します(NAC L2 IP Global Configuration - Advanced ダイアログボックスにパラメータを入力するには、 Advanced をクリックします)。

ステップ 12 値を入力後、Save をクリックします。

ダイアログボックスが閉じます。Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 13 Configure Services ダイアログボックスから NAC L2 IP Interface を選択し、ステップ 9ステップ 10 を繰り返します。

ステップ 14 Next をクリックします。

要約ウィンドウには、コンフィギュレーション インスタンスの詳細が表示されます。

ステップ 15 Finish をクリックします。

新しく作成したコンフィギュレーション インスタンスとともに、Configuration Instance Browser ページが再度表示されます。

ステップ 16 作成した Configuration Instance を選択し、Deploy をクリックします。

CiscoWorks ICM が生成した CLI コマンドがデバイスに展開されている間に、経過表示バーが表示されます。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

Device and Port Group に RADIUS Server アトリビュートを展開する

CiscoWorks ICM を使用して、Device and Port Group に含まれるデバイスとポートのセットに RADIUS Server コンフィギュレーションを展開できます。

RADIUS Server アトリビュートを展開するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configure > Configuration Instance Browser の順に選択します。

Configuration Instance Properties ダイアログボックスが表示されます。

ステップ 4 Create をクリックします。

ステップ 5 コンフィギュレーション インスタンスの名前と説明を入力します。

ステップ 6 Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが表示されます。

ステップ 7 コンフィギュレーションを展開する Device and Port Group を選択し、Next ボタンをクリックします。

ステップ 8 Configure Services ダイアログボックスにサービスのリストが表示されます。

ステップ 9 Radius Server Global を選択します。

ステップ 10 Config をクリックして RADIUS サーバを設定します。

RADIUS Server Global Configuration - Basic ダイアログボックスが表示されます。対応するセクションで、必要なパラメータを指定します。

RADIUS Server コンフィギュレーションの場合

a. Enable を選択して、RADIUS Server コンフィギュレーションをイネーブルにします(RADIUS Server コンフィギュレーションを削除するには、Disable を選択します。他の RADIUS Server コンフィギュレーションに影響を与えずに RADIUS Server Key コンフィギュレーションだけを設定するには、No Change を選択します)。

b. Server Name/IP Address フィールドに、RADIUS サーバ名または IP アドレスを入力します。

c. Auth Port フィールドに、RADIUS サーバ ポート番号(0 ~ 655536)を入力します。

Key コンフィギュレーションの場合

a. Enable を選択して、デバイスで RADIUS Server Key を設定します(RADIUS Server Key を削除するには、Disable を選択します。RADIUS Server Key を変更しない場合は No Change を選択します)。

b. Key フィールドに Key の値を入力し、Verify フィールドに同じ値を再度入力します。Key の値は、セキュリティ上の理由により、表示されません。

ステップ 11 値を入力後、 Save をクリックします。

ダイアログボックスが閉じます。Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 12 Next をクリックします。

要約ウィンドウには、コンフィギュレーション インスタンスの詳細が表示されます。

ステップ 13 Finish をクリックします。

新しく作成したコンフィギュレーション インスタンスとともに、Configuration Instance Browser ページが再度表示されます。

ステップ 14 作成した Configuration Instance を選択し、Deploy をクリックします。

CiscoWorks ICM が生成した CLI コマンドがデバイスに展開されている間に、経過表示バーが表示されます。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

ポートのセットにポート速度を設定する

Adhoc サービスを使用して、ポート速度の設定や、インターフェイス レベルでデバイスに適用できるコマンドの設定ができます。Adhoc Service ダイアログボックスに、デバイスが受け付ける有効な任意のインターフェイス レベル コマンドを入力できます。

対話コマンドは、Enter CLI Commands 領域で、次の構文を使用して入力することができます。

CLI Command <R> command response 1 <R> command response 2

<R> タグは大文字と小文字を区別し、大文字のみで入力する必要があります。

Catalyst デバイスでは、 clear counters コマンドで次の出力が表示されます。

c5000# (enable) clear counters This command will reset all MAC and port counters reported in CLI and SNMP. Do you want to continue (y/n) [n]?
 

カウンタをクリアする Adhoc タスクの構文は次のとおりです。

c5000# clear counters <R>y
 

デフォルト(no)を使用する Adhoc タスクの構文は次のとおりです。

c5000# clear counters <R>n
 

または

c5000# clear counters <R>
 

デフォルト値を受け入れる場合は、タグ <R> の後ろに値を入力する必要はありません。

デバイスとポートのセットで VLAN を作成し、割り当てる

CiscoWorks ICM を使用して、デバイスとポートのセットで VLAN を作成し、割り当てることができます。次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configure > Configuration Instance Browser の順に選択します。

Configuration Instance Properties ダイアログボックスが表示されます。

ステップ 4 Create をクリックします。

ステップ 5 コンフィギュレーション インスタンスの名前と説明を入力します。

ステップ 6 Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが表示されます。

ステップ 7 コンフィギュレーションを展開する Device and Port Group を選択し、Next ボタンをクリックします。

Configured Services ダイアログボックスにサービスのリストが表示されます。

ステップ 8 Adhoc Global を選択します。

Adhoc Global Configuration ダイアログボックスが表示されます。

ステップ 9 次のように入力します。

a. IOS Parameters グループの CLI コマンド

v lan 500

b. CatOS Parameters グループの CLI コマンド

set vlan 500

ステップ 10 Save をクリックします。

Adhoc Global Configuration ダイアログボックスが閉じます。

Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 11 Configure Services ダイアログボックスで、Adhoc Interface を選択します。

ステップ 12 Config をクリックして、VLAN をインターフェイスに割り当てます。

Adhoc Interface Configuration ダイアログボックスが表示されます。

ステップ 13 次のように入力します。

a. IOS の CLI コマンド

shutdown
switchport
switchport mode access
switchport access vlan 500
no shutdown
 

b. CatOS の CLI コマンド

set vlan 500 %?INTERFACE?%
 

ステップ 14 Save をクリックします。

ダイアログボックスが閉じます。

Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 15 Next をクリックします。

要約ウィンドウには、コンフィギュレーション インスタンスの詳細が表示されます。

ステップ 16 Finish をクリックします。

もう一度、Configuration Instance Browser ダイアログボックスが表示されます。

ステップ 17 作成したコンフィギュレーション インスタンスを選択し、Deploy ボタンをクリックします。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

デバイスのセットで PBACL を作成し、ポートのセットに割り当てる

CiscoWorks ICM を使用して、デバイスのセットで PBACL を作成し、ポートのセットに割り当てることができます。次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Configure > Configuration Instance Browser の順に選択します。

Configuration Instance Properties ダイアログボックスが表示されます。

ステップ 4 Create をクリックします。

ステップ 5 コンフィギュレーション インスタンスの名前と説明を入力します。

ステップ 6 Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが表示されます。

ステップ 7 該当する Device and Port Group を選択します。

このようなグループが存在しない場合、DPG テーブルの Create ボタンを使用して DPG を作成します。必要なデバイスとポートの DPG の作成方法については、「すべてのファースト イーサネット インターフェイスで Device and Port Group を作成する」の手順を参照してください。

ステップ 8 オプション ボタンをクリックして、ステップ 7 で作成した DPG を選択します。

ステップ 9 Next をクリックします。

Configure Services ダイアログボックスにサービスのリストが表示されます。

ステップ 10 PBACL Global をクリックして、選択した(DPG の)デバイスで PBACL を設定します。

Policy Based ACL Global Configuration ダイアログボックスが表示されます。

ステップ 11 必要な PBACL コンフィギュレーション値をこのダイアログボックスに入力します。

CatOS の PBACL コンフィギュレーションの例を示します。

set security acl ip nacl1 permit arp
set security acl ip nacl1 permit arp-inspection any any
set security acl ip nacl1 permit dhcp-snooping
set security acl ip nacl1 permit eapoudp
set security acl ip nacl1 permit ip 10.6.82.0 0.0.0.255 any
set security acl ip nacl1 permit ip 192.168.31.208 0.0.0.15 any
set security acl ip nacl1 permit ip 192.168.32.208 0.0.0.15 any
set security acl ip nacl1 permit ip 192.168.33.208 0.0.0.15 any
set security acl ip nacl1 permit ip 192.168.34.208 0.0.0.15 any
set security acl ip nacl1 permit ip 192.168.35.208 0.0.0.15 any
set security acl ip nacl1 permit ip group healthy any
set security acl ip nacl1 permit ip group infected host 10.6.82.253
set security acl ip nacl1 permit ip group infected host 1.1.1.1
set security acl ip nacl1 permit ip group checkup host 10.6.82.253
set security acl ip nacl1 permit ip group checkup host 1.1.1.2
set security acl ip nacl1 permit ip group quarantine host 10.6.82.253
set security acl ip nacl1 permit ip group quarantine host 1.1.1.3
set security acl ip nacl1 permit ip group unknown host 10.6.82.253
set security acl ip nacl1 permit ip group unknown host 1.1.1.4
set security acl ip nacl1 permit ip group transition host 10.6.82.253
set security acl ip nacl1 permit ip group transition host 1.1.1.5
set security acl ip nacl1 permit url-redirect

ステップ 12 Save をクリックして値を保存します。

ダイアログボックスが閉じます。

Configure Services ダイアログボックスが再度表示され、Configured カラムには設定して保存したサービスに対して Yes が表示されています。

ステップ 13 新しく作成したサービスを再度選択し、View CLIs をクリックして、ステップ 11 で入力したエントリが正しいことを確認します。

要約ウィンドウには、コンフィギュレーション インスタンスの詳細が表示されます。

ステップ 14 Finish をクリックします。

新しく作成したコンフィギュレーション インスタンスとともに、Configure Services ダイアログボックスが再度表示されます。

ステップ 15 Deploy をクリックして、デバイスに PBACL をダウンロードします。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

別のアクセス ポートのセットに 802.1、NAC L2 IP、または RADIUS を展開しなおす

別のアクセス ポートのセットに NAC L2 802.1x、NAC L2 IP、または RADIUS を展開しなおすことができます。次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name :1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Configuration タブの Configuration Instance Browser オプションを選択します。

ステップ 4 既存の NAC L2 802.1x、NAC L2 IP、または RADIUS コンフィギュレーション インスタンスを選択し、Edit をクリックしてから Next をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスに、既存の Device and Port Group のリストが表示されます。

ステップ 5 既存の DPG を選択するか、ステップ 6 にスキップして必要なポートで新しい DPG を作成します。

ステップ 6 Select Device and Port Groups (DPG) ダイアログボックスの下の Create をクリックします。

Device and Port Group Properties ダイアログボックスが表示されます。

ステップ 7 作成する Device and Port Group の名前と説明を入力し、Next をクリックします。

Select Devices ダイアログボックス(または Device Selector)が表示されます。

ステップ 8 RME@ server_name -> All Devices ツリーを展開し、目的のデバイスを選択します(複数可)。

NAC をサポートしないデバイスはグレー表示されます。

ステップ 9 Next をクリックします。

ステップ 10 Select Ports ページに、選択したデバイスのすべてのポートのリストが表示されます。

ステップ 11 この DPG で必要なすべてのポートを選択し、Next をクリックします。

要約ページが表示され、作成した Device and Port Group に関する情報が表示されます。

ステップ 12 Finish をクリックします。

Select Device and Port Groups (DPG) ダイアログボックスが再度表示されます。新しく作成された Device and Port Group が、新しいエントリとして、Device and Port Group の表に表示されます。

ステップ 13 残りの Configuration Instance ダイアログボックスでは、 Next Finish をクリックします。サービスを変更する必要がないためです。

ステップ 14 Device and Port Groups を選択し、ステップ 7 で作成した DPG を確認します。

ステップ 15 Deploy ボタンをクリックして、新しく作成された DPG を含むコンフィギュレーション インスタンスを展開します。

すべてのデバイスへの展開が完了した後で、展開が正常終了したことを示す情報メッセージが表示されます。


 

アプリケーションのトラブルシューティング:デバッグ用に適切なログ レベルを設定する

アプリケーションで問題が発生した場合、カスタマー サポートのエンジニアが、特定のロギング レベルに設定するように依頼することがあります。これは、アプリケーションのトラブルシューティングに役立つ詳細な情報を含むエラー メッセージを取得するためです。

ロギング レベルを変更するには、次の手順を実行します。


ステップ 1 次の URL から CiscoWorks サーバにログインします。

http:// Server_name : 1741

ここで、 Server_name は、CiscoWorks LMS をインストールしたサーバの名前です。

ステップ 2 CiscoWorks のホームページから CiscoWorks ICM を起動します。

ステップ 3 Interface Configuration Manager > Admin > System Preferences > Loglevel Settings を選択します。

Set Logging Levels ダイアログボックスが表示されます。

使用可能なログ レベルは次のとおりです。

Fatal

Error

Warn

Info

Debug

デフォルトのログ レベルは Info に設定されています。

ステップ 4 ドロップダウン リストから、カスタマー サポートのエンジニアが使用するように依頼したロギング レベルを選択し、Apply をクリックします。

デフォルト設定に戻すには、Restore Defaults をクリックします。