Cisco WAN Modeling Tools ユーザ ガイド Release 15.3.00
NMT Map
NMT Map
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

NMT Map

NMT Map の起動方法

ネットワーク ビューを使った検索

リンク情報の取得 - 物理リンク

リンク情報の取得 - 論理リンク

マップのズーム操作

マップのパンニング

マップの色分け

NMT におけるマップ表示の制御

NMT Map のメイン メニュー

新しいグループの追加

既存のグループへのノードの追加

グループの削除

既存のグループからのノードまたはグループの削除

作業の保存

マップ データの NMT での再検索

障害解析のための Map Tool の使用方法

トラフィック レベルの解析のための Map Tool の使用方法

NMT Map

NMT Network Display Tool は、Network Design Topology Map または NMT Map と呼ばれることもあり、ネットワーク モデルの視覚化に有効な機能を持っています。マップ ツールには、次の機能があります。

トポロジのグラフィカルな表示

トラフィック レベルの視覚化

ネットワーク内でノードまたはリンクに障害が発生した場合の影響の視覚化

論理ノードと論理リンクの PNNI Peer Group 階層の視覚化

ノードの論理グループの作成や簡単な変更によって、複数のピア グループで構成される PNNI ネットワークの設計を支援


) Map ツールを実行できるのは、UNIX(Solaris)オペレーティング システムで動作する NMT だけです。Windows 用の NMT には、Map ツールは含まれていません。


NMT Map の起動方法

NMT の Execute メニューから、Route または Optimize コマンドを実行した後で、MT の Display メニューから MAP を選択して MAP を起動します。MAP ウィンドウが表示されるまで、数秒かかります。

NMT Map が画面に表示された後は、適切な位置に移動させ、適切な大きさに変更することができます。

PNNI ネットワークでは、ピア グループの概念が導入されました。これは、物理ノードの集合です。グループは論理ノードとして表現され、NMT では色の付いた円で表示されます。PNNI ネットワークではグループの階層構造が許されますが、高位のグループは論理ノードの集合になります。NMT Map を使うと、物理ノードをグルーピングし、それを任意のネットワークの論理ノードとすることが可能です。

定義されたグループで構成されるネットワークの場合、マップを最初に開いたときは、マップには最高位の論理ノードだけが表示されます(図8-1)。すべてのノードがピア グループに割り当てられている場合は、表示される実際のノードはありません。ピア グループに割り当てられていないいくつかのノードがある場合は、これらのノードが表示されます。マップ内での座標が指定されていないノードは、左上の隅に表示されます。それらのノードはマップ内の適切な位置に移動させる必要があります。


) Configuration Extraction Tool を使って作成された大部分のネットワークは、PNNI ネットワーク上のネットワークであるかないかとは無関係に、ネットワーク全体を構成する 1 つの論理グループの一部になります。このようなネットワークに対してマップを起動すると、通常単一の孤立したグループとして表示されます。


図8-1 論理ノードを表示するネットワーク ビュー

 

図 8-2 は、図 8-1 に対応する物理ネットワークの例を示しています。物理ノードは四角、そして物理ノード間のリンクは線で表示されます。

複数のグループが定義されていて、リンクの終端が 2 つの異なるグループにある場合、それぞれの終端があるノードは境界ノードと呼ばれます。NMT Map では、境界ノードが縞模様の四角形で強調表示されます。また、リンクは 2 本分の線の太さで表示されます。細い線は終端間に 1 つのトランクだけがあることを示します。太い線は複数のトランクがあることを示します。図8-2 では、これらの表示機能がすべて使われています。

図8-2 物理ノードを表示するネットワーク ビュー

 

ネットワーク ビューを使った検索

図 8-2 に示したような物理ネットワークを表示するには、グループ アイコンをクリックします。階層に沿って移動するには、アイコンを選択して左マウスボタンをクリックします。するとマップには、アイコンのピア グループのすべてのノードとリンクが表示されます。境界ノードは、ノード アイコン上に斜めに縞が入れられて表示されます。(図8-3 を参照)。

図8-3 2 階層 - 第 2 レベル

 

階層に沿って移動するには、アイコンを選択して右マウスボタンをクリックします。


) マップ内での座標が指定されていないノードは、左上の隅に集められて表示されます。それらのノードはマップ内の適切な位置に移動させる必要があります。


複数レベルの階層がある場合、最高位のレベルのグループで左マウスボタンをクリックすると、次のレベルの論理ノードが出現します。論理ノードは円で表現されます。

最初のレベルのノードで左マウス ボタンをクリックすると、そのノードに関連付けられた次のレベルのノードが出現します(図8-4)。

図8-4 3 階層 - 第 2 レベル

 

第 2 レベルのノードで左マウスボタンをクリックすると、そのノードに関連付けられた第 3 レベルのノードが出現します。 (図8-5)

図8-5 3 階層 - 第 3 レベル

 


) ネットワーク全体を表示するには、すべての論理ノードのアイコンをクリックします。


図8-1 から図8-2 への変形、あるいはその逆を行うための 2 つのショートカットがあります。図8-2 の物理ネットワークを表示するには、Groups メニューから Explode を選択します。また、図8-1 の論理ネットワークを表示させるには、Groups メニューから Collapse を選択します。

リンク情報の取得 - 物理リンク

2 つの物理ノード間にあるリンクをクリックすると、その間にあるすべてのリンクが表示されます(図8-6)。

図8-6 物理リンクのリンクの表示

 

リンク情報の取得 - 論理リンク

2 つの論理ノード間にある論理リンクをクリックすると、その間にあるすべての物理リンクが表示されます。異なるノード ペアの数とは無関係に、すべてのリンクが表示されます(図8-7 を参照)。

図8-7 論理リンクのリンクの表示

 

マップのズーム操作

マップの特定の領域をズームするには次のステップを実行します。


ステップ 1 拡大表示させる領域の左上を指示するために、マップ上で何も表示されていない領域にカーソルを移動させます。

ステップ 2 左マウス ボタンを押しながら、カーソルを右下に移動させます。すると画面上に破線で囲まれたボックスが表示されます。

ステップ 3 破線のボックスが拡大する領域を囲むようにカーソルを移動します。

ステップ 4 左マウスボタンを離します。

画面上に拡大された領域が表示されます。

ズームしたマップを最初の大きさに戻すには、マップ上で何も表示されていない領域にカーソルを移動させ、右マウス ボタンをクリックします。マップはズーム アウトしますが、それでも最初のマップよりも大きな表示です。最初の大きさに戻すには、右クリックを繰り返します。通常のマップの大きさに戻るために、10 回クリックしなければならないこともあります。


 

あるいは、Background メニューからマップを選択した場合にも、通常の画面に戻ります。

マップのパンニング

マップを画面上で異なる位置に移動するには、画面の何も表示されていない領域にカーソルを移動させます。中マウス ボタンを押しながら、マップを移動させたい方向にカーソルをドラッグします。中マウス ボタンを離すと、ノード、リンク、および背景のマップは、画面上で指定した方向に移動します。

マップを最初の位置に戻すには、画面の何も表示されていない領域にカーソルを移動させ、右マウス ボタンをクリックします。

マップの色分け

マップ ツールは色分けを使って、ネットワーク トポロジの重要な状況を認識しやすくしています。この色分けを 表8-1 で説明します。

 

表8-1 Network Topology Map の色分け

ノード
リンク

緑色

ノードは正常に動作している(すべての接続に経路が通じている)。

リンクのトラフィックは警告しきい値以下。

黄色

ノードはハブであり、いくつかのフィーダは表示されていない。

リンクのトラフィックは警告しきい値を上回っているが、危険しきい値よりは下である。

赤色

このノードの接続には経路が通じていないものがある。

リンクのトラフィックが、危険しきい値を上回っている、またはリンクに障害がある。


) 論理ノード(ノードのグループ)と太い線で表示されるリンク(複数のリンク)の色は、その集合を構成する個々のノードまたはリンクの最も悪い条件で決定されます。


NMT におけるマップ表示の制御

マップ表示は、NMT のメイン メニューの Report メニューで制御できます。Set Options 画面には、マップ出力を制御する変数が含まれます(図8-8 を参照)。

図8-8 NMT の Report メニュー - Set Options 画面

 

NMT Map のメイン メニュー

NMT Map のメニュー バーには、マップ設定を制御するための最大 8 つのプルダウン メニューが含まれています(図8-9)。

図8-9 NMT Map のメイン メニュー

 

各プルダウン メニューの詳細を次に説明します。

File - マップの終了、作業の保存などの選択肢が含まれます。

Access - マップ表示でアクセス フィーダ ノードの追加や削除を行うための選択肢が含まれます。

Groups - グループを持つネットワークの表示、グループの追加や削除、およびグループに含まれるノードの変更を行うために選択肢が含まれます。

Background - 背景イメージを選んで表示するための選択肢が含まれます。

Topology- マップを更新したり、クリアするための選択肢が含まれます。

Options - マップ表示の色の選択肢が含まれます。

Messages -エラー メッセージを表示することができます。


) このメニューは、表示するエラー メッセージまたは状態メッセージがある場合にだけ表示されます。


Help - マップとその使用方法についての情報を取得するための選択肢が含まれます。

各プルダウンメニューには、1 つ~6 つのサブメニューが含まれます。各サブメニューの意味を、 表8-2 で説明します。

 

表8-2 Map Tool メニュー

メニュー バー
選択
説明

File

Save

ノードとグループの位置とノードのグループへの割り当て情報を保存する。

Quit

マップ ツールを終了する。オプションで、画面の新しい情報の保存または無視ができる。

Access

Add...

ノードにアクセス フィーダを追加する。

Delete

アクセス フィーダを削除する。

Groups

Explode

すべてのグループを開き、個々の物理ノードとリンクを表示する。

Collapse

すべてのノードを指定したグループに集約し、すべてのグループをルート グループに集約する。

Add new

新しいグループを追加する。

Add to

ノードまたはグループをグループに追加する。

Delete

グループを削除する。

Delete from

ノードまたはグループをグループから削除する。

Background

Display

背景マップの表示と非表示を切り替える。

Select...

背景で表示するマップを選択する。

Topology

Update Map

最新の NMT 設定情報をインポートする。

Clear Map

マップ画面をクリアする。

Options

Thresholds

リンクの色を帯域幅利用率に応じて設定する。

Black and White

ノード名と背景マップを白地に黒で表示する。

Messages

Browse Messages

エラー メッセージまたは状態メッセージを表示する。

このメニュー項目は、表示するエラー メッセージまたは状態メッセージがある場合にだけ表示されます。

Help

User Guide

マップの使用方法と NMT マップのメニュー項目の説明を表示する。

About...

マップ アプリケーションの説明を表示する。


) 指定がない限り、Map Tool のメニューは左マウス ボタンで選択してください。


新しい設定をグラフィック表示するには、次のステップを実行してください。


ステップ 1 メニューバーから Topology を選択し、Update Map をクリックして最新の設定をインポートします。

ステップ 2 Network Design Topology ウィンドウのメニューバーから Background を選択し、 Select をクリックして設定に適しているマップを選択します。

ステップ 3 各ノードをマップ上の適切な位置にドラッグします。ノード アイコン(色の付いた四角形)は、ウィンドウの左上隅に表示されています。カーソルをノードの上に置き、左マウス ボタンを押しながら、ノードを適切な場所に移動します。このステップを各ノードについて実行します。

ステップ 4 マップを保存するには、メニューバーで File を選択し、Save を選択します。


 

新しいグループの追加

新しいグループを追加するには、次の手順を実行します。


ステップ 1 メインメニューの Groups を選択します。

ステップ 2 Groups メニューから、Add new を選択します。

カーソルはグループ アイコンに似た大きな黒い点になります。

ステップ 3 新しいグループに追加するノードを選択します。カーソルをノードの中央に置き、マウスの左または右ボタンを押します。

ダイアログボックスが表示されます(図8-10)。

図8-10 Add Group ダイアログ

 

ステップ 4 グループ名を入力し、OK をクリックします。

ノード名はグループ名で置き換えられ、ノード アイコンはグループ アイコン(円)で置き換えられます(図8-11 を参照)。


 

図8-11 グループを追加した後のマップ表示

 

既存のグループへのノードの追加

既存のグループへノードを追加するには、次の手順を実行します。


ステップ 1 メインメニューの Groups を選択します。

ステップ 2 Groups メニューから、Add を選択します。カーソルは、グループ アイコンの真中が開いたようなリング状に変化します。

ステップ 3 ノードを追加するグループを選択します。カーソルをグループ アイコンの中央に置き、マウスの左または右ボタンを押します。カーソルは、ノード アイコンに似た、真中に点がある四角形に変化します。

ステップ 4 追加する最初のノードを選択します。カーソルをノード アイコンの中央に置き、マウスの左または右ボタンを押します。ノードが消滅し、そのノードに終端があったリンクは、グループ アイコンに接続されます(図8-12 を参照)。残りのノードを同様にグループに追加します。


 

図8-12 ノードをグループに追加した後のマップ表示

 

すべてのノードの追加が完了したら、マウスの左または右ボタンを、マップ上の何も表示されていない領域、または追加の終わったグループ上でクリックして、この機能を終了させます。これで Add to の機能が終了し、ビープ音とともにカーソルはもとの形状に戻ります。


警告 他の作業を始める前に、Add to の機能を終了させる必要があります。



) グループは NMT で定義されていなくても、Map User Interface には追加されている場合は、Topology メニューから Update Map を選択したとき、境界ノードだけが画面に表示されます。


グループの削除

グループの削除は次の手順で行います。


ステップ 1 メインメニューの Groups を選択します。

ステップ 2 Groups メニューの Delete を選択します。カーソルは頭蓋骨と2本の骨が交差した形に変わります。

ステップ 3 削除するグループを選択し、マウスの左または右ボタンをクリックします。ダイアログボックスが表示されます(図8-13)。

ステップ 4 OK をクリックします。ボックスが消えます。

図8-13 Confirm Deletion ダイアログボックス

 

マップ表示からグループ アイコンと名前が消えます。そして、もとのノードとリンクのすべての復元が行われます。


 

既存のグループからのノードまたはグループの削除

既存のグループからノードまたはグループを削除するには、次の手順を実行します。


ステップ 1 メインメニューの Groups を選択します。

ステップ 2 Groups メニューの Delete を選択します。カーソルは頭蓋骨と2本の骨が交差した形に変わります。

ステップ 3 削除するグループを選択し、マウスの左または右ボタンをクリックします。ダイアログボックスが表示されます(図8-14)。

ステップ 4 OK をクリックします。ボックスが消えます。

図8-14 グループからの削除を確認するダイアログボックス

 

マップ表示には変化がありません。ただし、階層を調べようとグループで右マウス ボタンをクリックすると、ビープ音が鳴ります。グループ内の別のノードで右マウス ボタンをクリックすると、マップではグループが閉じて、次の高位の論理ノードが表示されます。削除したノードも表示されます。これは、グループに属さなくなったからです(図8-15)。


 

図8-15 グループから削除した後のマップ表示

 

作業の保存

作業を保存するには 2 通りの方法があります。

メインメニューから Utility を選択して、Utility メニューから Save を選択します。

または、メイン メニューで Utility から Quit を選択し、表示されたダイアログボックスで、Save を選択します(図8-16)。

図8-16 Confirm Quit ダイアログボックス

 

作業の保存が完了すると、NMT マップによって、グループ名とマップ座標が NMT のローカル設定ディレクトリに書き込まれます。

マップ データの NMT での再検索

マップ内のマップ データの保存が完了すると、そのデータは NMT にインポートすることができます。そのためには、NMT の File メニューから Import、Map Data を選択します(図8-17)。

図8-17 NMT の File メニュー(Import Map Data 画面)

 

障害解析のための Map Tool の使用方法

障害解析を終了したら、マップ ウィンドウのメニュー バーから Update をクリックし、Update Map を選択します。リンク障害で再ルーティングが行えなかったサイトが赤色に変わります。

トラフィック レベルの解析のための Map Tool の使用方法

Options メニューをクリックし、Thresholds を選択します。2 つのスライド バー(Critical と Warning)を持つ Thresholds ダイアログボックスが表示され、「危険」と「警告」を総帯域幅の割合で定義できます。バーをスライドさせると、トラフィック量が「超過(危険)」と「超過に近い(警告)」状態を判断するためのしきい値を設定できます。NMT では、超過のトラフィックは赤色で表示され、超過に近いトラフィックは黄色で表示されます。残りのすべてのトラフィックは緑色で表示されます。