Cisco VPN Solutions Center: MPLS Solution プロビジョニング ガイド
Cisco VPNSC: MPLS Solution コマン ド リファレンス
Cisco VPNSC: MPLS Solution コマンド リファレンス
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco VPNSC: MPLS Solution コマンド リファレンス

address-family

clear ip route vrf

exit-address-family

import map

ip route vrf

ip vrf

ip vrf forwarding

neighbor activate

rd

route-target

show ip bgp vpnv4

show ip cef vrf

show ip protocols vrf

show ip route vrf

show ip vrf

show tag-switching forwarding vrf

debug ip bgp

Cisco VPNSC: MPLS Solution コマンド リファレンス

この付録は、MPLS VPN の構成に使用する Cisco IOS コマンドのうち、新規または修正されたものを対象としたコマンド リファレンスです。MPLS VPN で使用するその他のすべてのコマンドについては、 『Cisco IOS Release 12.0 Command Reference』 を参照してください。この付録では、次のコマンドを取り上げます。

 

address-family

route-target

clear ip route vrf

show ip bgp vpnv4

exit-address-family

show ip cef vrf

import map

show ip protocols vrf

ip route vrf

show ip route vrf

ip vrf

show ip vrf

ip vrf forwarding

show tag-switching forwarding vrf

neighbor activate

debug ip bgp

rd

Cisco IOS Release 12.0(1)T 以降では、 show コマンドおよび more コマンドの出力に、検索とフィルタリングを実行できます。大量の出力をソートする場合や、必要のない出力を除外する場合には、この機能が便利です。

この機能を使用するには、 show コマンドまたは more コマンドに続けて、パイプ文字(|)、begin、include、exclude のいずれかのキーワード、および検索またはフィルタリングの式を入力します。

command | { begin | include | exclude } regular-expression

次に示す show atm vc コマンドの例では、式「PeakRate」が表示される最初の行から出力が開始されます。

show atm vc | begin PeakRate

検索およびフィルタリング機能の詳細については、Cisco IOS Release 12.0(1)T 機能モジュールの 『CLI String Search』 を参照してください。

address-family

BGP、RIP、スタティック ルーティングなどのルーティング プロトコルを設定するために アドレス ファミリー サブモジュールに入るには、 address-family グローバル設定コマンドを使用します。ルーティング プロトコルを設定するためのアドレス ファミリー サブモジュールをディセーブルにするには、このコマンドの no 形式を使用します。

VPN-IPv4 ユニキャスト

address-family vpnv4 [unicast]

no address-family vpnv4 [unicast]

IPv4 unicast

address-family ipv4 [unicast]

no address-family ipv4 [unicast]

CE ルータを使用する IPv4 ユニキャスト

address-family ipv4 [unicast] vrf vrf_name

no address-family ipv4 [unicast] vrf vrf_name

 
構文の説明

ipv4

標準 IPv4 アドレス プレフィックスを伝送するセッションを設定します。

vpnv4

8 バイトのルート区分を追加することによって、それぞれグローバルに一意になっている、カスタマー VPN-IPv4 プレフィックスを伝送するセッションを設定します。

unicast

(オプションの)ユニキャスト プレフィックスを指定します。

vrf vrf_name

サブモード コマンドに関連付ける、VRF の名前を指定します。

neighbor...remote-as コマンドを使用して BGP セッションを設定すると、アドレス ファミリー IPv4 用のルーティング情報がデフォルトでアドバタイズされます。ただし、 no bgp default ipv4-activate コマンドを実行した場合はこの限りではありません。

 
使用上のガイドライン

address-family コマンドを使用すると、アドレス ファミリー設定サブモードに入ります。プロンプトは、次のとおりです。

(config-router-af)#

このサブモードでは、複数のレイヤ 3 アドレス ファミリーに適応する BGP など、アドレス ファミリー特有のルーティング プロトコル パラメータを設定できます。

アドレス ファミリー設定サブモードを終了してルータ設定モードに戻るには、 exit-address-family 、または単に exit と入力します。

次の例の address-family コマンドを使用すると、ルータは、VPNv4 アドレス ファミリーに対するアドレス ファミリー設定サブモードに入ります。このサブモードでは、 neighbor activate およびその他の関連コマンドを使用して、VPNv4 アドレス ファミリーの NLRI のアドバタイズメントを設定できます。

(config)# router bgp 100
(config-router)# address-family vpnv4
(config-router-af)#

次の例のコマンドを使用すると、ルータは、VPNv4 アドレス ファミリーに対するアドレス ファミリー設定サブモードに入ります。VRF を指定するこの形式のコマンドは、PE デバイスと CE デバイスの間のルーティング交換を設定するためにだけ使用します。この address-family コマンドを使用すると、サブモードで入力されたこれ以降のコマンドは、VRF vrf2 のコンテキストで実行されます。サブモード内では、 neighbor activate およびその他の関連コマンドを使用して、次を実行できます。

PE ルータと CE ルータ間の IPv4 NLRI のアドバタイズメントを設定する。

IPv4 NLRI の変換(つまり、CE から受信した NLRI では IPv4 から VPNv4 に、PE から CE に送信される NLRI では VPNv4 から IPv4 に変換する)を設定する。

この VRF に適用されるルーティング パラメータを入力する。

次のように、アドレス ファミリー サブモードに入ります。

(config)# router bgp 100

(config-router)# address-family ipv4 unicast vrf v2:blue

(config-router-af)#

 
関連コマンド

コマンド
説明

exit-address-family

アドレス ファミリー サブモードを終了します。

neighbor activate

近接ルータとアドレスを交換します。

clear ip route vrf

VRF ルーティング テーブルからルートを削除するには、 clear ip route vrf EXEC コマンドを使用します。

clear ip route vrf vrf_name { * | network [ mask ]}

 
構文の説明

vrf_name

このスタティック ルートの VRF の名前です。

*

所定の VRF に関するすべてのルートを削除します。

network

削除対象の宛先をドット付き 10 進形式で指定します。

mask

(オプション)指定のネットワーク宛先のマスクを、ドット付き 10 進形式で指定します。

 
使用上のガイドライン

このコマンドは、ルーティング テーブルからルートをクリアするために使用します。アスタリスク(*)を使用して指定の VRF の転送テーブルからすべてのルートを削除するか、または特定のネットワークのアドレスおよびマスクを入力してそのネットワークへのルートを削除します。

次のコマンドは、ネットワーク 10.13.0.0 へのルートを v1 ルーティング テーブルから削除します。

Router# clear ip route vrf v1:red 10.13.0.0

 
関連コマンド

コマンド
説明

show ip route vrf

VRF に関連付けられた IP ルーティング テーブルを表示します。

exit-address-family

アドレス ファミリー サブモードを終了するには、 exit-address-family アドレス ファミリー サブモード コマンドを使用します。

exit-address-family

 
使用上のガイドライン

このコマンドには、引数もキーワードもありません。デフォルトの動作や値はありません。

このコマンドは exit と短縮できます。

次の例では、アドレス ファミリー コマンド モードの終了方法を示します。

(config-router-af)# exit-address-family

 
関連コマンド

コマンド
説明

address-family

ルーティング プロトコルの設定に使用するアドレス ファミリー サブモードに入ります。

import map

VRF にインポート ルート マップを設定するには、 import VRF サブモード コマンドを使用します。

import map route-map

 
構文の説明

route-map

VRF のインポート ルート マップとして使用されるルート マップを指定します。

 
デフォルト

デフォルトはありません。VRF には、 import map コマンドを使用して設定されない限り、インポート ルート マップはありません。

 
使用上のガイドライン

インポートおよびエクスポートする VRF にインポートおよびエクスポート拡張コミュニティを設定することで実現するよりも上級の制御を、VRF にインポートされるルートに対して行うことをアプリケーションが必要とする場合に、インポート ルート マップを使用します。

import-map コマンドは、ルート マップを指定の VRF に関連付けます。ルート マップを使用して、ルートのルート ターゲット拡張コミュニティ アトリビュートに基づいて、VRF へのインポートに適したルートをフィルタリングできます。

ルート マップは、インポート リストにあるコミュニティから選択されたルートへのアクセスを拒否する場合があります。

次の例では、VRF にインポート ルート マップを設定する方法を示します。

(config)# ip vrf v1:blue

(config-vrf)# import map blue_import_map

 
関連コマンド

コマンド
説明

ip vrf

VRF 設定モードに入ります。

route-target

VRF のインポートおよびエクスポート拡張コミュニティ アトリビュートを設定します。

show ip vrf

ある VRF またはすべての VRF に関する情報を表示します。

ip route vrf

VRF へのスタティック ルートを確立するには、 ip route vrf グローバル設定コマンドを使用します。スタティック ルートをディセーブルにするには、このコマンドの no 形式を使用します。

ip route vrf vrf_name prefix mask [next-hop-address] [interface {interface-number}]

[ global ] [ distance ] [ permanent ] [ tag tag ]

no ip route vrf vrf_name prefix mask [ next-hop-address ] [ interface { interface-number }]

[ global ] [ distance ] [ permanent ] [ tag tag ]

 
構文の説明

vrf_name

このスタティック ルートの VRF の名前です。

prefix

宛先への IP ルート プレフィックスをドット付き 10 進形式で指定します。

mask

宛先のプレフィックス マスクをドット付き 10 進形式で指定します。

next-hop-address

(オプション)ネクストホップ(そのネットワークに到達するために使用できる転送ルータ)の IP アドレス。

interface

(オプション)使用するネットワーク インターフェイスのタイプ。ATM、Ethernet、loopback、POS (packet over SONET)、または null です。

interface-number

使用するネットワーク インターフェイスを識別する番号。

global

所定のネクストホップ アドレスが非 VRF ルーティング テーブルにあることを指定します。

distance

(オプション)このルートの管理距離。

permanent

(オプション)インターフェイスがシャットダウンしてもこのルートが削除されないことを指定します。

tag tag

(オプション)ルート マップを通じたルート再配布の制御に使用できるラベル値。

 
使用上のガイドライン

Cisco IOS ソフトウェアが宛先へのルートをダイナミックに構築できないとき、スタティック ルートを使用します。

ルートのセットアップ時に管理距離を指定する場合、ダイナミック情報で上書きできるスタティック ルートをフラグします。たとえば、IGRP 導出ルートのデフォルトの管理距離は 100 です。IGRP ダイナミック ルートで上書きされるようにスタティック ルートを設定するには、100 より大きい管理距離を指定します。各スタティック ルートのデフォルトの管理距離は 1 です。

インターフェイスに向かうスタティック ルートは、ルーティング プロトコルにルートが再配布されるかどうかにかかわらず、RIP、IGRP、およびその他のダイナミック ルーティング プロトコルを通じてアドバタイズされます。つまり、インターフェイスを指定することによって設定されたスタティック ルートは、ルーティング テーブルに入れるとそのスタティックな性質を失います。

ただし、ネットワーク コマンドで定義されていないインターフェイスへのスタティック ルートを定義する場合は、プロトコルに再配布スタティック コマンドが指定されていない限り、どのダイナミック ルーティング プロトコルもルートをアドバタイズしません。

次のコマンドは、VRF v3:blue にあるネットワーク 209.165.201.0 宛てのパケットを、IP アドレスが 209.165.200.250 のルータに再ルーティングします。

(config)# ip route vrf v3:b

 
関連コマンド

コマンド
説明

show ip route vrf

VRF に関連付けられた IP ルーティング テーブルを表示します。

ip vrf

VRF ルーティング テーブルを設定するには、 ip vrf グローバル設定コマンドを使用します。VRF ルーティング テーブルを削除するには、このコマンドの no 形式を使用します。

ip vrf vrf_name

no ip vrf vrf_name

 
構文の説明

vrf_name

VRF に割り当てられた名前です。

 
使用上のガイドライン

デフォルトでは、VRF は定義されていません。VRF にインポート リストやエクスポート リストは関連付けられていません。VRF にはルート マップも関連付けられていません。

ip vrf vrf_name コマンドは、VRF ルーティング テーブルおよび CEF(転送)テーブルを作成します。これらは両方とも vrf_name という名前です。

デフォルトの値も、これらのテーブルに関連付けられます。

次の例では、ルート マップを VRF にインポートします。

(Router-config)# ip vrf v2:green

(config-vrf)# rd 100:2

route-target both 100:2

route-target import 100:1

 
関連コマンド

コマンド
説明

ip vrf forwarding

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

ip vrf forwarding

VRF をインターフェイスまたはサブインターフェイスに関連付けるには、 ip vrf forwarding インターフェイス設定コマンドを使用します。VRF の関連付けを解除するには、このコマンドの no 形式を使用します。

インターフェイスにこのコマンドを実行すると、IP アドレスが削除されます。IP アドレスを再設定する必要があります。

ip vrf forwarding vrf_name

no ip vrf forwarding vrf_name

 
構文の説明

vrf_name

VRF に割り当てられた名前です。

 
デフォルト

インターフェイスのデフォルトは、グローバル ルーティング テーブルです。

次の例では、VRF を ATM インターフェイス 0/0 にリンクする方法を示します。

(config)# interface atm0/0

(config-if)# ip vrf forward

 
関連コマンド

コマンド
説明

ip vrf

VRF を定義します。

ip route vrf

VRF へのスタティック ルートを確立します。

neighbor activate

BGP 近接ルータとの情報交換をイネーブルにするには、 neighbor activate ルータ設定コマンドを使用します。近接ルータとのアドレス交換をディセーブルにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } activate

no neighbor { ip-address | peer-group-name } activate

 
構文の説明

ip-address

近接ルータの IP アドレス。

peer-group-name

BGP ピア グループの名前。

 
デフォルト

VPN IPv4 アドレス ファミリーについては、近隣ルータとの IP アドレス交換はデフォルトでイネーブルになっています。一般コマンド no default bgp ipv4 activate を使用して、IPv4 アドレス交換をディセーブルにできます。また、このコマンドの no 形式を使用すると、特定の近隣ルータに対してアドレス交換をディセーブルにできます。

その他すべてのアドレス ファミリーについては、アドレス交換はデフォルトでディセーブルになっています。適切なアドレス ファミリー サブモードを使用して、デフォルト コマンドを明示的にアクティブにできます。

次の例では、BGP ルータは、カスタマーの IP アドレス 10.15.0.15 を近接ルータと交換できるようにします。

router bgp 100
neighbor 10.15.0.15 remote-as 100
neighbor 10.15.0.15 update-source loopback0
address-family vpnv4 unicast
neighbor 10.15.0.15 activate
exit-address-family

 
関連コマンド

コマンド
説明

address-family

アドレス ファミリー サブモードに入ります。

exit-address-family

アドレス ファミリー サブモードを終了します。

rd

VRF が機能するためには、ルート区分を設定する必要があります。VRF に対してルーティング テーブルおよび転送テーブルを作成するには、 rd VRF サブモード コマンドを使用します。

rd route-distinguisher

 
構文の説明

route-distinguisher

8 バイトの値を IPv4 プレフィックスに追加して、VPN IPv4 プレフィックスを作成します。

 
デフォルト

デフォルトはありません。

 
使用上のガイドライン

RD は、VPN に対してルーティングおよび転送テーブルを作成し、デフォルト ルート区分を指定します。カスタマーの IPv4 プレフィックスの先頭に RD が付加され、グローバルに一意な VPN-IPv4 プレフィックスになります。

RD は ASN 関連、IP アドレス関連のいずれかです。前者の場合、AS 番号と任意の番号から成り、後者の場合は IP アドレスと任意の番号から成ります。

RD は次のいずれかの形式で入力できます。

16 ビットの AS 番号:独自の 32 ビットの番号

たとえば、101:3

32 ビットの IP アドレス:独自の 16 ビットの番号

たとえば、192.168.122.15:1

次の例では、2 つの VRF に対してデフォルト RD を設定します。AS 関連、IP アドレス関連両方の RD の使用方法を示しています。

(config)#ip vrf v1:blue
(config-vrf)#rd 100:3
(config-vrf)#exit
(config)#ip vrf v2:red
(config-vrf)#rd 173.13.0.12:200

 
関連コマンド

コマンド
説明

ip vrf

VRF 設定モードに入ります。

show ip vrf

VRF に関する情報を表示します。

route-target

VRF のルート ターゲット拡張コミュニティを作成するには、 route-target VRF サブモード コマンドを使用します。ルート ターゲット コミュニティ オプションをディセーブルにするには、このコマンドの no 形式を使用します。

route-target { import | export | both } route-target-ext-community

no route-target { import | export | both } route-target-ext-community

 
構文の説明

import

ターゲット VPN 拡張コミュニティから、ルーティング情報をインポートします。

export

ターゲット VPN 拡張コミュニティに、ルーティング情報をエクスポートします。

both

インポートとエクスポートの両方のルーティング情報を、ターゲット VPN 拡張コミュニティにインポートします。

route-target-ext-
community

ルート ターゲット拡張コミュニティ アトリビュートを、VRF の import、export、または both(インポートおよびエクスポート)ルート ターゲット拡張コミュニティのリストに追加します。

 
デフォルト

デフォルトはありません。 route-target コマンドで指定されるまで、VRF にはルート ターゲット拡張コミュニティ アトリビュートが関連付けられていません。

 
使用上のガイドライン

route-target コマンドは、指定された VRF に、インポートおよびエクスポート ルート ターゲット拡張コミュニティのリストを作成します。

各ターゲット コミュニティに対して、このコマンドを 1 回ずつ実行します。特定のルート ターゲット拡張コミュニティを伝送する学習ルートは、インポート ルート ターゲットとしてその拡張コミュニティが設定された、すべての VRF にインポートされます。VRF サイトから取得したルート(たとえば、BGP、RIP、スタティック ルート構成による)には、ルートがインポートされる VRF を制御するためにルート アトリビュートとして追加された、VRF に設定された拡張コミュニティ用のエクスポート ルート ターゲットが含まれます。

ルート ターゲットは、ターゲット VPN 拡張コミュニティを指定します。拡張コミュニティは、ルート区分と同様に、AS 番号と任意の番号、または IP アドレスと任意の番号で構成されます。

番号は次のいずれかの形式で入力できます。

16 ビットの AS 番号:独自の 32 ビットの番号

たとえば、101:3

32 ビットの IP アドレス:独自の 16 ビットの番号

たとえば、192.168.122.15:1

次の例では、VRF のルート ターゲット拡張コミュニティ アトリビュートの設定方法を示します。コマンド シーケンスの結果、VRF v1:blue に 2 つのエクスポート拡張コミュニティ(1000:1 および 1000:2)と 2 つのインポート拡張コミュニティ(1000:1 および 173.27.0.130:200)ができます。

(config)#ip vrf v1:blue
(config-vrf)#route-target both 1000:1
(config-vrf)#route-target export 1000:2
(config-vrf)#route-target import 173.27.0.130:200

 
関連コマンド

コマンド
説明

ip vrf

VRF 設定モードに入ります。

import

VRF のインポート ルート マップを設定します。

show ip bgp vpnv4

BGP テーブルにある VPN アドレス情報を表示するには、 show ip bgp vpnv4 EXEC コマンドを使用します。

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf_name }

[ ip-prefix/length [ longer-prefixes ] [ output-modifiers ]]

[ network-address [ mask ] [ longer-prefixes ] [ output-modifiers ]] [cidr-only] [community]

[community-list] [dampened-paths] [filter-list] [flap-statistics] [inconsistent-as]

[neighbors] [paths [ line ]] [peer-group] [quote-regexp] [regexp] [summary] [tags]

 
構文の説明

all

完全な VPNv4 データベースを表示します。

rd route-distinguisher

一致するルート区分を持つ NLRI を表示します。

vrf vrf_name

指定された VRF に関連付けられた NLRI を表示します。

ip-prefix/length

(オプション)IP プレフィックス アドレス(ドット付き 10 進形式)およびマスクの長さ(0 ~ 32)。

longer-prefixes

(オプション)指定されたプレフィックス パラメータに完全に一致するエントリがあればそのエントリと、「一致する文字列が一番長い」という意味でプレフィックスと一致するすべてのエントリを表示します。つまり、指定されたプレフィックスに対するプレフィックスが最初のサブストリングです。

output-modifiers

(オプション)関連のキーワードおよび引数のリストについて、文脈依存ヘルプを使用します。

network-address

(オプション)BGP ルーティング テーブル内のネットワークの IP アドレス。

mask

(オプション)ネットワーク アドレスのマスクを、ドット付き 10 進形式で指定します。

cidr-only

(オプション)不自然なネット マスクを持つルートだけを表示します。

community

(オプション)このコミュニティに一致するルートを表示します。

community-list

(オプション)このコミュニティ リストに一致するルートを表示します。

dampened-paths

(オプション)減衰(ピアからの BGP ルートがアップ、ダウンしている)のために抑止されているパスを表示します。

filter-list

(オプション)フィルタ リストに当てはまるルートを表示します。

flap-statistics

(オプション)ルートのフラップ統計情報を表示します。

inconsistent-as

(オプション)発信元のAS が一貫しないルートだけを表示します。

neighbors

(オプション)TCP および BGP 近隣ルータ接続に関する詳細を表示します。

paths

(オプション)パス情報を表示します。

line

(オプション) BGP AS パスと一致する正規表現。

peer-group

(オプション)ピア グループに関する情報を表示します。

quote-regexp

(オプション)AS パス「正規表現」に一致するルートを表示します。

regexp

(オプション) AS パス「正規表現」に一致するルートを表示します。

summary

(オプション) BGP 近隣ルータのステータスを表示します。

tags

(オプション)各 NLRI に対する BGP 着信ラベルおよび発信ラベルを表示します。

 
使用上のガイドライン

このコマンドを使用して、BGP データベースにある VPNv4 情報を表示します。コマンド show ip bgp vpnv4 all は、利用可能なすべての VPNv4 情報を表示します。コマンド show ip bgp vpnv4 summary は、BGP 近隣ルータのステータスを表示します。

次は、BGP ルーティング テーブル内の利用可能なすべての VPNv4 情報についての出力例です。

Router# show ip bgp vpnv4 all

BGP table version is 18, local router ID is 14.14.14.14

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP,?- incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (v1:blue)
*> 11.0.0.0 50.0.0.1 0 0 101 i
*>i12.0.0.0 13.13.13.13 0 100 0 102 i
*> 50.0.0.0 50.0.0.1 0 0 101 i
*>i51.0.0.0 13.13.13.13 0 100 0 102 i

 

表 B-1 show ip bgp vpnv4 フィールドの説明

フィールド
説明

Network

BGP テーブルから得たネットワーク アドレスが表示されます。

Next Hop

BGP ネクストホップのアドレスが表示されます。

Metric

BGP メトリックが表示されます。

LocPrf

ローカル プリファレンスが表示されます。

Weight

BGP の重みが表示されます。

Path

BGP パスがルートごとに表示されます。

次の例では、RD 値が 100:1 の NLRI についてラベルのテーブルを表示する方法を示します。

Router# show ip bgp vpnv4 rd 100:1 tags

Network Next Hop In tag/Out tag

Route Distinguisher: 100:1 (vrf1)

2.0.0.0 10.20.0.60 34/notag

10.0.0.0 10.20.0.60 35/notag

12.0.0.0 10.20.0.60 26/notag

10.20.0.60 26/notag

13.0.0.0 10.15.0.15 notag/26

 

表 B-2 show ip bgp vpnv4 rd tags フィールドの説明

フィールド
説明

Network

BGP テーブルから得たネットワーク アドレスが表示されます。

Network

BGP テーブルから得たネットワーク アドレスが表示されます。

Next Hop

BGP ネクストホップ アドレスを指定します。

In Tag

このルータによって割り当てられているラベルがあれば、表示されます。

Out Tag

BGP ネクストホップ ルータによって割り当てられているラベルが表示されます。

次の例では、v1:red という VRF の VPNv4 ルーティング エントリを示します。

Router# show ip bgp vpnv4 vrf v1:red

BGP table version is 18, local router ID is 14.14.14.14

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP,?- incomplete

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 100:1 (vrf1)

*> 11.0.0.0 50.0.0.1 0 0 101 i

*>i12.0.0.0 13.13.13.13 0 100 0 102 i

*> 50.0.0.0 50.0.0.1 0 0 101 i

*>i51.0.0.0 13.13.13.13 0 100 0 102 i

関連コマンド

 

 
関連コマンド

コマンド
説明

show ip vrf

VRF とその関連インターフェイスを表示します。

show ip cef vrf

VRF に関連付けられた CEF 転送テーブルを表示するには、show ip cef vrf EXEC コマンドを使用します。

show ip cef vrf vrf_name [ ip-prefix [ mask [ longer-prefixes ]] [ detail ] [ output-modifiers ]]

[interface interface-number] [ adjacency [interface interface-number] [detail] [ discard ]

[ drop ] [ glean ] [ null ] [ punt ] [ output-modifiers ]] [ detail [ output-modifiers ]]

[ non-recursive [ detail ] [ output-modifiers ]] [ summary [ output-modifiers ]]

[ traffic [ prefix-length ] [ output-modifiers ]] [ unresolved [ detail ] [ output-modifiers ]]

 
構文の説明

vrf_name

VRF に割り当てられた名前です。

ip-prefix

(オプション)表示するエントリの IP プレフィックスを、ドット付き 10 進形式(A.B.C.D)で指定します。

mask

(オプション)IP プレフィックスのマスクを、ドット付き 10 進形式で指定します。

longer-prefixes

(オプション)より特定的なルートについて十分なテーブル エントリを表示します。

detail

(オプション)各 CEF テーブル エントリに関する詳細情報を表示します。

output-modifiers

(オプション)関連のキーワードおよび引数のリストについて、文脈依存ヘルプを使用します。

interface

(オプション)使用するネットワーク インターフェイスのタイプ。ATM、Ethernet、Loopback、POS(packet over SONET)、または Null です。

interface-number

使用するネットワーク インターフェイスを識別する番号。

adjacency

(オプション)隣接関係で解決するすべてのプレフィックスを表示します。

discard

隣接関係を廃棄します。

drop

隣接関係をドロップします。

glean

隣接関係をグリーニングします。

null

隣接関係を Null にします。

punt

隣接関係をパントします。

non-recursive

(オプション)非再帰ルートだけを表示します。

summary

(オプション)CEF テーブルの要約を表示します。

traffic

(オプション)トラフィック統計情報を表示します。

prefix-length

(オプション)トラフィック統計情報をプレフィックス サイズごとに表示します。

unresolved

(オプション)未解決ルートだけを表示します。

 
使用上のガイドライン

show ip cef vrf コマンドで vrf_name 引数だけを使用した場合、CEF テーブルが短縮表示されます。 show ip cef vrf コマンドで detail 引数を使用すると、すべての CEF テーブル エントリに関する詳細情報が表示されます。

次の例では、v3:green という VRF に関連付けられた転送テーブルを表示します。

Router# show ip cef vrf v3:green

Prefix Next Hop Interface

0.0.0.0/32 receive

11.0.0.0/8 50.0.0.1 Ethernet1/3

12.0.0.0/8 52.0.0.2 POS6/0

50.0.0.0/8 attached Ethernet1/3

50.0.0.0/32 receive

50.0.0.1/32 50.0.0.1 Ethernet1/3

50.0.0.2/32 receive

50.255.255.255/32 receive

51,0.0.0/8 52.0.0.2 POS6/0

224,0.00,0/24 receive

255.255.255.255/32 receive

 

表 B-3 show ip cef vrf フィールドの説明

フィールド
説明

Prefix

ネットワーク プレフィックスを指定します。

Next Hop

BGP ネクストホップ アドレスを指定します。

Interface

VRF インターフェイスを示します。

 
関連コマンド

コマンド
説明

show ip vrf

VRF とその関連インターフェイスを表示します。

show ip route vrf

VRF に関連付けられた IP ルーティング テーブルを表示します。

show ip protocols vrf

VRF に関連付けられた ルーティング プロトコル情報を表示するには、 show ip protocols vrf EXEC コマンドを使用します。

show ip protocols vrf vrf_name

 
構文の説明

vrf_name

VRF に割り当てられた名前です。

次の例では、v2:red という VRF に関する情報が表示されます。

Router# show ip protocols vrf v2:red

Routing Protocol is "bgp 100"
Sending updates every 60 seconds, next due in 0 sec
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
IGP synchronization is disabled
Automatic route summarization is disabled
Redistributing: connected, static
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
13.13.13.13 200 03:26:15
18.18.18.18 200 03:26:54
Distance: external 20 internal 200 local 200

 

表 B-4 show ip protocols vrf フィールドの説明

フィールド
説明

Gateway

ネットワーク上のすべてのルータについて、ルータ識別情報の IP アドレスが表示されます。

Distance

宛先ルートへのアクセスに使用されるメトリックが表示されます。

Last update

ルーティング テーブルが発信元からアップデートされた最新の時刻が表示されます。

 
関連コマンド

コマンド
説明

show ip vrf

VRF とその関連インターフェイスを表示します。

show ip route vrf

VRF に関連付けられた IP ルーティング テーブルを表示するには、 show ip route vrf EXEC コマンドを使用します。

show ip route vrf vrf_name [ connected ] [protocol [as-number] [tag] [output-modifiers]]

[ list number [output-modifiers]] [ profile ] [ static [output-modifiers]]

[ summary [output-modifiers]] [ supernets-only [output-modifiers]]

[ traffic-engineering [output-modifiers]]

 
構文の説明

vrf_name

VRF に割り当てられた名前です。

connected

VRF にあるすべての接続ルートを表示します。

protocol

ルーティング プロトコルを指定するには、bgp、egp、eigrp、hello、igrp、isis、ospf、rip のうちいずれか 1 つのキーワードを使用します。

as-number

AS 番号。

tag

IOS ルーティング エリア ラベル。

output-modifiers

(オプション)関連のキーワードおよび引数のリストについて、文脈依存ヘルプを使用します。

list number

表示する IP アクセス リストを指定します。

profile

IP ルーティング テーブル プロファイルを表示します。

static

スタティック ルートを表示します。

summary

ルートのサマリーを表示します。

supernets-only

スーパーネット エントリだけを表示します。

traffic-engineering

トラフィック処理ルートだけを表示します。

次の例では、v1:red という VRF に関連付けられた IP ルーティング テーブルを表示します。

Router# show ip route vrf v1:red

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
U - per-user static route, o - ODR
T - traffic engineered route
Gateway of last resort is not set
B 51.0.0.0/8 [200/0] via 13.13.13.13, 00:24:19
C 50.0.0.0/8 is directly connected, Ethernet1/3
B 11.0.0.0/8 [20/0] via 50.0.0.1, 02:10:22
B 12.0.0.0/8 [200/0] via 13.13.13.13, 00:24:20

次の例では、v1:red という VRF に関連付けられた、IP ルーティング テーブル内の BGP エントリを表示します。

Router# show ip route vrf v1:red bgp

B 51.0.0.0/8 [200/0] via 13.13.13.13, 03:44:14
B 11.0.0.0/8 [20/0] via 51.0.0.1, 03:44:12
B 12.0.0.0/8 [200/0] via 13.13.13.13, 03:43:14

 
関連コマンド

コマンド
説明

show ip vrf

VRF とその関連インターフェイスを表示します。

show ip cef vrf

VRF に関連付けられた CEF 転送テーブルを表示します。

show ip vrf

定義された VRF と関連のインターフェイスのセットを表示するには、 show ip vrf EXEC コマンドを使用します。

show ip vrf [{ brief | detail | interfaces }] [ vrf_name ] [ output-modifiers ]

 
構文の説明

brief

(オプション)VRF および関連インターフェイスに関する簡略情報を表示します。

detail

(オプション)VRF および関連インターフェイスに関する詳細情報を表示します。

interfaces

(オプション)特定の VRF、または任意の VRF に向かうすべてのインターフェイスに関する詳細情報を表示します。

vrf_name

VRF に割り当てられた名前です。

output-modifiers

(オプション)関連のキーワードおよび引数のリストについて、文脈依存ヘルプを使用します。

 
使用上のガイドライン

このコマンドを使用して、VRF に関する情報を表示します。詳細レベルには、2 種類があります。 brief キーワードまたは no キーワードを使用すると、簡略情報が表示されます。 detail キーワードを使用すると、全情報が表示されます。特定の VRF、または任意の VRF に向かうすべてのインターフェイスに関する情報を表示するには、 interfaces キーワードを使用します。

オプション パラメータをまったく指定しないと、設定されたすべての VRF に関する簡略情報が表示されます。

この例では、現在設定されている VRF の簡略情報を示しています。

Router# show ip vrf

Name Default RD Interfaces
vrf1:red 100:1 Ethernet1/3
vrf2:blue 100:2 Ethernet0/3

 

表 B-5 show ip vrf フィールドの説明

フィールド
説明

Name

VRF 名を指定します。

Default RD

デフォルトのルート区分を指定します。

Interfaces

ネットワーク インターフェイスを指定します。

次の例では、v1:blue という VRF に関する詳細情報を表示します。

Router# show ip vrf detail v1:blue

VRF vrf1:blue; default RD 100:1
Interfaces:
Ethernet1/3
Export VPN route-target communities
RT:100:1
Import VPN route-target communities
RT:100:1
No import route-map

 

 

表 B-6 show ip vrf detail フィールドの説明

フィールド
説明

Interfaces

ネットワーク インターフェイスを指定します。

Export

VPN ルート ターゲット エクスポート コミュニティを指定します。

Import

VPN ルート ターゲット インポート コミュニティを指定します。

次の例では、特定の VRF に向かうインターフェイスを表示します。

router# show ip vrf interfaces

Interface IP-Address VRF Protocol
Ethernet2 130.22.0.33 vrf3:blue up
Ethernet4 130.77.0.33 hub up
router#

 

表 B-7 show ip vrf interfaces フィールドの説明

フィールド
説明

Interface

VRF のネットワーク インターフェイスを指定します。

IP-Address

VRF インターフェイスの IP アドレスを指定します。

VRF

VRF 名を指定します。

Protocol

各 VRF インターフェイスのプロトコルの状態(アップ/ダウン)が表示されます。

 
関連コマンド

コマンド
説明

ip vrf

VRF 設定モードに入ります。

rd

VRF のデフォルトの RD を設定します。

route-target

VRF のインポートおよびエクスポート拡張コミュニティ アトリビュートを設定します。

import

VRF のインポート ルート マップを設定します。

ip vrf forwarding

VRF をインターフェイスまたはサブインターフェイスに関連付けます。

show tag-switching forwarding vrf

特定の VRF または IP プレフィックスに関連付けられたラベル転送エントリを表示するには、 show tag-switching forwarding vrf EXEC コマンドを使用します。ラベル転送情報の表示をディセーブルにするには、このコマンドの no 形式を使用します。

show tag-switching forwarding vrf vrf_name [ ip-prefix /length [mask]] [detail] [ output-modifiers ]

no show tag-switching forwarding vrf vrf_name [ ip-prefix /length [mask]] [detail] [ output-modifiers ]

 
構文の説明

vrf_name

指定された VRF に関連付けられた NLRI を表示します。

ip-prefix/length

(オプション)IP プレフィックス アドレス(ドット付き 10 進形式)およびマスクの長さ(0 ~ 32)。

mask

(オプション)宛先ネットワーク マスクを、ドット付き 10 進形式で指定します。

detail

(オプション)VRF ルートに関する詳細情報を表示します。

output-modifiers

(オプション)関連のキーワードおよび引数のリストについて、文脈依存ヘルプを使用します。

次の例では、v2:green という VRF に対応するラベル転送エントリを表示します。

Router# show tag-switching forwarding vrf v2:green detail

 
関連コマンド

コマンド
説明

show tag-switching forwarding

ラベル転送情報を表示します。

show ip cef vrf

VRF に関連付けられた CEF 転送テーブルを表示します。

debug ip bgp

処理中の BGP に関連する情報を表示するには、 debug ip bgp EXEC コマンドを使用します。BGP 情報の表示をディセーブルにするには、このコマンドの no 形式を使用します。

debug ip bgp [ A.B.C.D. | dampening | events | in | keepalives | out | updates | vpnv4 ]

no debug ip bgp [ A.B.C.D. | dampening | events | in | keepalives | out | updates | vpnv4 ]

 
構文の説明

A.B.C.D.

(オプション)BGP 近隣ルータの IP アドレスを表示します。

dampening

(オプション)BGP 減衰を表示します。

events

(オプション)BGP イベントを表示します。

in

(オプション)BGP 着信情報を表示します。

keepalives

(オプション)BGP キープアライブを表示します。

out

(オプション)BGP 発信情報を表示します。

updates

(オプション)BGP アップデートを表示します。

vpnv4

(オプション)VPNv4 NLRI 情報を表示します。

次の例は、このコマンドの出力を示します。

Router# debug ip bgp vpnv4

03:47:14:vpn:bgp_vpnv4_bnetinit:100:2:58.0.0.0/8

03:47:14:vpn:bnettable add:100:2:58.0.0.0 / 8

03:47:14:vpn:bestpath_hook route_tag_change for v2:58.0.0.0/255.0.0.0(ok)

03:47:14:vpn:bgp_vpnv4_bnetinit:100:2:57.0.0.0/8