Cisco VPN Solutions Center: MPLS Solution プロビジョニング ガイド
VPN Solutions Center Template Manager によるプロビジョニング
VPN Solutions Center Template Manager によるプロビジョニング
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

VPN Solutions Center Template Manager によるプロビジョニング

Template Manager について

テンプレート作成機能の用途

VPN プロビジョニングのテンプレートの作成

テンプレート本体に設定コマンドを入力する

テンプレート変数にアトリビュートを割り当てる

変数タイプとアトリビュートについて

Integer 変数タイプ

String 変数タイプ

Float 変数タイプ

IPv4 Address 変数タイプ

Template 変数タイプ

テンプレート データ ファイル フォルダの作成

新しいテンプレート データ ファイルの作成

1 次元配列の値の入力

2 次元配列の値の入力

テンプレート データ ファイルのコピー

テンプレート データ ファイルの削除

テンプレート コンフィギュレーション ファイルの作成

テンプレートのコピー

テンプレートの削除

テンプレート コンフィギュレーション ファイルを直接ルータにプロビジョニングする

VPN Solutions Center の リポジトリ変数をテンプレート データとして使用する

MPLS リポジトリ変数の概要

IPsec LAN-to-LAN リポジトリ変数の概要

IPsec Remote-Access リポジトリ変数の概要

Ethernet Over MPLS を VPN Solutions Center で使用する

生成されたコンフィグレットの例

VPNSC Ethernet Over MPLS のテンプレート

EoMPLS テンプレートの内容

コンフィギュレーション例

OSR1 とデータ ファイル EndPoint1

OSR1 のコンフィグレットと EndPoint1 データ ファイル

OSR2 とデータ ファイル EndPoint2

OSR2 のコンフィグレットと EndPoint2 データ ファイル

Ethernet Over MPLS の削除テンプレート

EoMPLS テンプレートの内容

EoMPLS 削除テンプレート用に生成されたコンフィグレット

テンプレートの言語と構文のリファレンス

文法と構文

表記規則

トークン

テンプレート コメント

トークン変数

キーワード

定数

If-Else 文について

If-Else の関係

サブテンプレートについて

例 1:各値を 1 つずつ渡す簡単なケース

例 2:1 つの必須値と 1 つのオプション値

例 3:メイン テンプレートから 2 つのサブテンプレートを呼び出す

テンプレート組み込み関数呼び出し

サブストリングの取得

別のコメント文字の指定

IpAddrMaskPair 文字列からの IP アドレスの取得

IpAddrMaskPair 文字列からの IP マスクの取得

IpAddrMaskPair 文字列からの IP 逆マスクの取得

IpAddrMaskPair 文字列からのネットワーク アドレスの取得

IpAddrMaskPair 文字列からのクラスフル ネットワーク アドレスの取得

テンプレート言語の命令

コンフィグレット出力でのエラー説明の表示

コンフィグレットの生成の中断

VPN Solutions Center が提供するテンプレート例

VPN Solutions Center Template Manager によるプロビジョニング

Template Manager について

VPN Solutions Center ソフトウェアの Template Manager は、高速で柔軟かつ拡張可能な Cisco IOS コマンド生成機能を提供するプロビジョニング システムです。Template Manager では、標準テンプレートを定義し、共通の IPv4、QoS、VPN プロビジョニングなどの共通プロビジョニング タスク用に Cisco IOS コンフィギュレーション ファイルを生成します。

「テンプレート ファイル」は、Template Manager によって作成されるファイルで、VPN Solutions Center テンプレート定義が保存されます。

「テンプレート データ ファイル」は、テキスト ファイルで、テンプレート ファイルを生成するための変数値が格納されています。有効なデータ ファイルには、テンプレートで定義されている変数すべての名前と値のペアが含まれます。各テンプレート ファイルは、複数のデータ ファイルに関連付けることができますが、各データ ファイルを関連付けられるテンプレートは 1 つだけであることに注意してください。テンプレートの生成に使用するデータ ファイルは、選択できます。データ ファイルのファイル名拡張子は、 dat です。

「テンプレート コンフィギュレーション ファイル」は、IOS コンフィギュレーション ファイルであり、Template Manager により作成された Cisco IOS コマンドを格納しています。テンプレート コンフィギュレーション ファイルは、部分的または完全なコンフィギュレーション ファイルとして作成できます。特定のデータ ファイルを使用してテンプレート コンフィギュレーション ファイルを生成する場合、テンプレート コンフィギュレーション ファイルの名前は、使用するデータ ファイルの名前と同じになります。

テンプレート データ ファイルは、対応するテンプレートと密にリンクしています。データ ファイルとそれに関連付けられているテンプレートを使用して、テンプレート コンフィギュレーション ファイルを作成できます。テンプレート コンフィギュレーション ファイルは VPNSC コンフィグレットにマージ(アペンドまたはプリペンド)されます。VPN Solutions Center は結合されたコンフィグレットをエッジ デバイス ルータにダウンロードします。

同じテンプレートを複数のデバイスに適用できます。それには、各デバイスに適切なテンプレート データ ファイルを割り当てます。各テンプレート データ ファイルには、デバイスに関する詳細なデータ(たとえば、管理 IP アドレスまたは各デバイスのホスト名)が含まれています。

テンプレート ファイルおよびデータ ファイルは XML 形式となっています。テンプレート ファイル、そのデータ ファイル、およびすべてのテンプレート コンフィギュレーション ファイルは、1 つのディレクトリにマッピングされます。

VPN Solutions Center が、初期 VPNSC コンフィグレットを作成します。Template Manager を使用して、テンプレート コンフィギュレーション ファイルを作成します。その後で、テンプレート コンフィギュレーション ファイルをサービス要求に関連付けます。この関連付けにより、実際には VPNSC コンフィグレットとテンプレート コンフィギュレーション ファイルがマージされます。このプロセスの詳細については、「Templates」 を参照してください。

その後、このマージされた VPNSC コンフィグレットを、ターゲット ルータ(複数可)にダウンロードできます。


ヒント テンプレート コンフィギュレーション ファイルを作成し、それを直接ルータにダウンロードすることもできます。これについては、「テンプレート コンフィギュレーション ファイルを直接ルータにプロビジョニングする」 で説明します。


テンプレート作成機能の用途

サービス プロバイダーは Template Manager を使用して、VPN Solutions Center の機能を拡張できます。Telnet Gateway Server (TGS)を利用すると VPN Solutions Center ターゲットにコンソールからアクセスできるため、Template Manager を使用して、初期コンフィギュレーションを任意のサービス プロバイダーのコア デバイス、またはエッジ デバイスに対して提供できます。

Template Manager をスタンドアロン ツールとして使用して、完全なコンフィギュレーション ファイルを生成できます。このコンフィギュレーション ファイルは、あらゆる VPN Solutions Center ターゲットにダウンロードできます。

テンプレート作成機能のその他の用途として、次のものがあります。

IOS ファイアウォールのプロビジョニング

VPN Solutions Center がサービス要求に含めていないコマンド セットの追加。たとえば、ATM CoS (Class of Service)のプロビジョニング。

IP 接続を使用してサービス クラスを適用する。

VPN Solutions Center サービス要求および Cisco IOS コンフィギュレーション ファイルのダウンロードを、コンソールを介して 1 回のダウンロード操作で行う。このエッジ デバイスのステージング方式は、テンプレートの作成とサービス要求の適用を 1 ステップで行います。

VPN プロビジョニングのテンプレートの作成

VPN プロビジョニング用の VPN Solutions Center テンプレートを作成するには、次の手順を実行します。


ステップ 1 VPN Solutions Center を起動し、VPN コンソールを立ち上げます。

ステップ 2 VPN コンソールから Tools > Template Console を選択します。

VPN Solutions Center の Template Manager が表示されます(図 10-1 を参照)。

図 10-1 Template Manager ウィンドウ

 

Template Home は、テンプレート オブジェクトのライフ サイクルと場所を管理するオブジェクトです。

テンプレート フォルダではテンプレートが階層構造に論理的に構成されるため、ナビゲーションが容易です。ファイル システムにたとえると、テンプレート フォルダはディレクトリに当たり、テンプレートはファイルに当たります。多数のデータ ファイルを 1 つのテンプレートに関連付けることが可能で、任意のデータ ファイルを使用してテンプレートを生成できます。

図 10-1 に示すように、Template Manager にはロバストなテンプレート例のセットがあります。各テンプレート例の説明については、「VPN Solutions Center が提供するテンプレート例」 を参照してください。

ステップ 3 最上位レベルで新規のフォルダを作成するには、Template Home フォルダを選択して 右クリック します。

図 10-2 に示すメニューが、表示されます。

図 10-2 テンプレート フォルダ メニュー

 

ステップ 4 テンプレート フォルダ メニューから New Folder を選択します。

New Template Folder ダイアログボックスが表示されます(図 10-3 を参照)。

図 10-3 New Template Folder ダイアログボックス

 

ステップ 5 新しいテンプレート フォルダの名前を入力してから OK をクリックします。

新しいテンプレート フォルダが、テンプレート ツリー内のフォルダに追加されます。


) 新しいテンプレートを作成するために、新しいフォルダを作成する必要はありません。新しいテンプレートを作成する場合は、任意のテンプレート フォルダを選択できます。


ステップ 6 新しいテンプレートを格納するフォルダを選択して、 右クリック します。

フォルダ メニューが表示されます。このステップでは New Template などのその他のコマンドがイネーブルになります(図 10-4 を参照)。

図 10-4 新しいテンプレートの作成

 

ステップ 7 メニューから New Template を選択します。

データ ペインにテンプレート エディタが表示されます(図 10-5 を参照)。

図 10-5 テンプレート エディタ

 

ステップ 8 Title フィールド、 Description フィールドおよび Keywords フィールドに情報を入力します。

a. Title :新しいテンプレートのタイトルを入力します。

Title フィールドの入力はオプションですが、入力することをお勧めします。ここで入力するタイトルは、テンプレートの名前ではなく、テンプレートの簡潔な説明です。

b. Description :テンプレートの説明を入力します。

Description フィールドの入力はオプションですが、入力することをお勧めします。

ステップ 9 Keywords1 つまたはそれ以上のキーワードを Keywords 領域に入力します。

キーワードは、テンプレートを定義した後でテンプレートを検索する際に使用します。

a. キーワードを追加するには Add をクリックします。

新しいキーワード フィールドが Keywords 領域に表示されます。

b. Keywords 領域内をクリックし、キーワードを入力します。


 

テンプレート本体に設定コマンドを入力する

Template Manager の Body 領域は、コンフィギュレーション ファイルに追加する設定コマンドを入力する領域です。ここでは、Cisco IOS コマンドを入力し、入力したコマンドの VPN Solutions Center テンプレート構文をチェックして、IOS コマンドによって呼び出される変数を作成できます。

その結果、「テンプレート コンフィギュレーション ファイル」が作成され、これは VPN Solutions Center の標準プロビジョニングによって生成される「VPNSC コンフィグレット」に追加されます。VPN Solutions Center ソフトウェアは、テンプレート コンフィギュレーション ファイルと VPNSC コンフィグレットの組み合せをターゲット ルータにダウンロードします。


) VPN Solutions Center のテンプレートでは、対話型 Cisco IOS コマンドの使用はサポートされていません。


VPN Solutions Center テンプレート言語の詳細については、「テンプレートの言語と構文のリファレンス」 を参照してください。


ステップ 1 Template Manager の Body 領域に、必要なテンプレート コンフィギュレーション ファイルを作成するための Cisco IOS コマンドと適切な変数を入力します。


ヒント 効率的にデータを入力するには、端末ウィンドウから既存のコマンドをコピーし、Body 領域に貼り付けます(Ctrl キーを押した状態で V キーを押します)。


ステップ 2 IOS コマンドの入力が完了したら、 Create Variables をクリックします。

Template Manager は VPNSC テンプレート構文(Cisco IOS 構文ではない)を自動的にチェックし、Body 領域に入力した変数を Variables 領域(ダイアログボックスの下部)に配置します(図 10-6 を参照)。

テンプレート構文にエラーが 1 つまたはそれ以上ある場合は、構文エラー メッセージが表示されます。構文エラー メッセージには、エラーの種類と、エラーが発生した行が示されます。エラー メッセージを閉じ、構文エラーを訂正します。

図 10-6 テンプレートと変数の完成

 

ステップ 3 File >Save を選択し、変更内容を保存します。

Save ダイアログボックスが表示されます(図 10-7 を参照)。

図 10-7 テンプレートの変更内容の保存

 

ステップ 4 テンプレート ファイル名を入力し、 OK をクリックします。

テンプレートを保存すると、テンプレート ツリーの該当するテンプレート フォルダの下にテンプレート名が追加されます。


 

テンプレート変数にアトリビュートを割り当てる

変数は $ 記号で始まる文字列です。変数はプレースホルダで、テンプレートが生成された際に、テンプレート データ ファイルの実際の値で置き換わります。

VPN Solutions Center テンプレートに入力したすべての変数は、ローカル変数です。あるテンプレートで宣言された変数は、そのテンプレートでのみ使用できます。

変数にアトリビュートを設定するには、次の手順を実行します。


ステップ 1 Template Manager の Variables 領域(図 10-6 を参照)から、編集する変数を選択します。

ステップ 2 Edit をクリックします。

Edit Variable ダイアログボックスが表示されます(図 10-8 を参照)。

図 10-8 Edit Variable ダイアログボックス

 

変数タイプの設定

ステップ 3 Type ドロップダウン メニューから、選択した変数に割り当てる変数タイプを選択します。

図 10-8 に示すように、選択できる変数タイプは次の 5 つです。

Integer

String

Float

IPv4 Address

Template

変数タイプを選択すると、Edit Variable ダイアログボックスに表示されるフィールドが変わり、選択したタイプで設定できるパラメータが表示されます。一部のパラメータは、すべての変数タイプで共通です。このパラメータについては、後述の手順で説明します。

各変数タイプには、事前定義のアトリビュート セットが関連付けられています。各変数タイプの詳細については、「変数タイプとアトリビュートについて」を参照してください。

変数が必須かオプションかの宣言

ステップ 4 Declare ドロップダウン メニューから、変数を Required (必須)にするか Optional (オプション)にするかを指定します。

Required を選択する場合は、関連データ ファイルでこの変数の値を指定する必要があります。これはデフォルト設定です。

Optional を選択する場合は、関連データ ファイルでこの変数の値を省略できます。

Dimension アトリビュートの指定

ステップ 5 Dimension ドロップダウン メニューから、Dimension アトリビュートを指定します。

Dimension アトリビュートは、変数の配列(またはリスト)を作成する、オプションのアトリビュートです。デフォルト値は 0 で、これは単一変数または列挙変数を表します。

Dimension アトリビュートを 1 または 2 に設定すると、変数は 1 次元または 2 次元の配列になります。この場合は、配列のすべての要素に制約アトリビュートが適用されます。

Default アトリビュートの指定

ステップ 6 Default フィールドでは、選択した変数のデフォルト値を指定します(デフォルト値がある場合)。これはオプションのアトリビュートです。この変数の使用可能値も設定する場合、ここで指定するデフォルト値は、使用可能値のいずれかにする必要があります。

使用可能値の指定

変数の使用可能値を指定すると、入力した値だけが、変数に割り当てられる値になります。この変数のデフォルト値も設定する場合、デフォルト値は、使用可能値のいずれかにする必要があります。

ステップ 7 選択した変数に使用可能値を指定するには、次の手順を実行します。

a. Template Manager に表示される変数のリストから、編集する変数を選択して Edit をクリックします。

Edit Variable: variable_name ダイアログボックスが表示されます。

b. Add をクリックします。

新しい空白のフィールドが Available Values 領域に表示されます。

c. 最初の使用可能値を入力します。

d. 選択した変数に追加の使用可能値を指定するには、 Add をクリックして別の値を入力します。必要なすべての値を指定するまで、この手順を繰り返します。

e. 値の入力が終了したら OK をクリックします。

Edit Variable ダイアログボックスに入力した値が、Template Manager の Variables 領域で選択した変数に対応して表示されます。

ステップ 8 Save をクリックし、 Yes をクリックして保存操作を実行し、変更内容を保存します。


 

変数タイプとアトリビュートについて

変数とは、値を表す記号または名前です。VPN Solutions Center は、テンプレートが作成されるときに、ほぼすべての変数を文字列に変換しますが、各変数タイプに対してアトリビュートを設定できます。たとえば、Integer 変数では、データで許可される最小値と最大値を設定できます。

図 10-8 に示すように、選択できる変数タイプは次の 5 つです。

Integer

String

Float

IPv4 Address

Template

Integer 変数タイプ

Integer とは整数です。Integer 変数タイプに設定できるアトリビュートは次のとおりです。

 

表 10-1 Integer 変数の アトリビュート

アトリビュート
コメント
アトリビュート
コメント

Name

必須のアトリビュート。一意の名前である必要があります。

Minimum value

オプション。

Maximum value

オプション。

Available values

オプション。

Default

オペレータがデータを指定しない場合のデフォルト値。

Dimension

Dimension アトリビュートが 1 または 2 の場合は、変数の配列(またはリスト)が作成されます。Integer 変数を配列にするかどうかを指定します。選択肢は、 0 1 2 です。

Declaration

必須の変数またはオプションの変数のどちらであるかを指定します。

String 変数タイプ

String とは、グループとみなされる文字の組み合せをいいます。String 変数タイプに指定できるアトリビュートは次のとおりです。

 

表 10-2 String 変数のアトリビュート

アトリビュート
コメント
アトリビュート
コメント

Name

必須のアトリビュート。一意の名前である必要があります。

Minimum length

オプション。このアトリビュートを指定した場合、この値より文字列を短くすることはできません。

Maximum length

オプション。このアトリビュートを指定した場合、この値より文字列を長くすることはできません。

Available values

オプション。

Default

オペレータがデータを指定しない場合のデフォルト値。

Dimension

Dimension アトリビュートが 1 または 2 の場合は、変数の配列(またはリスト)が作成されます。String 変数を配列にするかどうかを指定します。選択肢は、 0 1 2 です。

Declaration

必須の変数またはオプションの変数のどちらであるかを指定します。

Pattern

文字列の正規表現パターン。たとえば、 vpnsc[0-9]+ というパターンは、「vpnsc」で始まり、0 から 9 の数字が続く文字列を定義します。

Float 変数タイプ

浮動小数点数とは、小数点前後の桁数が固定されていない数値です。Float 変数タイプに指定できるアトリビュートは次のとおりです。

 

表 10-3 Float 変数のアトリビュート

アトリビュート
コメント
アトリビュート
コメント

Name

必須のアトリビュート。一意の名前である必要があります。

Minimum value

このアトリビュートを指定した場合、この値より小さくすることはできません。

Maximum value

このアトリビュートを指定した場合、この値より大きくすることはできません。

Available values

オプション。

Default

オペレータがデータを指定しない場合のデフォルト値。

Dimension

Dimension アトリビュートが 1 または 2 の場合は、変数の配列(またはリスト)が作成されます。Float 変数を配列にするかどうかを指定します。選択肢は、 0 1 2 です。

Declaration

必須の変数またはオプションの変数のどちらであるかを指定します。

IPv4 Address 変数タイプ

この変数タイプは、IPv4 アドレスを表します。オペレータが IP アドレスのデータを提供しない限り、デフォルトの IPv4 Address 変数は文字列形式です。図 10-9 に、Edit Variable ダイアログボックスを使用した IPv4 変数の定義の例を示します。

図 10-9 IPv4 Address 変数の定義の例

 


) VPN Solutions Center リリース 2.x では、Subnet Mask アトリビュートがサポートされていません。


IPv4 Address 変数タイプに指定できるアトリビュートは次のとおりです。

 

表 10-4 IPv4 Address 変数のアトリビュート

アトリビュート
コメント
アトリビュート
コメント

Name

必須のアトリビュート。一意の名前である必要があります。

Class

IP アドレスのクラス。選択肢は、 A B C です。

Subnet mask

IP アドレスのサブネット マスク。このリリースでは、このアトリビュートはサポートされていません。

Available values

オプション。必要に応じて、使用できるアドレスを使用可能値として指定します。

Default

文字列 。オペレータがデータを指定しない場合のデフォルト値。

Dimension

Dimension アトリビュートが 1 または 2 の場合は、変数の配列(またはリスト)が作成されます。IPv4 Address 変数を配列にするかどうかを指定します。選択肢は、 0 1 2 です。

Declaration

必須の変数またはオプションの変数のどちらであるかを指定します。

Template 変数タイプ

テンプレート内に埋め込まれるテンプレートは、「サブテンプレート」と呼ばれます。この変数タイプでは、サブテンプレートを取得できるサブテンプレート変数を指定します。VPN Solutions Center では、1 レベルのサブテンプレートのみがサポートされています。このため、サブテンプレートに別のサブテンプレートを組み込む(埋め込む)ことはできません。

Template 変数を作成する前に、変数が参照するサブテンプレートを作成します。変数タイプを Template に設定した場合は、サブテンプレートの名前と場所を参照して指定する必要があります。

Template 変数タイプに指定できるアトリビュートは次のとおりです。

 

表 10-5 Template 変数のアトリビュート

アトリビュート
コメント
アトリビュート
コメント

Name

サブテンプレート名は一意である必要があります。

Template location

VPNSC テンプレート階層構造内でのテンプレートの位置を指定します。

テンプレート データ ファイル フォルダの作成

フォルダを作成して、テンプレート データ ファイルを整理できます。テンプレート データ ファイル フォルダでは、データ ファイルが階層構造に論理的に構成されるため、ナビゲーションが容易です。テンプレート データ ファイルは、関連するテンプレートに排他的にリンクされています。

テンプレート データ ファイル フォルダを作成するには、次の手順を実行します。


ステップ 1 VPN コンソールのメニュー バーから Tools > Template Console を選択します。

Template Manager が表示されます。

ステップ 2 Template Home 階層ペインで、新しいデータ ファイル フォルダを作成するテンプレートの名前が表示されるまで階層を展開します。

ステップ 3 テンプレート名を選択し、マウスを右クリックします。

ステップ 4 メニューから New Folder を選択します(図 10-10 を参照)。

図 10-10 New Folder オプション

 

New Data File Folder ダイアログボックスが表示されます(図 10-11 を参照)。

図 10-11 新しいデータ ファイル フォルダの名前の入力

 

ステップ 5 データ ファイル フォルダの名前を入力してから、 OK をクリックします。

新しいデータ ファイル フォルダがテンプレート階層構造に追加されます(図 10-12 を参照)。

図 10-12 追加された新しいデータ ファイル フォルダ

 


 

新しいテンプレート データ ファイルの作成

「テンプレート データ ファイル」はテキスト ファイルで、このファイルにはテンプレート ファイルの生成に必要な変数値が保存されます。有効なテンプレート データ ファイルには、テンプレート内で定義されている変数すべての名前と値のペアが含まれます。

各テンプレートには複数のデータ ファイルを関連付けられますが、各データ ファイルに関連付けられるテンプレートは 1 つだけです。テンプレートの生成に使用するテンプレート データ ファイルは選択できます。

新しいテンプレート データ ファイルを作成するには、次の手順を実行します。


ステップ 1 VPN コンソールのメニュー バーから Tools > Template Console を選択します。

Template Manager が表示されます。

ステップ 2 Template Home 階層ペインで、新しいデータ ファイルを作成するテンプレートの名前が表示されるまで階層を展開します。

ステップ 3 テンプレート名を選択し、マウスを右クリックします。

ステップ 4 メニューから New Data File を選択します(図 10-13 を参照)。

図 10-13 New Data File オプション

 

右側のデータ ペインに新しい Template Data Files ダイアログボックスが表示されます(図 10-14 を参照)。

ダイアログボックスの Data Files 領域に各変数の名前が表示され、その下のセルにその変数の指定値が表示されます。

図 10-14 新しい Template Data Files ダイアログボックス

 

ステップ 5 必要に応じて、デフォルト名( Data0 )から識別が容易な名前に、データ ファイルの名前を変更します。

a. Data File Name セルをクリックします。

b. 必要に応じてデータ ファイル名を変更します。

ステップ 6 各変数名の下にあるセルをクリックしてデータを入力し、テンプレート本体から呼び出される各変数に対して適切な値を入力します。

Template Manager に、標準スプレッドシート形式で変数が表示されます。各変数に対して初期デフォルト値が表示されます。

変数タイプ、設定、アトリビュートによって入力するデータ値は変わります。Template Manager はデータの保存時にタイプ チェックを行います。たとえば、Integer として定義されているフィールドに数値以外を入力すると、Template Manager にはデータを拒否し、誤りを警告します。

図 10-15 の track_priority 変数で示すように、変数の名前をクリックすると、その変数の使用可能値の設定を表示できます。

図 10-15 変数の使用可能値のリスト

 


 

1 次元配列の値の入力

1 次元配列では、該当する変数に対してテンプレートに適用できる値のリストが作成されます。特定の 1 次元変数に代入できる値の数は、定義する値の数によって決まります(図 10-17 を参照)。

次に、1 次元配列を定義する、テンプレートに入力するプログラム文の例を示します。

!
{
access-list $ACL[$i] permit ip $Source_IP_Address[$i] $Source_Mask[$i] $Dest_IP_Address[$i] $Dest_Mask[$i] precedence 7
}

この例のサブステートメントで宣言されている変数で指定されている $i、たとえば

$Source_IP_Address[i]

は、1 次元変数であることを表します。たとえば、 Source_IP_Address 変数にそれぞれの値が指定されている場合、テンプレートは Source_IP_Address に 1 つの値を代入します。

1 次元配列に値を入力するには、次の手順を実行します。


ステップ 1 Template Data Files ダイアログボックスが開いていない場合は、目的のデータ ファイルの名前が表示されるまで、Template Manager 階層構造を展開します。

ステップ 2 テンプレート データ ファイルを選択し、マウスを右クリックします。

ステップ 3 メニューから Open を選択します。

Template Manager の Data Files ダイアログボックスが表示されます(図 10-16 を参照)。

図 10-16 1 次元変数の選択

 

選択したテンプレート データ ファイルの名前と各変数が表示されます。各変数セルの幅は、マウスを使用して調整できます。

ステップ 4 編集する変数の名前が表示されているセルまでスクロールします。

ステップ 5 変数セルを選択して、ダブルクリックします。

Edit Variable: variable_name ダイアログボックスが表示されます(図 10-17 を参照)。

図 10-17 1 次元配列変数のデータの入力

 

ステップ 6 Edit Variable ダイアログボックスで Add をクリックします。

新しいフィールドが編集領域に表示されます。

ステップ 7 変数に割り当てる最初の値を入力します。

ステップ 8 Add をクリックし、変数に割り当てる追加の値を入力します。

リストから値を削除するには、削除する値を選択して Remove をクリックします。

ステップ 9 データの入力が終了したら、 OK をクリックします。

入力した値が、図 10-18 に示すように、該当する Data Files 変数セルに表示されます。

図 10-18 1 次元配列が追加されたデータ ファイルの変数表示

 

ステップ 10 File > Save を選択し、ファイル保存の確認に対して Yes をクリックして、変更内容を保存します。


 

2 次元配列の値の入力

2 次元配列では、該当する変数に対してテンプレートに適用できる値のテーブルが作成されます。特定の 2 次元変数に代入できる値の数は、Edit Variable ダイアログボックスで定義する行数と列数で決まります。

表 10-6 に示すように、インデックス規則では、インデックスが付いたテーブル内の位置を表す数値のペアを使用します。

 

表 10-6 2 次元配列のインデックス規則

0, 0

0, 1

0, 2

1, 0

1, 1

1, 2

2, 0

2, 1

2, 2

Template Manager の Variable Editor で作成した行と列に基づいて、2 次元変数のインデックス規則に対応するセルのテーブルが作成されます。インデックス規則で指定された位置と 2 次元変数文をリンクすると、値が代入されます。

たとえば、IP、TCP、RIP、UDP という 4 つの値を取るプロトコル変数があるとします。図 10-19 の Edit Variable ダイアログボックスの例は、4 つのプロトコル値が相対位置で示されています。

図 10-19 2 次元配列の入力

 

「IP」は 0, 0 インデックス位置に入ります。

「TCP」は 0, 1 インデックス位置に入ります。

「RIP」は 1, 0 インデックス位置に入ります。

「UDP」は 1, 1 インデックス位置に入ります。

適切な変数値を代入するには、テンプレート本体で定義した変数は次のように定義されます。

IP を代入する場合: Protocol [0] [0]

TCP を代入する場合: Protocol [0] [1]

RIP を代入する場合: Protocol [0] [1]

RIP を代入する場合: Protocol [1] [1]

2 次元配列に値を入力するには、次の手順を実行します。


ステップ 1 Template Data Files ダイアログボックスが開いていない場合は、目的のデータ ファイルの名前が表示されるまで、Template Manager 階層構造を展開します。

ステップ 2 テンプレート データ ファイルを選択し、マウスを右クリックします。

ステップ 3 メニューから Open を選択します。

Template Manager の Data Files ダイアログボックスが表示されます。選択したテンプレート データ ファイルの名前と各変数が表示されます。各変数セルの幅は、マウスを使用して調整できます。

ステップ 4 編集する変数の名前が表示されているセルまでスクロールします。

ステップ 5 変数セルを選択して、ダブルクリックします。

Edit Variable: variable_name ダイアログボックスが表示されます(図 10-20 を参照)。

図 10-20 2 次元配列の入力

 

2 次元配列の Edit Variable ダイアログボックスが初めて表示される場合は、編集領域にはフィールドが表示されていません。

ステップ 6 データ入力を開始するには、 Add Row をクリックします。

図 10-20 に示す行が表示されます。

ステップ 7 変数テーブルに列を追加するには、 Add Column をクリックします。

ステップ 8 必要に応じて行と列を追加して変数インデックス テーブルを構築し、変数の値に必要な数のセルを作成します。

不要な行や列を削除するには、削除する行または列のセルを選択し、 Remove Row または Remove Column をクリックします。

ステップ 9 各セルをクリックし、必要な変数値を入力します。

ステップ 10 データの入力が終了したら、 OK をクリックします。

入力した値が、図 10-21 に示すように、該当する Data Files 変数セルに表示されます。

図 10-21 2 次元配列が追加されたデータ ファイルの変数表示

 

ステップ 11 File > Save を選択し、ファイル保存の確認に対して Yes をクリックして、変更内容を保存します。


 

テンプレート データ ファイルのコピー

テンプレート データ ファイルは、Template Manager 内のある場所から別の場所にコピーできます。テンプレート データファイルは、関連するテンプレートと厳密にリンクしています。このため、一般的には同じテンプレートにテンプレート データ ファイルをコピーしてから、適宜に変数を修正します。

テンプレート データ ファイルをコピーするには、次の手順を実行します。


ステップ 1 コピーするデータ ファイルの名前が表示されるまで、テンプレート階層構造を展開します。

ステップ 2 データ ファイル名を選択し、マウスを右クリックします。

図 10-22 テンプレート データ ファイルのコピー

 

ステップ 3 メニューから Copy を選択します。

ステップ 4 データ ファイルをコピーする先のテンプレート フォルダ(またはデータ ファイル フォルダ)を選択します。

ステップ 5 メニューから Paste を選択します。

選択したフォルダにテンプレート データ ファイルがコピーされます。


 

テンプレート データ ファイルの削除

テンプレート データ ファイルは、Template Manager から削除できます。テンプレート データファイルは、関連するテンプレートと密にリンクしています。このため、データ ファイルを削除すると、結果としてテンプレートが使用不可になります。

テンプレート データ ファイルを削除するには、次の手順を実行します。


ステップ 1 削除するデータ ファイルの名前が表示されるまで、テンプレート階層構造を拡張します。

ステップ 2 データ ファイル名を選択し、マウスを右クリックします。

ステップ 3 メニューから Delete を選択します。

次の警告が表示されます。

Warning: Are you sure that you want to delete <filename> file?

ステップ 4 選択したデータ ファイルを削除するには、 Yes をクリックします。

データ ファイルの削除操作をキャンセルするには、 No をクリックします。


 

テンプレート コンフィギュレーション ファイルの作成

テンプレート コンフィギュレーション ファイルは、特定のテンプレートと特定のデータ ファイルに基づいて作成できます。

テンプレート コンフィギュレーション ファイルを作成するには、次の手順を実行します。


ステップ 1 VPN コンソールのメニュー バーから Tools > Template Console を選択します。

Template Manager が表示されます。

ステップ 2 Template Home 階層構造ペインで、テンプレート コンフィギュレーション ファイルの作成元とするテンプレートの名前と関連するテンプレート データ ファイルの名前が表示されるまで、階層を展開します。

ステップ 3 目的のテンプレート データ ファイルを選択し、マウスを右クリックします。

ステップ 4 メニューから Open を選択します。

Template Data Files ダイアログボックスが表示されます。

ステップ 5 データ ファイル名と変数が表示されている行を選択します(図 10-23 を参照)。

図 10-23 テンプレート データ ファイルの選択

 

ステップ 6 Create Config をクリックします。

次のメッセージを受信します。

The Data File will be saved before creating a configuration.

ステップ 7 OK をクリックして続行します。

Configuration Created ウィンドウが表示されます。このウィンドウには、選択したテンプレートとコンフィギュレーション ファイルから作成されたテンプレート コンフィギュレーション ファイルが表示されます(図 10-24 を参照)。

図 10-24 テンプレート コンフィギュレーション ファイルの表示

 

Template Manager は「Configurations」というフォルダを適切なテンプレート フォルダ内に作成し、コンフィギュレーション ファイルを Configurations フォルダ内に格納します。

ステップ 8 コンフィギュレーション ファイル ウィンドウを閉じるには、 OK をクリックします。


 

テンプレートのコピー

VPN Solution Center のテンプレートは、テンプレート階層構造内のあるフォルダから別のフォルダにコピーできます。テンプレートをコピーすると、そのテンプレートに関連する、すべてのファイルとフォルダ(データ ファイルとコンフィギュレーション ファイル)も新しい場所にコピーされます。

VPN Solution Center テンプレートをコピーするには、次の手順を実行します。


ステップ 1 コピーするテンプレートの名前が表示されるまで、テンプレート階層を展開します。

ステップ 2 テンプレート名を選択し、マウスを右クリックします。

ステップ 3 メニューから Copy を選択します。

ステップ 4 テンプレートのコピー先のテンプレート フォルダを選択します。

ステップ 5 メニューから Paste を選択します。

テンプレートと関連するファイルとフォルダが、選択したフォルダにコピーされます。


 

テンプレートの削除

テンプレートは、VPN Solutions Center の Template Manager から削除できます。テンプレートを削除すると、そのテンプレートに関連する、すべてのファイルとフォルダ(データ ファイルとコンフィギュレーション ファイル)も削除されます。

VPN Solution Center テンプレートを削除するには、次の手順を実行します。


ステップ 1 削除するテンプレートの名前が表示されるまで、テンプレート階層を展開します。

ステップ 2 テンプレート名を選択し、マウスを右クリックします。

ステップ 3 メニューから Delete Template を選択します。

次の警告が表示されます。

WARNING: All files in the selected template directory will be deleted.Do you want to continue?

ステップ 4 選択したテンプレートを削除するには、 Yes をクリックします。

テンプレートの削除操作をキャンセルするには、 No をクリックします。

テンプレートと関連するファイルとフォルダが、Template Manager から削除されます。


 

テンプレート コンフィギュレーション ファイルを直接ルータにプロビジョニングする

テンプレート コンフィギュレーション ファイルを、ルータに直接ダウンロードできます。これを行うには、次の手順を実行します。


ステップ 1 VPN コンソールのメニュー バーから Tools > Template Console を選択します。

Template Manager が表示されます。

ステップ 2 Template Home 階層構造ペインで、ルータにダウンロードするテンプレートの名前と関連するテンプレート コンフィギュレーション ファイルの名前が表示されるまで、階層を展開します。

ステップ 3 目的のテンプレート コンフィギュレーション ファイルを選択し、 右クリック します(図 10-25 を参照)。

図 10-25 テンプレート コンフィギュレーション ファイルのメニュー

 

ステップ 4 メニューから Download を選択します。

VPN Solutions Center Network ウィンドウが表示されます(図 10-26 を参照)。

図 10-26 VPNSC Network ウィンドウからルータを選択する

 

ステップ 5 Network ウィンドウで、次を指定します。

a. Network ドロップダウン メニューから適切なネットワークを選択します。

b. Role ドロップダウン メニューから Cisco Router を選択します。

c. ルータのリストから、テンプレート コンフィギュレーション ファイルのダウンロード先とする 1 つまたはそれ以上のルータを選択します。

ステップ 6 選択が終了したら Download をクリックします。

情報ウィンドウが表示され、テンプレート コンフィギュレーション ファイルのダウンロード操作のステータスが示されます(図 10-27 を参照)。

図 10-27 テンプレート コンフィギュレーション ファイルのダウンロード ステータス ウィンドウ

 


 

VPN Solutions Center の リポジトリ変数をテンプレート データとして使用する

VPN Solutions Center サービス定義の一部である、IPsec 変数、または MPLS 変数のいずれかのリストから、変数を選択できます。リストから選択するデータ値は、テンプレートをサービス要求に関連付けるときに代入されます。このプロセスの詳細については、「Templates」を参照してください。


注意 リポジトリ変数をテンプレート内で使用する場合は、Template Manager を使用してテンプレート コンフィギュレーション ファイルをルータにダウンロードできません。これは、VPN Solutions Center によってサービス要求がプロビジョニングされるときに、その変数のデータ値が代入されるためです。このプロセスではサービス要求が回避されるため、割り当てた リポジトリ変数に適切なデータが代入されません。

VPN Solutions Center のリポジトリ値をテンプレート データとして使用するには、次の手順を実行します。


ステップ 1 VPN コンソールのメニュー バーから Tools > Template Console を選択します。

ステップ 2 Template Manager 階層構造ペインで、目的のデータ ファイルの名前が表示されるまでテンプレート階層を展開します。

ステップ 3 目的のデータ ファイルの名前を選択し、マウスを右クリックします。

ステップ 4 メニューから Open を選択します。

Data Files ダイアログボックスが表示されます。

ステップ 5 目的の変数のセルを選択し、マウスを右クリックします。

ステップ 6 メニューから MPLS を選択します。MPLS サービス値のリストが表示されます(図 10-28 を参照)。

図 10-28 MPLS リポジトリ変数のメニュー

 

ステップ 7 変数値のリストから適切な値を選択します。


 

MPLS リポジトリ変数の概要

表 10-7 に、VPN Solutions Center の Template Manager で使用できる MPLS リポジトリ変数の概要を示します。

 

表 10-7 MPLS リポジトリ変数

リポジトリ変数
次元
説明

MPLSAsNumber

0

ドメイン AS の番号

100

MPLScableModemHelperAddr

0

ケーブル モデムのヘルパー アドレス

209.165.201.1

MPLScableModemHostHelperAddr

0

ケーブル モデム ホストのヘルパー アドレス

209.165.201.2

MPLScableModemMaintenanceInterfaceHelperAddr

0

ケーブル モデム メンテナンス インターフェイスのヘルパー アドレス

209.165.201.3

MPLScableModemSecondaryIpAddrList

1

ケーブル モデムのセカンダリ IP アドレスのリスト

209.165.201.4

MPLSCeATM

0

CE ルータの ATM 仮想回路記述子

200

MPLSCeATM-vci

0

CE ルータの仮想回路識別子

210

MPLSCeATM-vpi

0

CE ルータの仮想パス識別子

220

MPLSCeBGPASNumber

0

CE ルータの BGP AS 番号

100

MPLSCeDLCI

0

CE ルータのデータ リンク回路識別子

100

MPLSCeInterfaceAddress

0

CE ルータのインターフェイス アドレス

209.165.201.5

MPLSCeInterfaceName

0

CE ルータのインターフェイス名

Serial0

MPLSCeVlanId

0

CE ルータの仮想 LAN 識別子

755

MPLSPeCeLinkProtocol

0

PE-CE リンクのルーティング プロトコル

BGPRoutingType

MPLSPeATM-vcd

0

PE ルータの ATM 仮想回路記述子

200

MPLSPeATM-vci

0

PE ルータの仮想回路識別子

210

MPLSPeATM-vpi

0

PE ルータの仮想パス識別子

220

MPLSPeBGPASNumber

0

PE ルータの BGP AS 番号

MPLSPeDLCI

0

PE ルータの ATM リンク回路識別子

100

MPLSPeInterfaceName

0

PE ルータのインターフェイス名

Serial0

MPLSPeInterfaceAddress

0

PE ルータのインターフェイス アドレス

209.165.201.6

MPLSPeOSPFArea

0

PE ルータの OSPF エリア番号

500

MPLSPeOSPFProcessId

0

PE ルータの OSPF プロセス ID 番号

75

MPLSPeVlanId

0

PE ルータの仮想 LAN 識別子

755

MPLSVrfRouteDistinguisher

0

MP-BGP アトリビュート:VRF ルート識別子

100:100

MPLSVrfName

0

VPN ルーティングおよび転送テーブル名

V2:Widgets-S

IPsec LAN-to-LAN リポジトリ変数の概要

表 10-8 に、VPN Solutions Center の Template Manager で使用できる IPsec LAN-to-LAN リポジトリ変数の概要を示します。

 

表 10-8 IPsec LAN-to-LAN リポジトリ変数

リポジトリ変数
次元
説明

IPSecLocalProtectedIPAddress

1

当該エッジ デバイスによって保護される IP アドレス範囲のリスト

209.165.202.129

209.165.202.130...

IPSecLocalProtectedIPAddressMask

1

このエッジ デバイスによって保護されるIP アドレス範囲とサブネット マスクのリスト

209.165.20.129/30

209.165.20.130/30...

IPSecLocalProtectedIPAddress
ReverseMask

1

当該エッジ デバイスによって保護される IP アドレス範囲の逆サブネット マスクのリスト

209.165.202.129

209.165.202.130...

IPSecLocalProtectedIPMask

1

当該エッジ デバイスによって保護される IP アドレス範囲のサブネット マスクのリスト

209.165.20.129/30

209.165.20.130/30...

IPSecRoutingProtocol

0

IPsec VPN ルーティング プロトコルのリスト

NONE、OSPF

IPSecSecureInterfaceAddress

1

CPE のセキュア インターフェイスの IP アドレスのリスト

209.165.202.129
209.165.203.129

IPSecSecureInterfaceAddressMask

1

CPE のセキュア インターフェイスの IP アドレスとサブネット マスクのリスト

209.165.20.130/30
209.165.21.130/30

IPSecSecureInterfaceAddress
ReverseMask

1

エッジ デバイスのセキュア インターフェイスの逆サブネット マスク

0.0.0.3

IPSecSecureInterfaceMask

1

エッジ デバイスのセキュア インターフェイスのサブネット マスク

255.255.255.252

IPSecSecureInterfaceName

1

CPE のセキュア インターフェイス名のリスト

Serial0/0、Serial0/1

IPSecSecureLoopbackInterfaceAddress

0

エッジ デバイスのセキュア トンネル エンドポイント インターフェイスの IP アドレス

171.23.45.33

IPSecSecureLoopbackInterfaceAddressMask

0

エッジ デバイスのセキュア トンネル エンドポイント インターフェイスの IP アドレスとマスク

171.23.45.33/32

IPSecSecureLoopbackInterfaceAddress
ReverseMask

0

エッジ デバイスのセキュア トンネル エンドポイント インターフェイスの逆サブネット マスク

0.0.0.0

IPSecSecureLoopbackInterfaceMask

0

エッジ デバイスのセキュア トンネル エンドポイント インターフェイスのサブネット マスク

255.255.255.255

IPSecSecureLoopbackInterfaceName

0

エッジ デバイスのセキュア トンネル エンドポイントのインターフェイス名

Loopback0

IPSecUnsecureInterfaceAddress

1

エッジ デバイスのノンセキュア インターフェイスの IP アドレスのリスト

209.165.202.131
209.165.203.131

IPSecUnsecureInterfaceAddressMask

1

エッジ デバイスのノンセキュア インターフェイスの IP アドレスとサブネット マスクのリスト

192.23.45.33/24
192.23.46.33/24

IPSecUnsecureInterfaceAddressReverseMask

1

エッジ デバイスのノンセキュア インターフェイスの逆サブネット マスク

0.0.0.255

IPSecUnsecureInterfaceMask

1

エッジ デバイスのセキュア インターフェイスのサブネット マスク

255.255.255.0

IPSecUnsecureInterfaceName

1

CPE のノンセキュア インターフェイス名のリスト

Ethernet1、Ethernet0

IPSecUnsecureLoopbackInterface
Address

0

CPE のノンセキュア ループバック インターフェイスの IP アドレスのリスト

10.1.93.1
10.1.94.1

IPSecUnsecureLoopbackInterface
AddressMask

0

エッジ デバイスのノンセキュア ループバック インターフェイスの IP アドレスとマスク

10.1.93.1/32
10.1.94.1/32

IPSecUnsecureLoopbackInterface
AddressReverseMask

0

エッジ デバイスのノンセキュア ループバック インターフェイスの逆サブネット マスク

0.0.0.0

IPSecUnsecureLoopbackInterfaceMask

0

エッジ デバイスのノンセキュア ループバック インターフェイスのサブネット マスク

255.255.255.255

IPSecUnsecureLoopbackInterfaceName

0

ノンセキュア ループバック インターフェイス名のリスト

Loopback1
Loopback0

IPSecRemoteProtectedIPAddress

2

リモート ピアによって保護される IP アドレス範囲のリスト

209.165.202.129

209.165.202.130...

IPSecRemoteProtectedIPAddressMask

2

リモート ピアによって保護される IP アドレス範囲とサブネット マスクのリスト

209.165.20.129/30

209.165.20.130/30...

IPSecRemoteProtectedIPAddressReverseMask

2

リモート ピアによって保護される IP アドレス範囲の逆サブネット マスクのリスト

0.0.0.255...

IPSecRemoteProtectedIPMask

2

リモート ピアによって保護される IP アドレス範囲のサブネット マスクのリスト

209.165.20.129/30

209.165.20.130/30...

IPSecRemoteHostName

1

リモート ピア ホスト名のリスト

cpe1-frankfurt

IPsec Remote-Access リポジトリ変数の概要

表 10-9 に、VPN Solutions Center の Template Manager で使用できる IPsec Remote-Access リポジトリ変数の概要を示します。

 

表 10-9 IPsec Remote-Access リポジトリ変数

リポジトリ変数
次元
説明

$RA-AAServerNameList

1

認証サーバ名のリスト

North_Am_AA

$RA-GroupNameList

1

グループ名のリスト

North_AM_Sales

$RA-LocalProtectedIPAddressMaskList

1

このエッジ デバイスによって保護されるIP アドレス範囲とサブネット マスクのリスト

209.165.20.129/30

209.165.20.130/30...

$RA-SecureInterfaceIPAddressMaskList

1

セキュア インターフェイスの IP アドレスとマスクのリスト

192.209.10.10/30
192.209.11.10/30

$RA-SecureInterfaceNameList

1

CPE のセキュア インターフェイス名のリスト

Serial0/0、Serial0/1

$RA-SplitTunnelingNetworkLists

2

スプリット トンネリング ネットワークのリスト

List 0 (Sales Group)
10.1.1.0/24
10.1.2.0/24

$RA-SplitTunnelingTypeList

1

スプリット トンネリング タイプのリスト

Entry 0(Acct Group)
in-list
Entry1(Mkt Group)
in-list

$RA-UnsecureInterfaceIPAddressMaskList

1

ノンセキュア インターフェイスの IP アドレスとサブネット マスクのリスト

171.23.44.33/24
171.23.45.33/24

$RA-UnsecureInterfaceNameList

1

ノンセキュア インターフェイス名のリスト

Ethernet0、Ethernet1

Ethernet Over MPLS を VPN Solutions Center で使用する

Ethernet Over MPLS(EoMPLS)は、Layer 2 VPN テクノロジーの 1 つで、MPLS コア ネットワークを経由してイーサネット フレームを送信する技術です。EoMPLS テクノロジーでは、VPN サイト間のポイントツーポイント リンクが使用されることで、イーサネット LAN が拡張します。Ethernet Over MPLS では、MPLS VPN と異なり、CE から PE へのルーティングが必要ありません。VLAN 接続のみが必要です。このリリースの VPN Solutions Center では、Template Manager の使用によって EoMPLS がサポートされます。

EoMPLS サービスは、フレーム リレーに類似するポイントツーポイント サービスですが、イーサネット技術に基づいています。VPNSC は、VPNSC Template Manager を使用して、1 度に 1 つの PE に対して EoMPLS のプロビジョニングを行います。VPNSC では、MPLS LDP とコア ルーティング プロトコルがラベル配布用にアクティブになっている必要があります。テンプレートでは、1 つの PE につき複数の VLAN インターフェイスを作成でき、これによって PE 上の複数の EoMPLS エンドポイントにプロビジョニングできます。VPNSC テンプレートは、CE に対してプロビジョニングするようには設計されていません(ネットワーク内で CE 用に別のテンプレートをダウンロードする場合は除く)。

生成されたコンフィグレットの例

次に、OSR 1 の Template Manager によって生成されるコンフィグレットの例を示します。


 

OSR1
mpls label protocol ldp
vlan 25
!
vlan 60
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface GigabitEthernet4/1
ip address 10.4.1.2 255.255.0.0
no negotiation auto
tag switching ip
!
interface GibabitEthernet4/2
switch port
switchport trunk vlan 25
!
interface GibabitEthernet4/3
switch port
switchport trunk vlan 60
!
interface Vlan25
no ip address
mpls 12transport route 10.1.1.2 1021
!
router ospf 100
network 10.1.0.0 0.0.255.255 area 0


 

VPNSC Ethernet Over MPLS のテンプレート

VPNSC テンプレート内の変数は、トンネル エンドポイント PE1 と PE2 を参照します。VPNSC Template Manager では、オペレータは VPNSC テンプレート データ ファイルに情報を入力します。テンプレート データ ファイルとテンプレート本体の組み合せによって、コンフィギュレーションが生成されます。

テンプレート内の主な変数は、VLAN ID とループバック IP アドレスの 1 次元配列です。オペレータがこの変数に N 次元の配列を設定した場合は、テンプレートを各 PE に連続してダウンロードすることで、N+1 個の PE エンドポイントにプロビジョニングできます。データはすべての PE で同じですが、各テンプレート データ ファイルに応じてわずかに修正する必要があります。 表 10-10 に、Ethernet Over MPLS テンプレート本体で使用されるすべての変数のリストを示します。

 

表 10-10 Ethernet Over MPLS テンプレートの変数

変数名
説明

$cust_intf_name

VLAN でカスタマー側に向いているインターフェイスの名前。

$cust_vlan_num

カスタマー側に向いている VLAN ID。この変数は 1 次元配列です。

$endpt

ポイントツーポイント リンクのエンドポイントで、値は 1 または 2 です。この変数が 1 である場合は、VPNSC は最初のエンドポイント(PE1)にプロビジョニングします。値が 2 である場合は、VPNSC は第 2 エンドポイント(PE2)にプロビジョニングします。

$intf_loop_num

ループバック インターフェイスの数。

$MPLS_Vlan_id

MPLS コアの VLAN ID。PE 間の接続に使用します。この変数は 1 次元配列です。

$PE1_loopback_addr

PE1 のループバック インターフェイスの IP アドレス。このインターフェイスはトンネル エンドポイントです。この変数は 1 次元配列です。

$PE2_loopback_addr

PE2 のループバック インターフェイスの IP アドレス。このインターフェイスはトンネル エンドポイントです。この変数は 1 次元配列です。

EoMPLS テンプレートの内容

ここでは、Ethernet Over MPLS テンプレートの内容の例を示します。


 

mpls label protocol ldp
#if($endpt #eq 1)
{
!
interface loopback $intf_loop_num
ip address $PE1_loopback[$i] 255.255.255.255
!
#repeat ( $MPLS_Vlan_id, $i)
{
vlan $cust_Vlan_num[$i]
!
interface VLAN $cust_Vlan_num[$i]
mpls l2transport route $PE2_loopback[$i] $MPLS_Vlan_id[$i]
no shutdown
!
interface $cust_intf_name[$i]
switchport
switchport trunk vlan $cust_Vlan_num[$i]
no shutdown
!
}
!
router ospf 1
network $PE1_loopback[$i] 0.0.0.0 area 10
}
 
#else
{
#if($endpt #eq 2)
{
!
interface loopback $intf_loop_num
ip address $PE2_loopback[$i] 255.255.255.255
!
#repeat ($MPLS_Vlan_id, $i)
{
vlan $cust_Vlan_num[$i]
!
interface VLAN $cust_Vlan_num[$i]
mpls l2transport route $PE1_loopback[$i] $MPLS_Vlan_id[$i]
no shutdown
!
interface $cust_intf_name[$i]
switchport
switchport trunk vlan $cust_Vlan_num[$i]
no shutdown
}
!
}
!
router ospf 1
network $PE2_loopback[$i] 0.0.0.0 area 10
!
}


 

コンフィギュレーション例

この項では、Template Manager を使用して EoMPLS をプロビジョニングする例を紹介します。Template Manager 階層のフォルダ名は EOverMPLS 、テンプレート本体の名前は
EthernetOverMPLS
です。次の例では、Template Manager は、OSR1 と OSR2 に対するプロビジョニングに、テンプレート データ ファイル EndPoint1 と EndPoint2 を使用します。

OSR1 とデータ ファイル EndPoint1

このコンフィギュレーション例では、エンドポイントが 2 つと、OSR CPE 間に複数の VLAN があります。

VPNSC テンプレート データ ファイル EndPoint1 を使用して、最初の PE(つまり OSR1)にコンフィグレットがプロビジョニングされます。


) 配列変数の次元を確実に 1 に設定してください。


 

表 10-11 EndPoint1 テンプレート データ ファイルの変数値

変数名

$cust_intf_name

GigabitEthernet4/2、GigabitEthernet4/3

$cust_vlan_num

25, 60

$endpt

1

$intf_loop_num

0

$MPLS_Vlan_id

50, 1021

$PE1_loopback_addr

143.10.0.1, 143.10.0.1

$PE2_loopback_addr

143.20.0.1, 143.20.0.1

OSR1 のコンフィグレットと EndPoint1 データ ファイル

次に、EndPoint1 テンプレート データ ファイルを使用して生成された、OSR1 エッジ デバイスのコンフィグレットを示します。


 

!Configlet - OSR 1
interface loopback 0
ip address 143.10.0.1 255.255.255.255
!
vlan 25
!
interface VLAN 25
mpls l2transport route 143.20.0.1 50
no shutdown
!
interface GigabitEthernet4/2
switchport
switchport trunk vlan 25
no shutdown
!
vlan 60
!
interface VLAN 60
mpls l2transport route 143.20.0.1 1021
no shutdown
!
interface GigabitEthernet4/3
switchport
switchport trunk vlan 60
no shutdown
!
router ospf 1
network 143.10.0.1 0.0.0.0 area 10


 

OSR2 とデータ ファイル EndPoint2

VPNSC テンプレート データ ファイル EndPoint2 を使用して、2 つめの PE(つまり OSR2)にコンフィグレットがプロビジョニングされます。

 

表 10-12 EndPoint2 テンプレート データ ファイルの変数値

変数名

$cust_intf_name

GigabitEthernet4/2、GigabitEthernet4/3

$cust_vlan_num

25, 60

$endpt

2

$intf_loop_num

0

$MPLS_Vlan_id

50, 1021

$PE1_loopback_addr

143.10.0.1, 143.10.0.1

$PE2_loopback_addr

143.20.0.1, 143.20.0.1

OSR2 のコンフィグレットと EndPoint2 データ ファイル

次に、EndPoint2 テンプレート データ ファイルを使用して生成された、OSR2 エッジ デバイスのコンフィグレットを示します。


 

!Configlet - OSR 2
mpls label protocol ldp
!
interface loopback 0
ip address 143.20.0.1 255.255.255.255
!
vlan 25
!
interface VLAN 25
mpls l2transport route 143.10.0.1 50
no shutdown
!
interface GigabitEthernet4/2
switchport
switchport access 25
no shutdown
vlan 60
!
interface VLAN 60
mpls l2transport route 143.20.0.1 1021
no shutdown
!
interface GigabitEthernet4/3
switchport
switchport access 60
no shutdown
!
router ospf 1
network 143.20.0.1 0.0.0.0 area 10
!


 

Ethernet Over MPLS の削除テンプレート

この項では、Ethernet Over MPLS テンプレートで生成されたコマンドをルータから削除するテンプレートについて説明します。

EoMPLS テンプレートの内容

この項では、Ethernet Over MPLS 削除テンプレートの内容を示します。


 

#if($endpt #eq 1)
{
!
interface loopback $intf_loop_num
ip address $PE1_loopback[$i] 255.255.255.255
!
#repeat ( $MPLS_Vlan_id, $i)
{
no vlan $cust_Vlan_num[$i]
!
no interface VLAN $cust_Vlan_num[$i]
 
!
interface $cust_intf_name[$i]
no switchport
no switchport trunk vlan $cust_Vlan_num[$i]
shutdown
!
}
!
router ospf 1
no network $PE1_loopback[$i] 0.0.0.0 area 10
}
 
#else
{
#if($endpt #eq 2)
{
!
interface loopback $intf_loop_num
ip address $PE2_loopback[$i] 255.255.255.255
!
#repeat ($MPLS_Vlan_id, $i)
{
no vlan $cust_Vlan_num[$i]
!
no interface VLAN $cust_Vlan_num[$i]
!
interface $cust_intf_name[$i]
no switchport
no switchport trunk vlan $cust_Vlan_num[$i]
shutdown
}
!
}
!
router ospf 1
no network $PE2_loopback[$i] 0.0.0.0 area 10
!
}


 

 

表 10-13 EoMPLS 削除テンプレートの変数値

変数名

$cust_intf_name

GigabitEthernet4/2、GigabitEthernet4/3

$cust_vlan_num

25, 60

$endpt

1

$intf_loop_num

0

$MPLS_Vlan_id

50, 1021

$PE1_loopback_addr

143.10.0.1, 143.10.0.1

$PE2_loopback_addr

143.20.0.1, 143.20.0.1

EoMPLS 削除テンプレート用に生成されたコンフィグレット

この項では、EoMPLS 削除テンプレート用に生成されたコンフィグレットを示します。


 

!EoMPLS Removal Configlet - OSR 1
interface loopback 0
ip address 143.10.0.1 255.255.255.255 !
no vlan 25
!
no interface VLAN 25
!
interface GigabitEthernet4/2
no switchport
no switchport trunk vlan 25
shutdown
!
no vlan 60
!
no interface VLAN 60
!
interface GigabitEthernet4/3
no switchport
no switchport trunk vlan 60
shutdown
!
router ospf 1
no network 143.10.0.1 0.0.0.0 area 10
!


 

テンプレートの言語と構文のリファレンス

この項では、VPN Solutions Center テンプレート実装で使用する言語と構文の規則について説明します。

文法と構文

Extensible Markup Language(XML)テンプレート定義セクションは、IOS コマンド ラインのシーケンス、つまり制御文とテンプレート コメントのシーケンスから構成されます。

このセクションには、テンプレート言語の文法と構文について詳しく記述されています。シスコでは、テンプレート言語の構文として、コンテキストフリー文法(Bachus-Naur 形式)という、広く使用されている表記法を採用しました。テンプレート言語の意味の記述には、形式によらない説明と例を使用します。

引数

argument ®
variable = variable
| variable = constant
| variable = array_variable
| variable = IOS_command

引数のリスト

argument_list ®
argument
| argument_list, argument

配列変数

array_variable ®
variable[index]
| array_variable[index]

定数

constant ®
num
| float
| quoted_string

expression ®
term
| (expression)
| expression relational_opr expression
| expression logical_opr expression
| expression additive_opr expression
| expression multiplicative_opr expression

インデックス

index ®
variable
| num

IOS コマンド式

IOS_command_expression ®
IOS_command
| expression
| IOS_command_expression expression
| IOS_command_expression IOS_command

リピート カウンタ変数

repeat_counter_variable ®
$(letter | digit)*

リピート変数

repeat_variable ®
variable
| num
| array_variable

statement ®
IOS_command_expression
|IOS_comment
|Template_comment
|{statement_list }
|#if ( expression ) statement
| #if ( expression ) statement #else statement
| #repeat ( repeat_variable, repeat_counter_variable ) statement

文のリスト

statement_list ®
statement
|statement_list statement

テンプレート

template ®
statement_list

テンプレート変数

template_variable ®
variable ( argument_list )
| variable ( )

条件

term ®
variable
| constant
| array_variable
| template_variable

変数

variable ®
$(letter | digit)*

表記規則

この項では、VPN Solutions Center テンプレートの文法で使用される表記規則について説明します。

トークン

トークンには、IOS コマンド、変数、キーワード、定数、演算子、その他のセパレータという、6 つのクラスがあります。

後述の空白、タブ、改行、コメント(総称して「空白」)は、トークンを区切る場合以外は無視されます。一部の空白は、隣接するキーワードと定数を切り離すために必須となります。

テンプレート コメント

テンプレート コメントは「 // 」で指定します。このコメント記号の後ろはすべてテンプレート コメントとして扱われます。テンプレート コメントは、テンプレート コンフィギュレーション ファイルには含まれず、テンプレート生成プロセス中に破棄されます。

トークン変数

トークン変数は、文字と数字のシーケンスです。最初の文字として「$」を指定し、その後は次の文字か数字が続きます。

文字 a ~ z、A ~ Z

数字 0 ~ 9

大文字と小文字は区別されます。変数の長さは最大で 32 文字です。

キーワード

キーワードは予約語であり、太字で表示されます。次のキーワードは予約されているため、ほかのコンテキストでは使用できません。

 

表 10-14 テンプレート キーワード

#and

#else

#eq (等号)

#ge (以上)

#gt (より大きい)

#if

#le (以下)

#lt (より小さい)

#ne (不等号)

#or

#repeat

定数

次に示すように、数種類の定数があります。

トークン num 定数は、数字のシーケンスで構成されます。

num digit digit*

トークン float 定数は、整数部、小数点、小数部 の 3 つの部分で構成されます。整数部と小数部はどちらも、数字のシーケンスで構成されます。

float num.num

トークン quoted_string 定数は、二重引用符で囲まれた文字のシーケンスです(たとえば、「....」)。

VPN Solutions Center のテンプレートで使用する式は次のとおりです。

IOS コマンド、変数

配列変数

テンプレート変数

定数

かっこで囲まれた式

演算子の優先順位は、この項で説明する順序と同じで(つまり乗算演算子が最初で、続いて加算演算子)、優先順位が最も高いものが先に処理されます。

1. 乗算演算子

この演算子には * および / があり、左から右に評価されます。 * および / のオペランドは、算術型である必要があります。バイナリの * 演算子は乗算を表します。バイナリの / 演算子は、最初のオペランドを次のオペランドで割った商を返します。

2. 加算演算子

この演算子には + および - があり、左から右に評価されます。 + 演算子の結果は、オペランドの和です。 - 演算子の結果は、オペランドの差です。

3. 比較演算子

比較演算子は左から右に評価されます。この演算子には次のものがあります。

#lt (より小さい)

#gt (より大きい)

#le (以下)

#ge (以上)

#eq (等号)

#ne (不等号)

すべての比較演算子は、指定された関係が偽である場合は 0、真である場合は 1 を返します。結果の型は整数です。

4. 論理演算子

論理演算子は左から右に評価されます。この演算子には次のものがあります。

#or

#or 演算子は、両方のオペランドがゼロに等しくない場合に 1、等しい場合に 0 を返します。

#and

#and 演算子は、どちらかのオペランドがゼロに等しい場合に 1、等しくない場合に 0 を返します。オペランドは同じ算術型である必要があり、結果は整数です。

5. 配列演算子

配列演算子には次のものがあります。

1 次元演算子:[a]

2 次元演算子:[a] [b]

特に指定しない限り、文は順番に実行されて出力されます。文は実行されることで発効します。また、文に値は含まれません。文は、次のグループに分類されます。

IOS コマンド式文

テンプレートのほとんどの文は IOS コマンド 文で、これは Cisco IOS ルータ コマンドです。

複合文

複合文(「ブロック」ともいう)を使用すると、1 文が期待されている場所で複数の文を使用できます。

選択文

選択文には 2 つの形式があります。#if 文の形式は両方とも、算術型である必要がある式が評価されます。

0 に等しくない場合は、最初のサブ文が実行されます。

もう 1 つの形式では、式が 0 である場合、次の(#else の)サブ文が実行されます。

反復文

反復( repeat )文はループ操作を指定します。 repeat 変数に指定されている値の数によって、#repeat 文はサブ文を実行します。その変数に定義されている値がある限り、繰り返しが行われます。

たとえば、次の repeat 文は、 ACL (1 次元)変数に指定されている値がある限り、 access-list サブ文を繰り返します。

指定されている $i は「リピート カウンタ変数 です。このリピート カウンタ変数は最初は 0 に設定され、文が繰り返されるたびに 1 ずつ増加します。

!
#repeat ($ACL, $i)
{
access-list $ACL[$i] permit ip $Source_IP_Address[$i] $Source_Mask[$i] $Dest_IP_Address[$i] $Dest_Mask[$i] precedence 7
}

繰り返し文に指定される $i は、繰り返し文のカウンタです。このカウンタ変数は最初は 0 に設定され、文が繰り返されるたびに 1 ずつ増加します。

たとえば、上の例の repeat 文は、 ACL (1 次元)変数に指定されている値がある限り、 access-list サブ文を繰り返します。 繰り返されるたびに 1 行がテンプレート コンフィギュレーション ファイルに生成されます。

サブ文で宣言された変数に指定される $i は、1 次元変数であることを表します。たとえば、 Source_IP_Address 変数にそれぞれの値が指定されている場合、テンプレートは Source_IP_Address に 1 つの値を代入します。

If-Else 文について

if-else 文は、選択の決定に使用します。構文は次のとおりです。

#if ( expression )

Statement-1

#else

Statement-2

#else とそれに続く文 Statement-2 はオプションです。

最初に、 #if expression が評価されます。結果が true である場合、つまり expression の値がゼロでない場合は、 Statement-1 が実行されます。

結果が false である場合、つまり expression の値がゼロであり、かつ else 部がある場合は、 Statement-2 が代わりに実行されます。

If-Else の関係

if-else else 部はオプションであるため、ネストしている if シーケンスの場合に else 部を省略するとわかりにくい構造になります。これは一般的な方法で解決できます。 else は、 else 文が関連付けられていない、直前の if 文に関連付けられます。次の例の else は、インデントからもわかるように、内側の if に関連付けられます。

#if ($n $gt 0)
#if ($a #le $b)
Statement-1
#else
Statement-2

else を内側の if に関連付けない場合は、かっこを使用して適切な関係を示す必要があります。次の例の else は、外側の if に関連付けられます。

#if ($n #gt 0)
(
#if ($a #le $b)
Statement-1
)
#else
Statement-2

サブテンプレートについて

テンプレートはすべて、別のテンプレートによって使用され、ブロックを構築できます。別のテンプレートを使用するテンプレートを「スーパー テンプレート」、使用されるテンプレートを「サブテンプレート」と呼びます。

スーパー テンプレートは、サブテンプレートの変数に値を渡すことでサブテンプレートを生成します。スーパー テンプレートは、サプテンプレートを生成した後で、サブテンプレートによって生成されたコンフィグレットをスーパー テンプレートに配置します。

変数の値は、C 型の関数呼び出しを使用してサブテンプレートに渡されます。パラメータはカンマで区切られ、すべてのパラメータは文字列として扱われます。

次の 3 つの例を参照してください。

例 1:各値を 1 つずつ渡す簡単なケース

このサブテンプレートは、それぞれの値を 1 つずつ渡します。この例では、 SampleTemplate1 というサブテンプレートが、次の変数を宣言します。

<VarDeclaration>
<String VarName=”sl”/>
<Integer VarName=”bw”/>
</VarDeclaration>
 

このテンプレートを生成するには、次を入力します。

$SampleTemplate1($sl=”abc”,$bw=31)

例 2:1 つの必須値と 1 つのオプション値

この例では、 SampleTemplate2 というサブテンプレートが、1 つの必須値と 1 つのオプション値を宣言します。

ケース 1:

<VarDeclaration>
<String VarName=”sl”/>
<Integer VarName=”bw” declare=”optional”/>
</VarDeclaration>
 

このテンプレートを生成するには、次を入力します。

$SampleTemplate2($sl=”abc”)
 

ケース 2:

<VarDeclaration>
<String VarName=”sl” declare=”optional”/>
<Integer VarName=”bw”/>
</VarDeclaration>
 

このテンプレートを生成するには、次を入力します。

$SampleTemplate2($bw=31)

例 3:メイン テンプレートから 2 つのサブテンプレートを呼び出す

この例では、メイン テンプレートで複数のサブテンプレートを呼び出す方法を示します。

サブテンプレート変数を呼び出す構文は次のとおりです。

$subtemplateVariable ($variableInSubtemplate=$variableInMainTemplate,...)

次の例を参照してください。

Template_Main

Template_Main のテンプレート本体は次のとおりです。

$subVar1 ($protocol=$tcp)
$subVar2 ($CE-lo=”192.168.1.1,” $mgt-prefix=”192.168.2.0”, $mgt-mask=”255.255.255.0”)

Template_Sub1

Template_Sub1 のテンプレート本体は次のとおりです。

access-list 104 permit $protocol

Template_Sub2

Template_Sub2 のテンプレート本体は次のとおりです。

access-list 103 permit host $CE-lo $mgt-prefix $mgt-mask

サブテンプレートの呼び出し

1. テンプレートの場所を $subVar1 に指定し、Template_Sub1 をポイントします。

2. テンプレートの場所を $subVar2 に指定し、Template_Sub2 をポイントします。

$tcp は、Template_Main で定義されている変数です。$tcp の値を「tcp」に設定すると、Template_Main のコンフィグレットの出力は次のようになります。

access-list 104 permit tcp
access list 103 permit host 192.168.1.1 192.168.2.0 255.255.255.0

 

テンプレート組み込み関数呼び出し

この項では、VPN Solutions Center の Template Manager が提供する組み込み関数呼び出しについて説明します。

サブストリングの取得

次のテンプレート関数呼び出しは、delimChar をセパレータとして使用して、srcString からサブストリングを取り出します。

#system.substringToDelim (srcString, delimChar, from beginning:0/from end:1)

Examples

#system.substringToDelim ("abc#def", "#", 0) は「 abc 」を返します。

#system.substringToDelim ("abc#def", "#", 1) は「def」を返します。

#system.substringToDelim ("abc#def", "d", 0) は「abc#」を返します。

#system.substringToDelim ("abc#def", "d", 1) は「ef」を返します。

別のコメント文字の指定

IOS ルータ以外のデバイスにコンフィギュレーション ファイルをダウンロードする必要がある場合は、次のテンプレート関数呼び出しにより、特定のコメント文字が設定されます。

#system.setCommentChar (commentChar)

#system.setCommentChar ( : )

Template Manager では、コロン( : )をコメント文字として使用します。

IpAddrMaskPair 文字列からの IP アドレスの取得

次のテンプレート関数呼び出しは、IpAddrMaskPair 文字列の IP アドレス部分を取り出します。

#system.getAddr (IpAddrMaskPair)

#system.getAddr ("10.33.4.5/30") は「 10.33.4.5 」を返します。

IpAddrMaskPair 文字列からの IP マスクの取得

次のテンプレート関数呼び出しは、IpAddrMaskPair 文字列の IP マスク部分を取り出します。

#system.getMask (IpAddrMaskPair)

#system.getMask ("10.33.4.5/30") は「 255.255.255.252 」を返します。

IpAddrMaskPair 文字列からの IP 逆マスクの取得

次のテンプレート関数呼び出しは、IpAddrMaskPair 文字列の IP 逆マスク部分を取り出します。

#system.getReverseMask (IpAddrMaskPair)

#system.getReverseMask ("10.33.4.5/30") は「 0.0.0.3 」を返します。

IpAddrMaskPair 文字列からのネットワーク アドレスの取得

次のテンプレート関数呼び出しは、IpAddrMaskPair 文字列の IP ネットワーク アドレス部分を取り出します。

#system.getNetworkAddr (IpAddrMaskPair)

#system.getNetworkAddr ("10.33.4.5/30") は「 10.33.4.4 」を返します。

IpAddrMaskPair 文字列からのクラスフル ネットワーク アドレスの取得

次のテンプレート関数呼び出しは、IpAddrMaskPair 文字列からクラスフル ネットワーク アドレスを取り出します。

#system.getClassfulNetworkAddr (IpAddrMaskPair)

#system.getClassfulNetworkAddr ("10.33.4.5/30") は「 10.0.0.0 」を返します。

テンプレート言語の命令

この項では、VPN Solutions Center の Template Manager で提供されるテンプレート言語命令について説明します。

コンフィグレット出力でのエラー説明の表示

このテンプレート命令では、コンフィグレット出力にエラーを説明する文字列が表示されます。

#system.error (error_description_string)

テンプレート

Hostname myHost

#if (#varA #eq 1)

#system.error ("Some error occurred.")

#else

ip addr 10.33.4.5 255.255.255.0

出力

$varA が 1 である場合、コンフィグレットの出力は次のようになります。

Hostname myHost

ERROR:Some error occurred.

$varA が 1 でない場合、コンフィグレットの出力は次のようになります。

Hostname myHost

ip addr 10.33.4.5 255.255.255.0

コンフィグレットの生成の中断

次のテンプレート命令は、コンフィグレットの生成を中断するように VPN Solutions Center に指示します。

#system.abort (abort_description_string)

VPN Solutions Center が提供するテンプレート例

VPN Solutions Center の Template Manager では、便利なテンプレート例のセットを利用できます。 表 10-15 に、各テンプレート例の概要を示します。

 

表 10-15 VPN Solutions Center が提供するテンプレート例

フォルダ
テンプレート
説明

Examples

AccessList

ネストしたリピート ループと多次元変数を含むテンプレートの例。

AccessList1

単純なテンプレート変数代入のテンプレートの例。

CEWanCOS

if-else 文、繰り返し文、算術式、1 次元変数のテンプレートの例。

interface

shutdownIf

IPsec サービス要求にある特定デバイスのノンセキュア インターフェイスをすべてシャットダウンします。

noshutdownIf

IPsec サービス要求にある特定デバイスのノンセキュア インターフェイスをすべて起動します。

Firewall

cust-qos

以下を許可します。a)IPsec:認証ヘッダー(AH)、b)Encapsulating Security Payload(ESP)、c)Internet Security Association and Key Management Protocol(ISAKMP)がファイアウォールへ入ること。

次を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)IPsec ルータからのリターン管理トラフィック。c)VPN ルータに向かう Internet Control Message Protocol(ICMP;インターネット制御メッセージ プロトコル)トラフィック。d)発信セッションからのすべてのリターン トラフィック。ICMP トラフィックが VPN ルータにアクセスすること。発信セッションからのリターン トラフィック。その他すべてのトラフィックを拒否します。

cust-rtr1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

次を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)ICMP トラフィックが VPN ルータにアクセスすること。c)リモート サイト トラフィックが VPN ルータにアクセスすること。ローカル ネットワーク トラフィックが VPN ルータにアクセスすることを拒否します。

カスタマー ネットワーク トラフィックがインターネットにアクセスすることを許可します。その他のローカル ネットワーク トラフィックがインターネットにアクセスすることを拒否します。

cust-rtr2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

次を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)SNMP トラフィックが VPN ルータにアクセスすること。c)アプリケーション トラフィックが VPN ルータにアクセスすること。d)ICMP トラフィックが VPN ルータにアクセスすること。その他すべての IP トラフィックが VPN ルータにアクセスすることを拒否します。

以下を許可します。a)すべての IP トラフィックが VPN ルータを通過すること。b)カスタマー ネットワークが VPN ルータにアクセスすること。ローカル ネットワーク トラフィックが VPN ルータにアクセスすることを拒否します。

default-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)すべてのトラフィックがリモート サイトから発信されること、およびリターン SLA。c)Network Time Protocol(NTP;ネットワーク タイム プロトコル)。d)ドメイン トラフィックが VPN ルータに戻ること。e)ICMP トラフィックが VPN ルータにアクセスすること。内部インターフェイスおよび外部インターフェイスから着信する、ルータに向かうその他すべてのアクセスを拒否します。

カスタマー ネットワークから発信するすべてのトラフィック、およびカスタマー ネットワークにから着信するすべてのトラフィックを許可します。内部インターフェイスおよび外部インターフェイスから着信する、すべてのトラフィックを拒否します。

default-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)tftp と SNMP の VPN ルータに向かうリターン User Datagram Protocol(UDP;ユーザ データグラム プロトコル)。c)ルータに向かうリターン SLA、NTP、ドメイン トラフィック。d)管理ネットワークから VPN ルータに向かう ICMP。内部インターフェイスおよび外部インターフェイスから着信する、VPN ルータに向かうその他すべてのアクセスを拒否します。

ipsec-ingress

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

管理トラフィックが IPsec VPN ルータにアクセスすること、すべてのトラフィックがリモート サイト ネットワークからアクセスすることを許可します。

negotiated-wan-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)UDP リターン トラフィックが VPN ルータにアクセスすること。c)アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータへ戻ること。d)ICMP トラフィックが VPN ルータにアクセスすること。外部インターフェイスから VPN ルータに向かうアクセスをすべて拒否します。

カスタマー ステートフル トラフィックがファイアウォールを通過することを許可します。内部インターフェイスまたは外部インターフェイスから着信する、その他すべてのトラフィックを拒否します。

negotiated-wan-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)UDP リターン トラフィックが VPN ルータにアクセスすること。c)アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータへ戻ること。d)ICMP トラフィックが VPN ルータにアクセスすること。外部インターフェイスから VPN ルータに向かうアクセスをすべて拒否します。

カスタマー ステートフル トラフィックがファイアウォールを通過することを許可します。内部インターフェイスまたは外部インターフェイスから着信する、すべての IP トラフィックを拒否します。

vpnfiltered-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。a)管理トラフィックが IPsec VPN ルータにアクセスすること。b)UDP リターン トラフィックが VPN ルータにアクセスすること。c)アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータへ戻ること。d)ICMP トラフィックが VPN ルータにアクセスすること。その他すべての IP トラフィックが VPN ルータにアクセスすることを拒否します。

ICMP トラフィックが VPN ルータにアクセスすることを許可します。VPN ルータに向かうその他すべての IP トラフィックを拒否します。

ICMP トラフィックがカスタマー ネットワークにアクセスすることを許可します。その他すべての IP トラフィックを拒否します。

以下を許可します。内部インターフェイスからのその他すべてのトラフィックを拒否します。

vpnfiltered-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。その他すべての IP トラフィックが VPN ルータにアクセスすること、およびすべての IP トラフィックを拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。

vpnfiltered-dial

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。リモート ネットワークからのすべての IP トラフィック。アプリケーション トラフィック、SLA、NTP。ICMP トラフィックが管理ネットワークから VPN ルータにアクセスすること。VPN に向かうその他すべてのアクセス、およびすべての IP トラフィックを拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。

vpnonly-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。tftp と SNMP の IPsec VPN ルータに向かうリターン UDP。アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータに戻ること。ICMP トラフィックが管理ネットワークから VPN ルータにアクセスすること。内部インターフェイスまたは外部インターフェイスへ着信する、ルータに向かうその他すべてのアクセスを拒否します。

VPN ルータから発信される Extended Services Processor(ESP; 拡張サービス プロセッサ)、およびカスタマー ネットワークから発信されるすべてのサービスを許可します。外部インターフェイスから着信するすべての IP トラフィックとすべてのトラフィックを拒否します。

vpnonly-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。リモート サイトからのすべてのトラフィック。アプリケーション トラフィック、SLA、NTP、ドメインが VPN ルータに戻ること。ICMP トラフィックが管理ネットワークから VPN ルータにアクセスすること。外部インターフェイスに着信する、ルータに向かうその他すべてのアクセスを拒否します。

VPN ルータから発信する ESP を許可します。外部インターフェイスからのすべての IP トラフィック、および内部インターフェイスからのすべてのトラフィックを拒否します。

PIX

cust-qos

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。IPsec ルータからのリターン管理トラフィック。ICMP トラフィックが VPN ルータにアクセスすること。発信セッションからのリターン トラフィック。その他すべてのトラフィックを拒否します。

cust-rtr1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。ICMP トラフィックが VPN ルータにアクセスすること。リモート サイト トラフィックが VPN ルータにアクセスすること。ローカル ネットワーク トラフィックが VPN ルータにアクセスすることを拒否します。

カスタマー ネットワーク トラフィックがインターネットにアクセスすることを許可します。その他のローカル ネットワーク トラフィックがインターネットにアクセスすることを拒否します。

cust-rtr2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。管理ネットワークからの SNMP トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィックが VPN ルータにアクセスすること。ICMP トラフィックが VPN ルータにアクセスすること。その他すべての IP トラフィックが VPN ルータにアクセスすることを拒否します。

カスタマー ネットワークが VPN ルータにアクセスすることを許可します。その他のローカル ネットワーク トラフィックが VPN ルータにアクセスすることを拒否します。

default-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。リモート サイトから発信するすべてのトラフィック。内部インターフェイスまたは外部インターフェイスから着信する、ルータに向かうその他すべてのアクセスを拒否します。

カスタマー ネットワークから発信されるすべてのトラフィック、およびカスタマー ネットワークに着信するすべてのトラフィックを許可します。内部インターフェイスまたは外部インターフェイスから着信する、すべてのトラフィックを拒否します。

default-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。SLA、NTP、ドメイン トラフィックが VPN ルータに戻ること。ICMP トラフィックが VPN ルータにアクセスすること。内部インターフェイスまたは外部インターフェイスから着信する、ルータに向かうその他すべてのアクセスを拒否します。

ipsec-ingress

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

管理トラフィックが IPsec VPN ルータにアクセスすること、およびリモート サイト ネットワークからのすべてのトラフィックを許可します。

negotiated-wan-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。外部インターフェイスから VPN ルータに向かうアクセスをすべて拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。内部インターフェイスと外部インターフェイスから着信する、その他のすべてのトラフィックを拒否します。

negotiated-wan-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。VPN ルータに向かう外部インターフェイス トラフィックを拒否します。内部インターフェイスまたは外部インターフェイスからの、すべての IP トラフィックを拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。

vpnfiltered-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。VPN ルータに向かうその他すべての IP トラフィックを拒否します。

VPN ルータに向かう ICMP トラフィックを許可します。VPN ルータに向かうその他すべての IP トラフィックを拒否します。

カスタマー ネットワークに向かう ICMP トラフィックを許可します。その他すべての IP トラフィックを拒否します。

以下を許可します。VPN ルータから発信される IPsec トラフィック。内部インターフェイスまたは外部インターフェイスからのステートフル トラフィック。カスタマー ネットワークからの ICMP トラフィック。内部インターフェイスからのその他すべてのトラフィックを拒否します。

vpnfiltered-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが VPN ルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。VPN ルータに向かうその他すべての IP トラフィックを拒否します。VPN ルータに向かうその他すべての IP トラフィック、およびすべての IP トラフィックを拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。

vpnfiltered-dial

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。リモート ネットワークからのすべての IP トラフィック。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが VPN ルータにアクセスすること。VPN ルータに向かうその他すべての IP トラフィック、およびすべての IP トラフィックを拒否します。

ファイアウォールを通って戻る、ステートフルなトラフィックを許可します。

vpnonly-1

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィック が IPsec VPN ルータにアクセスすること。UDP リターン トラフィックが、tftp と SNMP のルータにアクセスすること。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが管理ネットワークから VPN ルータにアクセスすること。内部インターフェイスおよび外部インターフェイスに着信する、ルータに向かうその他すべてのアクセスを拒否します。

VPN ルータから発信される ESPと、カスタマー ネットワークから発信されるすべてのサービスを許可します。外部インターフェイスから着信するすべての IP トラフィックとすべてのトラフィックを拒否します。

vpnonly-2

IPsec AH、ESP、および ISAKMP がファイアウォールに入ることを許可します。

以下を許可します。管理トラフィックが IPsec VPN ルータにアクセスすること。リモート サイトからのすべてのトラフィック。アプリケーション トラフィック、SLA、NTP、ドメイン トラフィックが VPN ルータへ戻ること。ICMP トラフィックが管理ネットワークから VPN ルータにアクセスすること。外部インターフェイスに着信する、ルータに向かうその他すべてのアクセスを拒否します。

VPN ルータから発信される ESPと、カスタマー ネットワークから発信されるすべてのサービスを許可します。内部インターフェイスと外部インターフェイスから着信する、すべての IP トラフィックを拒否します。

dslam

RFC1483_routed_prepend

Permanent Virtual Path(PVP; 相手先固定パス)コマンドと Request for Comments(RFC; コメント要求)1483 ブリッジ モードを使用する Digital Subscriber Line(DSL; デジタル加入者回線)モデム インターフェイスでサブインターフェイスを作成するコマンドを指定します。

pppoa_vt_append

Point-to-Point Protocol over Asynchronous Transfer Mode(PPPoA)仮想テンプレートを作成します。

pppoa_snap_prepend

DSL インターフェイスでサブインターフェイスを作成します。

pppoe_vt_append

VPNSC コンフィグレットと併用し、IP DSL スイッチの Point-to-Point Protocol over Ethernet(PPPoe)セッションを MPLS VPN にマップします。これは、VPN サービス要求に追加されます。

pppoe_snap_prepend

VPNSC コンフィグレットと併用し、IP DSL スイッチの PPPoEthernet セッションを MPLS VPN にマップします。これは、VPN サービス要求に追加されます。

RBE_1483Br_prepend

IP DSL スイッチ DSL インターフェイスでサブインターフェイスを作成し、ATM RBE か RFC 1483 Bridged 用に構成します。

pppoa_mux_prepend

PPPoATM ATM Adaptation Layer 5 Multiplexing Device(AAL5MUX)Encapsulation 用に構成した DSLAM モデムに使用します。

pppoa_mux_append

PPPoATM 仮想テンプレートを作成します。

VPN 3000/Routing

Ethernet-RIP

特定のイーサネット インターフェイス用に RIP をセットアップします。

Ethernet-OSPF

特定のイーサネット インターフェイスの OSPF インターフェイスを構成します。

Static-Routes

スタティック ルート レコードを構成します。

Default-Gateway

デフォルト ゲートウェイをセットアップします。

General-OSPF

汎用の OSPF パラメータをセットアップします。

Create-OSPFArea

汎用の OSPF エリア パラメータを作成します。

Modify-OSPFArea

特定の OSPF エリアを修正します。

VRRP

VRRP 冗長性をセットアップします。

VPN 3000/Servers

DNS-Server

DNS サーバ パラメータをセットアップします。

FTP-Server

FTP サーバ パラメータをセットアップします。

HTTP-Server

HTTP サーバ パラメータをセットアップします。

HTTPS-Server

HTTPS サーバ パラメータをセットアップします。

TFTP-Server

TFTP サーバ パラメータをセットアップします。

Telnet-Server

Telnet サーバ パラメータをセットアップします。

Telnet-SSL-Server

Telnet over Secure Socket Layer(SSL)パラメータをセットアップします。

SNMP-Server

SNMP サーバ パラメータをセットアップします。

SNMP-Communities

SNMP コミュニティ ストリングをセットアップします。

SSL

SSL レコード パラメータをセットアップします。

SSH

SSH レコード パラメータをセットアップします。

DHCP-Server-Create

DHCP サーバ パラメータをセットアップします。

DHCP-Server-Modify

DHCP サーバ パラメータを修正します。

VPN 3000/Events

General-Event

汎用のイベント パラメータをセットアップします。

FTPLogBackup

FTP ログ バックアップ パラメータをセットアップします。

EventClass-Create

EventClass レコード パラメータをセットアップします。

EventClass-Modify

特定のイベント クラスを修正します。

TrapDestination-Create

トラップ宛先レコード パラメータをセットアップします。

TrapDestination-Modify

特定のトラップ宛先を修正します。

SyslogServer-Create

Syslog サーバ レコード パラメータをセットアップします。

SyslogServer-Modify

Syslog サーバ レコード パラメータを修正します。

SMTPServer-Create

SMTP サーバを作成します。

SMTPServer-Modify

SMTP サーバ パラメータを修正します。

EmailRecipient-Create

電子メール受信者レコードを作成します。

EmailRecipient-Modify

電子メール受信者レコードを修正します。

VPN 3000/
Users

AddUsers

VPN 3000 Concentrator でユーザ データベースにユーザ リストを追加するために使用します。このデータベースは、グループの認証が内部に設定されている場合に使用されます。ユーザごとに、ユーザ名、パスワード、およびこのユーザが属するグループを設定する必要があります。

DeleteUsers

VPN 3000 Concentrator でユーザ データベースからユーザ リストを削除するために使用します。このデータベースは、グループの認証が内部に設定されている場合に使用されます。

EOverMPLS

EthernetOverMPLS

Ethernet over MPLS(EOverMPLS)をプロビジョニングします。エンドポイントは 1 つずつプロビジョニングする必要があります。

Remove_EthernetOMPLS

EthernetOverMPLS コンフィグレットを削除します。

UTI

PE 間の Universal Transport Interface (UTI) トンネルをプロビジョニングします。各エンドポイントは 1 つずつプロビジョニングする必要があります。

MPLS-\MultiVRF

MVCE-VRF-Name

ip vrf コマンドをマルチ VRF CE に追加します。

Provider-Facing Interface

NumberedInterface

マルチ VRF CE 上の番号指定インターフェイスに ip vrf forwarding コマンドを追加します。

UnnumberedInterface

マルチ VRF CE 上の番号未指定インターフェイスに ip vrf forwarding コマンドを追加します。

Remove-NumberedInterface

マルチ VRF CE 上の番号指定インターフェイスから ip vrf forwarding コマンドを削除します。

Remove-Unnumbered Interface

マルチ VRF CE 上の番号未指定インターフェイスから ip vrf forwarding コマンドを削除します。

Provider-Facing-
Routing

BGP-IpNumbered

BGP を IP 番号指定のプロバイダー側に向かうインターフェイスにプロビジョニングします。

BGP-IpUnnumbered

BGP を IP 番号未指定のプロバイダー側に向かうインターフェイスにプロビジョニングします。

OSPF

マルチ VRF CE 上に OSPF をプロビジョニングします。

RIP

マルチ VRF CE 上に RIP をプロビジョニングします。

Static

マルチ VRF CE 上に スタティック ルートをプロビジョニングします。

Remove-BGP-
IpUnnumbered

BGP のプロビジョニングを IP 番号未指定のプロバイダー側に向かうインターフェイスから削除します。

Customer-
Facing Interface

NumberedInterface

ip vrf forwarding コマンドをカスタマー側に向かう IP番号指定ファーストイーサネット インターフェイスに追加します。

UnnumberedInterface

ip vrf forwarding コマンドをカスタマー側に向かう IP番号指定ファーストイーサネット インターフェイスに追加します。

FasterEthernetSample

ip vrf forwarding コマンドをカスタマー側に向かうファーストイーサネット インターフェイスに追加します。

SerialSample

ip vrf forwarding コマンドをカスタマー側に向けられるシリアル インターフェイスに追加します。

Remove-Numbered Interface

ip vrf forwarding コマンドをカスタマー側に向かう IP 番号指定インターフェイスから削除します。

Remove-Unnumbered Interface

ip vrf forwarding コマンドをカスタマー側に向かう IP 番号未指定インターフェイスから削除します。

Customer-
Facing Routing

BGP-IpNumbered

BGP を IP スにプロビジョニングします。

BGP-IpUnnumbered

BGP をカスタマー側に向かう IP 未指定インターフェイスにプロビジョニングします。

Static

Provisions a Static をカスタマー側に向かうインターフェイスにプロビジョンします。

RIP

RIP をカスタマー側に向かうインターフェイスにプロビジョニングします。

OSPF

OSPF をカスタマー側に向かうインターフェイスにプロビジョニングします。

Remove-BGP-
IpUnnumbered

BGP をカスタマー側に向かう IP 番号未指定インターフェイスから削除します。

templateEZVpn

ezvpn-client

VPN クライアントとして動作するローエンド シスコ ルータ用の IOS EZVpn クライアント テンプレート。

CNS

CNS-Agent-Enable

ルータ上の CNS クライアントをイネーブルにして、CNS サーバ(現在の Cisco IE2100)と通信します。

Certificate

RSA-Key-Generation

秘密キーと公開キーのペアを当該ルータ用に生成する IOS コマンド。

Root-Cert-Import

ルート証明書をルータにインポートします。

Root-Cert-By-Auth

ルート証明書サーバを認証してルート証明書を取得します。

Cert-Enrollment

ルート証明書サーバに登録して当該ルータの証明書を取得します。