Cisco Prime Fulfillment ユーザ ガイド 6.1
トポロジ ツールの使用
トポロジ ツールの使用
発行日;2012/05/09 | 英語版ドキュメント(2011/11/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

トポロジ ツールの使用

概要

トポロジ ツールの起動

表記法

-VPN Topology でのトポロジ ツールへのアクセス

ビューのタイプ

VPN ビュー

論理ビュー

物理ビュー

デバイスのプロパティとリンクのプロパティの表示

デバイスのプロパティ

リンクのプロパティ

フィルタリングと検索

フィルタリング

検索

マップの使用

マップのロード

レイヤ

マップ データ

ノードの位置

新規マップの追加

トポロジ ツールの使用

トポロジ ツールを使用すると、Cisco Prime Fulfillment Web クライアントを使って、セットアップされたネットワークをグラフィカルに表示できます。これはネットワークのデバイスおよびリンクの両方について、さまざまな物理的および論理的部分をグラフィックで表現するツールです。

「概要」

「トポロジ ツールの起動」

「表記法」

「Prime Fulfillment-VPN Topology でのトポロジ ツールへのアクセス」

「ビューのタイプ」

「VPN ビュー」

「論理ビュー」

「物理ビュー」

「デバイスのプロパティとリンクのプロパティの表示」

「フィルタリングと検索」

「フィルタリング」

「検索」

「マップの使用」

「マップのロード」

「レイヤ」

「マップ データ」

「ノードの位置」

「新規マップの追加」

概要

トポロジ ツールには 3 種類のビューがあります。

VPN ビュー:カスタマー デバイス間の接続を表示します。また、VPN ビューは、すべてのサービスを集約したビューと、各サービスを個別に表した論理ビューおよび物理ビューも表示します。

論理ビュー:選択されたプロバイダー リージョンでセットアップされた論理接続を表示します。

物理ビュー:プロバイダー リージョンで指定された物理回線の接続性を表示します。

さらに、この章では、次の機能についても説明します。

フィルタリングおよび検索:巨大なグラフから必要のない詳細部分をフィルタして取り除きます。または、検索ツールを使用して、特定のデバイスへ直接ジャンプします。

マップの使用:個々のビューとマップを関連付けます。

ただし、ウィンドウの装飾など、一部の詳細はシステム固有で、環境が異なると表示も異なる可能性があります。しかし、機能は一貫性を保ちます。

トポロジ ツールの起動

トポロジ ツールを起動するステップは、次のとおりです。


ステップ 1 Prime Fulfillment にログインします。

ステップ 2 [Inventory] > [Logical Inventory] > [Topology] を選択します。図 64-1 のようにウィンドウが表示されます。

ウィンドウの下部で指定されている適切な Java Runtime Environment(JRE)を使用していない場合、使用しているシステムに対応するリンクをクリックし、そのパスに従って進んでから、ブラウザを終了し、もう一度ログインして、[Topology Tool] ページに戻ります。

図 64-1 トポロジ起動ウィンドウ

 

ステップ 3 Web クライアントでトポロジ ツール アプリケーションを起動するには、図 64-1 の [Prime Fulfillment-VPN Topology] をクリックします。

これにより、Java Web Start アプリケーションが起動されます。


) 名前の解決が必要です。Prime Fulfillment HTTP サーバ ホストは、この Web クライアントが使用している Domain Name System(DNS; ドメイン ネーム システム)に含まれている必要があります。含まれていない場合は、Prime Fulfillment サーバの名前とアドレスがクライアントのホスト ファイルに記載されていなければなりません。


ステップ 4 初めてインベントリ マネージャをアクティブ化すると、[Security Warning] ウィンドウが表示されます。先に進む場合は、[Start] をクリックします。セキュリティ証明書を検証する場合は、[Details] をクリックします。[Desktop Integration] ウィンドウが表示されます。

ステップ 5 デスクトップ環境に統合する場合は [Yes]、しない場合は [No]、次回、VPN トポロジを起動したときにもう一度このウィンドウを表示する場合は [Ask Later]、デスクトップの統合をカスタマイズする場合は [Configure ...] をクリックします。

[Desktop Integration] ウィンドウで選択したかどうかに関係なく、図 64-2 に示す [Login] ウィンドウが表示されます。

図 64-2 [Prime Fulfillment] ウィンドウへのログイン

 

ステップ 6 [User Name] および [Password] を入力し、[OK] をクリックします。

トポロジ ツールが起動し、マスタ Prime Fulfillment サーバに接続します。


 

表記法

トポロジ ソフトウェアには、表示されたオブジェクトに関する情報を視覚的に伝えるための規則がいくつかあります。デバイスを表すノードの形状と色は、 表 64-1 に示すとおり、デバイスのロールによって異なります。

 

表 64-1 デバイス ロール アイコン

形状
説明

CAT OS カスタマー デバイスを表す緑色のアイコン。これに続けて、次の情報が表示されます。

- デバイス名
- カスタマー名
- サイト名
- 管理 IP アドレス
- 説明
- ロール(VPN の SPOKE または HUB)

ルータ カスタマー デバイスを表す緑色のアイコン。これに続けて、次の情報が表示されます。

- デバイス名
- カスタマー名
- サイト名
- 管理 IP アドレス
- 説明
- ロール(VPN の SPOKE または HUB)

インターフェイスを表す緑色のアイコン。これに続けて、次の情報が表示されます。

- インターフェイス名
- 管理 IP アドレス
- カプセル化タイプ
- インターフェイス タイプ

CAT OS プロバイダー デバイスを表す青色のアイコン。これに続けて、次の情報が表示されます。

- デバイス名
- プロバイダー名
- リージョン名
- 管理 IP アドレス
- 説明
- ロール

ルータ プロバイダー デバイスを表す青色のアイコン。これに続けて、次の情報が表示されます。

- デバイス名
- プロバイダー名
- リージョン名
- 管理 IP アドレス
- 説明
- ロール

リージョンを表す青色のアイコン。これに続けて、次の情報が表示されます。

- リージョン名
- プロバイダー名

サイトを表す緑色のアイコン。これに続けて、次の情報が表示されます。

- サイト名
- カスタマー名
- サイトのデバイスが VPN に参加したときのロール(HUB、SPOKE、または HUB と SPOKE の組み合わせ)

サイトを表す緑色のアイコン。これに続けて、次の情報が表示されます。

- サイト名
- カスタマー名
- サイトのデバイスが VPN に参加したときのロール(HUB、SPOKE、または HUB と SPOKE の組み合わせ)

リンクのタイプを強調するため、 表 64-2 に示す配色パターンが使用されています。

 

表 64-2 リンクのタイプ別配色パターン

カラー
接続タイプ

(緑色)

エンドツーエンド ワイヤ

(紫色)

接続回線

(茶色)

MPLS VPN リンク

最後に、 表 64-3 に示す 4 種類のパターンはサービス要求の状態を示すために使用されます。

 

表 64-3 リンク状態を表すパターン

パターン
サービス要求の状態

Deployed、Functional、Pending

Failed Audit、Invalid、Broken、Lost

Wait Deploy、Requested、Failed Deploy

Closed

Prime Fulfillment-VPN Topology でのトポロジ ツールへのアクセス

「トポロジ ツールの起動」 トポロジ起動ウィンドウにある図 64-1 のステップに従ってトポロジ ツールを起動し、次のステップに従って、 Prime Fulfillment-VPN Topology ツールにアクセスします。


ステップ 1 [Inventory] > [Logical Inventory] > [Topology] > [Prime Fulfillment-VPN Topology] を選択します。

図 64-3 に示す [Topology] ウィンドウが表示されます。

図 64-3 トポロジ アプリケーション ウィンドウ

 

アプリケーション ウィンドウは、図 64-3 に示すとおり 4 つのエリアに分けられます。

エリア(1):左上には概要エリアが表示されます。色付きの長方形のパネルは「パナー」と呼ばれ、そのときメイン エリアに表示されているエリアに対応しています。パナーを移動すると、メイン エリアに表示されるグラフの部分が変わります。これは、大型のグラフでは特に便利な機能です。

エリア(2):左下のエリアには、グラフのツリー ビューが表示されます。グラフが何も表示されていない場合、[Unnamed] と呼ばれるノードが 1 つ表示されます。グラフが表示されると、デバイスを表すツリーと、そのインターフェイスおよび接続があればそれらが表示されます。このツリーは、デバイスや接続をすばやく見つけるために使用できます。

エリア(3):ウィンドウのメイン エリア(メイン ビュー)には、デバイス間の接続を表すグラフが表示されます。表示されているネットワークの名前は最下部に表示されます。ビューが表示されていない場合のデフォルト名は [Unnamed] です。

エリア(4):メイン ウィンドウの上にはフィルタ エリアがあります。ここにパターンを入力して、ノードをフィルタできます。入力したパターンを含む名前を持つノードの明るさのレベルは通常と変わりません。その他のノードやエッジはすべて淡色表示されます(図 64-25 および「フィルタリング」を参照)。


) すべてのエリアの下にあるバーはステータス バーです。



 

ビューのロード、保存、およびクローズには [File] メニューを使用します(図 64-4 を参照)。

図 64-4 [File] メニュー

 

[File] メニューには、次のメニュー項目が含まれます。

[Open]:ビューを開きます。

[Save]:開かれていてアクティブなビューを、すでにファイル名がつけられていればその名前で保存します。

[Export]:Scalable Vector Graphics(SVG)、Joint Photographics Expert Group(JPG)、または Portable Network Graphics(PNG)フォーマットのいずれかでアクティブ ビューをエクスポートします。

[Save All]:開かれているビューをすべて保存します。

[Close]:開かれていてアクティブなビューを閉じます。

[Close All]:開かれているビューをすべて閉じます。

[Print]:開かれていてアクティブなビューを印刷します。

[Exit]:トポロジ ツールを終了します。

ビューのタイプ

トポロジ アプリケーションには 3 種類のビュー ペインがあります。これ以降の項では、これらのペインについて説明します。

「VPN ビュー」。VPN 内のデバイス間の接続を示します。

「論理ビュー」。リージョン内の PE と CPE の間の接続を示します。

「物理ビュー」。リージョン内の PE に対する物理デバイスとリンクを示します。

ビュー属性は、図 64-5 に示すとおり、[View] メニューを使って変更できます。

図 64-5 [View] メニュー

 

[View] メニューには、次のメニュー項目が含まれます。

[Anti-Aliasing]:ビューを描画するときに、パフォーマンスを犠牲にして、より滑らかなラインと気持ちのよい外観を生み出します。

[Grid]:磁気グリッドをアクティブ化します。グリッドは 10 X 10 の間隔で、ビュー内のノードをそろえやすくするために使用できます。

[Auto-Layout]:ビュー内にノードの自動レイアウトを生成します。選択した場合、プログラムは、最も体裁のよいノード配置を見つけようと試行します。

[Zoom]:ウィンドウが開かれます。このウィンドウでは、必要な拡大レベルを指定できます。

[Zoom In]:拡大レベルを増やします。

[Zoom Out]:拡大レベルを減らします。

[Refresh]:ビューを再生成します。これは、リポジトリ内のデータが変化した場合に特に便利です。更新後のビューを確認するには、[Refresh] を選択するか、または [Refresh] ツールバー ボタンをクリックします。

VPN ビュー

VPN ビューは、指定された VPN を構成するデバイス間の接続を表示します。VPN ビューをアクティブ化するステップは、次のとおりです。


ステップ 1 メニュー バーで、[File] > [Open] を選択します。

または

ツールバーの [Open] ボタンをクリックします。

図 64-6 のフォルダ ビュー ウィンドウが開き、ディレクトリ ツリーと使用可能な VPN が表示されます。

図 64-6 フォルダ ビュー ウィンドウ

 

ステップ 2 目的の VPN フォルダを見つけ、このフォルダを選択して、[Open] をクリックします。

これにより、目的のフォルダが開かれ、この VPN に関連付けられている論理ビューと物理ビューがすべて表示されます。

フォルダ ツリーから論理ビューまたは物理ビュー項目を 1 つクリックします。論理ビューは詳細の量を最小限に抑え、カスタマー デバイス間の接続を表示します。物理ビューは、VPN の物理的構造に関する詳細を明らかにします。たとえば、MPLS については、カスタマー デバイスとプロバイダー デバイスの間の接続とプロバイダーのコアが表示されます。


 

集約ビュー

図 64-7 に示す集約ビューには、カスタマー デバイスの接続に使用されているテクノロジーのタイプに関係なく、すべてのカスタマー デバイス間の接続を示します。

1 つのビューには、MPLS、レイヤ 2、および VPLS の組み合わせが表示されることもあります。MPLS については、Customer Premises Equipment(CPE; 顧客宅内機器)デバイスのみ表示されます。

図 64-7 集約ビュー

 

CPE に加えて、レイヤ 2 VPN に Customer Location Edge(CLE)デバイス間、または Provider Edge(PE; プロバイダー エッジ)デバイス間の接続が表示されることもあります。VPLS では、CPE 間の接続が表示されます。欠損 CPE では、PE への接続が表示されます。

MPLS レイヤ 2 VPN では、トポロジは、Virtual Circuit(VC; 仮想回線)を MPLS コアとともに(MPLS 文字列として)表示しますが、L2TPv3 では、図 64-8 に示すように、Virtual Circuit(VC; 仮想回線)を IP コアとともに(IP 文字列として)表示します。

図 64-8 IP コアを持つ Virtual Circuit

 

VPLS トポロジ

VPLS トポロジの場合、Attachment Circuit View または Emulated Circuit View にアクセスできます。Attachment Circuit View は、他のタイプの VPN にある論理ビューに相当します。このビューには、図 64-9 にあるとおり、仮想プライベート LAN に接続されているカスタマー デバイスが表示されます。

図 64-9 Attachment Circuit View

 

Emulated Circuit View には、Attachment Circuit View では省略されている物理接続に関する詳細が表示されます。このビューには、図 64-10 にあるとおり、プロバイダーのデバイスと、プロバイダーのデバイスに接続されているカスタマー デバイスの間の接続が表示されます。

図 64-10 Emulated Circuit View

 


 

論理ビュー

この論理ビューには、指定されたリージョンの PE と CPE の間にある、サービス要求により作成された接続が表示されます。

論理ビューをアクティブ化するステップは、次のとおりです。


ステップ 1 メニュー バーで、[File] > [Open] を選択します。

または

ツールバーの [Open] ボタンをクリックします。

フォルダ ビュー ウィンドウが表示されます(図 64-6 を参照)。

ステップ 2 目的の VPN のフォルダを見つけ、このフォルダをダブルクリックします。

この VPN に関連付けられている論理ビューおよび物理ビューがすべて表示されます。

ステップ 3 選択した VPN の論理ビューを開くには、次のいずれかを実行します。

[Logical View] アイコンを 1 回クリックし、[Open] をクリックします。

または

[Logical View] アイコンをダブルクリックします。

これにより、図 64-11 に示すように、選択した VPN の論理ビューが作成されます。

図 64-11 論理ビュー

 

作成されたビューでは、通常、グラフの中央にあるノードは、あるプロバイダーに与えられたリージョンを表すノードです。このノードには、そのリージョンの名前とプロバイダーの名前が注釈として付けられています。

リージョンのノードに直接接続されているノードは PE を表します。ノードのアイコンは、それが表しているデバイスのタイプとロールによって異なります(「表記法」を参照)。

個々の PE には、完全修飾デバイス名、プロバイダー名、リージョン名、管理 IP アドレスの説明、およびロールが注釈として付けられています。ノードを右クリックすると、このノードに関連付けられている論理デバイスと物理デバイス、インターフェイス、および Service Request(SR; サービス要求)の詳細が表示されます(図 64-12 を参照)。リージョン内のノードに関する詳細は表形式で表示されます。

図 64-12 デバイスのプロパティ

 

さまざまなノードやリンク プロパティの詳細については、「デバイスのプロパティとリンクのプロパティの表示」で説明します。

また、リンクを右クリックすると、そのリンク プロパティについての説明が表示されます。たとえば、サンプル シリアル リンクの [Interfaces...] を選択すると、図 64-13 に示すような [Properties] ウィンドウが表示されます。

図 64-13 インターフェイスの [Properties] ウィンドウ

 

個々の PE は、1 つ以上の CPE に論理接続できます。このような接続は、MPLS VPN リンク、またはレイヤ 2 論理リンクによって作成されます。これらの接続はそれぞれ、指定された PE を CPE にリンクするエッジによって表されます。特定の PE と CPE の間にさらにその他にも接続がある場合は、これらもすべて表示されます。接続の状態に応じて、エッジは実線(機能している接続を表す)、点線(壊れている接続)、破線(まだ確立されていない接続)を使って描画されます。

接続のタイプに応じて、接続は 表 64-2 および 表 64-3 で説明されているとおりに描画されます。個々の接続には、PE インターフェイス名(IP アドレス)、VLAN ID 番号、CPE インターフェイス名(IP アドレス)が注釈として付けられています。

概要エリアでは、接続の形成に多数のデバイスが使用されていたとしても、CPE と PE の間に直接接続が描画されます。

デバイス プロパティの表示の詳細については、「デバイスのプロパティとリンクのプロパティの表示」を参照してください。

接続の詳細を表示するには、この接続を右クリックし、ポップアップ メニューから [Expand] オプションを選択します。展開されたビューが新しいタブに表示され、そこには指定された PE から CPE への接続を形成するすべてのデバイスとインターフェイスが表示されます(図 64-14 を参照)。

図 64-14 接続詳細ビュー

 


 

物理ビュー

物理ビューには、指定されたリージョンで PE について定義されている指定された物理回線がすべて表示されます。指定された物理回線はそれぞれ、PE からそのインターフェイスを通って CLE または CPE のインターフェイスへと続く接続のシーケンスとして表されます。指定されたリージョンの PE と CLE または CPE の間の物理リンクがすべて表示されます。物理リンクは、完璧な動作順になっていることが前提であるため、エッジは常に実線で描画されます。

物理ビューをアクティブ化するステップは、次のとおりです。


ステップ 1 メニュー バーで、[File] > [Open] を選択します。

または

ツールバーの [Open] ボタンをクリックします。

フォルダ ビュー ウィンドウが表示されます(図 64-6 を参照)。

ステップ 2 目的の VPN のフォルダを見つけ、このフォルダをダブルクリックします。

この VPN に関連付けられている論理ビューおよび物理ビューがすべて表示されます。

ステップ 3 選択した VPN の物理ビューを開くには、次のいずれかを実行します。

[Physical View] アイコンを 1 回クリックし、[Open] をクリックします。

または

[Physical View] アイコンをダブルクリックします。

これにより、図 64-15 に示すように、選択した VPN の物理ビューが作成されます。

図 64-15 物理ビュー

 

このビューでは、各デバイスは、専用のインターフェイスに細い線で接続されています。インターフェイスは他のインターフェイスと太い線で接続されています。2 つのインターフェイスの間に複数の接続が存在する場合、すべての接続を表示するために、インターフェイスどうしは間を空けて表示されます。

ツリーにはデバイスと接続が表示されます。各デバイスが、ツリーに接続されたすべてのインターフェイスを持つフォルダである可能性もあります。


 

デバイスのプロパティとリンクのプロパティの表示

論理ビューには、デバイスとリンクの両方のプロパティを表示できます。物理ビューでは、物理デバイスのプロパティにのみアクセスできます。

したがって、デバイスのプロパティは論理ビューと物理ビューの両方で確認可能です。

デバイスのプロパティ

デバイスのプロパティを表示するには、目的のデバイスを右クリックします。デバイスのプロパティ メニュー(図 64-16 を参照)が表示されます。

図 64-16 デバイスのプロパティ

 

次のプロパティを使用できます。

[ Logical Device...]:デバイスの論理プロパティを表示します。

[ Physical Device...]:デバイスの物理プロパティを表示します。

[ Interfaces...]:デバイスのインターフェイス

プロパティを表示します。

[ Service Requests...]:デバイスに関連付けられたサービス要求プロパティを表示します。

Logical Device

デバイスを右クリックし、[Logical Device...] を選択すると、図 64-17 のような論理デバイスの [Properties] ウィンドウが表示されます。

図 64-17 論理デバイスの [Properties] ウィンドウ

 

論理プロパティ ウィンドウには、次の情報が表示されます。

[Device Name]:デバイスの名前。

[Provider Name]:このデバイスがサービスを提供しているプロバイダーの名前。

[Region Name]:プロバイダー リージョンの名前。

[Loopback Address]:ループバック アドレスの IP アドレス。

[Role Type]:このデバイスに割り当てられているロール。

Physical Device

デバイスを右クリックし、[Physical Device...] を選択すると、図 64-18 のような物理デバイスの [Properties] ウィンドウが表示されます。

図 64-18 物理デバイスの [Properties] ウィンドウ

 

物理プロパティ ウィンドウには、次の情報が表示されます。

[Name]:デバイスの名前。

[Description]:ユーザが入力したデバイスの説明。

[Collection Zone]:デバイス データの収集ゾーン。

[IP Address]:トポロジで使用されているインターフェイスの IP アドレス。

[User ID]:インターフェイスのユーザ ID。

[Enable User]:インターフェイスのパスワード。

[Device Access Protocol]:デバイスとの通信に使用されるプロトコル。

[Config Upload/Download]:コンフィギュレーション ファイルのアップロードおよびダウンロード方法。

[SNMP Version]:このデバイスの Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)のバージョン。

[Community String RO]:[public] または [private]。

[Community String RW]:[public] または [private]。

[SNMP Security Level]:Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)のセキュリティ レベル。

[Authentication User Name]:このデバイスで認証を行うユーザの名前。

[Authentication Algorithm]:認証の実行に使用されるアルゴリズム。

[Encryption Algorithm]:セキュアな通信に使用される暗号化アルゴリズム。

[Terminal Server]:ターミナル サーバの名前。

[Terminal Server Port]:ターミナル サーバにより使用されるポートの番号。

[Platform]:ハードウェア プラットフォーム。

[Software]:このデバイスに搭載されている IOS バージョン、またはその他の管理ソフトウェア。

[Image Name]:デバイス初期化用ブート イメージ。

[Serial Number]:デバイスのシリアル番号。

Interfaces

デバイスを右クリックし、[Interfaces...] を選択すると、図 64-19 のようなインターフェイスの [Properties] ウィンドウが表示されます。

図 64-19 デバイス インターフェイスの [Properties] ウィンドウ

 

インターフェイス プロパティ ウィンドウには、次の情報が表示されます。

[Name]:デバイスの名前。

[IP Address]:デバイスの IP アドレス。

[IP Address Type]:[STATIC] または [DYNAMIC]。

[Encapsulation]:インターフェイス トラフィックで使用されるカプセル化。

[Description]:インターフェイスに割り当てられた説明(もしあれば)。

[Select](リンク):接続がインターフェイスに付加されている場合、ウィンドウの下部にあるドロップダウン リストで、このデバイスで使用できるインターフェイスの中から選択できます。

Service Requests

デバイスを右クリックし、[Service Requests...] を選択すると、図 64-20 のような Service Request(SR; サービス要求)の [Properties] ウィンドウが表示されます。

図 64-20 サービス要求の [Properties] ウィンドウ

 

サービス要求プロパティ ウィンドウには、次の情報が表示されます。

[Job ID]:SR の ID。

[Type]:SR で使用されるプロトコルのタイプ。

[State]:SR の状態。

[Operation Type]:インターフェイス トラフィックで使用されるカプセル化。

[Creator]:インターフェイスに割り当てられた説明(もしあれば)。

[Creation Time]:SR の作成日時。

[Customer Name]:SR に関連付けられているカスタマー名。

[Last Modified]:SR の最終変更日時。

[Description]:ユーザが入力した SR の説明。

[Select](SR):インターフェイスに複数の SR が関連付けられている場合、ウィンドウの下部にあるドロップダウン リストで、これらの SR の中から選択できます。

リンクのプロパティ

特定のリンクのプロパティを表示するには、目的のリンクを右クリックします。リンクのプロパティ メニュー(図 64-21 を参照)が表示されます。

図 64-21 リンクのプロパティ

 

次のオプションを使用できます。

[ Expand ]:全体的なトポロジには表示されていない、このリンクについてローカルなデバイスなど、リンクの詳細を表示します。

[ Service Request...]:リンクに関連付けられたサービス要求プロパティを表示します。

[ MPLS VPN ]:リンクの MPLS VPN プロパティを表示します。MPLS VPN 以外のリンク プロトコル プロパティは現在使用できません。

Expand

リンクを右クリックして、[Expand...] を選択すると、トポロジ表示により、そのリンクについてローカルなデバイスと接続がすべて表示されます。図 64-22 に類似したリンク展開ウィンドウが表示されます。

図 64-22 リンク展開ウィンドウ

 

デバイスおよびリンクのプロパティ情報は、この項で先に説明したとおり、マスター ビューでのみ入手可能です。

Service Request

リンクを右クリックし、[Service Requests...] を選択すると、図 64-23 のような Service Request(SR; サービス要求)の [Properties] ウィンドウが表示されます。

図 64-23 リンクのサービス要求の [Properties] ウィンドウ

 

サービス要求プロパティ ウィンドウには、次の情報が表示されます。

[Job ID]:SR の ID。

[Type]:SR で使用されるプロトコルのタイプ。

[State]:SR の状態。

[Operation Type]:インターフェイス トラフィックで使用されるカプセル化。

[Creator]:インターフェイスに割り当てられた説明(もしあれば)。

[Creation Time]:SR の作成日時。

[Customer Name]:SR に関連付けられているカスタマー名。

[Last Modified]:SR の最終変更日時。

[Description]:ユーザが入力した SR の説明。

[Select](SR):インターフェイスに複数の SR が関連付けられている場合、ウィンドウの下部にあるドロップダウン リストで、これらの SR の中から選択できます。

MPLS VPN

MPLS VPN 用に設定されたリンクを右クリックし、[MPLS VPN...] を選択すると、図 64-24 のような MPLS VPN の [Properties] ウィンドウが表示されます。

図 64-24 Link MPLS の VPN [Properties] ウィンドウ

 

サービス要求プロパティ ウィンドウには、次の情報が表示されます。

[Status]:MPLS VPN リンクのステータス。

[Status Message]:エラー メッセージ、または警告メッセージがあれば、すべて表示します。

[Operation Type]:MPLS 動作タイプ。

[Policy Type]:リンクに適用されるポリシー タイプ。

[Data MTD Threshold]:Memory Technology Driver(MTD)データしきい値。

[Default MTD Address]:デフォルト MTD の IP アドレス。

[Data MTD Subnet]:データ MTD のサブネット。

[Data MTD Size]:データ MTD のサイズ。

[SOO Enabled]:Site of Origin(SOO)のイネーブル化( [Yes] または [No]

[Manual Config]: [Yes] または [No]

フィルタリングと検索

大きなグラフでは、場合によっては詳細情報の量が非常に多くなります。このような場合、フィルタリングにより、必要のない情報を削除できます。一方、さらに詳しく調べたいデバイスをすばやく見つけるには、検索を行います。

高度なフィルタリングおよび検索の両方で、フィルタまたは検索されるノードに対する条件の入力に、同じウィンドウが使用されます。フィルタリング エリアでも、表示されているオブジェクトを名前ですばやくフィルタできます。

フィルタリング

トポロジ ビューのフィルタリングには、簡易フィルタリングと高度なフィルタリングの 2 通りがあります。

簡易フィルタリング

ビューの簡易フィルタリングを行うには、次のステップを実行します。


ステップ 1 メイン ウィンドウのエリア(4)に文字列を入力します(図 64-3 を参照)。

ステップ 2 Enter を押します。指定された文字列を含まない名前を持つオブジェクトがすべて淡色表示となります。

たとえば、名前に文字列「router」が含まれるノードを見つけるには、エリア(4)に「router」と入力し、Enter をクリックします。入力された文字列を含まない名前を持つオブジェクトはすべて淡色表示されます(図 64-25 を参照)。

図 64-25 物理ビューと淡色表示されたノード

 


) 正規表現もサポートされていますが、高度なフィルタリング ウィンドウでのみ使用できます([Advanced...] ボタンをクリックします)。たとえば、「^foo.*a」と入力すると、先頭が「foo」で、その後に「a」を含む任意の文字列が続く名前を持つノードのみ要求されます。正規表現は、Java の正規表現で定義されているルールに従う必要があります。



 

高度なフィルタリング

高度なフィルタリングのステップは、次のとおりです。


ステップ 1 [Advanced...] ボタンをクリックして、高度なフィルタリング ウィンドウを開きます。

図 64-26 に示すように、詳細 [Filter] ウィンドウが表示されます。

ステップ 2 目的のフィルタリング方法を選択します。

このウィンドウでは、フィルタされるノードに対する条件を 1 つ以上、入力できます。1 つめのドロップダウン リストでは、フィルタリング実行の基準となる属性を指定します。2 つめのドロップダウン リストには、属性の値と、3 列目に入力されるテキストの照合方法を指定します。

ドロップダウン リストから選択できる照合モードは、次のとおりです。

[contains]:デバイスから取得された属性値に指定された文字列が含まれていた場合、この属性値が選択されます。この文字列が属性値の先頭、末尾、または中に含まれていた場合、この照合は成功します。たとえば、パターンが「cle」である場合、[contains] モードでは、「clean」、「nucleus」、「circle」が一致します。

[starts with]:属性値は指定された文字列で始まらなければなりません。たとえば、パターンが「foot」である場合、「footwork」は一致しますが、「afoot」は一致しません。

[ends with]:これは [starts with] とは逆のケースで、指定された属性の値が指定されたパターンで終わっていた場合のみ、この属性はパターンに一致します。このモードでは、たとえば、パターン「foot」は「afoot」には一致しますが、「footwork」には一致しません。

[doesn't contain]:このモードでは、指定されたパターンを含まない文字列のみ一致します。結果は [contains] モードの逆です。たとえば、このモードで「cle」を指定した場合、「clean」、「nucleus」、および「circle」は却下されますが、「foot」には「cle」が含まれていないため、一致します。

[matches]:これは最も汎用的なモードで、必要なノードを定義する表現の全体または一部を指定できます。

図 64-26 詳細 [Filter] ウィンドウ

 

[Match any conditions] または [Match all conditions] オプション ボタンのいずれかをクリックして、いずれかの条件が一致すればよいか、すべての条件が一致する必要があるかを指定できます。最初のケースでは、たとえば、名前に「cisco」が含まれ、管理 IP アドレスが「204」で終わるデバイスを検索できます。すべての条件が一致しなければならない場合、たとえば、指定された名前やプラットフォームを持つデバイスを検索できます。

条件行を追加するには [More]、既存の条件行を削除するには [Fewer] をクリックします。

デフォルトでは、すべての照合が、大文字、小文字を区別せずに実行されます。しかし、大文字と小文字を考慮しながら、より正確な照合を実行した方が都合がよいこともあります。そのためには、[Match case] チェックボックスをオンにします。

ステップ 3 [OK] をクリックして、フィルタリング プロセスを開始します。フィルタの状態を変更せずにウィンドウを非表示にするには、[Cancel] をクリックします。

すべての条件をクリアするには、[Clear] ボタンを使用します。[Clear] に続けて [OK] をクリックすると、すべてのフィルタを効果的に削除し、すべてのノードの明るさのレベルをデフォルトに戻すことができます。フィルタリングがアクティブである場合は、メイン ウィンドウのエリア(4)(図 64-3を参照)で [Clear] をクリックしても同じ結果を得ることができます。


 

検索

検索はメニュー、またはツールバーを使用して行います。検索のステップは、次のとおりです。


ステップ 1 [Edit] メニューで [Find] を選択します。

または

メイン ツールバーの [Find] アイコンをクリックします。

どちらの方法でも、同じウィンドウ(図 64-27 を参照)が表示されます。

ここでも、条件を 1 つ以上入力して、ノードを検索できます。

図 64-27 [Find] ウィンドウ

 

ステップ 2 目的のフィルタリング方法を選択します。

照合モード、大文字小文字の区別を指定するためのチェックボックス、オプション ボタンの使用方法については、「高度なフィルタリング」図 64-26 を参照してください。

ステップ 3 [OK] をクリックします。指定された条件と一致する最初のノードの検索が開始されます。

見つかると、このノードがハイライトされ、そのときメイン ウィンドウに表示されているエリアに表示されるように、ビューの表示がずらされます。

ステップ 4 最初の検索後に F3 キーを押すか、[Find Again] ボタンをクリックすると、検索が繰り返されます。

複数のノードが条件に一致する場合、[Find Again] 機能により、これらのノードが 1 つずつハイライトされます。入力した条件に一致するノードがない場合は、[Object Not Found] ウィンドウが表示されます。


 

マップの使用

各ビューには、マップを 1 つ関連付けることができます。現在、トポロジ ビューアでは、Environmental Systems Research Institute, Inc.(ESRI)のシェープ形式のマップのみサポートされています。以降の章では、マップをロードし、マップ レイヤと各マップに関連付けられているデータを選択的に表示する方法について説明します。

マップの機能を使用するには、[Map] メニュー(図 64-28 を参照)を使用します。

図 64-28 [Map] メニュー

 

[Map] メニューには、次のメニュー項目が含まれます。

[Open Map]:アプリケーションにマップをロードします。

[Clear Map]:現在のビューからアクティブなマップをクリアします。

[View]:マップにあるどのレイヤを表示するかを選択できます(例:国、都道府県、市町村)。

マップのロード

表示されたデバイスの物理的な位置を表示したバックグラウンド マップの設定が必要になることがあります。マップをロードするステップは、次のとおりです。


ステップ 1 メニュー バーで、[Map] > [Open Map...] を選択します。

または

Ctrl+M を押します。

ステップ 2 [Load Map] ウィンドウで必要な選択を行います。

ウィンドウの右側部分には、小さいコントロール パネルがあり、マップを表示する投影法を選択できます。マップの投影では、平面に球体がマップされます。一般的な投影法には、メルカトル、ランベルト、およびステレオ投影があります。

投影法の詳細については、次の場所にある、Eric Weisstein による「World of Mathematics」の「Map Projections」の項を参照してください。

http://mathworld.wolfram.com/topics/MapProjections.html

それぞれの投影について、表示されるマップのリージョンを選択することもできます。多くの場合、あらかじめ定義されている値で十分です。

必要に応じて、[Longitude Range] フィールドと [Latitude Range] フィールドの設定を変更します。

ステップ 3 マップ ファイルを選択し、[Open] をクリックして、マップをロードします。

マップ ファイルを選択し、[Open] ボタンをクリックすると、ファイルのロードが開始されます。マップは複数のコンポーネントから構成されることもあるため、進捗ウィンドウが開き、マップ ファイルのどの部分がロードされているかという情報が表示されます。


 

レイヤ

1 つのマップに複数のレイヤが含まれることがあります。たとえば、国土マップの大半には、図 64-29 に示すように、国レイヤ、地域レイヤ、市区町村レイヤがあります。

図 64-29 マップ レイヤ

 

マップのロード後、[Map] メニューの [View] サブメニューに自動的に項目が入力されます。使用可能な各レイヤの名前が、そのレイヤの可視性を示すチェックボックスとともに表示されます。特定のマップに現れる詳細が多すぎる場合は、レイヤのチェックボックスをオフにして、レイヤの一部またはすべてが表示されないようにできます。同じサブメニューを使って、レイヤを再表示できます。

誤ったマップがロードされた場合、またはマップがロードされているときのトポロジ ツールのパフォーマンスに満足できない場合は、マップ全体をクリアします。そのためには、[Map] メニューから [Clear Map] を選択します。このマップは、別のマップをロードすると自動的にクリアされます。

したがって、単に別のマップをロードするだけの場合は、既存のマップをクリアする必要はありません。新しいマップをロードすれば同じ結果が得られます。

マップ データ

マップとともに、マップ データ ファイルのロードが正常に終了すると、ステータス バーの右側のフィールドに、マップ上でカーソルがある位置の緯度と経度が表示されます。都市、湖などのマップ オブジェクトにデータが関連付けられている場合、緯度と経度の座標に続けて、その名前が表示されます。

ノードの位置

マップのロードが正常終了すると、図 64-30 に示すとおり、マップ全体が表示されるように、ビュー エリアが調整されます。ウィンドウに表示されるノードに緯度および経度の情報が関連付けられている場合、ノードは、マップ上でその地理的な場所に対応する位置に移動します。関連付けられていない場合、位置は変わりません。

ただし、目的の位置に手動で移動して、将来参照するために、この位置を保存できます。次にこのネットワークのイメージをロードしたときには、ノードの位置が復元され、マップ ファイルがロードされます。

図 64-30 日本のマップが表示された物理ビュー

 

新規マップの追加

マップの選択肢に独自のマップを追加して、トポロジ アプリケーションで使用することもできます。このためには、root ディレクトリにマップを保存します。この例を分かりやすく説明するために、クイーンズランド州の州都ブリスベンの郊外にあるトゥーウォンのマップを追加するとします。最初のステップとして、マップ ベンダーからマップを入手します。すべてのマップは ESRI シェープ ファイル形式でなければなりません(詳細は、Web サイト http://www.esri.com で説明されています)。また、各シェープ ファイルにデータ ファイルが付属することもあります。データ ファイルには、シェープ ファイルに含まれているシェープを持つオブジェクトに関する情報が含まれます。ベンダーが次の 4 つのファイルを提供しているとします。

toowong_city.shp

toowong_city.dbf

toowong_street.shp

toowong_street.dbf

ここで、トポロジ アプリケーションにマップのレイヤに関する情報を伝えるマップ ファイルを作成するとします。この例では、City と Street という 2 つのレイヤがあります。マップ ファイル(たとえば、Toowong.map)は、次のような内容になります。

toowong_city
toowong_street
 

このファイルには、トゥーウォンのマップを構成するレイヤがすべてリストされます。最初のファイルがバックグラウンド レイヤになり、他のレイヤは先行するレイヤの上に配置されるため、順序が重要です。

シェープ ファイルとデータ ファイルを取得し、マップ ファイルを書き込んだら、その位置を決定します。前述のとおり、トゥーウォンはオーストラリアのクイーンズランド州にあるブリスベンの郊外にある都市です。マップ ファイルはすべて、$PRIMEF_HOME/resources/webserver/tomcat/webapps/ipsc-maps/data ディレクトリの中、またはこの下になければなりません。デフォルトでは、このディレクトリはその地域のマップすべてを対象とした Oceania というディレクトリに含まれていますから、Oceania ディレクトリの下に Australia/Queensland/Brisbane パスを作成します。次に、この場所に 5 つのファイルをすべて配置します。これが終了すると、自動的にトポロジ ビューアからこのマップにアクセスできるようになります。