Cisco Prime Fulfillment ユーザ ガイド 6.1
MPLS VPN サービス ポリシー
MPLS VPN サービス ポリシー
発行日;2012/05/08 | 英語版ドキュメント(2011/11/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

MPLS VPN サービス ポリシー

サービス ポリシーの概要

サービス ポリシー エディタ

Cisco の IP アドレスについて

MPLS VPN サービス ポリシーの定義

PE および CE インターフェイス パラメータの指定

IP アドレス スキームの指定

既存のループバック インターフェイス番号の使用

サービスのルーティング プロトコルの指定

IP ルートの再配布

CSC サポート

CE へのデフォルト ルートのみの提供

スタティック プロトコルの選択

RIP プロトコルの選択

BGP プロトコルの選択

OSPF プロトコルの選択

IGP の OSPF プロセス ID(IOSXR のみ)

EIGRP プロトコルの選択

[None] を選択:ケーブル サービス

VRF および VPN の情報の定義

BGP マルチパス ロード シェアリングおよび最大パス設定

IOS XR デバイスの BGP マルチパス サポート

マルチパス設定の除去

ポリシーのテンプレートの関連付けのイネーブル化

MPLS VPN サービス ポリシー

この章では、Cisco Prime Fulfillment GUI を使用して MPLS VPN サービス ポリシーを定義する方法を説明します。

サービス ポリシーの概要

MPLS VPN のプロビジョニングは、サービス ポリシーの定義で始まります。サービス ポリシーは、単一のサービス要求で複数の PE-CE リンクに適用できます。 ネットワーク オペレータ はサービス ポリシーを定義します。 サービス オペレータ は、サービス ポリシーを使用してサービス要求を作成します。各サービス要求には、PE-CE リンクのリストが含まれています。サービス オペレータがサービス要求を作成するときに、オペレータは入力する必要があるポリシー情報のみを参照します。その他の必要な情報はすべて、サービス ポリシー自体(および自動検出プロセス)によって入力されます。

サービス ポリシー エディタ

Prime Fulfillment のサービス ポリシーを定義するときに一連のダイアログボックスが表示され、MPLS サービス要求を実行するために必要な各主要カテゴリのパラメータを指定できます。サービス ポリシー エディタには、[Attribute]、[Value]、および [Editable] の 3 つの列があります。

[Attribute]

[Attribute] 列には、各主要カテゴリに対して定義する必要がある各パラメータの名前が表示されます(たとえば、IP アドレスやルーティング プロトコルなど)。

[Value]

[Value] 列には、各パラメータおよびオプションに対応するフィールドおよびその他の選択可能項目が表示されます。

属性を編集するときに呼び出されるダイアログボックスのタイプは、属性のタイプによって異なります。一部の場合、値は単純な文字列値または整数値であり、単一のテキスト入力フィールドが表示されます。その他の場合、値は複合値であるか、または複数の値で構成されています(IP アドレスなど)。これらの場合、必要な値を指定できるようにダイアログボックスが表示されます。入力する値は検証され、無効な値が入力されると、無効な値に関する通知が表示されます。その他の場合、チェックボックスが表示され、特定のオプションをイネーブルまたはディセーブルにできます。


) 場合により、属性の値を変更すると、関連属性の値が無効になります。たとえば、PE インターフェイス名を変更すると、PE カプセル化値が無効になる可能性があります。これが発生すると、サービス ポリシー エディタから無効な値が除去され、それらを適切にリセットする必要があります。


一部の属性間には親子関係があります。これらの場合、親属性の値を変更すると、子属性がイネーブルまたはディセーブルになる場合があります。たとえば、PE カプセル化の値を変更すると、Data Link Connection Identifier(DLCI)、VLAN ID、ATM 回線 ID、トンネル ソース属性、および宛先アドレス属性がイネーブルまたはディセーブルになる可能性があります。

[Editable]

[Editable] 列を使用すると、ネットワーク オペレータは複数のサービス要求間で変更されると思われる属性を指定できます。属性のチェックボックスが編集可能としてオンになっていると、そのサービス要求ポリシーを使用してサービス要求を作成または変更するときに、サービス オペレータはそれらの属性のみを使用できます。

属性カテゴリが編集可能と設定されている場合、関連属性および子属性もすべて編集可能属性です。

Cisco Prime Fulfillment の IP アドレスについて

VPN(またはエクストラネット)内では、すべての IP アドレスは固有である必要があります。カスタマー IP アドレスは、プロバイダー IP アドレスとオーバーラップできません。オーバーラップは、2 つのデバイスが相互に参照できない場合、つまり、2 つのデバイスが分離された非エクストラネット VPN 内にある場合にのみ可能です。

Prime Fulfillment MPLS VPN ソフトウェアでは、アドレスを取得する IP アドレス プールがあることを想定しています。製品がこれらのアドレスを自由に使用できることが保証されるのは、それらがプロバイダー IP アドレスである場合のみです。

PE-CE リンクに対する IP アドレス スペースの固有セクションを事前定義することが、安定したセキュリティを確保する唯一の方法です。したがって、セキュリティおよびメンテナンスの問題があるため、PE-CE リンクでカスタマー IP アドレスを使用することを推奨しません。

MPLS VPN サービス ポリシーの定義

この章の残りの項では、PE-CE リンクの MPLS サービス ポリシー定義の拡張例を説明します。これは、MPLS サービス ポリシーの定義に含まれるさまざまなステップを例示するためのものです。その他のタイプの MPLS VPN サービス ポリシーの定義の基本として、このステップを使用できます。その他のタイプの MPLS VPN ポリシーについては、このガイドのその他の章で説明します。

PE-CE リンクの MPLS VPN サービス ポリシーの定義を開始するには、次のステップを実行します。


ステップ 1 [Service Design] > [Policies] > [MPLS] を選択します。

図 24-1 に示されているような、[MPLS Policy Editor - Policy Type] ダイアログボックスが表示されます。

図 24-1 MPLS サービス ポリシーの定義

 

ステップ 2 [Policy Name] に MPLS ポリシーの名前を入力します。

ステップ 3 [Policy Owner] を選択します。

3 つのタイプの MPLS ポリシー所有権があります。

カスタマー所有権

プロバイダー所有権

グローバル所有権:任意のサービス オペレータがこの MPLS ポリシーを使用できます。

この所有権は、Prime Fulfillment Role-Based Access Control(RBAC; ロールベース アクセス コントロール)が有効になると関係してきます。たとえば、カスタマー所有の MPLS ポリシーは、このカスタマー所有ポリシーでの作業が許可されているオペレータのみが参照できます。

同様に、プロバイダーのネットワークでの作業を許可されているオペレータは、特定のプロバイダー所有ポリシーを表示、使用、および導入できます。


) ケーブル(PE-NoCE)の場合、ポリシー所有権を「プロバイダー」に設定する必要があります。


ステップ 4 [Select] をクリックして、MPLS ポリシーの所有者を選択します(グローバル所有権を選択すると、[Select] 機能を使用できません)。

[Select Customer] ウィンドウまたは [Select Provider] ウィンドウが表示され、ポリシーの所有者を選択して [Select] をクリックできます。

ステップ 5 MPLS ポリシーの [Policy Type] の値を選択します。

MPLS ポリシーには 2 つのポリシー タイプがあります。

標準 PE-CE:PE から CE へのリンク

MVRFCE PE-CE:PE のマルチ VRF 機能を使用した PE から CE へのリンク

ステップ 6 Prime Fulfillment がサービス アクティベーション時に CE ルータとインターフェイスを指定するようにこの MPLS ポリシーを使用するサービス オペレータに尋ねるようにするには、[CE Present] チェックボックスをオンにします。デフォルトでは、サービスに CE が存在します。

[CE Present] チェックボックスをオンにしない場合、Prime Fulfillment は、PE-CLE または PE-POP ルータおよびカスタマー方向のインターフェイスについてのみ、サービス アクティベーション時にサービス オペレータに尋ねます。

ステップ 7 [Next] をクリックします。


 

この例を続行するには、次の項、「PE および CE インターフェイス パラメータの指定」を参照してください。

PE および CE インターフェイス パラメータの指定

図 24-2 に示されているような、[MPLS Policy Interface] ダイアログボックスが表示されます。


ヒント この時点では、PE および CE に対して特定のインターフェイス タイプを選択する必要はありません。フィールドがデフォルトで [Editable] に設定されていることに注意してください。インターフェイス パラメータが [Editable] に設定されていると、サービス オペレータはサービス要求の作成時に正確なインターフェイス タイプと形式を指定できます。

サービス要求の作成時にこのサービス ポリシーのデバイス インターフェイス情報を指定する場合は、フィールドを現在デフォルトで設定されているままにして、[Next] をクリックします。

図 24-2 PE UNI セキュリティ、および CE インターフェイス パラメータの指定

 

この MPLS ポリシーの PE、UNI セキュリティ、および CE インターフェイスを指定するには、次の手順を実行します。

[PE Information]


ステップ 1 [Interface Type]:ドロップダウン リストから、PE のインターフェイス タイプを選択します。

Cisco IP Solution Center は、次のインターフェイス タイプをサポートします(PE と CE の両方について)。

任意

ATM(非同期転送モード)

BRI(基本速度インターフェイス)

Bundle-Ether(詳細については、「[Interface Format]:オプションで、PE インターフェイスのスロット番号およびポート番号を指定できます。」を参照してください)。

イーサネット

ファスト イーサネット

FDDI(ファイバ分散データ インターフェイス)

GE-WAN(ギガビット イーサネット WAN)

ギガビット イーサネット

HSSI(高速シリアル インターフェイス)

ループバック

MFR

マルチリンク

PoS(Packet over Sonet)

ポートチャネル

シリアル

スイッチ

トンネル

VLAN

ステップ 2 [Interface Format]:オプションで、PE インターフェイスのスロット番号およびポート番号を指定できます。

標準命名法: スロット番号/ポート番号 で形式を指定します(たとえば、 1/0 は、インターフェイスがスロット 1、ポート 0 にあることを示します)。

これは、サービス内のすべてまたは大部分のネットワーク デバイスにある特定のインターフェイスのスロットまたはポートの位置をリンクが常に通過することがわかっている場合に、ここで指定しておくと特に役立ちます。このパラメータを編集可能のままにしておくと、サービス オペレータがサービス要求を作成するときに変更できます。

インターフェイス形式をチャネライズド インターフェイスとして指定することもできます。

slot/subSlot/port (たとえば、 2/3/4 は、インターフェイスがシリアル 2/3/4 にあることを示します)

slot/subSlot/port/T1#:channelGroup# (たとえば、 2/0/4/6:8 は、インターフェイスがシリアル 2/0/4/6:8 にあることを示します)

slot/subSlot/port.STS-1Path/T1#:channelGroup# (たとえば、 2/0/0.1/6:8 は、インターフェイスがシリアル 2/0/0.1/6:8 にあることを示します)

ステップ 3 [Interface Description]:オプションで、PE インターフェイスの説明を入力できます。

ステップ 4 [Shutdown Interface]:このチェックボックスをオンにすると、指定された PE インターフェイスはシャットダウン状態で設定されます。

ステップ 5 [Encapsulation]:指定された PE インターフェイス タイプに使用するカプセル化を選択します。

インターフェイス タイプを選択するときに、指定されたインターフェイス タイプに対してサポートされるカプセル化タイプのドロップダウン リストが [Encapsulation] フィールドに表示されます。

表 24-1 に、サポートされる各インターフェイス タイプで使用可能なプロトコル カプセル化を示します。

 

表 24-1 インターフェイス タイプおよび対応するカプセル化

インターフェイス タイプ
カプセル化

ATM

AAL5SNAP

BRI

フレームリレー、フレームリレー ietf、HDLC(ハイレベル データリンク コントロール)、PPP(ポイントツーポイント プロトコル)

フレームリレー ietf は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)標準(RFC 1490)に準拠するようにカプセル化方式を設定します。フレーム リレー ネットワークを介して別のベンダーの機器に接続する場合は、この方式を使用します。

Bundle-Ether

デフォルト フレーム、dot1q(802.1Q)

イーサネット

デフォルト フレーム、dot1q(802.1Q)

ファスト イーサネット

デフォルト フレーム、ISL(スイッチ間リンク)、dot1q(802.1Q)

FDDI(ファイバ分散データ インターフェイス)

なし

ギガビット イーサネット

デフォルト フレーム、ISL(スイッチ間リンク)、dot1q(802.1Q)

ギガビット イーサネット WAN

デフォルト フレーム、ISL(スイッチ間リンク)、dot1q(802.1Q)

HSSI(高速シリアル インターフェイス)

フレームリレー、フレームリレー ietf、HDLC(ハイレベル データリンク コントロール)、PPP(ポイントツーポイント プロトコル)

ループバック

なし

MFR

フレームリレー、フレームリレー ietf、HDLC(ハイレベル データリンク コントロール)、PPP(ポイントツーポイント プロトコル)

マルチリンク

PPP(ポイントツーポイント プロトコル)

ポートチャネル

デフォルト フレーム、ISL(スイッチ間リンク)、dot1q(802.1Q)

 

POS(Packet Over Sonet)

フレームリレー、HDLC(ハイレベル データリンク コントロール)、PPP(ポイントツーポイント プロトコル)

シリアル

フレームリレー、フレームリレー ietf、HDLC(ハイレベル データリンク コントロール)、PPP(ポイントツーポイント プロトコル)

スイッチ

AAL5SNAP

トンネル

GRE(総称ルーティング カプセル化) - このリリースでは GRE はサポートされていません -

VLAN

なし


) MLFR インターフェイスは IOS デバイスおよび IOS XR デバイスでサポートされます。Prime Fulfillment は、MLFR インターフェイスをセットアップしません。Prime Fulfillment は、MLFR インターフェイス上のレイヤ 3 サービスをプロビジョニングします。


ステップ 6 [Auto-Pick VLAN ID]:Prime Fulfillment が自動的に VLAN ID を選択するようにする場合は、このチェックボックスをオンにします。


) [Auto-Pick VLAN ID] がオフの場合、そのポリシーに基づくサービス要求の作成時に、VLAN ID を入力するようにプロンプトが表示されます。


ステップ 7 [Use SVI]:Prime Fulfillment が SVI で VRF を終了するようにするには、このチェックボックスをオンにします。

ステップ 8 [ETTH Support]:Ethernet-To-The-Home(ETTH)を設定するには、このチェックボックスをオンにします。ETTH の説明については、「Ethernet-To-The-Home(ETTH)」を参照してください。

ステップ 9 [Standard UNI Port]:UNI セキュリティ パラメータにアクセスするには、このチェックボックスをオンにします。

UNI セキュリティ情報

ステップ 10 [Disable CDP]:CDP をディセーブルにするには、このチェックボックスをオンにします。

ステップ 11 [Filter BPDU]:BPDU をフィルタリングするには、このチェックボックスをオンにします。

ステップ 12 [Use existing ACL Name]:既存の ACL 名を使用するには、このチェックボックスをオンにします。

ステップ 13 [UNI MAC Addresses]:MAC アドレス レコードを変更または作成するには、[Edit] をクリックします。

ステップ 14 [UNI Port Security]:UNI ポート セキュリティ パラメータにアクセスするには、このチェックボックスをオンにします。

a. [Maximum MAC Address]:有効な値を入力します。

b. [Aging (in minutes)]:有効な値を入力します。

c. [Violation Action]:ドロップダウン リストから、次のいずれかを選択します。

PROTECT

RESTRICT

SHUTDOWN

d. [Secure MAC Address]:セキュア MAC アドレス レコードを変更または作成するには、[Edit] をクリックします。

CE インターフェイス情報

ステップ 15 [Interface Type]:ドロップダウン リストから、CE のインターフェイス タイプを選択します。

ステップ 16 [Interface Format]:オプションで、CE インターフェイスのスロット番号およびポート番号を指定できます。

ステップ 17 [Interface Description]:オプションで、CE インターフェイスの説明を入力できます。

ステップ 18 [Encapsulation]:指定された CE インターフェイス タイプに使用するカプセル化を選択します。

ステップ 19 インターフェイス設定に満足したら、[Next] をクリックします。


 

この例を続行するには、次の項、「IP アドレス スキームの指定」を参照してください。

IP アドレス スキームの指定

図 24-3 に示されているような、[MPLS Policy Interface Address Selection] ウィンドウが表示されます。

図 24-3 IP アドレス スキームの指定

 

このサービス ポリシーで使用する IP アドレス スキームを指定するには、次のステップを実行します。


ステップ 1 PE-CE リンクに適した IP アドレッシング スキームを定義します。

[IP Numbering Scheme]

次のオプションから選択できます。

[IPv4 Numbered]

[IPv4 Numbered] を選択し、[Automatically Assign IP Address] チェックボックスもオンにすると、Prime Fulfillment:MPLS は、対応する IP アドレスがルータのコンフィギュレーション ファイル内に存在するかどうかを確認します。アドレスが存在し、同じサブネット内にある場合、Prime Fulfillment はそれらのアドレスを使用します(アドレス プールからは割り当てません)。IP アドレスがコンフィギュレーション ファイル内に存在しない場合、Prime Fulfillment は、/30 サブネット ポイントツーポイント IP アドレス プールから IPv4 アドレスを選択します。

[IPv4 Unnumbered]

IPv4 アドレスは、ループバック IPv4 アドレス プールから取得されます。アンナンバード IPv4 アドレスは、各インターフェイスがルータ上の別のインターフェイス(通常はループバック インターフェイス)からアドレスを「借用」することを意味します。アンナンバード アドレスは、ポイントツーポイント WAN リンク(シリアル、フレーム、ATM など)でのみ使用可能で、LAN リンク(イーサネットなど)では使用できません。IP アンナンバードを使用する場合、PE と CE の両方が同じ IP アンナンバード アドレッシング スキームを使用する必要があります。[IPv4 Unnumbered] を選択すると、Prime Fulfillment:MPLS は、PE-CE リンクのスタティック ルートを作成します。

[IPv4 Unnumbered] を選択すると、Prime Fulfillment:MPLS は、自動的にループバック インターフェイスを作成します(正しい属性のループバック インターフェイスが存在しない場合)。関連情報については、「既存のループバック インターフェイス番号の使用」を参照してください。

[IPv6 Numbered]

このアドレッシング スキームは、6VPE ルータをサポートするために提供されています。MPLS VPN 管理においての IPv6 および 6VPE サポートの詳細については、「MPLS VPN での IPv6 および 6VPE サポート」を参照してください。


) このオプションは、ポリシー タイプが標準 PE-CE ポリシーである場合にのみ表示されます。


[IPv4+IPv6 Numbered]

6VPE デバイスの場合、PE インターフェイスを「デュアル スタック」、つまり、IPv4 アドレスと IPv6 アドレスの両方を含むことができるようにすることができます。後のステップで、IPv4 と IPv6 両方のルーティング情報を独立して入力できます。MPLS VPN 管理においての IPv6 および 6VPE サポートの詳細については、「MPLS VPN での IPv6 および 6VPE サポート」を参照してください。


) このオプションは、ポリシー タイプが標準 PE-CE ポリシーである場合にのみ表示されます。


ステップ 2 CE に追加ループバック インターフェイスが必要であるかどうかを指定します。

[Extra CE Loopback Required]

番号指定 IP アドレスはループバック アドレスを必要としませんが、Prime Fulfillment ソフトウェアは、追加の CE ループバック インターフェイスが必要であることを指定するオプションを提供します。このオプションは、どの物理インターフェイスにも接続されていない CE ルータに IP アドレスを配置します。

[Extra CE Loopback Required] をイネーブルにすると、CE ループバック アドレスを入力できます。

ステップ 3 自動的に IP アドレスを割り当てるかどうかを指定します。

[Automatically Assign IP Address]

[IPv4 Unnumbered] を選択し、[Automatically Assign IP Address] チェックボックスもオンにすると、Prime Fulfillment は、/32 サブネット ポイントツーポイント IP アドレス プールから 2 つの IP アドレスを選択します。

[IPv4 Numbered] を選択し、[Automatically Assign IP Address] チェックボックスもオンにすると、Prime Fulfillment は、対応する IP アドレスがルータのコンフィギュレーション ファイル内に存在するかどうかを確認します。アドレスが存在し、同じサブネット内にある場合、Prime Fulfillment はそれらのアドレスを使用します(アドレス プールからは割り当てません)。IP アドレスがコンフィギュレーション ファイル内に存在しない場合、Prime Fulfillment は、/30 サブネット ポイントツーポイント IP アドレス プールから IP アドレスを選択します。


) このオプションは、[IPv6 Numbered] アドレス スキームおよび [IPv4+IPv6 Numbered] アドレス スキームの場合はサポートされません。


ステップ 4 このサービス ポリシーの IP アドレス プールおよび関連リージョンを指定します。

[IP Address Pool]

[IP Address Pool] オプションは、Prime Fulfillment が、リージョンに接続された IP アドレス プールから自動的に IP アドレスを割り当てるようにする機能をサービス オペレータに提供します。サービス ポリシーのこの側面を定義する前に、リージョンが定義されていて、適切な IP アドレス プールがそのリージョンに割り当てられている必要があります。

ポイントツーポイント(IP 番号指定)PE-CE リンクに対して IP アドレス プール情報を指定できます。

IP アンナンバード アドレスは、ループバック IP アドレス プールから取得されます。アンナンバード IP アドレスは、各インターフェイスがルータ上の別のインターフェイス(通常はループバック インターフェイス)からアドレスを「借用」することを意味します。アンナンバード アドレスは、ポイントツーポイント WAN リンク(シリアル、フレーム、ATM など)でのみ使用可能で、LAN リンク(イーサネットなど)では使用できません。IP アンナンバードを使用する場合、PE と CE の両方が同じ IP アンナンバード アドレッシング スキームを使用する必要があります。


) このオプションは、[IPv6 Numbered] アドレス スキームおよび [IPv4+IPv6 Numbered] アドレス スキームの場合はサポートされません。


ステップ 5 IP アドレス スキームに満足したら、[Next] をクリックします。


 

既存のループバック インターフェイス番号の使用

各 PE には、IP アンナンバード アドレスを使用しているインターフェイスについて、通常は VRF ごとに 1 つのループバック インターフェイス番号のみが存在します。ただし、IP アンナンバード アドレスと手動で割り当てた IP アドレスを使用してインターフェイスをプロビジョニングしている場合、同じ VRF で複数のループバック インターフェイス番号を持つことができます。IP アンナンバード アドレスのプロビジョニングに自動的に割り当てられる IP アドレスを使用する場合、Prime Fulfillment は同じ VRF 名を持つ最初のループバック番号をインターフェイスに関連付けます。ループバック番号が存在しない場合、Prime Fulfillment はループバック番号を作成します。

Prime Fulfillment が既存のループバック インターフェイス番号(たとえば、Loopback0)を使用することをサービス プロバイダーが要求する場合、サービス プロバイダーは関連のあるルータ(PE または CE)のコンフィギュレーション ファイルのループバック インターフェイス記述行を変更する必要があります。

既存のループバック インターフェイス番号を使用するには、次のルータ コンフィギュレーション ファイル ファイルの例で示されているように、キーワード VPN-SC が含まれるようにループバック インターフェイス記述行を変更する必要があります。


) PE に対して既存のループバック インターフェイス番号を使用する場合、ip vrf forwarding VRF_name コマンドを持つ追加のコマンド行を「description」行の直後に含める必要があります。


interface Loopback0
description by VPN-SC
ip vrf forwarding <VRF_name> ; This line is required on the PE only
ip address 209.165.202.129 255.255.255.224
 

既存のループバック インターフェイスは、インターフェイス コンフィギュレーションが「IP アンナンバード アドレスを使用する WAN シリアル インターフェイスである」という条件をみたす場合にのみ使用できます。

Prime Fulfillment は、ループバック インターフェイス番号を順番に選択します。Prime Fulfillment は、要件(CE の場合、VPN-SC キーワードが含まれていること。PE の場合、一致する VRF 名であること)を満たす最初のループバック インターフェイス番号を使用します。

たとえば、loopback1 と loopback2 に VPN-SC キーワードが含まれていて、loopback3 には含まれていない場合、loopback3 に VPN-SC キーワードを追加しても、自動的に割り当てられるアドレスの使用時に Prime Fulfillment がアンナンバード インターフェイスに強制的に loopback3 を選択することにはなりません。代わりに、loopback1 が選択されます。特定のループバック インターフェイス番号を選択する唯一の方法は、必要なループバック インターフェイス番号に一致する手動割り当て IP アドレスを使用することです。


) 標準インターフェイスとは異なり、Prime Fulfillment でループバック インターフェイスがプロビジョニングされる場合、結果として生成されるコンフィギュレーション ファイルには Service Request(SR; サービス要求)の ID 番号は含まれていません。これは、複数のインターフェイスまたはサービス要求が同じループバック インターフェイスを使用する可能性があるためです。


この例を続行するには、次の項、「サービスのルーティング プロトコルの指定」を参照してください。

サービスのルーティング プロトコルの指定

これで、図 24-4 に示されているように、このサービス ポリシーのルーティング プロトコル情報を指定できます。


) IPv4 および IPv6 のルーティングは独立しています。Prime Fulfillment GUI を使用すると、選択したアドレッシング スキームに応じて、IPv4 および IPv6 に対して同じルーティング プロトコル、または異なるルーティング プロトコルを入力できます。IPv6 の場合、すべてのルーティング プロトコルがサポートされるわけではありません。IPv6 およびサポートされるルーティング プロトコルの詳細については、「MPLS VPN での IPv6 および 6VPE サポート」を参照してください。


選択するルーティング プロトコルは、PE と CE の両方で実行される必要があります。次のプロトコルのいずれかを選択できます。

[Static]:スタティック ルートを指定します(「スタティック プロトコルの選択」を参照)。

[RIP]:Routing Information Protocol(「RIP プロトコルの選択」を参照)。

[BGP]:ボーダー ゲートウェイ プロトコル(「BGP プロトコルの選択」を参照)。

[OSPF]:Open Shortest Path First(「OSPF プロトコルの選択」を参照)。

[EIGRP]:Enhanced Interior Gateway Routing Protocol(「EIGRP プロトコルの選択」を参照)。

[None]:ケーブル サービスのパラメータを指定します(「[None] を選択:ケーブル サービス」を参照)。

PE-CE リンクのルーティング プロトコルを指定するには、次のステップを実行します。


ステップ 1 [Routing Protocol] ドロップダウン リストから適切なプロトコルを選択します。


) IPv6 アドレッシングの場合、ルーティング プロトコルのサブセットのみがサポートされます。IOS XR デバイスの場合、[Static]、[BGP]、[EIGRP]、および [None] のみがサポートされます。IOS デバイスの場合、[Static]、[BGP]、および [None] のみがサポートされます。


特定のルーティング プロトコルを選択すると、そのプロトコルの関連パラメータが表示されます。

ステップ 2 選択されたルーティング プロトコルに必要な情報を入力し、[Next] をクリックします。

ステップ 3 「VRF および VPN の情報の定義」で説明されているように、[MPLS Policy VRF and VPN Selection] のパラメータを定義します。


 

IP ルートの再配布

ルート再配布 は、1 つのソースからルーティング情報を取得して、その情報を別のソースにインポートするプロセスです。再配布へのアプローチには注意が必要です。ルート再配布を実行すると、情報が失われます。メトリックを適宜リセットする必要があります。たとえば、5 ホップ メトリックを使用する RIP ルートのグループを iGRP に再配布する場合、5 ホップ RIP メトリックを IGRP の複合メトリックに変換する方法はありません。RIP ルートが IGRP に再配布されるときに、RIP ルートのメトリックを適宜選択する必要があります。また、2 つのダイナミック ルーティング プロトコル ドメイン間の複数のポイントで再配布が実行されると、ルーティング ループが発生する可能性があります。

CSC サポート

Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

CE へのデフォルト ルートのみの提供

[Give only default routes to CE] オプションをイネーブルにするときに、サイトが 完全なルーティング または デフォルト ルーティング のどちらを必要とするかを示します。完全なルーティングは、VPN 内に存在するその他のルートをサイトが具体的に認識する必要がある場合です。デフォルト ルーティングは、具体的にそのサイトに対するものではないパケットをすべて VPN に送信すれば十分な場合です。

このオプションを選択すると、Prime Fulfillment は、実行プロトコルで PE ルータに対して default-info originate コマンドを設定します(RIP、OSPF、または EIGRP の場合)。Static の場合、Prime Fulfillment は、CE ルータに対して ip route 0.0.0.0 0.0.0.0 <out-going interface name> コマンドを設定します。

デバイスは、デフォルト ルートを 1 つのみ持つことができます。したがって、VPN はデフォルト ルートを使用できますが、それはカスタマー サイトにまだ別のデフォルト ルートがない場合のみです。すでにデフォルト ルートがある最も一般的な理由は、VPN と独立したインターネット フィードがサイトにあるということです。

CE サイトにインターネット サービスがすでにある場合、CE は、不明な宛先へのパケットをすべてインターネットにルーティングするか、またはインターネット内のすべてのルートを学習できます。明らかな選択は、不明な宛先へのパケットをすべてインターネットにルーティングすることです。サイトにインターネット フィードがある場合、すでにデフォルト ルートがある可能性があります。そのような場合は、VPN をデフォルト ルートとして設定することは正しくありません。VPN は、その他の VPN サイト用のパケットのみをルーティングする必要があります。

スタティック プロトコルの選択

スタティック ルーティングとは、ルータに手動でリストされている宛先へのルートのことです。この場合のネットワーク到達可能性は、ネットワーク自体の存在および状態には依存しません。宛先のアップ/ダウンには関係なく、スタティック ルートはルーティング テーブルに残り、トラフィックはその宛先に送信されます。

プロトコルとして [Static] を選択すると、図 24-4 に示されているように、[CSC Support]、[Give Only Default Routes to CE]、[Redistribute Connected (BGP only)]、および [Default Information Originate (BGP only)] の 4 つのオプションがイネーブルになります。


) その他の 2 つのオプション([AdvertisedRoutes] および [Default Routes - Routes to reach other sites]は、サービス要求を作成するときに使用できます。「スタティック ルーティング プロトコル属性の設定(IPv4 と IPv6)」を参照してください。


図 24-4 スタティック ルーティング プロトコルの指定

 

サービス ポリシーのルーティング プロトコルとしてスタティックを指定するには、次のステップを実行します。


ステップ 1 [CsC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

前のステップで IP アドレッシング スキームが IPv6 に設定されている場合は、この属性を使用できません。

ステップ 2 [Give Only Default Routes to CE]:スタティック ルートを使用してプロビジョニングするときに、このサービス ポリシーが CE にデフォルト ルートのみを与えるかどうかを指定します。

PE-CE リンクのスタティック ルート プロビジョニングで [Give only default routes to CE] オプションをイネーブルにすると、Prime Fulfillment は PE を指すデフォルト ルートを CE に作成します。CE サイトへの VRF スタティック ルートは、VPN 内のその他のサイトの BGP に再配布されます。

このオプションを選択すると、デフォルト ルート(0.0.0.0/32)が自動的に設定されます。サイトには、インターネット フィードやその他のデフォルト ルートに対する要件は含まれません。ローカルにはルーティングされないパケットをサイトが検出すると、そのパケットを VPN に送信できます。

このオプションを選択すると、Prime Fulfillment は、実行プロトコルで PE ルータに対して default-info originate コマンドを設定します(RIP、OSPF、または EIGRP の場合)。Static の場合、Prime Fulfillment は、CE ルータに対して ip route 0.0.0.0 0.0.0.0 <out-going interface name> コマンドを設定します。

ステップ 3 [Redistribute Connected (BGP Only)]:このサービス ポリシーが、VPN 内のその他の CE に接続済みルートを再配布するかどうかを示します。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。


ヒント 管理 VPN に参加し、IP 番号指定アドレスも使用している場合、[Redistribute Connected] オプションをイネーブルにする必要があります。

ステップ 4 [Default Information Originate (BGP Only)]:このオプションをイネーブルにすると、Prime Fulfillment は、現在指定されている VRF に対して iBGP アドレス ファミリで default-information-originate コマンドを発行します。

[Default Information Originate] オプションは、特にハブ アンド スポーク トポロジ内では必須です。これは、各スポークがその他すべてのスポークと通信できる必要があるためです(ハブ PE にスポーク PE へのデフォルト ルートを挿入することによる)。

ステップ 5 このサービス ポリシーのスタティック ルーティングの定義が完了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 

RIP プロトコルの選択

Routing Information Protocol(RIP)は、ホップ カウントをメトリックとして使用する距離ベクトル型のプロトコルです。RIP は一種の Interior Gateway Protocol(IGP)であり、単一自律システム内でルーティングを実行することを意味します。RIP は、ルーティング アップデート メッセージを定期的に、またネットワーク トポロジが変更されたときに送信します。ルータは、エントリの変更が含まれるルーティング アップデートを受け取ると、新しいルートを反映するようにそのルーティング テーブルを更新します。パスのメトリック値は 1 ずつ大きくなり、送信者はネクスト ホップとして示されます。

RIP ルータは宛先への最善なルート(つまり、メトリック値が可能な範囲で最小のルート)のみを維持します。ルータは、そのルーティング テーブルを更新した後、他のネットワーク ルータに変更を通知するために、ルーティング アップデートの送信をただちに開始します。これらのアップデートは、RIP ルータが送信する定期的にスケジュールされたアップデートとは独立して送信されます。

サービス ポリシーのルーティング プロトコルとして RIP を指定するには、次のステップを実行します。


ステップ 1 [Routing Protocol] ドロップダウン リストから [RIP] を選択します。

図 24-5 に示されているような、[RIP Routing Protocol] ダイアログボックスが表示されます。

図 24-5 ルーティング プロトコルとして RIP を選択

 

ステップ 2 [CSC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

ステップ 3 [Give Only Default Routes to CE]:CE にデフォルト ルートのみを与えるかどうかを指定します。

インターネットワークが階層的に設計されている場合、デフォルト ルートはルーティング情報の伝搬の必要性を制限するために役立つツールです。アクセス レベル ネットワーク(ブランチ オフィスなど)は、通常は本社への接続を 1 つのみを持っています。組織のネットワーク プレフィクスすべてをブランチ オフィスにアドバタイズする代わりに、デフォルト ルートを設定します。宛先プレフィクスがブランチ オフィスのルーティング テーブルにない場合は、デフォルト ルートを介してパケットを転送します。Cisco IP ルーティング テーブルでは、デフォルト ルートはルーティング テーブルの上部に「Gateway of Last Resort」として表示されます。RIP は、自動的に 0.0.0.0 0.0.0.0 ルートを再配布します。

このオプションを選択すると、Prime Fulfillment は、実行プロトコルで PE ルータに対して default-info originate コマンドを設定します(RIP、OSPF、または EIGRP の場合)。Static の場合、Prime Fulfillment は、CE ルータに対して ip route 0.0.0.0 0.0.0.0 <out-going interface name> コマンドを設定します。

RIP の場合に [Give Only Default Routes to CE] オプションをイネーブルにすると、Prime Fulfillment は PE にデフォルト RIP ルートを作成します。デフォルト RIP ルートは PE を指し、CE に送信されます。プロビジョニング要求は、カスタマー ネットワーク内のその他のルーティング プロトコルを CE RIP ルーティング プロトコルに再配布するというオプションを提供します。PE から CE サイトへの RIP ルートは、BGP からその他の VPN サイトに再配布されます。

RIP ルーティングの場合にこのオプションを選択すると、PE は、その他の方法ではルーティングできないトラフィックを PE に送信するように CE に指示します。CE サイトが何らかの理由(別のインターネット フィードがあるなど)でデフォルト ルートを必要とする場合は、このオプションを使用 しない でください。

ステップ 4 [Redistribute Static]:(BGP および RIP)コア BGP ネットワークにスタティック ルートを再配布するかどうかを示します。

RIP の場合に [Redistribute Static] オプションをイネーブルにすると、ソフトウェアはスタティック ルートをコア ネットワーク(BGP を実行)および CE(RIP を実行)にインポートします。

ステップ 5 [Redistribute Connected]:(BGP のみ)VPN 内の CE に接続済みルートを再配布するかどうかを指定します。

BGP の場合に [Redistribute Connected] オプションをイネーブルにすると、ソフトウェアは、接続済みルート(つまり、直接接続された PE または CE へのルート)をその特定の VPN にあるその他すべての CE にインポートします。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。

ステップ 6 [RIP Metrics]:(BGP のみ)適切な RIP メトリック値を入力します。有効なメトリック値は、 1 16 です。

RIP で使用されるメトリックはホップ カウントです。直接接続されたインターフェイスすべてのホップ カウントは 1 です。隣接するルータがホップ カウント 1 の別のネットワークへのルートをアドバタイズする場合、そのネットワークのメトリックは 2 です。これは、送信元ルータが宛先ネットワークに到達するためにそのルータにパケットを送信する必要があるためです。

各ルータがルーティング テーブルをネイバーに送信すると、AS 内で各ネットワークに対するルートを決定できます。ルータからネットワークへの複数のパスが AS 内に存在する場合、ルータは最小のホップ カウントのパスを選択し、その他のパスは無視します。

ステップ 7 [Redistributed Protocols on PE]:ルーティング プロトコルを PE に配布するかどうかを指定します。

再配布により、別のルーティング プロトコルを使用して検出されたルーティング情報を現在のルーティング プロトコルのアップデート メッセージで配信できます。再配布を使用すると、ご使用の IP インターネットワークのすべてのポイントに到達できます。RIP ルータは、別のプロトコルからルーティング情報を受信すると、再配布情報をインポートするプロトコルですでに検出済みの新規ルーティング情報ですべての RIP ネイバーを更新します。

RIP が PE にルーティング情報をインポートする必要があるプロトコルを指定するには、次の手順を実行します。

a. [Redistribute Protocols on PE] オプションから、[Edit] をクリックします。

[PE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[PE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、PE にインポートするプロトコルを選択します。

次のいずれかを選択できます。 Static OSPF 、または EIGRP

Static を再配布します。RIP への再配布に Static ルートを選択すると、Prime Fulfillment は RIP を実行している PE にスタティック ルートをインポートします。

Static ルートを PE に再配布するために必要なパラメータやメトリックはありません。

Open Shortest Path First(OSPF)を再配布します。RIP への再配布に OSPF プロトコルを選択すると、Prime Fulfillment は RIP を実行している PE に OSPF ルートをインポートします。

パラメータ :OSPF プロセス番号

メトリック :1 ~ 16 の範囲内の任意の数値

Enhanced IGRP(EIGRP)を再配布します。RIP への再配布に EIGRP プロトコルを選択すると、Prime Fulfillment は RIP を実行している PE に EIGRP ルートをインポートします。

パラメータ :EIGRP Autonomous System(AS; 自律システム)番号

メトリック :1 ~ 16 の範囲内の任意の数値

d. PE の RIP に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. PE の RIP に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 8 [Redistribute Protocols on CE]:CE にルーティング プロトコルを再配布するかどうかを指定します。

RIP が CE にルーティング情報をインポートする必要があるプロトコルを指定するには、次の手順を実行します。

a. [Redistribute Protocols on CE] オプションから、[Edit] をクリックします。

[CE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[CE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、CE にインポートするプロトコルを選択します。

次のいずれかのプロトコルを選択できます。 Static BGP Connected(ルート) IGRP OSPF EIGRP 、または IS-IS

Static を再配布します。RIP への再配布に Static ルートを選択すると、Prime Fulfillment は RIP を実行している CE にスタティック ルートをインポートします。

Static ルートを CE に再配布するために必要なパラメータはありません。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を再配布します。RIP への再配布に BGP プロトコルを選択すると、Prime Fulfillment は RIP を実行している CE に BGP ルートをインポートします。

パラメータ :BGP Autonomous System(AS; 自律システム)番号

Connected ルートを再配布します。RIP への再配布に Connected ルートを選択すると、Prime Fulfillment は現在のルータに接続されているインターフェイスにすべてのルートをインポートします。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

パラメータ :パラメータは不要

Interior Gateway Routing Protocol(IGRP)を再配布します。RIP への再配布に IGRP (Interior Gateway Routing Protocol)を選択すると、Prime Fulfillment は RIP を実行している CE に IGRP ルートをインポートします。

パラメータ :IGRP Autonomous System(AS; 自律システム)番号

Enhanced IGRP(EIGRP)を再配布します。RIP への再配布に EIGRP プロトコルを選択すると、Prime Fulfillment は RIP を実行している PE に EIGRP ルートをインポートします。

パラメータ :EIGRP Autonomous System(AS; 自律システム)番号

Open Shortest Path First(OSPF)を再配布します。RIP への再配布に OSPF プロトコルを選択すると、Prime Fulfillment は RIP を実行している CE に OSPF ルートをインポートします。

パラメータ :OSPF プロセス番号

Intermediate System-to-Intermediate System(IS-IS)を再配布します。RIP への再配布に IS-IS プロトコルを選択すると、Prime Fulfillment は RIP を実行している CE に IS-IS ルートをインポートします。

パラメータ :IS-IS タグ番号

d. CE の RIP に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. CE の RIP に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 9 このサービス ポリシーの RIP プロトコル設定が終了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 


) PE リンクが、最初は RIP ルーティング プロトコルを使用するように設定され、その後別のルーティング プロトコル(またはスタティック ルーティング)を使用するように変更される場合、Prime Fulfillment は、インターフェイスに関連付けられた RIP CLI コマンドすべてを PE コンフィギュレーション ファイルから除去するわけではありません。特に、サービス要求に関連付けられた VRF が除去されない場合、Prime Fulfillment は RIP コマンドのアドレス ファミリ サブコマンドを除去しません。これは、Prime Fulfillment がアドレス ファミリに基づくネットワーク クラス(つまり、ネットワーク a.0.0.0)を使用して RIP プロトコルを設定するためです。後でルーティング プロトコルが変更される場合、Prime Fulfillment は同じネットワークの他のサービスを除去しません。


BGP プロトコルの選択

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)は、Transmission Control Protocol(TCP; 伝送制御プロトコル)の上でポート 179 を使用して動作します。TCP を使用することにより、BGP では信頼性が高い転送が保証されるため、BGP プロトコル自体にはどのような形式のエラー検出やエラー訂正もありません(TCP がこれらの機能を実行します)。BGP は、複数の中間ホップで分離されているピア間で動作できます。これは、ピアが必ずしも BGP プロトコルを実行していない場合も同様です。

BGP は、2 つのモード、Internal BGP(iBGP; 内部 BGP)または external BGP(eBGP; 外部 BGP)、のいずれかで動作します。このプロトコルは、どちらの場合でも同じパケット形式とデータ構造を使用します。iBGP は単一自律システム内の BGP スピーカー間で使用されますが、eBGP は Inter-AS リンクを介して動作します。

eBGP 拡張機能は、IPv6 およびデュアル スタック サービスの場合にサポートされます。eBGP 拡張機能は BGP ネイバーごとに設定されます。したがって、同じ VRF の IPv4 ネイバーと IPv6 ネイバーを異なる値のセットで設定できます。Prime Fulfillment では、これらのパラメータを BGP ネイバーごとに設定できるようにすることにより、これを行いやすくしています。

サービス ポリシーのルーティング プロトコルとして BGP を指定するには、次のステップを実行します。


ステップ 1 [Routing Protocol] ドロップダウン リストから [BGP] を選択します。

図 24-6 に示されているような、[BGP Routing Protocol] ダイアログボックスが表示されます。

図 24-6 ルーティング プロトコルとして BGP を選択

 

ステップ 2 [CsC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

前のステップで IP アドレッシング スキームが IPv6 に設定されている場合は、この属性を使用できません。

ステップ 3 [Redistribute Static (BGP Only)]:BGP にスタティック ルートを再配布するかどうかを示します。

BGP にスタティック ルートをインポートする場合は、このチェックボックスをオンにします。

ステップ 4 [Redistribute Connected Routes (BGP Only)]:直接接続されたルートを BGP に再配布するかどうかを示します。

[Redistribute Connected] オプションをイネーブルにすると、現在のルータに接続されているインターフェイスにすべてのルートがインポートされます。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Redistribute Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。

ステップ 5 [Default Information Originate]:ドロップダウン リストから適切なオプションを選択して、BGP スピーカー(ローカル ルータ)がネイバーにデフォルト ルートを送信するようにします。

これにより、ネイバー単位設定に default-originate コマンドが挿入されます。

このドロップダウン リストには 3 つの選択肢があります。

[None]。 これはデフォルトの選択肢です。ネイバー単位設定に default-origination コマンドは追加されません。デフォルト ルートは BGP ネイバーにアドバタイズされません。

[Enable]。 Prime Fulfillment GUI に動的に表示される [Route-Policy (Default Information Origination)] フィールドでルート ポリシーの名前を指定できるようにします。ルート ポリシーでは、条件に応じてルート 0.0.0.0 を挿入できます。詳細については、次の使用方法に関する注釈を参照してください。

[Disable]。 default-originate コマンドの特性が親グループから継承されないようにします。

使用方法に関する注釈:

[Route-Policy (Default Information Origination)] フィールドへのルート ポリシーの入力はオプションです。

指定されるルート ポリシーは、そのデバイス上に事前に存在している必要があります。存在しない場合、Prime Fulfillment はそのポリシーに基づくサービス要求の作成時にエラー メッセージを生成します。

default-originate コマンドでは、ローカル ルータにデフォルト ルート(IPv4 では 0.0.0.0/0、IPv6 では ::/0)は必要ありません。ルート ポリシーを指定して default-originate コマンドを使用すると、このポリシーに一致するルートが BGP テーブルに存在する場合、デフォルト ルートがアドバタイズされます。

[Default Information Originate] 属性は、IPv4 と IPv6 の両方のアドレス ファミリの MPLS ポリシーとサービス要求でサポートされます。これは、MPLS PE_CE と PE_No_CE の各ポリシーとサービス要求の場合にのみサポートされます。MVRFCE ポリシーとサービス要求の場合にはサポートされません。

[Default Information Originate] 属性は、IOS XR デバイスでのみサポートされます。

次の Prime Fulfillment テンプレート変数は、この機能をサポートします。

IPv4 の場合:PE_CE_NBR_DEFAULT_INFO_ORIGINATE_ROUTE_POLICY

IPv4 の場合:PE_CE_NBR_DEFAULT_INFO_ORIGINATE

IPv6 の場合:PE_CE_NBR_DEFAULT_INFO_ORIGINATE_ROUTE_POLICY_IPV6

IPv6 の場合:PE_CE_NBR_DEFAULT_INFO_ORIGINATE_IPV6

[Default Information Originate] オプションの使用方法を示すサンプル コンフィグレットについては、「PE L3 MPLS VPN(BGP、Default Information Originate、IOS XR)」を参照してください。

ステップ 6 [CE BGP AS ID]:カスタマーの BGP ネットワークの BGP Autonomous System(AS; 自律システム)番号を入力します。

ここで CE に対して割り当てられる自律番号は、サービス プロバイダーのコア ネットワークの BGP AS 番号と異なっている必要があります。

有効な AS 番号の値として 2 バイト整数値がサポートされます。さらに、Prime Fulfillment は、[0-65535].[0-65535] という形式のリモート 4 バイト AS 番号をサポートします。例:100.65535。このリモート 4 バイト AS 番号は、サービス ポリシーとサービス要求で CE BGP AS 番号としてサポートされます。プラットフォームがリモート 4 バイト AS 番号をサポートしない場合、サービス展開は失敗します。リモート 4 バイト AS 番号は、IOS プラットフォームではサポートされませんが、IOS XR(IPv4 サービスと IPv6 サービスの両方)ではサポートされます。

ステップ 7 [Neighbor Allow-AS In]:適切な場合は、[Neighbor Allow-AS-in] の値を入力します。

[Neighbor Allow-AS-in] 値を入力するときに、サービス プロバイダー Autonomous System(AS; 自律システム)番号が自律システム パス内で発生する最大回数(10 まで)を指定します。

ステップ 8 [Neighbor AS Override]:この VPN に必要な場合は、[Neighbor AS Override] オプションをイネーブルにします。

AS Override 機能を使用すると、MPLS VPN サービス プロバイダーは、カスタマーが別のサイトで同じ AS 番号を使用している場合でも、そのカスタマーとともに BGP ルーティング プロトコルを実行できます。この機能は、VPN カスタマーがプライベートまたはパブリックのいずれかの自律システム番号を使用している場合に使用できます。

[Neighbor AS-Override] オプションをイネーブルにするときに、VPN のすべてのサイトで同じ AS 番号を使用するように VPN Solutions Center を設定します。

ステップ 9 [Route Map/Policy In]:着信ルートに適用するルート マップ(IOS デバイス)またはルート ポリシー(IOS XR デバイス)を入力します。

この属性の詳細については、ステップ 10 の後の使用方法に関する注釈を参照してください。


) この属性は、MVRFCE ポリシーとサービス要求で使用する場合はサポートされません。


ステップ 10 [Route Map/Policy Out]:発信ルートに適用するルート マップ(IOS デバイス)またはルート ポリシー(IOS XR デバイス)を入力します。


) この属性は、MVRFCE ポリシーとサービス要求で使用する場合はサポートされません。サービス要求内の IOS デバイス上の IPv6 の場合にもサポートされません。


IOS デバイスの使用方法に関する注釈(BGP ルート マップ):

[Route Map/Policy In] 属性と [Route Map/Policy Out] 属性は、BGP を PE-CE プロトコルとして使用する IOS デバイスに対して route-map コマンドをサポートするために使用できます。それらの属性は、ルート フィルタリングを目的として着信ルートまたは発信ルートにルート マップを適用するために使用されます。

テキスト フィールドに入力された値は、次の設定例で示されているように、アドレス ファミリまたはルータ コンフィギュレーション モードの neighbor route-map コマンドに変換されます。

neighbor x.x.x.x route-map slmpls-in in
neighbor x.x.x.x route-map no-routes out
 

これらの属性はオプションです。IOS デバイスの場合、デフォルト値は不要です。

次の Prime Fulfillment テンプレート変数は、IOS デバイスの BGP ルート マップをサポートします。

PE_CE_NBR_ROUTE_MAP_IN_NAME

PE_CE_NBR_ROUTE_MAP_OUT_NAME

サービス要求レベルでは、[Route Map/Policy In] 属性は、[Site of Origin] がイネーブルである場合はディセーブルで、クリアされています。[Site of Origin] 属性は、ポリシー レベルでは表示されませんが、サービス要求ワークフローでのみ(および IOS デバイスとコンフィギュレーションが CE を持たない PE で構成されている場合にのみ)表示されます。この動作の詳細については、[Site of Origin] 属性の使用方法に関する注釈を参照してください (P.25-27)

IOS XR デバイスの使用方法に関する注釈(ルート ポリシー):

[Route Map/Policy In] 属性と [Route Map/Policy Out] 属性は、IOS XR デバイスに対して route-policy コマンドをサポートするために使用できます。これらの属性は、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ネイバーに対してアドバタイズまたは BGP ネイバーから受信されるアップデートにルーティング ポリシーを適用する方法を提供します。ポリシーは、ルートをフィルタリングするか、またはルート属性を変更します。着信ルートまたは発信ルートのルーティング ポリシーの名前を指定します。

グローバルに定義された参照可能ルート ポリシー(たとえば、「pass all」)が存在しますが、[Route Map/Policy In] 属性と [Route Map/Policy Out] 属性は、それらのポリシーを独自の固有ルート ポリシーでオーバーライドする手段を提供します。

このポリシーに基づくサービス要求を作成する前に、デバイスに対して実際のルート ポリシーを外部的に設定する必要があります。

次に示すように、GUI からの in/out 値は IOS XR デバイス設定に挿入されます。

route-policy <IN param> in
route-policy <OUT param> out
 

これらの属性はオプションです。IOS XR デバイスの場合、値が指定されない場合、デフォルトで DEFAULT 値に設定されます。

次の Prime Fulfillment テンプレート変数は、IOS XR デバイスの Prime Fulfillment ルート ポリシー コマンドをサポートします。

PE_CE_BGP_Neighbor _Route_Map_Or_Policy_In

PE_CE_BGP_Neighbor _ Route_Map _Or_Policy_Out

ステップ 11 [Neighbor Send Community]:ドロップダウン リストから次のいずれかを選択して、BGP ネイバーにコミュニティ属性を送信します。

[None]。 コミュニティ属性を BGP ネイバーに送信しません。

[Standard]。 標準コミュニティのみを BGP ネイバーに送信します。

[Extended]。 拡張コミュニティのみを BGP ネイバーに送信します。

[Both]。 標準コミュニティと拡張コミュニティの両方を BGP ネイバーに送信します。

このオプションは、PE-CE ルーティング プロトコルが BGP である場合にのみ使用できます。このオプションは、IOS デバイスと IOS XR デバイスの両方に適用できます。このオプションは、IPv4 と IPv6 両方の external BGP(eBGP; 外部 BGP)ネイバーに適用できます。


) この属性は、MVRFCE ポリシーとサービス要求で使用する場合はサポートされません。


ステップ 12 CE にルーティング プロトコルを再配布するかどうかを指定します。

[Redistributed Protocols on CE]:MP-iBGP へのルートの再配布は、ルートが PE ルータと CE ルータ間の BGP 以外の手段で学習される場合にのみ必要です。これには、接続済みサブネットおよびスタティック ルートが含まれます。CE から BGP を介して学習されるルートの場合、再配布は自動的に実行されるため不要です。

BGP が CE にルーティング情報をインポートする必要があるプロトコルを指定するには、次の手順を実行します。

a. [Redistribute Protocols on CE] オプションから、[Edit] をクリックします。

[CE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[CE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、CE にインポートするプロトコルを選択します。

次のいずれかのプロトコルを選択できます。 Static RIP Connected(ルート) IGRP OSPF EIGRP 、または IS-IS

Static を再配布します。BGP への再配布に Static ルートを選択すると、Prime Fulfillment は BGP を実行している CE にスタティック ルートをインポートします。

パラメータ :パラメータは不要

Routing Information Protocol(RIP)を再配布します。BGP への再配布に RIP プロトコルを選択すると、Cisco Prime Fulfillment は BGP を実行している CE に RIP ルートをインポートします。

パラメータ :パラメータは不要

Connected ルートを再配布します。BGP への再配布に Connected ルートを選択すると、Prime Fulfillment は現在のルータに接続されているインターフェイスにすべてのルートをインポートします。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

パラメータ :パラメータは不要

Interior Gateway Routing Protocol(IGRP)を再配布します。BGP への再配布に IGRP プロトコルを選択すると、IP Solution Center は BGP を実行している CE に IGRP ルートをインポートします。

パラメータ :IGRP Autonomous System(AS; 自律システム)番号

Enhanced IGRP(EIGRP)を再配布します。BGP への再配布に EIGRP プロトコルを選択すると、Prime Fulfillment は BGP を実行している CE に EIGRP ルートをインポートします。

パラメータ :EIGRP Autonomous System(AS; 自律システム)番号

Open Shortest Path First(OSPF)を再配布します。BGP への再配布に OSPF プロトコルを選択すると、Prime FulfillmentPrime Fulfillment は BGP を実行している CE に OSPF ルートをインポートします。

パラメータ :OSPF プロセス番号

Intermediate System-to-Intermediate System(IS-IS)を再配布します。BGP への再配布に IS-IS プロトコルを選択すると、Prime Fulfillment は BGP を実行している CE に IS-IS ルートをインポートします。

パラメータ :IS-IS タグ番号

d. CE の BGP に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. PE の BGP に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 13 [Advertise Interval]:eBGP アドバタイズメント間隔を入力します。

値は 0 ~ 600 の範囲の整数で、アドバタイズメント間隔の秒数を指定します。デフォルト設定は、eBGP ピアの場合 30 秒です(明示的に設定されていない場合)。この eBGP 拡張機能は、IOS デバイスと IOS XR PE デバイスの両方の設定に使用できます。

ステップ 14 [Max Prefix Number]:ネイバーから受信できるプレフィクスの最大数を入力します。

使用方法に関する注釈:

この機能を使用すると、ピアから受信されたプレフィクスの数が制限を超えた場合に、ルータはそのピアを停止できます。

範囲は次のとおりです。

IOS デバイスの場合、1 ~ 2147483647

IOS XR デバイスの場合、1 ~ 4294967295

このオプションおよび関連オプションは、IPv4 と IPv6 両方のアドレス ファミリでサポートされます。

[Max Prefix Number]、[Max Prefix Threshold]、[Max Prefix Warning Only]、および [Max Prefix Restart] の各オプションの使用方法を示すサンプル コンフィグレットについては、「PE L3 MPLS VPN(BGP、最大プレフィクス/再開、IOS XR)」を参照してください。

ステップ 15 [Max Prefix Threshold]:[Max Prefix Number] に設定するパーセントを指定する値を入力します。

範囲は 1 ~ 100 % で、デフォルトは 75 % です。このしきい値に達すると、ルータは警告メッセージを生成します。たとえば、[Max Prefix Number] が 20 で [Max Prefix Threshold] が 60 である場合、ネイバーからの BGP 学習ルート数が 20 の 60 %、つまり 12 ルートを超えると、ルータは警告メッセージを生成します。

ステップ 16 [Max Prefix Warning Only]:最大プレフィクス制限を超えたときに、ルータがピアリング セッションを停止する代わりにログ メッセージを生成できるようにするには、このチェックボックスをオンにします。

ステップ 17 [Max Prefix Restart]:設定済み最大プレフィクス制限を超えたために停止したピアリング セッションをルータがいつ自動的に再確立かを指定する値(分単位)を入力します。

範囲は 1 ~ 65535 です。この機能がイネーブルのときには、ネットワーク オペレータの介入は必要ありません。この機能は、指定されている設定済み間隔でディセーブルになっているピアリング セッションの再確立を試みます。ただし、再起動タイマーの設定だけでは、送信しているプレフィクス数が超過しているピアを変更または修正できません。ネットワーク オペレータは、最大プレフィクス制限を再設定するか、そのピアから送信されるプレフィクス数を減らす必要があります。プレフィクスを過剰に送信するように設定されたピアは、ネットワークに不安定な状態をもたらす可能性があり、過剰な数のプレフィクスが急速にアドバタイズおよび除去されます。この場合、ネットワーク オペレータが問題の原因を修正する間に、再起動機能をディセーブルにするように [Max Prefix Warning Only] 属性を設定できます。

ステップ 18 このサービス ポリシーの BGP プロトコル設定が終了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 

OSPF プロトコルの選択

MPLS VPN バックボーンは、純粋な OSPF エリア 0 バックボーンではありません。PE ルータ間に隣接性は形成されません。PE と CE 間のみです。MP-iBGP が PE 間で使用され、すべての OSPF ルートは VPN IPv4 ルートに変換されます。したがって、BGP にルートを再配布しても、これらのルートは同じ VPN の他のメンバー サイトにアドバタイズされるときに外部 OSPF ルートになりません。

サービス ポリシーのルーティング プロトコルとして OSPF を指定するには、次のステップを実行します。


ステップ 1 [Routing Protocol] ドロップダウン リストから [OSPF] を選択します。

図 24-7 に示されているような、[OSPF Routing Protocol] ダイアログボックスが表示されます。

図 24-7 ルーティング プロトコルとして OSPF を選択

 

ステップ 2 [CSC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

ステップ 3 [Give Only Default Routes to CE]:CE にデフォルト ルートのみを与えるかどうかを指定します。

[Give only default routes to CE] オプションをイネーブルにするときに、サイトが 完全なルーティング または デフォルト ルーティング のどちらを必要とするかを示します。完全なルーティングは、VPN 内に存在するその他のルートをサイトが具体的に認識する必要がある場合です。デフォルト ルーティングは、具体的にそのサイトに対するものではないパケットをすべて VPN に送信すれば十分な場合です。

このオプションを選択すると、Prime Fulfillment は、実行プロトコル RIP または EIGRP で PE ルータに対して default-info originate コマンド、および Static の実行プロトコル OSPF で PE ルータに対して default-info originate always コマンドを設定し、CE ルータに対して ip route 0.0.0.0 0.0.0.0 <out-going interface name> コマンドを設定します。

ステップ 4 [Redistribute Static (BGP only)]:OSPF にスタティック ルートを再配布するかどうかを示します。

スタティック ルートを OSPF にインポートする場合は、このチェックボックスをオンにします。

ステップ 5 [Redistribute Connected Routes (BGP only)]:直接接続されたルートを OSPF に再配布するかどうかを示します。

[Redistribute Connected] オプションをイネーブルにすると、現在のルータに接続されているインターフェイスにすべてのルートがインポートされます。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Redistribute Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。

ステップ 6 [Default Information Originate]:OSPF ルーティング ドメインにデフォルト外部ルートを生成するかどうかを示します。

[Default Information Originate] チェックボックスをオンにすると、その他のオプションが GUI に動的に表示されます。

a. ルーティング テーブルにデフォルト ルートがあるかどうかには関係なくデフォルト ルートをアドバタイズするには、[OSPF Default Information Originate Always] をオンにします。

b. [Metric Value] には、デフォルト ルートの生成に使用する OSPF メトリックを入力します。範囲は 1 ~ 16777214 です。

c. [Metric Type] では、ドロップダウン リストから次のいずれかを選択して、デフォルト ルートに関連付けられたリンク タイプを指定します。

[None]

[Type-1 External Route]

[Type-2 External Route]

d. [Default Info Route Policy] には、ルート ポリシーの名前を入力します。

使用方法に関する注釈:

[Default Information Originate] は、MPLS ポリシーとサービス要求ワークフローで使用できます。

すべてのサブオプションは任意指定です。

ルート ポリシー(指定される場合)は、そのデバイス上に事前に存在している必要があります。存在しない場合、この機能を使用してそのポリシーに基づくサービス要求を作成するときにエラーが生成されます。

この機能は、IOS XR デバイスの場合にのみサポートされます。

この機能は、IPv4 アドレス ファミリの場合にのみ使用できます。

次の Prime Fulfillment テンプレート変数は、この機能をサポートします。

PE_CE_OSPF_ METRIC_VALUE

PE_CE_OSPF_METRIC_TYPE

PE_CE_OSPF_ROUTE_POLICY

[Default Information Originate] オプションの使用方法を示すサンプル コンフィグレットについては、「L3 MPLS VPN(OSPF、Default Information Originate、IOS XR)」を参照してください。

ステップ 7 [OSPF Route Policy]:ルート ポリシーを入力します。

使用方法に関する注釈:

これは、任意指定の属性です。

この属性は、IOS デバイスおよび IOS XR PE デバイスでの IPv4 ルーティングの場合にのみサポートされます。

この属性は、OSPF ルート ポリシーの再配布のサポートに使用されます。この属性は、次の例に示すようなデバイス設定に GUI から取得した値を挿入する手段を提供します。

この属性を使用したポリシーに基づくサービス要求展開後の IOS XR 設定例:

vrf edn
rd 11.31.128.80:300
address-family ipv4 unicast
redistribute connected
redistribute ospf 3000 route-policy 'xxxx'
 

IOS 設定例:

address-family ipv4 vrf edn
redistribute connected
redistribute ospf 3000 route-map <route-map>
 

文字列は GUI からそのまま取得されます。検証は実行されません。

有効なルート ポリシーが指定されていない場合、デフォルト ルート ポリシーが使用されます。

このポリシーに基づくサービス要求を作成する前に、デバイスに対して実際のルート ポリシーを外部的に設定する必要があります。

次の Prime Fulfillment テンプレート変数は、OSPF ルート ポリシーの再配布をサポートします。

PE_CE_Ospf_Route_Policy

PE_MVRFCE_Ospf_ Route_Policy

ステップ 8 [OSPF Redistribute Match Internal/External (BGP only)]:OSPF ルートをその他のルーティング ドメインに再配布するときに使用する一致基準を設定するには、ドロップダウン リストから次のいずれかを選択します。

[None]:ルート再配布の一致基準を指定しません。これはデフォルトです。

[Internal only]:Autonomous System(AS; 自律システム)に対して内部的であるルートを照合します。

[External only]:AS に対して外部的であるルートを照合します。

[Both]:AS に対して内部的であるルートおよび外部的であるルートを照合します。

使用方法に関する注釈:

この属性は、IOS デバイスおよび IOS XR PE デバイスでの IPv4 ルーティングの場合にのみサポートされます。

OSPF 内部一致を再配布するための IOS XR 設定例:

vrf edn
rd 11.31.128.80:300
address-family ipv4 unicast
redistribute connected
redistribute ospf 3000 match internal
 

OSPF 内部一致を再配布するための IOS 設定例:

address-family ipv4 vrf edn
redistribute connected
redistribute ospf 3000 match internal
 

OSPF 外部一致を再配布するための IOS XR 設定例:

vrf edn
rd 11.31.128.80:300
address-family ipv4 unicast
redistribute connected
redistribute ospf 3000 match external
 

OSPF 外部一致を再配布するための IOS 設定例:

address-family ipv4 vrf edn
redistribute connected
redistribute ospf 3000 match external 1 external 2
 

[Both] オプションが選択されたときの IOS XR 設定例:

redistribute ospf 3000 match internal external
 

[Both] オプションが選択されたときの IOS 設定例:

redistribute ospf 3000 match internal external 1 external 2
 

このコマンドの IOS XR バリエーションには external type 1 または external type 2 のサポートは存在しませんが、IOS ではそのサポートが存在します。Prime Fulfillment GUI には、 external type 1 または external type 2 を指定するオプションはありません。唯一のオプションは [External only] です。生成されるコンフィグレットは、デバイスが IOS または IOS XR のどちらであるかに基づいて異なります。

Prime Fulfillment テンプレート変数 PE_CE_Ospf_Match_Internal_External は、この属性をサポートします。

ステップ 9 [OSPF Process ID on PE]:PE の OSPF プロセス ID を入力します。

OSPF プロセス ID は、単一ルータ内の各 OSPF ルーティング プロセスに割り当てられる固有の値です。このプロセス ID は PE のみに対して内部的です。この数値は、1 ~ 65535 の範囲内の任意の 10 進数、またはドット付き 10 進表記の数値のいずれかとして入力できます。


) OSPF プロセス ID が Prime Fulfillment でどのように処理されるかについての詳細は、「IGP の OSPF プロセス ID(IOS XR のみ)」を参照してください。


ステップ 10 [Use VRF or VPN Domain ID]:VRF または VPN から取得される OSPF ドメイン ID を使用するには、このチェックボックスをオンにします。

使用方法に関する注釈:

このチェックボックスをオンにしない場合、[OSPF Domain ID on PE] 属性のテキスト フィールド(GUI における次の属性)に PE の OSPF ドメイン ID の値を入力できます。

[Use VPN or VRF Domain ID] チェックボックスをオンにすると、[OSPF Domain ID on PE] 属性のフィールドはディセーブルになります。

OSPF ドメイン ID 機能は、PE-CE ポリシーおよび PE- NoCE ポリシーの場合にのみサポートされます。[OSPF Domain ID] 属性と [OSPF Domain ID on PE] 属性は、ポリシー タイプが PE-CE または PE-NoCE である場合にのみ GUI に表示されます。

OSPF ドメイン ID 機能は、MultiVRF-CE ポリシーの場合はサポートされません。

OSPF ドメイン ID は、IOS XR デバイスでのみサポートされます。IOS デバイスの場合、OSPF ドメイン ID を指定して VRF オブジェクトまたは VPN を使用すると、Prime Fulfillment はこの属性を無視します。

[OSPF Domain ID] 属性は、ルートの再配布元の OSPF ドメインを一意に識別します。このドメイン ID は、カスタマーごとに固有である必要があります。IOS デバイスの場合、IOS がプロセスごとに 1 つの VRF だけを許可するために、デフォルト動作では OSPF プロセス ID を OSPF ドメイン ID と見なします。IOS XR は、プロセスごとに複数の VRF をサポートしています。このため、IOS XR デバイスの場合、各 VRF に対して固有の OSPF ドメイン ID を明示的に設定する必要があります。OSPF プロセスごとに 1 つの VRF を設定することはできますが、これはスケーラブルなソリューションではありません。

タイプ 0005 の OSPF ドメイン ID 設定のみがサポートされます。

ポリシーに基づいて作成されるサービス要求の場合は、次の点に注意してください。

OSPF ドメイン ID 設定はオプションです。[Use VPN or VRF Domain ID] がイネーブルになっておらず、[OSPF Domain ID] フィールドに値が指定されていない場合、Prime Fulfillment は OSPF ドメイン ID 設定を無視します。

[Use VPN or VRF Domain ID] がイネーブルの場合、プロビジョニング時に Prime Fulfillment は選択された VPN オブジェクトから OSPF ドメイン ID を取得します。VPN オブジェクトで OSPF ドメイン ID が設定されていない場合、Prime Fulfillment は OSPF ドメイン ID 設定を無視します。エラー メッセージは生成されません。

[Use VPN or VRF Domain ID] がイネーブルであり、そのリンク(外部)に対して複数の VPN が結合されている場合、Prime Fulfillment は OSPF ドメイン設定を無視します。

ステップ 11 [OSPF Domain ID on PE]:OSPF ドメイン ID を 10 進形式で入力します。

使用方法に関する注釈:

[Use VPN or VRF Domain ID] チェックボックスがオンの場合、このフィールドはディセーブルです。前のステップの注釈を参照してください。

値を 10 進形式で入力します。[Hex value:] フィールドは、対応する 16 進数値を表示する編集不可のテキスト フィールドです。この 16 進数値は、実際にデバイスに表示される値です。

OSPF ドメイン ID は、IOS XR デバイスでのみサポートされます。IOS デバイスの場合、OSPF ドメイン ID を指定して VRF オブジェクトまたは VPN を使用すると、Prime Fulfillment はこの属性を無視します。

ステップ 12 [OSPF Process ID on CE]:CE の OSPF プロセス ID を入力します。

OSPF プロセス ID は、単一ルータ内の各 OSPF ルーティング プロセスに割り当てられる固有の値です。このプロセス ID は CE のみに対して内部的です。この数値は、1 ~ 65535 の範囲内の任意の 10 進数、またはドット付き 10 進表記の数値のいずれかとして入力できます。


) OSPF プロセス ID が Prime Fulfillment でどのように処理されるかについての詳細は、「IGP の OSPF プロセス ID(IOS XR のみ)」を参照してください。


ステップ 13 [OSPF Process Area Number]:OSPF プロセス領域番号を入力します。

PE の OSPF 領域番号は、指定された範囲内の任意の 10 進数、またはドット付き 10 進表記の数値のいずれかとして入力できます。

ステップ 14 [Redistributed Protocols on PE]:必要な場合、PE に再配布されるプロトコルを指定します。


) 再配布の量を制限することは、OSPF 環境では重要である可能性があります。ルートを OSPF に再配布するときは、必ず外部 OSPF ルートとして再配布します。OSPF プロトコルでは OSPF ドメイン全体で外部ルートのフラッディングが発生し、プロトコルのオーバーヘッドおよびその OSPF ドメインに参加しているすべてのルータの CPU 負荷が上昇します。


OSPF が PE にインポートする必要があるプロトコルを指定するには、次のステップを実行します。

a. [Redistribute Protocols on PE] オプションから、[Edit] をクリックします。

[PE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[PE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、PE にインポートするプロトコルを選択します。

次のいずれかを選択できます。 Static EIGRP 、または RIP

Static を再配布します。OSPF への再配布に Static ルートを選択すると、Prime Fulfillment は OSPF を実行している PE にスタティック ルートをインポートします。

Static ルートを PE に再配布するために必要なパラメータやメトリックはありません。

Enhanced IGRP(EIGRP)を再配布します。OSPF への再配布に EIGRP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している PE に EIGRP ルートをインポートします。

パラメータ :EIGRP Autonomous System(AS; 自律システム)番号

メトリック :1 ~ 16777214 の範囲内の任意の数値

RIP を再配布します。OSPF への再配布に RIP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している PE に RIP ルートをインポートします。

パラメータ :パラメータは不要

メトリック :1 ~ 16777214 の範囲内の任意の数値

d. PE の OSPF に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. PE の OSPF に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 15 CE にルーティング プロトコルを再配布するかどうかを指定します。

[Redistribute Protocols on CE]:OSPF が CE にルーティング情報をインポートする必要があるプロトコルを指定するには、次のステップを実行します。

a. [Redistribute Protocols on CE] オプションから、[Edit] をクリックします。

[CE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[CE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、CE にインポートするプロトコルを選択します。

次のいずれかのプロトコルを選択できます。 Static RIP BGP Connected(ルート) IGRP EIGRP 、または IS-IS

Static を再配布します。OSPF への再配布に Static ルートを選択すると、Prime Fulfillment は OSPF を実行している CE にスタティック ルートをインポートします。

Static ルートを CE に再配布するために必要なパラメータはありません。

RIP を再配布します。OSPF への再配布に RIP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している CE に RIP ルートをインポートします。

パラメータ :パラメータは不要

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を再配布します。OSPF への再配布に BGP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している CE に BGP ルートをインポートします。

パラメータ :BGP Autonomous System(AS; 自律システム)番号

Connected ルートを再配布します。OSPF への再配布に Connected ルートを選択すると、Prime Fulfillment は現在のルータに接続されているインターフェイスにすべてのルートをインポートします。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

パラメータ :パラメータは不要

Interior Gateway Routing Protocol(IGRP)を再配布します。OSPF への再配布に IGRP (Interior Gateway Routing Protocol)を選択すると、IP Solution Center は OSPF を実行している CE に IGRP ルートをインポートします。

パラメータ :IGRP Autonomous System(AS; 自律システム)番号

Enhanced IGRP(EIGRP)を再配布します。OSPF への再配布に EIGRP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している CE に EIGRP ルートをインポートします。

パラメータ :EIGRP Autonomous System(AS; 自律システム)番号

Intermediate System-to-Intermediate System(IS-IS)を再配布します。OSPF への再配布に IS-IS プロトコルを選択すると、Prime Fulfillment は OSPF を実行している CE に IS-IS ルートをインポートします。

パラメータ :IS-IS タグ番号

d. CE の OSPF に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. CE の OSPF に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 16 このサービス ポリシーの OSPF プロトコル設定が終了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 

IGP の OSPF プロセス ID(IOS XR のみ)


) この項の情報は、IOS XR デバイスにのみ適用されます。これは、IOS XR が仮想 OSPF プロセスをサポートするためです。IOS デバイスには適用されません。


IOS XR デバイスの場合、Prime Fulfillment は Interior Gateway Protocol(IGP)の OSPF プロセスを分離されたプロセスとして保持します。デフォルトでは、すべての PE-CE リンクの OSPF は別のプロセスです。その他の OSPF プロセスの場合、PE-CE VRF はその親の下にあります。

ユーザの責任で、OSPF プロセス ID を決定およびトラッキングします。Prime Fulfillment は、PE-CE プロセス ID が IGP プロセス ID と異なっていることを確認し、そのプロセス ID がすでに使用されている場合は警告メッセージを表示します。

すでに IGP のために使用されている OSPF プロセス ID をユーザが指定すると、Prime Fulfillment はサービス要求の展開時に警告メッセージを生成します。OSPF プロセスが VRF を参照している場合、その OSPF プロセスは使用中であると見なされます。その場合は、非 IGP プロセスと見なされます。それ以外の場合は、IGP プロセスと見なされます。

Prime Fulfillment は、OSPF プロセスの最大数を設定するための DCPL プロパティを提供します。その DCPL プロパティは、Provisioning¥Service¥mpls¥ospfProcessLimit です。この値のデフォルトは 2 です。Prime Fulfillment は、設定されている OSPF プロセスの数をトラッキングします。制限を超えるか制限に達すると、サービス要求の展開時に警告メッセージが生成されます。警告メッセージの他には、制限を超えることによる影響はありません。


) DCPL 制限は、すべての OSPF プロセス(IGP など)の合計を表します。OSPF プロセス ID がすでに VRF ベース OSPF プロセスとして存在していても、警告は生成されません。複数の VRF ベース OSPF プロセスが存在する場合、警告が生成されます(ospfProcessLimit にデフォルト値 2 が設定されていることを想定)。


次の設定例を参照してください。

例:コア IGP(90)

router ospf 90
nsr
log adjacency changes
router-id 11.31.128.77
bfd minimum-interval 200
bfd multiplier 3
network point-to-point
nsf cisco
auto-cost reference-bandwidth 100000
redistribute rip metric 3 metric-type 1
redistribute isis ntt metric 10 metric-type 1
address-family ipv4 unicast
area 51
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0
network broadcast
!
!
area 0.0.0.0
mpls traffic-eng
interface GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2
network point-to-point
!
interface GigabitEthernet0/0/0/4
network point-to-point
!
interface TenGigE0/3/0/0
!
!
mpls traffic-eng router-id Loopback0
mpls traffic-eng multicast-intact
 

例:PE-CE VRF(3000)

router ospf 3000
vrf edn
log adjacency changes detail
router-id 1.1.1.77
domain-tag 77
area 0.0.0.100
bfd minimum-interval 250
bfd fast-detect
bfd multiplier 3
network point-to-point
stub
interface GigabitEthernet0/0/5/7.101
!
!
!
vrf regus
log adjacency changes detail
router-id 2.2.2.1
domain-tag 3177
network point-to-point
address-family ipv4 unicast
area 51
bfd minimum-interval 250
bfd fast-detect
bfd multiplier 3
network point-to-point
interface Loopback9000
 

) ルータでルート ポリシーが使用されている場合、照合は適用されません。


EIGRP プロトコルの選択

Enhanced IGRP(EIGRP)はハイブリッド ルーティング プロトコルであり、ディスタンス ベクトル プロトコルなどのネットワークを検出しますが(つまり IGRP)、高速再コンバージェンスのためにトポロジカル データベースを維持します。EIGRP は、可変長サブネット マスクと不連続サブネットをサポートします。IP に対して設定されている場合、同じ自律システム内に定義されている IGRP プロセスを使用するルートが自動的に再配布されます。デフォルトでは、EIGRP はクラスフル ネットワーク境界でサブネットを自動集約します。

EIGRP は、IGRP と同じメトリック集積を実行します。ただし、IGRP と EIGRP の間でメトリック計算を確認すると、EIGRP 値の方がかなり大きいことがわかります。EIGRP メトリックを 256 で割ると、同じ IGRP メトリック値が得られます。

EIGRP では、トポロジ変更に関与するすべてのルータを同時に同期化できます。トポロジ変更の影響を受けないルータは、再計算から除外されます。結果として、コンバージェンス時間が非常に速くなります。

サービス ポリシーのルーティング プロトコルとして EIGRP を指定するには、次のステップを実行します。


ステップ 1 [Routing Protocol] ドロップダウン リストから [EIGRP] を選択します。

図 24-8 に示されているような、[EIGRP Routing Protocol] ダイアログボックスが表示されます。

図 24-8 ルーティング プロトコルとして EIGRP を選択

 

ステップ 2 [CSC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

前のステップで IP アドレッシング スキームが IPv6 に設定されている場合は、この属性を使用できません。

ステップ 3 [Redistribute Static]:(BGP のみ)適切な場合、[Redistribute Static (BGP only)] オプションをイネーブルにします。

BGP の場合に [Redistribute Static] オプションをイネーブルにすると、ソフトウェアはスタティック ルートをコア ネットワーク(BGP を実行)にインポートします。

ステップ 4 [Redistribute Connected]:(BGP のみ)適切な場合、[Redistribute Connected (BGP only)] オプションをイネーブルにします。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ PCP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。


) すべての接続済みルートが指定されたルーティング ドメインに無差別に再配布されるため、接続済みルートを再配布すると問題が発生する可能性があります。すべての接続済みルートを再配布することを望まない場合は、distribute-list out ステートメントを使用して、再配布する特定の接続済みルートを識別します。


ステップ 5 [EIGRP Authentication KeyChain Name]:1 つ以上のインターフェイスですべての EIGRP プロトコル トラフィックを認証するためのキーチェーン名を入力します。

使用方法に関する注釈:

キーチェーン名内ではスペース文字およびバックスラッシュ(¥)文字は使用できません。

名前が指定されない場合、EIGRP キーチェーン認証は導入されません。

このオプションは、IPv4 と IPv6 の両方のアドレス ファミリの場合にサポートされます。

このオプションは、IOS XR デバイスの場合にのみ使用できます。

[EIGRP Authentication KeyChain Name] オプションの使用方法を示すサンプル コンフィグレットについては、次を参照してください。
「PE L3 MPLS VPN(EIGRP、認証キーチェーン名、IOS XR)」

ステップ 6 [EIGRP AS ID on PE]:PE の EIGRP 自律システム ID を入力します。

これは固有の 16 ビット数値です。

ステップ 7 [EIGRP AS ID on CE]:CE の EIGRP 自律システム ID を入力します。

これは固有の 16 ビット数値です。

ステップ 8 次の説明に従って、EIGRP メトリックの値を入力します。

EIGRP メトリック

EIGRP は、IGRP の場合と同様にメトリックを使用します。ルート テーブル内の各ルートには関連付けられたメトリックがあります。EIGRP は、IGRP の場合とほとんど同様に複合メトリックを使用しますが、その複合メトリックは乗数 256 で変更されます。[Bandwidth]、[Delay]、[Load]、[Reliability]、および [MTU] は、サブメトリックです。IGRP の場合と同様に、EIGRP は、主として帯域幅と遅延、または数値が最も小さい複合メトリックに基づいて、ルートを選択します。EIGRP は、ルートに対してこのメトリックを計算する場合、ルートへの到達可能距離と呼びます。EIGRP は、ネットワーク内のすべてのルートへの到達可能距離を計算します。

[Bandwidth Metric]:帯域幅はキロビット単位で表されます。帯域幅は、EIGRP が実行しているインターフェイスを正確に表すように静的に設定する必要があります。たとえば、56 kbps インターフェイスおよび T1 インターフェイスのデフォルトの帯域幅は 1,544 kbps です。

[Delay Metric]:遅延はマイクロ秒単位で表されます。遅延も、EIGRP が実行しているインターフェイスを正確に表すように静的に設定する必要があります。インターフェイス上での遅延は、delay time_in_microseconds インターフェイス サブコマンドを使用して調整できます。

[Reliability Metric]:信頼性は 1 ~ 255 の範囲内の動的数値です。ここで、255 は 100 % 信頼性があるリンク、1 は信頼性がないリンクです。

[Loading Metric]:負荷は 1 ~ 255 の範囲内の数値で、インターフェイスの出力負荷を示します。この値は動的で、 show interfaces コマンドを使用して表示できます。値 1 は負荷が最小であるリンクを示し、255 は負荷が 100 % であるリンクを示します。

[MTU Metric]:Maximum Transmission Unit(MTU; 最大伝送ユニット)は、パス内に記録されている最小の MTU 値で、通常は 1500 です。


) IGRP または EIGRP でルーティングの決定に影響する場合は、必ず Bandwidth に対して Delay メトリックを使用します。帯域幅の変更は、その他のルーティング プロトコル(OSPF など)に影響を与える可能性があります。遅延の変更は、IGRP と EIGRP にのみ影響を与えます。


ステップ 9 [Redistributed Protocols on PE]:必要な場合、PE に再配布されるプロトコルを指定します。

IP に対して設定されている場合、同じ自律システム内に定義されている IGRP プロセスを使用するルートが自動的に再配布されます。デフォルトでは、EIGRP はクラスフル ネットワーク境界でサブネットを自動集約します。

EIGRP が PE にインポートする必要があるプロトコルを指定するには、次の手順を実行します。

a. [Redistribute Protocols on PE] オプションから、[Edit] をクリックします。

[PE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[PE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、PE にインポートするプロトコルを選択します。

次のいずれかを選択できます。 Static RIP 、または OSPF

Static を再配布します。EIGRP への再配布に Static ルートを選択すると、Prime Fulfillment は OSPF を実行している PE にスタティック ルートをインポートします。

Static ルートを PE に再配布するために必要なパラメータやメトリックはありません。

RIP を再配布します。EIGRP への再配布に RIP プロトコルを選択すると、Prime Fulfillment は EIGRP を実行している PE に RIP ルートをインポートします。

パラメータ :パラメータは不要

メトリック :1 ~ 16777214 の範囲内の任意の数値

Open Shortest Path First(OSPF)を再配布します。EIGRP への再配布に OSPF プロトコルを選択すると、Prime Fulfillment は EIGRP を実行している PE に OSPF ルートをインポートします。

パラメータ :OSPF プロセス番号

メトリック :1 ~ 16 の範囲内の任意の数値

d. CE の EIGRP に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. PE の EIGRP に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 10 [Redistribute Protocols on CE]:CE にルーティング プロトコルを再配布するかどうかを指定します。

EIGRP が CE にルーティング情報をインポートする必要があるプロトコルを指定するには、次の手順を実行します。

a. [Redistribute Protocols on CE] オプションから、[Edit] をクリックします。

[CE Redistributed Protocol] ダイアログボックスが表示されます。

b. [Add] をクリックします。

[CE Redistributed Protocols] ダイアログボックスが表示されます。

c. [Protocol Type] ドロップダウン リストから、CE にインポートするプロトコルを選択します。

次のいずれかのプロトコルを選択できます。 Static BGP Connected(ルート) IGRP RIP OSPF 、または IS-IS

Static を再配布します。EIGRP への再配布に Static ルートを選択すると、Prime Fulfillment は OSPF を実行している CE にスタティック ルートをインポートします。

Static ルートを CE に再配布するために必要なパラメータはありません。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を再配布します。EIGRP への再配布に BGP プロトコルを選択すると、Prime Fulfillment は OSPF を実行している CE に BGP ルートをインポートします。

パラメータ :BGP Autonomous System(AS; 自律システム)番号

Connected ルートを再配布します。EIGRP への再配布に Connected ルートを選択すると、Prime Fulfillment は現在のルータに接続されているインターフェイスにすべてのルートをインポートします。ネットワークをアドバタイズするが、そのネットワークにルーティング アップデートを送信しない場合は、[Connected] オプションを使用します。接続済みルートを再配布すると、すべての接続済みルートが無差別にルーティング ドメインに再配布されることに注意してください。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。

パラメータ :パラメータは不要

Interior Gateway Routing Protocol(IGRP)を再配布します。EIGRP への再配布に IGRP (Interior Gateway Routing Protocol)を選択すると、IP Solution Center は EIGRP を実行している CE に IGRP ルートをインポートします。

パラメータ :IGRP Autonomous System(AS; 自律システム)番号

RIP を再配布します。EIGRP への再配布に RIP プロトコルを選択すると、Cisco Prime Fulfillment は EIGRP を実行している CE に RIP ルートをインポートします。

パラメータ :パラメータは不要

Open Shortest Path First(OSPF)を再配布します。EIGRP への再配布に OSPF プロトコルを選択すると、Prime Fulfillment は EIGRP を実行している CE に OSPF ルートをインポートします。

パラメータ :OSPF プロセス番号

Intermediate System-to-Intermediate System(IS-IS)を再配布します。EIGRP への再配布に IS-IS プロトコルを選択すると、Prime Fulfillment は EIGRP を実行している CE に IS-IS ルートをインポートします。

パラメータ :IS-IS タグ番号

d. CE の EIGRP に再配布するプロトコルを選択します。

e. 選択したプロトコルに適したパラメータを入力します。

f. [Add] をクリックします。

g. CE の EIGRP に再配布する追加のプロトコルすべてについてこのステップを繰り返し、[OK] をクリックします。

ステップ 11 このサービス ポリシーの EIGRP プロトコル設定が終了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 

[None] を選択:ケーブル サービス

ケーブル リンクを操作する場合、リンクはルーティング プロトコルを実行しません。ルーティング プロトコルを不必要に指定することなくケーブル リンクを介したサービスを設定できるようにするために、サービス ポリシーのルーティング プロトコルのダイアログに [None] オプションが提供されています。

このサービス ポリシーがケーブル サービス用である場合は、次のステップを実行します。


ステップ 1 ルーティング プロトコルのリストから [None] を選択します。

図 24-9 に示されているようなダイアログボックスが表示されます。

図 24-9 ルーティング プロトコルの選択なし

 

ステップ 2 [CSC Support]:Carrier Supporting Carrier(CSC)を使用してサービス ポリシーを定義するには、[MPLS Policy Editor - Routing Information] で [CSC Support] チェックボックスをオンにします。

[CSC Support] をオンにすると、MPLS VPN サービスに対して CSC 機能がイネーブルになります。CSC のプロビジョニングについては、 「Carrier Supporting Carrier のプロビジョニング」 で説明します。

ステップ 3 [Redistribute Static]:プロバイダー コア ネットワーク(BGP を実行)にスタティック ルートを配布する場合は、[Redistribute Static (BGP only)] チェックボックスをオンにします。

ステップ 4 [Redistribute Connected]:ケーブル リンクにはルーティング プロトコルが存在しないため、VPN 内のその他すべての CE に接続済みルートを再配布することを推奨します。これを行うには、[Redistribute Connected (BGP only)] チェックボックスをオンにします。

[Redistribute Connected] オプションをイネーブルにすると、接続済みルート(つまり、直接接続された PE または CE へのルート)は、その特定の VPN にあるその他すべての CE に配布されます。このオプションは、PE と CE 間のルーティング プロトコルが BGP 以外のプロトコルである場合は iBGP 用です。たとえば、ルーティング プロトコルが RIP、OSPF、EIGRP、または Static である場合は、このオプションは、MPLS コアの PE で設定されているルータ BGP 用です。PE ルータでは、MPLS 用に常に実行されているルータ BGP プロセスが 1 つ存在します。このオプションは BGP 用でもあります。

ステップ 5 必要な設定値の指定が完了したら、[Next] をクリックします。

[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。続行するには、「VRF および VPN の情報の定義」を参照してください。


 

VRF および VPN の情報の定義

サービス ポリシーのルーティング プロトコルの定義が完了したら、このサービス ポリシーについて VRF および VPN の情報を指定する必要があります。これを行うには、次のステップを実行します。


ステップ 1 図 24-10 に示されているような、[MPLS Policy VRF and VPN Membership] ダイアログボックスが表示されます。

図 24-10 VRF 情報の指定

 

ステップ 2 以前に定義された VRF オブジェクトから VRF および VPN の属性を設定する場合は、[Use VRF Object] チェックボックスをオンにします。

この機能の詳細については、「独立 VRF の管理」を参照してください。この章では、MPLS VPN サービス ポリシーとサービス要求で独立 VRF オブジェクトを使用する方法について説明します。

VRF オブジェクト機能を使用していない場合は、次のステップの説明に従って VRF および VPN の属性を定義します。

ステップ 3 [Export Map]:必要な場合は、エクスポート ルート マップの名前を入力します。

ここで入力するエクスポート ルート マップの名前は、PE に存在しているエクスポート ルート マップの名前である必要があります。


) IOS は、エクスポート ルート マップを VRF ごとに 1 つのみサポートします。したがって、エクスポート ルート マップは VPN ごとに 1 つのみ存在できます。


Prime Fulfillment ソフトウェアを使用して管理 VPN を定義するときに、Prime Fulfillment は管理 VPN のエクスポート ルート マップを自動的に生成します。Cisco IOS はエクスポート ルート マップを VRF ごとに 1 つのみサポートし、そのルート マップは管理 VPN 用に予約されているため、VRF が管理 VPN に含まれる場合は [Export Map] フィールドは使用不可です。

エクスポート ルート マップはフィルタを適用しません。エクスポート ルート マップを使用して、ルートに関連付けられているルート ターゲットのデフォルト セットをオーバーライドできます。

ステップ 4 [Import Map]:インポート ルート マップの名前を入力します。

ここで入力するインポート ルート マップの名前は、PE に存在しているインポート ルート マップの名前である必要があります。


) IOS は、インポート ルート マップを VRF ごとに 1 つのみサポートします。したがって、インポート ルート マップは VPN ごとに 1 つのみ存在できます。


インポート ルート マップはフィルタを適用します。したがって、この PE の VRF から特定のルートを除外するには、送信ルータにエクスポート ルート マップを設定して現在の VRF にインポートできるルート ターゲットが含まれないようにするか、または PE にインポート ルート マップを作成してそのルートを除外します。

ステップ 5 [Maximum Routes]:この PE の VRF にインポートできるルートの最大数を指定します。


) [Maximum Routes] の値が設定された後は、Prime Fulfillment は別の値をプロビジョニングすることを許可しません。VRF は複数のインターフェイス(リンク)で使用される可能性があるため、この値がリンクに対して設定された後は、その値を手動で変更しないことを推奨します。この VRF を使用する既存または新規サービス要求の最大ルート数の値を変更しようとすると、Prime Fulfillment はエラーを生成します。


ステップ 6 [Maximum Route Threshold]:最大ルート数のしきい値を指定します。

指定された最大ルート数を超えると、Prime Fulfillment は警告メッセージを送信します。

ステップ 7 [VRF Description]:オプションで、現在の VPN の VRF の説明を入力できます。

ステップ 8 [BGP Multipath Load Sharing]:BGP マルチパス ロード シェアリングおよび最大パス設定をイネーブルにするには、このチェックボックスをオンにします。

このオプションの使用方法の詳細については、「BGP マルチパス ロード シェアリングおよび最大パス設定」を参照してください。

ステップ 9 [Allocate New Route Distinguisher]:Route Distinguisher(RD; ルート識別子)は、各 IPv4 ルートに付加される 64 ビットの数値であり、VPN で固有である IP アドレスが MPLS コアでも固有であるようにします。この拡張アドレスは、VPN-IPv4 アドレスとも呼ばれます。

[Allocate New Route Distinguisher] がイネーブルで、一致する VRF 設定がその PE に存在しない場合は、新規 VRF を作成します。存在する場合は再利用します。

[Allocate New Route Distinguisher] がディセーブルである場合、PE の範囲全体にわたって最初の一致する VRF 設定を検出します(PE には無関係)。設定されている PE でこの VRF が検出された場合は、再利用します。PE で検出されない場合は、作成します。


) すでに別の PE ルータで設定されている VRF をサービス要求が取得する可能性があります。


Prime Fulfillment は Route Target(RT; ルート ターゲット)および RD の値を自動的に設定しますが、代わりに [VRF and RD] チェックボックスをオンにすることにより独自の値を割り当てることができます。


) VPN の作成時に固有ルート識別子機能をイネーブルにした場合、[Allocate New Route Distinguisher] オプションはディセーブルです。詳細については、「VPN の固有ルート識別子のイネーブル化」を参照してください。


ステップ 10 [VRF and RD Overwrite]:[VRF and RD Overwrite] オプションをイネーブルにすると、図 24-11 に示されているように、このダイアログボックスに 2 つの新規フィールドが表示され、デフォルトの VRF 名およびルート識別子の値を上書きできます。


注意 正しく行わない場合、VRF 名およびルート識別子のデフォルト値を変更すると、現在実行中のサービス要求が変更されるかディセーブルになる可能性があります。これらの変更は、絶対に必要な場合にのみ注意をして行ってください。


) VPN の作成時に固有ルート識別子機能をイネーブルにした場合、[VRF and RD Overwrite] オプションはディセーブルです。詳細については、「VPN の固有ルート識別子のイネーブル化」を参照してください。


図 24-11 ルーティング プロトコルの選択なし

 

a. [VRF Name]:新規 VRF 名を入力します。次の特殊文字は使用しないことを推奨します
(' ` " < > ( ) [ ] { } / ¥ & ^ !?~ * % = , .+ |)。これにより、特定のデバイスの VRF 名に誤設定が生じる可能性があるためです。

b. [RD Value]:新規 RD 値を入力します。


) MPLS サービス要求では、[VRF and RD Overwrite] 属性の下のサブ属性(つまり、[VRF Name] 属性と [RD Value] 属性)に一度値を指定してサービス要求を保存すると、これらのフィールドは両方ともディセーブルになり、編集不可になります。[VRF Name] および [RD Value] のデフォルト値を変更すると、現在実行中のサービス要求を変更またはディセーブルにする可能性があるために、この動作は導入されました。したがって、展開済みサービス要求でこれらの値を変更する必要がある場合の回避策は、そのサービス要求をデコミッションおよび削除し、新規サービス要求を作成することです。まだ展開されていない新規サービス要求の場合、サービス要求を強制的に削除してから新規値を使用して新規サービスを作成する必要があります。


ステップ 11 [PE VPN Membership]:チェックボックスで、このサービス ポリシーに関連付けられる VPN を指定します。

[PE VPN Membership] の情報には、カスタマー名、VPN 名、サービス プロバイダー名、CE ルーティング コミュニティ名、および CERC タイプがハブ アンド スポーク CERC またはフル メッシュ CERC のどちらであるかが含まれます。

[Is Hub] チェックボックスがオンの場合、CERC タイプがハブ アンド スポークであることを示します。

[Add] ボタンまたは [Delete] ボタンを使用して、このリストに VPN を追加、またはこのリストから VPN を削除できます。

ステップ 12 テンプレートおよびデータ ファイルがポリシーをサポートできるようにするには、[Next] ボタンをクリックして [Template Association] ウィンドウにアクセスし、「ポリシーのテンプレートの関連付けのイネーブル化」を参照してテンプレートおよびデータ ファイルの処理方法の詳細を参照します。

ステップ 13 VRF および VPN の選択に満足したら、[Finish] をクリックします。

[Policies] ウィンドウが表示されます。


 

MPLS PE-to-CE サービスのサービス ポリシーが定義されたため、サービス オペレータはこのポリシーを使用して PE-CE リンクのサービス要求を作成および展開できるようになりました。詳細については、 「MPLS VPN サービス要求」 を参照してください。

BGP マルチパス ロード シェアリングおよび最大パス設定

Prime Fulfillment は、external BGP(eBGP; 外部 BGP)、internal BGP(iBGP; 内部 BGP)、および external and internal BGP(eiBGP)の場合に、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)マルチパス ロード シェアリングの設定をサポートします。BGP マルチパス ロード シェアリングの追加サポートとして、MPLS は、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)および Virtual Route Forwarding(VRF; 仮想ルーティング転送)テーブルに対して、Provider Edge(PE; プロバイダー エッジ)ルータごとに固有 Route Distinguisher(RD; ルート識別子)を設定することもできます。図 24-12 に示されているように、[BGP Multipath Load Sharing] オプションを使用すると、BGP マルチパス ロード シェアリングをイネーブルまたはディセーブルにできます。

図 24-12 [VRF and VPN Membership] ウィンドウのマルチパス設定オプション

 

[BGP Multipath Load Sharing] チェックボックスがオンの場合、BGP マルチパス アクション、最大パス数、インポート パス数、および不等コスト ルート数に対する追加のフィールドが表示されます。追加のフィールドは、選択した [BGP Multipath Action] オプションに基づいて GUI に動的に表示されます。

既存の BGP マルチパス設定がない場合、これらのフィールドを使用してマルチパス ロード シェアリングを指定すると、PE の VRF に対して新規マルチパス BGP 設定が作成されます。BGP マルチパス設定がすでに存在する場合、このアクションは既存の設定を新規マルチパス値で上書きします。除去オプションを使用すると、PE の VRF の特定タイプの既存 BGP マルチパス設定をすべて削除できます。[BGP Multipath Load Sharing] チェックボックスがオフの場合、BGP マルチパス アクションは実行されません。サービス要求に定義されているマルチパス設定を除去する方法については、「マルチパス設定の除去」を参照してください。

既存の MPLS サービス要求で BGP マルチパス設定が編集されると、同じ VPN メンバーシップを持つ同じデバイス上のすべての MPLS サービス要求は [Requested] 状態に移行します。これにより、IPv4 および IPv6 のマルチパス設定の同期が保たれます。


) IOS XR デバイスの BGP マルチパス サポートについては、「IOS XR デバイスの BGP マルチパス サポート」を参照してください。


BGP マルチパスは、IPv6 およびデュアル スタック サービスの場合にサポートされます。BGP マルチパス設定は、VPN Routing/Forwarding(VRF; VPN ルーティング/転送)インスタンスに対して設定されます。したがって、1 つのパラメータ セットのみを IPv4 サービスと IPv6 サービスの両方に対して設定できます。

次の項では、[BGP Multipath Action] ドロップダウン リストで選択される BGP のタイプで決定される各マルチパス シナリオを説明します。ドロップダウン リストで選択可能なオプションは次のとおりです。

[eBGP]:eBGP のマルチパス設定を指定します。これはデフォルトの選択肢です。

[iBGP]:iBGP のマルチパス設定を指定します。

[eiBGP]:eBGP と iBGP 両方のマルチパス設定を指定します。このオプションを使用すると、eBGP と iBGP 両方に対して最大パス数とインポートパス数の共通の共有値を設定できます。

[eBGP+iBGP]:eBGP と iBGP 両方のマルチパス設定を指定します。このオプションを使用すると、eBGP と iBGP の両方に対して最大パス数とインポート パス数を別々に設定できます。

[Remove]:PE の VRF に対する既存の BGP マルチパス設定をすべて削除します。

これらの各シナリオについて、次に説明します。


) [MPLS Link Editor - VPN and VRF] ウィンドウでのサービス要求の作成時に、[BGP Multipath Load Sharing] チェックボックスがオンの場合、[Force Modify Shared Multipath Attributes] という追加の BGP 属性が GUI に表示されます。この属性の目的は、その他のリンクで使用されている共有 VRF 属性を強制的に変更できるようにすることです。このフィールドは持続されません。この属性は、サービス要求作成時にのみ表示され、ポリシー作成時には表示されません。


eBGP マルチパス

[eBGP] オプションを選択すると、[Maximum Paths] フィールドと [Import Paths] フィールドが表示されます。各項目の意味は次のとおりです。

[Maximum Paths]:ルーティング テーブルで許可されるルートの最大数を指定します。

[Import Paths]:VRF のバックアップ マルチパスとして設定できる冗長パスの数を指定します。


) eBGP マルチパス設定をセットアップするときに、[Maximum Paths] または [Import Paths] のいずれかの値を設定する必要があります。両方のフィールドをブランクにすることはできません。


iBGP マルチパス

[iBGP] オプションを選択すると、[Maximum Paths] フィールド、[Import Paths] フィールド、および [Unequal Cost] フィールドが表示されます。各項目の意味は次のとおりです。

[Maximum Paths]:ルーティング テーブルで許可されるルートの最大数を指定します。iBGP マルチパス設定をセットアップするときに値を指定する必要があります。

[Import Paths]:VRF のバックアップ マルチパスとして設定できる冗長パスの数を指定します。

[Unequal Cost]:不等コスト マルチパスをイネーブルまたはディセーブルにします。不等コスト マルチパスを使用すると、複数の不等コスト パス間でトラフィックを配布し、全体のスループットと信頼性を大きくできます。

eiBGP マルチパス

[eiBGP] オプションを選択すると、[Maximum Paths] フィールドと [Import Paths] フィールドが表示されます。各項目の意味は次のとおりです。

[Maximum Paths]:ルーティング テーブルで許可されるルートの最大数を指定します。eiBGP マルチパス設定をセットアップするときに値を指定する必要があります。

[Import Paths]:VRF のバックアップ マルチパスとして設定できる冗長パスの数を指定します。

eiBGP+iBGP マルチパス

[eiBGP+iBGP] オプションを選択すると、[Maximum Paths] フィールド、[Import Paths] フィールド、および [Unequal Cost] フィールドが表示されます。各項目の意味は次のとおりです。

[Maximum Paths]:ルーティング テーブルで許可されるルートの最大数を指定します。ルートの数は、eBGP と iBGP に対して別々に指定できます。

[Import Paths]:VRF のバックアップ マルチパスとして設定できる冗長パスの数を指定します。パスの数は、eBGP と iBGP に対して別々に指定できます。

[Unequal Cost]:不等コスト マルチパスをイネーブルまたはディセーブルにします。不等コスト マルチパスを使用すると、複数の不等コスト パス間でトラフィックを配布し、全体のスループットと信頼性を大きくできます。


) マルチパス ロード シェアリングをサポートするには、VPN(VRF)の各 PE ルータに固有 Route Distinguisher(RD; ルート識別子)が必要です。この目的は、同じ RD が異なるカスタマーに割り当てられないようにすることです。これにより、同じ RD を同じ VRF に使用できます。つまり、PE 内のすべてのサイトが同じ固有 RD を持つことができます。固有 RD 機能はオプションです。これは、グローバル VPN レベルとサービス要求レベルの両方でイネーブルです。VPN の PE ごとの固有 RD をイネーブルにするために、[Create VPN] ウィンドウには新しい [Enable Unique Route Distinguisher] フィールドが含まれています。この機能の使用方法の詳細については、「VPN の固有ルート識別子のイネーブル化」を参照してください。


IOS XR デバイスの BGP マルチパス サポート

IOS XR デバイスでの BGP マルチパス設定のために、Prime Fulfillment では次の属性がサポートされています。

[Maximum Paths]:IOS XR の場合、この属性の範囲は 2 ~ 8 です。範囲外の値が指定されると、サービス要求を保存できず、エラーが表示されます。サービス要求は [Invalid] 状態に移行しません(展開の実行時に発生します)。

[Unequal Cost]:この属性は iBGP の場合にのみサポートされます。

[Import Paths] 属性は、IOS ではサポートされますが、IOS XR ではサポートされません。

マルチパス設定の除去

[BGP Multipath Action] 属性のドロップダウン リストで [Remove] オプションを選択することにより、マルチパス設定を除去できます。[Remove] オプションは、PE の VRF のマルチパス設定を除去します(以前に設定されている場合)。

サービス要求がマルチパス設定とともに保存されていて、その設定を除去する必要がある場合、[Remove] オプションを使用する必要があります。


) マルチパス設定は、単に [BGP Multipath Load Sharing] チェックボックスをオフにしても除去できません。これを除去するには、[BGP Multipath Action] 属性を [Remove] に設定してから、そのサービス要求を保存する必要があります。[BGP Multipath Load Sharing] チェックボックスは、マルチパス設定を除去した後でのみオフにしてください。


ポリシーのテンプレートの関連付けのイネーブル化

Prime Fulfillment テンプレート機能は、MPLS サービス要求内のリンクに設定されているデバイスにフリーフォーマットの CLI をダウンロードする手段を提供します。テンプレートをイネーブルにすると、テンプレートおよびデータ ファイルを使用して、現在は Prime Fulfillment でサポートされていないコマンドをダウンロードできます。


ステップ 1 ポリシーのテンプレートの関連付けをイネーブルにするには、[MPLS Policy Editor - VRF and VPN Membership] ウィンドウで [Next] ボタンをクリックします。

[Template Association] ウィンドウが表示されます。このウィンドウで、テンプレート サポートをイネーブルにして、任意でテンプレートとデータ ファイルをポリシーに関連付けることができます。テンプレートをポリシーに関連付ける方法、およびこのウィンドウでの機能の使用方法については、「ポリシーおよびサービス要求でのテンプレートおよびデータ ファイルの使用」 を参照してください。

ステップ 2 付録の手順に従ってポリシーのテンプレートおよびデータ ファイルのセットアップが完了したら、[Template Association] ウィンドウで [Finish] をクリックして閉じます。

[Policies] ウィンドウが表示されます。


 

MPLS PE-to-CE サービスのサービス ポリシーが定義されたため、サービス オペレータはこのポリシーを使用して PE-CE リンクのサービス要求を作成および展開できるようになりました。詳細については、 「MPLS VPN サービス要求」 を参照してください。