Cisco Prime Fulfillment ユーザ ガイド 6.1
サンプル コンフィグレット
サンプル コンフィグレット
発行日;2012/05/08 | 英語版ドキュメント(2011/11/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

サンプル コンフィグレット

概要

L2 Access into L3 MPLS VPN

CE-PE L3 MPLS VPN(フル メッシュを使用した BGP)

CE-PE L3 MPLS VPN(SOO を使用した BGP)

CE-PE L3 MPLS VPN

N-PE L3 MPLS VPN(IPv4、IOS XR、OSPF)

N-PE L3 MPLS VPN(IPv6、IOS XR、EIGRP)

PE L3 MPLS VPN(デュアルスタック、Static(IPv4)、BGP(IPv6)、IOS)

CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS)

CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS XR)

PE L3 MPLS VPN(マルチキャスト、IPv4/IPv6 がイネーブルの VPN、IOS XR)

PE L3 MPLS VPN(スタティック、IOS、IPv6)

PE L3 MPLS VPN(BGP、IOS)

PE L3 MPLS VPN(BGP、IOS、IPv6)

PE L3 MPLS VPN(BGP、IOS XR)

PE L3 MPLS VPN(BGP、RD フォーマット、IOS XR)

PE L3 MPLS VPN(BGP、最大プレフィクス/再開、IOS XR)

PE L3 MPLS VPN(BGP、Default Information Originate、IOS XR)

PE L3 MPLS VPN(OSPF、IOS)

PE L3 MPLS VPN(OSPF、IOS XR)

L3 MPLS VPN(OSPF、Default Information Originate、IOS XR)

PE L3 MPLS VPN(EIGRP、認証キーチェーン名、IOS XR)

PE L3 MPLS VPN(独立 VRF、IOS XR)

PE L3 MPLS VPN(IPv4 および IPv6 の独立 RT、IOS XR)

PE L3 MPLS VPN(バンドルイーサネット インターフェイス、IOS XR)

PE L3 MPLS VPN(発信インターフェイス + ネクスト ホップ IP アドレス、スタティック ルート コンフィギュレーション、IOS XR および IOS)

サンプル コンフィグレット

この付録では、Prime Fulfillment における MPLS VPN のプロビジョニングのためのサンプル コンフィグレットを示します。次の事項について説明します。

「概要」

「L2 Access into L3 MPLS VPN」

「CE-PE L3 MPLS VPN(フル メッシュを使用した BGP)」

「CE-PE L3 MPLS VPN(SOO を使用した BGP)」

「CE-PE L3 MPLS VPN」

「N-PE L3 MPLS VPN(IPv4、IOS XR、OSPF)」

「N-PE L3 MPLS VPN(IPv6、IOS XR、EIGRP)」

「PE L3 MPLS VPN(デュアルスタック、Static(IPv4)、BGP(IPv6)、IOS)」

「CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS)」

「CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS XR)」

「PE L3 MPLS VPN(マルチキャスト、IPv4/IPv6 がイネーブルの VPN、IOS XR)」

「PE L3 MPLS VPN(スタティック、IOS、IPv6)」

「PE L3 MPLS VPN(BGP、IOS)」

「PE L3 MPLS VPN(BGP、IOS、IPv6)」

「PE L3 MPLS VPN(BGP、IOS XR)」

「PE L3 MPLS VPN(BGP、RD フォーマット、IOS XR)」

「PE L3 MPLS VPN(BGP、最大プレフィクス/再開、IOS XR)」

「PE L3 MPLS VPN(BGP、Default Information Originate、IOS XR)」

「PE L3 MPLS VPN(OSPF、IOS)」

「PE L3 MPLS VPN(OSPF、IOS XR)」

「L3 MPLS VPN(OSPF、Default Information Originate、IOS XR)」

「PE L3 MPLS VPN(EIGRP、認証キーチェーン名、IOS XR)」

「PE L3 MPLS VPN(独立 VRF、IOS XR)」

「PE L3 MPLS VPN(IPv4 および IPv6 の独立 RT、IOS XR)」

「PE L3 MPLS VPN(バンドルイーサネット インターフェイス、IOS XR)」

「PE L3 MPLS VPN(発信インターフェイス + ネクスト ホップ IP アドレス、スタティック ルート コンフィギュレーション、IOS XR および IOS)」

概要

この付録で説明するコンフィグレットは、特定のサービスおよび機能向けに Prime Fulfillment によって生成された CLI を示しています。各コンフィグレット例では、次の情報を提供します。

サービス

機能

デバイス設定(ネットワーク ロール、ハードウェア プラットフォーム、デバイス間の関係、その他の関連情報)

構成内の各デバイスのサンプル コンフィグレット

コメント


) Prime Fulfillment によって生成されるコンフィグレットは、プロビジョニングする必要のある要素と現在デバイス上に存在する要素の差分にすぎません。つまり、関連する CLI がすでにデバイス上に存在する場合、その CLI は関連コンフィグレットには示されません。



) この付録にあるすべての例は MPLS コアを前提としています。


コンフィグレットの表示方法については、「サービス要求コンフィグレットの表示」を参照してください。

L2 Access into L3 MPLS VPN

構成

サービス:L2VPN/メトロ イーサネット。

機能:L3 MPLS VPN へのアクセス。

デバイス設定:

CE は、IOS 12.1(22)EA1 が動作する Cisco 3550。

インターフェイス:F0/13 <-> F0/4。

U-PE は IOS 12.1(22)EA1 が動作する Cisco 3550。

インターフェイス:F0/14。

N-PE は IOS 12.2(18)SXF が動作する Cisco 7609。

インターフェイス:F2/8。

VLAN = 3101。

コンフィグレット

 

CE
U-PE
N-PE
!
vlan 3101
exit
!
interface FastEthernet0/13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1,3101
!
interface Vlan3101
description By VPNSC: Job Id# = 13
ip address 10.19.19.10 255.255.255.252
no shutdown
!
vlan 3101
exit
!
interface FastEthernet0/14
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1,3101
!
interface FastEthernet0/4
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 3101
switchport nonegotiate
cdp enable
no shutdown
mac access-group ISC-FastEthernet0/4 in
!
mac access-list extended ISC-FastEthernet0/4
deny any host 0100.0ccc.cccc
deny any host 0100.0ccc.cccd
deny any host 0100.0ccd.cdd0
deny any host 0180.c200.0000
permit any any
!
ip vrf V5:VPN_sample
rd 100:1502
route-target import 100:1602
route-target import 100:1603
route-target export 100:1602
maximum routes 100 80
!
interface FastEthernet2/8
no shutdown
!
interface FastEthernet2/8.3101
description FastEthernet2/8.3101 dot1q vlan id=3101. By VPNSC: Job Id# = 13
encapsulation dot1Q 3101
ip vrf forwarding V5:VPN_sample
ip address 10.19.19.9 255.255.255.252
no shutdown
!
router bgp 100
address-family ipv4 vrf V5:VPN_sample
redistribute connected
redistribute static

exit-address-family

コメント

VPN リンクの Dot1q カプセル化を使用した IP 番号付きシナリオ。

VRF は N-PE デバイス上で作成されます(-s は、VRF が VPN に、ハブ アンド スポーク トポロジのスポークとして参加することを指定します)。

N-PE では、接続オプションと静的オプションのユーザ設定再配布を使用して、VRF が iBGP ルーティング インスタンスに追加されています。

VRF は、U-PE に面するインターフェイスに関連付けられた転送を使用して、NPE 上で作成されます。

CE-PE L3 MPLS VPN(フル メッシュを使用した BGP)

構成

サービス:L3 MPLS VPN

機能:フル メッシュを使用した CE-PE BGP

デバイス設定:

PE は IOS 12.2(18)SXF が動作する Cisco 7609

インターフェイス:F2/5

CE は、IOS 12.2(22)EA1 が動作する Cisco 3550

インターフェイス:F0/13

ルーティング プロトコル = BGP

コンフィグレット

 

CE
PE
!
vlan 62
exit
!
interface FastEthernet0/13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 62
!
interface Vlan62
description By VPNSC: Job Id# = 29
ip address 10.19.19.42 255.255.255.252
no shutdown
!
router bgp 10
neighbor 10.19.19.41 remote-as 100
!
ip vrf V9:mpls_vpn1
rd 100:1506
route-target import 99:3204
route-target export 99:3204
maximum routes 100 80
!
interface FastEthernet2/5.62
description FastEthernet2/5.62 dot1q vlan id=62. By VPNSC: Job Id# = 29
encapsulation dot1Q 62
ip vrf forwarding V9:mpls_vpn1
ip address 10.19.19.41 255.255.255.252
no shutdown
!
router bgp 100
address-family ipv4 vrf V9:mpls_vpn1
neighbor 10.19.19.42 remote-as 10
neighbor 10.19.19.42 activate
neighbor 10.19.19.42 allowas-in 2
redistribute connected
redistribute static
exit-address-family

コメント

フル メッシュ構成は、VPN ポリシーに対して選択された CERC を利用して作成されます。その結果、ルートターゲットのインポートとルートターゲットのエクスポートは同じです。

BGP は CE-PE アクセス リンク上のルーティング プロトコルです。

VPN リンクの dot1q カプセル化を使用した IP 番号付きシナリオです。

VRF は PE デバイス上で作成されます。

VRF は、CE に面するインターフェイスに関連付けられた転送を使用して、PE 上で作成されます。

CE-PE L3 MPLS VPN(SOO を使用した BGP)

構成

サービス:L3 MPLS VPN

機能:CE-PE

デバイス設定:

PE は IOS 12.2(18)SXF が動作する Cisco 7609

インターフェイス:FE2/3

CE は Prime Fulfillment で作成

インターフェイス:FE1/0/14

ルーティング プロトコル = BGP

VPN = ハブ

コンフィグレット

 

CE
PE
!
vlan 3100
exit
!
interface FastEthernet1/0/14
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1,3100
no shutdown
!
interface Vlan3100
description By VPNSC: Job Id# = 12
ip address 10.19.19.6 255.255.255.252
no shutdown
!
router ospf 3500
network 10.19.19.4 0.0.0.3 area 12345
!
ip vrf V4:VPN_sample-s
rd 100:1501
route-target import 100:1602
route-target export 100:1603
maximum routes 100 80
!
interface FastEthernet2/3.3100
description FastEthernet2/3.3100 dot1q vlan id=3100. By VPNSC: Job Id# = 12
encapsulation dot1Q 3100
ip vrf forwarding V4:VPN_sample-s
ip address 10.19.19.5 255.255.255.252
no shutdown
!
router ospf 2500 vrf V4:VPN_sample-s
redistribute bgp 100 subnets
network 10.19.19.4 0.0.0.3 area 12345
!
router bgp 100
address-family ipv4 vrf V4:VPN_sample-s
redistribute connected
redistribute ospf 2500 vrf V4:VPN_sample-s match internal external 1 external 2
redistribute static
exit-address-family

コメント

VPN リンクの dot1q カプセル化を使用した IP 番号付きシナリオです。

VRF は PE デバイス上で作成されます(VPN はスポークとして参加しています)。

PE で、接続オプションと静的オプションのユーザ設定再配布を使用して、VRF が iBGP ルーティング インスタンスに追加されています。

VRF は、CE に面するインターフェイスに関連付けられた転送を使用して、PE 上で作成されます。

この例は IOS デバイス用です。Site-of-Origin(SoO)は、IOS XR デバイスに対してもサポートされています。IOS XR デバイスでは、得られる構成は異なります。IOS XR デバイスの場合、SOO 用に生成されるコンフィグレットの形式は site-of-origin 64512:500 です。

CE-PE L3 MPLS VPN

構成

サービス:L3 MPLS VPN

機能:CE-PE

デバイス設定:

PE は IOS 12.2(18)SXD7 が動作する Cisco 7603

インターフェイス:FE2/25

CE は IOS 12.2(25)EY2 が動作する Cisco 3750ME-I5-M

インターフェイス:FE1/0/6

VPN = スポーク

コンフィグレット

 

CE
PE
!
vlan 890
exit
!
interface FastEthernet1/0/6
no ip address
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 890
no shutdown
!
interface Vlan890
description By VPNSC: Job Id# = 336 : SR Id# = 336 ip address 10.10.75.2 255.255.255.252 no shutdown !
router bgp 120
neighbor 10.10.75.1 remote-as 100
no auto-summary
!
ip vrf V60:TestVPN-s
rd 100:8069
route-target import 100:1891
route-target export 100:1892
!
interface FastEthernet2/25.890
description FastEthernet2/25.890 dot1q vlan id=890. By VPNSC: Job Id# = 336 : SR Id# = 336 encapsulation dot1Q 890 ip vrf forwarding V60:TestVPN-s ip address 10.10.75.1 255.255.255.252 no shutdown !
router bgp 100
no auto-summary
address-family ipv4 vrf V60:TestVPN-s
neighbor 10.10.75.2 remote-as 120
neighbor 10.10.75.2 activate
neighbor 10.10.75.2 route-map SetSOO_V60:TestVPN-s_100:100 in exit-address-family !
route-map SetSOO_V60:TestVPN-s_100:100 permit 10 set extcommunity soo 100:100

コメント

VPN リンクの dot1q カプセル化を使用した IP 番号付きシナリオです。

VRF は PE デバイス上で作成されます。

CE BGP AS ID が 120 に設定されているポリシーの結果として、 neighbor 10.10.75.2 remote-as 120 が作成されます。

VRF は、CE に面するインターフェイスに関連付けられた転送を使用して、PE 上で作成されます。

PE 上で、BGP は CE ネイバーのルートマップを定義します。

関連付けられているルート マップは、拡張されたコミュニティ属性を SOO に設定します。これはコミュニティ値(Prime Fulfillment で定義された SOO プール値)です。

この例は IOS デバイス用です。Site-of-Origin(SoO)は、IOS XR デバイスに対してもサポートされています。IOS XR デバイスでは、得られる構成は異なります。IOS XR デバイスの場合、SOO 用に生成されるコンフィグレットの形式は site-of-origin 64512:500 です。

N-PE L3 MPLS VPN(IPv4、IOS XR、OSPF)

構成

サービス:L3 MPLS VPN

機能:IOS XR を使用した IPv4

デバイス設定:

N-PE は IOS XR が動作する Cisco 12000 ルータ

ルーティング プロトコル = OSPF

コンフィグレット

 

N-PE

(次の拡張コード例を参照)

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/1.856</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>ICICI_VPN_1</Name>
</Naming>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
</Naming>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>1</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>1</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/1.856</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/1/1.856 dot1q vlan id=856. By VPNSC: Job Id# = 116</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>856</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>ICICI_VPN_1</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>10.10.56.1</IPAddress>
<Mask>255.255.255.252</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>ICICI_VPN_1</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>8064</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<Redistribution>
<ConnectedRoutes/>
<OSPFRouteTable>
<OSPFRoutes>
<Naming>
<OSPFInstanceName>100</OSPFInstanceName>
</Naming>
<RedistType>21</RedistType>
<DefaultMetric>20000</DefaultMetric>
</OSPFRoutes>
</OSPFRouteTable>
<StaticRoutes/>
</Redistribution>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
<OSPF>
<ProcessTable>
<Process>
<Naming>
<InstanceName>100</InstanceName>
</Naming>
<Start>true</Start>
<VRFTable>
<VRF>
<Naming>
<VRFName>ICICI_VPN_1</VRFName>
</Naming>
<VRFStart>true</VRFStart>
<Redistribution>
<RedistributeTable>
<Redistribute>
<Naming>
<ProtocolType>rip</ProtocolType>
<InstanceName>rip</InstanceName>
</Naming>
<Classful>false</Classful>
</Redistribute>
<Redistribute>
<Naming>
<ProtocolType>static</ProtocolType>
<InstanceName>static</InstanceName>
</Naming>
<Classful>false</Classful>
</Redistribute>
</RedistributeTable>
</Redistribution>
<AreaTable>
<Area>
<Naming>
<IntegerID>100</IntegerID>
</Naming>
<NameScopeTable>
<NameScope>
<Naming>
<Interface>GigabitEthernet0/1/1/1.856</Interface>
</Naming>
<Running>true</Running>
</NameScope>
</NameScopeTable>
<Running>true</Running>
</Area>
</AreaTable>
<DefaultInformation>
<AlwaysAdvertise>true</AlwaysAdvertise>
</DefaultInformation>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</OSPF>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

IOS XR では、デバイス設定は XML 形式で指定します。

XML スキーマに関して、IOS XR のバージョンが異なれば、異なる XML コンフィグレットが生成されます。ただし、XML スキーマの変更を除き、設定はほぼ同じです。

考慮すべきさまざまなケースがあります。たとえば、サービス要求がデコミッションまたは変更された場合、XML の構成が若干異なります。

N-PE L3 MPLS VPN(IPv6、IOS XR、EIGRP)

構成

サービス:L3 MPLS VPN

機能:IOS XR 3.5.x が動作する N-PE

デバイス設定:

N-PE は IOS XR 3.5.x が動作する Cisco 12000 ルータ

ルーティング プロトコル = EIGRP

コンフィグレット

 

N-PE

(次の拡張コード例を参照)

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
interface GigabitEthernet0/1/1/1.840
 
ipv6 address fec0:140:9834::/64
 
exit
 
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<EIGRP>
<ProcessTable>
<Process>
<Naming>
<ASNumber>100</ASNumber>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V10:ICICI_VPN</VRFName>
</Naming>
<VRF_AFTable>
<VRF_AF>
<Naming>
<VRF_AFType>IPv4</VRF_AFType>
</Naming>
<AutoSummary/>
</VRF_AF>
</VRF_AFTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</EIGRP>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/1.840</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/1.840</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/1/1.840 dot1q vlan id=840. By VPNSC: Job Id# = 50</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>840</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V10:ICICI_VPN</VRF>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V10:ICICI_VPN</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<Redistribution>
<EIGRPRouteTable>
<EIGRPRoutes>
<Naming>
<EIGRPInstanceName>120</EIGRPInstanceName>
</Naming>
</EIGRPRoutes>
</EIGRPRouteTable>
</Redistribution>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
<EIGRP>
<ProcessTable>
<Process>
<Naming>
<ASNumber>100</ASNumber>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V10:ICICI_VPN</VRFName>
</Naming>
<Enabled>true</Enabled>
<VRF_AFTable>
<VRF_AF>
<Naming>
<VRF_AFType>IPv4</VRF_AFType>
</Naming>
<Enabled>true</Enabled>
<RedistributeTable>
<Redistribute>
<Naming>
<Protocol>BGP</Protocol>
<SecondASNumber>100</SecondASNumber>
</Naming>
<PolicySpecified>false</PolicySpecified>
</Redistribute>
</RedistributeTable>
<DefaultMetric>
<BW>2000</BW>
<Delay>2001</Delay>
<Reliability>200</Reliability>
<Load>201</Load>
<MTU>20000</MTU>
</DefaultMetric>
<InterfaceTable>
<Interface>
<Naming>
<InterfaceName>GigabitEthernet0/1/1/1.840</InterfaceName>
</Naming>
<Enabled>true</Enabled>
</Interface>
</InterfaceTable>
<AutonomousSystem>120</AutonomousSystem>
</VRF_AF>
</VRF_AFTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</EIGRP>
</Configuration>
</Set>
<Commit/>
</Request>Comments
 

IOS XR では、デバイス設定は XML 形式で指定します。

XML スキーマに関して、IOS XR のバージョンが異なれば、異なる XML コンフィグレットが生成されます。ただし、XML スキーマの変更を除き、設定はほぼ同じです。

考慮すべきさまざまなケースがあります。たとえば、サービス要求がデコミッションまたは変更された場合、XML の構成が若干異なります。

PE L3 MPLS VPN(デュアルスタック、Static(IPv4)、BGP(IPv6)、IOS)

構成

サービス:L3 MPLS VPN

機能:VPN ルーティング プロトコルを、IOS デバイス上の静的および BGP(デュアルスタック)として使用する MPLS サービス要求

デバイス設定:

PE は IOS バージョン 12.2(33) SRD2 を実行

インターフェイス:GigabitEthernet2/3.345

ルーティング プロトコル = STATIC(IPv4)、BGP(IPv6)

コンフィグレット

 

PE

(次の拡張コード例を参照)

!
vrf definition UP-Tony-1
rd 1:45
address-family ipv4
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
mdt default 225.4.4.1
mdt data 225.4.4.2 0.0.0.0 threshold 2343
mdt mtu 2345
address-family ipv6
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
!
interface GigabitEthernet2/3.345
description GigabitEthernet2/3.345 dot1q vlan id=345. By VPNSC: Job Id# = 42
encapsulation dot1Q 345
vrf forwarding UP-Tony-1
ip address 44.5.5.5 255.255.255.0
ipv6 address 53:33::3/60
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
no shutdown
!
ip multicast vrf UP-Tony-1 route-limit 12343
!
ip multicast-routing vrf UP-Tony-1
!
ip pim vrf UP-Tony-1 autorp listener
!
ip pim vrf UP-Tony-1 rp-address 4.3.3.4 list132 override
!
router bgp 64512
address-family ipv4 vrf UP-Tony-1
default-information originate
redistribute connected
redistribute static
exit-address-family
address-family ipv6 vrf UP-Tony-1
neighbor 535::2 remote-as 35
neighbor 535::2 activate
neighbor 535::2 as-override
neighbor 535::2 allowas-in 1
neighbor 535::2 send-community both
neighbor 535::2 advertisement-interval 34
neighbor 535::2 maximum-prefix 455 23 restart 2345
redistribute connected
redistribute static
exit-address-family
!
ip route vrf UP-Tony-1 34.5.3.3 255.255.255.255 GigabitEthernet2/3.345 4.5.3.2 234
!
ip route vrf UP-Tony-1 44.3.4.4 255.255.255.255 GigabitEthernet2/3.345 4.5.3.2 23
 

コメント

なし

CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS)

構成

サービス:L3 MPLS VPN

機能:CE-PE Q-in-Q(2 番めの VLAN ID)を PE 上で構成

デバイス設定:

N-PE は、IOS 12.2(33)SRC が動作し、ES20 ライン カードを搭載した Cisco 7606-S

インターフェイス:GE2/0/15

CE は Cisco 2811

インターフェイス:FE0/0

VPN = スポーク

コンフィグレット

 

CE
N-PE
!
interface FastEthernet0/0.158
description FastEthernet0/0.158 dot1q vlan id=158. By VPNSC: Job Id# = 239
encapsulation dot1Q 158
ip address 10.1.1.98 255.255.255.252
no shutdown
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.158
 
!
ip vrf V15:MPLS-1
rd 100:6812
route-target import 100:7000
route-target import 100:7001
route-target export 100:7000
!
interface GigabitEthernet2/0/15.158
description GigabitEthernet2/0/15.158 dot1q vlan id=158. By VPNSC: Job Id# = 239
encapsulation dot1Q 158 second-dot1q 1502
ip vrf forwarding V15:MPLS-1
ip address 10.1.1.97 255.255.255.252
no shutdown
!
router bgp 100
address-family ipv4 vrf V15:MPLS-1
redistribute connected
redistribute static
exit-address-family

コメント

カプセル化は dot1q とし、SVI をディセーブルにする必要があります。

得られる CLI コンフィギュレーション コマンドは次のとおりです。

encapsulation dot1Q <VID-1> second-dot1q <VID-2>
 

VID-1 は、Prime Fulfillment VLAN ID リソース プールまたは手動で割り当てることができます。

VID-2 は手動で追加する必要があります。2 番めの VLAN ID の autopick ID のサポートはありません。

コマンドをサポートしているプラットフォームまたは IOS バージョンとしては次のものがあります(これに限りません)。

ES-20、SIP400 + 2、および 5 ポート GE-V2 SPA を搭載した Cisco 7600/SRBx

ES-20、SIP400 + 2、5 ポート GE-V2 SPA、および 10GE-V2 SPA を搭載した Cisco 7600/SRCx

IOS 12.4 メインラインが動作する Cisco 7200 NPE-G1

IOS 12.4(4)XD が動作する Cisco 7200 NPE-G2

Q-in-Q は IOS XR デバイスでもサポートされます。

2 番めの VLAN ID 用のテンプレート変数 Second_PE_Vlan_ID があります。

サポートされるネットワーク構成には次のものがあります。

PE のみ

管理対象 CE と管理対象外 CE がある PE-CE


) CE が管理対象か管理対象外かにかかわらず、Q-in-Q または 2 番めの VLAN ID は、PE のみで設定されます。


Prime Fulfillment での Q-in-Q のサポートの追加の対象範囲については、「MPLS VPN PE-CE サービス要求の作成」の [Second VLAN ID] 属性の対象範囲を参照してください。

CE-PE L3 MPLS VPN(Q-in-Q/2 番めの VLAN ID、IOS XR)

構成

サービス:L3 MPLS VPN

機能:CE-PE Q-in-Q(2 番めの VLAN ID)を PE 上で構成

デバイス設定:

PE は IOS XR バージョン 3.8.1 または 3.9.0 が動作する Cisco GSR 12008

インターフェイス:TenGigE0/0/0/0

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

vrf V3:Vpn-Apr-30
address-family ipv4 unicast
import route-target
64512:9688
64512:9689
!
export route-target
64512:9688
!
!
address-family ipv6 unicast
import route-target
64512:9688
64512:9689
!
export route-target
64512:9688
!
!
!
interface TenGigE0/0/0/0.1825
description TenGigE0/0/0/0.1825 dot1q vlan id=1825. By VPNSC: Job Id# = 29
vrf V3:Vpn-Apr-30
ipv4 address 6.8.14.15 255.255.255.0
ipv6 address 18::219/64
dot1q vlan 1825 869
!
router bgp 64512
vrf V3:Vpn-Apr-30
rd 64512:9864
address-family ipv4 unicast
redistribute static
!
address-family ipv6 unicast
redistribute static
!
!
!
end
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

vrf V3:Vpn-Apr-30
address-family ipv4 unicast
import route-target
64512:9688
64512:9689
!
export route-target
64512:9688
!
!
address-family ipv6 unicast
import route-target
64512:9688
64512:9689
!
export route-target
64512:9688
!
!
!
interface GigabitEthernet0/3/0/1.488
description GigabitEthernet0/3/0/1.488 dot1q vlan id=488. By VPNSC: Job Id# = 30
vrf V3:Vpn-Apr-30
ipv4 address 25.14.12.4 255.255.255.0
ipv6 address 98::16/64
dot1q vlan 488 758
!
router bgp 64512
address-family vpnv4 unicast
!
address-family vpnv6 unicast
!
vrf V3:Vpn-Apr-30
rd 64512:9864
address-family ipv4 unicast
redistribute static
!
address-family ipv6 unicast
redistribute static
!
!
!
end

XML コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V3:Vpn-Apr-30
address-family ipv6 unicast
import route-target 64512:9688
import route-target 64512:9689
export route-target 64512:9688
exit
interface TenGigE0/0/0/0.1825
ipv6 address 18::219/64
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>TenGigE0/0/0/0.1825</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V3:Vpn-Apr-30</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>9688</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>9689</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>9688</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>TenGigE0/0/0/0.1825</Name>
<Active>act</Active>
</Naming>
<Description>TenGigE0/0/0/0.1825 dot1q vlan id=1825. By VPNSC: Job Id# = 29</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>1825</FirstTag>
<SecondTag>869</SecondTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V3:Vpn-Apr-30</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>6.8.14.15</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V3:Vpn-Apr-30</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>9864</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V3:Vpn-Apr-30
address-family ipv6 unicast
import route-target 64512:9688
import route-target 64512:9689
export route-target 64512:9688
exit
interface GigabitEthernet0/3/0/1.488
ipv6 address 98::16/64
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<InterfaceName>GigabitEthernet0/3/0/1.488</InterfaceName>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<VRFName>V3:Vpn-Apr-30</VRFName>
</Naming>
<Create>true</Create>
<AFTable>
<AF>
<Naming>
<AFName>IPv4</AFName>
<SAFName>Unicast</SAFName>
<TopologyName>default</TopologyName>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>9688</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>9689</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>9688</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AF>
</AFTable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<InterfaceName>GigabitEthernet0/3/0/1.488</InterfaceName>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/3/0/1.488 dot1q vlan id=488. By VPNSC: Job Id# = 30</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>488</FirstTag>
<SecondTag>758</SecondTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V3:Vpn-Apr-30</VRF>
<IPV4Network>
<Addresses>
<Primary>
<Address>25.14.12.4</Address>
<Netmask>255.255.255.0</Netmask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V3:Vpn-Apr-30</VRFName>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>9864</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv4Unicast</AFName>
</Naming>
<Enable>true</Enable>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv6Unicast</AFName>
</Naming>
<Enable>true</Enable>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
<DefaultVRF>
<Global>
<GlobalAFTable>
<GlobalAF>
<Naming>
<AFName>VPNv4Unicast</AFName>
</Naming>
<Enable>true</Enable>
</GlobalAF>
<GlobalAF>
<Naming>
<AFName>VPNv6Unicast</AFName>
</Naming>
<Enable>true</Enable>
</GlobalAF>
</GlobalAFTable>
</Global>
</DefaultVRF>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

なし。

PE L3 MPLS VPN(マルチキャスト、IPv4/IPv6 がイネーブルの VPN、IOS XR)

構成

サービス:L3 MPLS VPN

機能:IOS XR 上のマルチキャスト IPv4 と IPv6 がイネーブルな MPLS サービス要求

デバイス設定:

PE は、IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:GigabitEthernet0/1/0/1

ルーティング プロトコル = なし

コンフィグレット

 

PE

次のコード例は、MPLS サービス要求の CLI および XML コンフィグレットを示します。

CLI コンフィグレット

 
vrf V18:VPN_Verve1
address-family ipv4 unicast
import route-target
100:19916
100:19917
!
export route-target
100:19916
!
!
address-family ipv6 unicast
import route-target
100:19916
100:19917
!
export route-target
100:19916
!
!
!
interface GigabitEthernet0/1/0/1.2589
description GigabitEthernet0/1/0/1.2589 dot1q vlan id=2589. By VPNSC: Job Id# = 54
vrf V18:VPN_Verve1
ipv4 address 115.106.116.122 255.255.255.0
ipv6 address 1125::254/24
dot1q vlan 2589
!
router bgp 100
vrf V18:VPN_Verve1
rd 100:19891
address-family ipv4 unicast
!
address-family ipv6 unicast
!
!
!
multicast-routing
vrf V18:VPN_Verve1 address-family ipv4
interface GigabitEthernet0/1/0/1.2589
enable
!
mdt mtu 8003
mdt data 224.10.0.5/32 threshold 8002
mdt default ipv4 224.10.0.4
!
vrf V18:VPN_Verve1 address-family ipv6
interface GigabitEthernet0/1/0/1.2589
enable
!
mdt mtu 8003
mdt default ipv4 224.10.0.4
!
!
router pim vrf V18:VPN_Verve1 address-family ipv4
rp-address 115.101.110.122 list1
!
router pim vrf V18:VPN_Verve1 address-family ipv6
rp-address 1114::122 list2
!
end
 

XML コンフィグレット

 
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V18:VPN_Verve1
address-family ipv6 unicast
import route-target 100:19916
import route-target 100:19917
export route-target 100:19916
exit
interface GigabitEthernet0/1/0/1.2589
ipv6 address 1125::254/24
multicast-routing
vrf V18:VPN_Verve1
mdt default 224.10.0.4
mdt data 224.10.0.5/32 threshold 8002
mdt mtu 8003
interface GigabitEthernet0/1/0/1.2589
enable
vrf V18:VPN_Verve1 address-family ipv6
mdt default 224.10.0.4
mdt mtu 8003
interface GigabitEthernet0/1/0/1.2589
enable
router pim vrf V18:VPN_Verve1 address-family ipv4 rp-address 115.101.110.122 list1
router pim vrf V18:VPN_Verve1 address-family ipv6 rp-address 1114::122 list2
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/1.2589</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V18:VPN_Verve1</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19916</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19917</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19916</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/1.2589</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/0/1.2589 dot1q vlan id=2589. By VPNSC: Job Id# = 54</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2589</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V18:VPN_Verve1</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>115.106.116.122</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V18:VPN_Verve1</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19891</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

このサービス要求では、コンフィグレットに示すように、マルチキャスト IPv4 と IPv6 がイネーブルな VPN と、スタティック RP を使用しています。

PE L3 MPLS VPN(スタティック、IOS、IPv6)

構成

サービス:L3 MPLS VPN

機能:IPv6 アドレッシングを使用した IOS デバイス上の、VPN ルーティング プロトコルがスタティックに設定された MPLS サービス要求

デバイス設定:

PE は IOS 12.2(33) SRD2 を実行

インターフェイス:GigabitEthernet2/3.455

ルーティング プロトコル = STATIC

コンフィグレット

 

PE
vrf definition test-vpn-1
rd 123:4
address-family ipv6
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
!
interface GigabitEthernet2/3.455
description GigabitEthernet2/3.455 dot1q vlan id=455. By VPNSC: Job Id# = 87
encapsulation dot1Q 455
vrf forwarding test-vpn-1
ipv6 address 455::2/60
no shutdown
!
router bgp 64512
address-family ipv6 vrf test-vpn-1
default-information originate
redistribute connected
redistribute static
exit-address-family
!
ipv6 route vrf test-vpn-1 54::4/128 GigabitEthernet2/3.455 24::5 45
 

コメント

なし。

PE L3 MPLS VPN(BGP、IOS)

構成

サービス:L3 MPLS VPN

機能:VPN ルーティング プロトコルが BGP と設定された IOS 上の MPLS サービス要求

デバイス設定:

PE は IOS バージョン 12.2(17r) S2 が動作する iscind-7600-2

インターフェイス:FastEthernet2/14

ルーティング プロトコル = BGP

コンフィグレット

 

PE
!
ip vrf V21:VPN
rd 100:19894
route-target import 100:19906
route-target import 100:19907
route-target export 100:19906
!
interface FastEthernet2/14.2691
description FastEthernet2/14.2691 dot1q vlan id=2691. By VPNSC: Job Id# = 59
encapsulation dot1Q 2691
ip vrf forwarding V21:VPN
ip address 115.123.102.122 255.255.255.0
no shutdown
!
router bgp 100
address-family ipv4 vrf V21:VPN
neighbor 115.102.123.102 remote-as 100
neighbor 115.102.123.102 activate
neighbor 115.102.123.102 allowas-in 5
neighbor 115.102.123.102 send-community both
neighbor 115.102.123.102 advertisement-interval 122
neighbor 115.102.123.102 maximum-prefix 122 12 restart 122
neighbor 5.2.2.5 route-map TESTING_IN in
neighbor 5.2.2.5 route-map TESTING_OUT out
exit-address-family
 

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

このサービス要求では、Neighbor Send Community 属性( send-community コンフィギュレーション コマンドを生成)は「Both」に設定されています。

PE L3 MPLS VPN(BGP、IOS、IPv6)

構成

サービス:L3 MPLS VPN

機能:IPv6 アドレッシングを使用した IOS デバイス上の、VPN ルーティング プロトコルが BGP として設定された MPLS サービス要求

デバイス設定:

PE は IOS バージョン 12.2(33) SRD2 を実行

インターフェイス:GigabitEthernet2/3.1234

ルーティング プロトコル = BGP

コンフィグレット

 

PE
!
vrf definition VPN-test
rd 12:44
address-family ipv6
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
!
interface GigabitEthernet2/3.1234
description GigabitEthernet2/3.1234 dot1q vlan id=1234. By VPNSC: Job Id# = 86
encapsulation dot1Q 1234
vrf forwarding VPN-test
ipv6 address 23::5/60
no shutdown
!
router bgp 64512
address-family ipv6 vrf VPN-test
neighbor 345::2 remote-as 44
neighbor 345::2 activate
neighbor 345::2 as-override
neighbor 345::2 allowas-in 4
neighbor 345::2 send-community both
neighbor 345::2 advertisement-interval 123
neighbor 345::2 maximum-prefix 4567 23 restart 234
redistribute connected
redistribute static
exit-address-family
 

コメント

なし

PE L3 MPLS VPN(BGP、IOS XR)

構成

サービス:L3 MPLS VPN

機能:IOS XR 上の VPN ルーティング プロトコルが BGP と設定された MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:GigabitEthernet0/1/0/1

ルーティング プロトコル = BGP

コンフィグレット

 

PE

次のコード例は、MPLS サービス要求の CLI および XML コンフィグレットを示します。

CLI コンフィグレット

 
vrf V25:Cisco3
address-family ipv4 unicast
import route-target
100:19926
100:19927
!
export route-target
100:19926
!
!
!
interface GigabitEthernet0/1/0/1.2841
description GigabitEthernet0/1/0/1.2841 dot1q vlan id=2841. By VPNSC: Job Id# = 86
vrf V25:Cisco3
ipv4 address 125.101.122.125 255.255.255.0
dot1q vlan 2841
!
router bgp 100
vrf V25:Cisco3
rd 100:19898
address-family ipv4 unicast
!
neighbor 112.120.102.112
remote-as 100
advertisement-interval 122
address-family ipv4 unicast
route-policy verve in
allowas-in 3
route-policy verve out
site-of-origin 64512:700
!
!
!
!
end
 

XML コンフィグレット

 
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V25:Cisco3
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/1.2841</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V25:Cisco3</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19926</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19927</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19926</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/1.2841</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/0/1.2841 dot1q vlan id=2841. By VPNSC: Job Id# = 86</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2841</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V25:Cisco3</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>125.101.122.125</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V25:Cisco3</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19898</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
<VRFNeighborTable>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>112.120.102.112</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Activate>true</Activate>
</VRFNeighborAF>
</VRFNeighborAFTable>
<RemoteAS>
<AS_XX>0</AS_XX>
<AS_YY>100</AS_YY>
</RemoteAS>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>112.120.102.112</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<AllowASIn>3</AllowASIn>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>112.120.102.112</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<RoutePolicyIn>verve</RoutePolicyIn>
<RoutePolicyIn>verve</RoutePolicyIn>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>112.120.102.112</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<RoutePolicyOut>verve</RoutePolicyOut>
<RoutePolicyOut>verve</RoutePolicyOut>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>112.120.102.112</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Activate>true</Activate>
</VRFNeighborAF>
</VRFNeighborAFTable>
<AdvertisementInterval>122</AdvertisementInterval>
</VRFNeighbor>
</VRFNeighborTable>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

このサービス要求では、Neighbor Send Community 属性( send-community コンフィギュレーション コマンドを生成)は「None」に設定されています。

このサービス要求では、Route Map/Policy In(Out)属性を使用してルートポリシー名が指定されています。


) ルート ポリシーはデバイス上にすでに存在します。


コンフィグレットに示すように、展開はその名前のみを使用しました。

ルートマップ名が指定されていない場合、Prime Fulfillment により IscDefaultPassAll がデフォルトとして追加されます。このデフォルトは、IOS XR デバイスの場合のみ追加されます。IOS デバイスについてはデフォルトが追加されません。

PE L3 MPLS VPN(BGP、RD フォーマット、IOS XR)

構成

サービス:L3 MPLS VPN

機能:IOS XR 上の BGP プロトコルと RD IP アドレス形式を使用した MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.7.1 が動作する Cisco IOX デバイス

インターフェイス:GigabitEthernet

ルーティング プロトコル = BGP

コンフィグレット

 

PE

次のコード例は、MPLS サービス要求の CLI および XML コンフィグレットを示します。

MPLS サービス要求の CLI コンフィグレット

 
vrf V29:vpn_techm_cisco
address-family ipv6 unicast
import route-target
100:15038
100:15039
!
export route-target
100:15038
!
!
!
 
Router bgp 100
vrf V29:vpn_techm_cisco
rd 13.13.13.1:14540
address-family ipv6 unicast
!
!
 

MPLS サービス要求の XML コンフィグレット

 
<VRF>
<Naming>
<Name>V1:vpn1</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type> IPV4Address </Type>
<Addr>13.13.13.1</Addr>
<AddrIndex>14540</AddrIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
 

コメント

なし。

PE L3 MPLS VPN(BGP、最大プレフィクス/再開、IOS XR)

構成

サービス:L3 MPLS VPN

機能:BGP ルーティング プロトコルを使用し、最大プレフィクスと再開値を指定した MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.8.1 または 3.9.0 が動作する IOS XR デバイス

インターフェイス:各種

ルーティング プロトコル = BGP

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

router bgp 64512
vrf V22:27Cerc1
address-family ipv4 unicast
!
address-family ipv6 unicast
!
neighbor 1.2.5.4
address-family ipv4 unicast
maximum-prefix 101 91 restart 81
!
!
neighbor 11::69
address-family ipv6 unicast
maximum-prefix 124 46 restart 6711
!
!
!
!
end
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。これは再開コンフィグレットを示す例です。

router bgp 64512
vrf V23:27Cerc2
address-family ipv4 unicast
!
address-family ipv6 unicast
!
neighbor 8.5.2.33
address-family ipv4 unicast
maximum-prefix 160 80 restart 300
!
!
neighbor 25::9
address-family ipv6 unicast
maximum-prefix 200 26 restart 214
!
!
!
!
end
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。これは警告のみのコンフィグレットを示す例です。

router bgp 64512
vrf V23:27Cerc2
address-family ipv4 unicast
!
address-family ipv6 unicast
!
neighbor 8.5.2.33
address-family ipv4 unicast
maximum-prefix 160 80 warning-only
!
!
neighbor 25::9
address-family ipv6 unicast
maximum-prefix 200 26 warning-only
!
!
!
!
end
 

XML コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Set>
<Configuration Source="CurrentConfig">
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V22:27Cerc1</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
<VRFNeighborTable>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>1.2.5.4</IPV4Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<MaximumPrefixes>
<Value>101</Value>
<WarningPercentage>91</WarningPercentage>
<RestartTime>81</RestartTime>
<WarningOnly>false</WarningOnly>
</MaximumPrefixes>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV6Address>11::69</IPV6Address>
</IPAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<MaximumPrefixes>
<Value>124</Value>
<WarningPercentage>46</WarningPercentage>
<RestartTime>6711</RestartTime>
<WarningOnly>false</WarningOnly>
</MaximumPrefixes>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
</VRFNeighborTable>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Set>
<Configuration Source="CurrentConfig">
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V23:27Cerc2</VRFName>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv4Unicast</AFName>
</Naming>
<Enable>true</Enable>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv6Unicast</AFName>
</Naming>
<Enable>true</Enable>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
<VRFNeighborTable>
<VRFNeighbor>
<Naming>
<NeighborAddress>
<IPV4Address>8.5.2.33</IPV4Address>
</NeighborAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AFName>IPv4Unicast</AFName>
</Naming>
<MaximumPrefixes>
<PrefixLimit>160</PrefixLimit>
<WarningPercentage>80</WarningPercentage>
<RestartTime>300</RestartTime>
<WarningOnly>false</WarningOnly>
</MaximumPrefixes>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<NeighborAddress>
<IPV6Address>25::9</IPV6Address>
</NeighborAddress>
</Naming>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AFName>IPv6Unicast</AFName>
</Naming>
<MaximumPrefixes>
<PrefixLimit>200</PrefixLimit>
<WarningPercentage>26</WarningPercentage>
<RestartTime>214</RestartTime>
<WarningOnly>false</WarningOnly>
</MaximumPrefixes>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
</VRFNeighborTable>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

ユーザが警告のみの値と再開値の両方を指定した場合、Prime Fulfillment は、すべての IOS および IOS XR バージョンの再開値を評価し、優先順位を与えます。

個別の値については(警告のみまたは再開などのいずれかが指定されていれば)、Prime Fulfillment によりそれに応じて設定されます。

PE L3 MPLS VPN(BGP、Default Information Originate、IOS XR)

構成

サービス:L3 MPLS VPN

機能:BGP ルーティング プロトコルを使用し、Default Information Originate 属性の設定を指定した MPLS サービス要求。これにより、BGP スピーカー(ローカル ルータ)はデフォルト ルートをネイバーに送信します。

デバイス設定:

PE は IOS XR バージョン 3.8.1 または 3.9.0 が動作する IOS XR デバイス

インターフェイス:各種

ルーティング プロトコル = BGP

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

vrf V1:mpls
rd 100:345
address-family ipv4 unicast
redistribute static
!
address-family ipv6 unicast
!
neighbor 1.1.1.1
remote-as 100
address-family ipv4 unicast
default-originate route-policy dinesh
!
!
neighbor 1.1.1.2
remote-as 100
address-family ipv4 unicast
default-originate
!
!
 
neighbor 2002::23
remote-as 100
address-family ipv6 unicast
default-originate disable
!
!
!
 

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

vrf V1:mpls
rd 100:345
address-family ipv4 unicast
redistribute static
!
address-family ipv6 unicast
!
neighbor 1.1.1.1
remote-as 100
address-family ipv4 unicast
default-originate route-policy dinesh
!
!
neighbor 1.1.1.2
remote-as 100
address-family ipv4 unicast
default-originate
!
!
 
neighbor 2002::23
remote-as 100
address-family ipv6 unicast
default-originate inheritance-disable
!
!
!

XML コンフィグレットの例

次に、IOS XR 3.8.1 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<BGP MajorVersion="30" MinorVersion="2">
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<BGPRunning>true</BGPRunning>
<VRFTable>
<VRF>
<Naming>
<Name>V1:mpls</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>345</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<StaticRoutes/>
</VRFGlobalAF>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
<VRFNeighborTable>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV4Address>1.1.1.1</IPV4Address>
</IPAddress>
</Naming>
<RemoteAS>
<AS_XX>0</AS_XX>
<AS_YY>100</AS_YY>
</RemoteAS>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Activate>true</Activate>
<DefaultOriginate>
<Enable>true</Enable>
<RoutePolicy>dinesh</RoutePolicy>
</DefaultOriginate>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV6Address>2002::23</IPV6Address>
</IPAddress>
</Naming>
<RemoteAS>
<AS_XX>0</AS_XX>
<AS_YY>100</AS_YY>
</RemoteAS>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Activate>true</Activate>
<DefaultOriginate>
<Enable>true</Enable>
</DefaultOriginate>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
 
<VRFNeighbor>
<Naming>
<IPAddress>
<IPV6Address>2002::23</IPV6Address>
</IPAddress>
</Naming>
<RemoteAS>
<AS_XX>0</AS_XX>
<AS_YY>100</AS_YY>
</RemoteAS>
<VRFNeighborAFTable>
<VRFNeighborAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Activate>true</Activate>
<DefaultOriginate>
<Enable>false</Enable>
</DefaultOriginate>
</VRFNeighborAF>
</VRFNeighborAFTable>
</VRFNeighbor>
</VRFNeighborTable>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>

コメント

なし。

PE L3 MPLS VPN(OSPF、IOS)

構成

サービス:L3 MPLS VPN

機能:VPN ルーティング プロトコルが OSPF に設定された IOS 上の MPLS サービス要求

デバイス設定:

PE は IOS バージョン 12.2(17r) S2 が動作する iscind-7600-2

ルーティング プロトコル = OSPF

コンフィグレット

 

PE
!
no interface FastEthernet2/14.2685
!
interface FastEthernet2/14.2677
description FastEthernet2/14.2677 dot1q vlan id=2677. By VPNSC: Job Id# = 60
encapsulation dot1Q 2677
ip vrf forwarding Tester1
ip address 112.126.102.106 255.255.255.0
no shutdown
!
router ospf 1266 vrf Tester1
redistribute bgp 100 subnets
network 112.126.102.0 0.0.0.255 area 23693
!
router bgp 100
address-family ipv4 vrf Tester1
redistribute ospf 1266 vrf Tester1 metric 1263 route-map verve match internal external 1 external 2
 

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

OSPF 一致条件は「Both」に設定されています。そのため、コンフィギュレーション コマンド internal external1 、および external2 がコンフィグレット中に生成されます。

このコマンドの IOS XR バリエーションに external type 1 または external type 2 コマンドのサポートはありませんが、IOS でサポートされています。

PE L3 MPLS VPN(OSPF、IOS XR)

構成

サービス:L3 MPLS VPN

機能:VPN ルーティング プロトコルが OSPF に設定された IOS XR 上の MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.6.1[00] が動作する mlpe7

インターフェイス:GigabitEthernet0/1/0/1

ルーティング プロトコル = OSPF

コンフィグレット

 

PE

次のコード例は、MPLS サービス要求の CLI および XML コンフィグレットを示します。

MPLS サービス要求の CLI コンフィグレット

 
vrf V28:Cisco5
address-family ipv4 unicast
import route-target
100:19930
100:19931
!
export route-target
100:19930
!
!
!
interface GigabitEthernet0/1/1/4.2693
description GigabitEthernet0/1/1/4.2693 dot1q vlan id=2693. By VPNSC: Job Id# = 90
vrf V28:Cisco5
ipv4 address 123.33.102.112 255.255.255.0
dot1q vlan 2693
!
router ospf 1238
vrf V28:Cisco5
redistribute bgp 100
area 29871
interface GigabitEthernet0/1/1/4.2693
!
!
!
!
router bgp 100
vrf V28:Cisco5
rd 100:19901
address-family ipv4 unicast
redistribute ospf 1238 match internal external metric 2581 route-policy verve
!
!
!
end
 

MPLS サービス要求の XML コンフィグレット

 
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V28:Cisco5
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/4.2693</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V28:Cisco5</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19930</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19931</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19930</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/1/4.2693</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/1/4.2693 dot1q vlan id=2693. By VPNSC: Job Id# = 90</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2693</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V28:Cisco5</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>123.33.102.112</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V28:Cisco5</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19901</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<OSPFRouteTable>
<OSPFRoutes>
<Naming>
<OSPFInstanceName>1238</OSPFInstanceName>
</Naming>
<RoutePolicy/>
<RedistType>21</RedistType>
<DefaultMetric>2581</DefaultMetric>
</OSPFRoutes>
</OSPFRouteTable>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
<OSPF>
<ProcessTable>
<Process>
<Naming>
<InstanceName>1238</InstanceName>
</Naming>
<Start>true</Start>
<VRFTable>
<VRF>
<Naming>
<VRFName>V28:Cisco5</VRFName>
</Naming>
<VRFStart>true</VRFStart>
<Redistribution>
<RedistributeTable>
<Redistribute>
<Naming>
<ProtocolType>bgp</ProtocolType>
<InstanceName>bgp</InstanceName>
<BGP_AS_XX>0</BGP_AS_XX>
<BGP_AS_YY>100</BGP_AS_YY>
</Naming>
<Classful>false</Classful>
</Redistribute>
</RedistributeTable>
</Redistribution>
<AreaTable>
<Area>
<Naming>
<IntegerID>29871</IntegerID>
</Naming>
<NameScopeTable>
<NameScope>
<Naming>
<Interface>GigabitEthernet0/1/1/4.2693</Interface>
</Naming>
<Running>true</Running>
</NameScope>
</NameScopeTable>
<Running>true</Running>
</Area>
</AreaTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</OSPF>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

OSPF 一致条件は「Both」に設定されています。そのため、コンフィギュレーション コマンド internal および external がコンフィグレット中に生成されます。

このコマンドの IOS XR バリエーションには external type 1 または external type 2 のサポートは存在しませんが、IOS ではそのサポートが存在します。

L3 MPLS VPN(OSPF、Default Information Originate、IOS XR)

構成

サービス:L3 MPLS VPN

機能:OSPF ルーティング プロトコルを使用し、Default Information Originate を設定することで、OSPF ルーティング ドメインにデフォルト外部ルートを生成する MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.9.0 が動作する IOS XR デバイス

インターフェイス:各種

ルーティング プロトコル = OSPF

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの CLI コンフィグレットの例を示します。

vrf V35:apr26-vpn9
address-family ipv4 unicast
import route-target
64512:2776
64512:2777
!
export route-target
64512:2776
!
!
address-family ipv6 unicast
import route-target
64512:2776
64512:2777
!
export route-target
64512:2776
!
!
!
interface GigabitEthernet0/15/1/1.947
description GigabitEthernet0/15/1/1.947 dot1q vlan id=947. By VPNSC: Job Id# = 191
vrf V35:apr26-vpn9
ipv4 address 26.27.28.21 255.255.255.0
ipv6 address 2165::541/32
dot1q vlan 947
!
router ospf 1611
vrf V35:apr26-vpn9
default-information originate always metric 652 metric-type 2 route-policy dinesh
area 218
interface GigabitEthernet0/15/1/1.947
!
!
!
!
router bgp 64512
vrf V35:apr26-vpn9
rd 64512:2190
address-family ipv4 unicast
redistribute connected
redistribute static
redistribute ospf 1611 match internal metric 325
!
address-family ipv6 unicast
redistribute static
!
!
!
end

XML コンフィグレットの例

次に、IOS XR 3.9.0 が動作する IOS XR デバイスの XML コンフィグレットの例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V35:apr26-vpn9
address-family ipv6 unicast
import route-target 64512:2776
import route-target 64512:2777
export route-target 64512:2776
exit
interface GigabitEthernet0/15/1/1.947
ipv6 address 2165::541/32
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<VRFName>V35:apr26-vpn9</VRFName>
</Naming>
<Create>true</Create>
<AFTable>
<AF>
<Naming>
<AFName>IPv4</AFName>
<SAFName>Unicast</SAFName>
<TopologyName>default</TopologyName>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>2776</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>2777</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>2776</ASIndex>
</Naming>
<Enable>true</Enable>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AF>
</AFTable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/15/1/1.947 dot1q vlan id=947. By VPNSC: Job Id# = 191</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>947</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V35:apr26-vpn9</VRF>
<IPV4Network>
<Addresses>
<Primary>
<Address>26.27.28.21</Address>
<Netmask>255.255.255.0</Netmask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V35:apr26-vpn9</VRFName>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS_XX>0</AS_XX>
<AS>64512</AS>
<ASIndex>2190</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv4Unicast</AFName>
</Naming>
<Enable>true</Enable>
<ConnectedRoutes/>
<OSPFRouteTable>
<OSPFRoute>
<Naming>
<InstanceName>1611</InstanceName>
</Naming>
<RoutePolicyName/>
<RedistType>01</RedistType>
<DefaultMetric>325</DefaultMetric>
</OSPFRoute>
</OSPFRouteTable>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AFName>IPv6Unicast</AFName>
</Naming>
<Enable>true</Enable>
<StaticRoutes/>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
<OSPF>
<ProcessTable>
<Process>
<Naming>
<ProcessName>1611</ProcessName>
</Naming>
<Start>true</Start>
<VRFTable>
<VRF>
<Naming>
<VRFName>V35:apr26-vpn9</VRFName>
</Naming>
<VRFStart>true</VRFStart>
<DefaultInformation>
<AlwaysAdvertise>true</AlwaysAdvertise>
<Metric>652</Metric>
<MetricType>Type2</MetricType>
<Policy>dinesh</Policy>
</DefaultInformation>
<AreaTable>
<Area>
<Naming>
<AreaID>218</AreaID>
</Naming>
<NameScopeTable>
<NameScope>
<Naming>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
</Naming>
<Running>true</Running>
</NameScope>
</NameScopeTable>
<Running>true</Running>
</Area>
</AreaTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</OSPF>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

なし。

PE L3 MPLS VPN(EIGRP、認証キーチェーン名、IOS XR)

構成

サービス:L3 MPLS VPN

機能:EIGRP ルーティング プロトコルを使用し、インターフェイス上の EIGRP プロトコル トラフィックを認証するためのキーチェーン名を指定した MPLS サービス要求

デバイス設定:

PE は IOS XR バージョン 3.8.1 または 3.9.0 が動作する IOS XR デバイス

インターフェイス:各種

ルーティング プロトコル = EIGRP

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS XR デバイスの CLI コンフィグレット例を示します。

vrf V67:apr26-vpn2
address-family ipv4 unicast
import route-target
64512:2764
64512:2765
!
export route-target
64512:2764
!
!
address-family ipv6 unicast
import route-target
64512:2764
64512:2765
!
export route-target
64512:2764
!
!
!
interface TenGigE0/0/0/3.841
description TenGigE0/0/0/3.841 dot1q vlan id=841. By VPNSC: Job Id# = 188
vrf V67:apr26-vpn2
ipv4 address 31.32.33.23 255.255.255.0
ipv6 address 500::200/32
dot1q vlan 841
!
router bgp 64512
vrf V67:apr26-vpn2
rd 64512:2222
address-family ipv4 unicast
redistribute eigrp 1324
!
address-family ipv6 unicast
redistribute eigrp 1321
!
!
!
router eigrp 100
vrf V67:apr26-vpn2
address-family ipv4
default-metric 1509 1842 196 187 1657
autonomous-system 1324
interface TenGigE0/0/0/3.841
authentication keychain keychain-ipv4
!
!
address-family ipv6
default-metric 1624 1428 186 127 1095
autonomous-system 1321
interface TenGigE0/0/0/3.841
authentication keychain keychain-ipv6
!
!
!
!
end

XML コンフィグレットの例

次に、IOS XR デバイスの XML コンフィグレット例を示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V67:apr26-vpn2
address-family ipv6 unicast
import route-target 64512:2764
import route-target 64512:2765
export route-target 64512:2764
exit
interface TenGigE0/0/0/3.841
ipv6 address 500::200/32
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<EIGRP>
<ProcessTable>
<Process>
<Naming>
<ASNumber>100</ASNumber>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V67:apr26-vpn2</VRFName>
</Naming>
<VRF_AFTable>
<VRF_AF>
<Naming>
<VRF_AFType>IPv4</VRF_AFType>
</Naming>
<AutoSummary/>
</VRF_AF>
<VRF_AF>
<Naming>
<VRF_AFType>IPv6</VRF_AFType>
</Naming>
<AutoSummary/>
</VRF_AF>
</VRF_AFTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</EIGRP>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>TenGigE0/0/0/3.841</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V67:apr26-vpn2</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>2764</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>2765</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>2764</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>TenGigE0/0/0/3.841</Name>
<Active>act</Active>
</Naming>
<Description>TenGigE0/0/0/3.841 dot1q vlan id=841. By VPNSC: Job Id# = 188</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>841</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>V67:apr26-vpn2</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>31.32.33.23</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>64512</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>V67:apr26-vpn2</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>2222</ASIndex>
</RouteDistinguisher>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<EIGRPRouteTable>
<EIGRPRoutes>
<Naming>
<EIGRPInstanceName>1324</EIGRPInstanceName>
</Naming>
</EIGRPRoutes>
</EIGRPRouteTable>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
<EIGRPRouteTable>
<EIGRPRoutes>
<Naming>
<EIGRPInstanceName>1321</EIGRPInstanceName>
</Naming>
</EIGRPRoutes>
</EIGRPRouteTable>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
<EIGRP>
<ProcessTable>
<Process>
<Naming>
<ASNumber>100</ASNumber>
</Naming>
<VRFTable>
<VRF>
<Naming>
<VRFName>V67:apr26-vpn2</VRFName>
</Naming>
<Enabled>true</Enabled>
<VRF_AFTable>
<VRF_AF>
<Naming>
<VRF_AFType>IPv4</VRF_AFType>
</Naming>
<Enabled>true</Enabled>
<RedistributeTable>
<Redistribute>
<Naming>
<Protocol>BGP</Protocol>
<SecondASNumber>64512</SecondASNumber>
</Naming>
<PolicySpecified>false</PolicySpecified>
</Redistribute>
</RedistributeTable>
<DefaultMetric>
<BW>1509</BW>
<Delay>1842</Delay>
<Reliability>196</Reliability>
<Load>187</Load>
<MTU>1657</MTU>
</DefaultMetric>
<InterfaceTable>
<Interface>
<Naming>
<InterfaceName>TenGigE0/0/0/3.841</InterfaceName>
</Naming>
<Enabled>true</Enabled>
<Authentication>
<Keychain>keychain-ipv4</Keychain>
</Authentication>
</Interface>
</InterfaceTable>
<AutonomousSystem>1324</AutonomousSystem>
</VRF_AF>
<VRF_AF>
<Naming>
<VRF_AFType>IPv6</VRF_AFType>
</Naming>
<Enabled>true</Enabled>
<RedistributeTable>
<Redistribute>
<Naming>
<Protocol>BGP</Protocol>
<SecondASNumber>64512</SecondASNumber>
</Naming>
<PolicySpecified>false</PolicySpecified>
</Redistribute>
</RedistributeTable>
<DefaultMetric>
<BW>1624</BW>
<Delay>1428</Delay>
<Reliability>186</Reliability>
<Load>127</Load>
<MTU>1095</MTU>
</DefaultMetric>
<InterfaceTable>
<Interface>
<Naming>
<InterfaceName>TenGigE0/0/0/3.841</InterfaceName>
</Naming>
<Enabled>true</Enabled>
<Authentication>
<Keychain>keychain-ipv6</Keychain>
</Authentication>
</Interface>
</InterfaceTable>
<AutonomousSystem>1321</AutonomousSystem>
</VRF_AF>
</VRF_AFTable>
</VRF>
</VRFTable>
</Process>
</ProcessTable>
</EIGRP>
</Configuration>
</Set>
<Commit/>
</Request>

コメント

なし。

PE L3 MPLS VPN(独立 VRF、IOS XR)

構成

サービス:L3 MPLS VPN

機能:IOS XR 上の独立 VRF を使用した MPLS サービス要求

デバイス設定:

PE は、IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:GigabitEthernet0/1/0/1

ルーティング プロトコル = なし

コンフィグレット

 

PE および VRF

次のコード例は、MPLS サービス要求と VRF オブジェクトの CLI および XML コンフィグレットを示します。

MPLS サービス要求の CLI コンフィグレット

 
interface GigabitEthernet0/1/0/0.3233
description GigabitEthernet0/1/0/0.3233 dot1q vlan id=3233. By VPNSC: Job Id# = 64
vrf VRF112
ipv4 address 126.112.102.102 255.255.255.0
ipv6 address 1365::126/28
dot1q vlan 3233
!
router bgp 100
vrf VRF112
address-family ipv4 unicast
!
address-family ipv6 unicast
!
!
!
multicast-routing
vrf VRF112 address-family ipv4
interface GigabitEthernet0/1/0/0.3233
enable
!
!
vrf VRF112 address-family ipv6
interface GigabitEthernet0/1/0/0.3233
enable
!
!
!
end
 

MPLS サービス要求の XML コンフィグレット

 
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
interface GigabitEthernet0/1/0/0.3233
ipv6 address 1365::126/28
multicast-routing
vrf VRF112
interface GigabitEthernet0/1/0/0.3233
enable
vrf VRF112 address-family ipv6
interface GigabitEthernet0/1/0/0.3233
enable
</Configuration>
</CLI>
<Delete>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/0.3233</Name>
<Active>act</Active>
</Naming>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
</Configuration>
</Delete>
<Set>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceConfiguration>
<Naming>
<Name>GigabitEthernet0/1/0/0.3233</Name>
<Active>act</Active>
</Naming>
<Description>GigabitEthernet0/1/0/0.3233 dot1q vlan id=3233. By VPNSC: Job Id# = 64</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VLANSubConfiguration>
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>3233</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
<VRF>VRF112</VRF>
<IPV4Network>
<Addresses>
<Primary>
<IPAddress>126.112.102.102</IPAddress>
<Mask>255.255.255.0</Mask>
</Primary>
</Addresses>
</IPV4Network>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>VRF112</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv4Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
<VRFGlobalAFTable>
<VRFGlobalAF>
<Naming>
<AF>IPv6Unicast</AF>
</Naming>
<Enabled>true</Enabled>
</VRFGlobalAF>
</VRFGlobalAFTable>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>
</Request>

VRF サービス要求の CLI コンフィグレット

 
vrf VRF112
address-family ipv4 unicast
import route-target
100:19890
100:19891
!
export route-target
100:19890
!
!
address-family ipv6 unicast
import route-target
100:19890
100:19891
!
export route-target
100:19890
!
!
!
router bgp 100
vrf VRF112
rd 112.101.112.101:1263
!
!
multicast-routing
vrf VRF112 address-family ipv4
mdt mtu 8025
mdt data 224.10.0.9/32 threshold 8024
mdt default ipv4 224.10.0.8
!
vrf VRF112 address-family ipv6
mdt mtu 8025
mdt default ipv4 224.10.0.8
!
!
router pim vrf VRF112 address-family ipv4
rp-address 112.101.122.102 list1
!
router pim vrf VRF112 address-family ipv6
rp-address 1253::214 list2
!
end

 

VRF サービス要求の XML コンフィグレット

 
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf VRF112
address-family ipv6 unicast
import route-target 100:19890
import route-target 100:19891
export route-target 100:19890
exit
multicast-routing
vrf VRF112
mdt default 224.10.0.8
mdt data 224.10.0.9/32 threshold 8024
mdt mtu 8025
vrf VRF112 address-family ipv6
mdt default 224.10.0.8
mdt mtu 8025
router pim vrf VRF112 address-family ipv4 rp-address 112.101.122.102 list1
router pim vrf VRF112 address-family ipv6 rp-address 1253::214 list2
</Configuration>
</CLI>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>VRF112</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19890</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19891</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>100</AS>
<ASIndex>19890</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
<BGP>
<AS>
<Naming>
<AS>0</AS>
</Naming>
<FourByteAS>
<Naming>
<AS>100</AS>
</Naming>
<VRFTable>
<VRF>
<Naming>
<Name>VRF112</Name>
</Naming>
<VRFGlobal>
<Exists>true</Exists>
<RouteDistinguisher>
<Type>IPV4Address</Type>
<Addr>112.101.112.101</Addr>
<AddrIndex>1263</AddrIndex>
</RouteDistinguisher>
</VRFGlobal>
</VRF>
</VRFTable>
</FourByteAS>
</AS>
</BGP>
</Configuration>
</Set>
<Commit/>

</Request>

コメント

このサービス要求は MPLS VPN PE_NO_CE ポリシーを使用しています。

このサービス要求では、コンフィグレットに示すように、マルチキャスト IPv4 と IPv6 がイネーブルな VPN と、スタティック RP を使用しています。

PE L3 MPLS VPN(IPv4 および IPv6 の独立 RT、IOS XR)

構成

サービス:L3 MPLS VPN

機能:IPv4 および IPv6 について独立 RT を使用する MPLS サービス要求

デバイス設定:

PE は、IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:各種

ルーティング プロトコル = なし

コンフィグレット

 

PE

次のコード例は、注に示すように、指定した独立 RT 構成の CLI および XML コンフィグレット例を示します。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次の例は、指定した独立 RT 構成の CLI コンフィグレットを示します。

例 1: CERC タイプが IPv4 に設定された CE-PE

address-family ipv4 unicast
import route-target
7777:12345
export route-target
7777:12345
address-family ipv6 unicast

) CERC が IPv6 とタグ付けされていた場合、RT は ipv6 address-family の下で構成されます。


例 2: CERC タイプが IPv4+IPv6 に設定された PE-CE

address-family ipv4 unicast
import route-target
7777:12345
export route-target
7777:12345
address-family ipv6 unicast
import route-target
7777:123456
export route-target
7777:123456

) 追加の IPv4 または IPv6 CERC が選択およびタグ付けされていた場合、適切な address-family CLI の下で上の形式に増分的に追加されます。


例 3: VPN の追加

さらに VPN を構成に追加する場合、次に示すように、VPN 名は文字列 -etc が追加されてコンフィグレットに現れます。

vrf V872:vpn2-etc
address-family ipv4 unicast
import route-target
64512:1005
!
export route-target
64512:1005
!
!

XML コンフィグレットの例

次に、CERC タイプが IPv4+IPv6 に設定された PE-CE の XML コンフィグレット例を示します。重要な XML タグは太字で示します。

<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V6:Verve_VPN32
address-family ipv6 unicast
import route-target <?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<CLI>
<Configuration>
vrf V6:Verve_VPN32
address-family ipv6 unicast
import route-target 64512:25428
import route-target 64512:25429
export route-target 64512:25428
exit
interface GigabitEthernet0/3/0/2.3039
ipv6 address 10::12/24
ipv6 address 10::15/32
ipv6 address 15::20/28
</Configuration>
</CLI>
<Set>
<Configuration Source="CurrentConfig">
<VRFTable>
<VRF>
<Naming>
<Name>V6:Verve_VPN32</Name>
</Naming>
<Create>true</Create>
<AFI_SAFITable>
<AFI_SAFI>
<Naming>
<AFI>IPv4</AFI>
<SAFI>Unicast</SAFI>
<Topology>default</Topology>
</Naming>
<Create>true</Create>
<BGP>
<ImportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>254288</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>254299</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ImportRouteTargets>
<ExportRouteTargets>
<RouteTargetTable>
<RouteTarget>
<Naming>
<Type>AS</Type>
<AS>64512</AS>
<ASIndex>254288</ASIndex>
</Naming>
<True>true</True>
</RouteTarget>
</RouteTargetTable>
</ExportRouteTargets>
</BGP>
</AFI_SAFI>
</AFI_SAFITable>
</VRF>
</VRFTable>
</Configuration>
</Set>
</Request>

コメント

なし。

PE L3 MPLS VPN(バンドルイーサネット インターフェイス、IOS XR)

構成

サービス:L3 MPLS VPN

機能:バンドルイーサネット インターフェイスを使用した MPLS サービス要求

デバイス設定:

PE は、IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:Bundle-Ether147

ルーティング プロトコル = なし

コンフィグレット

 

PE

次のコード例は、注に示すように、バンドルイーサネット インターフェイスの CLI および XML コンフィグレット例を示します。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次の例は、バンドル インターフェイス機能の CLI コンフィグレットです。コンフィグレットは PE デバイスに展開されます。

interface Bundle-Ether147
description Bun
!
interface Bundle-Ether147.369
description subbun
vrf ISC521
ipv4 address 66.174.25.3 255.255.255.254
ipv6 address 2001:4888:10:100::3/64
dot1q vlan 269
!

XML コンフィグレットの例

次に示すのは、バンドル インターフェイス機能の XML コンフィグレット例です。コンフィグレットは PE デバイスに展開されます。

<InterfaceConfiguration>
<Naming>
<Active>act</Active>
<Name>Bundle-Ether147</Name>
</Naming>
<InterfaceVirtual>true</InterfaceVirtual>
<Description>Bun</Description>
</InterfaceConfiguration>
 
<InterfaceConfiguration>
<Naming>
<Active>act</Active>
<Name>Bundle-Ether147.369</Name>
</Naming>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<Description>subbun</Description>
<VRF MajorVersion="3" MinorVersion="3">ISC521</VRF>
<IPV4Network MajorVersion="5" MinorVersion="0">
<Addresses>
<Primary>
<IPAddress>66.174.25.3</IPAddress>
<Mask>255.255.255.254</Mask>
</Primary>
</Addresses>
</IPV4Network>
<VLANSubConfiguration MajorVersion="2" MinorVersion="1">
<VLANIdentifier>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>269</FirstTag>
</VLANIdentifier>
</VLANSubConfiguration>
</InterfaceConfiguration>

コメント

なし。

PE L3 MPLS VPN(発信インターフェイス + ネクスト ホップ IP アドレス、スタティック ルート コンフィギュレーション、IOS XR および IOS)

構成

サービス:L3 MPLS VPN

機能:スタティック ルーティング プロトコルを使用し、発信インターフェイスとネクスト ホップ IP アドレスを指定した MPLS サービス要求

デバイス設定:

PE は、IOS XR バージョン 3.7.1[00] が動作する iscind-12010-1(GSR)

インターフェイス:各種

ルーティング プロトコル = Static

コンフィグレット

 

PE

次のコード例は、CLI および XML コンフィグレットを示しています。すべてのコンフィグレットが PE デバイスに展開されます。

CLI コンフィグレットの例

次に、IOS デバイスの CLI コンフィグレット例を示します。

router bgp 64512
address-family ipv4 vrf V14:July7_VPN
redistribute static
exit-address-family
!
ip route vrf V14:July7_VPN 15.18.16.17 255.255.255.255 GigabitEthernet0/3/0/0 10.12.16.19 78
 

次に、IOS XR デバイスの CLI コンフィグレット例を示します。

router static
vrf V7:techm_vpn
address-family ipv4 unicast
12.23.34.34/32 GigabitEthernet0/3/0/2 10.14.54.18 45
!
address-family ipv6 unicast
15:16:17:13:14:15:17:18/128 GigabitEthernet0/3/0/2 18:12:13:14:16:13:16:14
!

XML コンフィグレットの例

次に示すのは、IPv4 アドレス ファミリの XML コンフィグレット例です。

<VRF>
<Naming>
<VRFName>V1:VPN_June22</VRFName>
</Naming>
<AddressFamily>
<VRFIPV4>
<VRFUnicast>
<VRFPrefixTable>
<VRFPrefix>
<Naming>
<Prefix>
<IPV4Address>10.77.66.58</IPV4Address>
</Prefix>
<Length>32</Length>
</Naming>
<VRFRouteTable>
<VRFNexthopInfoTable>
<VRFNexthopInfo>
<Naming>
<Interface>GigabitEthernet0/3/0/0</Interface>
<Address>
<IPV4Address>10.12.16.19</IPV4Address>
</Address>
</Naming>
<Metric>48</Metric>
</VRFNexthopInfo>
</VRFNexthopInfoTable>
</VRFRouteTable>
</VRFPrefix>
</VRFPrefixTable>
</VRFUnicast>
</VRFIPV4>
</AddressFamily>
</VRF>
 

次に示すのは、IPv6 アドレス ファミリの XML コンフィグレット例です。

<VRF>
<Naming>
<VRFName>V39:techm_vpn</VRFName>
</Naming>
<AddressFamily>
<VRFIPV6>
<VRFUnicast>
<VRFPrefixTable>
<VRFPrefix>
<Naming>
<Prefix>
<IPV6Address>10::19</IPV6Address>
</Prefix>
<Length>128</Length>
</Naming>
<VRFRouteTable>
<VRFNexthopInfoTable>
<VRFNexthopInfo>
<Naming>
<Interface>GigabitEthernet0/3/0/0</Interface>
<Address>
<IPV6Address>45::10</IPV6Address>
</Address>
</Naming>
<Metric>75</Metric>
</VRFNexthopInfo>
</VRFNexthopInfoTable>
</VRFRouteTable>
</VRFPrefix>
</VRFPrefixTable>
</VRFUnicast>
</VRFIPV6>
</AddressFamily>
</VRF>

コメント

なし。