Cisco IP Solution Center L2VPN および Carrier Ethernet ユーザ ガイド 6.0
コンフィグレットの例
コンフィグレットの例
発行日;2012/02/05 | 英語版ドキュメント(2010/09/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

コンフィグレットの例

概要

ERS(EVPL)(ポイントツーポイント)

ERS(EVPL)(ポイントツーポイント、UNI ポート セキュリティ)

ERS(EVPL)(1 対 1 VLAN 変換)

ERS(EVPL)(2 対 1 VLAN 変換)

ERS(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

ERS(EVPL)(L2VPN の NBI 拡張、IOS デバイス)

ERS(EVPL)または EWS(EPL)(IOS XR デバイス)

ERS(EVPL)および EWS(EPL)(E-Line 上のローカル接続)

ERS(EVPL)、EWS(EPL)、ATM、またはフレーム リレー(L2VPN の追加テンプレート変数、IOS および IOS XR デバイス)

EWS(EPL)(ポイントツーポイント)

EWS(EPL)(ポイントツーポイント、UNI ポート セキュリティ、BPDU トンネリング)

EWS(EPL)(ハイブリッド)

EWS(EPL)(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

EWS(EPL)(L2VPN の NBI 拡張、IOS デバイス)

ATM over MPLS(VC モード)

ATM over MPLS(VP モード)

ATM(ポート モード、疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

Frame Relay over MPLS

フレーム リレー(DLCI モード)

VPLS(マルチポイント、ERMS/EVP-LAN)

VPLS(マルチポイント、EMS/EP-LAN)、BPDU トンネリング)

FlexUNI/EVC(疑似回線コア接続、UNI ポート セキュリティ)

FlexUNI/EVC(疑似回線コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン使用)

FlexUNI/EVC(疑似回線コア接続、UNI、および疑似回線トンネリング)

FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティ)

FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティなし)

FlexUNI/EVC(ローカル コア接続、UNI ポート セキュリティ)

FlexUNI/EVC(ローカル コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン)

FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメイン、SVI 上の疑似回線)

FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメインなし、SVI 上の疑似回線なし)

FlexUNI/EVC(AutoPick サービス インスタンス名)

FlexUNI/EVC(AutoPick サービス インスタンス名なし、サービス インスタンス名なし)

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、疑似回線コア接続)

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、ローカル コア接続)

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、VPLS コア接続)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、ポイントツーポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメインなし)

コンフィグレットの例

この付録では、ISC での L2VPN およびメトロ イーサネット サービス プロビジョニングのコンフィグレットの例について説明します。次の事項について説明します。

「概要」

「ERS(EVPL)(ポイントツーポイント)」

「ERS(EVPL)(ポイントツーポイント、UNI ポート セキュリティ)」

「ERS(EVPL)(1 対 1 VLAN 変換)」

「ERS(EVPL)(2 対 1 VLAN 変換)」

「ERS(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)」

「ERS(EVPL)(L2VPN の NBI 拡張、IOS デバイス)」

「ERS(EVPL)または EWS(EPL)(IOS XR デバイス)」

「ERS(EVPL)および EWS(EPL)(E-Line 上のローカル接続)」

「ERS(EVPL)、EWS(EPL)、ATM、またはフレーム リレー(L2VPN の追加テンプレート変数、IOS および IOS XR デバイス)」

「EWS(EPL)(ポイントツーポイント)」

「EWS(EPL)(ポイントツーポイント、UNI ポート セキュリティ、BPDU トンネリング)」

「EWS(EPL)(ハイブリッド)」

「EWS(EPL)(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)」

「EWS(EPL)(L2VPN の NBI 拡張、IOS デバイス)」

「ATM over MPLS(VC モード)」

「ATM over MPLS(VP モード)」

「ATM(ポート モード、疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)」

「Frame Relay over MPLS」

「フレーム リレー(DLCI モード)」

「VPLS(マルチポイント、ERMS/EVP-LAN)」

「VPLS(マルチポイント、EMS/EP-LAN)、BPDU トンネリング)」

「FlexUNI/EVC(疑似回線コア接続、UNI ポート セキュリティ)」

「FlexUNI/EVC(疑似回線コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン使用)」

「FlexUNI/EVC(疑似回線コア接続、UNI、および疑似回線トンネリング)」

「FlexUNI/EVC(疑似回線コア接続、UNI、および疑似回線トンネリング)」

「FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティ)」

「FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティなし)」

「FlexUNI/EVC(ローカル コア接続、UNI ポート セキュリティ)」

「FlexUNI/EVC(ローカル コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン)」

「FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメイン、SVI 上の疑似回線)」

「FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメインなし、SVI 上の疑似回線なし)」

「FlexUNI/EVC(AutoPick サービス インスタンス名なし、サービス インスタンス名なし)」

「FlexUNI/EVC(ユーザ指定のサービス インスタンス名、疑似回線コア接続)」

「FlexUNI/EVC(ユーザ指定のサービス インスタンス名、ローカル コア接続)」

「FlexUNI/EVC(ユーザ指定のサービス インスタンス名、VPLS コア接続)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、ポイントツーポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)」

「FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメインなし)」

概要

この付録で説明されているコンフィグレットは、特定のサービスおよび機能のために ISC が生成した CLI を示します。各コンフィグレットの例では、次の情報が示されます。

サービス

機能

デバイス コンフィギュレーション(ネットワーク ロール、ハードウェア プラットフォーム、デバイスと他の関連情報との関係)

コンフィギュレーションの各デバイスに対するコンフィグレットの例

説明


) ISC によって生成されるコンフィグレットは、デバイス上でプロピジョニングされる必要があるものと、現在存在するものとの間の delta だけです。これは、関連する CLI がすでにデバイス上にある場合は、関連付けられているコンフィグレットに、その CLI が表示されないことを意味します。



) 太字で表示される CLI は、最も関連性が高いコマンドです。



) この付録の例ではすべて、MPLS コアを想定しています。


ERS(EVPL)(ポイントツーポイント)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)(ポイントツーポイント)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA8/17。

U-PE は 12.2(25)EY1 が稼動する Cisco 3750ME で、ポート セキュリティなしです。

インターフェイス:FA1/0/4 ~ FA1/0/23。

L2VPN ポイントツーポイント。

コンフィグレット

 

U-PE
N-PE

vlan 772

exit

!

interface FastEthernet1/0/23

switchport trunk allowed vlan 500,772

!

interface FastEthernet1/0/4

no cdp enable

no keepalive

no ip address

switchport trunk allowed vlan 500,772

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/4 in

!

mac access-list extended ISC-FastEthernet1/0/4

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

vlan 772

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,878

!

interface Vlan772

no ip address

description L2VPN ERS

xconnect 99.99.8.99 89027 encapsulation mpls

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。カスタマー BPDU は、PACL によってブロックされます。

ERS(EVPL)(ポイントツーポイント、UNI ポート セキュリティ)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:UNI ポート セキュリティを備えている ERS(EVPL)(ポイントツーポイント)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、OSM が稼動する Cisco 7600 です。

インターフェイス:FA2/18。

U-PE は、IOS 12.2(25)SEC2 が稼動する Cisco 3550 です。ポート セキュリティはイネーブルにされています。

インターフェイス:FA3/31 ~ FA3/23。

L2VPN ポイントツーポイント。

コンフィグレット

 

U-PE
N-PE

vlan 788

exit

!

interface FastEthernet3/23

no ip address

switchport trunk allowed vlan 783,787-788

!

interface FastEthernet3/31

no cdp enable

no keepalive

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 788

switchport port-security

switchport nonegotiate

switchport port-security maximum 45

switchport port-security aging time 34

switchport port-security violation shutdown

switchport port-security mac-address 3456.3456.5678

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/31 in

!

mac access-list extended ISC-FastEthernet3/31

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

deny any host 1234.3234.3432

permit any any

vlan 788

exit

!

interface FastEthernet2/18

switchport trunk allowed vlan 350,351,430,630,777,780,783,785-788

!

interface Vlan788

no ip address

description L2VPN ERS with UNI port security

xconnect 99.99.5.99 89028 encapsulation mpls

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。カスタマー BPDU は、PACL によってブロックされます。

さまざまな UNI ポート セキュリティ コマンドがプロビジョニングされます。

ユーザ定義の PACL エントリがデフォルト PACL に追加されます。

ERS(EVPL)(1 対 1 VLAN 変換)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:VLAN 1:1 変換を備えている ERS(EVPL)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA8/34。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。NNI ポート(アップリンク)上の VLAN 変換。

インターフェイス:FA1/0/8 ~- GI1/1/1。

L2VPN ポイントツーポイント。

コンフィグレット

 

U-PE
N-PE

!

vlan 123

exit

!

interface FastEthernet1/0/8

no cdp enable

no keepalive

no ip address

switchport trunk allowed vlan 123

switchport nonegotiate

switchport port-security maximum 34

switchport port-security aging time 23

switchport port-security violation protect

switchport port-security

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/8 in

!

interface GigabitEthernet1/1/1

no ip address

switchport mode trunk

switchport trunk allowed vlan 1,123

switchport vlan mapping 123 778

vlan 778

exit

!

interface FastEthernet8/34

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1,778

!

interface Vlan778

no ip address

description L2VPN ERS 1 to 1 vlan translation

xconnect 99.99.8.99 89032 encapsulation mpls

no shutdown

説明

VLAN 変換は、L2VPN(ポイントツーポイント)ERS(EVPL)専用です。

この場合、VLAN 1:1 変換は U-PE(1 台の 3750)で行われます。NNI(アップリンク)ポートでプロビジョニングされます。

カスタマー VLAN 123 は VLAN 778 に変換されます。

ERS(EVPL)(2 対 1 VLAN 変換)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:VLAN 2:1 変換を備えている ERS(EVPL)。デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA8/34。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。NNI ポート(アップリンク)上の VLAN 変換。

インターフェイス:FA1/0/5 ~ GI1/1/1。

L2VPN ポイントツーポイント。

コンフィグレット

 

U-PE
N-PE

vlan 567

exit

!

interface FastEthernet1/0/5

no cdp enable

no keepalive

no ip address

switchport

switchport access vlan 567

switchport mode dot1q-tunnel

switchport trunk allowed vlan none

switchport nonegotiate

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/5 in

!

interface GigabitEthernet1/1/1

no ip address

switchport trunk allowed vlan 1,123,567

switchport vlan mapping dot1q-tunnel 567 234 779

!

mac access-list extended ISC-FastEthernet1/0/5

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

vlan 779

exit

!

interface FastEthernet8/34

switchport trunk allowed vlan 1,778-779

!

interface Vlan779

no ip address

description L2VPN ERS 2 to 1 vlan translation

xconnect 99.99.8.99 89033 encapsulation mpls

no shutdown

説明

VLAN 変換は、L2VPN(ポイントツーポイント)ERS(EVPL)専用です。

この場合、2:1 VLAN 変換は U-PE(1 台の 3750)で行われます。NNI(アップリンク)ポートでプロビジョニングされます。

カスタマー VLAN 123 およびプロバイダー VLAN 234(Q -in-Q の一部)は、新しいプロバイダー VLAN 779 に変換されます。

ERS(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)。

デバイス コンフィギュレーション:

N-PE は、IOS XR 3.6.1 以降が稼動する CRS-1 です。

N-PE 上の UNI。

U-PE 上の UNI。

コンフィグレット

 

U-PE
N-PE

!

vlan 700

exit

!

interface FastEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 700

switchport mode trunk

switchport nonegotiate

no keepalive

mac access-group ISC-FastEthernet1/0/2 in

no cdp enable

spanning-tree bpdufilter enable

!

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 700

switchport mode trunk

keepalive 10

!

!

mac access-list extended ISC-FastEthernet1/0/2

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

!

!

interface GigabitEthernet0/3/1/1.700 l2transport

dot1q vlan 700

!

l2vpn

pw-class PW_AD3-AD7_Customer1

encapsulation mpls

transport-mode vlan

preferred-path interface tunnel-te 1370 fallback disable

!

!

xconnect group L2VPN_Customer1-Gold_class

p2p GoldPkg_AD3-AD7_Customer1

interface GigabitEthernet0/3/1/1.700

neighbor 192.169.105.30 pw-id 1000

pw-class PW_AD3-AD7_Customer1

!

!

説明

N-PE は、IOS XR 3.7 が稼動する CRS-1 です。

疑似回線クラス機能は、カプセル化、転送モード、推奨パス、およびフォールバック オプションのような、関連付けられている種々の属性で設定されます。

ディセーブル フォールバック オプションは、IOS XR 3.6.1 および IOS XR 3.7 のオプション以降で必要です。

E-Line 名( p2p コマンド)および L2VPN グループ名( xconnect group コマンド)は、ユーザ設定です。

ERS(EVPL)(L2VPN の NBI 拡張、IOS デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)。

デバイス コンフィギュレーション:

N-PE は、IOS が稼動する 12.2(18)SXF です。

U-PE は、IOS が稼動する 12.2(25)EY4 です。

N-PE 上の UNI。

U-PE 上の UNI。

コンフィグレット

 

U-PE
N-PE

!

vlan 3200

exit

!

interface FastEthernet1/0/2

no cdp enable

no ip address

duplex auto

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 3200

switchport nonegotiate

switchport port-security aging type inactivity

switchport port-security maximum 100

switchport port-security aging time 1000

switchport port-security violation protect

switchport port-security

storm-control unicast level 1.0

storm-control broadcast level 50.0

storm-control multicast level 50.0

shutdown

keepalive

spanning-tree bpdufilter enable

 

!

interface GigabitEthernet1/0/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 3200

!

!

vlan 3300

exit

!

interface FastEthernet1/0/24

no cdp enable

no ip address

duplex auto

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 3300

switchport nonegotiate

switchport port-security aging type inactivity

switchport port-security maximum 100

switchport port-security aging time 1000

switchport port-security violation protect

switchport port-security

storm-control unicast level 1.0

storm-control broadcast level 50.0

storm-control multicast level 50.0

shutdown

keepalive

spanning-tree bpdufilter enable

 

!

interface Vlan3300

no ip address

xconnect 192.169.105.40 7502 encapsulation mpls

no shutdown

!

説明

なし。

ERS(EVPL)または EWS(EPL)(IOS XR デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)または EWS(EPL)。

デバイス コンフィギュレーション:

N-PE は、IOS XR 3.4.2 が稼動する CRS-1 です。

N-PE 上の UNI。ERS(EVPL)専用。

U-PE。EWS(EPL)または ERS(EVPL)。

コンフィグレット

 

N-PE

<?xml version="1.0" encoding="UTF-8"?>

<Request MajorVersion="1" MinorVersion="0">

<Set>

<Configuration Source="CurrentConfig">

<InterfaceConfigurationTable>

<InterfaceConfiguration>

<Naming>

<Name>GigabitEthernet0/0/0/1.302</Name>

<Active>act</Active>

</Naming>

<InterfaceModeNonPhysical>L2Transport</InterfaceModeNonPhysical>

</InterfaceConfiguration>

</InterfaceConfigurationTable>

<L2VPN>

<Enabled>true</Enabled>

<XConnectGroupTable>

<XConnectGroup>

<Naming>

<Name>VPNSC</Name>

</Naming>

<Enabled>true</Enabled>

<P2PXConnectTable>

<P2PXConnect>

<Naming>

<Name>GigabitEthernet0_0_0_1.302</Name>

</Naming>

<Enabled>true</Enabled>

<AttachmentCircuitTable>

<AttachmentCircuit>

<Naming>

<Name>GigabitEthernet0/0/0/1.302</Name>

</Naming>

<Enabled>true</Enabled>

</AttachmentCircuit>

</AttachmentCircuitTable>

<PseudoWireTable>

<PseudoWire>

<Naming>

<Neighbor>

<IPV4Address>10.11.13.15</IPV4Address>

</Neighbor>

<PseudowireID>1005</PseudowireID>

</Naming>

<PseudoWireParameters/>

</PseudoWire>

</PseudoWireTable>

</P2PXConnect>

</P2PXConnectTable>

</XConnectGroup>

</XConnectGroupTable>

</L2VPN>

</Configuration>

</Set>

<Commit/>

</Request>

 

説明

IOS XR では、デバイス コンフィギュレーションが XML 形式で指定されます。

XML スキーマについては、さまざまなバージョンの IOS XR が、複数の XML コンフィグレットを生成します。ただし、各コンフィギュレーションは、XML スキーマの変更内容を除き、ほとんど同じです。

考慮すべき、さまざまな場合があります。たとえば、サービス リクエストが稼動中止または変更される場合、XML コンフィギュレーションが若干異なります。

ERS(EVPL)および EWS(EPL)(E-Line 上のローカル接続)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)および EWS(EPL)。

デバイス コンフィギュレーション:

N-PE は、IOS XR 3.6 以降が稼動する CRS-1 です。

U-PE は、IOS が稼動する 12.2(18)SXF です。

コンフィグレット

 

U-PE
N-PE

 

interface GigabitEthernet0/0/0/2.559

dot1q vlan 559

l2transport

!

interface GigabitEthernet0/0/0/4.559

dot1q vlan 559

l2transport

!

l2vpn

xconnect group ISC

p2p cl-test-l2-crs1-1--0--559

interface GigabitEthernet0/0/0/2.559

interface GigabitEthernet0/0/0/4.559

!

!

!

説明

ローカル接続コンフィグレットに対するデフォルトの E-Line 名が変更されています。

デフォルトの E-line 名の形式は次のとおりです。

device_name_with_underscores--VCID--VLANID

ERS(EVPL)、EWS(EPL)、ATM、またはフレーム リレー(L2VPN の追加テンプレート変数、IOS および IOS XR デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ERS(EVPL)、EWS(EPL)、ATM、およびフレーム リレー。

デバイス コンフィギュレーション:

N-PE は、ERS(EVPL)、EWS(EPL)、フレーム リレー サービス用の IOS が稼動する 12.2(18)SXF です。

N-PE は、ERS(EVPL)、EWS(EPL)サービス用の IOS XR 3.6 以降、および ATM サービス(ATM ポート モード)用の IOS XR 3.7 以降が稼動する CRS-1 です。

U-PE は、ERS(EVPL)または EWS(EPL)サービス用の IOS が稼動する 12.2(25)EY4 です。

コンフィグレット

 

U-PE
N-PE

(なし)

テンプレートの内容:

interface Loopback0

description

LocalLoopbackAddress=$L2VPNLocalLoopback

LocalHostName=$L2VPNLocalHostName

RemoteLoopbackAddress=$L2VPNRemoteLoopback

RemoteHostName=$L2VPNRemoteHostName

 

コンフィグレット:

interface Loopback0

description LocalLoopbackAddress= 192.169.105.40

LocalHostName=cl-test-l2-7600-2

RemoteLoopbackAddress=192.169.105.80

RemoteHostName= cl-test-l2-7600-4

説明

これらの 4 つの変数がサポートされるのは、N-PE だけです。

この値は、他のすべてのデバイス ロール(U-PE、PE-AGG、および CE)では空になります。

EWS(EPL)(ポイントツーポイント)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:EWS(EPL)(ポイントツーポイント)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA8/17。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。ポート セキュリティなし、トンネリングなし。

インターフェイス:FA1/0/20 ~ FA1/0/23。

L2VPN ポイントツーポイント。

Q-in-Q UNI。

コンフィグレット

 

U-PE
N-PE

system mtu 1522

!

vlan 774

exit

!

interface FastEthernet1/0/20

no cdp enable

no keepalive

switchport

switchport access vlan 774

switchport mode dot1q-tunnel

switchport nonegotiate

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet1/0/23

no ip address

switchport trunk allowed vlan 774,787-788

vlan 774

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-774,878

!

interface Vlan774

no ip address

description L2VPN EWS

xconnect 99.99.8.99 89029 encapsulation mpls

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。プロビジョニングは、ERS(EVPL)の例と同じです。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。

デフォルトでは、PACL はプロビジョニングされません。必要に応じて、BPDU をトンネリングできます。

Q-in-Q フレームの余分な 4 バイトを処理するには、システム MTU を 1522 に設定する必要があります。

EWS(EPL)(ポイントツーポイント、UNI ポート セキュリティ、BPDU トンネリング)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ポート セキュリティおよび BPDU トンネリングを備えている EWS(EPL)(ポイントツーポイント)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。ポート セキュリティなし、トンネリングあり。

L2VPN ポイントツーポイント。

Q-in-Q UNI。

コンフィグレット

 

U-PE
N-PE

system mtu 1522

!

vlan 775

exit

!

system mtu 1522

!

vlan 775

exit

!

interface FastEthernet1/0/19

no cdp enable

no keepalive

switchport

switchport access vlan 775

switchport mode dot1q-tunnel

switchport nonegotiate

switchport port-security maximum 34

switchport port-security aging time 32

switchport port-security violation shutdown

switchport port-security

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

l2protocol-tunnel shutdown-threshold cdp 88

l2protocol-tunnel shutdown-threshold stp 99

l2protocol-tunnel shutdown-threshold vtp 56

l2protocol-tunnel drop-threshold cdp 56

l2protocol-tunnel drop-threshold stp 64

l2protocol-tunnel drop-threshold vtp 34

storm-control unicast level 34.0

storm-control broadcast level 23.0

storm-control multicast level 12.0

spanning-tree portfast

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/19 in

 

interface FastEthernet1/0/23

no ip address

switchport trunk allowed vlan 774-775,787-788

 

!

mac access-list extended ISC-FastEthernet1/0/19

no permit any any

deny any host 3456.3456.1234

permit any any

vlan 775

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-775,878

!

interface Vlan775

no ip address

description L2VPN EWS

xconnect 99.99.8.99 89029 encapsulation mpls

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。プロビジョニングは、ERS(EVPL)の例と同じです。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。

1 つのユーザ定義エントリがある PACL。

BPDU(CDP、STP および VTP)は、MPLS コアでトンネリングされます。

ストーム制御は、ユニキャスト、マルチキャスト、およびブロードキャストでイネーブルにされます。

EWS(EPL)(ハイブリッド)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:EWS(EPL)ハイブリッド。片側が EWS(EPL)UNI、もう一方側が ERS(EVPL)NNI。

デバイス コンフィギュレーション:

N-PE は、12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA8/17。

U-PE は、12.2(25)EY1 が稼動する Cisco 3750ME です。ポート セキュリティなし、トンネリングあり。

インターフェイス:FA1/0/20 ~ FA1/0/23。

L2VPN ポイントツーポイント。

Q-in-Q UNI。


) 最初のコンフィグレットの例は、EWS(EPL)側(UNI)です。2 番目のコンフィグレットの例は、ERS(EVPL)側(NNI)です。


コンフィグレット(EWS)

 

U-PE
N-PE

system mtu 1522

!

vlan 775

exit

!

system mtu 1522

!

vlan 775

exit

!

interface FastEthernet1/0/19

no cdp enable

no keepalive

switchport

switchport access vlan 775

switchport mode dot1q-tunnel

switchport nonegotiate

switchport port-security maximum 34

switchport port-security aging time 32

switchport port-security violation shutdown

switchport port-security

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

l2protocol-tunnel shutdown-threshold cdp 88

l2protocol-tunnel shutdown-threshold stp 99

l2protocol-tunnel shutdown-threshold vtp 56

l2protocol-tunnel drop-threshold cdp 56

l2protocol-tunnel drop-threshold stp 64

l2protocol-tunnel drop-threshold vtp 34

storm-control unicast level 34.0

storm-control broadcast level 23.0

storm-control multicast level 12.0

spanning-tree portfast

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/19 in

 

interface FastEthernet1/0/23

no ip address

switchport trunk allowed vlan 774-775,787-788

 

!

mac access-list extended ISC-FastEthernet1/0/19

no permit any any

deny any host 3456.3456.1234

permit any any

 

vlan 775

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-775,878

!

interface Vlan775

no ip address

description L2VPN EWS

xconnect 99.99.8.99 89029 encapsulation mpls

no shutdown

説明

これは EWS(EPL)側(UNI)です。

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。プロビジョニングは、ERS(EVPL)と同じです。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。

1 つのユーザ定義エントリがある PACL。

BPDU(cdp、stp および vtp)は、MPLS コアでトンネリングされます。

ストーム制御は、ユニキャスト、マルチキャスト、およびブロードキャストでイネーブルにされます。

コンフィグレット(ERS)

 

U-PE
N-PE

system mtu 1522

 

vlan 775

exit

 

interface FastEthernet1/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-775,878

 

interface FastEthernet1/10

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-775,878

vlan 775

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772,773-775,878

!

interface Vlan775

no ip address

description L2VPN EWS

xconnect 99.99.8.99 89029 encapsulation mpls

no shutdown

説明

これは ERS(EVPL)側(NNI)です。

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。プロビジョニングは、ERS(EVPL)と同じです。

U-PE は実際に PE-AGG です。U-PE は、大規模なカスタマーに NNI として接続します。両方のポートは、通常の NNI ポートです。

EWS(EPL)(疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:EWS(EPL)。

デバイス コンフィギュレーション:

N-PE は、IOS XR 3.6.1 以降が稼動する CRS-1 です。

U-PE 上の UNI。

コンフィグレット

 

U-PE
N-PE

!

system mtu 1522

!

vlan 700

exit

!

interface FastEthernet1/0/2

switchport

switchport access vlan 700

switchport mode dot1q-tunnel

switchport nonegotiate

no keepalive

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface GigabitEthernet1/0/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 700

switchport mode trunk

!

!

interface GigabitEthernet0/3/1/1.700 l2transport

dot1q vlan 700

!

!

l2vpn

pw-class PW_AD7-AD3_Cutsomer2

encapsulation mpls

transport-mode ethernet

preferred-path interface tunnel-te 2730

!

!

xconnect group ISC

p2p cl-test-l2-12404-2--1000

interface GigabitEthernet0/3/1/1.700

neighbor 192.169.105.30 pw-id 1000

pw-class PW_AD7-AD3_Cutsomer2

!

説明

N-PE は、IOS XR 3.7 が稼動する CRS-1 ルータです。

疑似回線クラス機能は、カプセル化、転送モード、推奨パス、およびフォールバック オプションのような、関連付けられているさまざまな属性で設定されます。

ディセーブル フォールバック オプションは、IOS XR 3.6.1 および IOS XR 3.7 のオプション以降で必要です。

ユーザ入力が提供されない場合、E-Line 名( p2p コマンド)および L2VPN グループ名( xconnect group コマンド)は、ISC に生成されたデフォルト値になります。

EWS(EPL)(L2VPN の NBI 拡張、IOS デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:EWS(EPL)。

デバイス コンフィギュレーション:

N-PE は、IOS が稼動する 12.2(18)SXF です。

U-PE は、IOS が稼動する 12.2(25)EY4 です。

N-PE 上の UNI。

U-PE 上の UNI。

コンフィグレット

 

U-PE
N-PE

!

vlan 3201

exit

!

interface FastEthernet1/0/2

no cdp enable

no ip address

duplex auto

switchport

switchport access vlan 3201

switchport mode dot1q-tunnel

switchport nonegotiate

switchport port-security aging type inactivity

switchport port-security maximum 100

switchport port-security aging time 1000

switchport port-security violation protect

switchport port-security

storm-control unicast level 1.0

storm-control broadcast level 50.0

storm-control multicast level 50.0

shutdown

keepalive

spanning-tree bpdufilter enable

 

!

interface GigabitEthernet1/0/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 3201

!

!

vlan 3301

exit

!

interface FastEthernet1/0/24

no cdp enable

no ip address

duplex auto

switchport

switchport access vlan 3301

switchport mode dot1q-tunnel

switchport nonegotiate

switchport port-security aging type inactivity

switchport port-security maximum 100

switchport port-security aging time 1000

switchport port-security violation protect

switchport port-security

storm-control unicast level 1.0

storm-control broadcast level 50.0

storm-control multicast level 50.0

shutdown

keepalive

spanning-tree bpdufilter enable

 

!

interface Vlan3301

no ip address

xconnect 192.169.105.40 7502 encapsulation mpls

no shutdown

!

説明

なし。

ATM over MPLS(VC モード)

コンフィギュレーション

サービス:L2VPN。

機能:VC モードの ATM over MPLS(AToM の 1 つのタイプである ATMoMPLS)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.0(28)S が稼動する Cisco 7200 です。

CE なし。

U-PE なし。

L2VPN ポイントツーポイント(ATMoMPLS)。

C7200(ATM2/0)。

コンフィグレット

 

U-PE
N-PE

(なし)

interface ATM2/0.34234 point-to-point

pvc 213/423 l2transport

encapsulation aal5

xconnect 99.99.4.99 89025 encapsulation mpls

説明

N-PE は、MPLS がイネーブルにされているルータです。

L2VPN プロビジョニングは、ATM VC 接続上で実行されます。

ATM over MPLS(VP モード)

コンフィギュレーション

サービス:L2VPN。

機能:VP モードの ATM over MPLS(AToM の 1 つのタイプである ATMoMPLS)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.0(28)S が稼動する Cisco 7200 です。

インターフェイス:ATM2/0。

CE なし。

U-PE なし。

L2VPN ポイントツーポイント(ATMoMPLS)。

コンフィグレット

 

U-PE
N-PE

(なし)

pseudowire-class ISC-pw-tunnel-123

encapsulation mpls

preferred-path interface tunnel123 disable-fallback

!

interface ATM2/0

atm pvp 131 l2transport

xconnect 99.99.4.99 89024 pw-class ISC-pw-tunnel-123

説明

N-PE は、MPLS がイネーブルにされているルータです。

L2VPN プロビジョニングは、ATM VP 接続上で実行されます。

L2VPN 疑似回線は、TE トンネルにマッピングされます。

ATM(ポート モード、疑似回線クラス、E-Line、L2VPN グループ名、IOS XR デバイス)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:ATM。

デバイス コンフィギュレーション:

N-PE は、ATM サービス(ポート モードだけ)用の IOS XR 3.7 以降が稼動する CRS-1 です。

N-PE 上の UNI。

コンフィグレット

 

U-PE
N-PE

(なし)

interface ATM0/1/0/0

description UNIDesc_AC1

l2transport

!

!

l2vpn

pw-class PWClass-1

encapsulation mpls

preferred-path interface tunnel-te 500 fallback disable

!

!

xconnect group ISC

p2p ELine_AC1

interface ATM0/1/0/0

neighbor 192.169.105.70 pw-id 100

pw-class PWClass-1

!

 

説明

N-PE は CRS-1 ルータです。

疑似回線クラス機能はオプションであり、設定されていません。

E-Line 名( p2p コマンド)および L2VPN グループ名( xconnect group コマンド)は、ユーザ設定です。

IOS XR では、ポート モードだけがサポートされます。

このポート モードは、IOS XR デバイス上で、 pvp または pvc などの固有のコマンドを生成しません。

ATM インターフェイスは、 xconnect の下に含まれます。

Frame Relay over MPLS

コンフィギュレーション

サービス:L2VPN。

機能:Frame Relay over MPLS(AToM の 1 つのタイプである FRoMPLS)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.0(28)S が稼動する Cisco 7200 です。

インターフェイス:ATM2/0。

CE なし。

U-PE なし。

L2VPN ポイントツーポイント(ATMoMPLS)。

コンフィグレット

 

U-PE
N-PE

(なし)

interface Serial1/1

exit

!

connect C1_89001 Serial1/1 135 l2transport

xconnect 99.99.4.99 89001 encapsulation mpls

説明

N-PE は、MPLS がイネーブルにされているルータです。

L2VPN プロビジョニングは、フレーム リレー接続のシリアル ポート上で実行されます。

フレーム リレー(DLCI モード)

コンフィギュレーション

サービス:L2TPv3 コアによる L2VPN。

機能:DLCI モードの FR。

デバイス コンフィギュレーション:

N-PE は、IOS 12.0(28)S が稼動する Cisco 7200 です。

インターフェイス:ATM2/0。

CE なし。

U-PE なし。

L2VPN ポイントツーポイント(ATMoMPLS)。

コンフィグレット

 

U-PE
N-PE

(なし)

pseudowire-class ISC-pw-dynamic-default

encapsulation l2tpv3

ip local interface Loopback10

ip dfbit set

!

interface Serial3/2

encapsulation frame-relay

exit

!

connect ISC_1054 Serial3/2 86 l2transport

xconnect 10.9.1.1 1054 encapsulation l2tpv3 pw-class ISC-pw-dynamic-default

説明

N-PE は、L2TPv3 がイネーブルにされているルータです。

L2VPN プロビジョニングは、フレーム リレー接続のシリアル ポート上で実行されます。

VPLS(マルチポイント、ERMS/EVP-LAN)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:VPLS(マルチポイント)ERMS(EVP-LAN)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BX.L が稼動する Cisco 7600 です。

インターフェイス:FA2/18。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。ポート セキュリティなし、トンネリングなし。

インターフェイス:FA1/0/21 ~ FA1/0/23。

VLAN 767 を備えた VPLS マルチポイント VPN。

コンフィグレット

 

U-PE
N-PE

vlan 767

exit

!

interface FastEthernet1/0/21

no cdp enable

no keepalive

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 767

switchport nonegotiate

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet1/0/21 in

!

interface FastEthernet1/0/23

no ip address

 

mac access-list extended ISC-FastEthernet1/0/21

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

l2 vfi vpls_ers_1-0 manual

vpn id 89017

neighbor 99.99.10.9 encapsulation mpls

neighbor 99.99.5.99 encapsulation mpls

!

vlan 767

exit

!

interface FastEthernet2/18

switchport trunk allowed vlan 350,351,430,630,767,780,783,785-791

!

interface Vlan767

no ip address

description VPLS ERS

xconnect vfi vpls_ers_1-0

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。

VFI には、この N-PE が通信する、すべての N-PE(ネイバー)が含まれています。

U-PE は、汎用の Metro Ethernet(ME; メトロ イーサネット)スイッチです。カスタマー BPDU は、PACL によってブロックされます。VPLS ERMS(EVP-LAN)UNI は、L2VPN(ポイントツーポイント)ERS(EVPL)UNI と同じです。

SVI(インターフェイス 767)は、複数のピアリング N-PE が含まれるグローバル VFI です。

VPLS(マルチポイント、EMS/EP-LAN)、BPDU トンネリング)

コンフィギュレーション

サービス:L2VPN/メトロ イーサネット。

機能:BPDU トンネリングを備えている VPLS(マルチポイント)EMS(EP-LAN)。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(18)SXF、Sup720-3BXL が稼動する Cisco 7600 です。

インターフェイス:FA2/18。

U-PE は、IOS 12.2(25)EY1 が稼動する Cisco 3750ME です。ポート セキュリティなし、トンネリングなし。

インターフェイス:FA1/0/12 ~ FA1/0/23。

VLAN 767 を備えた VPLS マルチポイント VPN。

Q-in-Q UNI。

コンフィグレット

 

U-PE
N-PE

system mtu 1522

!

errdisable recovery interval 33

!

vlan 776

exit

!

interface FastEthernet1/0/12

no cdp enable

no keepalive

switchport

switchport access vlan 776

switchport mode dot1q-tunnel

switchport nonegotiate

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

l2protocol-tunnel shutdown-threshold cdp 88

l2protocol-tunnel shutdown-threshold stp 64

l2protocol-tunnel shutdown-threshold vtp 77

l2protocol-tunnel drop-threshold cdp 34

l2protocol-tunnel drop-threshold stp 23

l2protocol-tunnel drop-threshold vtp 45

no shutdown

spanning-tree portfast

spanning-tree bpdufilter enable

l2 vfi vpls_ews-89019 manual

vpn id 89019

neighbor 99.99.8.99 encapsulation mpls

!

vlan 776

exit

!

interface FastEthernet8/17

switchport trunk allowed vlan 1,451,653,659,766-768,772-776,878

!

interface Vlan776

no ip address

description VPLS EWS

xconnect vfi vpls_ews-89019

no shutdown

説明

N-PE は、OSM モジュールまたは SIP-600 モジュールが稼動する 7600 です。

VFI には、この N-PE が通信する、すべての N-PE(ネイバー)が含まれています。

VPLS EMS(EP-LAN)UNI は、L2VPN(ポイントツーポイント)EWS(EPL)UNI と同じです。

SVI は、VPLS ERS(EVP-LAN)SVI と同じです。

FlexUNI/EVC(疑似回線コア接続、UNI ポート セキュリティ)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続および UNI ポート セキュリティを備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI2/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。ポート セキュリティはイネーブルにされています。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 788

exit

!

interface FastEthernet3/23

no ip address

switchport trunk allowed vlan 783,787-788

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 788

switchport port-security

switchport nonegotiate

switchport port-security maximum 45

switchport port-security aging time 34

switchport port-security violation shutdown

switchport port-security mac-address

3456.3456.5678

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet3/31

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

deny any host 1234.3234.3432

permit any any

interface GigabitEtherne4/0/1

no shut

service instance 10 ethernet

encapsulation dot1q 500

rewrite ingress tag push dot1q 555 symmetric

xconnect 192.169.105.20 505 encapsulation mpls

説明

U-PE 上の UNI。

単一の一致タグが実行されます。

再書き込み動作 push は、555 の外部 VLAN タグをプッシュします。

FlexUNI/EVC(疑似回線コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン使用)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続、UNI、およびブリッジ ドメインを備え、ポート セキュリティを備えていない FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI2/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。ポート セキュリティはイネーブルにされています。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 772

exit

!

interface FastEthernet3/23

switchport trunk allowed vlan 500,772

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport trunk allowed vlan 500,772

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet1/14

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

vlan 100

interface GigabitEtherne2/0/0

no shut

service instance 10 ethernet

encapsulation dot1q 500

rewrite ingress tag push dot1q 23 second-dot1q 41 symmetric

bridge-domain 100 split-horizon

 

Interface Vlan100

no shut

xconnect 192.169.105.20 101 encapsulation mpls

説明

U-PE 上の UNI。

単一の一致タグが実行されます。

再書き込み動作 push は、2 つのタグをプッシュします。

FlexUNI/EVC(疑似回線コア接続、UNI、および疑似回線トンネリング)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続、UNI、および疑似回線トンネリングを備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI4/0/0 <-> GI2/0/0。

コンフィグレット

 

U-PE
N-PE

(なし)

pseudowire-class ISC-pw-tunnel-2147

encapsulation mpls

preferred-path interface Tunnel2147 disable-fallback

 

interface GigabitEtherne4/0/0

service instance 1 ethernet

encapsulation dot1q 11 second-dot1q 41

rewrite ingress tag pop 2 symmetric

xconnect pw-class ISC-pw-tunnel-2147

説明

N-PE(CE が直接接続されている)上の UNI。

両方のタグの一致が実行されます。

再書き込み動作は、内部 VLAN タグおよび外部 VLAN タグの両方をポップします。

FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティ)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:VPLS コア接続および UNI ポート セキュリティを備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI4/0/1。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。ポート セキュリティはイネーブルにされています。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 788

exit

!

interface FastEthernet3/23

no ip address

switchport trunk allowed vlan 783,787-788

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 788

switchport port-security

switchport nonegotiate

switchport port-security maximum 58

switchport port-security aging time 85

switchport port-security violation shutdown

switchport port-security mac-address

1252.1254.2544

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet3/31

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

deny any host 1234.3234.3432

permit any any

l2 vfi attest-226 manual

vpn id 226

neighbor 192.169.105.20 encapsulation mpls

 

vlan 200

bridge-domain 200 split-horizon

 

interface GigabitEtherne4/0/1

no shut

service instance 10 ethernet

encapsulation dot1q 500

rewrite ingress tag translate 1-to-1 dot1q 222 symmetric

Interface vlan 200

xconnect vfi attest-226

説明

U-PE 上の UNI。

再書き込み動作は、着信 VLAN タグ 500 を 222 に変換します。

FlexUNI/EVC(VPLS コア接続、UNI ポート セキュリティなし)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:VPLS コア接続を備えて、UNI ポート セキュリティを備えていない FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI4/0/1。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 772

exit

!

interface FastEthernet3/23

switchport trunk allowed vlan 500,772

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport trunk allowed vlan 500,772

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet1/14

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

l2 vfi attest1-458 manual

vpn id 452

neighbor 192.169.105.20 encapsulation mpls

 

vlan 200

bridge-domain 200 split-horizon

 

interface GigabitEtherne4/0/1

no shut

service instance 10 ethernet

encapsulation dot1q 500

rewrite ingress tag translate 1-to-2 dot1q 222 second-dot1q 41 symmetric

Interface vlan 200

xconnect vfi attest1-458

説明

U-PE 上の UNI。

再書き込み動作は、着信 VLAN タグ 500 を 2 つのタグ、222 および 41 に変換します。

FlexUNI/EVC(ローカル コア接続、UNI ポート セキュリティ)

コンフィギュレーション

サービス:FlexUNI(EVC)/メトロ イーサネット。

機能:ローカル コネクト コア接続および UNI ポート セキュリティを備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI2/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。ポート セキュリティはイネーブルにされています。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 788

exit

!

interface FastEthernet3/23

no ip address

switchport trunk allowed vlan 783,787-788

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan none

switchport trunk allowed vlan 788

switchport port-security

switchport nonegotiate

switchport port-security maximum 45

switchport port-security aging time 34

switchport port-security violation shutdown

switchport port-security mac-address

4111.4545.1211

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet3/31

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

deny any host 1234.3234.3432

permit any any

Connect Customer_1 GigabitEthernet4/0/1 10 GigabitEthernet4/0/10 25

 

interface GigabitEtherne4/0/1

no shut

service instance 10 ethernet

encapsulation dot1q 500

rewrite ingress tag push dot1q 555 symmetric

interface GigabitEtherne4/0/10

no shut

service instance 25 ethernet

encapsulation dot1q 500 second-dot1q 501

rewrite ingress tag translate 2-to-1 dot1q 222 symmetric

説明

U-PE 上の UNI。

2 つのタグの一致動作が実行されます。

再書き込み動作は、2 つのタグを単一のタグに変換します。

2 つのサービス インスタンスは、 connect コマンドで接続されます。

FlexUNI/EVC(ローカル コア接続、UNI、ポート セキュリティなし、ブリッジ ドメイン)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:ローカル コネクト コア接続、UNI、およびブリッジ ドメインを備え、ポート セキュリティを備えていない FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GI2/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FA1/14 ~ FA3/23。

コンフィグレット

 

U-PE
N-PE

vlan 772

exit

!

interface FastEthernet3/23

switchport trunk allowed vlan 500,772

!

interface FastEthernet1/14

no cdp enable

no keepalive

no ip address

switchport trunk allowed vlan 500,772

spanning-tree bpdufilter enable

mac access-group ISC-FastEthernet3/23 in

!

mac access-list extended

ISC-FastEthernet1/14

deny any host 0100.0ccc.cccc

deny any host 0100.0ccc.cccd

deny any host 0100.0ccd.cdd0

deny any host 0180.c200.0000

permit any any

interface GigabitEtherne2/0/0

no shut

service instance 10 ethernet

encapsulation dot1q 500 second-dot1q 501

rewrite ingress tag translate 2-to-2 dot1q 222 second-dot1q 41 symmetric

bridge-domain 200 split-horizon

 

interface GigabitEtherne2/0/10

no shut

service instance 15 ethernet

encapsulation dot1q 24

rewrite ingress tag pop 1 symmetric

bridge-domain 200 split-horizon

説明

U-PE 上の UNI。

再書き込み動作は、着信する 2 つのタグを 2 つの異なるタグにマッピングまたは変換します。

ここで、サービス インスタンスはブリッジ ドメイン経由で接続されます。

FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメイン、SVI 上の疑似回線)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続とブリッジ ドメインを備え、N-PE で SVI 上の疑似回線がイネーブルにされている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/10。

コンフィグレット

 

U-PE
N-PE
vlan 452
exit
!
interface FastEthernet1/0/10
no ip address
switchport trunk allowed vlan add 452
!
interface FastEthernet1/0/13
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 452
switchport nonegotiate
vlan 3524
exit
!
ethernet evc Customer1_253
!
interface GigabitEthernet7/0/0
service instance 3 ethernet Customer1_253
encapsulation dot1q 452
rewrite ingress tag pop 1 symmetric
bridge-domain 3524 split-horizon
!
interface Vlan3524
no ip address
description BD=T,SVI=T,Flex
xconnect 22.22.22.22 52500 encapsulation mpls
backup peer 22.22.22.22 52501
no shutdown

説明

なし。

FlexUNI/EVC(疑似回線コア接続、ブリッジ ドメインなし、SVI 上の疑似回線なし)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続を備え、ブリッジ ドメインがディセーブルに、N-PE で SVI 上の疑似回線がディセーブルにされている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/10。

コンフィグレット

 

U-PE
N-PE
vlan 545
exit
!
interface FastEthernet1/0/10
no ip address
switchport trunk allowed vlan add 545
!
interface FastEthernet1/0/12
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 545
switchport nonegotiate
mac access-group ISC-FastEthernet1/0/12 in
ethernet evc Customer1_248
!
interface GigabitEthernet7/0/0
service instance 2 ethernet Customer1_248
encapsulation dot1q 545
rewrite ingress tag pop 1 symmetric
xconnect 22.22.22.22 52498 encapsulation mpls
backup peer 22.22.22.22 52499

説明

なし。

FlexUNI/EVC(AutoPick サービス インスタンス名)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:AutoPick Service Instance Name がイネーブルで、Service Instance Name 入力フィールドが空欄のままの FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/2。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/14。

コンフィグレット

 

U-PE
N-PE
!
vlan 452
exit
!
interface FastEthernet1/0/10
no ip address
switchport trunk allowed vlan add 452
!
interface FastEthernet1/0/13
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 452
switchport nonegotiate
mac access-group ISC-FastEthernet1/0/13 in
!
vlan 3524
exit
!
ethernet evc C1_1
!
interface GigabitEthernet7/0/0
service instance 3 ethernet C1_1
encapsulation dot1q 452
rewrite ingress tag pop 1 symmetric
bridge-domain 3524 split-horizon
!
interface Vlan3524
no ip address
description BD=T,SVI=T,Flex
xconnect 22.22.22.22 52500 encapsulation mpls
backup peer 22.22.22.22 52501
no shutdown

説明

転送タイプは疑似回線です。

オートピックの Service Instance Name は、 CustomerName_JobID の値を受け取ります。

FlexUNI/EVC(AutoPick サービス インスタンス名なし、サービス インスタンス名なし)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:AutoPick Service Instance Name がイネーブルでなく、Service Instance Name 入力フィールドが空欄のままの FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/2。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/14。

コンフィグレット

 

U-PE
N-PE
!
vlan 566
exit
!
interface FastEthernet1/0/14
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 566
switchport nonegotiate
no shutdown
mac access-group ISC-FastEthernet1/0/14 in
!
interface FastEthernet1/0/18
no ip address
switchport trunk allowed vlan 566
!
mac access-list extended ISC-FastEthernet1/0/14
deny any host 0100.0ccc.cccc
deny any host 0100.0ccc.cccd
deny any host 0100.0ccd.cdd0
deny any host 0180.c200.0000
permit any any
!
interface GigabitEthernet7/0/2
service instance 43 ethernet
encapsulation dot1q 566
xconnect 1.1.1.1 453366 encapsulation mpls

説明

この例で、ユーザは AutoPick Service Instance Name をイネーブルにしないで、また、Service Instance Name 入力フィールドを空欄のままにしています。

グローバル コマンド ethernet evc は生成されませんが、コマンド service instance 43 ethernet は生成されます。

サービス インスタンス名はなく、サービス インスタンス ID は 43 です。

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、疑似回線コア接続)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:疑似回線コア接続、およびユーザ提供のサービス インスタンス名を備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/10。

コンフィグレット

 

U-PE
N-PE
!
vlan 452
exit
!
interface FastEthernet1/0/10
no ip address
switchport trunk allowed vlan add 452
!
interface FastEthernet1/0/13
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 452
switchport nonegotiate
mac access-group ISC-FastEthernet1/0/13 in
!
vlan 3524
exit
!
ethernet evc ServiceInst
!
interface GigabitEthernet7/0/0
service instance 3 ethernet ServiceInst
encapsulation dot1q 452
rewrite ingress tag pop 1 symmetric
bridge-domain 3524 split-horizon
!
interface Vlan3524
no ip address
description BD=T,SVI=T,Flex
xconnect 22.22.22.22 52500 encapsulation mpls
backup peer 22.22.22.22 52501
no shutdown

説明

転送タイプは疑似回線です。

ユーザは、 ServiceInst をサービス インスタンス名として手動で指定しました。これは、サービス インスタンス ID が 3 のデバイスにプッシュされます。

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、ローカル コア接続)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:ローカルコア接続、およびユーザ指定のサービス インスタンス名を備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet1/0/6、GigabitEthernet1/0/7。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/12、FastEthernet1/0/14。

コンフィグレット

 

U-PE
N-PE
vlan 45
exit
!
interface FastEthernet1/0/12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 45
!
interface FastEthernet1/0/14
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 45
switchport nonegotiate
no shutdown
mac access-group ISC-FastEthernet1/0/14 in
!
mac access-list extended ISC-FastEthernet1/0/14
deny any host 0100.0ccc.cccc
deny any host 0100.0ccc.cccd
deny any host 0100.0ccd.cdd0
deny any host 0180.c200.0000
permit any any
ethernet evc service_int
!
interface GigabitEthernet1/0/6
no shutdown
service instance 5 ethernet service_int
encapsulation dot1q 56
!
interface GigabitEthernet1/0/7
no shutdown
service instance 33 ethernet service_int
encapsulation dot1q 45
!
connect Customer2_195 GigabitEthernet1/0/7 33 GigabitEthernet1/0/6 5

説明

転送タイプはローカルです。

ユーザは、 service_int をサービス インスタンス名として手動で提供しました。これは、サービス インスタンス ID が 5 および 33 のそれぞれのデバイスにプッシュされます。

FlexUNI/EVC(ユーザ指定のサービス インスタンス名、VPLS コア接続)

コンフィギュレーション

FlexUNI(EVC)/メトロ イーサネット。

機能:VPLS コア接続、およびユーザ提供のサービス インスタンス名を備えている FlexUNI/EVC。

デバイス コンフィギュレーション:

N-PE は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/0。

U-PE は、IOS 12.2(25)EY2 が稼動する Cisco 3750ME です。

インターフェイス:FastEthernet1/0/10。

コンフィグレット

 

U-PE
N-PE
!
vlan 452
exit
!
interface FastEthernet1/0/10
no ip address
switchport trunk allowed vlan add 452
!
interface FastEthernet1/0/13
no spanning-tree bpdufilter enable
switchport
no keepalive
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 452
switchport nonegotiate
mac access-group ISC-FastEthernet1/0/13 in
l2 vfi vpls-test manual
vpn id 300
neighbor 22.22.22.22 encapsulation mpls
!
vlan 500
!
ethernet evc ServiceInst
!
interface GigabitEtherne7/0/0
service instance 10 ethernet ServiceInst
encapsulation dot1q 400
rewrite ingress tag pop 1 symmetric
bridge-domain 500 split-horizon
!
interface vlan500
xconnect vfi vpls-test
 

説明

転送タイプは VPLS です。

ユーザは、 ServiceInst をサービス インスタンス名として手動で指定しました。これは、サービス インスタンス ID が 10 のデバイスにプッシュされます。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、ポイントツーポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:複数のリンクがあるエンドツーエンド回線を備えている疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンクが N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.370。

N-PE 2 は、IOS 12.2(33)SRE が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet4/0/2。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
!
interface ATM1/0/0.370 point-to-point
no atm enable-ilmi-trap
pvc 0/370 l2transport
encapsulation aal5snap
xconnect 192.169.105.10 123 pw-class inter-ether
!
!
ethernet evc 1-3_51
!
interface GigabitEthernet4/0/2
no ip address
no mls qos trust
service instance 103 ethernet 1-3_51
encapsulation dot1q 370
rewrite ingress tag pop 1 symmetric
xconnect 192.169.105.20 123 encapsulation mpls
!

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:マルチポイント回線を備えている疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。リンク #1 が N-PE 1 の ATM インターフェイス上で終端し、リンク #2 が N-PE 1 のイーサネット インターフェイス上で終端し、リンク #3 が N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/4、ATM6/0/0.100。

N-PE 2 は、IOS 12.2(33)SRE が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet7/0/5。

コンフィグレット

 

N-PE 1(ATM + イーサネット)
N-PE 2(イーサネット)
!
vlan 500
exit
!
ethernet evc Customer1_166
!
interface GigabitEthernet7/0/4
no shutdown
service instance 1 ethernet Customer1_166
encapsulation dot1q 600
bridge-domain 500 split-horizon
!
interface ATM6/0/0.100 point-to-point
pvc 200/300
encapsulation aal5snap
bridge-domain 500 split-horizon
!
interface Vlan500
no ip address
description UT-9
xconnect 1.1.1.1 6 pw-class ISC-pw-tunnel-400
no shutdown
 
!
vlan 800
exit
!
ethernet evc Customer1_166
!
interface GigabitEthernet7/0/5
no shutdown
service instance 1 ethernet Customer1_166
encapsulation dot1q 623
bridge-domain 800 split-horizon
!
interface Vlan800
description UT-9
xconnect 192.169.105.20 6 pw-class ISC-pw-tunnel-900
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:ポイントツーポイント回線を備えているローカル コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。この回線は、同じローカル N-PE の異なる ATM インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/1、ATM4/1/0、ATM1/0/1.99、ATM4/1/0.98。

コンフィグレット

 

N-PE 1(ATM)
N/A
!
interface ATM1/0/1
no shutdown
!
interface ATM4/1/0
no shutdown
!
interface ATM1/0/1.99 point-to-point
pvc 99/99 l2transport
encapsulation aal0
!
interface ATM4/1/0.98 point-to-point
pvc 98/98 l2transport
encapsulation aal0
!
connect ATM-to-ATM ATM1/0/1 99/99 ATM4/1/0 98/98
!
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:同じローカル N-PE 上で終端する複数のリンクのローカル コア接続で ATM とイーサネットがインターワーキングを実行する FlexUNI/EVC。リンク #1 は ATM インターフェイスで終端し、リンク #2 はイーサネット インターフェイスで終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.99、TenGigabitEthernet6/0/0、TenGigabitEthernet6/0/1。

コンフィグレット

 

N-PE 1(ATM + イーサネット)
N/A
!
vlan 1001
exit
!
interface ATM1/0/0.99 point-to-point
no atm enable-ilmi-trap
pvc 99/99
encapsulation aal5snap
bridge-domain 1001
!
!
interface TenGigabitEthernet6/0/0
no ip address
no mls qos trust
service instance 104 ethernet 1-4_60
encapsulation dot1q 11
rewrite ingress tag pop 1 symmetric
bridge-domain 1001
!
!
interface TenGigabitEthernet6/0/1
no ip address
no mls qos trust
service instance 105 ethernet 1-4_60
encapsulation dot1q 12
rewrite ingress tag pop 1 symmetric
bridge-domain 1001
!
 
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、マルチポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:ローカル コア接続で ATM とイーサネットがインターワーキングを実行するための ATMFlexUNI/EVC。複数のリンクは、同じローカル N-PE 上で終端します。リンク #1 は ATM インターフェイス上で終端し、リンク #2 は ATM インターフェイス上で終端し、リンク #3 は ATM インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM6/0/0.100、ATM6/0/1.101、ATM6/0/2.102。

コンフィグレット

 

N-PE 1(ATM)
N/A
!
vlan 500
exit
!
interface ATM6/0/0.100 point-to-point
pvc 200/300
encapsulation aal5snap
bridge-domain 500
!
interface ATM6/0/1.101 point-to-point
pvc 201/301
encapsulation aal5snap
bridge-domain 500
!
interface ATM6/0/2.102 point-to-point
pvc 202/302
encapsulation aal5snap
bridge-domain 500
!
 
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:ローカル コア接続で ATM とイーサネットがインターワーキングを実行するための ATMFlexUNI/EVC。ポイントツーポイント回線は、同じローカル N-PE の異なる ATM インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0、ATM1/0/1。

コンフィグレット

 

N-PE 1(ATM)
N/A
!
interface ATM1/0/0
atm pvp 33 l2transport
!
interface ATM1/0/1
atm pvp 222 l2transport
!
connect Customer1_208 ATM1/0/0 33 ATM1/0/1 222
 
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:複数のリンクがあるエンドツーエンド回線の疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンクが N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.370。

N-PE 2 は、IOS XR 3.9.0 が稼動する Cisco ASR 9000 です。

インターフェイス:GigabitEthernet0/0/0/4.458。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
!
interface ATM1/0/0.370 point-to-point
no atm enable-ilmi-trap
pvc 0/370 l2transport
encapsulation aal5snap
xconnect 192.169.105.10 123 pw-class inter-ether
!
interface GigabitEthernet0/0/0/4.458 l2transport
encapsulation dot1q 458
!
l2vpn
xconnect group VPNSC
p2p iscind-crs-1--48856
interface GigabitEthernet0/0/0/4.458
neighbor 192.168.118.167 pw-id 123
!
!
!

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、マルチポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:複数のリンクがあるエンドツーエンド回線を備えている疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンク(Flex 以外)が N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM4/1/0.8790。

N-PE 2 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:GigabitEthernet4/0/17.600。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
interface ATM4/1/0.8790 point-to-point
pvc 150/3454 l2transport
encapsulation aal5snap
xconnect 192.169.105.10 760 pw-class ISC-pw-tunnel-1
interface GigabitEthernet4/0/17.600
encapsulation dot1Q 600
xconnect 192.169.105.20 760 pw-class ISC-pw-tunnel-1

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、ローカル コア接続、ポイントツーポイント回線)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:ポイントツーポイント回線のローカル コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。この回線は、同じローカル N-PE 1 上で終端します。1 つのリンクは ATM インターフェイスで終端し、別の(Flex 以外)リンクはイーサネット インターフェイスで終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.444。

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:FastEthernet3/39.674。

コンフィグレット

 

N-PE 1(ATM + イーサネット)
N/A
!
interface FastEthernet3/39.674
encapsulation dot1Q 674
!
interface ATM1/0/0.444 point-to-point
pvc 44/4444 l2transport
encapsulation aal5snap
!
connect Customer1_204 ATM1/0/0 44/4444 FastEthernet3/39.674 interworking ethernet
 
 

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:ブリッジ ドメインがイネーブルにされている複数のリンクがあるエンドツーエンド回線の疑似回線コア接続を使用して、ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンクが N-PE 2 の Flex イーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.370。

N-PE 2 は、IOS XR 3.9.0 が稼動する Cisco ASR 9000 です。

インターフェイス:GigabitEthernet0/0/0/25.341。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
!
interface ATM1/0/0.370 point-to-point
no atm enable-ilmi-trap
pvc 0/370 l2transport
encapsulation aal5snap
xconnect 10.20.21.1 4531 pw-class ISC-pw-tunnel-1
interface GigabitEthernet0/0/0/25.341 l2transport
encapsulation dot1q 341
rewrite ingress tag push dot1q 430 second-dot1q 349 symmetric
!
l2vpn
bridge group tml
bridge-domain CISCO
interface GigabitEthernet0/0/0/25.341
!
neighbor 192.169.105.20 pw-id 32190
!
!
!
!

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメイン使用)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:複数のリンクがあるエンドツーエンド回線の疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。ブリッジ ドメインはイネーブルにされています。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンク(Flex 以外)が N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.370。

N-PE 2 は、IOS XR 3.9.0 が稼動する Cisco ASR 9000 です。

インターフェイス:GigabitEthernet0/0/0/20.712。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
!
interface ATM1/0/0.370 point-to-point
no atm enable-ilmi-trap
pvc 0/370 l2transport
encapsulation aal5snap
xconnect 10.20.21.1 4531 pw-class ISC-pw-tunnel-1
!
interface GigabitEthernet0/0/0/20.712 l2transport
encapsulation dot1q 712
!
l2vpn
bridge group tml
bridge-domain CISCO
interface GigabitEthernet0/0/0/20.712
!
neighbor 192.169.105.20 pw-id 1005
!
!
!
!

説明

なし。

FlexUNI/EVC(ATM-Ethernet インターワーキング、疑似回線コア接続、エンドツーエンド回線、ブリッジ ドメインなし)

コンフィギュレーション

FlexUNI(EVC)/ATM- イーサネット インターワーキング。

機能:複数のリンクがあるエンドツーエンド回線の疑似回線コア接続で ATM とイーサネットがインターワーキングを実行するための FlexUNI/EVC。ブリッジ ドメインはディセーブルにされています。1 つのリンクが N-PE 1 の ATM インターフェイス上で終端し、別のリンクが N-PE 2 のイーサネット インターフェイス上で終端します。

デバイス コンフィギュレーション:

N-PE 1 は、IOS 12.2(33)SRB3 が稼動する Cisco 7600 です。

インターフェイス:ATM1/0/0.370。

N-PE 2 は、IOS XR 3.9.0 が稼動する Cisco ASR 9000 です。

インターフェイス:GigabitEthernet0/0/0/12.433。

コンフィグレット

 

N-PE 1(ATM)
N-PE 2(イーサネット)
!
interface ATM1/0/0.370 point-to-point
no atm enable-ilmi-trap
pvc 0/370 l2transport
encapsulation aal5snap
xconnect 10.20.21.1 4531 pw-class ISC-pw-tunnel-1 !
interface GigabitEthernet0/0/0/12.433 l2transport
encapsulation dot1q 433
rewrite ingress tag push dot1q 43 second-dot1q 53 symmetric
!
l2vpn
xconnect group ISC
p2p CISCO
interface GigabitEthernet0/0/0/12.433
neighbor 192.169.105.20 pw-id 4531
!
!
!
!

説明

なし。