Cisco Active Network Abstraction 3.6.7 カスタマイゼーション ユーザ ガイド
Command Builder を使用する前に
Command Builder を使用する前に
発行日;2012/02/01 | 英語版ドキュメント(2010/12/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Command Builder を使用する前に

Command Builder を開始する

Command Builder ウィザード

コマンドのテーブル

メニュー オプション

ツールバー

新しいコマンドを定義するワークフロー

コマンドの作成

Combo フィールド タイプの定義

ANA マクロ言語スクリプト ライン

Bean Shell スクリプト ラインの定義

コマンドの管理

コマンドのプレビューおよび実行

パブリッシング コマンド

編集コマンド

コマンドのエクスポート

コマンドのインポート

コマンドのアップデート

コマンド履歴のレビュー

コマンドの削除

[Command Builder] ウィンドウを閉じる

Command Builder を使用する前に

この章では、Command Builder ウィザードの作業環境および Command Builder ツールへのアクセス方法について説明します。さらに、コマンドの作成、実行およびパブリッシュの方法について説明します。

この章では、次の事項について説明します。

「Command Builder を開始する」

「Command Builder ウィザード」

「新しいコマンドを定義するワークフロー」

「コマンドの作成」

「コマンドの管理」

「[Command Builder] ウィンドウを閉じる」

Command Builder を開始する

このセクションでは、Command Builder ウィザードの起動方法を説明します。Command Builder は、特定の管理対象デバイスから起動されます。この管理対象デバイスは、ポートなど、管理対象デバイス内の選択されたオブジェクトである場合もあります。この管理対象デバイスを使用して、コマンドを開発、テストします。コマンドの完成後に、コマンドをパブリッシュし、管理対象デバイスのより広いスコープに付加できます。

Command Builder を開始するには、次の手順を行います。


ステップ 1 Cisco ANA NetworkVision で、目的のエレメントを選択します。

ツリー ペインまたはコンテキスト パネルにある管理対象デバイスを右クリックします。

目的の管理対象エレメントの [Inventory] ウィンドウを開き、目的の Virtual Network Element(VNE; 仮想ネットワーク要素)インベントリ アイテムを右クリックします。


) [Inventory] ウィンドウの詳細については、『Cisco Active Network Abstraction 3.6.7 User Guide』を参照してください。


ステップ 2 [Management] > [Command Builder] を選択します。Command Builder ウィザードが表示されます。


 

Command Builder ウィザード

図 3-1 に、Command Builder ウィザードの例を示します。

図 3-1 Command Builder ウィザード

 

Command Builder ウィザードは次の項目で構成されます。

「コマンドのテーブル」

「メニュー オプション」

「ツールバー」

コマンドのテーブル

Command Builder ウィザードは、選択された管理対象デバイスまたは Network Element(NE; ネットワーク要素)に使用可能なすべての既存コマンドのテーブルを表示します。Command Builder を使用すると次のことが実行できます。

新しいコマンドの追加。Telnet または Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)コマンド ラインのプログラマブル シーケンスを実行できます。

既存コマンドの編集。

パブリッシュされていないコマンドの削除。

コマンド定義のインポートおよびエクスポート。

既存コマンド定義のアップデート済みバージョンのインポート。

選択された管理対象デバイスでのコマンドのテストおよび実行。

コマンドのパブリッシュ、および管理対象デバイスのより広いスコープへのコマンドの付加。


) Cisco ANA インストールの一部として使用可能なコマンドは、編集、パブリッシュまたは削除できません。コマンドの実行だけが可能です。これらのコマンドを上書きすることもできます。コマンドの実行および新しいコマンドの作成方法の詳細については、「コマンドのプレビューおよび実行」および「コマンドの作成」を参照してください。


表 3-1 は、[Command Builder] テーブルのフィールドについて説明しています。

 

表 3-1 [Command Builder] テーブル

カラム
説明

Name

コマンド名。システム全体で一意な名前です。

Menu Caption

コマンドの起動の場合にメニューに表示されるテキスト。

IMO Context

コマンドに関連付けられたインベントリ オブジェクト

(注) コマンドは、管理対象デバイスの選択されたオブジェクトに常に関連付けられています。これによって、このオブジェクトのプロパティをスクリプト ライン内で使用できます。たとえば、ポート オブジェクトを選択した場合、portAlias および status などのポートのプロパティは、自動的にスクリプトで使用可能になります。

Local

コマンドが上位のレベルから継承されるのか、または、選択された管理対象デバイスでローカルに定義されるのかを指定します。管理対象デバイスのスコープ(「すべてのデバイス」または特定のデバイスの種類など)に対して定義されたコマンドは、そのスコープ内のすべての管理対象デバイスに自動的に関連付けられます。上位のレベルから継承されたコマンドに変更が加えられる場合、特定の管理対象デバイスに対してコマンドのローカル コピーが作成され、汎用的な定義を上書きします。ローカル コピーがテストされ、受け入れられた後で、ローカル コピーをパブリッシュし、上位レベルの定義にパブリッシュできます。

テーブルは次のようにソートできます。

目的のカラムの見出しをクリックすると、そのカラムでソートされます。 アイコンが選択されたカラム見出しの横に表示されます。

昇順または降順でソートするには、カラムの見出しをクリックします。選択されたカラム見出しの横に表示される三角形がソート順を示します。

セルの中に表示される三角形をクリックすると、セルが広がり、セルの中にすべての情報が表示されます。

[Location] フィールドには、選択した行の数とテーブル内の行の合計数が「2/16 Selected」のように表示されます。また、テーブル内の選択した行の場所が「Line 3」のように表示されます。

メニュー オプション

表 3-2 に、Command Builder で使用できるメニュー オプションを示します。

 

表 3-2 Command Builder ウィザード メニュー オプション

メニュー
説明
File

New Element

新しいコマンド定義を作成します。詳細については、「コマンドの作成」を参照してください。

Edit Element

既存のコマンド定義を編集します。詳細については、「編集コマンド」を参照してください。

Delete Element

既存のローカル定義コマンド、つまり、まだパブリッシュされていないコマンドを削除します。詳細については、「コマンドの削除」を参照してください。

Tools

Export Element

コマンド定義全体を保存します。これは後で別の管理対象デバイスにインポートできます。詳細については、 「コマンドのエクスポート」を参照してください。

Import Element

コマンド定義のバージョンが Command Builder にすでに存在するかどうかに応じて、次のアクションのいずれかを実行します

新しいコマンド定義の場合、コマンド定義全体を管理対象デバイスにインポートします。詳細については、「コマンドのインポート」を参照してください。

既存のコマンド定義の場合、既存のコマンド定義をアップデートされたバージョンのコマンド定義で置き換えます。詳細については、「コマンドのアップデート」を参照してください。

Hierarchy Manager

ネットワーク階層を超えてコマンド定義を別の場所に移動するか、またはコマンドのスコープを変更します。詳細については、「パブリッシング コマンド」を参照してください。

Run Command

コマンドをプレビューするかまたは実行します。詳細については、「コマンドのプレビューおよび実行」を参照してください。

ツールバー

表 3-3 に、Command Builder ウィザードに表示されるボタンの詳細を説明します。

 

表 3-3 Command Builder ウィザード アイコン

ボタン
名前
説明

 

New Element

新しいコマンド定義を作成します。詳細については、「コマンドの作成」を参照してください。

 

Edit Element

既存のコマンド定義を編集します。詳細については、「編集コマンド」を参照してください。

 

Delete Element

ローカルに存在するコマンド、つまり、まだパブリッシュされていないコマンドを削除します。詳細については、「コマンドの削除」を参照してください。

 

Export Element

コマンド定義全体をファイルに保存します。これは後で別の管理対象デバイスにインポートできます。詳細については、「コマンドのエクスポート」を参照してください。

 

Import Element

コマンド定義のバージョンが Command Builder にすでに存在するかどうかに応じて、次のアクションのいずれかを実行します

新しいコマンド定義の場合、コマンド定義全体を管理対象デバイスにインポートします。詳細については、「コマンドのインポート」を参照してください。

既存のコマンド定義の場合、既存のコマンド定義をアップデートされたバージョンのコマンド定義で置き換えます。詳細については、「コマンドのアップデート」を参照してください。

 

Hierarchy Manager

ネットワーク階層を超えてコマンド定義を別の場所に移動するか、またはコマンドのスコープを変更します。詳細については、「パブリッシング コマンド」を参照してください。

 

Run Command

コマンドをプレビューするかまたは実行します。詳細については、「コマンドのプレビューおよび実行」を参照してください。

[Close] ボタンは、Command Builder ウィザードを終了します。

新しいコマンドを定義するワークフロー

図 3-2 は、Command Builder を使用して新しいコマンド定義を作成するために必要な手順、および実行する手順の順序を示しています。

図 3-2 新しいコマンドの定義ワークフロー

 

コマンドの定義後、いつでもコマンドのテスト、実行、および、管理対象デバイスとネットワーク要素のより広いスコープへのパブリッシュができます。


) 作成、変更、または、アップデートなどのアクションをコマンドに実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリから正しいバージョンを取得するために十分な時間ができます。


詳細については、次の項目を参照してください。

コマンドの作成については、「コマンドの作成」を参照してください。

セキュリティ アクセス ロールの定義、入力パラメータの定義、および、タブ ページの定義については、「コマンドの作成」を参照してください。

スクリプト ラインの定義およびコマンドの保存については、次を参照してください。

「ANA マクロ言語スクリプト ライン」

「Bean Shell スクリプト ラインの定義」

コマンドの作成

Command Builder を使用して、コマンド定義を作成できます。コマンド定義はデフォルトで、ローカル インスタンスとして作成されます。コマンドのローカル インスタンスを階層の上位レベルへパブリッシュする方法については、「パブリッシング コマンド」を参照してください。

さらに、既存のコマンドを編集できます。既存のコマンドの編集については、「編集コマンド」を参照してください。

コマンドを作成するには次の手順を行います。


ステップ 1 次のいずれかの方法で、[Command Builder] ダイアログボックスで、[New Command] ダイアログボックスを開きます。

ツールバーの [New Element] をクリックします。

[File] > [New Element] の順に選択します。

[New Command] ダイアログボックスが表示されます(図 3-3)。

図 3-3 [New Command] ダイアログボックス

 

ステップ 2 コマンド識別情報を入力します。

 

フィールド
説明

Name

コマンドを識別する一意な名前。

Menu Caption

メニュー オプション。メニュー内でコマンドを説明するテキスト。

Menu Visible

Cisco ANA NetworkVision のメニュー オプションとしてコマンドが表示されるかどうかを示します。

チェックボックスをオンにすると、メニュー オプションとして表示されます。チェックをオフにすると、コマンドはメニュー オプションとして表示されません。

(注) メニューに表示されないと定義されたコマンドも、Application Programming Interfaces(API; アプリケーション プログラミング インターフェイス)を通じて実行できます。

Menu Path

[Menu Visible] チェックボックスをオンにした場合、コマンドが表示されるメニューの場所を入力します。

Context IMO

コマンドに関連付けられた(さらに、データ プロパティをコマンドにパブリッシュした)インベントリ オブジェクト。インベントリ オブジェクトにインベントリ ツリーに表示されないサブオブジェクトがある場合(ポートのパラメータ グループなど)、ドロップダウン リストに表示されます。

Timeout

コマンドのタイムアウト値(ミリ秒単位)。デフォルト値は、120,000 ミリ秒(2 分)です。

Language

コマンドに使用されるスクリプト言語。

ANA マクロ:シンプル モード (「Cisco ANA マクロ言語」を参照してください)。

Bean Shell:プログラマブル モード、完全なスクリプト言語(「Bean Shell コマンド」を参照してください)。

Protocol

使用するプロトコルは次のとおりです。

Telnet:ANA マクロと Bean Shell の両方でサポートされます。

SNMP:Bean Shell だけでサポートされます。[Language] フィールドで ANA マクロを選択したときは、このオプションが表示されません。

(注) Cisco ANAには、SNMP コマンドの作成を容易にする SNMP Bean Shell テンプレートが用意されています。

ステップ 3 [Next] をクリックします。[Command Authorizations] ダイアログボックスが表示されます。

ステップ 4 コマンドの実行を許可されている次のセキュリティ アクセス ロールを選択します。

Administrator

Configurator

Operator Plus

Operator

Viewer

ステップ 5 [Next] をクリックします。[User Input Arguments] ダイアログボックスが表示されます。

Command Builder を使用すると任意の数の入力パラメータを定義できます。入力パラメータ アトリビュートは、入力フォームの構造と形式を決定します。コマンドが実行されたとき、入力フォームは自動的に生成されます。


) 入力パラメータの順番は、入力フォームに表示される順序を決定します。


ANA マクロ言語は、組み込みパラメータとユーザ定義パラメータの 2 種類のスクリプト パラメータをサポートします。パラメータは両方とも実行時に置き換えられます。すべてのパラメータ(組み込みパラメータとユーザ定義パラメータの両方)は、コマンド編集時に選択リストから使用できます。

ANA マクロ言語スクリプトについては、「ANA マクロ言語スクリプト ライン」を参照してください。

ステップ 6 [Command Authorizations] ダイアログボックスの [Next] をクリックします。[User Input Arguments] ダイアログボックスが表示されます(図 3-4)。

図 3-4 [User Input Arguments] ダイアログボックス

 

ステップ 7 新しい引数を追加するには、[New] をクリックします。[Add/Edit User Argument] ダイアログボックスが表示されます(図 3-5)。

図 3-5 [Add/Edit User Argument for Command] ダイアログボックス

 

ステップ 8 必要な情報を入力します。

 

プロパティ
説明

Name

パラメータ名。このエントリは一意である必要があります。また、文字、数字、ハイフン(-)、およびアンダースコア(_)だけから構成される必要があります。

Caption

パラメータの表示名。このエントリは、Command Builder スクリプト実行ウィンドウに表示されます。

Type

入力値の種類は次のとおりです。

String

Integer

IPSubnet

Combo

IP Address

Float

Long

Combo フィールド タイプの詳細については、「Combo フィールド タイプの定義」を参照してください。

(注) 選択された種類に有効な入力値だけが受け入れられます。これらの値は、実行時に検証されます。

Width

フィールドの幅(文字数)。Command Builder スクリプト実行ウィンドウに関連します。

Visible

このパラメータが Command Builder スクリプト実行ウィンドウに表示されるかどうかを示します。

パラメータを表示するにはチェックボックスをオンにし、パラメータをユーザに表示しない場合はチェックボックスをオフにします。引数が表示されない場合でも、コマンドから引数を(デフォルト値で)使用できます。

(注) パラメータが表示されない場合でデフォルト値が割り当てられている場合は、定数引数のような働きをします。

Tooltip

コマンド パラメータのツールチップを表示します。このストリングは、入力フォームのパラメータ フィールドに表示されます(「コマンドのプレビューおよび実行」を参照してください)。ツールチップは最大 256 文字です。

Default

パラメータのデフォルト値です。

Required

引数が必須か省略可能かを示しています。必須引数は、入力フォームに太字で表示されます(「コマンドのプレビューおよび実行」を参照してください)。


) 高度なオプションの説明は、本ガイドの目的の範囲ではありません。


ステップ 9 [OK] をクリックします。新しく作成された引数が [User Input Arguments] ダイアログボックスに表示されます。

ステップ 10 複数の引数が実行時に表示される順序を指定するには、引数を選択し、[Move Up] ボタンまたは [Move Down] をクリックします。

ステップ 11 [Next] をクリックします。[Tab Pages] ダイアログボックスが表示されます。

別のタブにパラメータを配置できます。デフォルトでは、すべてのパラメータが 1 つの General タブに表示されます。

ステップ 12 [New] をクリックします。[Add/Edit User Tab Page] ダイアログボックスが表示されます。

図 3-6 [Add/Edit User Tab Page for Command] ダイアログボックス

 

ステップ 13 タブの名前を入力し、必要なパラメータを選択します。

1 つのコマンドに対して最大 20 個のタブを定義できます。タブの名前は最大 20 文字です。

各パラメータに異なるタブを設定する場合は、ステップ 12 およびステップ 13 を繰り返します。

ステップ 14 [Next] ボタンをクリックして、コマンドを定義します。

ANA マクロ言語コマンドの場合は、「ANA マクロ言語スクリプト ライン」を参照してください。

Bean Shell コマンドの場合は、「Bean Shell スクリプト ラインの定義」 を参照してください。


 

Combo フィールド タイプの定義

[Add/Edit User Argument for x Command] ダイアログボックスの [Type] フィールドで [Combo] が選択されると、[Browse] ボタンがイネーブルになります。これによって、Up = 1 and Down = 2 などの、入力フォームのコンボ ボックスに表示される有効なオプションの選択リスト(ドロップダウン リスト)を作成できます。

コンボ エントリを定義するには、次の手順を行います。


ステップ 1 [Add/Edit User Argument for x Command] ダイアログボックスの [Type] フィールドで [Combo] を選択します。

ステップ 2 [Browse] をクリックします。[Selection List] ダイアログボックスが表示されます(図 3-7)。

図 3-7 [Selection List] ダイアログボックス

 

ステップ 3 必要な情報を入力します。

 

フィールド
説明

Value

オプションの実際の値(例:1)。

Label

入力フォームの選択リスト(ドロップダウン リスト)に表示されるエントリの説明、(例:Up)。

ステップ 4 [Add] をクリックします。

ステップ 5 すべてのエントリを追加するまでステップ 3 およびステップ 4 を必要に応じて繰り返します。

ステップ 6 [Close] をクリックします。[Add/Edit User Argument] ダイアログボックスが表示されます。


 

ANA マクロ言語スクリプト ライン

スクリプト言語として、ANA マクロ言語または Bean Shell のいずれかを指定できます。ANA マクロ言語スクリプトは、Telnet コマンドの単純なシーケンス、実行時に置き換えられるユーザ定義入力パラメータ、インライン実行ディレクティブから構成されます。インライン実行ディレクティブは、ネットワーキング デバイスで Telnet コンフィギュレーション コマンドとして順番に実行されます。

ANA マクロ言語は両方のタイプのパラメータ(組み込みおよびユーザ定義)をスクリプト ラインで、ドル記号で囲んで表します(例:$...$)。たとえば、VRF コンフィギュレーション コマンドで、入力変数 vrfName は、ip vrf $vrfName$ として定義できます。

ANA マクロ言語スクリプト ラインを定義するには、次の手順を行います(「コマンドの作成」ステップ 14 から継続します)。


ステップ 1 [User Input Arguments] ダイアログボックスで、[Next] をクリックします。[Script Lines] ダイアログボックスが表示され、図 3-8 に示されるように、スクリプト ラインの追加または編集ができます。

図 3-8 [Script Lines] ダイアログボックス

 

ステップ 2 次のガイドラインに従って必要な情報を入力します。

Command Builder アプリケーションですべてのユーザ定義パラメータおよび組み込みパラメータを表示するには、[Script] フィールドまたは [Rollback] フィールドで、 Ctrl キー+スペースバー を押します。すべての使用可能な引数を表示するダイアログボックスが表示されます(ユーザ定義入力引数および Information Model Object(IMO)コンテキストの組み込みプロパティも含まれます)。リストからエントリを選択して、[OK] ボタンをクリックし、[Script] フィールドまたは [Rollback] フィールドに追加します。

プラグマは角カッコで囲まれます(例:[...])。

複数のプラグマを単一のラインに使用できます。その場合、すべてのプラグマが解析されます。同じタイプのプラグマが繰り返された場合、最後のプラグマだけが使用されます。

コマンド ラインに復帰が必要な場合は、エスケープ シーケンス &cr を入力します。

 

フィールド
説明

Script

デバイスに送信される、実際の Telnet スクリプト ライン。スクリプト ラインには、より細かい制御のためにオプションでインライン ディレクティブ(プラグマ)を含めることができます。サポートされるプラグマの詳細については、「サポートされるプラグマ」を参照してください。

Rollback

(オプション)コマンドが失敗したときに使用されるロールバック スクリプト。

(注) ロールバック スクリプトが失敗した場合は、追加のアクションは実行されません。

Failure Condition

(オプション)すべてのスクリプト ラインに適用される一般的な失敗状態。

失敗状態を指定するには、次の手順を行います。

1. [Failure Condition] チェックボックスをオンにします。

2. [Failure Condition] フィールドでスクリプト実行中に表示されるテキストを入力します。指定されたテキストが応答に現れると、コマンドは中断されます。

ステップ 3 [Finish] をクリックします。[Create Command] ダイアログボックスが表示されます。

Light-Emitting Diode(LED; 発光ダイオード)は、レジストリに保存されるときの進捗またはコマンドの状態を示します。

青色 コマンド定義が保存されています。

緑色 コマンドは正常に作成またはアップデートされました。

赤色 Command Builder ウィザードは、コマンドの作成またはアップデートに失敗しました。

ステップ 4 コマンドが正常に保存された場合は、[Close] をクリックします。新しく作成されたコマンドが [Command Builder] テーブルに表示されます。

コマンドをプレビューする、または実行するには、「コマンドのプレビューおよび実行」を参照してください。

コマンドをパブリッシュするには、「パブリッシング コマンド」を参照してください。


コマンドを複数のネットワーク要素にパブリッシュするためにコマンドをまとめて実行する場合は、コマンドをパブリッシュした後にローカル コピーを削除することを忘れないでください。ローカル コピーを削除しなければ、複数の NE を選択したときに、コマンドがリストに表示されません。



 

コマンドの作成、変更、または、アップデートを実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリから正しいバージョンを取得するために十分な時間ができます。

Bean Shell スクリプト ラインの定義

スクリプトの言語を ANA マクロ言語または Bean Shell のいずれかに定義できます。Bean Shell は、スクリプト言語によって十分なプログラム ロジック(条件、ループ、外部ファイルなど)を使用できます。

ANA マクロ言語スクリプトについては、「ANA マクロ言語スクリプト ライン」を参照してください。

Bean Shell スクリプト ラインを定義するには次の手順を行います( コマンドの作成 ステップ 14 から継続します)。


ステップ 1 [User Input Arguments] ダイアログボックスで、[Next] をクリックします。[Bean Shell Script] ダイアログボックスが表示されます。

ステップ 2 次のガイドラインに従って必要な情報を入力します。

Command Builder アプリケーションですべてのユーザ定義パラメータおよび組み込みパラメータを表示するには、[Script] フィールドまたは [Rollback] フィールドで、 Ctrl キー+スペースバー を押します。すべての使用可能な引数を表示するダイアログボックスが表示されます(ユーザ定義入力引数および IMO コンテキストの組み込みプロパティも含まれます)。リストからエントリを選択して、[OK] ボタンをクリックし、[Script] フィールドまたは [Rollback] フィールドに追加します。

ANA マクロ言語とは異なり、Bean Shell ユーザ引数では、インベントリ プロパティをドル記号で(例:$...$) 囲みません

 

フィールド
説明

Script

デバイスに送信される、実際の Telnet スクリプト ライン。スクリプト ラインには、より細かい制御のためにオプションでインライン ディレクティブ(プラグマ)を含めることができます。サポートされるプラグマの詳細については、「サポートされるプラグマ」を参照してください。

Rollback

(オプション)コマンドが失敗したときに使用されるロールバック スクリプト。

(注) ロールバック スクリプトが失敗した場合、実行される追加アクションはありません。

ステップ 3 [OK] をクリックします。選択されたフィールドが [Bean Shell Script] ダイアログボックスに表示されます。

ステップ 4 [Finish] をクリックします。[Create Command] ダイアログボックスが表示されます。

LED は、レジストリに保存されるときの進捗またはコマンドの状態を示します。

青色 コマンド定義が保存されています。

緑色 コマンドは正常に作成またはアップデートされました。

赤色 Command Builder ウィザードは、コマンドの作成またはアップデートに失敗しました。

詳細については、「ANA マクロ言語スクリプト ライン」を参照してください。

ステップ 5 コマンドが正常に保存された場合は、[Close] をクリックします。新しく作成されたコマンドが [Command Builder] テーブルに表示されます。

コマンドをプレビューする、または実行するには、「コマンドのプレビューおよび実行」を参照してください。

コマンドをパブリッシュするには、「パブリッシング コマンド」を参照してください。


コマンドを複数のネットワーク要素にパブリッシュするためにコマンドをまとめて実行する場合は、コマンドをパブリッシュした後にローカル コピーを削除することを忘れないでください。ローカル コピーを削除しなければ、複数の NE を選択したときに、コマンドがリストに表示されません。



 

コマンドの作成、変更、または、アップデートを実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリから正しいバージョンを取得するために十分な時間ができます。

コマンドの管理

Cisco ANA では、次の方法でコマンドを管理できます。

コマンドをプレビューする、またはコマンドを実行する。「コマンドのプレビューおよび実行」を参照してください。

コマンドをパブリッシュする。「パブリッシング コマンド」を参照してください。

コマンドを編集する。「編集コマンド」を参照してください。

他のネットワーク要素で使用するためにコマンドをエクスポートする。「コマンドのエクスポート」を参照してください。

新しいコマンドをインポートする。「コマンドのインポート」を参照してください。

コマンドのアップデートされたバージョンをインポートする。「コマンドのアップデート」を参照してください。

コマンドの履歴をレビューする。「コマンド履歴のレビュー」を参照してください。

コマンドを削除する。「コマンドの削除」を参照してください。

コマンドのプレビューおよび実行

Command Builder では、(変数を含む)コマンドを実行する前にプレビューできます。入力フォームは自動的に生成され、そのコマンドに対するユーザ定義の入力フィールドをすべて表示した状態で開始されます。Command Builder は複数のアクティベーションをサポートします。これは、コマンドが複数の管理対象デバイスまたはネットワーク要素で同時に実行されるために呼び出されることが可能であることを意味します。

コマンドをプレビューする、または実行するには、次の手順を行います。


ステップ 1 Command Builder ウィザードのテーブルで必要なコマンドを選択します。

ステップ 2 次のいずれかの方法でコマンドを実行します。

ツールバーの [Run Command] をクリックします。

[Tools] > [Run Command] の順に選択します。

コマンドを右クリックし、[Run Command] を選択します。

入力フォームが生成され、表示されます(図 3-9)。

図 3-9 入力フォーム

 

入力フォームの見出しはコマンドの名前を表示し、入力フォームには次のタブが含まれます。

ユーザ定義:ユーザ定義タブが表示されます。図 3-9では、[VRF Name] タブがユーザ定義タブです。

General:入力パラメータを表示します。パラメータをユーザ定義タブにグループ化してなければ、パラメータは [General] タブに表示されます。

Result:完全な実行監査を行った出力コンソールでのコマンドのプレビューまたは実際のコマンドの相互作用を表示します。

ステップ 3 [Preview] をクリックし、コマンドの実行前に、変数を含むコマンドがどのように見えるかを確認します。

ステップ 4 [Execute] をクリックし、実行されているコマンドの実際の結果を表示します。図 3-10 のように、結果が [Result] タブに表示されます。

図 3-10 実際のコマンドの結果

 

ステップ 5 入力フォームを閉じ、Command Builder ウィザードに戻ります。


 

パブリッシング コマンド

コマンドを定義し特定の管理対象デバイスのインスタンスでテストした後、そのコマンドをパブリッシュし、ネットワークの管理対象デバイスのより広いスコープに適用できます。複数のネットワーク要素を選択し、それらすべての上でコマンドを同時に実行できます。


) Cisco ANA インストールの一部として使用可能なコマンドは、パブリッシュできません。コマンドの実行だけが可能です。コマンドの実行の詳細については、「コマンドのプレビューおよび実行」を参照してください。


[Command Builder Hierarchy Manager] ダイアログボックスでは、(システム内で定義されている)継承階層全体の複数の場所にコマンドをパブリッシュできます。つまり、階層内のコマンドが適用されるスコープを定義します。

コマンドのさまざまなバリエーションを、さまざまな管理対象デバイスおよびネットワーク要素に使用できますが、コマンドの実装は管理対象デバイスやネットワーク要素ごとに異なります。

図 3-11 に、継承階層の例を示します。この例では、階層の最上位は「すべてのデバイス」、階層の最下位は「デバイス XYZ」です。

図 3-11 継承階層の例

 

階層内のノードにコマンドがパブリッシュされた場合、上位レベルから継承されたコマンドはすべて上書きされ、すべての子に自動的に適用されます。たとえば、Cisco 7200 にコマンドがパブリッシュされた場合、上位レベルで定義されたこのコマンドのすべてのバリアントが上書きされ、システムの Cisco 7200 タイプのすべてのデバイスに関連付けられます。

コマンドをパブリッシュするには次の手順を行います。


ステップ 1 Command Builder ウィザードのテーブルで必要なコマンドを選択します。

ステップ 2 次のうちのいずれかの方法で、[Hierarchy Manager] ダイアログボックスを開始します。

ツールバーの [Hierarchy Manager] をクリックします。

[Tools] > [Hierarchy Manager] の順に選択します。

コマンドを右クリックし、[Hierarchy Manager] を選択します。


) ユーザフレンドリな VNE 名がスキーマ内に存在する場合は、[Hierarchy Manager] テーブルの [VNE Hierarchy Location] カラムにユーザフレンドリなレジストリ ロケーション名が表示されます。ユーザフレンドリな VNE 名はレジストリで設定された階層パスであり、そのため[Hierarchy Manager] テーブルに表示されます。


[Hierarchy Manager] ダイアログボックスに表示される行は、階層の異なるレベルを表します。行は、1 番上の行が階層の最高レベルを示し、1 番下の行が階層の最低レベルを表し、降順に表示されます。

表には次の情報が表示されます。

Exist:このカラムのチェック マークは、その VNE 階層ロケーションに対して、コマンドのローカル変形が存在することを示します。

Registry Key:階層パス。レジストリ内で定義されます。

表 3-4 に、[Hierarchy Manager] ダイアログボックスに表示されるツールを説明します。

 

表 3-4 [Hierarchy Manager] ダイアログボックス Tools

ボタン
説明

 

階層の別のノードにペーストするために、選択された階層のノードからコマンドをコピーします。[Copy] アイコンは選択したノードの左に表示されます。

 

階層の別のノードに移動するために、選択された階層のノードからコマンドを切り取ります。[Cut] アイコンは選択したノードの左に表示されます。

 

選択された階層のノードからコピーされた、または切り取られたコマンドを階層の別のノードに貼り付けます。[Paste] アイコンは選択したノードの左に表示されます。

 

選択された階層のノードからコマンドを削除します。

(注) コマンドがすべてのノードから削除されると、Command Builder ウィザードのメイン ダイアログボックスから削除されます。

 

コマンド定義全体をファイルに保存します。これは後で別の管理対象デバイスにインポートできます。詳細については、「コマンドのエクスポート」を参照してください。

 

コマンド定義のバージョンが Command Builder にすでに存在するかどうかに応じて、次のアクションのいずれかを実行します

新しいコマンド定義の場合、コマンド定義全体を管理対象デバイスにインポートします。詳細については、「コマンドのインポート」を参照してください。

既存のコマンド定義の場合、既存のコマンド定義をアップデートされたバージョンのコマンド定義で置き換えます。詳細については、「コマンドのアップデート」を参照してください。

ステップ 3 コマンドをパブリッシュする階層のノードを選択します。

ステップ 4 ツールバーの [Copy] ボタン、または [Cut] ボタンをクリックしてコマンドをコピーするかまたは切り取ります。

ステップ 5 コマンドをパブリッシュする階層のノードを選択します。

ステップ 6 ツールバーの [Paste] ボタンをクリックしてコマンドをペーストします。選択された階層のノードにコマンドがパブリッシュされます。


) コマンドを複数のネットワーク要素にパブリッシュするためにコマンドをまとめて実行する場合は、コマンドをパブリッシュした後にローカル コピーを削除することを忘れないでください。ローカル コピーを削除しなければ、複数の NE を選択したときに、コマンドがリストに表示されません。



 

ネットワーク要素のグループを選択したにもかかわらず、コマンドがリストに表示されない場合は、次のうちのいずれかが原因であると考えられます。

コマンドは、1 つのネットワーク要素にもパブリッシュされていません。Hierarchy Manager を使用してネットワーク要素にコマンドをパブリッシュする必要があります。

ネットワーク要素の 1 つにそのコマンドのローカル コピーがあります。Hierarchy Manager を使用してコマンドのローカル コピーを削除する必要があります。

編集コマンド

既存のユーザ作成コマンド定義を編集できます。編集されたコマンドは、ローカル インスタンスにだけ影響を与えます。継承されたコマンドが編集されたときは、新しいローカル インスタンスが特定の管理対象デバイスの汎用コマンド定義を上書きします。


) Cisco ANA インストールの一部として使用可能なコマンドは、編集できません。コマンドの実行だけが可能です。これらのコマンドを新しいコマンドを作成することで上書きすることもできます。コマンドの実行および新しいコマンドの作成方法の詳細については、「コマンドのプレビューおよび実行」および「コマンドの作成」を参照してください。


コマンドを編集するには、次の手順を行います。


ステップ 1 Command Builder ウィザードのテーブルで編集するコマンドを選択し、次のうちのいずれかを行います。

ツールバーの [Edit Element] をクリックします。

[File] > [Edit Element] の順に選択します。

コマンドを右クリックし、[Edit Element] を選択します。

[Hierarchy Manager] ダイアログボックスが表示されます。


) ユーザフレンドリな VNE 名がスキーマ内に存在する場合は、[Hierarchy Manager] テーブルの [VNE Hierarchy Location] カラムにユーザフレンドリなレジストリ ロケーション名が表示されます。ユーザフレンドリな VNE 名はレジストリで設定された階層パスであり、そのため[Hierarchy Manager] テーブルに表示されます。


ステップ 2 Hierarchy Manager から必要なコマンドのバージョンを選択し、[Next] をクリックします。選択されたコマンドの [Edit Command] ダイアログボックスが表示されます。

ステップ 3 必要に応じて、Command Builder ウィザードを使用してコマンドを編集します。詳細については、「コマンドの作成」を参照してください。

ステップ 4 スクリプト ダイアログボックスの [Finish] ボタンをクリックして、変更されたコマンドを保存します。

ステップ 5 コマンドが正常に保存された場合は、[Close] をクリックします。編集されたコマンドがサポートされ、Command Builder ウィザードに表示されます。


 

コマンドの作成、変更、または、アップデートを実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリから正しいバージョンを取得するために十分な時間ができます。

編集されたコマンドのプレビューおよび実行については、「コマンドのプレビューおよび実行」を参照してください。

変更されたコマンドのパブリッシュについては、「パブリッシング コマンド」を参照してください。

コマンドのエクスポート

コマンドをエクスポートするには、次の手順を行います。


ステップ 1 Command Builder ウィザードで、エクスポートするコマンドを選択します。一度に 1 つのコマンドしかエクスポートできません。

ステップ 2 次のうちのいずれかの方法で、[Export Element] ダイアログボックスを開きます。

ツールバーの [Export Element] をクリックします。

[Tools] > [Export Element] の順に選択します。

コマンドを右クリックし、[Export Element] を選択します。

ステップ 3 [Selected] カラムのチェックボックスをオンにして、エクスポートするコマンドを選択します。そのバージョンが表で選択されます。

ステップ 4 [OK] をクリックします。[Export Property] ダイアログボックスが表示されます。

ステップ 5 コマンドを保存するディレクトリへ移動します。

ステップ 6 [File name] フィールドに、コマンドの名前と拡張子(.txt など)を入力します。

ステップ 7 [Save] をクリックします。コマンドが選択されたディレクトリに保存されます。[Export] ダイアログボックスが表示されます。

ステップ 8 [Close] をクリックします。Command Builder ウィザードが表示されます。


 

コマンドのインポート

複数のコマンドのすべてが同一の VNE に関連付けられている限り、次の手順で複数のコマンドをインポートできます。

コマンドをインポートするには、次の手順を行います。


ステップ 1 Cisco ANA NetworkVision で、必要な管理対象デバイスを選択します。

ステップ 2 管理対象デバイスを右クリックし、[Management] > [Command Builder] を選択します。Command Builder ウィザードが表示されます。

ステップ 3 次のうちのいずれかの方法で、[Import Element] ダイアログボックスを開きます。

ツールバーの [Import Element] をクリックします。

[Tools] > [Import Element] の順に選択します。

ステップ 4 インポートするコマンドが含まれるディレクトリへ移動します。

ステップ 5 インポートするコマンドを選択します。複数のコマンドを選択するには、Shift キーまたは Ctrl キーを押したまま、コマンドを選択します。

ステップ 6 [Open] をクリックします。[Import Elements] ダイアログボックスが表示されます。

複数のファイルを選択した場合、Command Builder は、コマンドそれぞれに対して [Import Element] ダイアログボックスを表示します。

ステップ 7 [Import Element] ダイアログボックスで、指定したコマンドに対する VNE 階層ロケーションを選択します。

ステップ 8 [OK] をクリックします。Command Builder ウィザードが表示されます。

ステップ 9 [Close] をクリックします。コマンドがインポートされ、Command Builder ウィザードの開いているウィンドウに表示されます。


 

コマンドの作成、変更、または、アップデートを実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリから正しいバージョンを取得するために十分な時間ができます。

コマンドのアップデート

コマンドのアップデートされたバージョンをインポートできます。コマンドのアップデートされたバージョンをインポートする場合、Command Builder の既存バージョンは新しいコマンドで置き換えられます。既存コマンドがパブリッシュ済みであれば、アップデートされたバージョンは、継承階層で選択された特定のコマンドを置き換えます。


) コマンドのアップデートを実施した後、コマンドを実行する前に数秒待つことを推奨します。ゲートウェイの負荷が高い場合、数秒待つことによって、Command Builder がレジストリからアップデートされたバージョンを取得するために十分な時間ができます。


コマンドをアップデートするには、次の手順を行います。


ステップ 1 Cisco ANA NetworkVision で、必要な管理対象デバイスを選択します。

ステップ 2 管理対象デバイスを右クリックし、[Management] > [Command Builder] を選択します。Command Builder ウィザードが表示されます。

ステップ 3 次のうちのいずれかの方法で、[Import Element] ダイアログボックスを開きます。

ツールバーの [Import Element] をクリックします。

[Tools] > [Import Element] の順に選択します。

ステップ 4 コマンド定義のアップデートされたバージョンがあるディレクトリに移動します。

ステップ 5 インポートする、アップデートされたコマンド定義を選択します。一度に 1 つのアップデートされたコマンドしかインポートできません。

ステップ 6 [Open] をクリックします。[Import Elements] ダイアログボックスが表示されます。

ステップ 7 [Import Element] ダイアログボックスで、アップデートされたコマンド定義に対する VNE 階層ロケーションを選択します。

ステップ 8 [OK] をクリックします。ウィンドウが表示され、操作の確認を求められます。

ステップ 9 操作を確認する場合は [Yes] ボタンを、操作をキャンセルする場合は [No] をクリックします。

[Yes] ボタンをクリックすると、コマンド定義の既存のバージョンがコマンド定義のアップデートされたバージョンで置き換えられ、Command Builder ウィザードが表示されます。

ステップ 10 [Close] ボタンをクリックして、Command Builder ウィザードを終了します。


 

コマンド履歴のレビュー

実行されたコマンドはぞれぞれ、Cisco ANA イベント データベースに記録されています。コマンドの実行履歴は、Cisco ANA EventVision アプリケーションを使用して表示できます。Cisco ANA EventVision の詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください。

コマンドの削除

デフォルトで、ユーザが作成するコマンドは、ローカル インスタンスとして作成されます。ローカルに定義されたコマンドは、Command Builder ウィザードで参照できます。ローカルに存在するコマンド、つまり、まだパブリッシュされていないコマンドしか削除できません。

複数のコマンドのすべてが同一の VNE に関連付けられている限り、一度に複数のコマンドを削除できます。

コマンドを削除するには、次の手順を行います。


ステップ 1 Command Builder ウィザードで、削除するコマンドを選択します。複数のコマンドを選択するには、Shift キーまたは Ctrl キーを押したまま、コマンドを選択します。

ステップ 2 次のいずれかを実行します。

ツールバーの [Delete Element] をクリックします。

[File] > [Delete Element] の順に選択します。

選択したコマンドの 1 つを右クリックし、[Delete Element] を選択します。

ステップ 3 要求されたときは、削除プロセスを確認するかまたはキャンセルします。

削除を確認すると、コマンドは削除され、[Command Builder] テーブルに表示されなくなります。


 

[Command Builder] ウィンドウを閉じる

Command Builder での作業が終了したときは、[Close] をクリックします。