Cisco Active Network Abstraction 3.6.7 カスタマイゼーション ユーザ ガイド
Soft Properties Manager を使用する前に
Soft Properties Manager を使用する前に
発行日;2012/01/31 | 英語版ドキュメント(2009/11/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Soft Properties Manager を使用する前に

Soft Properties Manager の起動

[Soft Properties Manager] ウィンドウ

Properties Panel

[Element Properties] テーブル

Soft Properties Manager メニューバー

Soft Properties Manager [File] メニュー

Soft Properties Manager [Tools] メニュー

Soft Properties Manager ツールバー

Soft Properties Manager のワークフロー

ソフト プロパティの作成および編集

ソフト プロパティの作成

ソフト プロパティの編集

一般パラメータの設定

解析パラメータの設定

ソフト プロパティ テーブルの解析パラメータの設定

解析ルールのテスト

TCA パラメータの設定

ソフト プロパティのデバッグ

[Inventory] ウィンドウでのソフト プロパティの表示

ソフト プロパティのパブリッシュ

ソフト プロパティの削除

ソフト プロパティのインポートおよびエクスポート

ソフト プロパティのエクスポート

ソフト プロパティのインポート

Soft Properties Manager の終了

Soft Properties Manager を使用する前に

この章では、Soft Properties Manager の作業環境および Soft Properties Manager ツールへのアクセス方法について説明します。また、ソフト プロパティの作成からパブリッシュまでのプロセスも説明します。

「Soft Properties Manager の起動」

「[Soft Properties Manager] ウィンドウ」

「Soft Properties Manager のワークフロー」

「ソフト プロパティの作成および編集」

「一般パラメータの設定」

「解析パラメータの設定」

「解析ルールのテスト」

「TCA パラメータの設定」

「ソフト プロパティのデバッグ」

「[Inventory] ウィンドウでのソフト プロパティの表示」

「ソフト プロパティのパブリッシュ」

「ソフト プロパティの削除」

「ソフト プロパティのインポートおよびエクスポート」

「Soft Properties Manager の終了」

Soft Properties Manager の起動

Soft Properties Manager は特定のネットワーク要素から起動します。このネットワーク要素は、管理対象デバイスまたは管理対象デバイス内の選択されたオブジェクト(ポートなど)です。このネットワーク要素を使用してソフト プロパティを作成およびテストします。[Soft Properties Manager] ウィンドウに表示される内容は、Soft Properties Manager を起動した場所によって決まります。

ソフト プロパティを作成すると、広範な管理対象デバイスにパブリッシュし、関連付けることができます。


) 最初は、ソフト プロパティは実行時に使用する特定のオブジェクトにだけ適用されます。ソフト プロパティをパブリッシュし、システムを再起動すると、パブリッシュされた場所に応じて同じタイプのすべてのオブジェクトに適用されます。


Soft Properties Manager を起動するには、次の手順に従います。


ステップ 1 次のいずれかを実行します。

Cisco ANA NetworkVision のツリー ペインまたは作業スペースで、管理対象デバイスを右クリックしてショートカット メニューを表示します ([Cisco ANA Network Vision] ウィンドウの詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください)。

管理対象デバイスの [Inventory] ウィンドウを開き、ネットワーク要素内の必要なオブジェクト(ポート、カードなど)を右クリックします ([Inventory] ウィンドウの詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください)。

ステップ 2 ショートカット メニューから [Management] > [Soft Properties Management] の順に選択します。[Soft Properties Manager] ウィンドウが表示されます。


 

[Soft Properties Manager] ウィンドウ

図 8-1 に、[Soft Properties Manager] ウィンドウの例を示します。

図 8-1 [Soft Properties Manager] ウィンドウ

 

 

1

メニューバー

2

ツールバー

3

[Properties Panel]

4

[Element Properties] テーブル

[Soft Properties Manager] ウィンドウに、Soft Properties Manager が起動された、選択したエンティティに応じてすべての既存ソフト プロパティのテーブルが表示されます。また、Soft Properties Manager が起動された管理対象エンティティに適用される [Properties Panel] が表示されます。たとえば、Asynchronous Transfer Mode(ATM; 非同期転送モード)ポートの [Properties Panel] は [Location Information]、[ATM]、および [DS3] になります。


) Soft Properties Manager を初めて起動したときは、管理対象デバイスまたはネットワーク要素内の必要なオブジェクトの [Soft Properties Manager] ウィンドウにソフト プロパティは表示されません。


Soft Properties Manager を使用して次の作業を実行できます。

新しいソフト プロパティの追加

既存のソフト プロパティの編集

ソフト プロパティの削除

ソフト プロパティのインポートとエクスポート

選択した管理対象デバイスでのソフト プロパティのテスト

ソフト プロパティの広範な管理対象デバイスへのパブリッシュおよび関連付け

Soft Properties Manager は次で構成されています。

「Properties Panel」

「[Element Properties] テーブル」

「Soft Properties Manager メニューバー」

「Soft Properties Manager ツールバー」

Properties Panel

[Properties Panel] は、Soft Properties Manager が起動された、選択したネットワーク要素の Cisco ANA NetworkVision に表示されるパネルと同じパネルのリストが含まれたドロップダウン リストです。たとえば、ATM ポートが起動ポイントとして選択されている場合、[Properties Panel] には [Location Information]、[ATM]、および [OC3] のプロパティが含まれます。ここからプロパティを追加するパネルを選択できます。

[Element Properties] テーブル

[Element Properties] テーブルに表示される内容は、[Properties Panel] で選択した項目によって決まります。[Soft Properties Manager] ウィンドウの [Element Properties] テーブルには、次の情報が表示されます。

Label:GUI に表示されるプロパティの名前(たとえば、Port Type)。テーブルの場合は、タブに表示されるテーブル名です。

Type:ソフト プロパティのタイプ([Property] または [Table])。

Polling:プロパティに指定されたポーリング グループ(システムまたはステータス)。

Enabled:コマンドを実行する(True)または実行しない(False)。

Command Line:Network Element(NE; ネットワーク要素)に送信されてプロパティを取得するこのプロトコルのコマンド実行。このコマンドは、特定の Object Identifier(OID; オブジェクト ID)に対する Telnet/Secure Shell(SSH; セキュア シェル)コマンドまたは Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル) GET コマンドです。

テーブルは次のようにソートできます。

カラムでソートするには、カラムの見出しをクリックします。選択したカラムの見出しの横にソート アイコンが表示されます。

昇順または降順でソートするには、カラムの見出しをクリックします。選択したカラムの見出しの横に三角形が表示されます。

セル内の赤い三角形をクリックすると、セルが展開されてセル内のすべての情報が表示されます。

[Location] フィールドには、選択した行の数とテーブル内の行の合計数が「2/16 Selected」のように表示されます。また、テーブル内の選択した行の場所が「Line 3」のように表示されます。

Soft Properties Manager メニューバー

ここでは、Soft Properties Manager メニューで使用できる各オプションについて説明します。

「Soft Properties Manager [File] メニュー」

「Soft Properties Manager [Tools] メニュー」

Soft Properties Manager [File] メニュー

[File] メニューには次のオプションがあります。

New Element:新しいソフト プロパティを作成します。詳細については、「ソフト プロパティの作成および編集」を参照してください。

Edit Element:既存のソフト プロパティを編集します。詳細については、「ソフト プロパティの編集」を参照してください。

Delete Element:パブリッシュされているかどうかに関係なく、ソフト プロパティを削除します。詳細については、「ソフト プロパティの削除」を参照してください。

Soft Properties Manager [Tools] メニュー

[Tools] メニューには次のオプションがあります。

Export Element:後で別の管理対象デバイスにインポートできるようにソフト プロパティをファイルに保存します。詳細については、「ソフト プロパティのインポートおよびエクスポート」を参照してください。

Import Element:エクスポートされたファイルからソフト プロパティをコピーし、このソフト プロパティを別の管理対象デバイスにインポートします。詳細については、「ソフト プロパティのインポートおよびエクスポート」を参照してください。

Hierarchy Manager:ソフト プロパティを別の場所に移動するか、ネットワーク階層でソフト プロパティのスコープを変更します(パブリッシュ)。詳細については、「ソフト プロパティのパブリッシュ」を参照してください。

Soft Properties Manager ツールバー

表 8-1 に、Soft Properties Manager に表示されるボタンを示します。

 

表 8-1 Soft Properties Manager ツールバー

アイコン
名前
説明

 

New Element

新しいソフト プロパティを作成します。詳細については、「ソフト プロパティの作成および編集」を参照してください。

 

Edit Element

既存のソフト プロパティを編集します。詳細については、「ソフト プロパティの編集」を参照してください。

 

Delete Element

パブリッシュされているかどうかに関係なく、ソフト プロパティを削除します。詳細については、「ソフト プロパティの削除」を参照してください。

 

Export Element

後で別の管理対象デバイスにインポートできるようにソフト プロパティをファイルに保存します。詳細については、「ソフト プロパティのインポートおよびエクスポート」を参照してください。

 

Import Element

エクスポートされたファイルからソフト プロパティをコピーし、このソフト プロパティを別の管理対象デバイスにインポートします。詳細については、「ソフト プロパティのインポートおよびエクスポート」を参照してください。

 

Hierarchy Manager

ソフト プロパティを別の場所に移動するか、ネットワーク階層でソフト プロパティのスコープを変更します。詳細については、「ソフト プロパティのパブリッシュ」を参照してください。

[Close] ボタンは [Soft Properties Manager] ウィンドウを閉じます。詳細については、「Soft Properties Manager の終了」を参照してください。

Soft Properties Manager のワークフロー

図 8-2 に、Soft Properties Manager を使用して新しいソフト プロパティ定義を設定するために必要な手順とその順序を示します。

図 8-2 ワークフロー

 

ソフト プロパティの設定後いつでも、ソフト プロパティをテストし、広範な管理対象デバイスまたはネットワーク要素にパブリッシュできます。

詳細については、次の項目を参照してください。

ソフト プロパティの作成および編集については、「ソフト プロパティの作成および編集」を参照してください。

一般パラメータの設定については、「一般パラメータの設定」を参照してください。

解析パラメータの設定については、「解析パラメータの設定」を参照してください。

解析ルールの検証については、「解析ルールのテスト」を参照してください。

Threshold Crossing Alarm(TCA; しきい値超過アラーム)パラメータの設定については、「TCA パラメータの設定」を参照してください。

ソフト プロパティのデバッグについては、「ソフト プロパティのデバッグ」を参照してください。

ソフト プロパティの表示については、「[Inventory] ウィンドウでのソフト プロパティの表示」を参照してください。

ソフト プロパティのパブリッシュについては、「ソフト プロパティのパブリッシュ」を参照してください。

ソフト プロパティの削除については、「ソフト プロパティの削除」を参照してください。

ソフト プロパティのインポートおよびエクスポートについては、「ソフト プロパティのインポートおよびエクスポート」を参照してください。

Soft Property Manager ウィンドウを閉じるには、「Soft Properties Manager の終了」を参照してください。

ソフト プロパティの作成および編集

Soft Properties Manager では、[Add Soft Property] ダイアログボックスを使用してソフト プロパティの作成および既存ソフト プロパティの編集が行えます。最初に、ソフト プロパティを追加する管理対象デバイスまたはネットワーク要素内の選択したオブジェクトを確認する必要があります。

ソフト プロパティの作成

ソフト プロパティを作成するには、次の手順に従います。


ステップ 1 Cisco ANA NetworkVision で、次の手順を実行します。

Cisco ANA NetworkVision または作業スペースで、管理対象デバイスを右クリックします。

管理対象デバイスの [Inventory] ウィンドウを開き、必要なオブジェクトを右クリックします。

ステップ 2 [Management] > [Soft Properties Management] の順に選択します。[Soft Properties Manager] ウィンドウが表示されます。

ステップ 3 次のいずれかの方法で [Add Soft Property] ダイアログボックスを開きます。

ツールバーの [New Element] をクリックします。

[File] > [New Element] の順に選択します。


 

[Add Soft Property] ダイアログボックスには次のタブ(設定カテゴリ)があります。

General:ソフト プロパティの一般的な定義を設定します。詳細については、「一般パラメータの設定」を参照してください。

Parsing:ソフト プロパティの解析定義を設定します。詳細については、「解析パラメータの設定」を参照してください。

TCA Alarms:ソフト プロパティのアラームしきい値管理を設定します。詳細については、「TCA パラメータの設定」を参照してください。

ソフト プロパティの編集

既存のソフト プロパティを編集することができます。編集されたソフト プロパティはローカル インスタンスだけに適用されます。継承されたソフト プロパティを編集すると、新しいローカル インスタンスは特定の管理対象デバイスの汎用ソフト プロパティ定義を上書きします。

ソフト プロパティを編集するには、次の手順に従います。


ステップ 1 [Soft Properties Manager] ウィンドウで、編集するソフト プロパティを選択します。

ステップ 2 次のいずれかの方法で[Hierarchy Manager] テーブルを開きます。

ツールバーの [Edit Element] をクリックします。

[File] > [Edit Element] の順に選択します。

ソフト プロパティを右クリックして、[Edit Element] を選択します。

[Hierarchy Manager] テーブルが表示されます。


) ユーザフレンドリな Virtual Network Element(VNE)名がスキーマ内に存在する場合は、[Hierarchy Manager] テーブルの [VNE Hierarchy Location] カラムにユーザフレンドリなレジストリ ロケーション名が表示されます。ユーザフレンドリな VNE 名はレジストリで設定された階層パスであり、そのため[Hierarchy Manager] テーブルに表示されます。詳細については、「ソフト プロパティのパブリッシュ」を参照してください。


ステップ 3 階層マネージャからソフト プロパティの必要なバージョンを選択して、[OK] をクリックします。選択したソフト プロパティの [Edit Soft Property] ダイアログボックスが表示されます。

ステップ 4 [Soft Properties Manager] ウィンドウで既存の情報を変更して、必要に応じてソフト プロパティを編集します。

ステップ 5 ソフト プロパティを編集したら、[Edit Soft Property] ダイアログボックスの [OK] をクリックして変更を保存します。編集したソフト プロパティがサポートされ、[Soft Properties Manager] ウィンドウに表示されます。


 

編集したソフト プロパティの表示については、「[Inventory] ウィンドウでのソフト プロパティの表示」を参照してください。編集したソフト プロパティのパブリッシュについては、「ソフト プロパティのパブリッシュ」を参照してください。

一般パラメータの設定

[General] タブでは、ソフト プロパティの一般的な定義を設定できます。ソフト プロパティ フィールドを 1 つだけ設定することも、ソフト プロパティ テーブル全体を設定することもできます。

一般パラメータを設定するには、次の手順に従います。


ステップ 1 [Add Soft Property] ダイアログボックスの [General] タブを選択します。

次のフィールドが表示されます。

Name:場所および Information Model Object(IMO; 情報モデル オブジェクト)スコープに固有のソフト プロパティ識別名。このフィールドは必須です。


) 指定した名前がすでに存在する場合は、警告メッセージが表示されます。既存のソフト プロパティ実装を上書きするかどうか尋ねられます。


Label:GUI に表示され、場所および IMO スコープに固有のソフト プロパティ名。テーブルの場合は、タブに表示されるテーブル名です。このフィールドは必須です。

Description:ソフト プロパティの説明。

次のドロップダウン リストが表示されます。

Type:ソフト プロパティのタイプ。[Property](デフォルト値)または [Table] のいずれかです。[Parsing] タブに表示されるフィールドは、この選択によって決まります。


) [Table] を選択すると、[Add Soft Property] ダイアログボックスに [TCA Alarms] タブは表示されません。


Polling Rate:ソフト プロパティを割り当てるポーリング レート グループ。

trapevent

topo_unicast_pkts

topo_I2

buffering

topo_I1

configuration

status

system

次のチェックボックスが表示されます。

Enabled:VNE がコマンドを実行するかどうかを示します。このオプションはデフォルトでイネーブルです。

[Add Soft Property] ダイアログボックスに次のボタンが表示されます。

OK:フィールドのルール、つまり [General]、[Parsing]、[TCA Alarms] の各タブで設定された定義に従って変更を検証します。検証が正常に実行されると、変更が保存され、[Add Soft Property] ダイアログボックスが閉じます。


) 検証に失敗した場合は、警告メッセージが表示されます。


Cancel:変更を保存せずに [Add Soft Property] ダイアログボックスを閉じます。

Debug:[Debug Soft Property] ダイアログボックスを開き、ソフト プロパティのデバッグのステータスを表示します。

ステップ 2 ソフト プロパティの一般パラメータを設定します。


) ソフト プロパティのタイプとして [Table] を選択した場合は、「ソフト プロパティ テーブルの解析パラメータの設定」に進んでソフト プロパティの作成を続行します。



 

「解析パラメータの設定」に進んで、ソフト プロパティの解析パラメータを設定します。

解析パラメータの設定

[Parsing] タブでは、ソフト プロパティの解析定義の設定、表示、編集、および解析が行えます。

解析パラメータを設定するには、次の手順に従います。


ステップ 1 [Add Soft Property] ダイアログボックスの [Parsing] タブを選択します ([Parsing] タブは [General] タブで [Property] タイプを選択した場合に使用できます)。


) [General] タブで [Table] タイプを選択した場合は、SNMP オプションだけが使用できます。ソフト プロパティ テーブルの解析パラメータの設定の詳細については、「ソフト プロパティ テーブルの解析パラメータの設定」を参照してください。


[Parsing] タブでは、Telnet/SSH コマンド、または SNMP GET コマンドの MIB OID のいずれかを選択できます。

[Parsing] タブに次のオプション ボタンが表示されます。

Use SNMP get(OID):SNMP 取得表現。このオプションを選択すると、テキスト フィールドがイネーブルになり、必須になります。この表現には環境引数を含めることができます。


) [Use SNMP get(OID)] を選択した場合、テキスト ボックスで Ctrl キー+スペースバーを押すとすべてのプロトコルで使用可能なすべてのパラメータのリストが表示されます。


図 8-3 に、ポートで Ctrl キー+スペースバーを押したときの出力例を示します。

図 8-3 出力

 

ソフト プロパティの作成時、Telnet/SNMP コマンドが状況依存になる場合があります。その例として、SNMP を使用してポートに関連するデータを取得する場合があります。毎回すべてのポートを検索して該当するポートを検出するのは効率的ではなく、システムのパフォーマンスに大きな影響を与える可能性があります。この問題を解決するために、ソフト プロパティで インスツルメンテーション データ を使用できます。インスツルメンテーション データとは、システム内のさまざまな要素間のバリアントで、ソフト プロパティを追加するコンテキスト オブジェクトによって異なります。

この例では、インスツルメンテーション データはポートの ifIndex です。OID で ifIndex を使用するには、1.3.1.6......$ifIndex$.5.6.4 を使用します。コンテキスト オブジェクトで使用可能なインスツルメンテーション データを確認するには、カーソルをコマンド フィールドに置いて Ctrl キー+スペースバーを押します。

Use Telnet/SSH:Telnet/SSH 取得表現。このオプションを選択すると、テキスト フィールドがイネーブルになり、必須になります。この表現には環境引数を含めることができます。


) [Use Telnet/SSH] を選択した場合、テキスト ボックスで Ctrl キー+スペースバーを押すとすべてのプロトコルで使用可能なすべてのパラメータのリストが開きます。


[Parsing] タブのテキスト領域では、プロトコルのコマンドラインを入力できます。たとえば、SNMP の場合は SNMP パケットの OID を入力し、Telnet の場合は Telnet コマンドラインを入力します。


) SNMP OID はドットで始める必要があります。たとえば、1.3.6... の OID 値を取得する場合、.1.3.6... と入力します。


[Parsing] タブのテーブルに次のカラムが表示されます。

Index:解析ルールの順序を表示します。

Operation:[Add/Edit Parsing Rule] ダイアログボックスで選択した解析演算子のタイプを表示します。解析演算子の詳細については、 第 10 章「解析演算子/ルール」 を参照してください。

[Parsing] タブに次のボタンが表示されます。

Add:新しい演算子を追加します。[Add/Edit Parsing Rule] ダイアログボックスが表示されます。

Edit:既存の演算子を編集します。[Add/Edit Parsing Rule] ダイアログボックスが表示されます。


) テーブル内の必要な演算子をダブルクリックして演算子を編集することもできます。


Delete:選択した演算子をテーブルから削除します。


) 演算子を削除するには、テーブルから演算子を選択して [Delete] をクリックします。


Test:ソフト プロパティ解析をテストできます。[Test Parsing Rules] ダイアログボックスが表示されます。詳細については、「解析ルールのテスト」を参照してください。

並べ替え矢印を使用すると、シーケンス内でルールを上下に移動させて解析順序を変更できます。

ステップ 2 取得表現のタイプを [Use SNMP get(OID)] または [Use Telnet/SSH] から選択します。

ステップ 3 [Add] をクリックします。[Add/Edit Parsing Rule] ダイアログボックスが表示されます(図 8-4 を参照)。

図 8-4 [Add/Edit Parsing Rule] ダイアログボックス

 

 

1

Argument 1

2

Argument n

3

Source

4

Result

[Add/Edit Parsing Rule] ダイアログボックスは、解析演算子の追加、編集、およびテストに使用します。必要な演算子を選択すると、対応する引数が表示されます。

[Add/Edit Parsing Rule] ダイアログボックスに次のドロップダウン リストが表示されます。

Input Buffer:以前の演算子で設定された出力引数のリストおよびデフォルト(出力引数にリダイレクトされなかった直前の演算子の標準出力バッファ)を表示します。このフィールドは必須です。

演算子 N の解析結果は、デフォルトで演算子 N+1 の入力として得られます([Input Buffer] フィールドにデフォルトとして表示されます)。演算子 N の解析結果が、ローカルに設定された環境引数を示すことがあります。この場合、演算子 N+1 の入力は演算子 N の入力と同じです。デフォルトの入力バッファを変更するには、デフォルト以外の入力バッファを選択します。演算子 N+1 で使用可能な入力バッファは、演算子 1 ~ N で設定された出力引数のセットです。

ウィンドウの [Expression] 領域に表示されるフィールドは、[Operator] ドロップダウン リストで選択した内容(必須)に応じて異なります。演算子を選択すると、対応する引数が表示されます。[Operator] ドロップダウン リストでは、使用可能な解析演算子を 1 つ選択できます。

Header And Footer:入力テキストのヘッダーおよびフッターから指定した行数を削除します。詳細については、「Header and Footer」を参照してください。

Remove Lines:入力テキストの指定した開始行から指定した終了行までの範囲の行を削除します。詳細については、「Remove Lines」を参照してください。

Select Lines:入力テキストの指定した開始行から指定した終了行までの範囲の行を抽出します。詳細については、「Select Lines」を参照してください。

Replace:指定した正規表現と一致するサブストリング 1 つまたはすべてのサブストリングを検出し、指定した値に置き換えます。詳細については、「Replace」を参照してください。

Match:指定した正規表現と一致するサブストリングを検出し、抽出します。一致するサブストリングがない場合、出力バッファは空のストリングを受け取ります。詳細については、「Match」を参照してください。

Set:正規表現を使用して入力バッファおよび以前の演算子に設定されたローカル引数をフォーマットします。詳細については、「Set」を参照してください。

Substring:指定した開始点から指定した長さのサブストリングを抽出します。詳細については、「Substring」を参照してください。

Parse Integer:サブストリング ルールを使用し、結果をサブストリングで受信すると、整数値に変換します。詳細については、「Parse Integer」を参照してください。


) サブストリング演算子に文字が含まれている場合、整数解析演算子は失敗します。


[Add/Edit Parsing Rule] ダイアログボックスに表示される [Argument 1] および [Argument n] の各フィールドは動的で、選択した演算子に応じて引数を一覧表示します。演算子および対応する引数の詳細については、 第 10 章「解析演算子/ルール」 を参照してください。

[Direct result to output buffer variable] チェックボックスおよび対応するフィールドでは、解析出力を、次の演算子の入力値にするのではなく、指定された引数に出力できます。テキスト ボックスは、チェックボックスが選択されている場合に限りイネーブルになります。(このソフト プロパティ インスタンスの完全な解析シーケンス内で)一意の引数名をこのフィールドに入力する必要があります。

[Simulation] 領域には次の 2 つのテキスト領域があります。

[Source] テキスト ボックスは解析情報の入力またはペーストに使用します。

[Result] テキスト ボックスは解析結果の表示に使用します。

[Simulation] 領域に入力され、表示される情報はダイアログボックスを閉じたときに保存されません。[Test Expression] ボタンは、[Source] テキスト ボックスに入力された情報を設定されている解析演算子に従って解析し、その結果を [Result] テキスト ボックスに表示します。

[Add/Edit Parsing Rule] ダイアログボックスに次のボタンが表示されます。

OK:選択した演算子の検証ルールに従って演算子を検証します。変更を保存して、[Add/Edit Parsing Rule] ダイアログボックスを閉じます。

Cancel:変更を保存せずに [Add/Edit Parsing Rule] ダイアログボックスを閉じます。

ステップ 4 解析ルールを定義します。


 

「解析ルールのテスト」に進んで、解析ルールをテストします。

ソフト プロパティ テーブルの解析パラメータの設定

[Parsing] タブに表示されるフィールドは、[General] タブの [Type] ドロップダウン リストで選択した内容によって決まります。たとえば、[General] タブの [Type] ドロップダウン リストで [Table] を選択した場合、[Parsing] タブに Telnet/SSH オプションは表示されません。

ソフト プロパティ テーブルの解析パラメータを設定するには、次の手順に従います。


ステップ 1 [Add Soft Property] ダイアログボックスの [Parsing] タブを選択します

[Parsing] タブに次のオプション ボタンが表示されます。

Use SNMP get(OID):SNMP 取得表現。このオプションを選択した場合は、テキスト フィールドは必須です。この表現には環境引数を含めることができます。


) [Use SNMP get(OID)] を選択した場合、テキスト ボックスで Ctrl キー+スペースバーを押すとすべてのプロトコルで使用可能なすべてのパラメータのリストが表示されます。


[Parsing] タブのテーブルに次のカラムが表示されます。

Title:テーブルのカラムの見出しを表示します。

OID:テーブルのカラムの情報を表示します。

このタブに表示されるボタンの詳細については、「解析パラメータの設定」を参照してください。

ステップ 2 [Add] をクリックします。[Add/Edit Column Controller] ダイアログボックスが表示されます。

[Add/Edit Column Controller] ダイアログボックスでは、テーブルに表示されるカラムおよび情報を追加または編集できます。

[Add/Edit Column Controller] ダイアログボックスに次のフィールドが表示されます。

Column Title:テーブルに表示されるカラムの見出し

Column Data:テーブルに表示されるカラムの情報

[Add/Edit Column Controller] ダイアログボックスに次のボタンが表示されます。

OK:カラムの情報を保存して、[Add/Edit Column Controller] ダイアログボックスを閉じます。

Cancel:変更を保存せずに [Add/Edit Column Controller] ダイアログボックスを閉じます。

Apply:カラムの情報を保存します。[Add/Edit Column Controller] ダイアログボックスは開いたままです。

ステップ 3 ソフト プロパティのテーブル情報を設定します。

ステップ 4 [OK] をクリックします。[Parsing] タブに新しく設定されたテーブル情報が表示されます。


 

「ソフト プロパティのデバッグ」に進んで、ソフト プロパティ テーブルをデバッグします。

解析ルールのテスト

Soft Properties Manager は、各解析ルールおよび解析シーケンス全体をシミュレートできるテスト機能を備えています。また、NE でプロパティをテストし、デバッグできます。

解析演算子に従って実際の入力内容をテストおよびシミュレートし、解析結果を表示できます。設定されているすべての解析ルールを、解析ルールが設定された順にテストします。

解析ルールをテストするには、次の手順に従います。


ステップ 1 [Add/Edit Parsing Rule] ダイアログボックスの [Test Expression] をクリックします。[Test Parsing Rules] ダイアログボックスが表示されます。

[Input Buffer] 領域には、解析する内容を入力します。解析する入力内容をコピー アンド ペーストすることもデバイスから取得することも可能です。[Input Buffer] 領域は必須です。

[Output Buffer] 領域には解析結果のログが表示されます。最終解析結果または解析ログ全体を、使用したパーサーごとにコメントを付けて表示できます。

[Test Parsing Rules] ダイアログボックスに次のボタンが表示されます。

Close:[Test Parsing Rules] ダイアログボックスを閉じます。

Test:解析演算子に従って [Input Buffer] 領域に入力された内容を解析します。解析結果は [Output Buffer] 領域に表示されます。

ステップ 2 [Test] をクリックします。テストの結果は [Test Parsing Rules] ダイアログボックスに表示されます。

ステップ 3 [Close] をクリックします。[Add/Edit Parsing Rule] ダイアログボックスが表示されます。

ステップ 4 [OK] をクリックします。[Parsing] タブが表示されます。


 

「TCA パラメータの設定」に進んで、ソフト プロパティの TCA パラメータを設定します。

TCA パラメータの設定

[TCA Alarms] タブでは、ソフト プロパティ値のしきい値条件を設定できます。これにより、しきい値を超えたときにアラームが生成されます。

この機能を使用して次の作業を実行できます。

アラームに関連付ける重大度の選択

アラームのイネーブル化またはディセーブル化

しきい値タイプの選択

同じソフト プロパティに対して複数のアラームを設定できます。アラームは、[Cisco ANA Network Vision] ウィンドウのチケット ペインに表示されます。

TCA パラメータを設定するには、次の手順に従います。


ステップ 1 [TCA Alarms] タブを選択します。


) [TCA Alarms] タブは、[General] タブで [Property] タイプを選択した場合にだけ表示されます。


[TCA Alarms] タブに次のカラムが表示されます。

Description:アラームの説明に使用するフリー テキスト領域。

Trigger:アラームを送信させる、選択したトリガーの詳細を表示します。詳細については、 第 11 章「アラームしきい値トリガー」 を参照してください。

Enabled:[Add TCA] ダイアログボックスの [General] タブで設定されているアラームのステータス(イネーブル(True)またはディセーブル(False))を表示します。

[TCA Alarms] タブに次のボタンが表示されます。

Add:[Add TCA] ダイアログボックスが開いて、TCA のパラメータを設定できます。

Edit:[Add TCA] ダイアログボックスが開いて、以前に設定した TCA のパラメータを編集できます。


) TCA のパラメータを編集するには、テーブルからパラメータを選択して [Edit] をクリックします。


Delete:選択した TCA を [TCA Alarms] タブから削除します。


) TCA を削除するには、テーブルから TCA を選択して [Delete] をクリックします。


ステップ 2 [Add] をクリックします。[Add TCA] ダイアログボックスが表示されます。このダイアログボックスには次のタブがあります。

General:TCA の一般パラメータ(重大度、名前など)を設定します。

Trigger:TCA のアラームしきい値トリガーを設定します。詳細については、 第 11 章「アラームしきい値トリガー」 を参照してください。

[Add TCA] ダイアログボックスの [General] タブに次のフィールドが表示されます。

Name:アラームが起動したときにチケット ペインに表示されるアラーム名

Description:アラームの説明

[Add TCA] ダイアログボックスの [General] タブに次のチェックボックスが表示されます。

Enabled:アラームをイネーブルまたはディセーブルにします。アラームをイネーブルにする場合は、このオプションを選択します。

Can be correlated to other alarms:このアラームを他のアラームに関連付ける場合は、このオプションを選択します。アラームの関連付けの詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください。

Can other alarms be correlated to this alarm:他のアラームをこのアラームに関連付ける場合は、このオプションを選択します。アラームの関連付けの詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください。

[Add TCA] ダイアログボックスの [General] タブに次のドロップダウン リストが表示されます。

Alarm Severity:アラームに関連付ける重大度を選択します。

Critical

Major

Minor

Warning

Normal

アラームの重大度の詳細については、『 Cisco Active Network Abstraction 3.6.7 User Guide 』を参照してください。

このバージョンでは、アラームの説明のプレビュー領域は使用できません。

[Add TCA] ダイアログボックスの [General] タブに次のボタンが表示されます。

OK:TCA のパラメータを保存して、[Add TCA] ダイアログボックスを閉じます。

Cancel:変更を保存せずに [Add TCA] ダイアログボックスを閉じます。

Apply:TCA のパラメータを保存します。[Add TCA] ダイアログボックスは開いたままです。

ステップ 3 TCA の一般パラメータを設定します。

ステップ 4 [Trigger] タブを選択します。

[Trigger] ドロップダウン リストが表示されます。しきい値のタイプを選択します。

Value Equal:数値であるかどうかに関係なく、ソフト プロパティ値が [Alarm Value] で設定された値に等しくなると、アラーム条件を満たします。詳細については、「Value Equal」を参照してください。

Value Not Equal:数値であるかどうかに関係なく、ソフト プロパティ値が [Alarm Value] で設定された値に等しく ない ときにアラーム条件を満たします。詳細については、「Value Not Equal」を参照してください。

Upper Threshold:上限しきい値。この値を超えると設定されている数値プロパティのアラームが起動します。詳細については、「Upper Threshold」を参照してください。

Lower Threshold:下限しきい値。この値を下回ると設定されている数値プロパティのアラームが起動します。詳細については、「Lower Threshold」を参照してください。

Upper Rate:パフォーマンス カウンタの上限レートしきい値。この値を超えると設定されている数値プロパティのアラームが起動します。詳細については、「Upper Rate」を参照してください。

Lower Rate:パフォーマンス カウンタの下限レートしきい値。この値を下回ると設定されている数値プロパティのアラームが起動します。詳細については、「Lower Rate」を参照してください。

トリガーの詳細については、 第 11 章「アラームしきい値トリガー」 を参照してください。

ステップ 5 TCA の Trigger パラメータを設定します。

ステップ 6 [OK] をクリックします。[TCA Alarms] タブが表示されます。


 

「ソフト プロパティのデバッグ」に進んで、ソフト プロパティをデバッグします。

ソフト プロパティのデバッグ

[Debug Soft Property] ダイアログボックスを開いて、管理対象デバイスまたはネットワーク要素内の選択したオブジェクトのソフト プロパティをデバッグできます。このダイアログボックスには、ソフト プロパティをデバッグしたときのステータスが表示されます。たとえば、選択したデバイスが Telnet をサポートしていることを確認できます (詳細については、 第 9 章「ソフト プロパティの例」 を参照してください)。


) VNE がプロパティの収集に失敗した場合、通知メッセージは表示されません。プロパティは GUI に入力されていません。


ソフト プロパティをデバッグするには、次の手順に従います。


ステップ 1 [Add Soft Property] ダイアログボックスの [Debug] をクリックします。[Debug Soft Property] ダイアログボックスにデバッグの結果が表示されます。

図 8-5 [Debug Soft Property] ダイアログボックス

 

ステップ 2 [Close] をクリックします。[Add Soft Property] ダイアログボックスが再表示されます。

ステップ 3 [OK] をクリックします。[Soft Properties Manager] ウィンドウが表示され、新しく作成したソフト プロパティが [Element Properties] テーブルに表示されます。

ステップ 4 [Close] をクリックします。当初の選択に応じて、[Cisco ANA NetworkVision] または [Inventory] ウィンドウが表示されます。


 

「[Inventory] ウィンドウでのソフト プロパティの表示」に進んで、[Inventory] ウィンドウにソフト プロパティの結果を表示します。

[Inventory] ウィンドウでのソフト プロパティの表示

ソフト プロパティの作成または編集後、管理対象デバイスまたはネットワーク要素内の選択したオブジェクトの [Inventory] ウィンドウの [Properties] ペインに結果を表示できます。


) [Inventory] ウィンドウにソフト プロパティを表示できるのは、ウィンドウを閉じて再度開いてからです。たとえば、VNE の [Inventory] ウィンドウを開いて、ポートの 1 つにプロパティを追加した場合、VNE の [Inventory] ウィンドウを閉じて再度開くとプロパティが表示されます。


ソフト プロパティを表示するには、次の手順に従います。


ステップ 1 [Cisco ANA Network Vision] ウィンドウのツリー ペインまたは作業スペースで必要な管理対象デバイスを右クリックして、[Inventory] を選択します。管理対象デバイスの [Inventory] ウィンドウに、新しく設定したソフト プロパティまたはソフト プロパティ テーブルが表示されます。

ステップ 2 [Inventory] ウィンドウの右上隅をクリックしてウィンドウを閉じます。


 

「ソフト プロパティのパブリッシュ」に進んで、ソフト プロパティをパブリッシュします。

ソフト プロパティのパブリッシュ

プロパティ定義は、選択した NE 内の同じタイプのすべてのオブジェクトに適用されます。同じタイプまたはファミリのすべての NE に同じプロパティ定義を適用する必要がある場合があります。これには、プロパティ定義を特定の NE インスタンスからレジストリ階層内の上位に移動させる必要があります。

管理対象デバイスの特定インスタンスでソフト プロパティを設定およびテストした後、ネットワーク内の広範な管理対象デバイスにパブリッシュし、適用できます。

[Soft Properties Publish Controller] ダイアログボックスでは、(システム内で定義されている)継承階層全体の複数の場所にソフト プロパティをパブリッシュできます。つまり、階層内のソフト プロパティが適用されるスコープを定義します。

ソフト プロパティのさまざまなバリエーションを、さまざまな管理対象デバイスおよびネットワーク要素に使用できますが、ソフト プロパティの実装は管理対象デバイスやネットワーク要素ごとに異なります。

図 8-6 に、継承階層の例を示します。この例では、階層の最上位は「すべてのデバイス」、階層の最下位は「デバイス XYZ」です。

図 8-6 継承階層の例

 

ソフト プロパティを階層内のノードにパブリッシュすると、上位から継承されたソフト プロパティが上書きされ、その子すべてに自動的に適用されます。たとえば、ソフト プロパティを Cisco 7200 デバイスにパブリッシュすると、上位で定義されるこのソフト プロパティのバリアントが上書きされ、システム内の Cisco 7200 タイプのすべてのデバイスに割り当てられます。


) ソフト プロパティをパブリッシュする前に、ソフト プロパティのパブリッシュがシステムのメモリ使用状況に及ぼす影響を測定することを推奨します。変更を確認するには、VNE またはユニットを再起動してパブリッシュを有効にする必要があります。ソフト プロパティのパブリッシュによる影響の測定の詳細については、シスコの代理店にお問い合せください。



) ソフト プロパティのパブリッシュは、システムのメモリ使用状況、デバイス使用率、およびシステム パフォーマンスに大きく影響することがあります。たとえば、show running-config コマンドを含むプロパティをデバイスに追加し、デバイスのグループにパブリッシュすることができます。しかし、これはシステムのメモリ使用状況およびデバイス利用率を急上昇させる可能性があります。


ソフト プロパティをパブリッシュするには、次の手順に従います。


ステップ 1 Cisco ANA NetworkVision で、次のいずれかを実行します。

ツリー ペインまたは作業スペースで、管理対象デバイスを右クリックします。

管理対象デバイスの [Inventory] ウィンドウを開き、必要なオブジェクトを右クリックします。

ステップ 2 [Management] > [Soft Properties Management] の順に選択します。

ステップ 3 必要な [Properties Panel] および [Element Properties] テーブル内のソフト プロパティを選択します。

ステップ 4 次のいずれかの方法で[Hierarchy Manager] テーブルを開きます。

ツールバーの [Hierarchy Manager] をクリックします。

[Tools] > [Hierarchy Manager] の順に選択します。

項目を右クリックして、[Hierarchy Manager] を選択します。


) ユーザフレンドリな VNE 名がスキーマ内に存在する場合は、[Hierarchy Manager] テーブルの [VNE Hierarchy Location] カラムにユーザフレンドリなレジストリ ロケーション名が表示されます。ユーザフレンドリな VNE 名はレジストリで設定された階層パスであり、そのため[Hierarchy Manager] テーブルに表示されます。詳細については、「ソフト プロパティのパブリッシュ」を参照してください。


[Hierarchy Manager] テーブルに表示される各行は、異なる階層レベルを表します。行は降順で表示され、一番上の行は階層の最上位、一番下の行は階層の最下位を表します。

テーブルには次の情報が表示されます。

Exist:階層内のノードが選択されると、そのノードのソフト プロパティのローカル バリアントが存在することを示します。

VNE Hierarchy Location:レジストリで設定された階層パス。

IMO Class Name:このバージョンでは現在使用できません。

表 8-2 に、表示されるアイコンを示します。

 

表 8-2 [Hierarchy Manager] ウィンドウのツール

アイコン
名前
説明

 

Copy

階層内の選択したノードから階層内の別のノードにソフト プロパティをコピーします。[Copy] アイコンは選択したノードの左に表示されます。

 

Cut

階層内の選択したノードからソフト プロパティを切り取り、階層内の別のノードに移動します。[Cut] アイコンは選択したノードの左に表示されます。

 

Paste

階層内の選択したノードからコピーまたは切り取られたソフト プロパティを階層内の別のノードにペーストします。[Paste] アイコンは選択したノードの左に表示されます。

 

Delete

階層内の選択したノードからソフト プロパティを削除します。

(注) ソフト プロパティは、すべてのノードから削除されると、Soft Properties Manager のメイン ダイアログボックスのリストから削除されます。

次のボタンが表示されます。

Close:ソフト プロパティをパブリッシュせずに [Hierarchy Manager] ウィンドウを閉じます。

ステップ 5 ソフト プロパティのパブリッシュ元のノードを階層内から選択します。

ステップ 6 ツールバーの [Copy] または [Cut] をクリックしてソフト プロパティをコピーまたは切り取ります。

ステップ 7 ソフト プロパティをパブリッシュする階層内のノードを選択します。

ステップ 8 ツールバーの [Paste] をクリックしてソフト プロパティをペーストします。ソフト プロパティが階層内の選択したノードにパブリッシュされます。


 

ソフト プロパティの削除

作成するソフト プロパティは、デフォルトでは常にローカル インスタンスとして作成されます。ローカルで設定されたソフト プロパティは、[Soft Properties Publish Controller] ダイアログボックスで選択します。ソフト プロパティはパブリッシュされているかどうかに関係なく削除できます。

ソフト プロパティを削除するには、次の手順に従います。


ステップ 1 [Soft Properties Manager] ダイアログボックスの [Element Properties] テーブルで削除するソフト プロパティを選択します。

ステップ 2 次のいずれかの方法でソフト プロパティを削除します。

ツールバーの [Delete Element] をクリックします。

[File] > [Delete Element] の順に選択します。

ソフト プロパティを右クリックして、[Delete Element] を選択します。

警告メッセージが表示されます。

ステップ 3 [Yes] をクリックします。ソフト プロパティが削除され、[Soft Properties Manager] ウィンドウの [Element Properties] テーブルに表示されなくなります。


 

ソフト プロパティのインポートおよびエクスポート

[Soft Properties Manager] では、ソフト プロパティ定義をファイルにエクスポート(保存)できます。このソフト プロパティ定義は、別の管理対象デバイスにインポート(コピー)できます。

また、ソフト プロパティ定義をファイルにエクスポートおよびインポートして、[Hierarchy Manager] ウィンドウ内で複数の場所にパブリッシュできます。

ソフト プロパティのエクスポート

ソフト プロパティをエクスポートするには、次の手順に従います。


ステップ 1 [Soft Properties Manager] ダイアログボックスの [Element Properties] テーブルでエクスポートするソフト プロパティを選択します。

ステップ 2 次のいずれかの方法で [Export] ダイアログボックスを開きます。

ツールバーの [Export Element] をクリックします。

[Tools] > [Export Element] の順に選択します。

プロパティを右クリックして、[Export Element] を選択します。

[Export] ダイアログボックスが表示されます。


) ユーザフレンドリな VNE 名がスキーマ内に存在する場合は、[Hierarchy Manager] テーブルの [VNE Hierarchy Location] カラムにユーザフレンドリなレジストリ ロケーション名が表示されます。ユーザフレンドリな VNE 名はレジストリで設定された階層パスであり、そのため[Hierarchy Manager] テーブルに表示されます。詳細については、「ソフト プロパティのパブリッシュ」を参照してください。


ステップ 3 [Export] ウィンドウのテーブルでエクスポートするバージョンを選択します。そのバージョンがテーブルで選択されます。

ステップ 4 [OK] をクリックします。[Export Property] ダイアログボックスが表示されます。

ステップ 5 ソフト プロパティを保存するディレクトリを参照して指定します。

ステップ 6 [File name] フィールドにソフト プロパティの名前と拡張子(たとえば .txt)を入力します。

ステップ 7 [Save] をクリックします。ソフト プロパティが選択したディレクトリに保存されます。[Export] ダイアログボックスが表示されます。

ステップ 8 [Close] をクリックします。[Soft Properties Manager] ウィンドウが表示されます。


 

ソフト プロパティのインポート

ソフト プロパティをインポートするには、次の手順に従います。


ステップ 1 次のいずれかの方法で [Import Element] ダイアログボックスを開きます。

ツールバーの [Import Element] をクリックします。

[Tools] > [Import Element] の順に選択します。

ステップ 2 インポートするディレクトリおよびソフト プロパティを参照して指定します。

ステップ 3 [Open] をクリックします。[Import Elements] ウィンドウが表示されます。

ステップ 4 [Import Elements] ウィンドウのテーブルでインポートするバージョンを選択します。そのバージョンがテーブルで選択されます。

ステップ 5 [OK] をクリックします。[Soft Properties Manager] ウィンドウが表示されます。

ステップ 6 [Close] をクリックします。ソフト プロパティは選択した管理対象デバイスまたはネットワーク要素にインポートされ、[Soft Properties Manager] ウィンドウに表示されます。


 

Soft Properties Manager の終了

Soft Properties Manager での作業が完了したら、[Close] をクリックして終了します。