クラウドおよびシステム管理 : Cisco Prime Network Analysis Module(NAM)for ISR G2 SRE

Cisco SRE NAM 5.1 インストレーション/コンフィギュレーション ノート

Cisco SRE NAM 5.1 インストレーション/コンフィギュレーション ノート
発行日;2012/07/24 | 英語版ドキュメント(2012/05/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco SRE NAM 5.1 インストレーション/コンフィギュレーション ノート

内容

Cisco SRE NAM の仕様

サポートされる外部ソフトウェア インターフェイス

サポートされるブランチ ルータ

サポートされている Cisco SRE サービス モジュール

はじめに

NAM ソフトウェア

ハードウェア インターフェイス

Cisco SRE モジュール インターフェイスの設定

ルータ上の SRE インターフェイスの設定

セッションの開始

セッションの終了

NAM ソフトウェアのインストール

NAM ソフトウェア イメージ

NAM ソフトウェア アップグレードの種類

IOS コマンドを使用した Cisco SRE NAM のインストール

はじめに

NAM CLI コマンドを使用した Cisco SRE NAM のアップグレード

ヘルパーを使用して Cisco SRE NAM をインストールする

管理用の Cisco SRE NAM の設定

管理用の内部インターフェイスの設定:IP アンナンバード

管理用の内部インターフェイスの設定:ルーティング可能なサブネット

管理用の外部インターフェイスの設定

NAM コンソール回線での AAA ログイン認証のディセーブル化

ネットワーク接続用の Cisco SRE NAM の設定

前提条件

次の作業

NTP サーバを使用した NAM のシステム時刻の設定

NAM パケット モニタリングのイネーブル化

次の作業

NAM Traffic Analyzer のイネーブル化とアクセス

前提条件

次の作業

NAM ルート パスワードの変更

前提条件

トラブルシューティングのヒント

NAM ルート パスワードのデフォルト値へのリセット

トラブルシューティングのヒント

次の作業

NAM への Telnet または SSH セッションの開始と終了

前提条件

Cisco SRE NAM の管理

SRE NAM のシャットダウンとスタートアップ

システムの状態の検証

ロギング オプションの設定と診断情報の生成

その他の参考資料

RFC

ネットワーク解析モジュールの機能に関する情報

用語集

マニュアルの入手方法およびテクニカル サポート

Cisco SRE NAM 5.1 インストレーション/コンフィギュレーション ノート

改訂日:2011 年 3 月 OL-24407-01-J

 

Cisco Prime Network Analysis Module(NAM)は、エンドユーザに対するアプリケーションとサービス提供状況を把握、管理、改善するための、ネットワーク管理者向けの統合ソフトウェア モジュールです。Cisco NAM では、アプリケーション、ホスト、および会話のフローベースのトラフィック分析から、アプリケーション、サーバ、およびネットワーク遅延のパフォーマンスベースの測定や、Voice over IP(VoIP)やビデオなどのネットワークベースのサービスのエクスペリエンス メトリック、さらにはパケット キャプチャを使用した詳細で有用な問題分析が可能です。Cisco NAM には、Web ベースの Traffic Analyzer GUI が組み込まれており、設定メニューに簡単にアクセスして、Web、音声、およびビデオの各トラフィックに関する見やすいパフォーマンス レポートを表示できます。

Cisco 2900 シリーズまたは Cisco 3900 シリーズ サービス統合型ルータの第 2 世代(Cisco ISR G2)の SM スロットにインストールされている Cisco Services Ready Engine(SRE)Cisco Service Module(SM)は、Cisco IOS ソフトウェアを含むシスコ製、サードパーティ製、およびカスタムのアプリケーションをホストできるようにします。

このマニュアルでは、Cisco SRE サービス モジュールで Cisco NAM 5.1 をインストールおよび設定する方法について説明します。

内容

「Cisco SRE NAM の仕様」

「はじめに」

「Cisco SRE モジュール インターフェイスの設定」

「NAM ソフトウェアのインストール」

「管理用の Cisco SRE NAM の設定」

「ネットワーク接続用の Cisco SRE NAM の設定」

「NTP サーバを使用した NAM のシステム時刻の設定」

「NAM パケット モニタリングのイネーブル化」

「NAM Traffic Analyzer のイネーブル化とアクセス」

「NAM ルート パスワードの変更」

「NAM ルート パスワードのデフォルト値へのリセット」

「NAM への Telnet または SSH セッションの開始と終了」

「Cisco SRE NAM の管理」

「その他の参考資料」

「用語集」

「マニュアルの入手方法およびテクニカル サポート」

Cisco SRE NAM の仕様

次の項では、Cisco SRE NAM 5.1 の仕様について説明します。

サポートされる外部ソフトウェア インターフェイス

Cisco SRE NAM では、次の外部ソフトウェア インターフェイスをサポートします。

router/IOS の Telnet、SSH、およびセッション上の CLI

SNMP

HTTP/HTTPs

NetFlow データ エクスポート

サポートされるブランチ ルータ

Cisco SRE NAM は 表 1 に表示されたすべての Cisco ルータ プラットフォームの任意のネットワーク モジュール スロットに配置できます。1 つの Cisco NAM だけが Cisco ブランチ ルータに装着できます。

 

表 1 Cisco SRE NAM がサポートするルータ プラットフォーム

ルータ プラットフォーム
IOS バージョン(最小)

Cisco 3945E ISR

Cisco IOS 15.1(1T)

Cisco 3925E ISR

Cisco IOS 15.1(1T)

Cisco 3945 ISR

Cisco IOS 15.0(1)M

Cisco 3925 ISR

Cisco IOS 15.0(1)M

Cisco 2951 ISR

Cisco IOS 15.0(1)M

Cisco 2921 ISR

Cisco IOS 15.0(1)M

Cisco 2911 ISR

Cisco IOS 15.0(1)M

ルータで現在実行している IOS リリースを確認するには、 show version コマンドの出力を参照します。

サポートされている Cisco SRE サービス モジュール

Cisco SRE NAM 5.1 は、SM-SRE 700 シリーズおよび SM-SRE 900 シリーズのサービス モジュールをサポートします。Cisco SM-SRE は、Cisco 2911、Cisco 2921、Cisco 2951、または Cisco 3900 シリーズ ルータの SM スロットに取り付ける必要があります。

工場出荷時にハードウェア装着済みのすべての Cisco SM-SRE モデルは、 表 2 の一覧のとおりです。

表 2 Cisco SM-SRE ハードウェア

モデル
プロセッサ
ハード ディスク
メモリ
eUSB フラッシュ

SM-SRE-700-K9

1.86 GHz シングル コア

500 GB(SATA)

4 GB

2 GB

SM-SRE-900-K9

1.86 GHz
デュアル コア

2 X 500 GB(SATA)

4 GB

2 GB

SM-SRE のネットワーク モジュールを取り付ける必要がある場合は、次を参照してください。

『Connecting Cisco NAM Enhanced Network Modules to the Network』

http://www.cisco.com/en/US/docs/routers/access/interfaces/nm/hardware/installation/guide/namnme.htmll

『Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information』

http://www.cisco.com/en/US/docs/routers/access/interfaces/rcsi/IOHrcsi.html

『Cisco SRE Service Module Configuration and Installation Guide』

http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/ism-sm-sre.html

はじめに

NAM ソフトウェアのインストールを開始する前に、次を実行します。

ホスト ルータ内のネットワーク モジュールの場所を書き留めておきます。

slot :モジュールのルータ シャーシのスロットの数。モジュールのインストール後にこの情報を取得するには、ルータで show running-config コマンドを実行し、その出力で SM インターフェイスを確認します。

port :モジュール インターフェイスのポート番号。この値は常に 0 です。


「ルータ上の SRE インターフェイスの設定」および「セッションの終了」で、この情報が必要になります。


ダウンロード用の FTP または TFTP ファイル サーバにアクセスできることを確認します。

FTP ファイル サーバ:インストール、バックアップ、および復元に使用します。

TFTP ファイル サーバ:(FTP ファイル サーバに使用するマシン上で)インストールが失敗した場合に、boothelper を実行して復旧を行うときに使用します。

NAM ソフトウェア

NAM ソフトウェア アプリケーションは、Cisco IOS ソフトウェアを実行する Cisco アクセス ルータにプラグインされたネットワーク モジュール上に常駐します。

ネットワーク モジュールはスタンドアロンのサービス エンジンであり、ルータ上の Cisco IOS 設定に依存しない、独自のスタートアップ コンフィギュレーションと実行コンフィギュレーションを備えています。モジュールは、外部のコンソール ポートをサポートしていません。その代わりに、モジュールの設定セッションを使用して、ルータを介してモジュールを起動、設定できます。セッション後は、ルータの CLI に戻ってセッションをクリアしてください。

ホスト ルータおよびネットワーク モジュール(モジュールは「アプライアンス」または「ブレード」とも呼ばれ、ソフトウェアがインストールされると、「サービス」または「サービス エンジン」とも呼ばれます)は、ルータ統合アプリケーションプラットフォームを提供することによって、次のようなデータ集約型アプリケーションの処理を加速します。

アプリケーション指向のネットワーキング

コンタクト センターとインタラクティブな音声応答アプリケーション

コンテンツのキャッシングと配送

データとビデオの保管

ネットワーク解析

ボイスメールおよび自動応答アプリケーション

ハードウェア インターフェイス

ホスト ルータとネットワーク モジュールは、内部接続および外部接続にさまざまなインターフェイスを使用します(図 1 を参照)。それぞれのインターフェイスは、ルータから Cisco IOS CLI を使用して、またはモジュールからモジュールの CLI を使用して設定できます。

Cisco SRE NAM は、外部インターフェイスと内部インターフェイスの両方のトラフィックを同時にモニタリングできます。ただし、管理トラフィックに使用できるのは、どちらか 1 つだけです。

図 1 ルータとネットワークモジュールのインターフェイス

 

 

ハードウェア インターフェイス
適用する設定
使用する設定方法
1

ルータ インターフェイス
(たとえば、Gig0/0)

標準のルータの設定

ルータの Cisco IOS CLI

2

SM-SRE へのルータ側インターフェイス。

これは、ルータの sm インターフェイスです。

モジュールの IP アドレスとデフォルト ゲートウェイのルータ

3

SM-SRE の内部インターフェイス。

ギガビット イーサネット(GE)インターフェイスです。

他のすべてのモジュールおよび SM-SRE アプリケーション設定

モジュールの SM-SRE CLI、GUI、Telnet、SSH インターフェイス、または SNMP

4

SM-SRE の外部インターフェイス。ギガビット イーサネットインターフェイスです。

外部ソースからのデータ要求とデータ転送のサポート

Cisco SRE モジュール インターフェイスの設定

ここでは、Cisco IOS CLI を使用した SRE サービス モジュールの基本的なネットワーク パラメータの設定方法について説明します。ここでは、次のタスクについて説明します。

「ルータ上の SRE インターフェイスの設定」

「セッションの開始」

「セッションの終了」


) • 次のいずれかの手順の間に停電、切断が発生した場合、システムは通常、中断を検出し復旧を試みます。回復に失敗した場合は、IOS コマンドを使用してシステムを最初から再インストールします。「IOS コマンドを使用した Cisco SRE NAM のインストール」を参照してください。

ネットワークモジュールは、CLI または GUI を使用して設定できます。このドキュメントでは、CLI による設定手順について説明します。GUI による設定手順については、GUI のオンライン ヘルプを参照してください。


 

ルータ上の SRE インターフェイスの設定

最初の設定作業は、ホスト ルータおよび外部リンクへのネットワーク モジュール インターフェイスの設定です。これを設定することにより、モジュールにアクセスして SRE サービス モジュールをインストールし設定できるようになります。


) 最初のステップでは、ホスト ルータの CLI を開いて、ルータのモジュールへのインターフェイスにアクセスします。次のステップで、インターフェイスを設定します。


手順の概要

ホスト ルータの CLI から

1. enable

2. configure terminal

3. interface sm <slot> /0

4. ip address router-side-ip-address subnet-mask

または

ip unnumbered type number

5. (任意。ただし、実行した場合は、 ステップ 6 を省略) service-module ip address module-side-ip-address subnet-mask

6. (任意。ただし、実行した場合は、 ステップ 5 を省略) service-module external ip address external-ip-address subnet-mask


) ステップ 5 またはステップ 6 のいずれかを実行する必要があります。どちらも実行されていない場合、インストールは失敗します。


7. (任意) service-module ip default-gateway gateway-ip-address

8. end

9. copy running-config startup-config

10. show running-config

手順の詳細

 

コマンドまたはアクション
目的
 
ホスト ルータの CLI から

ステップ 1

enable

 

Router> enable

ホスト ルータで特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータでグローバル コンフィギュレーション モードを開始します。

ステップ 3

interface sm slot /0

 

Router(config)#
interface sm 1/0

ネットワーク モジュールが常駐するスロットとポートのインターフェイス コンフィギュレーション モードを入力します。

ステップ 4

ip address router-side-ip-address subnet-mask

 

または

ip unnumbered type number

 

Router(config-if)#
ip address 10.0.0.20 255.255.255.0

 

または

Router(config-if)# ip unnumbered ethernet 0/0

モジュールへのルータ インターフェイスを指定します。引数は次のとおりです。

router-side-ip-address subnet-mask :インターフェイスの IP アドレスとサブネット マスク。

type number :ルータに IP アドレスが指定された、もう 1 つのインターフェイスのタイプと番号。別のアンナンバード インターフェイスは指定できません。ハイ レベル データ リンク(HDLC)、ポイントツーポイント プロトコル(PPP)、平衡型リンクアクセス手順(LAPB)、フレームリレー カプセル化、シリアル ライン インターネット プロトコル(SLIP)を使用しているシリアル インターフェイスおよびトンネル インターフェイスは、アンナンバードでもかまいません。

ステップ 5

service-module ip address module-side-ip-address subnet-mask

 

Router(config-if)# service-module
ip address 172.0.0.20 255.255.255.0

ルータへのモジュール インターフェイスの IP アドレスを指定します。引数は次のとおりです。

module-side-ip-address :インターフェイスの IP アドレス

subnet-mask :IP アドレスに追加するサブネット マスクで、ホスト ルータと同じサブネットにあることが必要

このコマンドは、管理トラフィックの内部インターフェイスを選択して設定します。このコマンドを使用すると、SRE サービス モジュール CLI で ip interface internal コマンドと ip address <address> <mask> コマンドを使用するのと同じ結果が得られます。

を使用します。ステップ 5 またはステップ 6 のいずれかを実行する必要があります。どちらも実行されていない場合、インストールは失敗します。

ステップ 6

service-module external ip address external-ip-address subnet- mask

 

Router(config-if)# service-module external ip address 172.0.0.30 255.255.255.0

モジュール上の外部 LAN インターフェイスの IP アドレスを指定します。引数は次のとおりです。

external-ip-address :インターフェイスの IP アドレス

subnet-mask :IP アドレスに追加するサブネット マスク

このコマンドは、管理トラフィックの外部インターフェイスを選択して設定します。このコマンドを使用すると、SRE サービス モジュール CLI で ip interface external コマンドと ip address <address> <mask> コマンドを使用するのと同じ結果が得られます。

を使用します。ステップ 5 またはステップ 6 のいずれかを実行する必要があります。どちらも実行されていない場合、インストールは失敗します。

ステップ 7

service-module ip default-gateway gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.40

モジュールのデフォルト ゲートウェイ ルータの IP アドレスを指定します。引数は次のようになります。

gateway-ip-address :ゲートウェイ ルータの IP アドレス

を使用した場合のみ実行します。

ステップ 8

end

 

Router(config-if)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 9

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新規実行コンフィギュレーションを保存します。

ステップ 10

show running-config

 

Router# show running-config

アドレス設定を検証できるようにルータの実行コンフィギュレーションを表示します。

次の出力は show running-config コマンドの出力の一部で、インターフェイスがどのように設定されているかを示しています。

interface sm 1/0
ip address 10.0.0.20 255.255.255.0
service-module ip address 10.0.0.21 255.255.255.0
service-module ip default-gateway 10.0.0.20
 

セッションの開始

ここでは、SRE サービス モジュールのセッションを開始する方法を説明します。


) • アプリケーション ソフトウェアをインストールする前に、ブートローダを始動するセッションを開始します。ソフトウェアのインストール後、アプリケーションを始動するセッションを開始します。

同時に実行できるセッションは、1 つだけです。


 

手順の概要

ホスト ルータ CLI から

1. enable

2. service-module sm slot /0 session clear

3. service-module sm slot /0 session

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

ホスト ルータで特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

service-module sm slot /0 session clear

 

Router# service-module sm 1/0 session clear

[confirm]

[OK]

Router#

 

このセッションのログインの障害となる既存のセッションが存在しないことを確認します。

ステップ 3

service-module sm slot/0 session

 

Router# service-module sm 1/0 session

Trying 172.20.98.151, 2066 ... Open

 

Cisco Network Analysis Module (SM-SRE)

 

NAM.domain.name login:

 

指定したモジュールでセッションを開始します。

セッションの終了

ここでは、SRE サービス モジュール セッションを終了する方法を説明します。


) • アプリケーション ソフトウェアをインストールする前に、ブートローダを始動するセッションを開始します。ソフトウェアのインストール後、アプリケーションを始動するセッションを開始します。

同時に実行できるセッションは、1 つだけです。

NAM 5.1 では、CLI コマンド、 exit を実行すると、自動的にセッションが終了します。


 

手順の概要

セッションを終了するには、次の手順を実行します。

NAM CLI、NAM ログイン、NAM ヘルパー、または NAM ブートローダ プロンプトから

1. Control+Shift+6 x

ルータ プロンプト から

2. disconnect または
service-module sm
slot /0 session clear

手順の詳細

 

コマンドまたはアクション
目的
 
NAM CLI、NAM ログイン、NAM ヘルパー、または NAM ブートローダ プロンプトから

ステップ 1

Control+Shift+6 x を押します。

(注) このキーシーケンスによって、ルータ プロンプトが表示されます。

service-module セッションを閉じて、ルータの CLI に戻ります。

を押すことで、このセッションにルータ CLI から戻ることができます。

 
ホスト ルータ CLI から

ステップ 2

disconnect
or
service-module sm slot /0 session clear

 

Router# service-module sm 1/0 session clear

[confirm]

[OK]

Router#

指定したモジュールのセッション接続を切断するか、サービスモジュール セッションをクリアします。

このコマンドの実行を確認するプロンプトが表示されたら、 Enter キーを押します。

NAM ソフトウェアのインストール

ソフトウェアのインストールでは、ブートローダを使用します。これは、システムの電源を最初にオンにしたときに実行される小さなシステム ソフトウェアのセットです。ブートローダは、NAM アプリケーションをロードして実行します。またオプションとして、フラッシュ メモリ上でヘルパー イメージをロードして実行します。

ソフトウェアの再インストールには、ヘルパー イメージのインストール、設定、および起動が必要です。これにより、ヘルパーが NAM インストール ウィザードを起動し、ソフトウェアがインストールされます。


) ホスト ルータ上で実行中の全アプリケーションのサービスを停止したり、オフラインにしたりできる場合は、ソフトウェアのアップグレードまたはダウングレードも考慮に入れてください。


NAM ソフトウェア イメージ

Cisco SRE NAM には、次の 3 つの NAM ソフトウェア イメージが含まれています。

フラッシュ メモリ内のブートローダ:NAM アプリケーション イメージとヘルパー イメージのどちらを起動するかを指定するために使用します。

フラッシュ メモリ内のヘルパー イメージ:NAM ソフトウェア イメージの回復またはアップグレードに使用します。

ハード ドライブ上の NAM アプリケーション イメージ:NAM Traffic Analyzer および NAM CLI のソース。

NAM ソフトウェア アップグレードの種類

NAM ソフトウェアのアップグレードには次の 2 つの形式があります。

イメージ:ヘルパー イメージからインストールするフル イメージ リリース。フル イメージのアップグレードは、通常、NAM アプリケーション イメージのアップグレードに使用されます。必要に応じて、またはテクニカル サポートの勧めにより、ヘルパー イメージを使用してブートローダ イメージやヘルパー イメージのアップグレードも可能です。

パッチ:ソフトウェア バージョンへの差分アップデートであり、 patch NAM CLI コマンドを使用してインストールされます。パッチは NAM アプリケーション イメージ用のみを入手できます。

NAM アプリケーションへのパッチを追加するのか、フル ソフトウェア イメージのアップグレードを実行するのかに応じて、このセクションで説明する次の手順のいずれかを実行してください。

「IOS コマンドを使用した Cisco SRE NAM のインストール」:Cisco SRE NAM を初めてインストールする場合は、この手順を使用します。

「NAM CLI コマンドを使用した Cisco SRE NAM のアップグレード」:Cisco SRE NAM で既存の NAM をアップグレードする場合は、この手順を使用します。

「ヘルパーを使用して Cisco SRE NAM をインストールする」:アップグレード中にヘルパーをアクティブにするには、この手順を使用します。


) この方法を使用しないでください。IOS コマンドまたは CLI コマンドを使用してインストールすることを推奨します。


IOS コマンドを使用した Cisco SRE NAM のインストール

Cisco SRE NAM を初めてインストールしている場合は、次の IOS コマンドの方法を使用してインストールを実行する 必要があります


警告 このインストール方法は Cisco SM-SRE のハード ディスクを再フォーマットします。


はじめに

Cisco SRE NAM をインストールする前に、次の作業を実行します。

Cisco.com から NAM 5.1 ソフトウェア イメージをダウンロードします

イメージを FTP サーバにコピーします。

(任意)TFTP ファイル サーバの IP アドレスを使用できるように用意しておきます。

SM-SRE で Cisco NAM をインストールするには、次のリストのファイルが、同じディレクトリにあり、アクセス可能でなければなりません。

application(bin.gz)

helper

install.sre

install.sre.header

tcl signature

smbootloader

これらのファイルでは名前付けが重要です。これらのファイルはすべて、正しく名前付けされている場合に zip ファイルとして使用できるようになります。名前の語幹はアプリケーション イメージの名前です。これらの以外のファイルには、拡張子が付けられています。

SRE インストール プロセスは、まず IOS から tcl ファイルおよびヘルパーをロードします。tcl ファイルは IOS で実行されます。ブートローダは、ルータからヘルパー イメージをロードするように指示されます。インストール URL がヘルパー イメージに渡され、ヘルパーがブートローダおよびアプリケーション イメージをロードしてインストールします。


) ヘルパーは、名前解決を行わないため、URL では数字の IP アドレスを使用する必要があります。URL にはパスワードが含まれている必要があります。


一般的な操作手順については、次の『 Cisco SRE Service Module Configuration and Installation Guide 』を参照してください。

http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/ism-sm-sre.html

手順

SRE のインストールは、すべての SRE アプリケーションに共通のインストール手順です。これは IOS プロンプトから制御されます。


) ハード ドライブを初期化し、Cisco NAM ソフトウェアをインストールするには時間がかかります。


次の手順を実行します。


ステップ 1 NAM に telnet します。

ステップ 2 NAM から、ブートローダを開始します。NAM CLI から reboot と入力し、 Confirm=Yes を選択します。

システムがリブート時に、次のプロンプトが表示されます。

Enter *** to change boot configuration:
 

ステップ 3 *** と入力します。

1 分以内に *** を入力してください。そうしない場合は、ブートローダにブレークできなくなります。

ステップ 4 image ディレクトリに移動し、ZIP ファイルを展開します。

例:

namlab-pc7.cisco.com% unzip nam-app-x86_64.5-1-0-7.bin.gz.zip
Archive: nam-app-x86_64.5-1-0-7.bin.gz.zip
replace nam-app-x86_64.5-1-0-7.bin.gz? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: nam-app-x86_64.5-1-0-7.bin.gz.helper
inflating: nam-app-x86_64.5-1-0-7.bin.gz.install.sre
inflating: nam-app-x86_64.5-1-0-7.bin.gz.install.sre.header
inflating: nam-app-x86_64.5-1-0-7.bin.gz.key
inflating: nam-app-x86_64.5-1-0-7.bin.gz.smbootloader
 

ステップ 5 IOS CLI から service-module sm3/0 install url ftp://<file-location> コマンドを発行します。この例では、SM-SRE はスロット 3 にあります。

例:

MACE-3945-CORE-28#service-module sm3/0 install url ftp://ftp@172.20.98.174 pub/nam/interim/5-1/nam-app-x86_64.5-1-0-7.bin.gz
Delete the installed Network Analysis Module (NAM) and proceed with new installation? [no]: yes
Loading pub/nam/interim/5-1/nam-app-x86_64.5-1-0-7.bin.gz.install.sre !
[OK - 2853/4096 bytes]
Resource requirements check completed successfully. Proceeding to Install....
MACE-3945-CORE-28#term mon
MACE-3945-CORE-28#
*Dec 6 19:44:42.219: %SM_INSTALL-6-INST_RESET: SM3/0 is reset for software installation.
*Dec 6 19:45:50.323: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP Registration Request
*Dec 6 19:45:50.327: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP File Request
*Dec 6 19:45:51.955: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP File Request
*Dec 6 19:46:01.759: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP File Request
*Dec 6 19:46:01.875: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP File Request
*Dec 6 19:46:22.199: %SRE_SM-6-STATE_CHANGE: SM3/0 changing state from SERVICE_MODULE_STATE_ERRQ to SERVICE_MODULE_STATE_STDY
*Dec 6 19:46:39.755: %SM_INSTALL-6-INST_PROG: SM3/0 PROGRESSING: updated bootloader.
*Dec 6 19:46:39.755: %SM_INSTALL-6-INST_PROG: SM3/0 PROGRESSING: starting download of ftp://ftp@172.20.98.174/pub/nam/interim/5-1/nam-app-x86_64.5-1-0-7.bin.gz.
*Dec 6 19:55:42.155: %SM_INSTALL-6-INST_SUCC: SM3/0 SUCCESS: Application image
upgrade complete..
*Dec 6 19:57:00.299: %SM_INSTALL-6-INST_RBIP: SM3/0 received msg: RBIP Registration Request
 
 

メッセージ「 Application image upgrade complete. 」が表示されると、Cisco SRE NAM インストールが完了します。


 

NAM CLI コマンドを使用した Cisco SRE NAM のアップグレード


) このインストール方法は Cisco SRE NAM アップグレード専用です。ハード ドライブは再フォーマットされません。


手順

次の手順を実行します。


ステップ 1 Cisco 2900 シリーズまたは Cisco 3900 シリーズの ISR ルータに telnet します。

ステップ 2 Cisco SRE NA セッションを起動するには、次を入力します。次の slot を SM-SRE を含むスロットの数に置き換えます。

service-module sm slot /0 session

ステップ 3 root として NAM CLI にログインします。

ステップ 4 次のコマンドを入力します。

Upgrade ftp://ftp@FileServer//FilePath

ステップ 5 Do you want to proceed with installation 」のメッセージが表示された場合は、 Yes と入力します。

アップグレードの完了後、システムは自動的にリブートされます。


 

ヘルパーを使用して Cisco SRE NAM をインストールする

この方法は、アップグレードに使用できます。


) この方法を使用しないでください。「IOS コマンドを使用した Cisco SRE NAM のインストール」で説明されているように IOS コマンドを使用するか、または「NAM CLI コマンドを使用した Cisco SRE NAM のアップグレード」で説明されているように CLI コマンドを使用することを推奨します。



ステップ 1 Cisco 2900 シリーズまたは Cisco 3900 シリーズの ISR ルータに telnet します。

ステップ 2 Cisco SRE NAM セッションを起動するには、次を入力します。次の slot を SM-SRE を含むスロットの数に置き換えます。

service-module sm slot /0 session

ステップ 3 root として NAM CLI にログインします。

ステップ 4 次のコマンドを入力します。

reboot -helper

NAM システムはリブートしてからヘルパーを起動します。

ステップ 5 ヘルパーのメニューが表示されたら、他の機能とともに新しいインストール(ディスクを再フォーマットする)とアップグレード(ディスクは再フォーマットされない)の選択肢があります。

アップグレードを実行する場合は [1] を選択します。アップグレードの完了後、システムは自動的にリブートされます。

新規インストールを実行する場合は [2] を選択します。メッセージ「 Application image upgrade complete. 」が表示されると、Cisco SRE NAM インストールが完了します。


 

管理用の Cisco SRE NAM の設定

Cisco SRE NAM には内部ギガビット イーサネット インターフェイスと外部インターフェイスがあります。NAM web GUI、 telnet または ssh などの NAM 管理トラフィックにはどちらのインターフェイスでも使用できますが、両方の使用はできません。NAM 内部インターフェイスの設定によって、IP アンナンバードまたはルーティング可能なサブネットのいずれかを使用します。

次の各セクションでは、Cisco SRE NAM 内部インターフェイスを管理用に設定する方法について説明します。

「管理用の内部インターフェイスの設定:IP アンナンバード」

「管理用の内部インターフェイスの設定:ルーティング可能なサブネット」

「管理用の外部インターフェイスの設定」

「NAM コンソール回線での AAA ログイン認証のディセーブル化」

管理用の内部インターフェイスの設定:IP アンナンバード

ここでは、Cisco SRE NAM 内部インターフェイスを IP アンナンバード用に設定する方法を説明します。


) アドレスは、インターフェイス アドレス用(ステップ 4)、NAM アドレス用(ステップ 6 ~ 9)、および NAM デフォルト ゲートウェイ アドレス用(ステップ 7)が、すべて同じサブネットに存在する必要があります。


手順の概要

ルータ プロンプトから

1. enable

2. configure terminal

3. interface sm slot /0

4. ip unnumbered <interface> <number>

5. no shutdown

6. service-module ip address <NAM-Address> <subnetmask>

7. service-module ip default-gateway <NAM-Default-Gateway-Address>

8. exit

9. ip route <NAM-Address> 255.255.255.255 sm slot /0

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

IOS の EXEC モードを開始します。

ステップ 2

configure terminal

ターミナル モードから IOS 設定を開始します。

ステップ 3

interface sm slot/0

サービス モジュール インターフェイスの IOS インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered <interface> <number>

 

Router (config-if)# ip unnumbered gigabitethernet 0/1

<interface> で設定されたアドレスを借用します。この例では、インターフェイス sm 1/0 は、gigabitethernet0/1 インターフェイスに設定されたアドレスを借用します。

ステップ 5

no shutdown

sm のインターフェイスをイネーブルにします。

ステップ 6

service-module ip address <NAM-Address> <subnetmask>

 

Router (config-if)# service-module ip address 209.165.200.226 255.255.255.224

NAM 内部インターフェイスへの <NAM-Address> を設定します。

ステップ 7

service-module ip default-gateway <NAM-Default-Gateway-Address>

 

 

Router (config-if)# service-module ip default-gateway 209.165.200.225

 

NAM のデフォルト ゲートウェイ アドレスを設定します。

ステップ 8

exit

ルータ インターフェイス コンフィギュレーション モードから、ルータ グローバル コンフィギュレーション モードに移行します。

ステップ 9

ip route <NAM-Address> 255.255.255.255 sm slot/0

 

Router(config)# ip route 209.165.200.226 255.255.255.255 sm 1/0

 

NAM 管理アドレスのための完全な 32 ビット スタティック ルートを設定します。

ステップ 10

end

ルータ コンフィギュレーション モードを終了します。

設定例

この設定例の内容は次のとおりです。

内部 NAM インターフェイスはトラフィックの管理に使用されます。

ルーティング可能な同じサブネットからの IP アドレスは、サービス モジュール インターフェイスおよび NAM システムに割り当てられます

IP アドレス空間を節約するために、サービス モジュール インターフェイスを IP アンナンバードとして設定して、ギガビット イーサネット インターフェイスの IP アドレスを借ります。

サービス モジュール インターフェイスを介した NAM へのスタティック ルートが設定されます。

内部 NAM インターフェイスは、インターフェイス Serial 0/0 上の WAN トラフィックのモニタリングに使用され、外部 NAM インターフェイスは、インターフェイス、ギガビット イーサネット 0/0 上の LAN トラフィックのモニタリングに使用されます。

SM-SRE は、ルータのスロット 2 にインストールされます。

ルータの設定(Cisco IOS ソフトウェア)

!
interface GigabitEthernet0/0
ip address 209.165.200.225 255.255.255.224
duplex auto
speed auto
analysis-module monitoring
!
interface Integrated-Service-Engine2/0
ip unnumbered GigabitEthernet0/0
ip nbar protocol-discovery
no keepalive
!
!
ip route 209.165.200.226 255.255.255.255 Integrated-Service-Engine2/0
!
!
 

NAM の設定(NAM ソフトウェア)

root@myNAM.company.com# show ip
IP address: 209.165.200.226
Subnet mask: 255.255.255.224
IP Broadcast: 209.165.200.255
IP Interface: Internal
DNS Name: myNAM.company.com
Default Gateway: 209.165.200.225
Nameserver(s): 171.69.2.133
HTTP server: Enabled
HTTP secure server: Disabled
HTTP port: 80
HTTP secure port: 443
TACACS+ configured: No
Telnet: Enabled
SSH: Disabled
 

管理用の内部インターフェイスの設定:ルーティング可能なサブネット

ここでは、ルーティング可能なサブネット方式を使用して、SM-SRE の内部インターフェイスを管理用に設定する方法を説明します。

手順の概要

ルータ プロンプトから

1. enable

2. configure terminal

3. interface sm slot/0

4. ip address <router-side-address> <subnetmask>

5. no shutdown

6. service-module ip address <NAM-Address> <subnetmask>

7. service-module ip default-gateway <router-side-address>

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

IOS の EXEC モードを開始します。

ステップ 2

configure terminal

ターミナル モードから IOS 設定を開始します。

ステップ 3

interface sm slot /0

integrated-service-engine インターフェイスの IOS インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address <router-side-address> <subnetmask>

 

Router (config-if)# ip address 209.165.200.225 255.255.255.224

integrated-service-engine インターフェイスへのルーティング可能なアドレスを設定します。

ステップ 5

no shutdown

integrated-service-engine インターフェイスを開始します。

ステップ 6

service-module ip address <NAM-Address> <subnetmask>

 

Router (config-if)# service-module ip address 209.165.200.226 255.255.255.224

 

NAM 内部インターフェイスへの NAM-Address を設定します。

(注) NAM-Address は、router-side-address と同じサブネットに存在する必要があります。

ステップ 7

service-module ip default-gateway <router-side-address>

 

Router (config-if)# service-module ip default-gateway 209.165.200.225

 

NAM デフォルト ゲートウェイ アドレスを、router-side-address である integrated-service-engine インターフェイス アドレスに設定します。

ステップ 8

end

ルータ コンフィギュレーション モードを終了します。

設定例

この設定例の内容は次のとおりです。

内部 NAM インターフェイスはトラフィックの管理に使用されます。

integrated-service-engine インターフェイスと NAM システムに対し、同じルーティング可能なサブネットから IP アドレスが割り当てられます。

Integrated-Service-Engine インターフェイス経由で NAM にアクセスするスタティック ルートが設定されます。

内部 NAM インターフェイスは、インターフェイス Serial 0/0 上の WAN トラフィックのモニタリングに使用され、外部 NAM インターフェイスは、インターフェイス、ファスト イーサネット 0/0 上の LAN トラフィックのモニタリングに使用されます。

SM-SRE は、ルータのスロット 2 にインストールされます。

ルータの設定(Cisco IOS ソフトウェア)

!
interface sm2/0
ip address 209.165.200.225 255.255.255.224
 
 
ip route 209.165.200.226 255.255.255.255 Integrated-Service-Engine1/0
 
 

NAM の設定(NAM ソフトウェア)

root@myNAM.company.com# show ip
IP address: 209.165.200.226
Subnet mask: 255.255.255.224
IP Broadcast: 209.165.200.255
IP Interface: Internal
DNS Name: myNAM.company.com
Default Gateway: 209.165.200.225
Nameserver(s): 171.69.2.133
HTTP server: Enabled
HTTP secure server: Disabled
HTTP port: 80
HTTP secure port: 443
TACACS+ configured: No
Telnet: Enabled
SSH: Disabled
 

管理用の外部インターフェイスの設定

ここでは、SM-SRE を NAM 管理トラフィック用の外部インターフェイスとして使用するための設定方法について説明します。

手順の概要

ルータ プロンプトから

1. enable

2. configure terminal

3. interface loopback <loopback-number>

4. ip address <bogus-address> <subnetmask>

5. no shutdown

6. exit

7. interface sm slot/0

8. ip unnumbered loopback <loopback-number>

9. no shutdown

10. service-module external ip address <NAM-Address> <subnetmask>

11. service-module ip default-gateway <NAM-Default-Gateway-Address>

12. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

IOS の EXEC モードを開始します。

ステップ 2

configure terminal

ターミナル モードから IOS 設定を開始します。

ステップ 3

interface loopback <loopback-number>

 

Router (config)# interface loopback 0

Router (config-if)#

ルータ上にループバック インターフェイス 0 を作成します。

ステップ 4

ip address <bogus-address> <subnetmask>

 

Router(config-if)# ip address 10.1.1.1 255.255.255.0

 

ループバック インターフェイス上に偽のアドレスを設定します。この例では、インターフェイス loopback0 にアドレス 10.1.1.1/24 が割り当てられています。

ステップ 5

no shutdown

 

ループバック インターフェイスをイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

Router(config)#

 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに移行します。

ステップ 7

interface sm slot /0

 

integrated-service-engine インターフェイスの IOS インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip unnumbered loopback <number>

 

Router (config-if)# ip unnumbered loopback 0

 

ステップ 4 でループバック インターフェイスに設定されたアドレスを借用します。

ステップ 9

no shutdown

integrated-service-engine インターフェイスを開始します。

ステップ 10

service-module external ip address <NAM-Address> <subnetmask>

 

Router (config-if)# service-module external ip address 209.165.201.2 255.255.255.224

 

NAM 外部インターフェイスへの <NAM-Address> を設定します。

ステップ 11

service-module ip default-gateway <NAM-Default-Gateway-Address>

 

Router (config-if)# service-module ip default-gateway 209.165.201.222

 

NAM のデフォルト ゲートウェイ アドレスを設定します。

ステップ 12

end

ルータ コンフィギュレーション モードを終了します。

設定例

この設定例の内容は次のとおりです。

外部 NAM インターフェイスはトラフィックの管理に使用されます。

Integrated-Service-Engine インターフェイスは、IP アンナンバードとして設定され、ループバック インターフェイスの IP アドレスを借用します。

借りたループバック インターフェイスの IP アドレスはルーティングできません。

NAM システムには、外部 NAM インターフェイスに接続された LAN サブネットからの IP アドレスが設定されます。

内部 NAM インターフェイスは、インターフェイス Serial 0/0 上の WAN トラフィックのモニタリングに使用され、外部 NAM インターフェイスは、インターフェイス、ファスト イーサネット 0/0 上の LAN トラフィックのモニタリングに使用されます。

SM-SRE は、ルータのスロット 3 にインストールされます。

ルータの設定(Cisco IOS ソフトウェア)

!
interface loopback 0
ip address 10.1.1.1 255.255.255.0
!
!
interface sm3/0
ip unnumbered loopback 0
no shutdown
!
 

NAM の設定(NAM ソフトウェア)

root@myNAM.company.com# show ip
IP address: 209.165.201.2
Subnet mask: 255.255.255.224
IP Broadcast: 209.165.201.223
IP Interface: External
DNS Name: myNAM.company.com
Default Gateway: 209.165.201.222
Nameserver(s): 171.69.2.133
HTTP server: Enabled
HTTP secure server: Disabled
HTTP port: 80
HTTP secure port: 443
TACACS+ configured: No
Telnet: Enabled
SSH: Disabled
 

NAM コンソール回線での AAA ログイン認証のディセーブル化

ルータ上で認証、許可、アカウンティング(AAA)を設定している場合、ルータから NAM コンソール セッションを開始するために、ユーザ名とパスワードを使用したログインと、NAM ログインとパスワードを使用したログインの 2 回のログインが必要になることがあります。

2 回のログインを行わずにルータから NAM コンソール セッションを開始するには、この手順を実行して、ルータの NAM コンソール ライン上で、AAA ログイン認証をディセーブルにします。

ただし、SM-SRE とともにシスコの侵入検知システムである NM-CIDS を使用している場合、AAA は両方のネットワーク モジュールへのアクセスを一元的に制御する便利なツールとなります。AAA の詳細については、対象の Cisco IOS Release の『 Cisco IOS Security Configuration Guide 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. aaa authentication login list-name none

4. line number

5. login authentication list-name

6. end

7. show running-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

aaa authentication login list-name none

 

Router(config)# aaa authentication login name none

ローカルな認証リストを作成します。

none キーワードは、このリストに対して認証を指定しません。

ステップ 4

line number

 

Router(config)# line 33

認証リストを適用する回線のライン コンフィギュレーション モードを開始します。

number の値は、SM-SRE がインストールされているスロット番号を使用して、次のように算出されます。

number = (32 x slot ) + 1(Cisco 3700 シリーズの場合)

number = ( (32 x slot ) + 1) x 2(Cisco 2800 シリーズおよび Cisco 3800 シリーズの場合)

ステップ 5

login authentication list-name

 

Router(config-line)# login authentication name

回線に認証リストを適用します。

ステップ 3 で設定した認証リスト名を指定します。

ステップ 6

end

 

Router(config-line)# end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

 

Router# show running-config

現在実行中のコンフィギュレーション ファイルの内容を表示します。

ローカル認証リストが設定され、SM-SRE に対応するラインに適用されたことを確認します。

ネットワーク接続用の Cisco SRE NAM の設定

ここでは、Cisco SRE NAM のネットワーク接続を確立し、IP パラメータを設定する方法について説明します。この作業は、NAM CLI から実行する必要があります。高度な NAM 設定を行うには、NAM Traffic Analyzer(Web GUI)を使用するか、使用している NAM ソフトウェア リリースの『 Network Analysis Module Command Reference 』を参照してください。

前提条件

この手順を実行する前に、NAM コンソールにアクセスします。「セッションの開始」を参照してください。

手順の概要


「管理用の内部インターフェイスの設定:IP アンナンバード」(P.-16)または「管理用の外部インターフェイスの設定」(P.-20)を使用して、SM-SRE を管理用に設定した場合、ステップ 1 と 2 は、すでに完了している可能性があります。


1. ip interface { internal | external }

2. ip address ip-address subnet-mask

3. (任意) ip broadcast broadcast-address

4. ip gateway ip-address

5. exsession on
または
exsession on ssh

6. ip domain name

7. ip host name

8. ip nameserver ip-address [ ip-address ][ ip-address ]

9. ping { host | ip-address }

10. show ip

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

ip interface { internal | external }

 

root@localhost# ip interface internal

 

root@localhost# ip interface external

管理トラフィックを処理する NAM インターフェイスを指定します。

ステップ 2

ip address ip-address subnet-mask

 

root@localhost# ip address 172.20.104.126 255.255.255.248

NAM システムの IP アドレスを設定します。

ステップ 3

ip broadcast broadcast-address

 

root@localhost# ip broadcast 10.255.255.255

(任意)NAM システムのブロードキャスト アドレスを設定します。

ステップ 4

ip gateway ip-address

 

root@localhost# ip gateway 172.20.104.125

NAM システムのデフォルト ゲートウェイ アドレスを設定します。

ステップ 5

exsession on

 

または

exsession on ssh

 

root@localhost# exsession on

 

root@localhost# exsession on ssh

(任意)外部ログインをイネーブルにします。

exsession on は Telnet アクセスをイネーブルにします。

exsession on ssh は SSH アクセスをイネーブルにします。

を参照してください。

ステップ 6

ip domain name

 

root@localhost# ip domain company.com

(任意)NAM システムのドメイン名を設定します。

ステップ 7

ip host name

 

root@localhost# ip host nam1

(任意)NAM システムのホスト名を設定します。

ステップ 8

ip nameserver ip-address [ ip-address ][ ip-address ]

 

root@nam1# ip nameserver 209.165.201.1

(任意)NAM システムのネーム サーバを 1 つまたは複数設定します。

ドメイン ネーム システム(DNS)要求を解決するために、NAM システムのネーム サーバを設定することを推奨します。

ステップ 9

ping { host | ip-address }

 

root@nam1# ping 10.20.30.40

ネットワーク デバイスとの接続を確認します。

ルータまたは別の既知のホストとの接続を確認します。

ステップ 10

show ip

 

root@nam1# show ip

NAM の IP パラメータを表示します。

SRE NAM が正しく設定されていることを確認します。

ここで紹介する例は、次のとおりです。

「SM-SRE の設定」

「Ping を使用したネットワーク接続の確認」

「show ip NAM CLI コマンドの出力例」

SM-SRE の設定

次の例では、外部 NAM インターフェイスはトラフィックの管理に使用されます。HTTP サーバおよび Telnet アクセスはイネーブルに設定します。その結果、 root@nam1.company.com# という NAM CLI プロンプトが表示されます。

root@nam.domain.name# ip interface external
 
root@nam.domain.name# ip address 172.20.105.215 255.255.255.192
root@nam.domain.name# ip domain company.com
root@nam.company.com# ip host myNAM
root@myNAM.company.com# ip nameserver 209.165.201.29
root@myNAM.company.com# ip gateway 172.20.105.210
root@myNAM.company.com# exsession on
root@myNAM.company.com# ip http server enable
Enabling HTTP server...
 
No web users are configured.
Please enter a web administrator user name [admin]:
New password:
Confirm password:
 
User admin added.
Successfully enabled HTTP server.
 

Ping を使用したネットワーク接続の確認

root@myNAM.company.com# ping 172.20.98.129
PING 172.20.98.129 (172.20.98.129) 56(84) bytes of data.
64 bytes from 172.20.98.129: icmp_seq=1 ttl=254 time=1.27 ms
64 bytes from 172.20.98.129: icmp_seq=2 ttl=254 time=1.13 ms
64 bytes from 172.20.98.129: icmp_seq=3 ttl=254 time=1.04 ms
64 bytes from 172.20.98.129: icmp_seq=4 ttl=254 time=1.08 ms
64 bytes from 172.20.98.129: icmp_seq=5 ttl=254 time=1.11 ms
 
--- 172.20.98.129 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4003ms
rtt min/avg/max/mdev = 1.043/1.129/1.278/0.090 ms
root@myNAM.company.com#
 

show ip NAM CLI コマンドの出力例

root@nam1.company.com# show ip
 
IP address: 172.20.105.215
Subnet mask: 255.255.255.192
IP Broadcast: 10.255.255.255
IP Interface: External
DNS Name: nam1.company.com
Default Gateway: 172.20.105.210
Nameserver(s): 209.165.201.29
HTTP server: Enabled
HTTP secure server: Disabled
HTTP port: 80
HTTP secure port: 443
TACACS+ configured: No
Telnet: Enabled
SSH: Disabled
root@nam1.company.com#
 

次の作業

内部 NAM インターフェイスでトラフィックをモニタする場合は、「NAM パケット モニタリングのイネーブル化」に進みます。

内部 NAM インターフェイスでトラフィックをモニタしない場合は、「NAM Traffic Analyzer のイネーブル化とアクセス」に進みます。

NTP サーバを使用した NAM のシステム時刻の設定

Cisco SRE NAM は、外部 NTP サーバから UTC(GMT)を取得します。NAM の時刻の取得後に、[NAM System Time Configuration] 画面を使用してローカル時間帯を設定できます。


注意 クライアント コンピュータと NAM サーバは、それぞれのタイム ゾーンの時刻を正確に設定する必要があります。クライアントまたはサーバ時間に誤りがあれば、GUI に表示されるデータに誤りが生じます。

NTP サーバを使用して NAM のシステム時刻を設定するには、次の手順を実行します。


ステップ 1 NAM アプライアンス GUI で、[Administration] > [System] > [System Time] を選択します。

ステップ 2 [NTP Server] オプション ボタン を選択します。

ステップ 3 1 つまたは 2 つの NTP サーバ名または IP アドレスを、[NTP sever name] テキスト ボックスまたは [IP Address] テキスト ボックスに入力します。

ステップ 4 地域とローカル タイム ゾーンをリストから選択します。

ステップ 5 次のどちらかを実行します。

[Submit] をクリックして変更を保存します。

設定を変更しない場合は、[Reset] をクリックします。


 

NAM パケット モニタリングのイネーブル化

ここでは、内部 NAM インターフェイスでモニタするルータ インターフェイスの NAM パケット モニタリングをイネーブルにする方法について説明します。

インターフェイス上で NAM パケットのモニタリングをイネーブルにすると、そのインターフェイス上で送受信された各 IP パケットの余分のコピーが、シスコ エクスプレス フォワーディングによって、ルータの Integrated-Service-Engine インターフェイスと内部 NAM インターフェイス経由で NAM に送信されます。

手順の概要

1. enable

2. configure terminal

3. ip cef

4. interface type slot / port
または
interface type slot / wic-slot / port

5. analysis-module monitoring

6. NAM がモニタする各インターフェイスに対して、ステップ 4ステップ 5 を繰り返します。

7. end

8. show running-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングのスイッチング パスをイネーブルにします。

ステップ 4

interface type slot / port

または

interface type slot / wic-slot / port

 

Router(config)# interface serial 0/0

設定するインターフェイスを選択します。

ステップ 5

analysis-module monitoring

 

Router(config-if)# analysis-module monitoring

インターフェイスで NAM パケット モニタリングをイネーブルにします。

ステップ 6

NAM が内部 NAM インターフェイスでモニタする各インターフェイスに対して、ステップ 4ステップ 5 を繰り返します。

--

ステップ 7

end

 

Router(config-if)# end

Router#

 

特権 EXEC モードに戻ります。

ステップ 8

show running-config

 

Router# show running-config

現在実行中のコンフィギュレーション ファイルの内容を表示します。

シスコ エクスプレス フォワーディングのスイッチング パスをイネーブルにし、正しいインターフェイス上でパケット モニタリングをイネーブルにしたことを確認します。

ここでは、次の例について説明します。

「NAM パケット モニタリングのイネーブル化」

NAM パケット モニタリングのイネーブル化

次の例では、シリアル インターフェイスで NAM パケット モニタリングをイネーブルにします。

interface Serial 0/0
ip address 172.20.105.213 255.255.255.240
ip route-cache flow
speed auto
full-duplex
analysis-module monitoring
no mop enabled
!
interface Serial 0/1
ip address 172.20.105.53 255.255.255.252
ip route-cache flow
duplex auto
speed auto
analysis-module monitoring
!
interface Integrated-Service-Engine 2/0
ip address 10.1.1.1 255.255.255.0
hold-queue 60 out
!

NAM Traffic Analyzer のイネーブル化とアクセス

ここでは、NAM Traffic Analyzer(Web GUI)をイネーブルにし、アクセスする方法について説明します。

前提条件

使用している Web ブラウザが、対象の NAM ソフトウェア リリースをサポートしていることを確認します。サポートされているブラウザについては、次のアドレスで『 Release Notes for the Network Analysis Module Software, Release 5.1 』を参照してください。

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.1/release/notes/nam50note.html

手順の概要

1. ルータから NAM コンソール セッションを開きます。「セッションの開始」を参照してください。
または
NAM への Telnet または SSH セッションを開きます。「NAM への Telnet または SSH セッションの開始と終了」を参照してください。

2. ip http server enable
または
ip http secure server enable

3. Web ユーザ名を入力します。
または
Return を押して、デフォルトの Web ユーザ名「admin」を入力します。

4. パスワードを入力します。

5. 再度パスワードを入力します。

6. PC で Web ブラウザを開きます。

7. Web ブラウザで、URL として NAM システムの IP アドレスまたはホスト名を入力します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

ルータから NAM コンソール セッションを開きます。「セッションの終了」を参照してください。

または

NAM への Telnet または SSH セッションを開きます。「NAM への Telnet または SSH セッションの開始と終了」を参照してください。

NAM CLI にアクセスします。

ステップ 2

ip http server enable

 

または

ip http secure server enable

 

root@localhost# ip http server enable

 

root@localhost# ip http secure server enable

HTTP サーバをイネーブルにします。

または

HTTP セキュア サーバ(HTTPs)をイネーブルにします。

ステップ 3

Web ユーザ名を入力します。

または

Return を押して、デフォルトの Web ユーザ名「 admin 」を入力します。

 

Please enter a web administrator user name [admin]: joeadmin

 

Please enter a web administrator user name [admin]: <CR>

Web ユーザ名を設定します。

NAM では、少なくとも 1 つの Web ユーザ名とパスワードの設定が必要です。

NAM で Web ユーザ名とパスワードが要求されない場合は、少なくとも 1 つの Web ユーザ名とパスワードの組み合わせが以前に設定されています。

ステップ 4

パスワードを入力します。

 
New password: <adminpswd>

Web ユーザ名のパスワードを設定します。

ステップ 5

再度パスワードを入力します。

 
Confirm password: <adminpswd>

Web ユーザ名のパスワードを確認します。

ステップ 6

PC で Web ブラウザを開きます。

--

ステップ 7

Web ブラウザで、URL として NAM システムの IP アドレスまたはホスト名を入力します。

 

http://172.20.105.215/

 

https://172.20.105.215/

 

http://nam1/

Web ブラウザで NAM Traffic Analyzer を開きます。

NAM Traffic Analyzer のログイン ページに自動的にリダイレクトされます。

ここで紹介する例は、次のとおりです。

「NAM Traffic Analyzer の有効化」

「NAM Traffic Analyzer へのアクセス」

NAM Traffic Analyzer の有効化

root@nam1# ip http server enable
Enabling HTTP server...
 
No web users are configured.
Please enter a web administrator user name [admin]: <CR>
New password: <pswd>
Confirm password: <pswd>
 
User admin added.
Successfully enabled HTTP server.
root@nam1#

NAM Traffic Analyzer へのアクセス

Web ブラウザに URL として NAM システムの IP アドレスまたはホスト名を入力すると、NAM Traffic Analyzer ログイン ウィンドウが表示されます。システムを開始するには、ユーザ名とパスワードを入力してログイン ボタンをクリックする必要があります。

次の作業

NAM Traffic Analyzer については、対象の NAM ソフトウェア リリースのユーザ ガイドを参照してください。このドキュメントは、NAM Traffic Analyzer アプリケーションのオンライン ヘルプまたは Cisco.com の次の URL で参照できます。

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.1/user/guide/nam50_ug.html

NAM ルート パスワードの変更

ここでは、NAM CLI コマンドを入力できる NAM のルート(読み書き)レベルへのアクセス パスワードを新たに設定します。出荷時設定のデフォルト ルート パスワードは、 root です。

前提条件

このタスクを実行する前に、「セッションの終了」で説明する手順を実行して、NAM コンソールにアクセスしてください。

手順の概要

1. password root

2. 新しいパスワードを入力します。

3. 再度、新しいパスワードを入力します。

4. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

password root

 

root@localhost.company.com# password root

NAM ルート(読み書き)レベル パスワードの変更手順を開始します。

ステップ 2

新しいパスワードを入力します。

 

New UNIX password: <password>

新しいパスワードを入力します。

ステップ 3

再度、新しいパスワードを入力します。

 

Retype new UNIX password: <password>

新しいパスワードを確認します。

ステップ 4

exit

 

root@localhost# exit

NAM システムからログアウトします。

ここで紹介する例は、次のとおりです。

「NAM ルート パスワードの変更」

「NAM ルート パスワードの確認」

 

NAM ルート パスワードの変更

root@nam1.company.com# password root
Changing password for user root
New UNIX password: <rtpswd>
Retype new UNIX password: <rtpswd>
passwd:all authentication tokens updated successfully
root@nam1.company.com#
root@nam1.company.com# exit

NAM ルート パスワードの確認

nam1.company.com login: root
Password: <rtpswd>
Terminal type: vt100
 
Cisco Network Analysis Module (SM-SRE) Console, 5.1
Copyright (c) 2007-2010 by Cisco Systems, Inc.
 
root@nam1.company.com#
root@nam1.company.com# exit

トラブルシューティングのヒント

NAM のルート パスワードを忘れてしまった場合の詳細については、「NAM ルート パスワードのデフォルト値へのリセット」を参照してください。

NAM ルート パスワードのデフォルト値へのリセット

この手順では、NAM ルート パスワードをデフォルト値の root にリセットします。この手順は、NAM ルート パスワードを忘れてしまったが、NAM CLI にアクセスする必要がある場合に使用します。

手順の概要

1. enable

2. service-module sm slot /0 password-reset

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

service-module sm slot /0 password- reset

 

 

Router# service-module sm 1/0 password-reset

SM-SRE にソフトウェアを再ロードします。

トラブルシューティングのヒント

ルータから NAM コンソール セッションを開始できない場合は、特権 EXEC モードで service-module analysis-module slot /0 session clear コマンドを入力して NAM コンソール ラインがクリアされているかを確認します。

次の作業

「セッションの終了」で説明する手順を実行して、デフォルト ルート パスワードの root が、設定されたことを確認します。

NAM のルート パスワードを変更する方法については、「NAM ルート パスワードの変更」を参照してください。

NAM への Telnet または SSH セッションの開始と終了

この手順では、NAM への Telnet または SSH セッションを開始および終了します。NAM のモニタリングとメンテナンスには、通常、NAM Traffic Analyzer(Web GUI)を使用するので、この手順はあまり実行することはありません。ただし、NAM Traffic Analyzer にアクセスできない場合は、Telnet または SSH を使用し、NAM CLI からトラブルシューティングを実行しなければならない場合もあります。

SM-SRE で Telnet または SSH アクセスが正しく設定されていない場合(次の「前提条件」を参照)、SM-SRE がインストールされているルータへの Telnet セッションを開始した後、ルータから NAM コンソール セッションを開始することができます。「セッションの開始」を参照してください。

前提条件

NAM システム IP アドレスを設定します。オプションで、NAM システム ホスト名を設定します。「ネットワーク接続用の Cisco SRE NAM の設定」を参照してください。

次の ping テストのいずれかを実行して、NAM ネットワーク接続を確認します。

ゲートウェイの背後のホストから NAM システム IP アドレスに ping を実行します。

NAM CLI から、NAM システムのデフォルトのゲートウェイに ping を実行します。

Telnet の前提条件

NAM CLI コマンド exsession on を入力します。「ネットワーク接続用の Cisco SRE NAM の設定」ステップ 5 を参照してください。

SSH の前提条件

NAM ソフトウェア K9 暗号化パッチ(Cisco.com からダウンロード)をインストールします。

NAM CLI コマンド exsession on ssh を入力します。「ネットワーク接続用の Cisco SRE NAM の設定」ステップ 5 を参照してください。

手順の概要

1. telnet { ip-address | hostname }
または
ssh { ip-address | hostname }

2. ログイン プロンプトで root と入力します。

3. パスワード プロンプトで、パスワードを入力します。
または
パスワードを工場出荷時のデフォルト設定から変更していない場合は、ルート パスワードとして root を入力します。

4. NAM CLI で実行する必要がある作業を実行します。NAM への Telnet または SSH セッションを終了して Cisco IOS CLI に戻したい場合は、ステップ 5 およびステップ 6 を実行します。

5. exit

6. logout

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

telnet { ip-address | hostname }

または

ssh { ip-address | hostname }

 

Router# telnet 10.20.30.40

 

Router# ssh 10.20.30.40

Telnet をサポートするホストにログインします。

または

リモート ネットワーク デバイスとの暗号化されたセッションを開始します。

NAM システムの IP アドレスまたは NAM システムのホスト名を使用します。

ステップ 2

ログイン プロンプトで root と入力します。

 

login: root

NAM のルート(読み取り/書き込み)レベルにアクセスします。

ステップ 3

パスワード プロンプトで、パスワードを入力します。

または

パスワードを工場出荷時のデフォルト設定から変更していない場合は、ルート パスワードとして root を入力します。

 

Password: root

--

ステップ 4

NAM CLI で実行する必要がある作業を実行します。NAM への Telnet または SSH セッションを終了して Cisco IOS CLI に戻したい場合は、ステップ 5 およびステップ 6 を実行します。

NAM CLI コマンドの使用方法のヘルプは、「管理用の Cisco SRE NAM の設定」を参照してください。

ステップ 5

exit

 

root@localhost(sub-custom-filter-capture)# exit

root@localhost#

サブコマンド モードを終了します。

コマンド モードに戻ります。

ステップ 6

logout

 

root@localhost# logout

 

Connection closed by foreign host.

NAM システムからログアウトします。

ここで紹介する例は、次のとおりです。

「NAM システムの IP アドレスを使用した NAM への Telnet セッションの開始と終了」

「NAM システムのホスト名を使用した NAM への SSH セッションの開始と終了」

NAM システムの IP アドレスを使用した NAM への Telnet セッションの開始と終了

Router> telnet 172.20.105.215
Trying 172.20.105.215 ... Open
 
Cisco Network Analysis Module (SM-SRE)
 
login: root
Password: <password>
Terminal type: vt100
 
Cisco Network Analysis Module (SM-SRE) Console, 5.1
Copyright (c) 1999-2010 by cisco Systems, Inc.
 
WARNING! Default password has not been changed!
root@nam.company.com#
root@nam.company.com# logout
 
[Connection to 172.20.105.215 closed by foreign host]
Router>

NAM システムのホスト名を使用した NAM への SSH セッションの開始と終了

host [/home/user] ssh -l root nmnam2
root@nmnam2’s password: <password>
Terminal type: vt100
 
Cisco Network Analysis Module (SM-SRE) Console, 5.1
Copyright (c) 1999-2010 by Cisco Systems, Inc.
 
WARNING! Default password has not been changed!
root@nmnam2.company.com#
root@nmnam2.company.com# logout
 
Connection to nmnam2 closed.
host [/home/user]

Cisco SRE NAM の管理

ここでは、次の項目について説明します。

「SRE NAM のシャットダウンとスタートアップ」

「システムの状態の検証」

「ロギング オプションの設定と診断情報の生成」


) • このセクションの表では、ルータとネットワーク モジュールで共通のコマンドだけを記載します。

使用可能なすべてのコマンドの一覧を表示するには、プロンプトで ? と入力します
(例: Router(config-if)# ? )。

すべてのコマンド キーワード オプションの一覧を表示するには、コマンドの末尾に ? を入力します
(例: Router# service-module sm ? )。

表では、コンフィギュレーション モード別にコマンドを記載しています。同じコマンドが複数のモードで利用できる場合は、モードによってコマンドの動作が異なることがあります。


 

SRE NAM のシャットダウンとスタートアップ

ネットワーク モジュールまたはモジュール上で実行する SRE NAM アプリケーションをシャットダウンまたは起動するには、次のリストに記載した一般的なルータ コマンドとネットワーク モジュール コマンドから、必要なコマンドを使用します(表 3)。


) • shutdown コマンドには、サービスを中断させる可能性があるものもあります。このようなコマンドの出力に確認用のプロンプトが表示された場合、Enter を押して確認するか、n を押してから Enter を押して取り消してください。また、no-confirm キーワードを使用してプロンプトが表示されないようにすることもできます。

コマンドの中には、モジュールやアプリケーションをシャットダウンして、その後すぐに再起動させるものもあります。


 

 

表 3 共通のシャットダウン、起動コマンド

コンフィギュレーション モード
コマンド
目的
Router#

service-module sm slot /0 reload

ネットワーク モジュールのオペレーティング システムを正常終了した後、ブートローダから再起動します。

Router#

service-module sm slot /0 reset

モジュール上のハードウェアをリセットします。シャットダウンまたは障害状態からの復旧の目的のみに使用します。


注意 このコマンドの使用には注意が必要です。ソフトウェアに対する所定のシャットダウンが行われないため、処理中のファイル操作に影響を与える場合があります。

Router#

service-module sm slot /0 session

指定したサービス エンジンにアクセスして、ネットワーク モジュールの設定セッションを開始します。

Router#

service-module sm slot /0 shutdown

ネットワーク モジュールのオペレーティング システムをスムーズにシャットダウンします。オンラインでの抜き差し(OIR)の最中にホットスワップ可能なモジュールを取り外しするか、または交換したい場合に使用します。

Router#

service-module sm slot /0 status

ネットワーク モジュールのハードウェアとソフトウェアの設定および状態に関する情報を表示します。

Router(config)#

shutdown

システム全体(ホスト ルータとネットワーク モジュールの両方)を正常終了します。

ServiceEngine bootloader>

boot

ヘルパーまたはアプリケーションを起動します。

ServiceEngine
bootloader>

reboot

設定変更を保存せずに SM-SRE をシャットダウンした後、ブートローダから再起動します。

root@hostname.domain

reboot

SM-SRE を NAM CLI から安全に再起動します。

root@hostname.domain

shutdown

SM-SRE アプリケーションを正常にシャットダウンした後、モジュールをシャットダウンします。

システムの状態の検証

インストール、アップグレード、ダウングレードの状態を検証したい場合、または問題を解決したい場合は、下記の表のルータとネットワーク モジュールで共通のコマンドのリストから該当するコマンドを実行します(表 4)。


) 複数ある show コマンドのキーワード オプションの中には、画面に診断結果を表示し、それをファイルまたは URL にパイプするものもあります。


 

表 4 共通の検証、トラブルシューティングのコマンド

コンフィギュレーション モード
コマンド
目的
Router#

ping

指定した IP アドレスに ping して、ネットワークの接続をチェックします(目的地のホスト名は使用できません)。

Router#

show arp

現在のアドレス解決プロトコル(ARP)テーブルを表示します。

Router#

show clock

現在の日付と時刻が表示されます。

Router#

show configuration

configure コマンドを使用して入力した bootloader の現在の設定を表示します。

Router#

show controllers service-engine

インターフェイスのデバッグ情報を表示します。

Router#

show diag

SM-SRE についての情報など、標準の Cisco IOS 診断情報を表示します。

Router#

show hardware

ネットワーク モジュールとホスト ルータのハードウェア情報を表示します。

Router#

show hosts

デフォルトのドメイン名、ネーム ルックアップのスタイル、name-server のホスト リスト、ホスト名とアドレスのキャッシュされたリストを表示します

Router#

show interfaces

ネットワーク、ディスクを含め、すべてのハードウェア インターフェイスの情報を表示します。

Router#

show sm

ルータ、モジュールのインターフェイスのうち、モジュール側の情報を表示します。

Router#

show ntp status

ネットワーク タイム プロトコル(NTP)の情報を表示します。

Router#

show processes

実行中のアプリケーションのプロセスのリストを表示します。

Router#

show running-config

有効になっているコンフィギュレーション コマンドを表示します。

Router#

show startup-config

スタートアップ コンフィギュレーションを表示します。

Router#

show tech-support

シスコのテクニカル サポートが問題の診断に利用できるホスト ルータの情報を表示します。

Router#

show version

ルータ、ソフトウェア、ネットワーク モジュールの bootloader のバージョン情報とハードウェア、デバイスについての情報を表示します。

Router#

test scp ping

ネットワーク モジュールに ping を送信して、ネットワーク接続を確認します。

Router#

verify

インストールされたハードウェアおよびソフトウェアのバージョン情報を表示します。

SE-Module>

ping

指定した IP アドレスに ping して、ネットワークの接続をチェックします(目的地のホスト名は使用できません)。

ロギング オプションの設定と診断情報の生成

SRE NAM のロギング オプションを設定するには、 表 5 表 6 に示す一般的なネットワーク モジュール コマンドのリストから、必要なコマンドを使用します。


) 多くの log コマンドと trace コマンドではキーワード オプションが提供されており、診断結果を画面に表示するか、ファイルや URL に送信するかを選択できます。


 

表 5 一般的な syslog コマンド

コンフィギュレーション モード
コマンド
目的
Router#

show log

指定されたログの内容を表示します。

show logs

使用可能なログ ファイルのリストを表示します。

copy log

選択した保存先に syslog を保存します。

 

表 6 一般的なトレース コマンド

コマンド
目的

clear trace

指定されたモジュールについてログに記録されたトレース イベントを消去します。

log trace

設定されたトレースをネットワーク モジュールのログに記録します(ローカルでも、リモートでも実行できます)。

no trace

指定されたモジュール、エンティティ、またはアクティビティのトレースを無効にします。

show errors

モジュール、エンティティ、またはアクティビティ別にエラー統計情報を表示します。

show trace

トレースの設定を表示します。

show trace buffer

トレース バッファの内容を表示します。

show trace store

格納されているトレース済みのメッセージの内容を表示します。

trace

指定されたモジュール、エンティティ、またはアクティビティのトレース(つまり、エラー レポートの生成)を有効にします。

その他の参考資料

ここでは、SRE NAM 機能に関する関連資料について説明します。

表 7 関連資料

 

関連項目
ドキュメント名

ソフトウェア ダウンロード、製品マニュアル、および技術マニュアルへのリンク

Cisco Network Analysis Module (NAM) Software http://www.cisco.com/en/US/products/sw/cscowork/ps5401/tsd_products_support_series_home.html

ネットワーク モジュール

Installing Cisco Network Modules in Cisco Access Routers 』( http://www.cisco.com/en/US/docs/routers/access/interfaces/nm/hardware/installation/guide/InstNetM.html

Advanced Integration Module(AIM)

Installing Advanced Integration Modules in Cisco 2600 Series, Cisco 3600 Series, and Cisco 3700 Series Routers 』( http://www.cisco.com/en/US/docs/routers/access/2600/hardware/module/installation/guide/aims_ins.html

サービス モジュール

Cisco SRE Service Module Configuration and Installation Guide 』( http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/ism-sm-sre.html

Cisco Integrated Services Router Generation 2 のインストール。

Cisco 2900 and 3900 Series Hardware Installation 』( http://www.cisco.com/en/US/partner/docs/routers/access/2900/hardware/installation/guide/Install_Connect.html

安全性に関する準拠

『Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information』 http://www.cisco.com/en/US/docs/routers/access/interfaces/rcsi/IOHrcsi.html

ROM モニタへのアクセスとコマンドの発行

ROM Monitor Download Procedures for Cisco 2691, Cisco, 3631, Cisco 3725, and Cisco 3745 Routers 』( http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/sw_conf/piperrom.htm

Cisco IOS インターフェイス コマンド(コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例)

Cisco IOS Interface and Hardware Component Command Reference 』( http://www.cisco.com/en/US/products/ps6441/tsd_products_support_series_home.html

シスコ シリーズ ルータ上での Switch Port Analyzer(SPAN; スイッチ ポート アナライザ)セッションの設定

16- and 36-Port Ethernet Switch Module for Cisco 2600 Series, Cisco 3600 Series, and Cisco 3700 Series

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t8/feature/guide/ft1636nm.html

Cisco HWIC-4ESW and HWIC-D-9ESW EtherSwitch Interface Cards 』( http://www.cisco.com/en/US/docs/ios/12_3t/12_3t8/feature/guide/esw_cfg.html

IP アンナンバード インターフェイス

Understanding and Configuring the ip unnumbered Command 』( http://www.cisco.com/application/pdf/paws/13786/20.pdf

認証、許可、アカウンティング(AAA)

Cisco IOS Security Configuration Guide 』( http://www.cisco.com/en/US/products/ps6441/products_installation_and_configuration_guides_list.html

Cisco IOS ソフトウェア

Cisco IOS Software Releases 12.4 T http://www.cisco.com/en/US/products/ps6441/tsd_products_support_series_home.html

RFC

 

RFC
タイトル

RFC 768

『User Datagram Protocol』

RFC 793

『Transmission Control Protocol』

RFC 826

『Ethernet Address Resolution Protocol』

RFC 959

『File Transfer Protocol』

RFC 1165

『Network Time Protocol』

RFC 1213

『Remote Network Monitoring Management Information Base Version 2 using SMIv2』

RFC 1350

『The TFTP Protocol』

RFC 2074

『Remote Network Monitoring MIB Protocol Identifiers』

RFC 2613

『Remote Network Monitoring MIB Extensions for Switch Networks Version 1.0』

RFC 2896

『Remote Network Monitoring Management Information Base』

RFC 3164

『The BSD Syslog Protocol』

RFC 3273

『Remote Network Monitoring Management Information Base for High Capacity Networks』

RFC 3287

『Remote Monitoring MIB Extensions for Differentiated Services』

ネットワーク解析モジュールの機能に関する情報

このテクノロジーの機能に関する情報は、このマニュアルでは取り扱いません。 http://www.cisco.com/en/US/products/sw/cscowork/ps5401/tsd_products_support_series_home.html にある製品マニュアルを参照してください。

特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。使用する Cisco IOS ソフトウェア リリースによっては、一部のコマンドが使用できない場合もあります。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは不要です。

用語集

 

AAA

Authentication, Authorization, and Accounting(認証、許可、アカウンティング)。AAA は トリプル A と発音します。

AIM

Asynchronous interface module(非同期インターフェイス モジュール)。ネットワーク モジュールの一種です。

ARP

Address Resolution Protocol(アドレス解決プロトコル)。IP アドレスを MAC アドレスにマッピングする際に使用されるインターネット プロトコル。

CEF

Cisco Express Forwarding(シスコ エクスプレス フォワーディング)

FTP

File Transfer Protocol(ファイル転送プロトコル)。ネットワーク ノード間でファイルを転送するために使用され、TCP/IP プロトコル スタックの一部であるアプリケーション プロトコル。

GRE

Generic Routing Encapsulation(総称ルーティング カプセル化)。シスコが開発したトンネリング プロトコルで、さまざまなプロトコル パケット タイプを IP トンネル内でカプセル化し、IP インターネットワーク上で Cisco ルータへの仮想ポイントツーポイントリンクを作成します。単一プロトコル バックボーン環境で、マルチプロトコル サブネットワークに接続することで、GRE を使用する IP トンネリングは単一プロトコル バックボーン環境のネットワークを拡張できます。

GUI

Graphical User Interface(グラフィカル ユーザ インターフェイス)。アプリケーションの入出力、および情報が保存されている階層やデータ構造を表す際、テキストによる表現だけではなく、画像も使用するユーザ環境です。ボタン、アイコン、ウィンドウなどの表記法が典型で、多くの操作はポインティング デバイス(マウスなど)を使用して実行されます。マイクロソフトの Windows や、アップルの Macintosh は GUI を使用したプラットフォームの顕著な例です。

IP マルチキャスト

1 つまたは複数の送信元から複数の相手に対して IP トラフィックを同報するルーティング技術。1 つのパケットを各宛先に送信するのではなく、1 つのパケットが、1 つの IP 宛先グループ アドレスで定義されたマルチキャスト グループに送信されます。

MIB

Management Information Base(管理情報ベース)。ネットワーク管理情報のデータベースです。これらの情報は、SNMP や共通管理情報プロトコル(CMIP)などのネットワーク管理プロトコルにより使用および保持されます。MIB オブジェクトの値は、SNMP コマンドまたは CMIP コマンドを使用して変更および取得できます。これらのコマンドは通常、GUI のネットワーク管理システムから実行します。MIB オブジェクトはツリー構造であり、ツリーにはパブリック(標準)ブランチとプライベート(独自)ブランチを含みます。

NAT

Network Address Translation(ネットワーク アドレス変換)。グローバルに固有な IP アドレスを使用する必要性を減らすメカニズムです。NAT を使用すると、グローバルに一意ではないアドレスを持つ組織が、それらのアドレスをグローバルにルーティング可能なアドレス空間に変換することで、インターネットに接続できるようになります。 Network Address Translator と呼ぶ場合もあります。

NetFlow

一部のルータに搭載された、着信パケットをフローに分類する機能。同じフロー内のパケットは同様に処理される場合があるため、この分類はルータの動作の一部を回避し、ルータのスイッチング操作を高速化するために使用できます。

NTP

Network Time Protocol(ネットワーク タイム プロトコル)。インターネット内に置かれているラジオ クロックおよびアトミック クロックを参照することにより、正確な現地時間を維持する TCP 上に構築されたプロトコル。このプロトコルでは、分散されたクロックを長期にわたりミリ秒以内のレベルで同期させることができます。

PCI

Peripheral Component Interconnect。ローカル バスの業界規格。

QoS

Quality of Service。Cisco IOS QoS テクノロジーは、複雑なネットワークを制御し、さまざまなネットワーク アプリケーションやトラフィック タイプを、期待どおりに提供できるようにします。

Service エンジン

コンテンツ ネットワーキング製品(ハードウェアおよびソフトウェア)。コンテンツ配信を高速化し、最大のスケーラビリティとコンテンツの可用性を実現します。

SNMP

Simple Network Management Protocol(簡易ネットワーク管理プロトコル)。TCP/IP ネットワークでほぼ独占的に使用されているネットワーク管理プロトコル。SNMP を使用すると、ネットワーク デバイスのモニタと制御、およびコンフィギュレーション、統計情報収集、パフォーマンス、セキュリティの管理が可能になります。SNMPv2c は、集中型と分散型の両方のネットワーク管理をサポートします。また、Structure of Management Information(SMI; 管理情報構造)、プロトコルの動作、管理アーキテクチャ、セキュリティの面でも改善されています。SNMPv3 は、ネットワーク経由のパケットの認証と暗号化を組み合わせることによって、デバイスへのセキュア アクセスを実現します。

SRE

Services Ready Engine。

SSH

Secure Shell Connection(セキュア シェル接続)プロトコルは、伝送制御プロトコル(TCP)アプリケーションを使用して、セキュアなリモート接続を実現するプロトコルです。

syslog

ネットワーク上のデバイスに関するログ情報を取得するための業界標準プロトコルです。

TCP

Transmission Control Protocol(伝送制御プロトコル)。信頼性の高い全二重データ伝送を実現する接続指向のトランスポートレイヤ プロトコルです。TCP は TCP/IP プロトコル スタックの一部です。

telnet

アプリケーション サーバへのセキュリティ保護されていないインターネット接続に使用されるネットワーク プロトコル。

TFTP

Trivial File Transfer Protocol。ネットワークを介してファイルをあるコンピュータから別のコンピュータに転送できる FTP の簡易バージョン。通常はクライアント認証(ユーザ名やパスワードなど)を使用しません。

UDP

User Datagram Protocol(ユーザ データグラム プロトコル)。TCP/IP プロトコル スタックに含まれるコネクションレス型のトランスポート層プロトコル。UDP は確認応答や配送保証なしにデータグラムを交換します。エラー処理および再転送は他のプロトコルによって行う必要があります。

VoIP

Voice over IP。IP ベースのインターネット上で通常のテレフォニー スタイルの音声を伝送する方式。機能性、信頼性、および音声品質が POTS と同様です。VoIP を使用すれば、ルータから IP ネットワーク上で音声トラフィック(通話や FAX など)を伝送できます。VoIP では、デジタル シグナル プロセッサ(DSP)が音声信号をフレームにセグメント化し、2 つずつグループ化されて、音声パケットに格納されます。これらの音声パケットは、ITU-T 仕様の H.323 に従って、IP を使用して送信されます。

アクセス リスト

多数のサービスに対してルータからまたはルータへのアクセスを制御する(たとえば、特定の IP アドレスを持ったパケットがルータ上の特定のインターフェイスから送出されないようにする)ためにルータが保持するリスト。

アプライアンス

ネットワーク モジュールの別名。

サービス エンジン

アプリケーション ソフトウェアがインストールされたネットワーク モジュールの別名。

サービス モジュール

ルータ上の Cisco IOS の設定から独立した独自のスタートアップ コンフィギュレーションおよび実行コンフィギュレーションを持ったスタンドアロンのコンテンツ エンジン。

ネットワーク モジュール

ネットワーク モジュールの一種です。

フラッディング

スイッチおよびブリッジにより使用されるトラフィック通過手法。インターフェイス上で受信されたトラフィックは、最初に情報を受信したインターフェイスを除き、そのデバイスのすべてのインターフェイスから送信されます。

ブートヘルパー

ヘルパー を参照。

ブートローダ

システムの電源投入時に読み込まれるソフトウェアの小セット。これは Cisco SRE、NAM アプリケーションをロードして実行するオペレーティング システムを(ディスク、ネットワーク、外部フラッシュ、または外部 USB フラッシュから)ロードします。ブートローダは、オプションとして、ブートヘルパーをロードして実行することができます。

ブレード

ネットワーク モジュールの別名。

ヘルパー(旧名は ブートヘルパー

モジュール上で実行されるソフトウェアの小サブセット。モジュールをネットワークから起動し、ディザスタ リカバリ、ソフトウェアのインストールなど、モジュールがソフトウェアにアクセスできないときの動作を補助します。


) この用語集に記載されていない用語については、『Cisco IOS Voice Configuration Library Glossary』(http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_voice_configuration_library_glossary/VCLgloss.html)などの参考資料を参照してください。

マニュアルの入手方法およびテクニカル サポート

マニュアルの入手方法、テクニカル サポート、その他の有用な情報について、次の URL で、毎月更新される『 What's New in Cisco Product Documentation 』を参照してください。シスコの新規および改訂版の技術マニュアルの一覧も示されています。

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

What's New in Cisco Product Documentation 』は RSS フィードとして購読できます。また、リーダー アプリケーションを使用してコンテンツがデスクトップに直接配信されるように設定することもできます。RSS フィードは無料のサービスです。シスコは現在、RSS バージョン 2.0 をサポートしています。