Cisco MDS 9000 ファミリ NX-OS インターフェイス コンフィギュレーション ガイド Cisco MDS NX-OS Release 6.x
トランキングの設定
トランキングの設定
発行日;2012/09/24 | 英語版ドキュメント(2012/09/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

トランキングの設定

トランキングに関する情報

E ポートのトランキング

F ポートのトランキング

重要な概念

トランキング プロトコル

トランク モード

トランク許可 VSAN リストおよび VF_ID

注意事項と制限

一般的なガイドラインと制限事項

アップグレードとダウングレードに関する制限事項

TE ポートと TF-TNP ポートの相違点

トランキング誤設定の例

デフォルト設定

トランキングの設定

Cisco トランキング プロトコルおよびチャネリング プロトコルのイネーブル化

F ポートのトランキングおよびチャネリング プロトコルのイネーブル化

トランク モードの設定

VSAN の許可アクティブ リストの設定

トランキング設定の確認

F ポートのトランキングの設定例

トランキングに関する情報

トランキングは VSAN トランキングとも呼ばれ、Cisco MDS 9000 ファミリのスイッチに特有の機能です。トランキングでは、相互接続ポートが同一物理リンクによって複数の VSAN でフレームを送受信できます。トランキングは E ポートおよび F ポートでサポートされます(図 5-1 および図 5-2 を参照)。

ここで説明する内容は、次のとおりです。

「E ポートのトランキング」

「F ポートのトランキング」

「重要な概念」

「トランキング プロトコル」

「トランク モード」

「トランク許可 VSAN リストおよび VF_ID」

E ポートのトランキング

E ポートをトランキングすると、相互接続ポートが 拡張 ISL(EISL)フレーム形式を使用して、同一物理リンクによって複数の VSAN でフレームを送受信できます。

図 5-1 E ポートのトランキング

 


) HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用のシスコ ファブリック スイッチの両方の内部ポートでは、トランキングがサポートされません。


F ポートのトランキング

F ポートをトランキングすると、相互接続ポートが同一物理リンクによって、複数の VSAN でタグ付きフレームを送受信できます。

図 5-2 に、MDS コア スイッチ、NPV スイッチ、サードパーティ製コア スイッチ、および HBA が含まれる SAN で想定されるトランキングのシナリオを示します。

図 5-2 F ポートのトランキング


 

リンク番号
リンクの説明

1a および 1b

F ポートと N ポートのトランク1

2

F ポートと NP ポートのトランク

3

NP ポートとの F ポートチャネル

4

NP ポートとトランキングされた F ポートチャネル

5

サードパーティ製コア スイッチの F ポートとのトランキング NP ポート 1

1.この機能は現在サポートされていません。

重要な概念

トランキング機能には、次の重要な概念があります。

TE ポート:E ポートでトランク モードをイネーブルにして、このポートをトランキング E ポートとして動作させる場合、そのポートは TE ポートと呼ばれます。

TF ポート:F ポートでトランク モードをイネーブルにして(図 5-2 のリンク 2 を参照)、このポートをトランキング F ポートとして動作させる場合、そのポートは TF ポートと呼ばれます。

TN ポート:N ポートでトランク モードをイネーブル(現在は未サポート)にして(図 5-2 のリンク 1b を参照)、このポートをトランキング N ポートとして動作させる場合、そのポートは TN ポートと呼ばれます。

TNP ポート:NP ポートでトランク モードをイネーブルにして(図 5-2 のリンク 2 を参照)、このポートをトランキング NP ポートとして動作させる場合、そのポートは TNP ポートと呼ばれます。

TF ポートチャネル:F ポートチャネルでトランク モードをイネーブルにして(図 5-2 のリンク 4 を参照)、このポートチャネルをトランキング F ポートチャネルとして動作させる場合、そのポートチャネルは TF ポートチャネルと呼ばれます。Cisco Port Trunking Protocol(PTP)を使用して、タグ付きフレームが伝送されます。

TF-TN ポート リンク:Exchange Virtual Fabrics Protocol(EVFP)を使用して、F ポートを HBA に接続する単一のリンクを確立し、タグ付きフレームを伝送できます(図 5-2 のリンク 1a および 1b を参照)。サーバは、Inter-VSAN Routing(IVR)を使用せずに、TF ポートを使用して複数の VSAN に到達できます。

TF-TNP ポート リンク:PTP プロトコルを使用して、TF ポートを TNP ポートに接続する単一のリンクを確立し、タグ付きフレームを伝送できます(図 5-2 のリンク 2 を参照)。PTP もトランキング ポートチャネルをサポートしているため、このプロトコルが使用されます。


) サードパーティ製 NPV コア スイッチとシスコ NPV スイッチ間の TF-TNP ポート リンクは、EVFP プロトコルを使用して確立されます。


ファイバ チャネル VSAN は仮想ファブリックと呼ばれ、VSAN ID の代わりに VF_ID を使用します。デフォルトでは、すべてのポートで VF_ID は 1 です。N ポートがトランキングをサポートしている場合は各 VSAN に対して pWWN が定義されます。これは論理 pWWN と呼ばれます。MDS コア スイッチの場合、N ポートが追加の FC_ID を要求する pWWN は、仮想 pWWN と呼ばれます。

トランキング プロトコル

トランキング プロトコルは、ポートでトランキング処理を行う場合に重要です。このプロトコルでは、次のような処理を実行します。

動作可能なトランク モードのダイナミック ネゴシエーション。

トランク許可 VSAN の共通セットの選択。

ISL(スイッチ間リンク)間の VSAN 不一致の検出。

表 5-1 に、トランキングおよびチャネリングに使用するプロトコルを示します。

 

表 5-1 サポートされているトランキング プロトコル

トランク リンク
デフォルト

TE-TE ポート リンク

Cisco EPP(PTP)

TF-TN ポート リンク2

FC-LS Rev 1.62 EVFP

TF-TNP ポート リンク

Cisco EPP(PTP)

E または F ポートチャネル

Cisco EPP(PCP)

TF ポートチャネル

Cisco EPP(PTP および PCP)

サードパーティ製 TF-TNP ポート リンク 1

FC-LS Rev 1.62 EVFP

2.この機能は現在サポートされていません。

デフォルトでは、トランキング プロトコルは E ポートでイネーブル、F ポートではディセーブルです。トランキング プロトコルがスイッチでディセーブルの場合、そのスイッチのポートは新規トランク コンフィギュレーションを適用できません。既存のトランク設定は影響されません。TE ポートは引き続きトランク モードで機能しますが、以前(トランキング プロトコルがイネーブルだったときに)ネゴシエーションした VSAN だけでトラフィックをサポートします。このスイッチに直接接続している他のスイッチも同様に接続インターフェイスで影響を受けます。トランキング以外の ISL 間で、さまざまなポート VSAN からのトラフィックをマージしなければならないことがあります。そのような場合は、トランキング プロトコルをディセーブルにします。


) トランキング リンクの両側が同じポート VSAN に属することを推奨します。ポート VSAN が異なる特定スイッチまたはファブリック スイッチでは、片側がエラーを返し、反対側が接続されません。


トランク モード

デフォルトでは、非 NPV スイッチのすべてのファイバ チャネル インターフェイス(モード:E、F、FL、Fx、ST、および SD)でトランク モードがイネーブルです。NPV スイッチのデフォルトでは、トランク モードはディセーブルです。トランク モードを on(イネーブル)、off(ディセーブル)、または auto(自動)に設定できます。2 つのスイッチ間での ISL の両端のトランク モード設定により、リンクのトランキング状態および両端のポート モードが決まります( 表 5-2 を参照)。

 

表 5-2 スイッチ間のトランク モード ステータス

トランク モードの設定
最終的なステートとポート モード
ポートの種類
スイッチ 1
スイッチ 2
トランキング ステート
ポート モード

E ポート

On

auto または on

トランキング(EISL)

TE ポート

Off

auto、on、または off

トランキングなし(ISL)

E ポート

Auto

Auto

トランキングなし(ISL)

E ポート

ポートの種類
コア スイッチ
NPV スイッチ
トランキング ステート
リンク モード

F ポートおよび NP ポート

On

auto または on

トランキング

TF-TNP リンク

Auto

On

トランキング

TF-TNP リンク

Off

auto、on、または off

トランキングなし

F-NP リンク


ヒント Cisco MDS 9000 ファミリ スイッチでの推奨設定は、トランクの片側が auto、反対側が on です。


) サードパーティ製スイッチに接続した場合、E ポートのトランク モード設定は有効になりません。ISL は常にトランキング ディセーブルのステートです。F ポートの場合、EVFP ビットを使用する、サードパーティ製コア スイッチ ACC の物理 FLOGI が設定されていると、EVFP プロトコルによってリンクのトランキングがイネーブルになります。


トランク許可 VSAN リストおよび VF_ID

各ファイバ チャネル インターフェイスには、対応付けられたトランク許可 VSAN リストがあります。TE ポート モードでは、フレームはこのリストに指定された 1 つまたは複数の VSAN で送受信されます。デフォルトの場合、VSAN 範囲(1 ~ 4093)がトランク許可リストに組み込まれています。

スイッチで設定されてアクティブになっている VSAN の共通セットは、インターフェイスのトランク許可 VSAN リストに組み込まれ、これは 許可アクティブ VSAN と呼ばれます。トランキング プロトコルは、ISL の両端で allowed-active VSAN のリストを使用して、トラフィックが許可される通信可能な VSAN のリストを判別します。

トランク許可 VSAN のデフォルト設定で、スイッチ 1(図 5-3 を参照)に VSAN 1 ~ 5、スイッチ 2 に VSAN 1 ~ 3、スイッチ 3 に VSAN 1、2、4、5 が含まれています。3 つすべてのスイッチに設定された VSAN はすべて、allowed-active です。ただし、ISL の端で許可アクティブ VSAN の共通セットだけが動作状態になります(図 5-3 を参照)。

すべての F ポート、N ポート、および NP ポートについて、VF_ID が設定されていない場合のデフォルト VF_ID は 1 です。ポートのトランク許可 VF_ID リストは、トランク許可 VSAN のリストと同一です。VF_ID 4094 は制御 VF_ID と呼ばれ、リンクでトランキングがイネーブルな場合にトランク許可 VF-ID のリストを定義するために使用されます。

F ポートのトランキングおよびチャネリングがイネーブルな場合、任意のインターフェイスの NPV モードで switchport trunk mode on が設定されている場合、または NP ポートチャネルが設定されている場合、設定に使用できる VSAN および VF-ID の範囲は 表 5-3 のとおりです。

 

表 5-3 VSAN および VF-ID の予約

VSAN または VF-ID
説明

000h

Virtual Fabric Identifier としては使用できません。

001h(1)~ EFFh(3839)

この VSAN 範囲はユーザ設定に使用できます。

F00h(3840)~ FEEh(4078)

予約済み VSAN。ユーザ設定には使用できません。

FEFh(4079)

EVFP で分離された VSAN。

FF0h(4080)~ FFEh(4094)

ベンダー固有の VSAN に使用します。

FFFh

Virtual Fabric Identifier としては使用できません。


) F ポートと N ポートの VF_ID が一致しない場合、タグ付きフレームは交換できません。


図 5-3 Allowed-Active VSAN のデフォルト設定

 

許可アクティブ リストから VSAN の選択セットを設定し、トランキング ISL で指定されている VSAN へのアクセスを制御できます。

例として 図 5-3 を使用して、インターフェイスごとに許可 VSAN リストを設定できます(図 5-4 を参照)。たとえば、スイッチ 1 に接続された ISL の許可 VSAN リストから VSAN 2 と VSAN 4 を削除する場合、各 ISL の通信可能な VSAN リストは次のようになります。

スイッチ 1 とスイッチ 2 の間の ISL には、VSAN 1 と VSAN 3 が含まれます。

スイッチ 2 とスイッチ 3 の間の ISL には、VSAN 1 と VSAN 2 が含まれます。

スイッチ 3 とスイッチ 1 の間の ISL には、VSAN 1、VSAN 2、および VSAN 5 が含まれます。

したがって、VSAN 2 だけがスイッチ 1 からスイッチ 3、さらにスイッチ 2 にルーティングできます。

図 5-4 通信可能な許可 VSAN の設定

注意事項と制限

トランキング機能には、次の構成に関する注意事項と制限事項があります。

「一般的なガイドラインと制限事項」

「アップグレードとダウングレードに関する制限事項」

「TE ポートと TF-TNP ポートの相違点」

「トランキング誤設定の例」

一般的なガイドラインと制限事項

トランキング機能には、次の一般的な設定時の注意事項および制限事項があります。

F ポートは Fx モードでトランキングをサポートします。

TE、TF、および TNP の各リンク用に設定したトランク許可 VSAN はトランキング プロトコルによって使用され、フレームの送受信ができる許可アクティブ VSAN が判断されます。

トランキングがイネーブルの E ポートをサードパーティ製スイッチに接続すると、トランキング プロトコルによって E ポートとしてのシームレスな動作が保証されます。

次のハードウェアでは、F ポートおよび F ポートチャネルのトランキングがサポートされていません。

91x4 スイッチ(NPIV がイネーブルで、NPIV コア スイッチとして使用する場合)

第 1 世代の 2 Gbps ファイバ チャネル スイッチング モジュール

コア スイッチでは、物理 pWWN からの物理 FLOGI に対してだけ FC-SP 認証がサポートされます。

NPV スイッチはサーバ F ポートで FC-SP 認証をサポートしません。

MDS は VSAN 全体で論理 pWWN が一意であることを強制しません。

トランキングされた F ポート ログインで DPVM はサポートされません。

DPVM 機能はポート VSAN の制御だけに限定されています。これは、EVFP プロトコルでは論理 pWWN で FLOGI を実行した VSAN を変更できないためです。

ポート セキュリティ設定は、最初の物理 FLOGI および VSAN ごとの FLOGI の両方に適用されます。

FlexAttach がイネーブルにされている F ポートでは、トランキングをサポートしません。

MDS 91x4 コア スイッチでハード ゾーン分割を実行できるのは、NPIV またはトランキングのいずれかを実行している F ポートだけです。ただし、NPV モードではゾーン分割がコア F ポートで実行されるため、この制限が適用されません。

アップグレードとダウングレードに関する制限事項

トランキングおよびチャネリング機能には、次のようなアップグレードとダウングレードに関する制限事項があります。

リンク上に F ポートのトランキングまたはチャネリングが設定されている場合は、Cisco MDS SAN-OS Release 3.x および NX-OS Release 4.1(1b)、またはそれ以前のリリースにスイッチをダウングレードできません。

SAN-OS リリース 3.x から NX-OS リリース 5.0(1) にアップグレードするときに VSAN 4079 を作成していない場合は、NX-OS ソフトウェアによって VSAN 4079 が自動的に作成され、EVFP を使用するために予約されます。

EVFP を使用するために VSAN 4079 が予約されると、 switchport trunk allowed vsan コマンドによって VSAN 4079 が許可リストから除外されます(次に示す例を参照)。

switch(config-if)# switchport trunk allowed vsan 1-4080
1-4078,4080
switch(config-if)#
 

VSAN 4079 を作成してある場合、NX-OS リリース 5.0(1) へのアップグレードは VSAN 4079 に影響しません。

NX-OS リリース 5.0(1) からダウングレードした場合、EVFP 用の VSAN の予約は無効になります。

TE ポートと TF-TNP ポートの相違点

TE ポートの場合、そのインターフェイスで VSAN が起動してピアがネゴシエーション フェーズにあるとき、VSAN は初期状態にあります。ハンドシェイクが完了すると、成功した場合はアップの状態に、失敗した場合は分離状態に移行します。Device Manager では、初期化状態ではポート ステータスが黄色で表示され、VSAN がアップすると緑色で表示されます。

次に、TE ポートのトランク VSAN ステートの例を示します。

Switch# show interface fc2/15
fc2/15 is trunking
Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
Port WWN is 20:4f:00:0d:ec:6d:2b:40
Peer port WWN is 20:0a:00:0d:ec:3f:ab:80
Admin port mode is auto, trunk mode is on
snmp link state traps are enabled
Port mode is TE
Port vsan is 1
Speed is 2 Gbps
Rate mode is dedicated
Transmit B2B Credit is 16
Receive B2B Credit is 250
B2B State Change Number is 14
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100-101,1101,1163-1166,1216,2172,2182-2183)
Trunk vsans (up) (1,1101,1163-1166,1216,2172,2182-2183)
Trunk vsans (isolated) (100-101)
Trunk vsans (initializing) ()
 

TF ポートの場合、ハンドシェイク後に許可 VSANs のいずれかがアップ状態に移行します。ピアとのハンドシェイクが完了し、それが成功した場合でも、他の VSANs はすべて初期状態となります。対応する VSAN にある、トランキングされた F または NP ポートを使用してサーバまたはターゲットがログインしたとき、各 VSAN は、初期化状態からアップ状態に移行します。


) TF ポートまたは TNP ポートの場合、ポートがアップしていてエラーがない場合でも、Device Manager ではポート ステータスが黄色で表示されます。このステータスは、すべての VSAN のログインが成功すると緑色に変化します。


次に、ポートがアップ状態になった後の TF ポート情報の例を示します。

sw7# show interface fc1/13
fc1/13 is trunking (Not all VSANs UP on the trunk)
Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
Port WWN is 20:0d:00:0d:ec:6d:2b:40
Admin port mode is FX, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 1
Speed is 4 Gbps
Rate mode is shared
Transmit B2B Credit is 16
Receive B2B Credit is 32
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100-101,1101,1163-1166,1216,2172,2182-2183)
Trunk vsans (up) (1)
Trunk vsans (isolated) ()
Trunk vsans (initializing) (1101,1163-1166,1216,2172,2182)
 

次に、サーバが非内部 FLOGI VSAN にログインしたときの TF ポート情報の例を示します。サーバが VSAN 2183 にログインすると、VSAN 2183 はアップ状態に移行します。

w7# show interface fc1/13
fc1/13 is trunking (Not all VSANs UP on the trunk)
Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
Port WWN is 20:0d:00:0d:ec:6d:2b:40
Admin port mode is FX, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 1
Speed is 4 Gbps
Rate mode is shared
Transmit B2B Credit is 16
Receive B2B Credit is 32
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100-101,1101,1163-1166,1216,2172,2
182-2183)
Trunk vsans (up) (1,2183)
Trunk vsans (isolated) ()
Trunk vsans (initializing) (1101,1163-1166,1216,2172,2182)
 

トランキング誤設定の例

VSAN を正しく設定していないと、接続に問題が発生する場合があります。たとえば、2 つの VSAN のトラフィックをマージする場合に、両方の VSAN の不一致が発生します。トランキング プロトコルではリンクの両側で VSAN インターフェイスが確認され、VSAN のマージが回避されます(図 5-5 を参照)。

図 5-5 VSAN の不一致

 

トランキング プロトコルが潜在的な VSAN のマージを検出し、関連ポートを分離します(図 5-5 を参照)。

2 つの Cisco MDS 9000 ファミリ スイッチの間にサードパーティ製スイッチが配置されている場合、トランキング プロトコルは VSAN のマージを検出できません(図 5-6 を参照)。

図 5-6 サードパーティ製スイッチによる VSAN の不一致

 

VSAN 2 と VSAN 3 は、ネーム サーバおよびゾーン アプリケーションにおいてオーバーラップするエントリによって事実上結合されます。Cisco DCNM-SAN では、このようなトポロジを検出できます。

デフォルト設定

表 5-4 に、トランキング パラメータのデフォルト設定値を示します。

 

表 5-4 デフォルト トランク設定パラメータ

パラメータ
デフォルト

スイッチ ポートのトランク モード

ON(非 NPV スイッチおよび MDS コア スイッチ)

OFF(NPV スイッチ)

許可 VSAN リスト

1 ~ 4093 のユーザ定義 VSAN ID

許可 VF-ID リスト

1 ~ 4093 のユーザ定義 VF-ID ID

E ポートのトランキング プロトコル

イネーブル。

F ポートのトランキング プロトコル

ディセーブル。

トランキングの設定

ここで説明する内容は、次のとおりです。

「Cisco トランキング プロトコルおよびチャネリング プロトコルのイネーブル化」

「F ポートのトランキングおよびチャネリング プロトコルのイネーブル化」

「トランク モードの設定」

「VSAN の許可アクティブ リストの設定」

Cisco トランキング プロトコルおよびチャネリング プロトコルのイネーブル化

ここでは、必要なトランキング プロトコルおよびチャネリング プロトコルをイネーブルにする方法について説明します。

前提条件

矛盾した設定を避けるために、トランキング プロトコルをイネーブルまたはディセーブルにする前に、 shutdown コマンドを使用して、すべてのポートをディセーブルにしてください。

手順の詳細

Cisco トランキングおよびチャネリング プロトコルをイネーブルまたはディセーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# trunk protocol enable

switch(config)#

Cisco PTP トランキング プロトコルをイネーブルにします(デフォルト)。

switch(config)# no trunk protocol enable

switch(config)#

Cisco PTP トランキング プロトコルをディセーブルにします。

F ポートのトランキングおよびチャネリング プロトコルのイネーブル化

ここでは、F ポートのトランキングおよびチャネリング プロトコルをイネーブルにする方法について説明します。

前提条件

矛盾した設定を避けるには、すべてのポートをシャットダウンしてからトランキング プロトコルのイネーブル化またはディセーブル化を行います。

手順の詳細

F ポートのトランキングおよびチャネリング プロトコルをイネーブルまたはディセーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config tasf

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# feature fport-channel-trunk

switch(config)#

F ポートのトランキングおよびチャネリング プロトコルをイネーブルにします(デフォルト)。

switch(config)# no feature fport-channel-trunk

switch(config)#

F ポートのトランキングおよびチャネリング プロトコルをディセーブルにします。

トランク モードの設定

手順の詳細

トランク モードを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport trunk mode on

指定されたインターフェイスのトランク モードをイネーブルにします(デフォルト)。

switch(config-if)# switchport trunk mode off

指定されたインターフェイスのトランク モードをディセーブルにします。

switch(config-if)# switchport trunk mode auto

インターフェイスの自動検知を提供するトランク モードを auto モードに設定します。

VSAN の許可アクティブ リストの設定

手順の詳細

インターフェイスに VSAN の許可アクティブ リストを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport trunk allowed vsan 2-4

指定された VSAN の許可リストを変更します。

switch(config-if)# switchport trunk allowed vsan add 5

updated trunking membership

指定された VSAN (5) を新しい許可リストに追加します。

switch(config-if)# no switchport trunk allowed vsan 2-4

VSAN 2、3、および 4 を削除します。

switch(config-if)# no switchport trunk allowed vsan add 5

追加された許可リストを削除します。

トランキング設定の確認

トランキングの設定情報を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show interface fc slot/port

トランキング、トランク モード、許可 VSAN、およびステータスを含むインターフェイス設定情報を表示します。

show trunk protocol

トランク プロトコルがイネーブルかどうかを表示します。

show interface trunk vsan numbers

インターフェイスがトランキングを実行しているかどうかと、各トランク インターフェイスの許可 VSAN リストを表示します。

これらのコマンドの出力フィールドの詳細については、『 Cisco MDS NX-OS Command Reference 』を参照してください。

show interface コマンドを EXEC モードから呼び出して、TE ポートのトランキング設定を表示します。引数を入力せずに、このコマンドを実行すると、スイッチに設定されたすべてのインターフェイスの情報が表示されます。例 5-1 5-3 を参照してください。

例 5-1 トランキングしたファイバ チャネル インターフェイスの表示

switch# show interface fc1/13
fc1/13 is trunking
Hardware is Fibre Channel
Port WWN is 20:0d:00:05:30:00:58:1e
Peer port WWN is 20:0d:00:05:30:00:59:1e
Admin port mode is auto, trunk mode is on
Port mode is TE
Port vsan is 1
Speed is 2 Gbps
Receive B2B Credit is 255
Beacon is turned off
Trunk vsans (admin allowed and active) (1)
Trunk vsans (up) (1)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
233996 frames input, 14154208 bytes, 0 discards
0 CRC, 0 unknown class
0 too long, 0 too short
236 frames output, 13818044 bytes, 0 discards
11 input OLS, 12 LRR, 10 NOS, 28 loop inits
34 output OLS, 19 LRR, 17 NOS, 12 loop inits

例 5-2 トランキング プロトコルの表示

switch# show trunk protocol
Trunk protocol is enabled

例 5-3 トランク ポートの VSAN ごとの情報の表示

switch# show interface trunk vsan 1-1000
fc3/1 is not trunking
...
fc3/7 is trunking
Vsan 1000 is down (Isolation due to vsan not configured on peer)
...
fc3/10 is trunking
Vsan 1 is up, FCID is 0x760001
Vsan 2 is up, FCID is 0x6f0001
 
fc3/11 is trunking
Belongs to port-channel 6
Vsan 1 is up, FCID is 0xef0000
Vsan 2 is up, FCID is 0xef0000
...
port-channel 6 is trunking
Vsan 1 is up, FCID is 0xef0000
Vsan 2 is up, FCID is 0xef0000
 

F ポートのトランキングの設定例

次に、トランキングを設定し、NPIV コア スイッチの F ポートと NPV スイッチの NP ポート間の TF-TNP リンクをアップ状態にする例を示します。


ステップ 1 MDS コア スイッチの F ポートのトランキングおよびチャネリング プロトコルをイネーブルにします。

switch(config)# feature fport-channel-trunk
 

ステップ 2 MDS コア スイッチで NPIV をイネーブルにします。

switch(config)# feature npiv
 

ステップ 3 MDS コア スイッチのポート モードを auto、F、または Fx に設定します。

switch(config)# interface fc1/2
switch(config-if)# switchport mode F
 

ステップ 4 MDS コア スイッチのトランク モードをオンに設定します。

switch(config-if)# switchport trunk mode on
 

ステップ 5 NPV スイッチのポート モードを NP に設定します。

switch(config)# interface fc1/2
switch(config-if)# switchport mode NP
 

ステップ 6 NPV スイッチのトランク モードをオンに設定します。

switch(config-if)# switchport trunk mode on
 

ステップ 7 NPIV および NPV スイッチのポート管理ステートをオンに設定します。

switch(config)# interface fc1/2
switch(config-if)# shut
switch(config-if)# no shut
 

ステップ 8 設定を保存します。

switch(config)# copy running-config startup-config