Cisco MDS 9000 ファミリ NX-OS インターフェイス コンフィギュレーション ガイド Cisco MDS NX-OS Release 6.x
インターフェイスの設定
インターフェイスの設定
発行日;2012/09/24 | 英語版ドキュメント(2012/09/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

インターフェイスの設定

インターフェイスに関する情報

インターフェイスの説明

インターフェイス モード

E ポート

F ポート

FL ポート

NP ポート

TL ポート

TE ポート

TF ポート

TNP ポート

SD ポート

ST ポート

Fx ポート

B ポート

auto モード

インターフェイス ステート

管理ステート

動作ステート

原因コード

正常なシャットダウン

ポート管理速度

自動検知

フレームのカプセル化

ビーコン LED

速度 LED

ビット エラーしきい値

SFP トランスミッタ タイプ

TL ポート

TL ポート ALPA キャッシュ

ポート ガード

ポート モニタ

ポート モニタ ポート ガード

ポート グループ モニタ

ローカル スイッチング

低速ドレイン デバイスの検出と輻輳回避

管理インターフェイス

VSAN インターフェイス

インターフェイスの前提条件

注意事項と制限

第 1 世代インターフェイス設定の注意事項

プライベート ループの設定に関する注意事項

VSAN インターフェイスの設定に関する注意事項

デフォルト設定

インターフェイスの設定

ファイバ チャネル インターフェイスの設定

管理ステートの設定インターフェイスの管理ステートの設定

インターフェイス モードの設定

システムのデフォルト ポート モード F の設定

10 Gbps FC モードの設定

ポート管理速度の設定

ポート速度グループの設定

インターフェイスの説明の設定

ポート オーナーの指定

標識モードの設定

ビット エラーしきい値のディセーブル化

スイッチ ポート属性のデフォルト値の設定

TL ポートの設定

ALPA キャッシュへのエントリの手動追加

ALPA キャッシュのクリア

ポート ガードの設定

ポート モニタの設定

ポート モニタのイネーブル化

ポート モニタ ポリシーの設定

ポート モニタ ポリシーのアクティブ化

ポート モニタ ポート ガードの設定

ポート グループ モニタの設定

ポート グループ モニタのイネーブル化

ポート グループ モニタ ポリシーの設定

特定のカウンタのデフォルト ポリシーの復元

指定したカウンタのモニタリングのオフへの切り替え

ポート グループ モニタ ポリシーのアクティブ化

管理インターフェイスの設定

VSAN インターフェイスの作成

低速ドレイン デバイスの検出と輻輳回避の設定

スタック フレーム タイムアウト値の設定

No-Credit タイムアウト値の設定

クレジット損失回復のしきい値およびアクションの設定

平均クレジット使用不可時間のしきい値およびアクションの設定

インターフェイス設定の確認

インターフェイス情報の表示

TL ポート情報の表示

ALPA キャッシュの内容の表示

ポート モニタ ステータスおよびポリシーの表示

ポート グループ モニタのステータスおよびポリシーの表示

管理インターフェイスの設定の表示

VSAN インターフェイス情報の表示

インターフェイスに関する情報

スイッチの主要な機能は、1 つのデータ リンクから別のリンクへとフレームをリレーすることです。フレーム リレーを行うには、フレームが送受信されるインターフェイスの特性を定義する必要があります。インターフェイスは、ファイバ チャネル インターフェイス、ギガビット イーサネット インターフェイス、管理インターフェイス(mgmt0)、VSAN インターフェイスのうちいずれかに設定できます。

ここで説明する内容は、次のとおりです。

「インターフェイスの説明」

「インターフェイス モード」

「インターフェイス ステート」

「正常なシャットダウン」

「ポート管理速度」

「フレームのカプセル化」

「ビーコン LED」

「速度 LED」

「ビット エラーしきい値」

「SFP トランスミッタ タイプ」

「TL ポート」

「TL ポート ALPA キャッシュ」

「ポート ガード」

「ポート モニタ」

「ポート モニタ ポート ガード」

「ポート グループ モニタ」

「ローカル スイッチング」

「低速ドレイン デバイスの検出と輻輳回避」

「管理インターフェイス」

「VSAN インターフェイス」

インターフェイスの説明

ファイバ チャネル インターフェイスに説明パラメータを設定して、インターフェイスにわかりやすい名前を付けることができます。それぞれのインターフェイスに独自の名前を使用すれば、複数のインターフェイスから探す場合でも必要なインターフェイスをすぐに見つけることができます。説明を使用して、そのインターフェイスのトラフィックや使用方法を示すこともできます。

インターフェイス モード

スイッチ内の物理ファイバ チャネル インターフェイスはそれぞれ、複数あるポート モードのいずれかで動作できます。これらのモードは、E ポート、F ポート、FL ポート、TL ポート、TE ポート、SD ポート、ST ポート、および B ポートです(図 2-1 を参照)。これらのモードに加えて、各インターフェイスを auto ポート モードまたは Fx ポート モードに設定できます。これら 2 つのモードは、インターフェイスの初期化中にポート タイプを判別します。

図 2-1 Cisco MDS 9000 ファミリ スイッチ ポート モード

 


) デフォルトでは、インターフェイスが VSAN 1 に作成されます。『Cisco MDS 9000 Family NX-OS Fabric Configuration Guide』を参照してください。


各インターフェイスには、管理設定と動作ステータスが対応付けられています。

管理設定は、修正を加えない限り変更されません。この設定には、管理モードで設定できる各種の属性があります。

動作ステータスは、インターフェイス速度のような指定された属性の現在のステータスを表します。このステータスは変更できず、読み取り専用です。インターフェイスがダウンの状態のときは、値の一部(たとえば、動作速度)が有効にならない場合があります。


) モジュールを取り外して同じタイプのモジュールで置き換えても、設定は保持されます。別のタイプのモジュールを挿入すると、元の設定は保持されなくなります。


各インターフェイスについて、後続のセクションで簡単に説明します。

E ポート

拡張ポート(E ポート)モードでは、インターフェイスがファブリック拡張ポートとして機能します。このポートを別の E ポートに接続し、2 つのスイッチ間でスイッチ間リンク(ISL)を作成できます。E ポートはフレームをスイッチ間で伝送し、ファブリックを設定および管理できるようにします。リモート N ポートおよび NL ポート宛てフレームのスイッチ間コンジットとして機能します。E ポートは、クラス 2、クラス 3、およびクラス F サービスをサポートします。

別のスイッチに接続された E ポートも、ポートチャネルを形成するように設定できます(「ポートチャネルの設定」を参照)。


) 16 ポート モジュールで E ポートを設定することを推奨します。32 ポート オーバーサブスクライブ モジュールで E ポートを設定する必要がある場合は、4 ポートのグループ(たとえばポート 1 から 4、5 から 8 など)で最初のポートだけを使用できます。その他 3 つのポートは使用できません。


F ポート

ファブリック ポート(F ポート)モードでは、インターフェイスがファブリック ポートとして機能します。このポートを N ポートとして動作する周辺装置(ホストまたはディスク)に接続できます。F ポートは、1 つの N ポートだけに接続できます。F ポートは、クラス 2 とクラス 3 サービスをサポートします。

FL ポート

ファブリック ループ ポート(FL ポート)モードでは、インターフェイスがファブリック ループ ポートとして機能します。このポートを 1 つまたは複数の NL ポート(他のスイッチの FL ポートを含む)に接続し、パブリック アービトレート型ループを形成することができます。初期化の際に 2 つ以上の FL ポートがアービトレート型ループで検出されると、1 つの FL ポートだけが動作可能になり、その他の FL ポートが不参加モードになります。FL ポートは、クラス 2 とクラス 3 サービスをサポートします。


) FL ポート モードは、4 ポートの 10 Gbps スイッチング モジュール インターフェイスでサポートされません。


NP ポート

NP ポートは、NPV モードになっているデバイスのポートであり、F ポートでコア スイッチに接続されます。NP ポートは N ポートのように機能しますが、N ポート動作を提供することに加えて、複数の物理 N ポートのプロキシとして動作します。

NP ポートおよび NPV の詳細については、「N ポート バーチャライゼーションの設定」を参照してください。

TL ポート

トランスレーティブ ループ ポート(TL ポート)モードでは、インターフェイスがトランスレーティブ ループ ポートとして機能します。1 つまたは複数のプライベート ループ装置(NL ポート)に接続できます。TL ポートは Cisco MDS 9000 ファミリ スイッチに特有で、FL ポートとプロパティが似ています。TL ポートは、プライベート ループ装置と次のいずれかの装置間の通信をイネーブルにします。

ファブリックの任意のスイッチに接続された装置

ファブリック内のパブリック ループにある装置

ファブリック内の異なるプライベート ループにある装置

同一プライベート ループにある装置

TL ポートは、クラス 2 とクラス 3 サービスをサポートします。

プライベート ループ装置は、アービトレート型ループに存在するレガシー装置を表します。これらの装置は同一の物理ループ上にある装置だけと通信するので、スイッチ ファブリックを認識しません(「TL ポート ALPA キャッシュ」を参照)。


ヒント TL ポートに接続された装置は、最大 64 のゾーン メンバーを含むゾーン内に設定することを推奨します。


) TL ポート モードは、第 2 世代スイッチング モジュール インターフェイスでサポートされません。


TE ポート

トランキング E ポート(TE ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。別の TE ポートに接続し、2 つのスイッチ間で Extended ISL(EISL)を作成します。TE ポートは、Cisco MDS 9000 ファミリ スイッチに特有のポートです。E ポートの機能を拡張して、次の内容をサポートします。

VSAN トランキング

Quality of Service(QoS)パラメータの転送

ファイバ チャネル トレース(fctrace)機能

TE ポート モードでは、すべてのフレームが、VSAN 情報を含む EISL フレーム フォーマットで送信されます。相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。この機能は、Cisco MDS 9000 ファミリ スイッチではトランキングと呼ばれます(「トランキングの設定」を参照)。TE ポートは、クラス 2、クラス 3、およびクラス F サービスをサポートします。

TF ポート

トランキング F ポート(TF ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。トランキングした別の N ポート(TN ポート)または NP ポート(TNP ポート)に接続して、コア スイッチと NPV スイッチまたは HBA の間のリンクを作成し、タグ付きフレームを伝送できます。TF ポートは、Cisco MDS 9000 ファミリ スイッチに特有のポートです。F ポートの機能を拡張して、VSAN トランキングをサポートします。

TF ポート モードでは、すべてのフレームが、VSAN 情報を含む EISL フレーム フォーマットで送信されます。相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。この機能は、Cisco MDS 9000 ファミリではトランキングと呼ばれます(「トランキングの設定」を参照)。TF ポートは、クラス 2、クラス 3、およびクラス F サービスをサポートします。

TNP ポート

トランキング NP ポート(TNP ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。トランキングした F ポート(TF ポート)に接続して、NPV スイッチからコア NPIV スイッチへのリンクを作成し、タグ付きフレームを伝送できます。

SD ポート

SPAN 宛先ポート(SD ポート)モードでは、インターフェイスがスイッチド ポート アナライザ(SPAN)として機能します。SPAN 機能は、Cisco MDS 9000 ファミリ スイッチに特有の機能です。ファイバ チャネル インターフェイスを通過するネットワーク トラフィックをモニタします。このモニタリングは、SD ポートに接続された標準ファイバ チャネル アナライザ(または同様のスイッチ プローブ)を使用して行われます。SD ポートはフレームを受信しません。送信元トラフィックのコピーを送信するだけです。SPAN 機能は他の機能に割り込むことなく、SPAN 発信元ポートのネットワーク トラフィックのスイッチングに影響しません(『 Cisco MDS 9000 Family NX-OS System Management Configuration Guide 』を参照)。

ST ポート

SPAN トンネル ポート(ST ポート)モードでは、インターフェイスが RSPAN ファイバ チャネル トンネルの送信元スイッチ内の入口ポートとして機能します。ST ポート モードとリモート SPAN(RSPAN)機能は、Cisco MDS 9000 ファミリ スイッチに特有の機能です。ST ポート モードに設定されている場合、インターフェイスを任意の装置に接続できないので、通常のファイバ チャネル トラフィックに使用できません(『 Cisco MDS 9000 Family NX-OS System Management Configuration Guide 』を参照)。


) Cisco MDS 9124 ファブリック スイッチ、HP c-Class BladeSystem 用のシスコ ファブリック スイッチ、IBM BladeCenter 用のシスコ ファブリック スイッチでは、ST ポート モードがサポートされません。


Fx ポート

Fx ポートとして設定されたインターフェイスは、F ポートまたは FL ポート モードのいずれかで動作します。Fx ポート モードは、インターフェイスの初期化中に、接続された N ポートまたは NL ポートに応じて判別されます。この管理設定は、インターフェイスがその他のモードで動作するのを禁止します。たとえば、別のスイッチにインターフェイスが接続されるのを防ぎます。

B ポート

E ポートが一般的にファイバ チャネル スイッチを相互接続するのに対して、シスコ製の PA-FC-1G ファイバ チャネル ポート アダプタなど、一部の SAN 拡張装置は、ブリッジ ポート(B ポート)モデルを実装して地理的に分散したファブリックを接続します。このモデルは、T11 Standard FC-BB-2 に記載されたとおりに B ポートを使用します。

FCIP ピアがファイバ チャネル B ポートだけをサポートする SAN 拡張装置の場合、FCIP リンクに対して B ポート モードをイネーブルにする必要があります。B ポートがイネーブルにされている場合、E ポート機能もイネーブルにされ、共存します。B ポートをディセーブルにしても、E ポート機能はイネーブルのままです(『 Cisco MDS 9000 Family NX-OS IP Services Configuration Guide 』を参照)。

auto モード

auto モードに設定されたインターフェイスは、F ポート、FL ポート、E ポート、TE ポート、または TF ポートのいずれかのモードで動作できます。ポート モードは、インターフェイスの初期設定中に決定されます。たとえば、インターフェイスがノード(ホストまたはディスク)に接続されている場合、N ポートまたは NL ポート モードに応じて F ポートまたは FL ポートとして動作します。インターフェイスがサードパーティ製のスイッチに接続されている場合、E ポート モードで動作します。インターフェイスが Cisco MDS 9000 ファミリの別のスイッチに接続されている場合、TE ポート モードとして動作します(「トランキングの設定」を参照)。

TL ポートと SD ポートは初期化中に判別されず、管理上設定されます。


) Storage Services Module(SSM)のファイバ チャネル インターフェイスは auto モードで設定できません。


インターフェイス ステート

インターフェイス ステートは、インターフェイスの管理設定および物理リンクのダイナミック ステートによって異なります。

管理ステート

管理ステートは、インターフェイスの管理設定を表します( 表 2-1 を参照)。

 

表 2-1 管理ステート

管理ステート
説明

アップ

インターフェイスはイネーブルです。

ダウン

インターフェイスはディセーブルです。インターフェイスをシャットダウンして管理上のディセーブル状態にした場合は、物理リンク層ステートの変更が無視されます。

動作ステート

動作ステートは、インターフェイスの現在の動作ステートを示します( 表 2-2 を参照)。

 

表 2-2 動作ステート

動作ステート
説明

アップ

インターフェイスは、トラフィックを要求に応じて送受信しています。このステートにするためには、インターフェイスが管理上アップの状態、インターフェイス リンク層ステートがアップの状態で、インターフェイスの初期化が完了している必要があります。

ダウン

インターフェイスが(データ)トラフィックを送信または受信できません。

トランキング

インターフェイスが TE または TF モードで正常に動作しています。

原因コード

理由コードは、インターフェイスの動作ステートに左右されます( 表 2-3 を参照)。

 

表 2-3 インターフェイス ステートの理由コード

管理ステート
動作ステート
原因コード

アップ

アップ

なし。

ダウン

ダウン

管理上のダウン:管理のためにインターフェイスをダウンとして設定すると、インターフェイスはディセーブルになります。トラフィックが受信または送信されません。

アップ

ダウン

表 2-4 を参照してください。


表 2-4に示されている理由コードは一部だけです。


管理ステートがアップ、動作ステートがダウンの場合、理由コードは、動作不能理由コードに基づいて異なります( 表 2-4 を参照)。

 

表 2-4 動作不能ステートの理由コード

理由コード(長いバージョン)
説明
適用可能なモード

Link failure or not connected

物理層リンクが正常に動作していません。

すべて

SFP not present

Small Form-Factor Pluggable(SFP)ハードウェアが接続されていません。

Initializing

物理層リンクが正常に動作しており、プロトコル初期化が進行中です。

Reconfigure fabric in progress

ファブリックが現在再設定されています。

Offline

Cisco NX-OS ソフトウェアは指定された R_A_TOV 時間だけ待機してから、初期化を再試行します。

Inactive

インターフェイス VSAN が削除されているか、suspended ステートにあります。

インターフェイスを正常に動作させるには、設定されたアクティブな VSAN にポートを割り当てます。

Hardware failure

ハードウェア障害が検出されました。

Error disabled

エラー条件は、管理上の注意を必要とします。さまざまな理由でインターフェイスがエラーディセーブルになることがあります。次に例を示します。

設定障害。

互換性のない BB_credit 設定。

インターフェイスを動作させるには、最初にこのステートの原因となるエラー条件を修正してから、インターフェイスを管理上のシャット ダウン状態またはイネーブル状態にします。

FC redirect failure

ファイバ チャネルのリダイレクトがルートをプログラムできないので、ポートは分離されます。

No port activation license available

ポート ライセンスがないため、ポートはアクティブでありません。

SDM failure

SDM がルートをプログラムできないので、ポートは分離されます。

Isolation due to ELP failure

ポート ネゴシエーションが失敗しました。

E ポートと TE ポートのみ

Isolation due to ESC failure

ポート ネゴシエーションが失敗しました。

Isolation due to domain overlap

Fibre Channel Domain(fcdomain)のオーバーラップ。

Isolation due to domain ID assignment failure

割り当てられたドメイン ID が無効です。

Isolation due to the other side of the link E port isolated

リンクのもう一方の端の E ポートが分離しています。

Isolation due to invalid fabric reconfiguration

ファブリックの再設定によりポートが分離されました。

Isolation due to domain manager disabled

fcdomain 機能がディセーブルです。

Isolation due to zone merge failure

ゾーン結合に失敗しました。

Isolation due to VSAN mismatch

ISL の両端の VSAN が異なります。

Nonparticipating

FL ポートがループ操作に参加できません。1 つのループ内に複数の FL ポートが存在する場合に発生します。この場合、FL ポート 1 つを除くすべてが自動的に非参加モードになります。

FL ポートおよび TL ポートだけ

PortChannel administratively down

ポートチャネルに所属するインターフェイスがダウンの状態です。

ポートチャネル インターフェイスだけ

Suspended due to incompatible speed

ポートチャネルに所属するインターフェイスに互換性のない速度が存在します。

Suspended due to incompatible mode

ポートチャネルに所属するインターフェイスに互換性のないモードが存在します。

Suspended due to incompatible remote switch WWN

不適切な接続が検出されました。ポートチャネルのすべてのインターフェイスが同じスイッチ ペアに接続されている必要があります。

正常なシャットダウン

ポートのインターフェイスはデフォルトでシャットダウンされます(初期設定を変更しないかぎり)。

Cisco NX-OS ソフトウェアは、E ポート モードで動作しているインターフェイスの次の操作に反応して正常にシャットダウンします。

ユーザがインターフェイスをシャットダウンした場合。

Cisco NX-OS ソフトウェア アプリケーションが、その機能の一部としてポートのシャットダウンを実行した場合。

正常なシャットダウンでは、インターフェイスがシャットダウンされたとき、フレームが失われません。ユーザまたは Cisco NX-OS ソフトウェアがシャットダウンを行うと、シャットダウン リンクに接続されているスイッチは相互に調整し、ポートのすべてのフレームをリンクで安全に送信してからシャットダウンします。この拡張機能により、フレーム損失の可能性が低くなります。

次の状況では、正常なシャットダウンを実行できません。

スイッチからポートを物理的に取り外した場合。

In-Order Delivery(IOD)がイネーブルの場合(IOD の詳細については、『 Cisco MDS 9000 Family NX-OS Fabric Configuration Guide 』を参照してください)。

Min_LS_interval 間隔が 10 秒より長い場合。FSPF グローバル設定の詳細については、『 Cisco MDS 9000 Family NX-OS Fabric Configuration Guide 』を参照してください。


) この E ポート インターフェイスのどちらかの側にある両方のスイッチが MDS スイッチであり、Cisco SAN-OS Release 2.0(1b) 以上または MDS NX-OS Release 4.1(1a) 以上を実行している場合にかぎり、この機能は動作します。


ポート管理速度

デフォルトの場合、インターフェイスのポート管理速度はスイッチによって自動的に計算されます。

HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用シスコ ファブリック スイッチの内部ポートの場合、ポート速度 1 Gbps はサポートされません。オートネゴシエーションは、2 ~ 4 Gbps だけでサポートされます。BladeCenter が T シャーシである場合、ポート速度は 2 Gbps に固定され、オートネゴシエーションはイネーブルになりません。

自動検知

速度の自動検知は、すべての 4 Gbps および 8 Gbps スイッチング モジュール インターフェイスにおいてデフォルトでイネーブルです。インターフェイスは、この設定により、4 Gbps のスイッチング モジュールにおいて、1 Gbps、2 Gbps、4 Gbps のいずれかの速度で動作し、8 Gbps のスイッチング モジュールにおいて、8 Gbps の速度で動作できるようになります。専用レート モードで動作するインターフェイスで自動検知をイネーブルにすると、ポートが 1 Gbps または 2 Gbps の動作速度でネゴシエーションしていても、4 Gbps の帯域幅が予約されます。

48 ポートおよび 24 ポートの 4 Gbps および 8 Gbps ファイバ チャネル スイッチング モジュールで未使用帯域幅の無駄を防ぐには、デフォルトの 4 Gbps または 8 Gbps ではなく、必要な帯域幅の 2 Gbps だけを指定します。この機能では、ポートのレート制限設定を超えなければ、ポート グループ内で未使用帯域幅が共有されます。自動検知に設定されている共有レート ポートにも、この機能を使用できます。


ヒント 2 Gbps までのトラフィックをサポートする(つまり自動検知機能がある 4 Gbps ではない)ホストを 4 Gbps スイッチング モジュールに移行するときは、最大帯域幅を 2 Gbps にして自動検知を使用します。4 Gbps までのトラフィックをサポートする(つまり自動検知機能がある 8 Gbps ではない)ホストを 8 Gbps スイッチング モジュールに移行するときは、最大帯域幅を 4 Gbps にして自動検知を使用します。

フレームのカプセル化

switchport encap eisl コマンドは、SD ポート インターフェイスだけに適用されます。このコマンドは、SD ポート モードにあるインターフェイスによって送信されたすべてのフレームのフレーム フォーマットを判別します。カプセル化を EISL に設定すると、すべての発信フレームは、SPAN 送信元に関係なく EISL フレーム形式で送信されます。

switchport encap eisl コマンドは、デフォルトではディセーブルです。カプセル化をイネーブルにする場合、すべての発信フレームがカプセル化され、 show interface SD_port_interface コマンド出力に新しい行(Encapsulation is eisl)が表示されます。『 Cisco MDS 9000 Family NX-OS System Management Configuration Guide 』を参照してください。

SD ポート モードのインターフェイスで送信されるすべてのフレームには、フレーム形式を EISL に設定できます。フレームのカプセル化を EISL に設定すると、すべての発信フレームは、SPAN ソースに関係なく EISL フレーム形式で送信されます。『 Cisco MDS 9000 Family NX-OS System Management Configuration Guide 』を参照してください。

ビーコン LED

図 2-2 は、16 ポート スイッチング モジュールのステータス LED、リンク LED、速度 LED を示しています。

図 2-2 Cisco MDS 9000 ファミリ スイッチのインターフェイス モード

1

ステータス LED1

3

リンク LED 1 および速度 LED2

2

1/2 Gbps ファイバ チャネル ポート グループ3

4

資産タグ4

nullnullnullnull

速度 LED

各ポートの左側にはリンク LED、右側には速度 LED があります。

速度 LED では、ポート インターフェイスの速度が次のように示されます。

消灯:そのポートに接続しているインターフェイスは 1000 Mbps で機能しています。

点灯(グリーン):そのポートに接続しているインターフェイスは 2000 Mbps で機能しています(2 Gbps インターフェイスの場合)。

速度 LED は、標識モードがイネーブルであるかディセーブルであるかも示します。

消灯またはグリーンで点灯:標識モードはディセーブルです。

グリーンで点滅:標識モードはイネーブルです。LED は 1 秒間隔で点滅します。


) 第 2 世代、第 3 世代、および第 4 世代のモジュールおよびファブリック スイッチには、速度 LED がありません。


ビット エラーしきい値

ビット エラー レートしきい値は、パフォーマンスの低下がトラフィックに重大な影響を与える前にエラー レートの増加を検出するために、スイッチにより使用されます。

ビット エラーは、次の理由で発生することがあります。

ケーブル故障または不良。

GBIC または SFP 故障または不良。

GBIC または SFP は 1 Gbps で動作するように指定されているが、2 Gbps で使用されている。

GBIC または SFP は 2 Gbps で動作するように指定されているが、4 Gbps で使用されている。

長距離に短距離ケーブルが使用されている、または短距離に長距離ケーブルが使用されている。

一時的な同期の喪失。

ケーブルの片端または両端の接続のゆるみ。

片端または両端での不適切な GBIC 接続または SFP 接続。

5 分間に 15 のエラー バーストが発生すると、ビット エラー レートしきい値が検出されます。デフォルトでは、しきい値に達するとスイッチはインターフェイスをディセーブルにします。インターフェイスを再びイネーブルにするには、 shutdown および no shutdown コマンド シーケンスを入力します。

しきい値を超えてもインターフェイスがディセーブルにならないようにスイッチを設定できます。デフォルトの場合、しきい値によってインターフェイスはディセーブルになります。

SFP トランスミッタ タイプ

Small Form-Factor Pluggable(SFP)ハードウェア トランスミッタは略語で表示されます。 表 2-5 は SFP に使用される略語です。

Small Form-Factor Pluggable(SFP)ハードウェア トランスミッタは、 show interface brief コマンドで表示される際に略語で示されます。関連する SFP がシスコによって割り当てられた拡張 ID を持つ場合、 show interface コマンドと show interface brief コマンドは、トランスミッタ タイプではなく、ID を表示します。 show interface transceiver コマンドと show interface fc slot / port transceiver コマンドは、シスコがサポートする SFP に対して両方の値を表示します。 表 2-5 にコマンド出力で使用される略語の意味を示します(「インターフェイス情報の表示」を参照)。

 

表 2-5 SFP トランスミッタの略語

定義
略語
GBIC 仕様で定義される標準トランスミッタ

短波レーザー

swl

長波レーザー

lwl

コスト削減長波レーザー

lwcr

電気的

elec

Cisco がサポートする SFP に割り当てられた拡張トランスミッタ

CWDM-1470

c1470

CWDM-1490

c1490

CWDM-1510

c1510

CWDM-1530

c1530

CWDM-1550

c1550

CWDM-1570

c1570

CWDM-1590

c1590

CWDM-1610

c1610

TL ポート

プライベート ループ装置は、アービトレート型ループに存在するレガシー装置を表します。これらの装置は同一の物理ループ上にある装置だけと通信するので、スイッチ ファブリックを認識しません。レガシー装置をファイバ チャネル ネットワークで使用し、ループ外のデバイスがレガシー装置とやり取りしなければならないことがあります。通信機能は TL ポートで提供されます。「インターフェイス モード」を参照してください。

次のハードウェアでは TL ポート モードがサポートされていません。

第 2 世代スイッチング モジュール インターフェイス

Cisco MDS 9124 ファブリック スイッチ

HP c-Class BladeSystem 用の Cisco ファブリック スイッチ

IBM BladeCenter 用の Cisco ファブリック スイッチ

表 2-6 は、Cisco MDS 9000 ファミリ スイッチでサポートされている TL ポート変換を示しています。

 

表 2-6 サポートされている TL ポート変換

変換元
変換先

プライベート イニシエータ

プライベート ターゲット

I1 から T1 またはその反対

プライベート イニシエータ

パブリック ターゲット:N ポート

I1 から T2 またはその反対

プライベート イニシエータ

パブリック ターゲット:NL ポート

I4 から T3 またはその反対

パブリック イニシエータ:N ポート

プライベート ターゲット

I2 から T1 またはその反対

パブリック イニシエータ:NL ポート

プライベート ターゲット

I3 から T1 またはその反対

図 2-3 は、TL ポート変換のサポート例です。

図 2-3 TL ポート変換のサポート例

 

TL ポート ALPA キャッシュ

TL ポートは自動的に設定できませんが、Arbitrated Loop Physical Address(ALPA)キャッシュにエントリを手動で設定できます。一般的には、ALPA をデバイスに割り当てると、ALPA キャッシュ エントリが自動的に入力されます。各デバイスは、Port World Wide Name(pWWN)によって識別します。デバイスに ALPA を割り当てると、そのデバイスのエントリが ALPA キャッシュで自動的に作成されます。

キャッシュには、最近割り当てられた ALPA 値のエントリが含まれます。このキャッシュはさまざまな TL ポートで維持されます。デバイスに ALPA がすでに存在する場合、Cisco NX-OS ソフトウェアは同じ ALPA をデバイスに毎回割り当てようとします。ALPA キャッシュは永続ストレージに維持され、スイッチをリブートしても情報は保存されます。最大キャッシュ サイズは 1000 エントリです。キャッシュがいっぱいになって新しい ALPA が割り当てられると、Cisco NX-OS ソフトウェアはアクティブでないキャッシュ エントリがある場合はそれを廃棄し、新しいエントリ用にスペースを作成します。TL ポートの詳細については、「TL ポート」を参照してください。

ポート ガード

ポート ガード機能の使用の対象となるのは、ポートのダウンおよびバックアップ、あるいはポートの電源の投入および停止がすばやく発生するポートに、システムおよびアプリケーション環境が迅速かつ効率的に適応できない状況で、この状況は障害モードで発生することがあります。たとえば、ポートがダウンしてからシステムが安定するまで 5 秒かかり、ポートが 1 秒に 1 回アップとダウンを行う場合、ファブリックで重大な障害が発生する可能性があります。

ポート ガード機能によって、SAN 管理者はこれらの問題に対して脆弱な環境において、この問題の発生を避けることができます。ポートは最初の障害後にダウンしたままに設定するか、または指定された期間に指定された数の障害が発生したあとにダウンするように設定できます。これにより、SAN 管理者が介入してリカバリを制御することによって、電源の再投入による問題を回避できます。

ポート ガード機能を使用すると、エラー レポートの数を制限したり、誤動作中のポートをダイナミックにダウン状態にしたりできます。特定のエラー時にエラーディセーブル状態になるようにポートを設定できます。

リンクダウンによる一般的なリンク障害は、その他すべての原因を含みます。その他すべての原因の数を合計すると、リンクダウンによるリンク障害の数と等しくなります。つまり、許容されているリンク障害の最大数または特定の原因の数に達すると、ポートはダウン状態になります。

次のようなリンク障害の原因が考えられます。

ESP trustsec 違反

ビット エラー

信号損失

同期の喪失

リンクのリセット

クレジット損失

その他にも次の原因が考えられます。

正常に動作していない(NOS)。

中断が多すぎる。

ケーブルが切断されている。

ハードウェア回復可能エラー。

接続されている装置の再起動(F ポート限定)。

接続されているラインカードの再起動(ISL 限定)。

ポート モニタ

ポート モニタを使用すると、ポートのパフォーマンスとステータスを監視し、問題が発生したときにアラートを生成できます。さまざまなカウンタについてしきい値を設定し、値がしきい値設定を超えた場合にイベントをトリガーできます。

デフォルトのポート モニタ ポリシーには、次のしきい値が定義されています。

 

カウンタ
しきい値の種類
間隔(秒)
上昇しきい値(%)
イベント
下限しきい値(%)
イベント

Link Loss

差分(Delta)

60

5

4

1

4

Sync Loss

差分(Delta)

60

5

4

1

4

Protocol Error

差分(Delta)

60

1

4

0

4

Signal Loss

差分(Delta)

60

5

4

1

4

Invalid Words

差分(Delta)

60

1

4

0

4

Invalid CRCs

差分(Delta)

60

5

4

1

4

RX Performance

差分(Delta)

60

2147483648

4

524288000

4

TX Performance

差分(Delta)

60

2147483648

4

524288000

4

ポート モニタ ポート ガード

ポート モニタ ポート ガードは、イベントが発生したときにポートを無効にするか、シャットダウンする機能です。イベントが発生すると、設定によって、ポートがエラーディセーブルになるか、フラップされます。

ポート モニタ ポート ガード機能は、 errordisable コマンドの設定に基づいて動作する別個の機能です。

ポート グループ モニタ

各ラインカードまたはモジュールには、同じバックプレーン帯域幅を共有する、ポート グループと呼ばれる事前定義されたポートのセットがあります。オーバーサブスクリプションは機能ですが、ポート グループ モニタ機能は、スパインの帯域利用率のモニタリングに役立ちます。ポートをポート グループ全体に均等にプロビジョニングすることにより、オーバーサブスクリプションを効率的に管理できるように、アラーム syslog が生成されます。

ポート グループ モニタ機能がイネーブルで、ポーリング間隔(秒)で構成されるポリシーと上昇しきい値および下限しきい値(%)が指定されている場合、ポート グループ モニタは、ポート グループのトラフィックがそのポート グループでサポートされる最大帯域幅の指定されたパーセント値(rx と tx)を超えた場合に syslog を生成します。また、その値が指定されたしきい値を下回った場合にも別の syslog を生成します。

デフォルトのポート グループ ポリシーには、次のしきい値が定義されています。

カウンタ
しきい値の種類
間隔(秒)
上昇しきい値(%)
下限しきい値(%)

RX Performance

差分(Delta)

60

80

20

TX Performance

差分(Delta)

60

80

20

ローカル スイッチング

第 4 世代のモジュールでは、ローカル スイッチングをイネーブルにすることにより、あるポートから同じラインカードの別のポートにトラフィックが転送されるときにローカル クロスバーで直接スイッチングできます。ローカル スイッチングを使用すると、余分なスイッチングが回避されることにより、遅延が減少します。

ローカル スイッチングを使用する場合、次の点に注意してください。

すべてのポートが共有モード(通常はデフォルト状態)であることが必要です。ポートを共有モードにするには、 switchport ratemode shared コマンドを入力します。

E ポートは、専用モードでなければならないため、このモジュールでは許可されません。

低速ドレイン デバイスの検出と輻輳回避

SAN ファブリック内のエンド デバイス間では、すべてのデータ トラフィックがファイバ チャネル クラス 3 によって伝送されます。場合によっては、リンク レベルでホップ単位のバッファ間フロー制御を使用するクラス 2 サービスによってトラフィックが伝送されることもあります。これらのサービス クラスは、エンドツーエンド フロー制御をサポートしません。ファブリックに低速デバイスが接続されている場合、エンド デバイスは設定またはネゴシエーションされたレートのフレームを受け入れません。低速デバイスにより、これらのデバイスを宛先とするトラフィックで ISL クレジット不足が発生し、リンクが輻輳します。クレジット不足は、宛先デバイスで低速ドレインが発生していなくても、ファブリック内の同じ ISL リンクを使用する無関係なフローに影響します。

この機能は、ネットワークで輻輳を引き起こしている低速ドレイン デバイスを検出するためにさまざまな機能拡張を行い、さらに輻輳回避機能も提供します。

この機能は、主として、低速ドレイン デバイスに接続されたエッジ ポートを対象としています。目的は、ISL の閉塞を引き起こしている低速ドレイン デバイスが原因でフレームがエッジ ポートに残ることを回避または最小限に抑えることです。この閉塞状態を回避するか、最小限に抑えるためには、ポートのフレーム タイムアウトを短縮します。No-Credit タイムアウトでは、設定されたしきい値によって低速ドレインが検出されると、すべてのパケットがドロップされます。フレーム タイムアウト値を小さくすることにより、エッジ ポートで実際にタイムアウトになる時間(500 ミリ秒)より早くパケットがドロップされるため、ファブリックに影響する低速ドレイン状態が軽減されます。この機能は、ISL のバッファ領域を解放し、低速ドレイン状態が発生していない他の無関係なフローが使用できるようにします。


) この機能は、主として、低速ドレイン デバイスに接続されたエッジ ポートで使用されます。この機能は ISL にも適用できますが、エッジ F ポートにのみ適用し、ISL はデフォルト設定の E ポートおよび TE ポートのまま維持することを推奨します。この機能は、第 1 世代のモジュールではサポートされません。


管理インターフェイス

管理インターフェイス(mgmt0)を使用し、スイッチをリモートで設定できます。mgmt0 インターフェイスで接続を設定するには、IP バージョン 4(IPv4)パラメータ(IP アドレス、サブネット マスク、デフォルト ゲートウェイ)、または IP バージョン 6(IPv6)パラメータを設定し、スイッチに到達できるようにする必要があります。

管理インターフェイスの手動設定をはじめる前に、スイッチの IPv4 アドレスとサブネット マスク、または IPv6 アドレスを取得してください。

管理ポート(mgmt0)は自動検知であり、10/100/1000 Mbps の速度によって全二重モードで動作します。自動検知では、この速度とデュプレックス モードがサポートされます。スーパーバイザ 1 モジュールの場合、デフォルトの速度は 100 Mbps、デフォルトのデュプレックス モードは自動です。スーパーバイザ 2 モジュールの場合、デフォルトの速度は自動、デフォルトのデュプレックス モードは自動です。


) スイッチに接続して IP パケットを送信するには、デフォルト ゲートウェイを明示的に設定するか、サブネットごとにルートを追加する必要があります。


VSAN インターフェイス

VSAN はファイバ チャネル ファブリックに適用され、同一の物理インフラストラクチャで複数の独立 SAN トポロジーの設定を可能にします。VSAN の上に IP インターフェイスを作成して、このインターフェイスを使用してこの VSAN にフレームを送信できます。この機能を使用するには、この VSAN の IP アドレスを設定する必要があります。存在しない VSAN の VSAN インターフェイスは作成できません。

インターフェイスの前提条件

インターフェイスの設定をはじめる前に、シャーシのモジュールが設計どおりに機能していることを確認してください。任意の時点でモジュールのステータスを確認するには、EXEC モードで show module コマンドを入力します。モジュール ステータスの確認については、『 Cisco NX-OS Fundamentals Configuration Guide 』を参照してください。

注意事項と制限

ここで説明する内容は、次のとおりです。

「第 1 世代インターフェイス設定の注意事項」

「プライベート ループの設定に関する注意事項」

「VSAN インターフェイスの設定に関する注意事項」

第 1 世代インターフェイス設定の注意事項

第 1 世代インターフェイス設定の注意事項は、次のハードウェアに適用されます。

32 ポートの 2 Gbps または 1 Gbps スイッチング モジュール インターフェイス

Cisco MDS 9140 および 9120 スイッチ インターフェイス


) MDS 9134 スイッチのハードウェア設計上、2 つの 10 ギガビット ポートのいずれでも、インターフェイスのアウトオブサービス アクションはサポートされません。これは、アウトオブサービス アクションがこれらの 10 ギガビット ポートで実行された場合、内部ポートのハードウェア リソースが解放されないためです。


これらのホスト最適化ポートを設定する場合は、ポート モードに関する次の注意事項が適用されます。

各 4 ポートのグループの最初のポートだけを E ポートとして設定できます(ポート 1 ~ 4 の最初のポート、ポート 5 ~ 8 の 5 のポートなど)。そのグループの最初のポートが E ポートとして設定された場合は、各グループのその他の 3 つのポート(ポート 2 ~ 4、6 ~ 8 など)は使用できず、shutdown ステートのままになります。

32 ポート スイッチング モジュールで write erase コマンドを実行し、 no system default switchport shutdown コマンドを含むテキスト ファイルからスイッチに保存済み設定をコピーする場合、手動設定せずに E ポートをアップさせるには、テキスト ファイルをスイッチに再度コピーする必要があります。

その他の 3 つのポートのいずれかがイネーブルである場合は、最初のポートを E ポートとして設定できません。その他の 3 つのポートは、引き続きイネーブル状態になります。

auto モードは、Cisco 9100 シリーズの 32 ポート スイッチング モジュール、またはホスト最適化ポートで使用できません(Cisco MDS 9120 スイッチの 16 のホスト最適化ポートおよび Cisco MDS 9140 スイッチの 32 のホスト最適化ポート)。

32 ポート スイッチング モジュールのデフォルト ポート モードは Fx(Fx は、F または FL にネゴシエート)です

32 ポート スイッチング モジュールでは FICON がサポートされません。


) 16 ポート スイッチング モジュールで E ポートを設定することを推奨します。32 ポート ホスト最適化スイッチング モジュールで E ポートを設定する必要がある場合は、4 ポート グループのその他 3 つのポートを使用できません。



) Cisco MDS 9100 シリーズでは、左端の白抜きのポート グループは、フル回線レートで動作します。その他のポートはホスト向けに最適化されます。4 つのホスト最適化ポートの各グループの機能は、32 ポート スイッチング モジュールの機能と同じです。


プライベート ループの設定に関する注意事項

プライベート ループを設定する場合、次の注意事項に従ってください。

最大 64 のファブリック デバイスをプライベート ループにプロキシできます。

ファブリック デバイスは、プライベート ループ デバイスと同じゾーンに存在しなければ、プライベート ループにプロキシされません。

TL ポートの各プライベート デバイスは、別のゾーンに含めることができます。

ループのすべてのデバイスはプライベート ループとして扱われます。設定ポート モードが TL である場合は、プライベートおよびパブリックのデバイスをループで混在させることはできません。

TL ポートでサポートされる FC4 タイプは SCSI(FCP)だけです。

同一プライベート ループに存在するプライベート イニシエータからプライベート ターゲットへのやり取りでは、TL ポート サービスが起動されません。

VSAN インターフェイスの設定に関する注意事項

VSAN インターフェイスを作成または削除するときは、次の注意事項に従ってください。

目的の VSAN のインターフェイスを作成する前に VSAN を作成します。VSAN が存在しない場合、インターフェイスを作成できません。

インターフェイス VSAN を作成します。インターフェイス VSAN は自動作成されません。

VSAN を削除すると、接続されたインターフェイスが自動的に削除されます。

各インターフェイスを 1 つの VSAN だけに設定します。


ヒント VSAN インターフェイスを設定したあと、IP アドレスまたは Virtual Router Redundancy Protocol(VRRP)機能を設定できます。『Cisco MDS 9000 Family NX-OS IP Services Configuration Guide』を参照してください。

デフォルト設定

 

表 2-7 に、インターフェイス パラメータのデフォルト設定を示します。

 

表 2-7 デフォルト インターフェイス パラメータ

パラメータ
デフォルト

インターフェイス モード

自動

インターフェイス速度

自動

管理ステート

Shutdown(初期設定時に変更された場合を除く)

トランク モード

非 NPV スイッチおよび NPIV コア スイッチでオン(初期設定中に変更しない場合)、 NPV スイッチでオフ

トランク許可 VSAN または VF-ID

1 ~ 4093

インターフェイス VSAN

デフォルト VSAN(1)

標識モード

オフ(ディセーブル)

EISL カプセル化

ディセーブル

データ フィールド サイズ

2112 バイト

インターフェイスの設定

ここで説明する内容は、次のとおりです。

「ファイバ チャネル インターフェイスの設定」

「管理ステートの設定インターフェイスの管理ステートの設定」

「インターフェイス モードの設定」

「システムのデフォルト ポート モード F の設定」

「ポート管理速度の設定」

「ポート速度グループの設定」

「インターフェイスの説明の設定」

「ポート オーナーの指定」

「標識モードの設定」

「ビット エラーしきい値のディセーブル化」

「スイッチ ポート属性のデフォルト値の設定」

「TL ポートの設定」

「ALPA キャッシュへのエントリの手動追加」

「ALPA キャッシュのクリア」

「ポート ガードの設定」

「ポート モニタの設定」

「ポート グループ モニタの設定」

「管理インターフェイスの設定」

「VSAN インターフェイスの作成」

「低速ドレイン デバイスの検出と輻輳回避の設定」

mgmt0 インターフェイスの設定の詳細については、『 Cisco MDS 9000 Family NX-OS Fundamentals Configuration Guide 』および『 Cisco MDS 9000 Family NX-OS IP Services Configuration Guide 』を参照してください。

ギガビット イーサネット インターフェイスの設定の詳細については、『 Cisco MDS 9000 Family NX-OS IP Services Configuration Guide 』を参照してください。

ファイバ チャネル インターフェイスの設定

手順の詳細

ファイバ チャネル インターフェイスを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

(注) ファイバ チャネル インターフェイスが設定された場合、自動的に一意の World Wide Name(WWN)が割り当てられます。インターフェイスの動作ステートがアップの場合、ファイバ チャネル ID(FC ID)も割り当てられます。

インターフェイスの範囲を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1 - 4 , fc2/1 - 3

switch(config-if)#

ファイバ チャネル インターフェイスの範囲を選択し、インターフェイス コンフィギュレーション サブモード 3 を開始します。

(注) このコマンドでは、カンマの前後にスペースを挿入します。

HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用シスコ ファブリック スイッチの場合は、ある範囲のインターフェイスを内部ポート間または外部ポート間で設定できますが、同一範囲内で両方のインターフェイス タイプを混在させることはできません。たとえば、「ベイ 1 ~ 10、ベイ 12」または「外部 0、外部 15 ~ 18」は有効な範囲ですが、「ベイ 1 ~ 5、外部 15 ~ 17」は有効な範囲ではありません。

管理ステートの設定インターフェイスの管理ステートの設定

手順の詳細

インターフェイスを正常にシャット ダウンするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# shutdown

インターフェイスを正常にシャットダウンし、トラフィック フローを管理上ディセーブルにします(デフォルト)。

トラフィック フローをイネーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# no shutdown

no プレフィックスが使用された場合(動作ステートはアップ)、管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

インターフェイス モードの設定

手順の詳細

インターフェイス モードを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport mode F

switch(config-if)#

ポートの管理モードを設定します。動作ステートは、auto、E、F、FL、Fx、TL、NP、または SD ポート モードに設定できます。

(注) Fx ポートとは、F ポートまたは FL ポート(ホスト接続のみ)を意味し、これには E ポートは含まれません。

switch(config-if)# switchport mode auto

switch(config-if)#

E、F、FL、または TE ポート モード(TL または SD ポート モードではない)の操作をオートネゴシエーションするようにインターフェイス モードを設定します。

(注) TL ポートおよび SD ポートを自動的に設定することはできません。このポートは管理上設定する必要があります。

(注) SSM のファイバ チャネル インターフェイスを auto モードに設定することはできません。

システムのデフォルト ポート モード F の設定

system default switchport mode F コマンドは、すべてのファイバ チャネル ポートの管理モードをモード F に設定するとともに、不要なスイッチ間リンク(ISL)の形成によるトラフィックの中断を回避します。このコマンドは、 write erase または reload の実行後の起動中に実行されるセットアップ ユーティリティの一部です。また、このコマンドをコンフィギュレーション モードでコマンドラインから実行することもできます。このコマンドは、次のポートの設定を管理モード F に変更します。

ダウンしていて、アウト オブ サービスではない、すべてのポート。

アップしていて、動作モードが F であり、管理モードが F ではない、すべての F ポート。

このコマンドは、次のポートの設定には影響しません。

すべてのユーザ設定のポート(ダウンしている場合でも)。

F ポート以外のアップしているすべてのポート。ただし、F ポート以外のポートがダウンしている場合、このコマンドはそれらのポートの管理モードを変更します。

制約事項

ISL の一部であるポートがポート モード F に変更されないようにするには、auto モードではなくポート モード E にポートを設定します。

このコマンドをコマンドラインから実行した場合、スイッチの動作は正常なままです。いずれのポートもフラップされません。

手順の詳細

CLI でファイバ チャネル ポートの管理モードをモード F に設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# system default switchport mode F

ファイバ チャネル ポートの管理モードをモード F に設定します(該当する場合)。

switch(config)# no system default switchport mode F

ファイバ チャネル ポートの管理モードをデフォルトに設定します(ユーザ設定の場合を除く)。


) スイッチ セットアップ ユーティリティの詳細については、『Cisco MDS 9000 Family NX-OS Fundamentals Configuration Guide』を参照してください。


例 2-1 は、このコマンドをセットアップ ユーティリティで実行する方法を示します。例 2-2 は、このコマンドをコマンドラインから実行する方法を示します。

例 2-1 セットアップ ユーティリティ

Configure default switchport mode F (yes/no) [n]: y

例 2-2 コマンドライン

switch(config)# system default switchport mode F
 

10 Gbps FC モードの設定

48 ポートの 8 Gbps 拡張ファイバ チャネル モジュール(DS-X9248-256K9)と 32 ポートの 8 Gbps 拡張ファイバ チャネル モジュール(DS-X9232-256K9)は、2 つの速度モード(1、2、4、8 Gbps と 10 Gbps)の間で切り替えることができます。デフォルトでは、これらのモジュールは、最初にロードされたとき、1、2、4、および 8 Gbps モードでオンラインになります。ポートを 10 Gbps 速度モードに変更するには、次の 2 つの方法があります。

10G-speed mode コマンドを使用する。これが推奨される方法です。

汎用的な速度設定の switchport speed コマンドを使用する。このコマンドには制約があります。

次の条件に適合する場合、モジュールのポートを 10 Gbps 速度モードに設定できます。

モジュールのポートは、DS-13SLT-FAB3 モジュールの帯域幅が 256-G である場合にのみ速度を 10 Gbps に設定できます。ファブリック モジュールの他の組み合わせでは、ポートは 10 Gbps でアップになりません。

10 Gbps モードでは、モジュール内の 10 Gbps に対応していないポートがディセーブルになり、アウトオブサービス状態となります。

ポートはフル レート モードでのみ機能します。ポートを共有レート モードに移行することはできません。

ポートを他の速度に設定することはできません。

ディセーブルまたはアウトオブサービスになっている 10 Gbps 対応のポートを no out-of-service コマンドでサービス状態に戻すことはできません。これらのポートをサービス状態に戻すには、まずモジュール内のすべてのポートをアウトオブサービス状態にする必要があります。その後、ポートをサービス状態に戻すことができます。

ローカル スイッチングはディセーブルにする必要があります。そうしなければ、ポートを専用モードに設定できません。

48 ポートおよび 32 ポートの 8 Gbps 拡張ファイバ チャネル モジュールの特定のポートだけが 10 Gbps に対応しています。10 Gbps モードで動作している場合、10 Gbps でないポートは動作しません。それらのポートは shut 状態またはアウトオブサービス状態にする必要があります。

手順の詳細

インターフェイス モードを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1-12

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

(注) このコマンドを実行する前に、必ずいずれかの完全な ASIC 範囲を選択してください。たとえば、48 ポート モジュールの場合は /1-12、32 ポート モジュールの場合は fcY/1-8 をそれぞれ選択します。

48 ポート モジュールの場合、最初の ASIC にはポート fc1/1-12 があります。

ステップ 3

switch(config-if)# 10G-speed-mode

すべてのポート(fc1 ~ 12)をアウトオブサービス状態に設定します。

10 Gbps 設定対応のポート(fc1/4-8 および fc1/10)をサービス状態に移行します。

ポート fc1/4-8 および fc1/10 の速度を 10 Gbps に設定します。

これらのポートのポート モードを専用に設定します。

これらのポートに対して no shut を実行します。

switch(config-if)# no 10G-speed-mode

設定を元に戻し、すべてのポート(fc1 ~ 12)をアウトオブサービス状態にしてから、サービス状態に移行します。

ポート管理速度の設定

制約事項

ポート管理速度の変更は、中断を伴う操作です。

手順の詳細

インターフェイスのポート速度を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc 1/1

mgmt0 インターフェイスを選択して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport speed 1000

インターフェイスのポート速度を 1000 Mbps に設定します。

数値は、Mbps 単位の速度を表します。速度は、1000(1 Gbps インターフェイスの場合)、2000(2 Gbps インターフェイスの場合)、4000(4 Gbps インターフェイスの場合)、8000(8 Gbps インターフェイスの場合)、または auto(デフォルト)に設定できます。

switch(config-if)# switchport speed 10000

インターフェイスのポート速度を 10000 Mbps に設定します(10 Gbps の場合)。

(注) 設定するインターフェイスを除く 10 Gbps 対応のすべてのインターフェイスがアウトオブサービス状態であることが必要です。他の 10 Gbps 対応のインターフェイスのうち少なくとも 1 つは、サービス状態であることが必要です。

switch(config-if)# no switchport speed

インターフェイスの出荷時の設定(auto)管理速度に戻します。

ポート速度グループの設定

手順の詳細

インターフェイスのポート速度グループを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc 1/1

mgmt0 インターフェイスを選択して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# speed group 10000

10 Gbps のポート速度グループを設定します。

数字は Gbps 単位の速度を表します。速度は、1000(1 Gbps インターフェイスの場合)、2000(2 Gbps インターフェイスの場合)、4000(4 Gbps インターフェイスの場合)、8000(8 Gbps インターフェイスの場合)、10000(10 Gbps インターフェイスの場合)、または auto(デフォルト)に設定できます。

switch(config-if)# no speed group speed

ポート速度グループを解除し、インターフェイスの出荷時の設定(auto)管理速度グループに戻します。

インターフェイスの説明の設定

インターフェイスの説明には、任意の英数字の文字列を使用できます。

手順の詳細

インターフェイスの説明を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport description cisco-HBA2

インターフェイスの説明を設定します。ストリングの長さは、最大 80 文字まで可能です。

switch(config-if)# no switchport description

インターフェイスの説明をクリアします。

ポート オーナーの指定

ポート オーナー機能を使用すると、ポートのオーナーおよびポートの使用目的を指定でき、他の管理者に通知できます。


) ポート ガードおよびポート オーナーの機能は、動作モードに関係なくすべてのポートで使用できます。


手順の詳細

ポート オーナーを指定または削除するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ポート インターフェイスを選択します。

ステップ 3

switch(config)# switchport owner description

スイッチ ポートのオーナーを指定します。説明には、オーナーの名前とポートの使用目的を含めることができます。説明の長さは最大 80 文字です。

switch(config)# no switchport owner

ポート オーナーの説明を削除します(デフォルト)。

ポートに指定されたオーナーの説明を表示するには、次のコマンドを使用します。

switch# show running interface fc module-number/interface-number
switch# show port internal info interface fc module-number/interface-number
 

標識モードの設定

デフォルトの場合、標識モードはすべてのスイッチでディセーブルです。標識モードはグリーンの点滅で示され、指定インターフェイスの物理的な場所を識別できます。標識モードを設定しても、インターフェイスの動作には影響しません。

手順の詳細

指定したインターフェイスまたはインターフェイスの範囲の標識モードをイネーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport beacon

インターフェイスの標識モードをイネーブルにします。

switch(config-if)# no switchport beacon

インターフェイスの標識モードをディセーブルにします。

トラブルシューティングのヒント

インターフェイスの分離の原因となる外部ループバックが検出されると、グリーンの点滅が自動的に始まります。グリーンの点滅により、標識モード設定は無効になります。外部ループバックが削除されると、LED の状態は復元され、標識モード設定が反映されます。

ビット エラーしきい値のディセーブル化

手順の詳細

インターフェイスのビット エラーしきい値をディセーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがディセーブルにならないようにします。

switch(config-if)# no switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがイネーブルにならないようにします。

トラブルシューティングのヒント

switchport ignore bit-errors コマンドが設定されているかどうかに関係なく、ビット エラーしきい値イベントが検出されると、スイッチで syslog メッセージが生成されます。

スイッチ ポート属性のデフォルト値の設定

各種のスイッチ ポート属性の属性デフォルト値を設定できます。これらの属性は、この時点でそれぞれを指定しなくても、今後のすべてのスイッチ ポート設定にグローバルに適用されます。

手順の詳細

スイッチ ポート属性を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# no system default switchport shutdown

switch(config)#

インターフェイス管理ステートのデフォルト設定をアップに設定します。(出荷時のデフォルト設定はダウンです)。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport shutdown

switch(config)#

インターフェイス管理ステートのデフォルト設定をダウンに設定します。これが出荷時のデフォルト設定です。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport trunk mode auto

switch(config)#

インターフェイスの管理トランク モード ステートのデフォルト設定を auto に設定します。

(注) デフォルト設定のトランク モードは on です。

TL ポートの設定

プライベート ループでは、インターフェイス モードを TL に設定する必要があります。

TL ポートを設定するには、 switchport mode コマンドを使用します。「インターフェイス モードの設定」を参照してください。

ALPA キャッシュへのエントリの手動追加

手順の詳細

手動で ALPA キャッシュにエントリを挿入するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# tlport alpa-cache interface fc1/2 pwwn 22:00:00:20:37:46:09:bd alpa 0x02

ALPA キャッシュへのエントリの手動追加を設定します。

ステップ 3

switch(config)# tlport alpa-cache interface fc1/3 pwwn 22:00:00:20:37:46:09:bd

ALPA キャッシュからこのエントリを削除します。

ALPA キャッシュのクリア

clear tlport alpa-cache コマンドは、ALPA キャッシュの内容全体をクリアします。

ポート ガードの設定

手順の詳細

ポートのポート ガードをイネーブルまたはディセーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ポート インターフェイスを選択します。

ステップ 3

switch(config)# errdisable detect cause link-down

リンクが 1 回フラップした場合、ポートをダウン状態にします。

switch(config)# errdisable detect cause link-down [ num-times number duration seconds ]

インターフェイスのポート ガード設定をイネーブルにします。リンクが seconds に指定された時間内に number に指定された回数フラップした場合、ポートをダウン状態にします。

switch(config)# no errdisable detect cause link-down

インターフェイスのポート ガード設定を削除します(デフォルト)。リンクは、通常どおりにフラッピングとエラー レポートの送信を再開します。

ステップ 4

switch(config)# errdisable detect cause { trustsec-violation | bit-errors | credit-loss | link-reset | signal-loss | sync-loss }

指定されたエラーが 1 回でも発生すると、ポートをダウン状態にします。

switch(config)# errdisable detect cause { trustsec-violation | bit-errors | credit-loss | link-reset | signal-loss | sync-loss } [ num-times number duration seconds ]

指定されたエラーが seconds に指定された時間内に number に指定された回数発生した場合、ポートをダウン状態にします。

switch(config)# no errdisable detect cause { trustsec-violation | bit-errors | credit-loss | link-reset | signal-loss | sync-loss }

インターフェイスのポート ガード設定を削除します(デフォルト)。リンクは、通常どおりにフラッピングとエラー レポートの送信を再開します。

次に、リンクが複数の原因で 120 秒間に 5 回フラップした場合にポートをダウン状態にするようにポート ガードを設定する例を示します。

Switch# config t
Switch (config)# interface fc1/1
Switch (config-if)# errdisable detect cause link-down num-times 5 duration 120
Switch (config-if)# errdisable detect cause bit-errors num-times 5 duration 120
Switch (config-if)# errdisable detect cause credit-loss num-times 5 duration 120
 

上記の例では、状態を次のように移行します。

ポートでビット エラーによるリンク障害が 120 秒間に 5 回発生した場合、ポートはビット エラーによってエラーディセーブルになります。

ポートでクレジット損失によるリンク障害が 120 秒間に 5 回発生した場合、ポートはクレジット損失によってエラーディセーブルになります。

ポートで 120 秒間にビット エラーによるリンク障害が 2 回発生し、クレジット損失によるリンク障害が 3 回発生した場合、ポートはリンク ダウンによってエラーディセーブルになります。

次に、TrustSec 違反が原因でダウン状態にったポートに関する内部情報の例を示します。

Switch# show port internal info interface fc8/3
fc8/3 is down (Error disabled - port down due to trustsec violation)
Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
Port WWN is 21:c3:00:0d:ec:10:57:80
Admin port mode is E, trunk mode is on
snmp link state traps are enabled
Port vsan is 1
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
11274 frames input, 1050732 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
11242 frames output, 971900 bytes
0 discards, 0 errors
11 input OLS, 34 LRR, 10 NOS, 0 loop inits
72 output OLS, 37 LRR, 2 NOS, 0 loop inits
Interface last changed at Sun Nov 27 07:34:05 1988
 
admin port-down trustsec-violation(3) num_times 0, duration = 0
state reason (Error disabled - port down due to trustsec violation)
Port guard trustsec violation is Enabled
errdisabled on trustsec violation TRUE, oper cnt = 1
port guard first trustsec violation Sun Nov 27 07:34:05 1988
 

トラブルシューティングのヒント

リンク ダウンはその他すべての原因を含みます。他の原因の合計が許容されるリンクダウン障害の数と等しくなると、ポートはダウン状態になります。

リンク障害によるリンクのフラップが発生せず、ポート ガードがイネーブルでない場合であっても、無効な FLOGI 要求を同じホストから大量に受信する場合、ポートはダウン状態になります。リンクをアップ状態にするには、 shut コマンドと no shut コマンドを連続して使用します。

ポート モニタの設定

ここで説明する内容は、次のとおりです。

「ポート モニタのイネーブル化」

「ポート モニタ ポリシーの設定」

「ポート モニタ ポリシーのアクティブ化」

ポート モニタのイネーブル化

手順の詳細

ポート モニタをイネーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-monitor enable

ポート モニタリングをイネーブルにします(デフォルト)。

switch(config)# no port-monitor enable

ポート モニタリングをディセーブルにします。

ポート モニタ ポリシーの設定

手順の詳細

ポート モニタ ポリシーを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-monitor name policyname

ポリシーの名前を指定し、ポート モニタリング ポリシー コンフィギュレーション モードを開始します。

switch(config)# no port-monitor name policyname

ポリシーを削除します。

switch# config t

コンフィギュレーション モードに入ります。

ステップ 3

switch(config-port-monitor)# port-type access-port

アクセス ポートにポリシーを適用します。

switch(config-port-monitor)# port-type trunks

トランク ポートにポリシーを適用します。

switch(config-port-monitor)# port-type all

すべてのポートに適用します。

ステップ 4

switch(config-port-monitor)# counter credit-loss-reco poll-interval seconds percentage1 event event-id delta rising-threshold percentage1 event event-id

クレジット損失回復デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびイベントのイベント ID を指定します。

ステップ 5

switch(config-port-monitor)# monitor counter err-pkt-from-port5

 

switch(config-port-monitor)# counter err-pkt-from-port1 poll-interval seconds delta rising-threshold eventcount1 event event-id falling-threshold6 eventcount2 event event-id

err-pkt-from-port カウンタをアクティブ化します。

err-pkt-from-port カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびイベントのイベント ID を指定します。

ステップ 6

switch(config-port-monitor)# monitor counter err-pkt-from-xbar1

 

switch(config-port-monitor)# counter err-pkt-from-xbar1 poll-interval seconds delta rising-threshold eventcount1 event event-id

err-pkt-from-xbar カウンタをアクティブ化します。

err-pkt-from-xbar デルタ カウンタ、ポーリング間隔(秒)、しきい値(エラー フレーム イベント数)、およびイベントのイベント ID を指定します。

ステップ 7

switch(config-port-monitor)# monitor counter err-pkt-to-xbar1

 

switch(config-port-monitor)# counter err-pkt-to-xbar1 poll-interval seconds delta rising-threshold eventcount1 event event-id falling-threshold2 eventcount2 event event-id

err-pkt-to-xbar カウンタをアクティブ化します。

err-pkt-to-xbar デルタ カウンタ、ポーリング間隔(秒)、しきい値(エラー フレーム イベント数)、およびイベントのイベント ID を指定します。

ステップ 8

switch(config-port-monitor)# counter invalid-crc poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold2 percentage2 event event-id

無効 CRC デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 9

switch(config-port-monitor)# counter invalid-words poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

無効ワード デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 10

switch(config-port-monitor)# counter link-loss poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

リンク障害デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 11

switch(config-port-monitor)# counter protocol-error poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

プロトコル エラー デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 12

switch(config-port-monitor)# counter rx-performance poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

Rx デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)を指定します。

ステップ 13

switch(config-port-monitor)# counter signal-loss poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

信号損失デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 14

switch(config-port-monitor)# counter state-change poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

ステート変更デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 15

switch(config-port-monitor)# counter sync-loss poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

同期損失デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。

ステップ 16

switch(config-port-monitor)# counter tx-performance poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold 2 percentage2 event event-id

Tx デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)を指定します。

ステップ 17

switch(config-port-monitor)# no counter sync-loss

同期損失パフォーマンス カウンタ値をデフォルト ポリシーに戻します。

ステップ 18

switch(config-port-monitor)# no counter tx-performance

Tx パフォーマンス カウンタ値をデフォルト ポリシーに戻します。

ステップ 19

switch(config-port-monitor)# monitor counter rx-datarate

Rx パフォーマンス カウンタをオンにします。

switch(config-port-monitor)# monitor counter tx-datarate

Tx パフォーマンス カウンタをオンにします。

switch(config-port-monitor)# no monitor counter tx-datarate

Tx パフォーマンス カウンタをオフにします。

switch(config-port-monitor)# no monitor counter sync-loss

同期損失のモニタリングをオフにします。

switch(config-port-monitor)# no monitor counter state-change

ステート変更のモニタリングをオフにします。

nullnull

ポート モニタ ポリシーのアクティブ化

手順の詳細

ポート モニタ ポリシーをアクティブ化するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-monitor activate policyname

指定されたポート モニタ ポリシーをアクティブ化します。

switch(config)# port-monitor activate

デフォルトのポート モニタ ポリシーをアクティブ化します。

switch(config)# no port-monitor activate policyname

指定されたポート モニタリング ポリシーを非アクティブ化します。

ポート モニタ ポート ガードの設定

手順の詳細

ポート モニタ ポリシーを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-monitor name policyname

ポリシーの名前を指定し、ポート モニタリング ポリシー コンフィギュレーション モードを開始します。

switch(config)# no port-monitor name policyname

ポリシーを削除します。

ステップ 3

switch(config-port-monitor)# counter link-loss poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold percentage2 event event-id

portguard flap

リンク損失デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。イベント発生時にポートがフラップされる(アップまたはダウン状態になる)ことも指定します。

ステップ 4

switch(config-port-monitor)# counter link-loss poll-interval seconds delta rising-threshold percentage1 event event-id falling-threshold percentage2 event event-id

portguard errordisable

リンク損失デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)、およびトリガーするイベントのイベント ID を指定します。イベント発生時にインターフェイスがダウン状態になる(エラーディセーブルになる)ことも指定します。


) デフォルトでは、ポート モニタ ポート ガードはディセーブルです。この機能をイネーブルにするには、ステップ 3 またはステップ 4 を実行して、特定のカウンタのポート モニタ ポート ガード機能を明示的に設定する必要があります。


ポート グループ モニタのイネーブル化

手順の詳細

ポート グループ モニタをイネーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-group-monitor enable

ポート グループのモニタリングをイネーブルにします(デフォルト)。

switch(config)# no port-group-monitor enable

ポート グループのモニタリングをディセーブルにします。

ポート グループ モニタ ポリシーの設定

手順の詳細

ポート グループ モニタ ポリシーを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-group-monitor name policyname

ポリシーの名前を指定し、ポート グループ モニタリング ポリシー コンフィギュレーション モードを開始します。

switch(config)# no port-group-monitor name policyname

ポリシーを削除します。

ステップ 3

switch(config-port-group-monitor)# counter rx-performance poll-interval seconds delta rising-threshold percentage1 falling-threshold percentage2

Rx デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)を指定します。

switch(config-port-group-monitor)# counter tx-performance poll-interval seconds delta rising-threshold percentage1 falling-threshold percentage2

Tx デルタ カウンタ、ポーリング間隔(秒)、しきい値(パーセント)を指定します。

switch(config-port-group-monitor)# no counter tx-performance

78デフォルト ポリシーに戻します。

ステップ 4

switch(config-port-group-monitor)# monitor counter rx-performance

Rx パフォーマンス モニタリングをオンにします。

switch(config-port-group-monitor)# monitor counter tx-performance

Tx パフォーマンス モニタリングをオンにします。

switch(config-port-group-monitor)# no monitor counter tx-performance

9Tx パフォーマンス モニタリングをオフにします。

nullnullnull

特定のカウンタのデフォルト ポリシーの復元

no counter コマンドを config-port-group-monitor モードで使用すると、指定したポーリング カウンタ値は、次の例に示すようにデフォルト値に戻ります。

switch(config)# port-group-monitor name PGMON_policy
switch(config-port-group-monitor)# counter tx-performance poll-interval 100 delta rising-threshold 65 falling-threshold 25
switch(config)# show port-group-monitor PGMON_policy
 
Policy Name : PGMON_policy
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ---------------------
RX Performance Delta 60 80 10
TX Performance Delta 100 65 25
 
switch(config)# port-group-monitor name PGMON_policy
switch(config-port-group-monitor)# no counter tx-performance
switch(config)# show port-group-monitor PGMON_policy
 
 
Policy Name : PGMON_policy
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 60 80 10
TX Performance Delta 60 80 10
------------------------------------------------------------------------------------------

指定したカウンタのモニタリングのオフへの切り替え

no monitor counter コマンドを config-port-group-monitor モードで使用すると、次の例に示すように、特定のポリシーの指定したカウンタのモニタリングがオフになります。

switch(config)# show port-group-monitor PGMON_policy
 
Policy Name : PGMON_policy
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 26 450 250
TX Performance Delta 60 100 80
------------------------------------------------------------------------------------------
 
switch(config)# port-group-monitor name PGMON_policy
switch(config-port-group-monitor)# no monitor counter rx-performance
 
switch(config)# show port-group-monitor PGMON_policy
 
Policy Name : PGMON_policy
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 26 450 250
TX Performance Delta 60 100 80
------------------------------------------------------------------------------------------
 

ポート グループ モニタ ポリシーのアクティブ化

ポート グループ モニタ ポリシーをアクティブ化するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# port-group-monitor activate policyname

指定されたポート グループ モニタ ポリシーをアクティブ化します。

switch(config)# port-group-monitor activate

デフォルトのポート グループ モニタ ポリシーをアクティブ化します。

switch(config)# no port-group-monitor activate policyname

指定されたポート グループ モニタ ポリシーを非アクティブ化します。

管理インターフェイスの設定

手順の詳細

mgmt0 イーサネット インターフェイスを IPv4 上で接続するように設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface mgmt0

switch(config-if)#

スイッチの管理イーサネット インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# ip address 10.16.1.2 255.255.255.0

IPv4 アドレスおよび IPv4 サブネット マスクを設定します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# exit

switch(config)#

コンフィギュレーション モードに戻ります。

ステップ 6

switch(config)# ip default-gateway 1.1.1.4

デフォルト ゲートウェイの IPv4 アドレスを設定します。

ステップ 7

switch(config)# exit

switch#

EXEC モードに戻ります。

ステップ 8

switch# copy running-config startup-config

(任意)ファイル システムへの設定の変更を保存します。

(注) 設定を保存する場合は、このコマンドをいつでも入力できます。

mgmt0 イーサネット インターフェイスを IPv6 上で接続するように設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface mgmt0

switch(config-if)#

スイッチの管理イーサネット インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# ipv6 enable

IPv6 をイネーブルにし、インターフェイスにリンクローカル アドレスを割り当てます。

ステップ 4

switch(config-if)# ipv6 address ipv6 address 2001:0db8:800:200c::417a/64

インターフェイスの IPv6 ユニキャスト アドレスおよびプレフィックス長を指定します。

ステップ 5

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

switch(config-if)# end

switch#

EXEC モードに戻ります。

ステップ 7

switch# copy running-config startup-config

(任意)ファイル システムへの設定の変更を保存します。

(注) 設定を保存する場合は、このコマンドをいつでも入力できます。

VSAN インターフェイスの作成

手順の詳細

VSAN インターフェイスを作成するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface vsan 2

switch(config-if)#

ID 2 で VSAN を設定します。

ステップ 3

switch(config-if)# no shutdown

VSAN インターフェイスをイネーブルにします。

スタック フレーム タイムアウト値の設定

デフォルトのスタック フレーム タイムアウト値は 500 ミリ秒です。ISL ではデフォルト設定を維持し、ファブリック F ポートでは 500 ミリ秒を超えない値(100 ~ 200 ミリ秒)を設定することを推奨します。

スタック フレーム タイムアウト値を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# system timeout congestion-drop seconds mode E|F

スタック フレーム タイムアウト値(ミリ秒単位)とスイッチのポート モードを指定します。

switch(config)# system timeout congestion-drop default mode E|F

スイッチのデフォルトのスタック フレーム タイムアウト ポート モードを指定します。

No-Credit タイムアウト値の設定

ポートが設定された期間にわたりクレジットを保有しない場合、そのポートで No-Credit タイムアウトをイネーブルにできます。これにより、そのポートに着信するすべてのフレームが出力側でドロップされます。その結果、ISL リンクのバッファ領域が解放され、このポートのトラフィックが伝送されます。これによって、同じリンクを使用して他の関係のないフローにおいて、ファブリックの低速化と輻輳が軽減されます。

ドロップされるフレームは、スイッチに到着したばかりである場合もあれば、設定されたタイムアウト値の間スイッチに滞留していた場合もあります。これらは先取り的なドロップであり、スタック フレーム タイムアウト値とは異なり、輻輳を完全にクリアします。

No-Credit タイムアウト機能はデフォルトでディセーブルです。ISL ではデフォルト設定を維持し、ファブリック F ポートでは 500 ミリ秒を超えない値(200 ~ 300 ミリ秒)を設定することを推奨します。


) No-Credit タイムアウト値とスタック フレーム タイムアウト値は相互に関連します。No-Credit タイムアウト値は、常にスタック フレーム タイムアウト値より大きくなければなりません。


No-Credit タイムアウト値を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# system timeout no-credit-drop seconds mode E|F

スイッチの No-Credit タイムアウト値とポート モードを指定します。

switch(config)# system timeout no-credit-drop default mode E|F

スイッチのデフォルトの No-Credit タイムアウト値ポート モードを指定します。

クレジット損失回復のしきい値およびアクションの設定

ポートがクレジット損失状態を検出して回復したときには、ポートをエラーディセーブルにし、インターフェイスの詳細を含むトラップを送信し、インターフェイスの詳細を含む syslog を生成できます。設定されたしきい値を超えた場合、これらのアクションの 1 つまたは複数を組み合わせて実行できます。これらのアクションは、状況に応じてオンまたはオフにできます。ポート モニタ機能は、しきい値およびアクションを設定するためのコマンドライン インターフェイスを提供します。

しきい値では、クレジット損失の回復を 1 ~ 10、間隔を 1 秒~ 1 時間に設定できます。デフォルトは 10 分間に 3 回で、syslog が生成されます。

ポートは、クレジット損失状態を検出し、回復に失敗すると、フラップします。この機能は、すでにポート ガードの一部であり、ポート ガード機能を使用してサポートされるアクションを設定できます。

クレジット損失回復のしきい値およびアクションを設定する方法については、次の例を参照してください。次に、クレジット損失回復のしきい値およびアクションの設定例を示します。

switch# show port-monitor
Policy Name : Cisco
Admin status : Active
Oper status : Active
Port type : All Ports
------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event Portguard
------- --------- -------- ---------------- ----- ------------------ ----- --------- ---
Link Loss Delta 60 5 4 1 4 Not enabled
Sync Loss Delta 60 5 4 1 4 Not enabled
Protocol Error Delta 60 1 4 0 4 Not enabled
Signal Loss Delta 60 5 4 1 4 Not enabled
Invalid Words Delta 60 1 4 0 4 Not enabled
Invalid CRC's Delta 60 5 4 1 4 Not enabled
RX Performance Delta 60 2147483648 4 524288000 4 Not enabled
TX Performance Delta 60 2147483648 4 524288000 4 Not enabled
TX Discards Delta 60 200 4 10 4 Not enabled
LR RX Delta 60 5 4 1 4 Not enabled
LR TX Delta 60 5 4 1 4 Not enabled
Timeout Discards Delta 60 200 4 10 4 Not enabled
Credit Loss Reco Delta 60 1 4 0 4 Not enabled
TX Credit Not Available Delta 60 10 4 0 4 Not enabled
------------------------------------------------------------------------------------------
 

次のデフォルトのポート モニタ ポリシーは、スイッチが起動するとアクティブになります。

Policy Name : slowdrain
Admin status : Not Active
Oper status : Not Active
Port type : All Ports
----------------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event Portguard
------- --------- -------- ---------------- ----- ------------------ ----- --------- ------
Credit Loss Reco Delta 5 4 4 1 4 Not enabled
TX Credit Not Available Delta 1 20 4 10 4 Not enabled
------------------------------------------------------------------------------------------
 

平均クレジット使用不可時間のしきい値およびアクションの設定

平均クレジット使用不可時間が設定されたしきい値を超えたときには、ポートをエラーディセーブルにし、インターフェイスの詳細を含むトラップを送信し、インターフェイスの詳細を含む syslog を生成できます。これらのアクションの 1 つまたは複数を組み合わせて実行できます。これらのアクションは、状況に応じてオンまたはオフにできます。ポート モニタ機能は、しきい値およびアクションを設定するためのコマンドライン インターフェイスを提供します。しきい値は、ある間隔に対するクレジット使用不可時間のパーセンテージとして設定できます。

しきい値では、クレジット使用不可時間を 0 ~ 100%(10 の倍数)、間隔を 1 秒~ 1 時間に設定できます。デフォルトは 1 秒間に 10 % で、syslog が生成されます。

平均クレジット使用不可時間のしきい値とアクションを設定する方法については、「ポート モニタ」を参照してください。


) この機能は、1 RU ファブリック スイッチではサポートされません。


インターフェイス設定の確認

ここで説明する内容は、次のとおりです。

「インターフェイス情報の表示」

「TL ポート情報の表示」

「ALPA キャッシュの内容の表示」

「ポート モニタ ステータスおよびポリシーの表示」

「ポート グループ モニタのステータスおよびポリシーの表示」

「管理インターフェイスの設定の表示」

「VSAN インターフェイス情報の表示」

インターフェイス情報の表示

show interface コマンドは、EXEC モードから呼び出され、インターフェイスの設定を表示します。引数を入力せずにこのコマンドを実行すると、スイッチ内に設定されたすべてのインターフェイスの情報が表示されます。例 2-3 2-10 を参照してください。

例 2-3 すべてのインターフェイスの表示

switch# show interface
fc1/1 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0b:00:05:30:00:8d:de
Admin port mode is F
Port mode is F, FCID is 0x610000
Port vsan is 2
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
134 frames input, 8468 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
154 frames output, 46072 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 0 NOS, 0 loop inits
1 output OLS, 0 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
fc1/9 is trunking
Hardware is Fibre Channel, SFP is long wave laser cost reduced
Port WWN is 20:09:00:05:30:00:97:9e
Peer port WWN is 20:0b:00:0b:5f:a3:cc:00
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1,100,3000)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
5 minutes input rate 280 bits/sec, 35 bytes/sec, 0 frames/sec
5 minutes output rate 176 bits/sec, 22 bytes/sec, 0 frames/sec
4609939 frames input, 8149405708 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
4638491 frames output, 7264731728 bytes
0 discards, 0 errors
3 input OLS, 9 LRR, 1 NOS, 0 loop inits
9 output OLS, 7 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
fc1/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0d:00:05:30:00:97:9e
Admin port mode is auto, trunk mode is on
Port mode is F, FCID is 0x650100
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
8696 frames input, 3227212 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
16799 frames output, 6782444 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
sup-fc0 is up
Hardware is Fibre Channel
Speed is 1 Gbps
139597 packets input, 13852970 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
139516 packets output, 16759004 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

インターフェイス情報を表示するのに引数(インターフェイスの範囲、または複数の指定されたインターフェイス)を指定することもできます。次の形式でコマンドを発行して、インターフェイスの範囲を指定できます。

interface fc1/1 - 5 , fc2/5 - 7

) ダッシュ(-)とカンマ(,)の前後にはスペースが必要です。


例 2-4 複数の指定したインターフェイスの表示

switch# show interface fc3/13 , fc3/16
fc3/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:8d:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7b0300
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
1856 frames input, 116632 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
1886 frames output, 887712 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 1 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
 
fc3/16 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:90:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7d0100
Port vsan is 3000
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 504 bits/sec, 63 bytes/sec, 0 frames/sec
5 minutes output rate 520 bits/sec, 65 bytes/sec, 0 frames/sec
47050 frames input, 10311824 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
62659 frames output, 10676988 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.

例 2-5 特定のインターフェイスの表示

switch# show interface fc2/2
fc2/2 is trunking
Port description is Trunk to Core-4
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:42:00:05:30:00:97:9e
Peer port WWN is 20:cc:00:05:30:00:50:9e
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Belongs to port-channel 2
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1)
Trunk vsans (isolated) (100,3000)
Trunk vsans (initializing) ()
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
2214834 frames input, 98673588 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
2262415 frames output, 343158368 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 0 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.

例 2-6 ポートの説明の表示

switch# show interface description
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
fc3/1 test intest
fc3/2 --
fc3/3 --
fc3/4 TE port
fc3/5 --
fc3/6 --
fc3/10 Next hop switch 5
fc3/11 --
fc3/12 --
fc3/16 --
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
port-channel 1 --
port-channel 5 --
port-channel 6 --

例 2-7 要約形式でのインターフェイス情報の表示

switch# show interface brief
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc1/1 1 E on trunking swl TE 2 1
fc1/2 1 E on trunking swl TE 2 1
fc1/3 1 auto on SFPAbsent -- -- --
fc1/4 1 auto on SFPAbsent -- -- --
fc1/5 3000 auto on up swl F 2 --
...
fc2/2 1 E on trunking swl TE 2 2
fc2/3 1 auto on down c1610 -- --
fc2/4 1 auto on down c1590 -- --
fc2/5 3000 auto on notConnected lwcr -- --
fc2/6 1 auto on SFPAbsent -- -- --
...
fc3/16 3000 FX -- up swl F 2 --
fc3/17 1 FX -- SFPAbsent -- -- --
...
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
GigabitEthernet4/1 SFPAbsent -- auto 1500
...
GigabitEthernet4/6 down 10.1.1.2/8 auto 3000
GigabitEthernet4/7 down 10.1.1.27/24 auto 1500
GigabitEthernet4/8 down -- auto 1500
 
-------------------------------------------------------------------------------
Interface Status Oper Mode Oper Speed
(Gbps)
-------------------------------------------------------------------------------
iscsi4/1 down --
...
-------------------------------------------------------------------------------
Interface Status Speed
(Gbps)
-------------------------------------------------------------------------------
sup-fc0 up 1
 
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
mgmt0 up 172.19.48.96/25 100 Mbps 1500
 
-------------------------------------------------------------------------------
Interface Vsan Admin Status Oper Oper
Trunk Mode Speed
Mode (Gbps)
-------------------------------------------------------------------------------
port-channel 1 1 on trunking TE 4
port-channel 2 1 on trunking TE 4
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status Oper Profile Port-channel
Mode Trunk Mode
Mode
-------------------------------------------------------------------------------
fcip10 1 auto on notConnected -- 10 --

例 2-8 インターフェイス カウンタの表示

switch# show interface counters
fc3/1
5 minutes input rate 24 bits/sec, 3 bytes/sec, 0 frames/sec
5 minutes output rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
3502 frames input, 268400 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
3505 frames output, 198888 bytes
0 discards
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 1 NOS, 0 loop inits
1 link failures, 1 sync losses, 1 signal losses
.
.
.
fc9/8
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
sup-fc0
114000 packets input, 11585632 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
113997 packets output, 10969672 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 
mgmt0
31557 packets input, 2230860 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
26618 packets output, 16824342 bytes, 0 underruns
0 output errors, 0 collisions, 7 fifo
0 carrier errors
 
vsan1
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped
.
.
.
port-channel 1
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
 

) インターフェイス 9/8 および 9/9 は、トランキング ポートではなく、クラス 2、3、および F 情報を表示します。


例 2-9 要約形式でのインターフェイス カウンタの表示

switch# show interface counters brief
 
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
fc3/1 0 3871 0 3874
fc3/2 0 3902 0 4232
fc3/3 0 3901 0 4138
fc3/4 0 3895 0 3894
fc3/5 0 3890 0 3897
fc9/8 0 0 0 0
fc9/9 0 5 0 4
fc9/10 0 4186 0 4182
fc9/11 0 4331 0 4315
 
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
port-channel 1 0 0 0 0
port-channel 2 0 3946 0 3946
 

show interface transceiver コマンドは、Cisco MDS 9100 シリーズのスイッチで、SFP が存在する場合のみ実行できます(例 2-10 を参照)。


例 2-10 トランシーバ情報の表示

switch# show interface transceiver
fc1/1 SFP is present
name is CISCO-AGILENT
part number is QFBR-5796L
revision is
serial number is A00162193
fc-transmitter type is short wave laser
cisco extended id is unknown (0x0)
...
fc1/9 SFP is present
name is FINISAR CORP.
part number is FTRJ-1319-7D-CSC
revision is
serial number is H11A6ER
fc-transmitter type is long wave laser cost reduced
cisco extended id is unknown (0x0)
...
 

例 2-11 では、すべてのインターフェイスの情報を含む実行コンフィギュレーション全体を表示しています。スイッチがリロードしたとき、インターフェイス コンフィギュレーション コマンドが正しい順序で実行するように、インターフェイスはコンフィギュレーション ファイルに複数のエントリを持っています。

例 2-11 すべてのインターフェイスの実行コンフィギュレーションの表示

switch# show running-config
...
interface fc9/1
switchport speed 2000
...
interface fc9/1
switchport mode E
...
interface fc9/1
channel-group 11 force
no shutdown
 

例 2-12 では、指定したインターフェイスの実行コンフィギュレーション情報を表示しています。インターフェイス コンフィギュレーション コマンドがグループ化されます。

例 2-12 指定したインターフェイスの実行コンフィギュレーションの表示

switch# show running-config interface fc1/1
interface fc9/1
switchport speed 2000
switchport mode E
channel-group 11 force
no shutdown
 

例 2-13 では、 system default switchport mode F コマンドを実行した後の実行コンフィギュレーションを表示しています。

例 2-13 system default switchport mode F コマンド実行後の実行コンフィギュレーションの表示

switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
interface fc4/2
interface fc4/3
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/10
 

例 2-14 では、2 つのインターフェイスを個別にモード FL に設定した後の実行コンフィギュレーションを表示しています。

例 2-14 2 つのインターフェイスを個別にモード FL に設定した後の実行コンフィギュレーションの表示

switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
switchport mode FL
interface fc4/2
interface fc4/3
switchport mode FL
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/1
 

例 2-15 では、 system default switchport mode F コマンドを実行した後のインターフェイス情報を要約形式で表示しています。例 2-16 では、2 つのインターフェイスを個別にモード FL に設定した後のインターフェイス情報を要約形式で表示しています。

例 2-15 system default switchport mode F コマンド実行後のインターフェイス情報の要約形式での表示

switch# show interface brief
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 F -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 F -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --

例 2-16 2 つのインターフェイスを個別にモード FL に設定した後のインターフェイス情報の要約形式での表示

switch# show interface brief
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 FL -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 FL -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --
fc4/10 1 F -- sfpAbsent -- -- --

TL ポート情報の表示

show tlport コマンドは、TL ポート インターフェイスの設定を表示します。このコマンドは、スイッチに設定されているすべての TL ポートのリストを出力し、関連付けられている VSAN、ポートの FC ID(ドメインおよびエリアのみ有効)、および TL ポートの現在の動作ステート(アップ状態か初期化中か)を表示します。例 2-17例 2-20 を参照してください。

例 2-17 すべての VSAN の TL ポートの表示

switch# show tlport list
-------------------------------
Interface Vsan FC-ID State
------------------------- ------
fc1/16 1 0x420000 Init
fc2/26 1 0x150000 Up
 

TL ポートにより、ファブリック デバイスをループにプロキシすることで、プライベート デバイス(ループ上に物理的に存在するデバイス)とファブリック デバイスが互いを認識できるようになります。ファブリック デバイスをプロキシするには、各ファブリック デバイスにループの ALPA を割り当てます。

これらのプロキシされたデバイスに加え、他の仮想デバイス(ローカルまたはリモート ドメイン コントローラ アドレス)にもループの ALPA を割り当てます。スイッチはプライベート デバイスとの通信用に ALPA を予約しており、SCSI イニシエータとして機能します。

show tlport interface コマンド出力の最初のカラムは、ループ上のデバイスの ALPA ID です。後続のカラムには、ポート WWN、各デバイスのノード WWN、SCSI イニシエータまたはターゲットとしてのデバイス、およびデバイスの実 FC ID が含まれます。

例 2-18 特定の TL ポートに関する詳細情報の表示

switch# show tlport interface fc1/16 all
fc1/16 is up, vsan 1, FCID 0x420000
--------------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type Device FC-ID
--------------------------------------------------------------------------------
0x01 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator Proxied 0xfffc42
0x73 22:00:00:20:37:39:ae:54 20:00:00:20:37:39:ae:54 Target Private 0x420073
0xef 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator Switch 0x0000ef

例 2-19 プライベート デバイスの TL ポート情報の表示

switch# show tlport interface fc 1/16 private
fc1/16 is up, vsan 1, FCID 0x420000
------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type FC-ID ------------------------------------------------------------------------
0x73 22:00:00:20:37:39:ae:54 20:00:00:20:37:39:ae:54 Target 0x420073
0x74 22:00:00:20:37:38:d3:de 20:00:00:20:37:38:d3:de Target 0x420074

例 2-20 プロキシされたデバイスの TL ポート情報の表示

switch# show tlport interface fc 1/16 proxied
fc1/16 is up, vsan 1, FCID 0x420000
------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type FC-ID ------------------------------------------------------------------------
0x01 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator 0xfffc42
0x02 21:00:00:e0:8b:01:95:e7 20:00:00:e0:8b:01:95:e7 Initiator 0x420100
 

ALPA キャッシュの内容の表示

show tlport alpa-cache コマンドは、ALPA キャッシュの内容を表示します。

switch# show tlport alpa-cache
---------------------------------------------------------
alpa pWWN Interface
---------------------------------------------------------
0x02 22:00:00:20:37:46:09:bd fc1/2
0x04 23:00:00:20:37:46:09:bd fc1/2
 

最初のエントリは、pWWN が 22:00:00:20:37:46:09:bd であるデバイスが TL ポート fc1/2 にエクスポートされ、その後 pWWN に ALPA 0x02(使用可能な場合)が割り当てられることを示しています。

ポート モニタ ステータスおよびポリシーの表示

次のコマンドは、ポート モニタに関する情報を表示します。

switch# show port-monitor status
Port Monitor : Enabled
Active Policies : sample
Last 10 logs :
 
switch# show port-monitor
------------------------------------------------------------------------------------------
Port Monitor : enabled
------------------------------------------------------------------------------------------
Policy Name : sample
Admin status : Not Active
Oper status : Not Active
Port type : All Ports
------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event portguard
------- --------- -------- ---------------- ----- ------------------ ----- -----
Link Loss Delta 60 5 4 1 4
Not enabled
Sync Loss Delta 60 5 4 1 4
Not enabled
Protocol Error Delta 60 1 4 0 4
Not enabled
Signal Loss Delta 60 5 4 1 4
Not enabled
Invalid Words Delta 60 1 4 0 4
Not enabled
Invalid CRC's Delta 60 5 4 1 4
Not enabled
RX Performance Delta 60 2147483648 4 524288000 4
Not enabled
TX Performance Delta 60 2147483648 4 524288000 4
Not enabled
------------------------------------------------------------------------------------------
 
Policy Name : default
Admin status : Not Active
Oper status : Not Active
Port type : All Ports
------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event portguard
------- --------- -------- ---------------- ----- ------------------ ----- -----
Link Loss Delta 60 5 4 1 4
Not enabled
Sync Loss Delta 60 5 4 1 4
Not enabled
Protocol Error Delta 60 1 4 0 4
Not enabled
Signal Loss Delta 60 5 4 1 4
Not enabled
Invalid Words Delta 60 1 4 0 4
Not enabled
Invalid CRC's Delta 60 5 4 1 4
Not enabled
RX Performance Delta 60 2147483648 4 524288000 4
Not enabled
TX Performance Delta 60 2147483648 4 524288000 4
Not enabled
------------------------------------------------------------------------------------------
 
switch# show port-monitor active
Policy Name : sample
Admin status : Active
Oper status : Active
Port type : All Access Ports
------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event portguard
------- --------- -------- ---------------- ----- ------------------ ----- -----
Link Loss Delta 60 5 4 1 4
enabled
Sync Loss Delta 60 5 4 1 4
enabled
Protocol Error Delta 60 1 4 0 4
enabled
Signal Loss Delta 60 5 4 1 4
enabled
Invalid Words Delta 60 1 4 0 4
enabled
Invalid CRC's Delta 60 5 4 1 4
enabled
RX Performance Delta 60 2147483648 4 524288000 4
enabled
TX Performance Delta 60 2147483648 4 524288000 4
enabled
------------------------------------------------------------------------------------------
 
switch# show port-monitor sample
Policy Name : sample
Admin status : Active
Oper status : Active
Port type : All Access Ports
------------------------------------------------------------------------------------------
Counter Threshold Interval Rising Threshold event Falling Threshold event portgurard
------- --------- -------- ---------------- ----- ------------------ ----- -----
Link Loss Delta 60 5 4 1 4
enabled
Sync Loss Delta 60 5 4 1 4
enabled
Protocol Error Delta 60 1 4 0 4
enabled
Signal Loss Delta 60 5 4 1 4
enabled
Invalid Words Delta 60 1 4 0 4
enabled
Invalid CRC's Delta 60 5 4 1 4
enabled
RX Performance Delta 60 2147483648 4 524288000 4
enabled
TX Performance Delta 60 2147483648 4 524288000 4
enabled
------------------------------------------------------------------------------------------
 

ポート グループ モニタのステータスおよびポリシーの表示

次のコマンドは、ポート グループ モニタに関する情報を表示します。

switch# show port-group-monitor status
Port Group Monitor : Enabled
Active Policies : pgm2
Last 10 logs :
switch#
 
 
switch# show port-group-monitor
------------------------------------------------------------------------------------------
Port Group Monitor : enabled
------------------------------------------------------------------------------------------
Policy Name : pgm1
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 60 50 10
TX Performance Delta 60 50 10
------------------------------------------------------------------------------------------
Policy Name : pgm2
Admin status : Active
Oper status : Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 60 80 10
TX Performance Delta 60 80 10
------------------------------------------------------------------------------------------
Policy Name : default
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 60 80 20
TX Performance Delta 60 80 20
------------------------------------------------------------------------------------------
 
switch# show port-group-monitor active
Policy Name : pgm2
Admin status : Active
Oper status : Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 60 80 10
TX Performance Delta 60 80 10
------------------------------------------------------------------------------------------
 
switch# show port-group-monitor PGMON_policy
PPolicy Name : PGMON_policy
Admin status : Not Active
Oper status : Not Active
Port type : All Port Groups
------------------------------------------------------------------------------------------
Counter Threshold Interval %ge Rising Threshold %ge Falling Threshold
------- --------- -------- -------------------- ----------------------
RX Performance Delta 26 450 250
TX Performance Delta 60 100 80
------------------------------------------------------------------------------------------

管理インターフェイスの設定の表示

管理インターフェイスの設定を表示するには、 show interface mgmt 0 コマンドを使用します。

switch# show interface mgmt 0
mgmt0 is up
Hardware is FastEthernet
Address is 000c.30d9.fdbc
Internet address is 10.16.1.2/24
MTU 1500 bytes, BW 100 Mbps full Duplex
26388 packets input, 6101647 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
10247 packets output, 2389196 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

VSAN インターフェイス情報の表示

VSAN インターフェイス情報を表示するには、 show interface vsan コマンドを使用します。

switch# show interface vsan 2
vsan2 is up, line protocol is up
WWPN is 10:00:00:05:30:00:59:1f, FCID is 0xb90100
Internet address is 10.1.1.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped
 

 


1.

 
Cisco MDS 9000 Family NX-OS Fundamentals Configuration Guide 』を参照してください。

2.

 
「速度 LED」 を参照してください。

4.

 
プラットフォームの Cisco MDS 9000 ファミリ ハードウェア インストール ガイドを参照してください

5.

 
error-pkt-port カウンタ、err-pkt-from xbar カウンタ、および err-pkt-to-xbar カウンタは、すべて ASIC カウンタです。すべての ASIC カウンタはデフォルトでオフです。ASIC カウンタは 10 秒ごとに照会されます。特定の ASIC カウンタに対応する ASIC が 10 秒の間隔中にエラー パケットを送信または受信すると、そのカウンタの間隔中にエラー フレーム イベントが発生します。

6.

 
下限しきい値は、上昇しきい値よりも小さい必要があります。

8.

 
「ポート グループ モニタ」を参照してください。