Cisco インターフェイスとモジュール : Cisco Integrated Services Router (ISR) Modules

Cisco 4000 シリーズ ISR 用 Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール設定ガイド

Cisco 4000 シリーズ ISR 用 Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール設定ガイド
発行日;2016/05/24 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco 4000 シリーズ ISR 用 Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール設定ガイド

目次

の前提条件

に関する情報

ハードウェアの概要

ソフトウェア機能

スイッチ仮想インターフェイスへの IP アドレスの割り当て

IEEE 802.1x プロトコル

IPv4 用 IGMP スヌーピング

Power over Ethernet(Plus)

Cisco インテリジェント電源管理

電源ポリシング(検知)

MAC テーブル操作

MAC アドレス テーブルでのスタティック エントリの作成

MAC アドレスベースのトラフィック ブロッキング

エージング タイマーの設定と確認

STP

スイッチド ポート アナライザ(SPAN)の設定

SPAN 送信元の設定

SPAN 宛先の設定

SPAN セッションの確認

SPAN セッションからの送信元または宛先の削除

レイヤ 2 QoS の設定

802.1p CoS ベース キュー マッピングの設定

SDWRR プライオリティの設定

インターフェイスの CoS 値の設定

VLAN

レイヤ 2 スイッチング用 LAN ポートの設定

レイヤ 2 LAN ポート モード

レイヤ 2 LAN インターフェイスのデフォルト設定

レイヤ 2 スイッチング用の LAN インターフェイスの設定

レイヤ 2 スイッチング用の LAN ポートの設定

トランクとしてのレイヤ 2 スイッチング ポートの設定

STP の概要

Multiple Spanning Tree protocol

Per-VLAN Spanning Tree+

Rapid Per-VLAN Spanning Tree+

STP のデフォルト設定

STP のイネーブル化

オプションの STP 機能の設定

PortFast のイネーブル化

PortFast BPDU フィルタリングのイネーブル化

BPDU ガードのイネーブル化

UplinkFast のイネーブル化

BackboneFast のイネーブル化

OIR を用いた Cisco NIM ES2-4 および Cisco NIM ES2-8 の管理

Cisco 4000 シリーズ ISR 用 Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール設定ガイド

初版発行日:2015年5月6日

 

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール(NIM)は、レイヤ 2 機能を統合し、モジュール間通信用にマルチギガビット ファブリック(MGF)への 1 Gbps の接続を提供します。

Cisco NIM-ES2-4 および Cisco NIM-ES2-8 は、Cisco 4000 シリーズ ISR ファミリで動く堅牢な Power over Ethernet(POE)、Power over Ethernet Plus(PoE+)、Enhanced Power over Ethernet(ePoE)の機能によりポートあたり最大 30 ワットの電力を提供可能です。

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール の機能履歴は次の通りです。

 

表 1 Cisco レイヤ 2/3 NIM の機能履歴

リリース
変更内容

Cisco IOS XE リリース 3.15S (ルータ ソフトウェア)

この機能が導入されました

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール の前提条件

Cisco IOS XE リリース 3.15S は Cisco NIM-ES2-4 または Cisco NIM-ES2-8 をインストールする必要があります。

ルータで実行されている Cisco IOS ソフトウェアのバージョンを判断するには、ルータにログインし、 show version コマンドを入力します。

Router> show version

Cisco IOS XE Software, Version 03.15.00.S - Standard Support Release

Cisco IOS Software, ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(2)S, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2015 by Cisco Systems, Inc.

Compiled Sun 22-Mar-15 02:32 by mcpre

 

ルータ(Cisco 4000 シリーズ ISR)、Cisco IOS ソフトウェア リリースおよび機能セットを表示するには、特権 EXEC モードで show version コマンドを入力します。

Cisco IOS リリース番号マッピングを表示するには、「 Release Notes for the Cisco ISR 4400 Series 」を参照してください。

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール に関する情報

ここでは、Cisco NIM-ES2-4 および Cisco NIM-ES2-8 の機能と一部の重要な概念を説明します。

「ハードウェアの概要」

「ソフトウェア機能」


) お使いの Cisco NIM-ES2-4 および Cisco NIM-ES2-8 でサポートされる各種機能についての情報や Cisco IOS スイッチ機能に関するドキュメントのリストについては、「関連資料」 を参照してください。


ハードウェアの概要

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール (Cisco NIM-ES2-4 および Cisco NIM-ES2-8)は、Cisco IP Phone、Cisco ワイヤレス アクセスポイント ワークステーション、その他のネットワーク デバイス(ビデオ デバイス、ルータ、スイッチ、その他のネットワーク スイッチ モジュールなど)を接続できるスイッチ モジュールです。

Cisco 4000 シリーズ ISR では次の Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール がサポートされます。

4 ポート非 POE レイヤ 2 ギガビット イーサネット スイッチ ネットワーク インターフェイス モジュール(NIM-ES2-4)

8 ポート非 POE レイヤ 2 ギガビット イーサネット スイッチ ネットワーク インターフェイス モジュール(NIM-ES2-8)

8 ポート POE レイヤ 2 ギガビット イーサネット スイッチ ネットワーク インターフェイス モジュール(NIM-ES2-8-P)

Cisco NIM-ES2-4 および Cisco NIM-ES2-8 ハードウェアの詳細については、「 Installing the Cisco 4-Port and 8-Port Layer 2 Gigabit EtherSwitch Network Interface Module 」ガイド を参照してください。

ソフトウェア機能

Cisco NIM-ES2-4 および Cisco NIM-ES2-8では、次のスイッチング ソフトウェア機能がサポートされます。

「スイッチ仮想インターフェイスへの IP アドレスの割り当て」

「IEEE 802.1x プロトコル」

「IPv4 用 IGMP スヌーピング」

「Power over Ethernet(Plus)」

「MAC テーブル操作」

「STP」

「スイッチド ポート アナライザ(SPAN)の設定」

「レイヤ 2 QoS の設定」

「VLAN」

「レイヤ 2 スイッチング用 LAN ポートの設定」

スイッチ仮想インターフェイスへの IP アドレスの割り当て

IP ルーティングを設定するには、IP アドレスをレイヤ 3 ネットワーク インターフェイスに割り当てる必要があります。これにより、IP を使用するインターフェイスでホストとの通信が可能になります。IP ルーティングはデフォルトでディセーブルであり、IP アドレスはスイッチ仮想インターフェイス(SVI)に割り当てられていません。

IP アドレスは、IP パケットの宛先を特定します。一部の IP アドレスは特殊な目的のために予約されていて、ホスト、サブネット、またはネットワーク アドレスには使用できません。RFC 1166 『Internet Numbers』には、これらの IP アドレスに関する公式の説明が記載されています。

インターフェイスには、1 つのプライマリ IP アドレスを設定できます。サブネット マスクは、IP アドレスのネットワーク番号を表すビットを特定します。

IP アドレスおよびネットワーク マスクを SVI に割り当てるには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan_id

インターフェイス コンフィギュレーション モードを開始し、設定するレイヤ 3 VLAN を指定します。

ステップ 3

ip address ip-address subnet-mask

IP アドレスおよび IP サブネット マスクを設定します。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interfaces [ interface-id ]
show ip interface [ interface-id ]
show running-config interface [ interface-id ]

入力内容を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

IEEE 802.1x プロトコル

IEEE 802.1x 規格では、一般の人がアクセス可能なポートからクライアントが LAN に接続しないように規制する(認証されている場合を除く)、クライアント/サーバ型のアクセス コントロールおよび認証プロトコルを定めています。認証サーバがポートに接続する各クライアントを認証したうえで、ルータまたは LAN が提供するサービスを利用できるようにします。

クライアントが認証されるまで、IEEE 802.1x アクセス コントロールでは、クライアントの接続先であるポートを介して、Extensible Authentication Protocol over LAN(EAPOL)、Cisco Discovery Protocol(CDP)、およびスパニングツリー プロトコル(STP)トラフィックだけが許可されます。認証後、通常のトラフィックをポート経由で送受信できます。「 Cisco 7600 Series Router Software Configuration Guide, Cisco IOS Release 15S 」の「 Configuring IEEE 802.1X Port-Based Authentication 」の章を参照してください。

IPv4 用 IGMP スヌーピング

IGMP スヌーピングにより、スイッチで IGMP パケットを調べたり、パケットの内容に基づいて転送先を決定したりできます。IGMP または IGMP スヌーピング クエリアからの IGMP クエリーを受信するサブネットで、IGMP スヌーピングを使用するように、スイッチを設定できます。IGMP スヌーピングは、IPv4 マルチキャスト トラフィックを受信するポートだけにそのトラフィックをダイナミックに転送するように、レイヤ 2 LAN ポートを設定することにより、レイヤ 2 で IPv4 マルチキャスト トラフィックを抑制します。

レイヤ 2 スイッチは IGMP スヌーピングを使用して、レイヤ 2 インターフェイスを動的に設定し、マルチキャスト トラフィックが IP マルチキャスト デバイスと対応付けられたインターフェイスにのみ転送されるようにすることによって、マルチキャスト トラフィックのフラッディングを制限できます。名称が示すとおり、IGMP スヌーピングの場合は、LAN スイッチでホストとルータ間の IGMP 伝送をスヌーピングし、マルチキャスト グループとメンバ ポートを追跡する必要があります。特定のマルチキャスト グループについて、ホストから IGMP レポートを受信したスイッチは、ホストのポート番号を転送テーブル エントリに追加します。ホストから IGMP Leave Group メッセージを受信した場合は、テーブル エントリからホスト ポートを削除します。マルチキャスト クライアントから IGMP メンバーシップ レポートを受信しなかった場合にも、スイッチはエントリを定期的に削除します。この機能の詳細については、 http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/15-2_1_e/configuration/guide/scg3750x/swigmp.html を参照してください。

Power over Ethernet(Plus)

Cisco NIM-ES2-8-P は 8 ポートすべてで POE(802.3af)および POE+(802.3at)をサポートします。PoE の最大供給電力は 15.4 ワット、PoE+ の最大供給電力は 30 ワットです。PoE を使用すると、接続先の PoE 対応装置に壁面コンセントから電力を供給する必要がなくなります。これにより、接続先の装置に必要であった追加の電気配線にかかる費用が削減されます。


) PoE 機能が動作することを確認するには show platform コマンドおよび show power コマンドを使用して、ルータの PoE 電力の可用性を検証します。


NIM-ES2-8-P PoE の設定は ISR 4400 ルータの FPGE ポートと同じです。NIM-ES2-8-P ポートに PoE を設定する方法については、「 Configuring PoE for FPGE 」を参照してください。

この例では、電力は IP Phone NIM-ES2-8-P Gi0/1/1 ポートに供給されます。

Router# show power inline

RAvailable:500.0(w) Used:10.3(w) Remaining:489.8(w)
 
Interface Admin Oper Power Device Class Max
(Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Gi0/1/1 auto on 10.3 IP Phone 7970 3 30.0
Gi0/1/2 off off 0.0 n/a n/a 30.0
Gi0/1/3 auto off 0.0 n/a n/a 30.0
Gi0/1/4 auto off 0.0 n/a n/a 30.0
Gi0/1/5 auto off 0.0 n/a n/a 30.0
Gi0/1/6 auto off 0.0 n/a n/a 30.0
Gi0/1/7 auto off 0.0 n/a n/a 30.0
Gi0/1/8 auto off 0.0 n/a n/a 30.0.

Cisco インテリジェント電源管理

PD とスイッチは、電力消費レベルの合意に向け、CDP メッセージを通じて電力をネゴシエーションします。このネゴシエーションにより、高性能の Cisco PD が最高の電力モードで動作できるようになります。

PoE plus 機能により自動検出および電力バジェットが可能になります。スイッチは、電力バジェットの維持、電力要求のモニタおよび追跡を行いながら、電力が使用可能である場合だけ電力を許可します。「 Catalyst 3560 Switch Software Configuration Guide, Cisco IOS Release 15.0(2)SE and Later 」の「 Configuring the External PoE Service Module Power Supply Mode 」の項を参照してください。

電源ポリシング(検知)

電源ポリシングにより、リアルタイムの電力消費を監視できます。スイッチは、PoE ポート単位で、総消費電力を検知し、消費電力をポリシングして、電力消費量をレポートします。この機能の詳細については、「関連資料」を参照してください。

MAC アドレス テーブルでのスタティック エントリの作成

MAC アドレス テーブルにスタティック エントリを作成するには、次の作業を行います。

コマンド
目的

ステップ 1

enable

 

Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

  1. グローバル コンフィギュレーション モードを開始します。

ステップ 3

mac address-table static mac-address vlan vlan-id interface interface-id

 

Router# mac address-table static 00ff.ff0d.2dc0 vlan 1 interface gigabitethernet 0/1/0

MAC アドレス テーブルでスタティック エントリを作成します。

ステップ 4

end

 

Router# end

特権 EXEC モードに戻ります。

ステップ 5

show mac address-table

 

Router# show mac address-table

MAC アドレス テーブルを確認します。

MAC アドレスベースのトラフィック ブロッキング

特定の VLAN 内の MAC アドレスを経由するすべてのトラフィックをブロックするには、次の作業を行います。

コマンド
目的

ステップ 1

enable

 

Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router#configure terminal

  1. グローバル コンフィギュレーション モードを開始します。

ステップ 3

mac address-table static mac-address vlan vlan-id drop

 

Router# mac address-table static mac-address vlan vlan-id drop

MAC アドレス テーブルでスタティック エントリを作成します。

ステップ 4

end

 

Router# end

特権 EXEC モードに戻ります。

ステップ 5

show mac address-table

 

Router# show mac address-table

MAC アドレス テーブルを確認します。

エージング タイマーの設定と確認

エージング タイマーを設定するには、次の作業を行います。

コマンド
目的

ステップ 1

enable

 

Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

  1. グローバル コンフィギュレーション モードを開始します。

ステップ 3

mac address-table aging-time time

 

Router(config)# mac address-table aging-time 600

または

Router(config)# mac address-table aging-time 0

MAC アドレスのエージング タイマーを秒単位で設定します。

許容値は 0 または 10 ~ 1000000 秒です。デフォルト値は 300 秒です。

スイッチ チップセットがサポートする最大エージング タイマーは 634 秒です。634 秒以上を設定すると、MAC アドレスは 634 秒後にエージ アウトします。

値 0 にすると、ダイナミック MAC エントリはエージ アウトしません。

ステップ 4

end

 

Router# end

特権 EXEC モードに戻ります。

ステップ 5

show mac address-table aging-time

 

Router# show mac address-table aging-time

MAC アドレス テーブルを確認します。

STP

スパニング ツリー プロトコル(STP)は、ネットワーク内の有害なループを防止しながら、パスの冗長性を実現するレイヤ 2 リンク管理プロトコルです。レイヤ 2 イーサネット ネットワークの正常な動作を実現するには、どの 2 つのステーション間でもアクティブ パスを 1 つにする必要があります。スパニング ツリーの動作は透過的であり、エンド ステーション側で、単一 LAN セグメントに接続されているのか、複数セグメントからなるスイッチド LAN に接続されているのかを検出することはできません。この機能の詳細については、 http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/software/feature/guide/geshwic_cfg.html を参照してください。

スイッチド ポート アナライザ(SPAN)の設定

ここでは、Cisco NIM-ES2-4 および Cisco NIM-ES2-8 でスイッチド ポート アナライザ(SPAN)セッションを設定する方法について説明します。Cisco NIM-ES2-4 および Cisco NIM-ES2-8 には、次のような制約事項が適用されます。

モジュール内のローカル SPAN のみサポートされます。モジュール間の SPAN はサポートされません。

各 NIM-ES2-4/8 は 1 つのローカル SPAN セッションのみをサポートします。

各 SPAN セッションは 1 つの送信元ポートと 1 つの宛先ポートのみをサポートします。


) 送信、受信、または送受信の監視がサポートされています。


「SPAN 送信元の設定」

「SPAN 宛先の設定」

「SPAN セッションの確認」

「SPAN セッションからの送信元または宛先の削除」

SPAN 送信元の設定

SPAN セッションの送信元を設定するには、グローバル コンフィギュレーション モードで monitor session session source { interface type 0/slot/port | vlan vlan_ID [ , | - | rx | tx | both ]} コマンドを使用します。このコマンドは、SPAN セッション、送信元インターフェイスまたは VLAN、監視対象のトラフィックの方向を指定します。

Router(config)# monitor session 1 source interface gigabitethernet 0/1/1

SPAN 宛先の設定

SPAN セッションの宛先を設定するには、グローバル コンフィギュレーション モードで monitor session session destination { interface type slot/subslot/port | - | rx | tx | both ]} コマンドを使用します。

Router(config)# monitor session 1 destination interface gigabitethernet 0/1/1

SPAN セッションの確認

SPAN セッションで設定された送信元と宛先を確認するには、 show monitor session コマンドを使用します。

Router#show monitor session 1
Session 1
---------
Session 1
---------
Type : Local Session
Source Ports :
Both : Gi0/1/0
Destination Ports : Gi0/1/1

SPAN セッションからの送信元または宛先の削除

SPAN セッションから送信元または宛先を削除するには、次の例に示すように、グローバル コンフィギュレーション モードで no monitor session session コマンドを使用します。

Router(config)# no monitor session 1

 

レイヤ 2 QoS の設定

Cisco NIM-ES2-4 および Cisco NIM-ES2-8は L2 データ トラフィックの各ポートで 4 つの出力キューをサポートします。4 つのキューはデフォルトで完全優先キューであり、キュー 1 が最低優先キュー、キュー 4 が最高優先キューです。Shaped Deficit Weighted Round Robin (SDWRR)もサポートされ、各キューの重み付けを設定できます。

Cisco NIM-ES2-4 および Cisco NIM-ES2-8 L2 QoS 設定はグローバル設定であり、モジュールごとやポートごとの設定ではありません。

802.1p CoS ベース キュー マッピングの設定

CoS ベース キュー マッピングを設定するには、特権 EXEC モードで次のステップに従います。

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

wrr-queue cos-map qid cos1..cosn

このキュー ID にマッピングされる CoS 値を指定します。

デフォルト値は次のとおりです。

CoS Value - Queue ID

0、1 - Q1

2、3 - Q2

4、5 - Q3

6、7 - Q4

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show wrr-queue cos-map

キューのマッピングを表示します。

新しい CoS 設定をディセーブルにして、デフォルト設定に戻すには、no wrr-queue cos-map グローバル コンフィギュレーション コマンドを使用します。

SDWRR プライオリティの設定

SDWRR のプライオリティを設定するには、特権 EXEC モードで次のステップに従います。

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

wrr-queue bandwidth weight1...weight4

SDWRR の重みを 4 つの CoS キューに割り当てます。weight1 から weight4 の WRR 値の範囲は 1 ~ 255 です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show wrr-queue bandwidth

キューの SDWRR 帯域幅の割り当てを表示します。


) SDWRR プライオリティを設定すると SDWRR スケジューリングが有効になり、絶対優先はディセーブルになります。SDWRR スケジューリングをディセーブルにして、絶対優先スケジューリングをイネーブルにするには、no wrr-queue bandwidth グローバル コンフィギュレーション コマンドを使用します。


インターフェイスの CoS 値の設定

デフォルトのポート CoS 値を定義する場合、またはポート上のすべての着信パケットにデフォルトの CoS 値を割り当てる場合には、特権 EXEC モードで次の手順を実行します。

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Interface interface-id

EtherSwitch インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport priority {default default-cos | override}

デフォルトのポート CoS 値を設定します。

default-cos には、ポートに割り当てるデフォルトの CoS 値を指定します。タグなしの着信パケットでは、デフォルトの CoS 値はパケットの CoS 値になります。指定できる CoS 範囲は 0 ~ 7 です。デフォルトは 0 です。

タグなしの着信パケットの CoS 値を上書きし、パケットにデフォルトのポート CoS 値を適用するには、override キーワードを使用します。デフォルトでは、CoS の上書きはディセーブルに設定されています。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interface interface-id switchport

入力内容を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルト設定に戻すには、no switchport priority {default | override} インターフェイス コンフィギュレーション コマンドを使用します。

VLAN

仮想ローカル エリア ネットワーク(VLAN)は、物理的な位置にかかわりなく、共通の要件を持つエンド ステーションのグループです。VLAN は、物理 LAN と同じ属性をすべて備えていますが、物理的に同じ LAN セグメントに置かれていないエンド ステーションでもグループ化することができます。この機能の詳細については、 http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/software/feature/guide/geshwic_cfg.html を参照してください。

レイヤ 2 スイッチング用 LAN ポートの設定

この章では、コマンドライン インターフェイス(CLI)を使用して、Cisco 4000 シリーズ ルータ上でギガビット イーサネット、およびレイヤ 2 スイッチング用の 10/100/1000 ギガビット イーサネット LAN ポートを設定する方法について説明します。このセクションの設定タスクは LAN スイッチング モジュール上の LAN ポートに適用されます。

レイヤ 2 LAN ポート モード

表 1-2 に、レイヤ 2 LAN ポート モードを示し、LAN ポートにおける各モードの機能について説明します。

 

表 1-2 レイヤ 2 LAN ポート モード

モード
機能

switchport mode access

LAN ポートは永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションを行います。ネイバー LAN ポートが変更に同意しなくても、LAN ポートは非トランク ポートになります。

switchport mode dynamic desirable

リンクからトランク リンクへの変換を LAN ポートにアクティブに試行させます。ネイバー LAN ポートが trunk desirable 、または auto モードに設定されていれば、LAN ポートはトランク ポートになります。このモードは、すべての LAN ポートのデフォルト モードです。

switchport mode dynamic auto

LAN ポートにリンクからトランク リンクへの変換を試行させます。ネイバー LAN ポートが trunk または desirable モードに設定されていれば、LAN ポートはトランク ポートになります。

switchport mode trunk

LAN ポートは永続的なトランキング モードになり、リンクをトランク リンクに変換するようにネゴシエーションを行います。ネイバー ポートが変更に同意しなくても、LAN ポートはトランク ポートになります。

switchport nonegotiate

LAN ポートを永続的なトランキング モードにしますが、LAN ポートが DTP フレームを生成するのを防ぎます。トランク リンクを確立するには、ネイバー ポートを手動でトランク ポートとして設定する必要があります。


DTP はポイントツーポイント プロトコルです。ただし、インターネットワーキング デバイスによっては、DTP フレームが正しく転送されないことがあります。この問題を避けるために、これらのリンク上でトランキングを行わない場合は、DTP をサポートしないデバイスに接続されている LAN ポートが、access キーワードを使用して設定されていることを確認してください。DTP をサポートしないデバイスへのトランキングをイネーブルにするには、nonegotiate キーワードを使用して、LAN ポートをトランクにし、DTP フレームが生成されないようにします。


レイヤ 2 LAN インターフェイスのデフォルト設定

表 1-3 に、レイヤ 2 LAN ポートのデフォルト設定を示します。

 

表 1-3 レイヤ 2 LAN インターフェイスのデフォルト設定

機能
デフォルト

インターフェイス モード:

switchport コマンドの入力前

switchport コマンドの入力後

switchport mode dynamic desirable

デフォルト アクセス VLAN

VLAN 1

ネイティブ VLAN(802.1Q トランク用)

VLAN 1

レイヤ 2 スイッチング用の LAN インターフェイスの設定

ここでは、Cisco4000 シリーズ ルータにおけるレイヤ 2 スイッチングの設定手順について説明します。

「レイヤ 2 スイッチング用の LAN ポートの設定」

「トランクとしてのレイヤ 2 スイッチング ポートの設定」


) インターフェイスをデフォルト設定に戻すには、default interface {ethernet | fastethernet | gigabitethernet | tengigabitethernet} slot/subslot/port コマンドを使用します。


レイヤ 2 スイッチング用の LAN ポートの設定

レイヤ 2 スイッチング用の LAN ポートを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type 1 slot/subslot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if) # shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router# show running-config interface [ type 1 slot/port ]

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 4

Router# show interfaces [ type 1 slot/subslot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 5

Router# show interfaces [ type 1 slot/subslot/port ] trunk

インターフェイスのトランクの設定を表示します。

1.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

switchport コマンドを入力したあとのデフォルト モードは、 switchport mode dynamic desirable です。ネイバー ポートがトランキングをサポートし、かつトランキングを許可するように設定されている場合、 switchport コマンドを入力すると、リンクはレイヤ 2 トランクになります。LAN トランク ポートは、デフォルトでカプセル化についてネゴシエーションします。ネイバー ポートが ISL および 802.1Q カプセル化をサポートし、かつ両方のポートがカプセル化タイプについてネゴシエーションするように設定されていれば、トランクは ISL カプセル化を使用します(10 ギガビット イーサネット ポートは ISL カプセル化をサポートしません)。

802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定


) • ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。

他にキーワードを指定せずに switchport コマンドを入力する場合、デフォルト モードは switchport mode dynamic desirable および switchport trunk encapsulation negotiate です。


 

レイヤ 2 スイッチング ポートを ISL または 802.1Q トランクとして設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport mode trunk

(任意)802.1Q トランクとしてレイヤ 2 スイッチング ポート モードを設定します。

レイヤ 2 スイッチング ポートを 802.1Q トランクとして設定する場合、次の点に注意してください。

switchport mode trunk コマンド(「DTP を使用しないようにするためのレイヤ 2 トランクの設定」を参照)は、 switchport trunk encapsulation negotiate コマンドと互換性がありません。

switchport mode trunk コマンドを使用できるようにするには、カプセル化を 802.1Q として設定する必要があります。

DTP を使用するためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用するようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport mode dynamic { auto | desirable }

(任意)DTP を使用するようにトランクを設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード( switchport mode dynamic desirable )に戻します。

DTP を使用するようにレイヤ 2 トランクを設定する際、次の情報に注意してください。

インターフェイスがレイヤ 2 アクセス ポートの場合、またはトランキング モードを指定する場合に限り必須です。

トランキング モードの詳細については、表 1-2 を参照してください。

DTP を使用しないようにするためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用しないようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-if)# switchport mode trunk

(任意)無条件にポートをトランクに設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード( switchport mode dynamic desirable )に戻します。

ステップ 2

Router(config-if)# switchport nonegotiate

(任意)DTP を使用しないようにトランクを設定します。

Router(config-if)# no switchport nonegotiate

ポート上で DTP をイネーブルにします。

DTP を使用しないようにレイヤ 2 トランクを設定する際、次の点に注意してください。

switchport mode trunk コマンドを入力する前に、カプセル化を設定する必要があります(「802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)。

switchport nonegotiate コマンドを使用できるようにするには、 switchport mode trunk コマンドを入力する必要があります。

switchport mode dynamic trunk コマンドを入力します。トランキング モードの詳細については、表 1-2 を参照してください。

switchport nonegotiate コマンドを入力する前にカプセル化を設定し(「802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)、 switchport mode trunk コマンドを使用して無条件にポートをトランクに設定する必要があります(「DTP を使用するためのレイヤ 2 トランクの設定」を参照)。

アクセス VLAN の設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


アクセス VLAN を設定するには、次の作業を行います。

802.1Q ネイティブ VLAN の設定

コマンド
目的

Router(config-if)# switchport access vlan vlan_ID

(任意)インターフェイスがトランキングを停止した場合に使用するアクセス VLAN を設定します。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く)。

Router(config-if)# no switchport access vlan

デフォルト値に戻します(VLAN 1)。


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


802.1Q ネイティブ VLAN を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk native vlan vlan_ID

(任意)802.1Q ネイティブ VLAN を設定します。

Router(config-if)# no switchport trunk native vlan

デフォルト値に戻します(VLAN 1)。

ネイティブ VLAN を設定する際、次の点に注意してください。

vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く)。

アクセス VLAN がネイティブ VLAN として自動的に使用されることはありません。

トランク上で許容される VLAN のリストの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


トランク上で許容される VLAN のリストを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

(任意)トランク上で許容される VLAN のリストを設定します。

Router(config-if)# no switchport trunk allowed vlan

デフォルト値に戻します(すべての VLAN を許容)。

トランク上で許容される VLAN のリストを設定する際、次の情報に注意してください。

vlan パラメータは、1 ~ 4094 の間の 1 つの VLAN 番号、または 2 つの VLAN 番号で指定する(小さい方の数を先にして、間をダッシュで区切る)VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

VLAN 1 を削除できます。トランクから VLAN 1 を削除した場合も、トランク インターフェイスは VLAN 1 の Cisco Discovery Protocol(CDP)、VLAN トランキング プロトコル(VTP)、ポート集約プロトコル(PAgP)、DTP などの管理トラフィックを引き続き送受信します。

STP の概要

STP は、ネットワークの不要なループを防止しながらパスの冗長性を提供する、レイヤ 2 リンク管理プロトコルです。レイヤ 2 イーサネット ネットワークが正常に動作するには、任意の 2 つのステーション間で存在できるアクティブ パスは 1 つだけです。STP の動作はエンド ステーションに対してトランスペアレントなので、単一の LAN セグメントに接続されているのか、それとも複数セグメントからなるスイッチド LAN に接続されているのかを、エンド ステーションが検知することはできません。

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール は、すべての VLAN で STP(IEEE 802.1D ブリッジ プロトコル)を使用します。デフォルトでは、(STP を手動でディセーブルにしない限り)設定されている VLAN ごとに 1 つの STP インスタンスが動作します。STP は、VLAN 単位でイネーブルおよびディセーブルにすることができます。

Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール は、次の 3 つの STP をサポートします。

「Multiple Spanning Tree protocol」

「Per-VLAN Spanning Tree+」

「Rapid Per-VLAN Spanning Tree+」

Multiple Spanning Tree protocol

MST では複数の VLAN がスパニングツリー インスタンスにマッピングされ、それぞれのインスタンスには、その他のスパニングツリー インスタンスに依存しないスパニングツリー トポロジーが含まれます。このアーキテクチャによって複数の転送パスがデータ トラフィックに提供され、ロードバランスが可能になり、多数の VLAN のサポートに必要となるスパニングツリー インスタンスの数が減ります。MST では、1 つのインスタンス(転送パス)で障害が発生しても他のインスタンス(転送パス)に影響しないため、ネットワークのフォールトトレランスが向上します。

Per-VLAN Spanning Tree+

Per-VLAN Spanning Tree+(PVST+)は PVST 標準規格の拡張です。Per-VLAN Spanning Tree+(PVST+)は、シスコ スイッチの CST と PVST 間の相互運用性を実現し、IEEE 802.1Q 標準をサポートします。

Rapid Per-VLAN Spanning Tree+

Rapid PVST は既存の PVST+ 用の設定を使用しますが、Rapid PVST は RSTP を使用した方がコンバージェンスが速くなります。独立 VLAN は、独自の RSTP インスタンスを実行します。ダイナミック エントリは、TC を受信すると、ポート単位ですぐに消去されます。UplinkFast および BackboneFast 設定は Rapid PVST モードでは無視され、両機能は RSTP に含まれます。

STP のデフォルト設定

表 1-4 に、STP のデフォルト設定を示します。

 

表 1-4 STP のデフォルト設定

機能
デフォルト値

ディセーブル状態

すべての VLAN でディセーブル化された STP

ブリッジ プライオリティ

32768

SPT ポート プライオリティ(ポート単位で設定可能:レイヤ 2 アクセス ポートとして設定された LAN ポートで使用される)

128

SPT ポート コスト(ポート単位で設定可能:レイヤ 2 アクセス ポートとして設定された LAN ポートで使用される)

ギガビット イーサネット:4

STP VLAN ポート プライオリティ(VLAN 単位で設定可能。レイヤ 2 トランク ポートとして設定された LAN ポートで使用される)

128

STP VLAN ポート コスト(VLAN 単位で設定可能。レイヤ 2 トランク ポートとして設定された LAN ポートで使用される)

ギガビット イーサネット: 1000000000

hello タイム

2 秒

転送遅延時間

15 秒

最大エージング タイム

20 秒

モード

PVST

STP のイネーブル化


) デフォルトではすべての VLAN で STP がディセーブルです。


STP は、VLAN 単位でイネーブルにできます。Cisco 4 ポートおよび 8 ポート レイヤ 2 ギガビット EtherSwitch ネットワーク インターフェイス モジュール は VLAN ごとに個別の STP インスタンスを維持します(STP をディセーブルに設定した VLAN を除きます)。

VLAN 単位で STP をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree vlan vlan_ID

VLAN 単位で STP をイネーブルにします。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。表 1-4 を参照)。

Router(config)# default spanning-tree vlan vlan_ID

指定された VLAN のすべての STP パラメータを、デフォルト値に戻します。

Router(config)# no spanning-tree vlan vlan_ID

指定された VLAN で STP をディセーブルにします。このコマンドについては、次の「注意」を参照してください。

ステップ 2

Router(config)# end

設定モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

STP がイネーブルになっていることを確認します。


注意 VLAN のすべてのスイッチおよびブリッジでスパニングツリーがディセーブルになっていない場合は、VLAN でスパニングツリーをディセーブルにしないでください。スパニングツリーは、VLAN の一部のスイッチおよびブリッジでディセーブルにしておきながら、VLAN のその他のスイッチおよびブリッジでイネーブルにしておくことはできません。スパニングツリーをイネーブルにしたスイッチとブリッジに、ネットワークの物理トポロジに関する不完全な情報が含まれることになるので、この処理によって予想外の結果となることがあります。


注意 物理的なループの存在しないトポロジーであっても、スパニングツリーをディセーブルにすることは推奨しません。スパニングツリーは、設定の誤りおよび配線の誤りに対する保護手段として動作します。VLAN に物理ループが存在しないことを確認せずに、VLAN でスパニング ツリーをディセーブルにしないでください。

次に、VLAN 200 で STP をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree vlan 200
Router(config)# end
Router#

) STP はデフォルトでは無効に設定されています。


次に、設定を確認する例を示します。

Router# show spanning-tree vlan 200
 
G0:VLAN0200
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 00d0.00b8.14c8
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 
Bridge ID Priority 32768
Address 00d0.00b8.14c8
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
Gi1/4 Desg FWD 200000 128.196 P2p
Gi1/5 Back BLK 200000 128.197 P2p
 
Router#

) VLAN 200 スパニングツリーを作成するには、VLAN 200 にアクティブなインターフェイスが少なくとも 1 つ必要です。この例では、VLAN 200 内の 2 つのインターフェイスがアクティブです。


オプションの STP 機能の設定

ここでは、次のオプションの STP 機能の設定方法について説明します。

「PortFast のイネーブル化」

「PortFast BPDU フィルタリングのイネーブル化」

「BPDU ガードのイネーブル化」

「UplinkFast のイネーブル化」

「BackboneFast のイネーブル化」

PortFast のイネーブル化


注意 PortFast は、単一のエンド ステーションをレイヤ 2 アクセス ポートに接続する場合に限って使用してください。そうしない場合、ネットワーク ループが発生する可能性があります。

レイヤ 2 アクセス ポート上で PortFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 2 slot/port }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree portfast

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast をイネーブルにします。

ステップ 3

Router(config-if)# spanning-tree portfast default

PortFast をイネーブルにします。

ステップ 4

Router(config-if)# end

設定モードを終了します。

ステップ 5

Router# show running interface { type 1 slot/port }

設定を確認します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ギガビット イーサネット インターフェイス 1 上で PortFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface GigabitEthernet 1
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface GigabitEthernet1
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
 
Router#

PortFast のデフォルト設定をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast default

PortFast をデフォルトに設定します。

ステップ 2

Router(config)# show spanning-tree summary totals

グローバル コンフィギュレーションを確認します。

ステップ 3

Router(config)# show spanning-tree interface x detail

特定のポートに対する効果を確認します。

ステップ 4

Router(config-if)# spanning-tree portfast trunk

ポート上で PortFast トランクをイネーブルにします。

ステップ 5

Router# show spanning-tree interface fastEthernet x detail

設定を確認します。

次に、PortFast のデフォルト設定をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config)# ^Z
 
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 
Router# show spanning-tree interface GigabitEthernet 0/1/0 detail
Port 17 (GigabitEthernet0/1/0) of G0:VLAN0020 is forwarding
Port path cost 4, Port priority 128, Port Identifier 128.17.
Designated root has priority 32788, address f44e.05da.bb11
Designated bridge has priority 32788, address f44e.05da.bb11
Designated port id is 128.17, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 61, received 0
Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host.Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 

PortFast BPDU フィルタリングのイネーブル化

ここでは、PortFast BPDU フィルタリングを設定する手順について説明します。

PortFast BPDU フィルタリングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpdufilter default

ルータ上で BPDU フィルタリングをグローバルにイネーブル化します。

ステップ 2

Router# show spanning-tree summary totals

設定を確認します。

各ポート上で、BPDU フィルタリングはデフォルトに設定されています。次に、ポート上で PortFast BPDU フィルタリングをイネーブルにして、PVST+ モードで設定を確認する例を示します。

Router(config)# spanning-tree portfast bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Switch is in pvst mode
Root bridge for: G0:VLAN0013, G0:VLAN0020, G1:VLAN0020
EtherChannel misconfig guard is enabled
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is short
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
3 vlans 0 0 0 3 3
 

非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface fastEthernet 4/4

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter enable

BPDU フィルタリングをイネーブルにします。

ステップ 3

Router# show spanning-tree interface fastEthernet 4/4

設定を確認します。

次に、非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
Router# show spanning-tree interface fastEthernet 4/4 detail
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDU ガードのイネーブル化

BPDU ガードをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpduguard default

Router(config)# no spanning-tree portfast bpduguard default

BPDU ガードをグローバルにイネーブルにします。

BPDU ガードをグローバルにディセーブルにします。

ステップ 2

Router(config)# end

設定モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDU ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast bpduguard
Router(config)# end
Router#

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals default
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#

UplinkFast のイネーブル化

UplinkFast を使用すると、ブリッジ プライオリティが 49152 に増えるとともに、Cisco 7600 シリーズ ルータ上のすべてのレイヤ 2 LAN インターフェイスの STP ポート コストに 3000 が加算されます。その結果、ルータがルート ブリッジになる可能性が低くなります。 max_update_rate 値は、1 秒間に送信されるマルチキャスト パケット数を表します(デフォルトは 150 パケット/秒です)。ブリッジ プライオリティを設定している VLAN 上では、UplinkFast をイネーブルにすることはできません。ブリッジ プライオリティを設定している VLAN 上で UplinkFast をイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力して、VLAN のブリッジ プライオリティをデフォルトに戻します。


) UplinkFast をイネーブルにすると、Cisco 7600 シリーズ ルータ上のすべての VLAN に影響します。個々の VLAN について UplinkFast を設定することはできません。


UplinkFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFast をイネーブルにします。

Router(config)# no spanning-tree uplinkfast max-update-rate

デフォルトのレートに戻します。

Router(config)# no spanning-tree uplinkfast

UplinkFast をディセーブルにします。

ステップ 2

Router(config)# end

設定モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次に、UplinkFast をイネーブルにして、アップデート速度を 400 パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFast のイネーブル化


) BackboneFast が適切に動作するのは、ネットワーク内のすべてのネットワーク デバイス上でイネーブルになっている場合だけです。BackboneFast は、トークンリング VLAN ではサポートされません。この機能は、サードパーティ製のネットワーク デバイスと組み合わせて使用することができます。


BackboneFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFast をイネーブルにします。

Router(config)# no spanning-tree backbonefast

BackboneFast をディセーブルにします。

ステップ 2

Router(config)# end

設定モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次に、BackboneFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0

Router#

OIR を用いた Cisco NIM ES2-4 および Cisco NIM ES2-8 の管理

ここでは、Cisco 4000 シリーズ ISR 上で OIR を用いた Cisco NIM-ES2-4 および Cisco NIM-ES2-8 の管理についての情報を示します。活性挿抜(OIR)機能により、モジュールの電源をオンにしたまま Cisco 4000 シリーズ ISR に Cisco NIM-ES2-4 および Cisco NIM-ES2-8 を挿入または取り外しできます。このプロセスは、サプライズ OIR またはハード OIR とも呼ばれます。Cisco 4000 シリーズ ISR は、エニーツーエニー OIR もサポートしているため、スロット内のネットワーク インターフェイス モジュール(NIM)を OIR 機能を使用して別の NIM に置き換えることが可能になります。

モジュールが挿入されると、NIM が通電し、NIM 自身が初期化され、機能を開始します。ホット スワップ機能により、システムは、装置の物理構成に発生した変更の状況を判断し、すべてのインターフェイスが適切に機能するように装置のリソースを再度割り当てることができます。この機能を使用すると、NIM のインターフェイスを再構成しても、ルータの他のインターフェイスを変更せずに済みます。ソフトウェアは、NIM の取り外しと挿入の処理に必要なタスクを実行します。

ルータから取り外す前に、データを損失することなく Cisco NIM-ES2-4 および Cisco NIM-ES2-8 の電力を切ることもできます。このタイプの OIR はマネージド OIR またはソフト OIR としても知られています。マネージド OIR 機能では、他のアクティブなモジュールがルータにインストールされたままでも、 hw-module subslot [ stop ] コマンドを使用してモジュールへの電力供給を停止し、サブスロットの 1 つからモジュールを取り外すことができます。


) OIR を実行した後でモジュールをただちに交換する予定がない場合は、サブスロットにブランク フィルタ プレートを必ず取り付けてください。


stop オプションでは、データを損失することなくモジュールを非アクティブ化できます。コマンドの start オプションを実行するとモジュールはリブートされます。 reload オプションは、特定のモジュールを停止または非アクティブ化して再起動します。

 

ここでは、 hw-module subslot slot / subslot reload コマンドの出力例を示します。次の例は、 hw-module subslot slot-number/subslot-number reload コマンドを入力した場合の表示例です。

Router# hw-module subslot 0/1 reload
Proceed with reload of module?[confirm]y
*Mar 30 05:17:19.814: %IOSXE_OIR-6-SOFT_RELOADSPA: SPA(NIM-ES2-8) reloaded on subslot 0/1
*Mar 30 05:17:19.816: %SPA_OIR-6-OFFLINECARD: SPA (NIM-ES2-8) offline in subslot 0/1
*Mar 30 05:17:21.810: %LINK-3-UPDOWN: Interface Vlan20, changed state to down
*Mar 30 05:17:22.810: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to down
*Mar 30 05:17:28.176: %IOSXE-4-PLATFORM: R0/0: kernel: pci 0000:48:00.0: no hotplug settings from platform
*Mar 30 05:17:32.071: %SPA_OIR-6-ONLINECARD: SPA (NIM-ES2-8) online in subslot 0/1
*Mar 30 05:17:34.051: %LINK-3-UPDOWN: Interface GigabitEthernet0/1/0, changed state to down
*Mar 30 05:17:36.739: %LINK-3-UPDOWN: Interface GigabitEthernet0/1/0, changed state to up
*Mar 30 05:17:37.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1/0, changed state to up

関連資料

 

関連項目
マニュアル タイトル

Cisco NIM-ES2-4/8 向けのハードウェアの取り付け手順

Installing the Cisco 4-Port and 8-Port Layer 2 Gigabit EtherSwitch Network Interface Module

設定に関する一般情報およびコマンド リファレンス

Software Configuration Guide for the Cisco 4000 Integrated Services Router

Cisco 4000 ISR 向けの法規制の遵守に関する情報

Regulatory Compliance and Safety Information for the Cisco 4000 Integrated Services Router

Cisco サービス統合型ルータおよび Cisco 第 2 世代サービス統合型ルータにおけるソフトウェア アクティベーション

Software Activation on Cisco Integrated Services Routers and Cisco Integrated Service Routers G2

シスコのテクニカル サポート

 

説明
リンク

Technical Assistance Center(TAC)ホーム ページ:多数の技術関連の記事と、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクを提供する Web サイトです。必要な記事は検索して見つけることができます。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml