Cisco IOS XR インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド
Cisco IOS XR での双方向フォワーディング 検出の設定
Cisco IOS XR での双方向フォワーディング検出の設定
発行日;2012/01/30 | 英語版ドキュメント(2011/08/28 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

Cisco IOS XR での双方向フォワーディング検出の設定

この章の構成

BFD の実装の前提条件

BFD に関する情報

IPv4 での BFD

IPv6 での BFD

バンドル VLAN での BFD

BFD のパケット形式

制約事項

BFD の設定

ネイバでの BFD のイネーブル化

特定インターフェイスでの OSPF の BFD のイネーブル化

特定インターフェイスでの OSPFv3 の BFD のイネーブル化

スタティック ルートでの BFD のイネーブル化

ルータでのエコー モードのディセーブル化

個別のインターフェイスまたはバンドルでのエコー モードのディセーブル化

BFD カウンタのクリアおよびディセーブル化

での 双方向フォワーディング検出(BFD)の設定例

双方向フォワーディング検出(BFD):例

スタティック ルートでの BFD:例

BFD エコー モードのディセーブル化:例

関連情報

その他の参考資料

関連資料

規格

RFC

MIB

シスコのテクニカル サポート

Cisco IOS XR での双方向フォワーディング検出の設定

Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)では、隣接する転送エンジン間のパスにおける障害を低オーバーヘッド、短期間で検出できます。BFD では、あらゆるメディアおよびあらゆるプロトコル レイヤでの障害検出に単一のメカニズムを使用でき、広範な検出時間とオーバーヘッドに対応できます。障害の迅速な検出が可能なため、リンクやネイバの障害発生時にもただちに障害に対応することができます。

Cisco IOS XR での双方向フォワーディング検出(BFD)設定機能の履歴

リリース
変更点

リリース 3.2

この機能が Cisco CRS-1 キャリア ルーティング システム に追加され、次の機能がサポートされました。

物理 Packet-over-SONET/SDH(POS)およびギガビット イーサネット番号付きリンク、VLAN での IPv4 非同期モードおよびエコー モード

BFD IPv4 単一ホップ

ラインカードでの配信

BFD バージョン 0 およびバージョン 1

リリース 3.3.0

BFD の次の機能へのサポートが追加されました。

バンドル VLAN 経由のスタティック ルートを使用する BFD

トラフィック損失とネットワークのチャーンを最小限に抑えながらノード CPU の再起動を可能にする Minimum Disruption Restart(MDR; 最小限の中断による再起動)

イーサネット インターフェイスで BFD を使用した Fast Reroute/Traffic Engineering(FRR/TE; 高速再ルーティング/トラフィック エンジニアリング)

clear bfd counters packet コマンドおよび show bfd counters packet コマンドをサポートするために、設定手順が追加されました。

リリース 3.3.1

BFD サポートが Cisco XR 12000 シリーズ ルータに追加されました。

リリース 3.3.2

BFD が Unicast Reverse Path Forwarding(uRPF; ユニキャスト RFP)と組み合わせて使用されているルータまたはインターフェイスでのエコー モードをユーザがディセーブルにできるように、 echo disable コマンドが追加されました。

ユーザがエコー モードをディセーブルにできる新しい BFD コンフィギュレーション モードが追加されました。ユーザが新しい BFD コンフィギュレーション モードを開始できるようにする bfd コマンドが追加されました。

リリース 3.4.0

バンドル VLAN での BFD で、Open Shortest Path First(OSPF)および Intermediate System-to-Intermediate System(IS-IS)がサポートされました。

リリース 3.5.0

変更ありません。

リリース 3.6.0

変更ありません。

リリース 3.7.0

IPv6 の BFD が Cisco CRS-1 ルータに追加されました。

リリース 3.8.0

BFD での OSPFv3 のサポートが Cisco CRS-1 ルータに追加されました。
BFD MIB サポートが Cisco CRS-1 ルータおよび Cisco XR 12000 シリーズ ルータに追加されました。

BFD の実装の前提条件

次に、BFD を実装するための前提条件を示します。

この設定作業を行うには、Cisco IOS XR ソフトウェアのシステム管理者が、対応するコマンド タスク ID を含むタスク グループに関連付けられたユーザ グループにユーザを割り当てる必要があります。 すべてのコマンド タスク ID は、各コマンド リファレンスおよび『 Cisco IOS XR Task ID Reference Guide 』に記載されています。

タスク グループの割り当てについてサポートが必要な場合は、システム管理者に連絡してください。 ユーザ グループおよびタスク ID の詳細については、『 Cisco IOS XR Software System Security Configuration Guide 』の「 Configuring AAA Services on Cisco IOS XR Software 」モジュールを参照してください。

Cisco IOS XR ソフトウェアを稼動している Cisco CRS-1 ルータまたは Cisco XR 12000 シリーズ ルータであること。

マルチプロトコル ラベル スイッチング(MPLS)で BFD をイネーブルにする場合は、MPLS パッケージを含んだインストール済みの複合 PIE ファイル、または複合パッケージ イメージが必要です。Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)、Intermediate System-to-Intermediate System(IS-IS)、スタティック、Open Shortest Path First(OSPF)の場合は、インストール済みの Cisco IOS XR IP Unicast Routing Core Bundle イメージが必要です。

IS-IS または OSPF を使用している場合、ルータで Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)がアクティブになっていること。

Cisco CRS-1 ルータでは、BFD をサポートする各ラインカードが次のタスクを実行できる必要があります。

エコー パケットを 15 ms ごどに送信(通常の状態)。

制御パケットを 15 ms ごとに送信(負荷のある状態)。

6700 pps を超える User Datagram Protocol(UDP; ユーザ データグラム プロトコル)を送受信。これにより、15 ms 間隔で 100 セッション(または 150 ms 間隔で 1024 セッション)を維持します。

Cisco XR 12000 シリーズ ルータ プラットフォームでは、BFD をサポートする各ラインカードが次のタスクを実行できる必要があります。

エコー パケットを 50 ms ごとに送信(通常の状態)。

制御パケットを 250 ms ごとに送信(負荷のある状態)。

12000 シリーズ プラットフォームでは、1000 pps を超える User Datagram Protocol(UDP; ユーザ データグラム プロトコル)を送受信。これにより、50 ms 間隔で 50 セッションを維持します。

ネイバの BFD をイネーブルにするには、その近接ルータが BFD をサポートしている必要があります。

BFD セッションを設定する前に、グローバル コンフィギュレーション モードで router-id コマンドを使用してローカル ルータ ID を設定することをお勧めします。ローカル ルータ ID を設定しない場合、BFD エコー モードでの IP パケットの送信元アドレスは、出力インターフェイスの IP アドレスとなります。

BFD に関する情報

Cisco IOS XR ソフトウェアは、IPv4 と IPv6 の両方について双方向フォワーディング検出(BFD)をサポートします。

IPv4 での BFD

IPv4 単一ホップ接続の BFD において、Cisco IOS XR ソフトウェアは、番号付けされた物理 Packet-over-SONET/SDH(POS)およびギガビット イーサネット リンクでの非同期モードとエコー モードの両方を次のようにサポートします。

エコー モードは、BFD 制御パケットを使用してセッションが確立された後にのみ開始されます。BFD エコー パケットは、送信元および宛先ポート 3785 を使用して、UDP/IPv4 で転送されます。IP パケットの送信元アドレスはローカル ルータ ID、宛先アドレスは ローカル インターフェイス アドレスとなります。


) ローカル ルータ ID を設定するには、グローバル コンフィギュレーション モードで router-id コマンドを使用します。BFD セッションを設定する前にローカル ルータ ID を設定していない場合、IP パケットの送信元アドレスは出力インターフェイスの IP アドレスとなります。


BFD 非同期パケットは、送信元ポート 49152 および宛先ポート 3784 を使用して、UDP および IPv4 で転送されます。非同期モードの場合、IP パケットの送信元アドレスはローカル インターフェイス アドレス、宛先アドレスはリモート インターフェイス アドレスとなります。


) エコー モードは、VLAN バンドルではサポートされません。



注意 特定のインターフェイスで BFD をユニキャスト RPF (uRPF)と併用している場合は、echo disable コマンドを使用して、そのインターフェイスでのエコー モードをディセーブルにする必要があります。そうしないと、エコー パケットは拒否されます。エコー モードのディセーブル化は、ルータ全体、または個別のインターフェイスに対して行えます。

IPv4 インターフェイスでの IPv4 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv4 verify unicast source reachable-via コマンドを使用します。IPv6 インターフェイスでの loose 方式 IPv6 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv6 verify unicast source reachable-via any コマンドを使用します。

Cisco IOS XR ソフトウェアで BFD を設定する際には、次の事項に注意する必要があります。

BFD は固定長の hello プロトコルで、接続の各終端で転送パスを通じてパケットを定期的に転送します。Cisco IOS XR ソフトウェアは、BFD の適応型検出時間をサポートします。

BFD は、次のアプリケーションと併用することができます。

BGP

IS-IS

OSPF

MPLS Traffic-Engineering(MPLS-TE; MPLS トラフィック エンジニアリング)

Static

Protocol Independent Multicast(PIM)

BFD は、次のインターフェイス タイプでの接続でサポートされます。

Packet-over-SONET/SDH(POS)

Gigabit Ethernet(GigE; ギガビット イーサネット)

Ten Gigabit Ethernet(TenGigE; 10 ギガビット イーサネット)

Virtual LAN(VLAN; 仮想 LAN)

Cisco IOS XR ソフトウェアは、BFD バージョン 0 およびバージョン 1 をサポートします。BFD セッションは、ネイバに応じていずれかのバージョンを使用して確立されます。BFD バージョン 1 はデフォルト バージョンであり、セッション確立において最初に試行されます。

BFD は、IPv4 で直接接続されている外部 BGP ピアでサポートされます。

ユーザは、ルータで次の作業を行えます。

アプリケーション コンフィギュレーション スペースでの BFD パラメータ(適切な間隔および検出係数)の設定

BFD 動作ステータス(ステート、カウンタ、追跡など)の表示

BFD カウンタのクリア

IPv6 での BFD

IPv6 での双方向フォワーディング検出(BFD)では、IPv6 アドレスを使用するインターフェイスでの稼動中の接続の確認をサポートします。

稼動中の接続の確認は、IPv4 と IPv6 の両方のインターフェイスについて、同じサービスとプロセスによって実行されます。

ルート プロセッサ上の BFD サーバ

ラインカード上の BFD エージェント

ただし、BFD サーバと BFD エージェントは個別のデータベースを使用します。

IPv4 アドレスを保存するためのセッション データベース 1 つ

IPv6 アドレスを保存するためのセッション データベース 1 つ

同一ラインカード上で、IPv4 と IPv6 の両方の BFD セッションを同時に実行することができます。

次に記載する制約事項を除き、IPv4 での BFD でサポートされる機能および設定と同じものが、IPv6 での BFD でもサポートされます。

Cisco IOS XR ソフトウェア リリース 3.8.0 での IPv6 の BFDには、次の制約事項が適用されます。

IPv6 での BFD は、バンドル VLAN インターフェイスではサポートされません。

IPv6 での BFD は、エコー モードではサポートされません。

IPv6 での BFD は、エコー モードではなく非同期 モードでのみサポートされます。

バンドル VLAN での BFD

BFD は、スタティック ルーティング、IS-IS、OSPF を使用するバンドル VLAN でサポートされます。バンドル VLAN インターフェイスで BFD セッションを実行すると、VLAN バンドルがアップ状態である限り BFD セッションはアクティブな状態となります。

VLAN バンドルがアクティブであれば、次に示すイベントによって BFD セッションが失敗することはありません。

コンポーネント リンクの失敗

1 つまたは複数のコンポーネント リンクをホストするラインカードのホットスワップ(OIR)

バンドルへのコンポーネント リンクの追加(設定による)

バンドルからのコンポーネント リンクの削除(設定による)

コンポーネント リンクのシャットダウン

RP スイッチオーバー


) VLAN バンドル設定の詳細については、Cisco IOS XR ソフトウェアでのリンク バンドルの設定」モジュールを参照してください。


バンドル VLAN で BFD を設定する場合には、次の事項に注意する必要があります。

RP スイッチオーバーの場合、設定されているネクストホップは Routing Information Base(RIB)に登録されます。

BFD 再起動の場合、スタティック ルートは RIB に残ります。BFD セッションは、BFD の再起動時に再確立されます。


) スタティック BFD セッションは、ネクストホップがルータに直接接続されているアドレス プレフィクスを持つピアでサポートされます。


BFD のパケット形式

BFD ペイロード制御パケットは、宛先ポート 3784 および送信元ポート 49152 を使用して、UDP パケットにカプセル化されます。イーサネットのような共有型メディアでも、BFD 制御パケットは常にユニキャスト パケットとして BFD ピアに送信されます。

エコー パケットも、宛先ポート 3785 および送信元ポート 3785 を使用して、UDP パケットにカプセル化されます。

制約事項

BFD には、次の制約事項が適用されます。

特定のインターフェイスで BFD を uRPF と併用している場合は、 echo disable コマンドを使用して、そのインターフェイスでのエコー モードをディセーブルにする必要があります。そうしないと、エコー パケットは拒否されます。エコー モードのディセーブル化は、ルータ全体、または個別のインターフェイスに対して行えます。

バンドル VLAN での BFD では、スタティック、OSPF、IS-IS の各アプリケーションのみがサポートされます。

IPv6 での BFD は、バンドル VLAN インターフェイスではサポートされません。

IPv6 での BFD は、エコー モードではサポートされません。

IPv6 での BFD は、エコー モードではなく非同期 モードでのみサポートされます。

IPv6 スタティック ルートでの BFD は、クライアントのみによりサポートされます。

BFD の設定

次に、BGP でのBFD を設定する手順について説明します。BFD は、ネイバ単位またはインターフェイス単位でイネーブルにすることができます。ネイバ単位で BFD をイネーブルにするには、「ネイバでの BFD のイネーブル化」に記載されている手順を使用します。インターフェイス単位で BFD をイネーブルにするには、「特定インターフェイスでの OSPF の BFD のイネーブル化」に記載されている手順を使用します。


) BFD を使用する FRR/TE は、POS インターフェイスおよびイーサネット インターフェイスでサポートされます。


ネイバでの BFD のイネーブル化

次に、近接ルータで BGP でのBFD を設定する手順について説明します。


) BFD 近接ルータの設定は、BGP でのみサポートされます。


手順の概要

1. configure

2. router bgp autonomous-system-number

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. neighbor ip-address

6. remote-as autonomous-system-number

7. bfd fast-detect

8. end
または
commit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

 

RP/0/RP0/CPU0:router(config)# router bgp 120

BGP コンフィギュレーション モードを開始します。このモードでは、BGP ルーティング プロセスの設定を行えます。

現在のルータの autonomous-system-number を取得するには、EXEC モードで show bgp コマンドを使用します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RP0/CPU0:router(config-bgp)# bfd minimum-interval 6500

BFD の最小間隔を設定します。有効値の範囲は 15 ~ 30000 ms です。

この例では、BFD の最小間隔を 6500 ms に設定しています。

ステップ 4

bfd multiplier multiplier

 

RP/0/RP0/CPU0:router(config-bgp)# bfd multiplier 7

BFD 係数を設定します。

この例では、BFD 係数を 7 に設定しています。

ステップ 5

neighbor ip-address

 

RP/0/RP0/CPU0:router(config-bgp)# neighbor 172.168.40.24

BGP ルーティングのためにルータを ネイバ コンフィギュレーション モードにして、ネイバの IP アドレスを BGP ピアとして設定します。

この例では、IP アドレス172.168.40.24 をBGP ピアとして設定しています。

ステップ 6

remote-as autonomous-system-number

 

RP/0/RP0/CPU0:router(config-bgp-nbr)# remote-as 2002

ネイバを作成し、そのネイバをリモート自律システムに割り当てます。

この例では、設定されるリモート自律システムは 2002 です。

ステップ 7

bfd fast-detect

 

RP/0/RP0/CPU0:router(config-bgp-nbr)# bfd fast-detect

ローカル ネットワーキング装置と、ステップ 5 で IP アドレスを BGP ピアとして設定したネイバ間での BFD をイネーブルにします。

ステップ 5 の例では、IP アドレス 172.168.40.24 が BGP ピアとして設定されています。この例では、ローカル ネットワーキング装置とネイバ 172.168.40.24 間での BFD がイネーブルになります。

ステップ 8

end

または

commit

 

RP/0/RP0/CPU0:router (config-bgp-nbr)# end

または

RP/0/RP0/CPU0:router(config-bgp-nbr)# commit

設定変更を保存します。

end コマンドを発行すると、変更のコミットを求めるプロンプトが表示されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、コンフィギュレーション セッションの終了や設定変更のコミットは行われず、ルータでは現在のコンフィギュレーション セッションが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

特定インターフェイスでの OSPF の BFD のイネーブル化

次に、Open Shortest Path First(OSPF)での BDF を特定のインターフェイスで設定する手順について説明します。この方法の手順は、コマンド モードが異なる点を除き、IS-IS および MPLS-TE での BFD を設定する手順と共通です。


) インターフェイス単位での BFD の設定は、OSPF、OSPFv3、IS-IS、MPLS-TE でのみサポートされます。OSPFv3 インターフェイスでの BFD の設定の詳細については、「特定インターフェイスでの OSPFv3 の BFD のイネーブル化」を参照してください。


手順の概要

1. configure

2. router ospf process-name

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. area area-id

6. interface type interface-path-id

7. bfd fast-detect

8. end
または
commit

9. show run router ospf

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf process-name

 

RP/0/RP0/CPU0:router(config)# router ospf 0

OSPF コンフィギュレーション モードを開始します。このモードでは、OSPF ルーティング プロセスの設定を行えます。

現在のルータの process-name を取得するには、EXEC モードで show ospf コマンドを使用します。

(注) IS-IS または MPLS-TE での BFD を設定するには、対応するコンフィギュレーション モードを開始します。たとえば、MPLS-TE の場合は、MPLS-TE コンフィギュレーション モードを開始します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RP0/CPU0:router(config-ospf)# bfd minimum-interval 6500

BFD の最小間隔を設定します。有効値の範囲は 15 ~ 30000 ms です。

この例では、BFD の最小間隔を 6500 ms に設定しています。

ステップ 4

bfd multiplier multiplier

 

RP/0/RP0/CPU0:router(config-ospf)# bfd multiplier 7

BFD 係数を設定します。

この例では、BFD 係数を 7 に設定しています。

ステップ 5

area area-id

 

RP/0/RP0/CPU0:router(config-ospf)# area 0

Open Shortest Path First(OSPF)領域を設定します。

area-id は、OSPF 領域の ID に置き換えてください。

ステップ 6

interface type interface-path-id
 
RP/0/RP0/CPU0:router(config-ospf-ar)# interface gigabitEthernet 0/3/0/1

インターフェイス コンフィギュレーション モードを開始して、インターフェイス名と rack/slot/module/port 表記を指定します。

この例では、モジュラー サービス カード スロット 3 にあるギガビット イーサネット インターフェイスを示しています。

ステップ 7

bfd fast-detect
 
RP/0/RP0/CPU0:router(config-ospf-ar-if)# bfd fast-detect

隣接する転送エンジン間のパスで障害を検出するために、BFD をイネーブルにします。

ステップ 8

end

または

commit

 

RP/0/RP0/CPU0:router (config-ospf-ar-if)# end

または

RP/0/RP0/CPU0:router(config-ospf-ar-if)# commit

設定変更を保存します。

end コマンドを発行すると、変更のコミットを求めるプロンプトが表示されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、コンフィギュレーション セッションの終了や設定変更のコミットは行われず、ルータでは現在のコンフィギュレーション セッションが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 9

show run router ospf

 

RP/0/RP0/CPU0:router (config-ospf-ar-if)# show run router ospf

適切なインターフェイスで BFD がイネーブルになっていることを確認します。

特定インターフェイスでの OSPFv3 の BFD のイネーブル化

次に、OSPFv3 での BFD を特定のインターフェイスで設定する手順について説明します。この方法の手順は、コマンド モードが異なる点を除き、IS-IS および MPLS-TE での BFD を設定する手順と共通です。


) インターフェイス単位での BFD の設定は、OSPF、OSPFv3、IS-IS、MPLS-TE でのみサポートされます。OSPF インターフェイスでの BFD の設定の詳細については、「特定インターフェイスでの OSPF の BFD のイネーブル化」を参照してください。


手順の概要

1. configure

2. router ospfv3 process-name

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. area area-id

6. interface type interface-path-id

7. bfd fast-detect

8. end
または
commit

9. show run router ospfv3

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospfv3 process-name

 

RP/0/RP0/CPU0:router(config)# router ospfv3 0

OSPFv3 コンフィギュレーション モードを開始します。このモードでは、OSPFv3 ルーティング プロセスの設定を行えます。

現在のルータの process name を取得するには、EXEC モードで show ospfv3 コマンドを使用します。

(注) IS-IS または MPLS-TE での BFD を設定するには、対応するコンフィギュレーション モードを開始します。たとえば、MPLS-TE の場合は、MPLS-TE コンフィギュレーション モードを開始します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RP0/CPU0:router(config-ospfv3)# bfd minimum-interval 6500

BFD の最小間隔を設定します。有効値の範囲は 15 ~ 30000 ms です。

この例では、BFD の最小間隔を 6500 ms に設定しています。

ステップ 4

bfd multiplier multiplier

 

RP/0/RP0/CPU0:router(config-ospfv3)# bfd multiplier 7

BFD 係数を設定します。

この例では、BFD 係数を 7 に設定しています。

ステップ 5

area area-id

 

RP/0/RP0/CPU0:router(config-ospfv3)# area 0

OSPFv3 領域を設定します。

area-id は、OSPFv3 領域の ID に置き換えてください。

ステップ 6

interface type interface-path-id
 
RP/0/RP0/CPU0:router(config-ospfv3-ar)# interface gigabitEthernet 0/1/5/0

インターフェイス コンフィギュレーション モードを開始して、インターフェイス名と rack/slot/module/port 表記を指定します。

この例では、モジュラー サービス カード スロット 1 にあるギガビット イーサネット インターフェイスを示しています。

ステップ 7

bfd fast-detect
 
RP/0/RP0/CPU0:router(config-ospfv3-ar-if)# bfd fast-detect

隣接する転送エンジン間のパスで障害を検出するために、BFD をイネーブルにします。

ステップ 8

end

または

commit

 

RP/0/RP0/CPU0:router (config-ospfv3-ar-if)# end

または

RP/0/RP0/CPU0:router(config-ospfv3-ar-if)# commit

設定変更を保存します。

end コマンドを発行すると、変更のコミットを求めるプロンプトが表示されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、コンフィギュレーション セッションの終了や設定変更のコミットは行われず、ルータでは現在のコンフィギュレーション セッションが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 9

show run router ospfv3

 

RP/0/RP0/CPU0:router (config-ospfv3-ar-if)# show run router ospfv3

適切なインターフェイスで BFD がイネーブルになっていることを確認します。

スタティック ルートでの BFD のイネーブル化

次に、スタティック ルートでの BFD をイネーブルにする手順について説明します。


) バンドル VLAN セッションは、間隔 250 ms、係数 3 の場合のみに制限されます。これよりも強力なパラメータは使用できません。


手順の概要

1. configure

2. router static

3. address-family ipv4 unicast address nexthop bfd fast-detect [ minimum interval interval ] [multiplier multiplier ]

4. vrf vrf-name

5. address-family ipv4 unicast address nexthop bfd fast-detect [ minimum interval interval ] [ multiplier multiplier ]

6. end
または
commit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router static

 

RP/0/RP0/CPU0:router(config)# router static

スタティック ルート コンフィギュレーション モードを開始します。このモードでは、スタティック ルーティングの設定を行えます。

ステップ 3

address-family ipv4 unicast address nexthop bfd fast-detect [ minimum-interval interval ] [ multiplier multiplier ]

 
RP/0/RP0/CPU0:router(config-static)# address-family ipv4 unicast 0.0.0.0/0 2.6.0.1 bfd fast-detect minimum-interval 1000 multiplier 5

指定の IPV4 ユニキャスト宛先アドレス プレフィクスおよびフォワーディング ネクストホップ アドレスで BFD 高速検出をイネーブルにします。

引数は、間隔を ms 単位で指定する数字に置き換えてください。有効値の範囲は 10 ~ 10,000 です。

引数は、検出係数を指定する数字に置き換えてください。有効値の範囲は 1 ~ 10 です。

(注) バンドル VLAN セッションは、間隔 250 ms、係数 3 の場合のみに制限されます。これよりも強力なパラメータは使用できません。

ステップ 4

vrf vrf-name

 
RP/0/RP0/CPU0:router(config-static)# vrf vrf1

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスを指定して、その VRF に対するスタティック ルート コンフィギュレーション モードを開始します。

ステップ 5

address-family ipv4 unicast address nexthop bfd fast-detect

 
RP/0/RP0/CPU0:router(config-static-vrf)# address-family ipv4 unicast 0.0.0.0/0 2.6.0.2

指定の IPV4 ユニキャスト宛先アドレス プレフィクスおよびフォワーディング ネクストホップ アドレスで BFD 高速検出をイネーブルにします。

ステップ 6

end

または

commit

 

RP/0/RP0/CPU0:router (config-static-vrf)# end

または

RP/0/RP0/CPU0:router(config-static-vrf)# commit

設定変更を保存します。

end コマンドを発行すると、システムが変更をコミットするように求めるプロンプトを表示します。
Uncommitted changes found.Commit them?

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、設定変更のコミットは行われず、同じコマンド モードが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ルータでのエコー モードのディセーブル化

次に、uRPF と組み合わせて BFD を使用しているルータでエコー モードをディセーブルにする手順について説明します。


) IPv4 インターフェイスでの IPv4 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv4 verify unicast source reachable-via コマンドを使用します。IPv6 インターフェイスでの loose 方式 IPv6 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv6 verify unicast source reachable-via any コマンドを使用します。


手順の概要

1. configure

2. bfd

3. echo disable

4. end
または
commit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo disable

 

RP/0/RP0/CPU0:router(config-bfd)# echo disable

ルータでエコー モードをディセーブルにします。

ステップ 4

end

または

commit

 

RP/0/RP0/CPU0:router (config-bfd)# end

または

RP/0/RP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを発行すると、変更のコミットを求めるプロンプトが表示されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、コンフィギュレーション セッションの終了や設定変更のコミットは行われず、ルータでは現在のコンフィギュレーション セッションが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

個別のインターフェイスまたはバンドルでのエコー モードのディセーブル化

次に、uRPF と組み合わせて BFD を使用しているインターフェイスまたはバンドルでエコー モードをディセーブルにする手順について説明します。


) IPv4 インターフェイスでの IPv4 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv4 verify unicast source reachable-via コマンドを使用します。IPv6 インターフェイスでの loose 方式 IPv6 uRPF チェックをイネーブル/ディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv6 verify unicast source reachable-via any コマンドを使用します。


手順の概要

1. configure

2. bfd

3. interface type interface-path-id

4. echo disable

5. end
または
commit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

interface type interface-path-id

 

RP/0/RP0/CPU0:router(config-bfd)# interface gigabitEthernet 0/1/5/0

特定のインターフェイスまたはバンドルに対して BFD インターフェイス コンフィギュレーション モードを開始します。BFD インターフェイス コンフィギュレーション モードでは、個別のインターフェイスまたはバンドルでエコー モードをディセーブルにすることができます。

ステップ 4

echo disable

 

RP/0/RP0/CPU0:router(config-bfd-if)# echo disable

ルータでエコー モードをディセーブルにします。

ステップ 5

end

または

commit

 

RP/0/RP0/CPU0:router (config-bfd-if)# end

または

RP/0/RP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを発行すると、変更のコミットを求めるプロンプトが表示されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、設定変更をコミットせずにコンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

cancel と入力すると、コンフィギュレーション セッションの終了や設定変更のコミットは行われず、ルータでは現在のコンフィギュレーション セッションが継続されます。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

BFD カウンタのクリアおよびディセーブル化

次に、BFD パケット カウンタの表示およびクリアの手順について説明します。特定ノードまたは特定インターフェイスでホストされている BFD セッションのパケット カウンタをクリアすることができます。

手順の概要

1. show bfd counters packet [ interface type interface-path-id ] location node-id

2. clear bfd counters packet [ interface type interface-path-id ] location node-id

3. show bfd counters packet [ interface type interface-path-id ] location node-id

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

show bfd counters [ipv4 | ipv6 | all] packet [interface type interface-path-id ] location node-id

 

RP/0/RP0/CPU0:router# show bfd counters all packet location 0/3/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタを表示します。

ステップ 2

clear bfd counters [ipv4 | ipv6 | all] packet [ interface type interface-path-id ] location node-id

 

RP/0/RP0/CPU0:router# clear bfd counters all packet interface POS 0/5/0/1 location 0/5/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタをクリアします。

ステップ 3

show bfd counters [ipv4 | ipv6 | all] packet [interface type interface-path-id ] location node-id

 

RP/0/RP0/CPU0:router# show bfd counters all packet location 0/3/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタがクリアされていることを確認します。

Cisco IOS XR での 双方向フォワーディング検出(BFD)の設定例

ここでは、次の設定例について説明します。

「双方向フォワーディング検出(BFD):例」

「スタティック ルートでの BFD:例」

「BFD エコー モードのディセーブル化:例」

双方向フォワーディング検出(BFD):例

次に、自律システム 65000 とネイバ 192.168.70.24 間での BFD を設定する例を示します。

configure
router bgp 65000
bfd multiplier 2
bfd minimum-interval 20
neighbor 192.168.70.24
remote-as 2
bfd fast-detect
 

次に、ギガビット イーサネット インターフェイスで OSPF での BFD をイネーブルにする例を示します。

configure
router ospf 0
area 0
interface gigabitEthernet 0/3/0/1
bfd fast-detect
commit
 
RP/0/0/CPU0:Dec 2 07:06:48.508 : config[65685]: %MGBL-LIBTARCFG-6-COMMIT : Configuration committed by user 'xxx'. Use 'show configuration commit changes 1000001134' to view the changes.
 
end
 
RP/0/0/CPU0:Dec 2 07:06:48.848 : config[65685]: %MGBL-SYS-5-CONFIG_I : Configured from console by lab
 
show run router ospf
 
router ospf 0
area 0
interface GigabitEthernet0/3/0/1
bfd fast-detect
!

次に、ギガビット イーサネット インターフェイスで OSPFv3 での BFD をイネーブルにする例を示します。

configure
router ospfv3 0
bfd minimum-interval 6500
bfd multiplier 7
area 0
interface gigabitethernet 0/1/5/0
bfd fast-detect
commit
show run router ospfv3
 
router ospfv3 0
bfd multiplier 7
bfd minimum-interval 6500
area 0
interface GigabitEthernet0/1/5/0
bfd fast-detect
!
!
!

スタティック ルートでの BFD:例

次に、IPv4 スタティック ルートでの BFD をイネーブルにする例を示します。この例では、BFD セッションは、ネクストホップ 3.3.3.3 が到達可能になると、このネクストホップで確立されます。

configure
router static
address-family ipv4 unicast 2.2.2.0/24 3.3.3.3 bfd fast-detect
end
 

次に、IPv6 スタティック ルートでの BFD をイネーブルにする例を示します。この例では、BFD セッションは、ネクストホップ 2001:0DB8:D987:398:AE3:B39:333:783 が到達可能になると、このネクストホップで確立されます。

configure
router static
address-family ipv6 unicast 2001:0DB8:C18:2:1::F/64 2001:0DB8:D987:398:AE3:B39:333:783 bfd fast-detect minimum-interval 150 multiplier 4
end
exit
exit
show run router static address-family ipv6 unicast

BFD エコー モードのディセーブル化:例

次に、ルータでエコー モードをディセーブルにする例を示します。

configure
bfd
echo disable
 

次に、インターフェイスでエコー モードをディセーブルにする例を示します。

configure
bfd
interface pos 0/1/0/0
echo disable

関連情報

BFD は、複数プラットフォームでサポートされます。これらのコマンドの詳細については、関連するコマンド リファレンス マニュアルを参照してください。

『BGP Commands on Cisco IOS XR Software』

『IS-IS Commands on Cisco IOS XR Software』

『OSPF Commands on Cisco IOS XR Software』

Static Routing Commands on Cisco IOS XR Software

『MPLS Traffic Engineering Commands on Cisco IOS XR Software』

その他の参考資料

ここでは、Cisco IOS XR ソフトウェアでの BFD の実装に関する参考資料について説明します。

関連資料

内容
参照先

BFD コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、例

Cisco IOS XR Interface and Hardware Command Reference

規格

規格
タイトル

この機能によりサポートされた新規規格または改訂規格はありません。またこの機能による既存規格のサポートに変更はありません。

-

RFC

RFC
タイトル

draft-ietf-bfd-base-06

Bidirectional Forwarding Detection 』2007 年 3 月

draft-ietf-bfd-v4v6-1hop-06

BFD for IPv4 and IPv6 (Single Hop) 』2007年 3 月

MIB

MIB
MIB リンク

-

Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、テクニカル ヒント、ツールへのリンクなど、さまざまな技術的コンテンツを検索可能な形で提供しています。

Cisco.com に登録されている場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport