Cisco IOS コンフィギュレーションから Cisco IOS XR コンフィギュレーションへの変換方法 Release 3.5
Cisco IOS コンフィギュレーション から Cisco IOS XR コンフィギュレーションへの変換
Cisco IOS コンフィギュレーションから Cisco IOS XR コンフィギュレーションへの変換
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

Cisco IOS コンフィギュレーション

内容

変換手順

Cisco IOS ソフトウェアと Cisco IOS XR ソフトウェア間の一般的な相違点

Cisco IOS XR ソフトウェアに含まれていない Cisco IOS コンフィギュレーション

Cisco IOS および Cisco IOS XR で同じコンフィギュレーション

Cisco IOS XR でも同様の Cisco IOS コンフィギュレーション

基本的なインターフェイス コンフィギュレーション

コンフィギュレーションのコミット

IPv4 ユニキャスト ルーティングおよびフォワーディング

一般的な IP ルーティング

IS-IS

OSPF

BGP

BGP の概要および例

アドレス ファミリ パラメータ

セッション パラメータ

BGP ネイバー

ルート ポリシーの作成

ネイバー非依存の問題

Enhanced IGRP

EIGRP のルート ポリシー オプション

マルチキャスト ルーティングの設定

スタティック ルートの設定

MPLS

Cisco IOS ソフトウェアでの MPLS の使用

ラベル配布プロトコル

トラフィック エンジニアリング

QoS

IPv6 の設定

Cisco IOS XR ソフトウェアの問題

アクセス コントロール リスト

ユーザ名の設定および権限レベル

NTP

HSRPおよびVRRP

ライン コンフィギュレーション

Cisco IOS ルート マップから Cisco IOS XR RPL への変換

RPL の概要

元のルート マップ コンフィギュレーション

単純な変換

コンディショナルのネストによる反復的比較の削減

インラインセットの使用による小規模で間接的な set 参照の排除

パラメータ化による共通構造の再利用

Cisco IOS コンフィギュレーション
から Cisco IOS XR
コンフィギュレーションへの変換

このマニュアルでは、Cisco IOS コンフィギュレーションから Cisco IOS XR コンフィギュレーションへの変換について説明します。Cisco IOS から Cisco IOS XR ソフトウェアへのあらゆるコマンドまたはコンフィギュレーションの変換を完全に網羅するわけではなく、一般的な機能が中心です。したがって、このマニュアルで扱うのは、すべての Cisco IOS 機能ではありません。

ここで紹介する Cisco IOS XR コンフィギュレーションでは、Cisco IOS XR ソフトウェア Release 3.5.0 を使用します。

このマニュアルは、Cisco IOS XR ソフトウェアの概要ではありません。また、Cisco IOS XR ソフトウェアで設定できる機能の概要でもありません。Cisco IOS と Cisco IOS XR ソフトウェア間の動作インフラストラクチャの相違について十分な知識があり、プロトコルの機能を理解していることが前提です。

変換手順

変換は通常、このマニュアルに記載されている情報を使用して、Cisco IOS コンフィギュレーションを 1 行ずつ調べ、Cisco IOS XR ソフトウェアの同等のコンフィギュレーション コマンドを作成する方式をとります。


) ネットワークにコンフィギュレーションの変換を予定しているノード数が多い場合は、Cisco Advanced Services に連絡し、速やかに変換できるように支援してもらうことも検討してください。



ステップ 1 Cisco IOS XR ソフトウェアをインストールする前に、維持すべきコンフィギュレーションの Cisco IOS コマンドを Cisco IOS XR コンフィギュレーション コマンドに変換し、必要な Cisco IOS XR コンフィギュレーションが指定されたテキスト ファイルを作成する必要があります。

ステップ 2 Migrating from Cisco IOS to Cisco IOS XR Software on the Cisco XR 12000 Series Router 』の手順に従って、Cisco IOS XR ソフトウェアをインストールします。

ステップ 3 Cisco IOS XR ソフトウェアのインストール後、ステップ 1 で作成した Cisco IOS XR コンフィギュレーション コマンドを使用して、ルータを再設定します。ルータの再設定には、次の 2 つの方法のうち、どちらか 1 つを使用できます。

作成した IOS XR コンフィギュレーションを参考に、適切なコンフィギュレーション サブモードで、新しい CLI コンフィギュレーション コマンドを 1 行ずつ入力します。新しいコンフィギュレーションを実行コンフィギュレーションに組み込むには、commit コマンドを入力する必要があります。commit コマンドは、各サブモードでコンフィギュレーションを入力したあとで使用することも、すべての新規コンフィギュレーションを入力したあと、グローバル コンフィギュレーション モードで使用することもできます。

グローバル コンフィギュレーション モードを開始し、新しい IOS XR コンフィギュレーションが指定されたテキスト ファイル全体をコピーして、コマンド プロンプトから貼り付け、commit replace コマンドを入力して実行コンフィギュレーション全体を置き換えます。


) コマンドの解析時に、無効なコマンドまたは構文を伝えるエラー メッセージが表示されることがあります。



 

Cisco IOS ソフトウェアと Cisco IOS XR ソフトウェア間の一般的な相違点

Cisco IOS XR ソフトウェアでは、機能は通常、デフォルトでディセーブルであり、明示的にイネーブルにする必要があります。たとえば、一部のルーティング プロトコル(IS-IS、BGP)では、 address-family ipv4 unicast コマンドを明示的にイネーブルにする必要がありますが、Cisco IOS ソフトウェアではこの作業は不要でした。したがって、TCP/UDP ポートを受信する外部サービスおよび IP プロトコル(Telnet、SSH、tcp-small-servers など)も、オンにしないかぎりオフです。

Cisco IOS から Cisco IOS XR 稼働システムに初めて変換するときには、次の一般的な注意事項に従ってください。

新しい機能は、十分理解するまで設定しないでください。

Cisco IOS コンフィギュレーションでオフになっている機能を Cisco IOS XR ソフトウェアでオンにしないでください。

Cisco IOS ソフトウェアではさまざまな機能がデフォルトでオンになるので、Cisco IOS コンフィギュレーションに含まれている、Cisco IOS XR コンフィギュレーションの機能が全部は必要ではない可能性があります。

変更を慎重にテストしてください。

既存の Cisco IOS ソフトウェア コンフィギュレーションを Cisco IOS XR ソフトウェアの実行コンフィギュレーションに変換したあとで、Cisco IOS XR ソフトウェアの追加機能を試行することが必要になる可能性があります。このような機能の詳細については、次のコンフィギュレーション ガイドを参照してください。

Cisco IOS XR IP Addresses and Services Configuration Guide

Cisco IOS XR Interface and Hardware Component Configuration Guide

Cisco IOS XR Multicast Configuration Guide

Cisco IOS XR Multiprotocol Label Switching Configuration Guide

Cisco IOS XR Modular Quality of Service Configuration Guide

Cisco IOS XR Routing Configuration Guide

Cisco IOS XR System Management Configuration Guide

Cisco IOS XR System Monitoring Configuration Guide

Cisco IOS XR System Security Configuration Guide

Cisco IOS XR ソフトウェアに含まれていない Cisco IOS コンフィギュレーション

表1 に、Cisco IOS XR ソフトウェアにはない一般的な Cisco IOS ソフトウェア コンフィギュレーションを示します。2 番めのカラムの Cisco IOS コマンドにあるのは、コンフィギュレーション ストリング全体または一部です。部分ストリング(たとえば、 ip tftp ...)の場合、最上位のテキストだけが変更され、示されたテキストより後ろのオプションはすべて、Cisco IOS でも Cisco IOS XR ソフトウェアでも同じです。

Cisco IOS XR ソフトウェアのカラムにあるのは、次のいずれかです。

このようなコンフィギュレーションはありません ― Cisco IOS ソフトウェアで設定するサービスですが、Cisco IOS XR ソフトウェアでは設定できません。その理由はほとんどの場合、機能が存在しないからです。Cisco IOS の version コマンドが 1 例です。

このようなキーワードはありません ― コンフィギュレーションは存在しますが、Cisco IOS コンフィギュレーションで指定するそのキーワードが Cisco IOS XR ソフトウェアにはないという意味です。

どちらのタイプのエントリにも、機能の相違を説明するメモが記載されている場合があります。

 

表1 Cisco IOS XR ソフトウェアには存在しない Cisco IOS コンフィギュレーション

Cisco IOS コマンド
キーワード
Cisco IOS XR ソフトウェア
AAA

aaa accounting

connection

このようなキーワードはありません。

network

このようなキーワードはありません。

suppress

このようなキーワードはありません。

aaa authentication

banner

このようなキーワードはありません。

enable ...

このようなキーワードはありません。

Cisco IOS XR ソフトウェアは、ログイン時にイネーブル レベルを変更できるようになっていません。権限はすべてユーザグループ/タスクグループ モデルで定義します。『 Cisco IOS XR System Security
Configuration Guide
』を参照してください。

fail-message

このようなキーワードはありません。

username

このようなキーワードはありません。

aaa authorization

console

このようなキーワードはありません。

aaa new-model

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアには、旧モデルの authentication、authorization、accounting(AAA)は存在しません。

aaa session-id

--

このようなコンフィギュレーションはありません。

アクセス リスト

access-list compiled

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアが ACL(アクセス コントロール リスト)を管理します。ユーザからの設定可能な入力は受け付けません。

access-list number

--

このようなコンフィギュレーションはありません。

ACL はすべて、 ipv4 access-list コンフィギュレーション サブモードを使用して設定します。アクセス コントロール リストを参照してください。

ルータ BGP

auto-summary

--

このようなコンフィギュレーションはありません。

bgp always-compare-med

--

このようなコンフィギュレーションはありません。

bgp default

ipv4-unicast

route-target filter

bgp default local-preference を除き、このようなコンフィギュレーションはありません。

bgp determinist-med

--

このようなコンフィギュレーションはありません。

bgp maxas-limit

--

このようなキーワードはありません。

Cisco IOS XR ソフトウェアでは、Route-Policy Language(RPL)オプションの as-path length コマンドによって、BGP ルートの AS パスにおける ASN 数を調べます。AS パス長が設定限度を超えるルートを受信した場合は、BGP ルーティング プロセスがそのルートを廃棄します。

bgp scan-time import

--

このようなコンフィギュレーションはありません。

bgp suppress-inactive

--

このようなコンフィギュレーションはありません。

distribute-list

in | out

BGP に関してこのようなコンフィギュレーションはありません。

exit-address-family

--

このようなコンフィギュレーションはありません。

exit peer-policy

--

このようなコンフィギュレーションはありません。

neighbor advertise-map

--

このようなコンフィギュレーションはありません。

neighbor allowas-in

--

このようなコンフィギュレーションはありません。

neighbor disable-connected-check

--

このようなコンフィギュレーションはありません。

neighbor inherit

--

このようなコンフィギュレーションはありません。

neighbor local-as

--

このようなコンフィギュレーションはありません。

neighbor networks

--

このようなコンフィギュレーションはありません。

neighbor next-hop-unchanged

--

このようなコンフィギュレーションはありません。

neighbor override-capability-neg

--

このようなコンフィギュレーションはありません。

neighbor send-label

--

このようなコンフィギュレーションはありません。

neighbor translate-update

--

このようなコンフィギュレーションはありません。

neighbor transport

--

このようなコンフィギュレーションはありません。

neighbor unsuppress

--

このようなコンフィギュレーションはありません。

neighbor version

--

このようなコンフィギュレーションはありません。

synchronization

--

このようなコンフィギュレーションはありません。

クロック

clock calendar-valid

--

このようなコンフィギュレーションはありません。

コントローラ

down-when-looped

--

このようなコンフィギュレーションはありません。

pos report

rdool

このようなキーワードはありません。

インターフェイス

cablelength

--

このようなコンフィギュレーションはありません。

class-vc

--

このようなコンフィギュレーションはありません。

down-when-looped

--

このようなコンフィギュレーションはありません。

encapsulation

frame-relay

このようなコンフィギュレーションはありません。

x25

このようなコンフィギュレーションはありません。

fair-queue

--

このようなコンフィギュレーションはありません。

hold-queue

--

このようなコンフィギュレーションはありません。

ip accounting

--

このようなコンフィギュレーションはありません。IP アカウンティングのコマンドは、どれもサポートされません。

ip address negotiated

--

このようなコンフィギュレーションはありません。

ip bgp fast-external-fallover

--

このようなコンフィギュレーションはありません。

ip broadcast-address

--

このようなコンフィギュレーションはありません。

ip load-sharing

--

このようなコンフィギュレーションはありません。

ip mroute-cache

--

このようなコンフィギュレーションはありません。

ip policy

--

このようなコンフィギュレーションはありません。

ip rip

--

このようなコンフィギュレーションはありません。

ip route-cache

--

ip route-cache flow コマンドを除き、このようなコンフィギュレーションはありません。

ipv6 rip

--

このようなコンフィギュレーションはありません。

isis network point-to-point

--

このようなコンフィギュレーションはありません。

logging

--

このようなコンフィギュレーションはありません。

max-reserved-bandwidth

--

このようなコンフィギュレーションはありません。

media-type

--

このようなコンフィギュレーションはありません。

mls qos

--

このようなコンフィギュレーションはありません。

mpls bgp forwarding

--

このようなコンフィギュレーションはありません。

mpls label protocol

--

このようなコンフィギュレーションはありません。

multilink

--

このようなコンフィギュレーションはありません。

peer

--

このようなコンフィギュレーションはありません。

pos report

rdool

このようなキーワードはありません。

ppp

--

このようなコンフィギュレーションはありません。

protocol

ip

このようなコンフィギュレーションはありません。

rate-limit

--

このようなコンフィギュレーションはありません。

serial

--

Cisco IOS XR ソフトウェアでは、このコマンドはシリアル インターフェイス用です。

snmp

--

このようなコンフィギュレーションはありません。

tunnel mode ipv6ip

--

このようなコンフィギュレーションはありません。

tx-queue-limit

--

このようなコンフィギュレーションはありません。

tx-ring-limit

--

このようなコンフィギュレーションはありません。

x25

--

このようなコンフィギュレーションはありません。

IP

clns routing

--

このようなコンフィギュレーションはありません。

ip accounting

--

このようなコンフィギュレーションはありません。

mac-address

このようなコンフィギュレーションはありません。

precedence

このようなコンフィギュレーションはありません。

ip accounting-list

--

このようなコンフィギュレーションはありません。

ip accounting-threshold

--

このようなコンフィギュレーションはありません。

ip accounting-transits

--

このようなコンフィギュレーションはありません。

ip bgp-community new-format

--

このようなコンフィギュレーションはありません。

旧スタイルの番号方式をサポートするコミュニティ リストは廃止されます。このマニュアルで後述する、BGP(ボーダー ゲートウェイ プロトコル)に関するセクションも参照してください。

ip bootp server

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアに BOOTP サーバは存在しません。

ip cef

accounting

このようなコンフィギュレーションはありません。

distributed

このようなコンフィギュレーションはありません。

linecard ipc memory

このようなコンフィギュレーションはありません。

ip cef table

adjacency-prefix

adjacency-prefix override

consistency-check

event-log

resolution-timer

このようなコンフィギュレーションはありません。

ip classless

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアは、CIDR(クラスレス ドメイン間ルーティング)および VLSM(可変長サブネット マスク)を全面的にサポートします。Cisco IOS XR ソフトウェアにはクラスフル ルーティングが存在しないので、classless enable は不要です。

ip default-gateway

--

このようなコンフィギュレーションはありません。

ip default-network

--

このようなコンフィギュレーションはありません。

ip domain multicast

--

このようなコンフィギュレーションはありません。

ip finger

--

このようなキーワードはありません。

Cisco IOS XR ソフトウェアに finger デーモンはありません。

ip ftp username

--

このようなコンフィギュレーションはありません。

ip gratuitous-arps

--

このようなコンフィギュレーションはありません。

ip igmp ssm-map

--

このようなコンフィギュレーションはありません。

ip local policy route-map

--

このようなコンフィギュレーションはありません。

ip multicast

cache-headers

multipath

vrf

このようなコンフィギュレーションはありません。

ip multicast-routing vrf

--

このようなコンフィギュレーションはありません。

ip pim bidir-enable

--

このようなコンフィギュレーションはありません。

RP のアクセス リストを使用して、双方向 PIM
(bidir-PIM)としてアドバタイズするグループのリストを指定できます。

ip pim dm-fallback

--

このようなコンフィギュレーションはありません。

ip pim spt-threshold

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアでは、 spt-threshold infinity コマンドで、共有パス ツリー(SPT)にスイッチングすることがないようにルータを設定します。

ip pim vrf

--

このようなコンフィギュレーションはありません。

ip rcmd

domain-lookup

このようなコンフィギュレーションはありません。

rcp-enable

このようなコンフィギュレーションはありません。

remote-host

このようなコンフィギュレーションはありません。

rsh-enabl e

このようなコンフィギュレーションはありません。

ip receive ...

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアは、受信 ACL をサポートしません。

ip rip

--

このようなコンフィギュレーションはありません。

RIP は、 router rip コマンドを使用してサポートします。

ip spd

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアには、選択的パケット廃棄(SPD)が存在しません。ローカル パケット トランスポート サービス(LPTS)によって、SPD の必要性はほとんど排除されます。LPTS は設定できません。また、このマニュアルでは扱いません。

ip subnet-zero

--

このようなコンフィギュレーションはありません。

この動作は自動的です。Cisco IOS XR ソフトウェアは、完全にクラスレスであり、CIDR に対応します。

ip tcp queuemax

--

このようなコンフィギュレーションはありません。

IP ルート

ip route profile

--

このようなコンフィギュレーションはありません。

ipv6 route

vrf

このようなコンフィギュレーションはありません。

IPv6

ipv6 multicast-routing

--

このようなコンフィギュレーションはありません。

ipv6 pim bsr

announced rp

border

candidate bsr

candidate rp

このようなコンフィギュレーションはありません。

ipv6 unicast-routing

--

このようなコンフィギュレーションはありません。

ルータ ISIS

clns

--

このようなコンフィギュレーションはありません。

fast-flood

--

このようなコンフィギュレーションはありません。

ip fast-convergence

--

このようなコンフィギュレーションはありません。

max-area-addresses

--

このようなコンフィギュレーションはありません。

mpls traffic-eng

area および router-id 以外のすべてのキーワード

これは OSPF にもあります。

multi-topology

--

このようなコンフィギュレーションはありません。

partition avoidance

--

このようなコンフィギュレーションはありません。

prc-interval

--

このようなコンフィギュレーションはありません。

traffic-share

--

このようなコンフィギュレーションはありません。

ライン

autocommand

--

このようなコンフィギュレーションはありません。

exec

--

このようなコンフィギュレーションはありません。

history

--

このようなコンフィギュレーションはありません。

logging

--

このようなコンフィギュレーションはありません。

login

authentication 以外のすべてのキーワード

このようなコンフィギュレーションはありません。

modem

--

このようなコンフィギュレーションはありません。

privilege level

--

このようなコンフィギュレーションはありません。

rotary

--

このようなコンフィギュレーションはありません。

ロギング

logging linecard

linecard

このようなコンフィギュレーションはありません。

logging

rate-limit

このようなコンフィギュレーションはありません。

sequence-nums

このようなコンフィギュレーションはありません。

snmp-authfail

このようなコンフィギュレーションはありません。

snmp-trap

このようなコンフィギュレーションはありません。

ntp clock-period

--

このようなコンフィギュレーションはありません。

MPLS

mpls ip

--

このようなコンフィギュレーションはありません。

mpls ipv6

--

このようなコンフィギュレーションはありません。

mpls label protocol ldp

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアには TDP(タグ配布プロトコル)がないので、LDP(ラベル配布プロトコル)か TDP かという選択は不要です。

mpls static

--

このようなコンフィギュレーションはありません。

mpls traffic-eng auto-bw ...

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアでは、トラフィック エンジニアリング(TE)の auto-bw サポートはありません。

mpls traffic-eng logging

--

このようなコンフィギュレーションはありません。

tag-switching ...

--

このようなコンフィギュレーションはありません。

tag-switching CLI はすべて、MPLS(マルチプロトコル ラベル スイッチング)で置き換えられています。

ルータ MSDP

ip msdp cache-rejected-sa

--

このようなコンフィギュレーションはありません。

ip msdp filter-sa-request

--

このようなコンフィギュレーションはありません。

ip msdp redistribute

--

このようなコンフィギュレーションはありません。

ip msdp sa-request

--

このようなコンフィギュレーションはありません。

NetFlow

enabled

--

このようなコンフィギュレーションはありません。

flow-aggregation

--

このようなコンフィギュレーションはありません。

flow-cache mpls

--

このようなコンフィギュレーションはありません。

flow-export template

--

このようなコンフィギュレーションはありません。

ポリシー マップおよびクラス マップ

description

--

このようなコンフィギュレーションはありません。

fair-queue

--

このようなコンフィギュレーションはありません。

random-detect discard-class-based

--

このようなコンフィギュレーションはありません。

random-detect exponential-weighting-constant

--

このようなコンフィギュレーションはありません。

set atm-clp

--

このようなコンフィギュレーションはありません。

shape peak

--

このようなコンフィギュレーションはありません。

trust dscp

--

このようなコンフィギュレーションはありません。

ルータ OSPF および OSPFv3

domain-id

--

このようなコンフィギュレーションはありません。

domain-tag

--

このようなコンフィギュレーションはありません。

area authentication

--

このようなコンフィギュレーションはありません。

ispf

--

このようなコンフィギュレーションはありません。

mpls traffic-eng

area および router-id 以外のすべてのキーワード

このようなコンフィギュレーションはありません。

redistribute maximum-prefix

--

このようなコンフィギュレーションはありません。

traffic-share

--

このようなコンフィギュレーションはありません。

ルータ RIP

exit-address-family

--

このようなコンフィギュレーションはありません。

flash-update-threshold

--

このようなコンフィギュレーションはありません。

offset-list

--

このようなコンフィギュレーションはありません。

timers basic

--

このようなコンフィギュレーションはありません。

validate-update-source

--

このようなコンフィギュレーションはありません。

ルート マップ

match interface

--

このようなコンフィギュレーションはありません。

match length

--

このようなコンフィギュレーションはありません。

set ip precedence

--

このようなコンフィギュレーションはありません。

set nlri

--

このようなコンフィギュレーションはありません。

RADIUS サーバ

radius-server source-ports

--

このようなコンフィギュレーションはありません。

CoS スロット

multicast

--

このようなコンフィギュレーションはありません。

キュー グループ

exponential-weighting-constant

--

このようなコンフィギュレーションはありません。

サービス

service cerf

--

このようなコンフィギュレーションはありません。

service compress-config

--

このようなコンフィギュレーションはありません。

service config

--

このようなコンフィギュレーションはありません。

service dhcp

--

このようなコンフィギュレーションはありません。

service finger

--

このようなコンフィギュレーションはありません。

service linenumber

--

このようなコンフィギュレーションはありません。

service nagle

--

このようなコンフィギュレーションはありません。

nagle はデフォルトでオンです。ユーザがこの設定を変更することはできません。

service pad

--

このようなコンフィギュレーションはありません。

service prompt

--

このようなコンフィギュレーションはありません。

service sequence-numbers

--

このようなコンフィギュレーションはありません。

service single-slot-reload-enable

--

このようなコンフィギュレーションはありません。

service slave-log

--

このようなコンフィギュレーションはありません。

service tcp-keepalives-in

--

このようなコンフィギュレーションはありません。

Cisco IOS XR ソフトウェアでは、キープアライブを使用するかどうかをアプリケーションが決定します。キープアライブは設定できません。Telnet サーバ(クライアントではなく)はキープアライブを 5 分間隔で送信します。その他の TCP ベース プロトコル(BGP、SSH など)にも同様の組み込みキープアライブ値があります。

service password-encryption

--

このようなコンフィギュレーションはありません。Cisco IOS XR ソフトウェアには、暗号化されないパスワードは存在しません。

service tcp-keepalives-out

--

このようなコンフィギュレーションはありません。

service telnet-zeroidle

--

このようなコンフィギュレーションはありません。

service upgrade

--

このようなコンフィギュレーションはありません。

スロット テーブル

multicast

--

このようなコンフィギュレーションはありません。

SNMP サーバ

snmp-server enable traps

mpls

このようなコンフィギュレーションはありません。

pim

このようなコンフィギュレーションはありません。

rtr

このようなコンフィギュレーションはありません。

snmp-server system-shutdown

--

このようなコンフィギュレーションはありません。

snmp-server tftp-server-list

--

このようなコンフィギュレーションはありません。

TACACS サーバ

tacacs-server attempts

--

このようなコンフィギュレーションはありません。

tacacs-server authenticate

connection enable

このようなコンフィギュレーションはありません。

tacacs-server directed-request

--

このようなコンフィギュレーションはありません。

tacacs-server extended

--

このようなコンフィギュレーションはありません。

tacacs-server last-resort

--

このようなコンフィギュレーションはありません。

VRF

mdt

--

このようなコンフィギュレーションはありません。

システム管理

boot system ...

--

このようなコンフィギュレーションはありません。

enable

--

このようなコンフィギュレーションはありません。

ユーザ名を持っている必要があります。 username taskgroup のコマンド セット内で、パスワードとイネーブル レベルの能力を定義します。

Cisco IOS および Cisco IOS XR で同じコンフィギュレーション

Cisco IOS および Cisco IOS XR ソフトウェアで共通のコンフィギュレーションには、次のようなものがあります。

banner ...

hostname hostname

service timestamps debug datetime msec

service timestamps log datetime msec

snmp-server ...

リストには、コンフィギュレーション ストリング全体またはコンフィギュレーション ストリングの一部分が示されています。部分的なコンフィギュレーション ストリングの場合は、省略記号(...)が伴います。部分的なコンフィギュレーション ストリング(たとえば、 ip tftp )は、記載されたテキストより後ろのオプションはすべて、Cisco IOS ソフトウェアと Cisco IOS XR ソフトウェアとで同じです。

Cisco IOS XR でも同様の Cisco IOS コンフィギュレーション

表2 に、Cisco IOS XR の場合と微妙に異なる Cisco IOS コンフィギュレーションの一部を示します。Cisco IOS ソフトウェアのカラムには、コンフィギュレーション ストリング全体またはコンフィギュレーション ストリングの一部分が示されています。部分的なコンフィギュレーション ストリング(たとえば、 ip tftp ...)の場合、最上位のテキストだけが変更され、示されたテキストより後ろのオプションはすべて、Cisco IOS でも Cisco IOS XR ソフトウェアでも同じです。

2 つめのカラム、Cisco IOS XR ソフトウェアで、2 種類のコンフィギュレーション間の相違について説明します。

 

表2 Cisco IOS XR ソフトウェアでも同様の Cisco IOS コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
AAA

aaa authentication login name tacacs+

aaa authentication login name group tacacs+


tacacs+ の前に group キーワードを指定します。これは、すべての aaa...tacacs+ コマンドで共通です。


aaa authorization commands level { default | list-name } tacacs+

aaa authorization commands { default | list-name } group tacacs+


) Cisco IOS XR ソフトウェアの権限は Cisco IOS ソフトウェアの権限と異なるので、level 引数はありません。


aaa accounting exec { default | list-name } { start-stop | stop-only } tacacs+

aaa accounting exec { default | list-name } { start-stop | stop-only } group tacacs+


tacacs+ の前に group キーワードを指定します。


aaa accounting commands level { default | list-name } { start-stop | stop-only } tacacs+

aaa accounting commands { default | list-name } { start-stop | stop-only } group tacacs+


level 引数はありません。後ろのタスクグループのセクションも参照してください。


ルーティング

area-password password [ authenticate snp { validate | send-only }]

lsp-password { hmac-md5 | text } { clear | encrypted } password [ level { 1 | 2 }] [ send-only ] [ snp send-only ]

auto-cost reference-bandwidth mbps

auto-cost { reference-bandwidth mbps | disable }

auto-summary

auto-summary (EIGRP)
auto-summary (RIP)

BGP ルーティング

bgp bestpath compare-routerid

bgp bestpath compare-routerid

bgp cluster-id cluster-id

bgp cluster-id cluster-id

bgp confederation identifier as-number

bgp confederation identifier autonomous-system-number

bgp confederation peers as-number [... as-number ]

bgp confederation peers [ autonomous-system-number ]

bgp fast-external-fallover

bgp fast-external-fallover disable

このコマンドにより、bgp fast-external-fallover がディセーブルになります。

bgp graceful-restart [ restart-time seconds | stalepath-time seconds ]

bgp graceful-restart
bgp graceful-restart purge-time
bgp graceful-restart restart-time
bgp graceful-restart stalepath-time

bgp redistribute-internal

bgp redistribute-internal

bgp router-id ip-address

bgp router-id ip-address

bgp scan-time [ import ] scanner-interval

bgp scan-time seconds

cdp run

cdp

clock source { internal | line | loop }

clock source { internal | line }

crc { 16 | 32 }

crc { 16 | 32 }

dampening [ half-life-period reuse-threshold ] [ suppress-threshold max-suppress-time [ restart-penalty ]]

dampening [ half-life [ reuse suppress max-suppress-time ]]

default-information originate

default-information originate

default-metric number

default-metric value

description string

description string

distance { ip-address { wildcard-mask }} [ ip-standard-list ] [ ip-extended-list ]

distance weight [ ip-address mask [ access-list-name ]]

distance bgp external-distance internal-distance local-distance

distance bgp external-distance internal-distance local-distance

distance ospf {[ intra-area dist1 ] [ inter-area dist2 ] [ external dist3 ]}

distance ospf { intra-area | inter-area | external } distance

domain-password password [ authenticate snp { validate | send-only }]

lsp-password { hmac-md5 | text } { clear | encrypted } password [ level { 1 | 2 }] [ send-only ] [ snp send-only ]

encapsulation { hdlc | ppp }

encapsulation { hdlc | ppp }

escape-character { break | char | default | none | soft }

escape-character { break | number | character | default | none }

exec-timeout minutes [ seconds ]

exec-timeout minutes seconds

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

flowcontrol hardware { in | out | none }

hello padding

hello-padding { disable | sometimes } [ level { 1 | 2 }]

hostname name

hostname name

ip directed-broadcast [ access-list-number | extended access-list-number ]

ipv4 directed-broadcast

ip domain-list name

domain list domain-name

ip domain-name name

domain name domain-name

ip ftp ...

ftp client ...

ip host [ vrf vrf-name ] { name | modem-telephone-number } [ tcp-port-number ] address1 [ address2 ... address8 ]

hostname name

ip http server

http server [[ access-group name ] | [ ssl ] [ access-group name ]]

ip icmp rate-limit unreachable [ df ] [ ms ] [ log [ packets ] [ interval-ms ]]

icmp ipv4 rate-limit unreachable [ DF ] milliseconds

ip mask-reply

ipv4 mask-reply

ip msdp [ vrf vrf-name ] default-peer { peer-address | peer-name } [ prefix-list list ]

default-peer { ip-address | dns-name } [ prefix-list list ]

ip msdp [ vrf vrf-name ] originator-id interface-type interface-number

originator-id type instance

ip msdp sa-limit { peer-name | peer-address } sa-limit

maximum peer-external-sa entries

ip name-server

domain name-server

ip ospf name-lookup

ospf name-lookup

ip proxy-arp

proxy-arp

ip radius source-interface subinterface-name [ vrf vrf-name ]

radius source-interface interface-name

ip rcmd remote-username username

rcp client username username

ip rcmd source-interface interface-id

rcp client source-interface type instance

ip redirects

ipv4 redirects

ip sap cache-timeout minutes
ip sdr cache-timeout minutes

sap cache-timeout minutes

ip ssh timeout seconds

ssh timeout seconds

ip tacacs source-interface subinterface-name

tacacs source-interface type instance

ip tcp path-mtu-discovery [ age-timer { minutes | infinite }]

tcp path-mtu-discovery [ age-timer minutes | infinite ]

ip tcp synwait-time seconds

tcp synwait-time seconds

ip tcp window-size bytes

tcp window-size bytes

ip telnet source-interface

telnet ipv4 client source-interface

ip tftp ...

tftp client ...

ip route network mask ...

Router# ip route 10.0.0.0 255.0.0.0

route ipv4 network/masklen ...

RP0/0/RP0/CPU0:router# route ipv4 unicast 10.0.0.0/8

Cisco IOS ソフトウェアのパラメータで、 network および mask の後ろに指定できるすべてのオプション( outgoing interface next-hop tag admin distance など)は、Cisco IOS XR ソフトウェアの同じコマンドでも、 network / masklen パラメータの後ろに指定できます。

ip unnumbered interface-type interface-number

ipv4 unnumbered interface-name

ip unreachables

ipv4 unreachables disable

このコマンドによって、IPv4 の unreachable(到達不能)がディセーブルになります。

ip verify unicast reverse-path [ list ]
ip verify unicast source reachable-via

ipv4 verify unicast source reachable-via { any | rx } [ allow-default ] [ allow-self-ping ]

ipv6 address { ipv6-address/prefix-length | prefix-name sub-bits / prefix-length }

ipv6 address ipv6-prefix/prefix-length [ eui-64 ]

ipv6 enable

ipv6 enable

ipv6 icmp error-interval milliseconds [ bucketsize ]

ipv6 icmp error-interval milliseconds [ bucketsize ]

ipv6 mtu bytes

ipv6 mtu bytes

is-type [ level-1 | level-1-2 | level-2-only ]

is-type { level-1 | level-1-2 | level-2-only }

keepalive [ period [ retries ]]

keepalive { seconds | disable }

length screen-length

length lines

line { aux | console } 0

line { aux | console }

ライン番号は不要です。ライン コンフィギュレーションも参照してください。

load-interval seconds

load-interval seconds

log-adjacency-changes [ detail ]

log adjacency changes [ detail | disable ]

logging buffered [ buffer-size | severity-level ]

logging buffered [ size | severity ]

logging console filtered [ severity-level ]

logging console { severity | disable }

logging event { dlci-status-change | link-status | subif-link-status }

logging events link-status [ logical | physical ]

logging facility facility-type

logging facility [ type ]

logging history [ s everity-level-name | severity-level-numbe r ]

logging history severity

logging host {{ ip-address | hostname } [ vrf vrf-name ] | { ipv6 ipv6-address | hostname }} [ transport { udp [ port port-number ] | tcp [ port port-number ] [ audit ]}] [ xml | filtered [ stream stream-id ]] [ alarm [ severity ]]

logging { ip-address | hostname }

logging monitor filtered [ severity-level ]

logging monitor [ severity ]

logging on

logging on

logging source-interface interface-type interface-number

logging source-interface type instance

logging trap level

logging trap [ severity ]

lsp-mtu bytes

lsp-mtu bytes [ level { 1 | 2 }]

lsp-refresh-interval seconds

lsp-refresh-interval seconds [ level { 1 | 2 }]

max-lsp-lifetime [ hours ] value

max-lsp-lifetime seconds [ level { 1 | 2 }]

max-metric router-lsa [ on-startup { seconds | wait-for-bgp }]

max-metric router-lsa [ on-startup { wait-for-bgp | announce-time }]

maximum-paths {[ number-of-paths ] [ import number-of-paths ] | [ import number-of-paths ]}

maximum paths maximum

maximum-paths eibgp number [ import number ]
maximum-paths ibgp {[ number ] [ import number ] | [ import number ]}

maximum-paths { ebgp | ibgp | eibgp } maximum [ unequal-cost ]

metric-style narrow [ transition ] [ level-1 | level-2 | level-1-2 ]

metric-style narrow [ transition ] [ level { 1 | 2 }]

metric-style transition [ level-1 | level-2 | level-1-2 ]

metric-style transition [ level { 1 | 2 }]

metric-style wide [ transition ] [ level-1 | level-2 | level-1-2 ]

metric-style wide [ transition ] [ level { 1 | 2 }]

mpls label range min max

mpls label range [ table table-id ] minimum maximum

mpls traffic-eng area number

mpls traffic-eng area { ospf-area }

mpls traffic-eng { level-1 | level-2 }

mpls traffic-eng level { 1 | 2 }

mpls traffic-eng router-id interface-name

mpls traffic-eng router-id interface-name

RIP neighbor ip-address

neighbor ip-address

(OSPF) neighbor ip-address [ cost number ] [ priority number ] [ poll-interval seconds ]

neighbor ip-address [ cost number ] [ priority number ] [ poll-interval seconds ]

(EIGRP) neighbor { ip-address | ipv6-address } interface-type interface-number

neighbor ip-address

net network-entity-title

net network-entity-title

nsf cisco helper disable
nsf ietf helper disable

nsf { cisco | ietf }

ntp authentication-key number md5 value

authentication-key (NTP コンフィギュレーション モード)

output-delay delay

output-delay delay

passive-interface [ default ] { interface-type interface-number }

passive-interface

(dot1x クレデンシャル) password [ 0 | 7 ] password

(AAA) password { 0 | 7 } password
(BGP) password { clear | encrypted } password

pos ais-shut

ais-shut (SONET パス コンフィギュレーション モード)

pos flag { c2 | s1s0 } value

overhead { c2 byte-value | j1 ascii-value }

pos framing { sdh | sonet }

framing { sdh | sonet }

pos report { b1-tca | b2-tca | b3-tca | lais | lrdi | pais | plop | prdi | rdool | sd-ber | sf-ber | slof | slos }

report [ b1-tca | b2-tca | lais | lrdi | sd-ber | sf-ber | slof | slos ](SONET コンフィギュレーション)
report [ b3-tca disable | pais | plop disable | prdi ]
(SONET パス コンフィギュレーション)

pos threshold { b1-tca | b2-tca | b3-tca | sd-ber | sf-ber } rate

threshold { b1-tca | b2-tca | sd-ber | sf-ber } bit-error-rate (SONET コンフィギュレーション)
threshold b3-tca bit-error-rate (SONET パス コンフィギュレーション)

radius-server deadtime minutes

radius-server deadtime minutes

radius-server key { 0 string | 7 string | string }

radius-server key { 0 clear-text-key | 7 encrypted-key | clear-text-key }

radius-server retransmit retries

radius-server retransmit retries

radius-server timeout seconds

radius-server timeout seconds

router rip

router rip

router-id ip-address

router-id { interface-type interface-instance | router-id }

service tcp-small-servers

service { ipv4 | ipv6 } tcp-small-servers [ max-servers number | no-limit ] [ access-list-name ]

service timestamps [ debug | log ] [ uptime | datetime [ msec ] [ localtime ] [ show-timezone ] [ year ]]

service timestamps [[ debug | log ] { datetime [ localtime ] [ msec ] [ show-timezone ] | disable | uptime }]

service udp-small-servers

service { ipv4 | ipv6 } udp-small-servers [ max-servers number | no-limit ] [ access-list-name ]

session-timeout minutes [ output ]

session-timeout minutes [ output ]

shutdown

shutdown

snmp ifmib ifalias long

snmp-server ifmib ifalias long

snmp-server chassis-id text

snmp-server chassis-id serial-number

snmp-server contact text

snmp-server contact system-contact-string

snmp-server engineID local engineid-string

snmp-server engineid local engine-id

snmp-server group group-name { v1 | v2c | v3 { auth | noauth | priv }} [ context context-name ] [ read read-view ] [ write write-view ] [ notify notify-view ] [ access [ ipv6 named-access-list ] [ acl-number | acl-name ]]

snmp-server group name { v1 | v2c | v3 { auth | noauth | priv }} [ read view ] [ write view ] [ notify view ] [ context context-name ] [ access-list-name ]

snmp-server ifindex persist

snmp-server ifindex persist

snmp-server location text

snmp-server location system-location

snmp-server packetsize byte-count

snmp-server packetsize size

snmp-server queue-length length

snmp-server queue-length length

snmp-server trap-source interface

snmp-server trap-source interface-type interface-number

snmp-server user username group-name [ remote host [ udp-port port ]] { v1 | v2c | v3 [ encrypted ] [ auth { md5 | sha } auth-password ]} [ access [ ipv6 nacl ] [ priv { des | 3des | aes { 128 | 192 | 256 }} privpassword ] { acl-number | acl-name }]

snmp-server user username groupname { v1 | v2c | v3 [ auth { md5 | sha } { clear | encrypted } auth-password [ priv des56 { clear | encrypted } priv-password ]]} [ LROwner | SystemOwner ] [ access-list-name ]

snmp-server view view-name oid-tree { included | excluded }

snmp-server view view-name oid-tree { excluded | included }

stopbits { 1 | 1.5 | 2 }

stopbits { 1 | 2 }

summary-address address mask { level-1 | level-1-2 | level-2 }

summary-address ip-address {/ length | mask } [ admin-distance ]

summary-prefix ipv6-prefix / prefix-length { level-1 | level-1-2 | level-2 }

summary-prefix { address / prefix-length | ipv6-prefix / prefix-length } [ level { 1 | 2 }]

ip tacacs source-interface subinterface-name

tacacs source-interface type instance

tacacs-server key { 0 string | 7 string | string }

tacacs-server key key-name

tacacs-server timeout seconds

tacacs-server timeout seconds

tag-switching mtu bytes

mpls mtu bytes

timers bgp keepalive holdtime

timers bgp keepalive hold-time

timers lsa arrival milliseconds

timers lsa arrival milliseconds

timers lsa-group-pacing seconds

timers pacing lsa-group seconds

timers pacing lsa-group seconds

timers pacing lsa-group seconds

timers pacing flood milliseconds

timers pacing flood milliseconds

timers pacing retransmission milliseconds

timers pacing retransmission milliseconds

timers throttle spf spf-start spf-hold spf-max-wait

timers throttle spf spf-start spf-hold spf-max-wait

transport { tcp tls | udp }

transport [ udp | tcp ]

tunnel destination { host-name | ip-addres s | ipv6-address }

tunnel destination ip-address

tunnel source { ip-address | ipv6-address | interface-type interface-number }

tunnel source { ip-address | type instance }

version { 1 | 2 }

version { 1 | 2 | 3 }

width characters

width characters

基本的なインターフェイス コンフィギュレーション

表3 の例で、インターフェイス コンフィギュレーションの相違を示します。

 

表3 Cisco IOS および Cisco IOS XR ソフトウェアにおける基本的なインターフェイス コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
interface Loopback0
ip address 203.13.132.246 255.255.255.255
!
interface Loopback1
description Mgt Loopback1
ip address 172.26.2.61 255.255.255.255
!
interface Loopback2
ip vrf forwarding grey
ip address 1.1.1.1 255.255.255.255
!
interface POS1/0
ip address 210.180.227.109 255.255.255.252
no ip directed-broadcast
ip ospf cost 130
load-interval 30
shutdown
tx-queue-limit 1000
crc 16
pos framing sdh
pos flag s1s0 2
no cdp enable
!
interface Loopback0
ipv4 address 203.13.132.246/32
!
interface Loopback1
description Mgt Loopback1
ipv4 address 172.26.2.61/32
!
interface Loopback2
vrf grey
ipv4 address 1.1.1.1/32
!
controller SONET0/1/0/0
framing sdh
overhead s1s0 2
path scrambling disable
!
interface POS0/1/0/0
ipv4 address 210.180.227.109/30
no ipv4 directed-broadcast
load-interval 30
shutdown
pos crc 16
no cdp

!

interface POS2/1
ip address 192.168.14.5 255.255.255.0
no ip directed-broadcast
crc 32
clock source internal
pos ais-shut
pos scramble-atm
end
interface POS0/2/0/1
mtu 4474
ipv4 address 192.168.14.8 255.255.255.0
pos
crc 32
!
!
controller SONET0/2/0/1
ais-shut
path
ais-shut
!
clock source internal
!

主な相違点は、次のとおりです。

Cisco IOS XR ソフトウェアには、SONET 設定用の独立したモードがあります。

Cisco IOS XR ソフトウェアでは、Cisco IOS ソフトウェアの ip address コマンドの代わりに ipv4 address コマンドを使用します。

Cisco IOS XR ソフトウェアのコンフィギュレーションでは、 ais-shut コマンドおよび path ais-shut コマンドの両方を設定します。これは、 line ais-shut だけをイネーブルにする Cisco IOS の pos ais-shut コマンドと完全に対応しているわけではありませんが、どちらのコンフィギュレーションでも同じ結果が得られます。

Cisco IOS XR ソフトウェアのインターフェイスで有効なのは、POS(Packet-over-SONET)固有のコンフィギュレーション(HDLC [ハイレベル データリンク コントロール]、PPP [ポイントツーポイント プロトコル]、およびそれらを同期ペイロード エンベロープ [SPE] に格納する方法のコンフィギュレーション)だけです。

crc コマンドは、Cisco IOS XR ソフトウェアでは POS インターフェイス コンフィギュレーション サブモード(config-if-pos)で実行します。

SONET パス コンフィギュレーション サブモード(config-SONET-path)で使用する ais-shut clock path 、およびその他のコマンドは、Cisco IOS XR ソフトウェアでは SONET コントローラ サブモードで使用します。

ペイロード スクランブリング(Cisco IOS ソフトウェアの pos scramble-atm )は、Cisco IOS XR ソフトウェアではデフォルトでオンです。ディセーブルにするには、 path scrambling disable コマンドを使用します。

IOS XR のマルチリンク PPP は IOS のマルチリンク PPP と次の点で異なります。

マルチリンク コントローラがマルチリンク インターフェイスを作成します。

作成後ただちに、コンフィギュレーション(L2 および L3 機能を含む)がマルチリンク インターフェイスに適用されます。

さらに、マルチリンク インターフェイス コンフィギュレーションの検証(機能サポート、ハードウェア リソース チェックなど)もただちに実行されます。

ラインカードおよび SPA 間でマルチリンク インターフェイスを移動させることはできません。

SPA がマルチリンク インターフェイスを所有します(L2 プロトコルには結合されません)。

MLPPP コントロール プレーンは、ラインカード上にあります。

マルチリンク インターフェイスは、活性挿抜(Online Insertion and Removal; OIR)後、設定されたままにはなりません。

マルチリンク インターフェイス レベルの LCP キープアライブがサポートされます。

PPP および HDLS を含め、SONET コントローラおよび POS のコンフィギュレーションについては、次のコンフィギュレーション ガイドおよびコマンド リファレンス モジュールを参照してください。

Cisco IOS XR Interface and Hardware Component Configuration Guide 』の「 Configuring SONET Controller Interfaces on Cisco IOS XR Software 」モジュール

Cisco IOS XR Interface and Hardware Component Configuration Guide 』の「 Configuring POS Interfaces on Cisco IOS XR Software 」モジュール

Cisco IOS XR Interface and Hardware Component Command Reference 』の「 Packet-over-SONET User Interface and SONET Layer-1 Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Interface and Hardware Component Command Reference 』の「 SONET APS Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Interface and Hardware Component Command Reference 』の「 cHDLS Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Interface and Hardware Component Command Reference 』の「 PPP Commands on Cisco IOS XR Software 」モジュール


) Cisco IOS XR ソフトウェアでサポートされるもう 1 種類のインターフェイスは、ギガビット イーサネット(GigE)インターフェイスです。GigE インターフェイスには、コントローラ サブモードがありません。したがって、GigE の設定は、Cisco IOS ソフトウェアで GigE を設定する場合と同様です。


コンフィギュレーションのコミット

ここでは、コンフィギュレーション変更のコミットに関して、Cisco IOS と Cisco IOS XR ソフトウェア間の主な相違点について説明します。

Cisco IOS ソフトウェアでは、グローバル コンフィギュレーション モードでコマンドを入力すると、実行コンフィギュレーション ファイルがただちに更新されます。したがって、有効なコマンドの最後に Enter キーまたは Return キーを押すたびに、コンフィギュレーションの変更が有効になります。しかし、これらの変更は、 copy running-config startup-config EXEC モード コマンドを入力するまで、スタートアップ コンフィギュレーション ファイルには保存されません。

Cisco IOS XR ソフトウェアでは、グローバル コンフィギュレーション モードを終了する前に、変更をコミットする必要があります。変更をコミットしなかった場合、変更は行われません。ただし、ルータのリブート時に変更を有効にするために、スタートアップ コンフィギュレーションに変更を 保存 する必要はありません。

コンフィギュレーション コミットの詳細については、『 Cisco IOS XR Getting Started Guide 』を参照してください。

IPv4 ユニキャスト ルーティングおよびフォワーディング

ここでは、次のコンフィギュレーションについて説明します。

一般的な IP ルーティング

IS-IS

OSPF

BGP

Enhanced IGRP

マルチキャスト ルーティングの設定

スタティック ルートの設定

一般的な IP ルーティング

Cisco IOS と Cisco IOS XR ソフトウェア間の大きな相違は、Cisco IOS ソフトウェアでは、IGP と物理インターフェイス上のコンフィギュレーションの組み合わせによって、インターフェイス上でプロトコルをイネーブルにするということです。最初の方法の例は、OSPF ネットワーク文です。2 番めの方法の例は、IS-IS の ip router isis コマンド、すなわちインターフェイス コストの変更です。Cisco IOS XR ソフトウェアでは、プロトコル固有のあらゆるコンフィギュレーションは、物理インターフェイス コンフィギュレーションではなく、グローバル プロトコル コンフィギュレーション サブモードで実行されます。したがって、物理インターフェイス上では OSPF コマンドも IS-IS コマンドも使用しません。すべてルーティング プロトコル コンフィギュレーションのインターフェイス コンフィギュレーション サブモードで入力します。詳細については、IS-ISおよびOSPFの例を参照してください。

Cisco IOS XR におけるルーティングについては、次のコンフィギュレーション ガイドおよびコマンド リファレンス モジュールを参照してください。

Cisco IOS XR IP Addresses and Services Configuration Guide 』の「 Implementing Network Stack IPv4 and IPv6 on Cisco IOS XR Software 」モジュール

Cisco IOS XR IP Addresses and Services Command Reference 』の「 Network Stack IPv4 and IPv6 Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing BGP on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing Routing Policy on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 BGP Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 Routing Policy Language Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing IS-IS on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 IS-IS Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing OSPF on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 OSPF Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 OSPFv3 Commands on Cisco IOS XR Software 」モジュール

IS-IS

IS-IS の実装に関して、Cisco IOS と Cisco IOS XR 間の主な相違点は、次のとおりです。

Cisco IOS XR ソフトウェアでは、IPv4 アドレス ファミリを明示的にイネーブルにする必要がありますが、Cisco IOS ソフトウェアでは、暗黙でイネーブルです。

Cisco IOS XR ソフトウェアは、CLNS(コネクションレス型ネットワーク サービス)ルーティングをサポートしません。

Cisco IOS XR ソフトウェアでは、IPv6 はマルチトポロジがデフォルトです(IPv6 の設定を参照)。

Cisco IOS XR ソフトウェアでは、 router isis isp などのプロセス名が必要ですが、Cisco IOS ソフトウェアでは router isis だけで設定できます。

表4 に IS-IS のコンフィギュレーション例を示します。

1. 例 1 は、単純なネットワークの IPv4 ルーティング例です。Cisco IOS ソフトウェアで POS インターフェイス(POS2/1)が設定されたルータ(Router ID:192.168.1.5)と Cisco IOS XR ソフトウェアで POS インターフェイス(POS0/2/0/1)が設定されたルータ(Router ID:192.168.1.8)だけで構成されます。

2. 例 2 は例 1 より複雑で、IPv4 ルーティングと IPv6 ルーティングの両方が含まれます。

 

表4 Cisco IOS ソフトウェアおよび Cisco IOS XR ソフトウェアにおける IS-IS コンフィギュレーションの比較

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア

Router ID:192.168.1.5

router isis isp
net 49.0192.0168.0001.0005.00
is-type level-2-only
passive-interface Loopback0
!
interface POS2/1
...
ip router isis isp
isis metric 42
...

Router ID:192.168.1.8

router isis isp
is-type level-2-only
net 49.0192.0168.0001.0008.00
interface Loopback0
passive
address-family ipv4 unicast
!
!
interface POS0/2/0/1
address-family ipv4 unicast
metric 42
!
!
!
router isis
net 39.528f.1100.1000.4025.5062.00
is-type level-2-only
domain-password $xxyy
area-password $wwzz
metric-style wide
max-lsp-lifetime 65535
lsp-refresh-interval 65000
spf-interval 1 1 8
prc-interval 1 1 8
lsp-gen-interval 1 1 1
no hello padding
log-adjacency-changes all
redistribute connected
passive-interface GigabitEthernet2/0
passive-interface GigabitEthernet2/1
passive-interface Loopback0
passive-interface Loopback1
passive-interface Loopback6
!
address-family ipv6
no adjacency-check
exit-address-family
router isis isp
net 39.528f.1100.1000.4025.5062.00
is-type level-2-only
lsp-password $xxyy level 2
lsp-password $wwzz level 1
max-lsp-lifetime 65535
lsp-refresh-interval 65000
lsp-gen-interval maximum-wait 1 initial-wait 1 secondary-wait 1
log adjacency changes
!
address-family ipv4 unicast
metric-style wide
spf-interval maximum-wait 1 initial-wait 1 secondary-wait 8
prc-interval 1
redistribute connected
!
address-family ipv6 unicast
adjacency-check disable
!
interface Loopback1
no hello-padding
passive
address-family ipv4 unicast
!
!
interface POS0/3/0/1
no hello-padding
address-family ipv4 unicast
metric 503 level 2
!
address-family ipv6 unicast
!

これらの例からわかるように、Cisco IOS と Cisco IOS XR ソフトウェア間の大きな相違は、Cisco IOS XR ソフトウェアでは IPv4 アドレス ファミリを明示的にイネーブルにしなければならないのに対して、Cisco IOS ソフトウェアでは暗黙でイネーブルになることです。Cisco IOS ソフトウェアの IS-IS オプションは大部分または全部が Cisco IOS XR ソフトウェアにもあります。もう 1 つの相違は、Cisco IOS XR ソフトウェアでは CLNS コマンドが非常に少ないことです。Cisco IOS ソフトウェアの show clns オプションは、Cisco IOS XR ソフトウェアでは show isis コマンドにあります。

IS-IS の再配布は類似しています。唯一異なるのは、Cisco IOS ソフトウェアの route-map の代わりに、route-policy を指定することです。したがって、Cisco IOS XR ソフトウェアへの再配布は、RPL route-policy の接続ポイントです。 表5 を参照してください。

 

表5 Cisco IOS ソフトウェアと Cisco IOS XR ソフトウェア間の IS-IS 再配布に関する相違点

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router isis isp
redistribute connected route-map route-map
router isis isp
address-family ipv4 unicast
redistribute connected route-policy policy

すべての標準オプションは、Cisco IOS と Cisco IOS XR ソフトウェアの両方で使用できます。

表6 に、Cisco IOS および Cisco IOS XR ソフトウェアが稼働しているシステム上で、 redistribute connected コマンドの適切なコンフィギュレーション サブモードから help コマンド( ? )を入力した結果として生成される出力を示します。

 

表6 Cisco IOS ソフトウェアおよび Cisco IOS XR ソフトウェアにおける redistribute connected コマンドの比較

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
Router# redistribute connected ?
level-1
level-1-2
level-2
metric
metric-type
route-map
<cr>
RP/0/0/CPU0:gsr4(config-isis-af)# redistribute connected ?
level-1 Redistribute routes into level 1 only
level-1-2 Redistribute routes into both levels
level-2 Redistribute routes into level 2 only (the default)
metric Metric for redistributed routes
metric-type IS-IS metric type for redistributed routes
route-policy Route policy reference
<cr>

マルチトポロジの IS-IS コンフィギュレーションも多少異なります。詳細については、MPLSおよびIPv6 の設定を参照してください。

IS-IS コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Routing Configuration Guide 』の「 Implementing IS-IS on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 IS-IS Commands on Cisco IOS XR Software 」モジュール

OSPF

OSPF コンフィギュレーションは、IS-IS コンフィギュレーションと非常によく似ています。 表7 に、OSPF ルーティングのみのコンフィギュレーション例を示します。これは、Cisco IOS ソフトウェアが動作している POS インターフェイス(POS2/1)が設定されたルータ(Router ID:192.168.1.5)、および Cisco IOS XR ソフトウェアが動作している POS インターフェイス(POS0/2/0/1)が設定されたルータ(Router ID:192.168.1.5)からなる、単純なネットワークに対応します。

この説明で重要なのは、Cisco IOS XR ソフトウェア上では OSPF への再配布がポリシー接続ポイントだということです。

 

表7 Cisco IOS および Cisco IOS XR ソフトウェアにおける OSPF コンフィギュレーション

Cisco IOS(Router ID:192.168.1.5)
Cisco IOS XR(Router ID:192.168.1.8)
router ospf 1
log-adjacency-changes
passive-interface Loopback0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.255 area 0
network 192.168.13.0 0.0.0.255 area 0
network 192.168.14.0 0.0.0.255 area 0
network 192.168.18.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
interface Loopback0
ip address 192.168.1.5 255.255.255.255
!
interface POS2/1
ip address 192.168.14.5 255.255.255.0
ip ospf cost 17
router ospf 1
log adjacency changes
area 0
interface Loopback0
passive enable
!
interface POS0/1/0/1
!
interface POS0/2/0/0
!
interface POS0/2/0/1
cost 17
!
interface POS0/2/0/2
!
!
mpls traffic-eng area 0
!

Cisco IOS ソフトウェアのネットワーク文は、OSPF 内の area コマンドでインターフェイスをイネーブルにすることによって置き換えられることに注意してください。また、OSPF では BGP、IS-IS などと異なり、 address-family ipv4 unicast コマンドが不要です。これは、 router ospf がユニキャスト IPv4 のサポートを暗黙指定するからです。シスコでは、マルチキャスト OSPF(MOSPF)をサポートしません。さらに IPv6 では、 router ospfv3 コマンド ファミリからなる独自のルーティング プロトコルを使用します。

再配布も異なります。 表8 に、Cisco IOS および Cisco IOS XR ソフトウェアにおける再配布のコンフィギュレーション例を示します。

 

表8 Cisco IOS および Cisco IOS XR ソフトウェアにおける OSPF の再配布コンフィギュレーション

Cisco IOS
Cisco IOS XR
router ospf 1
redistribute connected subnets
redistribute static subnets route-map map
router ospf 1
redistribute connected
redistribute static route-policy policy

Cisco IOS XR ソフトウェアでは、 subnets キーワードが不要になりました。また、ルート マップではなく、Routing Policy Language(RPL)のルート ポリシーを宣言します。

Cisco IOS XR ソフトウェアで、クラスフル ルートだけを OSPF に再配布するには、 classful キーワードを指定して、 redistribute コマンドを使用します。ルート マップではなくポリシーを使用することについては、BGPおよび RPL に関する既存のCisco IOS XR ソフトウェア マニュアルを参照してください。この説明で重要なのは、Cisco IOS XR ソフトウェア上では OSPF への再配布がポリシー接続ポイントだということです。

OSPF コンフィギュレーションの詳細については、次のモジュールを参照してください。

Cisco IOS XR Routing Configuration Guide 』の「 Implementing OSPF on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 OSPF Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 OSPFv3 Commands on Cisco IOS XR Software 」モジュール

BGP の概要および例

BGP(ボーダー ゲートウェイ プロトコル)は、Cisco IOS XR ソフトウェアへの移行に際して、変換作業がもっとも大きな要素です。BGP コンフィギュレーションは複雑なので、複数のコンフィギュレーション例を示します。Cisco IOS XR ソフトウェアで BGP を設定するには、IPv4 アドレス ファミリを明示的にイネーブルにする必要がありますが、Cisco IOS ソフトウェアでは、暗黙でイネーブルです。

表9 に、BGP の基本的なコンフィギュレーション例を示します。

 

表9 Cisco IOS および Cisco IOS XR ルータにおける基本的な BGP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router bgp 9999
no synchronization
bgp cluster-id 400
bgp log-neighbor-changes
redistribute connected
neighbor 192.168 .0.3 remote-as 9999
neighbor 192.168 .0.3 description ANY_M160_BB1
neighbor 192.168 .0.3 update-source Loopback5
neighbor 192.168 .0.3 next-hop-self
neighbor 192.168 .0.3 send-community
neighbor 192.168 .0.3 soft-reconfiguration inbound
neighbor 192.168 .0.4 remote-as 9999
neighbor 192.168 .0.4 description ANY_M160_BB2
neighbor 192.168 .0.4 update-source Loopback5
neighbor 192.168 .0.4 next-hop-self
neighbor 192.168 .0.4 send-community
neighbor 192.168 .0.4 soft-reconfiguration inbound
 
router bgp 9999
bgp cluster-id 400
bgp log neighbor changes
address-family ipv4 unicast
redistribute connected
!
neighbor 192.168 .0.4
remote-as 9999
description ANY_M160_BB2
update-source Loopback5
address-family ipv4 unicast
next-hop-self
soft-reconfiguration inbound
route-policy default_policy_pass_all out
!
!
neighbor 192.168 .0.3
remote-as 9999
description ANY_M160_BB1
update-source Loopback5
address-family ipv4 unicast
next-hop-self
soft-reconfiguration inbound
route-policy default_policy_pass_all out
!
!

次の点に注意してください。

remote-as および update-source は、Cisco IOS XR ソフトウェアではネイバー サブモード(config-bgp-nbr)内で設定します。

bgp log neighbor changes disable コマンド(ハイフンなし)による BGP ネイバー ロギングのリセットは、デフォルトでオンであり、Cisco IOS XR コンフィギュレーションには含まれません。

Cisco IOS XR ソフトウェアには、BGP に関して auto-summary という概念がないので、Cisco IOS ソフトウェアのようにディセーブルにするものはありません。

先のコンフィギュレーションで最も重要なのは、ネイバー サブモードを使用してコンフィギュレーションを作成できるということです。Cisco IOS XR ソフトウェアではさらに、BGP コンフィギュレーションを独立した構築ブロックに分割できるので、それを再利用してよりモジュラ性が高く、理解が容易なコンフィギュレーションを作成できます。

BGP は RPL が最も多用されるところでもあるので、ここで RPL について説明しておきます。このマニュアルは、コンフィギュレーションの変換がテーマであり、RPL のチュートリアルではないので、RPL の扱いは完全ではありません。RPL の詳細については、次のマニュアルを参照してください。

Cisco IOS XR Routing Configuration Guide 』の「 Implementing Routing Policy on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 Routing Policy Language Commands on Cisco IOS XR Software 」モジュール

アドレス ファミリ パラメータ

Cisco IOS XR ソフトウェアでは、基本的な BGP ネイバー コンフィギュレーション用に 2 つの構築ブロックをサポートします。アドレス ファミリ グループ(コンフィギュレーションでは af-group )およびセッション グループ(コンフィギュレーションでは session-group )です。セッション グループの詳細については、セッション パラメータを参照してください。

さまざまなアドレス ファミリのプロパティは、 af-group キーワードを使用して設定します。Cisco IOS XR ソフトウェア Release 3.5 では、次のアドレス ファミリ グループがサポートされます。

IPv4 ユニキャスト

IPv4 ラベル付きユニキャスト

IPv4 マルチキャスト

IPv6 ユニキャスト

IPv6 マルチキャスト

VPNv4 ユニキャスト


) 個々のアドレス ファミリは、そのアドレス ファミリにアドレスが含まれているネイバーに限ってサポートされます。たとえば、IPv4 ネイバーは、IPv4 ユニキャストおよびマルチキャスト アドレス ファミリをサポートします。IPv6 ネイバーは、IPv6 ユニキャストおよびマルチキャスト アドレス ファミリをサポートします。ただし、IPv6 ルーティング情報を IPv4 ネイバーと交換することはできません。その逆もできません。


af-group 内で、特定のアドレス ファミリの情報交換に固有のプロパティを設定できます。

表10 に、Cisco IOS ルータ(Router ID:192.168.1.5)と Cisco IOS XR ルータ(Router ID:192.168.1.8)における IBGM ピアリングの複雑な例を示します。

 

表10 af-group を使用した BGP コンフィギュレーション

Cisco IOS ソフトウェア(Router ID:192.168.1.5)
Cisco IOS XR ソフトウェア(Router ID:192.168.1.8)
router bgp 3402
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.8 remote-as 3402
neighbor 192.168.1.8 update-source Loopback0
neighbor 192.168.1.8 soft-reconfiguration inbound
neighbor 192.168.1.8 weight 50
neighbor 192.168.1.8 maximum-prefix 75
no auto-summary
!
router bgp 3402
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
!
neighbor 192.168.1.5
remote-as 3402
update-source Loopback0
address-family ipv4 unicast
use af-group test
!
!
!

例から、Cisco IOS XR ソフトウェアを使用すると、 af-group アドレス ファミリ 固有のコンフィギュレーションを指定し、 af-group コマンドによって、特定のネイバーにその af-group を適用できることがわかります。その結果、 neighbor 192.168.1.5 から始まる一連の行が不要になります。

セッション パラメータ

セッション グループは概念上、アドレス ファミリ グループによく似ていますが、特定のアドレス ファミリのプロパティを設定するのではなく、BGP セッションのプロパティを設定する点が異なります。 表11 を参照してください。

 

表11 Cisco IOS XR ソフトウェアの session-group を使用した BGP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router bgp 3402
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.8 remote-as 3402
neighbor 192.168.1.8 password 7 045D0409
neighbor 192.168.1.8 update-source Loopback0
neighbor 192.168.1.8 soft-reconfiguration inbound
neighbor 192.168.1.8 weight 50
neighbor 192.168.1.8 maximum-prefix 75
no auto-summary
!
router bgp 3402
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
!
session-group example
remote-as 3402
password encrypted 1303181D
update-source Loopback0
!
neighbor 192.168.1.5
use session-group example
address-family ipv4 unicast
use af-group test
!
!
!

この例では、ネイバー間でパスワードが追加されています。Cisco IOS XR ソフトウェアでは、これはアドレス ファミリのプロパティではなく、セッションのプロパティなので、session-group に含まれます。また、Cisco IOS のキーワード シンタックス password 0 または password 7 の代わりに、Cisco IOS XR ソフトウェアではキーワード シンタックス password clear または password encrypted を使用します。

BGP ネイバー

次に重要な設定作業は、Cisco IOS のピア グループに相当するものを Cisco IOS XR ソフトウェアで設定することです。Cisco IOS XR ソフトウェアでは、ピア グループではなくネイバー グループと言いますが、機能は同じです。最近の Cisco IOS ソフトウェア バージョンでは、ポリシー グルーピングをネイバー グルーピングから分離するために、ダイナミック アップデート グループという概念が追加されています。Cisco IOS XR ソフトウェアでもこれは同じなので、アップデート グループ間で共有するポリシーに関して、制約はありません。

表12 のコンフィギュレーション例に、Cisco IOS ソフトウェアのピア グループと Cisco IOS XR ソフトウェアのネイバー グループの相違を示します。

 

表12 BGP の設定(Cisco IOS ソフトウェアのピア グループを使用した場合および Cisco IOS XR ソフトウェアのネイバー グループを使用した場合)

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router bgp 3402
no synchronization
bgp log-neighbor-changes
neighbor ibgp-peers peer-group
neighbor ibgp-peers remote-as 3402
neighbor ibgp-peers password 7 10480616
neighbor ibgp-peers update-source Loopback0
neighbor ibgp-peers soft-reconfiguration inbound
neighbor ibgp-peers weight 50
neighbor ibgp-peers maximum-prefix 75
neighbor 192.168.1.8 peer-group ibgp-peers
no auto-summary
!
router bgp 3402
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
!
session-group example
remote-as 3402
password 7 1303181D
update-source Loopback0
!
neighbor-group ibgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ibgp-peers
!
!

Cisco IOS XR のコンフィギュレーションの方が長いですが、ピアの数が増えるにしたがい、Cisco IOS XR ソフトウェアによる抽象によってコンフィギュレーションが短くなり、管理が容易になります。

もう 1 つ検討すべき問題は、ルーティング ポリシーについてです。ルーティング ポリシーは Cisco IOS XR ソフトウェアでは RPL を使用して適用され、Cisco IOS のルート マップに代わる強力な存在です。 表13 は、ルート マップ用語と RPL 用語の対照表です。

 

表13 Cisco IOS のルート マップと Cisco IOS XR の RPL の対照表

Cisco IOS ルート マップ用語
Cisco IOS XR RPL 用語

route-map

route-policy

ip prefix-list

prefix-set

ip as-path access-list

as-path-set

community-list

community-set

Cisco IOS ソフトウェアではリストを使用しますが、Cisco IOS XR ソフトウェアではセットを使用します。数学におけるセット(集合)は、アイテムを順序付けしないで集めたものですが、多くのアプリケーションでは、順序リストより論理的です。

Cisco IOS と Cisco IOS XR ソフトウェア間の重要な相違の 1 つは、Cisco IOS XR ソフトウェアでは、交換するルートに関して、外部 BGP(EBGP)ネイバー間で(着信と発信の両方に)適用するポリシーが なければならない ということです。次に、前と同じ 2 つのルータ間の基本的なコンフィギュレーションを示します。 表14 では、AS(自律システム)番号が異なることに注意してください。

 

表14 ポリシーを使用しない EBGP コンフィギュレーション

Cisco IOS ソフトウェア
(Router ID: 192.168.1.5)
Cisco IOS XR ソフトウェア
(Router ID: 192.168.1.8)
router bgp 5
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.8 remote-as 8
neighbor 192.168.1.8 ebgp-multihop 255
neighbor 192.168.1.8 update-source Loopback0
no auto-summary
!
router bgp 8
neighbor 192.168.1.5
remote-as 5
ebgp-multihop 255
update-source Loopback0
!
!

前のコンフィギュレーションでは、Cisco IOS XR ルータがルートを送受信することはありません。コンフィギュレーションをコミットすると、Cisco IOS XR ソフトウェアによって次のメッセージが表示されます。

%BGP-4-NBR_NOPOLICY: No inbound IPv4 Unicast policy is configured for eBGP neighbor 192.168.1.5. No IPv4 Unicast prefixes will be accepted from the neighbor until inbound policy is configured.
%BGP-4-NBR_NOPOLICY: No outbound IPv4 Unicast policy is configured for eBGP neighbor 192.168.1.5. No IPv4 Unicast prefixes will be sent to the neighbor until outbound policy is configured.
 

show bgp summary コマンドの使用時にポリシーを設定しておかなかった場合、警告が表示されます。

ルート ポリシーの作成

Cisco IOS XR ソフトウェアでは、着信と発信の両方のポリシーが必要です。あらゆるルートを前後双方向に通過させるのが、最も単純なポリシーです。 表15 に、このポリシーをコンフィギュレーションに追加した例を示します。

 

表15 着信ポリシーおよび発信ポリシーを指定した EBGP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router bgp 5
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.8 remote-as 8
neighbor 192.168.1.8 ebgp-multihop 255
neighbor 192.168.1.8 update-source Loopback0
no auto-summary
!
route-policy permit
pass
end-policy
!
router bgp 8
neighbor 192.168.1.5
remote-as 5
ebgp-multihop 255
update-source Loopback0
address-family ipv4 unicast
route-policy permit in
route-policy permit out
!
!
!

ポリシーを設定すると、ルートを通すことができます。

ルート マップを RPL ポリシーに変換する詳細については、このマニュアルでは扱いません。ただし、次の例で、プロセスを簡単に説明します。変換プロセスの詳細例については、このマニュアルのCisco IOS ルート マップから Cisco IOS XR RPL への変換を参照してください。

Cisco IOS XR ソフトウェアでルート ポリシーを作成する方法の詳細については、次のマニュアルを参照してください。

Cisco IOS XR Routing Configuration Guide 』の「 Implementing Routing Policy on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 Routing Policy Language Commands on Cisco IOS XR Software 」モジュール

Cisco IOS ソフトウェアと同じ動作を Cisco IOS XR ソフトウェアで実現するには、 permit (許可)のルート ポリシーを作成し、すべての EBGP ネイバーの各アドレス ファミリ(またはアドレス ファミリ グループ)にそのポリシーを適用します。

表16 に、内部 BGP(IBGP)例の af-group および session-group のコンフィギュレーションと EBGP ポリシー コンフィギュレーションを結合した、最終的なコンフィギュレーションを示します。

 

表16 Cisco IOS および Cisco IOS XR ソフトウェアにおける最終的な EBGP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
router bgp 5
no synchronization
bgp log-neighbor-changes
neighbor ebgp-peers peer-group
neighbor ebgp-peers remote-as 8
neighbor ebgp-peers password 7 15140403
neighbor ebgp-peers ebgp-multihop 255
neighbor ebgp-peers update-source Loopback0
neighbor ebgp-peers soft-reconfiguration inbound
neighbor ebgp-peers weight 50
neighbor ebgp-peers maximum-prefix 75
neighbor 192.168.1.8 peer-group ebgp-peers
no auto-summary
!
route-policy permit
pass
end-policy
!
router bgp 8
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
route-policy permit in
route-policy permit out
!
session-group example
remote-as 5
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ebgp-peers
!
!

Cisco IOS XR コンフィギュレーションを丹念に検証すると、セッション グループに EBGP AS( remote-as 5 )が埋め込まれていることがわかります。セッション グループに EBGP AS を埋め込むことは可能ですが、必須ではありません。埋め込む場合は、外部 AS ごとにセッション グループを作成するか、またはセッション グループを使用しないかのどちらかにする必要があります。

ポリシーはカスケードできるので、セッション グループおよびアドレス ファミリ グループは相互に相手から継承できます。また、セッション グループの設定値を上書きできます。次に、コンフィギュレーションの柔軟性を高めながら、Cisco IOS XR ソフトウェアで BGP ポリシーを作成する 2 通りの例を示します。

ネイバー グループから remote-as コマンドを削除し、ネイバーに直接指定します。

session-group example
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
remote-as 5
use neighbor-group ebgp-peers
!
!
 

第 2 のネイバー グループを作成し、継承を使用します。

router bgp 8
af-group test address-family ipv4 unicast
weight 50
maximum-prefix 75 75
soft-reconfiguration inbound
route-policy permit in
route-policy permit out
!
session-group example
password 7 00021C09
ebgp-multihop 255
update-source Loopback0
!
neighbor-group ASFive
remote-as 5
use neighbor-group ebgp-peers
!
neighbor-group ebgp-peers
use session-group example
address-family ipv4 unicast
use af-group test
!
!
neighbor 192.168.1.5
use neighbor-group ASFive
!
!

ネイバー非依存の問題

BGP に関して、Cisco IOS XR ソフトウェアで BGP のネイバーまたはポリシーに依存しない主要なキーワードは、 bgp socket 、および timers の 3 種類です。BGP で設定できるキーワードについては、このマニュアルでは扱いません。 bgp コマンドのキーワードは、次のとおりです。

as-path-loopcheck

auto-policy-soft-reset

bestpath

bgp

cluster-id

confederation

default

enforce-first-as

fast-external-fallover

graceful-restart

log

receive-buffer-size

redistribute-internal

router-id

scan-time

send-buffer-size

socket

timers bgp keepalive holdtime

update-delay

write-limit

BGP コンフィギュレーションの詳細については、次のマニュアルを参照してください。

Cisco IOS XR Routing Configuration Guide 』の「 Implementing BGP on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing Routing Policy on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 BGP Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Command Reference 』の「 Routing Policy Language Commands on Cisco IOS XR Software 」モジュール

Enhanced IGRP

Cisco IOS XR ソフトウェアの Enhanced IGRP(EIGRP)がサポートするのは、IPv4 だけです。EIGRP は、AS(自律システム)のコンテキストに従って動作します。Cisco IOS XR ソフトウェアでは、EIGRP の 1 つのインスタンスが

AS ごとに動作します。

その下に設定されているすべての VRF(VPN ルーティングおよび転送)インスタンスを管理します。

Cisco IOS と Cisco IOS XR ソフトウェア間で、EIGRP の機能上の相違は、次のとおりです。

autosummary はデフォルトでディセーブルです。

leak-maps はサポートされません。

IPv6 のアドレス ファミリ、双方向フォワーディング検出(BFD)、および SNMP はサポートされません。

サポートされる EIGRP インスタンスは 1 つだけです。

インターフェイスのスタティック ルートが EIGRP に自動的に再配布されることはありません。

接続ルートおよびスタティック ルートの再配布には、メトリックの設定( default-metric コマンドまたはルート ポリシーのどちらかを使用)が必要です。

traffic-share コマンドはサポートされません。

RPL のポリシー オプションは、Cisco IOS ソフトウェアのフィルタリングまたはルート マップ オプションと異なります。EIGRP のルート ポリシー オプションを参照してください。

表17 のコンフィギュレーション例で、Cisco IOS と Cisco IOS XR ソフトウェア間の EIGRP の相違を示します。

 

表17 Cisco IOS および Cisco IOS XR ソフトウェアにおける EIGRP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
route-map site-of-origin permit 10
set extcommunity soo 100:100
!
interface GigabitEthernet0/1
mtu 1514
ip vrf forwarding red
ip vrf sitemap site-of-origin
ip address 11.1.1.12 255.255.255.0
ip hello-interval eigrp 50 30
ip hold-time eigrp 50 100
duplex full
speed 1000
media-type gbic
negotiation auto
!
router eigrp 100
address-family ipv4 vrf red
variance 2
redistribute static route-map redistributionFromStatic
network 11.1.1.0 0.0.0.255
maximum-paths 9
default-metric 999 999 99 99 999
no auto-summary
autonomous-system 50
maximum-prefix 10000 50 restart-count 4 reset-time 10 dampened
eigrp router-id 40.40.40.40
exit-address-family
interface GigabitEthernet0/3/0/1
vrf red
ipv4 address 11.1.1.12 255.255.255.0
!
router eigrp 100
vrf red
address-family ipv4
maximum-paths 9
router-id 40.40.40.40
variance 2
maximum-prefix 10000 50 dampened reset-time 10 restart-count 4
default-metric 999 999 99 99 999
log-neighbor-changes
log-neighbor-warnings
autonomous-system 50
redistribute static route-policy redistributionFromStatic
interface GigabitEthernet0/3/0/1
hello-interval 30
hold-time 100
site-of-origin 100:100
 

EIGRP のルート ポリシー オプション

Cisco IOS XR ソフトウェアで使用できるルート ポリシー オプションは、次のとおりです。

match は、next-hop、source-protocol、および tag アトリビュートに対して実行できます。Cisco IOS ソフトウェアにおける out オプションを指定した distribute-list コマンドは、Cisco IOS XR ソフトウェアでは source-protocol コマンドを使用した場合にサポートされます。

set は、eigrp-metric、next-hop、および tag アトリビュートに対して実行できます。タグの範囲は、内部ルートでは 0 ~ 255、外部ルートでは 0 ~ 4294967295 です。

eigrp-metric を設定するには、次の新しい RPL コマンドを使用します。

set eigrp-metric bandwidth delay reliability load mtu

オフセットリスト機能を実行するには、次の新しい RPL コマンドを使用します。

add eigrp-metric bandwidth delay reliability load mtu

マルチキャスト ルーティングの設定

マルチキャストには、マルチキャスト転送およびマルチキャスト ルーティングを設定する必要があります。

Cisco IOS ソフトウェアでは、どこでマルチキャスト転送を設定し、どこでマルチキャスト ルーティングを設定するかを厳密に線引きすることが困難です。マルチキャスト ルーティング プロトコルをイネーブルにするまで、Cisco IOS インターフェイスではマルチキャスト転送がイネーブルにならないからです。また、Cisco IOS XR ソフトウェアの場合、独立した PIM コンフィギュレーション サブモードがあるにもかからわず、特定のインターフェイス上でマルチキャスト ルーティングをイネーブルにすると、そのインターフェイスで PIM がイネーブルになります。

Cisco IOS XR ソフトウェアは、PIM dense(稠密)モードをサポートしませんが、自動 RP をイネーブルにできるだけの dense モードはサポートされます。また、自動 RP に関連するマルチキャスト グループの転送はサポートされません。

マルチキャストは、インターフェイス上ではなく、プロトコル コンフィギュレーション サブモードでアイテムを設定する Cisco IOS XR モデルと一致します。 表18 に、基本的なマルチキャスト(自動 RP を実行するマルチキャスト転送および PIM)をイネーブルにする例を示します。

 

表18 Cisco IOS および Cisco IOS XR ソフトウェアにおける基本的なマルチキャスト コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
ip multicast-routing
ip igmp ssm-map enable
!
interface TenGigabitEthernet1/1
description ur01
ip address 68.87.36.14 255.255.255.252
ip pim sparse-mode
ip multicast boundary Hub_Local_MCAST
!
ip pim rp-address 68.87.8.10 BSTLAB_MCAST override
ip pim ssm range BOSTON-SSM-RANGE
!
ip msdp peer 145.145.18.26
ip msdp peer 145.145.18.242 remote-as 64920
ip msdp description 145.145.18.242 HvA
ip msdp sa-filter in 145.145.18.242 list 101
ip msdp sa-filter out 145.145.18.242 list 101
ip msdp sa-limit 145.145.18.242 5000
ip msdp cache-sa-state
ip msdp cache-rejected-sa 100
ip msdp redistribute list 101
ip msdp default-peer 145.145.18.242 prefix-list hva
ip msdp originator-id Loopback0
 
interface TenGigabitEthernet0/1/0/1
description ur01
ipv4 address 68.87.36.14/30
!
router pim address-family ipv4
rp-address 68.87.8.10 BSTLAB_MCAST override
!
multicast-routing address-family ipv4
ssm range BOSTON_SSM_RANGE
interface TenGigabitEthernet0/1/0/1
enable
boundary Hub_Local_MCAST
!
router msdp
maximum peer-external-sa 5000
default-peer 145.145.18.242 prefix-list hva
originator-id Loopback0
cache-sa-state
!
peer 145.145.18.242
remote-as 64920
description HvA
sa-filter in list acl_101
sa-filter out list acl_101
 

Cisco IOS XR ソフトウェアでは、ルータ PIM コンフィギュレーション モードで PIM パラメータを変更します。 表19 に、自動 RP で RP アドレスを検出するのではなく、RP アドレスを指定するコンフィギュレーション例を示します。

 

表19 マルチキャスト コンフィギュレーションの PIM パラメータの変更

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
ip pim rp-address 1.2.3.4
router pim address-family ipv4
rp-address 1.2.3.4
!

Cisco IOS XR ソフトウェアでは、マルチキャスト ルーティングをイネーブルにすると、指定された任意のインターフェイス上で、自動 RP(定義上は PIM sparse-dense)およびマルチキャスト転送がオンになります。さらに、 all キーワードによって、ルータのすべてのインターフェイスでマルチキャストをオンにして、さらに一部のインターフェイスを選択してディセーブルにできます。PIM コンフィギュレーションを変更する場合、大部分の変更は router pim コマンドを使用して行います。PIM には関係なく、転送に関連する管理用スコープの境界などのコンフィギュレーションは、config-mcast-ipv4 コンフィギュレーション サブモードで設定します。

マルチキャスト コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Multicast Configuration Guide

Cisco IOS XR Multicast Command Reference

スタティック ルートの設定

Cisco IOS XR ソフトウェアでスタティック ルートを設定するには、 router static コンフィギュレーション サブモードを使用します。 表20 の例を参照してください。

 

表20 Cisco IOS および Cisco IOS XR ソフトウェアにおけるスタティック ルート コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
ip route 10.48.160.0 255.255.255.0 10.48.162.2
ip route 11.0.0.0 255.0.0.0 POS2/0
ip route 144.254.0.0 255.255.0.0 10.48.162.2
ip route vrf V0.0.com 11.0.0.0 255.255.0.0 4.0.0.2
ip route vrf V0.1.com 11.1.0.0 255.255.0.0 4.1.0.2
ip route vrf V0.2.com 11.2.0.0 255.255.0.0 4.2.0.2
ip route vrf V0.3.com 11.3.0.0 255.255.0.0 4.3.0.2
 
router static
address-family ipv4 unicast
10.48.160.0/24 10.48.162.2
11.0.0.0/8 POS0/2/0/0
144.254.0.0/16 10.48.162.2
!
vrf V0.0.com
address-family ipv4 unicast
11.0.0.0/16 4.0.0.2
!
!
vrf V0.1.com
address-family ipv4 unicast
11.1.0.0/16 4.1.0.2
!
!
vrf V0.2.com
address-family ipv4 unicast
11.2.0.0/16 4.2.0.2
!
!
vrf V0.3.com
address-family ipv4 unicast
11.3.0.0/16 4.3.0.2
!
!

スタティック ルート コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Routing Command Reference 』の「 Static Routing Commands on Cisco IOS XR Software 」モジュール

Cisco IOS XR Routing Configuration Guide 』の「 Implementing Static Routing on Cisco IOS XR Software 」モジュール

MPLS

ここでは、Cisco IOS XR ソフトウェアの MPLS(マルチプロトコル ラベル スイッチング)コンフィギュレーションに関する次の問題について説明します。

Cisco IOS ソフトウェアでの MPLS の使用

ラベル配布プロトコル

トラフィック エンジニアリング

Cisco IOS XR ソフトウェアでは、スタティック ラベル、BGP の VPNv4 プレフィクス、または Any Transport over MPLS(AToM)はサポートされません。

Cisco IOS ソフトウェアでの MPLS の使用

表21 に、MPLS の使用に関して、Cisco IOS コンフィギュレーションと Cisco IOS XRコンフィギュレーションの小さな相違点を示します。

 

表21 MPLS の使用に関する Cisco IOS コンフィギュレーション と Cisco IOS XR コンフィギュレーション間の小さな相違点

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア

no mpls ip propagate-ttl

mpls ip-ttl-propagate disable

mpls label range min max { static ...}

mpls label range { table table-id } min max

ラベル配布プロトコル

ラベル配布プロトコル(Label Distribution Protocol; LDP)に関する Cisco IOS と Cisco IOS XR ソフトウェア間の相違は、OSPF コンフィギュレーションの相違と同様です。LDP コマンドはインターフェイス関連のものも含めてすべて、グローバル mpls ldp コンフィギュレーション サブモードに存在します。 表22 に、LDP コンフィギュレーションの例を示します。

 

表22 Cisco IOS および Cisco IOS XR ソフトウェアにおける LDP コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
mpls label protocol ldp
no tag-switching advertise-tags
tag-switching advertise-tags for ldp-filter
!
interface POS1/0
description OC48
ip address 12.122.5.246 255.255.255.252
no ip directed-broadcast
tag-switching ip
!
interface POS2/0
description DISC
ip address 12.122.3.53 255.255.255.252
no ip directed-broadcast
tag-switching ip
!
 
ip access-list standard ldp-filter
permit 12.122.64.0 0.0.3.255
permit 12.123.64.0 0.0.3.255
!
mpls ldp
label advertise
disable
for ldp_filter
!
interface POS0/1/0/0
!
interface POS0/2/0/0
!
!
 
 
ipv4 access-list ldp_filter
10 permit 12.122.64.0 0.0.3.255
20 permit 12.123.64.0 0.0.3.255
!
 

Cisco IOS XR ソフトウェアには、Cisco IOS ソフトウェアとほぼ同じ LDP 機能もあります。例外は、LDP ターゲット セッションを設定する機能です。Cisco IOS XR ソフトウェアでターゲット hello を受け付けるには、次のコマンド シーケンスを使用します。

mpls ldp
discovery targeted-hello accept
 

Cisco IOS でターゲット hello を受け付けるには、 mpls ldp neighbor nbr targeted コマンド(MPLS LDP コンフィギュレーション サブモードの neighbor nbr targeted コマンド)を実行します。

認証、タイマー調整、グレースフル リスタートなど、その他のコンフィギュレーションはどちらのシステムでも同様です。Cisco IOS XR ソフトウェアがサポートするのは、DU モードだけであることに注意してください。DoD コマンドはサポートされません。

LDP コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Multiprotocol Label Switching Configuration Guide 』の「 Implementing MPLS Label Distribution Protocol on Cisco IOS XR Software 」モジュール

Cisco IOS XR Multiprotocol Label Switching Command Reference 』の「 MPLS Label Distribution Protocol Commands on Cisco IOS XR Software 」モジュール

トラフィック エンジニアリング

Cisco IOS XR ソフトウェアのトラフィック エンジニアリング(TE)コンフィギュレーションは、Cisco IOS ソフトウェアの場合と多少異なります。Cisco IOS ソフトウェアでも Cisco IOS XR ソフトウェアでも、設定する機能はどちらも 4 種類です。

IGP

TE インフラストラクチャ

RSVP(リソース予約プロトコル)

TE トンネル

IGP コンフィギュレーションは、Cisco IOS でも Cisco IOS XR ソフトウェアでも同様です。

Cisco IOS XR ソフトウェアでは、TE および RSVP の両方に専用のサブモードがあります。一方、Cisco IOS ソフトウェアではどちらもサブモードはなく、ほとんどのコンフィギュレーションを物理インターフェイス上で行います。TE トンネル ヘッドエンドのコンフィギュレーションは同様ですが、Cisco IOS XR ソフトウェアでは、トンネル名がトンネルのタイプを表す点が異なります。したがって、各 TE トンネル コマンドの前に tunnel mpls traffic-eng コマンドを指定する必要がなくなります。

表23 に、トンネル ヘッドエンド/テールエンドのペアである、2 つのルータのコンフィギュレーション例を示します。

 

表23 ソフトウェアでのトンネル ヘッドエンド/テールエンド ペアの設定

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
interface Tunnel1
ip unnumbered Loopback0
tunnel destination 192.168.1.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 10 dynamic
 
interface POS6/0
...
mpls traffic-eng tunnels
ip rsvp bandwidth
 
interface POS7/0
...
mpls traffic-eng tunnels
ip rsvp bandwidth
 
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
interface tunnel-te1
ipv4 unnumbered Loopback0
tunnel destination 192.168.1.11
autoroute announce
path-option 10 dynamic
!
 
mpls traffic-eng
interface POS0/6/0/0
!
interface POS0/7/0/0
!
!
 
router ospf 1
mpls traffic-eng area 0
!
 
rsvp
interface POS0/6/0/0
bandwidth
!
interface POS0/7/0/0
bandwidth
!
!

Cisco IOS XR ソフトウェアでは、TE に関連する 4 種類のコンフィギュレーション サブモードがグローバル コンフィギュレーション モードに存在します。トンネル インターフェイス、MPLS トラフィック エンジニアリング、IGP、および RSVP です。Cisco IOS ソフトウェアでは、TE に関連する 3 種類のコンフィギュレーション サブモードがグローバル コンフィギュレーション モードに存在します。トンネル インターフェイス、物理インターフェイス、およびIGP です。

Cisco IOS XR ソフトウェアの IS-IS-TE コンフィギュレーションは、Cisco IOS ソフトウェアの IS-IS コンフィギュレーションと同様です。また、Cisco IOS XR ソフトウェアは、Cisco IOS ソフトウェアがサポートするナロー、トランジション、およびワイド メトリックの全範囲をサポートします。TE コンフィギュレーションは IPv4 アドレス ファミリの中で設定します。

router isis isp
address-family ipv4 unicast
mpls traffic-eng level 2
!
!
 

Cisco IOS XR ソフトウェアにおけるデフォルトのメトリック スタイルは、Cisco IOS ソフトウェアの場合と同様、ナローです。

TE コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Multiprotocol Label Switching Configuration Guide 』の「 Implementing MPLS Traffic Engineering on Cisco IOS XR Software 」モジュール

Cisco IOS XR Multiprotocol Label Switching Command Reference 』の「 MPLS Traffic Engineering Commands on Cisco IOS XR Software 」モジュール

QoS

Cisco XR 12000 シリーズ ルータで最も利用される QoS(Quality of Service)要素は、MQC(モジュラ QoS コマンドライン インターフェイス)です。Cisco IOS の MQC を Cisco IOS XR の MQC に変換する場合、使用するシンタックスは同じです。異なるのは、使用できる機能セットだけです。

表24 に、QoS のコンフィギュレーション例を示します。

 

表24 Cisco IOS および Cisco IOS XR ソフトウェアにおける QoS コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
class-map match-any prec_6_7
match ip precedence 6
match ip precedence 7
class-map match-all prec_1
match ip precedence 1
class-map match-all prec_3
match ip precedence 3
class-map match-any 3P-traffic
match vlan 999 1208
class-map match-all DSCP_AF31
match ip dscp af31
policy-map upstream_qos
class 3P-traffic
service-policy upstream_mapping
policy-map downstream_qos
class 3P-traffic
shape average 500000000 2097144 1
service-policy downstream_mappingip vrf 100008_mm
!
interface GigabitEthernet 8/0
service-policy input upstream_qos
service-policy output downstream_qos
 
class-map match-any 3P_traffic
match vlan 999 1208
!
class-map match-any DSCP_AF31
match dscp af31
!
class-map match-any precedence_1
match precedence 1
!
class-map match-any precedence_3
match precedence 3
!
class-map match-any prec_6_7
match precedence 6
match precedence 7
!
policy-map downstream_qos
class 3P_traffic
shape average 500000000
service-policy downstream_mappingip
!
!
!
policy-map upstream_mapping
class prec_1
set dscp af11
!
class prec_3
set dscp af31
!
!
interface GigabitEtherne0/0/0/0
service-policy input upstream_qos
service-policy output downstream_qos
 

表25 に、Cisco IOS ソフトウェア バージョンで一致する QoS オプションを示します。

 

表25 Cisco IOS および Cisco IOS XR コンフィギュレーションで一致する QoS オプション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア

access-group

any

atm

cos

dscp

fr-dlci

ip

mpls

not

precedence

protocol

qos-group

vlan

access-group

any

discard-class

dscp

mpls

packet

precedence

protocol

qos-group

vlan

表26 に、Cisco IOS および Cisco IOS XR ソフトウェアのポリシー マップ オプションを示します。

 

表26 Cisco IOS および Cisco IOS XR ソフトウェアにおけるポリシー マップ アクション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア

bandwidth

police

priority

queue-limit

random-detect

service-policy

set

dscp

ip

mpls

precedence

atm-clp

cos

discard-class

fr-de

qos-group

shape

bandwidth

police

priority

queue-limit

random-detect

service-policy

set

cos

discard-class

dscp

mpls

precedence

qos-group

srp-priority

shape

クラス マップ オプションは Cisco IOS ソフトウェアの方が Cisco IOS XR ソフトウェアより多いですが、中核の一致オプションである dscp mpls qos-group 、および discard-class は両方にあります。Cisco IOS XR ソフトウェアは atm-clp または fr-de をサポートしませんが、これは Cisco IOS XR ソフトウェアに ATM(非同期転送モード)またはフレームリレー カプセル化のサポートがないからです。

ポリシー マップで実行できるアクションは、ほとんど同じです。

Cisco IOS ソフトウェアの MQC では、ビット/秒、バイト/秒、さらに場合によってはキロビット/秒で帯域幅を計測します。

IOS ソフトウェアの場合、帯域幅に関連するポリシー マップのキーワードおよび計測単位は、次のとおりです。

bandwidth rate_in_kilobits_per_second

police rate_in_bits_per_second bc_bytes be_bytes

shape average cir_bits_per_second bc_bits be_bits

Cisco IOS XR ソフトウェアの場合、あらゆる帯域幅をキロビット/秒で計測します。

bandwidth kilobits_per_secon d

police rate kilobits_per_second bc_kilobits be_kilobits

shape average cir_kilobits_per_second burst_in_kilobits

バイトからキロビットに変換するには、0.008 を乗じます。したがって、64,000 バイトは 512 キロビットです。

その他、Cisco IOS ソフトウェアに存在する QoS 要素は、選択的パケット廃棄(SPD)および受信 ACL です。Cisco IOS XR ソフトウェアには、DoS 攻撃(サービス拒絶攻撃)から保護するローカル パケット トランスポート サービス(LPTS)があります。現在のリリースでは、LPTS を監視できますが、設定はできません。

QoS コンフィギュレーションについては、次のマニュアルを参照してください。

Cisco IOS XR Modular Quality of Service Configuration Guide

Cisco IOS XR Modular Quality of Service Command Reference

IPv6 の設定

IPv6 コンフィギュレーションは、IPv4 コンフィギュレーションと同様です。 表27 を参照してください。

 

表27 Cisco IOS ソフトウェアおよび Cisco IOS XR ソフトウェアにおける IPv6 IS-IS コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
interface POS2/1
ipv6 address FEC0:0:0:14::5/104
ipv6 router isis ispv6
 
router isis ispv6
net 49.0192.0168.0001.0005.00
is-type level-2-only
metric-style wide
redistribute connected
passive-interface Loopback0
!
address-family ipv6
multi-topology
exit-address-family
!
interface POS0/2/0/1
ipv6 address fec0:0:0:14::8/104
 
router isis ispv6
is-type level-2-only
net 49.0192.0168.0001.000.8.00
interface Loopback0
passive
address-family ipv6 unicast
!
!
interface POS0/2/0/1
address-family ipv6 unicast
!
!

Cisco IOS XR ソフトウェアでは、すべてのプレフィクスをリーフ ノードとするシングル トポロジではなく、マルチトポロジ ルーティングを使用します。したがって、Cisco IOS ソフトウェアのアドレス ファミリ コンフィギュレーション モードで、マルチトポロジをイネーブルにする必要があります。

一般に、IPv6 の show コマンドは IPv4 の show コマンドと同じです。Cisco IOS ソフトウェアの show ip ... コマンドの多くは、Cisco IOS XR ソフトウェアの show ipv4 コマンドになっています。また、これらのコマンドのほとんどに、相当する show ipv6 があります。

Cisco IOS XR ソフトウェアでは、3 種類のルーティング プロトコルが IPv6 をサポートします。

IPv6 ユニキャストまたはマルチキャスト アドレス ファミリを使用する BGP

OSPFv3

IPv6 ユニキャスト アドレス ファミリを使用する IS-IS

表27 に、IS-IS コンフィギュレーションを示します。BGP コンフィギュレーションは、IPv6 アドレス ファミリを使用する点を除き、前に示した BGP コンフィギュレーションと同じです。 表28 に、OSPF コンフィギュレーションを示します。OSPF は、1 つのルーティング プロトコルで別々のアドレス ファミリを使用するのではなく、新しい専用ルーティング プロトコル、OSPFv3 を使用します。OSPFv3 コンフィギュレーションは、IPv4 OSPF(別名 OSPFv2)コンフィギュレーションと同様です。

 

表28 Cisco IOS XR ソフトウェアの IPv4 OSPFv2 コンフィギュレーションおよび IPv6 OSPFv3 コンフィギュレーション

Cisco IOS XR OSPFv2(IPv4)
Cisco IOS XR OSPFv3(IPv6)
router ospf 1
log adjacency changes
area 0
interface Loopback0
passive enable
!
interface POS0/1/0/1
!
interface POS0/2/0/0
!
interface POS0/2/0/1
cost 17
!
interface POS0/2/0/2
!
!
!
router ospfv3 1v6
log adjacency changes
area 0
interface Loopback0
passive
!
interface POS0/1/0/1
!
interface POS0/2/0/0
!
interface POS0/2/0/1
cost 17
!
interface POS0/2/0/2
!
!
!

IS-IS または OSPF では、IPv6 対応の MPLS-TE が想定されないので、IGP コンフィギュレーション モードのトラフィック エンジニアリング コマンドは受け入れられません。

Cisco IOS の IPv6 および Cisco IOS XR ソフトウェアの IPv6 はどちらにも、このマニュアルでは扱わない機能があります。

IPv6 コンフィギュレーションの詳細については、次のマニュアルを参照してください。

Cisco IOS XR IP Addresses and Services Configuration Guide

Cisco IOS XR IP Addresses and Services Command Reference

Cisco IOS XR ソフトウェアの問題

ここでは、その他の問題を扱います。

アクセス コントロール リスト

ユーザ名の設定および権限レベル

NTP

HSRPおよびVRRP

ライン コンフィギュレーション

アクセス コントロール リスト

Cisco IOS ソフトウェアには、名前付きおよび番号付きアクセス リスト(ACL)のほかに、標準および拡張アクセス リストがあります。Cisco IOS XR ソフトウェアの場合、名前付きおよび番号付き ACL はありませんが、ASCII 名前文字列として一連の番号を使用できます。 表29 に、標準および拡張 ACL コンフィギュレーションを示します。

Cisco IOS ソフトウェアには、名前付きおよび番号付き ACL を示します。

Cisco IOS XR ソフトウェアには、対応するコンフィギュレーションを示します。

Cisco IOS XR ソフトウェアは、標準または拡張 ACL をサポートしません。Cisco IOS の標準 ACL と同等のものが必要な場合は、送信元 IP アドレスだけを指定して、Cisco IOS XR の ACL を設定します。

Cisco IOS XR ソフトウェアは、 表29 に示したとおり、Cisco IOS ソフトウェアと同等のキーワードをサポートします。

 

表29 Cisco IOS および Cisco IOS XR ソフトウェアにおけるアクセス リストの比較

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
access-list 10 permit 1.1.1.1
access-list 10 permit 10.0.0.0 0.255.255.255
ipv4 access-list ten
10 permit ipv4 host 1.1.1.1 any
20 permit ipv4 10.0.0.0 0.255.255.255 any
access-list 100 permit ip 20.0.0.0 0.0.255.0 any
access-list 100 permit icmp any host 1.2.3.4
ipv4 access-list 100
10 permit ipv4 20.0.0.0 0.0.255.0 any
20 permit icmp any host 1.2.3.4
ip access-list standard test
permit 9.9.9.9
ipv4 access-list test
10 permit ipv4 host 9.9.9.9 any
ip access-list extended moreTest
permit eigrp 1.0.2.0 0.255.0.255 host 7.7.7.6
ipv4 access-list moreTest
10 permit eigrp 1.0.2.0 0.255.0.255 host 7.7.7.6
interface GigabitEthernet4/0
description SX-1
ip address 10.203.1.201 255.255.255.252
ip access-group 111 in
ip access-group 111 out
!
access-list 111 permit ip host 192.117.236.29 any
access-list 111 permit ip host 62.219.160.51 any
access-list 111 permit ip host 62.219.165.7 any
access-list 111 permit ip host 62.219.160.36 any
access-list 111 permit ip 212.25.112.192 0.0.0.31 any
access-list 111 permit ip host 192.117.128.130 any
access-list 111 permit ip host 212.179.16.197 any
!
ip access-list standard BLOCK_RAN
remark Nationwide RAN allocation
deny 239.16.0.0 0.3.255.255
remark Nationwide RAN allocation
deny 239.20.0.0 0.3.255.255
remark Nationwide RAN allocation
deny 239.24.0.0 0.3.255.255
remark Nationwide RAN post-splice allocation
deny 239.28.0.0 0.3.255.255
remark Let all other m-cast pass (OSPF, PIM, etc.)
permit any
 
interface GigabitEthernet0/4/0/0
description SX-1
ipv4 address 10.203.1.201/30
ipv4 access-group acl_111 in
ipv4 access-group acl_111 out
!
ipv4 access-list acl_111
10 permit ip host 192.117.236.29 any
20 permit ip host 62.219.160.51 any
30 permit ip host 62.219.165.7 any
40 permit ip host 62.219.160.36 any
50 permit ip 212.25.112.192 0.0.0.31 any
60 permit ip host 192.117.128.130 any
70 permit ip host 212.179.16.197 any
!
ipv4 access-list BLOCK_RAN
10 remark Nationwide RAN allocation
20 deny 239.16.0.0 0.3.255.255
30 remark Nationwide RAN allocation
40 deny 239.20.0.0 0.3.255.255
50 remark Nationwide RAN allocation
60 deny 239.24.0.0 0.3.255.255
70 remark Nationwide RAN post-splice allocation
80 deny 239.28.0.0 0.3.255.255
90 remark Let all other m-cast pass (OSPF, PIM, etc.)
100 permit any
!

Cisco IOS XR ソフトウェアの場合

アクセス リストに行番号は不要です。行番号を指定しなかった場合、デフォルトで 10 ずつ行番号が増えます。例を参照してください。

ACL のシーケンスを変更できるので、新しい行を追加するスペースがなくなっても、そのスペースを作り出すことができます。

show ipv4 access-lists コマンドを実行すると、次のような結果が得られます。

RP/0/RP/CPU0:router# show ipv4 access-lists test
ipv4 access-list test
10 permit ipv4 11.0.0.0 0.0.0.255 any
11 permit ipv4 12.0.0.0 0.0.0.255 any

ユーザ名の設定および権限レベル

ここでは、CLI ユーザに複数の権限レベルを設定できる、Cisco IOS XR ソフトウェアの強力かつ複雑なツール セットについて簡単に説明します。Cisco IOS ソフトウェアには特権レベルがあります。不正ユーザの特権レベルは 1、イネーブル パスワードが与えられているユーザの特権レベルは 15 です。ネットワークによっては、部分アクセス権に応じてその中間のレベルを使用します。

Cisco IOS XR ソフトウェアには、タスク グループとユーザ グループという概念があり、特権レベルの場合より高い柔軟性が得られます。特定の機能セットにアクセスできるユーザのグループを定義します。該当する機能は debug コマンドのこともあれば、 show コマンドのこともあります。また、コンフィギュレーションのこともあります。ユーザ グループごとに、異なるルータブブンのコンフィギュレーションにアクセスできるので、Cisco IOS の権限のないユーザを正確に変換することは困難です。ただし、最低限、root-system ユーザを設定する必要があります。

root-system ユーザは、Cisco IOS XR のスキームで最も権限のあるユーザであり、本質的に、Cisco IOS ソフトウェアにおける完全イネーブル ユーザと同じです。Cisco IOS XR ソフトウェアでの root-system ユーザのコンフィギュレーションは、次のとおりです。

username user_a
password 7 1042081B
group root-system
 

この例では、作成するユーザの名前は user_a 、パスワードは 12zy89 です。このユーザには、ルータ上であらゆるアクションを実行する権限があります。次のタスク グループを使用すると、権限レベルを引き下げてユーザを容易に設定できます。

cisco-support ― デバッグおよびトラブルシューティング機能、通常はシスコのサポート担当者が使用

netadmin ― ルーティング プロトコル コンフィギュレーションなどの設定作業

operator ― 日常的なモニタリング作業、限定的な設定権

root-system ― システムのあらゆる Secure Domain Router(SDR)を設定して表示する権利

root-lr ― 特定の SDR を設定して表示する権利

sysadmin ― コア ダンプ保管場所のメンテナンス、NTP(ネットワーク タイム プロトコル)の設定などの管理作業

さらに、ユーザ独自のタスク グループ(タスク グループ メンバに与える機能セットを指定)およびユーザ グループ(タスク グループの集合)を定義して、それをユーザ名に結合することができます。タスク グループおよびユーザ グループの定義については、このマニュアルでは扱いませんが、タスク グループおよび Cisco IOS XR の認証モデルを調べてみることを推奨します。『 Cisco IOS XR System Security Configuration Guide 』および『 Cisco IOS XR Getting Started Guide 』を参照してください。

Cisco IOS XR ソフトウェアは Release 3.3.0 から、SDR をサポートしています。SDR ごとに、ユーザ名とアクセス権限の独自のセットがあります。管理 EXEC モードおよび管理コンフィギュレーション モードにアクセスする目的で、root-system ユーザ名を使用できるのは、Designated Shelf Controller(DSC)(ラック 0 のプライマリ RP)上に限られます。その他のユーザ名は、特定の SDR に割り当てられます。システムの SDR がデフォルト SDR だけの場合、各ユーザは同じ RP にログインします。

NTP

表30 に、Cisco IOS XR ソフトウェアおよび Cisco IOS ソフトウェアにおける NTP(ネットワーク タイム プロトコル)コンフィギュレーションを示します。

 

表30 Cisco IOS および Cisco IOS XR ソフトウェアにおける NTP コンフィギュレーション

Cisco IOS
Cisco IOS XR ソフトウェア
ntp server 10.86.202.56
ntp
server 161.44.71.59
!

HSRPおよびVRRP

HSRP(ホットスタンバイ ルータ プロトコル)および VRRP(仮想ルータ冗長プロトコル)のコンフィギュレーションは、Cisco IOS でも Cisco IOS XR ソフトウェアでも同様です。 表31 を参照してください。主な相違は、インターフェイス プロパティをインターフェイス上で直接設定するのではなく、インターフェイスのプロトコル コンフィギュレーション サブモード( router hsrp または router vrrp )で設定する点です。

 

表31 Cisco IOS および Cisco IOS XR ソフトウェアにおける HSRP および VRRP のコンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
interface GigabitEthernet4/0
...
standby 1 ip 1.2.3.4
end
router hsrp
interface GigabitEthernet0/6/0/0
hsrp 1 ipv4 1.2.3.4
!
!
interface GigabitEthernet4/0
...
vrrp 1 ip 1.2.3.4
end
 
router vrrp
interface GigabitEthernet0/6/0/0
vrrp 1 ipv4 1.2.3.4
!
!

ライン コンフィギュレーション

line { console | aux | vty } コンフィギュレーションは、Cisco IOS および Cisco IOS XR ソフトウェアで同様です。コンソールおよび VTY はほとんどのネットワークで設定しますが、補助ポートは Cisco IOS でも Cisco IOS XR ソフトウェアでもあまり使用されません。 表32 に、Cisco IOS から Cisco IOS XR ソフトウェアへの単純な変換例を示します。

 

表32 Cisco IOS および Cisco IOS XR ソフトウェアにおけるライン コンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
aaa authentication login default local
username user_a password 7 09404F0B
line con 0
exec-timeout 0 0
line vty 0 4
password 12zt89
login
!
username user_a
password 7 1042081B
group root-system
!
line console
exec-timeout 0 0
!
telnet ipv4 server enable

Cisco IOS XR ソフトウェアでルータに Telnet を使用させるには、グローバル コマンド telnet ipv4 server enable を設定する必要があります。

SSH(セキュア シェル)サポートは同様です。次のように、 crypto key zeroize および crypto key generate コマンドを使用します。

Cisco IOS XR ソフトウェア ― EXEC モード

Cisco IOS ソフトウェア ― コンフィギュレーション モード

 

表33 Cisco IOS および Cisco IOS XR ソフトウェアにおける SSH (Telnet なし)のコンフィギュレーション

Cisco IOS ソフトウェア
Cisco IOS XR ソフトウェア
aaa authentication login default local
username user_a password 7 09404F0B
line vty 0 4
transport input ssh
!
username user_a
password 7 1042081B
group root-system
!
line console
exec-timeout 0 0
!
ssh server enable

SSH をサポートするには、Cisco IOS ソフトウェアの場合と同様、クリプト サポートが必要です。クリプト サポートを実現するには、k9sec パッケージをインストールします。

Cisco IOS XR ソフトウェアでは、Telnet サーバをイネーブルにするのか、SSH サーバをイネーブルにするのか、またはその両方をイネーブルにするのかによって、 show line vty vty コマンドを実行し、両方のトランスポートを allowed(許可)として表示します。

RP/0/0/CPU0:router# show line vty 0
 
Tty Speed Modem Uses Noise Overruns Acc I/O
vty0 0 - - - 0/0 -/-
 
Line vty0, Location “Unknown”, Type “Unknown”
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 0, 0 parity, 0 stopbits, 0 databits
Template: default
Config:
Allowed transports are telnet ssh.
 

Cisco IOS ソフトウェアでは、トランスポートを許可するということは、そのトランスポートを使用してルータに接続できることを意味します。Cisco IOS XR ソフトウェアでは、サーバとトランスポートの両方をイネーブルにする必要があります。トランスポートはデフォルトでイネーブルです。ルータへのコントロール アクセスを確実にするには、サーバをイネーブルにしてからディセーブルにします。

Cisco IOS ルート マップから Cisco IOS XR RPL への変換

このセクションの内容は、次のとおりです。

RPL の概要

元のルート マップ コンフィギュレーション

単純な変換

コンディショナルのネストによる反復的比較の削減

インラインセットの使用による小規模で間接的な set 参照の排除

パラメータ化による共通構造の再利用

RPL の概要

次のルート マップ、プレフィクス リスト、およびコミュニティ リストで、Routing Policy Language(RPL)への 4 通りの変換を示します。順を追って、使用する言語機能が増え、必要なコンフィギュレーションが少なくなっています。

この例では、いくつかの言語機能を使用して、コンフィギュレーションをモジュラ化する方法を示します。ポリシーの特定の部分をどのように使用するかに応じて、モジュラ化するコンポーネントまたは具体的な部分を決定できます。

RPL と従来のポリシー(ルート マップ、アクセス コントロール リストを含む)の両方を同じ接続ポイントで使用することはできません。たとえば、次のコンフィギュレーションは無効です。

router bgp 2
neighbor 10.0.101.2
address-family ipv4 unicast
route-policy rpl0 in
route-map rm0 in
 

次のコンフィギュレーションは有効です。

router bgp 2
neighbor 10.0.101.2
address-family ipv4 unicast
route-policy rpl0 in
route-map rm0 out
neighbor 10.0.101.3
address-family ipv4 unicast
route-policy rpl1 out
 

次の例では、冗長動作を維持しながら、ルート マップをポリシー言語に変換します。

元のルート マップ コンフィギュレーション

元のルート マップの例を示します。

ip prefix-list 101
10 permit 10.48.0.0/16 le 32
20 permit 172.48.0.0/19 le 32
30 permit 172.10.10.0/24
40 permit 172.11.1.0/24
50 permit 192.168.3.0/24
60 permit 192.168.8.0/21
70 permit 192.168.32.0/21
 
ip prefix-list 102
10 permit 10.48.0.0/16 le 32
20 permit 10.48.0.5/19 le 32
30 permit 172.16.10.0/24
40 permit 172.16.1.0/24
50 permit 172.16.3.0/24
60 permit 192.168.8.0/21
70 permit 192.168.32.0/21
 
 
ip community-list 1
10 permit 10:11
 
ip community-list 2
10 permit 10:12
 
ip community-list 3
10 permit 10:13
 
ip community-list 4
10 permit 10:14
 
route-map sample1-translation-1 permit 10
match ip address prefix-list 101
match community 1
set community 12:34 additive
set metric 11
route-map sample1-translation-1 permit 20
match ip address prefix-list 101
match community 2
set metric 12
set community 12:34 additive
route-map sample1-translation-1 permit 30
match ip address prefix-list 101
match community 3
set metric 13
set community 12:34 additive
route-map sample1-translation-1 permit 40
match ip address prefix-list 101
match community 4
set metric 14
set community 12:34 additive
route-map sample1-translation-1 permit 50
match ip address prefix-list 101
set metric 100
set community 12:34 additive
 
route-map sample2-translation-1 permit 10
match ip address prefix-list 102
match community 1
set community 12:35 additive
set metric 11
route-map sample2-translation-1 permit 20
match ip address prefix-list 102
match community 2
set metric 12
set community 12:35 additive
route-map sample2-translation-1 permit 30
match ip address prefix-list 102
match community 3
set metric 13
set community 12:35 additive
route-map sample2-translation-1 permit 40
match ip address prefix-list 102
match community 4
set metric 14
set community 12:35 additive
route-map sample2-translation-1 permit 50
match ip address prefix-list 102
set metric 100
set community 12:35 additive

単純な変換

このルート マップ コンフィギュレーションからポリシー言語への単純な変換によって、冗長動作が維持されます。次の例を参照してください。

prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
community-set cs1
10:11
end-set
 
community-set cs2
10:12
end-set
 
community-set cs3
10:13
end-set
 
community-set cs4
10:14
end-set
 
route-policy sample1-translation-1a
if destination in ps101 and community matches-any cs1 then
set med 11
set community 12:34 additive
elseif destination in ps101 and community matches-any cs2 then
set med 12
set community 12:34 additive
elseif destination in ps101 and community matches-any cs3 then
set med 13
set community 12:34 additive
elseif destination in ps101 and community matches-any cs4 then
set med 14
set community 12:34 additive
elseif destination in ps101
set med 100
set community 12:34 additive
endif
end-policy
 
route-policy sample2-translation-1a
if destination in ps102 and community matches-any cs1 then
set med 11
set community (12:35) additive
elseif destination in ps102 and community matches-any cs2 then
set med 12
set community (12:35) additive
elseif destination in ps102 and community matches-any cs3 then
set med 13
set community (12:35) additive
elseif destination in ps102 and community matches-any cs4 then
set med 14
set community (12:35) additive
elseif destination in ps102
set med 100
set community (12:35) additive
endif
end-policy

コンディショナルのネストによる反復的比較の削減

コンディショナルをネストして宛先アドレスを 1 回だけテストし、コミュニティを 1 回だけ設定することによって、共通の処理を一体化できます。次の例を参照してください。

prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
community-set cs1
10:11
end-set
 
community-set cs2
10:12
end-set
 
community-set cs3
10:13
end-set
 
community-set cs4
10:14
end-set
 
route-policy sample1-translation-1b
if destination in ps101 then
set community (12:34) additive
if community matches-any cs1 then
set med 11
elseif community matches-any cs2 then
set med 12
elseif community matches-any cs3 then
set med 13
elseif community matches-any cs4 then
set med 14
else
set med 100
endif
endif
end-policy
 
route-policy sample2-translation-1b
if destination in ps102 then
set community (12:35) additive
if community matches-any cs1 then
set med 11
elseif community matches-any cs2 then
set med 12
elseif community matches-any cs3 then
set med 13
elseif community matches-any cs4 then
set med 14
else
set med 100
endif
endif
end-policy

インラインセットの使用による小規模で間接的な set 参照の排除

コミュニティの比較は単純なので、名前付きのコミュニティ セット参照を直接インライン参照に置き換えることができます。その結果、4 種類のコミュニティ セットを定義し、そのそれぞれにコミュニティ値を 1 つだけ指定する必要がなくなります。この置換によって、次のように、2 つのプレフィクス セットと 2 つのポリシーが残ります。

prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
route-policy sample1-translation-1c
if destination in ps101 then
set community (12:34) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy
 
route-policy sample2-translation-1c
if destination in ps102 then
set community (12:35) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy

パラメータ化による共通構造の再利用

次に、共通構造をパラメータ化できる機能を活用して、共通パラメータ化ポリシー( sample-translation-common )を作成して再利用する例を示します。

prefix-set ps101
10.48.0.0/16 le 32
172.48.0.0/19 le 32
172.10.10.0/24
172.11.1.0/24
192.168.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
prefix-set ps102
10.48.0.0/16 le 32
10.48.0.5/19 le 32
172.16.10.0/24
172.16.1.0/24
172.16.3.0/24
192.168.8.0/21
192.168.32.0/21
end-set
 
route-policy sample-translation-common($tag)
set community (12:$tag) additive
if community matches-any (10:11) then
set med 11
elseif community matches-any (10:12) then
set med 12
elseif community matches-any (10:13) then
set med 13
elseif community matches-any (10:14) then
set med 14
else
set med 100
endif
end-policy
 
route-policy sample1-translation-1d
if destination in ps101 then
apply sample-translation-common ($34)
pass
endif
end-policy
 
route-policy sample2-translation-1d
if destination in ps102 then
apply sample-translation-common ($35)
pass
endif
end-policy