Cisco IOS と NX-OS ソフトウェア : Cisco IOS XE 3S

マルチキャスト サービス リフレクションの 実装

マルチキャスト サービス リフレクションの実装
発行日;2012/03/30 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

マルチキャスト サービス リフレクションの実装

機能情報の検索

内容

マルチキャスト サービス リフレクション実装の前提条件

マルチキャスト サービス リフレクション実装の制約事項

マルチキャスト サービス リフレクションの実装について

マルチキャスト サービス リフレクションを使用する利点

ランデブー ポイント

PIM スパース モード

Vif1 インターフェイス

マルチキャスト サービス リフレクション アプリケーション

マルチキャスト サービス リフレクションの実装方法

マルチキャスト サービス リフレクションの設定

マルチキャスト サービス リフレクションの設定例

例:マルチキャストからマルチキャストの宛先への変換

例:マルチキャストからユニキャストの宛先への変換

例:ユニキャストからマルチキャストの宛先への変換

例:マルチキャストからマルチキャストの宛先への分割

例:マルチキャストからユニキャストの宛先への分割

例:ユニキャストからマルチキャストの宛先への分割

参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

マルチキャスト サービス リフレクションの機能情報

用語集

マルチキャスト サービス リフレクションの実装

シスコのマルチキャスト サービス リフレクション機能では、外部で受信したマルチキャストまたはユニキャストの宛先アドレスを、その組織の内部アドレッシング ポリシーに準拠したマルチキャストまたはユニキャストの宛先アドレスに変換できます。この機能を使用すると、Reverse Path Forwarding(RPF; リバース パス転送)を正常に機能させるために、変換境界の外部ソースから自社のネットワーク インフラストラクチャにユニキャスト ルートを再配信する必要はありません。さらに、ネットワークの 2 つの入力点から同じフィードを受け取り、個別にルーティングすることができます。

機能情報の検索

ご使用のソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「マルチキャスト サービス リフレクションの機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

マルチキャスト サービス リフレクション実装の前提条件

必要なインフラストラクチャとともにマルチキャストが可能なネットワークを設定して、Protocol Independent Multicast Sparse Mode(PIM-SM; Protocol Independent Multicast スパース モード)、Bidirectional PIM(bidir-PIM; 双方向 PIM)、または PIM Source Specific Multicast(PIM-SSM)を実行します。設定プロセスに、RP、インターフェイス境界、または SSM 範囲の設定が含まれることがあります。

設定情報については、『 Configuring Basic IP Multicast 』モジュールを参照してください。

マルチキャスト サービス リフレクション用仮想インターフェイス(Vif1 インターフェイス)が境界ルータにインストールされ、マルチキャスト サービス リフレクション アプリケーションがインストールされ、動作することを確認します。

各アクティブ レシーバが、PIM ドメインのルータで定義されているマルチキャスト グループに Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)加入を開始する必要があります。

マルチキャスト サービス リフレクション実装の制約事項

PIM-SSM を使用する場合のように、異なる送信元から同じマルチキャスト グループに向けて送信されるマルチキャスト パケットのグループを変換する場合、特定の SSM グループ宛のすべてのマルチキャスト パケットは、変換の発生後に 1 つの (S,G) にマッピングされます。たとえば、(10.1.1.1, 232.1.1.1) および (10.1.1.2, 232.1.1.1) に変換が必要な場合、これらは単一のエントリ、たとえば (192.168.1.2, 232.239.1.1) のように見えます。ここで、192.168.1.2 は、Vif1 IP サブネットの内側にある IP アドレスです。

PIM/IGMP 制御パケットは変換されません。

マルチキャスト サービス リフレクションの実装について

「マルチキャスト サービス リフレクションを使用する利点」

「ランデブー ポイント」

「Vif1 インターフェイス」

「マルチキャスト サービス リフレクション アプリケーション」

マルチキャスト サービス リフレクションを使用する利点

外部で受信したマルチキャストまたはユニキャストの宛先アドレスを自社の内部アドレッシング ポリシーに準拠したマルチキャストまたはユニキャスト アドレスに変換できます。この機能により、コンテンツ プロバイダーが使用しているプライベート アドレッシング スキームとサービス プロバイダーが使用しているパブリック アドレッシングを分離できます。次の変換タイプがサポートされています。

マルチキャストからマルチキャストの宛先への変換

マルチキャストからユニキャストの宛先への変換

ユニキャストからマルチキャストの宛先への変換

マルチキャストからマルチキャストの宛先への分割

マルチキャストからユニキャストの宛先への分割

ユニキャストからマルチキャストの宛先への分割

プライベートとパブリックのマルチキャスト ネットワークを論理的に分離できます。

同じ発信インターフェイスから変換済みまたは未変換のマルチキャスト パケットを転送する柔軟性を提供します。

ネットワークの 2 つの入力点から同じフィードを受信し、個別にルーティングできるようにすることで、冗長性を提供します。

ユーザが選択したサブネットを送信元ネットワークとして使用し、適切に範囲を設定できます。

ランデブー ポイント

Rendezvous Point(RP;ランデブー ポイント)は、PIM-SM または双方向 PIM で動作する場合にルータが実行するロールです。RP は、PIM-SM または双方向 PIM を実行するネットワークでのみ必要です。PIM-SM では、マルチキャスト データを明示的に要求したアクティブなレシーバを含むネットワーク セグメントだけにトラフィックが転送されます。

RP は、マルチキャスト データのソースとレシーバの接点として機能します。PIM-SM ネットワークでは、まず、ソースと直接接続されたファースト ホップ指定ルータが RP にトラフィックを送信します。このトラフィックは、それから共有配信ツリーを下ってレシーバに転送されます。デフォルトでは、レシーバと直接接続されたラスト ホップ ルータが共有ツリーからトラフィックを受信すると、即座に最短パス ツリー スイッチオーバーを実行し、ソースに加入メッセージを送信し、ソースとレシーバの間でソースベースの配信ツリーを送信します。

PIM スパース モード

PIM Sparse Mode(PIM-SM; PIM スパース モード)は、プル モデルを使用してマルチキャスト トラフィックを配信します。明示的にデータを要求したアクティブなレシーバを含むネットワーク セグメントだけがトラフィックを受信します。

デンス モードのインターフェイスと異なり、スパース モードのインターフェイスは、ダウンストリームのルータから定期的に加入メッセージを受信する場合またはインターフェイスに直接接続のメンバがある場合のみマルチキャスト ルーティング テーブルに追加されます。LAN から転送する場合、グループが認識している RP があれば、SM 動作が行われます。その場合、パケットはカプセル化され、その RP に送信されます。認識している RP がなければ、パケットは DM 方式でフラッディングされます。特定のソースからのマルチキャスト トラフィックが十分である場合、レシーバのファースト ホップ ルータは、ソース ベースのマルチキャスト配信ツリーを構築するために加入メッセージをソースに向けて送信できます。

PIM-SM は、共有ツリー上のデータ パケットを転送することで、アクティブなソースに関する情報を配信します。PIM-SM は少なくとも最初は共有ツリーを使用するので、Rendezvous Point(RP; ランデブー ポイント)を使用する必要があります。RP は管理上メットワークで設定されている必要があります。

スパース モードでは、ルータは、トラフィックに対する明示的な要求がない限り、他のルータはグループのマルチキャスト パケットを転送しないと見なします。ホストがマルチキャスト グループに加入すると、直接接続されたルータは RP に PIM 加入メッセージを送信します。RP はマルチキャスト グループを追跡します。マルチキャスト パケットを送信するホストは、そのホストのファースト ホップ ルータによって RP に登録されます。その後、RP は、ソースに加入メッセージを送信します。この時点で、パケットが共有配信ツリー上で転送されます。特定のソースからのマルチキャスト トラフィックが十分である場合、ホストのファースト ホップ ルータは、ソース ベースのマルチキャスト配信ツリーを構築するために加入メッセージをソースに向けて送信できます。

ソースと直接接続されたファーストホップ指定ルータは RP に登録され、データは共有ツリーを下ってレシーバに転送されます。エッジ ルータは、RP を介してソースから共有ツリーでデータ パケットを受信するときに、そのソースについて学習します。次に、エッジ ルータは、そのソースに向けて PIM (S, G)加入メッセージを送信します。リバース パスに沿った各ルータは、RP アドレスのユニキャスト ルーティング メトリックをソース アドレスのメトリックと比較します。ソース アドレスのメトリックの方が良い場合は、ソースに向けて PIM (S, G) 加入メッセージを転送します。RP のメトリックが同等以上の場合、PIM (S, G) 加入メッセージは、RP と同じ方向で送信されます。この場合、共有ツリーとソース ツリーは一致すると見なされます。

共有ツリーがソースとレシーバの間の最適なパスでない場合、ルータは動的にソース ツリーを作成し、共有ツリーの下方向へのトラフィック フローを停止します。この動作は、シスコ ソフトウェアのデフォルトの動作です。ネットワーク管理者は、 ip pim spt-threshold infinity コマンドを使用して、トラフィックを強制的に共有ツリー上で保持することができます。

PIM-SM は、WAN リンク付きのネットワークを含む、任意のサイズのネットワークに合わせて拡大または縮小します。明示的な加入メカニズムによって、不要なトラフィックが WAN リンクでフラッディングするのを防ぎます。

Vif1 インターフェイス

Vif1 インターフェイスは、ループバック インターフェイスと似ています。ルータがアクティブのときは常に動作している論理 IP インターフェイスです。

Vif1 インターフェイスは、独自の一意のサブネットに置く必要があります。また、そのサブネットは、Interior Gateway Protocol(IGP)アップデート(RIP、EIGRP、OSPF、IS-IS)でアドバタイズする必要があります。

Vif1 インターフェイスは、入力インターフェイス、プライベートからパブリックへの mgroup マッピング、マスク長(プール範囲を定義)および変換済みのパケットのソースに関する情報を維持します。

マルチキャスト サービス リフレクション アプリケーション

シスコのマルチキャスト サービス リフレクションは、シスコ ソフトウェアの割り込みレベル スイッチングで動作するアプリケーションで、シスコ ソフトウェアによって Vif1 インターフェイスに転送されるパケットを処理します。送信元 IP アドレスのみを変換する IP マルチキャスト Network Address Translation(NAT; ネットワーク アドレス変換)とは異なり、IP リフレクト サービスは送信元と宛先両方のアドレスを変換します。マルチキャスト サービス リフレクションは、新しいマルチキャスト グループにまだ移動していないユーザが未変換のストリームを受信する必要がある場合に特に役立ちます。

マルチキャスト サービス リフレクションは、インターフェイス コマンドを使用して実装します。設定された各マルチキャスト サービス リフレクション コマンドは、シスコのユニキャストまたはマルチキャスト パケット ルーティングによって Vif1 インターフェイスに送信されたパケットで実行されるパケット照合およびリライト操作を設定します。照合およびリライトされたパケットは、シスコのユニキャストまたはマルチキャスト パケット ルーティングに戻され、インターフェイスから到着した他のパケットのように処理されます。

Vif1 インターフェイスは、元のストリーム用のレシーバで、新しいストリームが Vif1 サブネットに直接接続された送信元から来たように見せます。Vif1 インターフェイスは、アクティブ ソースの Designated Router(DR; 代表ルータ)で、適切な RP に登録されます。

複数のマルチキャスト サービス リフレクションの動作を同じパケットに合うように設定できます。これによって、同一の受信トラフィックを複数の宛先アドレスに対して複製できます。

マルチキャスト サービス リフレクションの実装方法

「マルチキャスト サービス リフレクションの設定」

マルチキャスト サービス リフレクションの設定

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing { [ vrf vrf-name ] distributed }

4. interface type number

5. ip pim sparse-mode

6. no shutdown

7. exit

8. それぞれの PIM インターフェイスでステップ 4 ~ 7 を繰り返します。

9. interface Vif1

10. ip address ip-address mask [ secondary ]

11. ip pim sparse-mode

12. ip service reflect input-interface destination destination-address to new-destination-address mask-len number source new-source-address

13. ip igmp static-group { * | group-address [ source { source-address | ssm-map }]}

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing {[ vrf vrf-name ] distributed }

 

Router(config)# ip multicast-routing distributed

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface gigabitethernet 0/0/0

特定のインターフェイス タイプおよび番号のインターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスで PIM スパース モードをイネーブルにします。

ステップ 6

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

それぞれの PIM インターフェイスでステップ 4 ~ 7 を繰り返します。

--

ステップ 9

interface Vif1

 

Router(config)# interface Vif1

Vif1 インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 10

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.1.1.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 11

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスで PIM スパース モードをイネーブルにします。

ステップ 12

ip service reflect input-interface destination destination-address to new-destination-address mask-len number source new-source-address

 

Router(config-if)# ip service reflect gigabitethernet 0/0/0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source 10.1.1.2

Vif1 インターフェイスにルーティングされたマルチキャスト パケットを照合し、リライトします。

照合およびリライトされたパケットは、シスコのマルチキャスト パケット ルーティング(または宛先がユニキャストの場合はユニキャスト ルーティング)に戻され、インターフェイスから到着した他のパケットのように処理されます。

ステップ 13

ip igmp static-group { * | group-address [ source { source-address | ssm-map }]}

 

Router(config-if)# ip igmp static-group 224.1.1.1

インターフェイス上で指定グループのスタティックに接続されたメンバとしてルータを設定し、マルチキャスト グループ宛のトラフィックをインターフェイスに転送します。

この手順は、マルチキャストからマルチキャストおよびマルチキャストからユニキャストへのシナリオのみに適用されます。

ステップ 14

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

マルチキャスト サービス リフレクションの設定例

「例:マルチキャストからマルチキャストの宛先への変換」

「例:マルチキャストからユニキャストの宛先への変換」

「例:ユニキャストからマルチキャストの宛先への変換」

「例:マルチキャストからマルチキャストの宛先への分割」

「例:マルチキャストからユニキャストの宛先への分割」

「例:ユニキャストからマルチキャストの宛先への分割」

例:マルチキャストからマルチキャストの宛先への変換

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(マルチキャストからマルチキャストの宛先への変換)を実装する方法を示します。マルチキャストからマルチキャストの宛先への変換では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのマルチキャスト宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠したマルチキャスト宛先アドレスに変換できます。

この例では、図 1 に示すトポロジを使用します。

図 1 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(マルチキャストからマルチキャストの宛先への変換)例のトポロジ

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 にはループバック インターフェイスがあり、224.1.1.0/24 アドレス範囲の RP として動作します。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2 にはループバック インターフェイスがあり、239.2.2.0/24 アドレス範囲の RP として動作します。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

!

configure terminal

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

! Configure the loopback interface for the Service Provider RP

!

interface loopback 0

ip address 192.168.2.1 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.2.1 mcast-content-provider-groups override

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

!

! Configure the Vif1 virtual interface for multicast service reflection

!

interface Vif1

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source 10.1.1.2

ip igmp static-group 224.1.1.0

ip igmp static-group 224.1.1.1

ip igmp static-group 224.1.1.2

ip igmp static-group 224.1.1.3

.

.

.

ip igmp static-group 224.1.1.255

 

サービス プロバイダー ネットワークで RP として動作するルータ(R2)で次のコマンドを入力します。

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

interface loopback 0

ip address 192.168.2.2 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

!

サービス プロバイダー ネットワークの他のすべてのルータ(R3)で次のコマンドを入力します。

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

end

 

例:マルチキャストからユニキャストの宛先への変換

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(マルチキャストからユニキャストの宛先への変換)を実装する方法を示します。マルチキャストからユニキャストの宛先への変換では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのマルチキャストの宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠したユニキャストの宛先アドレスに変換できます。

この例では、図 2 に示すトポロジを使用します。

図 2 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(マルチキャストからユニキャストの宛先への変換)例のトポロジ

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 にはループバック インターフェイスがあり、224.1.1.0/24 アドレス範囲の RP として動作します。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2 と R3 は、サービス プロバイダー ネットワークでユニキャスト ルーティングのみを実行する非 PIM 対応ルータです。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

configure terminal

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

! Configure the loopback interface for the Service Provider RP

!

interface loopback 0

ip address 192.168.2.1 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.2.1 mcast-content-provider-groups override

ip access-list standard mcast-content-provider-groups permit 224.1.1.10 0.0.0.255

!

! Configure the Vif1 virtual interface for multicast service reflection

!

interface Vif1

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 10.3.3.0 mask-len 24 source 10.1.1.2

end

例:ユニキャストからマルチキャストの宛先への変換

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(ユニキャストからマルチキャストの宛先への変換)を実装する方法を示します。ユニキャストからマルチキャストの宛先への変換では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのユニキャストの宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠したマルチキャストの宛先アドレスに変換できます。

この例では、図 3 に示すトポロジを使用します。

図 3 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(ユニキャストからマルチキャストの宛先への変換)例のトポロジ

 

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2 にはループバック インターフェイスがあり、239.3.3.0/24 アドレス範囲の RP として動作します。

ルータ R3 は、サービス プロバイダーの PIM ドメインの別のエッジ ルータです。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

configure terminal

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

!

! Configure the Vif1 virtual interface for multicast service reflection

!

interface Vif1

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip service reflect GigabitEthernet 0/0/0 destination 10.1.1.2 to 239.3.3.2 mask-len 32 source 10.1.1.2

 

サービス プロバイダー ネットワークで RP として動作するルータ(R2)で次のコマンドを入力します。

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

 

interface loopback 0

ip address 192.168.2.2 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

 

サービス プロバイダー ネットワークの他のすべてのルータ(R3)で次のコマンドを入力します。

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

 

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

end

例:マルチキャストからマルチキャストの宛先への分割

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(マルチキャストの 1 つのストリームが 2 つの一意のマルチキャスト ストリームに変換されるマルチキャストからマルチキャストの宛先への分割)の実装方法を示します。マルチキャストからマルチキャストの宛先への分割では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのマルチキャスト宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠した複数のマルチキャスト宛先アドレスに変換できます。

この例では、図 4 に示すトポロジを使用します。

図 4 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(マルチキャストからマルチキャストの宛先への分割)例のトポロジ

 

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 には設定済みのループバックがあり、224.1.1.0/24 アドレス範囲の RP として動作します。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2 と R4 には複数のループバック インターフェイスがあり、239.2.2.0 と 239.3.3.0 のアドレス範囲でエニーキャスト RP として動作します。

ルータ R3 と R5 は、サービス プロバイダーの RIM ドメインのエッジ ルータです。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

 
configure terminal
ip multicast-routing distributed
interface <all IP numbered interfaces>
ip pim sparse-mode
no shutdown
!
! Configure the loopback interface for the Service Provider RP
!
interface loopback 0
ip address 192.168.2.1 255.255.255.255
ip pim sparse-mode
!
ip pim rp-address 192.168.2.1 mcast-content-provider-groups override
ip pim rp-address 192.168.0.254 mcast-service-provider-groups override
ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255
ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255
ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255
 
!

! Configure the Vif1 virtual interface for multicast service reflection

!

interface Vif1

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source 10.1.1.2

ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 239.3.3.0 mask-len 24 source 10.1.1.2

ip igmp static-group 224.1.1.0

ip igmp static-group 224.1.1.1

ip igmp static-group 224.1.1.2

ip igmp static-group 224.1.1.3

.

.

.

ip igmp static-group 224.1.1.254

 

サービス プロバイダー ネットワークのエニーキャスト RP である R2 ルータで次のコマンドを入力します。

 

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

interface loopback 0

ip address 192.168.2.2 255.255.255.255

ip pim sparse-mode

interface loopback 1

description --- Anycast RP ---

ip address 192.168.0.254 255.255.255.255

ip pim sparse-mode

!

ip msdp peer 192.168.2.3 connect-source Loopback0

ip msdp originator-id Loopback0

!

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

 

サービス プロバイダー ネットワークのエニーキャスト RP である R4 ルータで次のコマンドを入力します。

 

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

interface loopback 0

ip address 192.168.2.3 255.255.255.255

ip pim sparse-mode

interface loopback 1

ip address 192.168.0.254 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

!

ip msdp peer 192.168.2.2 connect-source Loopback0

ip msdp originator-id Loopback0

 

サービス プロバイダー ネットワークの R3 および R5 ルータで次のコマンドを入力します。

ip multicast-routing distributed

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

permit 239.3.3.0 0.0.0.255

!

例:マルチキャストからユニキャストの宛先への分割

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(マルチキャストの 1 つのストリームが 2 つの一意のユニキャスト ストリームに変換されるマルチキャストからユニキャストの宛先への分割)の実装方法を示します。マルチキャストからユニキャストの宛先への分割では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのマルチキャストの宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠した複数のユニキャストの宛先アドレスに変換できます。

この例では、図 5 に示すトポロジを使用します。

図 5 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(マルチキャストからユニキャストの宛先への分割)例のトポロジ

 

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 は、224.1.1.0/24 アドレス範囲の RP として動作します。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2、R3、R4、および R5 は、PIM 対応ではなく、サービス プロバイダー ネットワークでユニキャスト ルーティングのみを実行します。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

 
configure terminal
ip multicast-routing distributed
interface <all IP numbered interfaces>
ip pim sparse-mode
no shutdown
!
! Configure the loopback interface for the Service Provider RP
!
interface loopback 0
ip address 192.168.2.1 255.255.255.255
ip pim sparse-mode
!
ip pim rp-address 192.168.2.1 mcast-content-provider-groups override
ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255
!
! Configure the Vif1 virtual interface for multicast service reflection
!
interface Vif1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 10.3.3.0 mask-len 24 source 10.1.1.2
ip service reflect GigabitEthernet 0/0/0 destination 224.1.1.0 to 10.5.5.0 mask-len 24 source 10.1.1.2
ip igmp static-group 224.1.1.0
ip igmp static-group 224.1.1.1
ip igmp static-group 224.1.1.2
ip igmp static-group 224.1.1.3
.
.
.
ip igmp static-group 224.1.1.255
!
end

例:ユニキャストからマルチキャストの宛先への分割

次の例では、サービス プロバイダー ネットワークでマルチキャスト サービス リフレクション(ユニキャストの 1 つのストリームが 2 つの一意のマルチキャスト ストリームに変換されるユニキャストからマルチキャストの宛先への分割)の実装方法を示します。ユニキャストからマルチキャストの宛先への分割では、サービス プロバイダーは、外部で受信したコンテンツ プロバイダーのユニキャストの宛先アドレスを、サービス プロバイダーの内部アドレッシング ポリシーに準拠したマルチキャストの宛先アドレスに変換できます。

この例では、図 6 に示すトポロジを使用します。

図 6 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション(ユニキャストからマルチキャストの宛先への分割)例のトポロジ

 

 

この例のトポロジでは、コンテンツ プロバイダーはサービス プロバイダーに金融市場情報を送信しています。サービス プロバイダーはその情報をアクティブなレシーバ(証券会社)に送信します。サービス プロバイダーは複数のコンテンツ プロバイダーから市場データを受け取っている可能性があります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。

ルータ R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクション アプリケーションを実行しています。

ルータ R2 と R4 には複数のループバック インターフェイスがあり、239.2.2.0 と 239.3.3.0 のアドレス範囲でエニーキャスト RP として動作します。

ルータ R3 と R5 は、サービス プロバイダーの RIM ドメインの他のエッジ ルータです。

マルチキャスト サービス リフレクション アプリケーションを実行するルータ(R1)で次のコマンドを入力します。

 
configure terminal
ip multicast-routing distributed
interface <all IP numbered interfaces>
ip pim sparse-mode
no shutdown
!
ip pim rp-address 192.168.2.1 mcast-content-provider-groups override
ip pim rp-address 192.168.0.254 mcast-service-provider-groups override
ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255
ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255
ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255
!
! Configure the Vif1 virtual interface for multicast service reflection
!
interface Vif1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip service reflect GigabitEthernet 0/0/0 destination 10.1.1.2 to 239.3.3.2 mask-len 32 source 10.1.1.2
ip service reflect GigabitEthernet 0/0/0 destination 10.1.1.2 to 239.2.2.2 mask-len 32 source 10.1.1.2

 

 

サービス プロバイダー ネットワークでエニーキャスト RP として動作する R2 ルータで次のコマンドを入力します。

 

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

interface loopback 0

ip address 192.168.2.2 255.255.255.255

ip pim sparse-mode

interface loopback 1

description --- Anycast RP ---

ip address 192.168.0.254 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

!

ip msdp peer 192.168.2.3 connect-source Loopback0

ip msdp originator-id Loopback0

サービス プロバイダー ネットワークでエニーキャスト RP として動作する R4 ルータで次のコマンドを入力します。

 
ip multicast-routing distributed
interface <all IP numbered interfaces>
ip pim sparse-mode
no shutdown
!
interface loopback 0
ip address 192.168.2.3 255.255.255.255
ip pim sparse-mode
interface loopback 1
description --- Anycast RP ---
ip address 192.168.0.254 255.255.255.255

ip pim sparse-mode

!

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

 

ip msdp peer 192.168.2.2 connect-source Loopback0

ip msdp originator-id Loopback0

 

サービス プロバイダー ネットワークの他のすべてのルータで次のコマンドを入力します。

 

ip multicast-routing distributed

interface <all IP numbered interfaces>

ip pim sparse-mode

no shutdown

!

ip pim rp-address 192.168.0.254 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.3.3.0 0.0.0.255

end

参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

マルチキャスト コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項および例

Cisco IOS IP Multicast Command Reference

標準

標準
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

マルチキャスト サービス リフレクションの機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 マルチキャスト サービス リフレクションの機能情報

機能名
リリース
機能情報

マルチキャスト サービス リフレクション

Cisco IOS XE リリース 3.3S

シスコのマルチキャスト サービス リフレクション機能では、外部で受信したマルチキャストまたはユニキャストの宛先アドレスを、その組織の内部アドレッシング ポリシーに準拠したマルチキャストまたはユニキャストの宛先アドレスに変換できます。この機能を使用すると、Reverse Path Forwarding(RPF; リバース パス転送)を正常に機能させるために、変換境界の外部ソースから自社のネットワーク インフラストラクチャにユニキャスト ルートを再配信する必要はありません。さらに、ネットワークの 2 つの入力点から同じフィードを受け取り、個別にルーティングすることができます。

次のセクションで、この機能に関する情報を参照できます。

「マルチキャスト サービス リフレクションの実装について」

「マルチキャスト サービス リフレクションの実装方法」

コマンド ip service reflect、ip multicast-routing が導入または変更されました。

用語集

Protocol Independent Multicast(PIM):既存の IP ネットワークでの IP マルチキャスト ルーティングを可能にする、IETF によって規定されたマルチキャスト ルーティング アーキテクチャ。OSPF や BGP などの基礎となるユニキャスト プロトコルから独立している点が重要です。

Rendezvous Point(RP; ランデブー ポイント):PIM-SM 共有マルチキャスト配信ツリーのルートとなるマルチキャスト ルータ。

ソース ツリー:ソースとレシーバの代表ルータ(またはランデブー ポイント)を直接接続し、ネットワークの最短パスを取得するマルチキャスト配信パス。この結果、ソースとレシーバの間で最も効率的なデータ ルーティングが可能となりますが、RP 以外で構築された場合、ネットワーク全体で不要なデータが複製されることもあります。

配信ツリー:マルチキャスト トラフィックは、すべてのソースをグループ内のすべてのレシーバに接続する配信ツリー上で、ソースからマルチキャスト グループに流れます。このツリーは、すべてのソースで共有できます(共有ツリー)。または、各ソースに個別の配信ツリーを作成することもできます(ソース ツリー)。共有ツリーは一方向または双方向です。

マルチキャスト:IP トラフィックを 1 つのソースまたは複数のソースから送信し、複数の宛先に配信できるルーティング手法。各宛先に、個々のパケットを送信する代わりに、マルチキャスト グループと呼ばれる宛先のグループに 1 つのパケットが送信されます。このグループは 1 つの IP 宛先グループ アドレスで識別されます。マルチキャスト アドレッシングは、複数ホストへの 1 つの IP データグラムの転送をサポートします。

ユニキャスト:各要求者に個別にメッセージのコピーを送信するようにソースに要求するポイントツーポイント送信。