インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
GRE IPv6 トンネル
GRE IPv6 トンネル

GRE IPv6 トンネル

GRE IPv6 トンネル機能は、他のプロトコルから IPv6 ネットワークを介したパケット配信をイネーブルにして、グローバルにルーティングされた IPv6 アドレスのパブリック ネットワークを介したプライベート ネットワーク間で、IPv6 パケットのルーティングが可能になります。 総称ルーティング カプセル化(GRE)は、ブロードキャストおよびマルチキャスト トラフィック(マルチキャスト ストリーミングまたはルーティング プロトコル)をカプセル化するメリットを提供するユニキャスト プロトコルであるか、その他の非 IP プロトコルで、IPsec によって保護されています。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

GRE IPv6 トンネルの制約事項

  • GRE トンネル キープアライブ パケットはサポートされません。

  • マルチポイント GRE(mGRE)IPv6 トンネリングはサポートされていません。

  • 仮想ルーティングおよび転送(VRF)ではトンネル トランスポートのサポートが限られています。 VRF での限定サポートは、トンネル保護を使用しない Ipv6 ポイントツーポイント GRE に適用できます。

GRE IPv6 トンネルに関する情報

GRE IPv6 トンネルの概要

GRE IPv6 トンネル機能は、他のプロトコルから IPv6 ネットワークを介したパケット配信をイネーブルにして、グローバルにルーティングされた IPv6 アドレスのパブリック ネットワークを介したプライベート ネットワーク間で、IPv6 パケットのルーティングが可能になります。

ポイントツーポイント GRE トンネルでは、各トンネル インターフェイスは、設定時にトンネル送信元 IPv6 アドレスおよびトンネル宛先の IPv6 アドレスを必要とします。 すべてのパケットは、外部 IPv6 ヘッダーと GRE ヘッダーでカプセル化されます。

GRE IPv6 トンネル保護

GRE IPv6 トンネル保護により、デバイスをセキュリティ ゲートウェイとして動作させ、他のセキュリティ ゲートウェイ デバイス間に IPsec トンネルを確立し、トラフィックがパブリック IPv6 インターネットから送信される場合に内部ネットワークからのトラフィックに対する暗号化 IPsec 保護を提供できます。 GRE IPv6 トンネル保護機能は、IPv4 GRE トンネル保護を使用したセキュリティ ゲートウェイ モデルと似ています。

GRE IPv6 トンネルの設定方法

GRE IPv6 トンネルの設定

IPv6 ネットワーク上で GRE トンネルを設定するには、次の作業を実行します。 GRE トンネルは、IPv6 ネットワーク層を介して送出し、IPv6 トンネルを介して IPv6 パケットと IPv4 パケットを転送するように設定できます。

はじめる前に

GRE IPv6 トンネルが設定されている場合、IPv6 アドレスは、トンネル送信元およびトンネル宛先に割り当てられます。 トンネル インターフェイスは、IPv4 または IPv6 アドレスのいずれかにすることができます(このことは、以降の作業では示されていません)。 設定されたトンネルの両端にあるホストまたはデバイスは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    tunnel source {ipv6-address | interface-type interface-number}

    5.    tunnel destination ipv6-address

    6.    tunnel mode gre ipv6

    7.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。

     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 0
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 tunnel source {ipv6-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source ethernet 0
     

    送信元 IPv6 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

    • インターフェイスのタイプと番号が指定されている場合、そのインターフェイスは IPv6 アドレスを使用して設定する必要があります。

    (注)     

    このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 5 tunnel destination ipv6-address


    例:
    Device(config-if)# tunnel destination 2001:0DB8:0C18:2::300
     

    トンネル インターフェイスの宛先 IPv6 アドレスを指定します。

    (注)     

    このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 6 tunnel mode gre ipv6


    例:
    Device(config-if)# tunnel mode gre ipv6
     

    GRE IPv6 トンネルを指定します。

    (注)     

    tunnel mode gre ipv6 コマンドでは、GRE をトンネル インターフェイスのカプセル化プロトコルとして指定します。 このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 7 end


    例:
    Device(config-if)# end
     

    インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     

    GRE IPv6 トンネル保護の設定

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface tunnel tunnel-number

      4.    tunnel source {ipv6-address | interface-type interface-number}

      5.    tunnel destination ipv6-address

      6.    tunnel mode gre ipv6

      7.    tunnel protection ipsec profile profile-name

      8.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。

       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface tunnel tunnel-number


      例:
      Device(config)# interface tunnel 0
       

      トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 4 tunnel source {ipv6-address | interface-type interface-number}


      例:
      Device(config-if)# tunnel source ethernet 0
       

      送信元 IPv6 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

      • インターフェイスのタイプと番号が指定されている場合、そのインターフェイスは IPv6 アドレスを使用して設定する必要があります。

      (注)     

      このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

       
      ステップ 5 tunnel destination ipv6-address


      例:
      Device(config-if)# tunnel destination 2001:0DB8:0C18:2::300
       

      トンネル インターフェイスの宛先 IPv6 アドレスを指定します。

      (注)     

      このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

       
      ステップ 6 tunnel mode gre ipv6


      例:
      Device(config-if)# tunnel mode gre ipv6
       

      GRE IPv6 トンネルを指定します。

      (注)     

      tunnel mode gre ipv6 コマンドでは、GRE をトンネル インターフェイスのカプセル化プロトコルとして指定します。 このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

       
      ステップ 7 tunnel protection ipsec profile profile-name


      例:
      Device(config-if)# tunnel protection ipsec profile ipsec-profile
       

      トンネル インターフェイスを IPsec プロファイルに関連付けます。

      (注)     

      profile-name 引数の場合、グローバル コンフィギュレーション モードで設定された IPsec プロファイルを指定します。

       
      ステップ 8 end


      例:
      Device(config-if)# end
       

      インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

       

      GRE IPv6 トンネルの設定例

      例:GRE IPv6 トンネルの設定

      IPv6 トランスポートで GRE トンネルを設定する方法の例を次に示します。 この例では、イーサネット 0/0 は IPv6 アドレスを備えており、これがトンネル インターフェイスが使用する送信元アドレスとなります。 トンネルの宛先 IPv6 アドレスは直接指定されます。 この例では、トンネルは IPv4 トラフィックおよび IS-IS トラックの両方を伝送します。

      interface Tunnel0
       ip address 10.1.1.1 255.255.255.0
       ip router isis 
       tunnel source Ethernet0/0
       tunnel destination 2001:DB8:1111:2222::1
       tunnel mode gre ipv6
      !
      interface Ethernet0/0
       no ip address
       ipv6 address 2001:DB8:1111:1111::1/64
      !
      router isis 
       net 49.0001.0000.0000.000a.00

      例:GRE IPv6 トンネル保護の設定

      次に、GRE IPv6 トンネル インターフェイスに IPsec プロファイル「ipsec-profile」を関連付ける方法の例を示します。 IPSec プロファイルは、crypto ipsec profile コマンドを使用して設定します。

      crypto ipsec profile ipsec-profile
       set transform-set ipsec-profile
      !
      interface Tunnel1
       ip address 192.168.1.1 255.255.255.252
       tunnel source FastEthernet2/0
       tunnel destination 10.13.7.67
       tunnel protection ipsec profile ipsec-profile

      その他の関連資料

      関連資料

      関連項目

      マニュアル タイトル

      Cisco IOS コマンド

      『Master Commands List, All Releases』

      トンネル コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

      『Interface and Hardware Component Command Reference』

      IPv6 コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

      『IPv6 Command Reference』

      テクニカル サポート

      説明

      リンク

      右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      GRE IPv6 トンネルの機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

      表 1 GRE IPv6 トンネルの機能情報

      機能名

      リリース

      機能情報

      GRE IPv6 トンネル

      Cisco IOS XE Release 3.7S

      GRE IPv6 トンネル機能は、他のプロトコルから IPv6 ネットワークを介したパケット配信をイネーブルにして、グローバルにルーティングされた IPv6 アドレスのパブリック ネットワークを介したプライベート ネットワーク間で、IPv6 パケットのルーティングが可能になります。