インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
IPv4 GRE を介する IPv6 トンネル
IPv4 GRE を介する IPv6 トンネル

IPv4 GRE を介する IPv6 トンネル

GRE トンネルは、2 つのポイント間のリンクであり、リンクごとに個別のトンネルがあります。 これらのトンネルは、特定のパッセンジャまたはトランスポート プロトコルに結合されていませんが、この場合、GRE を使用するパッセンジャ プロトコルとして IPv6 を伝送し、トランスポート プロトコルとして IPv4 または IPv6 を伝送します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

IPv4 GRE を介する IPv6 トンネルに関する情報

オーバーレイ トンネル for IPv6

オーバーレイ トンネリングでは、IPv4 パケット内で IPv6 パケットをカプセル化して、IPv4 インフラストラクチャ(コア ネットワークまたは以下の図)へ伝送します。 オーバーレイ トンネルを使用することで、孤立した IPv6 ネットワークと通信できます。このとき、孤立した複数の IPv6 ネットワーク間にある IPv4 インフラストラクチャをアップグレードする必要はありません。 オーバーレイ トンネルは、境界デバイス間、または境界デバイスとホスト間に設定できますが、両方のトンネル エンドポイントが IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。 IPv6 では、次のタイプのオーバーレイ トンネリング メカニズムをサポートしています。

  • 手動

  • 総称ルーティング カプセル化(GRE)

  • IPv4 互換

  • 6to4

  • Intrasite Automatic Tunnel Addressing Protocol(ISATAP)

図 1. オーバーレイ トンネル


(注)  


オーバーレイ トンネルにより、インターフェイスの最大伝送単位(MTU)が 20 オクテット減少します(ただし、基本 IPv4 パケット ヘッダーにオプション フィールドが含まれていないことを前提とします)。 オーバーレイ トンネルを使用するネットワークは、トラブルシューティングが困難です。 したがって、独立した IPv6 ネットワークに接続するオーバーレイ トンネルは、最終的な IPv6 ネットワーク アーキテクチャと見なすことができません。 オーバーレイ トンネルの使用は、IPv4 と IPv6 の両方のプロトコル スタック、または IPv6 プロトコル スタックだけをサポートするネットワークへの移行方法と見なす必要があります。


以下の表は、IPv4 ネットワーク上での IPv6 パケットの伝送にどのトンネル タイプを設定すればよいかを決定する場合に役立ちます。

表 1 IPv4 ネットワーク上で IPv6 パケットを伝送するトンネル タイプの推奨される使用方法

トンネリング タイプ

推奨される使用方法

使用方法

手動

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6 パケットだけを伝送できます。

GRE および IPv4 互換

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6、コネクションレス型ネットワーク サービス(CLNS)、およびその他の多数のタイプのパケットを伝送できます。

IPv4 互換

ポイントツーマルチポイント トンネル

::/96 プレフィックスを使用します。 このトンネル タイプの使用は推奨しません。

6to4

独立した IPv6 サイトへの接続に使用可能なポイントツーマルチポイント トンネル

サイトでは、2002::/16 プレフィックスからのアドレスを使用します。

6RD

IPv6 サービスは、IPv4 に IPv6 のカプセル化を使用することで IPv4 ネットワーク上のユーザに提供されます。

プレフィックスは、SP 自身のアドレス ブロックから割り当てることができます。

ISATAP

サイト内のシステムへの接続に使用可能なポイントツーマルチポイント トンネル

サイトでは、任意の IPv6 ユニキャスト アドレスを使用できます。

個々のトンネル タイプについて、このマニュアルで詳しく説明しています。 実装する特定のトンネル タイプに関する情報を確認および理解することを推奨します。 必要なトンネル タイプに精通している場合は、以下の表で、有用と思われるトンネル設定パラメータの概要を参照してください。

表 2 トンネリング タイプ別のトンネル設定パラメータ

トンネリング タイプ

トンネル設定パラメータ

トンネル モード

トンネルの送信元

トンネルの宛先

インターフェイス プレフィックスまたはアドレス

手動

ipv6ip

IPv4 アドレス、または IPv4 が設定されたインターフェイスへの参照。

IPv4 アドレス。

IPv6 アドレス。

GRE/IPv4

gre ip

IPv4 アドレス。

IPv6 アドレス。

IPv4 互換

ipv6ip auto-tunnel

不要。 これらはすべて、ポイントツーマルチポイントのトンネリング タイプです。 IPv4 宛先アドレスは、パケット単位で、IPv6 宛先から計算されます。

不要。 インターフェイス アドレスは、::tunnel-source/96 として生成されます。

6to4

ipv6ip 6to4

IPv6 アドレス。 プレフィックスは、トンネル送信元の IPv4 アドレスを埋め込む必要があります。

6RD

ipv6ip 6rd

IPv6 アドレス。

ISATAP

ipv6ip isatap

変更された eui-64 形式での IPv6 プレフィックス。 IPv6 アドレスは、プレフィックスおよびトンネル送信元 IPv4 アドレスから生成されます。

IPv6 トラフィック用の GRE IPv4 トンネル サポート

IPv6 トラフィックは、標準的なポイントツーポイントのカプセル化スキームの実装にサービスを提供するように設計されている標準 GRE トンネリング技術を使用して、IPv4 GRE トンネルを介して伝送できます。 GRE トンネルは、手動で設定された IPv6 トンネルと同様、リンクごとに個別のトンネルが設定された 2 つのポイント間のリンクです。 これらのトンネルは、特定のパッセンジャまたはトランスポート プロトコルに結合されていませんが、この場合、GRE を使用するパッセンジャ プロトコルとして IPv6 を伝送し、トランスポート プロトコルとして IPv4 または IPv6 を伝送します。

GRE トンネルは、2 つのエッジ デバイス間またはエッジ デバイスとエンド システム間に定期的でセキュアな通信を必要とする安定した接続のために主に使用されます。 エッジ デバイスとエンド システムは、デュアル スタック実装である必要があります。

IPv4 GRE を介する IPv6 トンネルの設定方法

GRE/IPv6 トンネルの設定

GRE トンネルは、IPv6 ネットワーク層を介して送出し、IPv6 トンネルで IPv4 パケットと IPv6 パケットを転送するように設定できます。

はじめる前に

GRE IPv6 トンネルが設定されている場合、IPv6 アドレスは、トンネル送信元およびトンネル宛先に割り当てられます。 トンネル インターフェイスは、割り当て済みの IPv4 アドレスまたは IPv6 アドレスを持つことができます(ここでは説明していません)。 設定されたトンネルの両端にあるホストまたはデバイスは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    次のいずれかのコマンドを入力します。

    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]

    5.    tunnel source {ip-address | ipv6-address | interface-type interface-number}

    6.    tunnel destination {hostname | ip-address | ipv6-address}

    7.    tunnel mode {aurp | cayman | dvmrp | eon | gre | gre multipoint | gre ipv6 | ipip [decapsulate-any] | iptalk | ipv6 | mpls | nos}

    8.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。

     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 0
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 次のいずれかのコマンドを入力します。
    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]


    例:
    Device(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
     
    インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。
    • eui-64 キーワードを指定すると、ソフトウェアは、インターフェイスの IPv6 アドレスを設定し、アドレスの下位 64 ビットの EUI-64 インターフェイス ID を使用してインターフェイスで IPv6 処理をイネーブルにします。

     
    ステップ 5 tunnel source {ip-address | ipv6-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source gigabitethernet 0/0/0
     

    送信元 IPv4 アドレス、IPv6 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

    • インターフェイスが指定されている場合、そのインターフェイスは IPv4 アドレスを使用して設定されている必要があります。

     
    ステップ 6 tunnel destination {hostname | ip-address | ipv6-address}


    例:
    Device(config-if)# tunnel destination 2001:DB8:1111:2222::1/64
     

    トンネル インターフェイスの宛先 IPv4 アドレス、IPv6 アドレスまたはホスト名を指定します。

     
    ステップ 7 tunnel mode {aurp | cayman | dvmrp | eon | gre | gre multipoint | gre ipv6 | ipip [decapsulate-any] | iptalk | ipv6 | mpls | nos}


    例:
    Device(config-if)# tunnel mode gre ipv6
     

    GRE IPv6 トンネルを指定します。

    (注)     

    tunnel mode gre ipv6 コマンドでは、GRE をトンネルのカプセル化プロトコルとして指定します。

     
    ステップ 8 end


    例:
    Device(config-if)# end
     

    特権 EXEC モードに戻ります。

     

    IPv4 GRE を介する IPv6 トンネルの設定例

    例:IS-IS および IPv6 トラフィックを実行する GRE トンネル

    次に、ルータ A とルータ B との間で IS-IS および IPv6 トラフィックをともに送出する GRE トンネルを設定する例を示します。

    ルータ A の設定

    ipv6 unicast-routing
    clns routing
    !
    interface tunnel 0
     no ip address
     ipv6 address 3ffe:b00:c18:1::3/127
     ipv6 router isis 
     tunnel source GigabitEthernet 0/0/0
     tunnel destination 2001:DB8:1111:2222::1/64
     tunnel mode gre ipv6
    !
    interface GigabitEthernet0/0/0
     ip address 10.0.0.1 255.255.255.0
    !
    router isis 
     net 49.0000.0000.000a.00

    ルータ B の設定

    ipv6 unicast-routing
    clns routing
    !
    interface tunnel 0
     no ip address
     ipv6 address 3ffe:b00:c18:1::2/127
     ipv6 router isis 
     tunnel source GigabitEthernet 0/0/0
     tunnel destination 2001:DB8:1111:2222::2/64
     tunnel mode gre ipv6
    !
    interface GigabitEthernet0/0/0
     ip address 10.0.0.2 255.255.255.0
    !
    router isis 
     net 49.0000.0000.000b.00
     address-family ipv6
     redistribute static
     exit-address-family

    例:IPv6 トンネルのトンネル宛先アドレス

    Router(config
    )
    # 
    interface Tunnel0
    Router(config
    -if)
    # 
    ipv6 address 2001:1:1::1/48
    Router(config
    -if)
    # 
    tunnel source GigabitEthernet 0/0/0
    Router(config
    -if)
    # 
    tunnel destination 10.0.0.2
    Router(config
    -if)
    # 
    tunnel mode gre ipv6
    Router(config
    -if)
    # 
    exit
    !
    Router(config
    )
    # 
    interface GigabitEthernet0/0/0
    Router(config
    -if)
    # 
    ip address 10.0.0.1 255.255.255.0
    Router(config
    -if)
    # 
    exit
    !
    Router(config
    )
    # 
    ipv6 unicast-routing
    Router(config
    )
    # 
    router isis
     
    Router(config
    )
    # 
    net 49.0000.0000.000a.00
    

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    IPv6 アドレッシングと接続

    『IPv6 Configuration Guide』

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    『IPv6 RFCs』

    MIB

    MIB

    MIB のリンク

    選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    テクニカル サポート

    説明

    リンク

    右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    IPv4 GRE を介する IPv6 トンネルの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

    表 3 IPv4 GRE を介する IPv6 トンネルの機能情報

    機能名

    リリース

    機能情報

    IPv4 GRE を介する IPv6 トンネル

    Cisco IOS XE Release 2.1

    GRE トンネルは、2 つのポイント間のリンクであり、リンクごとに個別のトンネルがあります。 これらのトンネルは、特定のパッセンジャまたはトランスポート プロトコルに結合されていませんが、この場合、GRE を使用するパッセンジャ プロトコルとして IPv6 を伝送し、トランスポート プロトコルとして IPv4 または IPv6 を伝送します。

    tunnel destinationtunnel mode ipv6iptunnel source の各コマンドが導入または変更されました。