インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
VRF-Aware IPv6 Rapid Deployment トンネル
VRF-Aware IPv6 Rapid Deployment トンネル

VRF-Aware IPv6 Rapid Deployment トンネル

仮想ルーティングおよび転送(VRF)Aware トンネルは、信頼できないコア ネットワークまたは別のインフラストラクチャ(IPv4 または IPv6)を備えたコア ネットワークで区切られたカスタマー ネットワークに接続するために使用されます。 VRF-Aware IPv6 Rapid Deployment トンネル機能は、IPv6 Rapid Deployment トンネルに仮想ルーティングおよび転送(VRF)認識を拡張します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、http:/​/​www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

VRF-Aware IPv6 Rapid Deployment トンネルの制約事項

VRF- Aware IPv6 Rapid Deployment トンネル機能には次の制約があります。

  • 着信物理インターフェイスおよびトンネル インターフェイスには、定義されている同じ VRF インスタンスが必要。

  • トラフィックが転送されるトンネル転送 VRF および出力物理インターフェイスには、定義されている同じ VRF インスタンスが必要。

  • IPv6 Rapid Deployment Customer Edge(CE)ルータ コンフィギュレーションの場合、トンネル送信元および Border Relay(BR)ルータ アドレスには、トラフィックのフローが形成される物理インターフェイスとして定義される同じ VRF インスタンスが必要。

VRF-Aware IPv6 Rapid Deployment トンネルに関する情報

IPv6 Rapid Deployment トンネル機能により、サービス プロバイダーは、IPv4 による IPv6 のカプセル化を使用して、自身の IPv4 ネットワーク上でユニキャスト IPv6 サービスをお客様に提供できます。 現在、IPv6 Rapid Deployment トンネル機能は VRF をサポートしていません。 したがって、IPv6 オーバーレイ アドレスおよび IPv4 トランスポート アドレスを検索するためにフォワーディング テーブル検索タスクはグローバル ルーティング テーブルで実行されます。 VRF-Aware IPv6 Rapid Deployment トンネル機能は、VRF で IPv6 オーバーレイ アドレスおよび IPv4 トランスポート アドレスのIPv6 Rapid Deployment トンネリング サポートを拡張します。

次のシナリオは、VRF-Aware IPv6 Rapid Deployment トンネル機能でサポートされます。

  • IPv6 Rapid Deployment トンネルは VRF にあり、IPv6 オーバーレイ アドレスと IPv4 トランスポート アドレスの両方が VRF にあります。
  • IPv6 Rapid Deployment トンネルおよび IPv4 アドレスは VRF にあります。 着信グローバル ルーティング テーブル IPv6 トラフィックでは、IPv6 Rapid Deployment ドメインに基づいて、正しい VRF を選択します。

次の図では、IPv4 アドレスと IPv6 アドレスの両方が VRF にあるVRF Aware IPv6 Rapid Deploymen トンネル機能のトポロジおよび設定例を説明しています。

図 1. VRF-Aware IPv6 Rapid Deployment トンネルのトポロジ

VRF-Aware IPv6 Rapid Deployment トンネルの設定方法

VRF で IPv6 アドレスと IPv4 アドレスの両方がある場合に VRF-Aware IPv6 Rapid Deployment トンネル機能を設定するには、次の手順を実行します。 以下のプロシージャでは、特に明記されていない限り、CE ルータと BR ルータに対してこれらの手順を実行する必要があります。

VRF-Aware IPv6 Rapid Deployment トンネルの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    ipv6 unicast-routing

    4.    vrf definition vrf-name1

    5.    rd {ASN:nn | IP address: nn}

    6.    route-target [import | export | both] {ASN:nn |IP address: nn}

    7.    address-family ipv6

    8.    exit

    9.    address-family ipv4

    10.    exit

    11.    exit

    12.    vrf definition vrf-name2

    13.    rd {ASN:nn | IP address: nn}

    14.    route-target [import | export | both] { ASN:nn | IP address: nn}

    15.    address-family ipv4

    16.    exit

    17.    exit

    18.    interface gigabitethernet slot / port

    19.    vrf forwarding vrf-name1

    20.    ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}

    21.    exit

    22.    interface gigabitethernet slot / port

    23.    vrf forwarding vrf-name2

    24.    ip address ip-address mask

    25.    exit

    26.    interface loopback interface-number

    27.    vrf forwarding vrf-name2

    28.    ip address ip-address

    29.    exit

    30.    interface tunnel tunnel-number

    31.    vrf forwarding vrf-name1

    32.    ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}

    33.    tunnel source{ ip-address| interface-type interface-number}

    34.    tunnel mode ipv6ip [ 6rd| 6to4 | auto-tunnel | isatap]

    35.    tunnel 6rd ipv4 {prefix-length length} {suffix-length length}

    36.    tunnel 6rd prefix{ipv6-prefix/ prefix-length}

    37.    tunnel 6rd br ipv4-address

    38.    tunnel vrf vrf-name2

    39.    exit

    40.    ipv6 route vrf vrf-name1 {ipv6-prefix / prefix-length} tunnel tunnel-number

    41.    ipv6 route vrf vrf-name1{ipv6-prefix/ prefix-length} tunnel tunnel-number ipv6-address

    42.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router# enable
     

    特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

     

    ステップ 2configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3ipv6 unicast-routing


    例:
    Router(config)# ipv6 unicast-routing
     

    IPv6 ユニキャスト データグラムの転送タスクをイネーブルにします。

     

    ステップ 4vrf definition vrf-name1


    例:
    Router(config)# vrf definition VRF_RED
     

    VRF インスタンスを設定し、VRF 設定モードを開始します。

     

    ステップ 5rd {ASN:nn | IP address: nn}

    例:
    Router(config-vrf)# rd 1:1
     
    ルート識別子を指定します。
    • ASN: nn:自律システム番号および任意の番号を指定します。

    • IP address: nn:IP アドレスと任意の番号を指定します。

     

    ステップ 6route-target [import | export | both] {ASN:nn |IP address: nn}

    例:
    Router(config-vrf)# route-target import 1:1
     
    VRF インスタンス用にルート ターゲット拡張コミュニティを作成します。 ルート ターゲット拡張コミュニティ属性を使用して、一連のサイト、および設定されたルート ターゲットを使用するルートを受信できる VRF インスタンスが識別されます。
    • import:ターゲット VPN 拡張コミュニティからルーティング情報をインポートします。

    • export:ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートします。

    • both:ターゲット VPN 拡張コミュニティにインポート ルーティング情報およびエクスポート ルーティング情報の両方をインポートします。

    • ASN: nn:自律システム番号および任意の番号を指定します。

    • IP address: nn:IP アドレスと任意の番号を指定します。

     

    ステップ 7address-family ipv6


    例:
    Router(config-vrf)# address-family ipv6
     

    VRF テーブルのアドレス ファミリ タイプとして IPv6 を選択し、VRF アドレス ファミリ コンフィギュレーション モードを開始します。 IPv6 用の個別のルートターゲット ポリシーを設定します。

     

    ステップ 8exit


    例:
    Router(config-vrf-af)# exit
     

    アドレス ファミリ コンフィギュレーション モードを終了します。

     

    ステップ 9address-family ipv4


    例:
    Router(config-vrf)# address-family ipv4
     

    VRF テーブルのアドレス ファミリ タイプとして IPv4 を選択し、VRF アドレス ファミリ コンフィギュレーション モードを開始します。 IPv4 用の個別のルートターゲット ポリシーを設定します。

     

    ステップ 10exit


    例:
    Router(config-vrf-af)# exit
     

    アドレス ファミリ コンフィギュレーション モードを終了します。

     

    ステップ 11exit


    例:
    Router(config-vrf)# exit
     

    VRF コンフィギュレーション モードを終了します。

     

    ステップ 12vrf definition vrf-name2


    例:
    Router(config)# vrf definition VRF_GREEN
     

    VRF インスタンスを設定し、VRF 設定モードを開始します。

     

    ステップ 13rd {ASN:nn | IP address: nn}

    例:
    Router(config-vrf)# rd 1:1
     

    ルート識別子を指定します。

     

    ステップ 14route-target [import | export | both] { ASN:nn | IP address: nn}

    例:
    Router(config-vrf)# route-target import 1:1
     

    VRF インスタンス用にルート ターゲット拡張コミュニティを作成します。 ルート ターゲット拡張コミュニティ属性を使用して、一連のサイト、および設定されたルート ターゲットを使用するルートを受信できる VRF インスタンスが識別されます。

    • import:ターゲット VPN 拡張コミュニティからルーティング情報をインポートします。

    • export:ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートします。

    • both:ターゲット VPN 拡張コミュニティからルーティング情報をインポートし、ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートします。

    • ASN: nn:自律システム番号および任意の番号を指定します。

    • IP address: nn:IP アドレスと任意の番号を指定します。

     

    ステップ 15address-family ipv4


    例:
    Router(config-vrf)# address-family ipv4
     

    VRF テーブルのアドレス ファミリとして IPv4 を選択し、VRF アドレス ファミリ コンフィギュレーション モードを開始します。 IPv4 用の個別のルート ターゲット ポリシーを設定します。

     

    ステップ 16exit


    例:
    Router(config-vrf-af)# exit
     

    アドレス ファミリ コンフィギュレーション モードを終了します。

     

    ステップ 17exit


    例:
    Router(config-vrf)# exit
     

    VRF コンフィギュレーション モードを終了します。

     

    ステップ 18interface gigabitethernet slot / port


    例:
    Router(config)# interface gigabitethernet 3/1
     

    インターフェイス コンフィギュレーション モードを開始し、設定するギガビット インターフェイスを指定します。

     

    ステップ 19vrf forwarding vrf-name1


    例:
    Router(config-if)# vrf forwarding VRF_RED
    
     

    VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

     

    ステップ 20ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}


    例:
    Router(config-if)# ipv6 address 1::2/64
     

    インターフェイスに割り当てられた IPv6 アドレスを指定し、インターフェイスでの IPv6 処理をイネーブルにします。

     

    ステップ 21exit


    例:
    Router(config-if)# exit
     

    インターフェイス コンフィギュレーション モードを終了します。

     

    ステップ 22interface gigabitethernet slot / port


    例:
    Router(config)# interface gigabitethernet 4/5
     

    インターフェイス コンフィギュレーション モードを開始し、設定するギガビット インターフェイスを指定します。

     

    ステップ 23vrf forwarding vrf-name2


    例:
    Router(config-if)# vrf forwarding VRF_GREEN
     

    VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

     

    ステップ 24ip address ip-address mask


    例:
    Router(config-if)# ip address 17.1.1.1 255.255.255.0
     

    IP アドレスとサブネット マスクをインターフェイスに割り当てます。

     
    ステップ 25exit


    例:
    exit
     

    インターフェイス コンフィギュレーション モードを終了します。

     

    ステップ 26interface loopback interface-number


    例:
    Router(config)# interface Loopback 100
     
     

    インターフェイス コンフィギュレーション モードを開始して、新しいループバック インターフェイスを指定します。

     

    ステップ 27vrf forwarding vrf-name2


    例:
    Router(config-if)# vrf forwarding VRF_GREEN
     

    VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

     

    ステップ 28ip address ip-address


    例:
    Router(config-if)# ip address 60.1.1.1 255.255.255.0
    
     

    ループバック インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

     
    ステップ 29exit


    例:
    Router(config-if)# exit
     

    インターフェイス コンフィギュレーション モードを終了します。

     

    ステップ 30interface tunnel tunnel-number


    例:
    Router(config)# interface tunnel 10
     

    トンネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 31vrf forwarding vrf-name1


    例:
    Router(config-if)# vrf forwarding VRF_RED
     

    VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

     

    ステップ 32ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}


    例:
    Router(config-if)# ipv6 address 2001:A000:100::1/128
     

    インターフェイスに割り当てられた IPv6 アドレスを指定し、インターフェイスでの IPv6 処理をイネーブルにします。

     

    ステップ 33tunnel source{ ip-address| interface-type interface-number}


    例:
    Router(config-if)# tunnel source loopback 100
     

    トンネル インターフェイスの送信元インターフェイスのタイプおよび番号を指定します。

     

    ステップ 34tunnel mode ipv6ip [ 6rd| 6to4 | auto-tunnel | isatap]


    例:
    Router(config-if)# tunnel mode ipv6ip 6rd
     

    スタティック IPv6 トンネル インターフェイスを設定します。

     

    ステップ 35tunnel 6rd ipv4 {prefix-length length} {suffix-length length}


    例:
    Router(config-if)# tunnel 6rd ipv4 prefix-len 16 suffix-len 8
     

    すべての 6rd トンネルに共通の IPv4 トランスポート アドレスのプレフィックス長およびサフィクス長を指定します。

     

    ステップ 36tunnel 6rd prefix{ipv6-prefix/ prefix-length}


    例:
    Router(config-if)# tunnel 6rd prefix 2001:A000::/32
     

    IPv6 6rd トンネル上で共通の IPv6 プレフィックスを指定します。

     

    ステップ 37tunnel 6rd br ipv4-address


    例:
    Router(config-if)# tunnel 6rd br 60.1.2.1
     

    6rd CE ルータのセキュリティ チェックを回避します。

    • ipv4-address:Border Relay(BR)ルータの IPv4 アドレス

    (注)     

    CE ルータだけではなく、BR ルータでもこのステップを実行します。

     

    ステップ 38tunnel vrf vrf-name2


    例:
    Router(config-if)# tunnel vrf  VRF_GREEN
     

    特定のトンネル宛先、インターフェイス、またはサブインターフェイスに VRF インスタンスを設定します。

    (注)     

    このコマンドは、トンネル IPv4 トランスポート アドレス検索に使用する VRF インスタンスを指定します。

     

    ステップ 39exit


    例:
    Router(config-if)# exit
     

    インターフェイス コンフィギュレーション モードを終了します。

     

    ステップ 40ipv6 route vrf vrf-name1 {ipv6-prefix / prefix-length} tunnel tunnel-number


    例:
    Router(config)# ipv6 route vrf VRF_RED 2001:A000::/32 Tunnel10
    
     

    スタティック ルートを確立します。

    • ipv6-prefix:スタティック ルートの宛先となる IPv6 ネットワークを指定します。 スタティック ホスト ルートを設定する場合は、ホスト名も設定できます。

    • ipv6-address:指定したネットワークに到達するために使用可能なネクスト ホップの IPv6 アドレス。

     

    ステップ 41ipv6 route vrf vrf-name1{ipv6-prefix/ prefix-length} tunnel tunnel-number ipv6-address


    例:
    Router(config)# ipv6 route vrf VRF_RED 9000:1000::/64 Tunnel10 2001:A000:200::1
     

    スタティック ルートを確立します。

    • ipv6-prefix:スタティック ルートの宛先となる IPv6 ネットワークを指定します。 スタティック ホスト ルートを設定する場合は、ホスト名も設定できます。

    • prefix-length:IPv6 プレフィックスの長さを指定します

     

    ステップ 42end


    例:
    Router(config)# end
     

    現在のコンフィギュレーション セッションを終了します。

     

    例:VRF-Aware IPv6 Rapid Deployment トンネルの設定

    次に、CE ルータで VRF-Aware IPv6 Rapid Deployment トンネルを設定する例を示します。

    Router# enable
    Router# configure terminal
    Router(config)# ipv6 unicast-routing
    Router(config)# mls ipv6 vrf
    Router(config)# vrf definition VRF_RED
    Router(config-vrf)# rd 1:1
    Router(config-vrf)# route-target export 1:1
    Router(config-vrf)# route-target import 1:1
    Router(config-vrf)# address-family ipv6
    Router(config-vrf-af)# exit
    Router(config-vrf)# address-family ipv4
    Router(config-vrf-af)# exit
    Router(config-vrf)# exit
    Router(config)# vrf definition VRF_GREEN
    Router(config-vrf)# rd 1:1
    Router(config-vrf)# route-target export 1:1
    Router(config-vrf)# route-target import 1:1
    Router(config-vrf)# address-family ipv4
    Router(config-vrf-af)# exit
    Router(config-vrf)# exit
    Router(config)# interface gigabitethernet 3/1
    Router(config-if)# vrf forwarding VRF_RED
    Router(config-if)# ipv6 address 1::2/64
    Router(config-if)# exit
    Router(config)# interface gigabitethernet 4/5
    Router(config-if)# vrf forwarding VRF_GREEN
    Router(config-if)# ip address 17.1.1.1 255.255.255.0
    Router(config-if)# ip ospf 2 area 0
    Router(config-if)# exit
    Router(config)# interface Loopback 100
    Router(config-if)# vrf forwarding VRF_GREEN
    Router(config-if)# ip address 60.1.1.1 255.255.255.0
    Router(config-if)# ip ospf 2 area 0
    Router(config-if)# exit
    Router(config)# interface tunnel 10
    Router(config-if)# vrf forwarding VRF_RED
    Router(config-if)# ipv6 address 2001:A000:100::1/128
    Router(config-if)# mls 6rd reserve interface GigabitEthernet4/5
    Router(config-if)# tunnel source loopback 100
    Router(config-if)# tunnel mode ipv6ip 6rd
    Router(config-if)# tunnel 6rd ipv4 prefix-len 16 suffix-len 8
    Router(config-if)# tunnel 6rd prefix 2001:A000::/32
    Router(config-if)# tunnel 6rd br 60.1.2.1
    Router(config-if)# tunnel vrf  VRF_GREEN
    Router(config-if)# exit
    Router(config)# ipv6 route vrf VRF_RED 2001:A000::/32 Tunnel10
    Router(config)# ipv6 route vrf VRF_RED 9000:1000::/64 Tunnel10 2001:A000:200::1
    Router(config)# end
    

    次に、BR ルータで VRF-Aware IPv6 Rapid Deployment トンネルを設定する例を示します。

    Router# enable
    Router# configure terminal
    Router(config)# ipv6 unicast-routing
    Router(config)# vrf definition VRF_RED
    Router(config-vrf)# rd 1:1
    Router(config-vrf)# route-target export 1:1
    Router(config-vrf)# route-target import 1:1
    Router(config-vrf)# address-family ipv6
    Router(config-vrf-af)# exit
    Router(config-vrf)# address-family ipv4
    Router(config-vrf-af)# exit
    Router(config-vrf)# exit
    Router(config)# vrf definition VRF_GREEN
    Router(config-vrf)# rd 1:1
    Router(config-vrf)# route-target export 1:1
    Router(config-vrf)# route-target import 1:1
    Router(config-vrf)# address-family ipv4
    Router(config-vrf-af)# exit
    Router(config-vrf)# exit
    Router(config)# interface gigabitethernet 5/1
    Router(config-if)# vrf forwarding VRF_RED
    Router(config-if)# ipv6 address 9000:1000::/64
    Router(config-if)# exit
    Router(config)# interface gigabitethernet 4/1
    Router(config-if)# vrf forwarding VRF_GREEN
    Router(config-if)# ip address 17.1.1.2 255.255.255.0
    Router(config-if)# ip ospf 2 area 0
    Router(config-if)# exit
    Router(config)# interface Loopback 100
    Router(config-if)# vrf forwarding VRF_GREEN
    Router(config-if)# ip address 60.1.2.1 255.255.255.0
    Router(config-if)# exit
    Router(config)# interface tunnel 10
    Router(config-if)# vrf forwarding VRF_RED
    Router(config-if)# ipv6 address 2001:A000:100::1/128
    Router(config-if)# tunnel source loopback 100
    Router(config-if)# tunnel mode ipv6ip 6rd
    Router(config-if)# tunnel 6rd ipv4 prefix-len 16 suffix-len 8
    Router(config-if)# tunnel 6rd prefix 2001:A000::/32
    Router(config-if)# tunnel vrf  VRF_GREEN
    Router(config-if)# exit
    Router(config)# ipv6 route vrf VRF_RED 2001:A000::/32 Tunnel10
    Router(config)# end

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    IPv6 アドレッシングと接続

    『IPv6 Configuration Guide』

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    『IPv6 RFCs』

    テクニカル サポート

    説明

    リンク

    右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    VRF-Aware IPv6 Rapid Deployment トンネルの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco.com のアカウントは必要ありません。

    表 1 VRF-Aware IPv6 Rapid Deployment トンネルの機能情報

    機能名

    リリース

    機能情報

    VRF-Aware IPv6 Rapid Deployment トンネル

    Cisco IOS XE Release 3.10S

    IPv6 Rapid Deployment トンネル機能により、サービス プロバイダーは、IPv4 による IPv6 のカプセル化を使用して、自身の IPv4 ネットワーク上でユニキャスト IPv6 サービスをお客様に提供できます。 VRF-Aware IPv6 Rapid Deployment トンネル機能は、IPv6 Rapid Deployment トンネルに VRF 認識を拡張します。