インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
トンネルの実装
トンネルの実装

目次

トンネルの実装

このモジュールでは、トンネリング技術のさまざまなタイプを示します。 物理インターフェイスまたは仮想インターフェイスを使用するトンネル タイプについて、設定の詳細や設定例を示しています。 テクノロジー固有のコマンドを使用して多数のトンネリング技術が実装されており、テクノロジーに関して対応するモジュールへのリンクが示されています。

トンネリングを使用すると、トランスポート プロトコル内部の任意のパケットをカプセル化できます。 トンネルは、設定のために簡単なインターフェイスを提供するための仮想インターフェイスとして実装されます。 トンネル インターフェイスは、特定の「passenger」プロトコルまたは「transport」プロトコルには関連付けられていませんが、任意の標準的なポイントツーポイント カプセル化スキームの実装に必要なサービスを提供するアーキテクチャです。


(注)  


Cisco ASR 1000 シリーズ アグリゲーション サービス ルータは、VPN ルーティングおよび転送(VRF)Aware の総称ルーティング カプセル化(GRE)トンネル キープ アライブ機能をサポートします。


機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

トンネル実装の制約事項

  • トンネル プロトコルにファイアウォールとアクセス コントロール リスト(ACL)チェックのパススルーを許可することが必要です。

  • トンネル インターフェイスで帯域幅が正しく設定されていない場合、複数のポイントツーポイント トンネルがルーティング情報を使用して物理リンクを飽和させる可能性があります。

  • トンネルは単一のホップ リンクに似ており、ルーティング プロトコルはマルチホップ物理パスを経由するトンネルを優先することがあります。 トンネルは単一ホップ リンクに似ているかどうかに関係なく、マルチ ホップ リンクよりも低速パスを通過する場合があります。 トンネルは、実際に通過するリンクと同様に堅牢で高速であったり、信頼性が低く低速であったりします。 ホップ カウントだけに基づいて決定を行うルーティング プロトコルは、物理リンクのセットを経由するトンネルを優先することが多くなります。 トンネルは、1 つのホップのポイントツーポイント リンクで、パスのコストが最も低いように思われますが、代替物理トポロジと比較した場合、遅延の観点から見ると実際にはコストがかかる場合があります。 たとえば、以下の図に示すトポロジでは、ホスト 1 からのパケットは、w、x、y、z の 4 つのパスを使用する代わりに、トンネルのホップ カウントがより短いと思われるネットワーク w、t、および z を通過してホスト 2 へ送信されると考えられます。 ただし実際には、トンネルを通って送信されるパケットは、ルータ A、B、C を通過して、さらにルータ D まで移動してからルータ C に戻る必要があります。

図 1. トンネルに関する注意事項:ホップ カウント

  • ルーティングが正しく設定されていない場合、トンネルに再帰ルーティングの問題がある可能性があります。 トンネル宛先への最良パスはトンネル自身です。そのため再帰ルーティングによってトンネル インターフェイスがフラップします。 再帰ルーティングの問題を回避するには、次の方法を使用して、常にコントロール プレーン ルーティングをトンネル ルーティングとは別個にします。
    • 異なる自律システム番号またはタグを使用する。
    • 異なるルーティング プロトコルを使用する。
    • スタティック ルートを使用して最初のホップ(ルーティング ループがないかどうか監視)をオーバーライドされていることを確認する。
    次のエラーは、再帰ルーティングがトンネルの宛先にあるときに表示されます。
    %TUN-RECURDOWN Interface Tunnel 0
    temporarily disabled due to recursive routing

トンネル実装に関する情報

トンネリングとカプセル化

トンネルがどのように動作するかを理解するには、カプセル化とトンネリングの概念を区別できるようにする必要があります。 カプセル化は、特定のプロトコル スタックの各レイヤでデータにヘッダーを追加するプロセスです。 開放型システム間相互接続(OSI)参照モデルは、ネットワークの機能について説明します。 1 個のホスト(PC など)からネットワーク上の別のホストにデータ パケットを送信するには、カプセル化を使用して、プロトコル スタックの各レイヤで、データ パケットの前にヘッダーを降順で追加します。 ヘッダーには、現在のレイヤのすぐ上にあるレイヤでカプセル化されているデータのタイプを示すデータ フィールドが含まれていることが必要です。 ネットワークの受信側でパケットがプロトコル スタックを上っていくと、カプセル化された各ヘッダーは逆順に削除されます。

トンネリングでは、別のプロトコル内の 1 つのプロトコルからデータ パケットをカプセル化し、外部ネットワーク上のパケットを転送します。 トンネリングは、カプセル化とは異なり、より低いレイヤのプロトコルと同じレベルのレイヤのプロトコルが、トンネルを通って送信されるようにします。 トンネル インターフェイスは仮想(または論理)インターフェイスです。 トンネリングは、次の 3 種類の主要コンポーネントから構成されます。

  • パッセンジャ プロトコル:カプセル化の対象となるプロトコル。 たとえば、IPv4 プロトコルや IPv6 プロトコルなどです。

  • キャリア プロトコル:カプセル化するプロトコル。 たとえば、総称ルーティング カプセル化(GRE)やマルチプロトコル ラベル スイッチング(MPLS)などです。

  • トランスポート プロトコル:カプセル化したプロトコルを伝送するプロトコル。 主なトランスポート プロトコルは IP です。

Tunnel ToS(ToS)

トンネル タイプ オブ サービス(ToS)により、ネットワーク トラフィックをトンネリングして、すべてのパケットを同じ ToS バイト値に分類できます。 ToS バイト値および存続可能時間(TTL)のホップ カウント値は、ルータの IP トンネル インターフェイス向けのトンネル パケットのカプセル化 IP ヘッダーに設定できます。 トンネル ToS 機能は、シスコ エクスプレス フォワーディング(旧称:CEF)、高速スイッチング、およびプロセス スイッチングでサポートされます。

ToS および TTL バイト値は、RFC 791 で定義されています。 RFC 791 に定義されているとおり、RFC 2474 および RFC 2780 では ToS バイトの使用を廃止しています。 RFC 791 では、ToS バイトのビット 6 と 7(最初の 2 つの最下位ビット)は将来使用するために予約されており、0 に設定する必要があることが指定されています。 Cisco IOS XE Release 2.1 では、トンネル ToS 機能はこの標準に準拠していません。ビット 6 および 7 を含むすべての ToS バイト値を使用し、パケットの ToS バイトが準拠する RFC 標準を決定できるようになっています。

EoMPLS over GRE

Ethernet over MPLS(EoMPLS)は、レイヤ 3 の MPLS ネットワークを経由したレイヤ 2 トラフィックのトンネリングを可能にするトンネリング メカニズムです。 EoMPLS は、レイヤ 2 トンネリングとも呼ばれています。

EoMPLS は、長距離のレイヤ 2 拡張に非常に有効です。 EoMPLS over GRE は、ハードウェアベースのスイッチド トンネルとして GRE トンネルを作成し、GRE トンネル内で EoMPLS をカプセル化できるようにします。 GRE 接続が 2 つのコア ルータ間で確立され、MPLS ラベル スイッチド パス(LSP)がトンネリングされます。

GRE カプセル化は、転送前に追加されるヘッダー情報を持つパケットを定義するために使用されます。 カプセル化解除は、パケットが宛先トンネルのエンドポイントに到着したときに追加ヘッダー情報を削除するプロセスです。

パケットが GRE トンネルを経由して転送されると、パケットの先頭に 2 つの新しいヘッダーが追加されます。したがって、新しいペイロードの内容は変更されます。 カプセル化後、元のデータペイロードと独立した IP ヘッダーであった部分は、GRE ペイロードと呼ばれます。 プロトコルの種類の情報と再計算されたチェックサムを示すために、GRE ヘッダーがパケットに追加されます。 GRE ヘッダーの前に IP ヘッダーも追加されます。 この IP ヘッダーには、トンネルの宛先 IP アドレスが含まれます。

GRE ヘッダーは、ヘッダーがトンネルに入る前に、IP、レイヤ 2 VPN およびレイヤ 3 VPN などのパケットに追加されます。 カプセル化されたパケットを受信する、パス沿いにあるすべてのルータは、新しい IP ヘッダーを使用してトンネル エンドポイントへのパケットの到達方法を決定します。

IP 転送では、パケットがトンネル宛先エンドポイントに到着した時点で、新しい IP ヘッダーと GRE ヘッダーがパケットから削除され、その後はパケットの最終宛先への転送に元の IP ヘッダーが使用されます。

EoMPLS over GRE 機能は、トンネルの宛先でパケットから新しい IP ヘッダーおよび GRE ヘッダーを削除し、MPLS ラベルを使用して適切なレイヤ 2 接続回線またはレイヤ 3 VRF へとパケットを転送します。

次の項のシナリオでは、プロバイダー エッジ(PE)またはプロバイダー(P)ルータでの GRE 展開における L2VPN および L3VPN について説明します。

プロバイダー エッジからプロバイダー エッジ総称ルーティング カプセル化へのトンネル

プロバイダー エッジからプロバイダー エッジ(PE)GRE へのトンネルのシナリオでは、お客様は、コアのどの部分も MPLS へ移行せずに、EoMPLS および基本 MPLS VPN サービスを提供することを選択します。 したがって、MPLS トラフィックの GRE トンネリングは PE 間で行われます。

プロバイダーからプロバイダー総称ルーティング カプセル化へのトンネル

プロバイダーからプロバイダー(P)GRE へのトンネルのシナリオでは、プロバイダー エッジ(PE)ルータと P ルータの間でマルチプロトコル ラベル スイッチング(MPLS)がイネーブルですが、ネットワーク コアでは非 MPLS 認識ルータまたは IP 暗号化ボックスが使用できます。 このシナリオでは、P ルータ間で、MPLS ラベル付きパケットが GRE トンネリングされます。

プロバイダー エッジからプロバイダー総称ルーティング カプセル化へのトンネル

プロバイダー エッジからプロバイダー GRE へのトンネルのシナリオでは、ネットワークに MPLS 認識の P-to-P ノードがあります。 GRE トンネリングは、PE-to-P の非 MPLS ネットワーク セグメント間で行われます。

総称ルーティング カプセル化に固有の機能

導入シナリオに関して次の設定と情報を理解しておく必要があります。

  • トンネル エンドポイントは、ループバック インターフェイスまたは物理インターフェイス

  • キープアライブ タイマーの期限が切れると、エンドポイント単位で設定可能なトンネルのキープアライブ タイマー パラメータおよび Syslog メッセージを生成

  • トンネル障害およびトンネルを使用した Interior Gateway Protocol(IGP)に対する双方向フォワーディング検出(BFD)のサポート

  • GRE トンネル全体における IGP ロード シェアリングのサポート

  • GRE トンネル全体における IGP 冗長性のサポート

  • GRE トンネル全体におけるフラグメンテーションのサポート

  • ジャンボ フレーム通過機能のサポート

  • すべての IGP コントロール プレーン トラフィックのサポート

  • トンネル全体における IP ToS 保存のサポート

  • トンネルは、ATM、ギガビット、Packet over SONET(POS)、TenGigabit などのエンドポイントの物理インターフェイス タイプとは無関係

  • 最大 100 の GRE トンネルのサポート

MPLS を介するイーサネットに固有の機能

  • Any Transport over MPLS(AToM)シーケンス

  • IGP ロード シェアリングおよび冗長性

  • ポート モードのMPLS を介するイーサネット(EoMPLS)

  • 疑似回線の冗長性

  • 最大 200 の EoMPLS 仮想回線(VC)のサポート

  • トンネル選択および特定の疑似回線を GRE トンネルにマップする機能

  • VLAN モードの EoMPLS

マルチプロトコル ラベル スイッチングの仮想プライベート ネットワークに固有の機能

  • IPv4 VRF での PE ロールのサポート

  • すべての PE to カスタマー エッジ(CE)プロトコルのサポート

  • 複数のトンネルを経由したロード シェアリングおよび単一トンネルと等コストの IGP パス

  • 単一トンネルと非等コストの IGP パスによる冗長性のサポート

  • マルチプロトコル ラベル スイッチング(MPLS)ラベルの expression(EXP)ビット フィールドにコピーされてから、総称ルーティング カプセル化(GRE)パケットの外部 IPv4 ToS フィールドの precedence ビットにコピーされる IP precedence 値のサポート

EoMPLS over GRE の設定シーケンスの例については、「EoMPLS over GRE」の項を参照してください。 EoMPLS over GRE の詳細については、『Deploying and Configuring MPLS Virtual Private Networks In IP Tunnel Environments』マニュアルを参照してください。

パス MTU ディスカバリ

Path MTU Discovery(PMTUD)は、GRE または IP-in-IP トンネル インターフェイスでイネーブルにできます。 トンネル インターフェイスで PMTUD(RFC 1191)がイネーブルの場合、ルータは GRE(または IP-in-IP)トンネル IP パケットに対して PMTUD 処理を実行します。 ルータは、トンネルに入ってくる元のデータの IP パケットに対して常に PMTUD 処理を実行します。 PMTUD がイネーブルな場合、Don't Fragment(DF)ビットがすべてのパケットに設定されるため、トンネルを通過するパケットに対してはパケットのフラグメンテーションは許可されません。 トンネルに入ったパケットがそのパケットの MTU 値よりも小さい MTU 値を持つリンクを検出すると、パケットは廃棄され、パケットの送信元にインターネット制御メッセージ プロトコル(ICMP)メッセージが返されます。 このメッセージには、フラグメンテーションが要求されたこと(しかし許可されなかったこと)と、パケットがドロップされる原因となったリンクの MTU が含まれています。


(注)  


トンネル インターフェイスの PMTUD は、トンネル エンドポイントがトンネルのパスでルータによって生成される ICMP メッセージを受信できることを要求します。 ファイアウォール接続を通じて PMTUD を使用する前に、ICMP メッセージが受信できることを確認してください。


トンネルのパケットで PMTUD をイネーブルにするには、tunnel path-mtu-discovery コマンドを使用し、トンネルの PMTUD パラメータを確認するには、show interfaces tunnel コマンドを使用します。 PMTUD が動作するトンネル インターフェイスは現在、GRE および IP-in-IP だけです。

トンネル用 Quality of Service(QoS)オプション

トンネル インターフェイスは、物理インターフェイスとしてさまざまな Quality of Service(QoS)機能をサポートします。 QoS により、ミッション クリティカルなトラフィックのパフォーマンスを確実に受け入れ可能なレベルにする方法が提供されます。 トンネル用 QoS オプションでサポートされる項目には、Generic Traffic Shaping(GTS)のトンネル インターフェイスへの直接適用や、Modular QoS CLI(MQC)を使用したクラス ベースのシェーピングなどが含まれます。 またトンネル インターフェイスは、クラス ベースのポリシングもサポートしますが、専用アクセス レート(CAR)はサポートしません。

GRE トンネルでは、ルータは、ToS バイトの IP precedence ビット値をトンネルまたは内部パケットをカプセル化している GRE IP ヘッダーにコピーできます。 トンネルのエンドポイント間の中間ルータは、IP precedence 値を使用して、QoS 機能(ポリシー ルーティング、重み付け均等化キューイング(WFQ)、重み付けランダム早期検出(WRED)など)向けにパケットを分類できます。

トンネルまたは暗号化ヘッダーによってパケットがカプセル化されている場合、QoS 機能は元のパケットのヘッダーを調べてパケットを正しく分類することができません。 同じトンネルを通過するパケットは、同じトンネル ヘッダーを持つため、物理インターフェイスが輻輳している場合、パケットは同等に扱われます。 ただし、トンネルのパケットはトンネリング前に分類でき、ユーザがトンネル インターフェイス上またはクリプト マップ上で QoS の事前分類機能を適用する際に暗号化を行うことができます。


(注)  


クラス ベースのシェーピング内の Class-based WFQ(CBWFQ)は、マルチポイント インターフェイスではサポートされません。


トンネル インターフェイス上に一部の QoS 機能を導入する方法については、32 ページの「トンネル インターフェイスでの QoS オプションの設定例」の項を参照してください。

トンネルの実装方法

トンネル タイプの決定

トンネルを設定する前に、作成するトンネルのタイプを決定する必要があります。

手順の概要

    1.    パッセンジャ プロトコルを決定します。 パッセンジャ プロトコルはカプセル化の対象となるプロトコルです。

    2.    必要に応じて、tunnel mode コマンド キーワードを決定します。


手順の詳細
    ステップ 1   パッセンジャ プロトコルを決定します。 パッセンジャ プロトコルはカプセル化の対象となるプロトコルです。
    ステップ 2   必要に応じて、tunnel mode コマンド キーワードを決定します。

    次の表に tunnel mode コマンドで使用する適切なキーワードを設定する例を示します。

    表 1 トンネル モードのコマンド キーワードの決定

    キーワード

    目的

    dvmrp

    Distance Vector Multicast Routing Protocol(DVMRP)のカプセル化の使用を指定するには、dvmrp キーワードを使用します。

    gre ip

    IP での GRE カプセル化の使用を指定するには、gre キーワードおよび ip キーワードを使用します。

    gre ipv6

    IPv6 での GRE カプセル化の使用を指定するには、gre キーワードおよび ipv6 キーワードを使用します。

    ipip [decapsulate-any]

    IP-in-IP カプセル化の使用を指定するには、ipip キーワードを使用します。 オプションの decapsulate-any キーワードは、あるトンネル インターフェイスの任意の数の IP-in-IP トンネルを終了させます。 このトンネルは発信トラフィックを伝送しませんが、任意の数のリモート トンネル エンドポイントは、設定されたトンネルを宛先として使用できることに注意してください。

    ipv6

    IPv6 での汎用パケット トンネリングの使用を指定するには、ipv6 キーワードを使用します。

    ipv6ip

    IPv6 をパッセンジャ プロトコルとして使用し、IPv4 をキャリア(カプセル化)プロトコルおよびトランスポートプロトコルとして使用することを指定するには、ipv6ip キーワードを使用します。 追加のキーワードを使用しない場合は、手動 IPv6 トンネルが設定されます。 追加のキーワードを使用して、IPv4 互換、6to4、または ISATAP トンネルを指定できます。

    mpls

    トラフィック エンジニアリング(TE)トンネルの設定に MPLS の使用を指定するには、mpls キーワードを使用します。


    IPv4 GRE トンネルの設定

    GRE トンネルを設定するには、この作業を実行します。 トンネル インターフェイスを使用して、通常プロトコルをサポートしないネットワークへプロトコル トラフィックを通過させます。 トンネルを構築するには、トンネル インターフェイスを 2 つのルータそれぞれで定義し、そのトンネル インターフェイスが互いを参照することが必要です。 各ルータでは、トンネル インターフェイスはレイヤ 3 アドレスを使用して設定する必要があります。 トンネルのエンドポイント、トンネル送信元、およびトンネル宛先を定義して、トンネルのタイプを選択する必要があります。 オプションの手順を実行して、トンネルをカスタマイズできます。

    必ずトンネルの両側にルータを設定するようにしてください。 トンネルの片方の端だけが設定されている場合、(キープアライブが設定されていない限り)トンネル インターフェイスはアップした状態になっていますが、トンネルに入ったパケットはドロップされます。

    GRE トンネル キープアライブ

    キープアライブ パケットは、IP カプセル化された GRE トンネルを介して送信されるよう設定できます。 キープアライブが送信されるレートと、インターフェイスが非アクティブになるまでデバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定できます。 GRE キープアライブ パケットは、トンネルの両側または片側のみのどちらでも送信できます。

    はじめる前に

    この作業でトンネルの送信元として使用する物理インターフェイスがアップしており適切な IP アドレスを使用して設定されていることを確認します。 ハードウェアに関する技術的な説明およびインターフェイスのインストールに関する情報については、ご使用の製品のハードウェアのインストールおよび設定マニュアルを参照してください。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    bandwidth kb/s

      5.    keepalive [period [retries]]

      6.    tunnel source {ip-address | interface-type interface-number}

      7.    tunnel destination {hostname | ip-address}

      8.    tunnel key key-number

      9.    tunnel mode gre { ip | multipoint}

      10.    ip mtu bytes

      11.    ip tcp mss mss-value

      12.    tunnel path-mtu-discovery [age-timer {aging-mins | infinite}]

      13.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。

       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface type number


      例:
      Router(config)# interface tunnel 0
       

      インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

      • トンネルを設定するには、type 引数に tunnel を使用します。

       
      ステップ 4 bandwidth kb/s


      例:
      Router(config-if)# bandwidth 1000
       

      インターフェイスに対する現在の帯域幅を設定し、上位レベル プロトコルと通信します。

      • パケットの送信に使用されるトンネル帯域幅を指定します。

      • 帯域幅をキロビット/秒単位(kb/s)で設定するには、kb/s 引数を使用します。

      (注)     

      これはルーティング パラメータにすぎないため、物理インターフェイスには影響を及ぼしません。 トンネル インターフェイスのデフォルトの帯域幅設定は 9.6 kb/s です。 トンネルの帯域幅を適切な値に設定する必要があります。

       
      ステップ 5 keepalive [period [retries]]


      例:
      Router(config-if)# keepalive 3 7
       

      (任意)トンネル インターフェイス プロトコルがダウン状態になるまで、デバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定します。

      • GRE キープアライブ パケットは、トンネルの片側または両側のどちらででも設定できます。

      • GRE キープアライブをトンネルの両側で設定した場合、リンクの各側の period 引数と retries 引数は異なる値に設定できます。

      (注)     

      このコマンドがサポートされるのは、GRE ポイントツーポイント トンネルだけです。

      (注)     

      GRE トンネルのキープアライブ機能は、VRF トンネルでは設定しないでください。 機能のこの組み合わせはサポートされていません。

       
      ステップ 6 tunnel source {ip-address | interface-type interface-number}


      例:
      Router(config-if)# tunnel source GigabitEthernet 0/0/0
       

      トンネル送信元を設定します。

      • 送信元 IP アドレスを指定するには、ip-address 引数を使用します。

      • 使用するインターフェイスを指定する場合は、interface-type 引数および interface-number 引数を使用します。

      (注)     

      トンネルの送信元 IP アドレスと宛先の IP アドレスは、2 つの個別のデバイス上で定義する必要があります。

       
      ステップ 7 tunnel destination {hostname | ip-address}


      例:
      Router(config-if)# tunnel destination 10.0.2.1
       

      トンネル宛先を設定します。

      • ホストの宛先の名前を指定するには、hostname 引数を使用します。

      • ホストの宛先の IP アドレスを指定する場合は、ip-address 引数を使用します。

      (注)     

      トンネルの送信元と宛先の IP アドレスは、2 つの個別のデバイス上で定義する必要があります。

       
      ステップ 8 tunnel key key-number


      例:
      Router(config-if)# tunnel key 1000
       

      (任意)トンネル インターフェイスの ID キーをイネーブルにします。

      • 各パケットで運ばれるトンネル キーを識別するには、key-number 引数を使用します。

      • トンネルの ID キーは、強度の劣るセキュリティ形式として使用して、外部ソースからのパケットの不適切な設定や挿入を防止できます。

      (注)     

      このコマンドがサポートされるのは、GRE トンネル インターフェイスだけです。 セキュリティ目的でこのキーに依存することは推奨しません。

       
      ステップ 9 tunnel mode gre { ip | multipoint}


      例:
      Device(config-if)# tunnel mode gre ip
       

      トンネルで使用されるカプセル化プロトコルを指定します。

      • IP カプセル化での GRE の使用を指定するには、gre ip キーワードを使用します。

      • マルチポイント GRE(mGRE)の使用を指定するには、gre multipoint キーワードを使用します。

       
      ステップ 10 ip mtu bytes


      例:
      Device(config-if)# ip mtu 1400
       

      (任意)各インターフェイスで送信される IP パケットの MTU サイズを設定します。

      • インターフェイスに設定されている MTU を IP パケットが超過した場合、DF ビットが設定されていなければ Cisco ソフトウェアは DF ビットをフラグメント化します。

      • 物理メディアのすべてのデバイスが動作するには、同じプロトコル MTU を持っている必要があります。

      • IPv6 パケットに対しては、ipv6 mtu コマンドを使用します。

      (注)     

      tunnel path-mtu-discovery コマンドが有効になっている場合、このコマンドを設定しないでください。

       
      ステップ 11 ip tcp mss mss-value


      例:
      Device(config-if)# ip tcp mss 250
       

      (任意)ルータ上で生成または終了する TCP 接続に対して、最大セグメント サイズ(MSS)を指定します。

      • TCP 接続に対する最大セグメント サイズをバイト単位で指定するには、mss-value 引数を使用します。

       
      ステップ 12 tunnel path-mtu-discovery [age-timer {aging-mins | infinite}]


      例:
      Device(config-if)# tunnel path-mtu-discovery
       

      (任意)GRE または IP-in-IP トンネル インターフェイスで PMTUD をイネーブルにします。

      • トンネル インターフェイスで PMTUD がイネーブルの場合、PMTUD は GRE IP トンネル パケット用に動作し、トンネル エンドポイント間のパス内のフラグメンテーションを最低限に抑えます。

       
      ステップ 13 end


      例:
      Device(config-if)# end
       

      インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

       

      次の作業

      「トンネルの設定と動作の確認」の項に進みます。

      6to4 トンネルの設定

      はじめる前に

      6to4 トンネルでは、トンネルの宛先は、境界ルータの IPv4 アドレスによって決定されます。このアドレスは、プレフィックス 2002::/16 と連結されて 2002:border-router-IPv4-address::/48 という形式になります。 6to4 トンネルの両端の境界ルータは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。


      (注)  


      IPv4 互換トンネル 1 つだけの設定、および 6to4 IPv6 トンネル 1 つだけの設定が、1 台のルータ上でサポートされます。 同じルータで両方のトンネル タイプの設定を選択する場合は、シスコは、これらが同じ送信元を共有しないようにすることを強く推奨します。

      6to4 トンネルと IPv4 互換トンネルが同じインターフェイスを共有できない理由は、これらがともに NBMA「ポイントツーマルチポイント」アクセス リンクであり、多重化されたパケット ストリームからのパケットを着信インターフェイスの単一パケット ストリームに再度配列するために、トンネルの送信元しか使用できないためです。 IPv4 プロトコル タイプが 41 のパケットがインターフェイスに到着すると、このパケットは IPv4 アドレスに基づいて、IPv6 トンネル インターフェイスにマッピングされます。 ただし、6to4 トンネルと IPv4 互換トンネルが同じ送信元インターフェイスを共有している場合、ルータは、着信パケットを割り当てるべき IPv6 トンネル インターフェイスを区別できません。

      手動で設定された IPv6 トンネルの場合、手動トンネルは「ポイントツーポイント」リンクであり、トンネルの IPv4 送信元と IPv4 宛先が両方とも定義されているため、同じ送信元インターフェイスを共有できます。


      手順の概要

        1.    enable

        2.    configure terminal

        3.    interface tunnel tunnel-number

        4.    ipv6 address ipv6-prefix/prefix-length [eui-64]

        5.    tunnel source {ip-address | interface-type interface-number}

        6.    tunnel mode ipv6ip 6to4

        7.    exit

        8.    ipv6 route ipv6-prefix / prefix-length tunnel tunnel-number

        9.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。

         
        ステップ 2 configure terminal


        例:
        Router# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 interface tunnel tunnel-number


        例:
        Router(config)# interface tunnel 0
         

        トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 4 ipv6 address ipv6-prefix/prefix-length [eui-64]


        例:
        Router(config-if)# ipv6 address 2002:c0a8:6301:1::1/64
         

        インターフェイスに割り当てられた IPv6 アドレスを指定し、インターフェイスでの IPv6 処理をイネーブルにします。

        • 最初の 2002::/16 プレフィックスに続く 32 ビットは、トンネル送信元に割り当てられた IPv4 アドレスに対応します。

        (注)     

        IPv6 アドレスの設定の詳細については、「Configuring Basic Connectivity for IPv6」モジュールを参照してください。

         
        ステップ 5 tunnel source {ip-address | interface-type interface-number}


        例:
        Router(config-if)# tunnel source GigabitEthernet 0/0/0
         

        トンネル インターフェイスの送信元 IPv4 アドレスまたは送信元インターフェイス タイプと番号を指定します。

        (注)     

        tunnel source コマンドで指定したインターフェイスのタイプおよび番号は、IPv4 アドレスを使用して設定する必要があります。

         
        ステップ 6 tunnel mode ipv6ip 6to4


        例:
        Router(config-if)# tunnel mode ipv6ip 6to4
         

        6to4 アドレスを使用する IPv6 オーバーレイ トンネルを指定します。

         
        ステップ 7 exit


        例:
        Router(config-if)# exit
         

        インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

         
        ステップ 8 ipv6 route ipv6-prefix / prefix-length tunnel tunnel-number


        例:
        Router(config)# ipv6 route 2002::/16 tunnel 0
         

        指定したトンネル インターフェイスへのスタティック ルートを設定します。

        (注)     

        6to4 オーバーレイ トンネルを設定する場合は、6to4 トンネル インターフェイスに IPv6 6to4 プレフィックス 2002::/16 のスタティック ルートを設定する必要があります。

        • ipv6 route コマンドで指定したトンネル番号は、interface tunnel コマンドで指定したトンネル番号と同じである必要があります。

         
        ステップ 9 end


        例:
        Router(config)# end
         

        グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

         

        次の作業

        「トンネルの設定と動作の確認」の項に進みます。

        トンネルの設定と動作の確認

        以下の手順にある show コマンドおよび ping コマンドは、任意の順序で実行できます。 次のコマンドは、GRE トンネル、IPv6 手動設定トンネル、および IPv4 GRE トンネルを介する IPv6 に使用できます。

        手順の概要

          1.    enable

          2.    show interfaces tunnel number [accounting]

          3.    ping [protocol] destination

          4.    show ip route [address [mask]]

          5.    ping [protocol] destination


        手順の詳細
          ステップ 1   enable

          特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。



          例:
          Device> enable
          ステップ 2   show interfaces tunnel number [accounting]

          2 台のルータがトンネルのエンドポイントとして設定されます。 デバイス A では、IPv4 アドレスが 10.0.0.1、IPv6 プレフィックスが 2001:0DB8:1111:2222::1/64 のトンネル インターフェイス 0 に対する送信元として、ギガビット イーサネット インターフェイス 0/0/0 が設定されています。 デバイス B では、IPv4 アドレスが 10.0.0.2、IPv6 プレフィックスが 2001:0DB8:1111:2222::2/64 のトンネル インターフェイス 1 に対する送信元として、ギガビット イーサネット インターフェイス 0/0/0 が設定されています。

          トンネル送信元およびトンネル宛先のアドレスが設定されていることを確認するには、デバイス A で show interfaces tunnel コマンドを使用します。



          例:
          Device A# show interfaces tunnel 0
          
          Tunnel0 is up, line protocol is up 
            Hardware is Tunnel
            MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
               reliability 255/255, txload 1/255, rxload 1/255
            Encapsulation TUNNEL, loopback not set
            Keepalive not set
            Tunnel source 10.0.0.1 (GigabitEthernet0/0/0), destination 10.0.0.2, fastswitch TTL 255
            Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
            Tunnel TTL 255
            Checksumming of packets disabled,  fast tunneling enabled
            Last input 00:00:14, output 00:00:04, output hang never
            Last clearing of "show interface" counters never
            Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
            Queueing strategy: fifo
            Output queue :0/0 (size/max)
            5 minute input rate 0 bits/sec, 0 packets/sec
            5 minute output rate 0 bits/sec, 0 packets/sec
               4 packets input, 352 bytes, 0 no buffer
               Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
               0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
               8 packets output, 704 bytes, 0 underruns
               0 output errors, 0 collisions, 0 interface resets
               0 output buffer failures, 0 output buffers swapped out
          
          ステップ 3   ping [protocol] destination

          ローカル エンドポイントが設定され、動作していることをチェックするには、デバイス A で ping コマンドを使用します。



          例:
          DeviceA# ping 2001:0DB8:1111:2222::2
          
          Type escape sequence to abort.
          Sending 5, 100-byte ICMP Echos to 2001:0DB8:1111:2222::2, timeout is 2 seconds:
          !!!!!
          Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
          
          ステップ 4   show ip route [address [mask]]

          リモート エンドポイント アドレスへのルートが存在することを確認するには、show ip route コマンドを使用します。



          例:
          DeviceA# show ip route 10.0.0.2
          
          Routing entry for 10.0.0.0/24
            Known via "connected", distance 0, metric 0 (connected, via interface)
            Routing Descriptor Blocks:
            * directly connected, via GigabitEthernet0/0/0
                Route metric is 0, traffic share count is 1 
          
          ステップ 5   ping [protocol] destination

          リモート エンドポイント アドレスに到着できることを確認するには、デバイス A で ping コマンドを使用します。

          (注)     

          フィルタリングが原因で、ping コマンドを使用してリモート エンドポイント アドレスに到着できない場合がありますが、トンネル トラフィックは依然としてその宛先に到着している場合があります。



          例:
          DeviceA# ping 10.0.0.2
          
          Type escape sequence to abort.
          Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
          !!!!!
          Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/28 ms
          

          リモート IPv6 トンネル エンドポイントが到着可能であることを確認するには、デバイス A で ping コマンドを再び使用します。 この手順の前半のフィルタリングに関する説明も、この例に適用されます。



          例:
          DeviceA# ping 2001:0DB8:1111:2222::2
          
          Type escape sequence to abort.
          Sending 5, 100-byte ICMP Echos to 1::2, timeout is 2 seconds:
          !!!!!
          Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
          

          これらの手順は、トンネルのもう一方のエンドポイントで繰り返すことができます。


          トンネル実装の設定例

          例:GRE IPv4 トンネルの設定

          GRE トンネリングの単純な設定例を次に示します。 ギガビット イーサネット インターフェイス 0/0/1 はルータ A のトンネル送信元であり、ルータ B のトンネル宛先です。 ファスト イーサネット インターフェイス 0/0/1 はルータ B のトンネル送信元であり、ルータ A のトンネル宛先です。

          ルータ A

          interface Tunnel 0
           ip address 10.1.1.2 255.255.255.0
           tunnel source GigabitEthernet 0/0/1
           tunnel destination 192.168.3.2
           tunnel mode gre ip
          !
          interface GigabitEthernet 0/0/1
           ip address 192.168.4.2 255.255.255.0

          ルータ B

          interface Tunnel 0
           ip address 10.1.1.1 255.255.255.0
           tunnel source FastEthernet 0/0/1
           tunnel destination 192.168.4.2
           tunnel mode gre ip
          !
          interface FastEthernet 0/0/1
           ip address 192.168.3.2 255.255.255.0
          

          次に、ルータ A とルータ B との間で IS-IS および IPv6 トラフィックをともに送出する GRE トンネルを設定する例を示します。

          ルータ A

          ipv6 unicast-routing
          clns routing
          !
          interface Tunnel 0
           no ip address
           ipv6 address 2001:0DB8:1111:2222::1/64
           ipv6 router isis 
           tunnel source GigabitEthernet 0/0/0
           tunnel destination 10.0.0.2
           tunnel mode gre ip
          !
          interface GigabitEthernet 0/0/0
           ip address 10.0.0.1 255.255.255.0
          !
          router isis 
           network 49.0000.0000.000a.00

          ルータ B

          ipv6 unicast-routing
          clns routing
          !
          interface Tunnel 0
           no ip address
           ipv6 address 2001:0DB8:1111:2222::2/64
           ipv6 router isis 
           tunnel source GigabitEthernet 0/0/0
           tunnel destination 10.0.0.1
           tunnel mode gre ip
          !
          interface GigabitEthernet 0/0/0
           ip address 10.0.0.2 255.255.255.0
          !
          router isis 
           network 49.0000.0000.000b.00
           address-family ipv6
           redistribute static
           exit-address-family

          例:EoMPLS over GRE の設定

          ルータ A の設定

          vrf definition VPN1
           rd 100:1
           address-family ipv4
           route-target both 100:1
           exit-address-family
           !
          mpls label protocol ldp
          mpls ldp neighbor 209.165.200.224 targeted 
          mpls ldp router-id Loopback0 force
          !
          interface tunnel 0
           ip address 209.165.200.225 255.255.255.224
           mpls label protocol ldp
           mpls ip
           keepalive 10 3
           tunnel source TenGigabitEthernet 2/1/0
           tunnel destination 209.165.200.226
          !
          interface Loopback 0
           ip address 209.165.200.230 255.255.255.224
           !
          interface TenGigabitEthernet 2/1/0 
           mtu 9216
           ip address 209.165.200.235 255.255.255.224
          !
          interface TenGigabitEthernet 9/1
           no ip address
          !
          interface TenGigabitEthernet 9/1.11
           vrf forwarding VPN1
           encapsulation dot1Q 300
           ip address 209.165.200.237 255.255.255.224
          !
          interface TenGigabitEthernet 9/2
           mtu 9216
           no ip address
          xconnect 209.165.200.239 200 encapsulation mpls
          !
          router bgp 65000
           bgp log-neighbor-changes
           neighbor 209.165.200.240 remote-as 65000
           neighbor 209.165.200.240 update-source Loopback0
          neighbor 209.165.200.245 remote-as 100
           !
          address-family vpnv4
            neighbor 209.165.200.240 activate
            neighbor 209.165.200.240 send-community extended
           !
           address-family ipv4 vrf VPN1
            no synchronization
            neighbor 209.165.200.247 remote-as 100
            neighbor 209.165.200.248 activate
            neighbor 209.165.200.249 send-community extended
          !
          ip route 209.165.200.251 255.255.255.224 tunnel 0
          ip route 209.165.200.254 255.255.255.224 209.165.200.256
          Router B Configuration
          vrf definition VPN1
           rd 100:1
           address-family ipv4
           route-target both 100:1
          exit-address-family
           !
          mpls ldp neighbor 209.165.200.229 targeted
          mpls label protocol ldp
          mpls ldp router-id Loopback0 force
          !
          interface tunnel 0
           ip address 209.165.200.230 255.255.255.224
           mpls label protocol ldp
           mpls ip
           keepalive 10 3
           tunnel source TenGigabitEthernet 3/3/0
           tunnel destination 209.165.200.232
          !
          interface Loopback 0
           ip address 209.165.200.234 255.255.255.224
          !
          interface TenGigabitEthernet 2/1/1
           mtu 9216
           no ip address
           xconnect 209.165.200.237 200 encapsulation mpls  
          !
          interface TenGigabitEthernet 2/3/1
           mtu 9216
           no ip address
          !
          interface TenGigabitEthernet 2/3.11/1
           vrf forwarding VPN1
           encapsulation dot1Q 300
           ip address 209.165.200.239 255.255.255.224
          !
          interface TenGigabitEthernet 3/3/0
           mtu 9216
           ip address 209.165.200.240 255.255.255.224
          !
          router bgp 65000
           bgp log-neighbor-changes
           neighbor 209.165.200.241 remote-as 65000
           neighbor 209.165.200.241 update-source Loopback0
           neighbor 209.165.200.244 remote-as 200
           !
           address-family vpnv4
            neighbor 209.165.200.241 activate
            neighbor 209.165.200.241 send-community extended
           exit-address-family
           !
           address-family ipv4 vrf VPN1
            no synchronization
            neighbor 209.165.200.246 remote-as 200
            neighbor 209.165.200.246 activate
            neighbor 209.165.200.246 send-community extended
           exit-address-family
          ¡
          ip route 209.165.200.226 255.255.255.224 tunnel 0
          ip route 209.165.200.229 255.255.255.224 209.165.200.235
          

          トンネル インターフェイスでの QoS オプションの設定例

          次の設定例は、トンネル インターフェイスの GTS に直接適用されます。 この例では、設定によりトンネル インターフェイスが総出力レート 500 kb/s にシェーピングされます。

          interface Tunnel 0 
           ip address 10.1.2.1 255.255.255.0 
           traffic-shape rate 500000 125000 125000 1000 
           tunnel source 10.1.1.1 
           tunnel destination 10.2.2.2
          

          次の設定例では、MQC コマンドを使用して同じシェーピング ポリシーをトンネル インターフェイスに適用する方法を示しています。

          policy-map tunnel 
           class class-default 
           shape average 500000 125000 125000
          ! 
          interface Tunnel 0 
           ip address 10.1.2.1 255.255.255.0 
           service-policy output tunnel 
           tunnel source 10.1.35.1 
           tunnel destination 10.1.35.2

          ポリシングの例

          インターフェイスが混雑しており、パケットのキューイングを開始した場合、送信待ちのパケットにキューイング方式を適用できます。 論理インターフェイス(この例に挙げているトンネル インターフェイス)では本来、輻輳状態はサポートされておらず、キューイング方式を適用するサービス ポリシーの直接適用はサポートされていません。 代わりに、階層型ポリシーを適用します。 priority コマンドを使用した低遅延キューイングや、bandwidth コマンドを使用した CBWFQ などのキューイング メカニズムを設定する「子」ポリシー、つまり下位ポリシーを作成します。

          policy-map child 
           class voice 
           priority 512
          

          クラスベース シェーピングを適用する「親」ポリシー、つまり上位ポリシーを作成します。 子クラスのアドミッション制御は親クラスのシェーピング比率に従って実行されるので、親ポリシー下で子ポリシーをコマンドとして適用します。

          policy-map tunnel 
           class class-default 
           shape average 2000000 
           service-policy child
          

          親ポリシーをトンネル インターフェイスに適用します。

          interface tunnel 0 
           service-policy tunnel
          

          次の例では、トンネル インターフェイスは、シェーピングを行わないキューイングを適用するサービス ポリシーを使用して設定されます。 この設定がサポートされないことを通知するログ メッセージが表示されます。

          Router(config)# interface tunnel1
          Router(config-if)# service-policy output child
          Class Based Weighted Fair Queueing not supported on this interface

          その他の関連資料

          ここでは、トンネルの実装に関する関連資料について説明します。

          関連資料

          関連項目

          マニュアル タイトル

          すべての Cisco IOS XE コマンド

          Cisco IOS Master Command List, All Releases

          トンネル コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

          『Cisco IOS Interface and Hardware Component Command Reference』

          IPv6 コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

          『Cisco IOS IPv6 Command Reference』

          Cisco IOS XE Interface and Hardware Component コンフィギュレーション モジュール

          Cisco IOS XE Interface and Hardware Component Configuration Guide, Release 2』

          Cisco IOS XE IPv6 コンフィギュレーション モジュール

          Cisco IOS XE IPv6 Configuration Guide, Release 2』

          Cisco IOS XE Quality of Service Solutions コンフィギュレーション モジュール

          『Cisco IOS XE Quality of Service Solutions Configuration Guide』

          Cisco IOS XE Multiprotocol Label Switching コンフィギュレーション モジュール

          『Cisco IOS XE Multiprotocol Label Switching Configuration Guide』

          VRF 対応ダイナミック マルチポイント VPN(DMVPN)の設定例

          Cisco IOS XE Security Configuration Guide: Secure Connectivity』の「Dynamic Multipoint VPN (DMVPN)」コンフィギュレーション モジュール

          標準/RFC

          標準

          タイトル

          新しい標準または変更された標準はサポートされていません。また、既存の標準に対するサポートに変更はありません。

          --

          RFC 791

          『Internet Protocol』

          RFC 1191

          『Path MTU Discovery』

          RFC 1323

          『TCP Extensions for High Performance』

          RFC 1483

          『Multiprotocol Encapsulation over ATM Adaptation Layer 5』

          RFC 2003

          『IP Encapsulation Within IP』

          RFC 2018

          『TCP Selective Acknowledgment Options』

          RFC 2460

          『Internet Protocol, Version 6 (IPv6)』

          RFC 2473

          『Generic Packet Tunneling in IPv6 Specification』

          RFC 2474

          『Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers』

          RFC 2516

          『A Method for Transmitting PPP over Ethernet (PPPoE)』

          RFC 2547

          『BGP/MPLS VPNs』

          RFC 2780

          『IANA Allocation Guidelines for Values in the Internet Protocol and Related Headers』

          RFC 2784

          『Generic Routing Encapsulation (GRE)』

          RFC 2890

          『Key and Sequence Number Extensions to GRE』

          RFC 2893

          『Transition Mechanisms for IPv6 Hosts and Routers』

          RFC 3056

          『Connection of IPv6 Domains via IPv4 Clouds』

          RFC 3147

          『Generic Routing Encapsulation over CLNS Networks』

          テクニカル サポート

          説明

          リンク

          右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          トンネル実装の機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

          表 2 トンネル実装の機能情報

          機能名

          リリース

          機能情報

          EoMPLS over GRE

          Cisco IOS XE Release 2.5

          EoMPLS over GRE 機能により、レイヤ 3 MPLS ネットワークを経由してレイヤ 2 トラフィックをトンネリングできます。 またこの機能では、GRE トンネル内で EoMPLS フレームをカプセル化する高性能のハードウェアベースのスイッチド トンネルとして GRE トンネルを作成できます。

          この機能によって導入または変更された新しいコマンドはありません。

          GRE トンネルの IP 送信元および宛先の VRF メンバーシップ

          Cisco IOS XE Release 2.2

          GRE トンネルの IP 送信元および宛先の VRF メンバーシップ機能により、任意の VPN VRF テーブルに属するようにトンネルの送信元と宛先を設定できます。

          tunnel vrf コマンドが導入または変更されました。

          GRE トンネル キープアライブ

          Cisco IOS XE Release 2.1

          GRE トンネル キープアライブ機能により、IP カプセル化された GRE トンネルを介してキープアライブ パケットが送信されるように設定できるようになります。 キープアライブが送信されるレートと、インターフェイスが非アクティブになるまでデバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定できます。 GRE キープアライブ パケットは、トンネルの両側または片側のみのどちらでも送信できます。

          この機能により、keepalive(トンネル インターフェイス)コマンドが導入されました。

          IPv6 を介する IP トンネル

          Cisco IOS XE Release 2.4

          この機能により、tunnel destinationtunnel mode、および tunnel source の各コマンドが導入されました。

          GRE トンネル向け IP Precedence

          Cisco IOS XE Release 2.1

          この機能は、Cisco ASR 1000 アグリゲーション サービス ルータに導入されました。

          IP トンネル:SSO

          Cisco IOS XE Release 3.6

          ハイ アベイラビリティのサポートが、IP トンネルに追加されました。

          この機能によって導入または変更された新しいコマンドはありません。

          Tunnel ToS(ToS)

          Cisco IOS XE Release 2.1

          Tunnel ToS 機能を使用して、ルータの IP トンネル インターフェイス向けのトンネル パケットのカプセル化 IP ヘッダーに、ToS および Time-to-Live(TTL)バイト値を設定できます。 Tunnel ToS 機能は、シスコ エクスプレス フォワーディング、高速スイッチング、およびプロセス スイッチング フォワーディングの各モードでサポートされます。

          この機能により、show interfaces tunneltunnel tostunnel および ttl の各コマンドが導入または変更されました。