インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
GRE を介するイーサネット トンネルの QoS
GRE を介するイーサネット トンネルの QoS

GRE を介するイーサネット トンネルの QoS

GRE を介するイーサネット(EoGRE)トンネルの QoS 機能によって、サービス プロバイダーは、すべてのエンドポイントに対して 1 つの共通の Quality of Service(QoS)を設定することができます。その場合に、エンドポイントは顧客宅内機器(CPE)または CPE の VLAN です。 この機能は、ルート プロセッサのハイ アベイラビリティをサポートします。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

GRE を介するイーサネット トンネルの QoS に関する情報

EoGRE ダウンストリーム QoS

Ethernet over GRE(EoGRE)トンネルの Quality of Service(QoS)機能により、サービス プロバイダーは、トンネルのすべてのエンドポイントに統一した QoS ポリシーを適用できます。 これは、パブリック加入者がダウンロードできる帯域幅を制御し、プライベート顧客用の最大帯域幅を確保できるようにします。

次の表で示される展開シナリオでは、使用可能な WAN 全帯域幅は、顧客宅内機器(CPE)で10 Mbps、パブリック ユーザで 2 Mbps、残りの帯域幅を個人ユーザ用に使用できます。

図 1. EoGRE ダウンストリーム QoS 使用事例

単一 SSID

モバイル ノードはワイヤレス アクセス ポイント(AP)に接続します。 これらの AP は、サービス プロバイダーから提供されたサービス セット ID(SSID)を使用します。 顧客宅内機器(CPE)の SSID は VLAN ID です。 サービス プロバイダーは CPE で複数のパブリック SSID を提供できます。 CPE に複数の SSID がある場合、追加の mGRE トンネルは対応する VLAN タグを使用して設定されます。 設定されたマルチポイント総称ルーティング カプセル化(mGRE)トンネルは、リモート加入者および対応する CPE に関して個別に認識します。 これによって確実にVLAN、サブネット、デフォルト ゲートウェイ、および VRF が個別に保持され、相互に依存しません。これらのトンネルの各エンドポイントで設定された任意の QoS ポリシーが CPE で VLAN からのトラフィックに適用されます。

図 2. 各 SSID の個別のトンネル

複数 SSID

複数のサービス セット ID(SSID)の単一トンネルでは、サービス プロバイダーがマルチポイント総称ルーティング カプセル化(mGRE)トンネルで VLAN 範囲を設定できます。 加入者トラフィックを受信した場合、トラフィックはトンネル送信元および VLAN 範囲に従って一致します。 また、Ethernet over GRE(EoGRE)制御プロセスは、加入者の MAC アドレスおよびトラフィックが生成される CPE の VLAN タグを認識します。


(注)  


任意の加入者セッションまたは MAC アドレスが EoGRE 制御プロセスですでに認識されている場合、VLAN 設定を変更できません。 VLAN 設定を変更するには、すべての加入者セッションをクリアする必要があります。


次の図では、Tunnel 1 で認識されたすべてのエンドポイントが CPE を表し、このトンネル エンドポイントに適用される Quality of Service(QoS)ポリシーは VLAN に関係なく CPE に向かうすべてのトラフィックに適用されます。

図 3. 複数 SSID の単一トンネル

GRE を介するイーサネット トンネルの QoS の設定方法

GRE を介するイーサネット トンネルのダウンストリーム QoS ポリシーの設定

はじめる前に

GRE を介するイーサネット(EoGRE)トンネルに対応付ける Quality of Service(QoS)ポリシー マップを作成します。


(注)  


QoS ポリシー マップの作成方法は、次のタスクで説明していません。


手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    interface source {ip-address | ipv6-address | interface-type interface-number}

    5.    tunnel vlan vlan-id

    6.    ip address ip-address mask

    7.    tunnel mode ethernet gre {ipv4 | ipv6}

    8.    tunnel endpoint service-policy output policy-map-name

    9.    ip subscriber l2-connected

    10.    initiator unclassified mac-address

    11.    initiator dhcp

    12.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 1
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4interface source {ip-address | ipv6-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source loopback 2
     

    トンネル インターフェイスの送信元アドレスを設定します。

     
    ステップ 5tunnel vlan vlan-id


    例:
    Device(config-if)# tunnel vlan 10, 20
     

    GRE を介するイーサネット トンネルに VLAN ID を関連付けます。

     
    ステップ 6ip address ip-address mask


    例:
    Device(config-if)# ip address 192.168.4.3 255.255.255.0
     

    モバイル ノードの IP アドレスおよびマスクを指定します。

     
    ステップ 7tunnel mode ethernet gre {ipv4 | ipv6}


    例:
    Device(config-if)# tunnel mode ethernet gre ipv4
     

    GRE IPv4 または GRE IPv6 を介するイーサネットにトンネルのカプセル化モードを設定します。

     
    ステップ 8tunnel endpoint service-policy output policy-map-name


    例:
    Device(config-if)# tunnel endpoint service-policy output tunnel-qos-policy
     

    トンネル エンドポイントに対して QoS ポリシーを設定します。

     
    ステップ 9ip subscriber l2-connected


    例:
    Device(config-if)# ip subscriber l2-connected
     

    IP サブスクライバ コンフィギュレーション モードを開始します。

     
    ステップ 10initiator unclassified mac-address


    例:
    Device(config-subscriber)# initiator unclassified mac-address
     

    分類されていない MAC アドレスから IP セッションを開始します。

     
    ステップ 11initiator dhcp


    例:
    Device(config-subscriber)# initiator dhcp
     

    DHCP によって開始された IP セッションをイネーブルにします。

     
    ステップ 12end


    例:
    Device(config-subscriber)# end
     

    グローバル コンフィギュレーション モードに戻ります。

     

    GRE を介するイーサネット トンネルの QoS の確認

    show コマンドは、任意の順番で入力できます。

    はじめる前に

    GRE を介するイーサネット(EoGRE)トンネルの QoS を設定します。

    手順の概要

      1.    show interface tunnel tunnel-interface

      2.    show tunnel endpoints tunnel tunnel-interface

      3.    show tunnel mac-table tunnel tunnel-interface

      4.    show policy-map multipoint tunnel tunnel-interface


    手順の詳細
      ステップ 1   show interface tunnel tunnel-interface

      このコマンドは、トンネルに関する情報を表示します。



      例:
      Device# show interface tunnel 1
      
      Tunnel1 is up, line protocol is up
      Hardware is Tunnel
      Internet address is 11.1.1.1/24
      MTU 17846 bytes, BW 100 Kbit/sec, DLY 50000 usec, reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation TUNNEL, loopback not set
      Keepalive not set
      Tunnel source 10.0.0.1
      Tunnel MAC address 0000.5e00.5213
      Tunnel Vlan-id 1
      Tunnel protocol/transport Ethernet-GRE/IP Key 0x1, sequencing disabled Checksumming of packets disabled
      Tunnel TTL 255
      Tunnel transport MTU 1454 bytes
      Tunnel transmit bandwidth 8000 (kbps) Tunnel receive bandwidth 8000 (kbps)
      Last input 00:48:08, output never, output hang never
      Last clearing of "show interface" counters 00:48:26
      Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 107
      Queueing strategy: fifo
      Output queue: 0/0 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      1867 packets input, 161070 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      43 packets output, 4386 bytes, 0 underruns
      0 output errors, 0 collisions, 0 interface resets
      0 unknown protocol drops
      0 output buffer failures, 0 output buffers swapped out ind-uut#
      --- 22:03:51 ---
      44: 2013-01-30T22:03:51: %SCRIPT-6-INFO: {_haExecCmd: Executing cmd exec with ind-uut-a}
      
      
      Device# show interface tunnel 2
      
      Tunnel2 is up, line protocol is up
      Hardware is Tunnel
      Internet address is 10.1.1.1/24
      MTU 1434 bytes, BW 100 Kbit/sec, DLY 50000 usec, reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation TUNNEL, loopback not set
      Keepalive not set
      Tunnel source 10::1
      Tunnel MAC address 0000.5e00.5213
      Tunnel Vlan-id 2
      Tunnel protocol/transport Ethernet-GRE/IPv6
      Key 0x2, sequencing disabled
      Checksumming of packets disabled
      Tunnel TTL 255
      Path MTU Discovery, ager 10 mins, min MTU 1280
      Tunnel transport MTU 1434 bytes
      Tunnel transmit bandwidth 8000 (kbps) Tunnel receive bandwidth 8000 (kbps)
      Last input never, output never, output hang never
      Last clearing of "show interface" counters 00:48:28
      Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 106
      Queueing strategy: fifo
      Output queue: 0/0 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      0 packets input, 0 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      0 packets output, 0 bytes, 0 underruns
      0 output errors, 0 collisions, 0 interface resets
      0 unknown protocol drops
      0 output buffer failures, 0 output buffers swapped out 
      
      ステップ 2   show tunnel endpoints tunnel tunnel-interface

      このコマンドは、トンネル インターフェイスのエンドポイントを表示し、トンネルが正しく作成されているかを確認します。



      例:
      Device# show tunnel endpoints tunnel
      
      Tunnel0 running in Ethernet-GRE/IP mode
      
      Endpoint transport 10.1.1.1 Refcount 3 Base 0x2A98DD03C0 Create Time 3d02h
         overlay 10.1.1.1 Refcount 2 Parent 0x2A98DD03C0 Create Time 3d02h
       Endpoint transport 3.3.3.3 Refcount 3 Base 0x2A98DD0300 Create Time 3d02h
         overlay 10.1.1.3 Refcount 2 Parent 0x2A98DD0300 Create Time 3d02h
      
      ステップ 3   show tunnel mac-table tunnel tunnel-interface

      このコマンドは、トンネルに関連付けられた MAC テーブル エントリを表示します。



      例:
      Device# show tunnel mac-table tunnel0
      
      overlay-address 30.0.0.21, transport-address 192.168.0.50
      mac-address 0000.1200.0001, vlan 400 Mac Age 3d06h
      
      overlay-address 60.0.0.8, transport-address 120.0.40.2
      mac-address 3010.e495.b058, vlan 10 Mac Age 00:01:00
      
      
      ステップ 4   show policy-map multipoint tunnel tunnel-interface

      このコマンドは、トンネルに関連付けられたポリシーマップを表示します。



      例:
      Device> show policy-map multipoint tunnel 1
      
      Interface Tunnel 1 <--> 1.1.1.1
        Service-policy output: test
          Class-map: class-default (match-any)
            0 packets, 0 bytes
            5 minute offered rate 0000 bps, drop rate 0000 bps
            Match: any
            police:rate 300000 bps, burst 17898 bytes
            conformed 0 packets, 0 bytes;actions:transmit 
            exceeded 0 packets, 0 bytes; actions:drop
              conformed 0000 bps, exceeded 0000 bps
      
      

      GRE を介するイーサネット トンネルの QoS の設定例

      例:GRE を介するイーサネット トンネルの QoS

      モバイル ノードでの GRE を介するイーサネット(EoGRE)の設定

      ! configure the topology
      mobile-node1(config-if)# interface GigabitEthernet0/1
      mobile-node1(config-if)# ip address 10.21.1.1 255.255.255.0
      mobile-node1(config-if)# no shutdown
      mobile-node1(config-if)# exit
      mobile-node1(config)# ip route 10.0.0.1 255.255.255.255 10.21.1.2
      
      ! Configure the interface used as the source of the tunnel
      mobile-node1(config)# interface Loopback0
      mobile-node1(config-if)# ip address 10.40.0.1 255.255.255.0 
      mobile-node1(config-if)# ipv6 address 2001:db8:2:40::1/64
      mobile-node1(config-if)# no shutdown
      
      ! Configure the Ethernet over GRE IPv4 Tunnel
      mobile-node1(config-if)# interface Tunnel1
      mobile-node1(config-if)# mac-address 0000.0000.0001
      mobile-node1(config-if)# ip dhcp client client-id ascii MN1@cisco.com 
      mobile-node1(config-if)# ip address dhcp
      mobile-node1(config-if)# no ip redirects 
      mobile-node1(config-if)# no ip route-cache
      mobile-node1(config-if)# tunnel source Loopback0
      mobile-node1(config-if)# tunnel mode ethernet gre ipv4 
      mobile-node1(config-if)# tunnel key 1 
      mobile-node1(config-if)# tunnel vlan 10, 20
      mobile-node1(config-if)# no shutdown
      mobile-node1(config-if)# exit
      
      Configuring Ethernet over GRE tunnel on the MAG
      
      ! Configure the topology
      MAG(config)# interface FastEthernet1/1/5
      MAG(config-if)# ip address 10.21.1.2 255.255.255.0 
      MAG(config-if)# ipv6 address 2001:db8:2:21::2/64
      MAG(config-if)# no shutdown
      MAG(config)# ip route 10.40.0.1 255.255.255.255 10.21.1.1
      
      ! Configure the interface used as source of the tunnel
      MAG(config-if)# interface Loopback0
      MAG(config-if)# ip address 10.0.0.1 255.255.255.0 
      MAG(config-if)# no shutdown
      
      ! configure the policy map
      MAG(config)# policy-map tunnel-qos-policy
      MAG(config-pmap)# class class-default
      MAG(config-pmap-c)# police rate 200000 bps
      MAG(config-pmap-c)# exit
      
      ! Configure the Ethernet over GRE IPv4 Tunnel
      MAG(config)# interface Tunnel1
      MAG(config-if)# ip address 10.11.1.1 255.255.255.0 
      MAG(config-if)# tunnel mode ethernet gre ipv4
      MAG(config-if)# tunnel source Loopback0
      
      ! Configure a static GRE and VLAN ID for the tunnel
      MAG(config-if)# tunnel key 1
      MAG(config-if)# tunnel vlan 10, 20
       
      !Associate the QoS policy to the tunnel interface
      MAG(config-if)# tunnel endpoint service-policy output tunnel-qos-policy
      
      ! Enable ISG on the tunnel
      MAG(config-if)# ip subscriber l2-connected
      MAG(config-subscriber)# initiator unclassified mac-address
      MAG(config-subscriber)# initiator dhcp
      MAG(config-subscriber)# exit
      
      

      GRE を介するイーサネット トンネルの QoS のその他の関連資料

      関連資料

      関連項目

      マニュアル タイトル

      Cisco IOS コマンド

      『Cisco IOS Master Command List, All Releases』

      GRE を介するイーサネット トンネル

      『Cisco IOS Interface and Hardware Component Configuration Guide』

      トンネル コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

      『Interface and Hardware Component Command Reference』

      テクニカル サポート

      説明

      リンク

      シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

      お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

      シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      GRE を介するイーサネット トンネルの QoS の機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

      表 1 GRE を介するイーサネット トンネルの QoS の機能情報

      機能名

      リリース

      機能情報

      GRE を介するイーサネット トンネルの QoS

      Cisco IOS XE 3.13S

      GRE を介するイーサネット(EoGRE)トンネルの QoS 機能により、サービス プロバイダーはすべてのエンドポイントに共通の QoS ポリシーを設定できます。 この機能は、ルート プロセッサのデュアル ハイ アベイラビリティをサポートします。

      この機能により、tunnel endpoint service-policy output コマンドが導入されました。