インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
GRE を介するイーサネット トンネル
GRE を介するイーサネット トンネル

GRE を介するイーサネット トンネル

GRE を介するイーサネット トンネル機能によって、ユーザは、プロキシ モバイル IPv6(PMIPv6)、General Packet Radio Service(GPRS)トンネリング プロトコル(GTP)および Intelligent Service Gateway(ISG)を使用してモバイル ノードにモビリティ サービスを提供する既存のローエンド Residential Gateways を活用できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

GRE を介するイーサネット トンネルの制約事項

  • モバイル ノードは、IPv4 アドレスのみを持つことができます。

  • IPv6 モバイル クライアントはサポートされません。

GRE を介するイーサネット トンネルに関する情報

GRE を介するイーサネット トンネルの機能により、ユーザはモバイル ノードにモビリティ サービスを提供するために既存のローエンド レジデンシャル ゲートウェイを活用することができます。

サービス プロバイダー Wi-Fi 空間の需要が拡大すると、シスコのお客様は、パブリック ホットスポットを使用してインターネットおよびモバイル サービスへのアクセスを提供する必要があります。 ハイエンド RG は、プロキシ モバイル IPv6 (PMIPv6)、Intelligent Services Gateway(ISG)または General Packet Radio Service(GPRS)トンネリング プロトコル(GTP)を使用してこれらのモビリティ サービスを提供できます。

ローエンド RG または顧客宅内機器(CPE)は、モバイル ノードからハイエンド デバイスにトラフィックを転送するために使用できます。 これらの RG または CPE は、ブリッジ モードで設定でき、総称ルーティング カプセル化(GRE)を介するイーサネット トンネルはアグリゲーション デバイスへのイーサネット トラフィックを転送するために使用できます。

モバイル ノードは、Wi-Fi アクセス ポイント(AP)を介してインターネットにアクセスします。 AP はワイヤレス LAN コントローラ(WLC)に対して自律的に動作するか、または接続されます。 これらの AP および WLC は、一般に RG または CPE と呼ばれます。 CPE は個人またはコミュニティの住宅にあり、非対称 DSL(ADSL)モデム、またはケーブル モデムなどの接続メカニズムを介してサービス プロバイダー ネットワークに接続できます。 接続メカニズムは、アグリゲーション デバイスに対して透過的です。

これらの CPE は、ブロードバンド アクセス サービスの一環としてサービス プロバイダーが提供、プロビジョニング、管理します。 通常は、Wi-FI AP およびサービス プロバイダーへのバックエンド パイプに追加の帯域幅があり、近隣のローミング ユーザにモバイル インターネット サービスを提供するために使用できます。

PMIPv6 を使用したモビリティ サービス

モバイル デバイスにモビリティ サービスを提供するために PMIPv6 を使用できますが、Mobile Access Gateways(MAG)機能を備えたハイエンド RG が必要です。

RG または CPE により、GRE を介したイーサネット トンネルを使用してモバイル ノードから MAG 対応アグリゲーション デバイスにトラフィックを転送することもできます。

アグリゲーション デバイスでは、物理イーサネット インターフェイス上の通常の IP セッションと同様の方法で、IP セッションを作成し、IP アドレス(ローカルまたはプロキシ モード)を割り当てることができます。

図 1. PMIPv6 を使用したモビリティ サービス

上の図に示した展開シナリオで、MAG-1 および MAG-2 は、アクセス側からトンネリングされたイーサネットのトラフィックを処理するように設定され、1 つ以上のローカル モビリティ アンカー(LMA)に対して通常の IP トンネルを持ちます。

GTP を使用したモビリティ サービス

モバイル デバイスにモビリティ サービスを提供するために GTP を使用できますが、拡張 Wireless Access Gateway 機能を備えたハイエンド RG が必要です。

RG または CPE により、GRE を介するイーサネット トンネルを使用してモバイル ノードから 拡張 Wireless Access Gateways デバイスにトラフィックを転送することもできます。

図 2. GTP を使用したモビリティ サービス

上の図に示した展開シナリオで、eWAG-1 および eWAG-2 は、アクセス側からトンネリングされたイーサネットのトラフィックを処理するように設定され、1 つ以上の Gateway Cisco General Packet Radio Service(GPRS)サポート ノード(GGSN)デバイスに対して 1 つ以上の GTP トンネルを持ちます。

ISG を使用したモビリティ サービス

モバイル デバイスに簡易 IP サービスを提供するために ISG を使用できますが、ISG 機能を備えたハイエンド RG が必要です。

RG または CPE により、次の図に示すように GRE を介するイーサネット トンネルを使用してモバイル ノードから ISG デバイスにトラフィックを転送することもできます。

図 3. ISG を使用したモビリティ サービス

GRE を介するイーサネット トンネルがサポートする機能

GRE を介するイーサネット トンネルは以下の機能をサポートします。

  • モビリティ サービスは総称ルーティング カプセル化(GRE)を介するイーサネット トンネルを使用して既存のローエンド Residential Gateway (RG)を使用するとモバイル ノードを提供することができます。 Intelligent Services Gateway(ISG)、プロキシ モバイル IPv6(PMIPv6)、および GPRS トンネリング プロトコル(GTP)は、モビリティ サービスを提供するために使用できます。

  • イーサネット フレームは、IPv6 および IPv4 インフラストラクチャを介して転送できます。 顧客宅内機器(CPE)は、ポイントツーポイント総称ルーティング カプセル化(GRE)IPv4 または IPv6 トンネルを用いて事前設定されます。 トンネルの宛先は、アグリゲーション デバイスの既知の IPv4 アドレスまたは IPv6 アドレスです。

  • トンネルは単一 VLAN の一部となるように設定できます。CPE はイーサネット フレームで VLAN タグを入力できます。 1 つの VLAN タグのみがサポートされます。

  • トンネルは、スタティックに設定された対称 GRE キーで設定できます。 このキーを設定するには、tunnel key コマンドを使用します。

  • セッションは、DHCP for IPv4(DNAv4)、未分類 MAC、Address Resolution Protocol(ARP)Detecting Network Attachments for IPv4(DHCPv4)で作成できます。

GRE を介するイーサネット トンネルのトンネル カプセル化

GRE を介するイーサネット トンネルのトンネル カプセル化は、下の図に示されるように、マルチポイント総称ルーティング カプセル化(mGRE)でトンネルをカプセル化する方法と同様です。

図 4. GRE を介するイーサネット トンネルと mGRE トンネルの比較

mGRE トンネルは、複数のトンネル エンドポイントを処理できる非ブロードキャスト マルチアクセス(NBMA)のインターフェイスです。 mGRE トンネルは、異なるエンドポイントから GRE カプセル化 IPv4/IPv6 トランスポート フレームで IPv4、IPv6、およびマルチプロトコル ラベル スイッチング(MPLS)などのペイロードを転送できます。これは、特定のエンドポイントに送信することができます。 送信中、mGRE トンネル インターフェイスが、GRE によってペイロードをカプセル化し、IPv4/IPv6 ヘッダーを転送します。 受信側では、mGRE トンネル インターフェイスが、GRE とトランスポート ヘッダーを取り除き、ペイロードを転送します。

GRE を介するイーサネット トンネルでは、イーサネット ヘッダーは GRE およびトランスポート ヘッダーとともにトンネルのカプセル化に含まれます。

GRE IPv4 を介するイーサネット トランスポートに使用されるトンネル モードは、tunnel mode ethernet gre ipv4 コマンドを使用して設定できます。

同様に、GRE IPv6 を介するイーサネット トランスポートに使用されるトンネル モードは、tunnel mode ethernet gre ipv6 コマンドを使用して設定できます。

show tunnel source tracking コマンドを使用して、トンネルの送信元を確認できます。

GRE を介するイーサネット トンネルは、あらゆる点を考慮して通常のイーサネット動作のシミュレーションを行いますが、インターフェイスはデータリンク レイヤでの NBMA インターフェイスです。 GRE を介するイーサネット トンネルに接続された複数のモバイル ノードおよび CPE がある場合、パケットのブロードキャストはサポートされません。 Mobile Access Gateway(MAG)などのアグリゲーション デバイスがダウンストリーム パケット フレームでブロードキャスト MAC アドレスを使用する必要がある場合でも、メッセージは各 CPE に対してのみユニキャストします。 同様に、マルチキャスト メッセージは、モバイル ノードにユニキャスト メッセージとして送信されます。

仮想 MAC アドレス

GRE を介するイーサネット トンネルは、仮想 MAC アドレスに設定されます。 パケットがトンネルに入る際、パケットの宛先 MAC アドレスがトンネルの仮想 MAC アドレスあるいはブロードキャスト MAC アドレスに一致する場合に、トンネルはパケットを受け入れます。 設定されている場合、パケットはドロップされます。


(注)  


トンネル インターフェイスが特定のマルチキャスト グループのマルチキャスト トラフィックを処理するために設定されている場合、対応する MAC アドレスは、トンネルによっても受け入れられます。


PMIPv6 または GTP がトンネルでイネーブルの場合、プロトコルはトンネルから出たパケットの送信元 MAC アドレスとして使用される仮想 MAC アドレスを提供します。 PMIPv6 または GTP がイネーブルでない場合、トンネル インターフェイスの仮想 MAC アドレスは、トンネルから出たパケットの送信元 MAC アドレスとして使用されます。

仮想 MAC アドレスは、mac-address コマンドを使用してトンネルと関連付けられます。 MAC テーブル エントリを表示するには、show tunnel mac-table コマンドを使用します。 トンネル インターフェイスの MAC テーブルへの MAC アドレスの追加をテストするには、test tunnel mac-address コマンドを使用します。

トンネルインターフェイスの VLAN

モバイル ノードはワイヤレス アクセス ポイント(AP)に接続します。 これらの AP は、サービス プロバイダーから提供されたサービス セット ID(SSID)を使用します。 CPE の SSID は VLAN ID です。 CPE は、GRE トンネルで転送する前にモバイル ノードから受信したイーサネット フレームで VLAN タグを入力するように設定できます。 同様に、ダウンストリーム トラフィックの場合、GRE トンネルは MN に送信されるすべてのイーサネット フレームの VLAN タグを入力するように設定できます。

トンネル インターフェイスは 1 つの VLAN タグのみをサポートします。

tunnel vlan コマンドを使用すると、GRE を介するイーサネット トンネルと VLAN を関連付けることができます。

GRE を介するイーサネット トンネルの設定方法

GRE を介するイーサネット トンネルの設定

手順の概要

    1.    interface tunnel tunnel-number

    2.    mac-address mac-address

    3.    次のどちらかを実行します。

    • ip address dhcp
    • ip address ip-address mask

    4.    tunnel source {ip-address | ipv6-address | interface-type interface-number}

    5.    tunnel mode ethernet gre {ipv4 | ipv6}

    6.    tunnel key key

    7.    tunnel vlan vlan-id

    8.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 1
     

    トンネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

     

    ステップ 2mac-address mac-address


    例:
    Device(config-if)# mac-address 0000.0000.0001 
     

    (任意)トンネルの MAC アドレスを指定します。

     

    ステップ 3次のどちらかを実行します。
    • ip address dhcp
    • ip address ip-address mask


    例:
    Device(config-if)# ip address 192.168.4.3 255.255.255.0


    例:
    Device(config-if)# ip address dhcp
     
    • ネットワークに接続したときに、モバイル ノードの IP アドレスが DHCP によって割り当てられることを指定します。

    • モバイル ノードの IPv4 アドレスを指定します。

     
    ステップ 4tunnel source {ip-address | ipv6-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source loopback 2 
     

    トンネル インターフェイスの送信元アドレスを設定します。

     
    ステップ 5tunnel mode ethernet gre {ipv4 | ipv6}


    例:
    Device(config-if)# tunnel mode ethernet gre ipv4
     

    GRE IPv4 または GRE IPv6 を介するイーサネットにトンネルのカプセル化モードを設定します。

     
    ステップ 6tunnel key key


    例:
    Device(config-if)# tunnel key 1
     

    トンネル インターフェイスのキー ID をイネーブルにします。

     
    ステップ 7tunnel vlan vlan-id


    例:
    Device(config-if)# tunnel vlan 1
     

    GRE を介するイーサネット トンネルに VLAN ID を関連付けます。

     
    ステップ 8end


    例:
    end
     

    特権 EXEC モードに戻ります。

     
    次の作業

    トンネルを確認します。

    GRE を介するイーサネット トンネルの確認

    はじめる前に

    GRE を介するイーサネット トンネルを設定します。

    手順の概要

      1.    show interface tunnel

      2.    show tunnel mac-table

      3.    show tunnel endpoints


    手順の詳細
      ステップ 1   show interface tunnel

      このコマンドは、トンネルに関する情報を表示します。



      例:
      Device# show interface tunnel 1
      
      Tunnel1 is up, line protocol is up
      Hardware is Tunnel
      Internet address is 11.1.1.1/24
      MTU 17846 bytes, BW 100 Kbit/sec, DLY 50000 usec, reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation TUNNEL, loopback not set
      Keepalive not set
      Tunnel source 10.0.0.1
      Tunnel MAC address 0000.5e00.5213
      Tunnel Vlan-id 1
      Tunnel protocol/transport Ethernet-GRE/IP Key 0x1, sequencing disabled Checksumming of packets disabled
      Tunnel TTL 255
      Tunnel transport MTU 1454 bytes
      Tunnel transmit bandwidth 8000 (kbps) Tunnel receive bandwidth 8000 (kbps)
      Last input 00:48:08, output never, output hang never
      Last clearing of "show interface" counters 00:48:26
      Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 107
      Queueing strategy: fifo
      Output queue: 0/0 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      1867 packets input, 161070 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      43 packets output, 4386 bytes, 0 underruns
      0 output errors, 0 collisions, 0 interface resets
      0 unknown protocol drops
      0 output buffer failures, 0 output buffers swapped out ind-uut#
      --- 22:03:51 ---
      44: 2013-01-30T22:03:51: %SCRIPT-6-INFO: {_haExecCmd: Executing cmd exec with ind-uut-a}
      
      
      Device# show interface tunnel 2
      
      Tunnel2 is up, line protocol is up
      Hardware is Tunnel
      Internet address is 10.1.1.1/24
      MTU 1434 bytes, BW 100 Kbit/sec, DLY 50000 usec, reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation TUNNEL, loopback not set
      Keepalive not set
      Tunnel source 10::1
      Tunnel MAC address 0000.5e00.5213
      Tunnel Vlan-id 2
      Tunnel protocol/transport Ethernet-GRE/IPv6
      Key 0x2, sequencing disabled
      Checksumming of packets disabled
      Tunnel TTL 255
      Path MTU Discovery, ager 10 mins, min MTU 1280
      Tunnel transport MTU 1434 bytes
      Tunnel transmit bandwidth 8000 (kbps) Tunnel receive bandwidth 8000 (kbps)
      Last input never, output never, output hang never
      Last clearing of "show interface" counters 00:48:28
      Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 106
      Queueing strategy: fifo
      Output queue: 0/0 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      0 packets input, 0 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      0 packets output, 0 bytes, 0 underruns
      0 output errors, 0 collisions, 0 interface resets
      0 unknown protocol drops
      0 output buffer failures, 0 output buffers swapped out 
      
      ステップ 2   show tunnel mac-table

      このコマンドは、トンネルに関連付けられた MAC テーブル エントリを表示します。



      例:
      Device# show tunnel mac-table tunnel0
      
      CPE IP 1.1.1.1 Refcount 2 Base 0x2A98DD0000 
          mac-address 0122.0111.0111 vlan 1
          mac-address 0011.1111.0001 vlan 2
      CPE IP 3.3.3.3 Refcount 2 Base 0x12345678
         mac-address 1234.5678.9011 vlan 1
      
      ステップ 3   show tunnel endpoints

      このコマンドは、トンネル エンドポイントを表示し、トンネルが正しく作成されたかどうかを確認します。



      例:
      Device# show tunnel endpoints
      
      Tunnel0 running in Ethernet-GRE/IP mode
      
      Endpoint transport 10.1.1.1 Refcount 3 Base 0x2A98DD03C0 Create Time 3d02h
         overlay 10.1.1.1 Refcount 2 Parent 0x2A98DD03C0 Create Time 3d02h
       Endpoint transport 3.3.3.3 Refcount 3 Base 0x2A98DD0300 Create Time 3d02h
         overlay 10.1.1.3 Refcount 2 Parent 0x2A98DD0300 Create Time 3d02h
      

      GRE を介するイーサネット トンネルの設定例

      例:GRE を介するイーサネット トンネルの設定

      モバイル ノードでの GRE を介するイーサネット トンネルの設定

      
      ! Configure the topology
      mobile-node1(config-if)# interface GigabitEthernet0/1
      mobile-node1(config-if)# ip address 10.21.1.1 255.255.255.0
      mobile-node1(config-if)# no shut
      mobile-node1(config-if)# exit
      mobile-node1(config)# ip route 10.0.0.1 255.255.255.255 10.21.1.2 
      
      ! Configuring the interface used as the source of the tunnel
      mobile-node1(config)# interface Loopback0
      mobile-node1(config-if)# ip address 10.40.0.1 255.255.255.0 
      mobile-node1(config-if)# ipv6 address 2001:db8:2:40::1/64
      mobile-node1(config-if)# no shutdown
      
      ! Configuring the Ethernet over GRE IPv4 Tunnel
      mobile-node1(config-if)# interface Tunnel1
      mobile-node1(config-if)# mac-address 0000.0000.0001
      mobile-node1(config-if)# ip dhcp client client-id ascii MN1@cisco.com 
      mobile-node1(config-if)# ip address dhcp
      mobile-node1(config-if)# no ip redirects 
      mobile-node1(config-if)# no ip route-cache
      mobile-node1(config-if)# tunnel source Loopback0
      mobile-node1(config-if)# tunnel mode ethernet gre ipv4 
      mobile-node1(config-if)# tunnel key 1 
      mobile-node1(config-if)# tunnel vlan 1
      mobile-node1(config-if)# no shutdown
      
      

      MAG での GRE を介するイーサネット トンネルの設定

      
      ! Configure the topology
      MAG(config)# interface FastEthernet1/1/5
      MAG(config-if)# ip address 10.21.1.2 255.255.255.0 
      MAG(config-if)# ipv6 address 2001:db8:2:21::2/64
      MAG(config-if)# no shut
      MAG(config)# ip route 10.40.0.1 255.255.255.255 10.21.1.1
      
      ! Configure the interface used as source of the tunnel
      MAG(config-if)# interface Loopback0
      MAG(config-if)# ip address 10.0.0.1 255.255.255.0 
      MAG(config-if)# no shutdown
      
      ! Configuring the Ethernet over GRE IPv4 Tunnel
      MAG(config)# interface Tunnel1
      MAG(config-if)# ip address 10.11.1.1 255.255.255.0 
      MAG(config-if)# tunnel mode ethernet gre ipv4
      MAG(config-if)# tunnel source 10.0.0.1 
      
      ! Configuring a static GRE and VLAN ID for the tunnel
      MAG(config-if)# tunnel key 1
      MAG(config-if)# tunnel vlan 1
      
      ! Associating the service policy control with the tunnel
      MAG(config-if)# service-policy type control DHCP1 
      
      ! Enable ISG on the tunnel
      MAG(config-if)# ip subscriber l2-connected
      MAG(config-subscriber)# initiator unclassified mac-address
      Please unconfigure existing command before configuring. 
      MAG(config-subscriber)# initiator dhcp class-aware 
      
      

      その他の関連資料

      関連資料

      関連項目

      マニュアル タイトル

      IPv6 アドレッシングと接続

      『Cisco IOS IPv6 Configuration Guide』

      Cisco IOS コマンド

      『Cisco IOS Master Commands List, All Releases』

      IPv6 コマンド

      『Cisco IOS IPv6 Command Reference』

      Cisco IOS IPv6 機能

      『Cisco IOS IPv6 Feature Mapping』

      標準および RFC

      標準/RFC

      タイトル

      IPv6 に関する RFC

      『IPv6 RFCs』

      テクニカル サポート

      説明

      リンク

      右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      GRE を介するイーサネット トンネルの機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

      表 1 GRE を介するイーサネット トンネルの機能情報

      機能名

      リリース

      機能情報

      GRE を介するイーサネット トンネル

      Cisco IOS XE Release 3.9S

      GRE を介したイーサネット トンネル機能によって、ユーザはプロキシ モバイル IPv6(PMIPv6)、GPRS トンネリング プロトコル(GTP)および Intelligent Services Gateway(ISG)を使用するモバイル ノードにモビリティ サービスを提供する既存のローエンド レジデンシャル ゲートウェイを活用できます。

      tunnel mode ethernet gre コマンドは、IPv4 および IPv6 に対して Ethernet over GRE トンネルモードを追加するように変更されました。

      次のコマンドが導入されました。tunnel vlan show tunnel mac-table、 show tunnel source tracking test tunnel mac-address