インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
手動設定した IPv4 を介する IPv6 トンネル
手動設定した IPv4 を介する IPv6 トンネル

手動設定した IPv4 を介する IPv6 トンネル

この機能は、手動設定した IPv4 を介する IPv6 トンネルに対するサポートを提供します。 手動で設定されたトンネルは、IPv4 バックボーンを介した 2 つの IPv6 ドメイン間の固定リンクに相当します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

手動設定した IPv4 を介する IPv6 トンネルに関する情報

オーバーレイ トンネル for IPv6

オーバーレイ トンネリングでは、IPv4 パケット内で IPv6 パケットをカプセル化して、IPv4 インフラストラクチャ(コア ネットワークまたは以下の図)へ伝送します。 オーバーレイ トンネルを使用することで、孤立した IPv6 ネットワークと通信できます。このとき、孤立した複数の IPv6 ネットワーク間にある IPv4 インフラストラクチャをアップグレードする必要はありません。 オーバーレイ トンネルは、境界デバイス間、または境界デバイスとホスト間に設定できますが、両方のトンネル エンドポイントが IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。 IPv6 では、次のタイプのオーバーレイ トンネリング メカニズムをサポートしています。

  • 手動

  • 総称ルーティング カプセル化(GRE)

  • IPv4 互換

  • 6to4

  • Intrasite Automatic Tunnel Addressing Protocol(ISATAP)

図 1. オーバーレイ トンネル


(注)  


オーバーレイ トンネルにより、インターフェイスの最大伝送単位(MTU)が 20 オクテット減少します(ただし、基本 IPv4 パケット ヘッダーにオプション フィールドが含まれていないことを前提とします)。 オーバーレイ トンネルを使用するネットワークは、トラブルシューティングが困難です。 したがって、独立した IPv6 ネットワークに接続するオーバーレイ トンネルは、最終的な IPv6 ネットワーク アーキテクチャと見なすことができません。 オーバーレイ トンネルの使用は、IPv4 と IPv6 の両方のプロトコル スタック、または IPv6 プロトコル スタックだけをサポートするネットワークへの移行方法と見なす必要があります。


以下の表は、IPv4 ネットワーク上での IPv6 パケットの伝送にどのトンネル タイプを設定すればよいかを決定する場合に役立ちます。

表 1 IPv4 ネットワーク上で IPv6 パケットを伝送するトンネル タイプの推奨される使用方法

トンネリング タイプ

推奨される使用方法

使用方法

手動

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6 パケットだけを伝送できます。

GRE および IPv4 互換

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6、コネクションレス型ネットワーク サービス(CLNS)、およびその他の多数のタイプのパケットを伝送できます。

IPv4 互換

ポイントツーマルチポイント トンネル

::/96 プレフィックスを使用します。 このトンネル タイプの使用は推奨しません。

6to4

独立した IPv6 サイトへの接続に使用可能なポイントツーマルチポイント トンネル

サイトでは、2002::/16 プレフィックスからのアドレスを使用します。

6RD

IPv6 サービスは、IPv4 に IPv6 のカプセル化を使用することで IPv4 ネットワーク上のユーザに提供されます。

プレフィックスは、SP 自身のアドレス ブロックから割り当てることができます。

ISATAP

サイト内のシステムへの接続に使用可能なポイントツーマルチポイント トンネル

サイトでは、任意の IPv6 ユニキャスト アドレスを使用できます。

個々のトンネル タイプについて、このマニュアルで詳しく説明しています。 実装する特定のトンネル タイプに関する情報を確認および理解することを推奨します。 必要なトンネル タイプに精通している場合は、以下の表で、有用と思われるトンネル設定パラメータの概要を参照してください。

表 2 トンネリング タイプ別のトンネル設定パラメータ

トンネリング タイプ

トンネル設定パラメータ

トンネル モード

トンネルの送信元

トンネルの宛先

インターフェイス プレフィックスまたはアドレス

手動

ipv6ip

IPv4 アドレス、または IPv4 が設定されたインターフェイスへの参照。

IPv4 アドレス。

IPv6 アドレス。

GRE/IPv4

gre ip

IPv4 アドレス。

IPv6 アドレス。

IPv4 互換

ipv6ip auto-tunnel

不要。 これらはすべて、ポイントツーマルチポイントのトンネリング タイプです。 IPv4 宛先アドレスは、パケット単位で、IPv6 宛先から計算されます。

不要。 インターフェイス アドレスは、::tunnel-source/96 として生成されます。

6to4

ipv6ip 6to4

IPv6 アドレス。 プレフィックスは、トンネル送信元の IPv4 アドレスを埋め込む必要があります。

6RD

ipv6ip 6rd

IPv6 アドレス。

ISATAP

ipv6ip isatap

変更された eui-64 形式での IPv6 プレフィックス。 IPv6 アドレスは、プレフィックスおよびトンネル送信元 IPv4 アドレスから生成されます。

手動で設定された IPv6 トンネル

手動で設定されたトンネルは、IPv4 バックボーンを介した 2 つの IPv6 ドメイン間の固定リンクに相当します。 主に、2 つのエッジ デバイス間またはエンド システムとエッジ デバイス間に定期的でセキュアな通信を必要とする安定した接続のために、またはリモート IPv6 ネットワークへの接続のために使用されます。

IPv6 アドレスは、トンネル インターフェイス上で手動で設定され、手動で設定された IPv4 アドレスは、トンネル送信元およびトンネル宛先に割り当てられます。 設定されたトンネルの両端にあるホストまたはデバイスは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。 手動で設定されたトンネルは、境界デバイス間または境界デバイスとホスト間で設定できます。 シスコ エクスプレス フォワーディング スイッチングは、手動で設定された IPv6 トンネルに使用できます。または、シスコ エクスプレス フォワーディング スイッチングは、プロセス スイッチングが必要な場合はディセーブルにできます。

手動設定した IPv4 を介する IPv6 トンネルをイネーブルにする方法

手動 IPv6 トンネルの設定

はじめる前に

手動で設定された IPv6 トンネルでは、IPv6 アドレスは、トンネル インターフェイス上で設定され、手動で設定された IPv4 アドレスは、トンネル送信元およびトンネル宛先に割り当てられます。 設定されたトンネルの両端にあるホストまたはデバイスは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    次のいずれかのコマンドを入力します。

    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]

    5.    tunnel source {ip-address | interface-type interface-number}

    6.    tunnel destination ip-address

    7.    tunnel mode ipv6ip

    8.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。

     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 0
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 次のいずれかのコマンドを入力します。
    • ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
    • ipv6 address ipv6-prefix/prefix-length [eui-64]


    例:
    Device(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
     
    インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。
    • eui-64 キーワードを指定すると、ソフトウェアは、インターフェイスの IPv6 アドレスを設定し、アドレスの下位 64 ビットの EUI-64 インターフェイス ID を使用してインターフェイスで IPv6 処理をイネーブルにします。

    (注)     

    IPv6 アドレスの設定の詳細については、「Implementing IPv6 Addressing and Basic Connectivity」モジュールを参照してください。

     
    ステップ 5 tunnel source {ip-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source gigabitethernet 0/0/0
     

    トンネル インターフェイスの送信元 IPv4 アドレスまたは送信元インターフェイス タイプと番号を指定します。

    • インターフェイスが指定されている場合、そのインターフェイスは IPv4 アドレスを使用して設定されている必要があります。

     
    ステップ 6 tunnel destination ip-address


    例:
    Device(config-if)# tunnel destination 192.168.30.1
     

    トンネル インターフェイスの宛先 IPv4 アドレスまたはホスト名を指定します。

     
    ステップ 7 tunnel mode ipv6ip


    例:
    Device(config-if)# tunnel mode ipv6ip
     

    手動 IPv6 トンネルを指定します。

    (注)     

    tunnel mode ipv6ip コマンドでは、IPv6 をパッセンジャ プロトコルとして指定し、IPv4 を手動 IPv6 トンネル用のカプセル化プロトコルおよびトランスポート プロトコルの両方として指定します。

     
    ステップ 8 end


    例:
    Device(config-if)# end
     

    特権 EXEC モードに戻ります。

     

    手動設定した IPv4 を介する IPv6 トンネルの設定例

    例:手動 IPv6 トンネルの設定

    次に、ルータ A とルータ B 間で手動 IPv6 トンネルを設定する例を示します。 この例では、ルータ A とルータ B の両方のトンネル インターフェイス 0 が、グローバル IPv6 アドレスを使用して手動で設定されます。 トンネル送信元およびトンネル宛先のアドレスについても、手動で設定されます。

    ルータ A の設定

    interface ethernet 0
     ip address 192.168.99.1 255.255.255.0
    interface tunnel 0
     ipv6 address 3ffe:b00:c18:1::3/127
     tunnel source ethernet 0
     tunnel destination 192.168.30.1
     tunnel mode ipv6ip

    ルータ B の設定

    interface ethernet 0
     ip address 192.168.30.1 255.255.255.0
    interface tunnel 0
     ipv6 address 3ffe:b00:c18:1::2/127
     tunnel source ethernet 0
     tunnel destination 192.168.99.1
     tunnel mode ipv6ip

    例:GRE IPv4 を介する IPv6 トンネル

    例:CE1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ipv6 address 2001:DB8:2:1::1/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:1::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:1::2
    !
    

    例:PE1 の設定

    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     tunnel source 10.22.22.22
     tunnel destination 10.44.44.44
     exit
    !
    interface Ethernet0/0
     no ip address
     ipv6 address 2001:DB8:2:1::2/64
     no shutdown
     exit
    !
    interface Ethernet1/1
     no ip address
     ip address 10.22.22.22 255.255.255.0
     no shutdown
     exit
    !
    ip route 10.44.44.0 255.255.255.0 10.22.22.23
    ipv6 route 2001:DB8:2:2::/64 Tunnel0 2001:DB8:2:4::2
    
    

    例:PE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     tunnel source 10.44.44.44
     tunnel destination 10.22.22.22
     exit
    !
    interface Ethernet0/0 no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ip address 10.44.44.44 255.255.255.0
     no shutdown
     exit
    !
    ip route 10.22.22.0 255.255.255.0 10.44.44.43
    !
    ipv6 route 2001:DB8:2:1::/64 Tunnel0 2001:DB8:2:4::1
    !
    
    

    例:CE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:1::/64 2001:DB8:2:2::1
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::1
    !
    
    

    例:デバイス X の設定

    !
    interface Ethernet1/0
     no ip address
     ip address 10.44.44.43 255.255.255.0
     no shutdown
     exit
    !
    interface Ethernet1/1
     no ip address
     ip address 10.22.22.23 255.255.255.0
     no shutdown
     exit
    !
    
    
    

    例:トンネル設定の確認

    CE1 から

    Device# ping ipv6 2001:db8:2:2::2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2001:DB8:2:2::2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/43 ms
    
    Device# ping ipv6 2001:db8:2:2::2 source 2001:db8:2:1::1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2001:DB8:2:2::2, timeout is 2 seconds:
    Packet sent with a source address of 2001:DB8:2:1::1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    
    

    PE1 から

    Device# show tunnel interface
    
    Tunnel0
       Mode:GRE/IP, Destination 10.44.44.44, Source 10.22.22.22
       IP transport: output interface Ethernet1/1 next hop 10.22.22.23
       Application ID 1: unspecified
       Linestate - current up
       Internal linestate - current up, evaluated up
       Tunnel Source Flags: Local
       Transport IPv4 Header DF bit cleared
       OCE: IP tunnel decap
       Provider: interface Tu0, prot 47
         Performs protocol check [47]
         Protocol Handler: GRE: opt 0x0
           ptype: ipv4 [ipv4 dispatcher: punt]
           ptype: ipv6 [ipv6 dispatcher: from if Tu0]
           ptype: mpls [mpls dispatcher: drop]
           ptype: otv [mpls dispatcher: drop]
           ptype: generic [mpls dispatcher: drop]
    There are 0 tunnels running over the EON IP protocol
    There are 0 tunnels running over the IPinIP protocol
    There are 0 tunnels running over the NOSIP protocol
    There are 0 tunnels running over the IPv6inIP protocol
    There are 0 tunnels running over the RBSCP/IP protocol
    
    Device# show ip route 10.44.44.44
    
    Routing entry for 10.44.44.0/24
      Known via "static", distance 1, metric 0
      Routing Descriptor Blocks:
      * 10.22.22.23
          Route metric is 0, traffic share count is 1
    
    Device# debug ipv6 icmp
    
      ICMP Packet debugging is on
    *Jan  1 10:57:37.882: ICMPv6: Sent R-Advert, Src=FE80::A8BB:CCFF:FE00:5200, Dst=FF02::1
    *Jan  1 11:00:18.634: ICMPv6: Received R-Advert, Src=FE80::A8BB:CCFF:FE00:5200,Dst=FF02::1
    
    
    

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    IPv6 アドレッシングと接続

    『IPv6 Configuration Guide』

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    『IPv6 RFCs』

    MIB

    MIB

    MIB のリンク

    選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    テクニカル サポート

    説明

    リンク

    右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    手動設定した IPv4 を介する IPv6 トンネルの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

    表 3 手動設定した IPv4 を介する IPv6 トンネルの機能情報

    機能名

    リリース

    機能情報

    IPv6 トンネリング:手動設定した IPv4 を介する IPv6 トンネル

    Cisco IOS XE Release 2.1

    手動で設定されたトンネルは、IPv4 バックボーンを介した 2 つの IPv6 ドメイン間の固定リンクに相当します。

    tunnel destinationtunnel ipv6iptunnel source の各コマンドが導入または変更されました。