インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S
IPv6 を介する IP トンネル
IPv6 を介する IP トンネル

IPv6 を介する IP トンネル

IPv6 は IPv6 を介する IP トンネルをサポートします。サポート内容は次のとおりです。

  • IPv6 トラフィックに対する総称ルーティング カプセル化(GRE)IPv4 トンネル サポート:IPv6 トラフィックは、標準的なポイントツーポイントのカプセル化スキームの実装に必要なサービスを提供するように設計されている標準 GRE トンネリング技術を使用して、IPv4 GRE トンネルを介して伝送できます。 GRE トンネルは、2 つのエッジ デバイス間またはエッジ デバイスとエンド システム間に定期的でセキュアな通信を必要とする安定した接続のために主に使用されます。 エッジ デバイスとエンド システムは、デュアル スタック実装である必要があります。

  • IPv6 トランスポートを介した GRE サポート:GRE には、パッセンジャ プロトコルを識別するプロトコル フィールドが含まれています。 GRE トンネルでは、Intermediate System to Intermediate System(IS-IS)または IPv6 をパッセンジャ プロトコルとして指定でき、IS-IS トラフィックと IPv6 トラフィックをともに同じトンネルを介して送出できます。

  • IPv6 を介する VRF-Aware IPv4/IPv6 トンネル:仮想ルーティングおよび転送(VRF)Aware トンネルは、信頼できないコア ネットワークまたは別のインフラストラクチャ(IPv4 または IPv6)を備えたコア ネットワークで区切られたカスタマー ネットワークに接続するために使用されます。

IPv6 を介する IP トンネルに関する情報

IPv6 トラフィック用の GRE IPv4 トンネル サポート

IPv6 トラフィックは、標準的なポイントツーポイントのカプセル化スキームの実装にサービスを提供するように設計されている標準 GRE トンネリング技術を使用して、IPv4 GRE トンネルを介して伝送できます。 GRE トンネルは、手動で設定された IPv6 トンネルと同様、リンクごとに個別のトンネルが設定された 2 つのポイント間のリンクです。 これらのトンネルは、特定のパッセンジャまたはトランスポート プロトコルに結合されていませんが、この場合、GRE を使用するパッセンジャ プロトコルとして IPv6 を伝送し、トランスポート プロトコルとして IPv4 または IPv6 を伝送します。

GRE トンネルは、2 つのエッジ デバイス間またはエッジ デバイスとエンド システム間に定期的でセキュアな通信を必要とする安定した接続のために主に使用されます。 エッジ デバイスとエンド システムは、デュアル スタック実装である必要があります。

IPv6 トランスポートを介する GRE サポート

GRE には、パッセンジャ プロトコルを識別するプロトコル フィールドが含まれています。 GRE トンネルでは、Intermediate System to Intermediate System(IS-IS)または IPv6 をパッセンジャ プロトコルとして指定でき、IS-IS トラフィックと IPv6 トラフィックをともに同じトンネルを介して送出できます。 GRE にプロトコル フィールドが含まれていない場合は、トンネルが IS-IS パケットまたは IPv6 パケットを伝送していたかどうかは識別できません。 GRE プロトコル フィールドでは、GRE 内に IS-IS および IPv6 をトンネリングすることを推奨します。

IPv6 を介する IP トンネルの設定方法

次の作業では、IPv6 トンネルを設定する方法について説明します。 IPv6 または IPv4 パケットは、このトンネルで転送できます。

GRE IPv6 トンネルの設定

IPv6 ネットワーク上で GRE トンネルを設定するには、次の作業を実行します。 GRE トンネルは、IPv6 ネットワーク層を介して送出し、IPv6 トンネルを介して IPv6 パケットと IPv4 パケットを転送するように設定できます。

はじめる前に

GRE IPv6 トンネルが設定されている場合、IPv6 アドレスは、トンネル送信元およびトンネル宛先に割り当てられます。 トンネル インターフェイスは、IPv4 または IPv6 アドレスのいずれかにすることができます(このことは、以降の作業では示されていません)。 設定されたトンネルの両端にあるホストまたはデバイスは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    tunnel source {ipv6-address | interface-type interface-number}

    5.    tunnel destination ipv6-address

    6.    tunnel mode gre ipv6

    7.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。

     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface tunnel tunnel-number


    例:
    Device(config)# interface tunnel 0
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 tunnel source {ipv6-address | interface-type interface-number}


    例:
    Device(config-if)# tunnel source ethernet 0
     

    送信元 IPv6 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

    • インターフェイスのタイプと番号が指定されている場合、そのインターフェイスは IPv6 アドレスを使用して設定する必要があります。

    (注)     

    このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 5 tunnel destination ipv6-address


    例:
    Device(config-if)# tunnel destination 2001:0DB8:0C18:2::300
     

    トンネル インターフェイスの宛先 IPv6 アドレスを指定します。

    (注)     

    このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 6 tunnel mode gre ipv6


    例:
    Device(config-if)# tunnel mode gre ipv6
     

    GRE IPv6 トンネルを指定します。

    (注)     

    tunnel mode gre ipv6 コマンドでは、GRE をトンネル インターフェイスのカプセル化プロトコルとして指定します。 このコンテキストで使用される構文だけが表示されます。 詳細については、『IPv6 Command Reference』を参照してください。

     
    ステップ 7 end


    例:
    Device(config-if)# end
     

    インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     

    IPv6 を介する IP トンネルの設定例

    例:IPv6 を介する IPv6 トンネル

    例:CE1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:1::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:5::/64 2001:DB8:2:1::2
    ipv6 route 2001:DB8:2:9::/64 2001:DB8:2:1::2
    !
    		

    例:PE1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:9::1/64
     tunnel source 2001:DB8:2:2::1
     tunnel mode ipv6
     tunnel destination 2001:DB8:2:4::2
     exit
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:1::2/64
     no shutdown
     exit
    !
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:5::/64 Tunnel0 2001:DB8:2:9::2
    
    		

    例:PE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ipv6 address
     ipv6 address 2001:DB8:2:9::2/64
     tunnel source 2001:DB8:2:4::2
     tunnel mode ipv6
     tunnel destination 2001:DB8:2:2::1
     exit
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:5::1/64
     no shutdown
     exit
    !
    interface Ethernet0/1
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:1::/64 Tunnel0 2001:DB8:2:9::1
    
    		

    例:CE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ipv6 address
     ipv6 address 2001:DB8:2:5::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:1::/64 2001:DB8:2:5::1
    ipv6 route 2001:DB8:2:9::/64 2001:DB8:2:5::1
    !
    
    

    例:コア デバイス 1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet1/0
     no ipv6 address
     no shutdown
     ipv6 address 2001:DB8:2:3::1/64
     exit
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:3::2
    
    

    例:コア デバイス 2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/1
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ipv6 address 2001:DB8:2:3::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:3::1
    
    
    

    例:IPv6 を介する IPv4 トンネル

    例:CE1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.1.1 255.255.255.0
     no shutdown
     exit
    !
    ip route 192.168.5.0 255.255.255.0 192.168.1.2
    ip route 192.168.9.0 255.255.255.0 192.168.1.2
    !
    		

    例:PE1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ip address 192.168.9.1 255.255.255.0
     tunnel source 2001:DB8:2:2::1
     tunnel destination 2001:DB8:2:4::2
     tunnel mode ipv6
     exit
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.1.2 255.255.255.0
     no shutdown
     exit
    !
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::1/64
     no shutdown
     exit
    !
    
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:2::2
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::2
    ip route 192.168.5.0 255.255.255.0 Tunnel 0 192.168.9.2
    
    		

    例:PE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Tunnel0
     no ip address
     ip address 192.168.9.2 255.255.255.0
     tunnel source 2001:DB8:2:4::2
     tunnel destination 2001:DB8:2:2::1
     tunnel mode ipv6
     exit
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.5.1 255.255.255.0 
     no shutdown
     exit
    !
    interface Ethernet0/1
     no ipv6 address
     ipv6 address 2001:DB8:2:4::2/64
     no shutdown
     exit
    !
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:4::1
    ipv6 route 2001:DB8:2:3::/64 2001:DB8:2:4::1
    ip route 192.168.1.0 255.255.255.0 Tunnel 0 192.168.9.1
    
    		

    例:CE2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/0
     no ip address
     ip address 192.168.5.2 255.255.255.0 
     no shutdown
     exit
    !
    ip route 192.168.1.0 255.255.255.0 192.168.1.2
    ip route 192.168.9.0 255.255.255.0 192.168.1.2
    
    !
    
    

    例:コア デバイス 1 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet1/0
     no ipv6 address
     no shutdown
     ipv6 address 2001:DB8:2:3::1/64
     exit
    !
    interface Ethernet1/1
     no ipv6 address
     ipv6 address 2001:DB8:2:2::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:3::2
    
    
    

    例:コア デバイス 2 の設定

    !
    ipv6 unicast-routing
    ipv6 cef
    !
    interface Ethernet0/1
     no ip address
     ipv6 address 2001:DB8:2:4::1/64
     no shutdown
     exit
    !
    interface Ethernet1/0
     no ip address
     ipv6 address 2001:DB8:2:3::2/64
     no shutdown
     exit
    !
    ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:3::1
    
    

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Cisco IOS Master Command List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    IPv6 アドレッシングと接続

    『IPv6 Configuration Guide』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    IPv6 の RFC

    テクニカル サポート

    説明

    リンク

    右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    IPv6 を介する IP トンネルの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

    表 1 IPv6 を介する IP トンネルの機能情報

    機能名

    リリース

    機能情報

    IPv6 を介する IP トンネル

    12.2(30)S

    12.2(33)SRA

    12.3(7)T

    12.4

    12.4(2)T

    15.0(1)S

    Cisco IOS XE Release 2.1

    15.1(1)SY

    IPv6 を介する IP トンネル機能がサポートされます。

    tunnel destinationtunnel mode ipv6tunnel mode gre ipv6tunnel source の各コマンドが導入または変更されました。