IPv6 アドレッシングおよび基本的な接続のコンフィギュレーション ガイド、Cisco IOS XE Release 3S
IPv6 エニーキャスト アドレス
IPv6 エニーキャスト アドレス
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

IPv6 エニーキャスト アドレス

IPv6 エニーキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットに割り当てられます。 エニーキャスト アドレスは、ユニキャスト アドレス空間から割り当てられるため、その構文ではユニキャスト アドレスと区別できません。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

IPv6 エニーキャスト アドレスについて

IPv6 アドレス タイプ:エニーキャスト

エニーキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットに割り当てられます。 エニーキャスト アドレスに送信されたパケットは、使用しているルーティング プロトコルの定義に従って、そのエニーキャスト アドレスが示す最も近いインターフェイスに送信されます。 エニーキャスト アドレスは、ユニキャスト アドレス空間から割り当てられるため、その構文ではユニキャスト アドレスと区別できません。 ユニキャスト アドレスを複数のインターフェイスに割り当てると、ユニキャスト アドレスがエニーキャスト アドレスになります。 エニーキャスト アドレスを割り当てるノードは、アドレスがエニーキャスト アドレスであることを認識するように明示的に設定する必要があります。


(注)  


エニーキャスト アドレスを使用できるのはデバイスだけです。ホストでは使用できません。エニーキャスト アドレスは、IPv6 パケットの送信元アドレスとして使用できません。


次の図に、サブネット デバイス エニーキャスト アドレスの形式を示します。アドレスには、連続するゼロで連結されたプレフィックス(インターフェイス ID)があります。 サブネット デバイス エニーキャスト アドレスを使用すると、サブネット デバイス エニーキャスト アドレスのプレフィックスが示すリンク上のデバイスに到達できます。

図 1. サブネット デバイス エニーキャスト アドレスの形式

IPv6 エニーキャスト アドレスの設定方法

IPv6 エニーキャスト アドレスの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap]

    5.    tunnel source { ip address | ipv6-address | interface-type interface-number }

    6.    ipv6 address { ipv6-prefix/prefix-length | prefix-name sub-bits/prefix-length }

    7.    ipv6 address ipv6-prefix/prefix-length anycast


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface type number


    例:
    Device(config)# interface tunnel0
     

    インターフェイスのタイプと番号を指定し、デバイスをインターフェイス コンフィギュレーション モードにします。

     
    ステップ 4tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap]


    例:
    Device(config-if)# tunnel mode ipv6ip 6to4
     

    スタティック IPv6 トンネル インターフェイスを設定します。

     
    ステップ 5tunnel source { ip address | ipv6-address | interface-type interface-number }


    例:
    Device(config-if)# tunnel source GigabitEthernet1
     

    トンネル インターフェイスの送信元アドレスを設定します。 ここで使用されるアドレスは、イーサネット インターフェイス 1 に割り当てられているアドレスです。

     
    ステップ 6 ipv6 address { ipv6-prefix/prefix-length | prefix-name sub-bits/prefix-length }


    例:
    Device(config-if)# ipv6 address 2001:db8:A00:1::1/64
     

    IPv6 アドレスを設定し、インターフェイスで IPv6 処理をイネーブルにします。

     
    ステップ 7 ipv6 address ipv6-prefix/prefix-length anycast


    例:
    Device(config-if)# ipv6 address 2002:db8:c058::/128 anycast
     

    ipv6 address anycast コマンドを指定して、IPv6 エニーキャスト アドレスを追加します。

     

    IPv6 エニーキャスト アドレスの設定例

    例:IPv6 エニーキャスト アドレスの設定

     interface tunnel0
       tunnel mode ipv6ip 6to4
       tunnel source ethernet1
       ipv6 address 2001:0db8:1::1/64
       ipv6 address 2002:0db8:6301::/128 anycast
      !
      interface gigabitethernet1
       ip address 10.0.0.1 255.255.255.0
       ip address 192.88.99.1 255.255.255.0 secondary 
     

    IPv6 のソース ガードおよびプレフィックス ガードのその他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    IPv6 のアドレッシングと接続

    『IPv6 Configuration Guide』

    IPv4 アドレス指定

    『IP Addressing: IPv4 Addressing Configuration Guide』

    Cisco IOS コマンド

    『Cisco IOS Master Command List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    『IPv6 RFCs』

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    IPv6 エニーキャスト アドレスの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 IPv6 エニーキャスト アドレスの機能情報

    機能名

    リリース

    機能情報

    IPv6:エニーキャスト アドレス

    12.2(25)SEA

    12.2(25)SG

    12.2(33)SRA

    12.2(33)SXH

    12.3(4)T

    15.0(2)SG

    Cisco IOS XE Release 2.1

    3.2.0SG

    エニーキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットに割り当てられます。 エニーキャスト アドレスは、ユニキャスト アドレス空間から割り当てられるため、その構文ではユニキャスト アドレスと区別できません。

    ipv6 address anycastshow ipv6 interface の各コマンドが追加または変更されています。