IP マルチキャスト:IGMP コンフィギュレーション ガイド、Cisco IOS XE Release 3S
IGMP のカスタマイズ
IGMP のカスタマイズ
発行日;2013/06/14   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

IGMP のカスタマイズ

インターネット グループ管理プロトコル(IGMP)は、特定の LAN セグメント上でマルチキャスト グループに個々のホストを動的に登録する場合に使用されます。 インターフェイス上で Protocol Independent Multicast(PIM)をイネーブルにした場合でも、そのインターフェイス上で IGMP の動作がイネーブルにされます。

このモジュールでは、次の方法を含む、IGMP をカスタマイズする方法について説明します。

  • 直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定します。
  • マルチキャスト ネットワーク エンドポイントまたはホストとしてルータが動作できるように、IGMP バージョン 3(IGMPv3)ホスト スタックをイネーブルにする方法。
  • ルータによって、IGMPv3 環境で特定のグループまたはチャネルに加入している個々のホストそれぞれを追跡できるようにする方法。
  • IGMP 拡張アクセス リストを使用して SSM ネットワークへのアクセスを制御する方法。
  • ダウンストリーム ルータに直接接続されていないホストが、アップストリーム ネットワークがソースのマルチキャスト グループに加入できるようにするために、IGMP プロキシを設定する方法。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

IGMP のカスタマイズの前提条件

  • このモジュールの作業を実行する前に、「IP Multicast Technology Overview」モジュールで説明している概念をよく理解しておく必要があります。
  • このモジュールの作業では、IP マルチキャストがイネーブルに設定され、「Configuring Basic IP Multicast」モジュールで説明されている作業を使用して、Protocol Independent Multicast(PIM)インターフェイスが設定されていることを前提とします。

IGMP のカスタマイズの制約事項

SSM モードで設定されていないマルチキャスト グループでのトラフィック フィルタリング

Source Specific Multicast(SSM)モードで設定されていないマルチキャスト グループに対するトラフィックをフィルタリングまたは制限する場合、ソフトウェアで IGMPv3 メンバーシップは使用されません。 実際には、Cisco IOS ソフトウェアにより、デンス モード、スパース モード、または双方向モードで設定されているグループに対するすべての IGMPv3 メンバーシップ レポートが、グループ メンバーシップ レポートに解釈され、すべてのアクティブなソースからのトラフィックがネットワークに転送されます。

IGMP スヌーピングとの相互運用性

IGMPv3 メッセージは、IGMP バージョン 1(IGMPv1)およびバージョン 2(IGMPv2)で使用されているメッセージと異なるため、IGMP スヌーピングがサポートされ、IGMP スヌーピングでイネーブルにされているスイッチで IGMPv3 を使用するときには、注意が必要です。 IGMPv3 メッセージがスイッチで認識されない場合、IGMPv3 が使用されているときに、ホストではトラフィックが正しく受信されません。 この場合は、スイッチ上で IGMP スヌーピングがディセーブルにされているか、または、ルータではインターフェイス上で IGMPv2 に対する設定が行われています。これによって、URL Rendezvous Directory(URD)または IGMP v3lite を使用できないホスト アプリケーションに対して、SSM を使用する機能が削除されます。

CGMP との相互運用性

Cisco Group Management Protocol(CGMP)を使用しているネットワークでは、IGMPv3 で設定されている場合よりも、IGMPv2 で設定されている場合に、より優れたグループ脱退動作が使用されます。 IGMPv2 で CGMP が使用され、CGMP 脱退機能でスイッチがイネーブルの場合、マルチキャスト グループに加入しているポートへのトラフィックは、そのポート上の最後のメンバがそのグループに対するメンバーシップを廃棄した直後に、ポートから削除されます。 この高速脱退メカニズムは、IGMPv2 の一部で、特に CGMP 高速脱退対応スイッチによってサポートされます。

IGMPv3 では、現在、高速脱退をサポートしている CGMP スイッチはありません。 IGMPv3 がネットワークで使用される場合、CGMP は動作し続けますが、CGMP 高速脱退サポートは無効で、次の条件が適用されます。

  • CGMP スイッチの新しいポート上にあるホストがマルチキャスト グループに参加するたびに、そのポートは、このグループのトラフィックが送信される宛先のポートのリストに追加されます。
  • 特定のポート上のすべてのホストがマルチキャスト グループから脱退した場合でも、グループに加入している(同じ仮想 LAN 上の)他のポートにホストがある場合は何も行われません。 つまり、そのマルチキャスト グループからトラフィックを受信し続けます。
  • 仮想 LAN(VLAN)にある最後のホストからマルチキャスト グループを脱退するときにのみ、このグループのトラフィックの VLAN への転送は、転送スイッチのどのポートにも戻りません。

この加入の動作は IGMPv3 モードで実際に動作しているマルチキャスト グループにだけ適用されます。 IGMPv2 のみをサポートしているレガシー ホストがネットワークにある場合、グループは IGMPv2 に戻され、これらのグループに対して高速脱退が動作します。

CGMP 対応スイッチで高速脱退が必要な場合は、IGMPv3 をイネーブルにせず、そのインターフェイスで IGMPv2 を設定することを推奨します。

SSM を使用する場合は、IGMPv3 が必要で、次の 2 つの構成オプションがあります。

  • IGMPv2 のインターフェイスのみを設定し、IGMP v3lite および URD を使用する。
  • IGMPv3 をイネーブルにし、CGMP スイッチを介してより高度な脱退遅延を受け入れる。

IGMP のカスタマイズに関する情報

インターネット グループ管理プロトコル(IGMP)の役割

IGMP は、マルチキャスト グループの個々のホストを特定の LAN にダイナミックに登録するために使用します。 インターフェイスで PIM をイネーブルにすると、IGMP もイネーブルになります。 IGMP は、特別なマルチキャスト クエリアおよびホストを使用して、ネットワーク全体でマルチキャスト トラフィックのフローを自動的に制御および制限する手段を提供します。

  • クエリアは、クエリー メッセージを送信して、特定のマルチキャスト グループのメンバであるネットワーク デバイスを検出するネットワーク デバイス(ルータなど)です。
  • ホストは、クエリアにホスト メンバーシップを通知するためのレポート メッセージ(クエリー メッセージに応答するメッセージ)を送信するレシーバで、ルータも含まれます。 ホストでは、IGMP メッセージを使用して、マルチキャスト グループに加入し、マルチキャスト グループを脱退します。

ホストは、そのローカル マルチキャスト デバイスに IGMP メッセージを送信することで、グループ メンバーシップを識別します。 IGMP では、デバイスは IGMP メッセージを受信し、定期的にクエリーを送信して、特定のサブネットでアクティブなグループと非アクティブなグループを検出します。

IGMP のバージョンの違い

Internet Engineering Task Force(IETF)の Request for Comments(RFC)ドキュメントで定義されているように、IGMP には 3 種類のバージョンがあります。 IGMPv2 は IGMPv1 の強化版で、ホストがマルチキャスト グループからの脱退を通知する機能が追加されていいます。IGMPv3 は IGMPv2 の強化版で、あるソース IP アドレスのセットから送信されたマルチキャストだけをリッスンする機能が追加されています。

表 1 IGMP のバージョン

IGMP のバージョン

説明

IGMPv1

どのマルチキャスト グループがアクティブであるかをマルチキャスト デバイスが判断できる基本的なクエリー応答メカニズムと、ホストがマルチキャスト グループに加入および脱退できるようにするためのその他のプロセスを提供します。 RFC 1112 で、IP マルチキャスト用の IGMPv1 ホスト拡張が定義されています。

IGMPv2

IGMP の拡張で、IGMP の脱退処理、グループ固有のクエリーおよび明示的な最大応答時間フィールドなどの機能が可能になっています。 また、IGMPv2 ではこの作業を実行するために、マルチキャスト プロトコルに依存することなく IGMP クエリアを選択する機能もデバイスに追加されます。 IGMPv2 は RFC 2236 で定義されています。

IGMPv3

ソース フィルタリングを提供します。これにより、マルチキャスト レシーバ ホストは、どのグループからマルチキャスト トラフィックを受信するか、およびこのトラフィックがどのソースからのものと想定されているかをデバイスに知らせることができます。 さらに、IGMPv3 は IGMPv3 メンバーシップ レポートの宛先 IP アドレスであるリンク ローカル アドレス 224.0.0.22 をサポートしています。すべての IGMPv3 対応マルチキャスト デバイスは、このアドレスをリッスンする必要があります。 IGMPv3 は RFC 3376 で定義されています。


(注)  


デフォルトでは、インターフェイスで PIM をイネーブルにすると、そのデバイスで IGMPv2 がイネーブルになります。 IGMPv2 は、可能な限り IGMPv1 と下位互換性を保つよう設計されました。 この下位互換性を実現するために、RFC 2236 は特別な相互運用性ルールを定義しています。 ネットワークにレガシー IGMPv1 ホストが含まれている場合は、これらの運用性ルールをよく知っておく必要があります。 IGMPv1 と IGMPv2 の相互運用性の詳細については、RFC 2236『Internet Group Management Protocol, Version 2』を参照してください。


IGMPv1 を実行するデバイス

IGMPv1 デバイスは、「全ホスト」へのマルチキャスト アドレスである 224.0.0.1 に IGMP クエリーを送信して、アクティブ マルチキャスト レシーバが存在するマルチキャスト グループを求めます。 マルチキャスト レシーバも、デバイスに IGMP レポートを送信して、特定のマルチキャスト ストリームの受信を待機していることを通知できます。 ホストは非同期に、またはデバイスによって送信される IGMP クエリーに対応して、レポートを送信できます。 同じマルチキャスト グループに複数のマルチキャスト レシーバが存在する場合、これらのホストの 1 つのみで、IGMP レポート メッセージが送信されます。他のホストでは、レポート メッセージが抑制されます。

IGMPv1 では、IGMP クエリア選択はありません。 セグメント内に複数のデバイスがある場合、すべてのデバイスが定期的に IGMP クエリーを送信します。 IGMPv1 には、ホストがグループから脱退できる特別なメカニズムはありません。 ホストで、特定のグループに対するマルチキャスト パケットを受信する必要がなくなった場合は、デバイスから送信される IGMP クエリー パケットに対する応答を行わないだけです。 デバイスはクエリー パケットを送信し続けます。 デバイスが 3 回 IGMP クエリーの応答を受信しないと、グループはタイムアウトし、デバイスはグループのセグメントへのマルチキャスト パケットの送信を停止します。 ホストがタイムアウト期間後にマルチキャスト パケットを受信する場合、そのホストは新しい IGMP join をデバイスに送信するだけです。これにより、デバイスはマルチキャスト パケットの転送を再開します。

LAN 上に複数のデバイスが存在する場合は、指定ルータ(DR)を選択して、接続されているホストに対するマルチキャスト トラフィックの重複を回避する必要があります。 PIM デバイスは DR を選択する選定プロセスに従います。 最も大きい IP アドレスを持つ PIM デバイスが DR になります。

DR は、次のタスクを担当します。

  • PIM 登録メッセージ、PIM 加入メッセージ、および PIM プルーニング メッセージをランデブー ポイント(RP)に送信し、ホスト グループ メンバーシップに関する情報を通知する。
  • IGMP ホスト クエリー メッセージを送信する。
  • IGMP オーバーヘッドをホストおよびネットワークでできるだけ低く維持するために、ホスト クエリー メッセージをデフォルトで 60 秒ごとに送信する。

IGMPv2 を実行するデバイス

IGMPv2 では、IGMPv1 のクエリー メッセージング機能が改善されました。

IGMPv2 のクエリーおよびメンバーシップ レポート メッセージは、次の 2 つの例外を除き、IGMPv1 メッセージと同じです。

  • IGMPv2 クエリー メッセージは、一般クエリー(IGMPv1 クエリーと同じ)とグループ固有クエリーの 2 つのカテゴリに分かれる。
  • IGMPv1 メンバーシップ レポートと IGMPv2 メンバーシップ レポートの IGMP タイプ コードが異なる。

IGMPv2 では、次の機能に対するサポートを追加することにより、IGMP の機能の強化も行われました。

  • クエリア選択プロセス:IGMPv2 デバイスが、プロセスを実行するマルチキャスト ルーティング プロトコルに依存せずに、IGMP クエリアを選択できる機能を提供します。
  • [Maximum Response Time] フィールド:IGMP クエリアを使用して最大クエリー応答時間を指定できる、クエリー メッセージの新しいフィールド。 このフィールドで、応答のバースト性を制御し、脱退遅延を調整するクエリー応答プロセスの調整ができます。
  • グループ固有クエリー メッセージ:すべてのグループではなく特定の 1 つのグループでクエリー操作を実行する目的で、IGMP クエリアを使用することができます。
  • グループ脱退メッセージ:グループから脱退することをネットワーク上のデバイスに通知する手段をホストに提供します。

DR と IGMP クエリアが通常同じデバイスである IGMPv1 とは異なり、IGMPv2 では 2 つの機能は分離されます。 DR と IGMP クエリアは異なる基準で選択され、同じサブネット上の異なるデバイスである場合があります。 DR はサブネットで IP アドレスが最大のデバイスで、IGMP クエリアは最小の IP アドレスを持つデバイスです。

次のように、クエリー メッセージは IGMP クエリアの選択に使用されます。

  1. 各 IGMPv2 デバイスは起動時に、そのインターフェイス アドレスを一般クエリー メッセージのソース IP アドレス フィールドに使用して、当該メッセージを全システムのグループ アドレス 224.0.0.1 にマルチキャスト送信します。
  2. IGMPv2 デバイスが一般クエリー メッセージを受信すると、デバイスは自分のインターフェイス アドレスとメッセージのソース IP アドレスを比較します。 サブネット上の最下位 IP アドレスが使用されているデバイスにより、IGMP クエリアが選択されます。
  3. すべてのデバイス(クエリアは除く)でクエリー タイマーが開始されます。IGMP クエリアから一般クエリー メッセージを受信するたびに、タイマーはリセットされます。 クエリー タイマーが切れると、IGMP クエリアがダウンしたと見なされ、新しい IGMP クエリアを選択するために選択プロセスが再度実行されます。

デフォルトでは、タイマーはクエリー インターバルの 2 倍です。

IGMPv3 を実行するデバイス

IGMPv3 では、ソース フィルタリングのサポートが追加されています。これにより、マルチキャスト レシーバ ホストは、どのグループからマルチキャスト トラフィックを受信するか、およびこのトラフィックがどのソースからのものと想定されているかをデバイスに知らせることができます。 このメンバーシップ情報によって、レシーバがトラフィックを要求したソースからのトラフィックだけを転送できます。

IGMPv3 では、トラフィックを受信するソースに明示的に信号を送信するアプリケーションがサポートされます。 IGMPv3 では、次の 2 つのモードで、レシーバにより、マルチキャスト グループにメンバーシップの信号が送信されます。

  • INCLUDE モード:このモードでは、レシーバはグループにメンバーシップをアナウンスし、トラフィックを受信する IP アドレスのリスト(INCLUDE リスト)を提供します。
  • EXCLUDE モード:このモードでは、レシーバはグループにメンバーシップをアナウンスし、トラフィックを受信しない IP アドレスのリスト(EXCLUDE リスト)を提供します。 つまり、ホストは IP アドレスが EXCLUDE リストに記載されていないソースからのトラフィックだけを受信します。 インターネット標準マルチキャスト(ISM)サービス モデルの場合など、すべてのソースからトラフィックを受信するには、空の EXCLUDE リストを使用して EXCLUDE モードのメンバーシップを通知します。

IGMPv3 は SSM ネットワーク環境でホストがチャネル加入者に信号を送信する業界指定の標準プロトコルです。 IGMPv3 に依存する SSM では、ラスト ホップ デバイスおよびホストで実行されているオペレーティング システムのネットワーク スタック部分で IGMPv3 が使用でき、そのホスト上で動作しているアプリケーションで使用されている必要があります。

IGMPv3 では、ホストは 224.0.0.22 にメンバーシップ レポートを送信します。そのため、すべての IGMPv3 デバイスでこのアドレスをリッスンする必要があります。 ただし、ホストは 224.0.0.22 をリッスンせず、応答しません。ホストはこのアドレスにレポートを送信するだけです。 さらに、IGMPv3 では IGMPv3 ホストが他のホストによって送信されたレポートをリッスンしないため、メンバーシップ レポートの抑制はありません。 したがって、一般クエリーが送信されると、ネットワークのすべてのホストが応答します。

IGMP 加入の処理

ホストがマルチキャスト グループに加入するとき、ホストは、加入するマルチキャスト グループに 1 つ以上の送信要求されていないメンバーシップ レポートを送信します。 IGMP 加入処理は、IGMPv1 ホストと IGMPv2 ホストで同じです。

IGMPv3 では、ホストの加入処理は次のように処理されます。

  • ホストがグループに加入する場合は、空の EXCLUDE リストを使用して、224.0.0.22 に IGMPv3 メンバーシップ レポートを送信します。
  • ホストが特定のチャネルに加入する場合は、特定のソース アドレスを含む INCLUDE リストを使用して、224.0.0.22 に IGMPv3 メンバーシップ レポートを送信します。
  • ホストが特定のソースを除くグループに加入する場合は、これらのソースを EXCLUDE リストで除外して、224.0.0.22 に IGMPv3 メンバーシップ レポートを送信します。

(注)  


LAN 上にある一部の IGMPv3 ホストでソースが除外され、その他のホストで同じソースが含まれている場合、デバイスは LAN 上でそのソースのトラフィックを送信します(つまり、この場合、包含が除外より優先されます)。


IGMP の脱退処理

ホストがグループから脱退するために使用する方法は、動作中の IGMP のバージョンによって異なります。

IGMPv1 の脱退処理

IGMPv1 には、ホストがあるグループからのマルチキャスト トラフィックを受信しないことをそのサブネットのデバイスに通知するグループ脱退メッセージはありません。 ホストでは、マルチキャスト グループに対するトラフィックの処理が停止するだけで、そのグループに対する IGMP メンバーシップ レポートを使用した IGMP クエリーへの応答が終了します。 その結果、IGMPv1 デバイスがサブネットの特定のマルチキャスト グループにアクティブなレシーバがなくなったことを認識する唯一の方法は、デバイスがメンバーシップ レポートを受信しなくなったときになります。 このプロセスを容易にするために、IGMPv1 デバイスは、サブネットの IGMP グループとカウント ダウン タイマーを関連付けます。 サブネットのグループがメンバーシップ レポートを受信すると、タイマーがリセットされます。 IGMPv1 デバイスでは、このタイム アウト間隔は通常クエリー間隔の 3 倍(3 分)です。 このタイムアウト間隔は、すべてのホストがマルチキャスト グループから脱退した後最大 3 分間、デバイスがサブネットにマルチキャスト トラフィックを転送し続ける可能性があることを意味します。

IGMPv2 の脱退処理

IGMPv2 には、特定のグループのマルチキャスト トラフィックの受信を停止することをホストが提示する手段を提供するグループ脱退メッセージが組み込まれています。 IGMPv2 ホストがマルチキャスト グループから脱退するとき、そのホストがそのグループのメンバーシップ レポートでクエリーに応答する最後のホストである場合、デバイス全体のマルチキャスト グループ(224.0.0.2)にグループ脱退メッセージを送信します。

IGMPv3 の脱退処理

IGMPv3 は、IGMPv3 メンバーシップ レポートにソース、グループ、またはチャネルを含めるか除外することによって、ホストが特定のグループ、ソース、またはチャネルからのトラフィックの受信を停止できる機能を導入することで、脱退処理を拡張しています。

IGMP マルチキャスト アドレス

IP マルチキャスト トラフィックには、グループ アドレス(クラス D IP アドレス)が使用されます。 クラス D アドレスの上位 4 ビットは 1110 です。 したがって、ホスト グループ アドレスの範囲は 224.0.0.0 ~ 239.255.255.255 であると考えられます。

224.0.0.0 ~ 224.0.0.255 のマルチキャスト アドレスは、ルーティング プロトコルおよびその他のネットワーク制御トラフィックが使用するために予約されています。 アドレス 224.0.0.0 は、どのグループにも割り当てられません。

IGMP パケットは IP マルチキャスト グループ アドレスを使用して次のように送信されます。

  • IGMP 汎用クエリアは、アドレス 224.0.0.1(サブネット上のすべてのシステム)を宛先とします。
  • IGMP グループ固有のクエリーは、クエリー対象デバイスのグループ IP アドレスを宛先とします。
  • IGMP グループ メンバーシップ レポートは、レポート対象デバイスのグループ IP アドレスを宛先とします。
  • IGMPv2 グループ脱退メッセージは、アドレス 224.0.0.2(サブネット上のすべてのデバイス)を宛先とします。
  • IGMPv3 メンバーシップ レポートはアドレス 224.0.0.22 を宛先とします。すべての IGMPv3 対応マルチキャスト デバイスはこのアドレスをリッスンする必要があります。

IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート

IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート機能は、IGMPv3 が拡張アクセス リストに対応できるようにします。 IGMPv3 の拡張アクセス リストのサポートにより、IPv4 における SSM の重要な利点、つまりソース アドレス、グループ アドレス、またはその両方に基づいた IGMPv3 レポートのフィルタリングの利点を活用できます。

IPv4 で SSM がサポートされる拡張アクセス リストの利点

IGMPv3 は拡張アクセス リストに対応しており、ソース IP アドレスに基づいてアクセスできる IPv4 SSM の重要な利点を利用できます。 この機能の導入前は、IGMP アクセス リストは標準アクセス リストだけを受け入れ、メンバーシップ レポートはマルチキャスト グループ アドレスに基づいてフィルタリングされるだけでした。

IGMPv3 では、マルチキャスト レシーバがグループに加入できるだけではなく、グループにソースを含めたり除外したりできます。 したがって、適切なアクセス コントロールを行うために、報告されるグループ アドレスだけではなく、グループとソース アドレスで IGMPv3 メッセージをフィルタリングできるようにする必要があります。 IGMP 拡張アクセス リストでは、次の機能が導入されました。 SSM と IGMP 拡張アクセス リスト(ACL)を使用して、IGMPv3 レポートでソース S とグループ G (S, G) を許可または拒否できます。それにより、ソース アドレス、グループ アドレス、またはアドレスとグループ アドレスに基づいて IGMPv3 レポートをフィルタリングできます。

ASM グループの IGMPv3 レポートのソース アドレス

IGMP 拡張アクセス リストを使用して、(0.0.0.0, G)、つまり Any Source Multicast(ASM)など非 SSM である IGMP レポートの (*, G) に基づいてトラフィックを許可またはフィルタ(拒否)することもできます。


(注)  


(*, G) の許可ステートメントと拒否ステートメントは、それぞれ permit host 0.0.0.0 host group-address deny host 0.0.0.0 host group group-address です。


フィルタリングは ASM グループと SSM グループの両方に対する IGMPv3 レポートに適用されますが、IP マルチキャスト ルーティングは ASM グループに対する IGMPv3 レポートのソース アドレスを無視するため、SSM グループにとって最も重要です。 ASM グループに対する IGMPv3 メンバーシップ レポートのソース アドレスは、IGMP キャッシュに保存されます(show ip igmp membership コマンドで表示)が、PIM ベース IP マルチキャスト ルーティングでは、レポートされる ASM グループのみが考慮に入れられます。 したがって、ASM グループのソース アドレスのフィルタリングを追加すると、ASM グループの IGMP キャッシュだけに影響を与えます。

IGMP が拡張アクセス リストを検査する方法

IGMP 拡張アクセス リストがインターフェイスの ip igmp access-group コマンドで参照される場合、拡張アクセス リストの permit および deny ステートメントの (S, G) ペアがインターフェイスで受信された IGMP レポートの (S, G) ペアと照合されます。 たとえば、(S1, S2...Sn, G) が使用されている IGMP レポートが受信されると、最初のグループ (0.0.0.0, G) が、アクセス リスト ステートメントに対してチェックされます。 (0.0.0.0, G) の変換は (*, G) を意味し、これは、マルチキャスト グループ番号が使用されたワイルドカード ソースです。 グループが拒否された場合、IGMP レポートの全体が拒否されます。 グループが許可された場合、各 (S, G) ペアがアクセス リストに対して検査されます。 拒否されるソースが IGMP レポートから取得され、これらのソースはマルチキャスト トラフィックへのアクセスが拒否されます。

IGMP プロキシ

IGMP プロキシは、アップストリーム ネットワークがソースのマルチキャスト グループに、ダウンストリーム ルータに直接接続されていない単方向リンク ルーティング(UDLR)環境のホストが加入できるようにします。

次の図に、2 つの UDLR シナリオを示すトポロジ例を図示します。

  • 従来型の UDL ルーティングのシナリオ:直接接続されたレシーバがある UDL デバイス。
  • IGMP プロキシのシナリオ:直接接続されたレシーバのない UDL デバイス。

(注)  


IGMP UDL は、アップストリームおよびダウンストリーム デバイス上にある必要はありません。




シナリオ 1:従来型の UDLR のシナリオ(直接接続されたレシーバがある UDL デバイス)

シナリオ 1 では、IGMP プロキシ メカニズムは必要ありません。 このシナリオでは、次の一連のイベントが発生します。

  1. ユーザ 2 がグループ G の対象を要求する IGMP メンバーシップ レポートを送信します。
  2. ルータ B は、IGMP メンバーシップ レポートを受信し、LAN B のグループ G の転送エントリを追加し、UDLR アップストリーム デバイスであるルータ A に IGMP レポートをプロキシします。
  3. IGMP レポートは、インターネット リンク間でプロキシされます。
  4. ルータ A は IGMP プロキシを受信し、単方向リンクの転送エントリを保持します。

シナリオ 2:IGMP プロキシのシナリオ(直接接続されたレシーバのない UDL デバイス)

シナリオ 2 の場合、アップストリーム ネットワークがソースのマルチキャスト グループに、ダウンストリーム デバイスに直接接続されていないホストが加入できるように、IGMP プロキシ メカニズムが必要です。 このシナリオでは、次の一連のイベントが発生します。

  1. ユーザ 1 がグループ G の対象を要求する IGMP メンバーシップ レポートを送信します。
  2. ルータ C が RP(ルータ B)に PIM Join メッセージをホップバイホップで送信します。
  3. ルータ B で PIM Join メッセージを受信し、LAN B 上のグループ G に対する転送エントリが追加されます。
  4. ルータ B では、その mroute テーブルが定期的にチェックされ、インターネット リンクを介してアップストリーム UDL デバイスに IGMP メンバーシップ レポートがプロキシされます。
  5. ルータ A は単方向リンク(UDL)転送エントリを作成し、維持します。

エンタープライズ ネットワークでは、サテライトを介して IP マルチキャスト トラフィックを受信し、ネットワーク中にトラフィックを転送することができる必要があります。 シナリオ 2 は、受信ホストがダウンストリーム デバイスのルータ B に直接接続する必要があるため、単方向リンク ルーティング(UDLR)だけでは不可能です。 IGMP プロキシ メカニズムでは、マルチキャスト転送テーブルで (*, G) エントリに対する IGMP レポートを作成することによって、この制限が克服されました。 そのため、このシナリオを機能させるには、インターフェイスでプロキシされた (*, G) マルチキャスト スタティック ルート(mroute)エントリの IGMP レポートの転送をイネーブルにして(ip igmp mroute-proxy ip コマンドを使用)、mroute プロキシ サービスをイネーブルにし、(ip igmp proxy-service コマンドを使用)、PIM 対応ネットワークと可能性があるメンバーを続ける必要があります。


(注)  


PIM メッセージはアップストリームに転送されないため、各ダウンストリーム ネットワークとアップストリーム ネットワークのドメインは別になります。


IGMP のカスタマイズ方法

直接接続の IGMP ホストがない場合にマルチキャスト トラフィックが転送されるようにデバイスを設定する方法

直接接続された IGMP ホストがない場合に、マルチキャスト トラフィックを転送するようにデバイスを設定するには、次のオプション作業を実行します。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    次のいずれかを実行します。

    • ip igmp join-group group-address
    • ip igmp static-group {* | group-address [source source-address]}

    5.    end

    6.    show ip igmp interface [interface-type interface-number]


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface type number


    例:
    Device(config)# interface gigabitethernet 1
     

    インターフェイス コンフィギュレーション モードを開始します。

    • type 引数および number 引数に、ホストに接続されているインターフェイスを指定します。
     
    ステップ 4次のいずれかを実行します。
    • ip igmp join-group group-address
    • ip igmp static-group {* | group-address [source source-address]}


    例:
    Device(config-if)# ip igmp join-group 225.2.2.2 


    例:
    Device(config-if)# ip igmp static-group 225.2.2.2
     
    最初の例では、指定したグループに加入するデバイスのインターフェイスを設定する例を示します。
    • この方法では、デバイスは、マルチキャスト パケットの転送に加えて、マルチキャスト パケットを受信します。 マルチキャスト パケットを受信する場合は、高速スイッチングを実行できません。
    2 番目の例では、インターフェイスでスタティック グループ メンバーシップ エントリを設定する例を示します。
    • この方法の場合、デバイスはパケットそのものを受信せず、転送だけを実行します。 したがって、この方法では、高速スイッチングを実行できます。 発信インターフェイスが IGMP キャッシュに格納されますが、マルチキャスト ルート エントリに「L」(ローカル)フラグが付かないことからも明らかなように、デバイス自体はメンバではありません。
     
    ステップ 5 end


    例:
    Device(config-if)# end
     

    特権 EXEC モードに戻ります。

     
    ステップ 6 show ip igmp interface [interface-type interface-number]


    例:
    Device# show ip igmp interface 
     

    (任意)インターフェイスに関するマルチキャスト関連情報を表示します。

     

    IGMP 拡張アクセス リストを使用して SSM ネットワークへのアクセスを制御する方法

    ソース アドレス、グループ アドレス、またはその両方に基づいて SSM トラフィックをフィルタする IGMP 拡張アクセス リストを使用して SSM ネットワークへのアクセスを制御するには、次のオプション作業を実行します。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ip multicast-routing [distributed]

      4.    ip pim ssm {default | range access-list}

      5.    ip access-list extended access-list -name

      6.    deny igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [log] [time-range time-range-name] [fragments]

      7.    permit igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [log] [time-range time-range-name] [fragments]

      8.    exit

      9.    interface type number

      10.    ip igmp access-group access-list

      11.    ip pim sparse-mode

      12.    SSM チャネル メンバーシップのアクセス コントロールを必要とするすべてのインターフェイスでステップ 1 ~ 11 を繰り返します。

      13.    ip igmp version 3

      14.    ホスト方向のインターフェイスすべてでステップ 13 を繰り返します。

      15.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ip multicast-routing [distributed]


      例:
      Device(config)# ip multicast-routing distributed
       

      IP マルチキャスト ルーティングをイネーブルにします。

      • distributed キーワードは、IPv4 マルチキャストの場合に必要です。
       
      ステップ 4 ip pim ssm {default | range access-list}


      例:
      Device(config)# ip pim ssm default
       

      SSM サービスを設定します。

      • default キーワードは SSM 範囲のアクセス リストを 232/8 と定義します。
      • range キーワードは標準の IP アクセス リスト番号または SSM 範囲を定義する名前を指定します。
       
      ステップ 5 ip access-list extended access-list -name


      例:
      Device(config)# ip access-list extended mygroup
       

      名前付き拡張 IP アクセス リストを指定します。

       
      ステップ 6 deny igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [log] [time-range time-range-name] [fragments]


      例:
      Device(config-ext-nacl)# deny igmp host 10.1.2.3 any
       

      (任意)IGMP レポートから指定したソース アドレスまたはグループ アドレスをフィルタリングすることで、サブネットのホストをメンバーシップから (S, G) チャネルに制限します。

      • サブネット メンバーシップから他の (S, G) チャネルにホストを制限するには、この手順を繰り返します。 (特に許可されないソースまたはグループは拒否されるため、これらのソースは後続の permit ステートメントより限定的になります)。
      • アクセス リストは、暗黙の deny ステートメントで終了することに注意してください。
      • 次に、ソース 10.1.2.3 に対してすべてのグループをフィルタリングして、効果的にソースを拒否する deny ステートメントを作成する例を示します。
       
      ステップ 7 permit igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [log] [time-range time-range-name] [fragments]


      例:
      Device(config-ext-nacl)# permit igmp any any
       

      IGMP レポートのソース アドレスまたはグループ アドレスが IP アクセス リストを渡すことができます。

      • アクセス リストには少なくとも 1 つの permit ステートメントが必要です。
      • 他のソースが IP アクセス リストを渡せるようにする場合は、この手順を繰り返します。
      • この例では、前の deny ステートメントによって拒否されていないソースおよびグループに対するメンバーシップを許可する方法を示します。
       
      ステップ 8 exit


      例:
      Device(config-ext-nacl)# exit
       

      現在のコンフィギュレーション セッションを終了し、グローバル コンフィギュレーション モードに戻ります。

       
      ステップ 9 interface type number

      例:
      Device(config)# interface ethernet 0
       

      IGMPv3 をイネーブルにできるホストに接続されているインターフェイスを選択します。

       
      ステップ 10 ip igmp access-group access-list


      例:
      Device(config-if)# ip igmp access-group mygroup 
       

      IGMP レポートに指定されたアクセス リストが適用されます。

       
      ステップ 11 ip pim sparse-mode


      例:
      Device(config-if)# ip pim sparse-mode
       

      インターフェイスで PIM-SM をイネーブルにします。

      (注)     

      スパース モードを使用する必要があります。

       
      ステップ 12 SSM チャネル メンバーシップのアクセス コントロールを必要とするすべてのインターフェイスでステップ 1 ~ 11 を繰り返します。  

      --

       
      ステップ 13 ip igmp version 3


      例:
      Device(config-if)# ip igmp version 3
       

      このインターフェイス上で IGMPv3 をイネーブルにします。 デフォルトの IGMP バージョンは IGMP バージョン 2 です。 SSM にはバージョン 3 が必要です。

       
      ステップ 14 ホスト方向のインターフェイスすべてでステップ 13 を繰り返します。  

      --

       
      ステップ 15 end


      例:
      Device(config-if)# end
       

      特権 EXEC モードに戻ります。

       

      IGMP プロキシの設定

      IGMP プロキシ メカニズムを使用するように単方向リンク(UDL)ルータを設定するには、次のオプション作業を実行します。 IGMP プロキシは、アップストリーム ネットワークがソースのマルチキャスト グループに、ダウンストリーム ルータに直接接続されていない単方向リンク ルーティング(UDLR)環境のホストが加入できるようにします。

      IGMP プロキシを設定するには、次のタスクを実行する必要があります。

      前提条件

      IGMP プロキシを設定する前に、次の条件が存在することを確認します。

      • IGMP UDL 上のすべてのルータに、同じサブネット アドレスがあること。 UDL 上のすべてのルータで、同じサブネット アドレスを持つことができない場合、アップストリーム ルータは、ダウンストリーム ルータが接続されているすべてのサブネットに一致するセカンダリ アドレスで設定される必要があります。
      • この作業では、IP マルチキャストがイネーブルに設定され、PIM インターフェイスが設定されていることを前提とします。

      IGMP プロキシ シナリオのインターフェイスで PIM をイネーブルにする場合、次のガイドラインに留意してください。

        • インターフェイスがスパース モード領域で実行中で、スタティック RP、ブートストラップ(BSR)、または自動 RP リスナー機能ありで自動 RP を実行している場合は、PIM スパース モード(PIM-SM)を使用します。
        • インターフェイスがスパース-デンス モード領域で実行中で、自動 RP リスナー機能なしで自動 RP を実行している場合は、PIM スパース-デンス モードを使用します。
        • インターフェイスがデンス モードで実行中で、デンス モード領域に加入する場合、この手順で PIM デンス モード(PIM-DM)を使用します。
        • インターフェイスが、スパース モード領域のレシーバに到達する必要があるトラフィックをデンス モード領域から受信する場合は、プロキシ登録機能ありの PIM-DM を使用します。

      IGMP UDLR に対するアップストリーム UDL デバイスの設定

      IGMP UDLR に対するアップストリーム UDL デバイスを設定するには、この作業を実行します。

      手順の概要

        1.    enable

        2.    configure terminal

        3.    interface type number

        4.    ip igmp unidirectional-link

        5.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 interface type number


        例:
        Device(config)# interface gigabitethernet 1/0/0
         

        インターフェイス コンフィギュレーション モードを開始します。

        • type および number 引数に、アップストリーム デバイスの UDL として使用するインターフェイスを指定します。
         
        ステップ 4 ip igmp unidirectional-link


        例:
        Device(config-if)# ip igmp unidirectional-link
         

        インターフェイス上の IGMP を、IGMP UDLR に対して単方向になるよう設定します。

         
        ステップ 5 end


        例:
        Device(config-if)# end
         

        現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

         

        IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL デバイスの設定

        IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL デバイスを設定するには、この作業を実行します。

        手順の概要

          1.    enable

          2.    configure terminal

          3.    interface type number

          4.    ip igmp unidirectional-link

          5.    exit

          6.    interface type number

          7.    ip igmp mroute-proxy type number

          8.    exit

          9.    interface type number

          10.    ip igmp helper-address udl interface-type interface-number

          11.    ip igmp proxy-service

          12.    end

          13.    show ip igmp interface

          14.    show ip igmp udlr


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Device> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Device# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 interface type number


          例:
          Device(config)# interface gigabitethernet 0/0/0
           

          インターフェイス コンフィギュレーション モードを開始します。

          • type および number 引数に、IGMP UDLR に対するダウンストリーム デバイスの UDL として使用するインターフェイスを指定します。
           
          ステップ 4 ip igmp unidirectional-link


          例:
          Device(config-if)# ip igmp unidirectional-link
           

          インターフェイス上の IGMP を、IGMP UDLR に対して単方向になるよう設定します。

           
          ステップ 5 exit


          例:
          Device(config-if)# exit
           

          インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

           
          ステップ 6 interface type number


          例:
          Device(config)# interface gigabitethernet 1/0/0
           

          インターフェイス コンフィギュレーション モードを開始します。

          • type および number 引数で、間接的に接続されているホストの方向に向いているインターフェイスを選択します。
           
          ステップ 7 ip igmp mroute-proxy type number


          例:
          Device(config-if)# ip igmp mroute-proxy loopback 0 
           

          プロキシされた (*, G) マルチキャスト スタティック ルート(mroute)エントリの IGMP レポートの転送をイネーブルにします。

          • この手順は、マルチキャスト転送テーブルにあるすべての (*, G) 転送エントリに対するプロキシ サービス インターフェイスへの、IGMP レポートの転送をイネーブルにするために実行されます。
          • この例では、ギガビット イーサネット インターフェイス 1/0/0 で、ギガビット イーサネット インターフェイス 1/0/0 に転送される mroute テーブルのすべてのグループのループバック インターフェイス 0 に IGMP レポートを送信するように要求する ip igmp mroute-proxy コマンドが設定されます。
           
          ステップ 8 exit


          例:
          Device(config-if)# exit
           

          インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

           
          ステップ 9 interface type number


          例:
          Device(config)# interface loopback 0
           

          指定したインターフェイスに対してインターフェイス コンフィギュレーション モードを開始します。

          • この例では、ループバック インターフェイス 0 が指定されます。
           
          ステップ 10 ip igmp helper-address udl interface-type interface-number


          例:
          Device(config-if)# ip igmp helper-address udl gigabitethernet 0/0/0
           

          UDLR で IGMP ヘルパーを設定します。

          • このステップで、ダウンストリーム デバイスが受信したホストから interface-type および interface-number 引数で指定されたインターフェイスに関連付けられた UDL に接続されているアップストリーム デバイスへの IGMP レポートをヘルパー処理できるようになります。
          • トポロジ例では、IGMP ヘルパーはダウンストリーム デバイスのループバック インターフェイス 0 に設定されます。 そのため、ループバック インターフェイス 0 が、ホストからギガビット イーサネット インターフェイス 0/0/0 に接続されているアップストリーム デバイスへの IGMP レポートをヘルパー処理するように設定されます。
           
          ステップ 11 ip igmp proxy-service


          例:
          Device(config-if)# ip igmp proxy-service 
           

          mroute プロキシ サービスをイネーブルにします。

          • mroute プロキシ サービスがイネーブルのときに、IGMP クエリー インターバルに基づいて ip igmp mroute-proxy コマンド(ステップ 7 を参照)で設定されたインターフェイスに一致する、(*, G) 転送エントリのスタティック mroute テーブルが、デバイスによって定期的にチェックされます。 一致が存在する場合、1 つの IGMP レポートがこのインターフェイスで作成され、受信されます。
          (注)     

          ip igmp proxy-service コマンドは、ip igmp helper-address(UDL)コマンドと共に使用するように意図されています。

          • この例では、ip igmp mroute-proxy コマンドで登録されているインターフェイスに対するすべてのグループのインターフェイスに対して IGMP レポートの転送をイネーブルにするように、ループバック インターフェイス 0 で ip igmp proxy-service コマンドが設定されます(ステップ 7 を参照してください)。
           
          ステップ 12 end


          例:
          Device(config-if)# end
           

          現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

           
          ステップ 13 show ip igmp interface


          例:
          Device# show ip igmp interface
           

          (任意)インターフェイスに関するマルチキャスト関連情報を表示します。

           
          ステップ 14 show ip igmp udlr


          例:
          Device# show ip igmp udlr
           

          (任意)設定された UDL ヘルパー アドレスがあるインターフェイス上で、マルチキャスト グループに直接接続されている UDLR 情報を表示します。

           

          IGMP のカスタマイズ設定例

          例:直接接続された IGMP ホストがない場合に、マルチキャスト トラフィックを転送するようにデバイスを設定

          次に、ip igmp join-group コマンドを使用して、直接接続された IGMP ホストがない場合に、マルチキャスト トラフィックを転送するようデバイスを設定する例を示します。 この方法では、デバイスは、マルチキャスト パケットの転送に加えて、マルチキャスト パケットを受信します。 マルチキャスト パケットを受信する場合は、高速スイッチングを実行できません。

          この例では、グループ 225.2.2.2 に加入するように、デバイスでファスト イーサネット インターフェイス 0/0/0 が設定されています。

          interface FastEthernet0/0/0
           ip igmp join-group 225.2.2.2 
          

          次に、ip igmp static-group コマンドを使用して、直接接続された IGMP ホストがない場合に、マルチキャスト トラフィックを転送するようデバイスを設定する例を示します。 この方法の場合、デバイスはパケットそのものを受信せず、転送だけを実行します。 したがって、この方法では、高速スイッチングを実行できます。 発信インターフェイスが IGMP キャッシュに格納されますが、マルチキャスト ルート エントリに「L」(ローカル)フラグが付かないことからも明らかなように、デバイス自体はメンバではありません。

          この例では、グループ 225.2.2.2 のスタティック グループ メンバーシップ エントリがファスト イーサネット インターフェイス 0/1/0 で設定されます。

          interface FastEthernet0/1/0
           ip igmp static-group 225.2.2.2

          IGMP 拡張アクセス リストを使用して SSM ネットワークへのアクセスを制御する方法

          ここでは、IGMP 拡張アクセス リストを使用して SSM ネットワーク上でアクセスを制御する、次の設定例について説明します。


          (注)  


          アクセス リストは非常に柔軟が高いことに留意してください。マルチキャスト トラフィックのフィルタリングに使用できる permit ステートメントと deny ステートメントの組み合わせは多数あります。 この項では、少しの例を示します。


          例:グループ G のすべての状態を拒否

          次に、グループ G ですべての状態を拒否する例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.2.2.2 に対するすべてのソースがフィルタリングされるよう、ファスト イーサネット インターフェイス 0/0/0 が設定されます。これにより、このグループが効果的に拒否されます。

          ip access-list extended test1
           deny igmp any host 232.2.2.2
           permit igmp any any
          !
          interface FastEthernet0/0/0
           ip igmp access-group test1

          例:ソース S のすべての状態を拒否

          次に、ソース S ですべての状態を拒否する例を示します。 この例では、IGMPv3 レポートのソース 10.2.1.32 に対するすべてのグループがフィルタリングされるよう、ギガビット イーサネット インターフェイス 1/1/0 が設定されます。これにより、このソースが効果的に拒否されます。

          ip access-list extended test2
           deny igmp host 10.2.1.32 any
           permit igmp any any
          !
          interface GigabitEthernet1/1/0
           ip igmp access-group test2

          例:グループ G のすべての状態を許可

          次に、グループ G ですべての状態を許可する例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.1.1.10 のすべてのソースが受け付けられるよう、ギガビット イーサネット インターフェイス 1/2/0 が設定されます。これにより、このグループが効果的に受け付けられます。

          ip access-list extended test3
           permit igmp any host 232.1.1.10
          !
          interface GigabitEthernet1/2/0
           ip igmp access-group test3

          例:ソース S のすべての状態を許可

          次に、ソース S ですべての状態を許可する例を示します。 この例では、IGMPv3 レポートのソース 10.6.23.32 に対するすべてのグループが受け付けられるよう、ギガビット イーサネット インターフェイス 1/2 が設定されます。これにより、このソース全体が効果的に受け付けられます。

          ip access-list extended test4
           permit igmp host 10.6.23.32 any
          !
          interface GigabitEthernet1/2/0
           ip igmp access-group test4

          例:グループ G のソース S をフィルタリング

          次に、グループ G で特定のソース S をフィルタリングする例を示します。 この例では、IGMPv3 レポートの SSM グループ 232.2.30.30 のソース 232.2.2.2 をフィルタリングするよう、ギガビット イーサネット インターフェイス 0/3/0 が設定されます。

          ip access-list extended test5
           deny igmp host 10.4.4.4 host 232.2.30.30
           permit igmp any any
          !
          interface GigabitEthernet0/3/0
           ip igmp access-group test5

          例:IGMP プロキシ設定

          次に、IGMP UDLR に対してアップストリーム UDL デバイスを設定し、IGMP プロキシ サポート付きの IGMP UDLR に対してダウンストリーム UDL デバイスを設定する例を示します。

          アップストリーム デバイスの設定

          interface gigabitethernet 0/0/0 
          ip address 10.1.1.1 255.255.255.0 
          ip pim dense-mode 
          ! 
          interface gigabitethernet 1/0/0 
          ip address 10.2.1.1 255.255.255.0 
          ip pim dense-mode 
          ip igmp unidirectional-link 
          ! 
          interface gigabitethernet 2/0/0 
          ip address 10.3.1.1 255.255.255.0 

          ダウンストリーム デバイスの設定

          ip pim rp-address 10.5.1.1 5 
          access-list 5 permit 239.0.0.0 0.255.255.255 
          ! 
          interface loopback 0 
          ip address 10.7.1.1 255.255.255.0 
          ip pim dense-mode 
          ip igmp helper-address udl ethernet 0 
          ip igmp proxy-service 
          ! 
          interface gigabitethernet 0/0/0 
          ip address 10.2.1.2 255.255.255.0 
          ip pim dense-mode 
          ip igmp unidirectional-link 
          ! 
          interface gigabitethernet 1/0/0 
          ip address 10.5.1.1 255.255.255.0 
          ip pim sparse-mode 
          ip igmp mroute-proxy loopback 0 
          ! 
          interface gigabitethernet 2/0/0 
          ip address 10.6.1.1 255.255.255.0 

          その他の関連資料

          ここでは、IGMP のカスタマイズに関する関連資料について説明します。

          関連資料

          関連項目

          マニュアル タイトル

          Cisco IOS コマンド

          『Cisco IOS Master Commands List, All Releases』

          Cisco IOS IP SLA コマンド

          『Cisco IOS IP Multicast Command Reference』

          IP マルチキャスト テクノロジー分野の概要

          「IP Multicast Technology Overview」モジュール

          基本的な IP マルチキャストの概念、設定作業、および例

          「Configuring Basic IP Multicast」または「Configuring IP Multicast in IPv6 Networks」モジュール

          標準および RFC

          標準/RFC

          タイトル

          RFC 1112

          『Host extensions for IP multicasting』

          RFC 2236

          『Internet Group Management Protocol, Version 2』

          RFC 3376

          『Internet Group Management Protocol, Version 3』

          MIB

          MIB

          MIB のリンク

          これらの機能によってサポートされる新しい MIB または変更された MIB はありません。またこれらの機能による既存 MIB のサポートに変更はありません。

          選択したプラットフォーム、Cisco IOS XE Release、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

          http:/​/​www.cisco.com/​go/​mibs

          シスコのテクニカル サポート

          説明

          リンク

          シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          IGMP のカスタマイズの機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 2 IGMP のカスタマイズの機能情報

          機能名

          リリース

          機能情報

          IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート

          12.0(19)S

          12.3(7)T

          12.2(25)S

          12.2(27)SBC

          12.2(33)SRA

          12.2(33)SXH

          15.0(1)S

          Cisco IOS XE 3.1.0SG

          IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート機能は、IGMPv3 が拡張アクセス リストに対応できるようにします。 IGMPv3 の拡張アクセス リストのサポートにより、IPv4 における SSM の重要な利点、つまりソース アドレス、グループ アドレス、またはその両方に基づいた IGMPv3 レポートのフィルタリングの利点を活用できます。

          この機能により、ip igmp access-group コマンドが導入されました。