マルチトポロジ ルーティング コンフィギュレーション ガイド、Cisco IOS XE Release 3S
MTR に対する IS-IS サポート
MTR に対する IS-IS サポート
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

MTR に対する IS-IS サポート

MTR に対する IS-IS サポート機能により、単一の物理ネットワーク上の複数の論理トポロジに対する Intermediate System-to-Intermediate System(IS-IS)サポートが実現します。 ここでは、ユニキャスト トポロジとマルチキャスト トポロジの両方について、マルチトポロジ ルーティング(MTR)に対して IS-IS を設定する方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

MTR に対する IS-IS サポートの前提条件

  • 「MTR に対するルーティング プロトコル サポート」に記載されている概念について理解しておく必要があります。
  • グローバルなトポロジ コンフィギュレーションを設定し、アクティブ化します。
  • マルチキャスト トポロジで Intermediate System-to-Intermediate System(IS-IS)プロトコルをアクティブ化する前に、マルチキャスト トポロジを設定しておく必要があります。 詳細については、「マルチキャストに対する MTR サポート」フィーチャ モジュールを参照してください。
  • IS-IS デバイスでマルチトポロジ ルーティング(MTR)トポロジをアクティブ化します。
  • all-interfaces アドレス ファミリ トポロジ コンフィギュレーション コマンドを使用してすべてのインターフェイスをグローバルに設定するよう MTR トポロジを設定するか、IS-IS インターフェイスだけを設定するよう、インターフェイス コンフィギュレーション モードで IS-IS トポロジを設定する必要します。 これらの作業を実行する順番は、重要ではありません。

MTR に対する IS-IS サポートの制約事項

IPv4 アドレス ファミリ(マルチキャストおよびユニキャスト)と IPv6 アドレス ファミリ ユニキャストだけがサポートされています。 IPv6 のマルチトポロジ IS-IS の設定については、『IS-IS Configuration Guide』を参照してください。

MTR に対する IS-IS サポートに関する情報

MTR に対するルーティング プロトコル サポート

マルチトポロジ ルーティング(MTR)を動作させるには、デバイスで IP ルーティングをイネーブルにする必要があります。 MTR は、シスコ ソフトウェアでのスタティック ルーティングおよびダイナミック ルーティングをサポートします。 トポロジ単位のダイナミック ルーティングをイネーブルにすることで、ドメイン内およびドメイン間のルーティングをサポートできます。 ルートの計算と転送は、各トポロジで個別に行われます。 シスコ ソフトウェアには、次のプロトコルについて MTR のサポートが組み込まれています。

  • Border Gateway Protocol(BGP)
  • Enhanced Interior Gateway Routing Protocol(EIGRP)
  • Integrated Intermediate System-to-Intermediate System(IS-IS)
  • Open Shortest Path First(OSPF)

グローバル ルーティング プロセス(ルータ コンフィギュレーション モード)のルータ アドレス ファミリ コンフィギュレーション モードでトポロジ単位のコンフィギュレーションを適用します。 アドレス ファミリおよびサブアドレス ファミリは、デバイスがアドレス ファミリ コンフィギュレーション モードを開始するときに指定します。 トポロジ名とトポロジ ID を指定するには、アドレス ファミリ コンフィギュレーション モードで topology コマンドを入力します。

各トポロジに、ルーティング プロトコル下で一意のトポロジ ID を設定します。 トポロジ ID は、所定のプロトコルのアップデート時に各トポロジに対してネットワーク層到着可能性情報(NLRI)を識別してグループ化するために使用されます。 OSPF、EIGRP、および IS-IS では、クラス固有のトポロジに対する topology コマンドの最初のコンフィギュレーションでトポロジ ID を入力します。 BGP では、トポロジ コンフィギュレーションの下に bgp tid コマンドを入力することによってトポロジ ID を設定します。

クラス固有のトポロジには、基本トポロジとは異なるメトリックを設定できます。 基本トポロジに設定されたインターフェイス メトリックをクラス固有のトポロジに継承することもできます。 継承は、クラス固有のトポロジに明示的な継承メトリックが設定されていない場合に実行されます。

BGP サポートは、ルータ コンフィギュレーション モードだけで設定します。 Interior Gateway Protocol(IGP)サポートは、ルータ コンフィギュレーション モードとインターフェイス コンフィギュレーション モードで設定します。

デフォルトでは、インターフェイスには基本トポロジ以外のトポロジは含まれません。 EIGRP、IS-IS、および OSPF のルーティング プロトコル サポートについては、インターフェイスに基本トポロジ以外のトポロジを明示的に設定する必要があります。 アドレス ファミリ トポロジ コンフィギュレーション モードで all-interfaces コマンドを使用すると、デフォルト動作を無効にできます。 all-interfaces コマンドを入力すると、デフォルトのアドレス空間、またはトポロジが設定される仮想ルーティングおよび転送(VRF)に属するデバイスのすべてのインターフェイスに、基本トポロジ以外のトポロジが設定されます。

MTR に対するインターフェイス コンフィギュレーション サポート

インターフェイス コンフィギュレーション モードでマルチトポロジ ルーティング(MTR)トポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにできます。 デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

個々のインターフェイスを包含または除外するには、topology インターフェイス コンフィギュレーション コマンドを設定します。 このコマンドの入力時に、アドレス ファミリとトポロジ(基本またはクラス固有)を指定します。 サブアドレス ファミリを指定することもできます。 サブアドレス ファミリを指定しないと、デフォルトでユニキャスト サブアドレス ファミリが使用されます。

トポロジにデバイス上のすべてのインターフェイスをグローバルに包含するには、ルーティング トポロジ コンフィギュレーション モードで all-interfaces コマンドを入力します。 topology コマンドで適用したインターフェイス単位のトポロジ コンフィギュレーションは、グローバル インターフェイス コンフィギュレーションよりも優先されます。

MTR に対するインターフェイス コンフィギュレーション サポートには、次の特徴があります。

  • インターフェイス単位のルーティング コンフィギュレーション:Interior Gateway Protocol(IGP)ルーティングおよびメトリックのコンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用できます。 インターフェイス単位のメトリックおよびルーティングの動作は、IGP ごとに設定できます。
  • Open Shortest Path First(OSPF)インターフェイス トポロジ コンフィギュレーション:クラス固有のトポロジに対するインターフェイス モードの OSPF コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。 このモードでは、インターフェイスのコストを設定したり、グローバル トポロジ コンフィギュレーションからインターフェイスを削除することなく OSPF ルーティングをディセーブルにしたりすることができます。
  • Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイス トポロジ コンフィギュレーション:クラス固有のトポロジに対するインターフェイス モードの EIGRP コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。 このモードでは、各種の EIGRP 機能を設定できます。
  • Intermediate System-to-Intermediate System(IS-IS)インターフェイス トポロジ コンフィギュレーション:クラス固有のトポロジに対するインターフェイス モードの IS-IS コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。 このモードでは、インターフェイスのコストを設定したり、グローバル トポロジ コンフィギュレーションからインターフェイスを削除することなく IS-IS ルーティングをディセーブルにしたりすることができます。

MTR に対する IS-IS サポートの設定方法

IS-IS を使用した MTR トポロジのアクティブ化


(注)  


この作業には、マルチトポロジ ルーティング(MTR)コマンドだけが示されています。


手順の概要

    1.    enable

    2.    configure terminal

    3.    router isis [area-tag]

    4.    net network-entity-title

    5.    metric-style wide [transition] [level-1 | level-2 | level-1-2]

    6.    address-family ipv4 [multicast | unicast]

    7.    topology topology-name tid number

    8.    end

    9.    show isis neighbors detail


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 router isis [area-tag]


    例:
    Device(config)# router isis
     

    Intermediate System-to-Intermediate System(IS-IS)ルーティング プロトコルをイネーブルにし、任意で IS-IS プロセスを指定します。

    • ルータ コンフィギュレーション モードを開始します。
     
    ステップ 4 net network-entity-title


    例:
    Device(config-router)# net 31.3131.3131.3131.00
     

    コネクションレス型ネットワーク サービス(CLNS)ルーティング プロセスに対して IS-IS Network Entity Title(NET)を設定します。

     
    ステップ 5 metric-style wide [transition] [level-1 | level-2 | level-1-2]


    例:
    Device(config-router)# metric-style wide 
     

    すべての IS-IS インターフェイスのメトリック値をグローバルに変更します。

    (注)     

    プレフィックス タギングには、ワイド形式のメトリックが必要です。

     
    ステップ 6 address-family ipv4 [multicast | unicast]


    例:
    Device(config-router)# address-family ipv4 
     

    ルータ アドレス ファミリ コンフィギュレーション モードを開始します。

     
    ステップ 7 topology topology-name tid number


    例:
    Device(config-router-af)# topology DATA tid 100
     

    トポロジに対する IS-IS サポートを設定し、各トポロジにトポロジ ID(TID)番号を割り当てます。

    • この例では、DATA トポロジに対する IS-IS サポートが設定されます。
     
    ステップ 8 end


    例:
    Device(config-router-af)# end 
     

    ルータ アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     
    ステップ 9 show isis neighbors detail


    例:
    Device# show isis neighbors detail
     

    (任意)デバイスとその IS-IS ネイバーの TID 値に関する MTR 情報を含む、IS-IS ネイバーの情報を表示します。

     

    次の作業

    ボーダー ゲートウェイ プロトコル(BGP)トポロジ コンフィギュレーションが必要な場合は、「MTR に対する BGP サポート」フィーチャ モジュールを参照してください。

    インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化

    はじめる前に

    インターフェイス単位のトポロジ コンフィギュレーションを実行する前に、トポロジをグローバルに定義します。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    ip address ip-address mask [secondary]

      5.    ip router isis [area-tag]

      6.    topology ipv4 [multicast | unicast] {topology-name [disable | base]}

      7.    isis topology disable

      8.    topology ipv4 [multicast | unicast] {topology-name [disable | base]}

      9.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface type number


      例:
      Device(config)# interface Ethernet 2/0 
       

      インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 4 ip address ip-address mask [secondary]


      例:
      Device(config-if)# ip address 192.168.7.17 255.255.255.0
       

      インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

       
      ステップ 5 ip router isis [area-tag]


      例:
      Device(config-if)# ip router isis
       

      インターフェイスに IP 用の Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスを設定し、ルーティング プロセスにエリア指示子を付加します。

      (注)     

      タグが指定されていない場合、ヌル タグと想定され、プロセスがヌル タグで参照されます。

       
      ステップ 6 topology ipv4 [multicast | unicast] {topology-name [disable | base]}


      例:
      Device(config-if)# topology ipv4 DATA
       

      インターフェイスにマルチトポロジ ルーティング(MTR)トポロジ インスタンスを設定し、インターフェイス トポロジ コンフィギュレーション モードを開始します。

      (注)     

      この例では、DATA というグローバル トポロジを持つ MTR ネットワークに対して、トポロジ インスタンス DATA が設定されます。

       
      ステップ 7 isis topology disable


      例:
      Device(config-if-topology)# isis topology 
      disable
       

      (任意)IS-IS プロセスが、トポロジの一部としてインターフェイスをアドバタイズしないようにします。

      (注)     

      この例では、トポロジ インスタンス DATA は、トポロジの一部としてインターフェイスをアドバタイズしません。

       
      ステップ 8 topology ipv4 [multicast | unicast] {topology-name [disable | base]}


      例:
      Device(config-if-topology)# topology ipv4 VOICE
       

      インターフェイス上で MTR トポロジ インスタンスを設定します。

      (注)     

      この例では、VOICE というグローバル トポロジを持つ MTR ネットワークに対して、トポロジ インスタンス VOICE が設定されます。

       
      ステップ 9 end


      例:
      Device(config-if-topology)# end
       

      インターフェイス トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

       

      MTR に関するインターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング

      マルチトポロジ ルーティング(MTR)に関するインターフェイスおよびトポロジ IP トラフィック統計情報をモニタするには、次の任意のコマンドを任意の順序で使用します。

      手順の概要

        1.    enable

        2.    show ip interface [type number] [topology {name | all | base}] [stats]

        3.    show ip traffic [topology {name | all | base}]

        4.    clear ip interface type number [topology {name | all | base}] [stats]

        5.    clear ip traffic [topology {name | all | base}]


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 show ip interface [type number] [topology {name | all | base}] [stats]


        例:
        Device# show ip interface FastEthernet 1/10 stats
         

        (任意)すべてのインターフェイスに関する IP トラフィック統計情報、または指定したインターフェイスに関係する統計情報を表示します。

        • インターフェイスのタイプと番号を指定すると、その特定のインターフェイスに関する情報が表示されます。 省略可能な引数を指定しない場合は、すべてのインターフェイスに関する情報が表示されます。
        • topology name キーワードと引数を使用すると、統計情報はその特定のトポロジの IP トラフィックに制限されます。
        • base キーワードを使用すると、IPv4 ユニキャスト基本トポロジが表示されます。
         
        ステップ 3 show ip traffic [topology {name | all | base}]


        例:
        Device# show ip traffic topology VOICE
         

        (任意)グローバル IP トラフィック統計情報(MTR がイネーブルである場合のすべてのトポロジの集約)または、特定のトポロジに関する統計情報を表示します。

        • base キーワードは、IPv4 ユニキャスト基本トポロジ専用です。
         
        ステップ 4 clear ip interface type number [topology {name | all | base}] [stats]


        例:
        Device# clear ip interface FastEthernet 1/10 topology all
         

        (任意)インターフェイスレベルの IP トラフィック統計情報をリセットします。

        • topology キーワードおよび関連するキーワードを使用しないと、インターフェイスレベルの集約統計情報だけがリセットされます。
        • すべてのトポロジをリセットする必要がある場合は、トポロジ名として all キーワードを使用します。
         
        ステップ 5 clear ip traffic [topology {name | all | base}]


        例:
        Device# clear ip traffic topology all
         

        (任意)IP トラフィック統計情報をリセットします。

        • トポロジ名を指定しないと、グローバル統計情報がクリアされます。
         

        MTR に対する IS-IS サポートの設定例

        例:IS-IS を使用した MTR トポロジのアクティブ化

        次に、マルチトポロジ ルーティング(MTR)トポロジの DATA および VIDEO と、MTR に対する Intermediate System-to-Intermediate System(IS-IS)サポートの両方を設定する例を示します。 DATA トポロジと VIDEO トポロジは、ネットワーク内の 3 つの IS-IS ネイバーでイネーブルになります。

        デバイス 1

        global-address-family ipv4
         topology DATA
         topology VOICE
         end
        interface Ethernet 0/0
         ip address 192.168.128.2 255.255.255.0
         ip router isis
         topology ipv4 DATA
         isis topology disable
         topology ipv4 VOICE
         end
        router isis
         net 33.3333.3333.3333.00
         metric-style wide
         address-family ipv4
          topology DATA tid 100
          topology VOICE tid 200
          end

        デバイス 2

        global-address-family ipv4
         topology DATA
         topology VOICE
         all-interfaces
          forward-base
          maximum routes 1000 warning-only
          shutdown
          end
        interface Ethernet 0/0
         ip address 192.168.128.1 255.255.255.0
         ip router isis
         topology ipv4 DATA
          isis topology disable
          topology ipv4 VOICE
          end
        interface Ethernet 1/0
         ip address 192.168.130.1 255.255.255.0
         ip router isis
         topology ipv4 DATA
          isis topology disable
          topology ipv4 VOICE
          end
        router isis
         net 32.3232.3232.3232.00
         metric-style wide
         address-family ipv4
          topology DATA tid 100
          topology VOICE tid 200
          end 

        デバイス 3

        global-address-family ipv4
         topology DATA
          topology VOICE
          all-interfaces
          forward-base
          maximum routes 1000 warning-only
          shutdown
          end
        interface Ethernet 1/0
         ip address 192.168.131.1 255.255.255.0
         ip router isis
         topology ipv4 DATA
          isis topology disable
          topology ipv4 VOICE
          end
        router isis
         net 31.3131.3131.3131.00
         metric-style wide
         address-family ipv4
          topology DATA tid 100
          topology VOICE tid 200
          end
        

        show isis neighbors detail コマンドを入力すると、IS-IS ネイバー デバイス 1 を使用したトポロジ変換を確認できます。

        Device# show isis neighbors detail
        
        System Id      Type Interface IP Address      State Holdtime Circuit Id
        R1             L2   Et0/0     192.168.128.2   UP    28       R5.01              
          Area Address(es): 33
          SNPA: aabb.cc00.1f00      
          State Changed: 00:07:05
          LAN Priority: 64
          Format: Phase V
          Remote TID:  100, 200
          Local TID:   100, 200

        例:インターフェイス コンフィギュレーション モードでの MTR IS-IS トポロジ

        次に、Intermediate System-to-Intermediate System(IS-IS)プロセスによってインターフェイス イーサネット 1/0 が DATA トポロジの一部としてアドバタイズされないようにする例を示します。

        interface Ethernet 1/0
         ip address 192.168.130.1 255.255.255.0
         ip router isis
         topology ipv4 DATA
          isis topology disable
          topology ipv4 VOICE
          end

        その他の関連資料

        関連資料

        関連項目

        マニュアル タイトル

        Cisco IOS コマンド

        『Cisco IOS Master Command List, All Releases』

        マルチトポロジ ルーティング(MTR)コマンド

        『Cisco IOS Multitopology Routing Command Reference』

        Intermediate System-to-Intermediate System(IS-IS)コマンド

        『Cisco IOS IP Routing: IS-IS Command Reference』

        IS-IS の概念と作業

        『IP Routing: IS-IS Configuration Guide』

        マルチキャスト トポロジの設定

        マルチトポロジ ルーティング コンフィギュレーション ガイド』の「マルチキャストに対する MTR サポート」フィーチャ モジュール

        IPv6 に対するマルチトポロジ IS-IS の設定

        『IP Routing: IS-IS Configuration Guide』

        シスコのテクニカル サポート

        説明

        リンク

        シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        MTR に対する IS-IS サポートに関する機能情報

        次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

        プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

        表 1 MTR に対する IS-IS サポートに関する機能情報

        機能名

        リリース

        機能情報

        MTR に対する IS-IS サポート

        12.2(33)SRB

        Cisco IOS XE Release 2.5

        この機能により、単一の物理ネットワーク上の複数の論理トポロジに対する Intermediate System-to-Intermediate System(IS-IS)サポートが実現します。

        Cisco IOS XE Release 2.5 では、Cisco ASR 1000 シリーズ ルータのサポートが追加されました。

        address-family ipv4isis topology disableshow isis neighborstopology の各コマンドが追加または変更されました。