マルチトポロジ ルーティング コンフィギュレーション ガイド、Cisco IOS XE Release 3S
MTR に対する BGP サポート
MTR に対する BGP サポート
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

MTR に対する BGP サポート

MTR に対する BGP サポート機能により、単一の物理ネットワーク上の複数の論理トポロジに対するボーダー ゲートウェイ プロトコル(BGP)サポートが実現します。 ここでは、マルチトポロジ ルーティング(MTR)に対して BGP を設定する方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

MTR に対する BGP サポートの前提条件

  • 「MTR に対する BGP サポートに関する情報」に記載されているすべての概念について理解しておく必要があります。
  • グローバルなマルチトポロジ ルーティング(MTR)トポロジ コンフィギュレーションを設定し、アクティブ化します。

MTR に対する BGP サポートの制約事項

  • トポロジ内の再配布が許可されます。 あるトポロジから別のトポロジへの再配布は許可されません。 この制限は、ルーティング ループを防ぐために設計されています。 トポロジ変換またはトポロジ インポート機能を使用して、あるトポロジから別のトポロジにルートを移動できます。
  • 単一のマルチキャスト トポロジだけを設定でき、マルチキャスト トポロジが作成される場合は基本トポロジだけを指定できます。

MTR に対する BGP サポートに関する情報

MTR に対するルーティング プロトコル サポート

マルチトポロジ ルーティング(MTR)を動作させるには、デバイスで IP ルーティングをイネーブルにする必要があります。 MTR は、シスコ ソフトウェアでのスタティック ルーティングおよびダイナミック ルーティングをサポートします。 トポロジ単位のダイナミック ルーティングをイネーブルにすることで、ドメイン内およびドメイン間のルーティングをサポートできます。 ルートの計算と転送は、各トポロジで個別に行われます。 シスコ ソフトウェアには、次のプロトコルについて MTR のサポートが組み込まれています。

  • Border Gateway Protocol(BGP)
  • Enhanced Interior Gateway Routing Protocol(EIGRP)
  • Integrated Intermediate System-to-Intermediate System(IS-IS)
  • Open Shortest Path First(OSPF)

グローバル ルーティング プロセス(ルータ コンフィギュレーション モード)のルータ アドレス ファミリ コンフィギュレーション モードでトポロジ単位のコンフィギュレーションを適用します。 アドレス ファミリおよびサブアドレス ファミリは、デバイスがアドレス ファミリ コンフィギュレーション モードを開始するときに指定します。 トポロジ名とトポロジ ID を指定するには、アドレス ファミリ コンフィギュレーション モードで topology コマンドを入力します。

各トポロジに、ルーティング プロトコル下で一意のトポロジ ID を設定します。 トポロジ ID は、所定のプロトコルのアップデート時に各トポロジに対してネットワーク層到着可能性情報(NLRI)を識別してグループ化するために使用されます。 OSPF、EIGRP、および IS-IS では、クラス固有のトポロジに対する topology コマンドの最初のコンフィギュレーションでトポロジ ID を入力します。 BGP では、トポロジ コンフィギュレーションの下に bgp tid コマンドを入力することによってトポロジ ID を設定します。

クラス固有のトポロジには、基本トポロジとは異なるメトリックを設定できます。 基本トポロジに設定されたインターフェイス メトリックをクラス固有のトポロジに継承することもできます。 継承は、クラス固有のトポロジに明示的な継承メトリックが設定されていない場合に実行されます。

BGP サポートは、ルータ コンフィギュレーション モードだけで設定します。 Interior Gateway Protocol(IGP)サポートは、ルータ コンフィギュレーション モードとインターフェイス コンフィギュレーション モードで設定します。

デフォルトでは、インターフェイスには基本トポロジ以外のトポロジは含まれません。 EIGRP、IS-IS、および OSPF のルーティング プロトコル サポートについては、インターフェイスに基本トポロジ以外のトポロジを明示的に設定する必要があります。 アドレス ファミリ トポロジ コンフィギュレーション モードで all-interfaces コマンドを使用すると、デフォルト動作を無効にできます。 all-interfaces コマンドを入力すると、デフォルトのアドレス空間、またはトポロジが設定される仮想ルーティングおよび転送(VRF)に属するデバイスのすべてのインターフェイスに、基本トポロジ以外のトポロジが設定されます。

BGP ネットワーク スコープ

マルチトポロジ ルーティング(MTR)用のボーダー ゲートウェイ プロトコル(BGP)サポートを実装するにはスコープ階層が必要ですが、スコープ階層は MTR の使用に制限されません。 スコープ階層によって、ルータ スコープ コンフィギュレーション モードなどの新しいコンフィギュレーション モードが導入されています。 デバイスは、ルータ コンフィギュレーション モードで scope コマンドを設定すると、ルータ スコープ コンフィギュレーション モードを開始します。 このコマンドを入力すると、ルーティング テーブルの集合が作成されます。

BGP コマンドはスコープ階層で単一のネットワーク用に(グローバルに)設定するか、または仮想ルーティングおよび転送(VRF)単位で設定します。このようなコンフィギュレーションをスコープ コマンドと呼びます。 スコープ階層には、1 つ以上のアドレス ファミリを含めることができます。

BGP 下の MTR コマンドライン インターフェイス(CLI)階層

ボーダー ゲートウェイ プロトコル(BGP)CLI は、事前マルチトポロジ ルーティング(MTR)の BGP コンフィギュレーションに対する下位互換性を提供し、MTR の階層化実装を可能にします。 ルータ コンフィギュレーション モードには、事前アドレス ファミリおよび事前 MTR のコンフィギュレーション CLI との下位互換性があります。 すべてのネットワークに影響を与えるグローバル コマンドはこのコンフィギュレーション モードで設定されます。 アドレス ファミリおよびトポロジ コンフィギュレーション用に、アドレス ファミリ コンフィギュレーション モードまたはトポロジ コンフィギュレーション モードで使用する汎用のセッション コマンドとピア テンプレートを設定します。

グローバル コマンドの設定後に、スコープをグローバルに定義するか、特定の仮想ルーティングおよび転送(VRF)インスタンスに対して定義します。 デバイスは、ルータ スコープ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで address-family コマンドを設定すると、アドレス ファミリ コンフィギュレーション モードを開始します。 サブアドレス ファミリ識別子(SAFI)が指定されていない場合は、ユニキャストがデフォルトのアドレス ファミリです。 MTR では、ユニキャストまたはマルチキャストの SAFI が指定された IPv4 アドレス ファミリだけがサポートされます。

デバイスがルータ コンフィギュレーション モードからアドレス ファミリ コンフィギュレーション モードに移行すると、ソフトウェアは BGP が事前 MTR ベースの CLI を使用するように設定します。 このコンフィギュレーション モードには、既存のアドレス ファミリ コンフィギュレーションとの下位互換性があります。 ルータ スコープ コンフィギュレーション モードからアドレス ファミリ コンフィギュレーション モードを開始すると、デバイスは MTR をサポートする階層 CLI を使用するよう設定されます。 トポロジに固有ではないアドレス ファミリ コンフィギュレーション パラメータは、このアドレス ファミリ コンフィギュレーション モードで入力します。

デバイスは、アドレス ファミリ コンフィギュレーション モードで topology コマンドを設定すると、BGP トポロジ コンフィギュレーション モードを開始します。 デバイスには、最大 32 個のトポロジ(基本トポロジを含む)を設定できます。 トポロジ ID を設定するには、bgp tid コマンドを入力します。 トポロジのすべてのアドレス ファミリ コンフィギュレーション パラメータとサブアドレス ファミリ コンフィギュレーション パラメータがここで設定されます。


(注)  


BGP ルーティング プロセスのスコープを設定すると、事前 MTR ベース設定に対する CLI サポートは削除されます。


次の例は、MTR の実装に対して BGP を設定するときに使用される階層レベルを示しています。

router bgp <autonomous-system-number>
 ! Global commands

 scope {global | vrf <vrf-name>}
  ! Scoped commands

  address-family {<afi>} [<safi>]
   ! Address family specific commands

   topology {<topology-name> | base}
    ! topology specific commands

クラス固有のトポロジの BGP セッション

マルチトポロジ ルーティング(MTR)は、セッション単位でボーダー ゲートウェイ プロトコル(BGP)下で設定されます。 基本のユニキャスト トポロジとマルチキャスト トポロジは、グローバル(デフォルト)セッションで伝送されます。 BGP ルーティング プロセス下で設定されるクラス固有のトポロジごとに別個のセッションが作成されます。 各セッションは、トポロジ ID で識別されます。 BGP は、クラス固有のトポロジごとに最良パスの計算を個別に実行します。 セッションごとに別個のルーティング情報ベース(RIB)と転送情報ベース(FIB)が維持されます。

BGP を使用したトポロジの変換

ネットワークの設計とポリシー要件によっては、あるデバイス上のクラス固有のトポロジから、ネイバー デバイス上のクラス固有のトポロジにルートをインストールしなければならないことがあります。 ボーダー ゲートウェイ プロトコル(BGP)を使用したトポロジ変換機能によって、この操作がサポートされます。 トポロジ変換は、BGP ネイバー セッション ベースで行われます。 neighbor translate-topology コマンドを設定するには、ネイバーの IP アドレスとトポロジ ID を使用します。

トポロジ ID は、ネイバーのクラス固有のトポロジを識別します。 ネイバーのクラス固有のトポロジ内のルートは、ローカルのクラス固有のルーティング情報ベース(RIB)にインストールされます。 BGP は、インストールされているすべてのルートで最良パスの計算を実行し、これらのルートをローカルのクラス固有の RIB にインストールします。 重複するルートを変換すると、BGP は、標準の BGP 最良パスの計算ごとに、ルートのインスタンスを 1 つだけ選択してインストールします。

BGP を使用したトポロジのインポート

ボーダー ゲートウェイ プロトコル(BGP)を使用したトポロジのインポートはトポロジ変換と似ています。 違いは、ルートが同一デバイス上のクラス固有のトポロジ間で移動されることです。 この機能を設定するには、import topology コマンドを入力し、クラス固有のトポロジまたは基本トポロジの名前を指定します。 最良パスの計算は、インポート済みのルートがトポロジのルーティング情報ベース(RIB)にインストールされる前にこれらのルートで実行されます。 この import topology コマンドには、クラス固有のトポロジ間で移動されるルートをフィルタリングできるようにする route-map キーワードも含まれています。

MTR に対する BGP サポートの設定方法

BGP を使用した MTR トポロジのアクティブ化

この作業は、ボーダー ゲートウェイ プロトコル(BGP)を使用してアドレス ファミリ内でマルチトポロジ ルーティング(MTR)トポロジをアクティブにする場合に実行します。 下図のデバイス B で設定するこの作業は、デバイス D とデバイス E でも設定する必要があります。 この作業では、スコープ階層がグローバルに適用するよう設定され、ネイバーはルータ スコープ コンフィギュレーション モードで設定されます。 IPv4 ユニキャスト アドレス ファミリでは、ビデオ トラフィックに適用される MTR トポロジは、指定されたネイバーについてアクティブにされます。 BGP トポロジのインターフェイス コンフィギュレーション モードはありません。

図 1. BGP ネットワーク ダイアグラム


 
手順の概要

    1.    enable

    2.    configure terminal

    3.    router bgp autonomous-system-number

    4.    scope {global | vrf vrf-name}

    5.    neighbor {ip-address | peer-group-name} remote-as autonomous-system-number

    6.    neighbor {ip-address | peer-group-name} transport {connection-mode {active | passive} | path-mtu-discovery | multi-session | single-session}

    7.    address-family ipv4 [mdt | multicast | unicast]

    8.    topology {base | topology-name}

    9.    bgp tid number

    10.    neighbor ip-address activate

    11.    neighbor {ip-address | peer-group-name} translate-topology number

    12.    end

    13.    clear ip bgp topology {* | topology-name} {as-number | dampening [network-address [network-mask]] | flap-statistics [network-address [network-mask]] | peer-group peer-group-name | table-map | update-group [number | ip-address]} [in [prefix-filter] | out | soft [in [prefix-filter] | out]]

    14.    show ip bgp topology {* | topology} summary


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable 
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal 
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 router bgp autonomous-system-number


    例:
    Device(config)# router bgp 45000 
     

    ルータ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成または設定します。

     
    ステップ 4 scope {global | vrf vrf-name}


    例:
    Device(config-router)# scope global 
     

    BGP ルーティング プロセスに対してスコープを定義して、ルータ スコープ コンフィギュレーション モードを開始します。

    • 単一のネットワークに適用される BGP の一般的なセッション コマンドまたは指定された仮想ルーティングおよび転送(VRF)が、このコンフィギュレーション モードで入力されます。
    • BGP がグローバル ルーティング テーブルを使用することを指定するには、global キーワードを使用します。
    • BGP が特定の VRF ルーティング テーブルを使用することを指定するには、vrf vrf-name キーワードおよび引数を使用します。 VRF がすでに存在している必要があります。
     
    ステップ 5 neighbor {ip-address | peer-group-name} remote-as autonomous-system-number


    例:
    Device(config-router-scope)# neighbor 172.16.1.2 remote-as 45000
     

    指定された自律システムのネイバーの IP アドレスを、ローカル デバイスのマルチプロトコル BGP ネイバー テーブルに追加します。

     
    ステップ 6 neighbor {ip-address | peer-group-name} transport {connection-mode {active | passive} | path-mtu-discovery | multi-session | single-session}


    例:
    Device(config-router-scope)# neighbor 172.16.1.2 transport multi-session
     

    BGP セッションの TCP 転送セッション オプションをイネーブルにします。

    • 接続のタイプ(アクティブまたはパッシブのいずれか)を指定するには、connection-mode キーワードを使用します。
    • TCP 転送パスの最大伝送単位(MTU)検出をイネーブルにするには、path-mtu-discovery キーワードを使用します。
    • アドレス ファミリごとに別個の TCP 転送セッションを指定するには、multi-session キーワードを使用します。
    • すべてのアドレス ファミリが単一の TCP 転送セッションを使用することを指定するには、single-session キーワードを使用します。
     
    ステップ 7 address-family ipv4 [mdt | multicast | unicast]


    例:
    Device(config-router-scope)# address-family ipv4 
     

    IPv4 アドレス ファミリを指定して、ルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始します。

    • IPv4 マルチキャスト配信ツリー(MDT)アドレス プレフィックスを指定するには、mdt キーワードを使用します。
    • IPv4 マルチキャスト アドレス プレフィックスを指定するには、multicast キーワードを使用します。
    • IPv4 ユニキャスト アドレス ファミリを指定するには、unicast キーワードを使用します。 デフォルトでは、address-family ipv4 コマンドに unicast キーワードが指定されていない場合、デバイスは IPv4 ユニキャスト アドレス ファミリのアドレス ファミリ コンフィギュレーション モードになります。
    • トポロジに固有ではない設定パラメータは、このコンフィギュレーション モードで設定されます。
     
    ステップ 8 topology {base | topology-name}


    例:
    Device(config-router-scope-af)# topology VIDEO 
     

    BGP がクラス固有のトポロジまたは基本トポロジのトラフィックをルーティングするトポロジ インスタンスを設定し、ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

     
    ステップ 9 bgp tid number


    例:
    Device(config-router-scope-af-topo)# bgp tid 100
     

    BGP ルーティング プロセスを、指定されたトポロジ ID に関連付けます。

    • それぞれのトポロジは、固有のトポロジ ID を使用して設定する必要があります。
     
    ステップ 10 neighbor ip-address activate


    例:
    Device(config-router-scope-af-topo)# neighbor 172.16.1.2 activate
     

    BGP ネイバーが、ネットワーク サービス アクセス ポイント(NSAP)アドレス ファミリのプレフィックスをローカル デバイスと交換できるようにします。

    (注)     

    ピア グループを BGP ネイバーとして設定した場合は、このコマンドを使用しないでください。これは、ピア グループ パラメータの設定時にピア グループが自動的にアクティブにされるためです。

     
    ステップ 11 neighbor {ip-address | peer-group-name} translate-topology number


    例:
    Device(config-router-scope-af-topo)# neighbor 172.16.1.2 translate-topology 200 
     

    (任意)別のデバイス上のトポロジからローカル デバイス上のトポロジへのルートをインストールするよう BGP を設定します。

    • デバイス上のトポロジを識別するために、number 引数にトポロジ ID を入力します。
     
    ステップ 12 end


    例:
    Device(config-router-scope-af-topo)# end 
     

    (任意)ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

     
    ステップ 13 clear ip bgp topology {* | topology-name} {as-number | dampening [network-address [network-mask]] | flap-statistics [network-address [network-mask]] | peer-group peer-group-name | table-map | update-group [number | ip-address]} [in [prefix-filter] | out | soft [in [prefix-filter] | out]]


    例:
    Device# clear ip bgp topology VIDEO 45000
     

    指定されたトポロジまたはすべてのトポロジ下で BGP ネイバー セッションをリセットします。

     
    ステップ 14 show ip bgp topology {* | topology} summary


    例:
    Device# show ip bgp topology VIDEO summary
     

    (任意)トポロジに関する BGP 情報を表示します。

    • ほとんどの標準の BGP キーワードと引数は、topology キーワードの後に入力できます。
    (注)     

    この作業に必要な構文だけが示されています。 詳細については、『Cisco IOS IP Routing: BGP Command Reference』を参照してください。

     

    次の作業

    イネーブルにするトポロジごとにこの作業を繰り返して、トポロジを使用するすべてのネイバー デバイスでこの設定を繰り返します。

    同じルータ上のあるマルチトポロジ ルーティング(MTR)トポロジから別のトポロジにルートをインポートする場合は、「BGP を使用した MTR トポロジからのルートのインポート」セクションを参照してください。

    BGP を使用した MTR トポロジからのルートのインポート

    この作業は、複数のトポロジが同じデバイスで設定されている場合に、同じデバイス上のあるマルチトポロジ ルーティング(MTR)トポロジから別のトポロジにルートをインポートする場合に実行します。 この作業では、10.2.2.0 ネットワークからのプレフィックスを許可するためにプレフィックス リストが定義されます。このプレフィックス リストは、インポートされたトポロジから移動したルートをフィルタリングするために、ルート マップとともに使用されます。 グローバル スコープが設定され、アドレス ファミリ IPv4 が入力されて、VIDEO トポロジが指定されます。また、VOICE トポロジがインポートされ、10NET という名前のルート マップを使用してルートがフィルタリングされます。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ip prefix-list list-name [seq number] {deny | permit} network/length [ge ge-length] [le le-length]

      4.    route-map map-name [permit | deny] [sequence-number]

      5.    match ip address {access-list-number [access-list-number ... | access-list-name...] | access-list-name [access-list-number ... | access-list-name] | prefix-list prefix-list-name [prefix-list-name...]}

      6.    exit

      7.    router bgp autonomous-system-number

      8.    scope {global | vrf vrf-name}

      9.    address-family ipv4 [mdt | multicast | unicast]

      10.    topology {base | topology-name}

      11.    import topology {base | topology-name} [route-map map-name]

      12.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable 
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal 
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ip prefix-list list-name [seq number] {deny | permit} network/length [ge ge-length] [le le-length]


      例:
      Device(config)# ip prefix-list TEN permit 10.2.2.0/24
       

      IP プレフィックス リストを設定します。

      • この例では、プレフィックス リスト TEN は、match ip address コマンドによって設定されたマッチングに応じて、10.2.2.0/24 プレフィックスのアドバタイズを許可します。
       
      ステップ 4 route-map map-name [permit | deny] [sequence-number]


      例:
      Device(config)# route-map 10NET
       

      ルート マップを作成し、ルート マップ コンフィギュレーション モードを開始します。

      • この例では、10NET という名前のルート マップが作成されます。
       
      ステップ 5 match ip address {access-list-number [access-list-number ... | access-list-name...] | access-list-name [access-list-number ... | access-list-name] | prefix-list prefix-list-name [prefix-list-name...]}


      例:
      Device(config-route-map)# match ip address prefix-list TEN
       

      標準アクセス リスト、拡張アクセス リスト、またはプレフィックス リストにより許可されているプレフィックスと一致するルート マップを作成します。

      • この例では、ルート マップは、プレフィックス リスト TEN によって許可されるプレフィックスのマッチングを行うよう設定されます。
       
      ステップ 6 exit


      例:
      Device(config-route-map)# exit
       

      ルート マップ インターフェイス コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

       
      ステップ 7 router bgp autonomous-system-number


      例:
      Device(config)# router bgp 50000 
       

      ルータ コンフィギュレーション モードを開始して、ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスを作成または設定します。

       
      ステップ 8 scope {global | vrf vrf-name}


      例:
      Device(config-router)# scope global 
       

      BGP ルーティング プロセスに対してスコープを定義して、ルータ スコープ コンフィギュレーション モードを開始します。

      • 単一のネットワークに適用される BGP の一般的なセッション コマンドまたは指定された仮想ルーティングおよび転送(VRF)が、このコンフィギュレーション モードで入力されます。
      • BGP がグローバル ルーティング テーブルを使用することを指定するには、global キーワードを使用します。
      • BGP が特定の VRF ルーティング テーブルを使用することを指定するには、vrf vrf-name キーワードおよび引数を使用します。 VRF がすでに存在している必要があります。
       
      ステップ 9 address-family ipv4 [mdt | multicast | unicast]


      例:
      Device(config-router-scope)# address-family ipv4 
       

      ルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始して、BGP 下でアドレス ファミリ セッションを設定します。

      • トポロジに固有ではない設定パラメータは、このコンフィギュレーション モードで設定されます。
       
      ステップ 10 topology {base | topology-name}


      例:
      Device(config-router-scope-af)# topology VIDEO 
       

      BGP がクラス固有のトポロジまたは基本トポロジのトラフィックをルーティングするトポロジ インスタンスを設定し、ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

       
      ステップ 11 import topology {base | topology-name} [route-map map-name]


      例:
      Device(config-router-scope-af-topo)# import topology VOICE route-map 10NET
       

      (任意)同じデバイス上のあるトポロジから別のトポロジにルートを移動するよう BGP を設定します。

      • トポロジ間で移動するルートをフィルタリングするには、route-map キーワードを使用できます。
       
      ステップ 12 end


      例:
      Device(config-router-scope-af-topo)# end 
       

      (任意)ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

       

      MTR に対する BGP サポートの設定例

      例:BGP トポロジ変換コンフィギュレーション

      次に、VIDEO トポロジにボーダー ゲートウェイ プロトコル(BGP)を設定し、192.168.2.2 ネイバーを使用してトポロジ変換を設定する例を示します。

      router bgp 45000
       scope global
        neighbor 172.16.1.1 remote-as 50000 
        neighbor 192.168.2.2 remote-as 55000
        neighbor 172.16.1.1 transport multi-session
        neighbor 192.168.2.2 transport multi-session
         address-family ipv4 
          topology VIDEO 
           bgp tid 100
           neighbor 172.16.1.1 activate 
           neighbor 192.168.2.2 activate 
           neighbor 192.168.2.2 translate-topology 200
           end
      clear ip bgp topology VIDEO 50000 

      例:BGP のグローバル スコープおよび VRF コンフィギュレーション

      次に、ユニキャスト トポロジとマルチキャスト トポロジのグローバル スコープを設定する例を示します。 ルータ スコープ コンフィギュレーション モードの終了後に、DATA という名前の仮想ルーティングおよび転送(VRF)インスタンスについてスコープが設定されます。

      router bgp 45000 
       scope global
        bgp default ipv4-unicast
        neighbor 172.16.1.2 remote-as 45000 
        neighbor 192.168.3.2 remote-as 50000 
        address-family ipv4 unicast 
         topology VOICE 
         bgp tid 100 
         neighbor 172.16.1.2 activate 
         exit 
        address-family ipv4 multicast 
         topology base 
          neighbor 192.168.3.2 activate 
          exit 
         exit 
        exit 
       scope vrf DATA 
        neighbor 192.168.1.2 remote-as 40000 
        address-family ipv4 
         neighbor 192.168.1.2 activate 
         end

      例:BGP トポロジの確認

      次に、show ip bgp topology コマンドのサマリー出力の例を示します。 VIDEO という名前のマルチトポロジ ルーティング(MTR)トポロジを使用するよう設定されたボーダー ゲートウェイ プロトコル(BGP)ネイバーに関する情報が表示されます。

      Device# show ip bgp topology VIDEO summary
      
      BGP router identifier 192.168.3.1, local AS number 45000
      BGP table version is 1, main routing table version 1
      Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
      172.16.1.2      4 45000     289     289        1    0    0 04:48:44        0
      192.168.3.2     4 50000       3       3        1    0    0 00:00:27        0
      

      次の部分的な出力には、VIDEO トポロジ下に BGP ネイバー情報が表示されます。

      Device# show ip bgp topology VIDEO neighbors 172.16.1.2 
      
      BGP neighbor is 172.16.1.2,  remote AS 45000, internal link
        BGP version 4, remote router ID 192.168.2.1
        BGP state = Established, up for 04:56:30
        Last read 00:00:23, last write 00:00:21, hold time is 180, keepalive interval is 60
      seconds
        Neighbor sessions:
          1 active, is multisession capable
        Neighbor capabilities:
          Route refresh: advertised and received(new)
        Message statistics, state Established:
          InQ depth is 0
          OutQ depth is 0
                               Sent       Rcvd
          Opens:                  1          1
          Notifications:          0          0
          Updates:                0          0
          Keepalives:           296        296
          Route Refresh:          0          0
          Total:                297        297
        Default minimum time between advertisement runs is 0 seconds
       For address family: IPv4 Unicast topology VIDEO
        Session: 172.16.1.2 session 1
        BGP table version 1, neighbor version 1/0
        Output queue size : 0
        Index 1, Offset 0, Mask 0x2
      1 update-group member
        Topology identifier: 100
      .
      .
      .
        Address tracking is enabled, the RIB does have a route to 172.16.1.2
        Address tracking requires at least a /24 route to the peer
        Connections established 1; dropped 0
        Last reset never
        Transport(tcp) path-mtu-discovery is enabled
      Connection state is ESTAB, I/O status: 1, unread input bytes: 0
      Minimum incoming TTL 0, Outgoing TTL 255
      Local host: 172.16.1.1, Local port: 11113
      Foreign host: 172.16.1.2, Foreign port: 179
      .
      .
      .

      例:BGP を使用した MTR トポロジからのルートのインポート

      次に、VOICE という名前のルート マップが VOICE という名前のマルチトポロジ ルーティング(MTR)トポロジからインポートされたルートをフィルタリングするために使用するアクセス リストを設定する例を示します。 プレフィックス 192.168.1.0 が付いたルートだけがインポートされます。

      access-list 1 permit 192.168.1.0 0.0.0.255 
      route-map BLUE
       match ip address 1
       exit
      router bgp 50000 
       scope global
        neighbor 10.1.1.2 remote-as 50000
        neighbor 172.16.1.1 remote-as 60000
         address-family ipv4 
          topology VIDEO 
           bgp tid 100
           neighbor 10.1.1.2 activate 
           neighbor 172.16.1.1 activate 
           import topology VOICE route-map VOICE 
           end
      clear ip bgp topology VIDEO 50000 

      その他の関連資料

      関連資料

      関連項目

      マニュアル タイトル

      Cisco IOS コマンド

      『Cisco IOS Master Command List, All Releases』

      マルチトポロジ ルーティング(MTR)コマンド

      『Cisco IOS Multitopology Routing Command Reference』

      ボーダー ゲートウェイ プロトコル(BGP)コマンド

      『Cisco IOS IP Routing: BGP Command Reference』

      BGP の概念と作業

      『IP Routing: BGP Configuration Guide』

      シスコのテクニカル サポート

      説明

      リンク

      シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      MTR に対する BGP サポートに関する機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

      表 1 MTR に対する BGP サポートに関する機能情報

      機能名

      リリース

      機能情報

      MTR に対する BGP サポート

      12.2(33)SRB

      15.0(1)S

      Cisco IOS XE Release 2.5

      この機能により、単一の物理ネットワーク上の複数の論理トポロジに対するボーダー ゲートウェイ プロトコル(BGP)サポートが実現します。

      Cisco IOS XE Release 2.5 では、Cisco ASR 1000 シリーズ ルータのサポートが追加されました。

      address-family ipv4bgp tidclear ip bgp topologyimport topologyneighbor translate-topologyneighbor transportscopeshow ip bgp topologytopology の各コマンドが追加または変更されました。