Cisco IOS XE Release 3S 基本コンフィギュレーション ガイド
自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定
自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定
発行日;2013/05/30   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定

自動インストールを使用すると、ネットワーキング デバイスをリモートから自動的に設定できます。 一般に、自動インストールは、新しいネットワーキング デバイスをリモートからセットアップするために使用します。 ただし、既存のネットワーキング デバイスについても、NVRAM からコンフィギュレーション ファイルを削除した後で、自動インストールを使用して設定できます。 自動インストール プロセスは、TFTP サーバにあらかじめ格納されているコンフィギュレーション ファイルを使用します。

このモジュールでは、ネットワーキング デバイスという用語は、Cisco IOS ソフトウェアが動作するルータを指します。 また、次の用語は同じ意味で使用されます。

  • 初期設定およびスタートアップ コンフィギュレーション
  • セットアップおよび設定

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、目的のプラットフォームおよびソフトウェア リリースのバグ検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定に関する情報

自動インストールの IP アドレスのダイナミックな割り当てで使用するサービスとサーバ

ネットワークは、自動インストールを使用して設定するネットワーキング デバイスに対する IP アドレスのダイナミックな割り当てが可能であることが必要です。 使用する IP アドレス割り当てサーバの種類は、自動インストールを使用して設定するネットワーキング デバイスのネットワークに対する接続の種類によって変わります。

自動インストールは次の種類の IP アドレス サーバを使用します。

DHCP サーバ

LAN 接続上で自動インストールを使用するネットワーキング デバイスには、ダイナミックに IP アドレスを提供するために DHCP サーバが必要です。 この要件は、ファスト イーサネット、トークン リング、および FDDI のインターフェイスに適用されます。 DHCP サーバと、LAN 接続上で自動インストールを使用するすべてのデバイスとの間で、IP 接続が可能なようにネットワークが設定されている必要があります。

DHCP(RFC 2131 で規定)は、ブートストラップ プロトコル(RFC 951 で規定)により提供される機能を拡張したものです。 DHCP は、設定情報を TCP/IP ネットワーク上のホストに渡すためのフレームワークを提供します。 DHCP では、再利用可能なネットワーク アドレスと、ルータ(ゲートウェイ)の IP アドレス、TFTP サーバの IP アドレス、ロードするブート ファイルの名前、使用するドメイン名など、追加の設定オプションを自動的に割り当てる機能が追加されています。 DHCP サーバは、ルータ、UNIX サーバ、Microsoft Windows ベースのサーバ、その他のプラットフォーム上で設定できます。

一般に DHCP サーバは、IP アドレスのプールからランダムに IP アドレスを割り当てます。 DHCP を使用するデバイスは、ネットワークに接続するたびに異なる IP アドレスを取得することがあります。 これは、自動インストール プロセスの間、特定のデバイスに特定のホスト名を割り当てる必要がある場合に問題になります。 たとえば、リモート サイトの異なる階にルータを設置し、各ルータに、ChicagoHQ-1stChicagoHQ-2nd など、その場所を示す名前を割り当てる場合、各デバイスの IP アドレスが、その正しいホスト名にマッピングされるようにする必要があります。

デバイスに特定の IP アドレスが割り当てられるようにするためのプロセスを、予約作成と呼びます。 予約とは、IP アドレスと、デバイス上の LAN インターフェイスの物理層アドレスの間の関係を、手動で設定することです。 多くの Cisco IOS XE ベースのデバイスは、DHCP を通じて IP アドレスを要求する際に、その MAC アドレスを使用しません。 代わりに、より長いクライアント ID を使用します。 予約を事前に設定するためには、クライアント ID を特定しなくてはならず、新しいデバイスがその MAC アドレスとクライアント ID のどちらを使用するのかを知らなくてはなりません。デバイスが MAC アドレスとクライアント ID のどちらを使用しているかを特定するために、新しいデバイスが最初に DHCP 予約を使用せずに IP アドレスを取得できるようにすることを推奨します。 新しいデバイスが DHCP サーバに対して自身を識別する方法がわかったら、その形式をメモして、そのデバイス用の予約を作成します。 次回デバイスがリブートした際に、予約した IP アドレスが取得され、新しいデバイスに正しいホスト名が割り当てられます。 DHCP の予約の作成について、使用している DHCP サーバ ソフトウェアに付属している情報を参照してください。 Cisco IOS XE ベースの DHCP サーバを使用して予約を作成する手順については、「自動インストールを使用した LAN に接続されているデバイス設定の例」のモジュールで説明しています。 この項には、DHCP 予約を事前に設定できるように、デバイスがネットワークに接続される前にクライアント ID を特定するための手順が含まれています。


(注)  


このマニュアルでは、自動インストールを使用して LAN に接続されているネットワーキング デバイスを設定するために、シスコのルータを DHCP サーバとして使用します。 別のデバイスを DHCP サーバとして使用する場合は、設定時に参照できるように、そのユーザ マニュアルを手元に置いてください。



(注)  


コンフィギュレーション パラメータには、TFTP サーバ アドレス、DNS サーバ アドレス、ドメイン名など、さまざまなものがあります。これらのパラメータは、DHCP サーバにより、IP アドレスをクライアントに割り当てるプロセスの中で、LAN に接続されたクライアントに渡すことができます。 これらのパラメータは自動インストールでは必要ないため、このマニュアルには記載されていません。 これらのパラメータの使用方法を把握している場合は、ネットワーキング デバイスをセットアップするために自動インストールを使用しているときに、DHCP サーバの設定に組み込むことができます。


DHCP サービスの詳細については、IETF RFC のサイト(http:/​/​www.ietf.org/​rfc.html)で DHCP に関する RFC を参照してください。 ほとんどのサーバ オペレーティング システムが DHCP サーバをサポートしています。 詳細については、使用しているオペレーティング システムに付属しているマニュアルを参照してください。

SLARP サーバ

HDLC カプセル化を使用してシリアル インターフェイス上で自動インストールを使用して設定するルータは、ステージング ルータに接続されているシリアル インターフェイス上の IP アドレスに対するシリアル ライン ARP(SLARP)要求を送信します。

ステージング ルータのシリアル インターフェイスには、192.168.10.1 や 192.168.10.2 など、ホスト ポートが 1 または 2 の IP アドレスが設定されている必要があります。 ステージング ルータは、自動インストールで設定するルータに、ステージング ルータが使用していない値が格納された SLARP 応答を送信します。 たとえば、自動インストールで設定するルータに接続されているステージング ルータ上のインターフェイスが、IP アドレスとして 192.168.10.1 を使用している場合、ステージング ルータは、自動インストールで設定するルータに対し、値が 192.168.10.2 の SLARP 応答を送信します。


ヒント


ステージング ルータのシリアル インターフェイス上でマスク 255.255.255.252 を使用している場合、SLARP は使用可能な IP ホスト アドレスを新しいデバイスに割り当てます。 たとえば、IP アドレス 198.162.10.5 255.255.255.252 をステージング ルータの serial 0 に割り当てる場合、SLARP は 198.162.10.6 を新しいデバイスに割り当てます。 IP アドレス 198.162.10.6 255.255.255.252 をステージング ルータの serial 0 に割り当てる場合、SLARP は 198.162.10.5 を新しいデバイスに割り当てます。


次の図に、SLARP の例を示します。

次の図で、ステージング ルータ(R2)のシリアル インターフェイス 0 の IP アドレスは 192.168.10.1 です。 そのため、SLARP は IP アドレス 192.168.10.2 を新しいルータのシリアル インターフェイス 0 に割り当てます。

図 1. SLARP を使用した新しいデバイスへの IP アドレスの割り当て


(注)  


HDLC を使用したシリアル インターフェイス上の自動インストールは、新しいデバイスの最初のシリアル ポート(シリアル インターフェイス 0 またはシリアル インターフェイス x/0)上だけで実行できます。 ステージング ルータと新しいデバイスは、serial 0/0 や serial 2/0(シリアル ポートがデバイスの第 2 スロットにある場合)など、新しいデバイス上の最初のシリアル インターフェイス ポートを使用して直接接続されている必要があります。



ヒント


ステージング ルータから SLARP によって自動インストールを使用して設定されるルータに割り当てられる IP アドレスは、自動インストールの network-confg または cisconet.cfg ファイルの ip host hostname ip-address コマンドで使用する必要があります。これは、自動インストールを使用して設定するルータが、ホスト固有のコンフィギュレーション ファイルを要求できるように、正しいホスト名が割り当てられるようにするためです。


BOOTP サーバ

シリアル インターフェイス経由でフレーム リレー カプセル化を使用して自動インストールで設定するルータは、ステージング ルータに接続されているシリアル インターフェイス上で IP アドレスの BOOTP 要求を送信します。

ステージング ルータは、自動インストールで設定するルータに対する BOOTP 応答で提供すべき正しい IP アドレスを、自動インストールで設定するルータに接続するために使用しているインターフェイス上で設定されている frame-relay map ip ip-address dlci コマンドを調べることで取得します。

下の図で、R2 はステージング ルータです。 R2 では、インターフェイス serial 0 上で frame-relay map ip 172.16.27.100 100 ブロードキャスト コマンドが設定されています。 R2 が自動インストール プロセス中に R3 から IP アドレスの BOOTP 要求を受信すると、R3 は 172.16.27.100 で応答します。

図 2. フレーム リレー ネットワークを介した自動インストールで BOOTP を使用する例


ヒント


新しいデバイスとステージング ルータの IP アドレスが .1 または .2 で終わっていなければならないという SLARP での制限は、BOOTP には適用されません。 フレーム リレー上の自動インストールのための BOOTP は、自動インストールで設定するルータとステージング ルータの間のフレーム リレー回線に割り当てられた、IP アドレス サブネットに対するすべてのホスト アドレスをサポートします。



ヒント


ステージング ルータから BOOTP により自動インストールを使用して設定するルータに割り当てられる IP アドレスは、自動インストールの network-confg ファイルまたは cisconet.cfg ファイルの ip host hostname ip-address コマンドで使用する必要があります。これは、自動インストールを使用して設定するルータが、ホスト固有のコンフィギュレーション ファイルを要求できるように、正しいホスト名が割り当てられるようにするためです。



(注)  


フレーム リレー カプセル化を使用したシリアル インターフェイス上の自動インストールは、新しいデバイスの最初のシリアル ポート(シリアル インターフェイス 0 またはシリアル インターフェイス x/0)上だけで実行できます。 ステージング ルータと新しいデバイスは、serial 0/0 や serial 2/0(シリアル ポートがデバイスの第 2 スロットにある場合)など、新しいデバイス上の最初のシリアル インターフェイス ポートを使用して直接接続されている必要があります。


自動インストールの IP とホスト名のマッピングで使用されるサービスとサーバ

自動インストール プロセス中にネットワーキング デバイスに完全なコンフィギュレーション ファイルをロードするには、そのネットワーキング デバイス用に作成したコンフィギュレーション ファイルを要求できるように、ネットワーキング デバイスがそのホスト名を決定できる必要があります。

自動インストール用に IP アドレスからホスト名へのマッピングをプロビジョニングするためには、次の点に注意してください。

  • 自動インストールで設定するネットワーキング デバイスは、そのいずれかの自動インストール ネットワーク コンフィギュレーション ファイル(network-confg または cisconet.cfg)を TFTP サーバからロードすることで、そのホスト名を決定できます。このファイルには、iphosthostnameip-address コマンドが含まれています。 たとえば、ホスト R3 を IP アドレス 198.162.100.3 にマッピングするには、network-confg ファイルまたは cisconet.cfg ファイルに iphostr3198.162.100.3 コマンドが含まれている必要があります。
  • LAN インターフェイス上で自動インストールを使用して設定するネットワーキング デバイスは、DNS サーバに問い合わせることでもそのホスト名を決定できます。 DNS サーバが同じ LAN に接続されていない場合、デバイスは、DHCP サーバからダイナミックに割り当てられた IP アドレスを取得するプロセスの中で、DNS サーバの IP アドレスを DHCP サーバから取得する必要があります。

DNS サーバ

DNS サーバは、ホスト名を IP アドレスに、IP アドレスをホスト名に(逆 DNS ルックアップ)マッピングするネットワーク サービスを提供するために使用します。 PC がホスト名を使用してホストへの IP 接続を開始するときには、必ず接続先のホスト名に割り当てられている IP アドレスを特定する必要があります。 たとえば、シスコの Web サイト(http://www.cisco.com/)を参照すると、PC は DNS サーバに DNS クエリーを送信して、シスコの Web サイトに接続するために使用可能な現在の IP アドレスを知ります。

DNS サービスの詳細については、IETF RFC のサイト(http:/​/​www.ietf.org/​rfc.html)で DNS に関する RFC を参照してください。 ネーム サーバ ルックアップ ツール(nslookup)は、DNS の詳細を知るのに非常に便利です。 検索すると、nslookup に関する優れた Web サイトがいくつも見つかります。

自動インストールのコンフィギュレーション ファイルの格納と転送で使用されるサービスとサーバ

TFTP は、ネットワーク上のデバイス間でファイルを転送するために使用するプロトコルです。 TFTP サーバは、TFTP を使用してデバイスにファイルを転送するデバイスです。 TFTP サーバは、UNIX サーバ、Microsoft Windows ベースの PC およびサーバ、その他のプラットフォーム上で設定できます。


ヒント


TFTP サーバがない場合は、Cisco IOS ベースのルータを TFTP サーバとして設定できます。そのためには、tftp-serverfile-system:filename コマンドを使用します。 ルータを TFTP サーバとして設定する方法の詳細については、『Configuring Basic File Transfer Services』を参照してください。


シスコのルータは、TFTP を使用して、自動インストールで必要なコンフィギュレーション ファイルをロードします。 ファイルの格納と、自動インストールを使用するデバイスへのファイル転送のために、ネットワークに TFTP サーバを配置する必要があります。

TFTP サービスの詳細については、IETF RFC のサイト(http:/​/​www.ietf.org/​rfc.html)で TFTP に関する RFC を参照してください。 検索すると、TFTP に関する優れた Web サイトがいくつも見つかります。 インターネットでは、さまざまなオペレーティング システムおよびハードウェア プラットフォーム向けのフリーウェアとシェアウェア版の TFTP サーバがいくつも利用できます。

自動インストール向けに TFTP サーバをプロビジョニングする際には、次の点に注意してください。

  • LAN 経由で自動インストールを使用するデバイス:TFTP サーバと自動インストールを使用するデバイスが異なる LAN セグメント上にある場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信するすべてのインターフェイス上で、iphelper-addressaddress コマンドを設定する必要があります。
  • WAN 経由で自動インストールを使用するデバイス:自動インストールを使用するデバイスが WAN に接続されている場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信するすべてのインターフェイス上で、iphelper-addressaddress コマンドを設定する必要があります。

ip helper-address

新しいデバイスが、TFTP サーバの IP アドレスを、DHCP オプション 150 経由で取得しない場合、TFTP セッション初期化要求を、IP 宛先ブロードキャスト アドレス 255.255.255.255 を使用したネットワーク層ブロードキャストとして送信します。 ルータはネットワーク層ブロードキャスト データグラムをブロックするため、TFTP セッション開始要求が TFTP サーバに到達せず、自動インストールは失敗します。 この問題を解決するには、iphelper-addressaddress コマンドを使用します。 iphelper-addressaddress コマンドは、TFTP セッション開始要求のブロードキャスト アドレスを、255.255.255.255 から、address 引数で設定されるアドレスに変更します。 たとえば、iphelper-address172.16.29.252 コマンドは、IP 宛先ブロードキャスト アドレス 255.255.255.255 を 172.16.29.252 に変更します。

自動インストールで使用されるネットワーキング デバイス

自動インストールで設定するデバイス

自動インストールで設定するデバイスは、自動インストールをサポートし、NVRAM にコンフィギュレーション ファイルがない、任意の Cisco IOS XE ベースのルータです。

ステージング ルータ

ステージング ルータは、新しいデバイスと TFTP サーバが異なるネットワークに接続されている場合に、TFTP サーバ(IP 接続可能であることが必要です)と、自動インストールで設定されるデバイスの間の仲介役として振る舞います。 次の図で、R1 にはステージング ルータが必要です。これは、R1 が TFTP サーバと異なる LAN セグメントに接続されているためです。

ステージング ルータは、次の状況で必要です。

  • LAN 経由で自動インストールを使用するデバイス:TFTP サーバと DHCP サーバのいずれかまたは両方と、自動インストールを使用するデバイスが異なる LAN セグメントにある場合は、ステージング ルータを使用する必要があります。
  • WAN 経由で自動インストールを使用するデバイス:自動インストールを使用するデバイスが WAN に接続されている場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信する、直接接続されたすべてのインターフェイス上で、ip helper-address address コマンドを設定する必要があります。
図 3. ステージング ルータが必要な自動インストールの例

自動インストールで設定する新しいデバイスが、TFTP サーバおよび DHCP サーバと同じ LAN セグメントに接続されている場合には、ステージング ルータは不要です。 次の図で、R2 は、TFTP サーバと同じ LAN セグメント上にあるため、自動インストールを使用するためにステージング サーバは必要ありません。

図 4. ステージング ルータが不要な自動インストールの例

フレーム リレー/ATM 間スイッチング デバイス

フレーム リレー/ATM 間スイッチング デバイスは、ルーティングとスイッチング動作の両方を実行できるデバイスです。 フレーム リレー/ATM 間スイッチング デバイスは、フレーム リレー ネットワークと ATM ネットワークを接続するために使用します。

フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能は、自動インストール プロセスを、シスコが定義したフレーム リレー カプセル化ではなく、IETF 標準で定義されたフレーム リレー カプセル化を使用するように、自動インストール プロセスを変えたものです。

次の図は、フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能を使用するトポロジ例を示します。 ルータ R6 は、フレーム リレー DLCI 50 から ATM VPI/VCI 5/50 への、フレーム リレー/ATM 間サービス インターワーキング(FRF8)変換を行います。 LS1010 スイッチは、R6(5/50)が使用する VPI と VCI の組み合わせを、R4(6/60)が使用する VPI と VCI の組み合わせにルーティングします。

図 5. フレーム リレー/ATM 間インターワーキング接続上の自動インストールのトポロジ例

自動インストールの設定オプション

デバイスとサービスのいくつかの異なる組み合わせを使用して、自動インストールをサポートするようにネットワークをプロビジョニングできます。 次に例を示します。

  • 自動インストールで必要なすべてのサービス(シスコのルータで実行する必要がある、SLARP または BOOTP を使用したダイナミックな IP アドレスの割り当てを除く)を、1 台のネットワーク サーバ上にプロビジョニングすることも、各サービスを異なるネットワーク サーバにプロビジョニングすることもできます。
  • DHCP サービスは、シスコのルータ上にプロビジョニングできます。
  • 自動インストールを使用するデバイスの IP アドレスを DNS サーバから特定するか、ip host hostname ip-address コマンドを含むいずれかの自動インストールネットワーク コンフィギュレーション ファイル(network-confg または cisconet.cfg)を使用できます。
  • 自動インストールを使用するデバイスに、完全なコンフィギュレーションをロードするか部分的なコンフィギュレーションをロードするように自動インストールをプロビジョニングできます。

このモジュールでは、主に自動インストールをプロビジョニングするための最も一般的な方法のいくつかを扱います。 自動インストールをプロビジョニングする最も一般的な方法については、「自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法」のモジュールを参照してください。

自動インストール プロセス

自動インストール プロセスは、NVRAM にファイルが何もないネットワーキング デバイスをネットワークに接続したときに開始されます。


ワンポイント アドバイス


自動インストール プロセスが終了するまでは、ネットワーキング デバイス上の自動インストールで使用するインターフェイスだけを接続することで、自動インストールが完了するまでに要する時間を短縮できます。 たとえば、WAN インターフェイス経由でネットワーキング デバイスに対する自動インストールを実行する場合、その LAN インターフェイスと WAN インターフェイスを接続すると、ネットワーキング デバイスは、WAN インターフェイスの使用を試みる前に、LAN インターフェイス上で自動インストールの実行を試みます。 自動インストール プロセスが完了するまで LAN インターフェイスを接続しないでおくことで、ネットワーキング デバイスはすぐに WAN インターフェイス上で自動インストール プロセスを開始します。


次の図は、自動インストール プロセスの基本フローを示します。

図 6. 自動インストール プロセスのフローチャート

自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法

ここでは、自動インストールのためにルータを準備する方法について説明します。 LAN、HDLC WAN、およびフレーム リレーのネットワークに接続された新しいルータのために自動インストールを使用する追加の例は、「自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例」のモジュールを参照してください。

ほとんどの場合、自動インストールを実行する新規デバイスが TFTP、BOOTP、および DNS 要求を送信するときに経由するステージング ルータを設定する必要があります。


ヒント


いずれの場合にも、自動インストール プロセスが完了した後、ネットワーキング デバイス上でコンフィギュレーションを確認し保存する必要があります。 コンフィギュレーションを保存しない場合、プロセス全体を繰り返す必要があります。


SDM デフォルト コンフィギュレーション ファイルのディセーブル化

使用しているデバイスに SDM がプレインストールされているときに、セットアップを使用して、初期設定ファイルを作成する場合は、次の作業を実行します。 SDM はデバイスに残ります。

使用しているデバイスに SDM がプレインストールされているときに、代わりに自動インストールを使用して、デバイスを設定する場合は、次の作業を実行します。 SDM はデバイスに残ります。

手順の概要

    1.    デバイスに付属しているコンソール ケーブルを、デバイスのコンソール ポートから PC のシリアル ケーブルに接続します。 手順については、使用しているデバイスのハードウェア インストール ガイドを参照してください。

    2.    電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。 手順については、使用しているデバイスのクイック スタート ガイドを参照してください。

    3.    使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

    4.    enable

    5.    erase startup-config

    6.    reload


手順の詳細
    ステップ 1   デバイスに付属しているコンソール ケーブルを、デバイスのコンソール ポートから PC のシリアル ケーブルに接続します。 手順については、使用しているデバイスのハードウェア インストール ガイドを参照してください。
    ステップ 2   電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。 手順については、使用しているデバイスのクイック スタート ガイドを参照してください。
    ステップ 3   使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。
    • 9600 ボー
    • 8 データ ビット、パリティなし、1 ストップ ビット
    • フロー制御なし
    ステップ 4   enable

    特権 EXEC モードを開始します。

    enable



    例:
    Router> enable
    Router#
    
    ステップ 5   erase startup-config

    NVRAM から既存のコンフィギュレーションを消去します。



    例:
    Router# erase startup-config
    
    ステップ 6   reload

    リロード プロセスを開始します。 ルータはリロード プロセスの終了後、自動インストール プロセスを開始します。



    例:
    Router# reload
    

    自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例

    自動インストールを使用した LAN に接続されているデバイス設定の例

    このタスクでは、次に示す図のネットワークを使用します。 このタスクでは、自動インストールを使用してルータ R2、R3、および R4 を設定する方法を示します。 ルータ R1 は、自動インストール プロセス中に新しいルータのファスト イーサネット 0/0 に IP アドレスを割り当てるために使用される DHCP サーバです。

    図 7. 特定のデバイスに対する自動インストール コンフィギュレーション ファイルを割り当てるためのネットワーク トポロジ

    すべての DHCP クライアントには、固有の DHCP クライアント ID があります。 DHCP クライアント ID は、DHCP サーバによって、IP アドレスのリースを追跡し、IP アドレスの予約を設定するために使用されます。 DHCP IP アドレス予約を設定するためには、自動インストールを使用して設定する各ネットワーキング デバイスの DHCP クライアント ID を知る必要があります。これにより、各デバイスに正しい IP アドレスが提供され、その後固有のコンフィギュレーション ファイルが提供されます。 DHCP クライアント ID は手動または自動で特定できます。

    自動インストールを使用してルータ R2、R3、および R4 を設定するには、次の作業を実行します。

    手動での DHCP クライアント ID の特定

    クライアント ID の値を自動的に特定する場合は、この作業を実行する必要はありません。 「自動的な DHCP クライアント ID の特定」のモジュールに進みます。

    クライアント ID を手動で特定するためには、自動インストール プロセス中にルータを LAN に接続するために使用されるファスト イーサネット インターフェイスの MAC アドレスを知っておく必要があります。 これには、show interface interface-type interface-number コマンドを入力できるように、端末をルータに接続し、電源をオンにする必要があります。

    クライアント ID は次のように表示されます。

    0063.6973.636f.2d30.3030.362e.3533.6237.2e38.6537.312d.4661.332f.30

    形式は nullcisco-0006.53b7.8e71-fa3/0 です。0006.53b7.8e71 は MAC アドレスであり、fa3/0 は IP アドレスを要求するインターフェイスの短いインターフェイス名です。

    short-if-name フィールドの値は、Cisco MIB がインストールされた SNMP ワークステーションから取得できます。 次に、ifIndex を Cisco IOS 上のインターフェイスにマッピングする例を示します。

    snmpwalk -c public ponch ifName
    IF-MIB::ifName.1 = STRING: AT2/0
    IF-MIB::ifName.2 = STRING: Et0/0
    IF-MIB::ifName.3 = STRING: Se0/0
    IF-MIB::ifName.4 = STRING: BR0/0
    

    show interface interface-type interface-number コマンドを使用して、ファスト イーサネット インターフェイスの情報と統計情報を表示します。

    R6> show interface fastethernet 3/0
    FastEthernet3/0 is up, line protocol is up
      Hardware is AmdFE, address is 0006.53b7.8e71 (bia 0006.53b7.8e71)
    .
    .
    .
    R6>
    

    R6 上のファスト イーサネット 3/0 の MAC アドレスは 0006.53b7.8e71 です。 このインターフェイスのクライアント ID の形式は nullcisco-0006.53b7.8e71-fa3/0 です。


    (注)  


    ファスト イーサネット インターフェイスの短いインターフェイス名は fa です。


    次の表に、文字を 16 進数の文字に変換するための値を示します。 2 つ目の表の最後の行は、R6 上のファスト イーサネット 3/0 のクライアント ID(nullcisco-0006.53b7.8e71-fa3/0)を示します。

    表 1 16 進数から文字への変換表

    16 進数

    文字

    16 進数

    文字

    16 進数

    文字

    16 進数

    文字

    16 進数

    文字

    00

    NUL

    1a

    SUB

    34

    4

    4e

    N

    68

    h

    01

    SOH

    1b

    ESC

    35

    5

    4f

    O

    69

    I

    02

    STX

    1c

    FS

    36

    6

    50

    P

    6a

    j

    03

    ETX

    1d

    GS

    37

    7

    51

    Q

    6b

    k

    04

    EOT

    1e

    RS

    38

    8

    52

    R

    6c

    l

    05

    ENQ

    1f

    US

    39

    9

    53

    S

    6d

    m

    06

    ACK

    20

    3a

    :

    54

    T

    6e

    n

    07

    BEL

    21

    !

    3b

    ;

    55

    U

    6f

    o

    08

    BS

    22

    "

    3c

    <

    56

    V

    70

    p

    09

    TAB

    23

    #

    3d

    =

    57

    W

    71

    q

    0A

    LF

    24

    $

    3e

    >

    58

    X

    72

    r

    0B

    VT

    25

    %

    3f

    ?

    59

    Y

    73

    s

    0C

    FF

    26

    &

    40

    @

    5a

    Z

    74

    t

    0D

    CR

    27

    41

    A

    5b

    [

    75

    u

    0E

    SO

    28

    (

    42

    B

    5c

    \

    76

    v

    0F

    SI

    29

    )

    43

    C

    5d

    ]

    77

    w

    10

    DLE

    2a

    *

    44

    D

    5e

    ^

    78

    x

    11

    DC1

    2b

    +

    45

    E

    5f

    _

    79

    y

    12

    DC2

    2c

    ,

    46

    F

    60

    `

    7a

    z

    13

    DC3

    2d

    -

    47

    G

    61

    a

    7b

    {

    14

    DC4

    2e

    .

    48

    H

    62

    b

    7c

    |

    15

    NAK

    2f

    /

    49

    I

    63

    c

    7D

    }

    16

    SYN

    30

    0

    4a

    J

    64

    d

    7e

    ~

    17

    ETB

    31

    1

    4b

    K

    65

    e

    7f

    D

    18

    CAN

    32

    2

    4c

    L

    66

    f

    19

    EM

    33

    3

    4d

    M

    67

    g

    表 2 nullcisco-0006.53b7.8e71-fa3/0 からクライアント ID への変換

    00

    c

    i

    s

    c

    o

    -

    0

    0

    0

    6

    .

    5

    3

    b

    7

    .

    8

    e

    7

    1

    -

    f

    a

    3

    /

    0

    00

    63

    69

    73

    63

    6f

    2d

    30

    30

    30

    36

    2e

    35

    33

    62

    37

    2e

    38

    65

    37

    31

    2d

    46

    61

    33

    2f

    30

    R4

    show interface interface-type interface-number コマンドを使用して、R4 上のファスト イーサネット 0/0 の情報と統計情報を表示します。

    R4> show interface FastEthernet 0/0
    FastEthernet0 is up, line protocol is up
      Hardware is Lance, address is 00e0.1eb8.eb0e (bia 00e0.1eb8.eb0e)
    

    R4 のファスト イーサネット 0/0 の MAC アドレスは 00e0.1eb8.eb0e です。 このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb0e-et0 です。


    (注)  


    ファスト イーサネット インターフェイスの短いインターフェイス名は et です。


    上記の 1 つ目の表の 16 進数の文字に変換するための値を使用して、R4 上のファスト イーサネット 0/0 のクライアント ID を次の表の最後の行に示します。

    表 3 null.cisco-00e0.1eb8.eb0e-et0 から R4 のクライアント ID への変換

    00

    c

    i

    s

    c

    o

    -

    0

    0

    e

    0

    .

    1

    e

    b

    8

    .

    e

    b

    0

    e

    -

    e

    t

    0

    00

    63

    69

    73

    63

    6f

    2d

    30

    30

    65

    30

    2e

    31

    65

    62

    38

    2e

    65

    62

    30

    65

    2d

    45

    74

    30

    R3

    show interface interface-type interface-number コマンドを使用して、R3 上のファスト イーサネット 0/0 の情報と統計情報を表示します。

    R3> show interface FastEthernet 0/0
    FastEthernet0 is up, line protocol is up
      Hardware is Lance, address is 00e0.1eb8.eb73 (bia 00e0.1eb8.eb73)
    

    R3 のファスト イーサネット 0/0 の MAC アドレスは 00e0.1eb8.eb73 です。 このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb73-et0 です。

    上記の 1 つ目の表の 16 進数の文字に変換するための値を使用して、R3 上のファスト イーサネット 0/0 のクライアント ID を次の表の最後の行に示します。

    表 4 null.cisco-00e0.1eb8.eb73-et0 から R3 のクライアント ID への変換

    00

    c

    i

    s

    c

    o

    -

    0

    0

    e

    0

    .

    1

    e

    b

    8

    .

    e

    b

    7

    3

    -

    e

    t

    0

    00

    63

    69

    73

    63

    6f

    2d

    30

    30

    65

    30

    2e

    31

    65

    62

    38

    2e

    65

    62

    37

    33

    2d

    45

    74

    30

    R2

    show interface interface-type interface-number コマンドを使用して、R2 上のファスト イーサネット 0/0 の情報と統計情報を表示します。

    R2> show interface Fast Ethernet 0/0
    FastEthernet0/0 is up, line protocol is up
      Hardware is Lance, address is 00e0.1eb8.eb09 (bia 00e0.1eb8.eb09)
    

    R2 のファスト イーサネット 0/0 の MAC アドレスは 00e0.1eb8.eb09 です。 このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb09-et0 です。

    上記の 1 つ目の表の 16 進数の文字に変換するための値を使用して、R2 上のファスト イーサネット 0/0 のクライアント ID を次の表の最後の行に示します。

    表 5 null.cisco-00e0.1eb8.eb09-et0 から R2 のクライアント ID への変換

    00

    c

    i

    s

    c

    o

    -

    0

    0

    e

    0

    .

    1

    e

    b

    8

    .

    e

    b

    0

    9

    -

    e

    t

    0

    00

    63

    69

    73

    63

    6f

    2d

    30

    30

    65

    30

    2e

    31

    65

    62

    38

    2e

    65

    62

    30

    39

    2d

    45

    74

    30

    これで各ルータのクライアント ID の値が特定できました。 最後の手順は、次に示すように、左から右に 4 文字ずつのグループにし、その後にピリオドを追加することです。

    • R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30
    • R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30
    • R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

    自動的な DHCP クライアント ID の特定

    クライアント ID の値を手動で特定する場合は、この作業を実行する必要はありません。 「各ルータ用のプライベート DHCP プールの作成」のモジュールに進みます。

    この作業では、R1 上に、1 つの IP アドレスだけを提供する DHCP サーバを構築します。 この IP アドレスは、ルータのクライアント ID の値を特定する間、新しい各ルータによって順番に使用されます。 IP アドレスの範囲を単一の IP アドレスに制限することで、どのルータを操作しているかに関する混乱を避けることができます。 誰かが別のルータの電源をオンにし、自動インストール プロセスが開始されると、そのルータは IP アドレスを取得できません。


    ヒント


    network-confg またはルータ コンフィギュレーション ファイル(r4-confg、r3-confg、または r2-confg)は、まだ TFTP サーバのルート ディレクトリに格納しないでください。 ルータが正しいコンフィギュレーション ファイルをロードするように、各ルータが DHCP サーバから正しい IP アドレスを取得することを確認するまでは、これらのファイルをルータがロードしないようにします。


    このタスクは、分かりやすくするためにサブタスクに分かれています(すべてのサブタスクが必要)。

    R1 上のインターフェイスの IP の設定

    ファスト イーサネット インターフェイスで IP アドレスを設定します。 ファスト イーサネット 0/1 上で ip helper-address ip-address コマンドを設定します。

    !
    interface FastEthernet0/0
     ip address 172.16.29.99 255.255.255.0
    !
    interface FastEthernet0/1
     ip address 172.16.28.99 255.255.255.0
     ip helper-address 172.16.29.252
    !
    R1 上の DHCP プールの設定

    R1 上で一時的な DHCP サーバをセットアップするには、次のコマンドを設定します。


    (注)  


    これは、R1 で稼働する唯一の DHCP サーバである必要があります。 これは、自動インストールを使用して設定するルータがアクセスできる唯一の DHCP サーバであることが必要です。


    !
    ip dhcp pool get-client-id
       network 172.16.28.0 255.255.255.0
    !
    R1 上の DHCP プールからの 1 つを除くすべての IP アドレスの除外

    DHCP サーバからは常に 1 つの IP アドレスだけが利用できるようにする必要があります。 DHCP プールから、172.16.28.1 以外のすべての IP アドレスを除外するには、次のコマンドを設定します。

    !
    ip dhcp excluded-address 172.16.28.2 172.16.28.255
    !
    R1 の設定の確認

    R1 用のコンフィギュレーション ファイルに、1 つの IP アドレス(172.16.28.1)を DHCP クライアントに提供する、DHCP サーバ プールが設定されていることを確認します。

    コンフィギュレーション ファイルに、ファスト イーサネット インターフェイスの IP アドレスと ip helper-address ip-address コマンドが含まれていることを確認します。

    !
    ip dhcp excluded-address 172.16.28.2 172.16.28.255
    !
    ip dhcp pool get-client-id
       network 172.16.28.0 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 172.16.29.99 255.255.255.0
    !
    interface FastEthernet0/1
     ip address 172.16.28.99 255.255.255.0
     ip helper-address 172.16.29.252
    !
    R1 上での debug ip dhcp server events のイネーブル化

    R1 に接続された端末上で debug ip dhcp server events コマンドからの出力を使用し、各ルータのクライアント ID を特定します。

    R1 上で debug ip dhcp server events コマンドをイネーブルにします。

    R1# debug ip dhcp server events
    
    各ルータでのクライアント ID の値の特定

    この手順は、各ルータで繰り返します。 一度に 1 台のルータの電源だけをオンにする必要があります。 ルータのクライアント ID フィールドの値を特定したら、そのルータの電源をオフにし、次のルータに進みます。

    R4

    R4 をファスト イーサネット ネットワークに接続し、電源をオンにします。 R4 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

    DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30.
    

    クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30 をテキスト ファイルにコピーして保存します。 テキスト ファイルは、次の 2 台のルータ用に開いたままにします。

    R4 の電源をオフにします。

    R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP プールから R4 の IP アドレス バインディングを解放します。

    R1# clear ip dhcp binding *
    R1#
    01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.
    
    R3

    R3 をファスト イーサネット ネットワークに接続し、電源をオンにします。 R3 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

    DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30.
    

    クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30 をテキスト ファイルにコピーして保存します。 テキスト ファイルは、最後のルータ用に開いたままにします。

    R3 の電源をオフにします。

    R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP プールから R3 の IP アドレス バインディングを解放します。

    R1# clear ip dhcp binding *
    R1#
    01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.
    R2

    R2 をファスト イーサネット ネットワークに接続し、電源をオンにします。 R2 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

    DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30.
    

    クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30 をテキスト ファイルにコピーして保存します。

    R2 の電源をオフにします。

    R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP プールから R2 の IP アドレス バインディングを解放します。

    R1# clear ip dhcp binding *
    R1#
    01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.
    
    R4、R3、および R2 のクライアント ID

    これで各ルータのクライアント ID の値が特定できました。

    • R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30
    • R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30
    • R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30
    ネットワーク 172.16.28.0 24 用の R1 上の DHCP プールの削除

    ルータの一時的な DHCP プールは必要なくなり、削除する必要があります。

    R1(config)# no ip dhcp pool get-client-id
    
    R1 からの除外されたアドレス範囲の削除

    172.16.28.1 以外のすべての IP アドレスをルータ上の DHCP プールから除外するコマンドは必要なくなり、削除する必要があります。

    R1(config)# no ip dhcp excluded-address 172.16.28.2 172.16.28.255

    各ルータ用のプライベート DHCP プールの作成

    すべてのルータにネットワーク コンフィギュレーション ファイルでホスト名にマッピングされた IP アドレスが割り当てられるようにするために、各ルータ用のプライベート DHCP アドレス プールを作成する必要があります。

    !
    ip dhcp pool r4
       host 172.16.28.100 255.255.255.0
       client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30
    !
    ip dhcp pool r3
       host 172.16.28.101 255.255.255.0
       client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30
    !
    ip dhcp pool r2
       host 172.16.28.102 255.255.255.0
       client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

    各ルータ用のコンフィギュレーション ファイルの作成

    各ルータ用のコンフィギュレーション ファイルを作成し、TFTP サーバのルート ディレクトリに置きます。


    ヒント


    ルータにリモートからアクセスしてそのコンフィギュレーション ファイルを NVRAM に保存する場合は、リモート Telnet アクセスと特権 EXEC モードへのアクセス用のパスワードを設定するためのコマンドを含める必要があります。


    r2-confg
    !
    hostname R2
    !
    enable secret 7gD2A0
    !
    interface FastEthernet0/0
     ip address 172.16.28.102 255.255.255.0
    !
    interface Serial0/0
     ip address 192.168.100.1 255.255.255.252
     no shutdown
    !
    interface Serial0/1
     ip address 192.168.100.5 255.255.255.252
     no shutdown
    !
    no ip http server
    ip classless
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    line vty 0 4
     password 5Rf1k9
     login
    !
    end
    
    r3-confg
    !
    hostname R3
    !
    enable secret 7gD2A0
    !
    interface FastEthernet0/0
     ip address 172.16.28.101 255.255.255.0
    !
    interface Serial0/0
     ip address 192.168.100.9 255.255.255.252
     no shutdown
    !
    interface Serial0/1
     ip address 192.168.100.13 255.255.255.252
     no shutdown
    !
    no ip http server
    ip classless
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 FastEthernet0
    !
    line vty 0 4
     password 5Rf1k9
     login
    !
    end
    
    r4-confg
    !
    hostname R3
    !
    enable secret 7gD2A0
    !
    interface FastEthernet0/0
     ip address 172.16.28.101 255.255.255.0
    !
    interface Serial0/0
     ip address 192.168.100.9 255.255.255.252
     no shutdown
    !
    interface Serial0/1
     ip address 192.168.100.13 255.255.255.252
     no shutdown
    !
    no ip http server
    ip classless
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    line vty 0 4
     password 5Rf1k9
     login
    !
    end
    

    ネットワーク コンフィギュレーション ファイルの作成

    DHCP サーバに割り当てる IP アドレスをホスト名にマップする ip host hostname ip-address コマンドでネットワーク コンフィギュレーション ファイルを作成します。

    ip host r4 172.16.28.100
    ip host r3 172.16.28.101
    ip host r2 172.16.28.102

    自動インストールによるルータのセットアップ

    自動インストールを使用して、3 台のルータ(R4、R3、および R2)をセットアップする準備ができました。

    自動インストールの進行状況を監視するには、ルータに端末を接続します。 使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

    • 9600 ボー
    • 8 データ ビット、パリティなし、1 ストップ ビット
    • フロー制御なし

    TFTP サーバのルート ディレクトリに次のファイルを格納しておきます。

    • network-confg
    • r4-confg
    • r3-confg
    • r2-confg

    TFTP サーバが動作している必要があります。

    各ルータの電源をオンにします。


    ワンポイント アドバイス


    3 台のルータを同時に設定できます。


    R4

    次に示すのは、自動インストール プロセス中に R4 のコンソール端末に表示されるメッセージの一部です。

    Loading network-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 76 bytes]
    Configuration mapped ip address 172.16.28.100 to r4
    Loading r4-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 687 bytes]
    
    R3

    次に示すのは、自動インストール プロセス中に R3 のコンソール端末に表示されるメッセージの一部です。

    Loading network-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 76 bytes]
    Configuration mapped ip address 172.16.28.101 to r3
    Loading r3-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 687 bytes]
    
    R2

    次に示すのは、自動インストール プロセス中に R2 のコンソール端末に表示されるメッセージの一部です。

    Loading network-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 76 bytes]
    Configuration mapped ip address 172.16.28.102 to r2
    Loading r2-confg from 172.16.29.252 (via FastEthernet0/0): !
    [OK - 687 bytes]
    
    TFTP サーバ ログ

    TFTP サーバ ログには、次のようなメッセージが出力されます。

    Sent network-confg to (172.16.28.100), 76 bytes
    Sent r4-confg to (172.16.28.100),687 bytes
    Sent network-confg to (172.16.28.101), 76 bytes
    Sent r3-confg to (172.16.28.101),687 bytes
    Sent network-confg to (172.16.28.102), 76 bytes
    Sent r2-confg to (172.16.28.102),687 bytes

    ルータ上でのコンフィギュレーション ファイルの保存

    各ルータに電源が再投入された場合にもそれぞれの設定を保持できるようにするために、各ルータで実行中の設定を保存してから設定を開始する必要があります。

    R4
    R1# telnet 172.16.28.100
    Trying 172.16.28.100 ... Open
    User Access Verification
    Password:
    R4> enable
    Password:
    R4# copy running-config startup-config
    Destination filename [startup-config]?
    Building configuration...
    [OK]
    R4# exit
    [Connection to 172.16.28.100 closed by foreign host]
    R1#
    R3
    R1# telnet 172.16.28.101
    Trying 172.16.28.101 ... Open
    User Access Verification
    Password:
    R3> enable
    Password:
    R3# copy running-config startup-config
    Destination filename [startup-config]?
    Building configuration...
    [OK]
    R3# exit
    [Connection to 172.16.28.101 closed by foreign host]
    R1#
    
    R2
    R1# telnet 172.16.28.102
    Trying 172.16.28.102 ... Open
    User Access Verification
    Password:
    R2> enable
    Password:
    R2# copy running-config startup-config
    Destination filename [startup-config]?
    Building configuration...
    [OK]
    R2# exit
    [Connection to 172.16.28.102 closed by foreign host]
    R1#

    R1 からのプライベート DHCP アドレス プールの削除

    自動インストール プロセスの最後のステップは、R1 からプライベート DHCP アドレス プールを削除することです。

    R1(config)# no ip dhcp pool r4
    R1(config)# no ip dhcp pool r3
    R1(config)# no ip dhcp pool r2
    

    この作業は、自動インストールを使用して LAN に接続されたデバイスを設定するための最後の手順です。

    その他の関連資料

    このセクションでは、シスコ ネットワーキング デバイスの基本設定に関する参考資料について説明します。

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS XE ソフトウェアの自動インストール機能を使用した初めてのネットワーキング デバイスの設定

    『Using AutoInstall to Remotely Configure Cisco Networking Devices』

    Cisco IOS XE セットアップ モードを使用したネットワーキング デバイスの設定

    『Using Setup Mode to Configure a Cisco Networking Device』

    設定の基本的なコマンドと関連コマンド

    目的のリリースの『Cisco IOS XE Configuration Fundamentals Configuration Guide』と、リリースに依存しない『Cisco IOS Configuration Fundamentals Command Reference

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

    お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

    シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​en/​US/​support/​index.html

    自動インストールを使用したシスコのネットワーキング デバイスの設定に関する機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 6 自動インストールを使用したシスコ ネットワーキング デバイスのリモート設定の機能情報

    機能名

    リリース

    機能の設定情報

    LAN インターフェイスに DHCP を使用した自動インストール

    Cisco IOS XE Release 2.1

    LAN インターフェイスに DHCP を使用した自動インストール機能では、LAN インターフェイス(特にファスト イーサネット、トークンリング、FDDI のインターフェイス)上での Cisco IOS 自動インストール用に、ブートストラップ プロトコル(BOOTP)の使用を Dynamic Host Configuration Protocol(DHCP)の使用で置き換えることで、自動インストールの利点が強化されます。

    この機能は、Cisco IOS XE Release 2.1 で、Cisco ASR 1000 シリーズ ルータに導入されました。