Cisco IOS XE Release 3S 基本コンフィギュレーション ガイド
Cisco IOS コマンドライン インターフェイスの使用
Cisco IOS コマンドライン インターフェイスの使用
発行日;2013/05/30   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Cisco IOS コマンドライン インターフェイスの使用

Cisco IOS コマンドライン インターフェイス(CLI)は、シスコ デバイスの設定、監視、およびメンテナンスに使用される主要なユーザ インターフェイスです。 このユーザ インターフェイスは、ルータ コンソールや端末、またはリモート アクセス方式を使用して、Cisco IOS コマンドを直接シンプルに実行することを可能にします。

この章では、Cisco IOS CLI の基本的な機能とその使用方法について説明します。 この章で扱うトピックは、Cisco IOS コマンド モードの概要、ナビゲーションおよび編集機能、ヘルプ機能、コマンド履歴機能です。

追加ユーザ インターフェイスには、セットアップ モード(初回の起動に使用)、Cisco Web ブラウザ、およびシステム管理者が設定したユーザ メニューが含まれます。 セットアップ モードの詳細については、「セットアップ モードを使用したシスコ ネットワーキング デバイスの設定」および「自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定」を参照してください。 シスコ Web ブラウザを使用したコマンドの実行については、「Cisco Web ブラウザ ユーザ インターフェイスの使用」を参照してください。 ユーザ メニューの詳細については、「接続、メニュー、およびシステム バナーの管理」を参照してください。

この章のユーザ インターフェイス コマンドの完全な説明については、『Cisco IOS Configuration Fundamentals Command Reference』を参照してください。 この章で説明される他のコマンドの資料を検索するには、『Cisco IOS Master Command List, All Releases』を使用します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、目的のプラットフォームおよびソフトウェア リリースのバグ検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

Cisco IOS XE CLI コマンド モードの概要

シスコ デバイスの設定を支援するために、Cisco IOS XE コマンドライン インターフェイスは、さまざまなコマンド モードに分かれています。 各コマンド モードには、ルータとネットワークの動作を設定、メンテナンス、モニタリングするための独自のコマンド セットがあります。 ある時点で使用できるコマンドは、そのときのモードに依存します。 システム プロンプトに疑問符(?)を入力すると、各コマンド モードで使用できるコマンドの一覧が表示されます。

特定のコマンドを使用すると、コマンド モードを変更できます。 ユーザがモードにアクセスする標準の順序は、ユーザ EXEC モード、特権 EXEC モード、グローバル コンフィギュレーション モード、特定のコンフィギュレーション モード、コンフィギュレーション サブモード、およびコンフィギュレーション サブモードです。

ルータでセッションを開始するときは、通常、EXEC モードの 2 つあるアクセス レベルの 1 つであるユーザ EXEC モードから始めます。 セキュリティのために、ユーザ EXEC モードで使用できる EXEC コマンドは制限されています。 このアクセス レベルは、ルータのステータスを確認するなど、ルータの設定を変更しない作業のために予約されています。

すべてのコマンドにアクセスするには、EXEC モードの第 2 レベルである特権 EXEC モードを開始する必要があります。 特権 EXEC モードを開始するには、通常、パスワードが必要です。 特権 EXEC モードでは、任意の EXEC コマンドを入力できます。これは、特権 EXEC モードが、ユーザ EXEC モード コマンドのスーパーセットであるためです。

ほとんどの EXEC モード コマンドは、現在の設定ステータスを表示する show コマンドまたは more コマンドや、カウンタやインターフェイスをクリアする clear コマンドのように、1 回限りのコマンドです。 EXEC モードのコマンドは、ルータをリブートすると保持されません。

特権 EXEC モードから、グローバル コンフィギュレーション モードを開始できます。 このモードでは、一般的なシステム特性を設定するためのコマンドを実行できます。 また、グローバル コンフィギュレーション モードを使用して特定のコンフィギュレーション モードを開始することもできます。 グローバル コンフィギュレーション モードを含むコンフィギュレーション モードでは、実行コンフィギュレーションを変更できます。 後で設定を保存すると、ルータをリブートしてもこれらのコマンドが保持されます。

グローバル コンフィギュレーション モードから、さまざまなプロトコル固有または機能固有のコンフィギュレーション モードを開始できます。 CLI 階層では、グローバル コンフィギュレーション モードからしかこれらのコンフィギュレーション モードを開始できません。 例として、この章では一般的に使用されるインターフェイス コンフィギュレーション モードについて説明します。

コンフィギュレーション モードから、コンフィギュレーション サブモードを開始できます。 コンフィギュレーション サブモードは、特定のコンフィギュレーション モードの範囲内で特定の機能を設定するために使用します。 たとえば、この章では、インターフェイス コンフィギュレーション モードのサブモードであるサブインターフェイス コンフィギュレーション モードについて説明します。

ROM モニタ モードは、ルータが適切にブートできない場合に使用される別のモードです。 システム(ルータ、スイッチ、またはアクセス サーバ)のブート時に適切なシステム イメージが見つからない場合、システムは ROM モニタ モードを開始します。 ROM モニタ(ROMMON)モードには、起動時にブート シーケンスに割り込むことでもアクセスできます。

次の項では、これらのコマンド モードについて詳しく説明します。

この項の後にあるCisco IOS XE CLI コマンド モードの概要に、Cisco IOS XE の主なコマンド モードの要約を示します。

Cisco IOS XE CLI の作業リスト

Cisco IOS XE CLI の機能に慣れるために、以降のセクションで説明する作業のいずれかを実行してください。

状況依存ヘルプの参照

システム プロンプトで疑問符(?)を入力すると、各コマンド モードで使用できるコマンドの一覧が表示されます。 また、状況依存ヘルプ機能を使用して、任意のコマンドで使用できる引数とキーワードの一覧を参照できます。

コマンド モード、コマンド名、キーワード、または引数についてのヘルプ情報を表示するには、次のいずれかのコマンドを使用します。

コマンド

目的

(prompt
)# help

ヘルプ システムの簡単な説明が表示されます。

(prompt
)# 
abbreviated-command-entry?

現在のモードの、特定の文字ストリングで始まるコマンドの一覧を表示します。

(prompt
)# abbreviated-command-entry
<Tab>

特定のコマンド名を補完します。

(prompt
)# ? 

そのコマンド モードで使用できるすべてのコマンドの一覧を表示します。

(prompt
)# command? 

コマンドに使用できる構文オプション(引数およびキーワード)の一覧を表示します。

(prompt
)# command
keyword ?

コマンドに次に使用できる構文オプションの一覧を表示します。

システム プロンプトは、現在のコンフィギュレーション モードによって変わることに注意してください。

状況依存ヘルプが使用される場合は、疑問符(?)の前のスペースが重要です。 特定の文字シーケンスで始まるコマンドのリストを表示するには、それらの文字を入力し、その直後に疑問符(?)を入力します。 スペースは含めません。 この形式のヘルプは、ユーザに代わって 1 つの単語を完成させるため、ワード ヘルプと呼びます。 詳細については、この章の「部分的なコマンド名の補完」のセクションを参照してください。

キーワードまたは引数の一覧を表示するには、キーワードまたは引数の代わりに疑問符(?)を入力します。 ? の前にはスペースを挿入します。 この形式のヘルプは、コマンド構文ヘルプと呼びます。これは、すでに入力したコマンド、キーワード、および引数に基づいて、使用できるキーワードや引数が表示されるためです。

コマンドおよびキーワードは、一意の省略形として認識可能な文字数まで省略できます。 たとえば、configureterminal コマンドは configt に省略できます。 コマンドの省略形が一意であるため、ルータによって省略形が受け付けられ、コマンドが実行されます。

help コマンド(どのコマンド モードでも使用できます)を実行すると、次のようにヘルプ システムの説明が表示されます。

Router#
 help
Help may be requested at any point in a command by entering
a question mark '?'. If nothing matches, the help list will
be empty and you must back up until entering a '?' shows the
available options.
Two styles of help are provided:
1. Full help is available when you are ready to enter a
   command argument (e.g. 'show ?') and describes each possible
   argument.
2. Partial help is provided when an abbreviated argument is entered
   and you want to know what arguments match the input
   (e.g. 'show pr?'.)

help コマンドの出力が示すように、疑問符(?)を使用して部分的なコマンド名を補完したり(部分ヘルプ)、現在のコマンドを補完する引数またはキーワードの一覧を表示したりできます。

次に、状況依存ヘルプ機能を使用して、コンフィギュレーション モードでアクセス リストを作成する例を示します。

システム プロンプトで、co に続けて疑問符(?)を入力します。 最後の文字と疑問符の間にはスペースを入れません。 システムには co で始まるコマンドが表示されます。

Router# co?
configure  connect  copy

configure コマンドの後にスペースと疑問符を入力すると、そのコマンドのキーワードと簡単な説明の一覧が表示されます。

Router# configure ?
  memory    Configure from NV memory
  network   Configure from a TFTP network host
  overwrite-network  Overwrite NV memory from TFTP network host
  terminal  Configure from the terminal
  <cr>

一覧内の <cr> 記号(「cr」は復帰を表します)は、Return キーまたは Enter キーを押して、キーワードを追加せずにコマンドを実行することが 1 つの選択肢であることを示します。 この例の出力に、configure コマンドのオプションが configurememory(NVRAM から設定)、configurenetwork(ネットワーク上のファイルから設定)、configureoverwrite-network(ネットワーク上のファイルから設定し、NVRAM のファイルを置き換える)、または configureterminal(端末接続から手動で設定)であることが示されます。 ほとんどのコマンドで、<cr> 記号は、入力済みの構文でコマンドを実行できることを示すために使用されます。 ただし、configure コマンドは特殊であり、CLI によって不足している構文の入力を求められます。

Router# configure
Configuring from terminal, memory, or network [terminal]? terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

? プロンプトに対するデフォルトの応答は、 CLI 出力中の行末にある角カッコで囲まれたオプションによって示されます。 前の例では、Enter(または Return)キーを押すことは、「terminal」の単語を入力することと同じです。

グローバル コンフィギュレーション モードを開始するには、configureterminal コマンドを実行します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

CLI では、エラー インジケータであるキャレット記号(^)を使用してエラーの位置が示されます。 ^ 記号は、コマンド構文中の、ユーザが正しくないか認識されないコマンド構文を入力した場所に表示されます。 たとえば、次の出力のキャレット記号は、コマンド中の入力ミスした文字を示しています。

Router# configure terminal
                     ^
% Invalid input detected at '^' marker.
Router#

エラー マーカーを警告するため、画面上にエラー メッセージ(% 記号によって示されます)が表示されることに注意してください。

access-list コマンドの後にスペースと疑問符を入力すると、コマンドで使用できるオプションの一覧が表示されます。

Router(config)# access-list ?
 <1-99>            IP standard access list
 <100-199>         IP extended access list
 <1100-1199>       Extended 48-bit MAC address access list
 <1300-1999>       IP standard access list (expanded range)
 <200-299>         Protocol type-code access list
 <2000-2699>       IP extended access list (expanded range)
 <700-799>         48-bit MAC address access list
 dynamic-extended  Extend the dynamic ACL absolute timer
 rate-limit        Simple rate-limit specific access list

山カッコ内の 2 つの数は包含範囲を表します。 アクセス リスト番号 99 を入力し、再度疑問符を入力すると、キーワードに該当する引数と簡単な説明が表示されます。

Router(config)# access-list 99 ?
  deny    Specify packets to reject
  permit  Specify packets to forward

deny 引数の後に疑問符(?を入力すると、追加のオプションの一覧が表示されます。

Router(config)# access-list 99 deny ?
  A.B.C.D  Address to match

一般に大文字は変数(引数)を表します。 IP アドレスに続けて疑問符(?)を入力すると、追加のオプション一覧が表示されます。

Router(config)# access-list 99 deny 172.31.134.0 ?
  A.B.C.D  Mask of bits to ignore
  <cr>

この出力では、A.B.C.D は、ワイルドカード マスクの使用が可能であることを示します。 ワイルドカード マスクは、IP アドレスまたは IP アドレスの範囲を照合するための方法の 1 つです。 たとえば、0.0.0.255 のワイルドカード マスクは、IP アドレスの 4 番目のオクテットに表示される、0 ~ 255 の範囲の番号に一致します。

ワイルドカード マスクに続けて疑問符(?)を入力すると、その他のオプションの一覧が表示されます。

Router(config)# access-list 99 deny 172.31.134.0 0.0.0.255 ?
<cr>

<cr> 記号は、それ以上キーワードや引数がないことを示します。 Enter(または Return)キーを押してコマンドを実行します。

Router(config)# access-list 99 deny 172.31.134.0 0.0.0.255

システムではエントリがアクセス リスト 99 に追加され、サブネット 172.31.134.0 上のすべてのホストへのアクセスが拒否され、0 ~ 255 の範囲で終わる IP アドレスに対するビットが無視されます。

コマンドの no 形式および default 形式の使用

ほぼすべてのコンフィギュレーション コマンドに no 形式があります。 一般に、no 形式を使用すると、機能がディセーブルになります。 no キーワードなしでコマンドを使用すると、ディセーブルにされた機能を再度イネーブルにしたり、デフォルトでディセーブルになっている機能をイネーブルにすることができます。 たとえば、IP ルーティングはデフォルトでイネーブルに設定されています。 IP ルーティングをディセーブルにするには、iprouting コマンドの noiprouting 形式を使用します。 これを再度イネーブルにするには、iprouting のプレーンな形式を使用します。 Cisco IOS ソフトウェアのコマンド リファレンスの資料では、コマンドの no 形式が使用できる場合は常に no 形式の機能について説明しています。

多くの CLI コマンドには default 形式もあります。 defaultcommand-name コマンドを実行することで、コマンドをデフォルトの設定にすることができます。 Cisco IOS ソフトウェアのコマンド リファレンス マニュアルでは、default 形式が、コマンドのプレーン形式か no 形式と異なる機能を実行する場合、一般にコマンドの default 形式の機能を説明しています。 システムで使用できるデフォルト コマンドを表示するには、該当するコマンド モードで default? と入力します。

コマンド履歴の使用方法

Cisco IOS CLI では、入力したコマンドの履歴(記録)が提供されます。 この機能は、アクセス リストなど、長いまたは複雑なコマンドやエントリを呼び出す場合、特に便利です。 コマンド履歴機能を使用するには、以降の項で説明するいずれかの作業を実行します。

CLI 編集機能とショートカットの使用

Cisco IOS CLI では、さまざまなショートカットと編集機能が使用できます。 以降のサブセクションで次の機能について説明します。

コマンド ラインでのカーソルの移動

次の表に、修正または変更を加える際、コマンド ラインでカーソルを移動するために使用できるキーの組み合わせまたはキー シーケンスを示します。 Ctrl は Control キーを示し、対応する文字キーと同時に押す必要があります。 Esc は Escape キーを示し、最初に押してから対応する文字キーを押します。 キーの大文字と小文字は区別されません。 CLI のナビゲーションと編集で使用される文字の多くは、その機能を簡単に覚えておけるように選択されています。 次の表では、使用される文字と機能の関係を示すために「機能の概要」の列の文字が太字で示されています。

表 1 カーソルを移動するために使用するキーの組み合わせ

キーストローク

機能の要約

機能の詳細

矢印または Ctrl+B

1 文字戻る( Back character)

カーソルを 1 文字左に移動します。 複数行にわたってコマンドを入力するときは、左矢印キーまたは Ctrl+B キーを繰り返し押してシステム プロンプトまでスクロール バックして、コマンド エントリの先頭まで移動できます。あるいは Ctrl+A キーを押してコマンド エントリの先頭に移動します。

矢印または Ctrl+F

1 文字進む( Forward character)

カーソルを 1 文字右に移動します。

EscB

1 単語戻る( Back word)

カーソルを 1 単語後退させます。

EscF

1 単語進む( Forward word)

カーソルを 1 単語前進させます。

Ctrl+A

行の先頭(Beginning of line)

カーソルを行の先頭に移動します。

Ctrl+E

行末( End of line)

カーソルをコマンド ラインの末尾に移動します。

部分的なコマンド名の補完

完全なコマンド名を思い出せない場合や、入力の作業量を減らす場合は、コマンドの先頭の数文字を入力して、Tab キーを押します。 コマンドライン パーサーは、入力されたストリングがコマンド モードで一意である場合に、コマンドを補完します。 キーボードに Tab キーがない場合は、代わりに Ctrl+I キーを押します。

コマンドは、コマンドが一意になるのに十分な文字が入力されていれば認識されます。 たとえば、特権 EXEC モードで conf と入力すると、エントリを configure コマンドと関連付けることができます。これは、conf で始まるコマンドが configure コマンドしかないためです。

次の例で、Tab キーを押すと、特権 EXEC モードの conf に対する一意のストリングが認識されます。

Router# conf
<Tab
>
Router# configure

コマンド補完機能を使用すると、CLI により完全なコマンド名が表示されます。 Return キーか Enter キーを押すまでコマンドは実行されません。 これにより、完全なコマンドが省略形によって意図したものでない場合に、コマンドを修正できます。 複数のコマンドに該当する文字列を入力した場合、テキスト ストリングが一意でないことを示すためにブザー音が鳴ります。

コマンドが補完できない場合は、疑問符(?)を入力して、その文字で始まるコマンドの一覧を表示します。 入力した最後の文字と疑問符(?)の間にはスペースを入れません。

たとえば、co? と入力すると、 現在のコマンド モードで使用可能なすべてのコマンドの一覧が表示されます。

Router# co?
configure connect copy
Router# co

疑問符の前に入力した文字は、コマンドを完全に入力できるように画面に表示されます。

削除したエントリの呼び出し

CLI では、削除したコマンドまたはキーワードが履歴バッファに格納されます。 スペースで始まるかスペースで終わるストリングだけがバッファに格納され、削除した個別の文字(Backspace または Ctrl+D を使用)は格納されません。 バッファには、Ctrl+K、Ctrl+U、または Ctrl+X で削除された最後の 10 個の項目が格納されます。 これらの項目を呼び出してコマンドラインに貼り付けるには、次のキーの組み合わせを使用します。

キーストローク

目的

Ctrl+Y

バッファ内の最新のエントリを呼び出します(キーを同時に押します)。

EscY

履歴バッファ内の前のエントリを呼び出します(キーは順番に押します)。

Esc、Y キー シーケンスは、最初に Ctrl+Y キーの組み合わせを押さない限り機能しません。 Esc、Y を 11 回以上押すと、バッファ内の最新のエントリに戻ります。

画面幅よりも長いコマンドラインの編集

CLI には、画面上の 1 行を超えるコマンドに対する折り返し機能が備わっています。 カーソルが右マージンに達すると、そのコマンドラインは 10 文字分だけ左へシフトされます。 コマンドラインの先頭から 10 文字までは見えなくなりますが、左へスクロールして、コマンドの先頭部分の構文をチェックできます。 スクロールで戻るには、Ctrl+B キーまたは←キーを繰り返し押してコマンド エントリの先頭に戻るか、Ctrl+A キーを押して直接行の先頭に戻ります。

次の例で、access-list コマンド エントリが 1 行を超えています。 最初にカーソルが行末に達すると、その行は 10 文字分だけ左へシフトされ、再表示されます。 ドル記号($)は、行が左にスクロールされたことを示しています。 カーソルが行末に達するたびに、その行は再び 10 文字分だけ左へシフトされます。

Router(config)# access-list 101 permit tcp 172.31.134.5 255.255.255.0 172.31.1
Router(config)# $ 101 permit tcp 172.31.134.5 255.255.255.0 172.31.135.0 255.25
Router(config)# $t tcp 172.31.134.5 255.255.255.0 172.31.135.0 255.255.255.0 eq
Router(config)# 
$31.134.5 255.255.255.0 172.31.135.0 255.255.255.0 eq 45

入力を完了したら、Return キーを押してコマンドを実行する前に、Ctrl+A キーを押して、完全な構文を確認します。 行が右にスクロールしていることを示すため、ドル記号($)が行末に表示されます。

Router(config)# access-list 101 permit tcp 172.31.134.5 255.255.255.0 172.31.1$

Cisco IOS XE ソフトウェアでは、幅が 80 カラムの端末画面を使用していると仮定しています。 画面の幅が異なる場合は、terminal width ユーザ EXEC コマンドを使用して端末の幅を設定します。

ライン ラップとコマンド履歴機能を組み合わせることで、以前の複雑なコマンド エントリを呼び出したり修正したりできます。 以前のコマンド エントリを呼び出す方法については、この章のコマンドのリコールの関するセクションを参照してください。

エントリの削除

入力を間違えた場合や気が変わった場合に、コマンド エントリを削除するには、次のキーまたはキーの組み合わせを使用します。

キーストローク

目的

Delete または Backspace

カーソルの左にある文字を削除します。

Ctrl+D

カーソル位置にある文字を削除します。

Ctrl+K

カーソル位置からコマンド ラインの末尾までのすべての文字を削除します。

Ctrl+U または Ctrl+X

カーソル位置からコマンド ラインの先頭までのすべての文字を削除します。

Ctrl+W

カーソルの左にある単語を削除します。

EscD

カーソルの位置から単語の末尾までを削除します。

--More-- プロンプトでの出力の続行

Cisco IOS XE CLI を使用する場合、出力が画面に表示可能な長さを超えることがあります。 多数の ?show、または more コマンドの出力など、出力が画面の下端を超えて続く場合、出力が一時停止され、--More-- プロンプトが下面の下部に表示されます。 出力を再開するには、Return キーを押して下に 1 行スクロールするか、スペースキーを押して出力の次の 1 画面分を表示します。


ヒント


出力が画面上で一時停止していて、--More-- プロンプトが表示されない場合は、length ライン コンフィギュレーション コマンドまたは terminal length 特権 EXEC モード コマンドを使用して、画面の長さより小さな値を入力します。 length の値をゼロにするとコマンド出力は一時停止しなくなります。


--More-- プロンプトからの出力のフィルタリングに関する情報については、この章の CLI 出力の検索とフィルタリングに関するモジュールを参照してください。

現在のコマンドラインの再表示

コマンドを入力していて、突然システムから画面にメッセージが表示された場合、現在のコマンド ライン エントリを簡単に呼び出すことができます。 現在のコマンド ラインを再表示(画面を更新)するには、次のキーの組み合わせのうちいずれかを使用します。

キーストローク

目的

Ctrl+L または Ctrl+R

現在のコマンド ラインを再表示します。

誤って入力した文字の置き換え

コマンド入力をミスした場合、入力ミスした文字を入れ替えることができます。 文字を入れ替えるには、次のキーの組み合わせを使用します。

キーストローク

目的

Ctrl+T

カーソルの左にある文字を、カーソルの右にある文字と置き換えます。

大文字と小文字の制御

単純なキー シーケンスで単語を大文字または小文字にしたり、文字セットを大文字にすることができます。 ただし、Cisco IOS XE コマンドでは、一般に大文字と小文字が区別されず、通常はすべて小文字で入力します。 コマンドの大文字と小文字を変更するには、次のキー シーケンスを使用します。

キーストローク

目的

EscC

カーソルの場所にある文字を大文字にします。

EscL

カーソルの場所にある単語を小文字にします。

EscU

カーソルの位置から単語の末尾までを大文字にします。

キーストロークをコマンド エントリとして指定

特定のキーストローク(キーの組み合わせまたはシーケンス)をコマンド エイリアスとして認識するようにシステムを設定できます。 つまり、ストロークを、コマンドを実行するためのショートカットとして設定できます。 システムにキーストロークをコマンドとして解釈させるには、コマンド シーケンスを入力する前に、次のいずれかのキーの組み合わせを使用します。

キーストローク

目的

Ctrl+V または EscQ

システムが次のキーストロークをユーザ コンフィギュレーション コマンド エントリとして受け付けるように設定します(編集コマンドとしてではありません)。

編集機能のディセーブル化と再イネーブル化

前のセクションで説明した編集機能はシステムで自動的にイネーブルになります。 しかし、これらの編集機能をディセーブルにすることが望ましい状況がいくつかあります。 たとえば、編集機能と競合するスクリプトがある場合です。 編集機能をグローバルにディセーブルにするには、ライン コンフィギュレーション モードで次のコマンドを使用します。

コマンド

目的

Router(config-line)# no editing

特定の回線に対して CLI 編集機能をディセーブルにします。

現在の端末セッションに対して編集機能をディセーブルにするには、ユーザ EXEC モードで次のコマンドを使用します。

コマンド

目的

Router# no terminal editing

ローカル ラインに対して CLI 編集機能をディセーブルにします。

現在の端末セッションに対して編集機能を再度イネーブルにするには、ユーザ EXEC モードで次のコマンドを使用します。

コマンド

目的

Router# terminal editing

現在の端末セッションに対して CLI 編集機能をイネーブルにします。

特定の回線に対して編集機能を再度イネーブルにするには、ライン コンフィギュレーション モードで次のコマンドを使用します。

コマンド

目的

Router(config-line)# editing

CLI 編集機能をイネーブルにします。

CLI 出力の検索とフィルタリング

Cisco IOS CLI には、大量のコマンド出力を検索したり、出力をフィルタリングして不要な情報を除外するための手段が提供されています。 これらの機能は、一般に大量のデータが表示される、show コマンドと more コマンドで使用できます。


(注)  


show コマンドと more コマンドは、常にユーザ EXEC モードまたは特権 EXEC モードで実行します。


画面に表示される内容を超えて出力が続く場合、Cisco IOS CLI では --More-- プロンプトが表示されます。 Return キーを押すことで次の行が表示され、スペースキーを押すことで次の画面が表示されます。 CLI ストリング検索機能を使用すると、--More-- プロンプトからの出力を検索またはフィルタリングできます。

Cisco IOS XE CLI の使用の例

コマンド構文の確認とコマンド履歴の使用の例

CLI では、エラー インジケータであるキャレット記号(^)を使用してエラーの位置が示されます。 ^ 記号は、コマンド ストリング内の誤ったコマンド、キーワード、または引数が入力された位置に表示されます。

次の例では、クロックを設定するものとします。 状況依存ヘルプを使用して、クロックを設定するための正しいコマンド構文を確認します。

Router# clock ?
  set  Set the time and date
Router# clock

ヘルプ出力により、set キーワードが必要であることが示されます。 時刻を入力するための構文を確認します。

Router# clock set ?
hh:mm:ss   Current time
Router# clock set

現在の時刻を入力します。

Router# clock set 13:32:00
% Incomplete command.

コマンドを完了するために追加の引数を指定する必要があることがシステムによって示されます。 Ctrl+P キーまたは↑キーを押して、以前のコマンド入力を自動的に繰り返します。 次にスペースと疑問符(?)を追加し、他の引数を確認します。

Router# clock set 13:32:00 ?
  <1-31>     Day of the month
  MONTH Month of the year

これでコマンド入力を完了できます。

Router# clock set 13:32:00 February 01
                                       ^
% Invalid input detected at '^' marker.

キャレット記号(^)とヘルプ応答により、01 に誤りがあることが示されます。 正しい構文の一覧を表示するために、エラーが発生した場所までコマンドを入力し、疑問符(?)を入力します。

Router# clock set 13:32:00 February ?
<1-31>     Day of the month
Router# clock set 13:32:00 February 23 ?
<1993-2035> Year 

正しい構文を使用して年を入力し、Enter または Return を押してコマンドを実行します。

Router# clock set 13:32:00 February 23 2001


 

CLI 出力の検索とフィルタリングの例

次に、morenvram:startup-config|begin 特権 EXEC モード コマンドの部分的な出力例を示します。これは、正規表現を含む最初の行で、フィルタリングされていない出力が開始されています。 --More-- プロンプトで、正規表現 ip を含む出力行を除外するためのフィルタを指定します。

Router# more nvram:startup-config | begin ip
address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
security passwords min-length 1
!
no aaa new-model
ip subnet-zero
no ip domain lookup
ip host sjc-tftp02 171.69.17.17
ip host sjc-tftp01 171.69.17.19
ip host dirt 171.69.1.129
!
!
multilink bundle-name authenticated
!
!
redundancy
 mode sso 
!         
!         
bba-group pppoe global
!         
!         
interface GigabitEthernet0/0/0
 ip address 10.4.9.158 255.255.255.0
 media-type rj45
 speed 1000
 duplex full
 negotiation auto
 no cdp enable
!         
interface GigabitEthernet0/0/1
 no ip address
 media-type rj45
 speed 1000
 duplex full
 negotiation auto
 no cdp enable
!         
interface POS0/1/0
 no ip address
 shutdown 
 no cdp enable
!         
interface POS0/1/1
 no ip address
 shutdown 
 no cdp enable
!         
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 speed 1000
 duplex full
 negotiation auto
!         
ip default-gateway 10.4.9.1
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 171.69.0.0 255.255.0.0 10.4.9.1
!         
no ip http server
no ip http secure-server
!         
!         
snmp mib bulkstat schema E0
snmp mib bulkstat schema IFMIB
snmp mib bulkstat transfer 23
snmp mib bulkstat transfer bulkstat1
!         
!         
control-plane
!         
!         
line con 0
 exec-timeout 30 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 15
 password lab
 login    
!         
end

次に、morenvram:startup-config|include 特権 EXEC コマンドの部分的な出力例を示します。 正規表現 ip を含む行だけが表示されています。

Router# more nvram:startup-config | include ip
ip subnet-zero
ip domain-name cisco.com
ip name-server 1192.168.48.48
ip name-server 172.16.2.132

次に、morenvram:startup-config|exclude 特権 EXEC コマンドの部分的な出力例を示します。 正規表現 service を含む行が除外されています。 --More-- プロンプトで、正規表現 Dialer1 をフィルタとして指定します。 このフィルタを指定することにより、Dialer1 を含む最初の行で出力が再開されます。

Router# more nvram:startup-config | exclude service
!
version 12.2
!
hostname router
!
boot system flash
no logging buffered
!
ip subnet-zero
ip domain-name cisco.com
.
.
.
--More--
/Dialer1
filtering...
interface Dialer1
 no ip address
 no ip directed-broadcast
 dialer in-band
 no cdp enable

次に、出力の検索が指定された、showinterface ユーザ EXEC または特権 EXEC コマンド モードの出力例の一部を示します。 パイプの後でキーワード beginFastEthernet を使用することで、正規表現 Fast Ethernet を含む最初の行でフィルタリングされていない出力が開始されます。 --More-- プロンプトで、正規表現 Serial を含む行だけを表示するフィルタを指定します。

Router# show interface | begin FastEthernet
FastEthernet0/0 is up, line protocol is up
Hardware is Lance, address is 0060.837c.6399 (bia 0060.837c.6399)
  Description: ip address is 172.1.2.14 255.255.255.0
  Internet address is 172.1.2.14/24
.
.
.
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
--More--
+Serial
filtering...
Serial1 is up, line protocol is up
Serial2 is up, line protocol is up
Serial3 is up, line protocol is down
Serial4 is down, line protocol is down
Serial5 is up, line protocol is up
Serial6 is up, line protocol is up
Serial7 is up, line protocol is up

次に、showbuffers|exclude コマンドの部分的な出力例を示します。 正規表現 0 misses を含む行が除外されています。 --More-- プロンプトで、フィルタされていない出力を、Serial0 を含む最初の行から続行するための検索を指定します。

Router# show buffers | exclude 0 misses
Buffer elements:
     398 in free list (500 max allowed)
Public buffer pools:
Small buffers, 104 bytes (total 50, permanent 50):
     50 in free list (20 min, 150 max allowed)
     551 hits, 3 misses, 0 trims, 0 created
Big buffers, 1524 bytes (total 50, permanent 50):
     49 in free list (5 min, 150 max allowed)
Very Big buffers, 4520 bytes (total 10, permanent 10):
.
.
.
Huge buffers, 18024 bytes (total 0 permanent 0):
     0 in free list (0 min, 4 max allowed)
--More--
/Serial0
filtering...
Serial0 buffers, 1543 bytes (total 64, permanent 64):
     16 in free list (0 min, 64 max allowed)
     48 hits, 0 fallbacks

次に、showinterface|include ユーザ EXEC または特権 EXEC コマンド モードの部分的な出力例を示します。 パイプ(|)の後で include(is) キーワードを使用することにより、正規表現 ( is ) が含まれる行だけが表示されます。 カッコにより、is の前後にスペースが含まれることが指定されます。 カッコを使用することで、is の前後にスペースを含む行だけが出力に含まれます(「disconnect」などの文字は検索から除外されます

router# show interface | include ( is )
ATM0 is administratively down, line protocol is down
  Hardware is ATMizer BX-50
Dialer0/1 is up (spoofing), line protocol is up (spoofing)
  Hardware is Unknown
  DTR is pulsed for 1 seconds on reset
FastEthernet0/0 is up, line protocol is up
  Hardware is Lance, address is 0060.837c.6399 (bia 0060.837c.6399)
  Internet address is 172.21.53.199/24
FastEthernet0/1 is up, line protocol is up
  Hardware is Lance, address is 0060.837c.639c (bia 0060.837c.639c)
  Internet address is 10.5.5.99/24
Serial0:0 is down, line protocol is down
  Hardware is DSX1
.
.
.
 --More-- 

--More-- プロンプトで、Serial0:13 を含む最初の行でフィルタリングされた出力を続行する検索を指定します。

/Serial0:13
filtering...
Serial0:13 is down, line protocol is down
  Hardware is DSX1
  Internet address is 10.0.0.2/8
     0 output errors, 0 collisions, 2 interface resets
  Timeslot(s) Used:14, Transmitter delay is 0 flag