Easy Virtual Network コンフィギュレーション ガイ ド、Cisco IOS XE Release 3S
Easy Virtual Network 共有サービスの設定
Easy Virtual Network 共有サービスの設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

Easy Virtual Network 共有サービスの設定

機能情報の検索

目次

仮想 IP ネットワーク共有サービスの前提条件

仮想 IP ネットワーク共有サービスの制約事項

Easy Virtual Network 共有サービスの概要

Easy Virtual Network の共有サービス

Easy Virtual Network は VRF-Lite よりも共有サービスを簡単にする

EVN でのルート レプリケーション プロセス

ルート レプリケーションを実装する場所

EVN のルート レプリケーションの動作

EVN でのルート レプリケーション後のルート プリファレンス ルール

Easy Virtual Network を使用してサービスを共有する方法

EVN でサービスを共有するためのルート レプリケーションの設定

この次の手順

EVN の共有サービスへの再配布の設定

EVN 共有サービスの設定例

例:マルチキャスト環境での EVN ルート レプリケーションとルート再配布

参考資料

関連資料

MIB

シスコのテクニカル サポート

Easy Virtual Network 共有サービスの機能情報

Easy Virtual Network 共有サービスの設定

このモジュールでは、Easy Virtual Network(EVN)でルート レプリケーションとルート再配布を使用してサービスを共有する方法について説明します。

機能情報の検索

ご使用のソフトウェア リリースによっては、このモジュールに記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「Easy Virtual Network 共有サービスの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

仮想 IP ネットワーク共有サービスの前提条件

Overview of Easy Virtual Networks 」を参照してください。

Configuring Easy Virtual Networks 」に基づいて、Easy Virtual Network を実装します。

仮想 IP ネットワーク共有サービスの制約事項

ルート レプリケーションは、スタティック ルート、EIGRP ルート、および OSPF ルートでサポートされています。BGP 間でルートをレプリケートすることは不可能ですが、VRF 間でルートをコピーする BGP のインポートおよびエクスポート方法が仮想ネットワークで使用できるため、問題になりません。

Easy Virtual Network 共有サービスの概要

「Easy Virtual Network の共有サービス」

「Easy Virtual Network は VRF-Lite よりも共有サービスを簡単にする」

「EVN でのルート レプリケーション プロセス」

「EVN のルート レプリケーションの動作」

「EVN でのルート レプリケーション後のルート プリファレンス ルール」

Easy Virtual Network の共有サービス

複数の仮想ネットワークがアクセスする必要がある共通のサービス(データベース サーバやアプリケーション サーバなど)がいくつかあります。共有サービスは次の理由のため、利点があります。

通常、グループごとにサービスが重複しません。

共有サービスは経済的です。

共有サービスは効率的で管理が容易です。

ポリシーを中央で展開できます。

ルートの分割を実現するには、物理的または仮想的に、各仮想ネットワークに 1 つずつサービスを複製することができます。ただし、そのソリューションは、費用効果が高くないか、実現不可能である場合があります。EVN をサポートするルータの場合、ソリューションはルート レプリケーションとルート再配布を実行することです。

ルート レプリケーションにより、ルートが仮想ネットワーク間でレプリケートされ、ある仮想ネットワークに存在するクライアントが、別の仮想ネットワークに存在するプレフィクスに到達できるため、共有サービスが可能になります。

共有サービス アプローチは、DNS、DHCP、および企業の通信に最適です。インターネット ゲートウェイへの共有アクセス用のソリューションではありません。

Easy Virtual Network は VRF-Lite よりも共有サービスを簡単にする

VRF-Lite の共有サービスでは、ルート識別子(RD)、インポートおよびエクスポートによるルート ターゲット、および BGP の設定が必要です。

EVN 環境では、簡単な展開であるルート レプリケーションによって、ルート共有サービスを実現できます。ルート レプリケーションでは BGP、RD、ルート ターゲット、インポートやエクスポートも必要ありません。

要約すると、VRF 間でルートをコピーするための BGP インポートおよびエクスポート方法は RF-Lite と EVN の両方で機能します。ただし、ルート レプリケーションは、複数の仮想ネットワークで共通サービスの共有を可能にするより簡単な代替方法です。

EVN でのルート レプリケーション プロセス

共有サービスでは、クライアントとサーバが異なる仮想ネットワークに存在します。クライアントとサーバ間の接続を実現するには、仮想ネットワーク間でルートが交換される必要があります。VRF 間のそのようなルート交換は、VRF-Lite が実装されているか EVN が実装されているかに応じて、2 つの方法で実現できます。

VRF-Lite では、ルート インポート/エクスポート機能を使用して、BGP によってルート リークが実現されます。

EVN では、ルート レプリケーションが RIB によって直接サポートされるため、BGP への依存関係はありません。ルートが異なる仮想ネットワークからレプリケートされると、Interior Gateway Protocol(IGP)への既存の再配布により、それらのルートが各仮想ネットワーク全体に伝播されます。

次のルート レプリケーション シナリオでは、ルータに Services と User-A という名前の 2 つの VRF があります。OSPF が次のように設定されます。

router ospf 99 vrf services
network 126.1.0.0 0.0.255.255 area 0
!
router ospf 98 vrf user-a
network 126.1.0.0 0.0.255.255 area 0
 

さらに、VRF User-A にルート再配布が設定されます。

vrf definition user-a
!
address-family ipv4
route-replicate from vrf services unicast ospf 99
exit-address-family
 

このシナリオでは、VRF サービスの次の RIB に 4 つのルートが含まれ、それらのうち 3 つは VRF User-A の RIB にレプリケートされます。ルート レプリケーションでは、図 1 に示すように、ソース RIB へのリンクが作成されます。

図 1 ルート レプリケーション

ルート レプリケーションの設定により、仮想 IP ネットワーク間の相互の再配布が可能になります。共有サービスの場合、共有サービスにアクセスする必要がある VRF 内にルート レプリケーションを設定することがあります。各 route-replicate コマンド内で、ルーティング ループを避けるため、ルート マップを使用して、任意でルートをフィルタで除外できます。つまり、ルートを元のルーティング プロトコルに再配布しないようにできます。ネィティブ ルートをレプリケートされたルートとして表示しないようにできます。

ルート レプリケーションを実装する場所

ルート レプリケーションは、できるだけ共有サービスの近くのルータに実装することをお勧めします。理想的には、サーバ サブネットに直接接続されているルータを使用して、サーバ VRF 上のホスト プレフィクスを再配布する必要をなくし、それにより、ルーティング ループの可能性を回避する必要があります。

EVN のルート レプリケーションの動作

このセクションでは、EVN のルート レプリケーションの動作について説明します。この動作は Multi-Topology ルーティングの動作と異なります。EVN 環境では、

route-replicate コマンドは address-family ipv4 コマンドでのみ受け入れられ、 vrf definition コマンドで設定されます。

route-replicate コマンドは、指定されたアドレス ファミリ内のベース トポロジにルートをレプリケートします。

ソース プロトコルとして all を指定した場合、指定した宛先トポロジに対して、VRF あたり 1 つの route-replicate コマンドのみが許可されます。

no route-replicate コマンドは、ソース プロトコルを除外できます。

ソース プロトコルとして all を指定した場合、接続されているルートがレプリケートされます( route-replicate コマンドの Multi-Topology ルーティング バージョンと異なる)。

レプリケートされたルートは、ソース ルートのアドミニストレーティブ ディスタンスとソース プロトコルを継承します。

EVN でのルート レプリケーション後のルート プリファレンス ルール

ルートがレプリケートされる場合、次のルールによってルート プリファレンスが決定します。

1. 2 つのルートが同じプロトコルで所有されていて(たとえば、両方とも OSPF ルートである)、両方のルートのソース VRF が同じであり、一方のルートがレプリケートされていない場合、レプリケートされていないルートが優先されます。

上のルールが適用しない場合、次のルールによって、この順番でルート プリファレンスが決定されます。

2. アドミニストレーティブ ディスタンスが小さいルートが優先されます。

3. デフォルトのアドミニストレーティブ ディスタンスが小さいルートが優先されます。

4. レプリケートされたルートよりもレプリケートされていないルートが優先されます。

5. 元の vrf 名を比較します。辞書編集上で vrf 名が小さいルートが優先されます。

6. 元のサブアドレスファミリを比較します。マルチキャストよりユニキャストが優先されます。

7. 最も古いルートが優先されます。

Easy Virtual Network を使用してサービスを共有する方法

2 つの VRF から共有サービス VRF への完全なアクセス可能性を実現するには、次の両方のタスクを実行します。

「EVN でサービスを共有するためのルート レプリケーションの設定」(必須)

「EVN の共有サービスへの再配布の設定」(必須)

EVN でサービスを共有するためのルート レプリケーションの設定

次のタスクを実行して、ある VRF から別の VRF にルートをレプリケートします。このタスク テーブル内の例は図 2 に基づいています。

図 2 ルート レプリケーションを使用した共有サービス

この特定のタスクでは、VRF SERVICES からのルートが VRF RED にレプリケートされます。双方向トラフィックを許可するため、VRF RED からのルートも VRF SERVICES にレプリケートされます。


) 実際の EVN 環境では、VRF SERVICES と 3 つ目の VRF 間、およびもっと多くの VRF 間のルート レプリケーションが存在することがあります。そうしたレプリケーションは、簡潔さのため、次の設定タスクから外しています。


手順の概要

1. enable

2. configure terminal

3. vrf definition vrf-name

4. vnet tag number

5. description string

6. address-family ipv4

7. exit

8. exit

9. vrf definition vrf-name

10. vnet tag number

11. description string

12. address-family ipv4

13. exit

14. exit

15. interface type number

16. vrf forwarding vrf-name

17. ip address ip-address mask

18. no shutdown

19. exit

20. router ospf process-id vrf vrf-name

21. network ip-address wildcard-mask area area-id

22. exit

23. router ospf process-id vrf vrf-name

24. network ip-address wildcard-mask area area-id

25. exit

26. vrf definition vrf-name

27. address-family ipv4

28. route-replicate from [ vrf vrf-name ] { multicast | unicast } { all | protocol-name } [ route-map map-tag ]

29. exit

30. exit

31. vrf definition vrf-name

32. address-family ipv4

33. route-replicate from [ vrf vrf-name ] { multicast | unicast } { all | protocol-name } [ route-map map-tag ]

34. end

35. show ip route vrf vrf-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition SERVICES

VRF を定義します。

ステップ 4

vnet tag number

 

Router(config-vrf)# vnet tag 100

VRF のグローバルな数値タグを指定します。

同じタグ番号を各エッジおよびトランク インターフェイス上の同じ VRF に設定する必要があります。

ステップ 5

description string

 

Router(config-vrf)# description shared services

(任意)コンフィギュレーション ファイルを参照するネットワーク管理者に役立つように、VRF について記述します。

ステップ 6

address-family ipv4

 

Router(config-vrf)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始し、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 7

exit

 

Router(config-vrf-af)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 8

exit

 

Router(config-vrf)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 9

vrf definition vrf-name

 

Router(config)# vrf definition RED

VRF を定義します。

ステップ 10

vnet tag number

 

Router(config-vrf)# vnet tag 200

VRF のグローバルな数値タグを指定します。

同じタグ番号を各エッジおよびトランク インターフェイス上の同じ VRF に設定する必要があります。

ステップ 11

description string

 

Router(config-vrf)# description user of services

(任意)コンフィギュレーション ファイルを参照するネットワーク管理者に役立つように、VRF について記述します。

ステップ 12

address-family ipv4

 

Router(config-vrf)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始し、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 13

exit

 

Router(config-vrf-af)# exit

次に最高のコンフィギュレーション モードに移動します。

ステップ 14

exit

 

Router(config-vrf)# exit

次に最高のコンフィギュレーション モードに移動します。

ステップ 15

interface type number

 

Router(config)# interface gigabitethernet 0/0/0

インターフェイス タイプと番号を設定します。

ステップ 16

vrf forwarding vrf-name

 

Router(config-if)# vrf forwarding SERVICES

インターフェイスと VRF インスタンスを関連付けます。

ステップ 17

ip address ip-address mask

 

Router(config-if)# ip address 192.168.1.3 255.255.255.0

インターフェイスに対するプライマリ IP アドレスを設定します。

ステップ 18

no shutdown

 

Router(config-if)# no shutdown

インターフェイスを再起動します。

ステップ 19

exit

 

Router(config-vrf)# exit

次に最高のコンフィギュレーション モードに移動します。

ステップ 20

router ospf process-id vrf vrf-name

 

Router(config)# router ospf 99 vrf SERVICES

OSPF ルーティング プロセスを設定します。

この例では OSPF を使用していますが、EIGRP も使用できます。

ステップ 21

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 192.168.1.0 0.0.0.255 area 0

OSPF が実行するインターフェイスと、それらのインターフェイスに対するエリア ID を定義します。

ステップ 22

exit

 

Router(config-router)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 23

router ospf process-id [ vrf vrf-name ]

 

Router(config)# router ospf 98 vrf RED

OSPF ルーティング プロセスを設定します。

ステップ 24

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 192.168.1.0 0.0.0.255 area 0

OSPF が実行するインターフェイスと、それらのインターフェイスに対するエリア ID を定義します。

ステップ 25

exit

 

Router(config-router)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 26

vrf definition vrf-name

 

Router(config)# vrf definition RED

VRF を定義します。

ステップ 27

address-family ipv4

 

Router(config-vrf)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始し、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 28

route-replicate from [ vrf vrf-name ] { multicast | unicast } { all | protocol-name } [ route-map map-tag ]

 

Router(config-vrf-af)# route replicate from vrf SERVICES unicast all

指定したアドレス ファミリ内のベース トポロジにルートをレプリケートします。

ソース プロトコルとして all キーワードを指定した場合、指定した宛先トポロジに対して、VRF あたり 1 つの route-replicate コマンドのみが許可されます。

接続されたルートのみをレプリケートするには、ソース protocol-name として connected キーワードを使用します。

ステップ 29

exit

 

Router(config-vrf-af)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 30

exit

 

Router(config-vrf)# exit

次に高いコンフィギュレーション モードに移動します。

ステップ 31

vrf definition vrf-name

 

Router(config)# vrf definition SERVICES

VRF を定義します。

ステップ 32

address-family ipv4

 

Router(config-vrf)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始し、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 33

route-replicate from [ vrf vrf-name ] { multicast | unicast } { all | protocol-name } [ route-map map-tag ]

 

Router(config-vrf-af)# route replicate from vrf RED unicast all

指定したアドレス ファミリ内のベース トポロジにルートをレプリケートします。

これは、双方向トラフィックを許可するステップ 28 と逆のレプリケーションです。

ステップ 34

end

 

Router(config-vrf-af)# end

コンフィギュレーション モードを終了します。

ステップ 35

show ip route vrf vrf-name

 

Router# show ip route vrf RED

(任意)プラス記号(+)で示されているレプリケートされたルートを含めて、ルートを表示します。

次に、前のタスク テーブルのタスクに基づいた show ip route vrf コマンドの出力を示します。

Router# show ip route vrf RED
 
Routing Table: RED
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
 
Gateway of last resort is not set
 
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C + 192.168.1.0/24 is directly connected (SERVICES), GigabitEthernet0/0/0
L + 192.168.1.3/32 is directly connected (SERVICES), GigabitEthernet0/0/0
Router#

この次の手順

タスク「EVN でサービスを共有するためのルート レプリケーションの設定」(および図 2 の VRF GREEN のパラレル タスク)の実行後、Router 3 には 10.0.0.0/8 と 20.0.0.0/8 へのルートが設定されます。さらに、Router 1 と Router 2 には 192.168.1.0/24 へのルートが設定されます。

しかし、Router 1 と Router 2 にはまだ 192.168.1.1 に存在する共有サービスへのルートが設定されていません。さらに、Router 4 には 10.0.0.0/8 と 20.0.0.0/8 へのルートが設定されていません。それらのアクセスには、次のタスク「EVN の共有サービスへの再配布の設定」で実行するルート再配布が必要です。

EVN の共有サービスへの再配布の設定

このタスクは、タスク「EVN でサービスを共有するためのルート レプリケーションの設定」も実行しているという仮定に基づいています。

図 3図 2 で使用した同じネットワークを示しています。このタスクでは、Router 1 と Router 2 に 192.168.1.1 に存在する共有サービスへのルートが設定されるように、Router 3 で再配布を実行します。

図 3 再配布を使用した共有サービス

手順の概要

1. enable

2. configure terminal

3. router ospf process-id vrf vrf-name

4. redistribute vrf vrf-name ospf process-id subnets

5. redistribute vrf vrf-name ospf process-id subnets

6. exit

7. router ospf process-id vrf vrf-name

8. redistribute vrf vrf-name ospf process-id subnets

9. exit

10. router ospf process-id vrf vrf-name

11. redistribute vrf vrf-name ospf process-id subnets

12. end

13. show ip route vrf vrf-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id vrf vrf-name

 

Router(config)# router ospf 99 vrf SERVICES

OSPF ルーティング プロセスを設定します。

ステップ 4

redistribute vrf vrf-name ospf process-id subnets

 

Router(config-router)# redistribute vrf RED ospf 98 subnets

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

ステップ 5

redistribute vrf vrf-name ospf process-id subnets

 

Router(config-router)# redistribute vrf GREEN ospf 97 subnets

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

ステップ 6

exit

 

Router(config-router)# exit

次に最高のコンフィギュレーション モードに移動します。

ステップ 7

router ospf process-id vrf vrf-name

 

Router(config)# router ospf 98 vrf RED

OSPF ルーティング プロセスを設定します。

ステップ 8

redistribute vrf vrf-name ospf process-id subnets

 

Router(config-router)# redistribute vrf SERVICES ospf 99 subnets

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

ステップ 9

exit

 

Router(config-router)# exit

次に最高のコンフィギュレーション モードに移動します。

ステップ 10

router ospf process-id vrf vrf-name

 

Router(config)# router ospf 97 vrf GREEN

OSPF ルーティング プロセスを設定します。

ステップ 11

redistribute vrf vrf-name ospf process-id subnets

 

Router(config-router)# redistribute vrf SERVICES ospf 99 subnets

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

ステップ 12

end

 

Router(config-router)# end

コンフィギュレーション モードを終了します。

ステップ 13

show ip route vrf vrf-name

 

Router# show ip route vrf RED

(任意)プラス記号(+)で示されているレプリケートされたルートを含めて、ルートを表示します。

EVN 共有サービスの設定例

「例:マルチキャスト環境での EVN ルート レプリケーションとルート再配布」

例:マルチキャスト環境での EVN ルート レプリケーションとルート再配布

図 4 マルチキャストの物理トポロジの例

図 5 VRF Blue トポロジ

図 6 VRF Red および VRF Green トポロジ

図 4図 5、および図 6 には、3 つのマルチキャスト ストリームがあります。

Sred、G1:(10.10.1.200、232.1.1.1):VRF red のソースとレシーバー

Sgreen、G1:(10.10.2.201、232.1.1.1):VRF green のソースとレシーバー

Sblue、G2:(10.10.3.202、232.3.3.3):VRF red と green の blue のソースとレシーバー

VRF blue(10.10.3.0/24)のサーバプレフィクスは、R3 と R2 の VRF にレプリケートされ、配布されます。

マルチキャスト グループ 232.3.3.3 と VRF blue のそのソースは、VRF red と VRF green の両方にレシーバーがあります。ストリームは共有 VRF(blue)経由で送信され、R3 の VRF と R2 の VRF green にレプリケートされます。

R1 の設定

vrf definition blue
vnet tag 4
!
address-family ipv4
exit-address-family
!
vrf definition green
vnet tag 3
!
address-family ipv4
exit-address-family
!
vrf definition red
vnet tag 2
!
address-family ipv4
exit-address-family
!
vrf list vnet-list1
member blue
member red
!
vrf list vnet-list2
member blue
member green
!
vrf list vnet-list3
member blue
!
ip multicast-routing distributed
ip multicast-routing vrf red distributed
ip multicast-routing vrf green distributed
ip multicast-routing vrf blue distributed
!
interface FastEthernet0/0/2
vnet trunk list vnet-list1 [vnet trunk for red and blue]
ip address 50.50.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/1
vnet trunk list vnet-list2 [vnet trunk for green and blue]
ip address 40.40.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/3
ip address 10.10.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/3.2
vrf forwarding red
encapsulation dot1Q 2
ip address 10.10.1.1 255.255.255.0
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/3.3
vrf forwarding green
encapsulation dot1Q 3
ip address 10.10.2.1 255.255.255.0
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/3.4
vrf forwarding blue
encapsulation dot1Q 4
ip address 10.10.3.1 255.255.255.0
ip pim sparse-dense-mode
!
router ospf 201 vrf red
nsf
redistribute connected subnets
network 10.10.1.0 0.0.0.255 area 0
network 50.50.0.0 0.0.0.255 area 0
!
router ospf 202 vrf green
nsf
network 10.10.2.0 0.0.0.255 area 0
network 40.40.0.0 0.0.0.255 area 0
!
router ospf 203 vrf blue
router-id 11.11.11.11
nsf
network 10.10.3.0 0.0.0.255 area 0
network 40.40.0.0 0.0.0.255 area 0
network 50.50.0.0 0.0.0.255 area 0
!
router ospf 200
nsf
redistribute connected subnets
network 10.10.0.0 0.0.0.255 area 0
network 40.40.0.0 0.0.0.255 area 0
network 50.50.0.0 0.0.0.255 area 0
!
ip pim ssm default
ip pim vrf red ssm default
ip pim vrf green ssm default
ip pim vrf blue ssm default
!

R2 の設定

vrf definition blue
vnet tag 4
!
address-family ipv4
exit-address-family
!
vrf definition green
vnet tag 3
!
address-family ipv4
route-replicate from vrf blue unicast all route-map blue-map [replicate routes from blue
to green]
exit-address-family
!
vrf definition red
vnet tag 2
!
address-family ipv4
exit-address-family
!
vrf list vnet-list1
member blue
member green
!
vrf list vnet-list2
member blue
!
ip multicast-routing distributed
ip multicast-routing vrf red distributed
ip multicast-routing vrf green distributed
ip multicast-routing vrf blue distributed
!
interface FastEthernet0/0/6
vnet trunk list vnet-list2 [vnet trunk for blue]
ip address 70.70.0.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/2
vnet trunk list vnet-list1 [vnet trunk for green and blue]
ip address 40.40.0.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/4
vnet trunk list vnet-list1 [vnet trunk for green and blue]
ip address 60.60.0.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
router ospf 202 vrf green
redistribute connected subnets
redistribute vrf blue ospf 203 subnets route-map blue-map [redistribute routes replicated from blue in red]
network 40.40.0.0 0.0.0.255 area 0
network 60.60.0.0 0.0.0.255 area 0
!
router ospf 203 vrf blue
router-id 22.22.22.22
network 40.40.0.0 0.0.0.255 area 0
network 60.60.0.0 0.0.0.255 area 0
network 70.70.0.0 0.0.0.255 area 0
!
router ospf 200
redistribute connected subnets
network 40.40.0.0 0.0.0.255 area 0
network 60.60.0.0 0.0.0.255 area 0
network 70.70.0.0 0.0.0.255 area 0
!
ip pim ssm default
ip pim vrf red ssm default
ip pim vrf green ssm default
ip pim vrf blue ssm default
!
ip prefix-list server-prefix seq 5 permit 10.10.3.0/24
!
route-map blue-map permit 10
match ip address prefix-list server-prefix
!

R3 の設定

vrf definition blue
vnet tag 4
!
address-family ipv4
exit-address-family
!
vrf definition green
vnet tag 3
!
address-family ipv4
exit-address-family
!
vrf definition red
vnet tag 2
!
address-family ipv4
route-replicate from vrf blue unicast all route-map blue-map [replicate routes from blue to red]
exit-address-family
!
vrf list vnet-list1
member blue
member red
!
vrf list vnet-list2
member blue
!
ip multicast-routing distributed
ip multicast-routing vrf red distributed
ip multicast-routing vrf green distributed
ip multicast-routing vrf blue distributed
!
interface GigabitEthernet0/2/0
vnet trunk list vnet-list1 [vnet trunk for red and blue]
ip address 90.90.0.5 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface GigabitEthernet1/2/0
vnet trunk list vnet-list1 [vnet trunk for red and blue]
ip address 50.50.0.5 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
interface FastEthernet2/0/0
vnet trunk list vnet-list2 [vnet trunk for blue]
ip address 70.70.0.5 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
!
router ospf 201 vrf red
redistribute connected subnets
redistribute vrf blue ospf 203 subnets route-map blue-map [redistribute routes replicated from blue in red]
network 50.50.0.0 0.0.0.255 area 0
network 90.90.0.0 0.0.0.255 area 0
!
router ospf 203 vrf blue
router-id 55.55.55.55
network 50.50.0.0 0.0.0.255 area 0
network 70.70.0.0 0.0.0.255 area 0
network 90.90.0.0 0.0.0.255 area 0
!
router ospf 200
redistribute connected subnets
network 50.50.0.0 0.0.0.255 area 0
network 70.70.0.0 0.0.0.255 area 0
network 90.90.0.0 0.0.0.255 area 0
!
ip pim ssm default
ip pim vrf red ssm default
ip pim vrf green ssm default
ip pim vrf blue ssm default
!
ip prefix-list server-prefix seq 5 permit 10.10.3.0/24
!
route-map blue-map permit 10
match ip address prefix-list server-prefix
!

参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

Easy Virtual Network コマンド

Easy Virtual Network Command Reference

Easy Virtual Network の概要

「Overview of Easy Virtual Network」

Easy Virtual Network の設定

「Configuring Easy Virtual Network」

Easy Virtual Network の管理とトラブルシューティング

「Easy Virtual Network Management and Troubleshooting」

MIB

MIB
MIB リンク

VRF 情報を提供する MIB は引き続き Easy Virtual Network で動作します。システムのすべての VRF に関する VRF 独立 MIB のレポート情報:

CISCO--VRF-MIB

CISCO--MVPN-MIB

MPLS-VPN MIB

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

Easy Virtual Network 共有サービスの機能情報

表 1 に、この機能のリリース履歴を示します。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連のソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 Easy Virtual Network 共有サービスの機能情報

機能名
リリース
機能情報

VRF ルート レプリケーション

Cisco IOS XE Release 3.2S

このモジュールでは、Easy Virtual Network 環境でルート レプリケーションと再配布を使用してサービスを共有する方法について説明します。

この機能によって、次のコマンドが変更されました。

redistribute (IP)

この機能によって、次のコマンドが追加されました。

route-replicate (VRF アドレス ファミリ)