Easy Virtual Network コンフィギュレーション ガイ ド、Cisco IOS XE Release 3S
Easy Virtual Network の概要
Easy Virtual Network の概要
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

Easy Virtual Network の概要

機能情報の検索

目次

EVN の設定に関する前提条件

EVN の制約事項

EVN の概要

EVN の利点

仮想ネットワーク タグによるパスの分離の提供

仮想ネットワーク タグ

vnet Global

エッジ インターフェイスと EVN トランク インターフェイス

仮想ネットワーク サブインターフェイスと出力でトランク インターフェイスを識別するための表記

トランク インターフェイスの単一の IP アドレス

定義されている VRF とトランク インターフェイス上で実行する VRF 間の関係

VRF 認識

EVN でサポートされるルーティング プロトコル

仮想ネットワークのパケット フロー

EVN トランク インターフェイスでのコマンド継承

コマンド継承の上書き:仮想ネットワーク インターフェイス モード

vnet Global のみへのアトリビュートの適用

上書きの削除と継承される値の復元

EXEC ルーティング コンテキスト

EVN の VRF-Lite との互換性

マルチアドレス ファミリ VRF 構造

参考資料

関連資料

MIB

シスコのテクニカル サポート

Easy Virtual Network の概要の機能情報

Easy Virtual Network の概要

Easy Virtual Network(EVN)は、複数のレイヤ 3 ネットワークのエンドツーエンドの仮想化を実現する IP ベースの仮想化テクノロジーです。単一の IP インフラストラクチャを使用して、トラフィック パスが相互に独立した状態で、個別の仮想ネットワークを提供できます。

EVN は、VRF-Lite と呼ばれる既存の IP ベースの仮想化メカニズムに基づいて構築されています。EVN はパス分離の拡張機能、簡単な設定と管理、改善された共有サービス サポートを提供します。EVN は VRF-Lite ソリューションと下位互換性があり、VRF-Lite から EVN へのシームレスなネットワーク移行を可能にします。

EVN はユニキャスト ルーティングの場合に IPv4、スタティック ルート、OSPFv2、および EIGRP をサポートし、IPv4 マルチキャスト ルーティングの場合に PIM および MSDP をサポートします。EVN は CEF と SNMP もサポートします。

機能情報の検索

ご使用のソフトウェア リリースによっては、このモジュールに記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「Easy Virtual Network の概要の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、および Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

EVN の設定に関する前提条件

ネットワークへの EVN の実装には、EVN を利用して、複数の論理ネットワークまたは L3VPN に仮想化する単一の IP インフラストラクチャが必要です。EVN は異なる仮想ネットワーク上のトラフィックのパス分離を提供します。

ネットワークに仮想化を追加する前に、機能するキャンパス設計が確立されている必要があります。

Virtual Routing and Forwarding(VRF)インスタンスおよびそれらを使用して、ネットワーク全体でのトラフィックの分割を維持する方法について理解する必要があります。

EVN の制約事項

EVN トランクは、ファスト イーサネットやギガビット イーサネットなどの 802.1q カプセル化をサポートするすべてのインターフェイスで使用できます。

トランクには追加のプラットフォームとラインカードの制約事項があります。サポートされるプラットフォームとラインカードについては、Cisco Feature Navigator を確認する必要があります。

単一の IP インフラストラクチャを仮想化して、最大 32 のエンドツーエンドの仮想ネットワークを提供できます。

インターフェイスに EVN トランクを設定した場合、同じインターフェイスに VRF-Lite を設定できません。

OSPFv3 はサポートされていません。OSPFv2 はサポートされています。

次はサポートされていません。

IS-IS

RIP

BGP ではルート レプリケーションがサポートされない

特定の SNMP set 操作

次は、EVN トランクでサポートされていません。

Access Control List(ACL; アクセス コントロール リスト)

BGP インターフェイス コマンドは継承されない

IPv6(ただし、IPv6 は vnet global でサポートされる)

NAT

NetFlow

WCCP

EVN の概要

「EVN の利点」

「仮想ネットワーク タグによるパスの分離の提供」

「仮想ネットワーク タグ」

「vnet Global」

「エッジ インターフェイスと EVN トランク インターフェイス」

「定義されている VRF とトランク インターフェイス上で実行する VRF 間の関係」

「VRF 認識」

「EVN でサポートされるルーティング プロトコル」

「仮想ネットワークのパケット フロー」

「EVN トランク インターフェイスでのコマンド継承」

「コマンド継承の上書き:仮想ネットワーク インターフェイス モード」

「EXEC ルーティング コンテキスト」

「EVN の VRF-Lite との互換性」

「マルチアドレス ファミリ VRF 構造」

EVN の利点

Easy Virtual Network は、レイヤ 3 ネットワークでのエンドツーエンドの仮想化を実現する IP ベースの仮想化テクノロジーです。ネットワーク仮想化は、ネットワークのセキュリティを保護するツールとして、また複数の仮想ネットワークに同じネットワーク インフラストラクチャを使用することで、ネットワークの資本と運用費を削減する方法として使用できます。それぞれ固有の論理ネットワークと一意のルーティングおよびフォワーディング テーブルを使用して、複数のグループをサポートすることにより、お客様は、同じ物理インフラストラクチャを何回でも利用できます。

ネットワーク仮想化以前、お客様は次の方法でパスの分離を実現していました。

グループごとに専用ルータを使用して、物理的に分離します。これは、仮想ネットワークよりも費用がかかります。

Access Control List(ACL; アクセス コントロール リスト)を使用しますが、ACL は一意のルーティングおよびフォワーディング テーブルをサポートしておらず、維持に費用がかかり、仮想ネットワークより、エラーが起こりやすい可能性があります。

EVN には次の利点があります。

トラフィックを分離するために個別の物理インフラストラクチャを維持する必要がないため、資本支出を削減します。1 つの IP ネットワークで、ネットワークのトラフィックのパスを分離する複数の仮想ネットワークを設定できるため、追加のハードウェアの費用を節約します。

合併、買収、ビジネス パートナーのネットワーク統合が容易なため、ビジネスの柔軟性が高まります。

ネットワークのコアを通るトラフィックの分離を維持するためのインフラストラクチャ要件が少ないため、複雑さを緩和します。

Multi-VRF(VRF-Lite)と呼ばれる既存のメカニズムに基づいて構築されています。EVN は VRF-Lite と互換性があります。「EVN の VRF-Lite との互換性」を参照してください。EVN はパス分離の拡張機能、簡単な設定と管理、改善された共有サービスのサポートを提供するため、VRF-Lite よりも EVN が推奨されます。

社内の部署間でトラフィックの分割を維持することに加えて、パスの分離が役に立つ他のシナリオがあります。いくつかの例を次に示します。

インターネットへのゲスト アクセス:お客様のネットワークを通るあらかじめ定められたデータ パスを使用し、ゲスト インターネット バウンド トラフィック用に一意のデフォルトのルートを定義できることで、インターネットへのゲストのネットワーク アクセスを制限します。

ネットワーク アドミッション コントロール(NAC)の分離:非準拠のデスクトップから発信されたトラフィックを分離します。

パートナー アクセス:お客様が許可するインターネット、電子メール、DNS、DHCP、またはアプリケーション サーバなどのネットワーク共有サービスへのパートナーや請負業者のアクセスを制限します。

アプリケーションとデバイスの分離:トラフィックが検査される中央のファイアウォールにトラフィックを「強制的に通す」ことによって、データ センターのサービスとデバイスのセキュリティを保護します。

アウトソーシング サービス:さまざまなクライアントからのデータ トラフィックを相互に分離します。

スケーラブルなネットワーク:ネットワークの一部を、きわめて厳格なサービス レベルを必要とするトラフィックに制限し、それにより、必要な場所にのみそれらの要件を提供することで、コストを低減することができます。

子会社/合併/買収:必要に応じてサービスの共有を可能にすると同時に、段階を追って会社やネットワークを統合します。

サービス プロバイダーとしての役割を持つ企業:それぞれ 1 つの権限下で個別のネットワークを必要とする自立したグループ。例は、航空路線ごとに仮想ネットワークをサポートする空港です。

仮想ネットワーク タグによるパスの分離の提供

異なるユーザ グループを同じ IP インフラストラクチャで実行することは珍しくありません。さまざまなビジネス上の理由から、異なるグループ間でのトラフィックの分離が必要になります。図 1 は、同じネットワークで実行する Red と Green の 2 つのユーザ グループを示しています。ネットワーク仮想化の前は、2 つのグループ間でのトラフィックの分離はありません。Red ユーザ グループのユーザは、Green ユーザ グループのサーバにアクセスでき、逆も可能です。

ネットワーク仮想化を使用しない場合、パスの分離はアクセス コントロールによって実現できますが、これは、維持に費用がかかり、エラーが起きやすく、ネットワークごとに一意のルーティングおよびフォワーディング テーブルをサポートしていません。

図 1 仮想化しないネットワーク

 

仮想ネットワークは、1 つの物理ネットワーク上のさまざまなユーザ グループを大まかにセグメント化します。仮想ネットワークを設定することによって、単一の IP インフラストラクチャを仮想化して、多数のエンドツーエンドの仮想ネットワークを実現できます。図 2 では、Red と Green の 2 つの VRF を作成して、単一の IP インフラストラクチャを 2 つの Virtual Private Network(VPN; バーチャル プライベート ネットワーク)に仮想化しています。

図 2 仮想化したネットワーク

 

VRF を使用して、デバイスレベルの分割を提供するだけでなく、各仮想ネットワークは相互にパスも分離されます。パスの分離は、トラフィックを明示的にタグ付けすることによって実現されます。トラフィックは同じ仮想ネットワーク全体で同じタグ値を伝送します。パスに沿った各ネットワーク デバイスは、タグを使用して、異なる VRF 間で分割を行います。1 つのタグ番号は、たとえば、あるルータ上の VRF red を別のルータ上の VRF red に関連付けます。

仮想ネットワーク タグ

各 VPN と関連付けられた EVN は、設定時に割り当てるタグ値を持ちます。タグ値はグローバルです。つまり、各ルータで同じ EVN には同じ数値のタグ値が関連付けられる必要があります。タグ値の範囲は、2 ~ 4094 です。EVN は、ファスト イーサネットやギガビット イーサネットなどの 802.1q カプセル化をサポートするすべてのインターフェイスで使用できます。VRF-Lite ソリューションとの下位互換性を可能にするため、802.1q フレームの vLAN ID フィールドを使用して、仮想ネットワーク タグが伝送されます。

仮想ネットワーク タグを伝送するトラフィックはタグ付きトラフィックと呼ばれます。仮想ネットワーク タグを伝送しないトラフィックはタグなしトラフィックと呼ばれます。

red と green の 2 つの VRF がある次の構成で、タグを説明します。2 つの VRF はそれぞれ固有のタグを持つため、ルータのタグの構成は次のように見えます。

! Define two VRFs, red and green.
vrf definition red
vnet tag 101
!
address-family ipv4
exit-address-family
!
vrf definition green
vnet tag 102
!
address-family ipv4
exit-address-family
!
 

上に示すように、仮想ネットワークは、仮想ネットワーク タグが割り当てられている VRF インスタンスとして定義されます。

vnet Global

ルータ上に「vnet global」と呼ばれる事前定義された EVN があります。これは、グローバル ルーティング コンテキストを表し、デフォルトの RIB に対応します。図 2図 3 では、vnet global がルータを接続する黒線で表されています。vnet global はタグなしトラフィックを伝送します。デフォルトで、インターフェイスは vnet global に属します。さらに、vnet global は常にトランク インターフェイス上で実行します。vnet global はデフォルトのルーティング テーブルとも呼ばれます。

IPv6 トラフィックは vnet global でのみサポートされます。

エッジ インターフェイスと EVN トランク インターフェイス

ユーザ デバイスはレイヤ 2 スイッチ ポートに接続され、VLAN に割り当てられています。VLAN はレイヤ 2 VPN として考えることができます。お客様は、単一の VLAN の共通の L3VPN でサポートされる必要があるすべてのデバイスをグループ化します。VLAN と VRF 間でデータ トラフィックが処理されるポイントは エッジ インターフェイス と呼ばれます。

エッジ インターフェイスはユーザ デバイスを EVN に接続し、事実上、EVN の境界を定義します。エッジ インターフェイスは VRF 対応でないホストやサーバなどのデバイスを接続します。エッジ インターフェイス経由で伝送されるトラフィックはタグが付けられません。エッジ インターフェイスは、受信したトラフィックが属する EVN を分類します。各エッジ インターフェイスは、1 つだけの EVN に属するように設定されます。

EVN トランク インターフェイスは、VRF 対応ルータ同士を接続し、コアに、複数の EVN のトラフィックを転送するための手段を提供します。トランク インターフェイスはタグ付きトラフィックを伝送します。タグは、対応する EVN へのパケットの多重化を解除するために使われます。トランク インターフェイスには、EVN ごとに 1 つずつサブインターフェイスがあります。インターフェイスは vnet trunk コマンドによって、EVN トランク インターフェイスとして定義されます。

EVN インターフェイスは、エッジ インターフェイスとトランク インターフェイスの 2 種類のインターフェイスを使用します。インターフェイスはエッジ インターフェイスまたはトランク インターフェイスのいずれかで、両方にはなりません。図 3 に VRF Red に属するエッジ インターフェイスがある Router A と D を示します。Router D および E には VRF Green に属するエッジ インターフェイスがあります。

Router B、C、D、F、G には EVN コアを構成するトランク インターフェイスがあります。これらの 5 台のルータは VRF Red と VRF Green の両方に属するインターフェイスがあります。

図 3 EVN のエッジインターフェイスとトランク インターフェイス

 

仮想ネットワーク サブインターフェイスと出力でトランク インターフェイスを識別するための表記

トランク インターフェイスは複数の EVN を伝送するため、トランク インターフェイス名を表示するだけでは十分でない場合があります。出力がトランク インターフェイス上で実行する特定の EVN に含まれることを示す必要がある場合、使用する表記は、ピリオドと仮想ネットワーク タグを追加して、< interface >.< virtual-network-tag > の形式になります。例は、gigabitethernet1/1/1.101 や gigabitethernet1/1/1.102 のようになります。

デフォルトで、トランク インターフェイスが設定されると、すべての EVN と関連付けられた仮想ネットワーク タグが設定され、仮想ネットワーク サブインターフェイスが自動的に作成されます。上記のように、ピリオドと仮想ネットワーク タグ番号がインターフェイス番号に追加されます。

次の例では、VRF red が仮想ネットワーク タグ 3 で定義されています。従って、システムにより、ファスト イーサネット 0/0/0.3(VRF red の)が作成されました。

Router# show running-config vrf red
 
Building configuration...
 
Current configuration : 1072 bytes
vrf definition red
vnet tag 3
!
address-family ipv4
exit-address-family
!

この非表示インターフェイスは show derived-config コマンドで表示でき、ファスト イーサネット 0/0/0 に入力されたすべてのコマンドが、ファスト イーサネット 0/0/0.3 に継承されていることがわかります。

Router# show derived-config interface fastethernet0/0/0.3
 
 
Derived configuration : 478 bytes
!
interface FastEthernet0/0/0.3
description Subinterface for VRF NG red
vrf forwarding red
encapsulation dot1Q 3
ip address 10.1.1.1 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 x
ip bandwidth-percent eigrp 1 3
ip hello-interval eigrp 1 6
ip hold-time eigrp 1 18
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip summary-address eigrp 1 10.0.0.0 255.0.0.0
end

トランク インターフェイスの単一の IP アドレス

トランク インターフェイスは複数の EVN にトラフィックを伝送できます。設定プロセスを簡単にするため、すべてのサブインターフェイスと関連付けられた EVN には同じ IP アドレスが割り当てられます。言い換えると、トランク インターフェイスは、異なる EVN コンテキストで、同じ IP アドレスによって識別されます。これは、各 EVN が一意のルーティングおよびフォワーディング テーブルを持つため、複数の EVN で重複する IP アドレスをサポートできる結果として実現されています。

定義されている VRF とトランク インターフェイス上で実行する VRF 間の関係

デフォルトで、ルータ上のトランク インターフェイスは、 vrf definition コマンドで定義された すべての VRF にトラフィックを伝送します。たとえば、次の構成では、ルータに定義されたすべての VRF がこのインターフェイスに含まれています。

interface FastEthernet 1/0/0
vnet trunk
ip address 10.1.1.1 255.255.255.0
 

ただし、トラフィック分割の目的で、特定のトランク インターフェイス上で VRF のサブセットのみを有効にしたい場合があります。これを実現するには、VRF リストを作成します。このリストは vnet trunk コマンドで参照されます。VRF リストでトランク インターフェイスを有効にすると、リスト上の VRF のみがインターフェイスで有効になります。例外として、 vnet global はトランク インターフェイスで常に有効にされます。

次の例では、リストに指定された 2 つの VRF(red と green)のみがこのインターフェイスで有効にされます。

vrf list mylist
member red
member green
!
interface FastEthernet 1/0/0
vnet trunk list mylist
ip address 10.1.1.1 255.255.255.0

VRF 認識

仮想ネットワークに接続されたデバイスが仮想ネットワーク タグを理解できず、タグなしトラフィックしか送受信できないことがあります。そのようなデバイスは VRF 認識不能と呼ばれます。たとえば、ラップトップ コンピュータは通常 VRF 認識不能です。

逆に、タグ付きトラフィックを送受信でき、そうしたトラフィックを処理する時にタグ値を考慮するデバイスは、VRF 認識と呼ばれます。たとえば、異なる EVN 間で共有されている VRF 対応サーバは、仮想ネットワーク タグを使用して、受信した要求を区別し、それに従って応答を送信します。VRF 認識デバイスは、図 4 に示すように、トランク インターフェイスを使用して、EVN に接続されます。

図 4 VRF 認識サーバ

 

「VRF 認識」という用語は、ルータで実行するソフトウェア コンポーネントを説明するためにも使うことができます。ソフトウェア コンポーネントは異なる EVN 上で動作できる場合、VRF 認識です。たとえば、ping は、ping パケットを送信する EVN を選択できるため、VRF 認識です。

EVN でサポートされるルーティング プロトコル

各 EVN はルーティング プロトコルの個別のインスタンスを実行します。これにより、EVN ごとにルーティングを個別に微調整することが可能になり、運命共同体的な事態の発生を抑えることができます。異なる仮想ネットワークで異なるルーティング プロトコルを同時に実行できます。

EVN は、ユニキャスト ルーティングの場合に、スタティック ルート、OSPFv2、および EIGRP をサポートし、マルチキャスト ルーティングの場合に、PIM、MSDP、および IGMP をサポートします。

仮想ネットワークのパケット フロー

パケットは、エッジ インターフェイスを通って EVN に入り、複数のトランク インターフェイスを通過して、別のエッジ インターフェイスから仮想ネットワークを出ます。入力エッジ インターフェイスでは、パケットが VLAN から特定の EVN にマッピングされます。パケットは、EVN にマッピングされると、関連付けられた仮想ネットワーク タグでタグ付けされます。仮想ネットワーク タグにより、トランク インターフェイスは複数の EVN にパケットを伝送できます。パケットは、出力エッジ インターフェイスを通って EVN を出るまで、タグが付けられたままになります。

エッジ インターフェイスでは、インターフェイスに関連付けられている EVN がルートのルックアップに使用されます。トランク インターフェイスで、パケットで伝送された仮想ネットワーク タグが使われ、パケットをルーティングするための対応する EVN が検索されます。

出力インターフェイスがエッジ インターフェイスの場合、パケットはタグが外されて転送されます。ただし、出力インターフェイスがトランク インターフェイスの場合、パケットは入力 EVN のタグが付けられて転送されます。

図 5 に、red と green の 2 つの VRF からのトラフィックが、タグ 101 と 102 を使用して、同じ IP インフラストラクチャ上で共存できる状況を示します。

図 5 仮想ネットワークのパケット フロー

 

VRF red の Laptop 1 から Server 1 へのパケット フローは次のようになります。

1. Laptop 1 がタグなしパケットを Server 1 に送信します。

2. Router A はエッジ インターフェイス上でパケットを受信し、これは VRF red に関連付けられています。

a. Router A は VRF red でルート ルックアップを実行し、次のホップがトランク インターフェイスから Router B であることがわかります。

b. Router A は VRF red のタグ(101)でパケットをカプセル化し、それをトランク インターフェイス上で送信します。

3. Router B はトランク インターフェイス上でパケットを受信します。Router B は仮想ネットワーク タグ 101 を確認して、そのパケットが VRF red に属することを識別します。

a. Router B は VRF red でルート ルックアップを実行し、次のホップがトランク インターフェイスから Router C であることがわかります。

b. Router B は VRF red のタグ(101)でパケットをカプセル化し、それをトランク インターフェイス上で送信します。

4. Router C はトランク インターフェイス上でパケットを受信します。Router C は仮想ネットワーク タグ 101 を使用して、そのパケットが VRF red に属することを識別します。

a. Router C は VRF red でルート ルックアップを実行し、次のホップがトランク インターフェイスから Router D であることがわかります。

b. Router C は VRF red のタグ(101)でパケットをカプセル化し、それをトランク インターフェイス上で送信します。

5. Router D はトランク インターフェイス上でパケットを受信します。Router D は仮想ネットワーク タグ 101 を使用して、そのパケットが VRF red に属することを識別します。

a. Router D は VRF red でルート ルックアップを実行し、次のホップがエッジ インターフェイスからわかります。

b. Router D は、エッジ インターフェイス上でタグなしパケットを Server 1 に送信します。

6. Server 1 は Laptop 1 から発信されたタグなしパケットを受信します。

EVN トランク インターフェイスでのコマンド継承

EVN トランク インターフェイスは、別々の EVN の設定要件が単一のトランク インターフェイス上で類似するという事実を利用します。トランク インターフェイスに設定された適格なコマンドは、同じインターフェイス上で実行するすべての EVN に継承されます。たとえば、OSPF hello interval は、次のように 1 行の設定で、トランク インターフェイス上のすべての EVN に設定できます。

interface gigabitethernet1/1/1
vnet trunk
ip address 10.1.2.1 255.255.255.0
! set OSPF hello interval for all VRFs on this interface.
ip ospf hello-interval 20
 

同じインターフェイス上で実行するすべての EVN によって継承可能な、トランク インターフェイス上に設定されるコマンドのリストについては、「 Configuring Easy Virtual Networks 」モジュールで説明しています。

コマンド継承のその他の例については、「 Configuring Easy Virtual Networks 」モジュールの設定例を参照してください。

コマンド継承の上書き:仮想ネットワーク インターフェイス モード

同じトランク インターフェイス上の一部の EVN の設定を変えたい場合があります。その場合、仮想ネットワーク インターフェイス モードを使用して、特定の EVN の設定を行い、これにより、継承を上書きします。特定のインターフェイス コマンド(すべてのコマンドではない)は、VRF 単位で上書きできます。

インターフェイス コンフィギュレーション モードから、 vnet name コマンドを入力すると、システムが仮想ネットワーク インターフェイス モードになります。このモードのシステム プロンプトは Router(config-if-vnet)# です。

次の例では、VRF blue の 30 のコストでインターフェイス上の他の VRF の 20 のコストを上書きします。

interface gigabitethernet 2/0/0
vnet trunk
ip address 10.1.1.1 255.255.255.0
! Set OSPF cost for all VRFs on this interface to 20.
ip ospf cost 20
vnet name blue
description Subinterface for VRF NG blue
! Set OSPF cost for blue to 30.
ip ospf cost 30
 

show derived コマンドで、30 のコストに変更されたサブインターフェイスが示されます。

Router(config-if-vnet)# do show derived | s interface GigabitEthernet2/0/0

interface GigabitEthernet2/0/0
vnet trunk
ip address 10.1.1.1 255.255.255.0
ip ospf cost 20
interface GigabitEthernet2/0/0.200
description Subinterface for VRF NG blue
vrf forwarding blue
ip address 10.1.1.1 255.255.255.0
ip ospf cost 30
Router(config-if-vnet)#

vnet Global のみへのアトリビュートの適用

同様に、vnet global のみにアトリビュートを有効にしたい場合があります。これを実行するには、次のように、 vnet global インターフェイス サブモードを使用します。

interface gigabitethernet1/1/1
vnet trunk
ip address 10.1.2.1 255.255.255.0
vnet global
! Set OSPF cost for global to 40.
ip ospf cost 40
 

この例では、ユーザは vnet global を除くすべての EVN に EIGRP インターフェイス アトリビュートを設定しようとしています。vnet global を除いて、すべての EVN は 20 秒の保留時間を継承します。vnet global は 20 秒の保留時間が 40 秒で上書きされます。

interface fastethernet 1/0/0
vnet trunk
ip address 10.1.3.1 255.255.255.0
ip hold-time eigrp 1 20
vnet global
ip hold-time eigrp 1 40

上書きの削除と継承される値の復元

no キーワードと default キーワードは、それらをトランク インターフェイスに使うか、仮想ネットワーク インターフェイス モードで使うかによって、結果が異なります。

トランク インターフェイス上でコマンドの前に、 no キーワードまたは default キーワードを入力すると、トランクがそのコマンドのシステムのデフォルト値に復元されます(これは、 no または default キーワードの標準の動作結果です)。

仮想ネットワーク インターフェイス モードで、コマンドの前に default キーワードを入力すると、上書き値が削除され、 トランクから継承された値 が復元されます。特定の EVN の上書き値が無効になります。

次の例では、20 の OSPF コストでトランク インターフェイスが構成されますが、VRF blue により、その値が 30 の OSPF コストで上書きされます。

 
interface gigabitethernet 2/0/0
vnet trunk
ip address 10.1.1.1 255.255.255.0
! Set OSPF cost for all VRFs on this interface to 20.
ip ospf cost 20
vnet name blue
! Set OSPF cost for blue to 30.
ip ospf cost 30

 

次のコマンドが入力された場合、OSPF コスト値が、トランク インターフェイスから継承されたコストである 20 に復元されます(20 は ip ospf cost コマンドのデフォルト値ではないことに注意してください)。

Router(config-if)# vnet name blue
Router(config-if-vnet)# default ip ospf cost

 

仮想ネットワーク インターフェイス モードでコマンドの前に default キーワードを入力すると、デフォルトの状態に復元されますが、 no キーワードでは、必ずそうなるとは限りません。次の例で、 no ip dampening-change eigrp 1 はダンプニングの変更を無効にします。

interface Ethernet1/1
vnet trunk
ip dampening-change eigrp 1 50
shutdown
vnet name red
no ip dampening-change eigrp 1
! Make sure vnet red does NOT have dampening change enabled, regardless of trunk setting. !
 

コマンドが機能のオンとオフを切り替える種類である場合、コマンドの no 形式がコンフィギュレーション ファイルに表示されます。つまり、NVGEN 処理されて、トランクからの設定が上書きされます。次に例を示します。

interface gigabitethernet 2/0/0
vnet trunk
ip access-group 1 in
vnet name red
no ip pim sparse-mode
no ip route-cache cef
no ip access-group in
vnet global
ip ospf cost 100
 

コマンドがその構文で ip ospf cost cost などの引数をとる場合、コマンドの no 形式によって、設定が削除されますが、コンフィギュレーション ファイルには表示されません。つまり、ユーザは ip ospf cost default-value を入力して、より直接的な方法で継承された値を上書きできるため、NVGEN 処理されません。

EXEC ルーティング コンテキスト

複数の EXEC コマンドを発行して、単一の EVN に適用したい場合があります。複数の EXEC コマンドに VRF 名を入力する回数を減らすため、 routing-context vrf コマンドを使用して、それらの EXEC コマンドの VRF コンテキストを 1 回設定してから、EXEC コマンドに進みます。

表 1 は、ルーティング コンテキストの有無で、Cisco IOS の 4 つの EXEC コマンドを対比させています。左の列では、各 EXEC コマンドで VRF を識別する必要があることに注意してください。右の列では、VRF コンテンツが 1 回で識別され、プロンプトがその VRF を反映して変更されるため、コマンドごとに VRF を識別する必要はありません。

 

表 1 ルーティング コンテキストでの EXEC コマンド

ルーティング コンテキストのない Cisco IOS CLI
ルーティング コンテキスト

--

Router# routing-context vrf red
 

Router%red#

Router# show ip route vrf red
 

[VRF red のルーティング テーブル出力]

Router%red# show ip route
 

[VRF red のルーティング テーブル出力]

Router# ping vrf red 10.1.1.1
 

[VRF red を使用した ping 結果]

Router%red# ping 10.1.1.1
 

[VRF red を使用した ping 結果]

Router# telnet 10.1.1.1 /vrf red
 

[VRF red の 10.1.1.1 への Telnet]

Router%red# telnet 10.1.1.1
 

[VRF red の 10.1.1.1 への Telnet]

Router# traceroute vrf red 10.1.1.1
 

[VRF red の Traceroute 出力]

Router%red# traceroute 10.1.1.1
 

[VRF red の Traceroute 出力]

EVN の VRF-Lite との互換性

EVN は VRF-Lite と密接な互換性があります。言い換えると、ボックス以外で、802.1q の使用、SNMP MIB、およびすべてのインフラストラクチャが VRF-Lite とまったく同じように見えます。

図 6 では、両方のルータに VRF が定義されています。左側のルータは VRF-Lite を使用し、右側のルータはタグ付きの EVN トランクを使用します。2 つの構成を図に示します。

図 6 VRF-Lite と EVN トランクの互換性

VRF-Lite サブインターフェイスの設定 EVN トランクの設定

interface TenGigabitEthernet1/1/1 interface TenGigabitEthernet 1/1/1
ip address 10.122.5.31 255.255.255.254 vnet trunk
ip pim query-interval 333 msec ip address 10.122.5.32 255.255.255.254
ip pim sparse-mode pim sparse-mode
logging event link-status logging event link-status
 
interface TenGigabitEthernet1/1/1.101 Global Configuration:
description Subinterface for Red VRF vrf definition red
encapsulation dot1Q 101 vnet tag 101
ip vrf forwarding Red
ip address 10.122.5.31 255.255.255.254 vrf definition green
ip pim query-interval 333 msec vnet tag 102
ip pim sparse-mode
logging event subif-link-status
 
interface TenGigabitEthernet1/1/1.102
description Subinterface for Green VRF
encapsulation dot1Q 102
ip vrf forwarding Green
ip address 10.122.5.31 255.255.255.254
ip pim query-interval 333 msec
ip pim sparse-mode
logging event subif-link-status

マルチアドレス ファミリ VRF 構造

Cisco IOS Release 12.2(33)SB および 15.0(1)M 以前では、VRF の CLI は一度に 1 つのアドレス ファミリにのみ適用できました。たとえば、次のコマンドは IPv4 アドレス ファミリにのみ適用されます。

ip vrf blue

Cisco IOS Release 12.2(33)SB および 15.0(1)M では、VRF の CLI は同じ VRF 下の複数のアドレス ファミリに適用されます。これは、マルチプロトコル VRF と呼ばれます。たとえば、次のコマンドは IPv4 VPN と IPv6 VPN に同時に適用されます。2 つのプロトコルのルーティング テーブルは異なります。

vrf definition blue


) Cisco IOS XE Release 3.2S で、仮想ネットワークは、vnet global を除いて、IPv6 をサポートしません。


参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

Easy Virtual Network コマンド

Easy Virtual Network Command Reference

Easy Virtual Network の設定

「Configuring Easy Virtual Network」

Easy Virtual Network 共有サービスとルート レプリケーションの設定

「Configuring Easy Virtual Network Shared Services」

Easy Virtual Network の管理とトラブルシューティング

「Easy Virtual Network Management and Troubleshooting」

MIB

MIB
MIB リンク

VRF 情報を提供する MIB は引き続き Easy Virtual Network で動作します。システムのすべての VRF に関する VRF 独立 MIB のレポート情報:

CISCO--VRF-MIB

CISCO--MVPN-MIB

MPLS-VPN MIB

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

Easy Virtual Network の概要の機能情報

表 2 に、この機能のリリース履歴を示します。

表 2 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連のソフトウェア リリースの以降のリリースでもサポートされます。


 

表 2 Easy Virtual Network の概要の機能情報

機能名
リリース
機能情報

Easy Virtual Network トランク

Cisco IOS Release XE 3.2S

Easy Virtual Network は、ネットワークのエンドツーエンドの仮想化を実現する IP ベースの仮想化テクノロジーです。単一の IP インフラストラクチャを使用して、トラフィック パスが相互に独立した状態で、個別の仮想ネットワークを提供できます。