Cisco IOS インターフェイスおよびハードウェア コ ンポーネント コンフィギュレーション ガイド
トンネルの実装
トンネルの実装
発行日;2012/01/31 | 英語版ドキュメント(2011/08/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

トンネルの実装

このモジュールで紹介する機能情報の入手方法

この章の構成

トンネル実装の前提条件

トンネル実装の制約事項

トンネル実装に関する情報

トンネリングとカプセル化

OSI レイヤによるトンネリング タイプの定義

トンネリングの利点

Tunnel ToS(ToS)

モバイル IP トンネリング

総称ルーティング カプセル化

GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ

マルチポイント GRE トンネリング

IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート

IPv6 トラフィックに対する GRE/IPv4 トンネルのサポート

IPv6 向けオーバーレイ トンネル

手動設定された IPv6 トンネル

自動 6to4 トンネル

自動 IPv4 互換 IPv6 トンネル

ISATAP トンネル

Rate-Based Satellite Control Protocol トンネル

Path MTU Discovery(PMTUD)

トンネル用 Quality of Service(QoS)オプション

トンネルの実装方法

トンネル タイプの決定

この次の手順

GRE トンネルの設定

GRE トンネル キープアライブ

前提条件

制約事項

この次の手順

GRE/IPv6 トンネルの設定

前提条件

この次の手順

GRE トンネル IP 送信元および宛先 VRF メンバシップの設定

GRE トンネル IP 送信元および宛先 VRF メンバシップの制約事項

この次の手順

CTunnel の設定

CTunnel

トラブルシューティングのヒント

この次の手順

IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定

CLNS ネットワークを経由する IPv4 および IPv6 パケット用トンネル

前提条件

制約事項

この次の手順

手動 IPv6 トンネルの設定

前提条件

この次の手順

6to4 トンネルの設定

前提条件

制約事項

この次の手順

IPv4 互換 IPv6 トンネルの設定

前提条件

制約事項

この次の手順

ISATAP トンネルの設定

前提条件

この次の手順

RBSCP トンネルの設定

前提条件

制約事項

この次の手順

トンネルの設定と動作の確認

RBSCP トンネルの設定と動作の確認

RBSCP トンネルがアクティブであるかの確認

RBSCP トラフィックの確認

トンネル実装の設定例

GRE/IPv4 トンネルの設定:例

GRE/IPv6 トンネルの設定:例

GRE トンネルの IP 送信元と宛先 VRF メンバシップの設定:例

IP だけのバックボーンにおける 2 つの AppleTalk ネットワークのルーティング:例

パブリック サービス プロバイダーでのプライベート IP ネットワークおよび Novell ネットワークのルーティング:例

CTunnel の設定:例

IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定:例

手動 IPv6 トンネルの設定:例

6to4 トンネルの設定:例

IPv4 互換 IPv6 トンネルの設定:例

ISATAP トンネルの設定:例

RBSCP トンネルの設定例

RBSCP トンネルのルーティングの設定例

トンネル インターフェイスでの QoS オプションの設定:例

関連情報

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

トンネル実装の機能情報

トンネルの実装

このモジュールでは、Cisco IOS ソフトウェアで使用可能なさまざまなタイプのトンネリング技術について説明します。物理インターフェイスまたは仮想インターフェイスを使用するトンネル タイプについて、設定の詳細や設定例を示しています。テクノロジー固有のコマンドを使用して多数のトンネリング技術が実装されており、テクノロジーに関して対応するモジュールへのリンクが示されています。

トンネリングを使用すると、トランスポート プロトコル内部の任意のパケットをカプセル化できます。トンネルは、仮想インターフェイスとして実装され、簡単なインターフェイスを設定できるようになっています。トンネル インターフェイスは、特定の "passenger" プロトコルまたは "transport" プロトコルには関連付けられていませんが、任意の標準的な point-to-point(p2p; ポイントツーポイント)カプセル化スキームの実装に必要なサービスが提供されるように設計された、アーキテクチャです。

このモジュールで紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、このモジュールに記載されている機能の一部がサポートされていない場合があります。このモジュールに記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「トンネル実装の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスしてください。Cisco.com のアカウントは必要ありません。

トンネル実装の前提条件

このモジュールでは、Cisco IOS Release 12.2 以降が実行されていることを前提としています。

トンネル実装の制約事項

以前のバージョンの Cisco IOS ソフトウェアでサポートされるのは、プロセッサ スイッチングだけです。Cisco IOS リリース 11.1 では、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネルの高速スイッチングが導入されました。現在、IPv6 および他のトンネリング プロトコルでは Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)スイッチングも一般的に使用されています。

トンネル プロトコルがファイアウォールを通過でき、Access Control List(ACL; アクセス制御リスト)のチェックに合格できるようにすることが重要です。

トンネル インターフェイスで帯域幅が正しく設定されていない場合、複数のポイントツーポイント トンネルがルーティング情報を使用して物理リンクを飽和させる可能性があります。

トンネルは 1 つのホップに似ており、ルーティング プロトコルはマルチホップ物理パスを経由するトンネルを優先することがあります。ただしこのことは、トンネルが、1 つのホップに似ているとはいえ、マルチホップ リンクよりもスピードの遅いパスを通過する場合があるため、誤りを招くおそれがあります。トンネルは、実際に通過するリンクと同様に堅牢で高速であったり、信頼性が低く低速であったりします。ホップ カウントのみに基づいて決定を行うルーティング プロトコルは、しばしば物理リンクのセットを経由するトンネルを優先します。トンネルは、1 つのホップのポイントツーポイント リンクで、パスのコストが最も低いように思われますが、遅延の観点から見ると実際には代替物理トポロジよりもコストがかかる場合があります。

たとえば、図 1 に示すトポロジでは、ホスト 1 からのパケットは、w、x、y、z の 4 つのパスを使用する代わりに、トンネルのホップ カウントがより短いと思われるネットワーク w、t、および z を通過してホスト 2 へ送信されると考えられます。ただし実際には、トンネルを通って送信されるパケットは、ルータ A、B、C を通過して、さらにルータ D まで移動してからルータ C に戻る必要があります。

図 1 トンネルに関する注意事項:ホップ カウント

 

ルーティングを慎重に設定しなければ、トンネルでは再帰ルーティングの問題が発生する場合があります。「トンネル宛先」に最も適したパスがトンネル自体を経由するパスの場合、再帰ルーティングによってトンネル インターフェイスがフラップします。再帰ルーティングの問題を回避するには、次の方法を使用して、常にコントロール プレーン ルーティングをトンネル ルーティングとは個別にします。

異なる自律システム番号またはタグを使用する。

異なるルーティング プロトコルを使用する。

スタティック ルートを使用して、最初のホップを無効にする(ただしルーティング ループに注意)。

トンネル宛先に対して再帰ルーティングを行った場合、次のエラー メッセージが表示されます。

%TUN-RECURDOWN Interface Tunnel 0
temporarily disabled due to recursive routing

トンネル実装に関する情報

トンネルを設定するには、次の概念を理解する必要があります。

「トンネリングとカプセル化」

「OSI レイヤによるトンネリング タイプの定義」

「トンネリングの利点」

「Tunnel ToS(ToS)」

「モバイル IP トンネリング」

「総称ルーティング カプセル化」

「GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ」

「マルチポイント GRE トンネリング」

「IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート」

「IPv6 トラフィックに対する GRE/IPv4 トンネルのサポート」

「IPv6 向けオーバーレイ トンネル」

「手動設定された IPv6 トンネル」

「自動 6to4 トンネル」

「自動 IPv4 互換 IPv6 トンネル」

「ISATAP トンネル」

「Rate-Based Satellite Control Protocol トンネル」

「Path MTU Discovery(PMTUD)」

「トンネル用 Quality of Service(QoS)オプション」

トンネリングとカプセル化

トンネルの動作のしくみについて理解するには、カプセル化とトンネリングのそれぞれの概念を区別することが重要です。カプセル化は、特定のプロトコル スタックの各レイヤでデータにヘッダーを追加するプロセスです。Open Systems Interconnection(OSI; オープン システム インターコネクション)のリファレンス モデルは、それぞれのレイヤの上にレイヤが積み重なった 7 つのレイヤとしてネットワークの機能を説明しています。データをあるネットワーク上のホスト(PC など)から別のホストへ送信する場合、カプセル化のプロセスを使用して、降順に並んでいるプロトコル スタックの各レイヤのデータの先頭にヘッダーが追加されます。ヘッダーには、現在のレイヤのすぐ上にあるレイヤでカプセル化されているデータのタイプを示すデータ フィールドが含まれていることが必要です。ネットワークの受信側でパケットがプロトコル スタックを上っていくと、カプセル化された各ヘッダーは逆順に削除されます。

トンネリングでは、別のプロトコル内にある 1 つのプロトコルからのデータ パケットをカプセル化し、データ パケットを変更しない状態で外部ネットワークを通じて送信します。トンネリングは、カプセル化と異なり、より低いレイヤのプロトコルまたは同じレベルのレイヤのプロトコルが、トンネルを通って送信されるようにします。トンネル インターフェイスは仮想(または論理)インターフェイスです。他のタイプの仮想インターフェイスの詳細については、「Configuring Virtual Interfaces」のモジュールを参照してください。さまざまなネットワークの問題を解決するためさまざまなタイプのトンネルがこれまで作成されてきていますが、トンネリングは次の 3 つの主要コンポーネントで構成されます。

パッセンジャ プロトコル:カプセル化の対象となるプロトコル。パッセンジャ プロトコルの例として、AppleTalk、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)、IP、および IPX があります。

キャリア プロトコル:カプセル化を実行するプロトコル。キャリア プロトコルの例として、GRE、IP-in-IP、L2TP、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)、STUN、および DLSw+ があります。

トランスポート プロトコル:カプセル化したプロトコルを伝送するために使用するプロトコル。主なトランスポート プロトコルは IP です。

図 2 IP トンネリングの用語と概念を示します。

図 2 IP トンネリングの用語と概念

 

 

トンネリングのプロセスを理解するため、2 つの AppleTalk ネットワークを非 AppleTalk バックボーン(IP など)を使用して接続する例を考えてみます。Routing Table Maintenance Protocol(RTMP; ルーティング テーブル メンテナンス プロトコル)のデータ パケットのブロードキャストによって使用される比較的高い帯域幅により、バックボーンのネットワーク パフォーマンスが大きく阻害されるおそれがあります。この問題は、IP などの外部プロトコルを通じて AppleTalk のトンネリングを行うことで解決できます。トンネリングにより、外部プロトコル パケット内の AppleTalk パケット(IP 内の GRE 内の AppleTalk)がカプセル化され、続いてバックボーンを通過して宛先ルータへ送信されます。宛先ルータは、AppleTalk パケットからカプセル化を削除し、パケットのルーティングを行います。

OSI レイヤによるトンネリング タイプの定義

トンネルは、さまざまなネットワークの課題を解決するために多数の異なるテクノロジーで使用されており、その結果多様なトンネル タイプが作成されたため、どのトンネリング技術を使用すべきかを決定することが困難になっています。OSI レイヤ モデルに従うことで、さまざまなキャリア プロトコルを分類できます。 表 1 に、OSI レイヤによって分類されるさまざまなキャリア プロトコルを示します。表に続いて、各キャリア プロトコルの定義を示します。このモジュールで言及されていないトンネル設定については、対応するモジュールへのリンクが示されています。

 

表 1 OSI レイヤごとのキャリア プロトコル

レイヤ
キャリア プロトコル

2

PPPoA:Point-to-Point Protocol(PPP)over ATM

PPPoE:PPP over Ethernet

UDLR:Unidirectional link routing

3

BSTUN:Block Serial Tunneling

CLNS:Connectionless Network Service

GRE:Generic Routing Encapsulation

IP-in-IP:Internet Protocol encapsulated within IP

IPsec:IP Security

IPv6:IP version 6

L2F:Layer 2 Forwarding

L2TP:Layer 2 Tunneling Protocol

MPLS:Multiprotocol Label Switching

PPTP:Point-to-Point Tunneling Protocol

STUN:Serial Tunneling

4

DLSw+:Data-link switching plus

RBSCP:Rate-Based Satellite Control Protocol

SSL:Secure Socket Layer

BSTUN

Block Serial Tunnel(BSTUN; ブロック シリアル トンネル)により、Bisync データリンク プロトコルを使用してデバイスのサポートがイネーブルになります。このプロトコルにより、企業は Systems Network Architecture(SNA; システム ネットワーク アーキテクチャ)とマルチプロトコル トラフィックをサポートする同一ネットワーク上で Bisync トラフィックを転送でき、個別の Bisync ファシリティの必要性を排除します。

BSTUN の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Serial Tunnel and Block Serial Tunnel」の章を参照してください。

CLNS

ISO コネクションレス型ネットワーク サービス(CLNS)プロトコルは、OSI モデルのネットワーク層の標準です。IP トラフィックは CLNS を通じて転送できます。たとえば、SONET リングの Data Communications Channel(DCC; データ通信チャネル)などです。IP over CLNS tunnel(CTunnel)は、CLNS ネットワークとのインタラクションを強化した仮想インターフェイスで、これにより IP パケットを コネクションレス型ネットワーク プロトコル(CLNP)を通じてトンネリングし、TCP/IP サービスを保持できます。また CLNS を、キャリア プロトコルとしての GRE とともにトランスポート プロトコルとして使用して(GRE/CLNS)、IPv4 および IPv6 パケットの両方を伝送できます。

DLSw+

Data-Link Switching plus (DLSw+)は、システム ネットワーク アーキテクチャ(SNA)および NetBIOS デバイス向けの DLSw 標準をシスコが実装したもので、いくつかの追加機能と拡張機能をサポートしています。DLSw+ は、キャンパスまたは WAN を介して SNA および NetBIOS トラフィックを転送する手段です。エンド システムは、トークンリング、イーサネット、Synchronous Data Link Control(SDLC; 同期データ リンク制御)、Qualified Logical Link Control(QLLC)または Fiber Distributed Data Interface(FDDI)を介してネットワークに接続できます。DLSw+ はさまざまなメディア間で切り替わってローカルでデータ リンクを終端し、確認応答やキープアライブを保持し、WAN をポーリング オフします。

DLSw+ の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Data-Link Switching Plus」の章を参照してください。

GRE

総称ルーティング カプセル化(GRE)は RFC 2784 で定義されています。GRE はキャリア プロトコルで、基礎となるさまざまなトランスポート プロトコルと併用でき、多様なパッセンジャ プロトコルを伝送できます。また RFC 2784 では、トランスポート プロトコルとパッセンジャ プロトコルとして、GRE と IPv4 の併用もカバーしています。シスコ IOS ソフトウェアは、GRE を、パッセンジャ プロトコルおよびトランスポート プロトコルの多数の組み合わせとともに使用するキャリア プロトコルとしてサポートしています。

GRE の詳細については、「総称ルーティング カプセル化」を参照してください。

IP-in-IP

IP-in-IP は、RFC 2003 で定義されているレイヤ 3 のトンネリング プロトコルで、別の IP ヘッダー内で IP パケットをカプセル化することによりその IP パケットの通常ルーティングを変更します。カプセル化を行うヘッダーは、パケットの実際の宛先アドレスに基づいて、ネクストホップ ルータとしては通常選択されないルータのアドレスを指定します。パケットは中継ノードによってカプセル化が解除され、その後通常どおり宛先へルーティングされます。

IPSec

簡単に言えば、IP Security(IPSec; IP セキュリティ)によって、2 つのピア(2 つのルータなど)間のセキュアなトンネルが提供されます。機密性が高く、セキュア トンネルを介して送信する必要があるパケットを定義し、セキュア トンネルの特性を指定することによって、これらのパケットを保護するために使用するパラメータを定義します。IPSec ピアはセキュアなトンネルを設定し、このトンネルを通過するパケットを暗号化してリモート ピアに送信します。

また IPSec は GRE および IP-in-IP、L2F、L2TP、DLSw+ トンネリング プロトコルとも連動しますが、マルチポイント トンネルはサポートされません。他のレイヤ 3 のトンネリング プロトコルと IPSec の併用はサポートされない場合があります。

IPSec の設定の詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Security for VPNs with IPSec」の章を参照してください。

IPv6

IP バージョン 6(IPv6)は、IP バージョン 4 に基づく新しいバージョンで、IP バージョン 4 の後継バージョンとして設計されています。IPv6 では、はるかに大きいアドレス空間(128 ビット)と改善機能(メイン ヘッダーや拡張ヘッダーの簡略化など)が追加されています。IPv6 は最初、RFC 2460 の「 Internet Protocol, Version 6 (IPv6) 」に記述されていました。IPv6 のキャリア プロトコルとしての使用は、RFC 2473 の「 Generic Packet Tunneling in IPv6 Specification 」に記述されています。

L2F

Layer 2 Forwarding(L2F; レイヤ 2 転送)トンネリングは、Virtual Private Dial-up Network(VPDN; 仮想プライベート ダイヤルアップ ネットワーク)で使用されます。VPDN により、個別の自律プロトコル ドメインが共通のアクセス インフラストラクチャ(モデム、アクセス サーバ、ISDN ルータ)をリンク レベル(レイヤ 2)フレームのトンネリングによって共有できます。通常の L2F トンネリングを使用する際は、リモート カスタマー サイトまたはリモート ユーザへ企業イントラネットまたはエクストラネット ネットワークを使用してリンクするための仮想トンネルを作成する Internet Service Provider(ISP; インターネット サービス プロバイダー)または、他のアクセス サービスが含まれます。

L2TP

Layer 2 Tunneling Protocol(L2TP; レイヤ 2 トンネリング プロトコル)は、L2F および Point-to-Point Tunneling Protocol(PPTP)の最良の機能を使用する Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)によって作成されたオープン規格です。L2TP は、管理されていない非信頼ネットワーク ドメインを通過する IP パケットの転送を保護するよう設計されており、Virtual Private Network(VPN; 仮想プライベート ネットワーク)の重要なコンポーネントです。VPN は、リモート アクセスを共有インフラストラクチャ上のユーザにまで拡張し、同時にプライベート ネットワークと同じセキュリティ ポリシーと管理ポリシーを維持します。

L2TP の設定の詳細については、『 Cisco IOS Dial Technologies Configuration Guide 』を参照してください。

MPLS

マルチプロトコル ラベル スイッチング(MPLS) は、高性能のパケット転送テクノロジーであり、データ リンク層(レイヤ 2)スイッチングのパフォーマンスおよびトラフィック管理機能と、ネットワーク層(レイヤ 3)ルーティングのスケーラビリティ、柔軟性、およびパフォーマンスが統合されています。MPLS アーキテクチャは、レイヤ 2 テクノロジーの任意の組み合わせを介したデータ転送、すべてのレイヤ 3 プロトコルのサポート、および拡張ができるよう設計されてきました。MPLS では、シスコ エクスプレス フォワーディング(CEF)を使用することで ATM スイッチド ネットワークを介して IP サービスを効率的に提供できるようにします。MPLS は、レイヤ 2 テクノロジーとレイヤ 3 テクノロジーを統合したものです。従来のレイヤ 2 機能をレイヤ 3 で使用可能にすることで、MPLS はトラフィック エンジニアリングを可能にしています。

MPLS トラフィック エンジニアリングによるトンネルの使用方法の詳細については、『 Cisco IOS Multiprotocol Label Switching Configuration Guide 』を参照してください。

PPPoA

PPP over ATM(PPPoA)は主に、Asymmetric Digital Subscriber Line(ADSL;デジタル加入者回線非対称デジタル加入者回線)の一部として実装されます。このプロトコルは RFC 1483 に依存しており、Logical Link Control-Subnetwork Access Protocol(LLC-SNAP)または VC-Mux モードのいずれかで動作します。Customer Premises Equipment(CPE; 宅内装置)デバイスは、この RFC に基づいて PPP セッションをカプセル化し、ADSL ループと Digital Subscriber Line Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)へ転送できるようにします。

PPPoE

RFC 2516 では、PPP over Ethernet(PPPoE)を、ホストのネットワークを単純なブリッジング アクセス デバイスを介してリモート アクセス コンセントレータまたはアグリゲーション コンセントレータ(加入者集約コンセントレータ)へ接続する機能を提供するプロトコルと定義しています。お客様が ADSL を展開する際、大容量でインストールされたレガシー ブリッジングを行う宅内装置(CPE)のベースを介して、PPP スタイルの認証および認可をサポートする必要があります。PPPoE は、トンネリングのカプセル化のフォームを使用することで、各ホストが独自の PPP を使用できるようにして、ユーザに使い慣れたユーザ インターフェイスで表示します。アクセス制御、課金、Type of Service(ToS; タイプ オブ サービス)は、サイト単位ではなく、ユーザ単位で行われます。

PPPoE の設定の詳細については、『 Cisco IOS Broadband Access Aggregation and DSL Configuration Guide 』を参照してください。

PPTP

Point-to-Point Tunneling Protocol(PPTP)は、TCP/IP データ ネットワークに VPN を作成することにより、リモート クライアント エンタープライズ サーバからのデータのセキュアな転送を可能にするネットワーク プロトコルです。PPTP は、インターネットなどのパブリック ネットワーク上で、オンデマンドのマルチプロトコル仮想プライベート ネットワークをサポートします。

RBSCP

Rate-Based Satellite Control Protocol(RBSCP)は、衛星リンクなどの、エラー レートが高い無線または長距離の遅延リンクのために設計されました。RBSCP では、トンネルを使用して、エンドツーエンド モデルを中断することなく衛星リンクを介して TCP および IP Security(IPSec)などの特定の IP プロトコルのパフォーマンスを改善できます。

SSL トンネル

Secure Socket Layer (SSL)は、TCP セッションを利用して、信頼性の高いエンドツーエンドのセキュアなサービスを提供することを目的として設計されています。SSL の主な役割は、Web トラフィックにセキュリティを提供することです。セキュリティには、機密保持、メッセージ整合性、および認証が含まれます。SSL は、暗号法、デジタル署名、および証明書の使用により、セキュリティに関するこれらの要素を実現します。SSL は暗号法を使用することで機密情報を保護します。機密データはパブリック ネットワークを介して暗号化され、機密保持レベルを達成します。

SSL は、Cisco Application and Content Networking System(ACNS)を使用して実装します。SSL の設定の詳細については、『 Cisco ACNS Software Deployment and Configuration Guide 』を参照してください。

STUN

シスコの Serial Tunneling(STUN)を実装することにより、同期データ リンク制御(SDLC)プロトコル デバイスおよび High-Level Data-Links Control(HDLC; 高レベル データ リンク制御)デバイスは、ダイレクト シリアル リンクを通じてではなく、マルチプロトコル インターネットワークを通じて互いに接続できます。STUN は、TCP/IP または HDLC プロトコルのいずれかで SDLC フレームをカプセル化します。STUN により、システム ネットワーク アーキテクチャ(SNA)デバイス間のエンドツーエンドに、すべての SDLC トラフィック(Receiver Ready などの制御フレームを含む)の直線的な通り道が提供されます。

STUN の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Serial Tunnel and Block Serial Tunnel」を参照してください。

UDLR トンネル

UniDirectional Link Routing(UDLR)では、物理的単一方向インターフェイス(ブロードキャスト衛星リンクなど)を介してユニキャスト パケットおよびマルチキャスト パケットのルーティングを可能にするためルータが双方向リンクをエミュレートするメカニズムが提供されます。ただし、物理的な UniDirectional Link(UDL)を共有するルータ間にバック チャネルまたはその他のパスが存在することが必要です。UDLR トンネルは、ユニキャスト トラフィックとマルチキャスト トラフィック向けのメカニズムで、Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)UDLR は、マルチキャスト トラフィック向けの関連テクノロジーです。

詳細については、『Cisco IOS IP Multicast Configuration Guide』を参照してください。

トンネリングの利点

トンネリング(別のプロトコルでのトラフィックのカプセル化)は、次のようないくつかの場合に、役に立ちます。

1 つのプロトコル バックボーンを介してマルチプロトコル ローカル ネットワークをイネーブルにする場合

たとえば、RIP バージョン 1、AppleTalk など、ホップ カウントが限定されているプロトコルが使用されているネットワークで、回避策を用意する場合(図 3を参照)

隣接していないサブネットワークを接続する場合

WAN を介して Virtual Private Network(VPN; 仮想プライベート ネットワーク)を使用できるようにする場合

図 3 ホップ カウントの制限によるネットワークへの回避策の提供

 

Tunnel ToS(ToS)

タイプ オブ サービス(ToS)により、ネットワーク トラフィックをトンネリングして、すべてのパケットを特定の同じ ToS バイト値に分類できます。ToS バイト値および Time-to-Live(TTL; 存続可能時間)のホップ カウント値は、ルータの IP トンネル インターフェイス向けのトンネル パケットのカプセル化 IP ヘッダーに設定できます。Tunnel ToS 機能は、シスコ エクスプレス フォワーディング(CEF)、ファスト スイッチング、およびプロセス スイッチングでサポートされます。

ToS および TTL バイト値は、RFC 791 で定義されています。RFC 791 に定義されているとおり、RFC 2474 および RFC 2780 では ToS バイトの使用を廃止しています。RFC 791 では、ToS バイトのビット 6 と 7(最初の 2 つの最下位ビット)は将来使用するために予約されており、0 に設定する必要があることが指定されています。現在、Tunnel ToS 機能はこの標準に準拠しておらず、ビット 6 と 7 を含む ToS バイト値全体を設定でき、お客様のパケットの ToS バイトがどの RFC 標準に準拠するかを決定できるようになっています。

モバイル IP トンネリング

新しいデバイスやビジネス プラクティス(PDA や次世代データ対応携帯電話およびサービスなど)は、ネットワーク接続を維持すると同時に、ユーザの移動能力への興味を駆り立てています。このユーザ グループに対するデータ接続ソリューションの要件は、固定のダイヤルアップ ユーザまたは固定型有線 LAN ユーザに対する要件とは大きく異なります。ソリューションに必要なのは、データ セッションまたは会話中に移動するという課題に対応することです。

モバイル IP は、シスコが作成した総称ルーティング カプセル化(GRE)トンネリング テクノロジーおよび単純な IP-in-IP トンネリング プロトコルを活用した、トンネリング ベースのソリューションです。

モバイル IP は、図 4 に示すとおり次の 3 つのコンポーネントで構成されます。

Mobile Node(MN; モバイル ノード)

Home Agent(HA)

Foreign Agent(FA)

図 4 モバイル IP のコンポーネントとトンネリングの使用

 

MN は、PDA、ラップトップ コンピュータ、またはデータ対応携帯電話などのノードで、あるネットワークまたはサブネットから別のネットワークまたはサブネットに接続ポイントを変更できます。このノードは、ホームの IP アドレスだけを使用しながら、現在の通信を維持できます。図 4 では、MN の現在の位置(ラップトップ コンピュータ)が太字で示されています。

HA は、MN のホーム IP アドレスと 気付アドレス 間の関係を維持する、MN のホーム ネットワーク上のルータです。気付アドレスは、外部ネットワーク上での MN の現在の位置です。HA は、MN がホーム上にない間に MN へパケットをトンネリングすることにより、パケットをリダイレクトします。

FA は、MN が HA に対して現在の気付アドレスを通知するのを支援する外部ネットワーク上のルータです。FA は、HA によってトンネリングされたパケットのトンネリングを解除し、パケットを MN に配送します。また FA は、MN が外部ネットワークに接続されている際に MN によって生成されるパケットに対するデフォルト ルータとしても動作します。

MN を宛先とするトラフィックは、三角ルーティング方式で転送されます。図 4 に示すとおり、通信ノード(CN)と呼ばれるインターネット上のデバイスがパケットを MN に送信した場合、パケットは MN のホーム ネットワークへルーティングされ、HA は外部ネットワーク上の MN の気付アドレス(現在の位置)までトンネリングすることにより、パケットをリダイレクトします。FA は HA からパケットを受信し、MN へローカルに転送します。ただし、MN が送信したパケットは、直接 CN へルーティングされます。

モバイル IP の設定の詳細については、『 Cisco IOS IP Mobility Configuration Guide 』を参照してください。

総称ルーティング カプセル化

総称ルーティング カプセル化(GRE)は RFC 2784 で定義されています。GRE はキャリア プロトコルで、基礎となるさまざまなトランスポート プロトコルと併用でき、多様なパッセンジャ プロトコルを伝送できます。また RFC 2784 では、トランスポート プロトコルとパッセンジャ プロトコルとして、GRE と IPv4 の併用もカバーしています。シスコ IOS ソフトウェアは、GRE を、次に示すパッセンジャ プロトコルおよびトランスポート プロトコルの多数の組み合わせとともに使用するキャリア プロトコルとしてサポートしています。

GRE を IPv4 ネットワーク上で使用(GRE/IPv4):GRE がキャリア プロトコル、IPv4 がトランスポート プロトコルとなります。これは、GRE トンネルで最もよく使用されるタイプです。設定の詳細については、「GRE トンネルの設定」を参照してください。シスコ IOS ソフトウェアは、GRE/IPv4 向けの多数のパッセンジャ プロトコル(AppleTalk、IPX、IPv4、および IPv6 など)をサポートしています。GRE/IPv4 で使用するパッセンジャ プロトコルとしての IPv6 の詳細については、「IPv6 トラフィックに対する GRE/IPv4 トンネルのサポート」を参照してください。

GRE を CLNS ネットワーク上で使用(GRE/CLNS):GRE がキャリア プロトコル、CLNS がトランスポート プロトコルとなります。これは RFC 3147 に記述されています。GRE/CLNS で使用するパッセンジャ プロトコルとしての CLNS の詳細については、「IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート」を参照してください。

GRE を IPv6 ネットワーク上で使用(GRE/IPv6):GRE がキャリア プロトコル、IPv6 がトランスポート プロトコルとなります。シスコ IOS ソフトウェアは、GRE/IPv6 で使用するパッセンジャ プロトコルとして IPv4 および IPv6 をサポートしています。GRE/IPv6 で使用するパッセンジャ プロトコルとしての IPv4 および IPv6 設定の詳細については、「GRE/IPv6 トンネルの設定」を参照してください。

GRE トンネルの次の説明が含まれています。

「GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ」

「マルチポイント GRE トンネリング」

「IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート」

「IPv6 トラフィックに対する GRE/IPv4 トンネルのサポート」

GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ

GRE トンネルの IP 送信元および宛先 VRF メンバシップを使用して、トンネルの送信元と宛先が任意の仮想プライベート ネットワーク(VPN)ルーティング/転送(VRF)テーブルに所属するよう設定できます。VRF テーブルには、各 VPN のルーティング データが保管されます。VRF テーブルは、Network Access Server(NAS; ネットワーク アクセス サーバ)に接続されているカスタマー サイトの VPN メンバシップを定義しています。各 VRF テーブルは、IP ルーティング テーブル、取得されたシスコ エクスプレス フォワーディング(CEF)テーブル、およびルーティング テーブルに格納されている情報を制御するためのガイドラインおよびルーティング プロトコル パラメータで構成されています。

以前は、総称ルーティング カプセル化(GRE) IP トンネルでは IP トンネルの宛先がグローバル ルーティング テーブルに含まれていることが必要でした。この機能の実装により、トンネルの送信元と宛先が任意の VRF に所属するよう設定できます。既存の GRE トンネルと同様、トンネルの宛先へのルートが定義されていない場合は、トンネルはディセーブルになります。

マルチポイント GRE トンネリング

Enhanced multipoint GRE(mGRE)トンネリング テクノロジーにより、IP ネットワークで使用するレイヤ 3(L3)トランスポート メカニズムが提供されます。これと同様のダイナミック レイヤ 3 トンネリング トランスポートは、IP ネットワーク内で使用して、VPN トラフィックをサービス プロバイダーおよび企業ネットワークへ転送でき、IP および MPLS VPN 間のパケット転送の相互運用性も提供します。この機能では、企業ネットワーク向けの IP バックボーン サービスのアウトソーシングを定義した RFC 2547 がサポートされます。

マルチポイント トンネルは、フレーム リレーのマルチポイント インターフェイスがリバース ARP メカニズムによって取得された情報を使用するのを同じ方法で Next Hop Resolution Protocol(NHRP)を使用して、リモートの Data-Link Connection Identifier(DLCI; データリンク接続識別子)のレイヤ 3 アドレスを学習します。

Cisco IOS Release 12.2(8)T 以降のリリースでは、mGRE トンネルでの CEF スイッチングが導入されています。以前のバージョンでは、mGRE トンネルで使用可能なのはプロセス スイッチングだけでした。mGRE トンネルでの CEF スイッチングにより、マルチポイント GRE トンネルとの間の IP トラフィックの CEF スイッチングが可能になりました。プレフィクスとトンネルの宛先がともにアプリケーションによって指定されている場合、トンネルのトラフィックは、トンネルの宛先を経由してプレフィクスへ転送できます。

IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート

CLNS ネットワーク経由の IPv4 および IPv6 パケットの GRE トンネリングにより、Cisco CLNS トンネル(CTunnels)を他のベンダー製のネットワーキング機器と相互運用できます。この機能により、RFC 3147 への準拠が実現します。

ヘッダー フィールドで定義されているオプションの GRE サービス(チェックサム、キー、シーケンス)はサポートされません。受信されるパケットやこのようなサービスを要求するパケットはいずれも廃棄されます。

IPv6 トラフィックに対する GRE/IPv4 トンネルのサポート

IPv6 トラフィックは、標準的なポイントツーポイント カプセル化スキームの実装に必要なサービスを提供するよう設計されている標準総称ルーティング カプセル化(GRE)トンネリング技術を使用して、IPv4 GRE トンネルを介して伝送できます。IPv6 を手動設定したトンネルと同様、GRE トンネルは、各リンクに個別のトンネルを持つ 2 つのポイント間のリンクです。トンネルは、特定のパッセンジャ プロトコルやトランスポート プロトコルに拘束されていませんが、この場合は IPv6 がパッセンジャ プロトコル、GRE がキャリア プロトコル、IPv4 がトランスポート プロトコルとなります。

GRE トンネルの主な用途は、2 つのエッジ ルータ間またはエッジ ルータとエンド システム間に標準的セキュアな通信を必要とする、安定した接続状態を確保することです。エッジ ルータとエンド システムはデュアル スタック実装にする必要があります。

GRE には、パッセンジャ プロトコルを識別するプロトコル フィールドがあります。GRE トンネルでは、IS-IS または IPv6 をパッセンジャ プロトコルとして指定でき、IS-IS トラフィックと IPv6 トラフィックをともに同じトンネルを介して送出できます。GRE がプロトコル フィールドを持っていない場合、トンネルが IS-IS または IPv6 のどちらのパケットを伝送しているかを区別することは不可能となります。つまり、GRE プロトコル フィールドを使用することで、GRE 内で IS-IS および IPv6 をトンネリングできるようになります。

IPv6 向けオーバーレイ トンネル

オーバーレイ トンネリングでは、IPv4 パケット内で IPv6 パケットをカプセル化して、IPv4 インフラストラクチャ(コア ネットワークまたはインターネット)へ伝送します (図 5 を参照)。オーバーレイ トンネルを使用することで、独立した IPv6 ネットワークとの間で IPv4 インフラストラクチャをアップグレードしなくても、そのネットワークと通信できます。オーバーレイ トンネルは、境界ルータ間または境界ルータとホスト間で設定できますが、トンネルのエンドポイントがともに IPv4 および IPv6 プロトコル スタックを両方ともサポートしていることが必要となります。Cisco IOS IPv6 は現在、次のタイプのオーバーレイ トンネリング メカニズムをサポートしています。

手動

総称ルーティング カプセル化(GRE)

IPv4 互換

6to4

Intra-Site Automatic Tunnel Addressing Protocol(ISATAP)

図 5 オーバーレイ トンネル

 


) オーバーレイ トンネルにより、インターフェイスの Maximum Transmission Unit(MTU; 最大伝送ユニット)が 20 オクテット減少します(ただし、基本 IPv4 パケット ヘッダーにオプション フィールドが含まれていないことを前提とします)。オーバーレイ トンネルを使用するネットワークは、トラブルシューティングが困難です。したがって、独立した IPv6 ネットワークに接続するオーバーレイ トンネルは、最終的な IPv6 ネットワーク アーキテクチャと見なしてはいけません。オーバーレイ トンネルの使用は、IPv4 および IPv6 プロトコル スタックの両方、または IPv6 プロトコル スタックだけをサポートするネットワークに対する過渡的な技術と考える必要があります。


表 2 を参照して、IPv4 ネットワークを介して IPv6 パケットを伝送するために設定するトンネルのタイプを決定します。

 

表 2 IPv4 ネットワークを介して IPv6 パケットを伝送する際の推奨されるトンネル タイプの使用方法

トンネリングのタイプ
推奨される使用方法
使用方法に関する注釈

手動

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6 パケットのみ伝送可能

GRE/IPv4

サイト内またはサイト間で使用可能な、単純なポイントツーポイント トンネル

IPv6、CLNS、およびその他多数のパケット タイプを伝送可能

互換

ポイントツーマルチポイント トンネル

プレフィクス ::/96 を使用。このトンネル タイプの使用は推奨しません。

6to4

独立した IPv6 サイトへの接続に使用可能なポイントツーマルチポイント トンネル

サイトはプレフィクス 2002::/16 を使用

ISATAP

サイト内のシステムへの接続に使用可能なポイントツーマルチポイント トンネル

サイトは任意の IPv6 ユニキャスト アドレスを使用可能

個々のトンネル タイプについては以降で詳しく説明します。シスコは、お客様が実装を希望する特定のトンネル タイプについての情報を確認して理解することを推奨します。必要なトンネルのタイプについて十分理解できたら、 表 3 のトンネル設定パラメータの概要を参照して役に立つ情報を確認してください。

 

表 3 トンネリング タイプ別オーバーレイ トンネルの設定パラメータ

オーバーレイ トンネリング タイプ
オーバーレイ トンネル設定パラメータ
トンネル モード
トンネルの送信元
トンネルの宛先
インターフェイスのプレフィクス/アドレス

手動

ipv6ip

IPv4 アドレスまたは IPv4 が設定されているインターフェイスのリファレンス

IPv4 アドレス

IPv6 アドレス

GRE/IPv4

gre ip

IPv4 アドレス

IPv6 アドレス

互換

ipv6ip auto-tunnel

不要。これらはすべてポイントツーマルチポイント トンネリング タイプです。IPv6 の宛先からパケット単位で IPv4 の宛先アドレスが計算されます。

不要。インターフェイスのアドレスは :: tunnel-source /96 として生成されます。

6to4

ipv6ip 6to4

IPv6 アドレス プレフィクスはトンネル送信元の IPv4 アドレスを埋め込む必要があります。

ISATAP

ipv6ip isatap

eui-64 修正版 IPv6 形式のプレフィクス。IPv6 アドレスは、プレフィクスとトンネル送信元の IPv4 アドレスから生成されます。

手動設定された IPv6 トンネル

手動設定されたトンネルは、IPv4 バックボーン上の 2 つの IPv6 ドメイン間の固定リンクと同等です。主な用途は、2 つのエッジ ルータ間またはエンド システムとエッジ ルータ間に標準的なセキュアな通信を必要とする、安定した接続状態を確保したり、リモートの IPv6 ネットワークへ接続することです。

IPv6 アドレスはトンネル インターフェイスで手動設定されます。また、手動設定された IPv4 アドレスはトンネルの送信元と宛先に割り当てられます。手動設定されたトンネルの両端のホストまたはルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。手動設定されたトンネルは、境界ルータ間または境界ルータとホスト間で設定できます。シスコ エクスプレス フォワーディング(CEF)スイッチングは、手動設定された IPv6 トンネルに使用できます。または、プロセス スイッチングが必要な場合は、CEF スイッチングをディセーブルにできます。

自動 6to4 トンネル

自動 6to4 トンネルにより、独立した IPv6 ドメインを IPv4 ネットワークを介してリモートの IPv6 ネットワークへ接続できます。自動 6to4 トンネルと手動設定されたトンネルとの主な違いは、トンネルがポイントツーポイントではなく、ポイントツーマルチポイントであることです。自動 6to4 トンネルでは、ルータは IPv4 インフラストラクチャを仮想 NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)リンクとして処理するため、ペアでは設定されません。IPv6 アドレスに埋め込まれている IPv4 アドレスは、自動トンネルのもう一端を検索するのに使用されます。

自動 6to4 トンネルは、独立した IPv6 ネットワーク内の境界ルータ上で設定できます。これにより、IPv4 インフラストラクチャ上の別の IPv6 ネットワーク内の境界ルータへのトンネルがパケット単位で作成されます。トンネルの宛先は、IPv6 アドレスから抽出された境界ルータの IPv4 アドレスによって決定され、プレフィクス 2002::/16 で始まる、2002: border-router-IPv4-address ::/48 という形式になります。埋め込まれた IPv4 アドレスの後に 16 ビットが続き、サイト内のネットワークに番号付けをするのに使用できます。6to4 トンネルの各終端の境界ルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。6to4 トンネルは、境界ルータ間または境界ルータとホスト間で設定されます。

6to4 トンネルの最も単純な展開シナリオは、複数の IPv6 サイトに相互接続し、各サイトに共有 IPv4 ネットワークへの接続を少なくとも 1 つ設定することです。この IPv4 ネットワークは、グローバル インターネットまたは企業バックボーンである可能性があります。主な要件は、各サイトがグローバルに一意の IPv4 アドレスを持つことです。Cisco IOS ソフトウェアはこのアドレスを使用して、グローバルに一意の 6to4/48 IPv6 プレフィクスを作成します。他のトンネル メカニズムと同様、IPv4 および IPv6 に対してホスト名と IP アドレス間のマッピングを行う Domain Name System(DNS; ドメイン ネーム システム)内の対応するエントリにより、アプリケーションは必要なアドレスを選択できます。

自動 IPv4 互換 IPv6 トンネル

自動 IPv4 互換トンネルは、IPv4 互換 IPv6 アドレスを使用します。IPv4 互換 IPv6 アドレスは、アドレスの上位 96 ビットがゼロで、下位 32 ビットが IPv4 アドレスの IPv6 ユニキャスト アドレスです。このアドレスは、0:0:0:0:0:0:A.B.C.D または ::A.B.C.D と記述でき、「A.B.C.D」は埋め込まれた IPv4 アドレスを表します。

トンネルの宛先は、IPv4 互換 IPv6 アドレスの下位 32 ビットに含まれる IPv4 アドレスにより自動的に決定されます。IPv4 互換トンネルの各終端のホストまたはルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。IPv4 互換トンネルは、境界ルータ間または境界ルータとホスト間で設定できます。IPv4 互換トンネルを使用することは、IPv4 上で IPv6 に対するトンネルを作成するうえで容易な方法ですが、この技術は大規模なネットワークに合わせて拡大することはできません。


) IPv4 互換トンネルは当初、IPv6 でサポートされていましたが、現在は廃止されされています。シスコは現在、ISATAP トンネルと呼ばれる別の IPv6 トンネリング技術の使用を推奨しています。


ISATAP トンネル

Intra-Site Automatic Tunnel Addressing Protocol(ISATAP)は、基盤となる IPv4 ネットワークを IPv6 に対する非ブロードキャスト マルチアクセス(NBMA)リンク層として使用する、自動オーバーレイ トンネリング メカニズムです。ISATAP は、ネイティブの IPv6 インフラストラクチャがまだ使用可能になっていない(希薄 IPv6 ホストがテスト用に展開されている場合などの)サイト 内の IPv6 パケットを転送することを目的として設計されています。ISATAP トンネルにより、サイト内の個々の IPv4/IPv6 デュアル スタック ホストが同じ仮想リンク上の他のホストと通信でき、基本的に IPv4 インフラストラクチャを使用して IPv6 ネットワークを作成できます。

ISATAP ルータでは、ISATAP サイトに対して標準的なルータ アドバタイズメント ネットワーク設定がサポートされます。この機能により、クライアントは、イーサネットに接続した場合に行うと思われる設定をクライアント自身に自動的に実行できます。また、サイト外で接続を行えるよう設定することもできます。ISATAP は、任意のユニキャスト IPv6 プレフィクス(/64)で構成される明確な IPv6 アドレス形式を使用します。この形式は、リンク ローカルまたはグローバル(6to4 プレフィクスを含む)にすることができ、IPv6 ルーティングをローカルまたはインターネットでイネーブルにできます。IPv4 アドレスは IPv6 アドレスの最後の 32 ビットで符号化され、自動 IPv6-in-IPv4 トンネリングをイネーブルにします。

ISATAP トンネリング メカニズムは他の自動トンネリング メカニズム(IPv6 6to4 トンネリングなど)と同様ですが、ISATAP は サイト間 ではなく、 サイト内 の IPv6 パケットを転送するよう設計されています。

ISATAP は、64 ビットの IPv6 プレフィクスと 64 ビットのインターフェイス識別子を含むユニキャスト アドレスを使用します。インターフェイス識別子は、修正版 EUI-64 形式で作成され、この形式では、最初の 32 ビットにはこのアドレスが IPv6 ISATAP アドレスであることを示す 000:5EFE という値が含まれます。 表 4 に ISATAP アドレスのレイアウトを示します。

 

表 4 ISATAP アドレスの例

64 ビット
32 ビット
32 ビット

リンク ローカルまたはグローバル IPv6 ユニキャスト プレフィクス

0000:5EFE

ISATAP リンクの IPv4 アドレス

表 4 に示すとおり、ISATAP アドレスは IPv6 プレフィクスと ISATAP インターフェイス識別子で構成されます。このインターフェイス識別子には、基盤となる IPv4 リンクの IPv4 アドレスが含まれます。プレフィクスが 2001:0DB8:1234:5678::/64 で、IPv4 アドレスが 10.173.129.8 の場合、実際の ISATAP アドレスがどのようになるかを次の例に示します。ISATAP アドレスでは、IPv4 アドレスは 16 進数の 0AAD:8108 として表現されます。

2001:0DB8:1234:5678:0000:5EFE:0AAD:8108

Rate-Based Satellite Control Protocol トンネル

Rate-Based Satellite Control Protocol(RBSCP)は、衛星リンクなどの、エラー レートが高い無線または長距離の遅延リンクのために設計されました。RBSCP では、トンネルを使用して、エンドツーエンド モデルを中断することなく衛星リンクを介して TCP および IP Security(IPSec)などの特定の IP プロトコルのパフォーマンスを改善できます。

衛星リンクには、リンクを介する IP プロトコルに影響を及ぼすいくつかの特性があります。図 6 は、衛星リンクに 275 ミリ秒の単方向遅延が発生する可能性があることを示しています。550 ミリ秒の Round-Trip Time(RTT; ラウンドトリップ時間)は、TCP に対する非常に長時間の遅延です。別の問題は、LAN の無線リンクに比較して衛星リンクに通常発生する、エラー レート(パケット損失レート)が高いことです。天候が衛星リンクに影響を及ぼし、使用可能な帯域幅が減少して、RTT およびパケット損失が増えることもあります。

図 6 通常の衛星リンク

 

RTT が長時間の場合、TCP は低速開始モードのままで、衛星リンク帯域幅全体が使用される前の時間が長くなります。TCP および Stream Control Transmission Protocol(SCTP)では、パケット損失イベントがネットワークの輻輳状態と解釈され、輻輳リカバリ手順の実行が開始されます。これによって、リンクを介して送信されるトラフィックが少なくなります。

使用可能な衛星リンク帯域幅は大きくなりますが、衛星リンクを介した IP プロトコルで発生する長時間の RTT および高いエラー レートによって、高い Bandwidth-Delay Product(BDP; 帯域遅延積)が生成されます。

衛星リンクの使用時に、低速開始モードで継続される TCP の問題に対処するために、多くの場合、中断を伴う Performance Enhancing Proxy(PEP)ソリューションがネットワークに導入されます。図 7 は、転送接続が、そのデフォルト ルータを介してインターネットに接続しているリモート側のホストで、3 つのセクションに分かれることを示したものです。ルータによって、すべてのインターネット バインド型トラフィックが TCP PEP に送信されます。これによって、インターネットへの TCP 接続が中断されます。PEP によって、すべてのデータのローカル TCP ACK(TCP スプーフィング)が生成されます。トラフィックはバッファリングされ、衛星リンクを介して 1 つの PEP プロトコルを介して再送信されます。2 つ目の PEP では、衛星リンクからのデータを受信し、別の TCP 接続を介してインターネットにデータが再送信されます。TCP 送信が妨害され、廃棄されたパケットは、TCP の輻輳として解釈されず、バッファリングされたデータから再送信されます。最小限の TCP ACK と抑制された TCP 低速の開始では、より多くの帯域幅を使用できます。

図 7 中断を伴う TCP PEP のソリューション

 

中断を伴う TCP PEP を使用する場合の欠陥の 1 つは、中断を伴う TCP PEP によって、エンドツーエンド モデルが中断されることです。トラフィックのフローが中断されると、一部のアプリケーションは動作できず、PEP では、暗号化トラフィック(IPSec)の処理の準備がありません。SCTP などの新しい転送プロトコルでは、中断を伴う TCP PEP で機能する場合に特別な処理または追加コードが必要です。各衛星ルータでは、追加の管理対象ネットワーク コンポーネントも必要です。

RBSCP は、エンドツーエンド モデルを保持するために設計され、PEP ソリューションを使用して衛星リンクを介してパフォーマンスの改善がもたらされます。衛星リンク中でのクリア テキスト トラフィックの IPSec の暗号化(たとえば VPN サービス設定)はサポートされます。RBSCP を使用すると、2 つのルータで、衛星リンクの送信レートを制御およびモニタリングでき、帯域利用率が高まります。損失パケットは、RBSCP によって衛星リンクを介して再送信され、エンド ホスト TCP の送信側が低速開始モードになることが防止されます。

図 8 に示されているように、RBSCP はトンネル インターフェイスを使用して実装されます。トンネルは、衛星モデムまたは内部衛星モデム ネットワーク モジュールで使用可能な Cisco IOS ソフトウェアによってサポートされる任意のネットワーク インターフェイスを介して、設定できます。IP トラフィックは、ルータ設定によって指定された適切な変更および機能拡張が使用される衛星リンクにまたがって送信されます。標準ルーティングまたはポリシーベース ルーティングを使用して、RBSCP トンネルを介して送信されるトラフィックを特定できます。

図 8 中断を伴わない RBSCP ソリューション

 

RBSCP トンネルでは、次のいずれかの機能を設定できます。

時間の遅延 :RBSCP ルータの 1 つでは、RBSCP トンネルを介した転送のため、フレームを保持するよう設定できます。遅延時間は、エンド ホストでの RTT が増え、RBSCP 時間によって、損失 TCP フレームまたはその他のプロトコル フレームを再送信できます。再送信が正常に実行されると、損失フレーム イベントが、輻輳手順がイネーブルのエンド ホストに到達することが防止されます。一部の場合、遅延なしで RBSCP によって再送信を完了できます。このオプションは、衛星リンクの Round Trip Time(RTT; ラウンドトリップ時間)が 700 ミリ秒を超える場合に限り使用します。

ACK の分割 :受信した各 TCP ACK で生成された多数の追加の TCP ACK で、Acknowledgement(ACK)分割を使用したクリア テキスト TCP トラフィックで、パフォーマンスを改善できます。TCP では、受信した各 TCP ACK の 1 つの Maximum Transmission Unit(MTU; 最大伝送ユニット)によって、輻輳ウィンドウが開かれます。輻輳ウィンドウが開かれると、より大きな帯域幅が使用可能になります。衛星リンクで使用可能なすべての帯域幅が使用されていないときにのみ、この機能を設定します。暗号化トラフィックでは、ACK 分割は使用できません。

ウィンドウ スタッフィング :クリア テキスト TCP トラフィックと SCTP トラフィックは、RBSCP ウィンドウ スタッフィング機能の利点を活用できます。RBSCP では、アドバタイジングされるウィンドウを、使用可能な衛星リンク帯域幅またはルータで使用可能なメモリまで増やすことができるよう、トラフィックをバッファリングできます。パケットを送信するエンド ホストでは、より大きなウィンドウが受信側のエンド ホストに存在し、より多くのトラフィックが送信されると、誤って見なされます。エンド ホストによって、衛星リンクに処理するトラフィックを多く送りすぎることがあり、発生したパケットの損失および再送信によって、リンクに輻輳状態が発生する可能性があるため、この機能は注意して使用してください。

SCTP 廃棄レポーティング :SCTP では、ACK 計算方式の代わりに適切なバイト計算方式を使用して、送信ウィンドウのサイズが決定されるため、ACK 分割は、SCTP では動作しません。RBSCP トンネルでは、輻輳による損失の結果としてではなく、衛星全体で廃棄されたパケットの SCTP パケット廃棄レポートを生成できます。この SCTP 廃棄レポートはデフォルトでオンに設定されており、輻輳ウィンドウ サイズに影響を及ぼすことなくパケットを再送信する機会が提供されます。実際の輻輳損失は、引き続きレポートされますが、通常のリカバリ メカニズムがアクティブにされます。

Path MTU Discovery(PMTUD)

Path MTU Discovery(PMTUD)は、GRE または IP-in-IP トンネル インターフェイスでイネーブルにできます。トンネル インターフェイスで PMTUD(RFC 1191)がイネーブルの場合、ルータは GRE(または IP-in-IP)トンネル IP パケットに対して PMTUD 処理を実行します。ルータは、トンネルに入ってくる元のデータの IP パケットに対して常に PMTUD 処理を実行します。PMTUD がイネーブルの場合、Don't Fragment(DF)ビットがすべてのパケットに設定されるため、トンネルを通過するパケットに対してはパケットのフラグメンテーションは許可されません。トンネルに入ったパケットがそのパケットの MTU 値よりも小さい MTU 値を持つリンクを検出すると、パケットは廃棄され、パケットの送信元に ICMP メッセージが返されます。このメッセージには、フラグメンテーションが要求されたこと(しかし許可されなかったこと)と、パケットが廃棄される原因となったリンクの MTU が含まれています。

PMTUD の詳細については、『 IP Fragmentation and PMTUD 』を参照してください。


) トンネル インターフェイスの PMTUD は、トンネル エンドポイントがトンネルのパスでルータによって生成される ICMP メッセージを受信できることを要求します。ファイアウォール接続を通じて PMTUD を使用する前に、ICMP メッセージが受信できることを確認してください。


トンネルのパケットに PMTUD をイネーブルにするには、 tunnel path-mtu-discovery コマンドを使用し、トンネルの PMTUD パラメータを確認するには、 show interfaces tunnel コマンドを使用します。PMTUD が動作するトンネル インターフェイスは現在、GRE および IP-in-IP だけです。

トンネル用 Quality of Service(QoS)オプション

トンネル インターフェイスは、物理インターフェイスと同じ多数の Quality of Service(QoS)機能をサポートします。QoS により、ミッション クリティカルなトラフィックのパフォーマンスを確実に受け入れ可能なレベルにする方法が提供されます。トンネル用 QoS オプションでサポートされる項目には、Generic Traffic Shaping (GTS)のトンネル インターフェイスへの直接適用や、Modular QoS CLI(MQC)を使用したクラス ベースのシェーピングなどが含まれます。またトンネル インターフェイスは、クラス ベースのポリシングもサポートしますが、Committed Access Rate(CAR; 専用アクセス レート)はサポートしません。


) Cisco 7500 シリーズ ルータのトンネル インターフェイスでは、サービス ポリシーはサポートされません。


GRE トンネルでは、ルータは、タイプ オブ サービス(ToS)バイトの IP precedence ビット値をトンネルまたは内部パケットをカプセル化している GRE IP ヘッダーにコピーできます。トンネルのエンドポイント間の中間ルータは、IP precedence 値を使用して、QoS 機能(ポリシー ルーティング、Weighted Fair Queuing(WFQ; 重み付け均等化キューイング)、Weighted Random Early Detection(WRED; 重み付けランダム早期検出)など)向けにパケットを分類できます。

トンネルまたは暗号化ヘッダーによってパケットがカプセル化されている場合、QoS 機能は元のパケットのヘッダーを調べてパケットを正しく分類することができません。同じトンネルを通過するパケットは、同じトンネル ヘッダーを持つため、物理インターフェイスが輻輳している場合、パケットは同等に扱われます。ただしトンネルのパケットは、トンネリング前に分類でき、QoS の事前分類機能を使用することで、トンネル インターフェイス上または暗号マップ上で暗号化を行うことができます。


) クラス ベースのシェーピング内の Class-based WFQ(CBWFQ)は、マルチポイント インターフェイスではサポートされません。


トンネル インターフェイスでの一部の QoS 機能の実装方法の例については、「トンネル インターフェイスでの QoS オプションの設定:例」を参照してください。

トンネルの実装方法

ここでは、次の作業について説明します。

「トンネル タイプの決定」(必須)

「GRE トンネルの設定」(任意)

「GRE/IPv6 トンネルの設定」(任意)

「GRE トンネル IP 送信元および宛先 VRF メンバシップの設定」(任意)

「CTunnel の設定」(任意)

「IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定」(任意)

「手動 IPv6 トンネルの設定」(任意)

「6to4 トンネルの設定」(任意)

「IPv4 互換 IPv6 トンネルの設定」(任意)

「ISATAP トンネルの設定」(任意)

「RBSCP トンネルの設定」(任意)

「トンネルの設定と動作の確認」(任意)

「RBSCP トンネルの設定と動作の確認」(任意)

トンネル タイプの決定

トンネルを設定する前に、作成するトンネルのタイプを決定する必要があります。

手順の概要

1. パッセンジャ プロトコルを決定します。

2. トンネルの Command-Line Interface(CLI; コマンドライン インターフェイス)のタイプを決定します。

3. 必要に応じて、 tunnel mode コマンド キーワードを決定します。

手順の詳細


ステップ 1 パッセンジャ プロトコルを決定します。

パッセンジャ プロトコルはカプセル化の対象となるプロトコルです。

ステップ 2 トンネルの CLI タイプを決定します。

トンネルで使用するトランスポート プロトコルに必要な、トンネルのコマンドライン インターフェイス(CLI)コマンドを決定する方法を 表 5 に示します。

 

表 5 トランスポート プロトコル別トンネル CLI の決定

トランスポート プロトコル
トンネルの CLI コマンド

CLNS

ctunnel オプションの mode gre キーワードを使用)

その他

tunnel mode 適切なキーワードを使用)

ステップ 3 必要に応じて、 tunnel mode コマンド キーワードを決定します。

tunnel mode コマンドで使用する適切なキーワードを決定する方法を 表 6 に示します。このモジュールの以降に示す作業では、 tunnel mode に関連するキーワードだけを示します。

 

表 6 トンネル モードのコマンド キーワードの決定

キーワード
目的

dvmrp

Distance Vector Multicast Routing Protocol(DVMRP)のカプセル化の使用を指定するには、 dvmrp キーワードを使用します。

gre ip

IP での GRE カプセル化の使用を指定するには、 gre ip キーワードを使用します。

gre ipv6

IPv6 での GRE カプセル化の使用を指定するには、 gre ipv6 キーワードを使用します。

gre multipoint

マルチポイント GRE(mGRE)カプセル化の使用を指定するには、 gre multipoint キーワードを使用します。

ipip [ decapsulate-any ]

IP-in-IP カプセル化の使用を指定するには、 ipip キーワードを使用します。オプションの decapsulate-any キーワードは、あるトンネル インターフェイスの任意の数の IP-in-IP トンネルを終了させます。このトンネルは発信トラフィックを伝送しませんが、任意の数のリモート トンネル エンドポイントは、このように設定されたトンネルを宛先として使用できることに注意してください。

ipv6

IPv6 での汎用パケット トンネリングの使用を指定するには、 ipv6 キーワードを使用します。

ipv6ip

IPv6 をパッセンジャ プロトコルとして使用し、IPv4 をキャリア(カプセル化)プロトコルおよびトランスポートプロトコルとして使用することを指定するには、 ipv6ip キーワードを使用します。追加のキーワードを使用しない場合は、手動 IPv6 トンネルが設定されます。追加のキーワードを使用して、IPv4 互換、6to4、または ISATAP トンネルを指定できます。

mpls

Traffic Engineering(TE; トラフィック エンジニアリング)トンネルの設定に MPLS の使用を指定するには、 mpls キーワードを使用します。

rbscp

RBSCP トンネルの使用を指定するには、 rbscp キーワードを使用します。


この次の手順

IP データ パケットを伝送するようトンネルを設定するには、「GRE トンネルの設定」に進みます。

CLNS データ パケットを伝送するようトンネルを設定するには、「CTunnel の設定」に進みます。

CLNS ネットワークを通じて IPv4 および IPv6 データ パケットを伝送するようトンネルを設定するには、「IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定」に進みます。

IPv6 データ パケットを伝送するようトンネルを設定するには、「IPv6 向けオーバーレイ トンネル」を確認のうえ、次の作業のいずれかに進みます。

「GRE/IPv6 トンネルの設定」

「手動 IPv6 トンネルの設定」

「6to4 トンネルの設定」

「IPv4 互換 IPv6 トンネルの設定」

「ISATAP トンネルの設定」

エラー レートの高い衛星または長距離遅延リンクを通じて IP データ パケットを伝送するよう RBSCP トンネルを設定するには、「RBSCP トンネルの設定」に進みます。

GRE トンネルの設定

GRE トンネルを設定するには、この作業を実行します。トンネル インターフェイスを使用して、通常プロトコルをサポートしないネットワークへプロトコル トラフィックを通過させます。トンネルを構築するには、トンネル インターフェイスを 2 つのルータそれぞれで定義し、そのトンネル インターフェイスが互いを参照することが必要です。各ルータでは、トンネル インターフェイスはレイヤ 3 アドレスを使用して設定する必要があります。トンネルのエンドポイント、トンネル送信元、およびトンネル宛先を定義して、トンネルのタイプを選択する必要があります。オプションの手順を実行して、トンネルをカスタマイズできます。

必ずトンネルの両側にルータを設定するようにしてください。トンネルの片方の端だけが設定されている場合、(キープアライブが設定されていない限り)トンネル インターフェイスはアップした状態になっていますが、トンネルに入ったパケットは廃棄されます。

Cisco IOS Release 12.2(8)T 以降のリリースでは、マルチポイント GRE トンネルでの CEF スイッチングが導入されました。以前のバージョンでは、マルチポイント GRE トンネルで使用可能なのはプロセス スイッチングだけでした。

GRE トンネル キープアライブ

キープアライブ パケットは、IP カプセル化された GRE トンネルを介して送信されるよう設定できます。キープアライブが送信されるレートと、インターフェイスが非アクティブになるまでデバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定できます。GRE キープアライブ パケットは、トンネルの両側または片側のみのどちらでも送信できます。

前提条件

この作業でトンネルの送信元として使用する物理インターフェイスがアップしており適切な IP アドレスを使用して設定されていることを確認します。ハードウェアに関する技術的な説明およびインターフェイスのインストールに関する情報については、ご使用の製品のハードウェアのインストールおよび設定マニュアルを参照してください。

制約事項

GRE トンネル キープアライブは、Virtual Route Forwarding(VRF)が GRE トンネルに適用されていない場合は、サポートされません。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. bandwidth kbps

5. keepalive [ period [ retries ]]

6. tunnel source { ip-address | interface-type interface-number }

7. tunnel destination { hostname | ip-address }

8. tunnel key key-number

9. tunnel mode { gre ip | gre multipoint }

10. ip mtu bytes

11. ip tcp mss mss-value

12. tunnel path-mtu-discovery [ age-timer { aging-mins | infinite } ]

13. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface tunnel 0

インターフェイス タイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

トンネルを設定するには、 type 引数に tunnel を使用します。

Cisco 7500 シリーズなど一部のルータ プラットフォームでは、number 引数は、スロット、ポート アダプタ、およびポート番号で構成されます。詳細については、『 Cisco IOS Interface and Hardware Component Command Reference 』の interface コマンドを参照してください。

ステップ 4

bandwidth kbps

 

Router(config-if)# bandwidth 1000

インターフェイスに対する現在の帯域幅を設定し、上位レベル プロトコルと通信します。パケットの送信に使用されるトンネル帯域幅を指定します。

帯域幅をキロビット/秒単位(kbps)で設定するには、 kbps 引数を使用します。

(注) これはルーティング パラメータのみのため、物理インターフェイスには影響を及ぼしません。トンネル インターフェイスのデフォルトの帯域幅は 9.6 kbps です。トンネルの帯域幅を適切な値に設定する必要があります。

ステップ 5

keepalive [ period [ retries ]]

 

Router(config-if)# keepalive 3 7

(任意)トンネル インターフェイス プロトコルがダウン状態になるまで、デバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定します。

GRE キープアライブ パケットは、トンネルの片側または両側のどちらででも設定できます。

GRE キープアライブをトンネルの両側で設定した場合、リンクの各側の period 引数と retries 引数は異なる値に設定できます。

(注) このコマンドがサポートされるのは、GRE ポイントツーポイント トンネルだけです。

(注) GRE トンネルのキープアライブ機能は、VRF トンネルでは設定しないでください。機能のこの組み合わせはサポートされていません。

ステップ 6

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source Ethernet 1

トンネル ソースを設定します。

送信元 IP アドレスを指定するには、 ip-address 引数を使用します。

使用するインターフェイスを指定する場合は、 interface-type 引数および interface-number 引数を使用します。

(注) トンネルの送信元と宛先の IP アドレスは、2 つの個別のデバイス上で定義する必要があります。

ステップ 7

tunnel destination { hostname | ip-address }

 

Router(config-if)# tunnel destination 172.17.2.1

トンネルの宛先を設定します。

ホストの宛先の名前を指定するには、 hostname 引数を使用します。

ホストの宛先の IP アドレスを指定する場合は、 ip-address 引数を使用します。

(注) トンネルの送信元と宛先の IP アドレスは、2 つの個別のデバイス上で定義する必要があります。

ステップ 8

tunnel key key-number

 

Router(config-if)# tunnel key 1000

(任意)トンネル インターフェイスの ID キーをイネーブルにします。

各パケットで運ばれるトンネル キーを識別するには、 key-number 引数を使用します。

トンネルの ID キーは、強度の劣るセキュリティ形式として使用して、外部ソースからのパケットの不適切な設定や挿入を防止できます。

(注) このコマンドがサポートされるのは、GRE トンネル インターフェイスだけです。セキュリティ目的でこのキーに依存することは推奨しません。

ステップ 9

tunnel mode { gre ip | gre multipoint }

 

Router(config-if)# tunnel mode gre ip

トンネルで使用されるカプセル化プロトコルを指定します。

IP カプセル化での GRE の使用を指定するには、 gre ip キーワードを使用します。

マルチポイント GRE(mGRE)の使用を指定するには、 gre multipoint キーワードを使用します。

ステップ 10

ip mtu bytes

 

Router(config-if)# ip mtu 1400

(任意)各インターフェイスにおいて送信される IP パケットの Maximum Transmission Unit(MTU; 最大伝送ユニット)のサイズをバイト単位で設定します。

インターフェイスに設定されている MTU を IP パケットが超過した場合、DF ビットが設定されていなければ Cisco IOS ソフトウェアは DF ビットをフラグメント化します。

物理メディアのすべてのデバイスが動作するには、同じプロトコル MTU を持っている必要があります。

コマンドがイネーブルになっている場合、このコマンドを設定しないでください。

ステップ 11

ip tcp mss mss-value

 

Router(config-if)# ip tcp mss 250

(任意)ルータ上で生成または終了する TCP 接続に対して、Maximum Segment Size(MSS; 最大セグメント サイズ)を指定します。

TCP 接続に対する最大セグメント サイズをバイト単位で指定するには、 mss-value 引数を使用します。

ステップ 12

tunnel path-mtu-discovery [ age-timer { aging-mins | infinite }]

 

Router(config-if)# tunnel path-mtu-discovery

(任意)GRE または IP-in-IP トンネル インターフェイスで Path MTU Discovery(PMTUD)をイネーブルにします。

トンネル インターフェイスで PMTUD がイネーブルの場合、PMTUD は GRE IP トンネル パケット用に動作し、トンネル エンドポイント間のパス内のフラグメンテーションを最低限に抑えます。

ステップ 13

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

この次の手順

「トンネルの設定と動作の確認」に進みます。

GRE/IPv6 トンネルの設定

この作業では、IPv6 ネットワーク上での GRE トンネルの設定方法を説明します。GRE トンネルを、IPv6 ネットワーク層を介して実行し、IPv6 トンネルに IPv6 パケットを転送して、IPv6 トンネルに IPv4 パケットを転送するよう設定できます。

前提条件

GRE/IPv6 トンネルが設定されている場合、IPv6 アドレスはトンネルの送信元と宛先に割り当てられます。トンネル インターフェイスには、IPv4 または IPv6 アドレスのいずれかを割り当てることができます(このことは、以降の作業では示されていません)。手動設定されたトンネルの両端のホストまたはルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. tunnel source { ipv6-address | interface-type interface-number }

5. tunnel destination ipv6-address

6. tunnel mode gre ipv6

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 0

トンネル インターフェイスと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

tunnel source { ipv6-address | interface-type interface-number }

 

Router(config-if)# tunnel source ethernet 0

送信元 IPv6 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

インターフェイスのタイプと番号が指定されている場合、そのインターフェイスは IPv6 アドレスを使用して設定する必要があります。

』を参照してください。

ステップ 5

tunnel destination ipv6-address

 

Router(config-if)# tunnel destination 2001:0DB8:0C18:2::300

トンネル インターフェイスの宛先 IPv6 アドレスを指定します。

』を参照してください。

ステップ 6

tunnel mode gre ipv6

 

Router(config-if)# tunnel mode gre ipv6

GRE IPv6 トンネルを指定します。

コマンドは、GRE をトンネルに対するカプセル化プロトコルとして指定します。

ステップ 7

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

この次の手順

「トンネルの設定と動作の確認」に進みます。

GRE トンネル IP 送信元および宛先 VRF メンバシップの設定

この作業では、トンネルの送信元と宛先を任意の仮想プライベート ネットワーク(VPN)ルーティング/転送(VRF)テーブルに所属するよう設定する方法を説明します。

GRE トンネル IP 送信元および宛先 VRF メンバシップの制約事項

Cisco 10000 シリーズ ルータ

tunnel vrf コマンドに関連する VRF は、トンネルがパケットを送信する(外部 IP パケット ルーティング)際に経由する物理インターフェイスに関連する VRF と同じです。

ip vrf forwarding コマンドを使用することによりトンネルに関連付けられた VRF は、パケットがトンネルを出る(内部 IP パケット ルーティング)際にパケットが転送される VRF です。

Cisco 10000 シリーズ ルータでは、マルチキャスト トンネルを通過するマルチキャスト パケットのフラグメンテーションはサポートされません。

手順の概要

1. enable

2. configure { terminal | memory | network }

3. interface tunnel slot

4. ip vrf forwarding vrf-name

5. ip address ip-address subnet-mask

6. tunnel source ( ip-address | type number )

7. tunnel destination ip-address { hostname | ip-address }

8. tunnel vrf vrf-name

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure { terminal | memory | network }

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel slot

 

Router(config)# interface tunnel 0

特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding green

VRF を指定します。

ステップ 5

ip address ip-address subnet-mask

 

Router(config-if)# ip address 10.7.7.7 255.255.255.255

IP アドレスおよびサブネット マスクを指定します。

ステップ 6

tunnel source { ip-address | type number }

 

Router(config-if)# tunnel source loop 0

トンネルの送信元を指定します。

ステップ 7

tunnel destination { hostname | ip-address }

 

Router(config-if)# tunnel destination 10.5.5.5

トンネルの宛先を指定します。

ステップ 8

tunnel vrf vrf-name

 

Router(config-if)# tunnel vrf finance1

VRF を指定します。

この次の手順

「トンネルの設定と動作の確認」に進みます。

CTunnel の設定

CLNS トンネル(CTunnel)で IP を設定するには、この作業を実行します。単一のルータ ペア間で CTunnel を設定するには、IP アドレスを使用してインターフェイスを設定し、トンネルの宛先を指定する必要があります。ルータ A の宛先 Network Services Access Point(NSAP; ネットワーク サービス アクセス ポイント)のアドレスは、ルータ B の NSAP アドレスとなり、ルータ B の宛先 NSAP アドレスは、ルータ A の NSAP アドレスとなります。トンネルのいずれか一端の仮想インターフェイスに使用される IP アドレスは、同じ IP サブネットに属していることが理想的です。必ずトンネルの両側にルータを設定するようにしてください。

CTunnel

CTunnel により、IP トラフィックをコネクションレス型ネットワーク サービス(CLNS)を通じて転送できます。たとえば、SONET リングのデータ通信チャネル(DCC)などです。CTunnel により、IP パケットをコネクションレス型ネットワーク プロトコル(CLNP)を通じてトンネリングし、TCP/IP サービスを保持できます。

CTunnel を設定することで、CLNS 接続しかできないリモート ルータへ telnet 接続できます。Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)や Trivial File Transfer Protocol(TFTP)など、その他の管理機能も使用できます。これらは、CTunnel を設定しなければ、CLNS ネットワークで使用できません。

手順の概要

1. enable

2. configure terminal

3. interface ctunnel interface-number

4. ip address ip-address mask

5. ctunnel destination remote-nsap-address

6. end

7. show interfaces ctunnel interface-number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface ctunnel interface-number

 

Router(config)# interface ctunnel 102

仮想インターフェイスを作成して、CLNS トンネルを通じて IP を転送し、インターフェイス コンフィギュレーション モードを開始します。

(注) インターフェイス番号は、各 CTunnel インターフェイスについて一意であることが必要です。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 10.0.0.1 255.255.255.0

インターフェイスで IP をイネーブルにします。

IP アドレスとインターフェイスのマスクを指定するには、 ip-address および mask 引数を使用します。

ステップ 5

ctunnel destination remote-nsap-address

 

Router(config-if)# ctunnel destination 49.0001.2222.2222.2222.00

CTunnel の宛先 NSAP アドレスを指定します。ここでパケットがトンネルを出ます。

CTunnel のエンドポイントの NSAP アドレスを指定するには、 remote-nsap-address 引数を使用します。

ステップ 6

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 7

show interfaces ctunnel interface-number

 

Router# show interfaces ctunnel 102

(任意)CLNS トンネルを通る IP に関する情報を表示します。

CTunnel インターフェイスを指定するには、 interface-number 引数を使用します。

CTunnel の設定を確認するには、このコマンドを使用します。

トラブルシューティングのヒント

基本的なネットワーク接続の問題を診断するには、 ping コマンドを使用します。

この次の手順

「トンネルの設定と動作の確認」に進みます。

IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定

GRE モードで CTunnel を設定して IPv4 および IPv6 パケットを CLNS ネットワークで転送するには、この作業を実行します。

単一のルータ ペア間で CTunnel を設定するには、インターフェイスを IP アドレスを使用して設定し、トンネルの宛先を指定する必要があります。ルータ A の宛先 Network Services Access Point(NSAP; ネットワーク サービス アクセス ポイント)のアドレスは、ルータ B の NSAP アドレスとなり、ルータ B の宛先 NSAP アドレスは、ルータ A の NSAP アドレスとなります。トンネルのいずれか一端の仮想インターフェイスに使用される IP アドレスは、同じ IP サブネットに属していることが理想的です。必ずトンネルの両側にルータを設定するようにしてください。

CLNS ネットワークを経由する IPv4 および IPv6 パケット用トンネル

CTunnel インターフェイスで ctunnel mode gre コマンドを設定することにより、IPv4 および IPv6 パケットを CLNS を通じてトンネリングでき、RFC 3147 に準拠することができます。この RFC に準拠することで、同じ標準が採用されているシスコの機器と他のベンダーの機器間の相互運用が許可されます。

RFC 3147 では、パケットのトンネリングに GRE の使用を指定しています。この機能の実装には、ヘッダー フィールドに定義されている GRE サービスのサポート(チェックサム、キー、またはシーケンスの指定に使用されるサービス)は含まれません。これらの機能の使用を指定している受信パケットはすべて廃棄されます。

デフォルトの CTunnel モードは、標準のシスコ カプセル化の使用を続行します。ここでは、IPv4 パケットだけがトンネリングされます。IPv6 パケットのトンネリングも行う場合は、GRE カプセル化モードを使用する必要があります。いずれの方法も正常に動作するには、トンネルの両端を、同じモードで設定する必要があります。

前提条件

IPv4 または IPv6 アドレスを、CTunnel インターフェイスで設定することが必要です。また CTunnel の宛先には、手動設定された CLNS アドレスを割り当てることが必要です。

設定された CTunnel の両端にあるホストまたはルータは、IPv4 および IPv6 プロトコル スタック両方をサポートする必要があります。

CTunnel の送信元と宛先は、同じモードで実行されるよう設定することが必要です。

制約事項

GRE サービス(チェックサム、キー、シーケンスの指定に使用されるサービス)はサポートされません。これら機能の使用を要求するパケットはすべて廃棄されます。

手順の概要

1. enable

2. configure terminal

3. interface ctunnel interface-number

4. ip address ip-address mask

または

ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

5. ctunnel destination remote-nsap-address

6. ctunnel mode gre

7. end

8. show interfaces ctunnel interface-number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface ctunnel interface-number

 

Router(config)# interface ctunnel 102

仮想インターフェイスを作成して、CLNS トンネルを通じて IP を転送し、インターフェイス コンフィギュレーション モードを開始します。

(注) インターフェイス番号は、各 CTunnel インターフェイスについて一意であることが必要です。

ステップ 4

ip address ip-address mask

または

ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

 

Router(config-if)# ipv6 address 2001:0DB8:1234:5678::3/126

インターフェイスに割り当てられている IPv4 または IPv6 ネットワークを指定して、インターフェイス上で IPv4 または IPv6 パケット処理をイネーブルにします。

」のモジュールを参照してください。

ステップ 5

ctunnel destination remote-nsap-address

 

Router(config-if)# ctunnel destination 192.168.30.1

パケットを抽出する、CTunnel の宛先 NSAP アドレスを指定します。

CTunnel のエンドポイントの NSAP アドレスを指定するには、 remote-nsap-address 引数を使用します。

ステップ 6

ctunnel mode gre

 

Router(config-if)# ctunnel mode gre

IPv4 および IPv6 トラフィックの両方について CTunnel を GRE モードで実行することを指定します。

コマンドは、トンネルのカプセル化プロトコルとして GRE を指定します。

ステップ 7

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 8

show interfaces ctunnel interface-number

 

Router# show interfaces ctunnel 102

(任意)CLNS トンネルを通る IP に関する情報を表示します。

CTunnel インターフェイスを指定するには、 interface-number 引数を使用します。

CTunnel の設定を確認するには、このコマンドを使用します。

この次の手順

「トンネルの設定と動作の確認」に進みます。

手動 IPv6 トンネルの設定

この作業では、手動 IPv6 オーバーレイ トンネルの設定方法を説明します。

前提条件

手動設定された IPv6 トンネルを使用して、トンネル インターフェイスで IPv6 アドレスが設定されており、手動設定された IPv4 アドレスがトンネルの送信元と宛先に割り当てられていることを前提とします。手動設定されたトンネルの両端のホストまたはルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

5. tunnel source { ip-address | interface-type interface-number }

6. tunnel destination ip-address

7. tunnel mode ipv6ip

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 0

トンネル インターフェイスと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

 

Router(config-if)# ipv6 address 2001:0DB8:1234:5678::3/126

インターフェイスに割り当てられている IPv6 ネットワークを指定して、インターフェイス上で IPv6 パケット処理をイネーブルにします。

IPv6」のモジュールを参照してください。

ステップ 5

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source ethernet 0

送信元 IPv4 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

インターフェイスが指定されている場合、そのインターフェイスは IPv4 アドレスを使用して設定する必要があります。

ステップ 6

tunnel destination ip-address

 

Router(config-if)# tunnel destination 192.168.30.1

トンネル インターフェイスの宛先 IPv4 アドレスを指定します。

ステップ 7

tunnel mode ipv6ip

 

Router(config-if)# tunnel mode ipv6ip

手動 IPv6 トンネルを指定します。

コマンドは IPv6 トンネル向けに、IPv6 をパッセンジャ プロトコルとして指定し、IPv4 をキャリア(カプセル化)プロトコルおよびトランスポートプロトコルとして指定します。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

この次の手順

「トンネルの設定と動作の確認」に進みます。

6to4 トンネルの設定

この作業では、6to4 オーバーレイ トンネルの設定方法を説明します。

前提条件

6to4 トンネルでは、トンネルの宛先は、境界ルータの IPv4 アドレスによって決定されます。このアドレスは、プレフィクス 2002::/16 と連結されて 2002: border-router-IPv4-address ::/48 という形式になります。6to4 トンネルの各終端の境界ルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。

制約事項

ルータでサポートされる設定は、IPv4 互換トンネルおよび 6to4 IPv6 トンネルそれぞれ 1 つだけです。同じルータで両方のトンネル タイプの設定を選択する場合は、これらが同じ送信元を共有しないようにすることを強く推奨します。

6to4 トンネルと IPv4 互換トンネルが同じインターフェイスを共有できない理由は、これらがともに NBMA 「ポイントツーマルチポイント」アクセス リンクであり、多重化されたパケット ストリームを着信インターフェイスの単一パケット ストリームに再度配列するには、トンネルの送信元しか使用できないためです。したがって、IPv4 プロトコル タイプが 41 のパケットがインターフェイスに到着すると、このパケットは IPv4 アドレスに基づいて、IPv6 トンネル インターフェイスにマッピングされます。ただし、6to4 トンネルと IPv4 互換トンネルが同じ送信元インターフェイスを共有している場合、ルータは、着信パケットを割り当てるべき IPv6 トンネル インターフェイスを区別できません。

手動トンネルは「ポイントツーポイント」リンクであり、トンネルの IPv4 送信元と IPv4 宛先がともに定義されているので、IPv6 の手動設定トンネルは同じ送信元インターフェイスを共有できます。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

5. tunnel source { ip-address | interface-type interface-number }

6. tunnel mode ipv6ip 6to4

7. exit

8. ipv6 route ipv6-prefix / prefix-length tunnel tunnel-number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 0

トンネル インターフェイスと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

 

Router(config-if)# ipv6 address 2002:c0a8:6301:1::1/64

インターフェイスに割り当てられている IPv6 アドレスを指定して、インターフェイス上で IPv6 パケット処理をイネーブルにします。

最初のプレフィクス 2002::/16 に続く 32 ビットは、トンネル送信元に割り当てられている IPv4 アドレスに相当します。

」のモジュールを参照してください。

ステップ 5

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source ethernet 0

送信元 IPv4 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

コマンドで指定されているインターフェイスのタイプと番号は、IPv4 アドレスを使用して設定することが必要です。

ステップ 6

tunnel mode ipv6ip 6to4

 

Router(config-if)# tunnel mode ipv6ip 6to4

6to4 アドレスを使用して、IPv6 オーバーレイ トンネルを指定します。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

ipv6 route ipv6-prefix / prefix-length tunnel tunnel-number

 

Router(config)# ipv6 route 2002::/16 tunnel 0

指定されているトンネル インターフェイスへの IPv6 6to4 プレフィクス 2002::/16 のスタティック ルートを設定します。

(注) 6to4 オーバーレイ トンネルを設定する際、6to4 トンネル インターフェイスへの IPv6 6to4 プレフィクス 2002::/16 のスタティック ルートを設定する必要があります。

ipv6 route コマンドで指定されるトンネル番号は、 interface tunnel コマンドで指定されているトンネル番号と同じであることが必要です。

この次の手順

「トンネルの設定と動作の確認」に進みます。

IPv4 互換 IPv6 トンネルの設定

この作業では、IPv4 互換 IPv6 オーバーレイ トンネルの設定方法を説明します。

前提条件

トンネルの宛先は、IPv4 互換トンネルを使用して、IPv4 互換 IPv6 アドレスの下位 32 ビットに含まれる IPv4 アドレスにより自動的に決定されます。IPv4 互換トンネルの各終端のホストまたはルータは、IPv4 および IPv6 プロトコル スタックをサポートする必要があります。

制約事項

IPv4 互換トンネルは当初、IPv6 でサポートされていましたが、現在シスコでは、別の IPv6 オーバーレイ トンネリング技術を使用することを推奨しています。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. tunnel source { ip-address | interface-type interface-number }

5. tunnel mode ipv6ip auto-tunnel

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 0

トンネル インターフェイスと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source ethernet 0

送信元 IPv4 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

コマンドで指定されているインターフェイスのタイプと番号は、IPv4 アドレスを使用して設定することが必要です。

ステップ 5

tunnel mode ipv6ip auto-tunnel

 

Router(config-if)# tunnel mode ipv6ip auto-tunnel

IPv4 互換 IPv6 アドレスを使用して IPv4 互換トンネルを指定します。

この次の手順

「トンネルの設定と動作の確認」に進みます。

ISATAP トンネルの設定

この作業では、ISATAP オーバーレイ トンネルの設定方法を説明します。

前提条件

ISATAP トンネルの設定で使用される tunnel source コマンドは、IPv4 アドレスを使用して設定されたインターフェイスをポイントすることが必要です。ISATAP IPv6 アドレスおよびアドバタイズされたプレフィクス(1 つまたは複数)は、ネイティブ IPv6 インターフェイス向けに設定されます。IPv6 トンネル インターフェイスは、修正された EUI-64 アドレスを使用して設定する必要があります。これは、インターフェイス識別子の最後の 32 ビットが IPv4 トンネル送信元アドレスを使用して作成されているためです。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel-number

4. ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

5. no ipv6 nd suppress-ra

6. tunnel source { ip-address | interface-type interface-number }

7. tunnel mode ipv6ip isatap

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-number

 

Router(config)# interface tunnel 1

トンネル インターフェイスと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 address ipv6-prefix / prefix-length [ eui-64 ]

 

Router(config-if)# ipv6 address 2001:0DB8:6301::/64 eui-64

インターフェイスに割り当てられている IPv6 アドレスを指定して、インターフェイス上で IPv6 パケット処理をイネーブルにします。

」のモジュールを参照してください。

ステップ 5

no ipv6 nd suppress-ra

 

Router(config-if)# no ipv6 nd suppress-ra

IPv6 ルータ アドバタイズメントの送信をイネーブルにして、クライアントによる自動設定を可能にします。

デフォルトでは、トンネル インターフェイスでの IPv6 ルータ アドバタイズメントはディセーブルになります。

ステップ 6

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source ethernet 1/0/1

送信元 IPv4 アドレスまたは送信元インターフェイス タイプおよびトンネル インターフェイスの番号を指定します。

コマンドで指定されているインターフェイスのタイプと番号は、IPv4 アドレスを使用して設定することが必要です。

ステップ 7

tunnel mode ipv6ip isatap

 

Router(config-if)# tunnel mode ipv6ip isatap

ISATAP アドレスを使用して IPv6 オーバーレイ トンネルを指定します。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

この次の手順

「トンネルの設定と動作の確認」に進みます。

RBSCP トンネルの設定

RBSCP トンネルを設定するには、この作業を実行します。必ずトンネルの両側にルータを設定するようにしてください。

前提条件

この作業でトンネル ソースとして使用される物理インターフェイスは、すでに設定済みであることを確認してください。

制約事項

RBSCP は、衛星リンクなどの、エラー レートが高い無線または長距離の遅延リンクのために設計されました。エラー レートが高い長距離遅延リンクがない場合は、この機能を実装しないでください。

RBSCP トンネルによって使用されるインターフェイス上に IP アクセス制御リスト(ACL)が設定されている場合、RBSCP IP プロトコル(199)では、動作しないインターフェイスまたはトンネルの開始および終了を行える必要があります。

トンネルを介するトラフィックはプロセスで切り替えられるため、RBSCP には一部パフォーマンス上の制約事項があります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip unnumbered interface-type interface-number

5. tunnel source { ip-address | interface-type interface-number }

6. tunnel destination { hostname | ip-address }

7. tunnel bandwidth { receive | transmit } bandwidth

8. tunnel mode rbscp

9. tunnel rbscp ack-split split-size

10. tunnel rbscp delay

11. tunnel rbscp report

12. tunnel rbscp window-stuff step-size

13. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface tunnel 0

インターフェイス タイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered interface-type interface-number

 

Router(config-if)# ip unnumbered Ethernet 1

明示的な IP アドレスを割り当てずに、インターフェイスで IP 処理をイネーブルにします。

番号なしインターフェイスでパケットが生成される(たとえば、ルーティング アップデート)たびに、指定されたインターフェイスのアドレスが IP パケットのソース アドレスとして使用されます。

ステップ 5

tunnel source { ip-address | interface-type interface-number }

 

Router(config-if)# tunnel source Ethernet 1

トンネル ソースを設定します。

サービス プロバイダーの IP アドレスを指定する場合は、 ip-address 引数を使用します。

使用するインターフェイスを指定する場合は、 interface-type 引数および interface-number 引数を使用します。RBSCP では、インターフェイスをトンネル ソースとして指定することを推奨します。

ステップ 6

tunnel destination { hostname | ip-address }

 

Router(config-if)# tunnel destination 172.17.2.1

トンネルの宛先を設定します。

ホストの宛先の名前を指定するには、 hostname 引数を使用します。

ホストの宛先の IP アドレスを指定する場合は、 ip-address 引数を使用します。

ステップ 7

tunnel bandwidth { receive | transmit } bandwidth

 

Router(config-if)# tunnel bandwidth transmit 1000

パケットの送信に使用されるトンネル帯域幅を指定します。

帯域幅を指定する場合は、 bandwidth 引数を使用します。

は使用されなくなりました。

ステップ 8

tunnel mode rbscp

 

Router(config-if)# tunnel mode rbscp

トンネルで使用されるプロトコルを指定します。

RBSCP がトンネル プロトコルとして使用されるように指定する場合は、 rbscp 引数を使用します。

ステップ 9

tunnel rbscp ack-split split-size

 

Router(config-if)# tunnel rbscp ack-split 6

(任意)RBSCP トンネルで分割される TCP Acknowledgement(ACK)をイネーブルにします。

受信する各 ACK に送信される ACK の数を指定する場合は、 split-size 引数を使用します。

ACK のデフォルト数は 4 です。

ステップ 10

tunnel rbscp delay

 

Router(config-if)# tunnel rbscp delay

(任意)RBSCP トンネル遅延をイネーブルにします。

このコマンドは、衛星リンクに最も近い 2 つのルータ間で測定された RTT が 700 ミリ秒を超えている場合に限り使用します。

ステップ 11

tunnel rbscp report

 

Router(config-if)# tunnel rbscp report

(任意)廃棄された RBSCP パケットを SCTP にレポートします。

廃棄されたパケットを SCTP にレポートすることによって、より優良な帯域幅が使用されます。これは、RBSCP が、エンド ホストにある SCTP 実装に対して、廃棄パケットを再送信するよう指示し、これによって、エンド ホストでネットワークが輻輳していると見なされなくなるためです。

ステップ 12

tunnel rbscp window-stuff step-size

 

Router(config-if)# tunnel rbscp window-stuff 1

(任意)RBSCP トンネルの TCP ウィンドウ スケールの値を増やすことによって、TCP ウィンドウ スタッフィングをイネーブルにします。

ステップ増分数を指定する場合は、 step-size 引数を使用します。

ステップ 13

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

この次の手順

この作業は、衛星リンクのもう一方の側にあるルータ上で繰り返す必要があります。2 つ目のルータ上の IP アドレスの例、ホスト名、および他のパラメータを、適切な値に置き換えます。

衛星リンクのもう一方のルータの作業が終了した後、「RBSCP トンネルの設定と動作の確認」へ進みます。

トンネルの設定と動作の確認

この任意の作業では、トンネルの設定と動作の確認方法を説明します。この作業手順に含まれるコマンドは、任意の順序で実行でき、繰り返し実行する必要がある場合があります。次のコマンドは、GRE トンネル、IPv6 手動設定トンネル、および IPv4 GRE トンネルを介する IPv6 に使用できます。プロセスは、一般的な次の手順で構成されます(詳しい手順はその次に説明します)。


ステップ 1 ルータ A で、ルータ B の CTunnel インターフェイスの IP アドレスに対して ping を実行します。

ステップ 2 ステップ 2:ルータ B で、ルータ A の CTunnel インターフェイスの IP アドレスに対して ping を実行します。

手順の概要

1. enable

2. show interfaces tunnel number [ accounting ]

3. ping [ protocol ] destination

4. show ip route [ address [ mask ]]

5. ping [ protocol ] destination

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show interfaces tunnel number [ accounting ]

IPv6 手動設定トンネルおよび IPv4 GRE トンネルを介する IPv6 両方に適した汎用例を想定して、2 つのルータがトンネルのエンドポイントとして設定されているとします。ルータ A では、IPv4 アドレスが 10.0.0.1、IPv6 プレフィクスが 2001:0DB8:1111:2222::1/64 のトンネル インターフェイス 0 に対する送信元として、イーサネット インターフェイス 0/0 が設定されています。ルータ B では、IPv4 アドレスが 10.0.0.2、IPv6 プレフィクスが 2001:0DB8:1111:2222::2/64 のトンネル インターフェイスに対する送信元として、イーサネット インターフェイス 0/0 が設定されています。

トンネルの送信元と宛先アドレスが設定されていることを確認するには、ルータ A で show interfaces tunnel コマンドを使用します。

RouterA# show interfaces tunnel 0
 
Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 10.0.0.1 (Ethernet0/0), destination 10.0.0.2, fastswitch TTL 255
Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
Tunnel TTL 255
Checksumming of packets disabled, fast tunneling enabled
Last input 00:00:14, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4 packets input, 352 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
8 packets output, 704 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ステップ 3 ping [ protocol ] destination

ローカル エンドポイントが設定され、動作していることをチェックするには、ルータ A で ping コマンドを使用します。

RouterA# ping 2001:0DB8:1111:2222::2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0DB8:1111:2222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
 

ステップ 4 show ip route [ address [ mask ]]

リモート エンドポイント アドレスに対するルートが存在するかをチェックするには、 show ip route コマンドを使用します。

RouterA# show ip route 10.0.0.2
 
Routing entry for 10.0.0.0/24
Known via "connected", distance 0, metric 0 (connected, via interface)
Routing Descriptor Blocks:
* directly connected, via Ethernet0/0
Route metric is 0, traffic share count is 1
 

ステップ 5 ping [ protocol ] destination

リモート エンドポイント アドレスが到達可能かをチェックするには、ルータ A で ping コマンドを使用します。


) フィルタリングが原因で、ping コマンドを使用してもリモート エンドポイント アドレスが到達可能でない場合がありますが、トンネル トラフィックは宛先に到達可能です。


RouterA# ping 10.0.0.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/28 ms
 

リモート IPv6 トンネルのエンドポイントが到達可能かをチェックするには、ルータ A で ping コマンドを使用します。この例にも、フィルタリングに関する同じ注釈が適用されます。

RouterA# ping 1::2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
 

これらの手順は、トンネルのもう一方のエンドポイントでも繰り返します。


 

RBSCP トンネルの設定と動作の確認

次のオプション作業のいずれかまたは両方を実行して、「RBSCP トンネルの設定」で設定した RBSCP トンネルの設定と動作を確認します。

「RBSCP トンネルがアクティブであるかの確認」

「RBSCP トラフィックの確認」

RBSCP トンネルがアクティブであるかの確認

この作業を実行して、RBSCP トンネルがアクティブであることを確認します。

手順の概要

1. enable

2. show rbscp [ all | state | statistics ] [ tunnel tunnel-number ]

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show rbscp [ all | state | statistics ] [ tunnel tunnel-number ]

トンネルの現在の状態に関する情報を表示するには、 state キーワードおよび tunnel キーワードを指定してこのコマンドを使用します。次の出力例では、トンネルがオープン状態で示されています。

Router# show rbscp state tunnel 1
 
Tunnel1 is up, line protocol is up
RBSCP operational state: OPEN
RBSCP operating mode: (264h) ack-split window-stuffing inorder SCTP-report
window step: 1
drop scale: 0
ACK split size: 4
input drop scale: 2
initial TSN: 1h
fuzz factor: 0
max burst: tunnel 0, network 0
next TSN: 1h
next sequence: 16Bh
current outstanding: 0
max out per RTT: 2062500
packets since SACK: 0
cumulative ack: 0h
TSN at SACK: 0h
last cumulative ack: 0h
last delivered TSN: 0h
next FWDTSN corr: 0h
RTO: 704 ms
RTT: 550 ms srtt_sa: 4391 srtt_sv: 3
sentQ: num packets: 0, num bytes: 0
tmitQ: num packets: 0, num bytes: 0
 

トンネルに関する統計情報を表示するには、 statistics キーワードおよび tunnel キーワードを指定してこのコマンドを使用します。すべてのカウンタで、最後に clear rbscp コマンドを実行した以降の累積合計が表示されます。

Router# show rbscp statistics tunnel 0
 
Tunnel0 is up, line protocol is up
RBSCP protocol statistics:
Init FWD-TSNs sent 0, received 0
TUNNEL-UPs sent 0, received 0
CLOSEDs sent 0, received 0
TSNs sent 0, resent 0, lost by sender 0
TSNs received 0 (duplicates 0)
FWD-TSNs sent 144 (heartbeats 0)
FWD-TSNs received 0 (ignored 0)
FWD-TSNs caused 0 packet drops, 0 whole window drops
SACKs sent 0, received 0 (ignored 0)
Recovered with RTX 0
Received with delay 0
Most released at once 0
Failed sends into the: tunnel 1, network 0
Dropped due to: excess delay 0, tmit queue full 0
Max on any queue: num packets: 0, num bytes: 0
Max outstanding: 0


 

RBSCP トラフィックの確認

トラフィックが、RBSCP トンネルを介して、また、衛星リンク全体に送信されていることを確認するには、この作業を実行します。

手順の概要

1. enable

2. show interfaces tunnel number [ accounting ]

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show interfaces tunnel number [ accounting ]

トラフィックが RBSCP トンネルを介して送信中であることを示すには、このコマンドを使用します。

Router# show interfaces tunnel 0
 
Tunnel0 is up, line protocol is down
Hardware is Tunnel
Internet address is 172.17.1.4/24
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 172.17.1.2, destination 172.20.1.3
Tunnel protocol/transport RBSCP/IP, key disabled, sequencing disabled
Tunnel TTL 255
Checksumming of packets disabled
Tunnel transmit bandwidth 1000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
RBSCP operational state: invalid (0h)
RBSCP operating mode: (2EEh) delay dual-delay drop-long-delay ack-split window-t
window step: 3
drop scale : 0
ACK split size: 6
input drop scale: 5
initial TSN: 1h
fuzz factor: 0
next TSN: 1h
next sequence: 1h
current outstanding: 0
max out per RTT: 550000
packets since SACK: 0
cumulative ack: 0h
TSN at SACK: 1h
last cumulative ack: 0h
last delivered TSN: 0h
next FWDTSN corr: 0h
RTO: 704 ms
RTT: 550 ms srtt_sa: 0 srtt_sv: 4
sentQ: num packets: 0, num bytes: 0
tmitQ: num packets: 0, num bytes: 0
 
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out


 

トンネル実装の設定例

ここでは、次の例について説明します。

「GRE/IPv4 トンネルの設定:例」

「GRE/IPv6 トンネルの設定:例」

「GRE トンネルの IP 送信元と宛先 VRF メンバシップの設定:例」

「IP だけのバックボーンにおける 2 つの AppleTalk ネットワークのルーティング:例」

「パブリック サービス プロバイダーでのプライベート IP ネットワークおよび Novell ネットワークのルーティング:例」

「CTunnel の設定:例」

「IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定:例」

「手動 IPv6 トンネルの設定:例」

「6to4 トンネルの設定:例」

「IPv4 互換 IPv6 トンネルの設定:例」

「ISATAP トンネルの設定:例」

「RBSCP トンネルの設定例」

「RBSCP トンネルのルーティングの設定例」

「トンネル インターフェイスでの QoS オプションの設定:例」

GRE/IPv4 トンネルの設定:例

GRE トンネリングの単純な設定例を次に示します。イーサネット インターフェイス 0/1 は、ルータ A のトンネル送信元であり、ルータ B のトンネル宛先です。ファスト イーサネット インターフェイス 0/1 は、ルータ B のトンネル送信元であり、ルータ A のトンネル宛先です。

ルータ A

interface Tunnel0
ip address 10.1.1.2 255.255.255.0
tunnel source Ethernet0/1
tunnel destination 192.168.3.2
tunnel mode gre ip
!
interface Ethernet0/1
ip address 192.168.4.2 255.255.255.0

ルータ B

interface Tunnel0
ip address 10.1.1.1 255.255.255.0
tunnel source FastEthernet0/1
tunnel destination 192.168.4.2
tunnel mode gre ip
!
interface FastEthernet0/1
ip address 192.168.3.2 255.255.255.0
 

ルータ A とルータ B 間で IS-IS および IPv6 トラフィックをともに送出する GRE トンネルを設定する例を次に示します。

ルータ A

ipv6 unicast-routing
clns routing
!
interface Tunnel0
no ip address
ipv6 address 2001:0DB8:1111:2222::1/64
ipv6 router isis
tunnel source Ethernet0/0
tunnel destination 10.0.0.2
tunnel mode gre ip
!
interface Ethernet0/0
ip address 10.0.0.1 255.255.255.0
!
router isis
network 49.0000.0000.000a.00

ルータ B

ipv6 unicast-routing
clns routing
!
interface Tunnel0
no ip address
ipv6 address 2001:0DB8:1111:2222::2/64
ipv6 router isis
tunnel source Ethernet0/0
tunnel destination 10.0.0.1
tunnel mode gre ip
!
interface Ethernet0/0
ip address 10.0.0.2 255.255.255.0
!
router isis
network 49.0000.0000.000b.00
address-family ipv6
redistribute static
exit-address-family

GRE/IPv6 トンネルの設定:例

IPv6 トランスポートで GRE トンネルを設定する方法の例を次に示します。イーサネット 0/0 は設定済みの IPv6 アドレスを備えており、これがトンネル インターフェイスが使用するソース アドレスとなります。トンネルの宛先 IPv6 アドレスは直接指定されます。この例では、トンネルは IPv4 および IS-IS トラフィックの両方を伝送します。

interface Tunnel0
ip address 10.1.1.1 255.255.255.0
ip router isis
tunnel source Ethernet0/0
tunnel destination 2001:DB8:1111:2222::1
tunnel mode gre ipv6
!
interface Ethernet0/0
no ip address
ipv6 address 2001:DB8:1111:1111::1/64
!
router isis
net 49.0001.0000.0000.000a.00

GRE トンネルの IP 送信元と宛先 VRF メンバシップの設定:例

この例では、VRF green を使用してインターフェイス e0 で受信されたパケットは、VRF blue を使用してインターフェイス e1 を使用してトンネルから外部へ転送されます。図 9 に、単純なトンネルのシナリオを示します。

図 9 GRE トンネルの図

 

図 9 に示したトンネルの設定例を次に示します。

ip vrf blue
rd 1:1
 
ip vrf green
rd 1:2
 
interface loopback0
ip vrf forwarding blue
ip address 10.7.7.7 255.255.255.255
 
interface tunnel0
ip vrf forwarding green
ip address 10.3.3.3 255.255.255.0
tunnel source loopback 0
tunnel destination 10.5.5.5
tunnel vrf blue
 
interface ethernet0
ip vrf forwarding green
ip address 10.1.1.1 255.255.255.0
 
interface ethernet1
ip vrf forwarding blue
ip address 10.2.2.2 255.255.255.0
 

ip route vrf blue 10.5.5.5 255.255.255.0 ethernet 1

IP だけのバックボーンにおける 2 つの AppleTalk ネットワークのルーティング:例

単一プロトコル バックボーンでマルチプロトコル サブネットワークを接続する例を図 10 に示します。図 10 の後に、ルータ A およびルータ B の設定を示します。

図 10 IP だけのバックボーンにおける AppleTalk ネットワークの接続

 

ルータ A

interface ethernet 0
description physics department AppleTalk LAN
appletalk cable-range 4001-4001 32
!
interface fddi 0
description connection to campus backbone
ip address 10.0.8.108 255.255.255.0
interface tunnel 0
tunnel source fddi 0
tunnel destination 10.0.21.20
appletalk cable-range 5313-5313 1

ルータ B

interface ethernet 0
description chemistry department AppleTalk LAN
appletalk cable-range 9458-9458 3
!
interface fddi 0
description connection to campus backbone
ip address 10.0.21.20 255.255.255.0
interface tunnel 0
tunnel source fddi 0
tunnel destination 10.0.8.108
appletalk cable-range 5313-5313 2

パブリック サービス プロバイダーでのプライベート IP ネットワークおよび Novell ネットワークのルーティング:例

パブリック サービス プロバイダーでのプライベート IP ネットワークおよび Novell ネットワークをルーティングする例を図 11 に示します。図 11 の後に、ルータ A およびルータ B の設定を示します。

図 11 WAN での仮想プライベート ネットワークの作成

 

ルータ A

interface ethernet 0
description Boston office
ip address 10.1.1.1 255.255.255.0
novell network 1e
!
interface serial 0
description connection to public service provider
ip address 172.17.2.1 255.255.255.0
!
interface tunnel 0
tunnel source serial 0
tunnel destination 172.28.5.2
ip address 10.1.2.1 255.255.255.0
novell network 1f

ルータ B

interface ethernet 0
description Menlo Park office
ip address 10.1.3.1 255.255.255.0
novell network 31
!
interface serial 4
description connection to public service provider
ip address 172.28.5.2 255.255.255.0
!
interface tunnel 0
tunnel source serial 4
tunnel destination 172.17.2.1
ip address 10.1.2.2 255.255.255.0
novell network 1f

CTunnel の設定:例

ルータ A およびルータ B 間に CTunnel を作成する例を図 12 に示し、続いて設定例を示します。

図 12 CTunnel の作成

 

ルータ A

ip routing
clns routing
 
interface ctunnel 102
ip address 10.0.0.1 255.255.255.0
ctunnel destination 49.0001.2222.2222.2222.00
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.1111.1111.1111.00
router rip
network 10.0.0.0

ルータ B

ip routing
clns routing
 
interface ctunnel 201
ip address 10.0.0.2 255.255.255.0
ctunnel destination 49.0001.1111.1111.1111.00
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.2222.2222.2222.00
 
router rip
network 10.0.0.0

IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定:例

CLNS ネットワーク内のルータ A とルータ B 間で IS-IS および IPv6 トラフィックをともに送出する GRE CTunnel を設定する例を次に示します。 ctunnel mode gre コマンドにより、RFC 3147 に準拠したトンネリング方法が提供され、シスコの機器とサードパーティ製ネットワーキング デバイス間のトンネリングが許可されます。

ルータ A

ipv6 unicast-routing
 
clns routing
 
interface ctunnel 102
ipv6 address 2001:0DB8:1111:2222::1/64
ctunnel destination 49.0001.2222.2222.2222.00
ctunnel mode gre
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.1111.1111.1111.00

ルータ B

ipv6 unicast-routing
 
clns routing
 
interface ctunnel 201
ipv6 address 2001:0DB8:1111:2222::2/64
ctunnel destination 49.0001.1111.1111.1111.00
ctunnel mode gre
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.2222.2222.2222.00
 

シスコ機器のエンドポイント間で GRE モードをオフにして、CTunnel をデフォルトのシスコ カプセル化ルーティングのみに戻すには、 no ctunnel mode コマンドまたは ctunnel mode cisco コマンドのいずれかを使用します。同じ設定を IPv4 トラフィックだけを転送するよう修正した例を次に示します。

ルータ A

ip routing
 
clns routing
 
interface ctunnel 102
ip address 10.2.2.5 255.255.255.0
ctunnel destination 49.0001.2222.2222.2222.00
ctunnel mode cisco
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.1111.1111.1111.00

ルータ B

ip routing
 
clns routing
 
interface ctunnel 201
ip address 10.0.0.5 255.255.255.0
ctunnel destination 49.0001.1111.1111.1111.00
ctunnel mode cisco
 
interface Ethernet0/1
clns router isis
 
router isis
network 49.0001.2222.2222.2222.00

手動 IPv6 トンネルの設定:例

ルータ A とルータ B 間で手動 IPv6 トンネルを設定する例を次に示します。例では、ルータ A とルータ B のトンネル インターフェイス 0 は、グローバル IPv6 アドレスを使用して手動で設定されています。トンネルの送信元と宛先の IP アドレスも手動設定されています。

ルータ A

interface ethernet 0
ip address 192.168.99.1 255.255.255.0
 
interface tunnel 0
ipv6 address 2001:0db8:c18:1::3/126
tunnel source ethernet 0
tunnel destination 192.168.30.1
tunnel mode ipv6ip

ルータ B

interface ethernet 0
ip address 192.168.30.1 255.255.255.0
 
interface tunnel 0
ipv6 address 2001:0db8:c18:1::2/126
tunnel source ethernet 0
tunnel destination 192.168.99.1
tunnel mode ipv6ip

6to4 トンネルの設定:例

独立した IPv6 ネットワーク内の境界ルータで 6to4 トンネルを設定する例を次に示します。IPv4 アドレスは 192.168.99.1 で、IPv6 プレフィクス 2002:c0a8:6301::/48 に変換されます。IPv6 プレフィクスは、トンネル インターフェイス用に 2002:c0a8:6301::/64 、1 番目のネットワーク用に 2002:c0a8:6301:1::/64 、2 番目のネットワーク用に 2002:c0a8:6301:2::/64 というようにサブネット化されます。スタティック ルートにより、IPv6 プレフィクス 2002::/16 はトンネル インターフェイス 0 に送信され自動的にトンネリングが行われます。

interface Ethernet0
description IPv4 uplink
ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
description IPv6 local network 1
ipv6 address 2002:c0a8:6301:1::1/64
!
interface Ethernet2
description IPv6 local network 2
ipv6 address 2002:c0a8:6301:2::1/64
!
interface Tunnel0
description IPv6 uplink
no ip address
ipv6 address 2002:c0a8:6301::1/64
tunnel source Ethernet0
tunnel mode ipv6ip 6to4
!
ipv6 route 2002::/16 Tunnel0

IPv4 互換 IPv6 トンネルの設定:例

手動トンネルのメッシュを設定することなく、多数のルータ間で BGP を送出可能な IPv4 互換 IPv6 トンネルを設定する例を次に示します。各ルータは単一の IPv4 互換トンネルを備えており、複数の BGP セッションを各トンネルから互いに実行できます。トンネルの送信元としてイーサネット インターフェイス 0 が使用されます。トンネルの宛先は、IPv4 互換 IPv6 アドレスの下位 32 ビットに含まれる IPv4 アドレスにより自動的に決定されます。具体的には、IPv6 プレフィクス 0:0:0:0:0:0 は IPv4 アドレスに連結され(0:0:0:0:0:0:A.B.C.D または ::A.B.C.D という形式)、IPv4 互換 IPv6 アドレスが作成されます。イーサネット インターフェイス 0 は、グローバル IPv6 アドレスと IPv4 アドレスを使用して設定されます(インターフェイスは IPv6 および IPv4 プロトコル スタックをともにサポートします)。

例では、マルチプロトコル BGP を使用して、IPv6 到着可能性情報をピア 10.67.0.2 と置き換えています。イーサネット インターフェイス 0 の IPv4 アドレスは IPv4 互換 IPv6 アドレスの下位 32 ビットで使用され、ネクスト ホップ アトリビュートとしても使用されます。BGP ネイバーの IPv4 互換 IPv6 アドレスにより、IPv6 BGP セッションを IPv4 互換トンネルを介して自動的に転送できます。

interface tunnel 0
tunnel source Ethernet 0
tunnel mode ipv6ip auto-tunnel
 
interface ethernet 0
ip address 10.27.0.1 255.255.255.0
ipv6 address 3000:2222::1/64
 
router bgp 65000
no synchronization
no bgp default ipv4-unicast
neighbor ::10.67.0.2 remote-as 65002
 
address-family ipv6
neighbor ::10.67.0.2 activate
neighbor ::10.67.0.2 next-hop-self
network 2001:2222:d00d:b10b::/64

ISATAP トンネルの設定:例

次の例では、イーサネット 0 で定義されているトンネルの送信元と、ISATAP トンネルの設定に使用される tunnel mode コマンドを示します。ルータ アドバタイズメントをイネーブルにして、クライアントによる自動設定を可能にします。

interface Tunnel1
tunnel source ethernet 0
tunnel mode ipv6ip isatap
ipv6 address 2001:0DB8::/64 eui-64
no ipv6 nd suppress-ra

RBSCP トンネルの設定例

次に、衛星リンク経由の RBSCP トンネルを介してトラフィックが送信されるよう、ルータ 1 およびルータ 2 を設定します。

ルータ 1

interface Tunnel 0
ip unnumbered ethernet1
tunnel source ethernet1
tunnel destination 172.17.2.1
tunnel bandwidth transmit 1000
tunnel mode rbscp
tunnel rbscp ack-split 6
tunnel rbscp report
!
interface ethernet1
description Satellite Link
ip address 172.20.1.2 255.255.255.0

ルータ 2

interface Tunnel 0
ip unnumbered ethernet1
tunnel source ethernet1
tunnel destination 172.20.1.2
tunnel bandwidth transmit 1000
tunnel mode rbscp
tunnel rbscp ack-split 6
tunnel rbscp report
!
interface ethernet1
description Satellite Link
ip address 172.17.2.1 255.255.255.0

RBSCP トンネルのルーティングの設定例

RBSCP トンネルを使用するトラフィックのタイプを制御するには、適切なルーティングを設定する必要があります。すべてのトラフィックをトンネルを介して送信する場合、スタティック ルートを設定できます。


) ダイナミック ルーティング プロトコルが使用されている場合に、ルーティング フラップを防止するには、必ずトンネル インターフェイスをパッシブに設定してください。


次に、一部の特定のプロトコル タイプをトンネルを介して送信するために、ポリシー ベースのルーティングを使用する例を示します。この例では、拡張アクセス リストを使用して、TCP、Stream Control Transmission Protocol(SCTP)、Encapsulating Security Payload(ESP)プロトコル、および Authentication Header(AH; 認証ヘッダー)トラフィックで、トンネルを介した送信が可能です。すべての IP トラフィックは拒否されます。

ルータ 1(ローカル側)

interface Tunnel1
ip unnumbered FastEthernet1/1
tunnel source FastEthernet1/1
tunnel destination 10.12.0.20
tunnel mode rbscp
tunnel ttl 5
tunnel bandwidth transmit 30000
tunnel rbscp window-stuff 1
tunnel rbscp ack-split 4
!
interface FastEthernet0/0
ip address 10.13.0.1 255.255.255.0
ip policy route-map rbscp-pbr
duplex auto
speed auto
!
interface FastEthernet1/1
description Satellite Link
ip address 10.12.0.1 255.255.255.0
duplex auto
speed auto
!
ip route 10.15.0.0 255.255.255.0 FastEthernet1/1
!
ip access-list extended rbscp-acl
permit tcp any 10.15.0.0 0.0.0.255
permit 132 any 10.15.0.0 0.0.0.255
permit esp any 10.15.0.0 0.0.0.255
permit ahp any 10.15.0.0 0.0.0.255
deny ip any any
!
route-map rbscp-pbr permit 10
match ip address rbscp-acl
set interface Tunnel1

ルータ 2(リモート側)

ip dhcp pool CLIENT
import all
network 10.15.0.0 255.255.255.0
default-router 10.15.0.1
domain-name engineer.chicago.il.us
dns-server 10.10.0.252
!
interface Tunnel1
ip unnumbered FastEthernet0/1
tunnel source FastEthernet0/1
tunnel destination 10.12.0.1
tunnel mode rbscp
tunnel ttl 5
tunnel bandwidth transmit 30000
tunnel rbscp window-stuff 1
tunnel rbscp ack-split 4
!
interface FastEthernet0/0
description Local LAN
ip address 10.15.0.1 255.255.255.0
ip policy route-map rbscp-pbr
duplex auto
speed auto
!
interface FastEthernet0/1
description Satellite Link
ip address 10.12.0.20 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
ip access-list extended rbscp-acl
permit tcp any any
permit 132 any any
permit esp any any
permit ahp any any
deny ip any any
!
route-map rbscp-pbr permit 10
match ip address rbscp-acl
set interface Tunnel1

トンネル インターフェイスでの QoS オプションの設定:例

次の設定例は、トンネル インターフェイスの Generic Traffic Shaping (GTS)に直接適用されます。この例では、設定によりトンネル インターフェイスが全体的な出力レート 500 kbps にシェーピングされます。GTS の詳細については、『Cisco IOS Quality of Service Solutions Configuration Guide』の「 Regulating Packet Flow Using Traffic Shaping 」の章を参照してください。

interface Tunnel0
ip address 10.1.2.1 255.255.255.0
traffic-shape rate 500000 125000 125000 1000
tunnel source 10.1.1.1
tunnel destination 10.2.2.2
 

次の設定例では、Modular QoS CLI(MQC)コマンドを備えたトンネル インターフェイスに同じシェーピング ポリシーを適用する方法を示します。MQC の詳細については、『 Cisco IOS Quality of Service Solutions Configuration Guide 』の「Modular Quality of Service Command-Line Interface」の章を参照してください。

policy-map tunnel
class class-default
shape average 500000 125000 125000
!
interface Tunnel0
ip address 10.1.2.1 255.255.255.0
service-policy output tunnel
tunnel source 10.1.35.1
tunnel destination 10.1.35.2

ポリシングの例

インターフェイスが混雑しており、パケットのキューイングを開始した場合、送信待ちのパケットにキューイング方式を適用できます。この例に挙げているトンネル インターフェイスである Cisco IOS 論理インターフェイスは、混雑した状況を本質的にサポートしておらず、キューイング方式を適用するサービス ポリシーの直接適用もサポートしていません。代わりに、階層型ポリシーを適用する必要があります。 priority コマンドを使用した低遅延キューイングや、 bandwidth コマンドを使用した Class-Based Weighted Fair Queuing(CBWFQ)などのキューイング メカニズムを設定する「子」ポリシーまたは下位ポリシーを作成します。

policy-map child
class voice
priority 512
 

クラス ベースのシェーピングに適用する親ポリシーまたは上位ポリシーを作成します。子クラスのアドミッション制御は親クラスのシェーピング比率に従って実行されるので、親ポリシー下で子ポリシーをコマンドとして適用します。

policy-map tunnel
class class-default
shape average 2000000
service-policy child
 

親ポリシーをトンネル インターフェイスに適用します。

interface tunnel0
service-policy tunnel
 

次の例では、トンネル インターフェイスは、シェーピングを行わないキューイングを適用するサービス ポリシーを使用して設定されます。この設定がサポートされないことを通知するログ メッセージが表示されます。

interface tunnel1
service-policy output child
Class Based Weighted Fair Queueing not supported on this interface
 

QoS ポリシングの詳細については、『 Cisco IOS Quality of Service Solutions Configuration Guide 』を参照してください。

関連情報

IPv6 トンネルを実装済みの場合は、次のいずれかのモジュールに進みます。

自動 6to4 トンネルを設定している場合は、IPv4 アドレスから作成した /48 6to4 プレフィクスを取り巻く IPv6 ネットワークを設計できます。

ルーティング プロトコルを実装する場合は、「 Implementing RIP for IPv6 」、「 Implementing IS-IS for IPv6 」、「 Implementing OSPF for IPv6 」、または「 Implementing Multiprotocol BGP for IPv6 」の各モジュールを参照してください。

IPv6 ネットワークにセキュリティ機能を実装する場合は、「 Implementing Security for IPv6 」のモジュールを参照してください。

その他の参考資料

ここでは、トンネルの実装に関する関連資料について説明します。

関連資料

関連項目
参照先

トンネル コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

『Cisco IOS Interface and Hardware Component Command Reference』

CLNS コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

『Cisco IOS ISO CLNS Command Reference』

IP コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

『Cisco IOS IP Addressing Services Command Reference』

『Cisco IOS IP Application Services Command Reference』

『Cisco IOS IP Routing Protocols Command Reference』

IPv6 コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、コマンド履歴、使用に関する注意事項および例

『Cisco IOS IPv6 Command Reference』

IPv6 の機能

『Cisco IOS IPv6 Configuration Guide』

Generic Traffic Shaping を使用した、インターフェイス単位のパケット フローの調整

『Cisco IOS Quality of Service Solutions Configuration Guide』

Modular QoS CLI の設定

『Cisco IOS Quality of Service Solutions Configuration Guide』

仮想インターフェイスの設定

『Cisco IOS Interface and Hardware Component Configuration Guide』

GRE/IPSec トンネルが Network Address Translation(NAT; ネットワーク アドレス変換)を実行するファイアウォールを通過する IP セキュリティ(IPSec)を介する GRE の設定例

『Configuring IPSec/GRE with NAT』

マルチプロトコル ラベル スイッチングの設定

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

規格

規格
タイトル

新しい規格または変更された規格はサポートされていません。また、既存の規格に対するサポートに変更はありません。

--

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 791

Internet Protocol

RFC 1191

Path MTU Discovery

RFC 1323

TCP Extensions for High Performance

RFC 1483

Multiprotocol Encapsulation over ATM Adaptation Layer 5

RFC 2003

IP Encapsulation Within IP

RFC 2018

TCP Selective Acknowledgment Options

RFC 2460

Internet Protocol , Version 6 (IPv6)

RFC 2473

Generic Packet Tunneling in IPv6 Specification

RFC 2474

Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers

RFC 2516

A Method for Transmitting PPP over Ethernet (PPPoE)

RFC 2547

BGP/MPLS VPNs

RFC 2780

IANA Allocation Guidelines for Values in the Internet Protocol and Related Headers

RFC 2784

Generic Routing Encapsulation (GRE)

RFC 2890

Key and Sequence Number Extensions to GRE

RFC 2893

Transition Mechanisms for IPv6 Hosts and Routers

RFC 3056

Connection of IPv6 Domains via IPv4 Clouds

RFC 3147

Generic Routing Encapsulation over CLNS Networks

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト (http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。

Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。

http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

トンネル実装の機能情報

表 7 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) または 12.0(3)S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスできます。アクセスするには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 7 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 7 トンネル実装の機能情報

機能名
リリース
機能設定情報

CEF スイッチド マルチポイント GRE トンネル

12.2(8)T
15.0(1)M

CEF スイッチド マルチポイント GRE トンネル機能により、マルチポイント GRE トンネルとの間の IP トラフィックの CEF スイッチングが可能になりました。プレフィクスとトンネルの宛先がともにアプリケーションによって指定されている場合、トンネルのトラフィックは、トンネルの宛先を経由してプレフィクスへ転送できます。

この機能では、マルチポイント GRE トンネルでの CEF スイッチングが導入されています。以前のバージョンでは、マルチポイント GRE トンネルで使用可能なのはプロセス スイッチングだけでした。

この機能に関する詳細については、次の各項を参照してください。

「マルチポイント GRE トンネリング」

「トンネル タイプの決定」

「GRE トンネルの設定」

この機能により、導入または修正されたコマンドはありません。

CLNS ネットワークにおける IPv4 および IPv6 パケットの GRE トンネリングに対する CLNS サポート

12.3(7)T
12.2(25)S

12.2(33)SRA

GRE トンネル モードのサポートにより、シスコの CTunnel では CLNS 単独ネットワークで、シスコ ネットワーキング機器と他のベンダー製機器間の相互運用を許可する形式で、IPv4 および IPv6 パケットを転送できるようになりました。この機能により、RFC 3147 への準拠が実現します。

この機能に関する詳細については、次の各項を参照してください。

「IPv4 および IPv6 パケットに対する GRE/CLNS トンネルのサポート」

「トンネル タイプの決定」

「IPv4 および IPv6 パケットを伝送するための GRE/CLNS CTunnel の設定」

「トンネルの設定と動作の確認」

この機能により、コマンド ctunnel mode が導入されました。

GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ

12.0(23)S

12.2(20)S

12.2(27)SBC
12.3(2)T

12.2(33)SRA
12.2(33)SRB
12.2(31)SB5
12.4(15)T

トンネルの送信元と宛先を任意の VPN VRF テーブルに所属するよう設定できます。

12.0(23)S で、この機能が導入されました。

12.2(20)S では、この機能は PXF 処理パスで NSE-100 を使用する Cisco 7304 ルータで使用可能になりました。

12.2(31)SB5 では、PRE2 および PRE3 に関する Cisco 10000 シリーズ ルータのサポートが追加されました。

この機能に関する詳細については、次の各項を参照してください。

「GRE トンネルの IP 送信元および宛先の VPN ルーティング/転送(VRF)メンバシップ」

「GRE トンネル IP 送信元および宛先 VRF メンバシップの設定」

「GRE トンネルの IP 送信元と宛先 VRF メンバシップの設定:例」

この機能をサポートするため、コマンド tunnel vrf が導入されました。

GRE トンネル キープアライブ

12.2(8)T
12.0(23)S
15.0(1)M

GRE トンネル キープアライブ機能により、IP カプセル化された総称ルーティング カプセル化(GRE)トンネルを介してキープアライブ パケットを送信されるよう設定する機能が提供されます。キープアライブが送信されるレートと、インターフェイスが非アクティブになるまでデバイスが応答なしでキープアライブ パケットの送信を続行する回数を指定できます。GRE キープアライブ パケットは、トンネルの両側または片側のみのどちらでも送信できます。

この機能に関する詳細については、次の項を参照してください。

「GRE トンネルの設定」

この機能により、コマンド keepalive (トンネル インターフェイス)が導入されました。

Rate-Based Satellite Control Protocol

12.3(7)T

Rate-Based Satellite Control Protocol(RBSCP)は、衛星リンクなどの、エラー レートが高い無線または長距離の遅延リンクのために設計されました。RBSCP では、トンネルを使用して、エンドツーエンド モデルを中断することなく衛星リンクを介して TCP および IP Security(IPSec)などの特定の IP プロトコルのパフォーマンスを改善できます。

この機能に関する詳細については、次の各項を参照してください。

「Rate-Based Satellite Control Protocol トンネル」

「トンネル タイプの決定」

「RBSCP トンネルの設定」

「RBSCP トンネルの設定と動作の確認」

この機能により、 clear rbscp debug tunnel rbscp show rbscp tunnel bandwidth tunnel mode tunnel rbscp ack-split tunnel rbscp delay tunnel rbscp input-drop tunnel rbscp long-drop tunnel rbscp report tunnel rbscp window-stuff の各コマンドが導入または修正されました。

Tunnel ToS(ToS)

12.0(17)S
12.0(17)ST
12.2(8)T
12.2(14)S
15.0(1)M

Tunnel ToS 機能を使用して、ルータの IP トンネル インターフェイス向けのトンネル パケットのカプセル化 IP ヘッダーに、ToS および Time-to-Live(TTL)バイト値を設定できます。Tunnel ToS 機能は、シスコ エクスプレス フォワーディング(CEF)、ファスト スイッチング、プロセス スイッチング フォワーディング モードでサポートされます。

この機能に関する詳細については、次の項を参照してください。

「Tunnel ToS(ToS)」

この機能により、 show interfaces tunnel tunnel tos tunnel ttl の各コマンドが導入または変更されました。