Cisco IOS インターフェイスおよびハードウェア コ ンポーネント コンフィギュレーション ガイド
LAN インターフェイスの設定
LAN インターフェイスの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

LAN インターフェイスの設定

イーサネット、ファスト イーサネット(FE)、またはギガビット イーサネット インターフェイスの設定

イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定作業の一覧

イーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスの指定

イーサネット カプセル化方式の指定

全二重動作の指定

メディアおよびコネクタ タイプの指定

10BASE-T 機能の拡張

ファスト イーサネット 100BASE-T の設定

PA-12E/2FE ポート アダプタの設定

100VG-AnyLAN ポート アダプタの設定

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E 入力/出力コントローラの設定

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E の設定作業の一覧

インターフェイスの伝送モードの設定

インターフェイス速度の設定

イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定

設定の確認

Cisco7200-I/OGE+E および Cisco7200-I/O-2FE/E のモニタリングとメンテナンス

ファスト EtherChannel の設定

ファスト EtherChannel の設定作業の一覧

ポートチャネル インターフェイスの設定

ファスト イーサネット インターフェイスの設定

ギガビット イーサネット インターフェイスの設定

FDDI インターフェイスの設定

Cisco4000-M、Cisco4500-M、Cisco4700-M ルータの FDDI でのソースルート ブリッジング(SRB)

Cisco7200 シリーズ ルータのソースルート ブリッジ パケットのパーティクルベース スイッチング

接続管理(CMT)情報の使用方法

FDDI の設定作業の一覧

FDDI インターフェイスの指定

FDDI ブリッジング カプセル化のイネーブル化

FDDI インターフェイスの全二重モードのイネーブル化

トークン回転時間の設定

有効な伝送タイマーの設定

伝送タイマーの制御

C-Min タイマーの変更

TB-Min タイマーの変更

FDDI タイムアウト タイマーの変更

SMT フレーム処理の制御

重複アドレス チェックのイネーブル化

ビット制御の設定

CMT マイクロコードの制御

FDDI の起動と停止

トークン制限ごとの FDDI フレームの設定

FDDI SMT メッセージ キュー サイズの制御

バースト性 FDDI トラフィックのバッファの事前割り当て

ハブ インターフェイスの設定

ハブ ポートのイネーブル化

受信データの自動極性反転のディセーブル化またはイネーブル化

リンク テスト機能のディセーブル化またはイネーブル化

送信元アドレス制御のイネーブル化

SNMP 不正アドレス トラップのイネーブル化

トークン リング インターフェイスの設定

Cisco7200 シリーズ ルータのソースルート ブリッジ パケットのパーティクルベース スイッチング

専用トークン リング ポート アダプタ

トークン リング インターフェイスの設定作業の一覧

トークン リング インターフェイスの指定

アーリー トークン リリースのイネーブル化

PCbus トークン リング インターフェイス管理の設定

トークン リング コンセントレータ ポートのイネーブル化

ポートのモニタリングおよびメンテナンス

LAN インターフェイスの設定例

イーサネット カプセル化のイネーブル化例

全二重モードのイネーブル化操作の例

PA-12E/2FE ポートの設定例

PA-VG100 ポート アダプタの設定例

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E の設定例

Cisco 7200-I/O-GE+E のギガビット イーサネット インターフェイスの設定

Cisco 7200-I/O-2FE/E の自動ネゴシエーションの設定

ファスト EtherChannel の設定例

FDDI フレームの設定例

ハブの設定例

ハブ ポートの起動例

イーサネット ハブ ポートの送信元アドレスの設定例

ハブ ポートのシャットダウン例

ハブ ポートの SNMP 不正アドレス トラップのイネーブル化例

LAN インターフェイスの設定

シスコのルータおよびアクセス サーバでサポートされる LAN インターフェイスを設定するには、この章に記載された情報を使用します。

機能に関連するハードウェア プラットフォームまたはソフトウェア イメージ情報を確認するには、Cisco.com で提供されている Cisco Feature Navigator を使用して機能に関する情報を検索します。

この章では、LAN インターフェイスを設定するプロセスについて説明します。内容は、次のとおりです。

「イーサネット、ファスト イーサネット(FE)、またはギガビット イーサネット インターフェイスの設定」

「Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E 入力/出力コントローラの設定」

「ファスト EtherChannel の設定」

「FDDI インターフェイスの設定」

「ハブ インターフェイスの設定」

「トークン リング インターフェイスの設定」

設定作業の例については、「LAN インターフェイスの設定例」を参照してください。

ハードウェアに関する技術的な説明およびインターフェイスのインストールに関する情報については、ご使用の製品のハードウェアのインストールおよび設定マニュアルを参照してください。この章で使用する LAN インターフェイス コマンドの詳細については、『 Cisco IOS Interface and Hardware Component Command Reference 』を参照してください。この章に記載されているその他のコマンドのマニュアルを見つけるには、マスター コマンド リストを使用するか、オンラインで検索してください。

イーサネット、ファスト イーサネット(FE)、またはギガビット イーサネット インターフェイスの設定

シスコは、10 Mbps イーサネット、100 Mbps Fast Ethernet(FE; ファスト イーサネット)、および 1000 Mbps ギガビット イーサネットをサポートします。10 Mbps、100 Mbps、1000 Mbps イーサネット インターフェイスは、さまざまなイーサネット ネットワーク インターフェイス カードまたはシステムでサポートされています。

ファスト イーサネット NP-1FE モジュールの利点

VLAN ルーティング:VLAN サポートにより、ネットワーク マネージャは、物理的な位置によってではなく、論理的にユーザをグループ分けできます。基盤となる Cisco 4700 の高パフォーマンスと機能が豊富な NP-1FE は、VLAN 間ルーティングなどの低密度、高パフォーマンス アプリケーションに理想的な組み合わせになります。

高速相互接続:ファスト イーサネット インターフェイスにより、ネットワーク マネージャは、キャンパスまたはエンタープライズ バックボーン、データセンターなど、広範なアプリケーションに最適なコストおよびパフォーマンスのファスト イーサネット ルーティング ソリューションを実装できます。また、従来の低速 WAN サービスにファスト イーサネット アクセスを低コストで提供することも可能です。

ローカルエリア ネットワークの集約:Cisco 4500 または Cisco 4700 シリーズ ルータは、12 個のイーサネット、4 個のトークン リング、または 1 個の Fiber Distributed Data Interface(FDDI; ファイバ分散データ インターフェイス)セグメントをサポートします。Integrated Services Digital Network(ISDN)インターフェイスもサポートされます。

Catalyst 3000 または Catalyst 5000 システムでは、ファスト イーサネット プロセッサを使用して、最大 12 個の 10 Mbps LAN を集約して、ファイアウォールを提供し、アクセス リストを保持するレイヤ 3 ルーティング サービスへの高速アクセスを提供できます。

ファスト イーサネットおよびギガビット イーサネット対応 Cisco 7200 シリーズ ルータ

Cisco 7200 シリーズ ルータは、ファスト イーサネット サポート用に RJ-45 インターフェイスを備えた Input/Output(I/O; 入力/出力)コントローラ、ギガビット イーサネット サポート用に RJ-45 および GBIC インターフェイスの両方を備えた I/O コントローラをサポートします。

Cisco 7200-I/O-GE+E は、ギガビット イーサネット ポート 1 個およびイーサネット ポート 1 個を備えた入力/出力コントローラです。また、1000 Mbps 動作用に GBIC レセプタクルおよび 10 Mbps 動作用に RJ-45 レセプタクルを装備しています。

Cisco 7200-I/O-2FE/E は、自動検知ファスト イーサネット ポート 2 個、および 10/100 Mbps 動作用に RJ-45 レセプタクル 2 個を備えた I/O コントローラです。

ファスト イーサネット ポートを 100 Mbps 全二重または半二重動作で使用するように設定できます(デフォルトは半二重です)。ファスト イーサネット ポートは、Media Independent Interface(MII; メディア独立型インターフェイス)レセプタクル 1 個、または MII レセプタクルと RJ-45 レセプタクルを備えています。この新機能をサポートするために、 media-type インターフェイス コマンドが変更されました。 media-type コマンドは現在次の 2 つのオプションをサポートしています。

100BASE-X :RJ-45 100BASE-X 物理接続を指定します。

mii :メディア独立型インターフェイスを指定します。

Cisco 7200-I/O-GE+E のギガビット イーサネット インターフェイスは、全二重で動作し、半二重モード用に設定できません。

第二世代の Fast Ethernet Interface Processor(FEIP; ファスト イーサネット インターフェイス プロセッサ)(FEIP2-DSW-2TX および FEIP2-DSW-2FX)は、Cisco 7500 シリーズ ルータおよび 7000 シリーズ ルート スイッチ プロセッサ(RSP7000)と 7000 シリーズ シャーシ インターフェイス(RSP7000CI)搭載 Cisco 7000 シリーズ ルータで使用できます。FEIP2-DSW は、100 Mbps ファスト イーサネット(FE)インターフェイス 2 個を備えたデュアル ポートの固定構成インターフェイス プロセッサです。FEIP2-DSW の各インターフェイスは、半二重および全二重をサポートします。

特定のプラットフォームおよびハードウェアの互換性の詳細については、『 Cisco Product Catalog 』を参照してください。

イーサネット ポート番号を表示するには、 show interfaces show controllers mci 、および show controllers cbus EXEC コマンドを使用します。これらのコマンドは、ルータまたはアクセス サーバでサポートされる各インターフェイスのレポートを提供します。

インターフェイスの統計情報を表示するには show interfaces fastethernet コマンド、ファスト イーサネット コントローラ チップに関する情報を表示するには show controllers fastethernet コマンドを使用します。出力に、初期化ブロック情報、送信リング、受信リング、およびエラーに関する情報を含む統計情報が表示されます。

インターフェイスの統計情報を表示するには show interfaces gigabitethernet コマンド、ギガビット イーサネット コントローラ チップに関する情報を表示するには show controllers gigabitethernet コマンドを使用します。出力に、初期化ブロック情報、送信リング、受信リング、およびエラーに関する情報を含む統計情報が表示されます。

ファスト EtherChannel の設定方法については、「ファスト EtherChannel の設定」に示されている作業を参照してください。

イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定作業の一覧

イーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスで機能を設定するには、次の項で説明する作業を実行します。

「イーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスの指定」(必須)

「イーサネット カプセル化方式の指定」(任意)

「全二重動作の指定」(任意)

「メディアおよびコネクタ タイプの指定」(任意)

「10BASE-T 機能の拡張」(任意)

「ファスト イーサネット 100BASE-T の設定」(任意)

「PA-12E/2FE ポート アダプタの設定」(任意)

「100VG-AnyLAN ポート アダプタの設定」(任意)

イーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスの指定

イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config)# interface ethernet number

インターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface ethernet slot / port

Cisco 7200 および Cisco 7500 シリーズ ルータのインターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface ethernet slot / port-adapter / port

Cisco 7500 シリーズ ルータのインターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface fastethernet number

ファスト イーサネット Network Interface Module(NIM)がインストールされている Cisco 4000 シリーズのインターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface fastethernet slot / port

Cisco 7200 シリーズ ルータでファスト イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface fastethernet slot / port-adapter / port

Cisco 7500 シリーズ ルータでファスト イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface gigabitethernet slot / port

Cisco 7200 シリーズ ルータでギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ファスト イーサネット スロットおよびポートを表示するには、 show interfaces fastethernet コマンドを使用します。ファスト イーサネット Network Interface Module(NIM)およびファスト イーサネット インターフェイス プロセッサ(FEIP)のデフォルトは半二重モードです。

イーサネット カプセル化方式の指定

現在、一般的なイーサネット カプセル化方式は 3 つあります。

標準的な Advanced Research Projects Agency(ARPA)イーサネット バージョン 2.0 カプセル化は、16 ビット プロトコル タイプ コードを使用します(デフォルトのカプセル化方式)。

Service Access Point(SAP; サービス アクセスポイント)IEEE 802.3 カプセル化では、タイプ コードが IEEE 802.2 LLC カプセル化のフレーム長になります(宛先および送信元のサービス アクセス ポイント、および制御バイト)。

RFC 1042「 Standard for the Transmission of IP Datagrams Over IEEE 802 Networks 」で指定されている SNAP 方式では、イーサネット プロトコルを IEEE 802.2 メディアで実行できます。

使用するカプセル化方式は、使用しているルーティング プロトコル、ルータまたはアクセス サーバに接続されているイーサネット メディアのタイプ、および設定したルーティングまたはブリッジング アプリケーションによって異なります。

IP パケットのイーサネット カプセル化を設定するには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# encapsulation arpa

ARPA イーサネット カプセル化を選択します。

Router(config-if)# encapsulation sap

SAP イーサネット カプセル化を選択します。

Router(config-if)# encapsulation snap

SNAP イーサネット カプセル化を選択します。

IP のイーサネット カプセル化を選択する例については、「イーサネット カプセル化のイネーブル化例」を参照してください。

全二重動作の指定

FEIP2-DSW-2FX では半二重モードがデフォルトです。FEIP2-DSW-2FX(最大集約帯域幅 200 Mbps)で全二重モードをイネーブルにするには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# full-duplex

 

または

Router(config-if)# no half-duplex

FEIP2-DSW-2FX のファスト イーサネット インターフェイスで全二重モードをイネーブルにします。

ファスト イーサネット インターフェイスで全二重モードをイネーブルにする例については、「全二重モードのイネーブル化操作の例」を参照してください。


注意 システムの問題を回避するために、両方の FEIP2-DSW-2FX インターフェイスを同時に全二重動作用に設定しないでください。

FEIP2-DSW-2TX は半二重だけをサポートするため、全二重用に設定しないでください。

メディアおよびコネクタ タイプの指定

Cisco 4000 シリーズ ルータのイーサネット Network Interface Module(NIM)がデフォルトの Attachment Unit Interface(AUI; アタッチメント ユニット インターフェイス)と 15 ピン コネクタ、または 10BASE-T と RJ-45 コネクタのいずれかを使用するように指定できます。それには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# media-type aui

15 ピン イーサネット コネクタを選択します。

Router(config-if)# media-type 10baset

RJ-45 イーサネット コネクタを選択します。

デフォルトのメディア コネクタ タイプは RJ-45 または SC(光ファイバ)コネクタです。インターフェイスが MII コネクタまたはデフォルトの RJ-45 または SC(光ファイバ)コネクタのいずれかを使用するように設定できます。それには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# media-type mii

MII イーサネット コネクタを選択します。

Router(config-if)# media-type 100basex

FEIP2-DSW-2TX には RJ-45 イーサネット コネクタ、FEIP2-DSW-2FX には SC コネクタを選択します。


) MII レセプタクルと RJ-45 レセプタクルを備えた I/O コントローラを使用する場合は、レセプタクルを一度に 1 つだけ使用するように設定できます。


10BASE-T 機能の拡張

Cisco 4000 シリーズまたは Cisco 4500 シリーズ ルータでは、 スケルチ (信号カットオフ時間)を削減することで標準の 100 m を超えて 10BASE-T 機能を拡張できます。この機能は、LANCE コントローラの 10BASE-T インターフェイスにだけ適用されます。LANCE は、Cisco 4000 および Cisco 4500 イーサネット インターフェイス用 AMD コントローラ チップで、ファスト イーサネット インターフェイスには適用されません。

スケルチを削減するには、インターフェイス コンフィギュレーション モードで次の表の 1 つめのコマンドを使用します。後でスケルチを通常に戻す場合は、2 つめのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# squelch reduced

スケルチを削減します。

Router(config-if)# squelch normal

スケルチを通常に戻します。

ファスト イーサネット 100BASE-T の設定

イーサネット LAN 上のデバイスとして認識されるように、Cisco AS5300 にファスト イーサネット 100BASE-T インターフェイスを設定する必要があります。ファスト イーサネット インターフェイスは、10BASE-T および 100BASE-T ルータ、ハブ、およびスイッチで 10 Mbps および 100 Mbps の速度をサポートします。

インターフェイスを設定するには、特権 EXEC モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface fastethernet number

ファスト イーサネット インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip address address subnet-mask

IP アドレスとサブネット マスクをインターフェイスに割り当てます。

ステップ 4

Router(config-if)# speed { 10 | 100 | auto }

インターフェイスに速度を指定します。デフォルト値は 100 Mbps です。1

duplex コマンド オプションと speed コマンド オプションの関係については、 表 1 を参照してください。

ステップ 5

Router(config-if)# duplex { full | half | auto }

ファスト イーサネット インターフェイスにデュプレックス設定を設定します。デフォルトは半二重です。1

duplex コマンド オプションと speed コマンド オプションの関係については、 表 1 を参照してください。

1.auto オプションは、速度およびピア ルータ、ハブ、またはスイッチ メディアに基づいて自動的に速度をネゴシエートします。

自動ネゴシエーション機能を使用するには(つまり、速度とデュプレックス モードを自動的に検出するには)、 speed コマンドおよび duplex コマンドを auto に設定する必要があります。 speed コマンドを auto に設定すると速度だけがネゴシエートされ、 duplex コマンドを auto に設定するとデュプレックスだけがネゴシエートされます。 表 1 に、 duplex コマンド オプションと speed コマンド オプションのさまざまな組み合わせに対するアクセス サーバのパフォーマンスを示します。指定された duplex コマンド オプションと指定された speed コマンド オプションを組み合わせると、その結果のシステム アクションが実行されます。

 

表 1 duplex コマンド オプションと speed コマンド オプションの関係

duplex コマンド
speed コマンド
システム アクション

Router(config-if)# duplex auto

speed auto

速度とデュプレックス モードの両方を自動ネゴシエートします。

Router(config-if)# duplex auto

speed 10 or speed 100

速度とデュプレックス モードの両方を自動ネゴシエートします。

Router(config-if)# duplex half

 

または

Router(config-if)# duplex full

speed auto

速度とデュプレックス モードの両方を自動ネゴシエートします。

Router(config-if)# duplex half

speed 10

10 Mbps および半二重を強制的に適用します。

Router(config-if)# duplex full

speed 10

10 Mbps および全二重を強制的に適用します。

Router(config-if)# duplex half

speed 100

100 Mbps および半二重を強制的に適用します。

Router(config-if)# duplex full

speed 100

100 Mbps および全二重を強制的に適用します。

PA-12E/2FE ポート アダプタの設定

PA-12E/2FE イーサネット スイッチ ポート アダプタは、Cisco 7200 シリーズ ルータに集約帯域幅 435 Mbps、全二重の最大 12 個の 10 Mbps および 2 個の 10/100 Mbps スイッチド イーサネット インターフェイス(10BASE-T)およびファスト イーサネット インターフェイス(100BASE-TX)を提供します。PA-12E/2FE ポート アダプタは、Unshielded Twisted Pair(UTP; シールドなしツイストペア)ケーブルでの 10 Mbps および 100 Mbps の伝送用にイーサネット、IEEE 802.3、および IEEE 802.3u 仕様をサポートします。

PA-12E/2FE ポート アダプタは、PA-12E/2FE ポート アダプタの同じ Virtual LAN(VLAN; 仮想 LAN)内のインターフェイス間でストアアンドフォワードまたはカットスルー スイッチング テクノロジーを使用して、ホスト CPU からレイヤ 2 スイッチングのロードを軽減します。PA-12E/2FE ポート アダプタは最大 4 つの VLAN(ブリッジ グループ)をサポートします。


) PA-12E/2FE ポート アダプタはデュアル幅のポート アダプタで、Cisco 7200 シリーズ ルータにインストールされると、水平に並んだポート アダプタ スロット 2 個を占有します (シングル幅のポート アダプタは、Cisco 7200 シリーズ ルータの個別のポート アダプタ スロットを占有します)。


PA-12E/2FE ポート アダプタのすべてのインターフェイスは、接続されているデバイスとの適切な伝送モード(半二重または全二重)の自動検知および自動ネゴシエーションをサポートします。最初の 2 つの PA-12E/2FE インターフェイス(ポート 0 とポート 1)は、接続されているデバイスとの適切な接続速度(10 Mbps または 100 Mbps)の自動検知および自動ネゴシエーションもサポートします。接続されているデバイスが適切な伝送モードの自動検知および自動ネゴシエーションをサポートしていない場合、デバイスに接続されている PA-12E/2FE インターフェイスは自動的に半二重モードを開始します。PA-12E/2FE インターフェイスが、接続されているデバイスとの適切な伝送モードを自動検知し、自動ネゴシエートしているかどうかを調べるには、 show system:running-config コマンドを使用します。PA-12E/2FE インターフェイスの伝送モードを変更するには、 full-duplex コマンドおよび half-duplex コマンドを使用します。インターフェイスの伝送モードを変更した後、伝送モードを確認するには、 show interfaces コマンドを使用します。


full-duplex コマンドおよび half-duplex コマンドを使用して最初の 2 つの PA-12E/2FE インターフェイス(ポート 0 とポート 1)の伝送モードを変更した場合、この 2 つの PA-12E/2FE インターフェイスの伝送速度は自動的にデフォルトの 100 Mbps に設定されます。最初の 2 つの PA-12E/2FE インターフェイスは、接続されているデバイスとの適切な接続速度(10 Mbps または 100 Mbps)を自動検知し、自動ネゴシエートしている場合、10 Mbps に限り動作します。


PA-12E/2FE ポート アダプタを設定するには、次の項で説明する作業を実行します。一覧内の各作業は、必須と任意に分けられています。

「PA-12E/2FE ポート アダプタの設定」(必須)

「PA-12E/2FE ポート アダプタのモニタリングとメンテナンス」(任意)

「12E/2FE VLAN 設定 WebTool を使用したブリッジ グループの設定」(任意)


) PA-12E/2FE インターフェイスを使用してネットワークから起動する場合(Trivial File Transfer Protocol(TFTP)を使用)、インターフェイスがループフリー環境用に設定されていること、インターフェイスのブリッジ グループ仮想インターフェイスの IP アドレスが設定されていること、およびシステム ブート イメージ 11.2(10)P がルータにインストールされていることを確認します(ルータのシステム ブート イメージを表示するには、show version コマンドを使用します)。ネットワーク サーバから起動する前にbridge-group bridge-group number spanning-disabled コマンドを使用してインターフェイスに設定されているスパニング ツリー プロトコルをディセーブルにして TFTP サーバがタイムアウトしてセッションを終了しないようにします。TFTP を使用したネットワークからの起動、ネットワーク サーバからのシステム イメージのロード、および Cisco 7200 シリーズ ルータのスパニング ツリー プロトコルの設定の詳細については、ハードウェアに付属の『PA-12E/2FE Ethernet Switch Port Adapter』および『Cisco IOS Bridging and IBM Networking Configuration Guide』を参照してください。


PA-12E/2FE ポート アダプタの設定に使用できるその他のコマンドの詳細については、『 Cisco IOS Interface and Hardware Component Command Reference 』を参照してください。ブリッジングの詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Transparent Bridging」の章を参照してください。

PA-12E/2FE ポート アダプタの設定例については、「PA-12E/2FE ポートの設定例」を参照してください。

PA-12E/2FE ポート アダプタの設定

ここでは、基本設定について説明します。システム設定の要件やインターフェイスでルーティングするプロトコルによっては、その他の設定コマンドを入力する必要がある場合もあります。使用可能な設定コマンドおよび設定オプションの詳細については、Cisco IOS マニュアル セットのその他のコンフィギュレーション ガイドおよびコマンド リファレンスを参照してください。

PA-12E/2FE ポート アダプタでインターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# bridge bridge-group protocol ieee

スパニング ツリー プロトコルのタイプを指定します。

PA-12E/2FE ポート アダプタは、Digital Equipment Corporation(DEC) および Institute of Electrical and Electronics Engineers(IEEE; 電気電子学会)のスパニング ツリー プロトコルをサポートしますが、ブリッジ グループを設定する場合は IEEE プロトコルを使用することを推奨します。

ステップ 2

Router(config)# interface fastethernet slot / port

(ポート 0 と 1)

Router(config)# interface ethernet slot / port

(ポート 2 ~ 13)

設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# bridge-group bridge-group

ブリッジ グループをインターフェイスに割り当てます。

ステップ 4

Router(config-if)# cut-through [ receive | transmit ]

(任意)カットスルー スイッチング テクノロジーのインターフェイスを設定します。デフォルトはストアアンドフォワード(非カットスルー)です。

ステップ 5

Router(config-if)# full-duplex

(任意)接続されているデバイスが自動検知または自動ネゴシエーションをサポートしていない場合、全二重伝送モードを設定します。デフォルトは半二重です。

ステップ 6

Router(config-if)# no shutdown

インターフェイスを再起動します。

ステップ 7

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

インターフェイスごとにステップ 1 ~ 7 を繰り返します。

--

ステップ 9

Router# copy system:running-config nvram:startup-config

新しい設定をメモリに保存します。

ブリッジ グループの Integrated Routing and Bridging をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# bridge irb

Integrated Routing and Bridging をイネーブルにします。

ステップ 2

Router(config)# interface bvi bridge-group

ブリッジ グループの仮想インターフェイスをイネーブルにします。

ステップ 3

Router(config-if)# ip address ip-address mask

IP アドレスとサブネット マスクをブリッジ グループ仮想インターフェイスに割り当てます。

ステップ 4

Router(config-if)# no shutdown

インターフェイスを再起動します。

ステップ 5

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

ブリッジ グループごとにステップ 1 ~ 5 を繰り返します。

--

ステップ 7

Router(config)# bridge bridge-group route protocol

ブリッジ グループごとにプロトコルを指定します。

ステップ 8

Router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 9

Router# copy system:running-config nvram:startup-config

新しい設定をメモリに保存します。

PA-12E/2FE ポート アダプタのモニタリングとメンテナンス

新しいインターフェイスを設定すると、そのステータスを表示し、その他の情報を確認できます。PA-12E/2FE ポート アダプタに関する情報を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router# show version

システム ハードウェアの設定、ソフトウェア バージョン、コンフィギュレーション ファイルの名前とソース、およびブート イメージを表示します。

Router# show controllers

現在のポート アダプタとそのインターフェイスをすべて表示します。

Router# show interfaces fastethernet slot / port

(ポート 0 と 1)

 

または

 

Router# show interfaces ethernet slot / port

(ポート 2 ~ 13)

インターフェイスを表示します。これにより、インターフェイスのスロット番号が正しいこと、およびインターフェイスとライン プロトコルが適切な状態であることを確認できます。

Router# show bridge group

ブリッジ グループとそのインターフェイスをすべて表示します。

Router# show interfaces fastethernet slot / port irb

(ポート 0 と 1)

 

または

 

Router# show interfaces ethernet slot / port irb

(ポート 2 ~ 13)

ルーテッド プロトコルを表示します。これにより、ルーテッド プロトコルがインターフェイスごとに正しく設定されていることを確認できます。

Router# show protocols

システム全体および特定のインターフェイスに設定されているプロトコルを表示します。

Router# show pas eswitch addresses fastethernet slot / port

(ポート 0 と 1)

 

または

 

Router# show pas eswitch addresses ethernet slot / port

(ポート 2 ~ 13)

インターフェイスごとにレイヤ 2 の学習されたアドレスを表示します。

Router# more system:running-config

実行コンフィギュレーション ファイルを表示します。

Router# more nvram:startup-config

NVRAM に格納されている設定を表示します。

12E/2FE VLAN 設定 WebTool を使用したブリッジ グループの設定

図 1 に示す 12E/2FE VLAN 設定 WebTool は Web ブラウザベースの Java アプレットで、シスコ ルータにインストールされている PA-12E/2FE ポート アダプタの設定済みインターフェイスおよびブリッジ グループを表示します。WebTool を使用すると、次の作業を実行できます。

ブリッジ グループ(VLAN とも言います)を作成および削除します。

ブリッジ グループに対して PA-12E/2FE インターフェイスを追加および削除します。

ブリッジ グループと PA-12E/2FE インターフェイスに色を指定します。

PA-12E/2FE インターフェイスを管理シャット ダウン(ディセーブル)および起動(イネーブル)します。

PA-12E/2FE インターフェイスごとにブリッジ グループのステータスを表示します。

12E/2FE VLAN 設定 WebTool にはご使用のルータのホーム ページからアクセスできます。VLAN 設定 WebTool の使用方法の手順については、ハードウェアに付属の『 PA-12E/2FE Ethernet Switch Port Adapter 』を参照してください。

図 1 Cisco 7200 シリーズ ルータ(Cisco 7206)のホーム ページの例

 

Cisco IOS Release 11.0 以降を実行するすべてのシスコ ルータにはホームページがあります。シスコ ルータのホームページはすべてパスワードで保護されています。Cisco 7200 シリーズ ルータの名前またはパスワードがわからない場合は、ネットワーク管理者にお問い合せください。

ご使用のルータに PA-12E/2FE ポート アダプタがインストールされている場合は、Java 対応 Web ブラウザを使用してルータのホーム ページから図 1 に示す 12E/2FE VLAN 設定 WebTool にアクセスできます。

100VG-AnyLAN ポート アダプタの設定

100VG-AnyLAN ポート アダプタ(PA-100VG)は、Cisco 7200 シリーズ ルータおよび Cisco 7500 シリーズ ルータで利用できます。

PA-100VG は、IEEE 802.12 に適合し、IEEE 802.12 で指定されているインターフェイスを 1 つ提供し、RJ-45 ターミネータ付きカテゴリ 3 またはカテゴリ 5 UTP ケーブルを介して 100 Mbps をサポートします。PA-100VG は 802.3 イーサネット パケットをサポートし、IEEE 802.12 インターフェイス MIB を使用してモニタリングできます。

PA-100VG ポート アダプタを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface vg-anylan slot / port

(Cisco 7200)

 

または

 

Router(config)# interface vg-anylan slot / port-adapter / port

(Cisco 7500)

100VG-AnyLAN インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# ip address ip-address mask

インターフェイスに IP アドレスとサブネット マスクを指定します。

ステップ 3

Router(config-if)# frame-type ethernet

フレーム タイプを設定します。現時点では、イーサネット フレームだけがサポートされています。フレーム タイプのデフォルトはイーサネットです。


) 100VG-AnyLAN ポート アダプタのポート番号は常に 0 です。


PA-100VG インターフェイスは、イーサネット インターフェイスやファスト イーサネット インターフェイスの設定方法と同様の方法で設定できます。100VG-AnyLAN ポート アダプタに関する情報を表示するには、 show interfaces vg-anylan EXEC コマンドを使用します。

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E 入力/出力コントローラの設定

Cisco 7200-I/O-GE+E は、ギガビット イーサネット ポート 1 個およびイーサネット ポート 1 個を備えた入力/出力コントローラです。1000 Mbps 動作用に GBIC レセプタクルおよび 10 Mbps 動作用に RJ-45 レセプタクルを装備しています。

Cisco 7200-I/O-2FE/E は、自動検知ファスト イーサネット ポート 2 個、および 10/100 Mbps 動作用に RJ-45 レセプタクル 2 個を備えた 入力/出力コントローラです。

I/O コントローラは次の機能をサポートします。

ローカル コンソールおよび補助ポート用のデュアル EIA/TIA-232 チャネル

システム設定および環境モニタリング ログを格納する NVRAM

デフォルトの Cisco IOS ソフトウェア イメージを格納するフラッシュ ディスクまたはフラッシュ メモリ カードを収容する PC カード スロット 2 個

ブート ヘルパ イメージを格納するフラッシュ メモリ

シャーシに出入りする冷気をモニタリングする環境センサ 2 台

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E の設定作業の一覧

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E 機能の設定作業については、次の項を参照してください。一覧内の各作業は、必須と任意に分けられています。

「インターフェイスの伝送モードの設定」(任意)

「インターフェイス速度の設定」(任意)

「イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定」(必須)

「設定の確認」(任意)

「Cisco 7200-I/O GE+E および Cisco 7200-I/O-2FE/E のモニタリングとメンテナンス」(任意)


) Cisco 7200 VXR ルータ を AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用している場合は、すべてのインターフェイス コマンドに router-shelf/slot/port コマンド形式を使用します。


インターフェイスの伝送モードの設定

インターフェイスの伝送モードを設定するには、特権 EXEC モードで次のコマンドを使用します。Cisco 7200-I/O-2FE/E のファスト イーサネット インターフェイスおよびイーサネット インターフェイスはデフォルトで duplex auto です。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始し、コンソール端末が設定サブコマンドのソースとなるように指定します。

ステップ 2

Router(config)# interface fastethernet 0/02

設定するファスト イーサネット インターフェイスを選択します。

ステップ 3

Router(config)# duplex full

ファスト イーサネット インターフェイス ポート伝送モードを自動ネゴシエーションから全二重に変更します。

2.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface fastethernet router-shelf/slot/port コマンドを使用します。

インターフェイス速度の設定

C7200-I/O-2FE/E で自動検知イーサネット/ファスト イーサネット インターフェイスを 2 つ設定するには、 speed コマンドを使用します。デフォルトのインターフェイス速度は auto です。次に、C7200-I/O-2FE/E を速度 10 Mbps に設定する手順を示します。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始し、コンソール端末が設定サブコマンドのソースとなるように指定します。

ステップ 2

Router(Config)# interface ethernet 0/13

設定するイーサネット インターフェイスを選択します。

Router(Config-if)# interface fastethernet 0/04

設定するファスト イーサネット インターフェイスを選択します。

ステップ 3

Router(Config-if)# speed 10

イーサネット インターフェイスまたはファスト イーサネット インターフェイスの速度を 10 Mbps に設定します。

3.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface ethernet router-shelf/slot/port コマンドを使用します。

4.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface fastethernet router-shelf/slot/port コマンドを使用します。

イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定

次に、C7200-I/O-GE+E または C7200-I/O-2FE/E のイーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスの基本設定を行う手順を示します。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始し、コンソール端末が設定サブコマンドのソースとなるように指定します。

ステップ 2

Router(config)# interface ethernet 0/15

ポート アダプタ スロット 1 のスロット 0 の I/O コントローラで、設定するイーサネット インターフェイスを選択します。

Router(config)# interface fastethernet 0/16

ポート アダプタ スロット 2 のスロット 0 の I/O コントローラで、設定するファスト イーサネット インターフェイスを選択します。

Router(config)# interface gigabitethernet 0/07

ポート アダプタ スロット 0 のスロット 0 の I/O コントローラで、設定するギガビット イーサネット インターフェイスを選択します。

ステップ 3

Router(config-if) # ip address 10.1.1.10 255.255.255.0

IP アドレスとサブネット マスクをインターフェイスに割り当てます(システムで IP ルーティングがイネーブルの場合)。

ステップ 4

Router(config-if)# duplex auto

ファスト イーサネット インターフェイス ポート伝送モードを自動ネゴシエーションに変更します。

ステップ 5

Router#(config-if)# Ctrl-Z

コンフィギュレーション モードを終了します。

5.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface ethernet router-shelf/slot/port コマンドを使用します。

6.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface fastethernet router-shelf/slot/port コマンドを使用します。

7.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface gigabitethernet router-shelf/slot/port コマンドを使用します。

設定の確認

インターフェイスとライン プロトコルが適切な状態(アップ状態)であること、およびインターフェイスで伝送モードが設定されていることを確認するには、 show interfaces { ethernet | fastethernet | gigabitethernet } コマンドを使用します。イーサネット インターフェイスおよびファスト イーサネット インターフェイスでは全二重、半二重、または自動伝送モードを設定できます。ギガビット イーサネット インターフェイスでは強制伝送モードを設定できます。次に、 show interfaces gigabitethernet コマンドの出力例を示します。

Router# show interfaces gigabitethernet 0/0
 
GigabitEthernet0/0 is up, line protocol is up
Hardware is 82543 (Livengood), address is 00d0.ffb6.4c00 (bia 00d0.ffb6.4c00)
Internet address is 10.1.1.0/0
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex mode, link type is autonegotiation, media type is SX
output flow-control is on, input flow-control is on
ARP type:ARPA, ARP Timeout 04:00:00
Last input 00:00:04, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Queueing strategy:fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
2252 packets input, 135120 bytes, 0 no buffer
Received 2252 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
2631 packets output, 268395 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
 

Cisco 7200-I/O GE+E および Cisco 7200-I/O-2FE/E のモニタリングとメンテナンス

Cisco 7200-I/O-GE+E のギガビット イーサネット インターフェイスまたはイーサネット インターフェイスのモニタリングとメンテナンスを行うには、特権 EXEC モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的
Router# show controllers ethernet

イーサネット インターフェイスに関するハードウェアおよびソフトウェア情報を表示します。

Router# show interfaces ethernet slot / port8

ルータのイーサネット インターフェイスに関する情報を表示します。

Router# show controllers gigabitethernet

ギガビット イーサネット インターフェイスに関するハードウェアおよびソフトウェア情報を表示します。

Router# show interfaces gigabitethernet slot / port9

ルータのギガビット イーサネット インターフェイスに関する情報を表示します。

8.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には show interfaces ethernet router-shelf/slot/port コマンドを使用します。

9.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には interface gigabitethernet router-shelf/slot/port コマンドを使用します。

Cisco 7200-I/O-2FE/E のファスト イーサネット インターフェイスまたはイーサネット インターフェイスのモニタリングとメンテナンスを行うには、特権 EXEC モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的
Router# show controllers ethernet

イーサネット インターフェイスに関するハードウェアおよびソフトウェア情報を表示します。

Router# show interfaces ethernet slot / port10

ルータのイーサネット インターフェイスに関する情報を表示します。

Router# show controllers fastethernet

ファスト イーサネット インターフェイスに関するハードウェアおよびソフトウェア情報を表示します。

Router# show interfaces fastethernet

ルータのファスト イーサネット インターフェイスに関する情報を表示します。

10.AS5800 ユニバーサル アクセス サーバのルータ シェルフとして使用される Cisco 7200 VXR には show interfaces ethernet router-shelf/slot/port コマンドを使用します。

ファスト EtherChannel の設定

ファスト EtherChannel 機能により、複数のファスト イーサネット ポイントツーポイント リンクを 1 つの論理リンクにバンドルして最大 800 Mbps の双方向帯域幅を提供できます。ファスト EtherChannel は標準ベースの 802.3 全二重ファスト イーサネットをベースにしており、スイッチ、ルータ、およびサーバ間にフォールト トレラントな高速リンクを実現します。この機能は、Cisco 7200 シリーズ ルータ、Cisco 7500 シリーズ ルータ、および 7000 シリーズ ルート スイッチ プロセッサ(RSP7000)と 7000 シリーズ シャーシ インターフェイス(RSP7000CI)搭載 Cisco 7000 シリーズ ルータの間で、または Cisco 7500 シリーズ ルータまたは RSP7000 と RSP7000CI 搭載 Cisco 7000 シリーズ ルータと Catalyst 5000 スイッチの間で設定できます。


) Catalyst 5000 スイッチでファスト EtherChannel 機能を使用するには、ハードウェアのアップグレードが必要です。アップグレードの詳細については、営業担当者にお問い合せください。


ファスト EtherChannel は、より高い双方向帯域幅、冗長性、およびロード シェアリングを提供します。最大 4 つのファスト イーサネット インターフェイスを 1 つのポート チャネルにバンドルでき、ルータまたはスイッチは最大 4 つのポート チャネルをサポートできます。ファスト EtherChannel 機能では、ファスト イーサネット リンクでトラフィックのロード バランシングが可能です。ユニキャスト、ブロードキャスト、およびマルチキャスト トラフィックはリンク全体に分散され、その結果パフォーマンスが向上し、冗長性のあるパラレル パスが実現します。リンクに障害が発生した場合、ユーザの介入なしにトラフィックはファスト EtherChannel 内の残りのリンクにリダイレクトされます。

ファスト EtherChannel 機能では、IP トラフィックはポート チャネル インターフェイスを介して配信されますが、その他のルーティング プロトコルからのトラフィックは 1 つのリンクを介して送信されます。ブリッジされたトラフィックは、パケット内のレイヤ 3 情報に基づいて配信されます。パケット内にレイヤ 3 情報がない場合は、トラフィックは最初のリンクを介して送信されます。

ファスト EtherChannel はファスト イーサネット インターフェイスで現在サポートされているすべての機能をサポートします。これらの機能は、個々のファスト イーサネット インターフェイスではなく、ポートチャネル インターフェイスに設定する必要があります。ファスト EtherChannel 接続は、Cisco IOS VLAN およびルーティング テクノロジーに完全に適合しています。Inter-Switch Link(ISL; スイッチ間リンク)VLAN トランキング プロトコルは、ファスト EtherChannel 上で複数の VLAN を伝送できます。また、ファスト EtherChannel リンクに接続されているルータは、Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)を使用してホット スタンバイをサポートし、完全なマルチプロトコル ルーティングを提供できます。

ポート チャネル(最大 4 つのファスト イーサネット インターフェイスで構成)は 1 つのインターフェイスとして扱われます。ポート チャネルは、Cisco IOS ソフトウェアで使用されて Catalyst 5000 スイッチで既存のコマンドとの互換性を維持します。ファスト EtherChannel を作成するには、 interface port-channel インターフェイス コンフィギュレーション コマンドを使用します。 channel-group インターフェイス コンフィギュレーション コマンドを使用して、最大 4 つの Fast Ethernet インターフェイスをポート チャネルに割り当てることができます。

その他のファスト EtherChannel 機能には次のようなものがあります。

ホットスタンバイ ルータ プロトコル(HSRP)

HSRP の設定の詳細については、『 Cisco IOS IP Application Services Configuration Guide 』の「Configuring IP Services」の章を参照してください。

Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)および Distributed CEF(dCEF)

CEF の設定の詳細については、『 Cisco IOS IP Switching Configuration Guide 』の「Configuring Cisco Express Forwarding」を参照してください

イーサネットまたはファスト イーサネットの設定方法については、「イーサネット、ファスト イーサネット、およびギガビット イーサネット インターフェイスの設定」 に示されている作業を参照してください。

ファスト EtherChannel の設定作業の一覧

ファスト EtherChannel を設定するには、次の項で説明する作業を実行します。各作業は、必須と任意に分けられています。

「ポートチャネル インターフェイスの設定」

「ファスト イーサネット インターフェイスの設定」

ファスト EtherChannel で使用できるその他のコマンドの詳細については、Cisco IOS マニュアル セットに含まれているその他のコンフィギュレーション ガイドおよびコマンド リファレンスを参照してください。

ポートチャネル インターフェイスの設定

ポートチャネル インターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface port-channel channel-number

ポートチャネル インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。チャネル番号には 1 ~ 4 を指定できます。

ステップ 2

Router(config-if)# ip address ip-address mask

IP アドレスとサブネット マスクをファスト EtherChannel に割り当てます。

ISL を設定する場合、IP アドレスをサブインターフェイスに割り当てる必要があります(たとえば、インターフェイス ポート チャネル 1.1、VLAN ごとの IP アドレス)。また、そのサブインターフェイスで VLAN 番号を使用してカプセル化を指定する必要があります(たとえば、カプセル化 isl 100)。

ステップ 3

Router(config-if)# mac-address ieee-address

(任意)スタティック MAC アドレスをファスト EtherChannel に割り当てます。

ポートチャネル インターフェイスでスタティック MAC アドレスを割り当てなかった場合、Cisco IOS ソフトウェアは自動的に MAC アドレスを割り当てます。スタティック MAC アドレスを割り当てた後で削除した場合も、Cisco IOS ソフトウェアは自動的に MAC アドレスを割り当てます。

ステップ 4

Router(config-if)# end

(任意)その他のサポートされているインターフェイス コマンドを実行し、実行後に終了します。

ステップ 5

Router# show interface port-channel

ポートチャネル インターフェイスに関する情報を表示します。これにより、設定を確認できます。


) Cisco Discovery Protocol(CDP; シスコ検出プロトコル)を使用する場合、ポートチャネル インターフェイスではなく、物理イーサネット、ファスト イーサネット、またはギガビット イーサネット インターフェイスにこれを設定する必要があります。



注意 Release 11.1(20)CC 以降のリリースでは、ファスト EtherChannel は CEF/dCEF をサポートします。ポートチャネル インターフェイスで dCEF をイネーブルにする前に、ファスト イーサネット インターフェイスからすべての明示的な ip route-cache distributed コマンドを消去することを推奨します。これにより、ポートチャネル インターフェイスは物理ファスト イーサネット リンクを適切に制御できます。CEF/dCEF をグローバルにイネーブルにすると、CEF/dCEF をサポートするすべてのインターフェイスがイネーブルになります。ポートチャネル インターフェイスで CEF/dCEF をイネーブルにすると、CEF/dCEF はチャネル グループ内の各ファスト イーサネット インターフェイスで自動的にイネーブルになります。ただし、それ以前にファスト イーサネット インターフェイスで CEF/dCEF をディセーブルにした場合、CEF/dCEF は自動的にイネーブルになりません。この場合、ファスト イーサネット インターフェイスで CEF/dCEF をイネーブルにする必要があります。

ファスト イーサネット インターフェイスの設定

ファスト イーサネット インターフェイスをファスト EtherChannel に割り当てるには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface fastethernet slot / port

(Cisco 7200 シリーズ ルータ)

Router(config)# interface fastethernet slot / port-adapter / port

(Cisco 7500 シリーズ ルータおよび RSP7000 搭載 Cisco 7000 シリーズ ルータ)

ファスト イーサネット インターフェイスを作成するか、既存のファスト イーサネット インターフェイスを変更し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no ip address

ファスト イーサネット インターフェイスがすでに存在し、IP アドレスが割り当てられている場合は、次のステップを実行する前に IP アドレスをディセーブルにします。

ステップ 3

Router(config-if)# channel-group channel-number

ファスト イーサネット インターフェイスをファスト EtherChannel に割り当てます。チャネル番号は、ポートチャネル インターフェイスを作成したときに指定したチャネル番号と同じです。

ステップ 4

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。最大 4 つのファスト イーサネット インターフェイスをファスト EtherChannel に追加するには、ステップ 1 ~ 4 を繰り返します。

ステップ 5

Router(config-if)# end

(任意)その他のサポートされているインターフェイス コマンドを実行し、実行後に終了します。

ステップ 6

Router(config)# show interfaces port-channel

ファスト イーサネット インターフェイスに関する情報を表示します。これにより、設定を確認できます。


注意 ポートチャネル インターフェイスはルーテッド インターフェイスです。物理ファスト イーサネット インターフェイスでレイヤ 3 アドレスをイネーブルにしないでください。物理ファスト イーサネット インターフェイスでブリッジ グループを割り当てないでください。これはループが作成されるためです。また、スパニング ツリーをディセーブルにする必要もあります。

ファスト EtherChannel からファスト イーサネット インターフェイスを削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface fastethernet slot / port

(Cisco 7200 シリーズ ルータ)

Router(config)# interface fastethernet slot / port-adapter / port

(Cisco 7500 シリーズ ルータおよび RSP7000 搭載 Cisco 7000 シリーズ ルータ)

ファスト イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no channel-group

チャネル グループからファスト イーサネット インターフェイスを削除します。

ステップ 3

Router(config-if)# end

(任意)その他のサポートされているインターフェイス コマンドを実行し、実行後に終了します。

Cisco IOS ソフトウェアは、ファスト イーサネット インターフェイスがダウンすると自動的にファスト EtherChannel からインターフェイスを削除し、インターフェイスがアップに戻ると自動的にファスト EtherChannel にインターフェイスを追加します。

現在、ファスト EtherChannel は、キープアライブを使用してライン プロトコルがアップしているかダウンしているかを検出します。デフォルトでは、キープアライブはファスト イーサネット インターフェイスでイネーブルに設定されます。キープアライブ信号を受信しなかったためにインターフェイスのライン プロトコルがダウンすると、ファスト EtherChannel はライン プロトコルがダウンしていることを検出し、そのインターフェイスをファスト EtherChannel から削除します。ただし、ファスト イーサネット インターフェイスでキープアライブがディセーブルになっているためにライン プロトコルがアップ状態のままになっている場合、ファスト EtherChannel では(ケーブル切断以外の)リンク障害を検出できないので、ライン プロトコルがダウンしていても、ファスト EtherChannel からインターフェイスは削除されません。これにより、予想外の動作が生じることがあります。この機能の以降のリリースでポート集約プロトコルを実装すると、キープアライブへの依存関係がなくなります。

設定例については、「LAN インターフェイスの設定例」を参照してください。

ファスト EtherChannel インターフェイスのステータスをモニタリングするには、 show interfaces port-channel EXEC コマンドを使用します。

ギガビット イーサネット インターフェイスの設定

ギガビット イーサネット インターフェイスをギガビット EtherChannel に割り当てるには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface gigabitethernet slot / port

(Cisco 7200 シリーズ ルータ)

ギガビット イーサネット インターフェイスを作成または既存のギガビット イーサネット インターフェイスを変更し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no ip address

ギガビット イーサネット インターフェイスがすでに存在し、IP アドレスが割り当てられている場合は、次のステップを実行する前に IP アドレスをディセーブルにします。

ステップ 3

Router(config-if)# channel-group channel-number

ギガビット イーサネット インターフェイスをギガビット EtherChannel に割り当てます。チャネル番号は、ポートチャネル インターフェイスを作成したときに指定したチャネル番号と同じです。

ステップ 4

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。最大 8 個のギガビット イーサネット インターフェイスをギガビット EtherChannel に追加するには、ステップ 1 ~ 4 を繰り返します。

ステップ 5

Router(config-if)# end

(任意)その他のサポートされているインターフェイス コマンドを実行し、実行後に終了します。

ステップ 6

Router(config)# show interfaces port-channel

ギガビット イーサネット インターフェイスに関する情報を表示します。これにより、設定を確認できます。

ギガビット EtherChannel からギガビット イーサネット インターフェイスを削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface gigabitethernet slot / port

(Cisco 7200 シリーズ ルータ)

ギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no channel-group

チャネル グループからギガビット イーサネット インターフェイスを削除します。

ステップ 3

Router(config-if)# end

(任意)その他のサポートされているインターフェイス コマンドを実行し、実行後に終了します。

ギガビット EtherChannel インターフェイスのステータスをモニタリングするには、 show interfaces port-channel EXEC コマンドを使用します。

FDDI インターフェイスの設定

FDDI は、American National Standards Institute(ANSI; 米国規格協会)により定義された、光ファイバ ケーブルを使用する 100 Mbps トークン パッシングの規格です。FDDI はアクセス サーバではサポートされません。

FDDI ネットワークは、反転トークン パッシング光ファイバ リング 2 個で構成されます。ほとんどのネットワークでは、プライマリ リングをデータ通信に使用し、セカンダリ リングをホットスタンバイとして使用します。FDDI 規格では、合計ファイバ長 200 km が設定されています (障害分離時に発生する信号のラッピング、つまりループバックにより、FDDI ネットワークの最大の外周は指定された長さ(km)の半分にしかなりません)。

FDDI 規格では、最大 500 のステーションが許可され、アクティブなステーション間の最大距離はマルチモード ファイバで相互接続されている場合は 2 km、シングル モード ファイバで相互接続されている場合は 10 km で、FDDI インターフェイス コントローラによってサポートされます。FDDI フレームには、17 ~ 4500 バイトを含めることができます。シスコの FDDI の実装では、X3T9.5 FDDI 仕様の Station Management(SMT; ステーション管理)バージョン 7.3 をサポートし、Dual Attachment Station(DAS; デュアル アタッチメント ステーション)の障害回復方式をサポートする単一の MAC デュアルアタッチ インターフェイスを提供します。ミッドレンジ プラットフォームは、Single Attachment Station(SAS; シングル アタッチメント ステーション)もサポートします。

プラットフォームおよびインターフェイスの互換性の詳細については、『 Cisco Product Catalog 』を参照してください。インストールおよび設定の詳細については、該当するインターフェイス カードまたはポート アダプタのインストールおよび設定マニュアルを参照してください。

Cisco 4000-M、Cisco 4500-M、Cisco 4700-M ルータの FDDI でのソースルート ブリッジング(SRB)

Source-Route Bridging(SRB; ソースルート ブリッジング)は、Cisco 4000-M、Cisco 4500-M、および Cisco 4700-M ルータとの FDDI インターフェイスでサポートされます。自律 FDDI SRB または FDDI のファストスイッチング SRB の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Source-Route Bridging」の章を参照してください。

Cisco 7200 シリーズ ルータのソースルート ブリッジ パケットのパーティクルベース スイッチング

SRB は FDDI でサポートされます。パーティクルベース スイッチングは、デフォルトで SRB パケットでサポートされます(FDDI およびトークン リング経由)。

パーティクルベース スイッチングは、SRB に分散収集機能を追加してパフォーマンスを向上させます。パーティクルは、隣接しないバッファの集まりとしての通信データ パケットを表します。従来の Cisco IOS パケットには、パケット タイプ制御構造と 1 つの隣接するデータ バッファがあります。パーティクル パケットには同じパケット タイプ制御構造がありますが、一連のパーティクル タイプ構造も保持しており、そのそれぞれが独自のブロックを管理します。

パーティクルベース スイッチングで使用される分散収集アーキテクチャには次の利点があります。

ドライバがメモリをより効率的に使用できます(特に、Maximum Transmission Unit(MTU; 最大伝送ユニット)が大きいメディアを使用する場合)。たとえば、トークン リング バッファは、16 KB ではなく、512 バイトにすることができます。

メモリの同じ領域を同時に使用できます。たとえば、IP マルチキャストでは複数のインターフェイスで 1 つのパケットを同時に受信し、送信します。

パケット内の任意の場所(最初や最後だけでなく)でメモリを挿入または削除できます。

FDDI 上の SRB の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Source-Route Bridging」の章を参照してください。

接続管理(CMT)情報の使用方法

Connection Management(CMT; 接続管理)は、X3T9.5 仕様で定義されているさまざまな状態(オフ、オン、アクティブ、接続など)を経るリングの遷移を処理する FDDI プロセスです。FDDI Interface Processor(FIP; FDDI インターフェイス プロセッサ)は CMT 機能をマイクロコードで提供します。

次に、 show interfaces fddi コマンドの出力例の一部を示し、出力内の CMT 情報の解釈方法について説明します。

Phy-A state is active, neighbor is B, cmt signal bits 08/20C, status ALS
Phy-B state is active, neighbor is A, cmt signal bits 20C/08, status ILS
CFM is thru A, token rotation 5000 usec, ring operational 0:01:42
Upstream neighbor 0800.2008.C52E, downstream neighbor 0800.2008.C52E
 

show interfaces fddi の例では、Physical A(Phy-A)はネイバーとの CMT を完了したことが示されています。状態はアクティブで、表示は Physical B タイプのネイバーを示します。

出力例は、Phy-A の CMT 信号ビット 08/20C を示します。伝送信号ビットは 08 です。Pulse Code Modulation(PCM; パルス符号変調)ステート マシンを見ると、08 はポート タイプが A であること、ポートの互換性が設定されていること、および要求された LCT 時間が短いことを示しています。受信信号ビットは 20C です。これは、ネイバー タイプが B であること、ポートの互換性が設定されていること、およびポート出力に MAC があることなどを示します。

ネイバーは、次のように受信した信号ビットから決まります。

ビット位置

9 8 7 6 5 4 3 2 1 0

受信した値

1 0 0 0 0 0 1 1 0 0

上の表のビットを解釈すると、受信した値は 0x20C に相当します。ビット位置 1 と 2(0 1)は、Physical B タイプの接続を示します。

表示される遷移状態は、CMT プロセスが実行されており、リモート物理接続との接続をアクティブに確立しようとしていることを示します。CMT プロセスには、PCM ステート マシンに示されるように、次の状態に移行する前に、送受信される異なる信号での状態遷移が必要です。10 ビットの CMT 情報が送信され、信号状態で受信されます。NEXT 状態は、信号状態で実行されるシグナリングの分離に使用されます。そのため、前の出力例では NEXT 状態は 11 回入力されました。


) FDDI インターフェイスがシャットダウンされている場合、cmt disconnect コマンドが発行されている場合、または fddi if-cmt コマンドが発行されている場合、遷移状態を示す表示行は生成されません (fddi if-cmt コマンドは Cisco 7500 シリーズ ルータだけに適用されます)。


CFM 状態は出力例の A を経由します。これは、このインターフェイスの Phy-A がネイバーの Phy-B との CMT を正常に完了したこと、およびこのインターフェイスの Phy-B がネイバーの Phy-A との CMT を正常に完了したことを示します。

アップストリームおよびダウンストリーム ネイバーの表示(または非表示)は、データのルーティングに影響しません。アップストリーム ネイバーは例に示すダウンストリーム ネイバーでもあるため、リング内にはアドレス 0800.2008.C52E のネットワーク サーバとルータの 2 つのステーションしかありません。

FDDI の設定作業の一覧

FDDI インターフェイスを設定するには、次の項で説明する作業を実行します。一覧内の各作業は、必須と任意に分けられています。

「FDDI インターフェイスの指定」(必須)

「FDDI ブリッジング カプセル化のイネーブル化」(任意)

「FDDI インターフェイスの全二重モードのイネーブル化」(任意)

「トークン回転時間の設定」(任意)

「有効な伝送タイマーの設定」(任意)

「伝送タイマーの制御」(任意)

「C-Min タイマーの変更」(任意)

「TB-Min タイマーの変更」(任意)

「FDDI タイムアウト タイマーの変更」(任意)

「SMT フレーム処理の制御」(任意)

「重複アドレス チェックのイネーブル化」(任意)

「ビット制御の設定」(任意)

「CMT マイクロコードの制御」(任意)

「FDDI の起動と停止」(任意)

「トークン制限ごとの FDDI フレームの設定」(任意)

「FDDI SMT メッセージ キュー サイズの制御」(任意)

「バースト性 FDDI トラフィックのバッファの事前割り当て」(任意)

FDDI インターフェイスの指定

FDDI インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config)# interface fddi number

インターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface fddi slot / port

Cisco 7200 または Cisco 7500 シリーズ ルータのインターフェイス コンフィギュレーション モードを開始します。

FDDI ブリッジング カプセル化のイネーブル化

デフォルトでは、Cisco FDDI は RFC 1042 で定義されている SNAP カプセル化形式を使用します。FIP を使用する場合は、このインターフェイスのカプセル化方式を定義する必要はありません。

FIP は、次の設定のトランスペアレント ブリッジングおよびトランスレーショナル ブリッジングを完全にサポートします。

FDDI から FDDI

FDDI からイーサネット

FDDI からトークン リング

FDDI ブリッジング カプセル化をイネーブルにすると、ブリッジングの実行時に FIP はカプセル化モードになります。トランスペアレント モードでは、同じリングでブリッジング機能を実行すると、FIP は以前のバージョンのカプセル化インターフェイスと相互運用します。FIP を使用すると、インターフェイス コンフィギュレーション モードで次のコマンドを使用してカプセル化を指定できます。

 

コマンドまたはアクション
目的

Router(config-if)# fddi encapsulate

FIP のカプセル化方式を指定します。

トランスレーショナル ブリッジングを実行する場合、ルーティング可能なプロトコルにはルーティングを使用し、その他(Local-Area Transport(LAT; ローカルエリア トランスポート)など)にはトランスレーショナル ブリッジングを使用します。


) 異なるメディア間のブリッジングでは、通信を妨げることがあるいくつかの問題が発生します。この問題には、ビット順変換(MAC アドレスをデータとして使用)、最大伝送ユニット(MTU)の相違、フレームのステータスの相違、マルチキャスト アドレスの使用などがあります。これらの問題の一部またはすべてはマルチメディアブリッジ型 LAN で発生することがあり、通信を妨げる場合があります。これらの問題は、トークン リングがエンド ノードで実装される方法が異なるため、トークン リング ネットワークとイーサネット ネットワーク間またはトークン リングと FDDI 間のブリッジングを行うネットワーク内で最もよく発生します。


現時点では、トークン リングと他のメディアの間でブリッジングを行うと、AppleTalk、DECnet、IP、Novell IPX、Phase IV、VINES、および XNS のプロトコルに問題が生じることがわかっています。また、FDDI と他のメディアの間でブリッジングを行うと、Novell IPX および XNS のプロトコルに問題が生じることがあります。これらのプロトコルは可能な限りルーティングすることを推奨します。

FDDI インターフェイスの全二重モードのイネーブル化

PA-F/FD-SM および PA-F/FD-MM ポート アダプタで全二重モードをイネーブルにするには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# full-duplex

 

または

Router(config-if)# no half-duplex

PA-F/FD-SM および PA-F/FD-MM ポート アダプタの FDDI インターフェイスで全二重モードをイネーブルにします。

トークン回転時間の設定

FDDI Token Rotation Timer(TRT; トークン回転時間)を設定して、通常の動作中のリング スケジューリングを制御し、重大なリング エラー状況を検出してエラー状況から回復できます。これを実行するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi token-rotation-time microseconds

FDDI トークン回転時間を設定します。

FDDI 規格では、設定可能な時間は 4000 マイクロ秒超、165,000 マイクロ秒未満に制限されています。X3T9.5 仕様で定義されているとおり、トークン回転時間(TRT)に残っている値は Token Holding Timer(THT; トークン保持時間)にロードされます。この 2 つのタイマーの値を組み合わせると、以降の伝送で使用できる帯域幅の量を確認できます。

有効な伝送タイマーの設定

一時的なリング エラーから回復するために伝送タイマーを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi valid-transmission-time microseconds

FDDI の有効な伝送タイマーを設定します。

伝送タイマーの制御

FDDI 制御伝送タイマーを設定すると、FDDI TL-Min 時間を制御できます。FDDI TL-Min 時間は、X3T9.5 仕様で定義された、次の Physical Connection Management(PCM)状態に進む前に、Physical Sublayer(PHY; 物理サブレイヤ)の回線状態を送信する最小時間です。これを実行するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi tl-min-time microseconds

FDDI 制御伝送タイマーを設定します。

C-Min タイマーの変更

PCM の C-Min タイマーをデフォルト値の 1600 ミリ秒から変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi c-min microseconds

PCM の C-Min タイマーを設定します。

TB-Min タイマーの変更

PCM の TB-Min タイマーをデフォルト値の 100 ミリ秒から変更できます。これを実行するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi tb-min milliseconds

PCM の TB-Min タイマーを設定します。

FDDI タイムアウト タイマーの変更

PCM の FDDI タイムアウト タイマーをデフォルト値の 100 ミリ秒から変更できます。それには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi t-out milliseconds

PCM のタイムアウト タイマーを設定します。

SMT フレーム処理の制御

診断を行うために、SMT フレーム処理をディセーブルまたはイネーブルに設定できます。それには、インターフェイス コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# no fddi smt-frames

SMT フレーム処理をディセーブルにします。

Router(config-if)# fddi smt-frames

SMT フレーム処理をイネーブルにします。

重複アドレス チェックのイネーブル化

FDDI で重複アドレス検出機能をイネーブルに設定できます。FDDI で重複アドレスが検出されると、エラー メッセージが表示され、インターフェイスがシャットダウンされます。重複アドレス チェックをイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi duplicate-address-check

重複アドレス チェック機能をイネーブルにします。

ビット制御の設定

FDDI ビット制御を設定すると、接続管理(CMT)のシグナリング フェーズで送信される情報を制御できます。これを実行するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi cmt-signal-bits signal-bits [ phy-a | phy-b ]

FDDI ビット制御を設定します。

CMT マイクロコードの制御

CMT 内蔵機能のオンまたはオフを制御できます。FIP は CMT 機能をマイクロコードで提供します。これらの機能は、プロセッサ カードで提供される機能とは別個のもので、EXEC コマンドを使用してアクセスします。

デフォルトでは、FIP の CMT 機能はオンです。これらの機能をディセーブルにする主な理由は、新しい FDDI 機器での作業時にリングの稼動に関して問題が発生するためです。CMT マイクロコードをディセーブルにすると、次のようになります。

FIP CMT マイクロコードがディセーブルになります。

デバッグ出力の生成中にメイン システムのコードが CMT 機能を実行します。

CMT マイクロコードをディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# no fddi if-cmt

FCIT の CMT 機能をディセーブルにします。

FDDI の起動と停止

通常の動作では、FDDI インターフェイスを接続し、設定すると FDDI インターフェイスが動作します。CMT 機能を実行するプロセスを開始および停止し、1 つのファイバ上のリングを停止できます。これを実行するには、EXEC モードで次のいずれかのコマンドを使用します。

 

コマンドまたはアクション
目的

Router# cmt connect [interface-name [ phy-a | phy-b ]]

FDDI リングの CMT プロセスを開始します。

Router# cmt disconnect [ interface-name [ phy-a | phy-b ]]

FDDI リングの CMT プロセスを停止します。

FDDI の通常の動作中は上記のコマンドを使用しないでください。これらのコマンドは相互運用性のテスト時に使用します。

トークン制限ごとの FDDI フレームの設定

FDDI インターフェイスは、Cisco 4000、Cisco 4500、および Cisco 4700 シリーズ ルータで、一度に 1 つのフレームだけを送信するのではなく、トークンごとに複数のフレームを送信できます。トークン キャプチャごとに送信されるフレームの最大数を指定できます。これにより、大量のトラフィックやバースト性トラフィックがあるときのスループットが大幅に向上します。

トークン キャプチャごとに最大数のフレームを送信するように FDDI インターフェイスを設定するには、特権 EXEC モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface fddi0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# fddi ?

fddi コマンド オプションを表示します。

ステップ 4

Router(config-if)# fddi frames-per-token ?

fddi frames-per-token コマンド オプションを表示します。

ステップ 5

Router(config-if)# fddi frames-per-token number

トークン キャプチャごとに送信されるフレームの最大数を指定します。

FDDI SMT メッセージ キュー サイズの制御

処理するために保持される未処理 FDDI Station Management(SMT; ステーション管理)フレームの最大数を設定できます。この数を設定すると、設定しているルータが、ルータの処理速度より速く着信するメッセージを大量に受信する場合に役立ちます。フレーム数を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config)# smt-queue-threshold number

SMT メッセージ キュー サイズを設定します。

バースト性 FDDI トラフィックのバッファの事前割り当て

FCI カードは、バースト性 FDDI トラフィック(たとえば、Network File System(NFS; ネットワーク ファイル システム)のバースト性 トラフィックなど)を処理するためのバッファを 3 つ事前に割り当てます。事前に割り当てられるバッファの数を変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-if)# fddi burst-count

バースト性 FDDI トラフィックを処理するバッファを事前に割り当てます。

ハブ インターフェイスの設定

Cisco 2500 シリーズには、イーサネット インターフェイスのハブ機能を持つルータがあります。ハブとはマルチポート リピータです。ハブ上のイーサネット インターフェイスの利点は、ハブがスター型配線の物理ネットワーク設定を提供し、イーサネット インターフェイスが 10BASE-T 物理ネットワーク設定を提供することです。ハブ ポート搭載ルータ モデルとその構成は次のとおりです。

Cisco 2505:イーサネット(ポート× 8)× 1、シリアル× 2

Cisco 2507:イーサネット(ポート× 16)× 1、シリアル× 2

Cisco 2516:イーサネット(ポート× 14)× 1、シリアル× 2、ISDN Basic Rate Interface(BRI; 基本インターフェイス)× 1

シスコは、RFC 1516「 Definitions of Managed Objects for IEEE 802.3 Repeater Devices 」で指定されている、イーサネット ハブの Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)管理を実現します。

イーサネット インターフェイスでハブ機能を設定するには、次の項で説明する作業を実行します。一覧内の各作業は、必須と任意に分けられています。

「ハブ ポートのイネーブル化」(必須)

「受信データの自動極性反転のディセーブル化またはイネーブル化」(任意)

「リンク テスト機能のディセーブル化またはイネーブル化」(任意)

「送信元アドレス制御のイネーブル化」(任意)

「SNMP 不正アドレス トラップのイネーブル化」(任意)

設定例については、「ハブの設定例」を参照してください。

ハブ ポートのイネーブル化

ハブ ポートをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# hub ethernet number port [ end-port ]

ハブ番号とハブ ポート(またはハブ ポートの範囲)を指定し、ハブ コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# no shutdown

ハブ ポートをイネーブルにします。

受信データの自動極性反転のディセーブル化またはイネーブル化

イーサネット ハブ ポートに限り、ハブ ポートは、配線エラーによって受信したデータ パケットの波形の極性が反転されていることを検出した場合、受信したデータの極性を反転(修正)できます。このように受信回路の極性を修正することで、ハブは正しい極性で以降のパケットを繰り返します。この機能をイネーブルにすると、リンク障害状態のリセット後にこの機能が一度実行されます。

受信データの自動極性反転はデフォルトでイネーブルです。ポート単位でこの機能をディセーブルにするには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-hub)# no auto-polarity

受信データの自動極性反転をディセーブルにします。

ポート単位で受信データの自動極性反転をイネーブルにするには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンドまたはアクション
目的

Router(config-hub)# auto-polarity

受信データの自動極性反転をイネーブルにします。

リンク テスト機能のディセーブル化またはイネーブル化

リンク テスト機能は、イーサネット ハブ ポートだけに適用されます。イーサネット ポートは、802.3 10BASE-T 規格で指定されているリンク テスト機能を実装しています。ハブ ポートは、8 ミリ秒を超えて 17 ミリ秒までの間アクティブでない場合、リンク テスト パルスを接続されているツイストペア デバイスに送信します。

ハブ ポートが 65 ミリ秒を超えて 132 ミリ秒までの間データ パケットまたはリンク テスト パルスを受信しなかった場合、そのポートでリンク テスト機能がイネーブルに設定されていると、ポートはリンク障害状態になり、送受信できません。ハブ ポートは 4 つの連続するリンク テスト パルスまたはデータ パケットを受信すると、再度イネーブルになります。

リンク テスト機能はデフォルトでイネーブルです。ハブがリンク テスト機能を実装していない 10BASE-T ツイストペア ネットワークと相互運用できるように、ハブのリンク テスト受信機能はポート単位でディセーブルに設定できます。それには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-hub)# no link-test

リンク テスト機能をディセーブルにします。

イーサネット インターフェイスに接続されているハブ ポートでリンク テスト機能をイネーブルにするには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-hub)# link-test

リンク テスト機能をイネーブルにします。

送信元アドレス制御のイネーブル化

イーサネット ハブ ポートに限り、ポートが特定の MAC アドレスからのパケットだけを受け入れるようにセキュリティ手段を構築できます。たとえば、ワークステーションがハブのポート 3 に接続され、ポート 3 で送信元アドレス制御がイネーブルになっているとします。ハブはポート 3 からワークステーションの MAC アドレスを持つパケットを受け入れるため、ワークステーションはネットワークにアクセスできます。別の MAC アドレスを持つパケットが着信すると、ポートはディセーブルになります。ポートは 1 分後に再度イネーブルになり、着信パケットの MAC アドレスが再度チェックされます。

ポート単位で送信元アドレス制御をイネーブルにするには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-hub)# source-address [ mac-address ]

送信元アドレス制御をイネーブルにします。

任意の MAC アドレスを省略すると、ハブは選択されたポートで受信した最初の MAC アドレスを記憶し、その学習した MAC アドレスからのパケットだけを許可します。

送信元アドレス制御の設定例については、「ハブの設定例」を参照してください。

SNMP 不正アドレス トラップのイネーブル化

イーサネット ハブ ポートで不正 MAC アドレスが検出されたときに、ルータが SNMP トラップを発行できるようにするには、ハブ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-hub)# hub ethernet number port [ end-port ]

ハブ番号とハブ ポート(またはハブ ポートの範囲)を指定し、ハブ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-hub)# snmp trap illegal-address

ハブ ポートで不正 MAC アドレスが検出されると、ルータが SNMP トラップを発行できるようにします。

このトラップ タイプを受信するために、Network Management System(NMS; ネットワーク管理システム)でこのトラップ タイプのホスト レシーバー(snmp-server ホスト)を設定する必要がある場合があります。デフォルトはトラップなしです。イーサネット ハブ ポートの SNMP トラップの設定例については、「ハブの設定例」を参照してください。

トークン リング インターフェイスの設定

シスコは、さまざまなトークン リング インターフェイスをサポートしています。プラットフォームおよびハードウェアの互換性の詳細については、『 Cisco Product Catalog 』を参照してください。

トークン リング インターフェイスは、プロトコル単位でルーティング(レイヤ 3 スイッチング)とソースルート ブリッジング(レイヤ 2 スイッチング)の両方をサポートします。たとえば、IP トラフィックをルーティングし、SNA トラフィックをブリッジングできます。ルーティング機能はソースルート ブリッジを拡張します。

トークン リング MIB 変数は、RFC 1231「 IEEE 802.5 Token Ring MIB 」の仕様をサポートします。必須のインターフェイス テーブルと統計情報テーブルは実装されますが、オプションのトークン リング MIB のタイマー テーブルは実装されません。トークン リング MIB は、Token Ring Interface Processor(TRIP)用に実装されています。

トークン リング番号を表示するには、 show interfaces show controllers token 、および show controllers cbus EXEC コマンドを使用します。これらのコマンドは、Cisco IOS ソフトウェアがサポートする各リングのレポートを提供します。


) トークン リング インターフェイスが配線に関する問題の兆候を示すと、システムはそのインターフェイスをリセット状態にして、再起動しません。これは、トークン リング インターフェイスを定期的に再起動しようとすると、ルーティング テーブルの安定性に大きく影響を及ぼすためです。Media Attachment Unit(MAU; メディア アタッチメント ユニット)に再度ケーブルを接続したら、clear interface tokenring number コマンドを使用してインターフェイスを再起動します。number 引数はインターフェイス番号です。


デフォルトでは、トークン リング インターフェイスは RFC 1042 で定義されている SNAP カプセル化形式を使用します。このインターフェイスのカプセル化方式を定義する必要はありません。

Cisco 7200 シリーズ ルータのソースルート ブリッジ パケットのパーティクルベース スイッチング

パーティクルベース スイッチングは、デフォルトで SRB パケットでサポートされます(FDDI およびトークン リング経由)。

パーティクルベース スイッチングは、SRB に分散収集機能を追加してパフォーマンスを向上させます。パーティクルは、隣接しないバッファの集まりとしての通信データ パケットを表します。従来の Cisco IOS パケットには、パケット タイプ制御構造と 1 つの隣接するデータ バッファがあります。パーティクル パケットには同じパケット タイプ制御構造がありますが、一連のパーティクル タイプ構造も保持しており、そのそれぞれが独自のブロックを管理します。

パーティクルベース スイッチングで使用される分散収集アーキテクチャには次の利点があります。

ドライバがメモリをより効率的に使用できます(特に、Maximum Transmission Unit(MTU; 最大伝送ユニット)が大きいメディアを使用する場合)。たとえば、トークン リング バッファは、16 KB ではなく、512 バイトにすることができます。

メモリの同じ領域を同時に使用できます。たとえば、IP マルチキャストでは複数のインターフェイスで 1 つのパケットを同時に受信し、送信します。

パケット内の任意の場所(最初や最後だけでなく)でメモリを挿入または削除できます。

FDDI 上の SRB の設定の詳細については、『 Cisco IOS Bridging and IBM Networking Configuration Guide 』の「Configuring Source-Route Bridging」の章を参照してください。

専用トークン リング ポート アダプタ

専用トークン リング ポート アダプタ(PA-4R-DTR)は、Cisco 7500 シリーズ ルータ、Cisco 7200 シリーズ ルータ、および 7000 シリーズ ルート スイッチ プロセッサ(RSP7000)と 7000 シリーズ シャーシ インターフェイス(RSP7000CI)搭載 Cisco 7000 シリーズ ルータで使用できます。

PA-4R-DTR は、最大 4 つの IBM トークン リング インターフェイスまたは IEEE 802.5 トークン リング インターフェイスを提供します。各トークン リング インターフェイスは、4 Mbps または 16 Mbps の半二重または全二重動作に設定でき、標準トークン リング ステーションまたはコンセントレータ ポートとして動作します。すべてのインターフェイスのデフォルトは、半二重 16 Mbps 動作のトークン リング ステーション モードです。PA-4R-DTR は、タイプ 1 またはタイプ 3 ローブ ケーブルで接続され、各インターフェイスは RJ-45 レセプタクルを備えています。

トークン リング インターフェイスの設定作業の一覧

トークン リング インターフェイスを設定するには、次の項で説明する作業を実行します。各作業は、必須と任意に分けられています。

「トークン リング インターフェイスの指定」(必須)

「アーリー トークン リリースのイネーブル化」(任意)

「PCbus トークン リング インターフェイス管理の設定」(任意)

「トークン リング コンセントレータ ポートのイネーブル化」(任意)

「ポートのモニタリングおよびメンテナンス」(任意)

トークン リング インターフェイスの指定

トークン リング インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで次のいずれかのコマンドを使用します。

 

コマンド
目的

Router(config)# interface tokenring number

インターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface tokenring slot / port

Cisco 7200 または Cisco 7500 シリーズ ルータのインターフェイス コンフィギュレーション モードを開始します。

Router(config)# interface tokenring slot / port-adapter / port

Cisco 7500 シリーズ ルータのインターフェイス コンフィギュレーション モードを開始します。

アーリー トークン リリースのイネーブル化

シスコ トークン リング インターフェイスは、アーリー トークン リリースをサポートします。アーリー トークン リリースでは、インターフェイスはフレームが戻るのを待機するのではなく、トークンの送信後ただちにトークンをリングに戻します。この機能は、トークン リングの全帯域幅を増やすのに役立ちます。アーリー トークン リリース用にインターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# early-token-release

アーリー トークン リリースをイネーブルにします。

PCbus トークン リング インターフェイス管理の設定

AccessPro PC カードのトークン リング インターフェイスは、PCbus インターフェイスのリモート LAN マネージャで管理できます。現時点では、IBM 互換 PC で実行される LanOptics ハブ ネットワーキング管理ソフトウェアでサポートされています。

PCbus トークン リング インターフェイスの LanOptics ハブ ネットワーキング管理をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# local-lnm

PCbus LAN 管理をイネーブルにします。

トークン リング コンセントレータ ポートのイネーブル化

インターフェイスがコンセントレータ ポートとして動作するようにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# port

コンセントレータ ポートの動作を指定します。

ポートのモニタリングおよびメンテナンス

トークン リング コンセントレータ ポートをモニタリングするには、EXEC モードで次のコマンドを 1 つまたは複数使用します。

 

コマンド
目的

Router# show controllers token

システム内のトークン リング インターフェイスの内部状態の情報を表示します。

Router# show interfaces token

特定のインターフェイスの高度な統計情報を表示します。

LAN インターフェイスの設定例

ここでは、この章で説明する設定作業の例について説明します。

「イーサネット カプセル化のイネーブル化例」

「全二重モードのイネーブル化操作の例」

「PA-12E/2FE ポートの設定例」

「PA-VG100 ポート アダプタの設定例」

「Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E の設定例」

「ファスト EtherChannel の設定例」

「FDDI フレームの設定例」

「ハブの設定例」

イーサネット カプセル化のイネーブル化例

次のコマンドは、Cisco 7500 シリーズ ルータのポート 2 のスロット 4 にあるイーサネット インターフェイス プロセッサの標準イーサネット バージョン 2.0 カプセル化をイネーブルにします。

interface ethernet 4/2
encapsulation arpa

全二重モードのイネーブル化操作の例

次に、スロット 1 のポート アダプタ 0 にあるファスト イーサネット インターフェイス ポート 0 で、IP アドレスとサブネット マスクを割り当て、MII イーサネット コネクタを指定し、全二重モードをイネーブルにする例を示します。

Router(config)# interface fastethernet 1/0/0
Router(config-if)# ip address 10.1.1.10 255.255.255.0
Router(config-if)# full-duplex
Router(config-if)# media-type mii
Router(config-if)# exit
Router(config)# exit

PA-12E/2FE ポートの設定例

次に、PA-12E/2FE ポート アダプタ インターフェイスの設定例を示します。ブリッジ グループ 10、20、および 30 は IEEE スパニング ツリー プロトコルを使用します。ポート アダプタ スロット 3 の PA-12E/2EF ポート アダプタの最初の 4 つのインターフェイスは、ブリッジ グループ 10 と 20 を使用します。各インターフェイスはブリッジ グループに割り当てられ、シャットダウン状態はアップに設定されます。PA-12E/2FE ポート アダプタは、同じブリッジ グループ内のインターフェイス間でストアアンドフォワードまたはカットスルー スイッチング テクノロジーをサポートします。デフォルトはストアアンドフォワードです。次の例では、 cut-through コマンドを使用して、受信または送信されたデータのカットスルー スイッチングの各インターフェイスを設定します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL-Z.
Router(config)# bridge 10 protocol ieee
Router(config)# bridge 20 protocol ieee
Router(config)# bridge 30 protocol ieee
 
Router(config)# interface fastethernet 3/0
Router(config-if)# bridge-group 10
Router(config-if)# cut-through
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Fast Ethernet3/0, changed
state to up
%LINK-3-UPDOWN: Interface Fast Ethernet3/0, changed state to up
 
Router(config)# interface fastethernet 3/1
Router(config-if)# bridge-group 10
Router(config-if)# cut-through
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Fast Ethernet3/1, changed
state to up
%LINK-3-UPDOWN: Interface Fast Ethernet3/1, changed state to up
 
Router(config)# interface ethernet 3/2
Router(config-if)# bridge-group 20
Router(config-if)# cut-through
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet3/2, changed state to up
%LINK-3-UPDOWN: Interface Ethernet3/2, changed state to up
 
Router(config)# interface ethernet 3/3
Router(config-if)# bridge-group 20
Router(config-if)# cut-through
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet3/3, changed state to up
%LINK-3-UPDOWN: Interface Ethernet3/3, changed state to up
 

次に、ブリッジ グループでイネーブルになっている Integrated Routing and Bridging の例を示します。ブリッジ グループ 10 は IP アドレスとサブネット マスクが割り当てられ、シャットダウン状態はアップに変更されます。ブリッジ グループ 10 は IP をルーティングするように設定されます。

Router(config)# bridge irb
Router(config)# interface bvi 10
Router(config-if)# ip address 10.1.15.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface BVI10, changed state to up
 
Router(config)# bridge 10 route ip
Router(config)# exit
Router#

PA-VG100 ポート アダプタの設定例

次に、Cisco 7500 シリーズ ルータのスロット 1 の PA-VG100 ポート アダプタ インターフェイスの基本設定例を示します。この例では、ルータで IP ルーティングがイネーブルに設定されているため、IP アドレスとサブネット マスクがインターフェイスに割り当てられます。

configure terminal
interface vg-anylan 1/0/0
ip address 10.1.1.10 255.255.255.0
no shutdown
exit
exit

Cisco 7200-I/O-GE+E および Cisco 7200-I/O-2FE/E の設定例

ここでは、次の設定例について説明します。

「Cisco 7200-I/O-GE+E のギガビット イーサネット インターフェイスの設定」

「Cisco 7200-I/O-2FE/E の自動ネゴシエーションの設定」

Cisco 7200-I/O-GE+E のギガビット イーサネット インターフェイスの設定

次に、Cisco 7200-I/O-GE+E にギガビット イーサネット インターフェイスを設定する例を示します。次のコマンドは、スロット 0、ポート 0 で設定します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 10.1.1.10 255.255.255.252
Router(config-if)# negotiation auto
Router(config-if)# end

Cisco 7200-I/O-2FE/E の自動ネゴシエーションの設定

次に、自動ネゴシエーションを完全にイネーブルにするために Cisco 7200-I/O-2FE/E のファスト イーサネット インターフェイスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 0/0
Router(config-if)# duplex auto
Router(config-if)# speed auto

ファスト EtherChannel の設定例

図 2 に、1 つのファスト EtherChannel インターフェイスに集約されたポイントツーポイント ファスト イーサネット インターフェイス 4 つを示します。

図 2 ファスト EtherChannel に集約されたファスト イーサネット インターフェイス

 

このトポロジを示すコンフィギュレーション ファイルは次のとおりです。

次に、ファスト イーサネット インターフェイスが 4 つあるファスト EtherChannel(ポートチャネル インターフェイス)を作成する例を示します。この例では、ISL がファスト EtherChannel でイネーブルに設定され、IP アドレスがサブインターフェイスに割り当てられています。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface port-channel 1.1
Router(config-if)# ip address 10.1.1.10 255.255.255.0
Router(config-if)# encapsulation isl 100
Router(config-if)# exit
Router(config)# interface fastethernet 0/0/0
Router(config-if)# no ip address
Router(config-if)# channel-group 1
Fast Ethernet 0/0 added as member-1 to port-channel1.
Router(config-if)# exit
Router(config)# interface fastethernet 0/1/0
Router(config-if)# no ip address
Router(config-if)# channel-group 1
Fast Ethernet 0/1 added as member-2 to port-channel1.
Router(config-if)# exit
Router(config)# interface fastethernet 1/0/0
Router(config-if)# no ip address
Router(config-if)# channel-group 1
Fast Ethernet 1/0 added as member-3 to port-channel1.
Router(config-if)# exit
Router(config)# interface fastethernet 1/1/0
Router(config-if)# no ip address
Router(config-if)# channel-group 1
Fast Ethernet 1/1 added as member-4 to port-channel1.
Router(config-if)# exit
Router(config)# exit
Router#
 

次に、コンフィギュレーション ファイルの例の一部を示します。ファスト イーサネット インターフェイスがファスト EtherChannel に追加されると、MAC アドレスが自動的にファスト イーサネット インターフェイスに追加されます。


) ポートチャネル インターフェイスでスタティック MAC アドレスを割り当てなかった場合、Cisco IOS ソフトウェアは自動的に MAC アドレスを割り当てます。スタティック MAC アドレスを割り当てた後で削除した場合も、Cisco IOS ソフトウェアは自動的に MAC アドレスを割り当てます。


interface Port-channel1
ip address 10.1.1.10 255.255.255.0
!
interface Port-channel1.1
encapsulation isl 100
!
interface Fast Ethernet0/0/0
mac-address 00e0.1476.7600
no ip address
channel-group 1
!
interface Fast Ethernet0/1/0
mac-address 00e0.1476.7600
no ip address
channel-group 1
!
interface Fast Ethernet1/0/0
mac-address 00e0.1476.7600
no ip address
channel-group 1
!
interface Fast Ethernet1/1/0
mac-address 00e0.1476.7600
no ip address
channel-group 1

FDDI フレームの設定例

次に、トークン キャプチャごとに 4 つのフレームを送信するように FDDI インターフェイスを設定する例を示します。

! Enter global configuration mode.
4700# configure terminal
! Enter interface configuration mode.
4700(config)# interface fddi0
! Show the fddi command options.
4700(config-if)# fddi ?
encapsulate Enable FDDI Encapsulation bridging
frames-per-token Maximum frames to transmit per service opportunity
tl-min-time Line state transmission time
token-rotation-time Set the token rotation timer
valid-transmission-time Set transmission valid timer
! Show fddi frames-per-token command options.
4700(config-if)# fddi frames-per-token ?
<1-10> Number of frames per token, default = 3
! Specify 4 as the maximum number of frames to be transmitted per token.
4700(config-if)# fddi frames-per-token 4

ハブ ポートの起動例

次に、イーサネット インターフェイス 0 のハブ 0 にポート 1 を設定する例を示します。

hub ethernet 0 1
no shutdown
 

次に、イーサネット インターフェイス 0 のハブ 0 にポート 1 ~ 8 を設定する例を示します。

hub ethernet 0 1 8
no shutdown

イーサネット ハブ ポートの送信元アドレスの設定例

次に、ハブ 0 のポート 2 で MAC アドレス 1111.2222.3333 からのパケットだけを許可するようにハブを設定する例を示します。

hub ethernet 0 2
source-address 1111.2222.3333
 

次に、ポート 2 で受信した最初の MAC アドレスを記憶し、その学習した MAC アドレスからのパケットだけを許可するようにハブを設定する例を示します。

hub ethernet 0 2
source-address

ハブ ポートのシャットダウン例

次に、ハブ 0 のポート 3 ~ 5 をシャットダウンする例を示します。

hub ethernet 0 3 5
shutdown
 

次に、ハブ 0 のポート 3 をシャットダウンする例を示します。

hub ethernet 0 3
shutdown

ハブ ポートの SNMP 不正アドレス トラップのイネーブル化例

次に、ハブ ポート 2、3、または 4 で MAC アドレス違反が検出されると、ゲートウェイ IP アドレスを指定し、ホスト 172.16.40.51 に対して SNMP トラップを発行する例を示します。これは、イーサネット インターフェイス 0 がルータのすべてのトラップの発信元になるように指定します。コミュニティ ストリングはストリング public として定義され、読み取りと書き込みパラメータが設定されます。

ip route 0.0.0.0 0.0.0.0 172.22.10.1
snmp-server community public rw
snmp-server trap-source ethernet 0
snmp-server host 172.16.40.51 public
hub ethernet 0 2 4
snmp trap illegal-address