Cisco IOS SIP コンフィギュレーション ガイド
SIP RSVP 機能の設定
SIP RSVP 機能の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

SIP RSVP 機能の設定

機能情報の確認

この章の構成

SIP RSVP 機能の前提条件

SIP RSVP 機能の制約事項

SIP RSVP 機能について

RSVP 帯域幅の制限

RSVP 事前条件

SIP オーディオ RSVP の事前条件

SIP ビデオ RSVP の事前条件

グローバルとインターフェイスごとの RSVP ポリシー

RSVP ポリシー アプリケーション

優先度の優先と保護

優先動作の概要

優先度の優先のシグナリング

優先させる動作の設定

サポートされる SIP RSVP の実装と機能

設定可能な RSVP アプリケーション ID

予約失敗時のコール処理ポリシー

RSVP なし、RSVP の正常終了、および RSVP の障害に基づいて設定可能な DSCP の値

SIP RSVP 機能の設定方法

SIP RSVP アプリケーション ID サポートの設定

SIP オーディオ RSVP 事前条件のアプリケーション識別情報の設定

RSVP の保護優先度の設定

RSVP の優先させる優先度の設定

SIP RSVP 帯域予約の設定

インターフェイスでの RSVP 帯域予約の設定

H.320 ダイヤル ピアのベアラ機能の設定

SIP RSVP 事前条件の設定

SIP オーディオ RSVP の事前条件の RSVP 障害ポリシーの設定

DSCP 識別情報の設定

SIP RSVP の設定例

SIP ゲートウェイ上の SIP オーディオ RSVP の事前条件の例

H.320-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例

H.324-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例

SIP コールでの RSVP 事前条件動作の確認例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

SIP RSVP 機能の機能情報

用語集

SIP RSVP 機能の設定

Cisco IOS ソフトウェアでは、Session Initiation Protocol(SIP)を Resource Reservation Protocol(RSVP; リソース予約プロトコル)と組み合わせて、RSVP アプリケーション ID サポート(RFC 2872)と RSVP 事前条件サポート(RFC 3312 と RFC 4032)が拡張されています。RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified Communications Manager Express(Cisco Unified CME)機能によって、Cisco IOS SIP デバイス上のローカル ポリシー一致基準の細部が拡張されるアプリケーション特有の予約が導入されています。さらに、この機能によって、Skinny Client Control Protocol(SCCP)回線側の Cisco Unified CME デバイスの、SIP Time-Division Multiplexing(TDM; 時分割多重)ゲートウェイと、SIP トランクの両方で、オーディオの SIP オーディオ RSVP 事前条件がサポートされます。

RSVP Preconditions for Video Gateway 機能では、H.324-SIP ビデオ ゲートウェイ上の SIP ビデオ コールの既存サポートが拡張され、H.320-SIP ビデオ ゲートウェイが含められます。さらに、この機能では、H.320-SIP ビデオ ゲートウェイと H.324-SIP ビデオ ゲートウェイの両方で、SIP ビデオ コールの SIP ビデオ RSVP 事前条件のサポートが追加されています。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の一部がサポートされていない場合があります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「SIP RSVP 機能の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、Cisco Catalyst OS ソフトウェア イメージ、および Cisco IOS XE ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

SIP RSVP 機能の前提条件

QoS(Quality of Service)管理の RSVP アプリケーション ID サポートを設定できるようになる前に、ネットワーク内でリンクを共有する、少なくとも 2 つの隣接ルータの 1 つまたは複数のインターフェイス上で、RSVP を設定する必要があります。

SIP 時分割多重(TDM)ゲートウェイでは、基本オーディオ コールおよび通話中帯域幅の変更のための、 RFC 3312 エンドツーエンドの事前条件に基づいて、RSVP 事前条件がすでにサポートされています。

SIP RSVP 機能の制約事項

SIP TDM ゲートウェイ上の RSVP 機能には、次のような制約事項が適用されます。

グローバル ポリシーとインターフェイス ベースのローカル ポリシーとのマージは、サポートされていません。複数のポリシーを一致させることはできません。

RSVP は、唯一サポートされている、事前条件ベースの QoS メカニズムです。

エンドツーエンド事前条件のみがサポートされ、セグメント化された事前条件はサポートされません。

QoS の強度は、両方向(SENDRECV)で同じ(必須または任意)である必要があります。

通話中 QoS ネゴシエーションでは、RFC 例で示されているように、暫定応答には使用されません。

新しいセッション パラメータ(コーデックおよびリモート アドレス)は、強度が必須の場合でも、通話中 QoS ネゴシエーションの OFFER/ANSWER の直後に使用されます( RFC 3312 、Section 6 を参照)。

RSVP の開始は、単一ストリームでのみサポートされます。

さらに、RSVP サポートは、次の機能とデバイスでは使用できません。

SIP コール フォーキング。

H.323 ゲートウェイ。

ビデオ補足サービス。

Cisco Unified Border Element のビデオ コール。

Cisco Unified CME のビデオ コール。

Cisco Unified Communications Manager またはサード パーティ エンドポイントに接続されたビデオ コール。

H.320、H.323、および H.324 オーディオのみのコール。

基本ビデオ エスカレーションおよびエスカレーション解除。

SIP RSVP 機能について

このセクションの情報は、主に、SIP の RSVP 事前条件に焦点を当てています。Cisco Unified CME ゲートウェイおよび SIP TDM ゲートウェイから発行された SIP RSVP オーディオ要求のサポートと、H.320-SIP ビデオ ゲートウェイおよび H.324-SIP ビデオ ゲートウェイのサポートについての情報が含まれています。RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified Communications Manager Express 機能は、Cisco IOS リリース 12.4(22)T またはそれ以降で実行中のサポート対象デバイス上でのみ使用可能で、RSVP Preconditions for Video Gateway 機能は、Cisco IOS リリース 12.4(24)T またはそれ以降のリリースを実行中のサポート対象デバイスでのみ使用可能です。RSVP アプリケーション ID 機能の詳細については、『 Cisco IOS Quality of Service Solutions Configuration Guide 』の「Signalling」にある RSVP に関するサブセクションの、「 Configuring RSVP 」を参照してください。

SIP TDM ゲートウェイまたは Cisco Unified CME で SIP RSVP アプリケーション ID サポートまたは SIP RSVP 事前条件を設定する前に、次の概念を理解しておく必要があります。

「RSVP 帯域幅の制限」

「RSVP 事前条件」

「グローバルとインターフェイスごとの RSVP ポリシー」

「RSVP ポリシー アプリケーション」

「優先度の優先と保護」

「サポートされる SIP RSVP の実装と機能」

RSVP 帯域幅の制限

音声およびビデオなどの複数アプリケーションでは、RSVP のサポートが必要です。Cisco IOS ソフトウェアでは、アプリケーション ID および設定されている RSVP ローカル ポリシーに基づいて、複数の帯域幅プールを参照することによって、RSVP によって、要求を処理し、受け付けることができます。これらのプールによって、許可されるアプリケーション、および、指定された帯域幅限度に達するまでそれぞれに予約できる帯域幅の容量が指定されます。

限度がない場合か、使用可能な残りの帯域幅がない場合、RSVP によって、設定されていない、帯域幅プールで優先順位付けされていない要求が拒否されます。たとえば、ビデオ コールがプールに設定されているが、音声コールは設定されていない場合、少しのビデオ コールによって、ほとんどまたはすべての音声コールの確立を防ぐことができます。ビデオ コールは、十分な残りの帯域幅がない可能性がある、非常に大容量の帯域幅が必要です。ビデオが、RSVP が必要とされるアプリケーションの 1 つのとき、このような動作によって、音声だけではなく、複数アプリケーションの RSVP の実装ができない可能性があります。

1 つのアプリケーション タイプですべての帯域幅の消費を防ぐために、 RFC 2872 Application and Sub Application Identity Policy Element for Use with RSVP 」によって、別の帯域幅予約プールの作成が許可されます。たとえば、これらのアプリケーション ID でタグ付けされている予約が、RSVP ローカル ポリシーを使用して、インターフェイス帯域幅プールに一致するようにするため、ある RSVP 予約プールを音声トラフィックに作成し、別のプールをビデオ トラフィックに作成できます。しかし、アプリケーションごとに帯域幅を制限するには、各アプリケーションに帯域幅の限度を設定し、アプリケーションを適切な帯域幅の限度と関連付ける、それぞれの予約フラグを設定する必要があります。

RSVP 事前条件

SIP コールの RSVP 事前条件についての情報は、次のセクションで説明します。

「SIP オーディオ RSVP の事前条件」

「SIP ビデオ RSVP の事前条件」

SIP オーディオ RSVP の事前条件

RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified CME 機能を使用すると、SIP ゲートウェイまたは Cisco Unified CME SIP トランクで開始された SIP セッションの確立のための事前条件として、RSVP を設定することができます。RSVP の限度を強制的に適用するには、両方のエンドポイントを設定し、RSVP 接続を受信およびサポートする必要があります。一度設定されると、RSVP 事前条件サポートによって、セッションを続行する前に、加入者のネットワーク リソースの予約を要求することによって、SIP TDM ゲートウェイ上の RSVP アプリケーション ID のサポートを行うことができます。

Cisco IOS SIP ゲートウェイ上の RSVP サポートには、コールの保留、コール転送、および共有回線機能のサポートが含まれます。この実装では、すべての制御が RSVP レイヤと同期させることができる SIP ヘッダー事前条件オプションが使用されます。

RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified CME 機能によって、Cisco IOS SIP ゲートウェイ上での RSVP サポートが強化され、Cisco IOS SIP-TDM ゲートウェイによって開始される reINVITE および REFER/302 ベースの補足サービスが処理されます。

SIP ビデオ RSVP の事前条件

RSVP Preconditions for Video Gateway 機能では、H.324-SIP ビデオ ゲートウェイ上の SIP ビデオ コールの既存サポートが拡張され、H.320-SIP ビデオ ゲートウェイが含められます。さらに、この機能では、H.320-SIP ビデオ ゲートウェイと H.324-SIP ビデオ ゲートウェイの両方で、SIP ビデオ コールの SIP ビデオ RSVP 事前条件のサポートが追加されています。ただし、これらのゲートウェイのそれぞれの帯域幅予約アトリビュートには、非常に大きな違いがあります。

H.320 ビデオ ゲートウェイの帯域予約

H.320 コールによって、(POTS ダイヤル ピア上の最大帯域幅設定によって決められる)最大で 16 B チャネルまでを占有できます。

事前条件ネゴシエーション中に、64 KB/s プラス 20 %のオーバーヘッドによって、オーディオ ストリームが予約され、設定された最大帯域幅容量(プラス 20 %までのオーバーヘッド)によって、ビデオ ストリームが予約されます。

コールが一度確立されると、ネゴシエートされるオーディオ コーデックが 64 KB/s 未満が必要な場合、超過分のオーディオ帯域幅は解放されます。さらに、必要なビデオ帯域幅が決定され(設定された最大帯域幅設定から、オーディオ帯域幅を差し引く)、超過分のビデオ帯域幅が解放されます。

H.324 ビデオ ゲートウェイの帯域予約

H.324 コールによって、1 つの B チャネルのみが占有されます。

オーディオ帯域幅は、Adaptive Multirate(AMR)コーデックの 12.2 KB/s または G.711 コーデックの 64 KB/s のいずれかになります。H.324 コーデックは、常に AMR で、SIP 側のオーディオ コーデックが G.711 の場合、Digital Signal Processor(DSP; デジタル シグナル プロセッサ)によって、2 つの間のトランスコーディングが実行されます。

ビデオ帯域幅は、常に、50 KB/s(64 KB/s から 12.2 KB/s を差し引く)です。

H.320 コールでは、事前条件ネゴシエーション中に、64 KB/s プラス 20 %のオーバーヘッドが、オーディオ ストリーム用に予約されます。しかし、H.324 コールでは、ビデオ用に予約された帯域幅は、常に 64 KB/s(プラス 20 %のオーバーヘッド)です。

コールが一度確立され、オーディオ コーデックがネゴシエートされると、超過帯域幅が解放され、これによって、(ネゴシエートされるコーデックによって、)ビデオ用に 50 KB/s の帯域幅が予約され、オーディオ用に 64 KB/s または 12.2 KB/s の帯域幅が予約されます。

グローバルとインターフェイスごとの RSVP ポリシー

RSVP をグローバルに、または、インターフェイスごとのベースで、設定できます。複数のグローバル ポリシーと、インターフェイスごとの複数のポリシーも、設定できます。

インターフェイスの数に関係なく、グローバル RSVP ポリシーによって、ルータが使用する RSVP 帯域幅の容量が制限されます。使用しているルータに、帯域幅の限度が異なる CPU の制約事項、1 つのインターフェイス、または複数のインターフェイスがある場合、グローバル ポリシーを設定する必要があります。

インターフェイスごとの RSVP ポリシーを使用すると、限度がさまざまな別の帯域幅プールを設定できます。これによって、廃棄される、音声などの他のアプリケーションによる負担で、指定されたインターフェイスのすべての RSVP 帯域幅が消費される、ビデオなどのアプリケーションはありません。使用可能な帯域幅を、より大幅に制御する必要がある場合、インターフェイスごとポリシーを設定する必要があります。

RSVP ポリシー アプリケーション

RSVP では、RSVP メッセージが処理されるたびに、ポリシーが検索されます。特別な処理がそのメッセージに必要な場合、ポリシーによって、RSVP に通知されます。

ネットワーク設定に、グローバルとインターフェイスごとの RSVP ポリシーがある場合、インターフェイスごとポリシーが、まず、適用されます。つまり、RSVP では、ポリシーが設定された順序でポリシー一致基準が検索されます。RSVP では、次の順序でポリシー一致基準が検索されます。

非デフォルト インターフェイス ポリシー

デフォルト インターフェイス ポリシー

非デフォルト グローバル ポリシー

グローバル デフォルト ポリシー

RSVP によって、ポリシー一致基準が見つからなかった場合、すべての着信メッセージを受信します。受信から拒否にこの決定を変更するには、ip rsvp policy default-reject コマンドを使用します。

優先度の優先と保護

RSVP プールの帯域幅が十分ではないため、1 つの予約では、別の予約よりも優先される優先度がある場合に、優先が発生します。優先度の動作の一般的な情報と設定は、次の項で説明します。

「優先動作の概要」

「優先度の優先のシグナリング」

「優先させる動作の設定」

優先動作の概要

RSVP 帯域幅プールには、ローカル ポリシーとインターフェイス プールとの、2 つのタイプがあります。ローカル ポリシーは、グローバルな場合とインターフェイス特有である場合があります。RESV メッセージの到着時に、RSVP によって、これらのプールに対してアドミッション コントロールが実行されます。

着信予約要求が、すでに到達した RSVP 帯域幅限度の RSVP ローカル ポリシーに一致する場合、RSVP では、ポリシーによって許可された、より低い優先度の予約よりも、優先させる試行が行われます。着信した、優先度がより高い要求のために容量を優先させることができる、より低い予約がない場合、RSVP によって、拒否されます。新しいコールのために容量を優先させることができる、より低い優先度予約が十分にある場合、RSVP では、次に、インターフェイス上に帯域幅が十分にあるかどうかを決めるインターフェイス帯域幅プールをチェックすることによって、予約処理が続行されます。

インターフェイス プール帯域幅の限度に到達すると、RSVP では、新しい予約要求を満たすために、インターフェイス上にある、より低い優先度予約に対する優先が試行されます。ただし、RSVP では、予約が許可されているローカル ポリシーは考慮に入れられません。新しいコールのために容量を優先させることができるインターフェイス帯域幅プール状に、十分な帯域幅がない場合、新しい予約によって、ローカル ポリシー プールから帯域幅を取得できる場合でも、RSVP では、新しい予約が拒否されます。

RSVP 帯域幅プールを使用している既存の予約が、プールに入らないような、値がより低いすべてのタイプの RSVP 帯域幅プールを、手作業で再設定する場合、優先が発生する場合があります。使用可能な帯域幅で他の予約と競合する場合、優先の割り当てと優先値の保護によって、予約では、これらの値で予約するか、優先を発生させるか、または優先を回避することができます。

優先度の優先のシグナリング

受信した RSVP PATH メッセージまたは RESV メッセージに、優先させる優先度が含まれていない場合、 ip rsvp policy preempt コマンドはグローバルにイネーブルにされ、メッセージは、 ip qos preemption-priority コマンドが含まれているローカル ポリシーに一致され、次に、ローカル ポリシーの優先度に含まれる、優先させる優先度要素が使用されている POLICY_DATA オブジェクトが、ポリシー決定の一部としてメッセージに追加されます。これらの優先度は、RSVP 状態でルータに保存され、ネイバーに転送されます。

優先させる動作の設定

ip rsvp policy preempt コマンドによって、必要に応じて、ルータが優先させる予約があるかどうかが制御されます。このコマンドを使用するときに、新しい予約に割り当てられたセットアップ優先度が、インストールされている予約に割り当てられている保留の優先度よりも高い場合、インターフェイス上に到着する後続の RESV メッセージでは、そのインターフェイス上の 1 つまたは複数の帯域幅を優先させることができます。

さらに、ダイヤル ピア VoIP コンフィギュレーション モードで、 ip qos defending-priority コマンドおよび ip qos preemption-priority コマンドを使用して、QoS 動作のより特有な設定について、それぞれ、RSVP の保護と優先の優先度値の設定が行われます。

サポートされる SIP RSVP の実装と機能

Cisco IOS Audio RSVP Precondition 機能では、SCCP 回線側 Cisco Unified CME デバイスの SIP トランク上に、RSVP サポートも追加されています。次の RSVP シナリオは、SIP-TDM ゲートウェイ上と、オーディオ コールの SCCP 回線側 Cisco Unified CME デバイスの SIP トランク上で、サポートされます。

SCCP-Cisco Unified CME と Cisco IOS SIP TDM ゲートウェイでの基本コール

SCCP-Cisco Unified CME と Cisco IOS SIP-TDM ゲートウェイによって、コールの保留、自動転送、およびコール転送(ブラインドおよびコンサルト)が開始されます。

この機能では、次の項で説明する機能もサポートされます。

「設定可能な RSVP アプリケーション ID」

「予約失敗時のコール処理ポリシー」

「RSVP なし、RSVP の正常終了、および RSVP の障害に基づいて設定可能な DSCP の値」

設定可能な RSVP アプリケーション ID

Cisco IOS リリース 12.4(22)T よりも前の Cisco IOS SIP の実装では、どの RSVP アプリケーションにも、QoS モジュールは渡されませんでした。その後、Cisco IOS リリース 12.4(22)T またはそれ以降が実行されている Cisco IOS デバイスで、オーディオ ストリームおよびビデオ ストリームに RSVP を要求中に、RSVP アプリケーション ID を QoS モジュールに渡すことができるよう、1 つのコマンドがダイヤル ピア VoIP コンフィギュレーション モードに追加されました。

予約失敗時のコール処理ポリシー

予約の失敗は、最初の RSVP 確立試行中、後続の RSVP 予約試行中(セッション ターゲットの変更など)、または確立された RSVP セッションの解放中に、発生する場合があります。障害が発生した時点に関係なく、RSVP 障害ポリシーは適用されます。事前アラート コールについては、 RFC 3312 で説明されているデフォルト ポリシーを参照してください。事後アラート コールについては、ダイヤル ピア VoIP コンフィギュレーション モードで voice-class sip rsvp-fail-policy コマンドを使用して、適用できます。

ローカル RSVP 障害ポリシーの強度は、次のオプションを使用して、「mandatory」または「optional」のいずれかに設定できます。

強度を optional に設定した場合: 障害ポリシーによって、RSVP の予約が再試行される間隔でのみ指定できます(間隔設定は、「infinity」に設定できます。これによって再試行されないことが指定されます)。

強度を mandatory に設定した場合: 障害ポリシーによって、RSVP の予約が再試行される間隔(「infinity」、または再試行なしオプション)と、コールの接続が解除される前に再試行される回数の両方が、決められます。必要に応じて、mandatory 強度が使用された障害ポリシーの再試行回数は、「infinity」に設定できます。これによって、障害の発生時にコールの接続が解除されないことが、指定されます。

RSVP なし、RSVP の正常終了、および RSVP の障害に基づいて設定可能な DSCP の値

Cisco IOS リリース 12.4(22)T よりも前のリリースでは、3 つの異なる RSVP シナリオに従って、ビデオ パケットに異なる DSCP 値を割り当てるコマンド(ダイヤル ピア VoIP コンフィギュレーション モードの ip qos dscp コマンド)があります。3 つの異なる RSVP シナリオとは、RSVP がディセーブルの場合、正常終了する場合、および障害が発生する場合です。しかし、RSVP シナリオに関係なく、1 つの DSCP 値のみを、オーディオ パケットに設定できます。

Cisco IOS リリース 12.4(22)T およびそれ以降のリリースには、 ip qos dscp コマンドに、3 つの異なる RSVP シナリオ(ディセーブル、正常終了、および障害発生)に特有でもあるオーディオ パケットに、異なる DSCP 値を設定できるようにする、変更が含まれます。このコマンドでは、RSVP ステータスに従って、ビデオ パケットとオーディオ パケットの両方の各 RSVP ステータスについて、固有の DSCP 値を設定し、RTP ライブラリに送信することができます。

SIP RSVP 機能の設定方法

ここでは、次の各手順について説明します。

「SIP RSVP アプリケーション ID サポートの設定」(必須)

「SIP RSVP 帯域予約の設定」(必須)

「SIP RSVP 事前条件の設定」(必須)

SIP RSVP アプリケーション ID サポートの設定

この項の作業を実行し、SIP RSVP アプリケーション ID、保護優先度設定、および、必要な場合は、優先させる優先度を設定します。

「SIP オーディオ RSVP 事前条件のアプリケーション識別情報の設定」(必須)

「RSVP の保護優先度の設定」(必須)

「RSVP の優先させる優先度の設定」(任意)

SIP オーディオ RSVP 事前条件のアプリケーション識別情報の設定

SIP オーディオ RSVP 事前条件を指定するアプリケーション識別情報を設定するには、この作業を実行します (この作業は、ビデオ コールには適用されません。ビデオには、デフォルト ポリシーが適用されます)。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. ip qos policy-locator { video | voice } [ app app-string ] [ guid guid-string ] [ sapp subapp-string ]
[ver version-string ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

グローバル コンフィギュレーション モードから、ダイヤル ピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

ip qos policy-locator { video | voice }
[ app app-string ] [ guid guid-string ]
[ sapp subapp-string ] [ ver version-string ]

 

Router(config-dial-peer)# ip qos policy-locator voice app CISCO guid aaa sapp bbb ver ccc

アプリケーション ID を設定します。

RSVP の保護優先度の設定

RSVP 予約の保護優先度を設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. ip qos defending-priority defending-pri-value

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

グローバル コンフィギュレーション モードから、ダイヤル ピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

ip qos defending-priority defending-pri-value

 

Router(config-dial-peer)# ip qos defending-priority 65

RSVP 保護優先度を設定します。

RSVP の優先させる優先度の設定

RSVP 予約の優先させる優先度を設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. ip qos preemption-priority preemption-pri-value

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

グローバル コンフィギュレーション モードから、ダイヤル ピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

ip qos preemption-priority preemption-pri-value

 

Router(config-dial-peer)# ip qos preemption-priority 45

RSVP 優先させるポリシーおよび保護優先度を設定します。

SIP RSVP 帯域予約の設定

SIP RSVP Preconditions 機能とともに使用される RSVP 帯域幅予約を設定するには、この項の作業を実行します。

「インターフェイスでの RSVP 帯域予約の設定」(必須)

「H.320 ダイヤル ピアのベアラ機能の設定」(任意)

インターフェイスでの RSVP 帯域予約の設定

インターフェイス上に RSVP 帯域予約を設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ rdm kbps { subpool kbps | bc1 subpool } | mam max-reservable-bw kbps bc0 kbps bc1 kbps ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet 0/1

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ rdm kbps { subpool kbps | bc1 subpool } | mam max-reservable-bw kbps bc0 kbps bc1 kbps ]

 

Router(config-if)# ip rsvp bandwidth 1158 100

インターフェイス上に、RSVP の帯域予約を設定します。

H.320 ダイヤル ピアのベアラ機能の設定

ベアラ機能を設定するには、この作業を実行します。これによって、H.320 ダイヤル ピア上に非制限デジタル メディアのサポートがイネーブルにされます。


) この作業は、H.320-SIP コールで必要です。H.324-SIP コールまたは RSVP には特に必要ではありませんが、H.320 ダイヤル ピア上の RSVP 事前条件を使用する前に、設定する必要があります。


手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. voice-class sip calltype-video

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

ダイヤルピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

voice-class sip calltype-video

 

Router(config-dial-peer)# voice-class sip calltype-video

H.320 ダイヤル ピア上にベアラ機能を設定し、非制限デジタル メディアをサポートします。

SIP RSVP 事前条件の設定

SIP TDM ゲートウェイまたは Cisco Unified CME 上で SIP RSVP Preconditions 機能を設定するには、この項の作業を実行します。

「SIP オーディオ RSVP の事前条件の RSVP 障害ポリシーの設定」(オーディオのみ必須)

「DSCP 識別情報の設定」(必須)

SIP オーディオ RSVP の事前条件の RSVP 障害ポリシーの設定

SIP オーディオ RSVP の事前条件の RSVP 障害ポリシーを設定するには、この作業を実行します (この作業は、ビデオ コールには適用されません。帯域幅計算アルゴリズムが原因で、ビデオ用の RSVP 障害事後アラートはありません)。

手順の概要

1. enable

2. configure terminal

3. interface type [number]

4. ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ rdm kbps { subpool kbps | bc1 subpool } | mam max-reservable-bw kbps bc0 kbps bc1 kbps ]

5. exit

6. dial-peer voice tag voip

7. req-qos { best-effort | controlled-load | guaranteed-delay } [{ audio bandwidth | video bandwidth } default | max bandwidth-value ]

8. acc-qos { best-effort | controlled-load | guaranteed-delay } [ audio | video ]

9. voice-class sip rsvp-fail-policy { video | voice } post-alert { optional keep-alive | mandatory { keep-alive | disconnect retry retry-attempts }} interval retry-interval

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface type [number]

 

Router(config)# interface FastEthernet 0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ] [ rdm kbps { subpool kbps | bc1 subpool } | mam max-reservable-bw kbps bc0 kbps bc1 kbps ]

 

Router(config-if)# ip rsvp bandwidth 85 85

指定されたインターフェイス上で、IP の RSVP をイネーブルにします。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

グローバル コンフィギュレーション モードから、ダイヤル ピア VoIP コンフィギュレーション モードを開始します。

ステップ 7

req-qos { best-effort | controlled-load | guaranteed-delay } [{ audio bandwidth | video bandwidth } default | max bandwidth-value ]

 

Router(config)# req-qos controlled-load

指定された VoIP ダイヤル ピアで使用される必要な QoS を指定します。

ステップ 8

acc-qos { best-effort | controlled-load | guaranteed-delay } [ audio | video ]

 

Router(config)# acc-qos controlled-load

VoIP ダイヤル ピア上のすべての着信コールおよび発信コールで、受け入れ可能な QoS を定義します。

ステップ 9

voice-class sip rsvp-fail-policy { video | voice } post-alert { optional keep-alive | mandatory { keep-alive | disconnect retry retry-attempts }} interval retry-interval

 

Router(config-dial-peer)# voice-class sip rsvp-fail-policy voice post-alert optional keep-alive interval 60

RSVP 障害ポリシーを設定します。

DSCP 識別情報の設定

DSCP 識別情報を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. ip qos dscp { dscp-value | set-af | set-cs | default | ef } { signaling | media [ rsvp-pass | rsvp-fail ] | video [ rsvp-none | rsvp-pass | rsvp-fail ]}

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 1 voip

グローバル コンフィギュレーション モードから、ダイヤル ピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

ip qos dscp { dscp-value | set-af | set-cs | default | ef } { signaling | media [ rsvp-pass | rsvp-fail ] | video [ rsvp-none | rsvp-pass | rsvp-fail ]}

 

Router(config-dial-peer)# ip qos dscp 12 media rsvp-pass

DSCP 識別情報を設定します。

SIP RSVP の設定例

ここでは、次の設定例について説明します。

「SIP ゲートウェイ上の SIP オーディオ RSVP の事前条件の例」

「H.320-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例」

「H.324-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例」

「SIP コールでの RSVP 事前条件動作の確認例」

SIP ゲートウェイ上の SIP オーディオ RSVP の事前条件の例

次に、SIP-TDM ゲートウェイ上に、オーディオ コール用の SIP オーディオ RSVP の事前条件を設定する例を示します。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3845-RSVP-1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no network-clock-participate slot 2
!
ip cef
!
no ip domain lookup
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
voice-card 2
no dspfarm
!
voice service voip
sip
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g729r8
codec preference 3 g729br8
!
archive
log config
hidekeys
!
controller T1 2/1/0
framing esf
linecode b8zs
!
controller T1 2/1/1
framing esf
linecode b8zs
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 172.25.19.72 255.255.255.0
duplex auto
speed auto
media-type rj45
ip rsvp bandwidth 85 85
!
ip route 0.0.0.0 0.0.0.0 172.25.19.1
!
ip http server
ip rsvp policy preempt
!
control-plane
!
voice-port 2/0/0
!
voice-port 2/0/1
!
dial-peer voice 1 voip
description TO RSVP GW-2
destination-pattern 2001
voice-class codec 1
voice-class sip rsvp-fail-policy audio post-alert optional keep-alive interval 60
voice-class sip rsvp-fail-policy audio post-alert mandatory disconnect retry 2 interval 30 interval 60
session protocol sipv2
session target ipv4:172.25.19.71
incoming called-number 1001
req-qos controlled-load
ip qos defending-priority 65534
ip qos preemption-priority 45
!
dial-peer voice 2 pots
destination-pattern 1001
port 2/0/0
!
dial-peer voice 3 voip
description TO CME-1
destination-pattern 6001
session protocol sipv2
session target ipv4:172.25.19.73
req-qos controlled-load
acc-qos controlled-load
ip qos defending-priority 65
!
dial-peer voice 4 voip
description TO CME-2
destination-pattern 7001
session protocol sipv2
session target ipv4:172.25.19.74
ip qos dscp af21 media rsvp-fail
ip qos dscp af21 media rsvp-pass
!
dial-peer voice 100 voip
description TO THE CUCM
destination-pattern 5000
session protocol sipv2
session target ipv4:172.25.19.3
!
sip-ua
handle-replaces
!
alias exec sdp show running-config | sec dial-peer
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
scheduler allocate 20000 1000
!
End

H.320-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例

次に、H.320-SIP ビデオ ゲートウェイ上に、ビデオ コール用の SIP ビデオ RSVP の事前条件を設定する例を示します。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname H320_GW2
!
voice-card 0
no dspfarm
!
voice-card 1
dspfarm
!
ip cef
!
isdn switch-type primary-ni
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
call start slow
!
voice class called number pool 100
index 1 5551005 - 5551015
!
voice class called number pool 7002
index 1 7003 - 7018
!
controller T1 3/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
interface GigabitEthernet0/1
ip address 172.25.19.72 255.255.255.0
duplex auto
speed auto
media-type rj45
ip rsvp bandwidth 400 400
!
interface Serial3/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn protocol-emulate network
isdn integrate calltype all
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1
!
ip http server
!
voice-port 3/0:23
voice-class called-number-pool 100
!
dial-peer voice 1 pots
description INCOMING DP FOR 8000
information-type video
incoming called-number 800
video calltype h320
bandwidth maximum 384
direct-inward-dial
forward-digits all
!
dial-peer voice 3 voip
description OUTGOING DP FOR 8000
destination-pattern 8001
voice-class sip rel1xx require "100rel"
session protocol sipv2
session target ipv4:172.25.19.77
req-qos controlled-load audio
req-qos controlled-load video
acc-qos controlled-load audio
acc-qos controlled-load video
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
scheduler allocate 20000 1000
!
End

H.324-SIP ゲートウェイ上の SIP ビデオ RSVP の事前条件の例

次に、H.324-SIP ビデオ ゲートウェイ上に、ビデオ コール用の SIP ビデオ RSVP の事前条件を設定する例を示します。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LB-5400-uut7
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging message-counter syslog
logging buffered 500000
no logging console
!
resource-pool disable
no aaa new-model
voice-card 1
!
voice-card 7
!
ip source-route
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-ni
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol none
h323
call start slow
sip
no update-callerid
!
voice class codec 200
codec preference 1 g711ulaw
video codec h261
video codec h263
!
voice class codec 301
codec preference 1 g711ulaw
video codec h263
video codec mpeg4
!
license feature gsmamrnb-codec-pack
!
archive
log config
hidekeys
!
controller T1 7/0
framing ESF
linecode b8zs
pri-group timeslots 1-24
!
controller T1 7/1
!
interface GigabitEthernet0/0
ip address 172.25.19.37 255.255.0.0
no ip proxy-arp
duplex auto
speed auto
negotiation auto
ip rsvp bandwidth 1000 1000
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
negotiation auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
no fair-queue
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial7/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn timer T310 400000
isdn protocol-emulate network
no cdp enable
!
ip default-gateway 172.25.1.1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.25.1.1
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
no ip http server
!
control-plane
!
voice-port 7/0:D
!
mgcp fax t38 ecm
!
dial-peer voice 301 voip
voice-class sip rel1xx require "100rel"
voice-class sip calltype-video
session protocol sipv2
session target ipv4:172.25.19.5
incoming called-number 8000
req-qos controlled-load audio
req-qos controlled-load video
acc-qos controlled-load audio
acc-qos controlled-load video
codec g711ulaw
!
dial-peer voice 300 pots
destination-pattern 8000
progress_ind alert strip
information-type video
direct-inward-dial
port 7/0:D
forward-digits all
!
ss7 mtp2-variant Company 0
ss7 mtp2-variant Company 1
ss7 mtp2-variant Company 2
ss7 mtp2-variant Company 3
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
exception data-corruption buffer truncate
end

SIP コールでの RSVP 事前条件動作の確認例

次に、エンドポイントの両側で必須の QoS を設定し、RSVP が正常終了したときに、RSVP 事前条件設定と動作を確認するための、 show sip - ua calls コマンドの出力例を示します。

Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of SIP User Agent Client(UAC) calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : F31FEA20-CFF411DC-8068DDB4-22C622B8@172.18.19.73
State of the call : STATE_ACTIVE (7)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 6001
Called Number : 1001
Bit Flags : 0x8C4401E 0x100 0x4
CC Call ID : 30
Source IP Address (Sig ): 172.18.19.72
Destn SIP Req Addr:Port : 172.18.19.73:5060
Destn SIP Resp Addr:Port: 172.18.19.73:64440
Destination Name : 172.18.19.73
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Mode : flow-through
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 30
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.19.72:18542
Media Dest IP Addr:Port : 172.18.19.73:16912
Orig Media Dest IP Addr:Port : 0.0.0.0:0
QoS ID : -2
Local QoS Strength : Mandatory
Negotiated QoS Strength : Mandatory
Negotiated QoS Direction : SendRecv
Local QoS Status : Success
 
 
Options-Ping ENABLED:NO ACTIVE:NO
Number of SIP User Agent Server(UAS) calls: 1

次に、エンドポイントの両側でオプションの QoS を設定し、RSVP が正常終了したときに、RSVP 事前条件設定と動作を確認するための、 show sip - ua calls コマンドの出力例を示します。

Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of SIP User Agent Client(UAC) calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : 867EA226-D01311DC-8041CA97-F9A5F4F1@172.18.19.73
State of the call : STATE_ACTIVE (7)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 6001
Called Number : 1001
Bit Flags : 0x8C4401E 0x100 0x4
CC Call ID : 30
Source IP Address (Sig ): 172.18.19.72
Destn SIP Req Addr:Port : 172.18.19.73:5060
Destn SIP Resp Addr:Port: 172.18.19.73:25055
Destination Name : 172.18.19.73
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Mode : flow-through
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 30
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.19.72:17556
Media Dest IP Addr:Port : 172.18.19.73:17966
Orig Media Dest IP Addr:Port : 0.0.0.0:0
QoS ID : -2
Local QoS Strength : Optional
Negotiated QoS Strength : Optional
Negotiated QoS Direction : SendRecv
Local QoS Status : Success
 
Options-Ping ENABLED:NO ACTIVE:NO
Number of SIP User Agent Server(UAS) calls: 1

次に、エンドポイントの両側でオプションの QoS を設定し、RSVP に障害が発生したときに、RSVP 事前条件設定と動作を確認するための、 show sip - ua calls コマンドの出力例を示します。

Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of SIP User Agent Client(UAC) calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : 867EA226-D01311DC-8041CA97-F9A5F4F1@172.18.19.73
State of the call : STATE_ACTIVE (7)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 6001
Called Number : 1001
Bit Flags : 0x8C4401E 0x100 0x4
CC Call ID : 30
Source IP Address (Sig ): 172.18.19.72
Destn SIP Req Addr:Port : 172.18.19.73:5060
Destn SIP Resp Addr:Port: 172.18.19.73:25055
Destination Name : 172.18.19.73
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Mode : flow-through
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 30
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.19.72:17556
Media Dest IP Addr:Port : 172.18.19.73:17966
Orig Media Dest IP Addr:Port : 0.0.0.0:0
QoS ID : -2
Local QoS Strength : Optional
Negotiated QoS Strength : Optional
Negotiated QoS Direction : SendRecv
Local QoS Status : Fail
 
Options-Ping ENABLED:NO ACTIVE:NO
Number of SIP User Agent Server(UAS) calls: 1

次に、OGW 上にオプションの QoS を設定し、終端ゲートウェイ(TGW)に必須の QoS を設定し、RSVP が正常終了したときに、RSVP 事前条件設定と動作を確認するための、発信側ゲートウェイ(OGW)での show sip - ua calls コマンドの出力例を示します。

Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of SIP User Agent Client(UAC) calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : 867EA226-D01311DC-8041CA97-F9A5F4F1@172.18.19.73
State of the call : STATE_ACTIVE (7)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 6001
Called Number : 1001
Bit Flags : 0x8C4401E 0x100 0x4
CC Call ID : 30
Source IP Address (Sig ): 172.18.19.72
Destn SIP Req Addr:Port : 172.18.19.73:5060
Destn SIP Resp Addr:Port: 172.18.19.73:25055
Destination Name : 172.18.19.73
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Mode : flow-through
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 30
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.19.72:17556
Media Dest IP Addr:Port : 172.18.19.73:17966
Orig Media Dest IP Addr:Port : 0.0.0.0:0
QoS ID : -2
Local QoS Strength : Optional
Negotiated QoS Strength : Mandatory
Negotiated QoS Direction : SendRecv
Local QoS Status : Success
 
Options-Ping ENABLED:NO ACTIVE:NO
Number of SIP User Agent Server(UAS) calls: 1

その他の参考資料

次の項では、SIP TDM ゲートウェイおよび Cisco Unified CME での SIP RSVP 事前条件に関連する参考資料を示します。

関連資料

関連項目
参照先

ISDN を使用したビデオ会議のチャネル集約

『H.320 Video - ISO/IEC-13871 Bonding』

マルチサービス アクセス ルータ上でデータ コールおよび音声コールの統合がサポートされる、ISDN PRI インターフェイスの設定

『Integrating Data and Voice Services for ISDN PRI Interfaces on Multiservice Access Routers』

H.324 SIP コールの通話中ビデオの拡大/拡大解除の設定

『Cisco Integrated 3G-324M Gateway』

RSVP の設定

Cisco IOS Quality of Service Solutions Configuration Guide 』の「Signalling」にある RSVP に関するサブセクションの「 Configuring RSVP

QoS ソリューション

『Cisco IOS Quality of Service Solutions Configuration Guide』

SIP 機能のロードマップ

『SIP Features Roadmap』

SIP の概要

『Overview of SIP』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト (http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

SIP RSVP 機能の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator により、どの Cisco IOS および Catalyst OS ソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 SIP RSVP 機能の機能情報

機能名
リリース
機能情報

RSVP アプリケーション ID サポート

12.2(33)SRB
12.4(6)T
12.4(22)T

Cisco IOS リリース 12.2(33)SRB(およびその後 Cisco IOS リリース 12.4(6)T と統合)に RSVP Application ID Support 機能が導入され、アプリケーション特有の予約がサポートされます。これによって、アプリケーション タイプのベースで QoS を管理できるよう、ローカル ポリシー一致基準の細かさが拡張されています。

RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified Communications Manager Express 機能に合わせるために、Cisco IOS リリース 12.4(22)T で RSVP Application ID Support 機能が変更されました。この機能の詳細情報は、次の項で説明します。

「SIP RSVP アプリケーション ID サポートの設定」

詳細については、『 Cisco IOS Quality of Service Solutions Configuration Guide 』の「Signalling」部にある RSVP に関するサブセクションの、「 Configuring RSVP 」章を参照してください。


ip qos defending-priority ip qos policy-locator
ip qos preemption-priority の各コマンドが追加または変更されました。

SIP-TDM ゲートウェイおよび Cisco Unified Communications Manager Express のオーディオ RSVP 事前条件

12.4(22)T

RSVP Preconditions for Audio on SIP-TDM Gateway 機能および Cisco Unified Communications Manager Express 機能を使用すると、SIP-TDM ゲートウェイおよび Cisco Unified CME 上の SIP コールの確立の事前条件として、SIP RSVP がイネーブルにされ、これによって、Cisco Unified CM および Cisco Unified CVP の両方の相互運用性がイネーブルになります。詳細情報は、次の項で説明します。

「SIP RSVP 事前条件の設定」

handle-replaces ip qos dscp show sip-ua calls
voice-class sip rsvp-fail-policy の各コマンドが追加または変更されました。

ビデオ ゲートウェイの RSVP 事前条件

12.4(24)T

RSVP Preconditions for Video Gateway 機能では、H.324-SIP ビデオ ゲートウェイ上の SIP ビデオ コールの既存サポートが拡張され、H.320-SIP ビデオ ゲートウェイが含められます。さらに、この機能では、H.320-SIP ビデオ ゲートウェイと H.324-SIP ビデオ ゲートウェイの両方で、SIP ビデオ コールの SIP ビデオ RSVP 事前条件のサポートが追加されています。詳細情報は、次の項で説明します。

「SIP RSVP 事前条件の設定」

voice-class sip calltype-video コマンドが導入されました。

用語集

CAC :Call Admission Control(コール アドミッション制御)。

CME :Communications Manager Express。

CVP :Customer Voice Portal。

GW :ゲートウェイ。

mline メディア ストリームに関する情報を制限する行。SDP セッションのメディア レベル セクションが、この行で開始および終了される。

MOH :Music On Hold(保留音)。

QoS :Quality Of Service(サービス品質)。

RSVP :Resource Reservation Protocol(リソース予約プロトコル)。

SDP :Session Description Protocol(セッション記述プロトコル)。

SIP :Session Initiation Protocol(セッション開始プロトコル)。

TDM :Time-Division Multiplexing(時分割多重)。

UA :User Agent(ユーザ エージェント)。