Cisco IOS SIP コンフィギュレーション ガイド
SIP ISDN 機能の設定
SIP ISDN 機能の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

SIP ISDN 機能の設定

この章の構成

SIP ISDN サポートの前提条件

SIP ISDN サポートの制限事項

SIP ISDN サポートについて

ISDN 発信者名表示

ISDN ネットワークの発信者番号

Remote-Party-ID ヘッダーが表示される ISDN と SIP のコール フロー

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信

SIP Carrier Identification Code(CIC)

プライバシー存在時の発信者番号の SIP の CLI

プライバシー向上のために削除可能な SIP の発信者番号

表示名使用不可時に表示名に置き換えられる SIP の発番号

ネットワーク指定またはユーザ指定として渡される SIP の発番号

SIP:ISDN の一時停止/再開のサポート

SIP コール保留処理

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送

GTD を使用した SIP ISUP の透過性の概要

SIP INFO メッセージの生成とシリアル化

GTD 形式での ISDN メッセージの転送

複数メッセージ ボディの SIP 生成

ISUP/SIP メッセージ マッピング

SIP ISDN サポート機能の設定方法

ISDN 発信者名表示の設定

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信の設定

SIP Carrier Identification Code(CIC)の設定

プライバシー存在時の発信者番号の SIP の CLI の設定

プライバシー存在時の発信者番号情報をグローバルにブロックする SIP の設定

プライバシー存在時に発信者番号情報をブロックするダイヤル ピア レベルの SIP の設定

表示名使用不可時に表示名に置き換えられる SIP の発番号のグローバルな設定

表示名使用不可時に表示名に置き換えられる発番号のダイヤル ピア レベル SIP の設定

ネットワーク指定として渡す発番号の SIP のパススルーのグローバルな設定

ネットワーク指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定

ユーザ指定として渡す発番号の SIP のパススルーのグローバルな設定

ユーザ指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定

SIP:ISDN の一時停止/再開のサポートの設定

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送の設定

SIP ISDN サポート機能の確認

トラブルシューティングのヒント

SIP ISDN サポート機能の設定例

ISDN 発信者名の例

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信例

SIP Carrier Identification Code(CIC)例

プライバシー存在時の発信者番号の SIP の CLI の例

SIP:ISDN の一時停止/再開のサポートの例

Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送の例

その他の参考資料

SIP ISDN 機能の設定

この章では、ISDN がサポートされる次の SIP 機能について説明します。

ISDN 発信者名表示

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信

SIP Carrier Identification Code(CIC)

プライバシー存在時の発信者番号の SIP の CLI

SIP:ISDN の一時停止/再開のサポート

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送

ISDN 発信者名表示機能の履歴

リリース
変更点

12.3(4)T

この機能が導入されました。

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信機能の履歴

リリース
変更点

12.3(7)T

この機能が導入されました。

SIP Carrier Identification Code(CIC)機能の履歴

リリース
変更点

12.2(11)T

この機能が導入されました。

プライバシー存在時の発信者番号の SIP の CLI 機能の履歴

リリース
変更点

12.4(4)T

この機能が導入されました。

SIP:ISDN の一時停止/再開のサポートの機能履歴

リリース
変更点

12.2(15)T

この機能が導入されました。

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送機能の履歴

リリース
変更点

12.3(1)

この機能が導入されました。

プラットフォーム、および Cisco IOS ソフトウェア イメージの各サポート情報を検索するには

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

SIP ISDN サポートの前提条件

ISDN 発信者名表示機能

使用している SIP ネットワークで Generic Transparency Descriptor(GTD)を設定します。


) GTD ボディを使用した ISDN 通信情報に対する SIP サポートの詳細については、「Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送」を参照してください。


使用している SIP ネットワークで Remote-Party-ID ヘッダーをイネーブルにします。Remote-Party-ID は、通常、デフォルトでイネーブルにされており、設定は不要です。コール セットアップ メッセージでは、Remote-Party-ID ヘッダーによって、ISDN スクリーニングとプレゼンテーションのインジケータの変換機能が提供されます。


) Remote-Party-ID ヘッダーの詳細については、「発信者 ID とプライバシーのための SIP 拡張」を参照してください。


この機能は、発信側ゲートウェイで始まる単方向環境で使用します。たとえば、フローは、ゲートウェイから電話機へ、またはゲートウェイからアプリケーション サーバへ、進む必要があります。

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信機能

SIP プロトコルを設定します。

プライバシー存在時の発信者番号の SIP の CLI

運用 IP ネットワークを確立します。

VoIP を設定します。

ゲートウェイで SIP の音声機能が設定されていることを確認。


) 音声機能の設定に関する詳細については、『Cisco IOS Voice Configuration Library』を参照してください。


SIP:ISDN の一時停止/再開のサポート機能

一時停止メッセージおよび再開メッセージがサポートされるよう、ゲートウェイ上に ISDN スイッチ タイプを設定します。

Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送

次のコンポーネントを含む、使用する VoIP ネットワークを設定します。

Cisco MGC ソフトウェア リリース 9.2(2) の Cisco PGW 2200 シグナリング コントローラ


) Cisco PGW 2200 SC は、以前、Cisco Media Gateway Controller(MGC; メディア ゲートウェイ コントローラ)および Cisco SC 2200 シグナリング コントローラとして知られていました。


Cisco PGW 2200 SC の Signaling System 7(SS7)が実行される、Cisco Signaling Link Terminal(Cisco SLT)

GTD 形式で SS7 ISUP メッセージの送信と処理が可能な Cisco IOS ゲートウェイ: Cisco IOS リリース 12.3(1)

音声ゲートウェイ用 Cisco SS7 Interconnect ソリューション

SIP ISDN サポートの制限事項

SIP Carrier Identification Code(CIC)機能

SIP では、SIP INVITE メッセージまたは 302 REDIRECT メッセージでのみ CIC パラメータを受け付けます。

SIP ゲートウェイでは、CIC パラメータは追加またはサポートされません。

ISDN SETUP メッセージの TNS IE は、SIP INVITE 要求の CIC パラメータにマッピングされません。発信 ISDN SETUP メッセージでのみ、CIC パラメータが TNS IE にマッピングされます。


) Cisco IOS リリース 12.3(2)XB での回避策は、この機能のリリースではサポートされません。回避策では、着番号に含めることによって、CIC パラメータが処理されました。着番号が含まれた、SIP INVITE メッセージの To ヘッダーの前には、101xxxx が付加されました。xxxx は、CIC パラメータです。次に、番号は、SETUP メッセージで ISDN に送信されました。ISDN で、たとえば 101032119193921234 という番号を受信した場合、

ISDN によって 101 が無視され、0321 が発信 SETUP メッセージの TNS IE にあったかのように、キャリア 0321 にコールがルーティングされました。着番号として書式化される残りの番号は、キャリアに転送されました。


CIC パラメータのサポートは、期限が切れた IETF draft-yu-tel-url-02.txt によって対処されます。SIP Carrier Identification Code 機能には、このドラフトに課題が記載されているすべての領域が含まれているわけではありません。

SIP:ISDN の一時停止/再開のサポート機能

SIP ISDN 一時停止/再開サポートは、ゲートウェイに接続されている ISDN PRI トランクでのみ使用可能です。

Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送

Redundant Link Manager(RLM; 冗長リンク マネージャ)は、Cisco Generic Transparency Descriptor 機能を使用した SIP PSTN 転送の要件です。この結果、RLM が使用されている、Cisco AS5300、Cisco AS5350、Cisco AS5400 の各プラットフォームのみがサポートされます。


) RLM に関する詳細は、Redundant Link Manager (RLM) を参照してください。


SIP-T では、SIP ネットワーク中に ISUP メッセージも透過的に送信されますが、この機能では、処理はサポートされていません。

SIP ISDN サポートについて

SIP ISDN サポート機能を設定するには、次の概念を理解する必要があります。

「ISDN 発信者名表示」

「音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信」

「SIP Carrier Identification Code(CIC)」

「プライバシー存在時の発信者番号の SIP の CLI」

「SIP:ISDN の一時停止/再開のサポート」

「Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送」

ISDN 発信者名表示

Cisco IOS リリース 12.2(15)ZJ よりも前のリリースでは、ISDN ネットワークから SIP ゲートウェイへのコールが着信したときに、ISDN Q.931 メッセージ(セットアップまたはファシリティのいずれか一方または両方)で表された発信者名は、VoIP クラウドを介して SIP エンドポイント(SIP IP 電話機)へエンドツーエンドは転送されませんでした。この機能では、Cisco IOS ゲートウェイ上の SIP シグナリングの機能が拡張され、SIP ヘッダーの発信者名と番号情報が、SIP 標準の推奨のとおりに更新されます。また、ISDN スクリーニングとプレゼンテーションのインジケータの完全な変換が含まれ、これによって、SIP カスタマーは、基本的な発信者番号権限を持つことができます。

ISDN ネットワークの発信者番号

ISDN ネットワークでは、発信者番号(発着信回線 ID の CLID または ICLID と呼ばれる)は、発信側情報をサブスクライバに供給するために、Central Office(CO; セントラル オフィス)によって提供されるアナログ サービスです。発信者番号を使用すると、発信側番号と名前が、電話機の表示などでデバイス上に表示されます。

ISDN メッセージによって、呼制御の信号が送信され、スクリーニングとプレゼンテーションのインジケータを指定する Information Element(IE; 情報要素)で構成されます。ISDN メッセージとその IE は、GTD 形式で渡されます。GTD 形式を使用すると、ネットワーク コンポーネント全体とアプリケーション全体に、標準形式でデータの信号送信の転送ができます。標準形式を使用すると、他のデバイスで、データのスキャンおよび解釈を行えます。SIP ネットワークでは、GTD 形式で発信者名が抽出され、発信者名情報が SIP カスタマーに送信されます。

Remote-Party-ID ヘッダーが表示される ISDN と SIP のコール フロー

図 1 に、発信者名を示す表示(またはファシリティ)IE が含まれる ISDN セットアップ メッセージを受信する SIP ゲートウェイを示します。メッセージの受信によって、コール確立が開始されます。

SIP ゲートウェイによって送信された Remote-Party-ID ヘッダーにより、発信側が特定され、プレゼンテーションとスクリーニングの情報が伝達されます。コール セッションの確立中に変更、追加、または削除できる Remote-Party-ID ヘッダーにより、コール参加者のプライバシー表示、スクリーニング、および検証が可能になります。

図 1 ISDN セットアップ メッセージの表示 IE またはファシリティ IE の発信者名

 

図 2 に、ISDN デバイスによって送信された元の ISDN セットアップ メッセージには、ファシリティ IE は含まれません。SIP ゲートウェイでは、発信者名が、後続の ISDN ファシリティ メッセージに配信されることを示す、ISDN セットアップ メッセージを受信します。次に、SIP ゲートウェイによって、Remote-Party-ID の表示名が pending に設定されます。INVITE の発信側 Remote-Party-ID の pending の存在によって、続いて表示名が表示されます。

後続メッセージに送信される発信者名の機能には、次のことが必要です。

ISDN スイッチ タイプには、最初の ISDN セットアップ メッセージ後の次のファシリティ メッセージに、続く名前を示す機能があります。

SIP ゲートウェイには、後続のファシリティ メッセージを SIP メッセージに変換する機能があります。SIP INFO メッセージは、ISDN デバイスから受信するファシリティの変換に使用されます。

図 2 ISDN ファシリティ メッセージのファシリティ IE の発信者名

 

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信機能を使用すると、コール管理アプリケーションでは、課金目的で音声ゲートウェイ コール中に使用される特定の ISDN ベアラ チャネルを指定できます。B チャネルの識別情報では、SIP ゲートウェイにより、音声録音およびコール転送などのポート特有の機能をイネーブルにできます。

Cisco IOS の 12.3(7)T よりも前のリリースでは、テレフォニー ポートに関するコール レッグ情報の保存に使用されるフィールドには、B チャネル情報は含まれません。B チャネル情報は、着信 ISDN コール レッグの説明に使用されます。音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信機能を使用すると、SIP ゲートウェイと H.323 ゲートウェイでは、着信 ISDN コールの B チャネル情報を受信します。取得された B チャネル情報は、コール転送またはコールのルーティング中に使用できます。

SIP ゲートウェイによって、 ds0-num コマンドが使用され、テレフォニー コール レッグの B チャネルの受信がイネーブルになります。H.323 ゲートウェイでは、異なるコマンドが使用されます。これによって、ユーザは、1 つのゲートウェイで 2 つのプロトコルを同時に実行できます。


) H.323 ゲートウェイでのこの機能の使用に関する詳細については、『Configuring H.323 Gateways』を参照してください。


SIP では、 ds0-num コマンドが設定されると、ISDN B チャネル情報が、発信 SIP 要求の Via ヘッダーで搬送されます。

SIP Carrier Identification Code(CIC)

SIP ゲートウェイでは、Carrier Identification Code(CIC)パラメータを送受信でき、これによって、多くの異なるネットワークで同様のアクセス サポートを行えます。CIC を使用すると、SIP ネットワークから ISDN への CIC パラメータの送信を行えます。

CIC パラメータがルーティング テーブルで使用され、コールが多くの異なるネットワークにルーティングされるときに、リモート ユーザの役割を果たすネットワークが特定されます。パラメータは、SIP INVITE 要求と 302 REDIRECT で搬送され、発信 ISDN SETUP メッセージで ISDN Transit Network Selection Information Element(TNS IE)にマッピングされます(図 3 を参照)。TNS IE によって、要求された転送ネットワークが特定され、カスタマーの選択に基づいて、異なるプロバイダーで、同様のアクセスがサポートされます。

図 3 受信側 SIP ゲートウェイと ISDN への CIC パラメータが使用された INVITE 要求のパス

 

CIC パラメータは、SIP URL でサポートされ、これによって、ユーザのアドレスが特定され、user@host のような E メール アドレスで表示されます。また、TEL URL の電話加入者の部分もサポートされます。この基本的な形式は tel:telephone subscriber number で、 tel によって、音声コールを発信するローカル エンティティが要求され、 telephone subscriber number は、コールを受信する番号です。

CIC パラメータは、3 桁または 4 桁のコードの場合があります。ただし、3 桁の場合、次の例のように、前にゼロが付きます。

cic=+1234 = TNS IE 0234.

プライバシー存在時の発信者番号の SIP の CLI

プライバシー存在時の発信者番号の SIP の CLI 機能は、次のような 3 つの主なコンポーネントで構成されます。

「プライバシー向上のために削除可能な SIP の発信者番号」

「表示名使用不可時に表示名に置き換えられる SIP の発番号」

「ネットワーク指定またはユーザ指定として渡される SIP の発番号」

プライバシー向上のために削除可能な SIP の発信者番号

発信者番号は、ISDN セットアップ メッセージの発信側情報要素(IE)を、SIP Remote-Party-ID ヘッダーと From ヘッダーの発信側フィールドに、コピーすることによって、ISDN から SIP に渡されます。

ISDN 表示 IE からの発信者名が、SIP Remote-Party-ID ヘッダーと From ヘッダーの SIP Display Name フィールドにコピーされます。発番号 IE には、許可されるプレゼンテーション、制限されるプレゼンテーション、相互動作中のため使用可能な番号、予約番号などの、表示インジケータ フィールドが含まれています。許可されるプレゼンテーションと制限されるプレゼンテーションでは、SIP Remote-Party-ID ヘッダー フィールドで、それぞれ、プライバシー セットがオフとヌルに設定されます。

ただし、追加されるプライバシーについては、プライバシー存在時の発信者番号の SIP の CLI 機能では、プレゼンテーションが禁止されている場合に、発信メッセージの From ヘッダーから発番号と表示名が完全に削除されます。Cisco ゲートウェイでは、表示名と発番号の両方がない場合に、SIP Remote-Party ID ヘッダーが送信されないため、これによって、SIP リモート パーティ ID の送信が禁止されます。


「プライバシー向上のために削除可能な SIP の発信者番号」 オプションは、グローバルとダイヤル ピア レベルの両方で、使用できます。


コール フローについては図 4 を、また、追加のプレゼンテーション マッピングについては 表 1 および 表 2 を、参照してください。

図 4 プライバシー存在時に発信者番号情報をブロックするコール フロー

 

表 1 CLI がディセーブルの場合のプレゼンテーションからプライバシーへのマッピング

プレゼンテーション インジケータ
発信元 Remote Party ID(RPID)

プレゼンテーションを許可

From: "User1" <sip:19195550100@10.0.0.0>;tag=1

Remote-Party-ID: "User1" <sip:19195550100@10.0.0.0>;party=calling;privacy=off

プレゼンテーションを禁止

From: "User1" <sip:19195550100@10.0.0.0>;tag=1

Remote-Party-ID: "User1"<sip:19195550100@10.0.0.0>;party=calling;privacy=full

表 2 CLI がイネーブルの場合のプレゼンテーションからプライバシーへのマッピング

プレゼンテーション インジケータ
発信元 RPID

プレゼンテーションを許可

From: "User1" <sip:19195550100@10.0.0.0>;tag=1

Remote-Party-ID: "User1"<sip:19195550100@10.0.0.0>;party=calling;privacy=off

プレゼンテーションを禁止

From: <sip:10.0.0.0>;tag=1

Remote Party ID not sent

表示名使用不可時に表示名に置き換えられる SIP の発番号

PSTN/SIP コールの表示情報要素(IE)は、セットアップ メッセージでは使用できず、Cisco ゲートウェイでは、SIP Remote-Party-ID ヘッダーと From ヘッダーの Display Name フィールドがブランクのままになります。

プレゼンテーションが許可される場合、プライバシー存在時の発信者番号の SIP の CLI 機能を使用すると、SIP Remote-Party-ID ヘッダーと From ヘッダーで欠落している表示名に置き換えられる発番号がイネーブルになります。使用する名前が示されている セットアップ メッセージを受信すると、発番号は表示名にはコピーされません。

また、SIP ゲートウェイでの発信者番号とプライバシーの SIP 拡張機能設定によって、SIP Remote-Party-ID ヘッダーと From ヘッダーに発信者名と番号をハードコードできる機能が追加されました。SIP ゲートウェイでの発信者番号とプライバシーの SIP 拡張機能設定は、プライバシー存在時の発信者番号の SIP の CLI 設定に優先します。


「表示名使用不可時に表示名に置き換えられる SIP の発番号」 オプションは、グローバルとダイヤル ピア レベルの両方で、使用できます。


発番号が表示名に置き換えられるコール フローについては、図 5 を参照してください。

図 5 表示名使用不可時に表示名が発番号に置き換えられるコール フロー

 

ネットワーク指定またはユーザ指定として渡される SIP の発番号

ISDN 番号は、ISDN 発信側情報要素(IE)スクリーニング インジケータ フィールドで、ネットワーク指定またはユーザ指定として渡すことができます。SIP/ISDN のコールでは、Cisco ゲートウェイによって、スクリーニング インジケータが、自動的にスクリーニング インジケータに設定されます。

プライバシー存在時の発信者番号の SIP の CLI 機能では、スクリーニング インジケータのユーザ指定とネットワーク指定の ISDN 番号を切り替えることができます。したがって、ビット 1 と 2 が、ネットワーク指定を反映するよう設定された後、既存のすべてのスクリーニング情報が失われます。ただし、ビット 6 と 7 のプレゼンテーション情報は予約されています。


「発番号をネットワーク指定として渡すコール フロー」 オプションは、グローバルとダイヤル ピア レベルの両方で、使用できます。


発番号がネットワーク指定とともに渡されるときのコール フローについては、図 6 を参照してください。

図 6 発番号をネットワーク指定として渡すコール フロー

 

SIP:ISDN の一時停止/再開のサポート

一時停止と再開は、ISDN および ISDN User Part(ISUP; ISDN ユーザ パート)のシグナリング手順の基本で、現在は、SIP 機能の一部です。再開は、ITU Q.764 で、コールを解放しない通信の一時的な中止を示すメッセージとして説明されています。一時停止メッセージは、通信中に受け付けることができます。再開メッセージは、一時停止メッセージの後に受信され、ITU Q.764 で、通信再開の要求を示すメッセージとして説明されています。発信側がコールの開放を要求した場合、一時停止と再開のシーケンスが上書きされます。

SIP コール保留処理

SIP 発信側ゲートウェイでは、ISDN 一時停止メッセージを受信します。発信側ゲートウェイによって、メディアが一時的に停止された、つまり、コールが保留されていたことが、終端ゲートウェイに通知されます。SIP ゲートウェイがコール保留の通知を受信する方法には、2 つあります。1 つ目の方法は、発信側ゲートウェイによって、 Session Description Protocol( SDP)で、IP アドレス 0.0.0.0(c=0.0.0.0)の接続を使用することです。SDP の情報が、re-Invite で終端ゲートウェイに送信されます。2 つ目の方法は、発信側ゲートウェイによって、re-Invite の SDP で、a=sendonly を使用することです。


) Cisco IOS リリース 12.3(8)T よりも前には、SIP ゲートウェイで、c=0.0.0.0 を使用することによって、コールの保留を開始できました。Cisco IOS リリース 12.3(8)T では、ゲートウェイで、c=0.0.0.0 または a=sendonly を使用することによって、コールの保留を開始できます。


行 c=0.0.0.0 の目的は、メディア パケットの送信停止を終端ゲートウェイに通知することです。保留が取り消されると、通信の再開のため、ISDN 再開メッセージが送信されます。SIP 発信側ゲートウェイでは、(0.0.0.0 ではなく)c= line でリモート SIP エンティティの実際の IP アドレスを使用して re-Invite を送信することによって、保留がとりやめられます。

re-Invite メッセージの SDP にある複数メディア フィールド(m-lines)は、各 m-line 行が 1 つのメディアの宛先を表すメディア フォーキングを示すために使用されます。SIP ゲートウェイによって、複数の m-line や c-line の複数のメディア ストリームがネゴシエートされます。発信側ゲートウェイでは、複数のメディア ストリームとネゴシエートされる 1 つのゲートウェイで ISDN の一時停止を受信すると、すべてのメディア ストリームが保留中になります。発信側ゲートウェイによって、すべてのストリームで IP アドレスを 0.0.0.0 でアドバタイズする c= line がある、re-Invite が送信されます。発信側ゲートウェイによって、どのメディアも終端ゲートウェイに送信されないよう、各メディア ストリームの SIP コールも音が消されます。発信側ゲートウェイで ISDN 再開を受信すると、元の SDP を使用した re-Invite が開始され、コールの保留がとりやめられます。

メディア非アクティビティ タイマーがネットワーク上に設定されている場合、すべてのアクティブ ストリームでタイマーが停止されます。メディア非アクティビティ タイマーの目的は、設定可能な時間範囲内に受信した Real-Time Control Protocol(RTCP)パケットがない場合に、コールが監視され、接続が解除されます。ただし、コール保留の開始時に、発信側ゲートウェイによって、特定コールに対するメディア非アクティビティ タイマーがディセーブルにされ、コールがアクティブのままになります。終端ゲートウェイは、発信側ゲートウェイから call-hold re-Invite を受信したときに、同様に動作します。コールが再開したときに、発信側ゲートウェイによって、メディア非アクティビティ タイマーが再度イネーブルにされます。


) タイマーの詳細については、「SIP メディア非アクティビティ タイマー」を参照してください。


すべての課金とアカウンティングの手順は、SIP の ISDN の一時停止/再開のサポート機能による提供は受けません。

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送

ここでは、次の内容について説明します。

「GTD を使用した SIP ISUP の透過性の概要」

「SIP INFO メッセージの生成とシリアル化」

「GTD 形式での ISDN メッセージの転送」

「複数メッセージ ボディの SIP 生成」

「ISUP/SIP メッセージ マッピング」

Cisco Generic Transparency Descriptor 機能を使用した SIP PSTN 転送によって、Generic Transparency Descriptor(GTD)を使用した ISDN User Part(ISUP)に対する SIP サポートが追加されます。発信側ゲートウェイ(OGW)で受信した ISUP データは、共通のテキスト形式で保存され、終端ゲートウェイ(TGW)に渡されます。

この機能の利点は次のとおりです。

ISUP データは、ネットワークの入力側での ISDN または ISUP のバリアントは一切考慮されず、ネットワークの出力側でプロトコルに基づいて再構築されます。

ISDN または ISUP の情報をテキスト形式で提供することによって、情報が、コア SIP ネットワーク内部のアプリケーションによっても使用できます。このようなアプリケーションの一例は、特定の ISDN 情報または ISUP 情報を使用してルーティングを決定できるルート サーバです。

GTP にカプセル化されている ISUP の転送では、H.323 プロトコルとの互換性が維持されます。

GTD を使用した SIP ISUP の透過性の概要

Cisco Generic Transparency Descriptor 機能を使用した SIP PSTN 転送によって、GTD を使用した ISUP 転送に対する SIP サポートが追加されます。つまり、OGW が受信した ISUP データは、共通の ASCII 形式で TGW に保存され、示されます。

GTD オブジェクトは、ISUP メッセージ、パラメータ、および R2 信号を表すために使用できます。これらの GTD オブジェクトは、SIP、エンドツーエンド転送の促進などの、既存のシグナリング プロトコルにカプセル化されます。GTD ASCII 形式でカプセル化された ISUP の転送は、H.323 にすでに存在します。Cisco Generic Transparency Descriptor を使用した SIP PSTN によって、機能のパリティが提供されます。Cisco IOS ソフトウェアでのシグナリング データの転送メカニズムとして GTD の使用によって、ネットワークのさまざまなコンポーネント間でシグナリング データを共有し、さまざまなシグナリング プロトコルが相互動作するため、共通の形式が提供されます。

VoIP ネットワークで ISUP の透過性を得るには、ゲートウェイでは、Cisco SC ノードと外部的にインターフェイスする必要があります。Cisco SC ノードは、ハードウェアの組み合わせ(Cisco PGW 2200 および Cisco SLT)で、シグナリング コントローラ機能が提供されるシグナリング コントローラ ソフトウェアです。Cisco SC ノードによって、SC ホストと SS7 シグナリング ネットワークとの間のシグナリング トラフィックが転送されます。Cisco SC ノードから Cisco OGW に着信する ISUP GTD メッセージに含まれる ISDN メッセージの処理の簡単な例について説明し、図 7 に示します。

図 7 ISUP の透過性の実装

 

図 7 のプロセスは次のとおりです。

1. Cisco SC ノード 1 では、Public Switched Telephone Network(PSTN; 公衆電話交換網)からの ISUP メッセージを受信します。このノードは、ISUP メッセージを GTD 形式にマッピングし、この GTD ボディを、OGW に送信される ISDN メッセージ内でカプセル化する役割を果たすようになりました。

2. OGW 上の SIP ユーザ エージェントは、Q931 メッセージから GTD ボディが抽出され、対応する SIP メッセージにマルチパート MIME アタッチメントとしてカプセル化されます。


) ISUP から SIP へのマッピングの詳細については、表 3 を参照してください。


3. SIP メッセージは、OGW によって、SIP ネットワークを介して TGW に送信されます。

4. TGW によって、SC ノード 2 に送信される発信 ISDN メッセージで GTD がカプセル化されます。次に、SC によって、PSTN に渡す前に、GTD が ISUP に再マッピングされます。

SIP INFO メッセージの生成とシリアル化

Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送では、コールのすべてのフェーズで、SIP INFO メッセージのクライアントとサーバのサポートが追加されます。INFO メッセージは、GTD 形式にカプセル化された ISUP メッセージの搬送に使用されますが、SIP 応答または要求への特定のマッピングはありません。これらの ISUP メッセージは、コールのどのフェーズでも受信できます。


) 特定のマッピング メッセージについては、「ISUP/SIP メッセージ マッピング」を参照してください。


ゲートウェイでは、重複する SIP INFO メッセージの送信はサポートされません。たとえば、1 つめの INFO メッセージが未解決の間、別の INFO メッセージは送信できません。SIP INFO メッセージにマッピングされる複数の PSTN メッセージは、シリアルに送信されます。

GTD 形式での ISDN メッセージの転送

GTD 形式の ISDN メッセージのサポートは、ISDN セットアップ メッセージに限定されます。次のパラメータのみがエンコードおよびデコードされます。

発信元回線情報

ベアラ機能

発番号

着番号

リダイレクト番号

ISDN の GTD パラメータへのマッピングは、デフォルトで、イネーブルになる一方で、ISUP メッセージが SIP シグナリングを介して転送されるよう、ゲートウェイを設定する必要があります。

ISDN パラメータは、GTD ヘッダーまたは SIP ヘッダーを使用して転送できます。Cisco Generic Transparency Descriptor 機能を使用した SIP PSTN 転送の前には、SIP ヘッダーのみによって、ISDN パラメータが提供されます。たとえば、SIP From ヘッダーのユーザ部分では、ISDN 発信側情報要素を搬送できます。

ヘッダーは、PSTN から取得される情報を使用して OGW に構築されるため、SIP ヘッダーには、通常、GTD によって提供される情報と同じ情報が含まれます。ただし、データに矛盾がある可能性がある状況があります。ヘッダーが、中間プロキシまたはアプリケーション サーバによって更新された場合、非整合データが発生します。矛盾がある場合、SIP ヘッダーには、通常、ほとんど最新の情報が含まれているため、SIP ヘッダーを使用して、TGW 上に ISDN パラメータを構築できます。

複数メッセージ ボディの SIP 生成

この機能よりも前には、SIP ゲートウェイでは、SDP のみがメッセージ ボディ タイプとして処理されました。Cisco Generic Transparency Descriptor を使用した SIP PSTN 転送の場合、ゲートウェイでは、SDP と GTD の両方のメッセージ ボディ タイプが含まれるメッセージを生成し、適切に書式化することができます。

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)転送が使用される場合、SDP と GTD の両方のボディが含まれるすべての SIP メッセージは、リンク レベル フラグメンテーションに必要な十分の大きさがあり、これによって、過度の再送信が発生する可能性があります。フラグメンテーションによってパフォーマンスの問題が発生する場合、TCP 転送を使用できます。

ISUP/SIP メッセージ マッピング

Cisco Generic Transparency Descriptor を使用した SIP PSTN 転送では、特定の ISUP メッセージの同等の SIP メッセージへのマップが試行されます。このマッピングは、 表 3 で定義されます。

 

表 3 補足 ISUP メッセージから SIP メッセージへのマッピング

ISUP メッセージ タイプ
ISDN(NI2C)メッセージ タイプ
SIP メッセージ タイプ

ACM

アラート

180/183 経過表示メッセージ

ANM

接続

INVITE 要求への 200 OK

CON

接続

INVITE 要求への 200 OK

CPG

経過表示

180/183 経過表示メッセージ

IAM

セットアップ

INVITE 要求

REL

接続解除

BYE/CANCEL/4xx/5xx/6xx

RES

再開

INVITE 要求

SUS

一時停止

INVITE


) SC ノードによって ISDN メッセージ内で GTD 形式にマッピングされる他の多くの PSTN メッセージまたは SS7 メッセージがあります。マッピングが表 3 のリストにない場合、メッセージは SIP INFO 方式で扱われます。


SIP ISDN サポート機能の設定方法

ここでは、次の各手順について説明します。

「ISDN 発信者名表示の設定」

「音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信の設定」

「SIP Carrier Identification Code(CIC)の設定」

「プライバシー存在時の発信者番号の SIP の CLI の設定」

「SIP:ISDN の一時停止/再開のサポートの設定」

「Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送の設定」

「SIP ISDN サポート機能の確認」

「トラブルシューティングのヒント」


) • 各手順を実行する前に、次の情報を理解してください。

「SIP ISDN サポートの前提条件」

「SIP ISDN サポートの制限事項」

手順に役立つ情報については、上記のトラブルシューティングのセクションを参照してください。


 

ISDN 発信者名表示の設定

SIP IP 電話機で、ISDN ネットワーク上で発信されたコールの発信者名 ID の表示をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. signaling forward

5. exit

6. interface serial

7. isdn supp-service name calling

8. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> Enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス コンフィギュレーション モードを開始します。

ステップ 4

signaling forward { none | unconditional }

 

Router(conf-voi-serv)# signaling forward unconditional

発信側ゲートウェイ(OGW)によって、終端ゲートウェイ(TGW)に、シグナリング ペイロードが転送されるかどうかを指定します。キーワードは次のとおりです。

none :ゲートウェイが、TGW に、シグナリング ペイロードを渡さないようにします。

unconditional :接続されている外部ルート サーバによって、GTD ペイロードが変更された場合でも、OGW で受信したシグナリング ペイロードが TGW に転送されます。

ステップ 5

exit

 

Router(conf-voi-serv)# exit

現在のモードを終了します。

ステップ 6

interface serial slot / port : timeslot

 

Router(config)# interface serial 1/0:23

チャネル化 E1 コントローラまたはチャネル化 T1 コントローラで作成されたシリアル インターフェイスを指定します。ユーザは、明示的にシリアル インターフェイスを指定する必要があります。引数は次のとおりです。

slot / port :チャネル化 E1 コントローラまたはチャネル化 T1 コントローラがあるスロットおよびポート。スラッシュ記号が必要です。

: time-slot :ISDN では、D チャネル タイム スロットで、チャネル化 T1 では 23 チャネル、チャネル化 E1 では 15 チャネルです。コロン記号が必要です。

ステップ 7

isdn supp-service name calling

 

Router(config-if)# isdn supp-service name calling

ISDN シリアル インターフェイスに送信される発信者名表示のパラメータを設定します。

ステップ 8

exit

 

Router(config-if)# exit

現在のモードを終了します。

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信の設定

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信機能を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. sip

5. ds0-num

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> Enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

VoIP 音声サービス コンフィギュレーション モードを開始します。

ステップ 4

sip

 

Router(conf-voi-serv)# sip

SIP コンフィギュレーション モードを開始します。

ステップ 5

ds0-num

 

Router(conf-serv-sip)# ds0-num

B チャネル情報を発信 SIP メッセージに追加します。

ステップ 6

exit

 

Router(conf-serv-sip)# exit

現在のモードを終了します。

SIP Carrier Identification Code(CIC)の設定

手順の概要

1. debug ccsip messages

2. debug isdn q931

手順の詳細


ステップ 1 debug ccsip messages

このコマンドを使用して、すべての SIP SPI メッセージ トレースを表示します。これを終端ゲートウェイで使用し、着信 CIC パラメータを確認します。

例:

ここでは、SIP URL が使用され、CIC パラメータが含まれる、INVITE 要求の出力が示されます。

Router# debug ccsip messages
 
00:03:01: Received:
INVITE sip:5550101;cic=+16789@172.18.202.60:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.202.62:5060
From: <sip:4440001@172.18.202.62>;tag=24176150-1A11
To: <sip:5550101@172.18.202.60;user=phone>
Date: Mon, 08 Mar 1993 00:11:51 GMT
Call-ID: 590F6480-1A7011CC-80B5CC57-1D726644@172.18.202.62
Supported: 100rel
Cisco-Guid: 1494180992-443552204-2159266903-494036548
User-Agent: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Max-Forwards: 6
Timestamp: 731549511
Contact: <sip:4440001@172.18.202.62:5060;user=phone>
Expires: 180
Allow-Events: telephone-event, x-com-cisco-telephone-event, x-com-cisco-fail-telephone-event
Content-Type: application/sdp
Content-Length: 160
 

ここでは、TEL URL が使用され、CIC パラメータが含まれる、INVITE 要求の出力が示されます。

Router# debug ccsip messages
 
00:01:00: Received:
INVITE tel:+5550101;cic=+16789 SIP/2.0
Via: SIP/2.0/UDP 172.18.202.62:5060
From: <sip:4440001@172.18.202.62>;tag=24158B04-1D45
To: <sip:5550101@172.18.202.60;user=phone>
Date: Mon, 08 Mar 1993 00:09:51 GMT
Call-ID: 114C6D4C-1A7011CC-80B0CC57-1D726644@172.18.202.62
Supported: 100rel
Cisco-Guid: 290221388-443552204-2158939223-494036548
User-Agent: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Max-Forwards: 6
Timestamp: 731549391
Contact: <sip:4440001@172.18.202.62:5060;user=phone>
Expires: 180
Allow-Events: telephone-event, x-com-cisco-telephone-event, x-com-cisco-fail-telephone-event
Content-Type: application/sdp
Content-Length: 160
 

ステップ 2 debug isdn q931

このコマンドを使用して、ローカル ルータ(ユーザ側)とネットワークの間の ISDN ネットワーク接続(レイヤ 3)のコールのセットアップおよびティアダウンに関する情報を表示します。これを使用して、CIC パラメータと TNS IE の内容を確認します。

例:

ここでは、TNS IE が含まれる発信コール セットアップの出力を示します。出力は、SIP または TEL URL のいずれでも同じです。

Router# debug isdn q931
 
00:01:00: ISDN Se2/0:23: TX -> SETUP pd = 8 callref = 0x0001
00:01:00: Bearer Capability i = 0x8090A2
00:01:00: Channel ID i = 0xA98397
00:01:00: Calling Party Number i = 0x0081, '4440001', Plan:Unknown, Type:Unknown
00:01:00: Called Party Number i = 0xA8, '5550101', Plan:National, Type:National
00:01:00: Transit Net Select i = 0xA1, '6789'
 


 

プライバシー存在時の発信者番号の SIP の CLI の設定

ここでは、次の各手順について説明します。

「プライバシー存在時の発信者番号情報をグローバルにブロックする SIP の設定」(任意)

「プライバシー存在時に発信者番号情報をブロックするダイヤル ピア レベルの SIP の設定」(任意)

「表示名使用不可時に表示名に置き換えられる SIP の発番号のグローバルな設定」(任意)

「表示名使用不可時に表示名に置き換えられる発番号のダイヤル ピア レベル SIP の設定」(任意)

「ネットワーク指定として渡す発番号の SIP のパススルーのグローバルな設定」(任意)

「ネットワーク指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定」(任意)

「ユーザ指定として渡す発番号の SIP のパススルーのグローバルな設定」(任意)

「ユーザ指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定」(任意)

プライバシー存在時の発信者番号情報をグローバルにブロックする SIP の設定

Call-ID 情報は、プライベート情報です。ISDN には、この情報を保護するために設定できるプライベート設定があります。ただし、SIP で Call-ID 情報が取得されるたびに、プライベート情報が非表示にされるわけではありません。プライベートであり、Call-ID 表示で表示されないことが反映されるよう、フィールドが設定されます。しかし、データは、依然、SIP メッセージ要求で表示可能です。このオプションを使用すると、Cisco ゲートウェイでは、SIP メッセージから Call-ID 情報が削除され、ネットワーク上で読み取りができないようになります。

発信側情報要素が使用された ISDN セットアップ メッセージの受信時に、Cisco ゲートウェイでは、プレゼンテーション インジケータが変換され、制限されたプレゼンテーションのプライバシーがフルに設定されるか、または、Remote-Party-ID ヘッダー フィールドで非制限プレゼンテーションのプライバシーがオフに設定されます。プライバシー存在時の発信者番号の SIP の CLI 機能によって、SIP メッセージ要求の From フィールドおよび Remote-Party-ID フィールドからの発信者番号および表示名のストリップが許可されるか、または情報が渡されます。ただし、非制限プレゼンテーションの場合、CLI 設定に関係なく、ゲートウェイによって、発信者番号が渡されます。

Remote-Party-ID ヘッダーおよび From ヘッダーからの発信者名および発番号をストリップするグローバル コマンドは、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. clid strip pi-restrict all

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

clid strip pi-restrict all

 

Router(config-voip-serv)# clid strip pi-restrict all

プライバシーがグローバル コンフィギュレーション モードに存在するときに、コール ID 情報のブロックを開始します。

ステップ 5

exit

 

Router(config-voip-serv)# exit

現在のモードを終了します。

プライバシー存在時に発信者番号情報をブロックするダイヤル ピア レベルの SIP の設定

Remote-Party-ID ヘッダーおよび From ヘッダーからの発信者名および発番号をストリップするダイヤル ピア特有のコマンドは、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice dial-peer-number voip

4. clid strip pi-restrict all

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice dial-peer-number voip

 

Router(config)# dial-peer voice 100 voip

ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

clid strip pi-restrict all

 

Router(config-dial-peer)# clid strip pi-restrict all

プライバシーが dial-peer コンフィギュレーション モードに存在するときに、コール ID 情報のブロックを開始します。

ステップ 5

exit

 

Router# exit

現在のモードを終了します。

表示名使用不可時に表示名に置き換えられる SIP の発番号のグローバルな設定

これがイネーブルのときに、Display Name フィールドがあるが、番号がない場合、番号が Display Name フィールドにコピーされ、番号が受信者のコール ID 表示に表示されます。

受信する表示情報がない場合、Cisco ゲートウェイでは、Display Name フィールドが省略されます。この機能では、プレゼンテーションが禁止されていない限り、発番号を Display Name フィールドにコピーできる CLI スイッチが導入されています。

Remote-Party-ID ヘッダーと From ヘッダーで使用できない表示名を発番号に置き換える手順は、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. clid substitute name

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

clid substitute name

 

Router(config-voip-serv)# clid substitute name

表示名がグローバル コンフィギュレーション モードで使用できないときに、表示名を発番号に置き換えます。

ステップ 5

exit

 

Router(config-voip-serv)# exit

現在のモードを終了します。

表示名使用不可時に表示名に置き換えられる発番号のダイヤル ピア レベル SIP の設定

Remote-Party-ID ヘッダーと From ヘッダーで使用できない表示名を発番号に置き換える、ダイヤル ピア特有の手順は、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice dial-peer-number voip

4. clid substitute name

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice dial-peer-number voip

 

Router(config-dial-peer)# dial-peer voice 100 voip

ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

clid substitute name

 

Router(config-dial-peer)# clid substitute name

表示名がダイヤル ピア コンフィギュレーション モードで使用できないときに、表示名を発番号に置き換えます。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

ネットワーク指定として渡す発番号の SIP のパススルーのグローバルな設定

このフィールドでは、コール ID 情報がネットワークによって提供されるかどうかが示されます。これは、スクリーニング目的です。

セッション開始側プロトコルから公衆電話交換網(SIP-to-PSTN)への発番号は、以前、常にユーザ指定に変換されました。この機能では、ユーザ指定またはネットワーク指定のブランド番号間を切り替える CLI スイッチが導入されます。

スクリーニング インジケータをグローバルにネットワーク指定に設定する手順は、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. clid network-provided

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

clid network-provided

 

Router(config-voip-serv)# clid network-provided

音声サービス VoIP コンフィギュレーション モードでネットワーク指定の発番号を入力します。

ステップ 5

exit

 

Router(config-voip-serv)# exit

現在のモードを終了します。

ネットワーク指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定

スクリーニング インジケータをネットワーク指定に設定するダイヤル ピア特有のコマンドは、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice dial-peer-number voip

4. clid network-provided

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice dial-peer-number voip

 

Router(config)# dial-peer voice 100 voip

ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

clid network-provided

 

Router(config-dial-peer)# clid network-provided

ダイヤル ピア コンフィギュレーション モードでネットワーク指定の発番号を入力します。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

ユーザ指定として渡す発番号の SIP のパススルーのグローバルな設定

スクリーニング インジケータをグローバルにユーザ指定に設定する手順は、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. no clid network-provided

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

no clid network-provided

 

Router(config-voip-serv)# no clid network-provided

音声サービス VoIP コンフィギュレーション モードでネットワーク指定の発番号を入力します。

ステップ 5

exit

 

Router(config-voip-serv)# exit

現在のモードを終了します。

ユーザ指定として渡す発番号の SIP のパススルーのダイヤル ピア レベルでの設定

スクリーニング インジケータをユーザ指定に設定するダイヤル ピア特有のコマンドは、次のとおりです。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice dial-peer-number voip

4. no clid network-provided

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice dial-peer-number voip

 

Router(config)# dial-peer voice 100 voip

ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

no clid network-provided

 

Router(config-dial-peer)# no clid network-provided

ダイヤル ピア コンフィギュレーション モードでユーザ指定の発番号を入力します。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

SIP:ISDN の一時停止/再開のサポートの設定

一時停止/再開機能は、デフォルトでイネーブルにされます。ただし、この機能は設定も可能です。VoIP ネットワークのすべてのダイヤル ピアで一時停止と再開を設定するには、発信側ゲートウェイと終端ゲートウェイの両方で次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. sip-ua

4. suspend-resume

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> Enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

sip-ua

 

Router(config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 4

suspend-resume

 

Router(config-sip-ua)# suspend-resume

一時停止と再開のサポートをイネーブルにします。

ステップ 5

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

Cisco Generic Transparency Descriptor(GTD)を使用した SIP PSTN 転送の設定

VoIP ネットワーク上のすべてのダイヤル ピアまたは個々のダイヤル ピアのいずれかのゲートウェイに GTD ペイロードを転送するには、次の手順を実行します。

前提条件

シスコ ゲートウェイ上の Cisco PGW 2200 シグナリング コントローラで signaling forward コマンドを使用する前に、SS7 ISUP メッセージを GTD 形式にカプセル化するよう、Cisco PGW2200 を設定します。

手順の概要

1. enable

2. configure terminal

3. voice service voip または signaling forward

4. signaling forward

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> Enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

 

 

または

dial-peer voice tag { pots | voip | mmoip | vofr | voatm }

 

Router(config)# dial-peer voice 100 voip

次のコンフィギュレーション モードの 1 つを開始します。

VoIP ネットワーク上のすべてのダイヤル ピアの音声サービス コンフィギュレーション モード

個々のダイヤル ピアのダイヤル ピア音声コンフィギュレーション モード

ステップ 4

signaling forward { none | unconditional }

 

Router(conf-voi-serv)# signaling forward unconditional

OGW によってシグナリング ペイロードが TGW に送信されるかどうかを指定します。キーワードは次のとおりです。

none :ゲートウェイが、TGW に、シグナリング ペイロードを渡さないようにします。

unconditional :接続されている外部ルート サーバによって変更された場合でも、OGW で受信したシグナリング ペイロードが TGW に転送されます。

を指定したかのように処理されます。

ステップ 5

exit

 

Router(conf-voi-serv)# exit

現在のモードを終了します。

SIP ISDN サポート機能の確認

SIP ISDN サポート機能の設定を確認するには、必要に応じて次の手順を実行します(コマンドは、アルファベット順に示しています)。

手順の概要

1. show dial-peer voice

2. show running-config

3. show sip-ua status

手順の詳細


ステップ 1 show running-config

このコマンドを使用して、設定を表示し、正しいダイヤル ピアが変更されたことを確認します。

ステップ 2 show dial-peer voice

設定されている各ダイヤル ピアに対して、このコマンドを使用し、ダイヤル ピア設定が正しいことを確認します。

ステップ 3 show sip-ua status

このコマンドを使用して、一時停止と再開のサポートがイネーブルかディセーブルかを表示します。

次に、一時停止と再開のサポートがイネーブルであることを示す出力例を示します。

Router# show sip-ua status
 
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP max-forwards : 6
SIP DNS SRV version: 1 (rfc 2052)
SDP application configuration:
Version line (v=) required
Owner line (o=) required
Session name line (s=) required
Timespec line (t=) required
Media supported: audio image
Network types supported: IN
Address types supported: IP4
Transport types supported: RTP/AVP udptl
SIP support for ISDN SUSPEND/RESUME: ENABLED
 


 

トラブルシューティングのヒント


) 一般的なトラブルシューティングのヒント、および重要な debug コマンドについては、「一般的なトラブルシューティングのヒント」を参照してください。


音声コールを行うことができることを確認します。

次の例に示したように、 debug ccsip messages コマンドを使用します。

SIP User-Agent Client(UAC)とアクセス サーバとの間でやり取りされるメッセージなどの、SIP メッセージで、トレースをイネーブルにするには、 debug ccsip messages コマンドを使用します。

debug isdn q931 コマンドを使用して、ローカル ルータ(ユーザ側)とネットワークの間の ISDN ネットワーク接続(レイヤ 3)のコールのセットアップおよびティアダウンに関する情報を表示します。

これらのコマンドの一部について、次に出力例を示します。

「debug ccsip messages コマンドの出力例」

debug ccsip messages コマンドの出力例

次に、拡張パラメータ「x-ds0num」として Via ヘッダーに追加された B チャネル情報での、INVITE 要求の例を示します。B チャネル課金情報の形式は、0 が D チャネル ID、0 が T1 コントローラ、および 1 が B チャネルです。

Router# debug ccsip messages
 
INVITE sip:3100802@172.18.193.99:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.100:5060;x-ds0num=”ISDN 0:D 0:DS1 1:DS0”
From: <sip:3100801@172.18.193.100>;tag=21AC4-594
To: <sip:3100802@172.18.193.99>
Date: Thu, 28 Dec 2000 16:15:28 GMT
Call-ID: 7876AC6C-DC1311D4-8005DBCA-A25DA994@172.18.193.100
Supported: 100rel
Cisco-Guid: 1981523172-3692237268-2147670986-2724047252
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO
CSeq: 101 INVITE
Max-Forwards: 6
Remote-Party-ID: <sip:3100801@172.18.193.100>;party=calling;screen=no;privacy=off
Timestamp: 978020128
Contact: <sip:3100801@172.18.193.100:5060>
Expires: 300
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 254
^M
v=0
o=CiscoSystemsSIP-GW-UserAgent 45 7604 IN IP4 172.18.193.100
s=SIP Call
c=IN IP4 172.18.193.100
t=0 0
m=audio 19492 RTP/AVP 18 0
c=IN IP4 172.18.193.100
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000
 

次に、着信トランクが T3 の場合の Via ヘッダーを示す INVITE 要求の例を示します。B チャネル課金情報の形式は、7/0 が T3 コントローラ、1 が T1 コントローラ、2 が B チャネルです。

Router# debug ccsip messages
 
Via: SIP/2.0/UDP 172.18.193.120:5060; x-ds0num="ISDN 7/0:D 1:D1 2:DS0"

SIP ISDN サポート機能の設定例

ここでは、次の設定例について説明します。

「ISDN 発信者名の例」

「音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信例」

「SIP Carrier Identification Code(CIC)例」

「プライバシー存在時の発信者番号の SIP の CLI の例」

「SIP:ISDN の一時停止/再開のサポートの例」

「Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送の例」

ISDN 発信者名の例


) 例に示す IP アドレスおよびホスト名は架空のものです。


Router# show running-config
 
Building configuration...
 
Current configuration : 3845 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
resource-pool disable
clock timezone GMT 5
clock summer-time GMT recurring
!
 
 
no aaa new-model
ip subnet-zero
ip tcp path-mtu-discovery
ip name-server 172.18.192.48
!
isdn switch-type primary-ni
isdn voice-call-failure 0
isdn alert-end-to-end
!
voice call send-alert
!
voice service voip
signaling forward unconditional
sip
!
fax interface-type fax-mail
!
controller T1 0
framing esf
crc-threshold 0
clock source line primary
linecode b8zs
pri-group timeslots 1-24
description lucent_pbx
!
controller T1 1
shutdown
framing esf
crc-threshold 0
linecode ami
description summa_pbx
!
controller T1 2
shutdown
framing esf
crc-threshold 0
linecode ami
!
controller T1 3
framing esf
crc-threshold 0
clock source line secondary 1
linecode b8zs
pri-group timeslots 1-24
!
translation-rule 100
Rule 1 ^1 1 ANY national
Rule 2 2% 2 ANY unknown
Rule 4 4% 4 ANY unknown
Rule 5 5% 5 ANY unknown
Rule 6 6% 6 ANY unknown
Rule 7 7% 7 ANY unknown
Rule 8 8% 8 ANY unknown
Rule 9 9% 9 ANY unknown
!
interface Ethernet0
ip address 172.18.193.100 255.255.255.0
no ip route-cache
no ip mroute-cache
ip rsvp bandwidth 1 1
!
interface Serial0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice modem
isdn guard-timer 3000
isdn supp-service name calling
isdn disconnect-cause 1
fair-queue 64 256 0
no cdp enable
!
interface Serial3:23
no ip address
isdn switch-type primary-ni
isdn protocol-emulate network
isdn incoming-voice modem
isdn guard-timer 3000
isdn supp-service name calling
isdn T310 30000
isdn disconnect-cause 1
isdn bchan-number-order descending
fair-queue 64 256 0
no cdp enable
!
interface FastEthernet0
ip address 10.1.1.2 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.193.1
ip route 0.0.0.0 0.0.0.0 172.18.193.129
ip route 0.0.0.0 0.0.0.0 172.18.207.129
ip route 0.0.0.0 0.0.0.0 172.18.16.129
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 172.18.197.1
ip route 0.0.0.0 255.255.255.0 Ethernet0
ip route 10.2.0.1 255.255.255.255 172.18.16.135
ip route 172.18.0.0 255.255.0.0 Ethernet0
no ip http server
!
map-class dialer test
dialer voice-call
dialer-list 1 protocol ip permit
!
control-plane
!
voice-port 0:D
!
dial-peer voice 10 pots
application session.t.old
destination-pattern 5550100
prefix 5550100
!
dial-peer voice 4 voip
application session
destination-pattern 5550120
session protocol sipv2
session target ipv4:172.18.193.99
incoming called-number 5550125
!
dial-peer voice 1 pots
application session
destination-pattern 5550125
incoming called-number 5550155
port 0:D
prefix 95550125
!
dial-peer voice 18 voip
application session
destination-pattern 36601
session protocol sipv2
session target ipv4:172.18.193.187
codec g711ulaw
!
dial-peer voice 25 voip
destination-pattern 5550155
session protocol sipv2
session target ipv4:172.18.192.232
!
dial-peer voice 5678 pots
destination-pattern 5678
port 3:D
prefix 5678
!
dial-peer voice 56781 voip
incoming called-number 5678
!
sip-ua
!
line con 0
line aux 0
line vty 0 4
password password1
login
!

end

音声ゲートウェイ トランクのアプリケーション制御をイネーブルにするための ISDN B チャネル ID の信号送信例

Router# show running-config
 
Building configuration...
 
Current configuration : 3394 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
voice service voip
h323
billing b-channel
sip
ds0-num
 
ip dhcp pool vespa
network 192.168.0.0 255.255.255.0
option 150 ip 192.168.0.1
default-router 192.168.0.1
!
voice call carrier capacity active
!
voice class codec 1
codec preference 2 g711ulaw
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Ethernet0/0
ip address 10.8.17.22 255.255.0.0
half-duplex
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id vespa2 ipaddr 10.8.15.4 1718
!
router rip
network 10.0.0.0
network 192.168.0.0
!
ip default-gateway 10.8.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.0.1
no ip http server
ip pim bidir-enable
!
tftp-server flash:SEPDEFAULT.cnf
tftp-server flash:P005B302.bin
call fallback active
!
call application global default.new
call rsvp-sync
!
voice-port 1/0
!
voice-port 1/1
!
mgcp profile default
!
dial-peer voice 1 pots
destination-pattern 5100
port 1/0
!
dial-peer voice 2 pots
destination-pattern 9998
port 1/1
!
dial-peer voice 123 voip
destination-pattern [12]...
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
!
gateway
!
sip-ua
retry invite 3
retry register 3
timers register 150
registrar dns:myhost3.example.com expires 3600
registrar ipv4:10.8.17.40 expires 3600 secondary
!
telephony-service
max-dn 10
max-conferences 4
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
login
!
no scheduler allocate
end

SIP Carrier Identification Code(CIC)例

ここでは、次の設定例について説明します。

「SIP URL での CIC パラメータ」

「TEL URL での CIC パラメータ」

「CIC パラメータとビジュアル セパレータ」

「CIC パラメータの生成される INVITE 要求へのコピー」

SIP URL での CIC パラメータ

ここでは、SIP URL のユーザ情報部分で CIC パラメータをサポートする設定例を示します。SIP URL はユーザのアドレスを識別し、user@host( user は電話番号で、 host はドメイン名または数字のネットワーク アドレスのいずれか)という電子メール アドレスと同じように見えます。たとえば、発信 INVITE 要求の要求行は、次のように見える場合があります。

INVITE sip:+5550100;cic=+16789@example.com;user=phone SIP/2.0
 

+5550100; cic=+16789 はユーザ情報、example.c om はドメイン名を表します。 user=phone パラメータは、ユーザ アドレスがユーザ名ではなく電話番号であることを表しています。

TEL URL での CIC パラメータ

ここでは、TEL URL の電話加入者部分で CIC パラメータをサポートする設定例を示します。TEL URL は、 tel:telephone subscriber number という基本的な形式を持ちます。 tel は音声コールを行うローカル エンティティを要求し、 telephone subscriber number はコールを受信する番号です。次に例を示します。

tel:+5550100;cic=+16789
 

追加の CIC パラメータは、次の 3 つのいずれかの形式である場合があります。

cic=+16789
cic=+1-6789
cic=6789

CIC パラメータとビジュアル セパレータ

ここでは、ビジュアル セパレータがある場合とない場合に、異なる形式の CIC パラメータをサポートする設定例を示します。ただし、CIC パラメータには、通常、ビジュアル セパレータがありません。次のすべての形式が受け付けられます。

+12345
cic=+12345
cic=2345

CIC パラメータの生成される INVITE 要求へのコピー

ここでは、CIC パラメータが、3xx 連絡先 SIP URL のユーザ情報部分から、生成される INVITE 要求にコピーできる設定例を示します。

たとえば、プロキシからの 302 REDIRECT 応答の場合は、次のように表示されます。

Contact: <sip:+5550100;cic=+16789@example.com;user=phone>
 

または、次のように表示されます。

Contact: <sip:+5550100;cic=6789@example.com;user=phone>
 

その結果、+1 でプロキシされた CIC が送信される INVITE 要求が表示されます。

INVITE sip:+5550100;cic=+16789@example.com;user=phone SIP/2.0

プライバシー存在時の発信者番号の SIP の CLI の例

次に、グローバルにイネーブルにされ、ダイヤル ピア レベルでディセーブルにされている場合の、プライバシー存在時の発信者番号の SIP の CLI の例を示します。

Router# show running-config
 
Building configuration...
Current configuration: 1234 bytes
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname pip
!
boot-start-marker
boot system tftp user1/c3660-is-mz 172.18.207.15
boot-end-marker
!
logging buffered 1000000 debugging
enable secret 5 $1$li0u$IkIqPXzKq4uKme.LhzGut0
enable password password1
!
no aaa new-model
!
resource policy
!
clock timezone GMT 0
clock summer-time EDT recurring
ip subnet-zero
ip tcp path-mtu-discovery
!
ip cef
ip domain name example.sip.com
ip host sip-server1 172.18.193.100
ip host CALLGEN-SECURITY-V2 10.76.47.38 10.30.0.0
ip name-server 172.18.192.48
no ip dhcp use vrf connected
!
ip vrf btknet
rd 8262:2000
!
voice call send-alert
!
voice service voip <- SIP: CLI for Caller ID When Privacy Exists feature enabled globally
clid substitute name
clid strip pi-restrict all
clid network-provided
sip
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw
codec preference 4 g729br8
codec preference 5 g726r32
codec preference 6 g726r24
codec preference 7 g726r16
codec preference 8 g723ar53
codec preference 9 g723r53
codec preference 10 g723ar63
codec preference 11 gsmefr
codec preference 12 gsmfr
codec preference 13 g728
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
voice class codec 99
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
fax interface-type fax-mail
!
interface FastEthernet0/0
ip address 172.18.195.49 255.255.255.0
duplex auto
speed auto
no cdp enable
ip rsvp bandwidth 96 96
!
interface FastEthernet0/1
ip address 172.18.193.190 255.255.255.0
shutdown
duplex auto
speed auto
no cdp enable
!
no ip http server
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 172.16.0.0 255.0.0.0 172.18.195.1
!
snmp-server community public RO
!
control-plane
!
voice-port 1/0/0
!
voice-port 1/0/1
!
mgcp behavior rsip-range tgcp-only
!
dial-peer cor custom
!
dial-peer voice 100 pots
destination-pattern 9001
!
dial-peer voice 3301 voip
destination-pattern 9002
session protocol sipv2
session target ipv4:172.18.193.87
incoming called-number 9001
codec g711ulaw
no vad
!
dial-peer voice 3303 voip
destination-pattern 777
session protocol sipv2
session target ipv4:172.18.199.94
!
dial-peer voice 36601 voip
destination-pattern 36601
no modem passthrough
session protocol sipv2
session target ipv4:172.18.193.98
!
dial-peer voice 5 voip
destination-pattern 5550100
session protocol sipv2
session target ipv4:172.18.197.182
codec g711ulaw
!
dial-peer voice 36602 voip
destination-pattern 36602
session protocol sipv2
session target ipv4:172.18.193.120
incoming called-number 9001
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 111 voip
destination-pattern 111
session protocol sipv2
session target ipv4:172.18.193.251
!
dial-peer voice 5550199 voip <- SIP: CLI for Caller ID When Privacy Exists feature disabled on dial-peer
destination-pattern 3100801
session protocol sipv2
session target ipv4:10.102.17.208
codec g711ulaw
!
dial-peer voice 333 voip
preference 2
destination-pattern 333
modem passthrough nse codec g711ulaw
voice-class codec 99
session protocol sipv2
session target ipv4:172.18.193.250
dtmf-relay rtp-nte
no vad
!
dial-peer voice 9003 pots
preference 2
destination-pattern 9003
!
dial-peer voice 90032 voip
preference 1
destination-pattern 9003
session protocol sipv2
session target ipv4:172.18.193.97
!
dial-peer voice 1 pots
!
num-exp 5550100 5550199
num-exp 5550199 5550100
gateway
timer receive-rtp 1200
!
sip-ua
srv version 1
retry response 1
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password password1
login
!
no process cpu extended
no process cpu autoprofile hog
ntp clock-period 17180176
ntp server 192.0.10.150 prefer
!
end
 
The following shows an example of the SIP: CLI for Caller ID When Privacy Exists feature when disabled globally and disabled on the dial-peer level:
Router# show running-config
 
Building configuration...
Current configuration: 1234 bytes
!
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname pip
!
boot-start-marker
boot system tftp user1/c3660-is-mz 172.18.207.15
boot-end-marker
!
logging buffered 1000000 debugging
enable secret 5 $1$li0u$IkIqPXzKq4uKme.LhzGut0
enable password password1
!
no aaa new-model
!
resource policy
!
clock timezone GMT 0
clock summer-time EDT recurring
ip subnet-zero
ip tcp path-mtu-discovery
!
ip cef
ip domain name example.sip.com
ip host sip-server1 172.18.193.100
ip host CALLGEN-SECURITY-V2 10.76.47.38 10.30.0.0
ip name-server 172.18.192.48
no ip dhcp use vrf connected
!
ip vrf btknet
rd 8262:2000
!
voice call send-alert
!
voice service voip <- SIP: CLI for Caller ID When Privacy Exists feature disabled globally
sip
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw
codec preference 4 g729br8
codec preference 5 g726r32
codec preference 6 g726r24
codec preference 7 g726r16
codec preference 8 g723ar53
codec preference 9 g723r53
codec preference 10 g723ar63
codec preference 11 gsmefr
codec preference 12 gsmfr
codec preference 13 g728
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
voice class codec 99
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
fax interface-type fax-mail
!
interface FastEthernet0/0
ip address 172.18.195.49 255.255.255.0
duplex auto
speed auto
no cdp enable
ip rsvp bandwidth 96 96
!
interface FastEthernet0/1
ip address 172.18.193.190 255.255.255.0
shutdown
duplex auto
speed auto
no cdp enable
!
no ip http server
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 172.16.0.0 255.0.0.0 172.18.195.1
!
snmp-server community public RO
!
control-plane
!
voice-port 1/0/0
!
voice-port 1/0/1
!
mgcp behavior rsip-range tgcp-only
!
dial-peer cor custom
!
dial-peer voice 100 pots
destination-pattern 9001
!
dial-peer voice 3301 voip
destination-pattern 9002
session protocol sipv2
session target ipv4:172.18.193.87
incoming called-number 9001
codec g711ulaw
no vad
!
dial-peer voice 3303 voip
destination-pattern 777
session protocol sipv2
session target ipv4:172.18.199.94
!
dial-peer voice 36601 voip
destination-pattern 36601
no modem passthrough
session protocol sipv2
session target ipv4:172.18.193.98
!
dial-peer voice 5 voip
destination-pattern 5550100
session protocol sipv2
session target ipv4:172.18.197.182
codec g711ulaw
!
dial-peer voice 36602 voip
destination-pattern 36602
session protocol sipv2
session target ipv4:172.18.193.120
incoming called-number 9001
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 111 voip
destination-pattern 111
session protocol sipv2
session target ipv4:172.18.193.251
!
dial-peer voice 5550199 voip <- SIP: CLI for Caller ID When Privacy Exists feature disabled on dial-peer
destination-pattern 5550199
session protocol sipv2
session target ipv4:10.102.17.208
codec g711ulaw
!
dial-peer voice 333 voip
preference 2
destination-pattern 333
modem passthrough nse codec g711ulaw
voice-class codec 99
session protocol sipv2
session target ipv4:172.18.193.250
dtmf-relay rtp-nte
no vad
!
dial-peer voice 9003 pots
preference 2
destination-pattern 9003
!
dial-peer voice 90032 voip
preference 1
destination-pattern 9003
session protocol sipv2
session target ipv4:172.18.193.97
!
dial-peer voice 1 pots
!
num-exp 5550100 5550199
num-exp 5550101 5550198
gateway
timer receive-rtp 1200
!
sip-ua
srv version 1
retry response 1
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password password1
login
!
no process cpu extended
no process cpu autoprofile hog
ntp clock-period 17180176
ntp server 192.0.10.150 prefer
!
end
 

次に、グローバルにディセーブルにされ、ダイヤル ピア レベルでイネーブルにされている場合の、プライバシー存在時の発信者番号の SIP の CLI の例を示します。

Router# show running-config
 
Building configuration...
Current configuration: 1234 bytes
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname pip
!
boot-start-marker
boot system tftp judyg/c3660-is-mz 172.18.207.15
boot-end-marker
!
logging buffered 1000000 debugging
enable secret 5 $1$li0u$IkIqPXzKq4uKme.LhzGut0
enable password password1
!
no aaa new-model
!
resource policy
!
clock timezone GMT 0
clock summer-time EDT recurring
ip subnet-zero
ip tcp path-mtu-discovery
!
ip cef
ip domain name example.sip.com
ip host sip-server1 172.18.193.100
ip host CALLGEN-SECURITY-V2 10.76.47.38 10.30.0.0
ip name-server 172.18.192.48
no ip dhcp use vrf connected
!
ip vrf btknet
rd 8262:2000
!
voice call send-alert
!
voice service voip <- SIP: CLI for Caller ID When Privacy Exists feature disabled globally
sip
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw
codec preference 4 g729br8
codec preference 5 g726r32
codec preference 6 g726r24
codec preference 7 g726r16
codec preference 8 g723ar53
codec preference 9 g723r53
codec preference 10 g723ar63
codec preference 11 gsmefr
codec preference 12 gsmfr
codec preference 13 g728
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
voice class codec 99
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
fax interface-type fax-mail
!
interface FastEthernet0/0
ip address 172.18.195.49 255.255.255.0
duplex auto
speed auto
no cdp enable
ip rsvp bandwidth 96 96
!
interface FastEthernet0/1
ip address 172.18.193.190 255.255.255.0
shutdown
duplex auto
speed auto
no cdp enable
!
no ip http server
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 172.16.0.0 255.0.0.0 172.18.195.1
!
snmp-server community public RO
!
control-plane
!
voice-port 1/0/0
!
voice-port 1/0/1
!
mgcp behavior rsip-range tgcp-only
!
dial-peer cor custom
!
dial-peer voice 100 pots
destination-pattern 9001
!
dial-peer voice 3301 voip
destination-pattern 9002
session protocol sipv2
session target ipv4:172.18.193.87
incoming called-number 9001
codec g711ulaw
no vad
!
dial-peer voice 3303 voip
destination-pattern 777
session protocol sipv2
session target ipv4:172.18.199.94
!
dial-peer voice 36601 voip
destination-pattern 36601
no modem passthrough
session protocol sipv2
session target ipv4:172.18.193.98
!
dial-peer voice 5 voip
destination-pattern 5550102
session protocol sipv2
session target ipv4:172.18.197.182
codec g711ulaw
!
dial-peer voice 36602 voip
destination-pattern 36602
session protocol sipv2
session target ipv4:172.18.193.120
incoming called-number 9001
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 111 voip
destination-pattern 111
session protocol sipv2
session target ipv4:172.18.193.251
!
dial-peer voice 5550100 voip <- SIP: CLI for Caller ID When Privacy Exists feature enabled on dial-peer
destination-pattern 5550100
session protocol sipv2
session target ipv4:10.102.17.208
codec g711ulaw
clid strip pi-restrict all
clid network-provided
clid substitute name
!
dial-peer voice 333 voip
preference 2
destination-pattern 333
modem passthrough nse codec g711ulaw
voice-class codec 99
session protocol sipv2
session target ipv4:172.18.193.250
dtmf-relay rtp-nte
no vad
!
dial-peer voice 9003 pots
preference 2
destination-pattern 9003
!
dial-peer voice 90032 voip
preference 1
destination-pattern 9003
session protocol sipv2
session target ipv4:172.18.193.97
!
dial-peer voice 1 pots
!
num-exp 5550100 5550199
num-exp 5550101 5550198
gateway
timer receive-rtp 1200
!
sip-ua
srv version 1
retry response 1
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password password1
login
!
no process cpu extended
no process cpu autoprofile hog
ntp clock-period 17180176
ntp server 192.0.10.150 prefer
!
end

SIP:ISDN の一時停止/再開のサポートの例

次に、ゲートウェイ上で SIP の一時停止と再開がディセーブルの例を示します(SIP の一時停止と再開は、ゲートウェイ上で、デフォルトでイネーブルにされています)。


) 例に示す IP アドレスおよびホスト名は架空のものです。


Router# show running-config
 
Building configuration...
 
Current configuration : 3845 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
resource-pool disable
clock timezone GMT 5
clock summer-time GMT recurring
!
 
 
no aaa new-model
ip subnet-zero
ip tcp path-mtu-discovery
ip name-server 172.18.192.48
!
isdn switch-type primary-ni
isdn voice-call-failure 0
isdn alert-end-to-end
!
voice call send-alert
!
voice service voip
signaling forward unconditional
sip
!
fax interface-type fax-mail
!
controller T1 0
framing esf
crc-threshold 0
clock source line primary
linecode b8zs
pri-group timeslots 1-24
description lucent_pbx
!
controller T1 1
shutdown
framing esf
crc-threshold 0
linecode ami
description summa_pbx
!
controller T1 2
shutdown
framing esf
crc-threshold 0
linecode ami
!
controller T1 3
framing esf
crc-threshold 0
clock source line secondary 1
linecode b8zs
pri-group timeslots 1-24
!
translation-rule 100
Rule 1 ^1 1 ANY national
Rule 2 2% 2 ANY unknown
Rule 4 4% 4 ANY unknown
Rule 5 5% 5 ANY unknown
Rule 6 6% 6 ANY unknown
Rule 7 7% 7 ANY unknown
Rule 8 8% 8 ANY unknown
Rule 9 9% 9 ANY unknown
!
interface Ethernet0
ip address 172.18.193.100 255.255.255.0
no ip route-cache
no ip mroute-cache
ip rsvp bandwidth 1 1
!
interface Serial0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice modem
isdn guard-timer 3000
isdn supp-service name calling
isdn disconnect-cause 1
fair-queue 64 256 0
no cdp enable
!
interface Serial3:23
no ip address
isdn switch-type primary-ni
isdn protocol-emulate network
isdn incoming-voice modem
isdn guard-timer 3000
isdn supp-service name calling
isdn T310 30000
isdn disconnect-cause 1
isdn bchan-number-order descending
fair-queue 64 256 0
no cdp enable
!
interface FastEthernet0
ip address 10.1.1.2 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.193.1
ip route 0.0.0.0 0.0.0.0 172.18.193.129
ip route 0.0.0.0 0.0.0.0 172.18.207.129
ip route 0.0.0.0 0.0.0.0 172.18.16.129
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 172.18.197.1
ip route 0.0.0.0 255.255.255.0 Ethernet0
ip route 10.2.0.1 255.255.255.255 172.18.16.135
ip route 172.18.0.0 255.255.0.0 Ethernet0
no ip http server
!
map-class dialer test
dialer voice-call
dialer-list 1 protocol ip permit
!
control-plane
!
voice-port 0:D
!
dial-peer voice 10 pots
application session.t.old
destination-pattern 5550100
prefix 5550100
!
dial-peer voice 4 voip
application session
destination-pattern 5550120
session protocol sipv2
session target ipv4:172.18.193.99
incoming called-number 5550125
!
dial-peer voice 1 pots
application session
destination-pattern 5550125
incoming called-number 5550155
port 0:D
prefix 95550125
!
dial-peer voice 18 voip
application session
destination-pattern 36601
session protocol sipv2
session target ipv4:172.18.193.187
codec g711ulaw
!
dial-peer voice 25 voip
destination-pattern 5550155
session protocol sipv2
session target ipv4:172.18.192.232
!
dial-peer voice 5678 pots
destination-pattern 5678
port 3:D
prefix 5678
!
dial-peer voice 56781 voip
incoming called-number 5678
!
sip-ua
no suspend-resume
retry invite 1
retry bye 1
 
line con 0
line aux 0
line vty 0 4
password password1
login
!

end

Cisco Generic Transparency Descriptor(GTD)機能を使用した SIP PSTN 転送の例

GTD のグローバルな設定

次に、GTD が設定されている例を示します。

Router# show running-config
 
Building configuration...
 
Current configuration : 4192 bytes
!
version 12.2
service config
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
!
hostname router
!
voice service voip
signaling forward unconditional
sip
.

個々のダイヤル ピアの GTD の設定

次に、2 つのダイヤル ピアで無条件転送が設定されている GTD の例を示します。

Router# show running-config
 
Building configuration...
 
Current configuration : 4169 bytes
!
version 12.2
service config
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
!
hostname router
.
.
.
dial-peer voice 36 voip
incoming called-number 3100802
destination-pattern 3100801
signaling forward unconditional
session protocol sipv2
session target ipv4:192.0.2.209
!
dial-peer voice 5 voip
destination-pattern 5555555
signaling forward unconditional
session protocol sipv2
session target ipv4:172.18.192.218
.
.
.

その他の参考資料

一般的な SIP 参考資料

SIP 機能のロードマップ:Cisco Feature Navigator にアクセスする手順について説明します。また、Cisco IOS リリース別に、そのリリースの SIP 機能を示して説明します。

Session Initiation Protocol(SIP)の基本設定:基本的な SIP テクノロジーのほか、関連資料、規格、MIB、RFC、および技術サポートを受ける方法のリストが掲載されています。

この章で言及した参考資料(アルファベット順)

Configuring H.323 Gateways 』( http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfax_c/callc_c/h323_c/323confg/3gwconf.htm

Redundant Link Manager (RLM) 』( http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/as5400/sw_conf/ios_121/pull_rlm.htm