Cisco IOS SIP コンフィギュレーション ガイド
SIP DTMF 機能の設定
SIP DTMF 機能の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

SIP DTMF 機能の設定

この章の構成

SIP DTMF の制約事項

SIP DTMF の前提条件

SIP DTMF に関する情報

RFC 2833 DTMF MTP パススルー

SIP シグナリング経由の DTMF イベント

DTMF ダイヤル

NOTIFY メッセージ

NTE を使用した SIP コール対 DTMF リレー

信頼性の高い DTMF リレー

SIP IP 電話のサポート

DTMF トーン生成用 SIP INFO 方式

SIP INFO メッセージ

SIP NOTIFY ベースのアウトオブバンド DTMF リレー

NOTIFY メッセージの送信

NOTIFY メッセージの受信

SIP KPML ベース アウトオブバンド DTMF リレー

非対称 SDP に対する SIP サポート

非対称 DTMF ペイロード対応の UAC の動作

非対称 DTMF ペイロード対応の UAS の動作

非対称ダイナミック コーデック ペイロード対応の UAC の動作

非対称ダイナミック コーデック ペイロード対応の UAS の動作

SIP DTMF 機能の設定方法

MTP またはトランスコーダ ゲートウェイに接続するゲートウェイにおけるパススルーの設定

SIP シグナリング経由の DTMF イベントの設定

NTE を使用した SIP コール対応 DTMF リレーの設定

NTE を使用した SIP コール対応 DTMF リレーの設定

DTMF トーン生成用 SIP INFO 方式の設定

SIP NOTIFY ベースのアウトオブバンド DTMF リレーの設定

SIP KPML ベースのアウトオブバンド DTMF リレーの設定

SIP DTMF サポートの確認

SDP に対する SIP サポートの設定

ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法

ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法

トラブルシューティングのヒント

SIP DTMF 機能の設定例

NTE を使用した SIP コール対応 DTMF リレーの例

SIP NOTIFY ベースのアウトオブバンド DTMF リレーの例

SIP KPML ベースのアウトオブバンド DTMF リレーの例

の例

非対称 SDP に対する SIP サポートの例

ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法の例

ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法の例

その他の参考資料

SIP DTMF 機能の設定

この章では、DTMF(Dual Tone MultiFrequency)シグナリングをサポートする次の SIP 機能について説明します。

RFC 2833 DTMF メディア ターミネーション ポイント(MTP)パススルー

SIP シグナリング経由の DTMF イベント

Named Telephony Event を使用した SIP コール対応 DTMF リレー

DTMF トーン生成用 SIP INFO 方式

SIP NOTIFY ベース アウトオブバンド DTMF リレー サポート

SIP KPML ベース アウトオブバンド DTMF リレー サポート

非対称 SDP に対する SIP サポート

RFC 2833 DTMF MTP パススルー機能履歴

リリース
変更点

12.4(11)T

この機能が導入されました。

SIP シグナリング経由の DTMF イベントの機能履歴

リリース
変更点

12.2(11)T

この機能が導入されました。

Named Telephony Event(NTE)を使用した SIP コール対応 DTMF リレーの機能履歴

リリース
変更点

12.2(2)XB

この機能が導入されました。

12.2(2)XB1

この機能が追加のプラットフォームに実装されました。

12.2(8)T

この機能がこのリリースに統合されました。

12.2(11)T

この機能が追加のプラットフォームに実装されました。

DTMF トーン生成用 SIP INFO 方式の機能履歴

リリース
変更点

12.2(11)T

この機能が導入されました。

SIP NOTIFY ベース アウトオブバンド DTMF リレー サポートの機能履歴

リリース
変更点

12.3(4)T

この機能が導入されました。

SIP KPML ベース アウトオブバンド DTMF リレー サポートの機能履歴

リリース
変更点

12.4(9)T

この機能が導入されました。

非対称 SDP に対する SIP サポートの機能履歴

リリース
変更点

12.4(15)T

この機能が導入されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

SIP DTMF の制約事項

RFC 2833 DTMF MTP パススルー機能

RFC 2833 DTMF MTP パススルー機能により、トランスコードまたは RSVP エージェント機能の使用を必要とする Session Initiation Protocol(SIP)エンドポイント間における DTMF トーンの透過的な通過にサポートが追加されます。IP ネットワークに T38 ファックス リレー機能も設定されている場合は、音声ゲートウェイを、ファックス リレー ネゴシエーションで PT97 または PT98 以外のペイロード タイプを使用するように設定するか、SIP エンドポイントが異なるタイプのペイロード タイプをサポートしているかどうかに応じて、Cisco Unified CME を DTMF 対応の PT97 または PT98 以外のペイロード タイプを使用するように設定します。

SIP シグナリング経由の DTMF イベント機能

SIP シグナリング経由の DTMF イベント機能により、SIP ゲートウェイからの SIP NOTIFY メッセージを介した電話イベント通知の送信に対するサポートが追加されます。通知が送信されるイベントは、ゲートウェイ上のローカル Plain Old Telephone Service(POTS; 一般電話サービス)インターフェイスからの DTMF イベントです。受信ユーザ エージェントからの Real-Time Transport Protocol(RTP; リアルタイム トランスポート プロトコル)ストリームで受信された DTMF イベントに対する通知は送信されません。

NTE を使用した SIP コール対応 DTMF リレー 機能

SIP NTE DTMF リレー機能は Cisco VoIP ゲートウェイにおける SIP コールでのみ利用できます。SIP NTE DTMF リレー機能はフックフラッシュ リレーのみをサポートし、コール ウェイティングや会議などの高度な機能のフックフラッシュ生成はサポートしません。

DTMF トーン生成用 SIP INFO 方式機能

最短信号持続時間は 100 ミリ秒です。持続時間が 100 ミリ秒未満の要求を受信した場合、デフォルトでは最短持続時間の 100 ミリ秒が使用されます。

最長信号持続時間は 5000 ミリ秒です。持続時間が 5000 ミリ秒を超える要求を受信した場合、デフォルトでは最長持続時間の 5000 ミリ秒が使用されます。

要求に持続時間のパラメータが含まれていない場合、ゲートウェイの信号持続時間はデフォルトの 250 ミリ秒になります。

SIP NOTIFY ベース アウトオブバンド DTMF リレー サポートの機能

発信および終端 SIP ゲートウェイは、NOTIFY ベース アウトオブバンド DTMF リレーを使用して Skinny Client Control Protocol(SCCP)IP 電話をサポートします。NOTIFY ベース アウトオブバンド DTMF リレーはシスコ独自の機能です。

サポートは SIP VoIP ダイヤル ピア上でのみ設定できます。

SIP KPML ベース アウトオブバンド DTMF リレー サポートの機能

着信ダイヤル ピアでは、複数の DTMF ネゴシエーション方式を設定する場合、最初に設定した値、次いで 2 番目、3 番目の順に優先されます。

着信ダイヤル ピアでは、最初のアウトオブバンド ネゴシエーション方式が DTMF ネゴシエーション方式よりも優先されますが、 dtmf - relay rtp-nte コマンドが優先される場合は、 dtmf - relay sip-kpml コマンドが他のアウトオブバンド ネゴシエーション方式よりも優先されます。

着信ダイヤル ピアでは、 dtmf - relay rtp-nte および dtmf - relay sip-kpml コマンドのおよび通知メカニズムの両方がイネーブルで、ネゴシエートされている場合、ゲートウェイは RFC 2833 通知によりディジットを受信し、KPML の SUBSCRIBE は初期化されません。

SIP KPML サポートは、次の制限付きで、IEFT ドラフト「draft-ietf-sipping-kpml-04.txt」に準拠します。

SIP ゲートウェイは構築された INVITE ダイアログのコンテキストから常に SUBSCRIBE を開始します。ゲートウェイは、構築された INVITE ダイアログのコンテキスト、および Event ヘッダー内のレッグ パラメータを持つアウトオブコール コンテキスト要求における SUBSCRIBE の受信をサポートします。要求コードが、既存の INVITE ダイアログに一致しない場合、ゲートウェイは KPML ステータス コード 481 の NOTIFY を送信し、サブスクリプション ステートを終了するように設定します。

ゲートウェイは、Globally Routable User Agent(GRUU)要件をサポートしません。INVITE/200 OK メッセージ内の Contact ヘッダーは、ゲートウェイのコンタクト情報からローカルに生成されます。

ゲートウェイは、常に継続的なサブスクリプションを開始し、継続的サブスクリプションおよびワンショット サブスクリプションを受信し、処理します。

ゲートウェイは、1 桁(ディジット)のレポートのみをサポートします。内部ディジット タイマーのサポートは必要ありません。正規表現は 1 桁に一致するもののみがサポートされます。例:

<regex>x</regex>:0 ~ 9 のすべてのディジットに一致

<regex>1</regex>:ディジット 1 に一致

<regex>[x#*ABCD]</regex>:0 ~ 9、#(ポンド記号)、*(アスタリスク)、または A、B、C、D のすべてに一致

<regex>[24]</regex>:ディジット 2 または 4 に一致

<regex>[2-9]</regex>:2 ~ 9 のすべてのディジットに一致

<regex>[^2-9]</regex>:ディジット 0 または 1 に一致

ゲートウェイは、キーが長く押されることをサポートしていないため、キーが長く押された場合は 1 桁の入力として検出およびレポートされます。

ディジット抑制はサポートされていません(帯域内ディジットの抑制には pre タグを使用します)。

個別のストリームの選択はサポートされていません。KPML に対する SUBSCRIBE 要求はダイアログ内のすべてのオーディオ ストリームに適用されます( stream 要素および reverse はサポートされていません)。

サポートは SIP VoIP ダイヤル ピア上でのみ設定できます。

SIP DTMF の前提条件

NTE を使用した SIP コール対応 DTMF リレー 機能

Cisco ゲートウェイ上の SIP を使用した稼動中の VoIP ネットワークが存在することを確認してください。

SIP DTMF に関する情報

SIP DTMF サポートを設定するには、次の概念を理解する必要があります。

「RFC 2833 DTMF MTP パススルー」

「SIP シグナリング経由の DTMF イベント」

「NTE を使用した SIP コール対 DTMF リレー」

「DTMF トーン生成用 SIP INFO 方式」

「SIP NOTIFY ベースのアウトオブバンド DTMF リレー」

「SIP KPML ベース アウトオブバンド DTMF リレー」

「非対称 SDP に対する SIP サポート」

RFC 2833 DTMF MTP パススルー

RFC 2833 DTMF MTP パススルー機能は、トランスコードまたは RSVP エージェント機能の使用が必要な Session Initiation Protocol(SIP)エンドポイント間において DTMF トーンを透過的に通過させます (RSVP エージェントは、Cisco IOS ベースのリソース予約プロトコル(RSVP)プロキシ サーバであり、コール マネージャの Cisco Unified CallManager か Cisco Unified CallManager Express に、メディア ターミネーション ポイントまたはトランスコーダ デバイスとして登録されます)。

ゲートウェイ上の MTP またはトランスコーディング モジュールは、IP エンドポイントからの RFC 2833(DTMF)パケットを検出します。次の 2 つの操作のいずれか、または両方を実行するように設定できます。

アウトオブバンド シグナル イベントの生成およびコール マネージャへの送信

他の IP エンドポイントに対するパケットの通過(デフォルト)

この命令は、コール マネージャ、ゲートウェイのいずれか、または両方から設定できます。ゲートウェイはそれ自体に MTP またはトランスコーダを持つコール マネージャを搭載することも、MTP またはトランスコーダを持つコール マネージャを搭載している他のゲートウェイに接続することもできます。コール マネージャ上の設定は、ゲートウェイ上の設定よりも優先されます。

SIP シグナリング経由の DTMF イベント

SIP シグナリング経由の DTMF イベント機能には、次の利点があります。

SIP メッセージに対する DTMF イベント通知の提供。

SIP NOTIFY 方式を使用したフックフラッシュ イベント通知の受信機能の提供。

テレホン カードやメッセージ サービスなどの高度なサービスを実現する、サードパーティ呼制御、または他のシグナリング メカニズムの有効化。

メディア接続外部のアプリケーションとの通信を実現。

SIP シグナリング経由の DTMF イベント機能は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)ドラフト「 SIP-Specific Event Notification 」で定義されている、SIP NOTIFY メッセージを介し SIP SUBSCRIBE/NOTIFY 方式を使用する、電話イベント通知の送信を可能にします。また、この機能は IETF ドラフト「 Signaled Telephony Events in the Session Initiation Protocol SIP )」( draft-mahy-sip-signaled-digits-01.txt )に基づく DTMF 通知の送信もサポートします。

DTMF ダイヤル

DTMF ダイヤルは、電話のボタンが押されたときに生成される同時音声バンド トーンから成ります。この機能に対し DTMF シグナリングを使用することにより、高度なテレフォニー サービスのサポートが有効になります。現在、メディア接続をサポートしないアプリケーション サーバや、サービス構築プラットフォームは、数多く存在します。付加価値のあるサービスをネットワークに提供するには、このようなサーバやプラットフォームはコールの特定の参加者からのシグナリング イベントを認識する必要があります。サーバやプラットフォームが、信号を送られた DTMF イベントを認識できるようになれば、これらはサードパーティ呼制御、または他のシグナリング メカニズムを使用して高度なサービスを提供することができます。この機能によりサポートされるサービスやプラットフォームの種類の例として、音声ブラウザ サービス、Centrex スイッチやビジネス サービス プラットフォーム、テレホン カード サービス、および統合メッセージ サーバがあります。これらのすべてのアプリケーションには、ユーザがメディア接続の外部のアプリケーションと通信できる方式が必要です。SIP シグナリング経由の DTMF イベント機能は、このシグナリング機能を提供します。

この機能は、SIP INFO 方式を使用してアウトオブバンド DTMF トーン生成にサポートを追加する DTMF トーン生成用 SIP INFO 方式機能と関連性があります。この 2 つの機能により、シグナリング パスに沿って、DTMF ディジットを送受信するメカニズムが提供されます。

NOTIFY メッセージ

SIP イベント通知メカニズムは、特定の電話イベントが発生した際に NOTIFY メッセージを使用して信号を送信します。NOTIFY メッセージを使用して DTMF シグナルを送信するには、DTMF ディジットが発信者から信号を送信された際に、ゲートウェイが登録者に通知します。通知には、SIP 応答状況表示行を含むメッセージの本文が含まれます。

次に、登録者にサブスクリプションが完了したことを知らせる、ノーティファイヤからの NOTIFY メッセージの例を示します。From、To、および Call-ID ヘッダーの組み合わせによりコール レッグが特定されます。Events ヘッダーは信号が送信されるイベント タイプを指定し、Content-Type は、インターネット メディア タイプを指定します。Content-Length は、インターネット メディア タイプを指定します。

NOTIFY sip:subscriber@example1.com SIP/2.0
Via: SIP/2.0/UDP example2.com:5060
From: Notifier <sip:notifier@example2.com>;tag=5678-EFGH
To: Subscriber <sip:subscriber@example1.com>;tag=1234-ABCD
Call-ID: 12345@example2.com
CSeq: 104 NOTIFY
Contact: Notifier <sip:notifier@example2.com>
Events: telephone-event;rate=1000
Content-Type: audio/telephone-event
Content-Length: 4

NTE を使用した SIP コール対 DTMF リレー

この機能の利点は次のとおりです。

低帯域幅のコーデックが使用される場合の、Cisco VoIP ゲートウェイ間における信頼性の高い DTMF ディジット リレー

DTMF ディジットの表示に NTE パケットを使用する SIP 電話ソフトウェアとの通信機能

SIP NTE DTMF リレー機能は、次のアプリケーションで使用されます。

「信頼性の高い DTMF リレー」

「SIP IP 電話のサポート」


) この機能は、VoIP ゲートウェイにおける SIP コール向けにのみ導入されています。


信頼性の高い DTMF リレー

SIP NTE DTMF リレー機能は、低帯域幅のコーデックが使用される場合の Cisco VoIP ゲートウェイ間における信頼性の高いディジット リレーを提供します。NTE を DTMF トーンのリレーに使用することにより、インターネット技術特別調査委員会(IETF)の Audio/Video Transport(AVT)ワーキング グループにより開発された RFC 2833 のセクション 3「 RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals 」に準拠したリアルタイム トランスポート プロトコル(RTP)パケットにおける DTMF トーンの転送に、共通基準が提供されます。RFC 2833 では、NTE RTP パケットの形式を、2 つのピア エンドポイント間の DTMF ディジット、フックフラッシュ、および他のテレフォニー イベントの転送に使用するよう定義しています。

DTMF トーンはプッシュホン電話機のボタンが押されたときに生成されます。トーンは生成されると圧縮され、電話の相手に転送されて圧縮解除されます。DTMF リレー方式を使用しない G.729 または G.723 のような低帯域幅コーデックが使用される場合、トーンは圧縮されたり圧縮解除されたりする間に歪む可能性があります。

SIP NTE DTMF リレー機能を使用すると、エンドポイントにより DTMF リレー方式のコール単位ネゴシエーションが実行されます。また、NTE RTP パケットのペイロード タイプ値を判別するネゴシエーションもゲートウェイにより実行されます。

SIP コールにおいて、ゲートウェイは次の内容を示す Session Description Protocol(SDP)メッセージを形成します。

NTE が使用されるかどうか

NTE を使用して送信されるイベントはどのイベントか

NTE ペイロード タイプ値

SIP NTE DTMF リレー機能は、NTP パケットを使用して RTP ストリーム内のフックフラッシュ イベントをリレーできます。


) SIP NTE DTMF リレー機能は、コール ウェイティングや会議などの高度な機能のフックフラッシュ生成はサポートしません。


SIP IP 電話のサポート

SIP NTE DTMF リレー機能は、SIP 電話のサポートを追加します。SIP IP 電話が、DTMF トーンを生成する機能のないソフトウェアを実行している場合、この電話は NTE パケットを使用して DTMF ディジットを表示します。SIP NTE DTMF リレー機能を使用すると、Cisco VoIP ゲートウェイは DTMF ディジットの表示に NTE パケットを使用する SIP 電話と通信できるようになります。Cisco VoIP ゲートウェイは、他のエンドポイントにディジットをリレーできます。

DTMF トーン生成用 SIP INFO 方式

ここでは、DTMF トーンの生成にテレフォニー コール レッグ上の SIP INFO 方式を使用する DTMF トーン生成用 SIP INFO 方式機能について説明します。SIP 方式、または要求メッセージタイプは、他のユーザ エージェントまたはプロキシ サーバによる特定のアクションを要求します。SIP INFO メッセージは、コールのシグナリング パスに沿って送信されます。この機能を使用して、DTMF リレー コンテンツを含む SIP INFO メッセージの受信時に、ゲートウェイがコールのテレフォニー側で指定された DTMF トーンを生成します。

DTMF トーン生成用 SIP INFO 方式機能は、常にイネーブルであり DTMF リレー コンテンツを含む SIP INFO メッセージの受信により実行されます。この機能は、アプリケーションを SIP NOTIFY メッセージを使用した DTMF イベントに関する通知を受信できるようにする SIP NOTIFY ベース アウトオブバンド DTMF リレー サポート機能と関連性があります。この 2 つの機能により、シグナリング パスに沿って、DTMF ディジットを送受信するメカニズムが提供されます。


) SIP NOTIFY メッセージを使用した DTMF イベント通知の送信の詳細については、「SIP シグナリング経由の DTMF イベント」を参照してください。


SIP INFO メッセージ

SIP INFO 方式は、ユーザ エージェントが、確立されたメディア セッションを持つ他のユーザ エージェントにコール シグナリング情報を送信する際に使用されます。次に、DTMF コンテンツを含む SIP INFO メッセージの例を示します。

INFO sip:2143302100@172.17.2.33 SIP/2.0
Via: SIP/2.0/UDP 172.80.2.100:5060
From: <sip:9724401003@172.80.2.100>;tag=43
To: <sip:2143302100@172.17.2.33>;tag=9753.0207
Call-ID: 984072_15401962@172.80.2.100
CSeq: 25634 INFO
Supported: 100rel
Supported: timer
Content-Length: 26
Content-Type: application/dtmf-relay
 
Signal= 1
Duration= 160
 

これは、DTMF トーンの具体的な情報を持つゲートウェイで受信された SIP INFO メッセージの例です。From、To、および Call-ID ヘッダーの組み合わせによりコール レッグが特定されます。signal ヘッダーおよび duration ヘッダーにより、DTMF トーン再生のディジット(この例の場合は 1)、持続時間(この例の場合は 160 ミリ秒)が指定されます。

SIP NOTIFY ベースのアウトオブバンド DTMF リレー

SCCP IP 電話は、インバンド DTMF ディジットをサポートしていないため、アウトオブバンド DTMF ディジットだけを送信できます。SCCP デバイスをサポートするには、発信側と着信側の SIP ゲートウェイがシスコ独自の NOTIFY ベースのアウトオブバンド DTMF リレーを使用できる必要があります。加えて、NOTIFY ベースのアウトオブバンド DTMF リレーは、ルータのアナログ音声ポート(FXS)に接続されたアナログ電話で使用することもできます。

NOTIFY ベースのアウトオブバンド DTMF リレーは、コール中に、発信側と着信側のゲートウェイ間で DTMF イベントに関するメッセージを双方向に送信します。SIP ダイヤルピア上で複数の DTMF リレー メカニズムをイネーブルにしている場合、ネゴシエーションに成功したときは、NOTIFY ベースのアウトオブバンド DTMF リレーが優先されます。

発信側ゲートウェイは、SIP Call-Info が含まれる INVITE メッセージを送信して、NOTIFY ベースのアウトオブバンド DTMF リレーの使用を示します。着信側ゲートウェイは、18x または 200 応答メッセージおよび Call-Info ヘッダーを使用してメッセージを確認します。NOTIFY ベースのアウトオブバンド リレーの Call-Info ヘッダーは、次のように表示されます。

Call-Info: <sip: address>; method="NOTIFY;Event=telephone-event;Duration=msec"
 

Duration は、単一のディジットに対して送信される NOTIFY メッセージ間の間隔を表し、notify telephone-event コマンドを使用して設定されます。


まず、NOTIFY ベースのアウトオブバンド DTMF リレー メカニズムは、SIP INVITE および 18x/200 応答メッセージによってネゴシエートされます。その後、DTMF イベントが発生すると、ゲートウェイは、そのイベントの SIP NOTIFY メッセージを送信します。その応答として、ゲートウェイは 200 OK メッセージを受信することを予期しています。

NOTIFY ベースのアウトオブバンド DTMF リレー メカニズムは、RFC 2833 に記載されている DTMF メッセージ形式に似ています。NOTIFY ベースのアウトオブバンド DTMF リレーは、バイナリ符号化形式の 4 バイトで構成されます。メッセージ形式を図 1 に、フィールドの説明を表 1 に示します。

図 1 NOTIFY ベースのアウトオブバンド DTMF リレー メッセージの形式

 

 

表 1 NOTIFY ベースのアウトオブバンド DTMF リレー メッセージのフィールド

フィールド
説明

event

DTMF イベント。0 ~ 9、A、B、C、D、#、*、および flash のいずれか。

E

E は、エンド ビットを示します。E の値が 1 に設定されている場合、NOTIFY メッセージは DTMF イベントの末尾を格納しています。したがって、この最終 NOTIFY メッセージの duration パラメータは、イベントの全期間を表します。

R

予約済み。

unused

RFC 2833 では、unused は volume フィールドに対応しますが、NOTIFY ベースのアウトオブバンド DTMF リレーでは使用されません。

duration

この DTMF イベントの期間(ミリ秒単位)。

NOTIFY メッセージの送信

DTMF イベントが認識されると、ゲートウェイは、INVITE の Call-Info ヘッダーでネゴシエートされた期間を持つ、このイベントの最初の NOTIFY メッセージをただちに送信します。この最初の NOTIFY メッセージのエンド ビットは 0 に設定されています。その後、次の処理のいずれかを行います。

DTMF イベントの期間がネゴシエートされた期間に満たない場合、発信側ゲートウェイは、duration フィールドにイベントの正確な期間を格納し、エンド ビットが 1 に設定された、このイベントの最終の NOTIFY メッセージを送信します。

DTMF イベントの期間がネゴシエートされた期間を超える場合、発信側ゲートウェイは、初期タイマーが期限切れになってから、このイベントに対する別の NOTIFY メッセージを送信します。更新後の NOTIFY メッセージの期間は、ネゴシエートされた期間の 2 倍になります。イベントは終了していないため、エンド ビットは 0 に設定されます。イベントが最初の更新済み NOTIFY メッセージ内で指定された期間を超えて存続する場合は、ネゴシエートされた期間の 3 倍の期間を持つ、別の更新済み NOTIFY メッセージが送信されます。

DTMF イベントの期間がネゴシエートされた期間と完全に一致する場合、DTMF イベントの末尾が、タイマーが期限切れになる前に発生したか、期限切れになってから発生したかに応じて、上記の 2 つの処理のいずれかを行います。

たとえば、ネゴシエートされた期間が 600 ms の場合は、DTMF イベントが発生すると、期間が 600 ms に設定された最初の NOTIFY メッセージがただちに送信されます。その後、この期間のタイマーが起動します。

DTMF イベントが 300 ms だけ存続する場合は、タイマーが停止してから、期間が 300 ms に設定された最終の NOTIFY メッセージが送信されます。

DTMF イベントが 600 ms を超えて(1000 ms)存続する場合は、タイマーが期限切れになると、期間が 1200 ms に設定された更新済み NOTIFY メッセージが送信され、タイマーが再起動します。DTMF イベントが終了すると、期間が 1000 ms に設定された最終の NOTIFY メッセージが送信されます。

各 DTMF イベントは、少なくとも 2 つの NOTIFY(最初の NOTIFY メッセージと最終の NOTIFY メッセージ)に対応します。また、イベントの合計期間がネゴシエートされた max-duration 間隔を超える場合には、いくつかの更新済み NOTIFY が関係する可能性があります。一般に、DTMF イベントの存続期間は 1000 ms 未満であるため、 notify telephone-event コマンドを使用して duration を 1000 ms を超える値に設定すると、送信される NOTIFY メッセージの合計数が減ります。 notify telephone-event コマンドのデフォルト値は 2000 ms です。

NOTIFY メッセージの受信

着信側ゲートウェイが NOTIFY メッセージを受信すると、DTMF トーンが鳴り、タイマーが duration フィールドの値に設定されます。その後、次の処理のいずれかを行います。

DTMF イベントの最終の NOTIFY メッセージを受信した場合は、トーンが停止します。

更新を受信した場合は、duration フィールドに従ってタイマーを更新します。

タイマーが期限切れになる前に更新または最終の NOTIFY メッセージを受信しなかった場合は、トーンが停止し、最終の NOTIFY メッセージを受信するまで、同じ DTMF イベントまたは DTMF ディジットの後続の NOTIFY メッセージをすべて無視します。

現在の DTMF イベントの最終の NOTIFY メッセージを受信する前に異なる DTMF イベントの NOTIFY メッセージを受信した場合は(ほとんどありません)、現在のトーンが停止し、新しいトーンが鳴ります。最終の NOTIFY メッセージは DTMF イベントごとに必要であり、ゲートウェイは、このメッセージの送信に成功して 200 OK を受信するまで、他の NOTIFY メッセージを送信できないため、このようなケースはほとんどありません。


) NOTIFY ベースのアウトオブバンド DTMF リレーを DTMF リレー方式として使用している間は、インバンド トーンは渡されません。


2 つのコマンドを使用して、ダイヤルピア上の NOTIFY ベースのアウトオブバンド DTMF リレーをイネーブルまたはディセーブルにすることができます。コマンドで DTMF リレーをイネーブルにする場合は、INVITE メッセージを使用して、この機能を相手側にアドバタイズします。発信側と着信側の SIP ゲートウェイの両方で機能を設定する必要もあります。3 番目のコマンドは、DTMF リレーのステータスを確認するために使用できます。

dtmf-relay(VoIP)

notify telephone-event

show sip-ua status

SIP KPML ベース アウトオブバンド DTMF リレー

SIP ゲートウェイにおける会議以外のコール、SIP 製品および SIP 電話間の相互運用には、KPML のサポートが必要です。ダイヤル ピアで KPML を設定すると、ゲートウェイは Allow-Events ヘッダー内の「kpml」とともに INVITE メッセージを送信します。現在、すべてが設定済みの DTMF 方式は、発信 INVITE で認識され、送信されます。rtp-nte(RFC 2833)、sip-notify、および sip-kpml を設定する場合、コール情報ヘッダー、KPML を含む Allow-Events ヘッダー、および rtp-nte ペイロードを含む sdp が発信 INVITE に含まれます。

DTMF ネゴシエーションは、着信ダイヤル ピア設定の一致に基づいて実行されます。ゲートウェイがネゴシエートするのは、cisco-rtp のみ、rtp-nte のみ、rtp-nte および kpml、kpml のみ、または sip-notify のみの場合のいずれかです。複数のアウトオブバンド DTMF 方式を設定する場合、プリファレンスは設定された順序で最高から最低になります。DTMF ネゴシエーション方式の種類にかかわらず最初に設定した方式が優先されます。

着信 INVITE で、rtp-nte および KPML がサポートされ、アドバタイズされている場合、ゲートウェイはその双方とネゴシエートします。ただし、この場合ゲートウェイのディジットの受信は rtp-nte DTMF 方式に依存し、SUBSCRIBE for KPML は、ゲートウェイで許容されますが初期化されません。これにより、ゲートウェイでのダブルディジット レポートの問題が防止されます。

次に、KPML に対する INVITE および SUBSCRIBE シーケンスの例を示します。

Sent:
INVITE sip:8888@172.18.193.250:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKC1ECC
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>
Date: Fri, 01 Mar 2002 00:15:59 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
Supported: 100rel,timer,resource-priority,replaces
Min-SE: 1800
Cisco-Guid: 1424162198-736104918-2148455531-3036263926
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1014941759
Contact: <sip:172.18.193.251:5060>
Expires: 180
Allow-Events: kpml, telephone-event
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 221
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 1438 8538 IN IP4 172.18.193.251
s=SIP Call
c=IN IP4 172.18.193.251
t=0 0
m=audio 17576 RTP/AVP 0 19
c=IN IP4 172.18.193.251
a=rtpmap:0 PCMU/8000
a=rtpmap:19 CN/8000
a=ptime:20
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKC1ECC
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Date: Fri, 01 Mar 2002 01:02:34 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
Timestamp: 1014941759
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Require: 100rel
RSeq: 3482
Allow-Events: kpml, telephone-event
Contact: <sip:8888@172.18.193.250:5060>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 221
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 9384 6237 IN IP4 172.18.193.250
s=SIP Call
c=IN IP4 172.18.193.250
t=0 0
m=audio 17468 RTP/AVP 0 19
c=IN IP4 172.18.193.250
a=rtpmap:0 PCMU/8000
a=rtpmap:19 CN/8000
a=ptime:20
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKC1ECC
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Date: Fri, 01 Mar 2002 01:02:38 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
Timestamp: 1014941759
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: kpml, telephone-event
Contact: <sip:8888@172.18.193.250:5060>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 221
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 9384 6237 IN IP4 172.18.193.250
s=SIP Call
c=IN IP4 172.18.193.250
t=0 0
m=audio 17468 RTP/AVP 0 19
c=IN IP4 172.18.193.250
a=rtpmap:0 PCMU/8000
a=rtpmap:19 CN/8000
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:8888@172.18.193.250:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKEB8B
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Date: Fri, 01 Mar 2002 00:16:00 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: kpml, telephone-event
Content-Length: 0
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SUBSCRIBE sip:8888@172.18.193.250:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKFF36
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 103 SUBSCRIBE
Max-Forwards: 70
Date: Fri, 01 Mar 2002 00:16:15 GMT
User-Agent: Cisco-SIPGateway/IOS-12.x
Event: kpml
Expires: 7200
Contact: <sip:172.18.193.251:5060>
Content-Type: application/kpml-request+xml
Content-Length: 327
 
<?xml version="1.0" encoding="UTF-8"?><kpml-request xmlns="urn:ietf:params:xml:ns:kpml-request" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:ietf:params:xml:ns:kpml-request kpml-request.xsd" version="1.0"><pattern persist="persist"><regex tag="dtmf">[x*#ABCD]</regex></pattern></kpml-request>
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SUBSCRIBE sip:172.18.193.251:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.250:5060;branch=z9hG4bK5FE3
From: <sip:8888@172.18.193.250>;tag=39497C-2EA
To: <sip:172.18.193.251>;tag=EA330-F6
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 101 SUBSCRIBE
Max-Forwards: 70
Date: Fri, 01 Mar 2002 01:02:46 GMT
User-Agent: Cisco-SIPGateway/IOS-12.x
Event: kpml
Expires: 7200
Contact: <sip:172.18.193.250:5060>
Content-Type: application/kpml-request+xml
Content-Length: 327
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bKFF36
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Date: Fri, 01 Mar 2002 01:02:51 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 103 SUBSCRIBE
Content-Length: 0
Contact: <sip:172.18.193.250:5060>
Expires: 7200
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.193.250:5060;branch=z9hG4bK5FE3
From: <sip:8888@172.18.193.250>;tag=39497C-2EA
To: <sip:172.18.193.251>;tag=EA330-F6
Date: Fri, 01 Mar 2002 00:16:24 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 101 SUBSCRIBE
Content-Length: 0
Contact: <sip:172.18.193.251:5060>
Expires: 7200
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
NOTIFY sip:172.18.193.250:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bK101EA4
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 104 NOTIFY
Max-Forwards: 70
Date: Fri, 01 Mar 2002 00:16:24 GMT
User-Agent: Cisco-SIPGateway/IOS-12.x
Event: kpml
Subscription-State: active
Contact: <sip:172.18.193.251:5060>
Content-Length: 0
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
NOTIFY sip:172.18.193.251:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.250:5060;branch=z9hG4bK6111
From: <sip:8888@172.18.193.250>;tag=39497C-2EA
To: <sip:172.18.193.251>;tag=EA330-F6
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 102 NOTIFY
Max-Forwards: 70
Date: Fri, 01 Mar 2002 01:02:51 GMT
User-Agent: Cisco-SIPGateway/IOS-12.x
Event: kpml
Subscription-State: active
Contact: <sip:172.18.193.250:5060>
Content-Length: 0
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.193.250:5060;branch=z9hG4bK6111
From: <sip:8888@172.18.193.250>;tag=39497C-2EA
To: <sip:172.18.193.251>;tag=EA330-F6
Date: Fri, 01 Mar 2002 00:16:32 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 102 NOTIFY
Content-Length: 0
 
//-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
NOTIFY sip:172.18.193.250:5060 SIP/2.0
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bK1117DE
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 105 NOTIFY
Max-Forwards: 70
Date: Fri, 01 Mar 2002 00:37:33 GMT
User-Agent: Cisco-SIPGateway/IOS-12.x
Event: kpml
Subscription-State: active
Contact: <sip:172.18.193.251:5060>
Content-Type: application/kpml-response+xml
Content-Length: 113
 
<?xml version="1.0" encoding="UTF-8"?><kpml-response version="1.0" code="200" text="OK" digits="1" tag="dtmf"/>
 
/-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.193.251:5060;branch=z9hG4bK1117DE
From: <sip:172.18.193.251>;tag=EA330-F6
To: <sip:8888@172.18.193.250>;tag=39497C-2EA
Date: Fri, 01 Mar 2002 01:24:08 GMT
Call-ID: 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
CSeq: 105 NOTIFY
Content-Length: 0
 

...

非対称 SDP に対する SIP サポート

非対称 SDP に対する SIP サポート機能は、SIP ゲートウェイがその優先順位と異なるペイロードのオファーまたは返答を受信し、およびそのペイロードが使用されない間、非対称として処理することを可能にします。ゲートウェイは、ペイロードを DTMF イベントとダイナミック コーデックに対して生成される RTP パケットを受信し生成するものとして解釈します。ゲートウェイは、DTMF イベントおよびダイナミック コーデック ペイロード値の受信を予期します。これらは最初、ゲートウェイが要求/応答メッセージ内で送信したものです。このようにして、ゲートウェイは受信したオファーに対する返答内の優先ペイロードをアドバタイズします。

ディレイド メディア(delayed media)の場合は、ゲートウェイが SDP を含まない INVITE メッセージを受信すると、対応する応答またはオファーが SDP 内の優先ペイロードを送信します。ゲートウェイは、リモート エンドが受信した RTP パケット内の提供されたペイロードを使用することを予期します。ゲートウェイは、生成したすべての RTP パケットの返答で受信したペイロードが使用されていない間は、このペイロード タイプを使用します。

下記に示す項では、非対称ペイロード処理対応の Universal Agent Client(UAC)および Universal Agent Server(UAS)ゲートウェイの動作について説明します。

「非対称 DTMF ペイロード対応の UAC の動作」

「非対称 DTMF ペイロード対応の UAS の動作」

「非対称ダイナミック コーデック ペイロード対応の UAC の動作」

「非対称ダイナミック コーデック ペイロード対応の UAS の動作」

非対称 DTMF ペイロード対応の UAC の動作

UAC ゲートウェイが INVITE メッセージを送信する場合、UAC ゲートウェイは優先 DTMF リレー ペイロードおよび方式をアドバタイズします。ただし、ゲートウェイが異なる DTMF ペイロードを持つ 18x/2xx 応答を受信した場合、ゲートウェイは、まず関連する DTMF リレー方式がその応答に対してネゴシエートできるかどうかを確認します。ネゴシエーションに成功すると、ゲートウェイは新しいペイロードを使用できるかどうかを確認します。新しいゲートウェイを使用できる場合、ゲートウェイは受信したペイロードを、生成するすべての RTP(RFC 2833)イベント パケットに使用します。同時に、ゲートウェイはリモート エンドが、ゲートウェイがその元の要求でアドバタイズした優先ペイロードとともにパケットを送信することを予期します。

リモート エンドが返答で要求した新しいペイロードをゲートウェイが使用できない場合、要求された DTMF リレー方式に対する DTMF リレー ネゴシエーションは失敗します。

図 2 に、非対称 DTMF ペイロードを使用した場合の Universal Access Controller(UAC) のコール動作の概要を示します。

図 2 非対称 DTMF ペイロード対応の UAC の動作

非対称 DTMF ペイロード対応の UAS の動作

ゲートウェイが優先 DTMF リレー方式およびペイロードを持つ INVITE メッセージを受信し、要求された DTMF リレーに対するネゴシエートが成功すると、ゲートウェイは要求された DTMF ペイロードが使用できるかどうかを確認します。DTMF ペイロードが使用できる場合、ゲートウェイは適合するダイヤル ピアで優先ペイロードが設定されているかどうかを確認します。

優先ペイロードが設定されていない場合、ゲートウェイはその特定の DTMF リレー方式に対してゲートウェイのデフォルト値を使用します。優先ペイロードが元の要求と異なる場合は、ゲートウェイが生成するすべての RTP(RFC 2833)イベント パケットに元の要求のペイロードが使用されます。ゲートウェイは、元の要求への応答に SDP の優先ペイロードを使用して返答します。ゲートウェイはリモート エンドが、ゲートウェイがその返答でアドバタイズした優先ペイロードとともにパケットを送信することを予期します。

ゲートウェイがディレイド メディア(delayed media)の要求を受信した場合、ゲートウェイはその応答に優先 DTMF リレーおよびペイロードを提供します。リモート エンドが同じ DTMF リレーと異なるペイロードを使用して応答した場合、この新しいペイロードが RTP RFC 2833 イベント パケットの生成に使用されます。ゲートウェイはリモート エンドが、ゲートウェイがその返答でアドバタイズした優先ペイロードとともにパケットを送信することを予期します。

図 3 に、非対称 DTMF ペイロードを使用した場合の Universal Access Server(UAS) のコール動作の概要を示します。

図 3 非対称 DTMF ペイロード対応の UAS の動作

非対称ダイナミック コーデック ペイロード対応の UAC の動作

UAC ゲートウェイが INVITE メッセージを送信する場合、ゲートウェイは優先ダイナミック コーデックをアドバタイズします。ただし、ゲートウェイが異なる DTMF ペイロードを持つ 18x/2xx 応答を受信した場合、ゲートウェイは、まず返答の SDP メッセージ内の新しいペイロードが、アドバタイズされた同じダイナミック コーデックで使用されているかどうかを確認します。新しいペイロードが同じコーデックであり、ダイナミック ペイロードが使用できる場合は、ゲートウェイにより生成されるすべての RTP ダイナミック コーデック パケットに受信されたペイロードが使用されます。同時に、ゲートウェイはリモート エンドが、ゲートウェイがその元の要求でアドバタイズした優先ペイロードとともにパケットを送信することを予期します。

リモート エンドが返答で要求した新しいペイロードをゲートウェイが使用できない場合、その特定のダイナミック コーデックに対するコーデック ネゴシエーションは失敗します。

図 4 に、非対称ダイナミック コーデック ペイロードを使用した場合の UAC のコール動作の概要を示します。

図 4 非対称ダイナミック コーデック ペイロード対応の UAC の動作

非対称ダイナミック コーデック ペイロード対応の UAS の動作

ゲートウェイがダイナミック コーデックおよびペイロードを持つ INVITE メッセージを受信し、要求されたダイナミック コーデックに対するネゴシエートが成功すると、ゲートウェイはその INVITE メッセージへの応答に同じペイロードを使用します。ゲートウェイは、応答メッセージ内で異なるダイナミック コーデックを生成できません。

Cisco ソフトウェア リリース 12.4(15)T より、ゲートウェイがディレイド メディア(delayed media)要求を受信した場合、その応答で優先ダイナミック コーデックおよびペイロードを提供するようゲートウェイを設定できるようになりました。リモート エンドが同じダイナミック コーデックと異なるペイロードを使用して応答した場合、この新しいペイロードがコーデック RTP パケットの生成に使用されます。ゲートウェイはリモート エンドが、ゲートウェイがその返答でアドバタイズした優先ペイロードとともにパケットを送信することを予期します。

図 5 に、非対称ダイナミック コーデック ペイロードを使用した場合の UAS のコール動作の概要を示します。

図 5 非対称ダイナミック コーデック ペイロード対応の UAS の動作

SIP DTMF 機能の設定方法

ここでは、次の各手順について説明します。

「MTP またはトランスコーダ ゲートウェイに接続するゲートウェイにおけるパススルーの設定」

「SIP シグナリング経由の DTMF イベントの設定」

「NTE を使用した SIP コール対応 DTMF リレーの設定」

「DTMF トーン生成用 SIP INFO 方式の設定」

「SIP NOTIFY ベースのアウトオブバンド DTMF リレーの設定」

「SIP KPML ベースのアウトオブバンド DTMF リレーの設定」

「SDP に対する SIP サポートの設定」

「トラブルシューティングのヒント」


) • 各手順を実行する前に、次の情報を理解してください。

「SIP DTMF の制約事項」

「SIP DTMF の前提条件」

手順の支援情報については、上記の検証およびトラブルシューティングの項を参照してください。


 

MTP またはトランスコーダ ゲートウェイに接続するゲートウェイにおけるパススルーの設定

MTP またはトランスコーダを搭載していないが、それらを搭載している他のゲートウェイに接続するゲートウェイ上で RFC 2833 DTMF MTP パススルーを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. dtmf-relay rtp-nte

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 103 voip

特定の VoIP ダイヤルピアで、ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

dtmf-relay rtp-nte

 

Router(config-dial-peer-voice)# dtmf-relay rtp-nte

Named Telephony Event(NTE)ペイロード タイプを持つ RTP を使用してテレフォニー インターフェイスと IP ネットワーク間を DTMF トーンをリレーするようにゲートウェイを設定します。

ステップ 5

exit

 

Router(config-dial-peer-voice)# exit

現在のコンフィギュレーション モードを終了します。


) この機能と Cisco Fax Relay の両方を使用する場合、両方とも同じデフォルトのペイロード タイプ(96 または 97)を、同じ RTP セッションで使用するため、ファックス リレーに異なるペイロード タイプの使用をゲートウェイがネゴシエートするよう、ゲートウェイを設定する必要がある場合があります。


ゲートウェイが異なるペイロード タイプを使用するように設定するには、 rtp payload-type コマンドを使用します。次に例を示します。

Router(config-dial-peer)# rtp payload-type nte 105

SIP シグナリング経由の DTMF イベントの設定

SIP シグナリング経由の DTMF イベント機能を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. sip-ua

4. timers notify number

5. retry notify number

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

sip-ua

 

Router(config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 4

timers notify number

 

Router(config-sip-ua)# timers notify 100

ユーザ エージェントが Notify メッセージを再送信するまでに待機する合計時間を設定します。引数は次のとおりです。

number :再試行までの時間(ミリ秒)。範囲:100 ~ 1000。デフォルト:500。

ステップ 5

retry notify number

 

Router(config-sip-ua)# retry notify 6

送信を開始した、または Refer 要求を送信したユーザ エージェントに Notify メッセージが再送信される回数を設定します。引数は次のとおりです。

number :再試行回数。範囲:1 ~ 10。デフォルト:10。

ステップ 6

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

NTE を使用した SIP コール対応 DTMF リレーの設定

ここでは、次の手順について説明します。

「NTE を使用した SIP コール対応 DTMF リレーの設定」

「MTP またはトランスコーダ ゲートウェイに接続するゲートウェイにおけるパススルーの設定」

NTE を使用した SIP コール対応 DTMF リレーの設定

NTE を使用した SIP コール対応 DTMF リレー機能を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice number voip

4. session protocol sipv2

5. dtmf-relay rtp-nte

6. rtp payload-type nte number comfort-noise [ 13 | 19 ]

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice number voip

 

Router(config)# dial-peer voice 10 voip

特定のダイヤルピアで、ダイヤルピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

session protocol sipv2

 

Router(config-dial-peer)# session protocol sipv2

パケット ネットワークを使用するローカル ルータとリモート ルータ間のコールで使用するセッション プロトコルを指定します。キーワードは次のとおりです。

sipv2 :ダイヤル ピアが IETF SIP を使用。このキーワードと SIP オプションを使用します。

ステップ 5

dtmf-relay rtp-nte

 

Router(config-dial-peer)# dtmf-relay rtp-nte

H.323 または SIP ゲートウェイが、電話インターフェイス/IP ネットワーク間で DTMF トーンをリレーする方法を指定します。キーワードは次のとおりです。

rtp-nte :NTE ペイロード タイプを持つ RTP を使用してトーンを転送。

ステップ 6

rtp payload-type nte number comfort-noise [ 13 | 19 ]

 

Router(config-dial-peer)# rtp payload-type nte 100 comfort-noise 13

RTP パケットのペイロード タイプを特定します。キーワードと引数は次のとおりです。

nte number :Named Telephony Event(NTE)。範囲:96 ~ 127。デフォルト:101。

comfort-noise :コンフォート ノイズの RTP ペイロード タイプ。RTP Payload for Comfort Noise July 2001 ドラフトで構成されるゲートウェイに接続する場合は、13 を使用します。バージョン 3.4.32 よりも前の DSPware を使用する古い Cisco ゲートウェイに接続する場合は、19 を使用します。

ステップ 7

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

DTMF トーン生成用 SIP INFO 方式の設定

この機能を設定したり、イネーブルまたはディセーブルにはできません。SIP INFO 方式統計情報を含む SIP 統計情報を表示するには、特権 EXEC モードで show sip-ua statistics コマンドおよび show sip-ua status コマンドを使用します。SIP INFO 方式の統計情報については、次に示すフィールドを参照してください。

SP Response Statistics の下の OkInfo 0/0 には、INFO 要求に対する成功した応答が表示されます。

IP Total Traffic Statistics の下の Info 0/0 には、ゲートウェイにより送受信された INFO メッセージの数が表示されます。


) • これらの show コマンドの出力例については、「MTP またはトランスコーダ ゲートウェイに接続するゲートウェイにおけるパススルーの設定」を参照してください。

sip-ua statistics コマンドのカウンタをリセットするには、 clear sip-ua statistics コマンドを使用します。


 

SIP NOTIFY ベースのアウトオブバンド DTMF リレーの設定

SIP NOTIFY ベース アウトオブバンド DTMF リレー機能を設定するには、次の手順を実行します。


) シスコ独自の NOTIFY ベース アウトオブバンド DTMF リレーは、インバンド DTMF をサポートしないデバイスにサポートを追加します。この設定は、発信、終端の両方のゲートウェイで完了する必要があります。この設定により、SIP Invites または 18x か 200 Response メッセージ内の SIP NOTIFY メッセージを使用して DTMF トーンが転送されます。


手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. dtmf-relay sip-notify

5. exit

6. sip-ua

7. notify telephone-event max-duration time

8. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 29 voip

指定されたダイヤルピアで、ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

dtmf-relay sip-notify

 

Router(config-dial-peer)# dtmf-relay sip-notify

SIP NOTIFY メッセージを使用して DTMF トーンを転送します。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

ステップ 6

sip-ua

 

Router (config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 7

notify telephone-event max-duration time

 

Router(config-sip-ua)# notify telephone-event max-duration 2000

単一の DTMF イベントに対する 2 つの連続した NOTIFY メッセージ間で許容される最大時間間隔を設定します。キーワードと引数は次のとおりです。

max-duration time :単一の DTMF イベントに対する 2 つの連続した NOTIFY メッセージ間で許容される時間(ミリ秒)。範囲:500 ~ 3000。デフォルト:2000。

ステップ 8

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

SIP KPML ベースのアウトオブバンド DTMF リレーの設定

SIP KPML アウトオブバンド DTMF リレー機能を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. dtmf-relay sip-kpml

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 29 voip

指定されたダイヤルピアで、ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 4

dtmf-relay sip-kpml

 

Router(config-dial-peer)# dtmf-relay sip-kpml

SIP KPML メッセージを使用して DTMF トーンを転送します。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

SIP DTMF サポートの確認

SIP DTMF サポートを確認するには、必要に応じて次の手順を実行します(コマンドは、アルファベット順に示しています)。

手順の概要

1. show running-config

2. show sip-ua retry

3. show sip-ua statistics

4. show sip-ua status

5. show sip-ua timers

6. show voip rtp connections

7. show sip-ua calls

手順の詳細


ステップ 1 show running-config

ダイヤル ピアの設定を表示するには、このコマンドを使用します。

次に、ダイヤル ピア 123 で設定された dtmf-relay sip-notify コマンドの出力例を示します。

Router# show running-config
 
.
.
.
dial-peer voice 123 voip
destination-pattern [12]...
monitor probe icmp-ping
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
 

次に、ダイヤル ピアで DTMF リレーおよび NTE が設定された場合の出力例を示します。

Router# show running-config
 
!
dial-peer voice 1000 pots
destination-pattern 4961234
port 1/0/0
!
dial-peer voice 2000 voip
application session
destination-pattern 4965678
session protocol sipv2
session target ipv4:192.0.2.34
dtmf-relay rtp-nte
! RTP payload type value = 101 (default)
!
dial-peer voice 3000 voip
application session
destination-pattern 2021010101
session protocol sipv2
session target ipv4:192.0.2.34
dtmf-relay rtp-nte
rtp payload-type nte 110
! RTP payload type value = 110 (user assigned)
!
 

ステップ 2 show sip-ua retry

SIP リレー統計情報を表示するには、このコマンドを使用します。

Router# show sip-ua retry
 
SIP UA Retry Values
invite retry count = 6 response retry count = 1
bye retry count = 1 cancel retry count = 1
prack retry count = 10 comet retry count = 10
reliable 1xx count = 6 notify retry count = 10
 

ステップ 3 show sip-ua statistics

SIP の応答、トラフィック、および再試行に関する統計情報を表示するには、このコマンドを使用します。


ヒント show sip-ua statistics の表示内容のカウンタをリセットするには、clear sip-ua statistics コマンドを使用します。


Router# show sip-ua statistics
 
SIP Response Statistics (Inbound/Outbound)
Informational:
Trying 4/2, Ringing 2/1,
Forwarded 0/0, Queued 0/0,
SessionProgress 0/0
Success:
OkInvite 1/2, OkBye 0/1,
OkCancel 1/0, OkOptions 0/0,
OkPrack 2/0, OkPreconditionMet 0/0,
OkNotify 1/0, 202Accepted 0/1
Redirection (Inbound only):
MultipleChoice 0, MovedPermanently 0,
MovedTemporarily 0, SeeOther 0,
UseProxy 0, AlternateService 0
Client Error:
BadRequest 0/0, Unauthorized 0/0,
PaymentRequired 0/0, Forbidden 0/0,
NotFound 0/0, MethodNotAllowed 0/0,
NotAcceptable 0/0, ProxyAuthReqd 0/0,
ReqTimeout 0/0, Conflict 0/0, Gone 0/0,
LengthRequired 0/0, ReqEntityTooLarge 0/0,
ReqURITooLarge 0/0, UnsupportedMediaType 0/0,
BadExtension 0/0, TempNotAvailable 0/0,
CallLegNonExistent 0/0, LoopDetected 0/0,
TooManyHops 0/0, AddrIncomplete 0/0,
Ambiguous 0/0, BusyHere 0/0
RequestCancel 1/0, NotAcceptableMedia 0/0
Server Error:
InternalError 0/1, NotImplemented 0/0,
BadGateway 0/0, ServiceUnavail 0/0,
GatewayTimeout 0/0, BadSipVer 0/0,
PreCondFailure 0/0
Global Failure:
BusyEverywhere 0/0, Decline 0/0,
NotExistAnywhere 0/0, NotAcceptable 0/0
SIP Total Traffic Statistics (Inbound/Outbound) /* Traffic Statistics
Invite 3/2, Ack 3/2, Bye 1/0,
Cancel 0/1, Options 0/0,
Prack 0/2, Comet 0/0,
Notify 0/1, Refer 1/0
Retry Statistics /* Retry Statistics
Invite 0, Bye 0, Cancel 0, Response 0,
Prack 0, Comet 0, Reliable1xx 0, Notify 0
 

次に、DTMF トーン生成用 SIP INFO 方式機能の設定を確認する出力例を示します。

Router# show sip-ua statistics
 
SIP Response Statistics (Inbound/Outbound)
Informational:
Trying 1/1, Ringing 0/0,
Forwarded 0/0, Queued 0/0,
SessionProgress 0/1
Success:
OkInvite 0/1, OkBye 1/0,
OkCancel 0/0, OkOptions 0/0,
OkPrack 0/0, OkPreconditionMet 0/0
OkSubscibe 0/0, OkNotify 0/0,
OkInfo 0/0, 202Accepted 0/0
Redirection (Inbound only):
MultipleChoice 0, MovedPermanently 0,
MovedTemporarily 0, SeeOther 0,
UseProxy 0, AlternateService 0
Client Error:
BadRequest 0/0, Unauthorized 0/0,
PaymentRequired 0/0, Forbidden 0/0,
NotFound 0/0, MethodNotAllowed 0/0,
NotAcceptable 0/0, ProxyAuthReqd 0/0,
ReqTimeout 0/0, Conflict 0/0, Gone 0/0,
LengthRequired 0/0, ReqEntityTooLarge 0/0,
ReqURITooLarge 0/0, UnsupportedMediaType 0/0,
BadExtension 0/0, TempNotAvailable 0/0,
CallLegNonExistent 0/0, LoopDetected 0/0,
TooManyHops 0/0, AddrIncomplete 0/0,
Ambiguous 0/0, BusyHere 0/0,
BadEvent 0/0
Server Error:
InternalError 0/0, NotImplemented 0/0,
BadGateway 0/0, ServiceUnavail 0/0,
GatewayTimeout 0/0, BadSipVer 0/0
Global Failure:
BusyEverywhere 0/0, Decline 0/0,
NotExistAnywhere 0/0, NotAcceptable 0/0
SIP Total Traffic Statistics (Inbound/Outbound)
Invite 0/0, Ack 0/0, Bye 0/0,
Cancel 0/0, Options 0/0,
Prack 0/0, Comet 0/0,
Subscribe 0/0, Notify 0/0,
Refer 0/0, Info 0/0
Retry Statistics
Invite 0, Bye 0, Cancel 0, Response 0, Notify 0
 

ステップ 4 show sip-ua status

このコマンドを使用して、SIP ユーザ エージェントのステータスを表示します。

Router# show sip-ua status
 
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP max-forwards : 6
SIP DNS SRV version: 2 (rfc 2782)
SDP application configuration:
Version line (v=) required
Owner line (o=) required
Session name line (s=) required
Timespec line (t=) required
Media supported: audio image
Network types supported: IN
Address types supported: IP4
Transport types supported: RTP/AVP udptl
 

次に、電話イベントに対する連続した NOTIFY メッセージ間の時間間隔が、デフォルトの 2000 ミリ秒である場合の出力例を示します。

Router# show sip-ua status
 
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 6
SIP DNS SRV version: 2 (rfc 2782)
NAT Settings for the SIP-UA
Role in SDP: NONE
Check media source packets: DISABLED
Maximum duration for a telephone-event in NOTIFYs: 2000 ms
SIP support for ISDN SUSPEND/RESUME: ENABLED
Redirection (3xx) message handling: ENABLED
 
SDP application configuration:
Version line (v=) required
Owner line (o=) required
Timespec line (t=) required
Media supported: audio image
Network types supported: IN
Address types supported: IP4
Transport types supported: RTP/AVP udptl
 

次に、DTMF トーン生成用 SIP INFO 方式機能の設定の出力例を示します。

Router# show sip-ua status
 
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP max-forwards : 6
SIP DNS SRV version: 2 (rfc 2782)
SDP application configuration:
Version line (v=) required
Owner line (o=) required
Session name line (s=) required
Timespec line (t=) required
Media supported: audio image
Network types supported: IN
Address types supported: IP4
Transport types supported: RTP/AVP udptl
 

ステップ 5 show sip-ua timers

このコマンドを使用して、SIP ユーザ エージェント タイマーの現在の設定を表示します。

Router# show sip-ua timers
 
SIP UA Timer Values (millisecs)
trying 500, expires 300000, connect 500, disconnect 500
comet 500, prack 500, rel1xx 500, notify 500
 

ステップ 6 show voip rtp connections

ローカルおよびリモートの Calling ID、IP アドレス、およびポート情報を表示するには、このコマンドを使用します。

ステップ 7 show sip-ua calls

DTMF 方式が SIP-KPML であることを確認するには、このコマンドを使用します。

次に、DTMF 方式が SIP-KPML であることを示す出力例を示します。

router# show sip-ua calls
SIP UAC CALL INFO
 
Call 1
SIP Call ID : 57633F68-2BE011D6-8013D46B-B4F9B5F6@172.18.193.251
State of the call : STATE_ACTIVE (7)
Substate of the call : SUBSTATE_NONE (0)
Calling Number :
Called Number : 8888
Bit Flags : 0xD44018 0x100 0x0
CC Call ID : 6
Source IP Address (Sig ): 172.18.193.251
Destn SIP Req Addr:Port : 172.18.193.250:5060
Destn SIP Resp Addr:Port: 172.18.193.250:5060
Destination Name : 172.18.193.250
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Mode : flow-through
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 6
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : sip-kpml
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.193.251:17576
Media Dest IP Addr:Port : 172.18.193.250:17468
Orig Media Dest IP Addr:Port : 0.0.0.0:0
 
Number of SIP User Agent Client(UAC) calls: 1
 
SIP UAS CALL INFO
 
Number of SIP User Agent Server(UAS) calls: 0


 

SDP に対する SIP サポートの設定

ここでは、非対称 SDP に対する SIP サポート機能の設定および関連付けの手順について説明します。これらの手順には、次の内容が含まれます。

「ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法」

「ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法」

ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法

SIP ネットワーク上で非対称ペイロードをグローバルに設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. voice service { pots | voatm | vofr | voip }

4. sip

5. asymmetric payload [ dtmf | dynamic-codecs | full ]

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service {pots | voatm | vofr | voip}

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

sip

 

Router(conf-voi-ser)# sip

SIP パラメータ モードを開始します。

ステップ 5

asymmetric payload [dtmf | dynamic-codecs | full]

 

Router(conf-ser-sip)# asymmetric payload dtmf

ゲートウェイが、異なるペイロードを持つ DTMF およびダイナミック コーデック RTP パケットを送受信できるようにします。

この例では、非対称ペイロードは DTMF 向けに設定されています。

ステップ 6

exit

 

Router (conf-ser-sip)# exit

現在のモードを終了します。

ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法

ダイヤルピア上で非対称ペイロードを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag { pots | voatm | vofr | voip }

4. voice-class sip

5. asymmetric payload [ dtmf | dynamic-codecs | full | system ]

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice < tag > {pots | vofr | voip}

 

Router(config)# dialpeer voice 111 voip

ダイヤルピア VoIP コンフィギュレーション モードを開始します。

ステップ 4

voice-class sip

 

Router(conf-dial-peer)# voice-class sip

SIP パラメータ モードを開始します。

ステップ 5

asymmetric payload [dtmf | dynamic-codecs | full]

 

Router(conf-dial-peer)# asymmetric payload dynamic-codecs

ゲートウェイが、異なるペイロードを持つ DTMF およびダイナミック コーデック RTP パケットを送受信できるようにします。

ステップ 6

exit

 

Router (conf-ser-sip)# exit

現在のモードを終了します。

トラブルシューティングのヒント


) 一般的なトラブルシューティングのヒント、および重要な debug コマンドについては、「基本的なトラブルシューティングの手順」を参照してください。


RTP ネームド イベント パケットのデバッグをイネーブルにするには、 debug voip rtp コマンドを使用します。

KPML デバッグをイネーブルにするには、 debug kpml コマンドを使用します。

SIP デバッグをイネーブルにするには、 debug ccsip コマンドを使用します。

コールが確立され、ディジットを押している間にデバッグを収集します。

確立されたコールが KPML を介してディジットを送信しない場合は、 show sip-ua calls コマンドを使用して、ネゴシエーション プロセスに SIP-KPML が含まれていることを確認します。

SIP DTMF 機能の設定例

ここでは、次の設定例について説明します。

「NTE を使用した SIP コール対応 DTMF リレーの例」

「SIP NOTIFY ベースのアウトオブバンド DTMF リレーの例」

「SIP KPML ベースのアウトオブバンド DTMF リレーの例」

「RFC 2833 DTMF MTP パススルーの例」

「非対称 SDP に対する SIP サポートの例」

NTE を使用した SIP コール対応 DTMF リレーの例

RTP-NTE を使用した DTMF リレー

次に、RTP-NTE を使用した DTMF リレーの例を示します。

Router(config)# dial-peer voice 62 voip
Router(config-dial-peer)# session protocol sipv2
Router(config-dial-peer)# dtmf-relay rtp-nte

ペイロード タイプ NTE を使用した RTP

次に、デフォルト値 101 のペイロード タイプ NTE を使用した RTP の例を示します。

Router(config)# dial-peer voice 62 voip
Router(config-dial-peer)# rtp payload-type nte 101

SIP NOTIFY ベースのアウトオブバンド DTMF リレーの例

Current configuration : 3394 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
voice service voip
redirect ip2ip
sip
redirect contact order best-match
 
ip dhcp pool vespa
network 192.168.0.0 255.255.255.0
option 150 ip 192.168.0.1
default-router 192.168.0.1
!
voice call carrier capacity active
!
voice class codec 1
codec preference 2 g711ulaw
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Ethernet0/0
ip address 10.8.17.22 255.255.0.0
half-duplex
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id vespa2 ipaddr 10.8.15.4 1718
!
router rip
network 10.0.0.0
network 192.168.0.0
!
ip default-gateway 10.8.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.0.1
no ip http server
ip pim bidir-enable
!
tftp-server flash:SEPDEFAULT.cnf
tftp-server flash:P005B302.bin
call fallback active
!
call application global default.new
call rsvp-sync
!
voice-port 1/0
!
voice-port 1/1
!
mgcp profile default
!
dial-peer voice 1 pots
destination-pattern 5100
port 1/0
!
dial-peer voice 2 pots
destination-pattern 9998
port 1/1
!
dial-peer voice 123 voip
destination-pattern [12]...
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
!
gateway
!
sip-ua
retry invite 3
retry register 3
timers register 150
registrar dns:myhost3.example.com expires 3600
registrar ipv4:10.8.17.40 expires 3600 secondary
!
telephony-service
max-dn 10
max-conferences 4
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
login
!
no scheduler allocate
end

SIP KPML ベースのアウトオブバンド DTMF リレーの例

router(config-dial-peer)#dtmf
router(config-dial-peer)#dtmf-relay ?
cisco-rtp Cisco Proprietary RTP
h245-alphanumeric DTMF Relay via H245 Alphanumeric IE
h245-signal DTMF Relay via H245 Signal IE
rtp-nte RTP Named Telephone Event RFC 2833
sip-kpml DTMF Relay via KPML over SIP SUBCRIBE/NOTIFY
sip-notify DTMF Relay via SIP NOTIFY messages
 
router(config-dial-peer)#dtmf-relay sip-kpml
router(config-dial-peer)#end
 
%SYS-5-CONFIG_I: Configured from console by console
router#sh run
 
Building configuration...Current configuration : 2430 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mahoney
!
boot-start-marker
boot-end-marker
!
logging buffered 5000000 debugging
!
no aaa new-model
!
resource policy
!
clock timezone EST 0
ip cef
ip name-server 192.0.2.21
ip name-server 192.0.2.22
!
voice-card 0
!
voice service voip
sip
min-se 90
registrar server
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
codec preference 5 g726r16
codec preference 6 g726r24
codec preference 7 g726r32
codec preference 8 g723ar53
codec preference 9 g723ar63
!
!
voice register pool 1
id ip 192.0.2.168 mask 0.0.0.0
dtmf-relay rtp-nte
!
!
interface FastEthernet0/0
ip address 172.18.193.250 255.255.255.0
no ip proxy-arp
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 172.20.118.129
ip route 0.0.0.0 0.0.0.0 192.0.2.1
ip route 0.0.0.0 0.0.0.0 172.18.193.1
!
ip http server
!
control-plane
!
voice-port 2/0
!
voice-port 2/1
!
voice-port 2/2
.
.
.
voice-port 2/22
!
voice-port 2/23
!
!
dial-peer voice 1 pots
destination-pattern 8888
port 2/1
!
dial-peer voice 9999 voip
destination-pattern 9999
session protocol sipv2
session target ipv4:192.0.2.228
dtmf-relay sip-kpml
codec g711ulaw
!
dial-peer voice 5555555 voip
destination-pattern 5555555
session protocol sipv2
session target ipv4:172.18.193.97
codec g711ulaw
!
dial-peer voice 36 voip
destination-pattern 36601
session protocol sipv2
session target ipv4:172.18.193.98
codec g711ulaw
!
dial-peer voice 444 voip
destination-pattern 444
session protocol sipv2
session target ipv4:172.18.197.154
codec g711ulaw
!
dial-peer voice 333 voip
destination-pattern 333
session protocol sipv2
session target ipv4:172.18.199.95
!
!
sip-ua
retry invite 3
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
 

RFC 2833 DTMF MTP パススルーの例

次に、SIP ゲートウェイ上での RFC 2833 DTMF MTP パススルー機能の設定例を示します。

dial-peer voice 1000 voip
destination-pattern .T
session protocol sipv2
session target ipv4:10.120.70.10
incoming called-number .T
dtmf-relay rtp-nte
!
sip-ua
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
 

ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法の例

次に、ゲートウェイで非対称 SDP に対する SIP サポートをグローバルに設定する方法の例を示します。

gateway> enable
gateway# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
gateway(config)# voice service voip
gateway(conf-voi-serv)# sip
gateway(conf-serv-sip)# asymmetric payload dtmf

ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法の例

次に、ダイヤル ピアで非対称 SDP に対する SIP サポートを設定する方法の例を示します。

gateway> enable
gateway# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
gateway(config)# dial-peer voice 111 voip
gateway(conf-dial-peer)# voice-class sip
gateway(conf-dial-peer)# asymmetric payload dtmf
 

その他の参考資料

一般的な SIP 参考資料

SIP 機能のロードマップ:Cisco Feature Navigator にアクセスする手順について説明します。また、Cisco IOS リリース別に、そのリリースの SIP 機能を示して説明します。

Session Initiation Protocol(SIP)の基本設定:基本的な SIP テクノロジーのほか、関連資料、規格、MIB、RFC、および技術サポートを受ける方法のリストが掲載されています。