Cisco IOS SIP コンフィギュレーション ガイド
SIP コネクション型メディア(Comedia)、 フォーキング、およびマルチレベル優先順位 およびプリエンプション(MLPP)機能の設定
SIP コネクション型メディア(Comedia)、フォーキング、およびマルチレベル優先順位およびプリエンプション(MLPP)機能の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

SIP コネクション型メディア(Comedia)、フォーキング、およびマルチレベル優先順位およびプリエンプション(MLPP)機能の設定

この章の構成

SIP コネクション型メディア、フォーキング、および Multilevel Precedence and Preemption(MLPP; マルチレベル優先順位およびプリエンプション)の前提条件

SIP コネクション型メディア、フォーキング、および MLPP の制約事項

SIP コネクション型メディア、フォーキング、および MLPP の概要

SIP:SIP 用のコネクション型メディア拡張

対称型 NAT トラバーサル

SDP メッセージの例

対称型 NAT のコール フロー

SIP:マルチレベルの優先順位(プライオリティ)サポート

SIP の説明

SIP の優先順位とサービス ドメイン

SIP のプリエンプション

SIP のネットワーク ソリューションとシステム フロー

メディア フォーキングに対する SIP サポート

メディア ストリーム

複数のコーデックの選択順序とダイナミック ペイロード コーデック

メディア フォーキング アプリケーション

メディア フォーキングの開始

SIP コネクション型メディア、フォーキング、および MLPP 機能を設定する方法

SIP:SIP 用のコネクション型メディア拡張の設定

SIP:マルチレベルの優先順位(プライオリティ)サポートの設定

メディア フォーキングに対する SIP サポートの設定

コーデックの複雑度の設定

ペイロード タイプとダイナミック ペイロード コーデックのマッピング

複数のコーデックの選択順序の設定

SIP 用のコネクション型メディア機能とフォーキング機能の確認

トラブルシューティングのヒント

SIP コネクション型メディア、フォーキング、および MLPP 機能の設定例

SIP 用のコネクション型メディア拡張の例

SIP:マルチレベルの優先順位(プライオリティ)サポートの例

メディア フォーキングに対する SIP サポートの例

その他の参考資料

SIP コネクション型メディア(Comedia)、フォーキング、およびマルチレベル優先順位およびプリエンプション(MLPP)機能の設定

この章では、次の SIP のメディア サポート機能を設定する方法について説明します。

SIP:SIP 用の Connection-Oriented Media(Comedia; コネクション型メディア)拡張

SIP:マルチレベルの優先順位(プライオリティ)サポート

メディア フォーキングに対する SIP サポート

SIP: SIP 用のコネクション型メディア(Comedia)拡張機能の履歴

リリース
変更点

12.2(13)T

この機能が導入されました。

SIP:マルチレベルの優先順位(プライオリティ)サポート機能の履歴

リリース
変更点

12.4(2)T

この機能が導入されました。

メディア フォーキングに対する SIP サポート機能の履歴

リリース
変更点

12.2(15)T

この機能が導入されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

SIP コネクション型メディア、フォーキング、および Multilevel Precedence and Preemption(MLPP; マルチレベル優先順位およびプリエンプション)の前提条件

SIP:SIP 用のコネクション型メディア拡張機能

Network Address Translation(NAT; ネットワーク アドレス変換)を設定します。NAT の設定方法については、『 Configuring Network Address Translation: Getting Started 』を参照してください。

メディア フォーキングに対する SIP サポート機能

SIP メディア アクティビティ タイマーが必要な場合は、ゲートウェイの receive-rtcp タイマー (ゲートウェイで timer receive-rtcpマンドを使用)を設定します。このタイマーでは、コールを監視し、指定した期間(期間は変更可能です)内に Real-Time Control Protocol(RTCP; リアルタイム制御プロトコル)パケットを受信しなかった場合はコールを切断します。

Cisco 2600 シリーズ、Cisco 3600 シリーズ、または Cisco 37xx を使用している場合は、メディア フォーキングが完全に機能するように音声カードを高複雑度動作モード用に設定していることを確認します。

Cisco 7200 シリーズを使用している場合は、音声カードを高複雑度動作モード用に設定していることを確認します。

Cisco AS5300 を使用している場合は、適切なバージョンの VCWare がルータにロードされていることを確認します。メディア フォーキング用の Voice Feature Card(VFC; 音声フィーチャ カード)は、DSPM Voice(C542 または C549)です。

SIP コネクション型メディア、フォーキング、および MLPP の制約事項

SIP:SIP 用のコネクション型メディア拡張機能

この機能では、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)ドラフトで定義されている Session Description Protocol(SDP)メッセージの a=direction:both アトリビュートをサポートしません(ドラフトについては、 http://tools.ietf.org/html/draft-ietf-mmusic-sdp-comedia-00 を参照してください)。

同様に、対応する Command-Line Interface(CLI; コマンドライン インターフェイス)コマンドもありません。SIP ゲートウェイは、a=direction:both が指定された SDP メッセージを受信すると、エンドポイントをアクティブとして処理し、エンドポイントは NAT の内側に存在すると見なします。


) この機能でプロキシ パラレル フォーキングがサポートされるのは、すべてのエンドポイントが SDP を使用せずに 180 メッセージ応答で応答する場合だけです。この機能では、複数のエンドポイントから同時に送信されるメディアを処理しません。


メディア フォーキングに対する SIP サポート機能

次の機能はサポートされません。

IP マルチキャストを使用する機能。

異なるコーデックでストリームを作成する機能。

Transmission Control Protocol(TCP; 伝送制御プロトコル)を経由してメディア フォーキング機能を使用する機能。サポートされるのは、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)だけです。

複数のストリームが使用されているときにファックス コールを行う機能。

複数のストリームが使用されているときにモデム コールを行う機能。

IP-IP ヘアピニング(コールに関連付けられるテレフォニー コール レッグがないため)。

Voice Activity Detection(VAD; 音声アクティビティ検出)を使用していない場合は、メディア フォーキングされたコールを行うときにルータの容量の 10 % を使用できます。Cisco 7200 シリーズに VAD が設定されていない場合は、最大 15 個のチャネルを使用できます。たとえば、1 台の Cisco 2691 では、2 つの T1 がサポートされます。2 つの T1 の 10 %は 4.8 個のコールなので、VAD が設定されていない場合は 4.8 個のメディア フォーキング コールを行うことができます。1 台の Cisco AS5300 では、4 つの T1 がサポートされ、サポートされるコールの合計数は 96 です。96 の 10 %は 9.6 個のコールなので、VAD が設定されていない場合は 9.6 個のメディア フォーキング コールを行うことができます。

次の制約事項がコーデックの使用に適用されます。

サポートされているすべてのプラットフォームに実装されているコーデックは、G.711、G.729、および G.726 です。その他のコーデックはサポートされません。

ダイナミック ペイロード タイプのコーデック(G.726)の場合、ペイロード タイプはコール内のすべてのストリームで同じにする必要があります。これにより、re-Invite メッセージのすべてのストリーム上で同じペイロード タイプにコーデックを確実にマッピングすることができます。

すべてのストリームのコーデックは、同じにする必要があり、 サポートされているコーデックのうちの 1 つである必要があります。 re-Invite メッセージを受信し、フォーキングされたメディア ストリームの m 行に複数のコーデックが指定されている場合、ゲートウェイは、そのリストから最初のストリームに一致するコーデックを見つけようとします。一致するコーデックが見つからない場合、応答でポート番号を 0 に設定してストリームを拒否します。


) コーデックの詳細については、「ペイロード タイプとダイナミック ペイロード コーデックのマッピング」を参照してください。


次の制約事項が、フォーキング機能と音声フィーチャ カードに適用されます。

Cisco 2600 シリーズ ルータ、Cisco 3600 シリーズ ルータ、または Cisco 37xx ルータを使用する場合、フォーキングは、中複雑度動作モード用に設定された High Density Voice Network Module(NM-HDV; 高密度音声ネットワーク モジュール)で一部サポートされます。最大 2 つのストリームがサポートされます。サポートされる使用方法は、両方のストリームに音声だけと、両方のストリームに音声と Dual Tone Multifrequency(DTMF)リレーです。完全な機能を使用するには、NM-HDV を高複雑度動作モード用に設定します。

Cisco 7200 シリーズ ルータを使用する場合、Enhanced High-Capacity Digital Voice ポート アダプタ(PA-VXC-2TE1+ T1/E1)を高複雑度動作モード用に設定する必要があります。

Cisco AS5300 ユニバーサル アクセス サーバを使用する場合、DSPM Voice(C542 および C549)を設定する必要があります。

次の制約事項が DTMF リレーに適用されます。

DTMF リレーは、RFC 2833 の「 RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals 」に規定されているとおりにサポートされます。シスコ独自の DTMF はサポートされません。

DTMF リレーを設定すると、Real-Time Transport Protocol Named Telephony Event(RTP-NTE)ペイロード形式だけをフォーキングされたコールで使用できます。RTP-NTE は、RFC 2833 に規定されています。RTP-NTE は、受信側ゲートウェイでのスプリアス ディジットの生成を防ぎます。

DTMF リレー パケットだけを含んでいるストリームは、2 ストリーム コールだけで使用でき、2 番目のストリームとして確立する必要があります。

フォーキングされた音声だけのストリームおよび音声と DTMF リレーのストリームは、すべて同じコーデックを使用する必要があります。

次の制約事項がメディア ストリームに適用されます。

複数の Domain Name System(DNS; ドメイン ネーム システム)メディア クエリーは、すべてのメディア ストリームでサポートされません。DNS クエリーは、最初のストリームの Fully Qualified Domain Name(FQDN; 完全修飾ドメイン名)に対してだけ実行されます。

メディア ストリームの作成および削除は、re-Invite メッセージだけで行います。コマンドライン インターフェイス(CLI)では作成しません。

3 つのストリームを同時に Digital Signal Processor(DSP; デジタル シグナル プロセッサ)に送信できるので、最大 3 つの VoIP メディア ストリームがサポートされます。

ストリームの数が 1 つのコール(つまり、従来の セカンド パーティ コール)は、DTMF だけとしてセットアップできません。

最初のストリームは、他のストリームがアクティブである間は削除できず、保留にすることもできません。

アクティブなストリームのストリーム タイプは変更できません。たとえば、音声だけのストリームを音声と DTMF のストリームに変更できません。

SIP コネクション型メディア、フォーキング、および MLPP の概要

SIP 用のコネクション型メディア機能とフォーキング機能を設定するには、次の概念を理解する必要があります。

「SIP:SIP 用のコネクション型メディア拡張」

「SIP:マルチレベルの優先順位(プライオリティ)サポート」

「メディア フォーキングに対する SIP サポート」

SIP:SIP 用のコネクション型メディア拡張

SIP:SIP 用のコネクション型メディア(Comedia)拡張機能によって、シスコのゲートウェイは、着信 Realtime Transport Protocol(RTP; リアルタイム転送プロトコル)パケットのメディア送信元をチェックでき、エンドポイントは、ネットワークアドレス変換(NAT)の内側または外側に存在することをアドバタイズできます。この機能では、既存の RTP セッションのリモート アドレスとポートを変更および更新する機能がサポートされるので、対称型 NAT トラバーサルを使用できます。

この機能の利点は次のとおりです。

着信 RTP パケットのメディア送信元のアドレスとポートをチェックする機能。これにより、既存のセッションのリモート アドレスとポートを更新できます。

NAT デバイスが SIP または SDP シグナリングを認識しないネットワークでの相互運用性の拡張。

エンドポイントが NAT の内側または外側に存在することをアドバタイズする機能。

エンドポイントの接続ロールを指定する機能。

SIP 用のコネクション型メディア拡張機能を設定するには、次の概念を理解する必要があります。

「対称型 NAT トラバーサル」

「SDP メッセージの例」

「対称型 NAT のコール フロー」

対称型 NAT トラバーサル

SIP 用のコネクション型メディア(Comedia)拡張機能は、対称型 NAT トラバーサルに次の機能を提供します。

シスコのゲートウェイは、着信(RTP)パケットのメディア送信元をチェックできます。

エンドポイントは、NAT の内側または外側に存在することをアドバタイズできます。

パケットの送信元 IP アドレスを別の IP アドレスにマッピングする NAT には、さまざまな機能と設定があります。NAT は、IP version 4(IPv4)アドレスを維持するのに役立ちます。また、NAT をセキュリティのために使用して、IP アドレスと LAN 構造を NAT の背後に隠すことができます。VoIP エンドポイントは、両方とも NAT の外側、両方とも NAT の内側、または一方が NAT の内側で、他方が NAT の外側に存在する場合があります。

対称型 NAT では、内部 IP アドレスとポートから特定の宛先 IP アドレスとポートへのすべての要求は、同じ外部 IP アドレスとポートにマッピングされます。この機能には、対称型 NAT トラバーサルに対する追加機能が用意されています。

コネクション型メディア拡張を実装する前は、コールをセットアップするプロトコル メッセージを信号で示す SIP と RTP(VoIP コールのオーディオ部分を転送するメディア ストリーム)両方に対し、NAT トラバーサルは認証確認を提示していました。NAT の背後にあるクライアントとオープン インターネット上にあるクライアントに接続しているエンドポイントには、SIP メッセージの SDP 部分で受信したアドレッシング情報を信頼するタイミング、または、クライアントから直接パケットを受信するまで待ってから、そのパケットの送信元 IP:port に戻るチャネルを開くのかどうかを判断する方法がありませんでした。VoIP セッションが確立されると、シナリオによっては、エンドポイントは、到達不能アドレスにパケットを送信していました。このようなシナリオは通常、SIP を認識しない NAT ネットワークで発生しました。

SIP の NAT トラバーサルによって示される認証確認に加えて、RTP の NAT トラバーサルでは、クライアントは、そのクライアントが配置されている NAT 環境のタイプを認識する必要があり、RTP ストリームのパブリック アドレスを取得する必要もあります。NAT の外側にあるエンドポイントと内側にあるエンドポイントの間の RTP 接続は、ポイントツーポイント接続として確立する必要があります。外側にあるエンドポイントは、応答の送信先を知るためにクライアントからパケットを受信するまで待つ必要があります。このタイプのセッションを記述するために使用するコネクション型プロトコルは、IETF ドラフトの「 Connection-Oriented Media Transport in SDP 」(draft-ietf-mmusic-sdp-comedia-04.txt)で定義されているように、コネクション型メディア(Comedia)と呼ばれています。

Cisco IOS VoiceXML 機能では、さまざまな NAT タイプとトラバーサルに関する問題に対応するために複数の考えられる SIP ソリューションの中から 1 つのソリューションを実装しています。Cisco IOS VoiceXML を使用すると、ゲートウェイは、リモート エンドとの間で RTP セッションを開始し、NAT を通過してから受信した実際のメディア パケットの送信元アドレスとポートを使用して、既存の RTP セッションのリモート アドレスとポート(raddr:rport)を更新または変更できます。この機能では、「 Connection-Oriented Media Transport in SDP 」(draft-ietf-mmusic-sdp-comedia-04.txt)に定義されている SDP direction(a=direction:<role>)アトリビュートのサポートを実装することによって、RTP セッションのリモート アドレスとポートを変更するようにゲートウェイを設定できます。アトリビュートの有効値は次のとおりです。

active:エンドポイントは、もう一方のエンドポイントから受信したセッション記述の m= 行に指定されているポート番号への接続を開始します。

passive:エンドポイントは、そのエンドポイントからもう一方のエンドポイントに送信したセッション記述の m= 行に指定したポート番号への接続を受け入れます。

both:エンドポイントは、着信接続を受け入れ、もう一方のエンドポイントから受信したセッション記述の m= 行に指定されているポート番号への発信接続を開始します。

この機能では、次の対称型 NAT 用の SIP ユーザ エージェント設定を設定するための CLI コマンドが導入されました。

nat symmetric check-media-src コマンドを使用すると、着信パケットでメディア送信元のアドレスをチェックできます。この機能によってゲートウェイは、送信元アドレスをチェックして、リモート メディア アドレスとポートを使用してメディア セッションを更新できます。

nat symmetric role コマンドを使用すると、接続セットアップ手順でのエンドポイントのロールを指定できます。 role キーワードに次のいずれかの値を設定します。

active :エンドポイントは、もう一方のエンドポイントから受信したセッション記述の m= 行に指定されているポート番号への接続を開始します。

passive :エンドポイントは、そのエンドポイントからもう一方のエンドポイントに送信したセッション記述の m= 行に指定したポート番号への接続を受け入れます。


) シスコの Comedia 実装では、a=direction:both をサポートしていません。シスコのゲートウェイは SDP メッセージで a=direction:both を受信すると、エンドポイントをアクティブと見なします。


SDP メッセージの例

  1. 次に、direction:<role> アトリビュートを passive に設定したセッションを記述している SDP メッセージの例を示します。
v=o
o=CiscoSystemsSIP-GW-UserAgent 5732 7442 IN IP4 10.15.66.43
s=SIP Call
c=IN IP4 10.15.66.43
t=0 0
m=audio 17306 RTP/AVP 0 100
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
a=direction:passive

対称型 NAT のコール フロー

次のコール フロー図では、対称型 NAT トラバーサルのシナリオでのコール セットアップについて説明します。図 1 は、SIP または SDP シグナリングを認識しない NAT デバイスを示しています。SIP エンドポイントは、SDP メッセージでコネクション型メディアの方向ロールを指定していません。発信側ゲートウェイは、 nat symmetric check-media-srcマンドを使用して、メディア送信元を検出し、VoIP RTP セッションをネットワーク アドレス変換された address:port ペアに更新するように設定されています。

図 1 SIP エンドポイントが SDP direction:<role> アトリビュートを指定していない場合

 

図 2 は、SIP または SDP シグナリングを認識しない NAT デバイスを示しています。ただし、SIP エンドポイントは、SDP メッセージでコネクション型メディアの方向ロールを指定しています。発信側ゲートウェイは、 nat symmetric role コマンドを使用して、ネットワークでパッシブ エンティティとして設定されています。パッシブ エンティティは、方向ロール active を受信すると、VoIP RTP セッションをネットワーク アドレス変換された address:port ペアに更新します。

図 2 SIP エンドポイントが SDP direction:<role> を指定している場合

 


) 発信側ゲートウェイの passive または active への設定は、NAT デバイスの設定とは異なる可能性があります。SIP ユーザ エージェントは、SDP の本文で CLI によって設定された方向ロールを示します。メディア パケットのチェックが自動的にイネーブルになるのは、ゲートウェイが方向ロール active または both を受信した場合だけです。


SIP:マルチレベルの優先順位(プライオリティ)サポート

SIP:マルチレベルの優先順位(プライオリティ)サポート機能によって、Cisco IOS ゲートウェイは、他のマルチレベル優先順位およびプリエンプション(MLPP)対応の回線交換ネットワークと相互運用することができます。

MLPP 対応のコールには、プライオリティの高い通信にエンド システムのリソースを割り当てるために、緊急事態と輻輳を処理するアプリケーションがプリエンプション処理するプライオリティの低いコールを決定するために使用するプライオリティ レベルが関連付けられています。この機能は、Cisco IOS ゲートウェイを経由して接続されている Defense Switched Network(DSN)とインターワーキングするときのプリエンプション処理に対応しています。

この機能を設定するには、次の概念を理解することを推奨します。

「SIP の説明」

「SIP の優先順位とサービス ドメイン」

「SIP のプリエンプション」

「SIP のネットワーク ソリューションとシステム フロー」

SIP の説明

SIP:マルチレベルの優先順位(プライオリティ)サポート機能によって、Cisco IOS ゲートウェイは、他の MLPP 対応の回線交換ネットワークと相互運用することができます。米国の Department of Defense(DoD; 米国国防総省)と Defense Information Service Agency(DISA; 国防情報システム局)は、すべての VoIP ネットワーク要素ではこの機能をサポートすることを義務付けています。

MLPP は、正式に許可されたユーザが、対象のステーションへのプライオリティの低い通話コール、または Time Division Multiplexing(TDM; 時分割多重)トランクや会議ブリッジなど、完全にサブスクライブされた共有リソースを経由するプライオリティの低い通話コールをプリエンプション処理できるようにするサービスです。この機能によって、国の緊急事態のときに階級の高い人物が重要な組織および担当者に確実に連絡を取ることができるようになります。

MLPP 加入者からのコールに属する接続とリソースは、優先レベルとドメイン識別子によってマーク付けされ、同じドメイン内の MLPP ユーザから優先順位の高いコールがあった場合にだけ、プリエンプション処理されます。DSN スイッチは、加入者に対して最大の優先レベルをスタティックに設定します。加入者がコールを発信すると、その加入者は最大の優先レベル(何も指定されていない場合)またはユーザが指定した優先レベルでタグ付けされます。

Cisco IOS ゲートウェイは、中継トランキング ネットワーク要素として機能し、着信の優先レベルを発信シグナリングにマッピングします。これによって、加入者線に対して最大レベルを設定するための方式、および Channel Associated Signaling/R2(CAS/R2)タイプのインターフェイスを経由してコールが発信されたときにプレフィクスに基づいてレベルを解釈するための方式は提供されません。

SIP の優先順位とサービス ドメイン

優先順位は、コール サービス要求の優先処理を可能にします。これには、コールへのプライオリティ レベルの割り当てと検証、および優先順位に基づく MLPP サービス要求の処理が含まれます。優先順位割り当ての性質は、割り当てられている優先レベルをコールに適用するかどうかはユーザが選択するという点で、内部の決定によって決まります。MLPP 優先順位は、他の Call Admission Control(CAC; コール アドミッション制御)または Enhanced Emergency Services(E911)サービスとは関係ありません。ユーザによる MLPP 要求の呼び出しは、ダイヤル文字列の専用のダイヤル アクセス コードとセレクタによって行われます。具体的には、優先コールは、文字列プレフィクス NP を使用してユーザから要求されます。P は、要求される優先レベルで、N は、設定済みの MLPP アクセス番号です。

DSN/Public SS7 Network Format(DSN/Q.735)サービス ドメインの優先順位の値の範囲を 表 1 に示します。

 

表 1 DSN/Q.735 優先順位の値の範囲

優先レベル
優先内容

0

フラッシュ オーバーライド

1

フラッシュ

2

即時

3

プライオリティ

4

標準

Defense Red Switched Network(DRSN)サービス ドメインには、 表 2 に示すように 6 つの優先レベルがあります。

 

表 2 DRSN 優先順位の値の範囲

優先レベル
優先内容

0

フラッシュ オーバーライド オーバーライド

1

フラッシュ オーバーライド

2

フラッシュ

3

即時

4

プライオリティ

5

標準

加入者 A(0100)が B(0150)に電話するときに優先レベル(プライオリティ)を特定のコールに明示的に関連付ける場合は、次の番号をダイヤルします。

8555-3-0150

^ ^ ^

| | |___________ 送信先番号

| |_____________ コールの優先順位(プライオリティ)

|__________________ MLPP サービスのプレフィクス

加入者 A が優先レベル 4(標準)が割り当てられている一般顧客の場合、MLPP は自動的にこのコールを標準コールとして処理します。

ただし、SIP と Integrated Services Digital Network(ISDN)シグナリングでは、優先レベルとドメインの名前空間情報は、プロトコル メッセージで個別に伝達されるので、ダイヤルする番号に該当するプレフィクスを付ける必要はありません。

SIP シグナリングでの優先レベル サポート

SIP 信号での MLPP 情報は、Resource-Priority ヘッダーに格納されて伝達されます。ヘッダー フィールドは、呼び出されたまたはコール発信者に割り当てられている優先レベルに応じて優先順位に基づくリソース アクセスを SIP 要求が要求していることを示します。Resource-Priority ヘッダー フィールドの構文は次のとおりです。

Resource-Priority="Resource-Priority" HCOLON Resource-value * (COMMA Resource-value)

Resource-value=namespace "." r-priority

namespace=*(alphanum / "-")

r-priority=*(alphanum / "-")

さまざまなサービス ドメインに対応するためにドラフトでは、次の 3 つの名前空間が定義されています。

dsn:米国 Defense Switched Network と DISA によって採用されています。5 つの優先順位の値 routine、priority、immediate、flash、flash-override が定義されています。

q735:International Telecommunication Union(ITU; 国際電気通信連合)Q.735.3 に基づく Signaling System 7(SS7; No.7 共通線信号方式)ネットワークによって使用されます。5 つの優先順位の値 4、3、2、1、0 が定義されています。

drsn:米国 DRSN によって使用されます。6 つの優先順位の値 routine、priority、immediate、flash、flash-override、flash-override-override が定義されています。

Cisco IOS ゲートウェイでは、3 つすべての名前空間をサポートします。任意のタイプの名前空間をサポートするネットワーク要素とのインターワーキングを容易にするために、名前空間は変更可能になっています。

ISDN シグナリングでの優先レベル サポート

MLPP サービスは、優先順位 Information Element(IE; 情報要素)41 を使用してユーザによって提供され、SETUP メッセージに格納して優先レベル MLPP サービス ドメインを伝達します。標準では、4 ビットで表すレベル値が 5 つ規定されています。ドメイン識別子の値は 1 つしか規定されていません(0000000:dsn)。

DRSN 名前空間の値を ISDN にマッピングすると、標準では flash-override-override に対して一意の値が規定されていないので、問題が発生します。flash-override-override 値は 1000 (8) で表します。4 ビット表現の Most Significant Bit(MSB; 最上位ビット)を使用すると、この情報は、flash-override-override を解釈またはサポートする他の実装に伝達されます。これにより、その実装で最上位ビット(MSB)が使用されていない場合でもそのコールが確実に最高のプライオリティとして処理されるようにすることができます。

SIP のプリエンプション

プリエンプションとは、優先順位の低い既存のコールを終了し、優先順位の高いコールを対象のデバイスに到達させる、または経由させることです。優先処理には、プリエンプション処理されるユーザの通知と確認応答、プリエンプション直後およびプリエンプション処理されたコールの終了直前での共有リソースの予約が含まれます。

プリエンプションは、次の 2 つのどちらかの状態のときに行われます。

着信側が優先順位の低いコールに対応するためにビジーで、そのコールは、発信側からの優先順位の高いコールを成立させるためにプリエンプション処理する必要がある場合

ネットワーク リソースがコールに対応するためにビジーで、いくつかのコールの優先順位が発信側から要求されたコールの優先順位よりも低い場合。これらの優先順位の低いコールのうち、1 つ以上のコールをプリエンプション処理して、優先順位の高いコールを成立させます。

Cisco IOS ゲートウェイでは、どのタイプのプリエンプション サービス ロジックも実装していません。このタスクは、完全に DSN スイッチに委ねられています。

SIP のネットワーク ソリューションとシステム フロー

図 3 に、典型的なユーザ シナリオのシステム フローを示します。

プライオリティの高いユーザからの要求によって、IP 電話などのユーザ端末でのプライオリティの低いユーザによる使用が中断されます。

Primary Rate Interface(PRI; 1 次群速度インターフェイス)は、Cisco IOS ゲートウェイを経由して DSN WAN に接続されています。この説明のために、ユーザ A、B、C、および D は、適切な最大プライオリティ レベルを備えた DSN スイッチで、次のように適切に設定されているとします。

ユーザ A:フラッシュ プライオリティ

ユーザ B:即時プライオリティ

ユーザ C:標準プライオリティ

ユーザ D:フラッシュ プライオリティ

ユーザ C がユーザ A とのコールを確立します。ユーザ C は、そのコールをプライオリティの最大値に設定するために、該当するコードをダイヤルします。ユーザ D はセキュリティ アドバイザに電話しようとしています。ユーザ D のコールには最も高いプライオリティが割り当てられており、図 3 は、このシナリオでの MLPP の全体的な仕組みと、Cisco IOS ゲートウェイでこの新しい機能が MLPP を実現するために果たす役割を示しています。


) MLPP アプリケーションは既存の機能で、SIP を使用する Cisco IOS ゲートウェイとインターワーキングするときに利用されます。


図 3 ネットワーク ソリューションとシステム フロー

 

 

典型的なネットワーク ソリューションとコール フローは次のようになります(図 3 を参照)。

ユーザ C(7777)がユーザ A(1000)に電話をかけ、両者は標準コールを実行中です。

ユーザ D(8888)がユーザ A(1000)に電話しようとしています。ユーザ D(8888)は、オフフック状態にし、1000 をダイヤルします。

DSN スイッチは、ダイヤルされた番号を確認してコールのプライオリティを解釈し、ISDN SETUP メッセージに次のようにマッピングします。

Precedence IE: Level - 0000, Service Domain - 0000000

コールは、Cisco IOS ゲートウェイを経由してルーティングされます。

Cisco IOS ゲートウェイは、ダイヤルされた番号と共に着信コールを渡します。ゲートウェイは、着信 ISDN Precedence IE を Resource-Priority ヘッダーの値にマッピングします。管理システムは、(ゲートウェイで設定されているとおりに)ローカル ポリシーを適用し、レベルを表す名前空間を選択します。

INVITE Resource-Priority: dsn.flash

管理システムは、Dialed Number(DN; 着信番号)を検証し、ユーザ A(1000)がすでに通話中であることを確認します。

管理システムは、ユーザ D(8888)からのコールの優先レベル(フラッシュ)を確認し、このレベルをユーザ A(1000)とユーザ C(7777)との間の既存のコールの優先レベル(標準)と比較します。

管理システムは、ユーザ C(7777)からユーザ A(1000)へのコールをプリエンプション処理することを決定します。

管理システムがユーザ C(7777)の処理を実行する方法は 2 つあります。管理システムがコード変換していて、リアルタイム転送プロトコル(RTP)ストリームが管理システムによって制御されている場合は、管理システムのエンドからプリエンプション トーンを実行します。または、RTP ストリームがエンドポイント ゲートウェイと電話機との間で直接確立されている場合は、適切な理由種別を SIP Reason ヘッダーに挿入し、ゲートウェイまたは DSN スイッチに処理を任せます。管理システムは、新しい Reason ヘッダーの名前空間プリエンプションで、または Q.850 形式で理由種別を示します。

BYE Reason: Preemption; cause=1;text="UA_Preemption"

アプリケーションは、エンドポイント ユーザ A を再使用できるとマーク付けして、ユーザ D のコールをユーザ A に渡します。

ユーザ D(8888)がコールを切断した場合、管理システムはリソースをクリアして、ユーザ A(1000)とユーザ C(7777)の間の既存のコールを維持します。

ユーザ D(8888)がユーザ A(1000)と通話中にさらに優先順位の高いコールが発信された場合、管理システムは、上位プリエンプションを処理します。IP 電話の場合、ユーザのプロファイルが割り当てられている IP 電話からコールが開始された場合、そのコールは、割り当てられているユーザの優先順位を継承します。

図 4図 5 に、それぞれ緩和モードと厳格モードが選択された場合の Resource-Priority(R-P)ヘッダーのコール フローの例を示します。


) 緩和モードでは、SIP 要求の Resource-Priority ヘッダーで受信した名前空間またはプライオリティ値の不明な値は、ゲートウェイで無視されます。要求は、Resource-Priority ヘッダーがない場合と同じように処理されます。


図 4 R-P ヘッダー送信(緩和モード選択時)

 

図 5 R-P ヘッダー送信(厳格モード選択時)

 

メディア フォーキングに対する SIP サポート

メディア フォーキングに対する SIP サポート機能には、1 つのコールに関連付けられている音の複数のストリーム(またはブランチ)を通話中に作成し、そのデータ ストリームを別の宛先に送信する機能が備わっています。この機能によって、サービス プロバイダーは、音声認識、音声認証、Text-to-Speech(TTS; 音声合成)などのテクノロジーを使用して、高度なサービスをエンド ユーザ顧客に提供できます。たとえば、Web ブラウジング アプリケーションは、音声認識テクノロジーと音声合成(TTS)テクノロジーを使用して、予約、出荷の確認、製品の注文を行います。

この機能の利点は、re-Invite メッセージだけで SIP メディア ストリームを作成および削除できることです。CLI は必要ありません。

メディア フォーキングに対する SIP サポート機能を設定するには、次の概念を理解する必要があります。

「メディア ストリーム」

「複数のコーデックの選択順序とダイナミック ペイロード コーデック」

「メディア フォーキング アプリケーション」

「メディア フォーキングの開始」

メディア ストリーム

メディア フォーキングに対する SIP サポート機能では、1 つの DS0 チャネル間で送受信するリアルタイム転送プロトコル(RTP)メディア ストリームを最大 3 つ作成できます。また、ストリームごとに個別のゲートウェイ宛先(IP アドレスまたは UDP ポート)を維持できます。ストリームは双方向です。宛先ゲートウェイから受信したメディアは、DSP で混合されてから、DS0 チャネルに送信され、DS0 から受信した Pulse Code Modulation(パルス符号変調; PCM)は、複製されて宛先ゲートウェイに送信されます。

発信側ゲートウェイは、宛先ゲートウェイ、サードパーティ コール コントローラ、またはその他の SIP シグナリング エンティティから通話中に受信した re-Invite に格納されている Session Description Protocol(SDP)に基づいて、複数のメディア ストリームを確立します。ゲートウェイでのメディア フォーキングでは、1 つの SIP コール レッグしか使用されないので、re-Invite を開始する SIP シグナリング エンティティは、複数の宛先のメディア情報(IP アドレス、ポート番号、ペイロード タイプ、コーデックなど)を 1 つの SDP 記述にまとめることができる必要があります。SDP で複数の m 行を使用して、メディア フォーキングを示します。各 m 行には、1 つのメディア宛先を指定します。


) SIP メディア ストリームは、re-Invite メッセージだけで作成および削除できます。特定の CLI は必要ありません。


1 つのコールに関連付けられている音の複数のストリーム(またはブランチ)を通話中に作成し、そのデータ ストリームを異なる宛先に送信する機能は、3 方向コールまたは会議コールに似ています。ただし、メディア フォーキングされたコールには次のような違いがあります。たとえば、3 方向コールでは、各パーティは他のすべてのパーティからの音が聞こえます。一方、メディア フォーキングされたコールでは、発信側(コントローラ)にだけ他のすべての参加者からの音(音声と DTMF ディジット)が聞こえます。他の参加者に聞こえるのは、発信側からの音だけです。お互いに音は聞こえません。

また、3 方向コールとは異なり、メディア フォーキングされたコールでは、メディア ストリームをゲートウェイで設定できます。3 方向コールでは、コールに参加している他のすべてのパーティに音が送信されます。一方、メディア フォーキングでは、各メディア ストリームを個別に設定できます。たとえば、ある 1 つのパーティに送信するメディア ストリームには音声と DTMF ディジット両方を入れ、別のパーティに送信するメディア ストリームには DTMF ディジットだけを入れることができます。

この機能では、音声、DTMF リレーだけ、音声と DTMF リレーという 3 種類のメディア ストリームをサポートしています。


) 次の説明に加えて、必要に応じて次のドキュメントも参照してください。

コーデックの詳細については、「ペイロード タイプとダイナミック ペイロード コーデックのマッピング」を参照してください。

ペイロード タイプの詳細については、「複数のコーデックの選択順序とダイナミック ペイロード コーデック」を参照してください。

DTMF リレーの詳細については、「DTMF トーン生成用 SIP INFO 方式」を参照してください。


 

音声メディア ストリーム

音声だけのメディア ストリームは、DS0 チャネルからのすべての音を送信します。音は、選択したこコーデックに従って符号化されます。音声だけのメディア ストリームには次の特徴があります。

DTMF ディジットは、インバンド音として送信されます。

すべてのフォーキングされたストリームでは同じコーデックを使用する必要があります。これは、簡易フォーキングと呼ばれます。

コーデック G.711、G.726、G.729 とそのバリアントだけを使用できます。

G.726 コーデックの場合、ダイナミック ペイロード タイプは SDP でネゴシエートされます。SDP メッセージには、ゲートウェイ間で交換される機能情報が格納されます。 ペイロード タイプは、1 つのコールのすべてのストリームで同じにする必要があります。

DTMF リレー メディア ストリーム

DTMF リレーを使用すると、VoIP ゲートウェイ間で信頼性の高いディジット リレーを実現できます。また、DTMF リレーには、RTP パケットで DTMF トーンを転送するための標準化された方法が備わっています。DTMF リレー メディア ストリームには次の特徴があります。

DTMF リレー メディア ストリームは、音声を含んでおらず、コーデックを使用しません。DTMF リレー パケットは、発信側が DTMF ディジットを押したときに送信されます。

フォーキングされた DTMF リレー コールで使用できるのは RTP-NTE だけです。RTP-NTE を使用して、2 つのエンドポイント間で DTMF ディジットなどのテレフォニー イベントが転送されます。RTP-NTE は、受信側ゲートウェイでのスプリアス ディジットの生成を防ぎます。詳細については、RFC 2833 を参照してください。

DTMF リレー ストリームは、2 つのストリームが確立されたコールに対してだけサポートされます。このストリームは、2 番目のストリームにする必要があります。

SDP で DTMF リレー パケットに割り当てられるペイロード タイプの値は、DTMF リレーを使用するすべてのストリームで同じである必要があります。シスコのゲートウェイで使用されるデフォルトのペイロード タイプは 101 です。

音声と DTMF リレーのメディア ストリーム

音声と DTMF リレーのメディア ストリームは、符号化された音声パケットと DTMF リレー パケットの両方を送信します。このメディア ストリームには次の特徴があります。

受信側ゲートウェイは、音声コンポーネントと DTMF コンポーネントを区別できます。

DTMF リレーとは異なり、音声と DTMF リレーのストリームは、フォーキングされたコールで確立されたどのストリームでもサポートされます。

フォーキングされた DTMF リレー コールで使用できるのは RTP-NTE だけです。

すべてのストリームは同じコーデックを使用する必要があります(簡易フォーキング)。

コーデック G.711、G.726、G.729 とそのバリアントだけを使用できます。

G.726 コーデックの場合、ダイナミック ペイロード タイプは SDP でネゴシエートされます。SDP メッセージには、ゲートウェイ間で交換される機能情報が格納されます。 ペイロード タイプは、1 つのコールのすべてのストリームで同じにする必要があります。

SDP で DTMF リレー パケットに割り当てられるペイロード タイプの値は、DTMF リレーを使用するすべてのストリームで同じである必要があります。シスコのゲートウェイで使用されるデフォルトのペイロード タイプは 101 です。

複数のコーデックの選択順序とダイナミック ペイロード コーデック

複数のコーデックを使用する場合、音声クラスを作成して、そこでコーデックの選択順序を定義する必要があります。作成した音声クラスは VoIP ダイヤル ピアに適用できます。 voice class codec グローバル コンフィギュレーション コマンドを使用して、コーデックの選択順序を示す音声クラスを定義できます。次に、 voice-class codec ダイヤル ピア コンフィギュレーション コマンドを使用して、そのクラスを各ダイヤル ピアに適用します。

ダイナミック ペイロード タイプ(g726r16、g726r24)を使用するコーデックがある場合は、Cisco IOS ソフトウェアは、設定に表示される順にペイロード タイプをこのコーデックに割り当てます。このとき、ダイナミック範囲で最初に使用できるペイロード タイプから割り当て始めます。ダイナミック ペイロード タイプの範囲は、96 ~ 127 ですが、Cisco IOS ソフトウェアは、デフォルトで次のペイロード タイプを事前に割り当てています。

 

表 3 コーデックのダイナミック ペイロード タイプと機能

範囲
機能

96

ファックス

97

ファックス ACK

100

Named Signal Event(NSE)

101

Named Telephony Event(NTE)

121

DTMF リレー

122

ファックス リレー

123

CAS

125

ClearChan

上の表に示すように、ペイロード タイプはデフォルトの割り当てによって予約されているので、Cisco IOS ソフトウェアは、ダイヤル ピアの設定の 1 番目のダイナミック コーデックに 98 を自動的に割り当て、2 番目のコーデックに 99、3 番目のコーデックに 102 を自動的に割り当てます。

事前に割り当てられたペイロード タイプの一部は、 modem relay (ダイヤル ピア)コマンドを使用して変更できます。このコマンドでは、コーデックに使用できる使用可能なペイロード タイプを変更できます。

発信側ゲートウェイでの発信コールの場合、ダイヤル ピアによって使用されるコーデック リストに設定されているコーデックはすべて、Invite メッセージの SDP に追加されます。

着信側ゲートウェイでは、Cisco IOS ソフトウェアは、発信側ゲートウェイが Invite メッセージの SDP で指定したダイナミック ペイロード タイプを必ず使用します。この動作によって、ほとんどのコール タイプでペイロード タイプの不整合の問題を回避できます。例外は、ディレイド メディア(delayed media)の Invite メッセージを受信した場合です。ディレイド メディア(delayed media)の Invite は、フォーキング ゲートウェイに re-Invite メッセージを送信する前に着信側ゲートウェイに信号を送るために音声ポータルで使用できます。ディレイド メディア(delayed media)の Invite を使用する場合、その Invite メッセージには、SDP 情報が格納されていないので、着信側ゲートウェイは、自分のコーデックとペイロード タイプをアドバタイズする必要があります。アドバタイズは、応答メッセージ(183 または 200 OK)の SDP で行います。着信側ゲートウェイは、発信側ゲートウェイと同じルールを使用してペイロード タイプをダイナミック コーデックに割り当てます。ただし、事前に割り当てられたダイナミック ペイロード タイプ、またはダイナミック コーデックがダイヤル ピアによって使用されるコーデック リストに表示される順序に違いがある場合は、発信側ゲートウェイと着信側ゲートウェイでのペイロード タイプの割り当てに不整合が生じる可能性があります。着信側ゲートウェイがダイナミック コーデックに異なるペイロード タイプを選択した場合、コールが失敗する可能性があります。

コールの最初のアクティブなストリームで G.726 コーデックが割り当てられた場合、音声ポータルによってディレイド メディア(delayed media)の re-Invite メッセージが 2 番目または 3 番目の着信側ゲートウェイに送信されるシナリオがいくつかあります。発信側ゲートウェイと 2 番目または 3 番目の着信側ゲートウェイが使用する事前に割り当てられたペイロード タイプと、コールに使用されているダイヤル ピアのコーデック リストにダイナミック コーデックが表示される順序が確実に同じになるようにする必要があります。同じでない場合、追加されたメディア ストリームは、ペイロード タイプが一致しない場合は発信側ゲートウェイによって拒否される可能性があります。

メディア フォーキング アプリケーション

音声認識テクノロジーと音声合成(TTS)テクノロジーを使用して、予約、出荷の確認、製品の注文を行う Web ブラウジング アプリケーションは、典型的なメディア フォーキング アプリケーションです。図 6 では、クライアント(パーティ A)は電話機を使用して Web をブラウズします。パーティ A は、音声ポータル(パーティ B)に電話します。そのコールは、発信側ゲートウェイを経由してルーティングされます。音声ポータルは、標準の音声ゲートウェイのように動作し、音声認識機能と TTS 機能を備えた音声応答システムにコールを終端します。この音声応答システムは、パーティ A からの入力を DTMF ディジットまたは音声認識で受け取り、応答(たとえば、Web から取得した株価)をパーティ A に返します。

音声ポータル(パーティ B)は、Third-Party Call Control(3pcc; サードパーティ呼制御)も実行でき、パーティ A と 3 番目の参加者(パーティ C)の間に直接のシグナリングがなくても、パーティ A とパーティ C のコールをセットアップできます。パーティ A とパーティ C のコールが考えられるのは、たとえば、パーティ A が Web ブラウジング中にレストランを見つけ、そのレストランに直接電話で予約する場合です。

音声ポータルのもう 1 つの機能は、パーティ A とパーティ C の間でコールが確立された後も、音声ポータルは、パーティ A からの音を引き続き監視できることです。監視することで、音声ポータルは、事前に確立された DTMF ディジットまたは音声コマンドを受信したときにパーティ A とパーティ C の間の接続を終了することができます。パーティ B は、パーティ A が追加の要求を行う場合に備えて、パーティ A との接続を維持します。前述のレストランの例では、パーティ A が別のレストランにも問い合せることを決めた場合は、接続が継続していることが重要になります。パーティ A は、パーティ B との接続に戻ります。パーティ B は、新しいレストランとのコールをセットアップします。

図 6 メディア フォーキング アプリケーション

 

メディア フォーキングのもう 1 つ重要な側面は、メディア宛先は複数使用できるが、シグナリング宛先は 1 つだけということです(この場合は音声ポータル)。(発信側ゲートウェイから音声ポータルに)最初にセットアップされたコール レッグは、セッション継続中は維持されます。メディア宛先は、シグナリング宛先とは関係ないので、re-Invite メッセージを使用してメディア ストリーム(または新しい宛先)をダイナミックに追加および削除できます。メディア ストリームを作成および削除するときには、CLI ではなく、re-Invite メッセージだけを使用します。

timer receive-rtcp コマンドをゲートウェイに設定した場合、Session Initiation Protocol(SIP)メディアの非アクティビティ タイマーが各アクティブなメディア ストリームに対して開始されます。このタイマーでは、コールを監視し、指定した期間(期間は変更可能です)内に RTCP パケットを受信しなかった場合はコールを切断します。いずれかのタイマーの期限が切れた場合、タイマーの期限が切れたストリームだけでなく、コール全体が終了します。ストリームが保留になると、そのストリームのタイマーが停止されます。ストリームの保留が解除されると、そのストリームのタイマーが再開されます。

1 つのコールに確立できる VoIP メディア ストリームは最大 3 つです。図 7 にストリームの最大数を示します。

図 7 複数のストリーム

 

メディア フォーキングの開始

メディア フォーキングを開始するには、re-Invite メッセージの SDP で複数のメディア フィールド(m 行)を指定します。複数の m 行を追加および削除するルールは、RFC 2543「 SIP: Session Initiation Protocol Appendix B 」に準拠しています。

複数のストリームは CLI では作成しません。

SIP コネクション型メディア、フォーキング、および MLPP 機能を設定する方法

ここでは、次の各手順について説明します。

「SIP:SIP 用のコネクション型メディア拡張の設定」

「SIP:マルチレベルの優先順位(プライオリティ)サポートの設定」

「メディア フォーキングに対する SIP サポートの設定」

「SIP 用のコネクション型メディア機能とフォーキング機能の確認」

「トラブルシューティングのヒント」


) • 各手順を実行する前に、次の情報を理解してください。

「SIP コネクション型メディア、フォーキング、および Multilevel Precedence and Preemption(MLPP; マルチレベル優先順位およびプリエンプション)の前提条件」

「SIP コネクション型メディア、フォーキング、および MLPP の制約事項」

手順に役立つ情報については、上記のトラブルシューティングのセクションを参照してください。


 

SIP:SIP 用のコネクション型メディア拡張の設定

SIP 用のコネクション型メディア拡張を設定するには、次の手順を実行します。


) 次の手順を実行すると、ゲートウェイが、最初の着信 RTP パケットのメディア送信元のアドレスとポートをチェックできるようになります。必要に応じて、エンドポイントがアクティブとパッシブのどちらであるかを指定することもできます。メディア送信元のチェックをイネーブルにすると、ゲートウェイは、受信した要求の SDP 本文から抽出したアップストリーム アドレッシング情報を使用して、確立されている VoIP RTP セッションを変更または更新します。


手順の概要

1. enable

2. configure terminal

3. sip-ua

4. nat symmetric check-media-source

5. nat symmetric role { active | passive }

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

sip-ua

 

Router(config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 4

nat symmetric check-media-source

 

Router(config-sip-ua)# nat symmetric check-media-source

ゲートウェイが対称型 NAT 環境で着信リアルタイム転送プロトコル(RTP)パケットのメディア送信元のアドレスとポートをチェックできるようにします。

ステップ 5

nat symmetric role { active | passive }

 

Router(config-sip-ua)# nat symmetric role active

(任意)対称型 NAT を設定するためにエンドポイントが接続を開始するのか、接続を受け入れるのかを定義します。キーワードは次のとおりです。

active :対称型 NAT のエンドポイントのロールはアクティブで、そのエンドポイントは発信接続を開始できます。

passive :対称型 NAT のエンドポイントのロールはパッシブで、そのエンドポイントは、もう一方のエンドポイントの Session Description Protocol(SDP)本文の m= 行に指定されているポート番号への着信接続を受け入れることができます。これがデフォルトです。

ステップ 6

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

SIP:マルチレベルの優先順位(プライオリティ)サポートの設定

SIP のマルチレベルの優先順位(プライオリティ)サポートを VoIP ダイヤル ピアに設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. destination-pattern [+]string [T]

5. voice-class sip resource priority namespace [drsn | dsn | q735]

6. voice-class sip resource priority mode [loose | strict]

7. session protocol sipv2

8. session target ipv4: destination-address

9. session transport {udp | tcp}

10. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 100 voip

特定の VoIP ダイヤルピアで、ダイヤルピア音声コンフィギュレーション モードを開始します。

ステップ 4

destination-pattern [ + ] string [ T ]

 

Router(config-dial-peer)# destination-pattern 7777

(ダイヤル プランに応じて)ダイヤル ピアに使用するプレフィクスまたは完全な E.164 電話番号を入力します。キーワードと引数は次のとおりです。

+:E.164 標準番号を示す文字。

string:E.164 の電話番号またはプライベート ダイヤリング プランの電話番号を指定する一連のディジット。有効なエントリは、数値は 0 ~ 9、文字は A ~ D、および任意の特殊文字です。

T:宛先パターンの値が可変長のダイヤル文字列であることを示す制御文字。

ステップ 5

voice-class sip resource priority namespace [ drsn | dsn | q735 ]

 

Router(config-dial-peer)# voice-class sip resource priority namespace dsn

最初の INVITE メッセージ要求に必須のコール優先順位付け処理を指定し、サービス ドメインの名前空間を指定します。キーワードは次のとおりです。

namespace:サービスドメインの名前空間

drsn:米国 RDSN 形式

dsn:米国 DSN 形式

q735:パブリック シグナリング SS7 ネットワーク形式

(注) ゲートウェイが SIP コールを発信している場合、発信の VoIP ダイヤル ピアでサポートされる名前空間のいずれかでプライオリティ値を設定します。この決定は、該当するドメインへのゲートウェイの接続に基づきます。

ステップ 6

voice-class sip resource priority mode [ loose | strict ]

 

Router(config-dial-peer)# voice-class sip resource priority mode loose

最初の INVITE メッセージ要求に必須のコール優先順位付け処理を指定し、リソースのプライオリティ処理モードを指定します。キーワードは次のとおりです。

mode:リソースのプライオリティ処理モード

loose:リソースの緩和プライオリティ処理

strict:リソースの厳格プライオリティ処理

(注) 発信側ゲートウェイは、受信側の SIP エンドポイントに対し、指定したプライオリティでコールを処理するように指示するか、または、受信側エンドポイントが名前空間ドメインまたは優先順位の値を解釈できない場合はコール プライオリティの値を無視するように指示します。

ステップ 7

session protocol sipv2

 

Router(config-dial-peer)# session protocol sipv2

インターネット技術特別調査委員会(IETF)の SIP を使用することを指定します。

ステップ 8

session target ipv4: destination-address

 

Router(config-dial-peer)# session target ipv4:10.10.1.3

ダイヤル ピアにネットワーク固有のアドレスを指定します。

ステップ 9

session transport { udp | tcp }

 

Router(config-dial-peer)# session transport udp

特定のセッション転送プロトコルを使用することを指定します。キーワードは次のとおりです。

udp:ユーザ データグラム プロトコル(UDP)

tcp:トランスポート レイヤ プロトコル(TCP)

デフォルトは UDP です。

ステップ 10

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

メディア フォーキングに対する SIP サポートの設定

ここでは、次の手順について説明します。

「コーデックの複雑度の設定」

「ペイロード タイプとダイナミック ペイロード コーデックのマッピング」

「複数のコーデックの選択順序の設定」

コーデックの複雑度の設定

Cisco 2600 シリーズ、Cisco 3600 シリーズ、Cisco 37xx、Cisco AS5300、Cisco 7200 シリーズでコーデックの複雑度を設定するには、ルータのタイプに応じて次のいずれかの手順を実行します。

Cisco 2600 シリーズ、Cisco 3600 シリーズ、Cisco 37xx、および Cisco AS5300


) • メディア フォーキングされたコールを使用するには、正しいコーデックの複雑度を設定することが必要です。Cisco AS5300 の場合、コーデックの複雑度は、音声フィーチャ カード(VFC)にロードされている VCWare コードによって決まります。Cisco VCWare ソフトウェアをダウンロードするには、シスコのソフトウェア ダウンロードのページにアクセスしてください。

すでに設定されているが、コーデックの複雑度を高に変更する必要があるルータで、カードのいずれかの T1 コントローラに DS0 グループまたは PRI グループが割り当てられている場合、その DS0 グループまたは PRI グループを削除する必要があります。グループを削除するには、そのグループに関連付けられている音声ポートをシャットダウンしてから、次の手順を実行します。


 

手順の概要

1. enable

2. configure terminal

3. voice card slot

4. codec complexity { high | medium } [ ecan-extended ]

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice card slot

 

Router(config)# voice-card 1

指定した音声カードのスロット位置に対して音声カードのコンフィギュレーション モードを開始します。

ステップ 4

codec complexity { high | medium } [ ecan-extended ]

 

Router(config-voice-card)# codec complexity high

使用されているコーデックの標準に従って、コールの密度とコーデックの複雑度を指定します。コーデックの複雑度は次のように設定します。

Cisco 2691 および Cisco 2600XM シリーズ:完全なフォーキング機能を実行する場合は、高に設定します。高複雑度の実装では、各 DSP は 2 つの音声チャネルをサポートします。

Cisco 3600 シリーズおよび Cisco 37xx:完全なフォーキング機能を実行する場合は、高に設定します。

ステップ 5

exit

 

Router(config-voice-card)# exit

現在のモードを終了します。

Cisco 7200 シリーズ

手順の概要

1. enable

2. show interfaces dspfarm [ slot/port ] dsp [ number ] [ long | short ]

3. configure terminal

4. dspint dspfarm slot/ port

5. codec high

6. description string

7. exit

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show interfaces dspfarm [ slot/port ] dsp [ number ] [ long | short ]

 

Router# show interface dspfarm 3/0

DSP 音声チャネルのアクティビティを表示します。音声チャネルがビジーの場合、コーデックの複雑度は変更できません変更できるのは、すべての DSP チャネルがアイドルのときだけです。キーワードと引数は次のとおりです。

slot/port :ポート アダプタのスロット位置とポート番号。

dsp number :表示する DSP セットの番号。範囲:1 ~ 30。

long :DSP の詳細情報。

short :DSP の簡略情報。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

dspint dspfarm slot/port

 

Router(config)# dspint dspfarm 2/0

指定したスロット/ポートの DSP インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

codec high

 

Router(config-dspfarm)# codec high

特定のコーデックの標準に基づいてコールの密度とコーデックの複雑度を指定します。メディア フォーキングに対する SIP サポート機能では、 high キーワードを使用します。 high キーワードを指定すると、2 つの符号化音声チャネルがサポートされます。この機能では、コーデック G.711、G.726、G.729 とそのバリアントがサポートされます。

ステップ 6

description string

 

Router(config-dspfarm)# description marketing_dept

DSP インターフェイスに関する具体的な説明( string )を入力します。この情報は、出力に表示されます。この情報がインターフェイスの動作に影響を与えることはありません。

ステップ 7

exit

 

Router(config-dspfarm)# exit

現在のモードを終了します。

ペイロード タイプとダイナミック ペイロード コーデックのマッピング

ペイロード タイプをダイナミック ペイロード コーデックにマッピングするには、次の手順を実行します。


) • すべてのメディア ストリームは同じペイロード タイプを使用する必要があるので、メディア フォーキングされたコールでは、Cisco IOS ソフトウェアがペイロード タイプをダイナミック ペイロード コーデックにマッピングするときに使用するプロセスが重要です。

VoIP ダイヤル ピアでは、単一のコーデックと複数のコーデックのどちらをダイヤル ピアに割り当てるのかに応じて、2 つの方法のどちらかを使用してコーデックのリストを作成できます。次の手順では、ダイヤル ピア モードで単一のコーデックを設定します。


 

手順の概要

1. enable

2. configure terminal

3. dial-peer voice tag voip

4. codec codec [ bytes payload-size ]

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 29 voip

特定のダイヤル ピアで、ダイヤル ピア コンフィギュレーション モードを開始します。

ステップ 4

codec codec [ bytes payload-size ]

 

Router(config-dial-peer)# codec g729r8

ダイヤル ピアにコーデックを指定します。キーワードと引数は次のとおりです。

codec :コーデックのタイプ。メディア フォーキングで使用できる有効な値は次のとおりです。

g711alaw

g711ulaw

g726r16

g726r24

g726r32

g729br8

g729r8(デフォルト)

bytes payload-size :各フレームの音声ペイロードのバイト数。値は、コーデックのタイプとパケット音声プロトコルによって異なります。

ステップ 5

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

複数のコーデックの選択順序の設定

複数のコーデックの選択順序を設定するには、次の手順を実行します。


) • 複数のコーデックを使用する場合、音声クラスを作成して、そこでコーデックの選択順序を定義できます。作成した音声クラスは VoIP ダイヤル ピアに適用できます。次の手順では、音声クラスを作成します。ダイヤル ピアの設定手順の詳細については、『Cisco IOS Voice Command Reference』(リリース 12.3)を参照してください。

ネットワークに対して複数の音声クラス コーデック リストを設定できます。ダイヤル ピアでサポート対象とするコーデック(とその順序)に応じて、1 つまたは複数のダイヤル ピアにコーデック リストが適用されるようにコーデック リストを設定します。特定のダイヤル ピアで複数のコーデックをサポートする場合は、選択順序を定義する必要があります。

SIP ゲートウェイは、H.323 シグナリングを使用している場合、コーデックの優先順位をサポートしません。リストに含まれるすべてのコーデックは、優先順位を付けられず、同等に扱われます。特に、g729r8 と g729br8 の両方が定義されている場合、g729br8 よりも g729r8 が優先されることはありません。


 

手順の概要

1. enable

2. configure terminal

3. voice class codec tag

4. codec preference value codec-type [ bytes payload-size ]

5. exit

6. dial-peer voice tag voip

7. voice-class codec tag

8. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice class codec tag

 

Router(config)# voice class codec 99

音声クラス コンフィギュレーション モードを開始し、コーデック音声クラスに識別タグ番号を割り当てます。引数は次のとおりです。

tag :ルータ上で一意の識別番号。範囲:1 ~ 10000。

ステップ 4

codec preference value codec-type [ bytes payload-size ]

 

Router(config-voice-class)# codec preference 1 g711alaw

ダイヤル ピアで使用するコーデックのリストを優先順位を付けて指定します。キーワードと引数は次のとおりです。

value :優先順位。1 が最も高い優先順位で、14 が最も低い優先順位です。

codec-type :優先するコーデック。

bytes payload-size :各フレームの音声ペイロードのバイト数。値は、コーデックのタイプとパケット音声プロトコルによって異なります。

(注) SIP ゲートウェイは、H.323 シグナリングを使用している場合、コーデックの優先順位をサポートしません。リストに含まれるすべてのコーデックは、優先順位を付けられず、同等に扱われます。特に、g729r8 と g729br8 の両方が定義されている場合、g729br8 よりも g729r8 が優先されることはありません。

ステップ 5

exit

 

Router(config-voice-class)# exit

現在のモードを終了します。

ステップ 6

dial-peer voice tag voip

 

Router(config)# dial-peer voice 16 voip

特定の VoIP ダイヤルピアで、ダイヤルピア コンフィギュレーション モードを開始します。

ステップ 7

voice-class codec tag

 

Router(config-dial-peer)# voice-class codec 99

以前に設定したコーデックを選択するときの優先順位のリスト(上記のステップ 3 で定義したコーデック音声クラス)を指定した VoIP ダイヤル ピアに割り当てます。

コマンドにはハイフンがありません。

ステップ 8

exit

 

Router(config-dial-peer)# exit

現在のモードを終了します。

SIP 用のコネクション型メディア機能とフォーキング機能の確認

SIP 用のコネクション型メディア機能とフォーキング機能の設定を確認するには、必要に応じて次の手順を実行します(コマンドはアルファベット順に記載しています)。

手順の概要

1. show dial-peer voice sum

2. show running-config

3. show sip-ua calls

4. show voice dsp

手順の詳細


ステップ 1 show dial-peer voice sum

このコマンドを使用して、ダイヤル ピア コンフィギュレーションを確認します。

Router# show dial-peer voice sum
 
dial-peer hunt 0
AD PRE PASS
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET PORT
110 voip up up 555110. 0 syst ipv4:172.18.195.49
210 voip up up 555330. 0 syst ipv4:172.18.195.49
200 pots up up 5553300 0 2/0/1
101 pots up up 5551100 0 2/0/0
366 voip up up 366.... 0 syst ipv4:172.18.195.49
 

ステップ 2 show running-config

このコマンドを使用して、現在の実行コンフィギュレーション ファイルの内容および特定のインターフェイスの設定を表示します。

Cisco 2600 シリーズ、Cisco 3600 シリーズ、Cisco 37xx、または Cisco 7200 シリーズでは、このコマンドを使用して、コーデックの複雑度を確認します (Cisco AS5300 の場合、コーデックの複雑度は、音声フィーチャ カードにロードされている VCWare イメージによって決まります)。コマンド出力には、現在の音声カードの設定が表示されます。中複雑度が指定されている場合、コーデックの複雑度設定は表示されません。高複雑度が指定されている場合、設定「codec complexity high」が表示されます。

次の出力例は、メディア フォーキング機能が完全に機能するように高複雑度動作モードが指定されていることを示しています。

Router# show running-config
 
Building configuration...
 
Current configuration : 1864 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
memory-size iomem 10
voice-card 1
codec complexity high
!
ip subnet-zero
 

ステップ 3 show sip-ua calls

このコマンドを使用して、SIP コールの User Agent Client(UAC; ユーザ エージェント クライアント)と User Agent Server(UAS; ユーザ エージェント サーバ)の情報を表示します。コマンド出力には、各メディア ストリーム(メディア フォーキングされたコールに対して最大 3 つのストリーム)の情報が含まれます。アクティブ コールがフォーキングされているかどうかが示されるので、デバッグ時に役に立ちます。

次の出力例は、SIP コールの UAC と UAS の情報を示しています。コマンド出力には、各メディア ストリーム(メディア フォーキングされたコールに対して最大 3 つのストリーム)の情報が含まれます。アクティブ コールがフォーキングされているかどうかが示されるので、デバッグ時に役に立ちます。

Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Call 1
SIP Call ID : 515205D4-20B711D6-8015FF77-1973C402@172.18.195.49
State of the call : STATE_ACTIVE (6)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 555 0200
Called Number : 5551101
Bit Flags : 0x12120030 0x220000
Source IP Address (Sig ): 172.18.195.49
Destn SIP Req Addr:Port : 172.18.207.18:5063
Destn SIP Resp Addr:Port: 172.18.207.18:5063
Destination Name : 172.18.207.18
Number of Media Streams : 4
Number of Active Streams: 3
RTP Fork Object : 0x637C7B60
Media Stream 1
State of the stream : STREAM_ACTIVE
Stream Call ID : 28
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice
Dtmf-relay Payload Type : 0
Media Source IP Addr:Port: 172.18.195.49:19444
Media Dest IP Addr:Port : 172.18.193.190:16890
Media Stream 2
State of the stream : STREAM_ACTIVE
Stream Call ID : 33
Stream Type : voice+dtmf (1)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : rtp-nte
Dtmf-relay Payload Type : 101
Media Source IP Addr:Port: 172.18.195.49:18928
Media Dest IP Addr:Port : 172.18.195.73:18246
Media Stream 3
State of the stream : STREAM_ACTIVE
Stream Call ID : 34
Stream Type : dtmf-only (2)
Negotiated Codec : No Codec (0 bytes)
Codec Payload Type : -1 (None)
Negotiated Dtmf-relay : rtp-nte
Dtmf-relay Payload Type : 101
Media Source IP Addr:Port: 172.18.195.49:18428
Media Dest IP Addr:Port : 172.16.123.99:34463
Media Stream 4
State of the stream : STREAM_DEAD
Stream Call ID : -1
Stream Type : dtmf-only (2)
Negotiated Codec : No Codec (0 bytes)
Codec Payload Type : -1 (None)
Negotiated Dtmf-relay : rtp-nte
Dtmf-relay Payload Type : 101
Media Source IP Addr:Port: 172.18.195.49:0
Media Dest IP Addr:Port : 172.16.123.99:0
 
Number of UAC calls: 1
 
SIP UAS CALL INFO
 
Number of UAS calls: 0
 

ステップ 4 show voice dsp

このコマンドを使用して、コーデックを含む、すべての DSP 音声チャネルの現在のステータスを表示します。

Router# show voice dsp
 
.
.
.
DSP#0: state IN SERVICE, 2 channels allocated
channel#0: voice port 1/0, codec G711 ulaw, state UP
channel#1: voice port 1/1, codec G711 ulaw, state UP
DSP#1: state IN SERVICE, 2 channels allocated
channel#0: voice port 2/0, codec G711 ulaw, state UP
channel#1: voice port 2/1, codec G711 ulaw, state UP
DSP#2: state RESET, 0 channels allocated
 


 

トラブルシューティングのヒント


) 一般的なトラブルシューティングのヒント、および重要な debug コマンドについては、「一般的なトラブルシューティングのヒント」を参照してください。


音声コールを行うことができることを確認します。

コーデック タイプ g726r16 または g726r24 を使用している場合、 debug voip rtp session named-event 101 コマンドを使用して、DTMF リレーのデバッグを行います。失敗によるメッセージとすべてのコールでコンソール画面がフラッディングしないように、引数 101 をコマンドに付加してください。

debug ccsip ファミリのコマンドは、方向アトリビュート設定、ポートやネットワーク アドレス変換トレースの表示など、一般的な SIP のデバッグに使用します。

これらのコマンドの一部について、次に出力例を示します。

「debug ccsip all コマンドの出力例」

debug ccsip all コマンドの出力例

次の例では、出力で、 nat symmetric コマンドの role キーワードが発信側ゲートウェイは active に設定され、着信側ゲートウェイは passive に設定されています。

Router# debug ccsip all
 
All SIP call tracing enabled
Router#
00:02:12:0x6327E424 :State change from (UNDEFINED, SUBSTATE_NONE) to (STATE_IDLE, SUBSTATE_NONE)
00:02:12:****Adding to UAC table
 
00:02:12:adding call id 3 to table
 
00:02:12:Queued event from SIP SPI :SIPSPI_EV_CC_CALL_SETUP (10)
00:02:12:CCSIP-SPI-CONTROL: act_idle_call_setup
00:02:12: act_idle_call_setup:Not using Voice Class Codec
 
00:02:12:act_idle_call_setup:preferred_codec set[0] type :g711ulaw bytes:160
00:02:12:sipSPICopyPeerDataToCCB:From CLI:Modem NSE payload = 100, Passthrough = 0,Modem relay = 0, Gw-Xid = 1
SPRT latency 200, SPRT Retries = 12, Dict Size = 1024
String Len = 32, Compress dir = 3
00:02:12:****Deleting from UAC table
 
00:02:12:****Adding to UAC table
 
00:02:12:Queued event from SIP SPI :SIPSPI_EV_CREATE_CONNECTION (6)
00:02:12:0x6327E424 :State change from (STATE_IDLE, SUBSTATE_NONE) to (STATE_IDLE, SUBSTATE_CONNECTING)
00:02:12:0x6327E424 :State change from (STATE_IDLE, SUBSTATE_CONNECTING) to (STATE_IDLE, SUBSTATE_CONNECTING)
00:02:12:sipSPIUsetBillingProfile:sipCallId for billing records = D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
00:02:12:CCSIP-SPI-CONTROL: act_idle_connection_created
00:02:12:CCSIP-SPI-CONTROL: act_idle_connection_created:Connid(1) created to 172.18.200.237:5060, local_port 56992
00:02:12:CCSIP-SPI-CONTROL: sipSPIOutgoingCallSDP
00:02:12: Preferred method of dtmf relay is:6, with payload :101
 
00:02:12: convert_codec_bytes_to_ptime:Values :Codec:g711ulaw codecbytes :160, ptime:20
 
00:02:12:sip_generate_sdp_xcaps_list:Modem Relay disabled. X-cap not needed
 
00:02:12:CCSIP-SPI-CONTROL: Clock Time Zone is UTC, same as GMT:Using GMT
00:02:12:sipSPIAddLocalContact
00:02:12:Queued event from SIP SPI :SIPSPI_EV_SEND_MESSAGE (7)
00:02:12:sip_stats_method
00:02:12:0x6327E424 :State change from (STATE_IDLE, SUBSTATE_CONNECTING) to (STATE_SENT_INVITE, SUBSTATE_NONE)
00:02:12:Sent:
INVITE sip:2021010124@172.18.200.237:5060;user=phone SIP/2.0
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>
Date:Mon, 01 Mar 1993 00:02:12 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Supported:timer,100rel
Min-SE: 1800
Cisco-Guid:3563045876-351146444-2147852364-2382746380
User-Agent:Cisco-SIPGateway/IOS-12.x
CSeq:101 INVITE
Max-Forwards:1
Timestamp:730944132
Contact:<sip:888001@10.15.66.43:5060;user=phone>
Expires:60
Allow-Events:telephone-event
Content-Type:application/sdp
Content-Length:291
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 9502 9606 IN IP4 10.15.66.43
s=SIP Call
c=IN IP4 10.15.66.43
t=0 0
m=audio 16398 RTP/AVP 0 100 101
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=direction:active
 
00:02:12:CCSIP-SPI-CONTROL: act_sentinvite_wait_100
00:02:12:CCSIP-SPI-CONTROL: Clock Time Zone is UTC, same as GMT:Using GMT
00:02:12:sipSPIAddLocalContact
00:02:12:Queued event from SIP SPI :SIPSPI_EV_SEND_MESSAGE (7)
00:02:12:sip_stats_method
00:02:12:Sent:
INVITE sip:2021010124@172.18.200.237:5060;user=phone SIP/2.0
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>
Date:Mon, 01 Mar 1993 00:02:12 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Supported:timer,100rel
Min-SE: 1800
Cisco-Guid:3563045876-351146444-2147852364-2382746380
User-Agent:Cisco-SIPGateway/IOS-12.x
CSeq:101 INVITE
Max-Forwards:1
Timestamp:730944132
Contact:<sip:888001@10.15.66.43:5060;user=phone>
Expires:60
Allow-Events:telephone-event
Content-Type:application/sdp
Content-Length:291
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 9502 9606 IN IP4 10.15.66.43
s=SIP Call
c=IN IP4 10.15.66.43
t=0 0
m=audio 16398 RTP/AVP 0 100 101
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=direction:active
 
00:02:12:Received:
SIP/2.0 100 Trying
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Tue, 04 Jan 2000 23:57:53 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Timestamp:730944132
Server:Cisco-SIPGateway/IOS-12.x
CSeq:101 INVITE
Allow-Events:telephone-event
Content-Length:0
 
00:02:12:HandleUdpSocketReads :Msg enqueued for SPI with IPaddr:172.18.200.237:5060
00:02:12:CCSIP-SPI-CONTROL: act_sentinvite_new_message
00:02:12:CCSIP-SPI-CONTROL: sipSPICheckResponse
00:02:12:sip_stats_status_code
00:02:12: Roundtrip delay 32 milliseconds for method INVITE
 
00:02:12:0x6327E424 :State change from (STATE_SENT_INVITE, SUBSTATE_NONE) to (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROCEEDING)
00:02:13:Received:
SIP/2.0 183 Session Progress
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Tue, 04 Jan 2000 23:57:53 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Timestamp:730944132
Server:Cisco-SIPGateway/IOS-12.x
CSeq:101 INVITE
Require:100rel
RSeq:5975
Allow-Events:telephone-event
Contact:<sip:2021010124@172.18.200.237:5060;user=phone>
Content-Type:application/sdp
Content-Disposition:session;handling=required
Content-Length:240
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 1692 40 IN IP4 172.18.200.237
s=SIP Call
c=IN IP4 172.18.200.237
t=0 0
m=audio 16898 RTP/AVP 0 100
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
a=direction:passive
 
00:02:13:HandleUdpSocketReads :Msg enqueued for SPI with IPaddr:172.18.200.237:5060
00:02:13:CCSIP-SPI-CONTROL: act_recdproc_new_message
00:02:13:CCSIP-SPI-CONTROL: sipSPICheckResponse
00:02:13:sip_stats_status_code
00:02:13: Roundtrip delay 708 milliseconds for method INVITE
 
00:02:13:sipSPIGetSdpBody :Parse incoming session description
00:02:13:HandleSIP1xxSessionProgress:Content-Disposition received in 18x response:session;handling=required
00:02:13:sipSPIDoFaxMediaNegotiation()
00:02:13:sipSPIDoMediaNegotiation:Codec (g711ulaw) Negotiation Successful on Static Payload
 
00:02:13: sipSPIDoPtimeNegotiation:One ptime attribute found - value:20
00:02:13: convert_ptime_to_codec_bytes:Values :Codec:g711ulaw ptime :20, codecbytes:160
 
00:02:13: convert_codec_bytes_to_ptime:Values :Codec:g711ulaw codecbytes :160, ptime:20
 
00:02:13: Parsed the direction:role identified as:0
 
00:02:13:sipSPIDoDTMFRelayNegotiation:Requested DTMF-RELAY option(s) not found in Preferred DTMF-RELAY option list!
00:02:13: sipSPIDoMediaNegotiation:DTMF Relay mode :Inband Voice
 
00:02:13:sip_sdp_get_modem_relay_cap_params:
00:02:13:sip_sdp_get_modem_relay_cap_params:NSE payload from X-cap = 0
00:02:13:sip_do_nse_negotiation:NSE Payload 100 found in SDP
00:02:13:sip_do_nse_negotiation:Remote NSE payload = local one = 100, Use it
00:02:13:sip_select_modem_relay_params:X-tmr not present in SDP. Disable modem relay
00:02:13:sipSPIDoQoSNegotiation - SDP body with media description
00:02:13:sipSPIUpdCcbWithSdpInfo:SDP Media Information:
Negotiated Codec :g711ulaw , bytes :160
Early Media :0
Delayed Media :0
Bridge Done :0
New Media :0
DSP DNLD Reqd :0
Media Dest addr/Port :172.18.200.237:16898
Orig Media Addr/Port :0.0.0.0:0
 
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROCEEDING) to (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROGRESS)
00:02:13:ccsip_process_response_contact_record_route
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROGRESS) to (STATE_RECD_PROCEEDING, SUBSTATE_CONNECTING)
00:02:13:Queued event from SIP SPI :SIPSPI_EV_CREATE_CONNECTION (6)
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_CONNECTING) to (STATE_RECD_PROCEEDING, SUBSTATE_CONNECTING)
00:02:13:sipSPIRtcpUpdates:rtcp_session info
laddr = 10.15.66.43, lport = 16398, raddr = 172.18.200.237, rport=16898
00:02:13:sipSPIRtcpUpdates:NO extraction of source address from remote media
 
00:02:13: sipSPIRtcpUpdates No rtp session in bridge, create a new one
 
00:02:13:CCSIP-SPI-CONTROL: ccsip_caps_ind
00:02:13:ccsip_get_rtcp_session_parameters:CURRENT VALUES:
ccCallID=3, current_seq_num=0x1500
00:02:13:ccsip_get_rtcp_session_parameters:NEW VALUES:
ccCallID=3, current_seq_num=0xB93
00:02:13:ccsip_caps_ind:Load DSP with negotiated codec :g711ulaw, Bytes=160
00:02:13:sipSPISetDTMFRelayMode:set DSP for dtmf-relay = CC_CAP_DTMF_RELAY_INBAND_VOICE_AND_OOB
00:02:13:sip_set_modem_caps:Negotiation already Done. Set negotiated Modem caps
00:02:13:sip_set_modem_caps:Modem Relay & Passthru both disabled
00:02:13:sip_set_modem_caps:nse payload = 100, ptru mode = 0, ptru-codec=0, redundancy=0, xid=0, relay=0, sprt-retry=12, latecncy=200, compres-dir=3, dict=1024, strnlen=32
00:02:13:ccsip_caps_ind:Load DSP with codec :g711ulaw, Bytes=160
00:02:13:CCSIP-SPI-CONTROL: ccsip_caps_ack
00:02:13:CCSIP-SPI-CONTROL: act_recdproc_connection_created
00:02:13:CCSIP-SPI-CONTROL: sipSPICheckSocketConnection:Connid(2) created to 172.18.200.237:5060, local_port 50689
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_CONNECTING) to (STATE_RECD_PROCEEDING, SUBSTATE_NONE)
00:02:13:Queued event from SIP SPI :SIPSPI_EV_SEND_MESSAGE (7)
00:02:13:sip_stats_method
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_NONE) to (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROGRESS)
00:02:13:Received:
SIP/2.0 200 OK
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Tue, 04 Jan 2000 23:57:53 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Timestamp:730944132
Server:Cisco-SIPGateway/IOS-12.x
CSeq:101 INVITE
Allow-Events:telephone-event
Contact:<sip:2021010124@172.18.200.237:5060;user=phone>
Content-Type:application/sdp
Content-Length:240
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 1692 40 IN IP4 172.18.200.237
s=SIP Call
c=IN IP4 172.18.200.237
t=0 0
m=audio 16898 RTP/AVP 0 100
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
a=direction:passive
 
00:02:13:HandleUdpSocketReads :Msg enqueued for SPI with IPaddr:172.18.200.237:5060
00:02:13:Sent:
PRACK sip:2021010124@172.18.200.237:5060;user=phone SIP/2.0
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Mon, 01 Mar 1993 00:02:12 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
CSeq:102 PRACK
RAck:5975 101 INVITE
Content-Length:0
 
00:02:13:CCSIP-SPI-CONTROL: act_recdproc_new_message
00:02:13:CCSIP-SPI-CONTROL: sipSPICheckResponse
00:02:13:sip_stats_status_code
00:02:13: Roundtrip delay 736 milliseconds for method PRACK
 
00:02:13:sipSPIGetSdpBody :Parse incoming session description
00:02:13:CCSIP-SPI-CONTROL: sipSPIUACSessionTimer
00:02:13:CCSIP-SPI-CONTROL: act_recdproc_continue_200_processing
00:02:13:CCSIP-SPI-CONTROL: act_recdproc_continue_200_processing:*** This ccb is the parent
 
00:02:13:sipSPIDoFaxMediaNegotiation()
00:02:13:sipSPIDoMediaNegotiation:Codec (g711ulaw) Negotiation Successful on Static Payload
 
00:02:13: sipSPIDoPtimeNegotiation:One ptime attribute found - value:20
00:02:13: convert_ptime_to_codec_bytes:Values :Codec:g711ulaw ptime :20, codecbytes:160
 
00:02:13: convert_codec_bytes_to_ptime:Values :Codec:g711ulaw codecbytes :160, ptime:20
 
00:02:13: Parsed the direction:role identified as:0
 
00:02:13:sipSPIDoDTMFRelayNegotiation:Requested DTMF-RELAY option(s) not found in Preferred DTMF-RELAY option list!
00:02:13: sipSPIDoMediaNegotiation:DTMF Relay mode :Inband Voice
 
00:02:13:sip_sdp_get_modem_relay_cap_params:
00:02:13:sip_sdp_get_modem_relay_cap_params:NSE payload from X-cap = 0
00:02:13:sip_do_nse_negotiation:NSE Payload 100 found in SDP
00:02:13:sip_do_nse_negotiation:Remote NSE payload = local one = 100, Use it
00:02:13:sip_select_modem_relay_params:X-tmr not present in SDP. Disable modem relay
00:02:13: sipSPICompareSDP:Flags set:NEW_MEDIA :0 DSPDNLD REQD:0
 
00:02:13:sipSPIUpdCcbWithSdpInfo Bridge was done and there are no fqdn queries in progress, do RTCP updates
 
00:02:13:sipSPIRtcpUpdates:rtcp_session info
laddr = 10.15.66.43, lport = 16398, raddr = 172.18.200.237, rport=16898
00:02:13:sipSPIRtcpUpdates:NO extraction of source address from remote media
 
00:02:13: sipSPIRtcpUpdates rtp session already created in bridge - update
 
00:02:13:sipSPIUpdCcbWithSdpInfo:SDP Media Information:
Negotiated Codec :g711ulaw , bytes :160
Early Media :0
Delayed Media :0
Bridge Done :1048576
New Media :0
DSP DNLD Reqd :0
Media Dest addr/Port :172.18.200.237:16898
Orig Media Addr/Port :0.0.0.0:0
 
00:02:13:sipSPIProcessMediaChanges
00:02:13:ccsip_process_response_contact_record_route
00:02:13:CCSIP-SPI-CONTROL: sipSPIProcess200OKforinvite
00:02:13:RequestCloseConnection:Closing connid 1 Local Port 50689
00:02:13:Queued event from SIP SPI :SIPSPI_EV_CLOSE_CONNECTION (8)
00:02:13:Queued event from SIP SPI :SIPSPI_EV_SEND_MESSAGE (7)
00:02:13:sip_stats_method
00:02:13:0x6327E424 :State change from (STATE_RECD_PROCEEDING, SUBSTATE_PROCEEDING_PROGRESS) to (STATE_ACTIVE, SUBSTATE_NONE)
00:02:13:The Call Setup Information is :
Call Control Block (CCB) :0x6327E424
State of The Call :STATE_ACTIVE
TCP Sockets Used :NO
Calling Number :888001
Called Number :2021010124
Negotiated Codec :g711ulaw
Negotiated Codec Bytes :160
Negotiated Dtmf-relay :0
Dtmf-relay Payload :0
 
00:02:13:
Source IP Address (Sig ):10.15.66.43
Source IP Address (Media):10.15.66.43
Source IP Port (Media):16398
Destn IP Address (Media):172.18.200.237
Destn IP Port (Media):16898
Destn SIP Req Addr:Port :172.18.200.237:5060
Destn SIP Resp Addr:Port :0.0.0.0:0
Destination Name :172.18.200.237
 
00:02:13:
Orig Destn IP Address:Port (Media):0.0.0.0:0
 
00:02:13:udpsock_close_connect:Socket fd:1 closed for connid 1 with remote port:5060
00:02:13:Sent:
ACK sip:2021010124@172.18.200.237:5060;user=phone SIP/2.0
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Mon, 01 Mar 1993 00:02:12 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Max-Forwards:1
Content-Length:0
CSeq:101 ACK
 
00:02:13:Received:
SIP/2.0 200 OK
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Tue, 04 Jan 2000 23:57:54 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Server:Cisco-SIPGateway/IOS-12.x
CSeq:102 PRACK
Content-Length:0
 
00:02:13:HandleUdpSocketReads :Msg enqueued for SPI with IPaddr:172.18.200.237:5060
00:02:13:CCSIP-SPI-CONTROL: act_active_new_message
00:02:13:CCSIP-SPI-CONTROL: sact_active_new_message_response
00:02:13:CCSIP-SPI-CONTROL: sipSPICheckResponse
00:02:27:Queued event from SIP SPI :SIPSPI_EV_CC_CALL_DISCONNECT (15)
00:02:27:CCSIP-SPI-CONTROL: act_active_disconnect
00:02:27:RequestCloseConnection:Closing connid 2 Local Port 50689
00:02:27:Queued event from SIP SPI :SIPSPI_EV_CLOSE_CONNECTION (8)
00:02:27:Queued event from SIP SPI :SIPSPI_EV_CREATE_CONNECTION (6)
00:02:27:0x6327E424 :State change from (STATE_ACTIVE, SUBSTATE_NONE) to (STATE_ACTIVE, SUBSTATE_CONNECTING)
00:02:27:0x6327E424 :State change from (STATE_ACTIVE, SUBSTATE_CONNECTING) to (STATE_ACTIVE, SUBSTATE_CONNECTING)
00:02:27:udpsock_close_connect:Socket fd:2 closed for connid 2 with remote port:5060
00:02:27:CCSIP-SPI-CONTROL: sipSPICheckSocketConnection:Connid(1) created to 172.18.200.237:5060, local_port 54607
00:02:27:0x6327E424 :State change from (STATE_ACTIVE, SUBSTATE_CONNECTING) to (STATE_ACTIVE, SUBSTATE_NONE)
00:02:27:CCSIP-SPI-CONTROL: act_active_connection_created Call Disconnect - Sending Bye
00:02:27:Queued event from SIP SPI :SIPSPI_EV_SEND_MESSAGE (7)
00:02:27:sip_stats_method
00:02:27:0x6327E424 :State change from (STATE_ACTIVE, SUBSTATE_NONE) to (STATE_DISCONNECTING, SUBSTATE_NONE)
00:02:27:Sent:
BYE sip:2021010124@172.18.200.237:5060;user=phone SIP/2.0
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Mon, 01 Mar 1993 00:02:12 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
User-Agent:Cisco-SIPGateway/IOS-12.x
Max-Forwards:1
Timestamp:730944147
CSeq:103 BYE
Content-Length:0
 
00:02:27:Received:
SIP/2.0 200 OK
Via:SIP/2.0/UDP 10.15.66.43:5060
From:"888001" <sip:888001@10.15.66.43>;tag=20694-C53
To:<sip:2021010124@172.18.200.237;user=phone>;tag=1069B954-25F
Date:Tue, 04 Jan 2000 23:58:08 GMT
Call-ID:D6EB9E87-14EE11CC-8008A04C-8E05D30C@10.15.66.43
Server:Cisco-SIPGateway/IOS-12.x
Timestamp:730944147
Content-Length:0
CSeq:103 BYE
 
00:02:27:HandleUdpSocketReads :Msg enqueued for SPI with IPaddr:172.18.200.237:5060
00:02:27:CCSIP-SPI-CONTROL: act_disconnecting_new_message
00:02:27:CCSIP-SPI-CONTROL: sact_disconnecting_new_message_response
00:02:27:CCSIP-SPI-CONTROL: sipSPICheckResponse
00:02:27:sip_stats_status_code
00:02:27: Roundtrip delay 16 milliseconds for method BYE
 
00:02:27:CCSIP-SPI-CONTROL: sipSPICallCleanup
00:02:27:sipSPIIcpifUpdate :CallState:4 Playout:0 DiscTime:14742 ConnTime 13360
 
00:02:27:0x6327E424 :State change from (STATE_DISCONNECTING, SUBSTATE_NONE) to (STATE_DEAD, SUBSTATE_NONE)
00:02:27:The Call Setup Information is :
Call Control Block (CCB) :0x6327E424
State of The Call :STATE_DEAD
TCP Sockets Used :NO
Calling Number :888001
Called Number :2021010124
Negotiated Codec :g711ulaw
Negotiated Codec Bytes :160
Negotiated Dtmf-relay :0
Dtmf-relay Payload :0
 
00:02:27:
Source IP Address (Sig ):10.15.66.43
Source IP Address (Media):10.15.66.43
Source IP Port (Media):16398
Destn IP Address (Media):172.18.200.237
Destn IP Port (Media):16898
Destn SIP Req Addr:Port :172.18.200.237:5060
Destn SIP Resp Addr:Port :0.0.0.0:0
Destination Name :172.18.200.237
 
00:02:27:
Orig Destn IP Address:Port (Media):0.0.0.0:0
 
00:02:27:
Disconnect Cause (CC) :16
Disconnect Cause (SIP) :200
 
00:02:27:****Deleting from UAC table
 
00:02:27:Removing call id 3
 
00:02:27:RequestCloseConnection:Closing connid 1 Local Port 54607
00:02:27:Queued event from SIP SPI :SIPSPI_EV_CLOSE_CONNECTION (8)
00:02:27: freeing ccb 6327E424
 
00:02:27:udpsock_close_connect:Socket fd:1 closed for connid 1 with remote port:5060

SIP コネクション型メディア、フォーキング、および MLPP 機能の設定例

ここでは、次の設定例について説明します。

「SIP 用のコネクション型メディア拡張の例」

「SIP:マルチレベルの優先順位(プライオリティ)サポートの例」

「メディア フォーキングに対する SIP サポートの例」

SIP 用のコネクション型メディア拡張の例

Router# show running-config
 
Building configuration...
 
Current configuration :2791 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
voice-card 2
!
ip subnet-zero
!
no ip domain lookup
ip domain name example.com
ip name-server 172.18.195.113
!
isdn switch-type primary-ni
!
fax interface-type fax-mail
mta receive maximum-recipients 0
ccm-manager mgcp
!
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2/1
framing esf
linecode b8zs
pri-group timeslots 1-24
!
interface Ethernet0/0
ip address 172.18.197.22 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0:23
no ip address
no logging event link-status
isdn switch-type primary-ni
isdn incoming-voice voice
isdn outgoing display-ie
no cdp enable
!
interface Serial2/1:23
no ip address
no logging event link-status
isdn switch-type primary-ni
isdn incoming-voice voice
isdn outgoing display-ie
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
ip pim bidir-enable
!
call rsvp-sync
!
voice-port 2/0:23
!
voice-port 2/1:23
!
voice-port 3/0/0
!
voice-port 3/0/1
!
mgcp ip qos dscp cs5 media
mgcp ip qos dscp cs3 signaling
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 646 voip
destination-pattern 5552222
session protocol sipv2
session target ipv4:10.0.0.1
!
dial-peer voice 700 pots
destination-pattern 700#T
port 0:D
!
gateway
!
sip-ua
nat symmetric check-media-src
max-forwards 5
!
line con 0
line aux 0
line vty 0 4
login
!
end

SIP:マルチレベルの優先順位(プライオリティ)サポートの例

次に、SIP のマルチレベルの優先順位(プライオリティ)サポート機能が設定されているときの結果を示します。

Router# show running-config
 
Building configuration...
Current configuration:2964 bytes
!
version 12.3
no parser cache
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
logging buffered 1000000 debugging
!
!
dial-peer voice 9876 voip
destination-pattern 9876
voice-class sip resource priority namespace drsn
voice-class sip resource priority mode strict
session protocol sipv2
session target ipv4:172.18.194.183
session transport udp
!
dial-peer voice 222 pots
incoming called-number
direct-inward-dial
!
dial-peer voice 333 pots
shutdown
destination-pattern 9876
prefix 9876
!
sip-ua
retry invite 1
retry bye 4
retry cancel 4
retry prack 4
retry notify 4
retry refer 4
retry info 4
sip-server ipv4:172.19.194.186
reason-header override
!
line con 0
exec-timeout 0 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login
transport preferred all
transport input all
transport output all
!
!
end

メディア フォーキングに対する SIP サポートの例

ここでは、次の設定について説明し、例を示します。

「メディア フォーキングを使用する SIP ネットワーク」

「エッジ ゲートウェイ」

「パーティ A」

「パーティ B」

「パーティ C」

「パーティ A の最初のコール セットアップの内容」

「パーティ B の最初のコール セットアップの内容」

「パーティ A が 2 番目のストリームを追加したときの内容」

「パーティ C が 2 番目のストリームを追加したときの内容」


) 例に示す IP アドレスおよびホスト名は架空のものです。


メディア フォーキングを使用する SIP ネットワーク

次の設定例は、メディア フォーキングを使用する SIP ネットワークの例を示しています。図 8 に、パーティ A がパーティ B(555-2201)に電話をかけるネットワークの例を示します。発信側ゲートウェイでパーティ B のダイヤル ピアは、サードパーティ コール コントローラとして機能する SIP_Tester の IP アドレスを指しています。Invite メッセージは SIP_Tester に送信されます。SIP_Tester はそのメッセージをパーティ B に転送します。一般的な SIP プロトコル変換が実行され、コールの最初のストリームがセットアップされます。SIP_Tester に関する SIP URL のユーザ情報部分は 9999 なので、パーティ B とパーティ C のダイヤル ピアは、9999 で設定されます。

SIP_Tester は、SDP を使用せずに最初の Invite メッセージをパーティ C に送信し、2 番目のストリームの確立を開始します。パーティ C は、着信側電話機の呼び出し音を鳴らし、原因コード 183 とメディア機能をアドバタイズする SDP を使用して SIP_Tester に応答します。着信側電話機が応答すると、パーティ C は 200 OK で SIP_Tester に応答します。SIP_Tester は、2 つのメディア行(m 行)を使用して re-Invite メッセージを作成し、パーティ C への 2 番目のストリームを作成するパーティ A に、そのメッセージを送信します。パーティ A は、SDP にローカル メディア情報を格納して ACK で応答します。SIP_Tester は、その SDP が指定された ACK をパーティ C に転送します。フォーキングされたコールが確立されます。

図 8 メディア フォーキングを使用する SIP ネットワークの例

 

エッジ ゲートウェイ

エッジ ゲートウェイの設定は、Foreign Exchange Station(FXS)インターフェイスを T1 インターフェイスに変換するときに使用されます。メディア フォーキングまたは VoIP では使用されません。

Router# show running-config
 
Building configuration...
 
Current configuration : 4455 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
logging rate-limit console 10 except errors
!
voice-card 1
!
ip subnet-zero
!
ip domain-name example.com
ip name-server 172.26.11.21
!
no ip dhcp-client network-discovery
isdn switch-type primary-dms100
isdn voice-call-failure 0
call rsvp-sync
!
controller T1 1/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1/1
framing esf
linecode b8zs
pri-group timeslots 1-24
!
interface Serial1/0:23
no ip address
no logging event link-status
isdn switch-type primary-dms100
isdn incoming-voice voice
isdn T310 4000
no cdp enable
!
interface Serial1/1:23
no ip address
no logging event link-status
isdn switch-type primary-dms100
isdn incoming-voice voice
no fair-queue
no cdp enable
!
interface FastEthernet3/0
ip address 172.18.193.136 255.255.0.0
duplex auto
speed auto
!
ip classless
ip route 172.16.0.0 255.0.0.0 FastEthernet3/0
no ip http server
!
snmp-server packetsize 4096
snmp-server manager
!
voice-port 1/0:23
!
voice-port 1/1:23
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
dial-peer cor custom
!
dial-peer voice 5552 pots
destination-pattern 5552...
port 1/1:23
prefix 5552
!
dial-peer voice 5555 pots
destination-pattern 5555101
port 2/0/1
!
line con 0
exec-timeout 0 0
transport preferred none
line aux 0
line vty 0 4
exec-timeout 0 0
password password1
login
!
end

パーティ A

Router# show running-config
 
Building configuration...
 
Current configuration : 1864 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
memory-size iomem 10
voice-card 1
codec complexity high
!
ip subnet-zero
!
ip domain-name example.com
ip name-server 172.26.11.21
!
isdn switch-type primary-dms100
isdn voice-call-failure 0
!
voice service voip
sip
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 1/0
framing esf
linecode b8zs
!
controller T1 1/1
framing esf
linecode b8zs
pri-group timeslots 1-24
!
interface Ethernet0/0
ip address 172.18.193.14 255.255.0.0
half-duplex
fair-queue 64 256 235
ip rsvp bandwidth 7500 7500
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Serial1/1:23
no ip address
no logging event link-status
isdn switch-type primary-dms100
isdn incoming-voice voice
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.193.1
no ip http server
!!
call rsvp-sync
!
voice-port 1/1:23
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 2100 voip
destination-pattern 55521..
session target ipv4:172.18.193.88
!
dial-peer voice 2200 voip
destination-pattern 55522..
session protocol sipv2
session target ipv4:172.18.207.18:5062
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 9999 voip
destination-pattern 9999
session protocol sipv2
session target ipv4:172.18.207.18:5062
!
dial-peer voice 5557 pots
destination-pattern 55571..
direct-inward-dial
port 1/1:23
!
sip-ua
retry invite 3
retry response 3
retry bye 3
retry cancel 3
timers trying 501
!
line con 0
exec-timeout 0 0
transport preferred none
line aux 0
line vty 0 4
password password1
login
line vty 5 15
login
!
no scheduler allocate
!
end

パーティ B

Router# show running-config
 
Building configuration...
 
Current configuration : 1769 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
memory-size iomem 10
clock timezone gmt 1
ip subnet-zero
!
ip domain-name example.com
ip name-server 172.26.11.21
!
interface FastEthernet0/0
ip address 172.18.193.88 255.255.0.0
no ip mroute-cache
duplex auto
speed auto
fair-queue 64 256 235
no cdp enable
ip rsvp bandwidth 7500 7500
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.193.1
no ip http server
!
snmp-server engineID local 00000009020000107BDC8FA0
snmp-server community public RO
snmp-server packetsize 2048
call rsvp-sync
!
voice-port 1/0/0
no supervisory disconnect lcfo
!
voice-port 1/0/1
no supervisory disconnect lcfo
!
dial-peer cor custom
!
dial-peer voice 2100 pots
destination-pattern 5552100
port 1/0/0
!
dial-peer voice 2101 pots
destination-pattern 5552101
port 1/0/1
!
dial-peer voice 2200 pots
destination-pattern 5552200
port 1/0/0
!
dial-peer voice 2201 pots
destination-pattern 5552201
port 1/0/1
!
dial-peer voice 9999 voip
destination-pattern 9999
session protocol sipv2
session target ipv4:172.18.207.18:5062
codec g711ulaw
!
sip-ua
retry invite 3
retry response 3
retry bye 3
retry cancel 3
timers trying 501
!
line con 0
exec-timeout 0 0
transport preferred none
line aux 0
line vty 0 4
password password1
login
line vty 5 15
login
!
end

パーティ C

Router# show running-config
 
Building configuration...
 
Current configuration : 1638 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
memory-size iomem 10
ip subnet-zero
!
ip domain-name example.com
ip name-server 172.26.11.21
!
interface Ethernet0/0
ip address 172.18.193.80 255.255.0.0
half-duplex
fair-queue 64 256 235
ip rsvp bandwidth 7500 7500
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.193.1
no ip http server
!
call rsvp-sync
!
voice-port 1/0/0
no supervisory disconnect lcfo
!
voice-port 1/0/1
no supervisory disconnect lcfo
 
dial-peer cor custom
!
dial-peer voice 3100 pots
destination-pattern 5553100
port 1/0/0
!
dial-peer voice 3101 pots
destination-pattern 5553101
port 1/0/1
!
dial-peer voice 3200 pots
destination-pattern 5553200
port 1/0/0
!
dial-peer voice 3201 pots
destination-pattern 5553201
port 1/0/1
!
dial-peer voice 9999 voip
destination-pattern 9999
session protocol sipv2
session target ipv4:172.18.207.18:5062
dtmf-relay rtp-nte
codec g711ulaw
!
sip-ua
retry invite 3
retry response 3
retry bye 3
retry cancel 3
!
line con 0
exec-timeout 0 0
transport preferred none
line aux 0
line vty 0 4
exec-timeout 0 0
password password1
login
transport input none
escape-character BREAK
line vty 5 15
login
!
end

パーティ A の最初のコール セットアップの内容

次に、パーティ A の最初のコール セットアップの内容を示します。

Router# debug ccsip message
 
*Mar 1 00:32:02.431: Sent:
INVITE sip:5552201@172.18.207.18:5062;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.193.14:5060
From: "5555101" <sip:5555101@172.18.193.14>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>
Date: Mon, 01 Mar 1993 00:32:02 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
Supported: timer,100rel
Min-SE: 1800
Cisco-Guid: 27401485-351474124-2149117103-281843893
User-Agent: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Max-Forwards: 6
Timestamp: 730945922
Contact: <sip:5555101@172.18.193.14:5060;user=phone>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 299
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 2763 7166 IN IP4 172.18.193.14
s=SIP Call
c=IN IP4 172.18.193.14
t=0 0
m=audio 16412 RTP/AVP 0 100 101
c=IN IP4 172.18.193.14
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
 
*Mar 1 00:32:02.499: Received:
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "5555101" <sip:5555101@172.18.193.14;user=phone>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
CSeq: 101 INVITE
Require: 100rel
RSeq: 5413
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Type: application/sdp
Content-Length: 223
 
v=0
o=SIP_Tester 1239625037 1770029373 IN IP4 172.18.207.18
s=SIP Prot Test Call
t=0 0
m=audio 17236 RTP/AVP 0 100
c=IN IP4 172.18.193.88
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
*Mar 1 00:32:02.539: Sent:
PRACK sip:9999@172.18.207.18:5062;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.193.14:5060
From: "5555101" <sip:5555101@172.18.193.14>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
Date: Mon, 01 Mar 1993 00:32:02 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
CSeq: 102 PRACK
RAck: 5413 101 INVITE
Content-Length: 0
 
*Mar 1 00:32:02.563: Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "5555101" <sip:5555101@172.18.193.14;user=phone>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
CSeq: 102 PRACK
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Length: 0
 
*Mar 1 00:32:03.609: Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "5555101" <sip:5555101@172.18.193.14;user=phone>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
CSeq: 101 INVITE
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Type: application/sdp
Content-Length: 223
 
v=0
o=SIP_Tester 1239625037 1770029374 IN IP4 172.18.207.18
s=SIP Prot Test Call
t=0 0
m=audio 17236 RTP/AVP 0 100
c=IN IP4 172.18.193.88
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
*Mar 1 00:32:03.633: Sent:
ACK sip:9999@172.18.207.18:5062;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.193.14:5060
From: "5555101" <sip:5555101@172.18.193.14>;tag=1D556B-24F1
To: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
Date: Mon, 01 Mar 1993 00:32:02 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
Max-Forwards: 6
Content-Length: 0
CSeq: 101 ACK

パーティ B の最初のコール セットアップの内容

次に、パーティ B の最初のコール セットアップの内容を示します。また、 show sip-ua calls コマンドによってコールのステータスが表示されています。

Router# debug ccsip message
 
*Mar 1 00:43:13.655: Received:
INVITE sip:5552201@172.18.193.88;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 487666621@172.18.207.18
Supported: 100rel
CSeq: 101 INVITE
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Type: application/sdp
Content-Length: 278
 
v=0
o=SIP_Tester 1818337819 831652457 IN IP4 172.18.207.18
s=SIP Prot Test Call
t=0 0
m=audio 16452 RTP/AVP 0 100 101
c=IN IP4 172.18.193.14
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
 
*Mar 1 00:43:13.683: Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 00:43:13 gmt
Call-ID: 487666621@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow-Events: telephone-event
Content-Length: 0
 
 
 
*Mar 1 00:43:13.715: Sent:
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 00:43:13 gmt
Call-ID: 487666621@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Require: 100rel
RSeq: 5450
Allow-Events: telephone-event
Contact: <sip:5552201@172.18.193.88:5060;user=phone>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 243
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 1886 7999 IN IP4 172.18.193.88
s=SIP Call
c=IN IP4 172.18.193.88
t=0 0
m=audio 17936 RTP/AVP 0 100
c=IN IP4 172.18.193.88
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
*Mar 1 00:43:13.779: Received:
PRACK sip:5552201@172.18.193.88;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 487666621@172.18.207.18
CSeq: 102 PRACK
RAck: 0 101 INVITE
Content-Length: 0
 
 
 
*Mar 1 00:43:13.791: Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 00:43:13 gmt
Call-ID: 487666621@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 102 PRACK
Content-Length: 0
 
 
 
*Mar 1 00:43:17.251: Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 00:43:13 gmt
Call-ID: 487666621@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow-Events: telephone-event
Contact: <sip:5552201@172.18.193.88:5060;user=phone>
Content-Type: application/sdp
Content-Length: 243
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 1886 7999 IN IP4 172.18.193.88
s=SIP Call
c=IN IP4 172.18.193.88
t=0 0
m=audio 17936 RTP/AVP 0 100
c=IN IP4 172.18.193.88
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
*Mar 1 00:43:17.343: Received:
ACK sip:5552201@172.18.193.88;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5552201" <sip:5552201@172.18.193.88;user=phone>;tag=279390-CB
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 487666621@172.18.207.18
CSeq: 101 ACK
Content-Length: 0
 
 
Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of UAC calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : 487666621@172.18.207.18
State of the call : STATE_ACTIVE (6)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 9999
Called Number : 5552201
Bit Flags : 0x1212003A 0x20000
Source IP Address (Sig ): 172.18.193.88
Destn SIP Req Addr:Port : 172.18.207.18:5062
Destn SIP Resp Addr:Port: 172.18.207.18:5062
Destination Name : 172.18.207.18
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Stream 1
State of the stream : STREAM_ACTIVE (5)
Stream Call ID : 9
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice (0)
Dtmf-relay Payload : 0
Media Source IP Addr:Port: 172.18.193.88:17936
Media Dest IP Addr:Port : 172.18.193.14:16452
Number of UAS calls: 1

パーティ A が 2 番目のストリームを追加したときの内容

次に、パーティ A が 2 番目のストリームを追加したときの内容を示します。また、 show sip-ua calls コマンドによってコールのステータスが表示されています。

Router# debug ccsip message
 
*Mar 1 00:33:05.178: Received:
INVITE sip:5555101@172.18.193.14;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
To: "5555101" <sip:5555101@172.18.193.14;user=phone>;tag=1D556B-24F1
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
Supported: 100rel
CSeq: 101 INVITE
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Type: application/sdp
Content-Length: 635
 
v=0
o=SIP_Tester 1239625037 1770029375 IN IP4 172.18.207.18
s=SIP Prot Test Call
t=0 0
m=audio 17236 RTP/AVP 0 100
c=IN IP4 172.18.193.88
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
m=audio 17114 RTP/AVP 0 100 101 101 100
c=IN IP4 172.18.193.80
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
 
*Mar 1 00:33:05.222: Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
To: "5555101" <sip:5555101@172.18.193.14>;tag=1D556B-24F1
Date: Mon, 01 Mar 1993 00:33:05 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow-Events: telephone-event
Contact: <sip:5555101@172.18.193.14:5060;user=phone>
Content-Type: application/sdp
Content-Length: 431
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 2763 7167 IN IP4 172.18.193.14
s=SIP Call
c=IN IP4 172.18.193.14
t=0 0
m=audio 16412 RTP/AVP 0 100
c=IN IP4 172.18.193.14
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
m=audio 18802 RTP/AVP 0 101 100
c=IN IP4 172.18.193.14
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
*Mar 1 00:33:05.234: Received:
ACK sip:5555101@172.18.193.14;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: <sip:5552201@172.18.207.18;user=phone>;tag=tester-tag
To: "5555101" <sip:5555101@172.18.193.14;user=phone>;tag=1D556B-24F1
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
CSeq: 101 ACK
Content-Length: 0
 
 
 
Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Call 1
SIP Call ID : 1A3F2B6-14F311CC-801AECAF-10CC98B5@172.18.193.14
State of the call : STATE_ACTIVE (6)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 5555101
Called Number : 5552201
Bit Flags : 0x12120030 0x20000
Source IP Address (Sig ): 172.18.193.14
Destn SIP Req Addr:Port : 172.18.207.18:5062
Destn SIP Resp Addr:Port: 172.18.207.18:5062
Destination Name : 172.18.207.18
Number of Media Streams : 2
Number of Active Streams: 2
RTP Fork Object : 0x83064DC8
Media Stream 1
State of the stream : STREAM_ACTIVE (5)
Stream Call ID : 11
Stream Type : voice-only (0)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : inband-voice (0)
Dtmf-relay Payload : 0
Media Source IP Addr:Port: 172.18.193.14:16412
Media Dest IP Addr:Port : 172.18.193.88:17236
Media Stream 2
State of the stream : STREAM_ACTIVE (5)
Stream Call ID : 12
Stream Type : voice+dtmf (1)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : rtp-nte (6)
Dtmf-relay Payload : 101
Media Source IP Addr:Port: 172.18.193.14:18802
Media Dest IP Addr:Port : 172.18.193.80:17114
Number of UAC calls: 1
 
SIP UAS CALL INFO
 
Number of UAS calls: 0

パーティ C が 2 番目のストリームを追加したときの内容

次に、パーティ C が 2 番目のストリームを追加したときの内容を示します。また、 show sip-ua calls コマンドによってコールのステータスが表示されています。

Router# debug ccsip message
 
*Mar 1 00:44:19.763: Received:
INVITE sip:5553201@172.18.193.80;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5553201" <sip:5553201@172.18.193.80;user=phone>
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 2108310431@172.18.207.18
Supported: 100rel
CSeq: 101 INVITE
Contact: <sip:9999@172.18.207.18:5062;user=phone>
Content-Length: 0
 
*Mar 1 00:44:19.792: Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5553201" <sip:5553201@172.18.193.80;user=phone>;tag=2895C8-53B
Date: Mon, 01 Mar 1993 00:44:19 GMT
Call-ID: 2108310431@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow-Events: telephone-event
Content-Length: 0
 
*Mar 1 00:44:19.828: Sent:
SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5553201" <sip:5553201@172.18.193.80;user=phone>;tag=2895C8-53B
Date: Mon, 01 Mar 1993 00:44:19 GMT
Call-ID: 2108310431@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Require: 100rel
RSeq: 6083
Allow-Events: telephone-event
Contact: <sip:5553201@172.18.193.80:5060;user=phone>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 523
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 8259 5683 IN IP4 172.18.193.80
s=SIP Call
c=IN IP4 172.18.193.80
t=0 0
m=audio 18988 RTP/AVP 0 100 101
c=IN IP4 172.18.193.80
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
 
*Mar 1 00:44:20.985: Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5553201" <sip:5553201@172.18.193.80;user=phone>;tag=2895C8-53B
Date: Mon, 01 Mar 1993 00:44:19 GMT
Call-ID: 2108310431@172.18.207.18
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 INVITE
Allow-Events: telephone-event
Contact: <sip:5553201@172.18.193.80:5060;user=phone>
Content-Type: application/sdp
Content-Length: 523
 
v=0
o=CiscoSystemsSIP-GW-UserAgent 8259 5683 IN IP4 172.18.193.80
s=SIP Call
c=IN IP4 172.18.193.80
t=0 0
m=audio 18988 RTP/AVP 0 100 101
c=IN IP4 172.18.193.80
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
 
*Mar 1 00:44:20.997: Received:
ACK sip:5553201@172.18.193.80;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.18.207.18:5062
From: "SIP_Tester" <sip:9999@172.18.207.18:5062;user=phone>;tag=tester-tag
To: "5553201" <sip:5553201@172.18.193.80;user=phone>;tag=2895C8-53B
Date: Mon, 01 Mar 1993 01:01:01 GMT
Call-ID: 2108310431@172.18.207.18
CSeq: 101 ACK
Content-Type: application/sdp
Content-Length: 277
 
v=0
o=SIP_Tester 2029259292 42666129 IN IP4 172.18.207.18
s=SIP Prot Test Call
t=0 0
m=audio 16728 RTP/AVP 0 101 100
c=IN IP4 172.18.193.14
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:100 X-NSE/8000
a=fmtp:100 192-194
a=ptime:20
 
Router# show sip-ua calls
 
SIP UAC CALL INFO
 
Number of UAC calls: 0
 
SIP UAS CALL INFO
 
Call 1
SIP Call ID : 186464186@172.18.207.18
State of the call : STATE_ACTIVE (6)
Substate of the call : SUBSTATE_NONE (0)
Calling Number : 9999
Called Number : 5553201
Bit Flags : 0x1212003A 0x20000
Source IP Address (Sig ): 172.18.193.80
Destn SIP Req Addr:Port : 172.18.207.18:5062
Destn SIP Resp Addr:Port: 172.18.207.18:5062
Destination Name : 172.18.207.18
Number of Media Streams : 1
Number of Active Streams: 1
RTP Fork Object : 0x0
Media Stream 1
State of the stream : STREAM_ACTIVE (5)
Stream Call ID : 7
Stream Type : voice+dtmf (1)
Negotiated Codec : g711ulaw (160 bytes)
Codec Payload Type : 0
Negotiated Dtmf-relay : rtp-nte (6)
Dtmf-relay Payload : 101
Media Source IP Addr:Port: 172.18.193.80:19352
Media Dest IP Addr:Port : 172.18.193.14:16770
 
Number of UAS calls: 1

その他の参考資料

一般的な SIP 参考資料

SIP 機能のロードマップ:Cisco Feature Navigator にアクセスする手順について説明します。また、Cisco IOS リリース別に、そのリリースの SIP 機能を示して説明します。

SIP の概要:基本的な SIP テクノロジーのほか、関連資料、規格、MIB、RFC、および技術サポートを受ける方法のリストが掲載されています。

この章で言及した参考資料(アルファベット順)

Cisco IOS Tcl IVR and VoiceXML Application Guide 』( http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t11/ivrapp/index.htm

Cisco VoiceXML Programmer's Guide 』( http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/rel_docs/vxmlprg/index.htm