Cisco IOS SIP コンフィギュレーション ガイド
Session Initiation Protocol(SIP)の基本 設定
Session Initiation Protocol(SIP)の基本設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

Session Initiation Protocol(SIP)の基本設定

この章の構成

SIP の基本設定の前提条件

SIP の基本設定の概要

SIP 登録サポート

SIP リダイレクト処理拡張

SIP 300 Multiple Choice メッセージの送信

SIP の基本設定の実行方法

シスコ ゲートウェイでの SIP VoIP サービスの設定

シスコ ゲートウェイでの VoIP サービスのシャットダウンまたはイネーブル化

シスコ ゲートウェイでの VoIP サブモードのシャットダウンまたはイネーブル化

SIP 登録サポートの設定

SIP リダイレクト処理拡張の設定

コール リダイレクト処理拡張の設定

SIP 300 Multiple Choice メッセージの設定

SIP 300 Multiple Choice メッセージの送信設定

SIP 実装の拡張の設定

フォーキング プロキシとの相互作用

SIP ゲートウェイ内ヘアピニング

SIP ゲートウェイ ステータスの確認

一般的なトラブルシューティングのヒント

SIP の基本設定の設定例

SIP 登録サポートの例

SIP リダイレクト処理拡張の例

SIP 300 Multiple Choice メッセージの例

電話ハッカーの侵入阻止

その他の参考資料

Session Initiation Protocol(SIP)の基本設定

この章では、次の機能の基本設定について説明します。

Session Initiation Protocol(SIP)登録サポート

SIP リダイレクト処理拡張

SIP 300 Multiple Choice メッセージ

SIP 実装の拡張:

フォーキング プロキシとの相互作用

SIP ゲートウェイ内ヘアピニング

SIP 登録サポート、SIP リダイレクト処理拡張、および SIP 300 Multiple Choice メッセージの機能履歴

リリース
変更点

12.2(15)ZJ

この機能が導入されました。

12.3(4)T

この機能がこのリリースに統合されました。

SIP 実装の拡張の機能履歴:フォーキング プロキシとの相互作用および SIP ゲートウェイ内ヘアピニング

リリース
変更点

12.2(2)XB

これらの機能が導入されました。

12.2(8)T

この機能がこのリリースに統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

SIP の基本設定の前提条件

SIP リダイレクト処理拡張機能

ご使用の SIP ゲートウェイが 300 または 302 Redirect メッセージをサポートすることを確認します。

SIP の基本設定の概要

SIP の基本設定作業を実行するには、次の概念を理解しておく必要があります。

「SIP 登録サポート」

「SIP リダイレクト処理拡張」

「SIP 300 Multiple Choice メッセージの送信」

SIP 登録サポート

H.323 により、Cisco IOS ゲートウェイは Plain Old Telephone Service(POTS; 一般電話サービス)ダイヤル ピアの E.164 番号をゲートキーパーに登録できます。これにより、ユーザのコンタクト情報がゲートキーパーに通知されます。Session Initiation Protocol(SIP)ゲートウェイにも同じ機能がありますが、登録には SIP プロキシまたはレジストラが使用されます。SIP ゲートウェイでは、アナログ電話機の音声ポート(FXS)、IP Phone の仮想音声ポート(EFXS)、およびローカル Skinny Client Control Protocol(SCCP)電話機の代わりに、SIP プロキシまたはレジストラに E.164 番号を登録できます。

ダイヤル ピアを外部レジストラに登録する場合、セカンダリ SIP プロキシまたはレジストラにも登録して冗長性を確保できます。セカンダリ登録は、プライマリ レジストラに障害が発生したときに使用できます。

SIP ゲートウェイでは、アナログ電話機の音声ポート(FXS)、IP Phone の仮想音声ポート(EFXS)、およびローカル SCCP 電話機の代わりに、SIP プロキシ サーバまたはレジストラ サーバに E.164 番号を登録できます。デフォルトでは、SIP ゲートウェイは SIP Register メッセージを生成しません。次の作業では、ゲートウェイが E.164 電話番号を外部 SIP レジストラに登録するように設定されます。


) H.323 プロトコルと SIP プロトコルとの間で登録が可能なコマンドはありません。


SIP リダイレクト処理拡張

SIP リダイレクト処理は、着信リダイレクトまたは 3 xx 応答クラスの処理に柔軟性をもたらします。リダイレクト応答は Command-Line Interface(CLI; コマンドライン インターフェイス)を使用してイネーブルまたはディセーブルにすることができるため、Cisco SIP ゲートウェイを配置するサービス プロバイダーにとって有用です。リダイレクト処理はデフォルトでアクティブです。つまり、SIP ゲートウェイは着信 3 xx メッセージを RFC 2543 に準拠して処理します。RFC 2543 の規定では、SIP ユーザ エージェントは、ユーザが既知の場所から移動したことを認識したときに、リダイレクト応答メッセージを使用して新規 Invite を開始します。

RFC 2543-bis-04 に従って、3 xx リダイレクションは次のように処理されます。

リダイレクトされる INVITE の Uniform Resource Identifier(URI; ユニフォーム リソース識別子)は、3 xx リダイレクト メッセージによって提供される新しいコンタクト情報が含まれるように更新されます。

CSeq ヘッダー内の送信される CSeq 番号が 1 増加します。更新された CSeq は新規 INVITE に含まれます。

コール レッグを識別する To、From、および Call ID ヘッダーは同じままです。同じ Call ID によって、課金履歴を取得するときに一貫性が維持されます。

User-Agent Client(UAC; ユーザ エージェント クライアント)は、3 xx Contact ヘッダー フィールドに指定された新しいアドレスで要求を再試行します。

リダイレクト処理は、SIP ユーザ エージェント コンフィギュレーション モードで no redirection コマンドを使用してディセーブルに設定できます。この場合、ユーザ エージェントは着信 3 xx 応答を 4 xx エラー クラス応答として処理します。コールはリダイレクトされずに、該当する Public Switched Telephone Network(PSTN; 公衆電話交換網)原因コード メッセージで解放されます。 表 1 に、3 xx 応答の 4 xx 応答へのマッピングを示します。

 

表 1 3 xx 応答の 4 xx 応答へのマッピング

リダイレクション(3 xx )応答メッセージ
4 xx (クライアント エラー)応答へのマッピング

300 Multiple Choices

410 Gone

301 Moved Permanently

410 Gone

302 Moved Temporarily

480 Temporarily Unavailable

305 Use Proxy

410 Gone

380 Alternative Service

410 Gone

<その他の 3xx 応答>

410 Gone

SIP リダイレクト処理では、アカウンティングまたは統計情報に使用できる、該当する解放原因コードを示すコール履歴情報が生成されます。3 xx 応答が 4 xx 応答クラスにマッピングされる場合、コール履歴に格納される原因コードは、マッピング先の 4 xx 応答コードに基づきます。

リダイレクト サーバが関連する SIP コール転送を正常に行うには、ゲートウェイでコール リダイレクションをイネーブルにする必要があります。

着信 VoIP コールが発信 VoIP ダイヤル ピアと一致する場合、Cisco IOS 音声ゲートウェイもコール リダイレクションを使用できます。ゲートウェイは 300 または 302 Redirect メッセージをコールの発信者に送信します。これにより、発信者はコールを再確立できます。2 つのコマンド redirect ip2ip (ダイヤル ピア) および redirect ip2ip(音声サービス) を使用すると、リダイレクト機能をグローバルに、または特定の着信ダイヤル ピアでイネーブルに設定できます。

SIP 300 Multiple Choice メッセージの送信

従来は、コールがリダイレクトされると、SIP ゲートウェイは 302 Moved Temporarily メッセージを送信していました。ゲートウェイ上の最初の最長一致ルート(ダイヤル ピア宛先パターン)が、302 メッセージの Contact ヘッダーで使用されていました。現在は、リダイレクトされる番号に対して宛先への複数のルートが存在する場合(複数のダイヤル ピアが一致する場合)、SIP ゲートウェイは 300 Multiple Choice メッセージを送信し、Contact ヘッダー内の複数のルートが一覧表示されます。

redirect contact order コマンドを使用すると、Contact ヘッダー内に表示されるルートの順序を柔軟に選択できます。

SIP の基本設定の実行方法

ここでは、次の各手順について説明します。

「シスコ ゲートウェイでの SIP VoIP サービスの設定」

「SIP 登録サポートの設定」

「SIP リダイレクト処理拡張の設定」

「SIP 300 Multiple Choice メッセージの設定」

「SIP 実装の拡張の設定」

「フォーキング プロキシとの相互作用」

「SIP ゲートウェイ内ヘアピニング」

「SIP ゲートウェイ ステータスの確認」


) 手順の支援情報については、上記の検証およびトラブルシューティングの項を参照してください。


シスコ ゲートウェイでの VoIP サービスのシャットダウンまたはイネーブル化

シスコ ゲートウェイで VoIP サービスをシャット ダウンするか、またはイネーブルにするには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. [ no ] shutdown

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 
Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

[no] shutdown [forced]

 

Router(config-voi-serv)# shutdown forced

VoIP コール サービスをシャットダウンするか、またはイネーブルにします。

ステップ 5

exit

 

Router(config-voi-serv)# exit

現在のモードを終了します。

シスコ ゲートウェイでの VoIP サブモードのシャットダウンまたはイネーブル化

シスコ ゲートウェイで VoIP サブモードをシャットダウンするか、またはイネーブルにするには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. voice service voip

4. sip

5. [ no ] call service stop

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

sip

 

Router(config-voi-serv)# sip

SIP コンフィギュレーション モードを開始します。

ステップ 5

[no] call service stop [ forced ] [ maintain-registration ]

 

Router(conf-serv-sip)# call service stop maintain-registration

選択したサブモードの VoIP コール サービスをシャットダウンするか、またはイネーブルにします。

ステップ 6

exit

 

Router(conf-serv-sip)# exit

現在のモードを終了します。

SIP 登録サポートの設定

SIP 登録サポートを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. sip-ua

4. registrar

5. retry register

6. timers register

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

sip-ua

 

Router(config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 4

registrar { dns: address | ipv4: destination-address } expires seconds [ tcp ] [ secondary ]

 

Router(config-sip-ua)# registrar ipv4:10.8.17.40 expires 3600 secondary

アナログ電話機の音声ポート(FXS)および IP Phone の仮想音声ポート(EFXS)の代わりに、外部 SIP プロキシ サーバまたは SIP レジストラ サーバに E.164 番号を登録します。キーワードと引数は次のとおりです。

dns: address :コールを受信するダイヤル ピアの名前を解決するドメイン ネーム サーバ。

ipv4: destination-address :コールを受信するダイヤル ピアの IP アドレス。

expires seconds :デフォルトの登録時間(秒単位)。

tcp :トランスポート レイヤ プロトコルを Transmission Control Protocol(TCP)に設定します。デフォルトは User Datagram Protocol(UDP; ユーザ データグラム プロトコル)です。

secondary :冗長性を確保するためにセカンダリ SIP プロキシまたはレジストラへの登録を指定します。任意です。

ステップ 5

retry register number

 

Router(config-sip-ua)# retry register 10

このコマンドを使用して、ゲートウェイが送信する SIP Register メッセージの総数を設定します。引数は次のとおりです。

number :Register メッセージのリトライ数。範囲:1 ~ 10。デフォルト:10。

ステップ 6

timers register milliseconds

 

Router(config-sip-ua)# timers register 500

このコマンドを使用して、SIP ユーザ エージェントが登録要求を送信する前に待機する時間を設定します。引数は次のとおりです。

milliseconds :待機時間(ミリ秒単位)。範囲:100 ~ 1000。デフォルト:500。

ステップ 7

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

SIP リダイレクト処理拡張の設定

ここでは、次の項目について説明します。

「コール リダイレクト処理拡張の設定」

「SIP 300 Multiple Choice メッセージの設定」

コール リダイレクト処理拡張の設定

redirection コマンドを使用したリダイレクト処理は、デフォルトでイネーブルになっています。リダイレクト処理をディセーブルにしてリセットするには、次の項で説明する手順を実行します。

「コール リダイレクト処理拡張の設定」

IP-IP コール リダイレクションは、グローバルにまたはダイヤル ピアごとにイネーブルに設定できます。設定するには、次の項で説明する手順を実行します。

「コールをグローバルにサポートするコール リダイレクトの設定」

「特定の VoIP ダイヤル ピアでコールをサポートするコール リダイレクトの設定」

コール リダイレクト処理拡張の設定

コール リダイレクト処理拡張を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. sip-ua

4. no redirection

5. redirection

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

sip-ua

 

Router(config)# sip-ua

SIP ユーザ エージェント コンフィギュレーション モードを開始します。

ステップ 4

no redirection

 

Router(config-sip-ua)# no redirection

リダイレクト処理をディセーブルにします。ゲートウェイは着信 3 xx 応答を 4 xx エラー クラス応答として処理するようになります。

ステップ 5

redirection

 
Router(config-sip-ua)# redirection

RFC 2543 で規定されているように動作するように、コール リダイレクションをリセットします。コマンド default redirection も、RFC 2543 で規定されているように動作するようにコール リダイレクションをリセットします。

ステップ 6

exit

 

Router(config-sip-ua)# exit

現在のモードを終了します。

コールをグローバルにサポートするコール リダイレクトの設定

コールをグローバルにサポートするようにコール リダイレクトを設定するには、次の手順を実行します。


) すべての VoIP ダイヤル ピアのグローバルな IP-IP コール リダイレクションをイネーブルにするには、音声サービス コンフィギュレーション モードを使用します。デフォルトの SIP アプリケーションは、IP-IP リダイレクションをサポートしています。


手順の概要

1. enable

2. configure terminal

3. voice service voip

4. redirect ip2ip

5. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

redirect ip2ip

 

Router(conf-voi-serv)# redirect ip2ip

Cisco IOS 音声ゲートウェイを使用して、ゲートウェイで SIP 通話コールを SIP 通話コールにグローバルにリダイレクトします。

ステップ 5

exit

 

Router(conf-voi-serv)# exit

現在のモードを終了します。

特定の VoIP ダイヤル ピアでコールをサポートするコール リダイレクトの設定

特定の VoIP ダイヤル ピアでコールをサポートするようにコール リダイレクトを設定するには、次の手順を実行します。


) • 特定の VoIP ダイヤル ピアの IP-IP コール リダイレクションを指定するには、ダイヤル ピア コンフィギュレーション モードで着信ダイヤル ピアに IP-IP コール リダイレクションを設定します。SIP Survivable Remote Site Telephony(SRST)のデフォルト アプリケーションは、IP-IP リダイレクションをサポートしています。

ダイヤル ピア コンフィギュレーション モードで IP-IP リダイレクションが設定されている場合、特定の着信ダイヤル ピアでの設定が、音声サービス設定で入力されたグローバル設定よりも優先されます。


 

手順の概要

1. enable

2. configure terminal

3. dial-peer voice voip

4. application

5. redirect ip2ip

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

dial-peer voice tag voip

 

Router(config)# dial-peer voice 29 voip

このコマンドを使用して、ダイヤル ピア コンフィギュレーション モードを開始します。引数は次のとおりです。

tag :特定のダイヤル ピアを定義するディジット。範囲:1 ~ 2,147,483,647(カンマなしで入力)。

ステップ 4

application application-name

 

Router(config-dial-peer)# application session

ダイヤル ピアで特定のアプリケーションをイネーブルにします。引数は次のとおりです。

application-name :ダイヤル ピアでイネーブルにする、事前定義されたアプリケーションの名前。SIP の場合、デフォルトの Tcl アプリケーション(Cisco IOS イメージから)は session であり、VoIP ダイヤル ピアと POTS ダイヤル ピアの両方に適用できます。アプリケーションは、IP-IP リダイレクションをサポートしている必要があります。

ステップ 5

redirect ip2ip

 

Router(conf-dial-peer)# redirect ip2ip

Cisco IOS 音声ゲートウェイを使用して、特定の VoIP ダイヤル ピアで SIP 通話コールを SIP 通話コールにリダイレクトします。

ステップ 6

exit

 

Router(conf-dial-peer)# exit

現在のモードを終了します。

SIP 300 Multiple Choice メッセージの設定

ここでは、次の内容について説明します。

「SIP 300 Multiple Choice メッセージの送信」

「SIP 300 Multiple Choice メッセージの送信設定」

SIP 300 Multiple Choice メッセージの送信設定

SIP 300 Multiple Choice メッセージを送信するには、次の手順を実行します。


) リダイレクトされる番号に対して宛先への複数のルートが存在する場合(複数のダイヤル ピアが一致する場合)、SIP ゲートウェイは 300 Multiple Choice メッセージを送信し、Contact ヘッダー内の複数のルートが一覧表示されます。この設定では、Contact ヘッダー内に表示されるルートの順序を選択できます。


手順の概要

1. enable

2. configure terminal

3. voice service voip

4. sip

5. redirect contact order

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モード、またはシステム管理者によって設定されたその他のセキュリティ レベルを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

voice service voip

 

Router(config)# voice service voip

音声サービス VoIP コンフィギュレーション モードを開始します。

ステップ 4

sip

 

Router(config-voi-serv)# sip

SIP コンフィギュレーション モードを開始します。

ステップ 5

redirect contact order [ best-match | longest-match ]

 

Router(conf-serv-sip)# redirect contact order best-match

300 Multiple Choice メッセージ内のコンタクトの順序を設定します。キーワードは次のとおりです。

best-match :現在のシステム設定を使用してコンタクトの順序を設定します。

longest-match 宛先パターンの最長一致を最初に使用し、次に 2 番目の最長一致、次に 3 番目の最長一致というようにコンタクトの順序を設定します。これがデフォルトです。

ステップ 6

exit

 

Router(conf-serv-sip)# exit

現在のモードを終了します。

SIP 実装の拡張の設定

次の項では、重要度の低い基本的な機能または最小限の設定が可能な機能について説明します。

「フォーキング プロキシとの相互作用」

「SIP ゲートウェイ内ヘアピニング」

SIP 実装の拡張の詳細については、『 Achieving SIP RFC Compliance 』を参照してください。

フォーキング プロキシとの相互作用

コール フォーキングによって、着信側ゲートウェイは複数の要求を処理でき、送信元ゲートウェイは同じコールの複数の暫定応答を処理できます。コール フォーキングは、 find me/follow me タイプのサービスの配置に必要です。

コール フォーキングのサポートによって、着信側ゲートウェイは複数の要求を処理でき、送信元ゲートウェイは同じコールの複数の暫定応答を処理できます。フォーキング プロキシとの相互作用は、UAC として動作するゲートウェイに適用され、ユーザが複数の異なる場所に登録される場合に行われます。UAC が INVITE メッセージをプロキシに送信すると、プロキシは要求をフォーキングして複数のユーザ エージェントに送信します。SIP ゲートウェイは複数の 18X 応答を同じコール ID での独立したトランザクションとして処理します。該当するダイヤル ピアが Quality of Service(QoS)に対して設定されている場合、ゲートウェイはステートを維持し、これらの独立したトランザクションごとに RSVP 予約を開始します。ゲートウェイは、200 OK などの確認応答を受信すると、成功の確認応答を受け入れ、他のすべてのトランザクションのステートを破棄します。

フォーキング機能は、ダイヤル ピアが QoS に対して設定されている場合に 限り 、トランザクションごとに RSVP を設定します。それ以外の場合、コールはベストエフォート型として続行されます。

フォーキング プロキシとの相互作用のサポートは、UAC として動作するゲートウェイにだけ適用されます。ゲートウェイが UAS として動作する場合は適用されません。その場合、プロキシは、同じゲートウェイへの同じコール ID を持つが異なる要求 URL を持つ複数の INVITE をフォーキングします。

また、フォーキング機能は、ダイヤル ピアが QoS に対して設定されている場合に 限り 、トランザクションごとに RSVP を設定します。それ以外の場合、コールはベストエフォート型として続行されます。

SIP ゲートウェイ内ヘアピニング

SIP ヘアピニングは、特定のゲートウェイの着信コールが IP ネットワークを介してシグナリングされ、同じゲートウェイに戻されるコール ルーティング機能です。SIP ヘアピニングには、IP ネットワークにルーティングされ、同じゲートウェイで PSTN に戻される PSTN コールがあります(図 1 を参照)。

図 1 PSTN ヘアピニングの例

 

同様に、SIP ヘアピニングには、回線(電話回線など)から IP ネットワークにシグナリングされ、同じアクセス ゲートウェイで回線に戻されるコールもあります(図 2 を参照)。

図 2 電話回線ヘアピニングの例

 

SIP ヘアピニングでは、入力専用および出力専用のゲートウェイは必要ありません。

SIP は、一般電話サービス(POTS)-POTS ヘアピニングをサポートします(コールは 1 つの音声ポートに着信し、別の音声ポートへルーティングされます)。また、POTS-IP コール レッグおよび IP-POTS コール レッグもサポートします。ただし、IP-IP ヘアピニングはサポートしません。つまり、SIP ゲートウェイは着信 SIP コールを取得できず、VoIP ダイヤル ピアを使用して別の SIP デバイスへ再ルーティングします。

この機能に必要なのは最小限の設定だけです。SIP ゲートウェイでヘアピニングをイネーブルにするには、次のダイヤル ピアの設定例を参照してください。次の点に注意してください。

POTS ダイヤル ピアにはプリファレンス 2 が定義されている必要があり、VoIP ダイヤル ピアにはプリファレンス 1 が定義されている必要があります。これにより、コールは一般電話サービス(POTS)ではなく IP で送信されます。

コールは同じゲートウェイにリダイレクトされるため、セッション ターゲットは同じゲートウェイです。

!
dial-peer voice 53001 pots
preference 2
destination-pattern 5300001
prefix 5300001
!
dial-peer voice 53002 pots
preference 2
destination-pattern 5300002
prefix 5300002
!
dial-peer voice 530011 voip
preference 1
destination-pattern 5300001
session protocol sipv2
session target ipv4:10.1.1.41
playout-delay maximum 300
codec g711alaw
!
dial-peer voice 530022 voip
preference 1
destination-pattern 5300002
session protocol sipv2
session target ipv4:10.1.1.41
playout-delay maximum 300
codec g711alaw

SIP ゲートウェイ ステータスの確認

SIP ゲートウェイのステータスおよび設定を確認するには、必要に応じて次の手順を実行します(コマンドは、アルファベット順に示しています)。

手順の概要

1. show sip service

2. show sip-ua register status

3. show sip-ua statistics

4. show sip-ua status

5. show sip-ua timers

手順の詳細


ステップ 1 show sip service

このコマンドを使用して、SIP ゲートウェイ上の SIP コール サービスのステータスを表示します。

次の出力例は、SIP コール サービスがイネーブルになっていることを示します。

Router# show sip service
 
SIP Service is up
 

次の出力例は、 shutdown コマンドで SIP コール サービスがシャットダウンされたことを示します。

Router# show sip service
 
SIP service is shut globally
under 'voice service voip'
 

次の出力例は、 call service stop コマンドで SIP コール サービスがシャットダウンされたことを示します。

Router# show sip service
 
SIP service is shut
under 'voice service voip', 'sip' submode
 

次の出力例は、 shutdown forced コマンドで SIP コール サービスがシャットダウンされたことを示します。

Router# show sip service
 
SIP service is forced shut globally
under 'voice service voip'
 

次の出力例は、 call service stop forced コマンドで SIP コール サービスがシャットダウンされたことを示します。

Router# show sip service
 
SIP service is forced shut
under 'voice service voip', 'sip' submode
 

ステップ 2 show sip-ua register status

このコマンドを使用して、SIP ゲートウェイが外部のプライマリ SIP レジストラに登録した E.164 番号のステータスを表示します。

Router# show sip-ua register status
 
Line peer expires(sec) registered
4001 20001 596 no
4002 20002 596 no
5100 1 596 no
9998 2 596 no
 

ステップ 3 show sip-ua statistics

このコマンドを使用して、コール リダイレクションがディセーブルになっているかどうかを含む、応答、トラフィック、およびリトライの SIP 統計情報を表示します。

次の出力例は、4 つの登録が送信されたことを示します。

Router# show sip-ua statistics
 
SIP Response Statistics (Inbound/Outbound)
Informational:
Trying 0/0, Ringing 0/0,
Forwarded 0/0, Queued 0/0,
SessionProgress 0/0
Success:
OkInvite 0/0, OkBye 0/0,
OkCancel 0/0, OkOptions 0/0,
OkPrack 0/0, OkPreconditionMet 0/0,
OkSubscribe 0/0, OkNOTIFY 0/0,
OkInfo 0/0, 202Accepted 0/0
OkRegister 12/49
Redirection (Inbound only except for MovedTemp(Inbound/Outbound)) :
MultipleChoice 0, MovedPermanently 0,
MovedTemporarily 0/0, UseProxy 0,
AlternateService 0
Client Error:
BadRequest 0/0, Unauthorized 0/0,
PaymentRequired 0/0, Forbidden 0/0,
NotFound 0/0, MethodNotAllowed 0/0,
NotAcceptable 0/0, ProxyAuthReqd 0/0,
ReqTimeout 0/0, Conflict 0/0, Gone 0/0,
ReqEntityTooLarge 0/0, ReqURITooLarge 0/0,
UnsupportedMediaType 0/0, BadExtension 0/0,
TempNotAvailable 0/0, CallLegNonExistent 0/0,
LoopDetected 0/0, TooManyHops 0/0,
AddrIncomplete 0/0, Ambiguous 0/0,
BusyHere 0/0, RequestCancel 0/0,
NotAcceptableMedia 0/0, BadEvent 0/0,
SETooSmall 0/0
Server Error:
InternalError 0/0, NotImplemented 0/0,
BadGateway 0/0, ServiceUnavail 0/0,
GatewayTimeout 0/0, BadSipVer 0/0,
PreCondFailure 0/0
Global Failure:
BusyEverywhere 0/0, Decline 0/0,
NotExistAnywhere 0/0, NotAcceptable 0/0
Miscellaneous counters:
RedirectRspMappedToClientErr 0
 
SIP Total Traffic Statistics (Inbound/Outbound)
Invite 0/0, Ack 0/0, Bye 0/0,
Cancel 0/0, Options 0/0,
Prack 0/0, Comet 0/0,
Subscribe 0/0, NOTIFY 0/0,
Refer 0/0, Info 0/0
Register 49/16
 
Retry Statistics
Invite 0, Bye 0, Cancel 0, Response 0,
Prack 0, Comet 0, Reliable1xx 0, NOTIFY 0
Register 4
 
SDP application statistics:
Parses: 0, Builds 0
Invalid token order: 0, Invalid param: 0
Not SDP desc: 0, No resource: 0
Last time SIP Statistics were cleared: <never>
 

次の出力例は、RedirectResponseMappedToClientError ステータス メッセージを示します。増分された番号は、3 xx 応答が 4 xx として処理されることを示します。コール リダイレクションがイネーブルになっている場合(デフォルト)、RedirectResponseMappedToClientError ステータス メッセージは増分されません。

Router# show sip-ua statistics
 
SIP Response Statistics (Inbound/Outbound)
Informational:
Trying 0/0, Ringing 0/0,
Forwarded 0/0, Queued 0/0,
SessionProgress 0/0
Success:
OkInvite 0/0, OkBye 0/0,
OkCancel 0/0, OkOptions 0/0,
OkPrack 0/0, OkPreconditionMet 0/0,
OKSubscribe 0/0, OkNotify 0/0,
202Accepted 0/0
Redirection (Inbound only):
MultipleChoice 0, MovedPermanently 0,
MovedTemporarily 0, UseProxy 0,
AlternateService 0
Client Error:
BadRequest 0/0, Unauthorized 0/0,
PaymentRequired 0/0, Forbidden 0/0,
NotFound 0/0, MethodNotAllowed 0/0,
NotAcceptable 0/0, ProxyAuthReqd 0/0,
ReqTimeout 0/0, Conflict 0/0, Gone 0/0,
ReqEntityTooLarge 0/0, ReqURITooLarge 0/0,
UnsupportedMediaType 0/0, BadExtension 0/0,
TempNotAvailable 0/0, CallLegNonExistent 0/0,
LoopDetected 0/0, TooManyHops 0/0,
AddrIncomplete 0/0, Ambiguous 0/0,
BusyHere 0/0, RequestCancel 0/0
NotAcceptableMedia 0/0, BadEvent 0/0
Server Error:
InternalError 0/0, NotImplemented 0/0,
BadGateway 0/0, ServiceUnavail 0/0,
GatewayTimeout 0/0, BadSipVer 0/0,
PreCondFailure 0/0
Global Failure:
BusyEverywhere 0/0, Decline 0/0,
NotExistAnywhere 0/0, NotAcceptable 0/0
Miscellaneous counters:
RedirectResponseMappedToClientError 1,
SIP Total Traffic Statistics (Inbound/Outbound)
Invite 0/0, Ack 0/0, Bye 0/0,
Cancel 0/0, Options 0/0,
Prack 0/0, Comet 0/0,
Subscribe 0/0, Notify 0/0,
Refer 0/0
 
Retry Statistics
Invite 0, Bye 0, Cancel 0, Response 0,
Prack 0, Comet 0, Reliable1xx 0, Notify 0
 
SDP application statistics:
Parses: 0, Builds 0
Invalid token order: 0, Invalid param: 0
Not SDP desc: 0, No resource: 0
 

ステップ 4 show sip-ua status

このコマンドを使用して、コール リダイレクションがイネーブルになっているか、ディセーブルになっているかを含む、SIP User-Agent(UA; ユーザ エージェント)のステータスを表示します。

Router# show sip-ua status
 
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP max-forwards : 6
SIP DNS SRV version: 1 (rfc 2052)
Redirection (3xx) message handling: ENABLED
 

ステップ 5 show sip-ua timers

このコマンドを使用して、SIP ユーザ エージェント(UA)タイマーの現在の設定を表示します。

次の出力例は、登録要求が送信されるまでの待機時間( timers register コマンドで設定された値)を示します。

Router# show sip-ua timers
 
SIP UA Timer Values (millisecs)
trying 500, expires 180000, connect 500, disconnect 500
comet 500, prack 500, rel1xx 500, notify 500
refer 500, register 500
 


 

一般的なトラブルシューティングのヒント


) トラブルシューティングの詳細については、次の参考資料を参照してください。

『Cisco IOS Voice Troubleshooting and Monitoring Guide』

『Cisco Technical Support』( http://www.cisco.com/en/US/support/index.html

『Cisco IOS Debug Command Reference』

『Cisco IOS Voice, Video, and Fax Configuration Guide』

『Troubleshooting and Debugging VoIP Call Basics』

『VoIP Debug Commands』


 


) コマンドは、アルファベット順に示しています。


VoIP が動作していることを確認します。

音声コールを行うことができることを確認します。

SIP でサポートされるコードが使用されていることを確認します。コーデックのサポートは、プラットフォームごとに異なります。特定のプラットフォームで使用できるコーデックを確認するには、 codec ? コマンドを使用します。

debug aaa authentication コマンドを使用して、Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)ログイン関連の高レベル診断を表示します。

debug asnl events コマンドを使用して、SIP 加入サーバが稼動していることを確認します。たとえば、クライアントがサーバとの通信に失敗した場合は、出力に保留中のメッセージが表示されます。

debug call fallback ファミリのコマンドを使用して、VoIP コールのフォールバックの詳細を表示します。

debug cch323 ファミリのコマンドを使用して、H.323 サブシステム内のさまざまなコンポーネントのデバッグ出力を表示します。

debug ccsip ファミリのコマンドは、方向アトリビュート設定、ポートやネットワーク アドレス変換トレースの表示など、一般的な SIP のデバッグに使用します。次のコマンドのいずれかを使用します。

debug ccsip all: すべての SIP 関連のデバッグをイネーブルにします。

debug ccsip calls :すべての SIP Service-Provider Interface(SPI; サービス プロバイダー インターフェイス)コールのトレースをイネーブルにします。

debug ccsip error :SIP SPI エラーのトレースをイネーブルにします。

debug ccsip events :すべての SIP SPI イベントのトレースをイネーブルにします。

debug ccsip info :一般的な SIP SPI 情報のトレース(コール リダイレクションがディセーブルであるかどうかの確認を含む)をイネーブルにします。

debug ccsip media :SIP メディア ストリームのトレースをイネーブルにします。

debug ccsip messages :SIP User-Agent Client(UAC; ユーザ エージェント クライアント)とアクセス サーバ間で交換されるメッセージのトレースなど、すべての SIP SPI メッセージ トレースをイネーブルにします。

debug ccsip preauth :SIP コールの認証、認可、アカウンティング(AAA)事前認証の診断レポートをイネーブルにします。

debug ccsip states :すべての SIP SPI ステート トレースのトレースをイネーブルにします。

debug ccsip transport :SIP 転送ハンドラおよび Transmission Control Protocol(TCP)または User Datagram Protocol(UDP; ユーザ データグラム プロトコル)プロセスのトレースをイネーブルにします。

debug isdn q931 コマンドを使用して、ローカル ルータ(ユーザ側)とネットワークの間の ISDN ネットワーク接続(レイヤ 3)のコールのセットアップおよびティアダウンに関する情報を表示します。

debug kpml コマンドを使用して、KeyPad Markup Language(KPML)パーサーおよびビルダ エラーのデバッグ トレースをイネーブルにします。

debug radius コマンドを使用して、Remote Access Dial-In User Service(RADIUS)アトリビュートのデバッグ トレースをイネーブルにします。

debug rpms-proc preauth コマンドを使用して、H.323 コール、SIP コール、または H.323 コールと SIP コールの両方の Resource Policy Management System(RPMS; リソース ポリシー管理システム)プロセスで、デバッグ トレースをイネーブルにします。

debug rtr trace コマンドを使用して、Service Assurance Agent(SAA; サービス保証エージェント)操作の実行をトレースします。

次に示す debug voip ファミリのコマンドを使用します。

debug voip ccapi protoheaders 発信側と着信側のゲートウェイ間で送信されたメッセージを表示します。着信側ゲートウェイがヘッダーを受信していない場合は、発信側ゲートウェイで header-passing コマンドがイネーブルになっていることを確認します。

debug voip ivr script: Toolkit command language(Tcl; ツールキット コマンド言語)スクリプトの実行中に発生した可能性があるエラーを表示します。

debug voip rtp session named-event 101 コーデック タイプ g726r16 または g726r24 を使用している場合に、Dual Tone MultiFrequency(DTMF)リレー デバッグにとって重要な情報を表示します。失敗によるメッセージとすべてのコールでコンソール画面がフラッディングしないように、引数 101 をコマンドに付加してください。

これらのコマンドの一部の出力例を次に示します。

「debug ccsip events コマンドの出力例」

「debug ccsip info コマンドの出力例」

debug ccsip events コマンドの出力例

この例は、Proxy-Authorization ヘッダーがどのようにデコード済みのユーザ名およびパスワードに分解されているのかを示します。

Router# debug ccsip events
 
CCSIP SPI: SIP Call Events tracing is enabled
 
21:03:21: sippmh_parse_proxy_auth: Challenge is 'Basic'.
21:03:21: sippmh_parse_proxy_auth: Base64 user-pass string is 'MTIzNDU2Nzg5MDEyMzQ1Njou'.
21:03:21: sip_process_proxy_auth: Decoded user-pass string is '1234567890123456:.'.
21:03:21: sip_process_proxy_auth: Username is '1234567890123456'.
21:03:21: sip_process_proxy_auth: Pass is '.'.
21:03:21: sipSPIAddBillingInfoToCcb: sipCallId for billing records =
10872472-173611CC-81E9C73D-F836C2B6@172.18.192.19421:03:21: ****Adding to UAS Request table

debug ccsip info コマンドの出力例

この例は、コール リダイレクションがディセーブルであることを示すデバッグ出力の部分だけを示します。コール リダイレクションがイネーブルの場合(デフォルト)、デバッグ行の変更はありません。

Router# debug ccsip info
 
00:20:32: HandleUdpSocketReads :Msg enqueued for SPI with IPaddr: 172.18.207.10
:5060
00:20:32: CCSIP-SPI-CONTROL: act_sentinvite_new_message
00:20:32: CCSIP-SPI-CONTROL: sipSPICheckResponse
00:20:32: sip_stats_status_code
00:20:32: ccsip_get_code_class: !!Call Redirection feature is disabled on the GW
00:20:32: ccsip_map_call_redirect_responses: !!Mapping 302 response to 480
00:20:32: Roundtrip delay 4 milliseconds for method INVITE

SIP の基本設定の設定例

ここでは、次の設定例について説明します。

「SIP 登録サポートの例」

「SIP リダイレクト処理拡張の例」

「SIP 300 Multiple Choice メッセージの例」

SIP 登録サポートの例

Current configuration : 3394 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
voice service voip
redirect ip2ip
sip
redirect contact order best-match
 
ip dhcp pool vespa
network 192.168.0.0 255.255.255.0
option 150 ip 192.168.0.1
default-router 192.168.0.1
!
voice call carrier capacity active
!
voice class codec 1
codec preference 2 g711ulaw
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Ethernet0/0
ip address 10.8.17.22 255.255.0.0
half-duplex
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id vespa2 ipaddr 10.8.15.4 1718
!
router rip
network 10.0.0.0
network 192.168.0.0
!
ip default-gateway 10.8.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.0.1
no ip http server
ip pim bidir-enable
!
tftp-server flash:SEPDEFAULT.cnf
tftp-server flash:P005B302.bin
call fallback active
!
call application global default.new
call rsvp-sync
!
voice-port 1/0
!
voice-port 1/1
!
mgcp profile default
!
dial-peer voice 1 pots
destination-pattern 5100
port 1/0
!
dial-peer voice 2 pots
destination-pattern 9998
port 1/1
!
dial-peer voice 123 voip
destination-pattern [12]...
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
!
gateway
!
sip-ua
retry invite 3
retry register 3
timers register 150
registrar dns:myhost3.example.com expires 3600
registrar ipv4:10.8.17.40 expires 3600 secondary
!
telephony-service
max-dn 10
max-conferences 4
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
login
!
no scheduler allocate
end

SIP リダイレクト処理拡張の例

ここでは、前の項で説明した設定作業に対応する設定例を示します。

「ディセーブルにされたコール リダイレクション」

「イネーブルにされたコール リダイレクション」

「IP-IP リダイレクションを使用するコール リダイレクション」

「SIP 300 Multiple Choice メッセージの例」


) 例に示す IP アドレスおよびホスト名は架空のものです。


ディセーブルにされたコール リダイレクション

この例では、コール リダイレクションはゲートウェイでディセーブルにされています。

Router# show running-config
 
Building configuration...
 
Current configuration : 2791 bytes
!
version 12.2
service config
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
!
interface FastEthernet2/0
ip address 172.18.200.24 255.255.255.0
duplex auto
no shut
speed 10
ip rsvp bandwidth 7500 7500
!
voice-port 1/1/1
no supervisory disconnect lcfo
!
dial-peer voice 1 pots
application session
destination-pattern 8183821111
port 1/1/1
!
dial-peer voice 3 voip
application session
destination-pattern 7173721111
session protocol sipv2
session target ipv4:172.18.200.36
codec g711ulaw
!
dial-peer voice 4 voip
application session
destination-pattern 6163621111
session protocol sipv2
session target ipv4:172.18.200.33
codec g711ulaw
!
gateway
!
sip-ua
no redirection
retry invite 1
retry bye 1
!
line con 0
line aux 0
line vty 0 4
login
!
end

イネーブルにされたコール リダイレクション

この例では、コール リダイレクションはゲートウェイでイネーブルにされています(デフォルト)。コール リダイレクションがイネーブルの場合、出力にはリダイレクションは表示されません。

Router# show running-config
 
Building configuration...
 
Current configuration : 2791 bytes
!
version 12.2
service config
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
service udp-small-servers
!
interface FastEthernet2/0
ip address 172.18.200.24 255.255.255.0
duplex auto
no shut
speed 10
ip rsvp bandwidth 7500 7500
!
voice-port 1/1/1
no supervisory disconnect lcfo
!
dial-peer voice 1 pots
application session
destination-pattern 8183821111
port 1/1/1
!
dial-peer voice 3 voip
application session
destination-pattern 7173721111
session protocol sipv2
session target ipv4:172.18.200.36
codec g711ulaw
!
dial-peer voice 4 voip
application session
destination-pattern 6163621111
session protocol sipv2
session target ipv4:172.18.200.33
codec g711ulaw
!
gateway
!
sip-ua
retry invite 1
retry bye 1
!
line con 0
line aux 0
line vty 0 4
login
!
end

IP-IP リダイレクションを使用するコール リダイレクション

この例では、リダイレクションはルータでグローバルに設定されています。

Current configuration : 3394 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
voice service voip
redirect ip2ip
sip
redirect contact order best-match
 
ip dhcp pool vespa
network 192.168.0.0 255.255.255.0
option 150 ip 192.168.0.1
default-router 192.168.0.1
!
voice call carrier capacity active
!
voice class codec 1
codec preference 2 g711ulaw
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Ethernet0/0
ip address 10.8.17.22 255.255.0.0
half-duplex
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id vespa2 ipaddr 10.8.15.4 1718
!
router rip
network 10.0.0.0
network 192.168.0.0
!
ip default-gateway 10.8.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.0.1
no ip http server
ip pim bidir-enable
!
tftp-server flash:SEPDEFAULT.cnf
tftp-server flash:P005B302.bin
call fallback active
!
!
call application global default.new
call rsvp-sync
!
voice-port 1/0
!
voice-port 1/1
!
mgcp profile default
!
dial-peer voice 1 pots
destination-pattern 5100
port 1/0
!
dial-peer voice 2 pots
destination-pattern 9998
port 1/1
!
dial-peer voice 123 voip
destination-pattern [12]...
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
!
gateway
!
sip-ua
retry invite 3
retry register 3
timers register 150
registrar dns:myhost3.example.com expires 3600
registrar ipv4:10.8.17.40 expires 3600 secondary
!
!
telephony-service
max-dn 10
max-conferences 4
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
login
!
no scheduler allocate
end

SIP 300 Multiple Choice メッセージの例

ここでは、redirect contact order が best-match に設定された設定例を示します。

Current configuration : 3394 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
memory-size iomem 15
ip subnet-zero
!
no ip domain lookup
!
voice service voip
redirect ip2ip
sip
redirect contact order best-match
 
ip dhcp pool vespa
network 192.168.0.0 255.255.255.0
option 150 ip 192.168.0.1
default-router 192.168.0.1
!
voice call carrier capacity active
!
voice class codec 1
codec preference 2 g711ulaw
!
no voice hpi capture buffer
no voice hpi capture destination
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Ethernet0/0
ip address 10.8.17.22 255.255.0.0
half-duplex
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id vespa2 ipaddr 10.8.15.4 1718
!
router rip
network 10.0.0.0
network 192.168.0.0
!
ip default-gateway 10.8.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.0.1
no ip http server
ip pim bidir-enable
!
tftp-server flash:SEPDEFAULT.cnf
tftp-server flash:P005B302.bin
call fallback active
!
call application global default.new
call rsvp-sync
!
voice-port 1/0
!
voice-port 1/1
!
mgcp profile default
!
dial-peer voice 1 pots
destination-pattern 5100
port 1/0
!
dial-peer voice 2 pots
destination-pattern 9998
port 1/1
!
dial-peer voice 123 voip
destination-pattern [12]...
session protocol sipv2
session target ipv4:10.8.17.42
dtmf-relay sip-notify
!
gateway
!
sip-ua
retry invite 3
retry register 3
timers register 150
registrar dns:myhost3.example.com expires 3600
registrar ipv4:10.8.17.40 expires 3600 secondary
!
telephony-service
max-dn 10
max-conferences 4
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
login
!
no scheduler allocate
end

電話ハッカーの侵入阻止

シスコ ルータ プラットフォームに音声対応 Cisco IOS ソフトウェア イメージをインストールする場合、不正なユーザによる電話ハッカーの侵入の可能性を防ぐためにプラットフォームで適切な機能をイネーブルにする必要があります。これらの機能は、音声コールを処理する Unified Communications アプリケーションすべてに展開します。アプリケーションには、Cisco Unified Communications Manager Express(Cisco Unified CME)、Cisco Survivable Remote Site Telephony(SRST)、Cisco Unified Border Element(Cisco UBE)、Cisco IOS ベースのルータ、スタンドアロンのアナログおよびデジタルの PBX 、公衆電話交換網(PSTN)ゲートウェイ、Cisco contact-center VoiceXML ゲートウェイなどがあります。これらの機能には次のようなものがあります。

音声ポートで第 2 発信音をディセーブルにする:デフォルトでは、第 2 発信音はシスコ ルータ ゲートウェイの音声ポートで再生されます。インバウンド発信者に対して第 2 発信音が再生されないようにするには、Foreign Exchange Office(FXO)ポートには Private Line Automatic Ringdown(PLAR)、T1/E1 ポートには Direct-Inward-Dial(DID)を使用します。

シスコ ルータの Access Control List(ACL; アクセス コントロール リスト):ACL を定義して、ルータまたはゲートウェイへのコールの明示的に有効な発信者だけを許可し、未知の発信者からの不正な SIP または H.323 コールがルータまたはゲートウェイによって処理および接続されないようにします。

使用されていない SIP および H.323 ポートを閉じる:配置で SIP または H.323 プロトコルのいずれかが使用されていない場合、そのプロトコルのポートを閉じます。シスコ音声ゲートウェイに、Time Division Multiplexing(TDM; 時分割多重)トランクまたは IP を使用して PSTN に発信コールをルーティングするようにダイヤル ピアが設定されている場合、不正なエンドポイントからのコールがコールを接続できないように、使用されていない H.323 または SIP ポートを閉じます。これらのプロトコルが使用されており、ポートを開いておく必要がある場合、ACL を使用して正当な発信元へのアクセスを制限します。

SIP ポート 5060 を変更する:SIP がアクティブに使用されている場合、ポートを既知のポート 5060 以外に変更することを検討します。

SIP 登録:SIP トランクで SIP 登録を使用できる場合、この機能をオンにします。これは、正当な発信元だけがコールを接続できる認証および検証レベルが追加されるためです。SIP 登録が使用できない場合は、適切な ACL が設定されていることを確認します。

SIP ダイジェスト認証:SIP ダイジェスト認証機能が登録または招待に使用できる場合、この機能をオンにします。これは、正当な発信元だけがコールを接続できる認証および検証レベルが追加されるためです。

明示的な着信および発信ダイヤル ピア:特に Cisco Unified CME、SRST、および Cisco UBE での IP-IP 接続で、明示的なダイヤル ピアを使用してルータによって許可されるコールのタイプおよびパラメータを制御します。着信ダイヤル ピアはコールの発信元、発信ダイヤル ピアは宛先をさらに制御します。着信ダイヤル ピアは常にコールに使用されます。ダイヤル ピアが明示的に定義されていない場合、暗黙のダイヤル ピア 0 を使用してすべてのコールを許可します。

明示的な宛先パターン:宛先パターンに .T より細かい粒度のダイヤル ピアを使用して、許可されていないオフネット コール宛先をブロックします。特定の宛先パターンを持つダイヤル ピアで Class Of Restriction(COR; 制限クラス)を使用すると、PSTN のさまざまな宛先へのコールをさらに詳細に制御できます。

トランスレーション ルール:トランスレーション ルールを使用して、コールが PSTN に接続する前にダイヤルされた番号を操作し、PSTN の宛先にダイヤルできるユーザを詳細に制御します。正当なユーザは、特定の PSTN(国際など)の場所に PSTN のアクセス コードおよび拡張番号をダイヤルします。

Tcl および VoiceXML スクリプト:Tcl/VoiceXML スクリプトをダイヤル ピアに付加して、データベース検索や追加のルータ外許可チェックを実行し、発信番号または宛先番号に基づいてコール フローを許可または拒否します。Tcl/VoiceXML スクリプトを使用して、インバウンド DID コールにプレフィクスを追加することもできます。プレフィクスと DID が内線と一致すると、コールは完了します。一致しない場合、無効な番号がダイヤルされたというプロンプトを発信者に対して再生できます。

ホスト名の検証:「ホスト名の許可」機能を使用して、Request Uniform Resource Identifier(Request URI)に Fully Qualified Domain Name(FQDN; 完全修飾ドメイン名)ホスト名を含む初期 SIP Invite を、正当な発信元ホスト名の設定済みリストに対して検証します。

ダイナミック Domain Name Service(DNS; ドメイン ネーム サービス):DNS をダイヤル ピアの「セッション ターゲット」として 使用している場合、コール接続の実際の IP アドレス宛先はコールごとに異なることがあります。音声ソース グループおよび ACL を使用して、DNS 応答で予想される有効なアドレス範囲を制限します(このアドレス範囲は後でコール設定宛先に使用されます)。

設定に関するガイダンスについては、『 Cisco IOS Unified Communications Manager Express Toll Fraud Prevention 』を参照してください。

その他の参考資料

SIP Features Roadmap 」:Cisco Feature Navigator にアクセスする手順について説明します。また、Cisco IOS リリース別に、そのリリースの SIP 機能を示して説明します。