Cisco IOS IP マルチキャスト コンフィギュレー ション ガイド
マルチキャスト サービス リフレクションの実 装
マルチキャスト サービス リフレクションの実装
発行日;2012/02/01 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

マルチキャスト サービス リフレクションの実装

この章の構成

マルチキャスト サービス リフレクション実装の前提条件

マルチキャスト サービス リフレクション実装の制限事項

マルチキャスト サービス リフレクションの実装の概要

マルチキャスト サービス リフレクションを使用する利点

ランデブー ポイント

PIM 希薄モード

Vif1 インターフェイス

マルチキャスト サービス リフレクションのアプリケーション

マルチキャスト サービス リフレクション実装の一般的な設定手順

マルチキャスト サービス リフレクションの実装方法

マルチキャスト サービス リフレクションの設定

マルチキャスト サービス リフレクションの設定例

サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

用語集

マルチキャスト サービス リフレクションの機能情報

マルチキャスト サービス リフレクションの実装

マルチキャスト サービス リフレクション機能は、外部で受信したマルチキャスト宛先アドレスを、組織の内部アドレス ポリシーに準拠したアドレスに変換するための機能を提供します。この機能を使用すると、ユーザは、Reverse Path Forwarding(RPF)を正常に機能させるために変換の境界でルートを自分のネットワーク インフラストラクチャに再配布する必要がなくなり、ネットワーク内の 2 つの入力点から同一のフィードを受信して、個別にルーティングできます。

この章で紹介する機能情報の入手方法

ご使用の Cisco OS ソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールで説明される特定機能に関する情報へのリンク、および各機能がサポートされるリリースの一覧については、「マルチキャスト サービス リフレクションの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

マルチキャスト サービス リフレクション実装の前提条件

マルチキャスト サービス リフレクションの実装には、次の前提条件が適用されます。

複製されたパケットのマルチキャスト コードへの仮想インターフェイス(Vif1)処理は、初期パケットを受信するスイッチと同じスイッチング コンテキストで実行されるため、 ip mroute-cache コマンドをイネーブルにして、プロセス スイッチングを回避する必要があります。

Protocol Independent Multicast Sparse Mode(PIM-SM; PIM 希薄モード)、Bidirectional PIM(Bidir-PIM; 双方向 PIM)、または PIM Source Specific Multicast(PIM-SSM)のうちのいずれかの実行に必要なインフラストラクチャを使用してマルチキャスト対応ネットワークを設定します。設定プロセスには、Rendezvous Point(RP; ランデブー ポイント)、インターフェイス境界、または、Source Specific Multicast(SSM)範囲の設定などがあります。

設定の詳細については、『 Configuring Basic IP Multicast 』モジュールを参照してください。

境界ルータに、Vif1 インターフェイスがインストールされていること、マルチキャスト サービス リフレクションのアプリケーションがインストールされ、動作していることを確認します。

PIM ドメインのルータで定義されたマルチキャスト グループに参加するアクティブなレシーバがそれぞれ、Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)を起動する必要があります。

マルチキャスト サービス リフレクション実装の制限事項

マルチキャスト サービス リフレクションの実装には、次の制限事項が適用されます。

同一のマルチキャスト グループを宛先とするが異なるソースから送信されているマルチキャスト パケットの変換グループの場合、Source Specific Multicast を使用する場合と同様に、特定の SSM グループを宛先とする、すべてのマルチキャスト パケットは、変換の発生後に単一の (S, G) にマッピングされます。たとえば、10.1.1.1, 232.1.1.1 および 10.1.1.2, 232.1.1.1 に変換が必要な場合、これらは単一のエントリ、たとえば 192.168.1.2, 232.239.1.1 のように見えます。ここで、192.168.1.2 は、Vif1 IP サブネットの内側にある IP アドレスです。

PIM/IGMP コントロール パケットは変換されません。

マルチキャスト サービス リフレクション機能は、ファースト スイッチング パスだけで実装されます。ハードウェア サポートはありません。

マルチキャスト サービス リフレクションの実装の概要

マルチキャスト サービス リフレクションを実装するには、次の概念を理解しておく必要があります。

「マルチキャスト サービス リフレクションを使用する利点」

「ランデブー ポイント」

「Vif1 インターフェイス」

「マルチキャスト サービス リフレクションのアプリケーション」

「マルチキャスト サービス リフレクション実装の一般的な設定手順」

マルチキャスト サービス リフレクションを使用する利点

ユーザは、外部から受信したマルチキャスト宛先アドレスを、企業の内部アドレス ポリシーに準拠したアドレスに変換できます。

プライベート マルチキャスト ネットワークとパブリック マルチキャスト ネットワークを論理的に分離できます。

同一の発信インターフェイスから発信された(変換、または変換されていない)マルチキャスト パケットの転送に柔軟性を与えます。

ユーザがネットワークの 2 つの入力点から同一のフィードを入手し、それらを別々にルーティングできることから、冗長性が得られます。

ユーザは、自身が選択したサブネットをソース ネットワークとして使用でき、適切にスコープできます。

ランデブー ポイント

ランデブー ポイント(RP)は、ルータが PIM-SM または双方向 PIM で動作しているときに実行する役割です。RP が必要になるのは、PIM-SM または双方向 PIM を実行しているネットワークだけです。PIM-SM では、マルチキャスト データを明示的に要求したアクティブなレシーバを含むネットワーク セグメントだけにトラフィックが転送されます。

RP は、マルチキャスト データのソースとレシーバが出会う場所として動作します。PIM-SM ネットワークでは、ソースはトラフィックを RP に送信する必要があります。このトラフィックは、共有配信ツリーの下方向にあるレシーバに転送されます。デフォルトでは、レシーバのファースト ホップ ルータは、ソースを認識すると、ソースに加入メッセージを直接送信し、ソースからレシーバへのソース ベースの配信ツリーを作成します。ソースとレシーバ間の最短パスに RP が存在しない限り、このソース ツリーには RP は含まれません。

ほとんどの場合、ネットワークにおける RP の配置は複雑な判断を必要としません。デフォルトでは、RP が必要になるのは、ソースおよびレシーバとの新しいセッションを開始する場合だけです。その結果、RP では、トラフィックのフローまたは処理によるオーバーヘッドはほとんど発生しません。PIM バージョン 2 では、ステートを作成する RP にソースが定期的に登録するだけなので、RP が実行する処理は PIM バージョン 1 よりも少なくなります。

PIM 希薄モード

PIM Sparse Mode(PIM-SM; PIM 希薄モード)は、プル モデルを使用してマルチキャスト トラフィックを配信します。明示的にデータを要求したアクティブなレシーバを含むネットワーク セグメントだけがトラフィックを受信します。

稠密モード インターフェイスとは異なり、希薄モード インターフェイスがマルチキャスト ルーティング テーブルに追加されるのは、ダウンストリーム ルータから定期的な加入メッセージを受信している場合、または直接接続されたメンバがインターフェイス上に存在する場合だけです。LAN から転送する場合、グループが認識している Rendezvous Point(RP; ランデブー ポイント)が存在すると希薄モード動作が発生します。その場合は、パケットがカプセル化され、RP に向けて送信されます。認識されている RP が存在しない場合は、稠密モード方式でパケットがフラッディングされます。特定のソースからのマルチキャスト トラフィックが十分である場合、レシーバのファースト ホップ ルータは、ソース ベースのマルチキャスト配信ツリーを構築するために加入メッセージをソースに向けて送信できます。

PIM-SM は、共有ツリーでデータ パケットを転送することにより、アクティブなソースに関する情報を配信します。PIM-SM は(少なくとも最初は)共有ツリーを使用するので、ランデブー ポイント(RP)の使用が必須です。RP は、管理者によってネットワーク内で設定されている必要があります。

希薄モードでは、ルータは、明示的なトラフィックの要求がない限り、他のルータが特定のグループのマルチキャスト パケットの転送を求めることはないと想定します。ホストがマルチキャスト グループに加入すると、直接接続されたルータは、RP に向けて PIM 加入メッセージを送信します。RP はマルチキャスト グループを追跡します。マルチキャスト パケットを送信するホストは、そのホストのファースト ホップ ルータによって RP に登録されます。その後、RP はソースに向けて加入メッセージを送信します。この時点で、パケットが共有配信ツリー上で転送されます。特定のソースからのマルチキャスト トラフィックが十分である場合、ホストのファースト ホップ ルータは、ソース ベースのマルチキャスト配信ツリーを構築するために加入メッセージをソースに向けて送信できます。

ソースに直接接続されたファースト ホップの代表ルータが RP に登録されると、データは共有ツリーの下方向に転送され、レシーバに到達します。エッジ ルータは、共有ツリー上のデータ パケットを特定のソースから RP 経由で受信した時点で、そのソースについて知ります。次に、エッジ ルータは、そのソースに向けて PIM (S, G)加入メッセージを送信します。リバース パス上の各ルータは、RP アドレスのユニキャスト ルーティング メトリックをソース アドレスのメトリックと比較します。ソース アドレスのメトリックの方が良い場合は、ソースに向けて PIM (S, G) 加入メッセージを転送します。RP のメトリックと同じ、または RP のメトリックの方が良い場合は、RP と同じ方向に PIM (S, G)加入メッセージが送信されます。この場合、共有ツリーとソース ツリーは一致しているとみなされます。

共有ツリーがソースとレシーバの間の最適なパスでない場合、ルータは動的にソース ツリーを作成し、共有ツリーの下方向へのトラフィック フローを停止します。この動作は、Cisco IOS ソフトウェアのデフォルトの動作です。ネットワーク管理者は、Cisco IOS の ip pim spt-threshold infinity コマンドを使用して、トラフィックを強制的に共有ツリー上で保持することができます。

PIM-SM は、WAN リンクを使用するネットワークも含め、あらゆるサイズのネットワークに適合します。明示的な加入メカニズムにより、不要なトラフィックによる WAN リンクのフラッディングを回避します。

Vif1 インターフェイス

Vif1 インターフェイスはループバック インターフェイスと似ており、ルータがアクティブなときは常にアップ状態にある論理 IP インターフェイスです。

Vif1 インターフェイスは固有のサブネットに存在しなければならず、そのサブネットは、ルーティング プロトコルのアップデート(Routing Information Protocol(RIP)、Open Shortest Path First(OSPF)など)に含まれる必要があります。

Vif1 インターフェイスは、入力インターフェイス、private-to-public mgroup マッピング、プール範囲を決定するマスク長、および、変換されたパケットのソースに関する情報を保持します。

マルチキャスト サービス リフレクションのアプリケーション

マルチキャスト サービス リフレクションは、Cisco IOS ソフトウェアの割り込みレベルスイッチングで動作するアプリケーションで、Cisco IOS ソフトウェアが Vif1 インターフェイスに転送したパケットを処理します。IP マルチキャスト Network Address Translation(NAT; ネットワーク アドレス変換)とは異なり、IP Reflect Service は、IP マルチキャスト ルーティングに統合されません。パケットが Vif1 インターフェイスに転送された場合、パケットのソース IP アドレスは、Vif サブネットの IP アドレスに変更されます。その結果、RPF 障害が回避されます。最後に、宛先 IP アドレスが新しいマルチキャスト グループに変換されます。さらに、オリジナルのマルチキャスト パケットは、ルータを通じて変換されずに転送されることもあります。たとえば、新しいマルチキャスト グループにまだ移動していないユーザは、変換されていないストリームを受信できます。

設定されたマルチキャスト サービス リフレクション ラインはそれぞれ、パケット照合を行い、Cisco IOS ユニキャストまたはマルチキャスト パケット ルーティングが Vif1 インターフェイスに送信したパケットに行われる書き換え動作を実施します。一致し、書き換えられたパケットは、Cisco IOS ユニキャストまたはマルチキャスト パケット ルーティングに送信され、インターフェイスから送信された他のパケットと同様に処理されます。

Vif1 インターフェイスは、「シンク」またはオリジナルのストリームのレシーバのように動作し、新しいストリームが Vif1 サブネットに直接接続されたソースから送信されたことを明らかにします。Vif1 インターフェイスは、ソースの Designated Router(DR; 代表ルータ)のように動作し、適切な RP に登録されます。

複数のマルチキャスト サービス リフレクションの動作を同じパケットに合うように設定できます。これによって、同一の受信トラフィックを複数の宛先アドレスに対して複製できます。Vif1 インターフェイスで設定できるマルチキャスト サービス リフレクション ステートメントの数にはっきりした制限はありません。

マルチキャスト サービス リフレクション機能は、ソフトウェアベースで非分散型転送プラットフォーム(Cisco 7200 シリーズ ルータおよびそれより下位のルータ)で動作する Cisco IOS Release 12.4(4)T で使用できます。

マルチキャスト サービス リフレクション実装の一般的な設定手順

マルチキャスト サービス リフレクションを実装するには、次の手順を完了させる必要があります。

1. 変換するマルチキャスト グループを特定します。

2. Vif1 インターフェイスで、サービス プロバイダー マルチキャスト グループへの IGMP の参加を静的に設定します。

3. コンテンツ プロバイダーのマルチキャスト グループの宛先アドレスを、PIM ドメインで使用できるマルチキャスト アドレスのプールに変換するように IP Reflect Service アプリケーションを設定し、これらのアドレスの新しいソースを定義します。

4. 新しく作成されたソース アドレスを内部ゲートウェイ プロトコル(OSPF、Intermediate System-to-Intermediate System(IS-IS)、Enhanced Interior Gateway Routing Protocol(EIGRP)など)にアドバタイズします。

マルチキャスト サービス リフレクションの実装方法

ここでは、次の作業について説明します。

「マルチキャスト サービス リフレクションの設定」

マルチキャスト サービス リフレクションの設定

次の作業を実行して、マルチキャスト サービス リフレクションを設定します。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. interface type number

5. ip pim sparse-mode

6. no shutdown

7. exit

8. それぞれの PIM インターフェイスでステップ 4 ~ 7 を繰り返します。

9. interface type number

10. ip address ip-address mask [ secondary ]

11. ip pim sparse-mode

12. ip service reflect input-interface destination destination-address to new-destination-address mask-len number source new-source-address

13. ip igmp static-group { * | group-address [ source { source-address | ssm-map }]}

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP multicast routing(mroute; マルチキャスト ルーティング)をイネーブルにします。

distributed キーワードを使用して、Multicast Distributed Switching(MDS; マルチキャスト分散スイッチング)機能をイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 0

特定のインターフェイス タイプおよび番号のインターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスの PIM 希薄モードをイネーブルにします。

ステップ 6

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

それぞれの PIM インターフェイスでステップ 4 ~ 7 を繰り返します。

--

ステップ 9

interface type number

 

Router(config)# interface Vif1

特定のインターフェイス タイプおよび番号のインターフェイス コンフィギュレーション モードを開始します。

Vif1 インターフェイスは、マルチキャスト サービス リフレクションの仮想インターフェイスです。

ステップ 10

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.1.1.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 11

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスで PIM 希薄モードをイネーブルにします。

ステップ 12

ip service reflect input-interface destination destination-address to new-destination-address mask-len number source new-source-address

 

Router(config-if)# ip service reflect ethernet0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source 10.1.1.2

Vif1 インターフェイスにルーティングされたマルチキャスト パケットを照合し、書き換えます。

一致し、書き換えられたパケットは、Cisco マルチキャスト パケット ルーティングに送信され、インターフェイスから送信された他のパケットと同様に処理されます。

ステップ 13

ip igmp static-group { * | group-address [ source { source-address | ssm-map }]}

 

Router(config-if)# ip igmp static-group 224.1.1.1

ルータを、静的に接続されたインターフェイス上の特定のグループのメンバに設定するか、またはインターフェイスのマルチキャスト グループに静的に転送するように設定します。

ステップ 14

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

マルチキャスト サービス リフレクションの設定例

ここでは、次の例を示します。

「サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション:例」

サービス プロバイダー ネットワークのマルチキャスト サービス リフレクション:例

次に、サービス プロバイダー ネットワークのマルチキャスト サービス リフレクションの実装方法例を示します。

この例では、図 1 に示されるトポロジを使用します。

図 1 サービス プロバイダー ネットワークのマルチキャスト サービス リフレクションのサンプル トポロジ

 

このサンプル トポロジでは、コンテンツ プロバイダーが金融市場情報をサービス プロバイダーに送信しています。次にサービス プロバイダーは、この情報をアクティブなレシーバ(取次業者)に送信しています。サービス プロバイダーが市場データを複数のコンテンツ プロバイダーから受信していることもあります。

ルータ R1 は、サービス プロバイダーの PIM ドメインのエッジ ルータです。R1 には Vif1 インターフェイスがあり、マルチキャスト サービス リフレクションのアプリケーションが動作しています。

ルータ R2 には、ループバック インターフェイスがあり、239.2.2.0 アドレス範囲の RP として機能しています。

ルータ R3 は、サービス プロバイダーの PIM ドメインのもう一つのエッジ ルータです。

! Enter these commands on the router running the multicast service reflection application (R1 in Figure 1)

!

configure terminal

ip multicast-routing

interface Ethernet 0

ip address 10.0.2.1 255.255.255.0

ip pim sparse-mode

no shutdown

!

interface Ethernet 1

ip address 10.0.3.1 255.255.255.0

ip pim sparse-mode

no shutdown

!

! Configure the loopback interface for the Service Provider RP

!

interface loopback 0

ip address 192.168.2.1 255.255.255.255

!

ip pim rp-address 192.168.2.1 mcast-content-provider-groups override

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

!

! Configure the Vif1 virtual interface for multicast service reflection

!

interface Vif1

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip service reflect Ethernet 0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source 10.1.1.2

ip igmp static-group 224.1.1.1

ip igmp static-group 224.1.1.2

ip igmp static-group 224.1.1.3

.

.

.

ip igmp static-group 224.1.1.255

!

! Enter these commands on the router that is the RP in the service provider network (R2 in Figure 1)

!

ip multicast-routing

interface loopback 0

ip address 192.168.2.2 255.255.255.255

!

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

!

!Enter these commands on all the other routers in the service provider network (R3 in Figure 1)

!

ip multicast-routing

ip pim rp-address 192.168.2.2 mcast-service-provider-groups override

ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255

end

!

その他の参考資料

ここでは、マルチキャスト サービス リフレクション機能に関する参考資料について説明します。

関連資料

関連項目
参照先

マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能で変更された既存 RFC のサポートはありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポートおよびドキュメンテーション Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、ツール、技術マニュアルへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/techsupport

用語集

ソース ツリー:ネットワーク上での最短パスを取得するために、ソースおよびレシーバの代表ルータ(またはランデブー ポイント)を直接接続するマルチキャスト配信パス。ソースとレシーバの間で最も効率的にデータをルーティングできますが、RP 以外のデバイスで構築されると、ネットワーク全体で不要なデータ重複が発生する可能性があります。

配信ツリー:マルチキャスト トラフィックは、すべてのソースをグループ内のすべてのレシーバに接続する配信ツリー上で、ソースからマルチキャスト グループに流れます。このツリーをすべてのソース(共有ツリー)で共有したり、ソース(ソース ツリー)ごとに個別の配信ツリーを構築したりできます。共有ツリーは一方向または双方向です。

プロトコル独立マルチキャスト(PIM):既存の IP ネットワーク上で IP マルチキャスト ルーティングを実現する、Internet Engineering Task Force(IETF)によって定義されたマルチキャスト ルーティング アーキテクチャ。要点は、基礎となる OSPF や BGP などのユニキャスト プロトコルから独立していることです。

マルチキャスト:IP トラフィックを 1 つのソースまたは複数のソースから送信し、複数の宛先に配信できるようにするルーティング技術。宛先ごとに個別のパケットを送信する代わりに、単一の IP 宛先グループ アドレスによって識別される宛先のグループ(マルチキャスト グループと呼ばれます)に単一のパケットを送信します。マルチキャスト アドレッシングでは、単一の IP データグラムから複数のホストへの送信がサポートされます。

ユニキャスト:各要求者に個別にメッセージのコピーを送信するようにソースに要求するポイントツーポイント送信。

ランデブー ポイント(RP):PIM-SM の共有マルチキャスト配信ツリーのルートであるマルチキャスト ルータ。

マルチキャスト サービス リフレクションの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator により、どの Cisco IOS および Catalyst OS ソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 マルチキャスト サービス リフレクションの機能情報

機能名
リリース
機能情報

マルチキャスト サービス リフレクション

12.4(4)T

マルチキャスト サービス リフレクション機能によって、外部から受信したマルチキャスト宛先アドレスを、組織の内部アドレス ポリシーに準拠したアドレスに変換できます。この機能を使用すると、ユーザは、Reverse Path Forwarding(RPF)を正常に機能させるために変換の境界でルートを自分のネットワーク インフラストラクチャに再配布する必要がなくなり、ネットワーク内の 2 つの入力点から同一のフィードを受信して、個別にルーティングできます。

この機能に関する詳細については、次の各項を参照してください。

「マルチキャスト サービス リフレクションのアプリケーション」

「マルチキャスト サービス リフレクションの設定」

この機能により、次のコマンドが導入されました。 ip service reflect