Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド
DHCP サーバ オンデマンド アドレス プール マネージャの設定
DHCP サーバ オンデマンド アドレス プール マネージャの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/07/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

DHCP サーバ オンデマンド アドレス プール マネージャの設定

この章の構成

DHCP サーバ オンデマンド アドレス プール マネージャの設定時の前提条件

DHCP サーバ オンデマンド アドレス プール マネージャの設定時の制限事項

DHCP サーバ オンデマンド アドレス プール マネージャについて

ODAP マネージャの操作

サブネット割り当てのサーバ動作

ODAP を使用することの利点

DHCP サーバ オンデマンド アドレス プール マネージャの設定方法

DHCP ODAP をグローバル デフォルト メカニズムとして定義

インターフェイスの DHCP ODAP 定義

DHCP プールを ODAP として設定

IPCP ネゴシエーションでサブネットを取得するように ODAP を設定

AAA の設定

RADIUS の設定

ODAP AAA プロファイル

ODAP のディセーブル化

ODAP 操作の確認

トラブルシューティングのヒント

ODAP のモニタリングとメンテナンス

DHCP ODAP サブネット割り当てサーバ サポートの設定方法

サブネット割り当てサーバのグローバル プールの設定

グローバル サブネット プール

サブネット割り当てサーバの VRF サブネット プールの設定

VRF サブネット プール

前提条件

サブネット割り当てサーバの VRF サブネット プール設定における VPN ID の使用

VRF プールおよび VPN ID

前提条件

サブネット割り当ておよび DHCP バインディングの確認

DHCP ODAP サブネット割り当てサーバのトラブルシューティング

DHCP サーバ オンデマンド アドレス プール マネージャの設定例

グローバル デフォルト メカニズムとしての DHCP ODAP の定義:例

インターフェイスの DHCP ODAP 定義:例

DHCP プールを ODAP として設定:例

DHCP プールを非 MPLS VPN の ODAP として設定:例

IPCP サブネット マスクの配信:例

AAA および RADIUS の設定:例

サブネット割り当てサーバのグローバル プールの設定:例

サブネット割り当てサーバの VRF プールの設定:例

VPN ID を使用した、サブネット割り当てサーバの VRF プールの設定:例

サブネット割り当てサーバのローカル設定の確認:例

アドレス プール割り当て情報の確認:例

サブネット割り当てと DHCP バインディングの確認:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

用語集

DHCP サーバ オンデマンド アドレス プール マネージャの機能情報

DHCP サーバ オンデマンド アドレス プール マネージャの設定

Cisco IOS DHCP サーバ On-Demand Address Pool(ODAP; オンデマンド アドレス プール)マネージャは、大規模なアドレス プールを集中管理し、大規模ネットワークの設定を単純化するために使用されます。ODAP は、IP アドレスを割り当てるための中央管理ポイントを提供します。Cisco IOS ルータが ODAP マネージャとして設定されている場合、アドレスの利用レベルに応じて IP アドレスのプール サイズはダイナミックに増減します。ルータに設定された DHCP プールは、IP アドレス プーリング メカニズムとしても使用できます。IP アドレス プーリング メカニズムはルータに設定され、PPP ピアの IP アドレスのソースを指定します。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用の Cisco IOS ソフトウェア リリースに対応したリリース ノートを参照してください。 この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「DHCP サーバ オンデマンド アドレス プール マネージャの機能情報」を参照してください。

プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージのサポート情報の入手方法

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

DHCP サーバ オンデマンド アドレス プール マネージャの設定時の前提条件

ODAP マネージャを設定する前に、「DHCP の概要」モジュールで説明されている概念を理解しておく必要があります。

非 MPLS VPN を使用する予定でない限り、標準の Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を設定する必要があります。

IP アドレス プーリング メカニズムが正しく動作するには、PPP セッションの VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスが、プールで設定されたものと一致する必要があります。通常、このマッチングは、バーチャル テンプレート インターフェイスの ip vrf forwarding vrf-name コマンドで行うか、PPP ユーザの認証に AAA が使用されている場合は、ユーザのプロファイル設定の一部として行うことができます。

DHCP サーバ オンデマンド アドレス プール マネージャの設定時の制限事項

ip dhcp excluded-address グローバル コンフィギュレーション コマンドは、VRF に関連づけられたプールからアドレスを除外するために使用することはできません。

vrf DHCP プール コンフィギュレーション コマンドは現在、ホスト プールをサポートしていません。

アトリビュートの継承は、VRF プールについてはサポートされていません。

ルータは、同時にサブネット割り当てサーバおよび DHCP サーバとして設定できますが、1 つ制約があります。その制約とは、サブネット割り当てと IP アドレス割り当て用に別のプールを作成する必要があるということです。DHCP で 1 つのアドレス プールをサブネット割り当てと IP アドレス割り当ての両方には使用できません。

DHCP サーバ オンデマンド アドレス プール マネージャについて

ODAP を設定する前に、次の概念を理解しておく必要があります。

「ODAP マネージャの操作」

「サブネット割り当てのサーバ動作」

「ODAP を使用することの利点」

ODAP マネージャの操作

ODAP は、アドレスの使用レベルに応じて IP アドレスのプールのサイズをダイナミックに増減することができます。設定すると、ODAP にはソース サーバからリースされた 1 つ以上のサブネットが入力され、DHCP クライアントまたは PPP セッションからのアドレス要求に応じられるようになります。ソース サーバとしては、リモート DHCP サーバまたは RADIUS サーバ(AAA)が可能です。現在、Cisco アクセス レジストラ RADIUS サーバだけが ODAP をサポートしています。一定の利用レベル(高利用マーク)に達したとき、プールにサブネットを追加することができます。利用レベルが一定レベル(低利用マーク)を下回ると、サブネットをリース元のサーバに戻すことができます。サブネットが ODAP に追加または削除されるごとに、リースされたサブネットごとの集約ルートが、関連する VRF に挿入または削除される必要があります。

ODAP は、MPLS VPN などのプライベート アドレスを使用しているお客様の DHCP を使用して、アドレス割り当てをサポートします。VPN を使用して、別々のネットワークにある 2 つのプールが同一のアドレス空間を共有することができます。このアドレス レンジには、同一の DHCP サーバによって処理されるプライベート ネットワーク アドレスがあります。これらの IP アドレスは VPN 識別情報により区別され、クライアントが属する VPN を選択する際に役立ちます。

各 ODAP は、特定の MPLS VPN で設定され、関連づけられます。 peer default ip address dhcp-pool pool-name コマンドに pool-name サポートを追加することで、Cisco IOS ソフトウェアは非 MPLS VPN アドレス プールもサポートします。

MPLS VPN では、VPN ごとに 1 つ以上の VRF と関連づけられます。VRF は VPN テクノロジーのキーとなる要素です。その理由は、カスタマー VPN サイトを定義するルーティング情報を VRF が持っているからです。このカスタマー サイトは、Provider Edge(PE; プロバイダー エッジ)ルータに接続されています。VRF は、IP ルーティング テーブル、取得された Cisco Express Forwarding(CEF)テーブル、転送テーブルを使用する一連のインターフェイス、およびルーティング テーブルに格納されている情報を制御するための一連のルールおよびルーティング プロトコル パラメータで構成されています。

特定の VPN に属する PPP セッションは、その VPN に関連付けられた ODAP からのアドレスを 1 つだけ割り当てられます。これらの PPP セッションは、ODAP が設定される Virtual Home Gateway(VHG; バーチャル ホーム ゲートウェイ)/PE ルータで終了します。VHG/PE ルータは、リモート ユーザを対応する MPLS VPN にマップします。

PPP セッションでは、ODAP からの個々のアドレス割り当ては、 F irst L eased subnet F irst (FLF) ポリシーに従います。FLF では、最初にリースされたサブネットから空きアドレスの検索を開始し、見つからない場合は 2 番目にリースされたサブネットを検索する、という順序で検索を続けます。このポリシーの利点は、時間の経過に伴ってリースされたアドレスをグループ化してサブネットのセットにすることで、サブネットのリリースとルート集約を効率的に行えることです。

ただし、FLF ポリシーは、通常の DHCP アドレス選択ポリシーとは異なっています。通常の DHCP アドレス選択では、受信インターフェイスの IP アドレスまたはゲートウェイ アドレス(ゼロでない場合)を考慮します。両方のポリシーをサポートするためには、DHCP サーバが、通常の DHCP アドレス要求と PPP クライアント用のアドレス要求を区別できる必要があります。ODAP マネージャは、PPP には IP アドレス プーリング メカニズムを使用し、DHCP サーバが通常の DHCP アドレス要求と PPP クライアントからの要求を区別できるようにしています。

ODAP からのサブネット リリースは、Last Leased subnet First LLF ポリシーに従っています。このポリシーでは、最後にリースされたサブネットが最初にリリースされます。この LLF ポリシーでは、最後にリースされたサブネットから、リリース可能なサブネット(現在、リースされているアドレスがないサブネット)を検索し始めます。リリース可能なサブネットが見つかった場合(候補のサブネット)はリリースされ、そのサブネットの集約ルートは削除されます。その際、リリース可能なサブネットが複数存在した場合、最後に割り当てられたサブネットだけがリリースされます。リリース可能なサブネットがない場合、なにも起こりません。候補のサブネットをリリースすると高利用マークに達する場合、そのサブネットはリリースされません。瞬間的な利用レベルにかかわりなく、最初にリースされたサブネットは、ODAP がディセーブルになるまで、決してリリースされません。

DHCP プールが、アップストリーム DHCP サーバから複数のサブネットを受信するとき、各サブネットからのアドレスは自動的に、クライアントに接続されたインターフェイスに設定され、サブネット内部のアドレスを DHCP クライアントから要求できるように設定されます。

最初のサブネットの最初のアドレスは、インターフェイスのプライマリ アドレスに自動的に割り当てられます。以降の各サブネットの最初のアドレスは、インターフェイスのセカンダリ アドレスに割り当てられます。さらに、クライアント アドレスが再要求されたとき、そのサブネットのリース アドレスのカウントは減少します。サブネットのリース カウンタがゼロになる、つまり、リース期限切れになると、そのサブネットはプールに戻されます。インターフェイスの前のアドレスは削除され、インターフェイスの最初のセカンダリ アドレスが、そのインターフェイスのプライマリ アドレスに昇格します。

図 1 は、Cisco IOS DHCP サーバに設定された ODAP マネージャです。ODAP は、最初のプールを AAA サーバに要求します。クライアントは DHCP 要求を行い、DHCP サーバはプールから要求を満たします。利用率が 90% に達すると ODAP マネージャは拡張を要求し、AAA サーバは、ODAP マネージャがアドレスを割り当てることが可能な他のサブネットを割り当てます。

図 1 MPLS VPN 用 ODAP アドレス プール管理

 

サブネット割り当てのサーバ動作

個々の IP アドレスの代わりにサブネットを割り当てるように ODAP マネージャを設定することもできます。

この機能を使用して、Cisco IOS ルータをサブネット割り当てサーバとして設定することができます。サブネット割り当てサーバの動作は、DHCP サーバの動作に類似していますが、IP アドレス プールの代わりに、サブネットが作成されて割り当てられます。サブネット割り当てプールは、DHCP プール コンフィギュレーション モードで、 subnet prefix-length コマンドを使用して作成、設定されます。割り当てられた各サブネットのサイズは、prefix-length 引数で設定されます。このとき、サブネット リースごとに設定されるアドレスの数を決めるために、標準の Common InterDomain Routing(CIDR)ビット カウント表記が使用されます。

DHCP サーバがサブネット割り当てサーバとして設定されると、ODAP マネージャにサブネット割り当てプールを提供します。図 2 では、ルータ B がサブネット割り当てサーバで、IP アドレスおよびサブネットの使用可能度の要求に基づき、ODAP マネージャにサブネットを割り当てます。ルータ B は、最初のアドレス レンジをサブネットの形式で ODAP マネージャに割り当てます。ODAP マネージャによって割り当てられるサブネットのサイズは、サブネット割り当てサーバで設定されたサブネットのサイズで決定されます。ODAP マネージャは、これらのサブネットからクライアントにアドレスを割り当て、アドレス レンジの需要が増えるに従ってさらにサブネットを割り当てます。

図 2 サブネット割り当てサーバの接続形態

 

ODAP マネージャがサブネットを割り当てるとき、サブネット割り当てサーバはサブネット バインディングを作成します。このバインディングは、ODAP マネージャがアドレス レンジを必要とする間、DHCP データベースに保管されます。このバインディングが削除され、サブネットがサブネット プールに戻されるのは、アドレス レンジの利用が減少して ODAP マネージャがサブネットをリリースするときだけです。

サブネット割り当てサーバは、VRF とも関連付けることができます。VRF は、IP ルーティング テーブル、取得された Cisco Express Forwarding(CEF)テーブル、転送テーブルを使用する一連のインターフェイス、およびルーティング テーブルに格納されている情報を制御するための一連のルールおよびルーティング プロトコル パラメータで構成されています。

ODAP を使用することの利点

効率的なアドレス管理

ODAP マネージャを使用して、IP アドレスの使用を最適化し、アドレス レンジを節約することができます。

効率的なルート集約と更新

サブネットが ODAP に追加されるとき、ODAP マネージャは集約されたルートを挿入します。

複数の VRF と独立したプライベート アドレスのサポート

ODAP マネージャは、サブネット ルーティング情報を自動的に適切な VRF に挿入します。

DHCP サーバ オンデマンド アドレス プール マネージャの設定方法

ここでは、次の作業について説明します。

「DHCP ODAP をグローバル デフォルト メカニズムとして定義」

「インターフェイスの DHCP ODAP 定義」

「DHCP プールを ODAP として設定」

「IPCP ネゴシエーションでサブネットを取得するように ODAP を設定」

「AAA の設定」

「RADIUS の設定」

「ODAP のディセーブル化」

「ODAP 操作の確認」

「ODAP のモニタリングとメンテナンス」

DHCP ODAP をグローバル デフォルト メカニズムとして定義

使用するグローバル デフォルト メカニズムがオンデマンド アドレス プーリングであることを指定するには、この作業を実行します。

IP アドレッシングで、グローバル デフォルト アドレス プーリング メカニズムを設定することができます。 DHCP サーバは、通常の DHCP アドレス要求と PPP クライアント用のアドレス要求を区別できる必要があります。

手順の概要

1. enable

2. configure terminal

3. ip address-pool dhcp-pool

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip address-pool dhcp-pool

 

Router(config)# ip address-pool dhcp-pool

オンデマンド アドレス プーリングをグローバル デフォルト IP アドレス メカニズムにすることができます。

MPLS VPN へのリモート アクセス(PPP)セッションでは、IP アドレスは、ローカルに設定された VRF に関連付けられた DHCP プールから取得されます。

インターフェイスの DHCP ODAP 定義

インターフェイスするのオンデマンド アドレス プールを設定するには、この作業を実行します。

インターフェイスのオンデマンド アドレス プーリング設定は、そのインターフェイスのグローバル デフォルト メカニズムを上書きします。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. peer default ip address dhcp-pool [ pool-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Virtual-Template1

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

peer default ip address dhcp-pool [ pool - name ]

 

Router(config)# peer default ip address dhcp-pool mypool

このインターフェイスに接続したリモート ピアに戻るように、オンデマンド アドレス プールから IP アドレスを指定します。

pool-name 引数は、非 MPLS VPN をサポートしており、セッションがどの VRF にも関連付けられていない場合は必須です。プール名を複数指定することはできますが、空白で区切る必要があります。

DHCP プールを ODAP として設定

DHCP アドレス プールを ODAP プールとして設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. vrf name

5. origin { dhcp | aaa | ipcp } [ subnet size initial size [ autogrow size ]]

6. utilization mark low percentage-number

7. utilization mark high percentage-number

8. end

9. show ip dhcp pool [ pool-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool red-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 4

vrf name

 

Router(dhcp-config)# vrf red

(任意)アドレス プールを VRF 名に関連付けます。

このコマンドは、MPLS VPN だけに使用します。

ステップ 5

origin { dhcp | aaa | ipcp } [ subnet size initial size [ autogrow size ]]

 

Router(dhcp-config)# origin dhcp subnet size initial /16 autogrow /16

アドレス プールをオンデマンド アドレス プールとして設定します。

プールを autogrow プールとして設定しない場合、プールにサブネットがすでに 1 つあれば、プールは追加のサブネットを要求しません。

サイズを、サブネット マスク(nnnn.nnnn.nnnn.nnnn)またはプレフィクス サイズ(/nn)のいずれかで入力することができます。有効値は、/0 および /4 ~ /30 です。

DHCP プールが、アップストリーム DHCP サーバから複数のサブネットを受信するとき、各サブネットからのアドレスは自動的に、クライアントに接続されたインターフェイスに設定され、サブネット内部のアドレスを DHCP クライアントから要求できるように設定されます。最初のサブネットの最初のアドレスは、インターフェイスのプライマリ アドレスに自動的に割り当てられます。以降の各サブネットの最初のアドレスは、インターフェイスのセカンダリ アドレスに割り当てられます。さらに、クライアント アドレスが再要求されたとき、そのサブネットのリース アドレスのカウントは減少します。サブネットのリース カウンタがゼロになる、つまり、リース期限切れになると、そのサブネットはプールに戻されます。インターフェイスの前のアドレスは削除され、インターフェイスの最初のセカンダリ アドレスが、そのインターフェイスのプライマリ アドレスに昇格します。

origin aaa オプションが設定されている場合、AAA を設定する必要があります。

ステップ 6

utilization mark low percentage-number

 

Router(dhcp-config)# utilization mark low 40

プール サイズの低利用マークを設定します。

このコマンドは、 origin コマンドの autogrow size オプション コマンドが設定されていないと使用できません。

デフォルト値は 0% です。

ステップ 7

utilization mark high percentage-number

 

Router(dhcp-config)# utilization mark high 60

プール サイズの高利用マークを設定します。

このコマンドは、 origin コマンドの autogrow size オプション コマンドが設定されていないと使用できません。

デフォルト値は 100% です。

ステップ 8

end

 

Router(dhcp-config)# end

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

show ip dhcp pool [ pool-name ]

 

Router# show ip dhcp pool

(任意)DHCP アドレス プールに関する情報を表示します。

プライマリおよびセカンダリ インターフェイスのアドレス割り当てに関する情報も表示されます。

IPCP ネゴシエーションでサブネットを取得するように ODAP を設定

Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)で取得したサブネットを使用するようにルータを設定するには、この作業を実行します。

IP アドレス プールを Customer Premises Equipment(CPE; 顧客宅内機器)デバイスに割り当てることができます。逆に、CPE デバイスは、IP アドレスを CPE および DHCP プールに割り当てます。この機能を使用するには、3 つの必要条件があります。

Cisco IOS CPE デバイスは、サブネットを要求し、使用できる必要があります。

RADIUS サーバは(AAA 経由で)そのサブネットを提供し、フレーム ルートを適切な VRF テーブルに挿入できる必要があります。

PE ルータは、(IPCP)ネゴシエーションにより、サブネットの提供を促進できる必要があります。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. import all

5. origin ipcp

6. exit

7. interface type number

8. ip address pool pool-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool red-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 4

import all

 

Router(dhcp-config)# import all

オプション パラメータを Cisco IOS DHCP サーバのデータベースにインポートします。

ステップ 5

origin ipcp

 

Router(dhcp-config)# origin ipcp

IPCP をサブネット割り当てプロトコルとして使用し、アドレス プールをオンデマンド アドレス プールとして設定します。

ステップ 6

exit

 

Router(dhcp-config)# exit

DHCP プール コンフィギュレーション モードを終了します。

ステップ 7

interface type number

 

Router(config)# interface ethernet 0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address pool pool-name

 

Router(config-if)# ip address pool red-pool

IPCP のサブネットがネームド プールに入力されるとき、インターフェイス IP アドレスがネームド プールから自動的に設定されるように指定します。

AAA の設定

AAA を設定するには、次の作業を実行します。

ODAP が AAA サーバからサブネットを取得できるようにするためには、AAA クライアントが VHG/PE ルータで設定されている必要があります。

手順の概要

1. enable

2. configure terminal

3. aaa new-model

4. aaa authorization configuration default group radius

5. aaa accounting network default start-stop group radius
または
aaa accounting network default stop-only group radius

6. aaa session-id common

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

aaa new-model

 

Router(config)# aaa new-model

AAA アクセス制御をイネーブルにします。

ステップ 4

aaa authorization configuration default group radius

 

Router(config)# aaa authorization configuration default group radius

RADIUS を使用して、AAA サーバからスタティック ルート設定情報をダウンロードします。

ステップ 5

aaa accounting network default start-stop group radius

または

aaa accounting network default stop-only group radius

 

Router(config)# aaa accounting network default start-stop group radius

または

 

Router(config)# aaa accounting network default stop-only group radius

RADIUS 使用時、課金やセキュリティのために、要求されたサービスの AAA アカウンティングをイネーブルにします。プロセスの最初で、「start」アカウンティング通知を送信します。

または

RADIUS 使用時、課金やセキュリティのために、要求されたサービスの AAA アカウンティングをイネーブルにします。要求されたユーザ プロセスの最後に、「stop」アカウンティング通知を送信します。

ステップ 6

aaa session-id common

 

Router(config)# aaa session-id common

コール内の AAA アカウンティング サービス タイプごとに同一のセッション ID が使用されることを確認します。

RADIUS の設定

RADIUS を設定するには、次の作業を実行します。

ODAP AAA プロファイル

AAA サーバは、RADIUS Cisco AV ペア アトリビュートの「pool-addr」および「pool-mask」を、アクセス要求およびアクセス受け入れで Cisco IOS DHCP サーバに送信します。pool-addr アトリビュートは IP アドレスで、pool-mask アトリビュートはネットワーク マスクです(たとえば、 pool-addr=192.168.1.0 pool-mask=255.255.0.0 )。これらのアトリビュートは合わせて、AAA サーバにより Cisco IOS DHCP サーバに割り当てられるネットワーク アドレス(アドレス/マスク)になります。

手順の概要

1. enable

2. configure terminal

3. ip radius source-interface subinterface-name

4. radius-server host ip-address [ auth-port port-number ] [acct-port port-number ]

5. radius server attribute 32 include-in-access-req

6. radius server attribute 44 include-in-access-req

7. radius-server vsa send accounting

8. radius-server vsa send authentication

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip radius source-interface subinterface-name

 

Router(config)# ip radius source-interface Ethernet1/1

発信 RADIUS パケットすべてに、指定したインターフェイスの IP アドレスを使用するように RADIUS を強制します。

ステップ 4

radius-server host ip-address auth-port port-number acct-port port-number

 

Router(config)# radius-server host 172.16.1.1 auth-port 1645 acct-port 1646

RADIUS サーバ ホストを指定します。

ip-address 引数は、RADIUS サーバ ホストの IP アドレスを指定します。

ステップ 5

radius server attribute 32 include-in-access-req

 

Router(config)# radius server attribute 32 include-in-access-req

アクセス要求またはアカウンティング要求で RADIUS アトリビュート 32(NAS ID)を送信します。

ステップ 6

radius server attribute 44 include-in-access-req

 

Router(config)# radius server attribute 44 include-in-access-req

アクセス要求またはアカウンティング要求で、RADIUS アトリビュート 44(アカウンティング セッション ID)を送信します。

ステップ 7

radius-server vsa send accounting

 

Router(config)# radius-server vsa send accounting

ベンダー固有のアカウンティング アトリビュートを認識および使用するように Network Access Server(NAS; ネットワーク アクセス サーバ)を設定します。

ステップ 8

Router(config)# radius-server vsa send authentication

 

Router(config)# radius-server vsa send authentication

ベンダー固有認証アトリビュートを認識して使用するように NAS を設定します。

ODAP のディセーブル化

この作業は、DHCP プールから ODAP をディセーブルにする方法を示します。

ODAP がディセーブルのとき、リースされたサブネットはすべてリリースされます。アクティブな PPP セッションがリリースされたサブネットのアドレスを使用している場合、そのセッションはリセットされます。リリースされたサブネットからアドレスをリースしている DHCP クライアントは、そのリースを更新できません。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. no origin { dhcp | aaa | ipcp }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool red-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 4

no origin { dhcp | aaa | ipcp }

 

Router(dhcp-config)# no origin dhcp

ODAP をディセーブルにします。

ODAP 操作の確認

ODAP 操作を確認するには、この作業を実行します。

手順の概要

1. enable

2. show ip dhcp pool [ pool-name ]

3. show ip dhcp binding

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show ip dhcp pool [ pool-name ]

次の出力は、Green と Global という 2 つの DHCP プール用です。Green プールは、高利用マーク 50、低利用マーク 30 で設定されます。プールはまた、高利用マークに達すると、追加のサブネットを取得します(autogrow)。Subnet size フィールドは、 origin コマンドで設定された値を、Green という名のプールが要求する最初のサブネット サイズおよび増分のサブネット サイズとして示します。アドレス フィールド全体は、プールの利用可能なアドレスの総数です。Leased addresses フィールドは、プールから作成されたバインディングの総数です。Pending event フィールドには subnet request が表示されています。つまり、subnet request がプールに保留されているということです。subnet request がスケジュールされているのは、Leased addresses カウントがプールの高利用レベルを超えているからです。Green プールに現在、追加されたサブネットが順に表示されています。Current index 列は、このサブネットの次に割り当てられるアドレスです。IP address range 列は、サブネットから利用可能なアドレスの範囲を示しています。Leased addresses 列は、サブネットごとに作成されたバインディングそれぞれの総数です。現在、3 つのサブネットが Green プールに追加されています。最初の 2 つのサブネットは、アドレスすべてを使用しており、したがって現在のインデックスは 0.0.0.0 を示しています。

Green プールと Global プールは同一のサブネット(172.16.0.1 ~ 172.16.0.6)を持つことができます。その理由は、Green プールは VRF Green にあるように設定され、Global プールはグローバル アドレス レンジにあるように設定されているからです。

Router# show ip dhcp pool

Pool Green :
Utilization mark (high/low) : 50 / 30
Subnet size (first/next) : 24 / 24 (autogrow)
VRF name : Green
Total addresses : 18
Leased addresses : 13
Pending event : subnet request
3 subnets are currently in the pool :
Current index IP address range Leased addresses
0.0.0.0 172.16.0.1 - 172.16.0.6 6
0.0.0.0 172.16.0.9 - 172.16.0.14 6
172.16.0.18 172.16.0.17 - 172.16.0.22 1
 
Pool Global :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 24 / 24 (autogrow)
Total addresses : 6
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
172.16.0.1 172.16.0.1 - 172.16.0.6 0
 
 

ステップ 3 show ip dhcp binding

次の出力は、Green プールからのバインディングを示しています。Type フィールドが示しているのは On-demand、つまり、PPP セッション用にアドレス バインディングが作成されたということです。Lease expiration フィールドは Infinite、つまり、セッションが活動している限り、バインディングは有効なことを示しています。セッションがまだ活動中にサブネットをリース サーバにリリースし戻す必要がある場合、セッションを強制的にリセットして新規 IP アドレスを取得します。On-demand エントリの Hardware address 列は、PPP で検出されたセッションの識別情報を示しています。Bindings from all pools not associated with VRF フィールドの下にバインディングの表示がないのは、グローバル プールがアドレスを割り当てていないためです。

Router# show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Hardware address Lease expiration Type
 
Bindings from VRF pool Green:
IP address Hardware address Lease expiration Type
172.16.0.1 5674.312d.7465.7374. Infinite On-demand
2d38.3930.39
172.16.0.2 5674.312d.7465.7374. Infinite On-demand
2d38.3839.31
172.16.0.3 5674.312d.7465.7374. Infinite On-demand
2d36.3432.34
172.16.0.4 5674.312d.7465.7374. Infinite On-demand
2d38.3236.34
172.16.0.5 5674.312d.7465.7374. Infinite On-demand
2d34.3331.37
172.16.0.6 5674.312d.7465.7374. Infinite On-demand
2d37.3237.39
172.16.0.9 5674.312d.7465.7374. Infinite On-demand
2d39.3732.36
172.16.0.10 5674.312d.7465.7374. Infinite On-demand
2d31.3637
172.16.0.11 5674.312d.7465.7374. Infinite On-demand
2d39.3137.36
172.16.0.12 5674.312d.7465.7374. Infinite On-demand
2d37.3838.30
172.16.0.13 5674.312d.7465.7374. Infinite On-demand
2d32.3339.37
172.16.0.14 5674.312d.7465.7374. Infinite On-demand
2d31.3038.31
172.16.0.17 5674.312d.7465.7374. Infinite On-demand
2d38.3832.38
172.16.0.18 5674.312d.7465.7374. Infinite On-demand
2d32.3735.31
 


 

トラブルシューティングのヒント

デフォルトでは、ODAP マネージャの基盤である Cisco IOS DHCP サーバは、アドレスを割り当てる前に ping を実行してアドレスが利用可能かを確認しようとします。DHCP の ping 設定のデフォルトでは、ICMP のエコー応答を 2 秒間待ちます。このデフォルト設定では、DHCP サーバは 1 つのアドレス要求に 2 秒ごとにサービスを行うことになります。送信される ping パケットの数と ping のタイムアウトは設定可能です。したがって、アドレス割り当て時間を短くするには、タイムアウトまたは送信 ping パケット数のいずれかを減らせばよいわけです。タイムアウトまたは送信 ping パケットを減らすとアドレス割り当て時間は短くなりますが、アドレスの重複を検出する能力は低下します。

各 ODAP は、DHCP または AAA からサブネットを取得するために有限回(再試行は 4 回まで)の試行を実行します。この試行が成功しない場合、プールに(新規に発生した PPP セッションからなど)他の個別のアドレス要求があるときは、プールからのサブネット要求が自動的に開始されます。プールにまだサブネットが割り当てられていない場合、 clear ip dhcp pool pool-name subnet * EXEC コマンドを使用して、強制的にサブネット要求プロセスを再開始させることができます。

ODAP のモニタリングとメンテナンス

この作業は、ODAP のモニタ法およびメンテナンス法を示します。

clear ip dhcp binding clear ip dhcp conflict 、および clear ip dhcp subnet コマンドの次の動作に注意します。

pool pool- name オプションを指定せず、IP アドレスを指定した場合、その IP アドレスはグローバル アドレス レンジのアドレスと仮定され、指定されたバインディング/競合/サブネットをすべての非 VRF DHCP プールで検索します。

pool pool- name オプションを指定せず、* オプションを指定する場合、すべての VRF および非 VRF プールのすべての自動またはオンデマンド バインディング/競合/サブネットは削除されると仮定されます。

pool pool- name オプションおよび * オプションの両方を指定する場合、指定されたプールのすべての自動またはオンデマンド バインディング/競合/サブネットだけがクリアされます。

pool pool- name オプションおよび IP アドレスを指定する場合、指定された IP アドレスを含むサブネットまたは指定されたバインディング/競合は、指定されたプールから削除されます。

手順の概要

1. enable

2. clear ip dhcp [ pool pool-name ] binding {* | address }

3. clear ip dhcp [ pool pool-name ] conflict {* | address }

4. clear ip dhcp [ pool pool-name ] subnet {* | address }

5. debug dhcp details

6. debug ip dhcp server events

7. show ip dhcp import

8. show ip interface [ type number ]

9. show ip dhcp pool pool-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

clear ip dhcp [ pool pool-name ] binding { * | address }

 

Router# clear ip dhcp binding *

自動アドレス バインディングまたは DHCP サーバ データベースの特定のプールからのオブジェクトを削除します。

ステップ 3

clear ip dhcp [ pool pool-name ] conflict { * | address }

 

Router# clear ip dhcp conflict *

アドレス競合または DHCP サーバ データベースの特定のプールからの競合をクリアします。

ステップ 4

clear ip dhcp [ pool pool-name ] subnet { * | address }

 

Router# clear ip dhcp subnet *

name が指定されていない場合、ネームド DHCP プールまたはすべての DHCP プールの現在リースされているサブネットすべてをクリアします。

ステップ 5

debug dhcp details

 

Router# debug dhcp details

オンデマンド アドレス プールのサブネット割り当てとリリースを監視します。

ステップ 6

debug ip dhcp server events

 

Router# debug ip dhcp server events

DHCP サーバのイベント(アドレスの割り当てやデータベースのアップデートなど)をレポートします。

ステップ 7

show ip dhcp import

 

Router# show ip dhcp import

DHCP サーバ データベースにインポートされるオプション パラメータを表示します。

ステップ 8

show ip interface [ type number ]

 

Router# show ip interface

IP 用に設定されたインターフェイスの使用可能度のステータスを表示します。

ステップ 9

show ip dhcp pool pool-name

 

Router# show ip dhcp pool green

DHCP アドレス プール情報を表示します。

DHCP ODAP サブネット割り当てサーバ サポートの設定方法

ここでは、次の作業について説明します。

「サブネット割り当てサーバのグローバル プールの設定」(必須)

「サブネット割り当てサーバの VRF サブネット プールの設定」(任意)

「サブネット割り当てサーバの VRF サブネット プール設定における VPN ID の使用」(任意)

「サブネット割り当ておよび DHCP バインディングの確認」(任意)

「DHCP ODAP サブネット割り当てサーバのトラブルシューティング」(任意)

サブネット割り当てサーバのグローバル プールの設定

サブネット割り当てサーバでグローバル サブネット プールを設定するには、この作業を実行します。

グローバル サブネット プール

グローバル サブネット プールは、集中化されたネットワークに作成されます。ODAP マネージャは、サブネットの利用可能度に基づき、サブネット割り当てサーバからサブネットを割り当てます。ODAP マネージャがサブネットを割り当てるとき、サブネット割り当てサーバはサブネット バインディングを作成します。このバインディングは、ODAP マネージャがアドレス レンジを必要とする間、DHCP データベースに保管されます。このバインディングが削除され、サブネットがサブネット プールに戻されるのは、アドレス レンジの利用が減少して ODAP マネージャがサブネットをリリースするときだけです。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. network network-number [mask | / prefix-length]

5. subnet prefix-length prefix-length

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool GLOBAL-POOL

DHCP プール コンフィギュレーションモードを開始し、サブネット プール名を指定します。

ステップ 4

network network-number [ mask | / prefix-length ]

 

Router(dhcp-config)# network 10.0.0.0 255.255.255.0

Cisco IOS DHCP サーバ上の DHCP アドレス プールにサブネット番号とマスクを設定します。

サブネット マスクまたはプレフィクスの長さは、この手順で設定できます。prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。prefix-length 引数を設定するとき、スラッシュ文字を使用する必要があります。

ステップ 5

subnet prefix-length prefix-length

 

Router(dhcp-config)# subnet prefix-length 8

サブネット プレフィクスの長さを設定します。prefix-length 引数の範囲は、1 ~ 31 です。

このコマンドで、サブネット プールから割り当てるためにサブネットごとに設定される IP アドレスの数を設定します。prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。

サブネット割り当てサーバの VRF サブネット プールの設定

この作業では、サブネット割り当てサーバの VRF サブネット プールの設定方法を示します。

VRF サブネット プール

サブネット割り当てサーバは、MPLS VPN クライアントの VRF サブネット割り当てプールからサブネットを割り当てるように設定することができます。ODAP マネージャとサブネット割り当てサーバ間の VPN ルートは、VRF 名または VPN ID 設定に基づいて設定されます。VRF および VPN ID は、カスタマー VPN サイトを定義するルーティング情報を保持するように設定されます。VPN カスタマー サイト(または Customer Equipment(CE; カスタマー装置))は、プロバイダー エッジ(PE)ルータに接続されます。VRF は VPN の指定に使用され、IP ルーティング テーブル、取得された Cisco Express Forwarding(CEF)テーブル、転送テーブルを使用する一連のインターフェイス、およびルーティング テーブルに格納されている情報を制御するための一連のルールおよびルーティング プロトコル パラメータで構成されています。

前提条件

VRF 名および VPN ID は、サブネット割り当てプールを設定する前に、ODAP マネージャおよびサブネット割り当てサーバに設定することができます。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. vrf vrf-name

5. network network-number [ mask | / prefix-length ]

6. subnet prefix-length prefix-length

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool VRF-POOL

DHCP プール コンフィギュレーションモードを開始し、サブネット プール名を指定します。

ステップ 4

vrf vrf-name

 

Router(dhcp-config)# vrf RED

オンデマンド アドレス プールを、VPN ルーティング/転送(VRF)インスタンス名(またはタグ)に関連付けます。

vrf キーワードおよび vrf-name 引数は、VRF 用の VPN の指定に使用されます。vrf-name 引数は、クライアントに設定された VRF 名(またはタグ)に一致する必要があります。

ステップ 5

network network-number [ mask | /prefix-length ]

 

Router(dhcp-config)# network 10.1.1.0 /24

Cisco IOS DHCP サーバ上の DHCP アドレス プールにサブネット番号とマスクを設定します。

サブネット マスクまたはプレフィクスの長さは、この手順で設定できます。prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。prefix-length 引数を設定するとき、スラッシュ文字を使用する必要があります。

ステップ 6

subnet prefix-length prefix-length

 

Router(dhcp-config)# subnet prefix-length 16

サブネット プレフィクスの長さを設定します。prefix-length 引数の範囲は、1 ~ 31 です。

このコマンドで、サブネット プールから割り当てるためにサブネットごとに設定される IP アドレスの数を設定します。prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。

サブネット割り当てサーバの VRF サブネット プール設定における VPN ID の使用

サブネット割り当てサーバで、VPN ID を使用して VRF サブネット プールを設定するには、この作業を実行します。

VRF プールおよび VPN ID

サブネット割り当てサーバは、クライアントの VPN ID に基づいて、VPN サブネット割り当てプールからサブネットを割り当てるように設定することもできます。VPN ID(または Organizational Unique Identifier(OUI; 組織固有識別子))は、IEEE によって割り当てられた固有識別子です。

前提条件

VRF 名および VPN ID は、サブネット割り当てプールを設定する前に、ODAP マネージャおよびサブネット割り当てサーバに設定することができます。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target both route-target-number

6. vpn id vpn-id

7. exit

8. ip dhcp pool pool-name

9. vrf vrf-name

10. network network-number [ mask | /prefix-length ]

11. subnet prefix-length prefix-length

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)#ip vrf RED

VRF ルーティング テーブルを作成し、VRF 名(またはタグ)を指定します。

vrf-name 引数は、ステップ 9 でクライアントおよび VRF プールに設定された VRF 名に一致する必要があります。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

ステップ 3 で作成された VRF インスタンス用のルーティングおよび転送テーブルを作成します。

ルート識別子の引数を設定するには、2 つの形式があります。例に示すように、as-number:network number(ASN:nn)形式で設定することも、IP address:network number フォーマット(IP アドレス:nn)で設定することもできます。

ステップ 5

route-target both route-target-number

 

Router(config-vrf)# route-target both 100:1

ステップ 3 で作成した VRF インスタンス用の route-target 拡張コミュニティを作成します。

both キーワードは、ターゲット VPN 拡張コミュニティ(または、この設定の ODAP マネージャ)にどのルートをインポートまたはエクスポートする必要があるかを指定する際に使用されます。

route-target-number 引数は、ステップ 4 の route-distinguisher 引数と同じ形式です。この 2 つの引数は一致する必要があります。

ステップ 6

vpn id vpn-id

 

Router(config-vrf)# vpn id 1234:123456

VPN ID の設定

このコマンドは、クライアント(ODAP マネージャ)も VPN ID を設定されているか割り当てられている場合にだけ使用します。

ステップ 7

exit

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 8

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool VPN-POOL

DHCP プール コンフィギュレーションモードを開始し、サブネット プール名を指定します。

VRF キーワードおよび vrf-name 引数は、VRF 用の VPN の指定に使用されます。vrf-name 引数は、クライアントに設定された VRF 名(またはタグ)に一致する必要があります。

ステップ 9

vrf vrf-name

 

Router(dhcp-config)#vrf RED

オンデマンド アドレス プールを VRF インスタンス名と関連付けます。

vrf-name 引数は、ステップ 3 で設定した vrf-name 引数と一致する必要があります。

ステップ 10

network network-number [ mask | /prefix-length ]

 

Router(dhcp-config)# network 192.168.0.0 /24

Cisco IOS DHCP サーバ上の DHCP アドレス プールにサブネット番号とマスクを設定します。

サブネット マスクまたはプレフィクスの長さは、この手順で設定できます。prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。prefix-length 引数を設定するとき、スラッシュ文字を使用する必要があります。

ステップ 11

subnet prefix-length prefix-length

 

Router(dhcp-config)# subnet prefix-length 16

サブネット プレフィクスの長さを設定します。

prefix-length 引数の範囲は、1 ~ 31 です。

このコマンドで、サブネット プールから割り当てるためにサブネットごとに設定される IP アドレスの数を設定します。 prefix-length 引数として設定する値は、CIDR ビット カウント表記で指定します。

サブネット割り当ておよび DHCP バインディングの確認

サブネット割り当ておよび DHCP バインディングを確認するには、この作業を実行します。

提供される情報が異なるため、 show ip dhcp pool および show ip dhcp binding コマンドは、同時に発行される必要もなく、同じセッションにある必要すらありません。ただし、これらのコマンドは、サブネット割り当ておよび DHCP バインディングの表示および確認に使用できます。 show running-config | begin dhcp コマンドは、DHCP のローカル設定や subnet prefix-length コマンドの設定を表示するために使用されます。

手順の概要

1. enable

2. show running-config | begin dhcp

3. show ip dhcp pool

4. show ip dhcp binding

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show running-config | begin dhcp

 

Router# show running-config | begin dhcp

ルータのローカル設定を表示するために使用されます。

subnet prefix-length コマンドの設定が DHCP プールの下に表示されます。このサブネット リース割り当てが設定されています。サブネット割り当てサイズがこのコマンドに続いて CIDR ビット カウント表記で表示されます。

サンプル出力は、実行中の設定の DHCP セクションで出力の表示を開始するために、begin キーワードでフィルタ処理されます。

ステップ 3

show ip dhcp pool [pool-name]

 

Router# show ip dhcp pool

DHCP プールに関する情報を表示します。

このコマンドは、サブネット割り当てサーバおよび ODAP マネージャ両方のサブネット割り当てプールの設定を確認するために使用できます。

このコマンドは、プール名、アドレス レンジの利用状態、サブネット サイズ、総アドレス数、リース中のアドレス数、保留中のイベントなど、具体的なアドレス プールの情報を出力として表示します。

ステップ 4

show ip dhcp binding [ip-address]

 

Router# show ip dhcp binding

DHCP バインディングに関する情報を表示します。

このコマンドは、DHCP バインディング マッピング情報へのサブネット割り当てを表示するために使用できます。

このコマンドは出力として、個々の IP アドレス割り当てと割り当てられたサブネットのバインディング情報を表示します。DHCP IP アドレス割り当てとサブネット割り当てに生成された出力はほとんど同一ですが、サブネット リースは、IP アドレスの後にサブネット マスク(割り当てられたサブネットのサイズを表示)を表示します。個々の IP アドレスのバインディングは IP アドレスを表示するだけで、サブネット マスクは表示されません。

DHCP ODAP サブネット割り当てサーバのトラブルシューティング

DHCP ODAP サブネット割り当てサーバのトラブルシューティングを行うには、この作業を実行します。

手順の概要

1. enable

2. debug dhcp [ detail ]

3. debug ip dhcp server

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug dhcp [detail]

 

Router# debug dhcp detail

DHCP クライアントの活動についてのデバッグ情報を表示し、DHCP パケットのステータスを監視します。

この例では、ODAP マネージャの detail キーワード付きでコマンドが発行されます。detail キーワードは、クライアントのリース エントリ構造とリース エントリのステート遷移を表示、監視するために使用されます。このコマンドは、オプション フィールドの長さに加え、DHCP パケットの op、htype、hlen、hops、server identifier option、xid、secs、flags、ciaddr、yiaddr、siaddr、giaddr の各フィールド値も表示します。

ステップ 3

debug ip dhcp server { events | packets | linkage }

 
Router# debug ip dhcp server packets
Router# debug ip dhcp server events

DHCP サーバのデバッグを可能にします。

この例では、サブネット割り当てサーバの packets および events キーワード付きでコマンドが発行されます。出力として、リースの移行状態および受信状態の他、データベース情報も表示します。

DHCP サーバ オンデマンド アドレス プール マネージャの設定例

ここでは、次の設定例について説明します。

「グローバル デフォルト メカニズムとしての DHCP ODAP の定義:例」

「インターフェイスの DHCP ODAP 定義:例」

「DHCP プールを ODAP として設定:例」

「DHCP プールを非 MPLS VPN の ODAP として設定:例」

「IPCP サブネット マスクの配信:例」

「AAA および RADIUS の設定:例」

「サブネット割り当てサーバのグローバル プールの設定:例」

「サブネット割り当てサーバの VRF プールの設定:例」

「VPN ID を使用した、サブネット割り当てサーバの VRF プールの設定:例」

「サブネット割り当てサーバのローカル設定の確認:例」

「アドレス プール割り当て情報の確認:例」

「サブネット割り当てと DHCP バインディングの確認:例」

グローバル デフォルト メカニズムとしての DHCP ODAP の定義:例

次の例では、PPP クライアントからのアドレス要求に応えるために使用されるオンデマンド アドレス プール メカニズムの設定方法を示しています。

ip address-pool dhcp-pool
!
ip dhcp pool Green-pool

インターフェイスの DHCP ODAP 定義:例

次の例では、オンデマンド アドレス プールから IP アドレスを取得するインターフェイスの設定方法を示しています。

interface Virtual-Template1
ip vrf forwarding green
ip unnumbered loopback1
ppp authentication chap
peer default ip address dhcp-pool
!

DHCP プールを ODAP として設定:例

次の例では、外部の DHCP サーバから自身のサブネットを取得するように設定された 2 つの ODAP を示しています。

Router# show run
 
Building configuration...
 
Current configuration : 3943 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
no logging console
enable password lab
!
username vpn_green_net1 password 0 lab
username vpn_red_net1 password 0 lab
ip subnet-zero
!
ip dhcp pool green_pool
vrf Green
utilization mark high 60
utilization mark low 40
origin dhcp subnet size initial /24 autogrow /24
!
ip dhcp pool red_pool
vrf Red
origin dhcp
!
ip vrf Green
rd 200:1
route-target export 200:1
route-target import 200:1
!
ip vrf Red
rd 300:1
route-target export 300:1
route-target import 300:1
ip cef
ip address-pool dhcp-pool
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding Green
ip address 100.10.10.1 255.255.255.255
!
interface Loopback2
ip vrf forwarding Red
ip address 110.10.10.1 255.255.255.255
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM3/0
no ip address
no atm ilmi-keepalive
!
interface Ethernet4/0
ip address 10.0.105.12 255.255.255.224
duplex half
!
interface Ethernet4/1
ip address 150.10.10.1 255.255.255.0
duplex half
!
interface Ethernet4/2
ip address 120.10.10.1 255.255.255.0
duplex half
tag-switching ip
!
interface Virtual-Template1
ip vrf forwarding Green
ip unnumbered Loopback1
ppp authentication chap
!
interface Virtual-Template2
ip vrf forwarding Green
ip unnumbered Loopback1
ppp authentication chap
!
interface Virtual-Template3
ip vrf forwarding Green
ip unnumbered Loopback1
ppp authentication chap
!
interface Virtual-Template4
ip vrf forwarding Red
ip unnumbered Loopback2
ppp authentication chap
!
interface Virtual-Template5
ip vrf forwarding Red
ip unnumbered Loopback2
ppp authentication chap
!
interface Virtual-Template6
ip vrf forwarding Red
ip unnumbered Loopback2
ppp authentication chap
!
router ospf 100
log-adjacency-changes
redistribute connected
network 1.1.1.1 0.0.0.0 area 0
network 120.10.10.0 0.0.0.255 area 0
network 150.10.10.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
!
address-family ipv4 vrf Red
redistribute connected
redistribute static
no auto-summary
no synchronization
network 110.0.0.0
exit-address-family
!
address-family ipv4 vrf Green
redistribute connected
redistribute static
no auto-summary
no synchronization
network 100.0.0.0
exit-address-family
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
ip classless
ip route 172.19.0.0 255.255.0.0 10.0.105.1
no ip http server
ip pim bidir-enable
!
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password lab
login
!
end

DHCP プールを非 MPLS VPN の ODAP として設定:例

次の例では、オンデマンド アドレス プールから IP アドレスを取得するインターフェイスの設定方法を示しています。この例では、2 つの非 VRF ODAP が設定されます。2 つのバーチャル テンプレート(virtual-template)と 2 つの DHCP アドレス プール(usergroup1 および usergroup2)があります。各 virtual-template インターフェイスは、関連付けられたアドレス プールからのピアの IP アドレスを取得するように設定されています。

!
ip dhcp pool usergroup1
origin dhcp subnet size initial /24 autogrow /24
lease 0 1
!
ip dhcp pool usergroup2
origin dhcp subnet size initial /24 autogrow /24
lease 0 1
!
interface virtual-template1
ip unnumbered loopback1
peer default ip address dhcp-pool usergroup1
!
interface virtual-template2
ip unnumbered loopback1
peer default ip address dhcp-pool usergroup2

IPCP サブネット マスクの配信:例

次の例では、IPCP サブネット マスクを使用するように設定された Cisco 827 ルータを示します。

Router# show run
 
Building configuration...
 
Current configuration :1479 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname Router
!
no logging buffered
logging rate-limit console 10 except errors
!
username 6400-nrp2 password 0 lab
ip subnet-zero
ip dhcp smart-relay
!
ip dhcp pool IPPOOLTEST
import all
origin ipcp
!
no ip dhcp-client network-discovery
!
interface Ethernet0
ip address pool IPPOOLTEST
ip verify unicast reverse-path
hold-queue 32 in
!
interface ATM0
no ip address
atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 1/40
no ilmi manage
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip unnumbered Ethernet0
ip verify unicast reverse-path
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname Router
ppp chap password 7 12150415
ppp ipcp accept-address
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
transport input none
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end

 

AAA および RADIUS の設定:例

次の例では、AAA(RADIUS)から自身のサブネットを取得するように設定された「Green」プールを示しています。AAA サーバの IP アドレスは 172.16.1.1 です。

!
aaa new-model
!
aaa authorization configuration default group radius
aaa accounting network default start-stop group radius
aaa session-id common
!
ip subnet-zero
!
ip dhcp ping packets 0
!
ip dhcp pool Green
vrf Green
utilization mark high 50
utilization mark low 30
origin aaa subnet size initial /28 autogrow /28
!
ip vrf Green
rd 300:1
route-target export 300:1
route-target import 300:1
!
interface Ethernet1/1
ip address 172.16.1.12 255.255.255.0
duplex half
!
interface Virtual-Template1
ip vrf forwarding Green
no ip address
!
ip radius source-interface Ethernet1/1
!
!IP address of the RADIUS server host
radius-server host 172.16.1.1 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server attribute 32 include-in-access-req
radius-server attribute 44 include-in-access-req
radius-server key cisco
radius-server vsa send accounting
radius-server vsa send authentication

サブネット割り当てサーバのグローバル プールの設定:例

次の例では、ルータをサブネット割り当てサーバとして設定し、10.0.0.0/24 ネットワークからサブネットを割り当てる「GLOBAL-POOL」という名のグローバル サブネット割り当てプールを作成する方法を示します。この例の subnet prefix-length コマンドの設定は、254 のホスト IP アドレスをサポートするためにサブネット プールから割り当てられた各サブネットの大きさを設定しています。

ip dhcp pool GLOBAL-POOL
network 10.0.0.0 255.255.255.0
subnet prefix-length 24
!

サブネット割り当てサーバの VRF プールの設定:例

次の例では、ルータをサブネット割り当てサーバとして設定し、172.16.0.0/16 ネットワークからサブネットを割り当てる「VRF-POOL」という名の VRF サブネット割り当てプールを作成する方法を示し、「RED」という名の VRF と一致するように VPN を設定します。この例で、 subnet prefix-length コマンドは、62 のホスト IP アドレスをサポートするために、サブネット プールから割り当てられた各サブネットの大きさを設定します。

ip dhcp pool VRF-POOL
vrf RED
network 172.16.0.0 /16
subnet prefix-length 26
!

VPN ID を使用した、サブネット割り当てサーバの VRF プールの設定:例

次の例では、ルータをサブネット割り当てサーバとして設定し、192.168.0.0/24 ネットワークからサブネットを割り当てる「VRF-POOL」という名の VRF サブネット割り当てプールを作成し、「RED」という名の VRF を設定する方法を示します。VPN ID は、クライアント サイトに割り当てられた固有識別子に一致する必要があります。ルート ターゲットおよびルート識別子は、as-number:network-number 形式で設定されます。ルート ターゲットとルート識別子は一致する必要があります。この例の subnet prefix-length コマンドの設定は、30 のホスト IP アドレスをサポートするためにサブネット プールから割り当てられた各サブネットの大きさを設定しています。

ip vrf RED
rd 100:1
route-target both 100:1
vpn id 1234:123456
exit
ip dhcp pool VPN-POOL
vrf RED
network 192.168.0.0 /24
subnet prefix-length /27
exit

サブネット割り当てサーバのローカル設定の確認:例

次に、 show running-config コマンドからの出力例を示します。このコマンドは、サブネット割り当てサーバのローカル設定を確認するために使用することができます。このコマンドは、「GLOBAL-POOL」という名の DHCP プールの下で、 subnet prefix-length コマンドの設定を出力として表示します。サブネット割り当てプールの合計の大きさは、 network コマンドで 254 アドレスに設定されます。 subnet prefix-length コマンドの設定は、254 のホスト IP アドレスをサポートするサブネットを割り当てるようにこのプールを設定するようになっています。合計のプール サイズ サポートがわずか 254 アドレスであるため、このプールから割り当てられるサブネットは 1 つだけです。

Router# show running-config | begin dhcp
ip dhcp pool GLOBAL-POOL
network 10.0.0.0 255.255.255.0
subnet prefix-length 24
!

アドレス プール割り当て情報の確認:例

次の例は、 show ip dhcp pool コマンドの出力例です。このコマンドは、サブネット割り当てサーバおよび ODAP マネージャのサブネット割り当てプールの設定を確認するために使用できます。このコマンドは出力として、アドレス プール名、利用レベル、設定されたサブネットのサイズ、(サブネットからの)アドレス総数、保留中のイベント、特定のサブネット リース情報を表示します。

次のサンプル出力は、サブネット割り当てサイズは /24(254 の IP アドレス)に設定され、保留中のサブネット割り当て要求があり、プールにサブネットがないことを示しています。

Router> show ip dhcp pool ISP-1
Pool ISP-1 :
Utilization mark (high/low) :100 / 0
Subnet size (first/next) :24 / 24 (autogrow)
Total addresses :0
Leased addresses :0
Pending event :subnet request
0 subnet is currently in the pool

次の例では、サブネット サイズは /24(254 の IP アドレス)、VRF 名は「RED」に設定されており、254 の IP アドレスを持つサブネットが割り当てられているが、サブネットからリースされている IP アドレスはないことを示しています。

Router> show ip dhcp pool SUBNET-ALLOC
Pool SUBNET-ALLOC :
Utilization mark (high/low) :100 / 0
Subnet size (first/next) :24 / 24 (autogrow)
VRF name :RED
Total addresses :254
Leased addresses :0
Pending event :none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.0.0.1 10.0.0.1 - 10.0.0.254 0

サブネット割り当てと DHCP バインディングの確認:例

次の例は、 show ip dhcp binding コマンドの出力です。このコマンドは、DHCP バインディング マッピング情報へのサブネット割り当てを表示するために使用できます。このコマンドの出力には、MAC アドレス マッピングへのサブネット リース、リース期限、リース タイプ(サブネット リース バインディングは、自動的に作成され、リリースされるようにデフォルトで設定されています)。DHCP IP アドレス割り当てとサブネット割り当てに生成された出力はほとんど同一ですが、サブネット リースは、IP アドレスの後にサブネット マスク(割り当てられたサブネットのサイズを表示)を CIDR ビット カウント表記で表示します。個々の IP アドレスのバインディングは IP アドレスを表示するだけで、サブネット マスクは表示されません。

Router# show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.0.0.0/26 0063.6973.636f.2d64. Mar 29 2003 04:36 AM Automatic
656d.6574.6572.2d47.
4c4f.4241.4c

その他の関連資料

ここでは、DHCP ODAP マネージャの設定の関連資料を示します。

関連資料

関連項目
参照先

DHCP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

Cisco IOS IP Addressing Services Command Reference

DHCP の概念的な説明

DHCP Overview 」モジュール

DHCP サーバ設定

Configuring the Cisco IOS DHCP Server 」モジュール

DHCP クライアントの設定

Configuring the Cisco IOS DHCP Client 」モジュール

DHCP リレー エージェントの設定

Configuring the Cisco IOS DHCP Relay Agent 」モジュール

DHCP の拡張機能

Configuring DHCP Services for Accounting and Security 」モジュール

エッジセッション管理用 DHCP 機能拡張の設定

Configuring DHCP Enhancements for Edge-Session Management 」モジュール

DHCP オプション

Network Registrar User's Guide , Release 6.1.1』の付録「DHCP Options」

規格

規格
タイトル

この機能によってサポートされる新しい規格や変更された規格はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 951

Bootstrap Protocol (BOOTP)

RFC 1542

Clarifications and Extensions for the Bootstrap Protocol

RFC 2131

Dynamic Host Configuration Protocol

RFC 2685

Virtual Private Networks Identifier

RFC 3046

DHCP Relay Information Option

シスコのテクニカル サポート

説明
リンク

Technical Assistance Center(TAC)ホームページは、30,000 ページの技術コンテンツが検索可能で、製品、テクノロジー、ソリューション、技術的ヒント、およびツールへのリンクが含まれています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

用語集

AAA :Authentication, Authorization, and Accounting(認証、認可、およびアカウンティング)。ネットワーク セキュリティ サービスのスイート。ご使用の Cisco ルータまたはアクセス サーバでアクセス コントロールが設定可能なプライマリ フレームワークを提供します。

Cisco アクセス レジストラ :AAA 情報を集中化し、プロビジョニングおよび管理を簡素化することで、サービス プロバイダーがアクセス サービスを展開することをサポートする RADIUS サーバ。

DHCP :Dynamic Host Configuration Protocol。

IPCP :Internet Protocol Control Protocol(インターネット プロトコル コントロール プロトコル。IP over PPP を確立し、設定するプロトコル。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。タグ スイッチングが基礎を置いている新しい産業標準。

ODAP :On-Demand Address Pool(オンデマンド アドレス プール)。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。

PPP :Point-to-Point Protocol(ポイントツーポイント プロトコル)。

RADIUS :Remote Authentication Dial-In User Service。モデムおよび ISDN 接続の認証、および接続時間のトラッキングのためのデータベース。

VHG :Virtual Home Gateway(バーチャル ホーム ゲートウェイ)。PPP セッションを終了する Cisco IOS ソフトウェア コンポーネント。お客様に代わってサービス プロバイダーが所有、管理し、お客様のネットワークのリモート ユーザへのアクセスを提供します。単一のサービス プロバイダー デバイス(ルータ)は、異なるお客様の複数の VHG をホストすることが可能です。VHG は、リモート ユーザのアクセス パターンに基づいてダイナミックに出し入れすることが可能です。VHG と呼ばれる単一の IOS 機能は存在しないことに注意してください。VHG は動作や機能の集まりです。

VHG/PE ルータ:PPP セッションを終了し、リモート ユーザを対応する MPLS VPN にマッピングするデバイス。

VPN :Virtual Private Network(バーチャル プライベート ネットワーク)。トンネリングを使用して、IP トラフィックがパブリック TCP/IP ネットワーク経由でセキュアに転送できるようにします。

VPN information :このドキュメントでは、VPN 情報とは VRF 名または VPN ID のことです。

VRF :VPN Routing and Forwarding(VPN ルーティング/転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。PE ルータでインスタンス化された各 VPN には固有の VRF があります。

クライアント :DHCP または BOOTP プロトコルを使用して自身のインターフェイスを設定(IP アドレスを取得)しようとしているホスト。

サーバ :DHCP または BOOTP サーバ。

初期サブネット サイズ :オンデマンド プール用に要求された最初のサブネットの要望サイズ。

増分のサブネット サイズ :オンデマンド プール用に要求された、2 番目以降のサブネットの要望サイズ。

リース可能なサブネット :リリースされたアドレスがない、リースされたサブネット。

リレー エージェント :異なるサブネット上のサーバとクライアント間で DHCP メッセージおよび BOOTP メッセージを転送するルータ。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。


DHCP サーバ オンデマンド アドレス プール マネージャの機能情報

表 1 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

ここに記載されていないこのテクノロジーの機能情報については、「 DHCP Features Roadmap 」を参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明な場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 DHCP のオンデマンド アドレス プール マネージャの機能情報

機能名
リリース
機能設定情報

非 MPLS VPN 用 DHCP サーバ オンデマンド アドレス プール マネージャ

12.2(15)T

12.2(28)SB

12.2(33)SRC

この機能は、非 MPLS VPN 用 ODAP サポートのために拡張されました。

この機能に関する詳細については、次の項を参照してください。

DHCP サーバ オンデマンド アドレス プール マネージャの設定方法

この機能により次のコマンドが変更されました。 peer default ip address

DHCP ODAP サーバ サポート

12.2(15)T

12.2(28)SB

12.2(33)SRC

この機能を使用して、DHCP サーバ(またはルータ)をサブネット割り当てサーバとして設定することができます。この機能により、Cisco IOS DHCP サーバを ODAP クライアントへのリース用サブネットのプールで設定することができます。

この機能に関する詳細については、次の項を参照してください。

DHCP ODAP サブネット割り当てサーバ サポートの設定方法

次のコマンドは、この機能で追加、変更されました。 subnet prefix-length および show ip dhcp binding

DHCP サーバ オンデマンド アドレス プール マネージャ

12.2(8)T

12.28(SB)

12.2(33)SRC

ODAP マネージャは、大規模なアドレス プールを集中管理し、大規模ネットワークの設定を単純化するために使用されます。ODAP は、IP アドレスを割り当てるための中央管理ポイントを提供します。Cisco IOS ルータが ODAP マネージャとして設定されている場合、アドレスの利用レベルに応じて IP アドレスのプール サイズはダイナミックに増減します。

この機能に関する詳細については、次の項を参照してください。

DHCP サーバ オンデマンド アドレス プール マネージャの設定方法

次のコマンドは、この機能により追加されました。 aaa session-id clear ip dhcp subnet ip address pool ip dhcp aaa default username origin show ip dhcp pool utilization mark high utilization mark low vrf

次のコマンドは、この機能で変更されました。 clear ip dhcp binding clear ip dhcp conflict ip address-pool peer default ip address