Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド
Cisco IOS DHCP リレー エージェントの設定
Cisco IOS DHCP リレー エージェントの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/07/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

Cisco IOS DHCP リレー エージェントの設定

機能情報の入手方法

この章の構成

Cisco IOS DHCP リレー エージェントの設定時の前提条件

DHCP リレー エージェントについて

DHCP リレー エージェント概要

DHCP リレー エージェントの設定方法

パケット転送アドレスの指定

リレー エージェント情報のオプション サポートの設定

リレー エージェント情報のオプション

リレー エージェントの情報再転送ポリシー

前提条件

制約事項

インターフェイスごとのリレー エージェント情報オプション サポートの設定

前提条件

制約事項

リレー エージェント情報オプションの加入者 ID サブオプションの設定

前提条件

クライアント識別用 DHCP リレー クラス サポートの設定

リレー クラス サポート概要

リレー クラス サポートの使用方法シナリオ

前提条件

MPLS VPN の DHCP リレー エージェント サポートの設定

MPLS VPN の DHCP リレー エージェント サポート

前提条件

制約事項

リレー エージェント情報オプションのカプセル化サポートの設定

Option 82 カプセル化の DHCP リレー サポート

スマート リレー エージェント転送を使用して、DHCP ブロードキャストのゲートウェイ アドレスをセカンダリ アドレスに設定

プライベートおよび標準サブオプション番号サポートの設定

DHCP リレー エージェントのトラブルシューティング

Cisco IOS DHCP リレー エージェントの設定例

DHCP リレー エージェントおよびリレー エージェント情報オプション サポートの設定:例

DHCP リレー エージェントおよびインターフェイスごとのリレー エージェント情報オプション サポートの設定:例

加入者識別情報サブオプションの設定:例

クライアント識別用 DHCP リレー クラス サポートの設定:例

MPLS VPN 用 DHCP リレー エージェント サポートの設定:例

DHCP リレー エージェント情報オプション カプセル化サポート:例

DHCP スマート リレー エージェント転送:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

Cisco IOS DHCP リレー エージェントの機能に関する情報

用語集

Cisco IOS DHCP リレー エージェントの設定

Cisco IOS ソフトウェアを実行中の Cisco ルータには、Dynamic Host Configuration Protocol(DHCP)サーバおよびリレー エージェント ソフトウェアが含まれています。DHCP リレー エージェントとは、クライアントとサーバ間で DHCP パケットを転送する任意のホストです。このモジュールでは、Cisco IOS DHCP リレー エージェントの設定に必要な概念と作業を説明します。

機能情報の入手方法

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「Cisco IOS DHCP リレー エージェントの機能に関する情報」 を参照してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

Cisco IOS DHCP リレー エージェントの設定時の前提条件

DHCP リレー エージェントを設定する前に、「DHCP の概要」モジュールで説明されている概念を理解しておく必要があります。

Cisco IOS DHCP サーバとリレー エージェントはデフォルトでイネーブルに設定されています。コンフィギュレーション ファイルをチェックすると、ディセーブルになっているか確認できます。ディセーブルになっている場合は、コンフィギュレーション ファイルに no service dhcp コマンドが表示されます。必要に応じて、 service dhcp コマンドでこの機能を再度イネーブルにします。

Cisco IOS DHCP リレー エージェントは、 ip helper-address が設定されている場合にだけインターフェイス上でイネーブルになります。このコマンドにより、DHCP ブロードキャストを設定済みの DHCP サーバに転送できるようになります。

DHCP リレー エージェントについて

DHCP リレー エージェントを設定する前に、次の概念を理解しておく必要があります。

「DHCP リレー エージェント概要」

DHCP リレー エージェント概要

DHCP リレー エージェントとは、クライアントとサーバ間で DHCP パケットを転送する任意のホストです。リレー エージェントは、クライアントとサーバが同じ物理サブネット上にない場合に、その間で要求と応答を転送するために使用されます。リレー エージェントによる転送は、IP ルータによる通常の転送とは異なります。IP ルータによる転送では、IP データグラムがネットワーク間である程度透過的にスイッチングされます。一方、リレー エージェントは DHCP メッセージを受信すると、新しい DHCP メッセージを生成し、別のインターフェイスに送信します。リレー エージェントはゲートウェイ IP アドレスを設定し(DHCP パケットの giaddr フィールド)、パケットにリレー エージェント情報のオプション(Option 82)を追加して(設定されている場合)、DHCP サーバに転送します。サーバからの応答は、Option 82 を削除してからクライアントに転送されます。

Cisco IOS DHCP リレー エージェントでは、スマート リレー エージェント転送など、アンナンバード インターフェイスが使用できます。アンナンバード インターフェイスで接続された DHCP クライアントでは、DHCP クライアントがアドレスを取得すると、DHCP リレー エージェントが自動的にスタティック ホスト ルートを追加します。この際、アンナンバード インターフェイスを発信インターフェイスとして指定します。リース期間が切れるか、またはクライアントがアドレスをリリースすると、ルートは自動的に削除されます。

DHCP リレー エージェントの設定方法

ここでは、次の作業について説明します。

「パケット転送アドレスの指定」(必須)

「リレー エージェント情報のオプション サポートの設定」(任意)

「インターフェイスごとのリレー エージェント情報オプション サポートの設定」(任意)

「リレー エージェント情報オプションの加入者 ID サブオプションの設定」(任意)

「クライアント識別用 DHCP リレー クラス サポートの設定」(任意)

「MPLS VPN の DHCP リレー エージェント サポートの設定」(任意)

「リレー エージェント情報オプションのカプセル化サポートの設定」(任意)

「スマート リレー エージェント転送を使用して、DHCP ブロードキャストのゲートウェイ アドレスをセカンダリ アドレスに設定」(任意)

「プライベートおよび標準サブオプション番号サポートの設定」(任意)

「DHCP リレー エージェントのトラブルシューティング」(任意)

パケット転送アドレスの指定

DHCP リレー エージェントが DHCP サーバにパケットを転送するように設定するには、この作業を実行します。

DHCP クライアントは、最初の DHCPDISCOVER メッセージを送信するために User Datagram Protocol(UDP; ユーザ データグラム プロトコル)ブロードキャストを使用する必要があります。その理由は、クライアントが接続先のネットワークについての情報を持っていないからです。サーバを含まないネットワーク セグメントにクライアントがある場合、ルータはたいてい、ブロードキャスト トラフィックを転送しないように設定されているため、UDP ブロードキャストは通常、転送されません。また、DHCP クライアントが DHCPDISCOVER メッセージをブロードキャストするとき、リレー エージェントはクライアントにブロードキャスト メッセージを送信します。Address Resolution Protocol(ARP; アドレス解決プロトコル)エントリが作成されるのは、クライアントが ACK メッセージを受信した後、不要な ARP チェックが実行されるためです。ARP テーブルにエントリが 2 つある場合、ARP タイムアウト後に 1 つはタイムアウトになります。

ブロードキャストを受信しているルータのインターフェイスを、ある種のクラスのブロードキャストをヘルパー アドレスに転送するように設定し、この状況を改善することができます。インターフェイスごとに、複数のヘルパー アドレスを使用することができます。

ルータがこれらのアドレス割り当て要求やパラメータ要求を転送するとき、ルータは DHCP リレー エージェントの役割を果たします。DHCP リレー エージェントの Cisco ルータでの実装は、 ip helper-address インターフェイス コンフィギュレーション コマンドで行います。

図 1で、DHCP クライアントは、ローカル LAN 上の IP アドレスおよび補足的なコンフィギュレーション パラメータ要求をブロードキャストします。ルータ B は DHCP リレー エージェントの役割を果たし、そのブロードキャストを取り上げて、他のインターフェイス上に送信するための新規 DHCP メッセージを作成します。この DHCP メッセージの一部として、リレー エージェントは、 ip helper-address コマンドを含むインターフェイスの IP アドレスを DHCP パケットのゲートウェイ IP アドレス(giaddr)フィールドに挿入します。この IP アドレスによって、DHCP サーバは、どのサブネットがその応答を受信する必要があるかを決定し、提示する適切な IP アドレス範囲を識別することが可能になります。DHCP リレー エージェントは、 ip helper-address インターフェイス コンフィギュレーション コマンドで指定される DHCP サーバ アドレス 172.16.1.2 に、ローカル ブロードキャストを(IP unicast で)送信します。

図 1 ヘルパー アドレスによる UDP ブロードキャストの DHCP サーバへの転送

 

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip helper-address address

5. exit

6. ip dhcp relay prefer known-good-server

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet0/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip helper-address address

 

Router(config-if)# ip helper-address 172.16.1.2

BOOTP や DHCP など、UPD ブロードキャストの転送

address 引数として特定の DHCP サーバ アドレスを指定できます。また、他の DHCP サーバが宛先ネットワーク セグメントにある場合、ネットワーク アドレスを取ることも可能です。ネットワーク アドレスを使用することによって、他のサーバが DHCP 要求に応答できます。

複数のサーバがある場合、サーバごとに 1 つのヘルパー アドレスを設定することができます。

ステップ 5

exit

 

Router(config-if)# exit

(任意)インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

ip dhcp relay prefer known-good-server

 

Router(config)# ip dhcp relay prefer known-good-server

(任意)DHCP クライアントがアドレスを変更し、前の要求を扱うサーバへのクライアント要求を転送する頻度を減らします。

DHCP リレーは、アンナンバード インターフェイス上の DHCP クライアントに提供されるアドレス用の ARP エントリを削除します。

リレー エージェント情報のオプション サポートの設定

DHCP リレー エージェント情報オプションのサポートをイネーブルにするには、この作業を行います。

リレー エージェント情報のオプション

自動 DHCP アドレス割り当ては通常、IP アドレスに基づいて行われます。具体的には、ゲートウェイ IP アドレス(DHCP パケットの giaddr フィールド)か、着信インターフェイスの IP アドレスかによって自動的に割り当てられます。一部のネットワークでは、割り当てる IP アドレスをさらに特定するための追加情報を使用する必要があります。Cisco IOS リレー エージェントは、リレー エージェント情報オプション(Option 82)を使用することで、クライアントを発信元として DHCP サーバに向かう DHCP パケットを転送する際、自分自身に関する補足情報を含めることができます。

Cisco IOS は、 ip dhcp relay information option コマンドを使用してこの機能をサポートします。リレー エージェントは、回線 ID サブオプションとリモート ID サブオプションをリレー エージェント情報オプションに追加し、DHCP サーバに転送します。

DHCP サーバはこの情報を使用して、IP アドレスの割り当て、アクセス コントロールの実行、Quality of Service(QoS)およびセキュリティ ポリシー(あるいはパラメータを割り当てる他のポリシー)の設定を、サービス プロバイダー ネットワークの加入者ごとに行うことができます。

図 2 は、次の手順でリレー エージェント情報オプションを DHCP パケットに挿入している様子を示しています。

1. ホスト(DHCP クライアント)は DHCP 要求を生成し、これをネットワーク上にブロードキャストします。

2. DHCP リレー エージェントはブロードキャスト DHCP 要求パケットを代行受信し、リレー エージェント情報オプション(Option 82)をそのパケットに挿入します。リレー エージェント情報オプションには、関連するサブオプションが含まれます。

3. DHCP リレー エージェントは、DHCP パケットを DHCP サーバにユニキャストします。

4. DHCP サーバはパケットを受信し、サブオプションを使用して IP アドレスおよび他のコンフィギュレーション パラメータを割り当て、クライアントに戻します。

5. クライアントに転送される間に、サブオプション フィールドはリレー エージェントでパケットから取り除かれます。

図 2 リレー エージェントの情報オプション操作

 

リレー エージェントの情報再転送ポリシー

DHCP リレー エージェントは、すでにリレー情報を持っている別の DHCP リレー エージェントからメッセージを受信する場合があります。デフォルトでは、前のリレー エージェントからのリレー情報は置き換えられます。ご使用のネットワークでこの動作が不適切な場合、 ip dhcp relay information policy { drop | keep | replace } グローバル コンフィギュレーション コマンドを使用して処理法を変更することができます。

再転送ポリシーが確実に正しく処理されるように、 no ip dhcp relay information check グローバル コンフィギュレーション コマンドを使用して、リレー エージェントの情報チェックを確実にディセーブルにします。

前提条件

DHCP オプションがどのように動作するかを理解することは重要です。詳細については、「DHCP の概要」モジュールを参照してください。

制約事項

ip dhcp relay information コマンドが、グローバル コンフィギュレーション モードで設定されているが、インターフェイス コンフィギュレーション モードでは設定されていない場合、すべてのインターフェイスにグローバル コンフィギュレーションが適用されます。

ip dhcp relay information コマンドがグローバル コンフィギュレーション モードとインターフェイス コンフィギュレーション モードの両方で設定されている場合、インターフェイス コンフィギュレーション コマンドがグローバル コンフィギュレーション コマンドより優先されます。ただし、インターフェイス コンフィギュレーションのないインターフェイスにはグローバル コンフィギュレーションが適用されます。

ip dhcp relay information コマンドが、グローバル コンフィギュレーション モードでは設定されていないがインターフェイス コンフィギュレーション モードでは設定されている場合、適用される設定オプションのあるインターフェイスだけが影響を受けます。他のすべてのインターフェイスは、設定の影響を受けません。

リレー エージェント情報オプションのインターフェイスごとのサポートについては、「インターフェイスごとのリレー エージェント情報オプション サポートの設定」を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip dhcp relay information option

4. ip dhcp relay information check

5. ip dhcp relay information policy { drop | keep | replace }

6. ip dhcp relay information trust-all

7. end

8. show ip dhcp relay information trusted-sources

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp relay information option

 

Router(config)# ip dhcp relay information option

DHCP サーバに転送された BOOTREQUEST メッセージに DHCP リレー エージェント情報オプション(Option 82 フィールド)を挿入できるようにします。

この機能は、デフォルトでディセーブルになっています。

ステップ 4

ip dhcp relay information check

 

Router(config)# ip dhcp relay information check

(任意)転送された BOOTREPLY メッセージのリレー エージェント情報オプションが有効であることを確認するように DHCP を設定します。

デフォルトでは、DHCP は、DHCP サーバから受信した DHCP 応答パケットの Option 82 フィールドが有効であることを確認します。無効なメッセージを受信した場合、リレー エージェントはそれをドロップします。有効なメッセージを受信した場合、リレー エージェントは Option 82 フィールドを削除し、そのパケットを転送します。ディセーブルになっている場合は、 ip dhcp relay information check コマンドで、この機能を再度イネーブルにします。

ステップ 5

ip dhcp relay information policy { drop | keep | replace }

 

Router(config)# ip dhcp relay information policy replace

(任意)メッセージにリレー情報がすでに含まれている場合、リレー エージェントは何をする必要があるかという DHCP リレー エージェントの再転送ポリシーを設定します。

詳細については、「リレー エージェントの情報再転送ポリシー」の項を参照してください。

ステップ 6

ip dhcp relay information trust-all

 

Router(config)# ip dhcp relay information trust-all

(任意)ルータのインターフェイスすべてを、DHCP リレー情報オプションの信頼できるソースとして設定します。

デフォルトでは、DHCP パケットでゲートウェイ アドレスがすべて 0 に設定され、リレー エージェント情報オプションがすでにパケットにある場合、DHCP リレー エージェントはそのパケットを廃棄します。 ip dhcp relay information trust-all コマンドを使用して、この動作を上書きし、パケットを受け入れます。

エージェントとクライアントとの間に、Option 82 を挿入する可能性のあるスイッチがある場合、このコマンドは役に立ちます。このコマンドを使用して、確実にこれらのパケットがドロップしないようにします。

ip dhcp relay information trusted インターフェイス コンフィギュレーション モード コマンドを使用すれば、DHCP リレー情報オプションの信頼できるソースとして各インターフェイスを設定することができます。

ステップ 7

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 8

show ip dhcp relay information trusted-sources

 

Router# show ip dhcp relay information trusted-sources

(任意)DHCP リレー情報オプションの信頼できるソースとして設定されるインターフェイスすべてを表示します。

インターフェイスごとのリレー エージェント情報オプション サポートの設定

インターフェイスごとに DHCP リレー エージェント情報オプション(Option 82)のサポートをイネーブルにするには、この作業を実行します。

このようにインターフェイスを設定すれば、インターフェイスごとに異なる DHCP Option 82 を持つ加入者に 1 台の Cisco ルータから到達することが可能になります。

前提条件

DHCP オプションがどのように動作するかを理解することは重要です。詳細については、「DHCP の概要」モジュールを参照してください。

DHCP がグローバル コンフィギュレーションのリレー エージェント情報オプションをどのように処理するか、「リレー エージェント情報のオプション」および「リレー エージェントの情報再転送ポリシー」の項を読んで理解してください。

制約事項

ip dhcp relay information コマンドが、グローバル コンフィギュレーション モードで設定されているが、インターフェイス コンフィギュレーション モードでは設定されていない場合、すべてのインターフェイスにグローバル コンフィギュレーションが適用されます。

ip dhcp relay information コマンドがグローバル コンフィギュレーション モードとインターフェイス コンフィギュレーション モードの両方で設定されている場合、インターフェイス コンフィギュレーション コマンドがグローバル コンフィギュレーション コマンドより優先されます。ただし、インターフェイス コンフィギュレーションのないインターフェイスにはグローバル コンフィギュレーションが適用されます。

ip dhcp relay information コマンドが、グローバル コンフィギュレーション モードでは設定されていないがインターフェイス コンフィギュレーション モードでは設定されている場合、適用される設定オプションのあるインターフェイスだけが影響を受けます。他のすべてのインターフェイスは、設定の影響を受けません。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip dhcp relay information option-insert [ none ]

5. ip dhcp relay information check-reply [ none ]

6. ip dhcp relay information policy-action { drop | keep | replace }

7. exit

8. ステップ 3 ~ 7 を繰り返して、それぞれのインターフェイスでリレー エージェント情報オプションを設定します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet0/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip dhcp relay information option-insert [ none ]

 

Router(config-if)# ip dhcp relay information option-insert

DHCP サーバに転送された BOOTREQUEST メッセージに DHCP リレー エージェント情報オプション(Option 82 フィールド)を挿入できるようにします。

この機能は、デフォルトでディセーブルになっています。ただし、グローバル コンフィギュレーション モードではリレー エージェント情報オプションのサポートが設定されているが、インターフェイス コンフィギュレーション モードでは設定されていない場合、インターフェイスはグローバル コンフィギュレーションを継承します。

実行中の設定に、 ip dhcp relay information option-insert none インターフェイス コンフィギュレーション コマンドが保存されます。このコマンドは、あらゆるグローバル リレー エージェント情報設定に優先します。

ステップ 5

ip dhcp relay information check-reply [ none ]

 

Router(config-if)# ip dhcp relay information check-reply

転送された BOOTREPLY メッセージのリレー情報オプションを検証するように、DHCP サーバを設定します。

デフォルトでは、DHCP は、DHCP サーバから受信した DHCP 応答パケットの Option 82 フィールドが有効であることを確認します。無効なメッセージを受信した場合、リレー エージェントはそれをドロップします。有効なメッセージを受信した場合、リレー エージェントは Option 82 フィールドを削除し、そのパケットを転送します。ディセーブルになっている場合は、 ip dhcp relay information check-reply コマンドで、この機能を再度イネーブルにします。

実行中の設定に、 ip dhcp relay information check-reply none インターフェイス コンフィギュレーション コマンドオプションが保存されます。このコマンドは、あらゆるグローバル リレー エージェント情報設定に優先します。

ステップ 6

ip dhcp relay information policy-action { drop | keep | replace }

 

Router(config-if)# ip dhcp relay information policy-action replace

メッセージにリレー情報がすでに含まれている場合、リレー エージェントは何をする必要があるかという DHCP リレー エージェントの情報再転送ポリシーを設定します。

詳細については、「リレー エージェントの情報再転送ポリシー」を参照してください。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 8

ステップ 3 ~ 7 を繰り返して、それぞれのインターフェイスでリレー エージェント情報を設定します。

(任意)

リレー エージェント情報オプションの加入者 ID サブオプションの設定

Internet Service Provider(ISP; インターネット サービス プロバイダー)がリレー エージェント情報オプションの加入者 ID サブオプションに固有識別情報を追加できるようにするには、この作業を実行します。

固有識別情報を利用して、ISP は、加入者を識別し、その加入者に特定のアクション(ホスト IP アドレス、サブネット マスク、ドメイン ネーム システム DNS の割り当てなど)を割り当て、アカウンティングを発生させることができます。

この機能が追加される以前は、加入者が移動した場合、各 ISP にその変更を通知する必要があり、各 ISP では、影響を受けるお客様に対して同時に DHCP 設定を再設定する必要がありました。サービスが変更されていなくても、移動があるたびに管理者は ISP 環境を変更する必要がありました。この機能が追加されたことにより、あるネットワーク アクセス サーバから他のサーバに加入者が移動した場合、DHCP サーバまたは ISP の該当部分の設定を変更する必要がなくなりました。

前提条件

加入者ごとに固有識別情報を設定する必要があります。

新規の設定可能な加入者識別情報オプションを、クライアントに接続されたインターフェイスに設定する必要があります。あるインターフェイスから別のものに加入者が移動するとき、インターフェイス コンフィギュレーションも変更する必要があります。

サーバは、その新規加入者を認識できる必要があります。

手順の概要

1. enable

2. configure terminal

3. ip dhcp relay information option

4. interface type number

5. ip dhcp relay information option subscriber-id string

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp relay information option

 

Router(config)# ip dhcp relay information option

DHCP サーバに転送された BOOTREQUEST メッセージに DHCP リレー エージェント情報オプション(Option 82 フィールド)を挿入できるようにします。

この機能は、デフォルトでディセーブルになっています。

ステップ 4

interface type number

 

Router(config)# interface atm4/0.1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip dhcp relay information option subscriber-id string

 

Router(config-if)# ip dhcp relay information option subscriber-id newsubscriber123

DHCP リレー エージェントがリレー情報オプションに加入者識別情報を追加するように指定します。

string 引数には、最大で 50 文字の英数字が使えます。

(注) 50 文字を超えて設定すると、ストリングは切り捨てられます。

コマンドは、デフォルトではディセーブルになっています。

クライアント識別用 DHCP リレー クラス サポートの設定

クライアント識別用 DHCP リレー クラス サポートを設定するには、この作業を実行します。

リレー クラス サポート概要

クライアント識別用 DHCP リレー クラス サポートを使用して、次の 4 つのオプションの内容に基づき、Cisco IOS リレー エージェントは、異なる DHCP サーバに、クライアントが生成した DHCP メッセージを転送することができます。

Option 60:ベンダー クラス識別情報

Option 77:ユーザ クラス

Option 124:ベンダー識別用ベンダー クラス

Option 125:ベンダー識別用ベンダー固有情報

各オプションで、DHCP メッセージを送信するクライアントのタイプを識別します。

リレー プールは、アドレス割り当てに使用されない DHCP プールを定義する方法を提供します。これらのリレー プールを使用して、特定のサブネット上のクライアントからの DHCP メッセージを特定の DHCP サーバに転送するように指定することができます。これらのリレー プールは、転送動作の決定に役立つ、プール内部のリレー クラスで設定することができます。

たとえば、DHCP DISCOVER メッセージ中のオプションを受信後、リレー エージェントはリレー プールからのリレー クラスを一致させて識別し、そのリレー クラスに関連付けられた DHCP サーバに DHCP DISCOVER メッセージを導きます。

リレー クラス サポートの使用方法シナリオ

応用例では、DHCP リレー エージェントの役割を果たす Cisco ルータは、2 つの VoIP サービス(H323 および SIP)から DHCP 要求を受信します。要求側のデバイスは、Option 60 で識別されます。

両方の VoIP サービスにはそれぞれ異なるバックオフィス インフラストラクチャがあり、同一の DHCP サーバからサービスを受けることはできません。H323 デバイスへの要求は H323 サーバに、SIP デバイスからの要求は SIP サーバに転送する必要があります。

解決策として、クライアント デバイスから送信される Option 60 の値に一致するように設定されたリレー クラスでリレー エージェントを設定します。そのオプション値に基づき、リレー エージェントはリレー クラスと一致させて識別し、識別したリレー クラスに関連付けられた DHCP サーバに DHCP DISCOVER メッセージを転送します。

Cisco IOS DHCP サーバは、プールに適切なリレー クラスを検証し、設定順序にかかわらず、完全に一致するクラスを使用します。完全に一致するクラスが見つからない場合、DHCP サーバは、見つかった最初のデフォルト一致を使用します。

前提条件

DHCP オプションがどのように動作するかを理解することは重要です。詳細については、「DHCP の概要」モジュールを参照してください。

option hex コマンドを設定するためには、オプションの各バイト位置の 16 進値を確認する必要があります。形式は製品ごとに異なる場合があります。この情報については、リレー エージェントのベンダーに問い合せてください。

手順の概要

1. enable

2. configure terminal

3. ip dhcp class class-name

4. option code hex hex-pattern [*] [ mask bit-mask-pattern ]

5. exit

6. 設定が必要な DHCP クラスごとにステップ 3 ~ 5 を繰り返します。

7. ip dhcp pool name

8. relay source ip-address subnet-mask

9. class class-name

10. relay target [ vrf vrf-name | global ] ip-address

11. exit

12. 設定する必要のある DHCP クラスごとにステップ 9 ~ 11 を繰り返します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp class class-name

 

Router(config)# ip dhcp class SIP

DHCP クラスを定義し、DHCP クラス コンフィギュレーション モードを開始します。

ステップ 4

option code hex hex-pattern [ * ][ mask bit-mask-pattern ]

 

Router(dhcp-class)# option 60 hex 010203

DHCP メッセージに挿入された DHCP オプションに基づき、リレー エージェントが転送の決定を行えるようにします。

ステップ 5

exit

 

Router(dhcp-class)# exit

DHCP クラス コンフィギュレーション モードを終了します。

ステップ 6

設定が必要な DHCP クラスごとにステップ 3 ~ 5 を繰り返します。

--

ステップ 7

ip dhcp pool name

 

Router(config)# ip dhcp pool ABC

DHCP サーバで DHCP プールを設定し、DHCP プール コンフィギュレーション モードに入ります。

ステップ 8

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.2.0.0 255.0.0.0

リレー ソースを設定します。 ip-address および
subnet-mask 引数は、リレー ソースの IP アドレスとサブネット マスクです。

このコマンドは、通常の DHCP ネットワーク プロトコルの network コマンドに類似しています。その理由は、アドレス プールの利用が、IP アドレスおよびマスクの設定がリレー ソースの設定と一致するインターフェイスに着信するパケットに制限されるからです。

ステップ 9

class class-name

 

Router(dhcp-config)# class SIP

クラスを DHCP プールに関連付け、DHCP プールクラス コンフィギュレーション モードに入ります。

ステップ 10

relay target [ vrf vrf-name | global ] ip-address

 

Router(config-dhcp-pool-class)# relay target 10.21.3.1

パケットが転送される DHCP サーバの IP アドレスを設定します。

ステップ 11

exit

 

Router(dhcp-class)# exit

DHCP プール クラス コンフィギュレーション モードを終了します。

ステップ 12

設定する必要のある DHCP クラスごとにステップ 9 ~ 11 を繰り返します。

--

MPLS VPN の DHCP リレー エージェント サポートの設定

MPLS VPN の DHCP リレー エージェント サポートを設定するには、この作業を実行します。

MPLS VPN の DHCP リレー エージェント サポート

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)の Virtual Private Network(VPN; バーチャル プライベート ネットワーク)の DHCP リレー サポートを使用することにより、アドレスを重複させてアドレス空間を節約することができます。リレー エージェントは、異なる VPN 上の複数のクライアントをサポートすることができます。また、VPN が異なるこれらのクライアントの多くは、同一の IP アドレスを共有することができます。

VPN の設定には、通常の DHCP ホスト IP アドレスの割り当てが必要です。VPN では、インターネット全体で一意ではない可能性のあるプライベートなアドレス空間を使用します。

1 つ以上の MPLS VPN にもアクセスするネットワーク要素にリレー エージェントが常駐する環境もあります。このような複数の VPN 上の DHCP クライアントにサービスを提供する DHCP サーバは、各クライアントが常駐する VPN を見つける必要があります。リレー エージェントを含むネットワーク要素は通常、DHCP クライアントの VPN アソシエーションをキャプチャし、その情報を DHCP パケットのリレー エージェント情報オプションに含めます。

MPLS VPN の DHCP リレー サポートを使用することにより、DHCP リレー エージェント情報オプションの次の 3 つのサブオプションを使用して、リレー エージェントがこの必要な VPN 関連情報を DHCP サーバに転送することができるようになります。

VPN 識別情報

サブネット選択

サーバ識別情報の上書き

VPN 識別情報サブオプションはリレー エージェントに使用され、VPN が DHCP サーバに渡す DHCP 要求すべてに対して VPN を DHCP サーバに通知します。また、DHCP サーバがリレー エージェントに返す DHCP 応答を正しく転送するためにも使用されます。VPN 識別情報サブオプションには、クライアントが接続された着信インターフェイスで設定された VPN ID が含まれています。VRF 名は設定したが VPN ID は設定していない場合、VRF 名が VPN 識別情報サブオプションとして使用されます。インターフェイスがグローバル ルーティング空間にある場合、VPN サブオプションは追加されません。

サブネット選択サブオプションを使用して、クライアントが常駐するサブネットを、リレー エージェントと通信する IP アドレスから分離することができます。通常の DHCP 処理では、ゲートウェイ アドレスは、DHCP クライアントが常駐するサブネットと、サーバがリレー エージェントと通信するために使用可能な IP アドレスの両方を指定します。DHCP クライアントが常駐するサブネットをリレー エージェントが指定する必要がある場合があります。このサブネットは、リレーエージェントとの通信にサーバが使用可能な IP アドレスとは異なります。リレー エージェント情報オプションにはサブネット選択サブオプションが含まれており、DHCP サーバに渡されます。ゲートウェイ アドレスは、DHCP サーバに向かうリレー エージェントの発信インターフェイスに変更されます。DHCP サーバは、応答パケットをリレー エージェントに送り返すのにこのゲートウェイ アドレス使用します。

サーバ識別情報の上書きサブオプション値は、通常のサーバ ID アドレスの代わりに DHCP サーバから応答パケットにコピーされます。サーバ識別情報の上書きサブオプションには、着信インターフェイスの IP アドレスが含まれています。これは、クライアントからアクセス可能なリレー エージェントの IP アドレスです。この情報を利用して、DHCP クライアントは更新パケットおよびリリースパケットのすべてをリレー エージェントに送信します。リレー エージェントは VPN サブオプションすべてを追加し、更新パケットおよびリリースパケットを元の DHCP サーバに転送します。

これらのサブオプションを DHCP リレー エージェント情報オプションに追加した後、ゲートウェイ アドレスは、DHCP サーバに向かうリレー エージェントの発信インターフェイスに変更されます。パケットが DHCP サーバから戻ったとき、リレー エージェントはリレー エージェント情報オプションを削除し、正しい VPN 上の DHCP クライアントにパケットを転送します。

図 3 は、DHCP リレー エージェントおよび DHCP サーバが、各クライアントが常駐する VPN を認識できるという VPN シナリオです。DHCP クライアント 1 は、VPN green の一部であり、DHCP クライアント 2 は VPN red の一部であり、両方の IP アドレスは同じ 192.168.1.0/24 です。クライアントの IP アドレスが同じであるため、DHCP リレー エージェントと DHCP サーバは、リレー エージェント情報オプションの VPN 識別情報、サブネット選択、およびサーバ識別情報を使用して、クライアントの正しい VPN を識別します。

図 3 バーチャル プライベート ネットワークの DHCP 設定

 

前提条件

MPLS VPN の DHCP リレー サポートを設定する前に、標準の MPLS VPN を設定する必要があります。

制約事項

ip dhcp relay information option vpn グローバル コンフィギュレーション コマンドが設定され、 ip dhcp relay information option vpn-id インターフェイス コンフィギュレーション コマンドが設定されてない場合、すべてのインターフェイスにグローバル コンフィギュレーションが適用されます。

dhcp relay information option vpn グローバル コンフィギュレーション コマンドが設定され、 ip dhcp relay information option vpn-id インターフェイス コンフィギュレーション コマンドも設定されている場合、インターフェイス コンフィギュレーション コマンドがグローバル コンフィギュレーション コマンドよりも優先されます。ただし、インターフェイス コンフィギュレーションのないインターフェイスにはグローバル コンフィギュレーションが適用されます。

ip dhcp relay information option vpn グローバル コンフィギュレーション コマンドが未設定で、 ip dhcp relay information option vpn-id interface コンフィギュレーション コマンドが設定されている場合、コンフィギュレーション オプションが適用されたインターフェイスだけが影響を受けます。他のすべてのインターフェイスは、設定の影響を受けません。

手順の概要

1. enable

2. configure terminal

3. ip dhcp relay information option vpn

4. interface type number

5. ip helper-address vrf name [ global ] address

6. ip dhcp relay information option vpn-id [ none ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp relay information option vpn

 

Router(config)# ip dhcp relay information option vpn

DHCP サーバに転送された BOOTREQUEST メッセージの DHCP リレー エージェント情報オプションにシステムが VPN サブオプションを挿入できるようにし、DHCP サーバに向かう発信インターフェイスへのゲートウェイ アドレスを設定します。

コマンド設定時、VPN サブオプションは BOOTP ブロードキャスト パケットにも追加されます。

ステップ 4

interface type number

 

Router(config)# interface FastEthernet0/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip helper-address vrf name [ global ] address

 

Router(config-if)# ip helper-address vrf blue 172.27.180.232

インターフェイスで受信された BOOTP などの UDP ブロードキャストを転送します。

DHCP サーバが、異なる VPN または VPN と異なるグローバル空間に常駐する場合、 vrf name または global オプションを使用して、DHCP サーバが常駐する VRF またはグローバル空間の名前を指定することができます。

ステップ 6

ip dhcp relay information option vpn-id [ none ]

 

Router(config-if)# ip dhcp relay information option vpn-id

(任意)DHCP サーバに転送された BOOTREQUEST メッセージの DHCP リレー エージェント情報オプションにシステムが VPN サブオプションを挿入できるようにし、DHCP サーバに向かう発信インターフェイスへのゲートウェイ アドレスを設定します。

コマンド設定時、VPN サブオプションは BOOTP ブロードキャスト パケットにも追加されます。

ip dhcp relay information option vpn-id none コマンドを使用して、インターフェイスの VPN 機能をディセーブルにすることができます。このコマンドを使用する必要があるのは、 ip dhcp relay information option vpn グローバル コンフィギュレーション コマンドが設定されていて、そのグローバル コンフィギュレーションを上書きする必要がある場合だけです。

no ip dhcp relay information option vpn-id コマンドは、実行中の設定から、設定を削除します。この場合、インターフェイスはそのグローバル コンフィギュレーションを継承します。設定は、VPN サブオプションを挿入するように設定されていることも、設定されていないこともあります。

リレー エージェント情報オプションのカプセル化サポートの設定

DHCP リレー エージェント情報オプション(Option 82)のカプセル化サポートをイネーブルにするには、次の作業を実行します。

Option 82 カプセル化の DHCP リレー サポート

2 つのリレー エージェントが DHCP クライアントと DHCP サーバの間でメッセージをリレーするとき、2 番目のリレー エージェント(サーバに近い方)は、デフォルトで、最初の Option 82 情報を自身の Option 82 と置き換えます。最初のリレー エージェントのリモート ID および回線 ID 情報は消去されます。配置のシナリオによっては、2 番目のリレー エージェントの Option 82 の他に、最初のリレー エージェントの元の Option 82 も保持する必要があります。たとえば、2 番目のリレー エージェントとして機能する Intelligent Service Gateway(ISG; インテリジェント サービス ゲートウェイ)は、レイヤ 2 デバイスに接続されています。レイヤ 2 デバイスは家庭に接続され、自身の Option 82 で家庭を識別します。

DHCP リレー Option 82 カプセル化機能を使用して、1 番目のリレー エージェントから受信したメッセージの Option 82 情報を 2 番目のリレー エージェントがカプセル化することができます(自身の Option 82 情報を追加するように設定されている場合)。この設定を使用すれば、DHCP サーバは両方のリレー エージェントの Option 82 情報を使用することができます。DHCP サーバは、2 番目のリレー エージェントの VPN 情報を 1 番目のリレー エージェントの Option 82 情報とともに使用し、クライアント デバイスの正しいアドレス割り当てや他のコンフィギュレーション パラメータを、VRF、Option 60、およびカプセル化された Option 82 に基づいて送信することができます。DHCP サーバから DHCP クライアントへの応答メッセージは、2 つのリレー エージェントを通過して DHCP クライアントに到達する要求メッセージと同じパスを経由します。

図 4 に、この機能が設定されたとき、2 つのリレー エージェントおよび DHCP サーバで発生する処理を示しています。

1. DHCP クライアントは、(Option 60 を含む)DHCP メッセージを生成し、ネットワークにブロードキャストします。

2. 1 番目の DHCP リレー エージェントは、ブロードキャスト DHCP 要求パケットを代行受信し、自身の Option 82 をパケットに挿入します。

3. リレー エージェントは回線 ID サブオプションおよびリモート ID サブオプションを Option 82 に自動的に追加し、2 番目のリレー エージェントに転送します。

4. 2 番目のリレー エージェントは 1 番目のリレー エージェントの Option 82 をカプセル化し、自身の Option 82 を挿入します。

5. ゲートウェイ IP アドレス(giaddr)は、2 番目のリレー エージェントの着信インターフェイスに設定され、1 番目のリレー エージェントの元の giaddr はカプセル化されます。

6. 2 番目の DHCP リレー エージェントは、DHCP パケットを DHCP サーバへユニキャストします。

7. DHCP サーバはそのパケットを受信し、2 番目のリレーの VPN サブオプションを 1 番目のリレー エージェントの Option 82 と合わせて使用して IP アドレスおよび他のコンフィギュレーション パラメータを割り当て、2 番目のリレー エージェントにパケットを転送し戻します。

8. 2 番目のリレー エージェントがサーバからの応答メッセージを受信すると、1 番目のリレー エージェントからの、カプセル化された Option 82 および giaddr を復元します。応答メッセージは次に先の giaddr に送信されます。

9. Option 82 は、クライアントに転送する前に 1 番目のリレー エージェントによってパケットから取り除かれます。

図 4 DHCP リレー エージェント情報オプション カプセル化サポートの処理

手順の概要

1. enable

2. configure terminal

3. ip dhcp relay information option

4. ip dhcp relay information option vpn

5. ip dhcp relay information policy encapsulate

6. interface type number

7. ip dhcp relay information option policy-action encapsulate

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp relay information option

 

Router(config)# ip dhcp relay information option

DHCP サーバに転送された BOOTREQUEST メッセージに DHCP リレー エージェント情報オプション(Option 82 フィールド)を挿入できるようにします。

この機能は、デフォルトでディセーブルになっています。

ステップ 4

ip dhcp relay information option vpn

 

Router(config)# ip dhcp relay information option vpn

(任意)DHCP サーバに転送された BOOTREQUEST メッセージの DHCP リレー エージェント情報オプションにシステムが VPN サブオプションを挿入できるようにし、DHCP サーバに向かう発信インターフェイスへのゲートウェイ アドレスを設定します。

コマンド設定時、VPN サブオプションは BOOTP ブロードキャスト パケットにも追加されます。

ステップ 5

ip dhcp relay information policy encapsulate

 

Router(config)# ip dhcp relay information policy encapsulate

DHCP リレー エージェント情報オプション(Option 82 フィールド)をカプセル化できるようにします。この情報オプションは先のリレー エージェントから受信したもので、DHCP サーバに向けて転送された BOOTREQUEST メッセージに含まれています。

両方のリレー エージェントの Option 82 情報は、DHCP サーバに転送されます。

ステップ 6

interface type number

 

Router(config)# interface FastEthernet0/0

(任意)インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

グローバル コンフィギュレーション コマンドを設定する場合、特定のインターフェイスに適用するために設定を変更する必要がない限り、インターフェイス コンフィギュレーション コマンドを設定する必要はありません。

ステップ 7

ip dhcp relay information policy-action encapsulate

 

Router(config-if)# ip dhcp relay information policy-action encapsulate

(任意)DHCP リレー エージェント情報オプション(Option 82 フィールド)をカプセル化できるようにします。この情報オプションは、先のリレー エージェントからインターフェイスに受信したもので、インターフェイスの DHCP サーバに転送された BOOTREQUEST メッセージに含まれています。

この機能は、デフォルトでディセーブルになっています。このコマンドは、すべてのグローバル コンフィギュレーションに優先します。ただし、グローバル コンフィギュレーション モードではリレー エージェント情報オプションのカプセル化サポートへの対応が設定されているが、インターフェイス コンフィギュレーション モードでは設定されていない場合、インターフェイスはグローバル コンフィギュレーションを継承します。

スマート リレー エージェント転送を使用して、DHCP ブロードキャストのゲートウェイ アドレスをセカンダリ アドレスに設定

スマート リレー エージェント転送を設定するには、この作業を実行します。

必要なのは、DHCP サーバに転送する UDP ブロードキャストを受信しているインターフェイスにヘルパー アドレスを設定することだけです。このインターフェイスにセカンダリ アドレスがあり、DHCP 要求を転送するとき、ルータに各 IP ネットワークを経由させる場合、必要なのは、 ip dhcp smart-relay コマンドを設定することだけです。スマート リレー エージェントを設定しない場合、すべての要求は、インターフェイスのプライマリ IP アドレスを使用して転送されます。

ip dhcp smart-relay コマンドが設定される場合、リレー エージェントは DHCP サーバからの DHCPOFFER メッセージがなかった時にクライアントが DHCP サーバに要求を送信するリトライ回数をカウントします。3 回リトライした後、リレー エージェントはゲートウェイ アドレスをセカンダリ アドレスに設定します。さらに 3 回リトライしてもまだ DHCP サーバが応答しない場合、次のセカンダリ アドレスがゲートウェイ アドレスとして使用されます。

この機能は、セカンダリ プールを使用するように DHCP サーバを設定できないときに役立ちます。

手順の概要

1. enable

2. configure terminal

3. ip dhcp smart-relay

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp smart-relay

 

Router(config)# ip dhcp smart-relay

DHCP サーバからの DHCPOFFER メッセージがない場合、DHCP リレー エージェントが、ゲートウェイ アドレス(DHCP パケットの giaddr フィールド)をセカンダリ アドレスに切り替えることを可能にします。

プライベートおよび標準サブオプション番号サポートの設定

標準化されていない機能で、プライベート シスコ リレー エージェント サブオプション番号を使用しているものがあります。機能が標準化されると、リレー エージェント サブオプションには、Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)番号が割り当てられます。Cisco IOS では、これらのサブオプションのプライベートおよび IANA 番号の両方をサポートしています。

プライベートまたは IANA 標準リレー エージェント サブオプション番号を使用するように DHCP クライアントを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip dhcp compatibility suboption link-selection { cisco | standard }

4. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp compatibility suboption link-selection { cisco | standard }

 

Router(config)# ip dhcp compatibility suboption link-selection standard

プライベートまたは IANA 標準リレー エージェント サブオプション番号を使用するように DHCP クライアントを設定します。

ステップ 4

exit

 

Router(config)# exit

(任意)グローバル コンフィギュレーション モードを終了します。

DHCP リレー エージェントのトラブルシューティング

DHCP リレー エージェントのトラブルシューティングを行うには、この作業を実行します。

show ip route dhcp コマンドは、DHCP リレー エージェントがアンナンバード インターフェイスからクライアントにルートを追加する際の問題を理解する助けとして役立ちます。DHCP サーバおよびリレー エージェントによってルーティング テーブルに追加されたルートすべてを表示します。

手順の概要

1. enable

2. show ip route dhcp

3. show ip route dhcp ip-address

4. show ip route vrf vrf-name dhcp

5. clear ip route [ vrf vrf-name ] dhcp [ ip-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip route dhcp

 

Router# show ip route dhcp

Cisco IOS DHCP サーバおよびリレー エージェントによって追加されたルートすべてを表示します。

ステップ 3

show ip route dhcp ip-address

 

Router# show ip route dhcp 172.16.1.3

IP アドレスに関連づけられた Cisco IOS DHCP サーバおよびリレー エージェントによって追加されたルートすべてを表示します。

ステップ 4

show ip route vrf vrf-name dhcp

 

Router# show ip route vrf vrf1 dhcp

名前付き VRF に関連づけられた Cisco IOS DHCP サーバおよびリレー エージェントによって追加されたルートすべてを表示します。

ステップ 5

clear ip route [ vrf vrf-name ] dhcp [ ip-address ]

 

Router# clear ip route dhcp

アンナンバード インターフェイス上の DHCP クライアントのリレー エージェントおよび DHCP サーバによって追加されたルーティング テーブルからルートを削除します。

Cisco IOS DHCP リレー エージェントの設定例

ここでは、次の設定例について説明します。

「DHCP リレー エージェントおよびリレー エージェント情報オプション サポートの設定:例」

「DHCP リレー エージェントおよびインターフェイスごとのリレー エージェント情報オプション サポートの設定:例」

「加入者識別情報サブオプションの設定:例」

「クライアント識別用 DHCP リレー クラス サポートの設定:例」

「MPLS VPN 用 DHCP リレー エージェント サポートの設定:例」

「DHCP リレー エージェント情報オプション カプセル化サポート:例」

「DHCP スマート リレー エージェント転送:例」

DHCP リレー エージェントおよびリレー エージェント情報オプション サポートの設定:例

次の例では、DHCP サーバ、リレー エージェントをイネーブルにする方法、および DHCP リレー情報オプション(Option 82)の挿入および削除を示します。Cisco IOS DHCP サーバは、デフォルトでイネーブルになることに注意してください。この例では、DHCP サーバはディセーブルでした。

!reenables the DHCP server
service dhcp
ip dhcp relay information option
!
interface ethernet0/0
ip address 192.168.100.1 255.255.255.0
ip helper-address 10.55.11.3

DHCP リレー エージェントおよびインターフェイスごとのリレー エージェント情報オプション サポートの設定:例

次の例では、同じ集約ルータのサービスを受ける加入者で、Asynchronous Transfer Mode(ATM; 非同期転送モード)の加入者とイーサネットのデジタル加入者では、リレー エージェント情報オプションで異なる処理を行う必要があることを示します。ATM 加入者では、リレー エージェント情報オプションは、クライアントに転送する前にリレー エージェントがパケットから削除するように設定されます。イーサネット加入者では、接続されたデバイスがリレー エージェント情報オプションを提供し、パケットに残され、クライアントに転送されるように設定されます。

ip dhcp relay information trust-all
interface Loopback0
ip address 10.16.0.1 255.255.255.0
!
interface ATM3/0
no ip address
!
interface ATM3/0.1
ip helper-address 10.16.1.2
ip unnumbered loopback0
ip dhcp relay information option-insert
!
interface Loopback1
ip address 10.18.0.1 255.255.255.0
!
interface Ethernet4
no ip address
!
interface Ethernet4/0.1
encap dot1q 123
ip unnumbered loopback1
ip helper-address 10.18.1.2
ip dhcp relay information policy-action keep

加入者識別情報サブオプションの設定:例

次の例では、リレー エージェント情報オプションの加入者識別情報サブオプションに固有識別情報を追加する方法を示します。

ip dhcp relay information option
!
interface Loopback0
ip address 10.1.1.129 255.255.255.192
!
interface ATM4/0
no ip address
!
interface ATM4/0.1 point-to-point
ip helper-address 10.16.1.2
ip unnumbered Loopback0
ip dhcp relay information option subscriber-id newperson123
atm route-bridged ip
pvc 88/800
encapsulation aal5snap

クライアント識別用 DHCP リレー クラス サポートの設定:例

次の例では、DHCP メッセージは、サブネット 10.2.2.0 の DHCP クライアントから受信します。リレー エージェントは、リレー プールのリレー クラスを照合および識別し、 relay target コマンドで識別される適切な DHCP サーバに DHCP メッセージを転送します。

!
ip dhcp class H323
option 60 hex 010203
!
ip dhcp class SIP
option 60 hex 040506
!
! The following is the relay pool
ip dhcp pool pool1
relay source 10.2.2.0 255.255.255.0
class H323
relay target 172.16.2.1
relay target 172.17.2.1
!
class SIP
relay target 172.18.2.1

MPLS VPN 用 DHCP リレー エージェント サポートの設定:例

次の例では、DHCP リレー エージェントはイーサネット インターフェイス 0/1 の DHCP 要求を受信し、IP ヘルパー アドレス 10.44.23.7 の DHCP サーバに転送します。このヘルパー アドレスは、vrf1 と名付けられた VRF に関連付けられています。

ip dhcp relay information option vpn
!
interface ethernet 0/1
ip helper-address vrf vrf1 10.44.23.7
!

DHCP リレー エージェント情報オプション カプセル化サポート:例

次の例では、DHCP リレー エージェント 1 は、リレー エージェント情報オプションを DHCP パケットに挿入するように設定されます。DHCP リレー エージェント 2 は、VPN 情報を含む自身のリレー エージェント情報オプション追加し、DHCP リレー エージェント 1 から受信したリレー エージェント情報オプションをカプセル化するように設定されます。DHCP サーバは、両方のリレー エージェントからリレー エージェント情報オプションを受信し、この情報を使用して IP アドレスや他のコンフィギュレーション パラメータを割り当て、クライアントに転送し戻します。

DHCP リレー エージェント 1

ip dhcp relay information option
 

DHCP リレー エージェント 2

ip dhcp relay information option
ip dhcp relay information option vpn
ip dhcp relay information option encapsulation
 

DHCP スマート リレー エージェント転送:例

次の例でルータは、イーサネット インターフェイス 0/0 で受信した DHCP ブロードキャストを DHCP サーバ(10.55.11.3)に転送します。その際、DHCP パケットの giaddr フィールドに 192.168.100.1 を挿入します。DHCP サーバに 192.168.100.0/24 ネットワーク用に設定したスコープまたはプールがある場合、応答します。ない場合は、応答しません。

ip dhcp smart-relay グローバル コンフィギュレーション コマンドが設定されているため、ルータが giaddr フィールドの 192.168.100.1 を使用して 3 つの要求を送信し、1 つも応答がなかった場合、引き続き、代わりに giaddr フィールドの 172.16.31.254 の使用を開始します。スマート リレー機能がなしで、ルートは giaddr フィールドの 192.168.100.1 だけを使用します。

ip dhcp smart-relay
!
interface ethernet0/0
ip address 192.168.100.1 255.255.255.0
ip address 172.16.31.254 255.255.255.0
ip helper-address 10.55.11.3
!

その他の関連資料

次の項は、Cisco IOS DHCP リレー エージェントに関連する参考資料です。

関連資料

関連項目
参照先

DHCP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

Cisco IOS IP Addressing Services Command Reference

DHCP の概念的な説明

DHCP Overview 」モジュール

DHCP サーバ設定

Configuring the Cisco IOS DHCP Server 」モジュール

DHCP クライアントの設定

Configuring the Cisco IOS DHCP Client 」モジュール

DHCP サーバ オンデマンド アドレス プール マネージャの設定

Configuring the DHCP Server On-Demand Address Pool Manager 」モジュール

DHCP の拡張機能

Configuring DHCP Services for Accounting and Security 」モジュール

エッジセッション管理用 DHCP 機能拡張の設定

Configuring DHCP Enhancements for Edge-Session Management 」モジュール

DHCP オプション

Network Registrar User’s Guide, Release 6.1.1 』の付録「 DHCP Options

規格

規格
タイトル

この機能によってサポートされる新しい規格や変更された規格はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 951

Bootstrap Protocol (BOOTP)

RFC 1542

Clarifications and Extensions for the Bootstrap Protocol

RFC 2131

Dynamic Host Configuration Protocol

RFC 2685

Virtual Private Networks Identifier

RFC 3046

DHCP Relay Information Option

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト(http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。 http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

Cisco IOS DHCP リレー エージェントの機能に関する情報

表 1 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ここに記載されていないこのテクノロジーの機能情報については、「 DHCP Features Roadmap 」を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 Cisco IOS DHCP リレー エージェントの機能に関する情報

機能名
リリース
機能情報

DHCP リレー Option 82 カプセル化

12.2(33)SRD

この機能により、別の DHCP リレー エージェントが、先のリレー エージェントからのリレー エージェント情報オプション(Option 82)をカプセル化し、独自の Option 82 を追加し、そのパケットを DHCP サーバに転送することができます。DHCP サーバは、2 番目のリレー エージェントの VPN 情報を 1 番目のリレー エージェントの Option 82 情報とともに使用し、クライアント デバイスの正しいアドレス割り当てや他のコンフィギュレーション パラメータを、VRF、Option 60、およびカプセル化された Option 82 に基づいて送信することができます。

この機能に関する詳細については、次の項を参照してください。

リレー エージェント情報オプションのカプセル化サポートの設定

次のコマンドは、この機能により変更されています。
ip dhcp relay information policy ip dhcp relay information policy-action

クライアント認証用 DHCP クラス サポート

12.4(11)T

この機能は、DHCP クラス メカニズムを拡張して、オプション 60、77、124、および 125 をサポートします。これらのオプションは、DHCP メッセージを送信してクライアントのタイプを識別します。DHCP リレー エージェントは、クライアントから送信された DHCP メッセージのオプションの内容に基づき、決定を転送することができます。

この機能に関する詳細については、次の各項を参照してください。

クライアント識別用 DHCP リレー クラス サポートの設定

クライアント識別用 DHCP リレー クラス サポートの設定:例

この機能により、次のコマンドが追加されました。 option hex

インターフェイス VPN ID ごとの DHCPv4 リレー サポート

12.4(11)T

インターフェイス VPN ID ごとの DHCPv4 リレー サポート機能によって、Cisco IOS DHCP リレー エージェントをインターフェイスごとに設定し、 ip dhcp relay information option vpn コマンドを上書きすることができます。この機能により、異なるインターフェイス上の異なるリレー情報オプションの VPN ID 要件を持つ加入者に 1 つの Cisco ルータから到達することが可能になります。

この機能に関する詳細については、次の各項を参照してください。

MPLS VPN の DHCP リレー エージェント サポートの設定

MPLS VPN 用 DHCP リレー エージェント サポートの設定:例

この機能により、次のコマンドが導入されました。 ip dhcp relay information option vpn-id

インターフェイスごとの DHCP リレー オプション 82 サポート

12.4(6)T
12.2(31)SB2
12.2(33)SRC

この機能により、インターフェイスごとの DHCP リレー エージェント情報オプション(Option 82)のサポートが可能になります。このインターフェイス コンフィギュレーションで、異なる DHCP Option 82 要件を持つ異なる DHCP サーバに 1 つの Cisco ルータから到達することが可能になります。

この機能に関する詳細については、次の各項を参照してください。

インターフェイスごとのリレー エージェント情報オプション サポートの設定

DHCP リレー エージェントおよびインターフェイスごとのリレー エージェント情報オプション サポートの設定:例

この機能により、次のコマンドが導入されました。 ip dhcp relay information check-reply ip dhcp relay information option-insert ip dhcp relay information policy-action

Option 82 の DHCP 加入者 ID サブオプション

12.3(14)T
12.2(28)SB
12.2(33)SRB

この機能によって、ISP が、リレー エージェント情報オプションの加入者識別サブオプションに固有識別情報を追加することが可能になります。

この機能に関する詳細については、次の各項を参照してください。

リレー エージェント情報オプションの加入者 ID サブオプションの設定

加入者識別情報サブオプションの設定:例

この機能により、次のコマンドが導入されました。 ip dhcp relay information option subscriber-id

DHCP リレー MPLS VPN サポート

12.2(8)
12.2(28)SB
12.2(33)SRC

MPLS VPN 用 DHCP リレー サポートを使用して、アドレスの重複を許可し、アドレス空間を温存することができます。リレー エージェントは、異なる VPN 上の複数のクライアントをサポートすることができます。また、VPN が異なるこれらのクライアントの多くは、同一の IP アドレスを共有することができます。

この機能に関する詳細については、次の各項を参照してください。

MPLS VPN の DHCP リレー エージェント サポートの設定

MPLS VPN 用 DHCP リレー エージェント サポートの設定:例

この機能により、次のコマンドが導入されました。 ip dhcp relay information option ip helper address

用語集

DHCP :Dynamic Host Configuration Protocol。

giaddr :ゲートウェイ IP アドレス。DHCP メッセージの giaddr フィールドは、DHCP サーバに、クライアントが常駐する IP アドレス サブネットの情報を提供します。このフィールドは、DHCP サーバに、応答メッセージが送信される IP アドレスも提供します。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。タグ スイッチングが基礎を置いている新しい産業標準。

VPN :Virtual Private Network(バーチャル プライベート ネットワーク)。トンネリングを使用して、IP トラフィックがパブリック TCP/IP ネットワーク経由でセキュアに転送できるようにします。

VRF :VPN Routing and Forwarding(VPN ルーティング/転送)インスタンス。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトが定義されたルーティング情報が格納されています。PE ルータでインスタンス化された各 VPN には固有の VRF があります。

クライアント :DHCP または BOOTP プロトコルを使用して自身のインターフェイスを設定(IP アドレスを取得)しようとしているホスト。

サーバ :DHCP または BOOTP サーバ。

リレー エージェント :異なるサブネット上のサーバとクライアント間で DHCP メッセージおよび BOOTP メッセージを転送するルータ。