Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド
エッジセッション管理用 DHCP 機能拡張の 設定
エッジセッション管理用 DHCP 機能拡張の設定
発行日;2012/02/04 | 英語版ドキュメント(2011/07/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

エッジセッション管理用 DHCP 機能拡張の設定

この章の構成

エッジセッション管理用 DHCP 機能拡張について

DHCP サーバとリレー エージェント

オンデマンド アドレス プール管理

エッジセッション管理機能の DHCP 機能拡張の設計

SG と共存する DHCP サーバ

SG と共存する DHCP リレー エージェント

エッジセッション管理用 DHCP 機能拡張の利点

エッジセッション管理用 DHCP 機能拡張の設定方法

DHCP アドレス プールおよびクラス名の設定

前提条件

リレー ソースと宛先によるリレー プールの設定

制約事項

リモート DHCP サーバ用リレー プールの設定

制約事項

他タイプのリレー プールの設定

アドレス プールのリレー情報の設定

リレー プールの複数のリレー ソースの設定

エッジセッション管理用 DHCP 機能拡張の設定例

DHCP アドレス範囲およびクラス名設定:例

SG 設定と共存する DHCP サーバ:例

SG 設定と共存する DHCP リレー エージェント:例

複数の DHCP プールおよび別の ISP 設定:例

複数のリレー ソースおよび宛先の設定:例

SG 提供のクラス名設定:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

エッジセッション管理用 DHCP 機能拡張の機能情報

エッジセッション管理用 DHCP 機能拡張の設定

エッジセッション管理機能の DHCP 機能拡張は、1 つのネットワーク インフラストラクチャを使用しているお客様に複数の Internet Service Provider(ISP; インターネット サービス プロバイダー)による同時サービスを提供します。エンドユーザのお客様は随時、ISP を変更することができます。

DHCP 機能拡張は、Service Gateway(SG; サービス ゲートウェイ)の要件として、クライアントの DISCOVER パケット(セッション開始)の受信時刻、クライアントにアドレスが割り当てられた時刻、クライアントが DHCP リースをリリースした時刻、またはリースが期限切れになった時刻(セッション終了)に関する情報を DHCP サーバから受信する必要があることから発展しました。

変更履歴

このマニュアルの初版の発行は 2005/03/29 で、最終更新日は 2007/12/31 です。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用の Cisco IOS ソフトウェア リリースに対応したリリース ノートを参照してください。 この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「エッジセッション管理用 DHCP 機能拡張の機能情報」を参照してください。

プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージのサポート情報の入手方法

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

エッジセッション管理用 DHCP 機能拡張について

エッジセッション管理機能の DHCP の拡張機能を設定するには、次の概念を理解しておく必要があります。

「DHCP サーバとリレー エージェント」

「オンデマンド アドレス プール管理」

「エッジセッション管理機能の DHCP 機能拡張の設計」

「エッジセッション管理用 DHCP 機能拡張の利点」

DHCP サーバとリレー エージェント

DHCP は、TCP/IP ネットワークのホストに構成情報をダイナミックに渡すフレームワークを提供します。DHCP クライアントは、IP アドレスなどのコンフィギュレーション パラメータを取得するために DHCP を使用するインターネット ホストです。

DHCP リレー エージェントとは、クライアントとサーバ間で DHCP パケットを転送する任意のホストです。リレー エージェントは、クライアントとサーバが同じ物理サブネット上にない場合に、その間で要求と応答を転送するために使用されます。リレー エージェントによる転送は、IP ルータによる通常の転送とは異なります。IP ルータによる転送では、IP データグラムがネットワーク間である程度透過的にスイッチングされます。一方、リレー エージェントは DHCP メッセージを受信すると、新しい DHCP メッセージを生成し、別のインターフェイスに送信します。

詳細については、『Cisco IOS IP Addressing Services Configuration Guide, Release 12.4』の「DHCP」 モジュールを参照してください。

オンデマンド アドレス プール管理

On-Demand Address Pool(ODAP; オンデマンド アドレス プール)は、大量のアドレスを集中して管理し、大規模ネットワークの設定を簡素化するために使用されます。ODAP は、IP アドレスを割り当てるための中央管理ポイントを提供します。

Cisco ルータが ODAP マネージャとして設定されているとき、IP アドレス プールの大きさは、アドレスの利用レベルによって増減します。ODAP マネージャは、集中化された Remote Authentication Dial-In User Service(RADIUS)または DHCP サーバのサポートを受け、RADIUS または DHCP サーバのいずれかに最初のアドレス プールを要求するように設定されます。

ODAP マネージャは IP アドレスの割り当てを制御し、必要に応じて追加の IP アドレスを割り当てます。この方法でアドレス割り当てや割り付けを行うと、利用可能なアドレス空間を最適化し、中規模から大規模ネットワークの設定を簡略化することができます。

詳細については、「DHCP サーバ オンデマンド アドレス プール マネージャの設定」モジュールを参照してください。

エッジセッション管理機能の DHCP 機能拡張の設計

エッジセッション管理用 DHCP 機能拡張では、DHCP サーバとリレー エージェントは分離していますが、密接に結合されています。この機能の基本設計は、ISP ネットワークのエッジで、次のような 2 種類の設定を含んでいます。

(同一デバイスに)共存する DHCP サーバおよび SG

共存する DHCP リレー エージェントおよび SG

SG と共存する DHCP サーバ

この設定では、DHCP サーバは SG と同一デバイスにあり、ローカルに設定されたアドレス プールからアドレスを割り当てるか、割り当てるアドレスのサブネットをネットワーク上の他のシステムから取得します。この設定をサポートするために、サーバ アドレス割り付け機能に変更はありません。

この設定で、DHCP サーバは、エンドユーザ DHCP クライアントから送信されたブロードキャストを受信したことを SG に通知することが可能になります。SG は MAC アドレスおよびその他の情報を DHCP サーバに渡します。SG はクラス名(たとえば、ISP の名前)も渡します。クラス名は、DHCP サーバがプールクラス定義と一致させるのに使用されます。

リース ステート通知は常に DHCP サーバから SG に行われます。それは、情報がすでにあるからです。


) ローカル設定は、アドレス プール用のサブネットを他の DHCP サーバまたは RADIUS サーバから取得した ODAP により実行されることもあります。


SG と共存する DHCP リレー エージェント

この設定では、リレー エージェントは SG と同じデバイスにあり、DHCP セッションでは、DHCP クライアントに対する DHCP サーバとして関係を調整します。サーバとして、DHCP セッションに関するすべてのイベント(リース終了など)を SG に通知するために十分な情報をリレー エージェントが持っている場合もあります。

DHCP サーバらしさは、アンナンバード インターフェイスで現在使用されている DHCP 機能を使用するときに表れます。この機能により、リレー エージェントが自身の IP アドレスをサーバに置換することが可能になります。

パケットは、リレー エージェントから DHCP サーバに渡され、SG は受信したことを通知します。通知に続き、リレー エージェントから SG に、使用する DHCP クラス名についての照会が行われます。次に、パケットはリレー エージェントにより、選択された DHCP サーバに渡されます。

エンドユーザ DHCP クライアントの MAC アドレスおよび他の関連情報は SG に渡されます。DHCP プールの照合に使用するため、SG は DHCP クラス名を返します(SG がそのように設定されている場合)。DHCP リレー エージェントがサーバとして動作していない場合は、パケットを DHCP サーバに渡します。


) アドレス プールには、リレー エージェントがパケットを渡す 1 つの集中 DHCP サーバを指定するために定義された 1 つの DHCP クラスを持つか、各クライアントに対して異なる DHCP サーバを指定するために定義された複数の DHCP クラスを持つことができます。


エッジセッション管理用 DHCP 機能拡張の利点

エッジセッション管理用 DHCP 機能拡張の利点は次のとおりです。

本格的な DHCP サーバ システムをネットワーク内の深部に置き、エッジでは相対的にシンプルな DHCP エージェントを実行するだけにとどめることができます。

エッジでの DHCP 設定を簡素化します。

DHCP サーバすべての管理を 1 台の集中 DHCP サーバによりネットワークの中央近くで行うか、または別々の DHCP サーバ(ISP ごとに 1 台)で行うことを可能にします。

各 ISP が DHCP オプションすべてとリース期間に対して完全な制御を行えるようにします。

DHCP サーバおよびクライアントの両方の設定を同一のエッジ システムで同時に使用可能にします。

エッジセッション管理用 DHCP 機能拡張の設定方法

ここでは、次の各手順について説明します。

「DHCP アドレス プールおよびクラス名の設定」(任意)

「リレー ソースと宛先によるリレー プールの設定」(必須)

「リモート DHCP サーバ用リレー プールの設定」(必須)

「他タイプのリレー プールの設定」(任意)

DHCP アドレス プールおよびクラス名の設定

特定のクラス名用アドレス プールからアドレスを割り当てる DHCP サーバを設定するには、この作業を実行してください。このクラス名は、エッジの DHCP サーバに共存する SG によって割り当てられたものです。

DHCP サーバが SG として同一デバイスに常駐し、両方がエッジにある場合、クラス名とアドレス プールが設定される必要があります。この場合、DHCP サーバはクライアントから受信した DISCOVER ブロードキャストを SG に通知し、SG はクラス名を返します。返されたクラス名によりアドレス プールのアドレス範囲が指定されます。DHCP サーバは、MAC アドレスと着信インターフェイスの IP アドレスまたは指定されたリレー エージェントのアドレスを SG に送信します。


) DHCP サーバがローカルに定義されたアドレス プールを持っている場合、または ODAP を使用して ISP DHCP サーバまたは AAA サーバからサブネットを取得する場合、SG の代わりに追加の DHCP サーバを設定する必要はありません。


ODAP を使用してアドレス プールのダイナミック割り当てが必要な場合、 origin コマンドが指定されます。

前提条件

各 DHCP クライアントのクラス名を指定するためには、DHCP アドレス プール設定および SG システム自身の中でクラス名を指定することが必要です。ユーザにクラス名がなかった場合、デフォルトのクラス名を設定する必要があります。

各アドレス プールには、1 つ以上の DHCP クラス(アドレスプロバイダー ISP)が関連づけられる必要があります。DHCP クライアントが ISP を選択すると、選択されたものが SG で指定されたクラス名になります。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. origin { dhcp | file url }

5. network network-number [ mask | prefix-length ]

6. class class-name

7. address range start-ip end-ip

8. ステップ 3、5、6 を繰り返します。

9. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、シンボリックなストリング(engineering など)または整数(0 など)です。

ステップ 4

origin { dhcp | file url }

 

Router(dhcp-config)# origin dhcp

(任意)アドレス プールをオンデマンド アドレス プール(ODAP)またはスタティック マッピング プールとして設定します。引数およびキーワードは次のとおりです。

ステップ 5

network network-number [ mask | prefix-length ]

 

Router(dhcp-config)# network 10.10.0.0 255.255.0.0

Cisco IOS DHCP サーバの DHCP アドレス プール用のサブネット番号とマスクを設定します。引数は次のとおりです。

network-number :DHCP アドレス プールの IP アドレス この引数は、IP アドレス割り当て方法が ODAP でない場合に使用します。

mask :(任意)DHCP アドレス プールのアドレスのどの部分がネットワークまたはサブネットを指し、どの部分がホストを指しているのかを表すビットの組み合わせです。

prefix-length :(任意)アドレスのプレフィクスを構成するビット数。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法の 1 つです。プレフィクスの長さ指定の前にスラッシュ(/)を付ける必要があります。

ステップ 6

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プールクラス コンフィギュレーション モードに入ります。 class-name 引数には、クラス名を指定します。クラス名は、DHCP アドレス プールの名前と一致する必要があります。

SG で必要な場合、このステップを繰り返してデフォルトのクラス名を指定します。

ステップ 7

address range start-ip end-ip

 

Router(config-dhcp-pool-class)# address range 10.10.5.0 10.99.99.99

(任意)DHCP サーバが IP アドレスを割り当てる IP アドレスの範囲を設定します。設定されていない IP アドレスを SG が返した場合、何も起こりません。

この作業を実行することで、前の手順で指定したクラス名の範囲からアドレスを割り当てることができるようになります。

コマンドでアドレスを指定します。

ステップ 8

ステップ 3、5、6 を繰り返します。

複数のサブネットおよび異なる ISP で設定されたインターフェイスがある場合、サブネット番号が一致するようにこの手順を繰り返します。「複数の DHCP プールおよび別の ISP 設定:例」を参照してください。

ステップ 9

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーションモードに戻ります。

リレー ソースと宛先によるリレー プールの設定

エッジの同じデバイスに DHCP リレーと SG が常駐しているとき、この作業を実行してリレー プールを設定すると、すべてのエンド ユーザが 1 つのプールからアドレスを取得します。この作業は、IP ヘルパーアドレスのインターフェイス コンフィギュレーションに置き換わります。

特定の DHCP クライアントには DHCP セッション通知が必要なことを SG がリレー エージェントに知らせると、リレー エージェントは、SG に(リース終了など)すべてのイベントを通知するために、DHCP セッションに関する十分な情報を保持します。リレーは DHCP セッション間を取り持ち、DHCP サーバの役割を引き受けます。DHCP クライアント情報および SG デバイス ポリシー情報に次第で、IP アドレス設定はダイナミックに変化する値になります。

制約事項

リレー エージェントが DHCP セッション間の仲介をしており、DHCP サーバの役割を引き受けている場合、DHCP 認証は使用できません。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. update arp

5. relay source ip-address subnet-mask

6. relay destination [ vrf vrf-name | global ] ip-address

7. accounting method-list-name

8. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、シンボリックなストリング(engineering など)または整数(0 など)です。複数の名前を設定することが可能です。

ステップ 4

update arp

 

Router(dhcp-config)# update arp

(任意)対応する DHCP バインディングへ、セキュアでダイナミックな Address Resolution Protocol(ARP)テーブルの ARP エントリを設定します。

(注) システムがアドレス プールからアドレスを割り当てる場合、セキュアな ARP が追加されます。アドレス プールを使用してシステムがパケットをリレーする場合、セキュアな ARP も追加されます。

ステップ 5

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address および subnet-mask 引数はそれぞれ、リレー ソースの IP アドレスおよびサブネット マスクです。

コマンドに類似しています。その理由は、アドレス プールの利用が、IP アドレスおよびマスクの設定がリレー ソースの設定と一致するインターフェイスに着信するパケットに制限されるからです。

ステップ 6

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアントのパケットが送信されるリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー先の IP アドレスに関連付けられた VRF の名前です。

global :(任意)グローバル IP アドレス。このキーワードは、リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合に使用します。

ip-address :リレー先の IP アドレス。

キーワードを指定する必要があります。

ステップ 7

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定されたサーバ グループが RADIUS アカウンティングを実行するように設定されている場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングが作動する前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定されている場合、DHCP アカウンティングの START および STOP メッセージを送信するように設定します。STOP メッセージが送信されるのは、RADIUS-GROUP1 が stop-only グループとして設定された場合だけです。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ目的での DHCP サービスの設定」モジュールを参照してください。

ステップ 8

exit

 

Router(dhcp-config)# exit

グローバル コンフィギュレーション モードに戻ります。

リモート DHCP サーバ用リレー プールの設定

設定されたリレー プールでリモート DHCP サーバを選択するとき、SG 提供のクラス名を使用するには、この作業を実行します。設定されたリレー プールは、DHCP クライアント パケットがどのようにリレーされる必要があるかを指定するために使用されます。プールクラスの定義に複数のリレー ターゲットの設定が表示されることがあります。その場合、すべてのアドレスがリレー目的で使用されます。

制約事項

relay source コマンドは、 network コマンドまたは origin コマンドと併用できません。その理由は、これらのコマンドは暗黙のうちに着信インターフェイスを指定し、別のタイプのプールを定義するために使用されるからです。インターフェイス コンフィギュレーション コマンドとしての ip helper-address コマンドと同様の方法で、リレーをインターフェイスにだけ関連付けます。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. relay source ip-address subnet-mask

5. relay destination [ vrf vrf-name | global ] ip-address

6. accounting method-list-name

7. class class-name

8. relay target [ vrf vrf-name | global ] ip-address

9. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、シンボリックなストリング(engineering など)または整数(0 など)です。複数の DHCP アドレス プールを指定することができます。

ステップ 4

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address および subnet-mask 引数はそれぞれ、リレー ソースの IP アドレスおよびサブネット マスクです。

コマンドに類似しています。その理由は、アドレス プールの利用が、IP アドレスおよびマスクの設定がリレー ソースの設定と一致するインターフェイスに着信するパケットに制限されるからです。

ステップ 5

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアントのパケットが送信されるリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー先の IP アドレスに関連付けられた VRF の名前です。

global :(任意)グローバル IP アドレス。このキーワードは、リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合に使用します。

ip-address :リレー先の IP アドレス。

キーワードを指定する必要があります。

ステップ 6

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定されたサーバ グループが RADIUS アカウンティングを実行するように設定されている場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングが作動する前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定されている場合、DHCP アカウンティングの START および STOP メッセージを送信するように設定します。STOP メッセージが送信されるのは、RADIUS-GROUP1 が stop-only グループとして設定された場合だけです。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ目的での DHCP サービスの設定」モジュールを参照してください。

ステップ 7

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プールクラス コンフィギュレーション モードに入ります。 class-name 引数には、クラス名を指定します。複数のクラス名を設定することができます。

ステップ 8

relay target [ vrf vrf-name | global ] ip-address

 

Router(config-dhcp-pool-class)# relay target 10.0.0.0

リレー ターゲットの IP アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー ターゲットの IP アドレスに関連付けられた VRF の名前で、複数のターゲットを指定することができます。

global :(任意)グローバル IP アドレス空間。

ip-address :リレー ターゲットの IP アドレス。複数のターゲット IP アドレスを指定することができます。

コマンドと同様の方法で、リレー機能の宛先を指定します。

キーワードを指定する必要があります。

ステップ 9

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーションモードに戻ります。

他タイプのリレー プールの設定

ここでは、次の各手順について説明します。

「アドレス プールのリレー情報の設定」(必須)

「リレー プールの複数のリレー ソースの設定」(必須)

アドレス プールのリレー情報の設定

アドレス プールにリレー情報を設定するには、この作業を実行します。この設定で SG は、結果として DISCOVER パケットになるクラス名を送信します。DISCOVER パケットは、 relay target コマンドを使用して設定された IP アドレスのサーバにリレーされます。アドレス プールに関連付けられるように設定されていないクラス名を SG が送信する場合、何も起こりません。

制約事項

1 つのプールクラス定義で address range コマンドと relay target コマンドは指定できません。その理由は、これによって同じパケットにアドレスとリレーを割り当てることになるからです。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. network network-number [ mask | prefix-length ]

5. class class-name

6. relay target [ vrf vrf-name | global ] ip-address

7. exit

8. 設定する必要のある DHCP クラスごとにステップ 5 ~ 7 を繰り返します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、シンボリックなストリング(engineering など)または整数(0 など)です。

ステップ 4

network network-number [ mask | prefix-length ]

 

Router(dhcp-config)# network 10.0.0.0 255.0.0.0

Cisco IOS DHCP サーバの DHCP アドレス プール用のサブネット番号とマスクを設定します。引数は次のとおりです。

network-number :DHCP アドレス プールの IP アドレス

mask :(任意)DHCP アドレス プールのアドレスのどの部分がネットワークまたはサブネットを指し、どの部分がホストを指しているのかを表すビットの組み合わせです。

prefix-length :(任意)アドレスのプレフィクスを構成するビット数。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法の 1 つです。プレフィクスの長さ指定の前にスラッシュ(/)を付ける必要があります。

ステップ 5

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プールクラス コンフィギュレーション モードに入ります。 class-name 引数には、クラス名を指定します。複数のクラス名を設定することが可能です。

(注) DHCP プールのクラス名にリレー ターゲットまたはアドレス範囲が設定されない場合、クラスとしてデフォルトで DHCP プール設定が使用されます。

ステップ 6

relay target [ vrf vrf-name | global ] ip-address

 

Router(config-dhcp-pool-class)# relay target 10.0.0.0

リレー ターゲットの IP アドレスを設定します。 relay target コマンドの引数とキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー ターゲットの IP アドレスに関連付けられた VRF の名前で、複数のターゲットを指定することができます。

global :(任意)グローバル IP アドレス空間。

ip-address :リレー ターゲットの IP アドレス。複数のターゲット IP アドレスを指定することができます。

キーワードを指定する必要があります。

ステップ 7

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーションモードに戻ります。

ステップ 8

設定する必要のある DHCP クラスごとにステップ 5 ~ 7 を繰り返します。

--

リレー プールの複数のリレー ソースの設定

リレー プールに複数のリレー ソースを設定するには、この作業を実行します。設定は、複数インターフェイスで IP ヘルパーアドレスを設定するのと類似しています。プールは、着信インターフェイスの IP アドレスに一致します。その際の順序は、 show running-config コマンドが使用された時にインターフェイスが表示する順序です。リレーが見つかるか、アドレス割り当てが見つかると、検索は中止されます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask [secondary]

5. exit

6. ip dhcp pool name

7. relay source ip-address subnet-mask

8. relay destination [ vrf vrf-name | global ] ip-address

9. accounting method-list-name

10. 設定された DHCP プールごとにステップ 6 および 7 を繰り返します。

11. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。引数は次のとおりです。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.0.0.0 255.0.0.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool1

DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、シンボリックなストリング(engineering など)または整数(0 など)です。複数のプールを割り当てることができます。

ステップ 7

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address および subnet-mask 引数はそれぞれ、リレー ソースの IP アドレスおよびサブネット マスクです。

コマンドに類似しています。その理由は、アドレス プールの利用が、IP アドレスおよびマスクの設定がリレー ソースの設定と一致するインターフェイスに着信するパケットに制限されるからです。

ステップ 8

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアントのパケットが送信されるリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー先の IP アドレスに関連付けられた VRF の名前です。

global :(任意)グローバル IP アドレス。このキーワードは、リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合に使用します。

ip-address :リレー先の IP アドレス。

キーワードを指定する必要があります。

ステップ 9

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定されたサーバ グループが RADIUS アカウンティングを実行するように設定されている場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングが作動する前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定されている場合、DHCP アカウンティングの START および STOP メッセージを送信するように設定します。STOP メッセージが送信されるのは、RADIUS-GROUP1 が stop-only グループとして設定された場合だけです。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ目的での DHCP サービスの設定」モジュールを参照してください。

ステップ 10

設定された DHCP プールごとにステップ 6 および 7 を繰り返します。

--

ステップ 11

exit

 

Router(dhcp-config)# exit

グローバル コンフィギュレーション モードに戻ります。

エッジセッション管理用 DHCP 機能拡張の設定例

ここでは、次の設定例について説明します。

「DHCP アドレス範囲およびクラス名設定:例」

「SG 設定と共存する DHCP サーバ:例」

「SG 設定と共存する DHCP リレー エージェント:例」

「複数の DHCP プールおよび別の ISP 設定:例」

「複数のリレー ソースおよび宛先の設定:例」

「SG 提供のクラス名設定:例」

DHCP アドレス範囲およびクラス名設定:例

次の例では、特定のネットワークのアドレス範囲および DHCP プールのクラス名の設定方法を示します。

ip dhcp pool abc-pool
network 10.10.0.0 255.255.0.0
class abc-pool
address range 10.10.5.0 10.10.5.99

SG 設定と共存する DHCP サーバ:例

次の例では、ISP は ABC 会社と DEF 会社です。ABC 会社には、ODAP を使用してダイナミックに割り当てられたアドレス プールから割り当てられたアドレスがあります。DEF 会社には、10.100.0.0/16 のアドレス プールから割り当てられたカスタマー アドレスがあります。どの ISP にも関連づけられていないお客様には、アドレス プール 10.1.0.0/16 から割り当てられたアドレスが与えられ、リース期間が 10 分に設定されます。

!Interface configuration
 
interface ethernet1
ip address 10.20.0.1. 255.255.0.0
ip address 10.1.0.1 255.255.0.0 secondary
ip address 10.100.0.1 255.255.0.0 secondary
 
!Address pool for ABC customers
 
ip dhcp pool abc-pool
network 20.1.0.0 255.255.0.0
class abc
!
!Address pool for DEF customers
 
ip dhcp pool def-pool
network 10.100.0.0 255.255.0.0
class def
 
!Address pool for customers without an ISP
 
ip dhcp pool temp
network 10.1.0.0 255.255.0.0
lease 0 0 10
class default

SG 設定と共存する DHCP リレー エージェント:例

次の例では、abcpool および defpool の 2 つの ISP があります。abcpool の ISP およびそのお客様は、10.1.0.0/16 ~ 30.1.0.0/16 の範囲のアドレスを持つことが可能で、10.55.10.1 のアドレスの DHCP サーバにリレーされます。defpool の ISP およびそのお客様は、20.1.0.0/16 ~ 40.4.0.0/16 の範囲のアドレスを持つことが可能で、12.10.2.1 のアドレスの DHCP サーバにリレーされます。

!Address ranges:
 
interface ethernet1
ip address 10.1.0.0 255.255.0.0
ip address 10.2.0.0 255.255.0.0 secondary
 
interface ethernet2
ip address 10.3.0.0 255.255.0.0
ip address 10.4.0.0 255.255.0.0 secondary
 
!Address pools for abcpool1 and abcpool2:
 
ip dhcp pool abcpool1
relay source 10.1.0.0 255.255.0.0
class abcpool
relay target 10.5.10.1
 
!Address pool for abcpool2:
 
ip dhcp pool abcpool2
relay source 10.1.0.0 255.255.0.0
class abcpool
relay target 10.55.10.1
 
!Address pools for defpool1 and defpool2:
 
ip dhcp pool defpool1
relay source 10.1.0.0 255.255.0.0
class defpool
relay target 10.10.2.1
 
ip dhcp pool defpool2
relay source 10.4.0.0 255.255.0.0
class defpool
relay target 10.10.2.1

複数の DHCP プールおよび別の ISP 設定:例

次の例では、 network コマンドを使用して、1 つのインターフェイスと、異なる ISP を持つ複数の DHCP プールを設定する方法を示します。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.1.0.1 255.0.0.0
!
ip dhcp pool x
network 10.0.0.0 255.0.0.0
class ISP1
!
ip dhcp pool y
network 10.1.0.0 255.0.0.0
class ISP2

複数のリレー ソースおよび宛先の設定:例

次の例では、リレー プールに複数のリレー ソースと宛先を設定することができます。これは、複数インターフェイスのヘルパーアドレス設定に類似しています。プールは、着信インターフェイスの(場合によっては複数の)IP アドレスに一致します。その際の順序は、 show running-config コマンドが使用された時にインターフェイスが表示する順序です。リレーまたはアドレス割り当てのいずれかが見つかると、検索は中止されます。たとえば、次の設定があるとします。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.0.0.5 255.0.0.0 secondary
 
ip dhcp pool x
relay source 10.0.0.0 255.0.0.0
relay destination 10.0.0.1
 
ip dhcp pool y
relay source 10.0.0.0 255.0.0.0
relay destination 10.0.0.1
 

次の例で、DHCP クライアント パケットは、SG が ISP1 をクラス名として指定した場合は 10.0.0.1 にリレーされ、SG が ISP2 をクラス名として指定した場合は 10.0.0.5 にリレーされます。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.0.0.5 255.0.0.0 secondary
 
ip dhcp pool x
relay source 10.0.0.0 255.0.0.0
relay destination 10.2.0.0 255.0.0.0
class ISP1
relay target 10.0.0.1
class ISP2
relay target 10.0.0.5

SG 提供のクラス名設定:例

次の例では、SG が提供するクラス名が、パケットのリレー先のリモート DHCP サーバを選択するために使用されます。

ip dhcp pool abc-pool-1
relay source 10.1.0.0 255.255.0.0
relay destination 10.1.0.0
class classname1
relay target 10.20.10.1
class classname2
relay target 10.0.10.1
class classname3
 

上の例では、SG が提供するクラス名(classname1 と呼ぶ)は、DHCP DISCOVER パケットを、リレー ターゲット IP アドレス 10.20.10.1 のサーバにリレーし、SG classname2 は DHCP DISCOVER パケットをリレー ターゲット IP アドレス 10.0.10.1 のサーバにリレーします。この設定でパケットを宛先 IP アドレス 10.0.0.1 にリレーするのは、プールがインターフェイスの最初の設定アドレスに一致するからです。SG が classname3 を返す場合、デフォルト プールは、リレー先として指定されたデフォルトのアドレスです。SG が classname1、classname2、classname3 以外のクラス名を返す場合、リレー アクションは起こりません。

その他の関連資料

ここでは、エッジセッション VPN の DHCP 設定に関連する参考資料を示します。

関連資料

関連項目
参照先

DHCP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

Cisco IOS IP Addressing Services Command Reference

DHCP の概念的な説明

DHCP Overview 」モジュール

DHCP サーバ設定

Configuring the Cisco IOS DHCP Server 」モジュール

DHCP クライアントの設定

Configuring the Cisco IOS DHCP Client 」モジュール

DHCP リレー エージェントの設定

Configuring the Cisco IOS DHCP Relay Agent 」モジュール

DHCP サーバ オンデマンド アドレス プール マネージャの設定

Configuring the DHCP Server On-Demand Address Pool Manager 」モジュール

DHCP の拡張機能

Configuring DHCP Services for Accounting and Security 」モジュール

DHCP オプション

Network Registrar User's Guide , Release 6.1.1』の付録「DHCP Options」

規格

規格
タイトル

この機能によってサポートされる新しい規格や変更された規格はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 951

Bootstrap Protocol (BOOTP)

RFC 1542

Clarifications and Extensions for the Bootstrap Protocol

RFC 2131

Dynamic Host Configuration Protocol

RFC 2685

Virtual Private Networks Identifier

RFC 3046

DHCP Relay Information Option

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト(http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

エッジセッション管理用 DHCP 機能拡張の機能情報

表 1 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ここに記載されていないこのテクノロジーの機能情報については、「 DHCP Features Roadmap 」を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 エッジセッション管理用 DHCP 機能拡張の機能情報

機能名
リリース
機能設定情報

DHCP リレー アカウンティング

12.4(6)T

クライアントにアドレスが割り当てられたときに Cisco IOS DHCP リレー エージェントが RADIUS アカウンティング開始パケットを送り、アドレスがリリースされたときに RADIUS アカウンティング終了パケットを送ることが、DHCP リレー アカウンティング機能によって可能になります。この機能は、DHCP プール コンフィギュレーション モードで、 relay destination コマンドを使用するリレー プールで accounting コマンドを使用することで可能になります。

この機能に関する詳細については、次の各項を参照してください。

リレー ソースと宛先によるリレー プールの設定

リモート DHCP サーバ用リレー プールの設定

この機能では、新規コマンドはありません。

エッジセッション管理用 DHCP 機能拡張

12.3(14)T

12.2(28)SB

12.2(33)SRC

エッジセッション管理機能の DHCP 機能拡張は、1 つのネットワーク インフラストラクチャを使用しているお客様に複数の ISP による同時サービスを提供します。エンドユーザのお客様は随時、ISP を変更することができます。

本モジュールのどの項にもこの機能の説明があります。

この機能では、次のコマンドが追加されました。 relay destination relay source 、および relay target