Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド
Cisco IOS DHCP クライアントの設定
Cisco IOS DHCP クライアントの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/07/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

Cisco IOS DHCP クライアントの設定

機能情報の入手方法

この章の構成

DHCP クライアントの設定の制約事項

DHCP クライアントについて

DHCP クライアントの動作

DHCP クライアントの概要

WAN インターフェイス上の DHCP クライアント

DHCP FORCERENEW

DHCP クライアントの設定方法

DHCP クライアントの設定

DHCP クライアントのデフォルト動作

前提条件

トラブルシューティングのヒント

DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新

DHCP リリースおよび更新の CLI 操作

前提条件

制約事項

FORCERENEW メッセージ処理のイネーブル化

前提条件

DHCP クライアントの設定例

DHCP クライアントの設定:例

DHCP クライアントの設定のカスタマイズ:例

aal5snap カプセル化および Inverse ARP を使用した ATM プライマリ インターフェイス(マルチポイント)の設定:例

aa15snap カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

aa15nlpid カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

aa15mux PPP カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

DHCP リースのリリース:例

DHCP リースの更新:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

DHCP クライアントの機能情報

Cisco IOS DHCP クライアントの設定

Cisco IOS Dynamic Host Configuration Protocol(DHCP)クライアント ソフトウェアは、DHCP クライアントにさまざまな設定オプションを組み込むための柔軟性を備えています。DHCP クライアントは、IP アドレスなどのコンフィギュレーション パラメータの取得に DHCP を使用しているインターネットのホストとして定義されます。このモジュールでは、Cisco IOS DHCP クライアントを設定するために必要な概念と作業について説明します。また、エンティティ認証およびメッセージ認証を提供する、Cisco DHCP FORCERENEW 機能についても説明します。

機能情報の入手方法

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「DHCP クライアントの機能情報」 を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、Cisco Catalyst OS ソフトウェア イメージ、および Cisco IOS XE ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

DHCP クライアントの設定の制約事項

DHCP クライアントは、イーサネット インターフェイス、PPP over ATM(PPPoA)、および一部の ATM インターフェイス上で設定できます。DHCP クライアントは ATM ポイントツーポイント インターフェイスと一緒に動作し、任意のカプセル化タイプを受け入れます。ATM マルチポイント インターフェイスの場合、DHCP クライアントは、Inverse Address Resolution Protocol(ARP; アドレス解決プロトコル)と組み合わせて aal5snap カプセル化タイプを使用するときだけサポートされます。Inverse ARP は、ATM マップ エントリを構築し、接続の別の端にあるサーバ(またはリレー エージェント)にユニキャスト パケットを送信するために必要です。Inverse ARP は aal5snap カプセル化タイプに限りサポートされます。

マルチポイント インターフェイスの場合、ブロードキャスト パケットが使用されるため、他のカプセル化タイプを使用して IP アドレスを取得できます。ただし、相手側の端末へのユニキャスト パケットは、ATM マップ エントリが存在しないため失敗し、したがって DHCP の更新およびリリースにも失敗します。

DHCP クライアントについて

DHCP クライアントを設定するには、次の概念を理解しておく必要があります。

「DHCP クライアントの動作」

「DHCP クライアントの概要」

「WAN インターフェイス上の DHCP クライアント」

「DHCP FORCERENEW」

DHCP クライアントの動作

DHCP は、TCP/IP ネットワーク上のホストに設定情報を渡すためのフレームワークを提供します。DHCP クライアントは、IP アドレスなどのコンフィギュレーション パラメータを取得するために DHCP を使用するインターネット ホストです。図 1 に、DHCP クライアントが DHCP サーバに IP アドレスを要求したときに発生する基本手順を示します。クライアントであるホスト A は、DHCPDISCOVER ブロードキャスト メッセージを送信して、DHCP サーバを見つけます。DHCP サーバは DHCPOFFER ユニキャスト メッセージにより、(IP アドレス、MAC アドレス、ドメイン名、IP アドレスのリースなどの)コンフィギュレーション パラメータをクライアントに提供します。

図 1 DHCP サーバからの IP アドレスの DHCP 要求

 

DHCP クライアントは複数の DHCP サーバから応答を受信し、任意の応答を 1 つ受け入れることができますが、通常クライアントは受信した最初の応答を受け入れます。また、DHCP サーバからの応答があっても、その IP アドレスがそのクライアントに割り当てられることが保証されたわけではありませんが、通常サーバはクライアントから正式なアドレスの要求があるまで、そのアドレスを予約します。

クライアントは、DHCPREQUEST ブロードキャスト メッセージにより、提示された IP アドレスの正式な要求を DHCP サーバに返します。DHCP サーバは DHCPACK ユニキャスト メッセージをクライアントに返すことで、IP アドレスがクライアントに割り当てられたことを確認します。

DHCP クライアントの概要

設定可能な DHCP クライアント機能によって、DHCP サーバにアドレスを要求するとき、DHCP クライアントはユーザ指定のクライアント ID、クラス ID、または推奨されるリース期間を使用できます。

コンフィギュレーション パラメータおよびその他の制御情報は、DHCP メッセージのオプション フィールドに格納される、タグ付けされたデータ項目内で送受信されます。DHCP クライアント機能は、DHCP クライアントに次のオプションを設定できる柔軟性を備えています。

Option 12:このオプションはクライアントの名前を指定します。名前はローカル ドメインで修飾されていてもされていなくてもかまいません。

Option 33:このオプションは、クライアントにスタティック ルートのリストを設定するために使用します。

Option 51:このオプションは、クライアントが IP アドレスのリース期間を要求するために、クライアント要求(DHCPDISCOVER または DHCPREQUEST)内で使用されます。

Option 55:このオプションによって、DHCP クライアントは特定のオプションを DHCP サーバに要求できます。 ip dhcp client request コマンドを使用すると、システム管理者は要求されたオプションの一部をオフにでき、これらのオプションを要求リストから削除できます。

Option 60:このオプションによって、ユーザはベンダー クラス ID ストリングを DHCP インタラクション内で使用するように設定できます。

Option 61:このオプションは、DHCP クライアントが固有 ID を指定するために使用します。DHCP サーバはこの値を使用して、アドレス バインディングのデータベースを索引付けします。この値は、管理ドメイン内のすべてのクライアントについて固有であると想定されています。

Option 120:このオプションは、SIP サーバを見つけるために SIP クライアントによって使用される 32 ビット(2 進数)IPv4 アドレスを指定するために使用されます。

Option 121:このオプションは、クラスレス スタティック ルート内のクラスレス ネットワーク宛先を指定することによって、これらのルートを設定するために使用します。つまり、各ルーティング テーブル エントリにはサブネット マスクが含まれます。


) 要求がスタティック ルートとクラスレス スタティック ルートの両方を含む場合、クライアントはクラスレス スタティック ルートだけを使用します。
DHCP サーバがクラスレス スタティック ルート オプションとルータ オプションの両方を返す場合、DHCP クライアントはルータ オプションを無視します。


Option 125:このオプションは、DHCP クライアントとサーバがベンダー固有情報を交換するために使用します。

WAN インターフェイス上の DHCP クライアント

WAN インターフェイス上の DHCP クライアントを使用すると、DHCP クライアントは PPP over ATM(PPPoA)および一部の ATM インターフェイス上で IP アドレスを取得できます。Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)の代わりに DHCP を使用することで、DHCP クライアントは DNS アドレス、DNS デフォルト ドメイン名、およびデフォルト ルートなどの他の役立つ情報を取得できます。

PPPoA および Classical IP および ARP over ATM の設定によって、インターフェイス上でのブロードキャスト機能は、(ATM インターフェイス上で broadcast キーワードを使用して)すでに可能になっています この機能では、DHCP パケットを送信できるインターフェイスのタイプに関する既存の制約事項を取り除くことに、機能の変更の大半が振り向けられました(以前は、ダイヤラ インターフェイスは許可されていませんでした)。またこの機能により、DHCP RELEASE メッセージがインターフェイスに送信されてから、接続の切断が許可されるようになります。

DHCP FORCERENEW

Cisco DHCP FORCERENEW 機能では、RFC 3118 に従って、エンティティ認証およびメッセージ認証が提供されます。この機能によって、DHCP クライアントと DHCP サーバは、他の DHCP エンティティの ID を認証し、DHCP メッセージの内容が、ネットワークを通過して配信される間に変更されていないことを確認します。

メッセージ認証メカニズムでは、DHCP 情報の要求が、ネットワークの使用を許可されたクライアントからのものであるかどうかをサーバが判断できます。また、有効な設定を提供する DHCP サーバが信頼できることをクライアントが確認できます。

Cisco DHCP FORCERENEW 機能では認証が必要です。クライアントとサーバ間でのすべてのメッセージ交換は認証が必要です。 ip dhcp client authentication mode および key chain コマンドを設定する必要があります。

クライアントが FORCERENEW メッセージを取得すると、次のことが実行されます。

ip dhcp client authentication mode コマンドで指定される認証モードに従ってメッセージが認証されます。Cisco DHCP FORCERENEW 機能では、トークンベース認証と MD5 ベース認証の両方がサポートされます。

トークンベース認証は、間違ってインスタンス化された DHCP サーバに対する基礎的な保護に限り役立ちます。トークンはプレーン テキストで送信されるため、トークンの認証は弱く、メッセージ認証は提供されません。

MD5 ベース認証では、メッセージ認証コードとして発信元によって生成される使い捨ての値が含まれているため、メッセージ認証およびエンティティ認証の機能が向上します。

ステートが RENEW に変更されます。

通常の DHCP 手順に従ってリースを更新しようとします。

クライアントはマルチキャスト FORCERENEW メッセージや、認証に失敗したメッセージを廃棄します。

DHCP クライアントの設定方法

ここでは、次の作業について説明します。

「DHCP クライアントの設定」

「DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新」

「FORCERENEW メッセージ処理のイネーブル化」

DHCP クライアントの設定

DHCP クライアントを設定するには、次の作業を実行します。

DHCP クライアントのデフォルト動作

Cisco IOS ソフトウェアを実行する Cisco ルータには DHCP サーバおよびリレー エージェント ソフトウェアが含まれており、これらはデフォルトでイネーブルになっています。ルータは DHCP クライアントおよび DHCP サーバの両方として機能できます。設定されたインターフェイスの IP アドレス情報を取得するには、 ip address dhcp インターフェイス コマンドを使用します。

前提条件

生成される DHCPDISCOVER メッセージに正しいオプション値が含まれるようにするため、 ip dhcp client コマンドを設定してから ip address dhcp コマンドをインターフェイス上で入力する必要があります。 ip dhcp client コマンドは、DHCP から IP アドレスが取得されるときだけチェックされます。DHCP から IP アドレスを取得した後に ip dhcp client などのコマンドが入力された場合、そのコマンドは、ルータが次回 DHCP から IP アドレスを取得するときまで有効になりません。つまり、新しい設定が有効になるのは、 ip address dhcp コマンドまたは release dhcp および renew dhcp EXEC コマンドが設定された後になります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip dhcp client client-id { interface-name | ascii string | hex string }

5. ip dhcp client class-id { string | hex string }

6. ip dhcp client lease days [ hours ] [ minutes ]

7. ip dhcp client hostname host-name

8. [ no ] ip dhcp client request option-name

9. ip address dhcp

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip dhcp client client-id { interface-name | ascii string | hex string }

 

Router(config-if)# ip dhcp client client-id ascii mytest1

(任意)クライアント ID を指定します。

このコマンドの no 形式を指定した場合、設定が削除され、システムはデフォルト形式の使用に戻ります。クライアント ID を含まないシステムの設定はできません。

ステップ 5

ip dhcp client class-id { string | hex string }

 

Router(config-if)# ip dhcp client class-id my-class-id

(任意)クラス ID を指定します。

ステップ 6

ip dhcp client lease days [ hours ] [ minutes ]

 

Router(config-if)# ip dhcp client lease 2

(任意)DHCP クライアントから DHCP サーバに要求される IP アドレスのリース期間を設定します。

ステップ 7

ip dhcp client hostname host-name

 

Router(config-if)# ip dhcp client hostname router1

(任意)DHCP メッセージ内で送信されるホスト名を指定または変更します。

ステップ 8

[ no ] ip dhcp client request option-name

 

Router(config-if)# no ip dhcp client request tftp-server-address

(任意)DHCP サーバからオプションを要求するように DHCP クライアントを設定します。

オプション名は、 tftp-server-address netbios-nameserver vendor-specific static-route domain-name dns-nameserver 、または router が可能です。デフォルトでは、これらすべてのオプションが要求されます。このコマンドの no 形式では、特定のオプションを要求しないようシステムに指示します。

ステップ 9

ip address dhcp

 

Router(config-if)# ip address dhcp

DHCP からインターフェイスの IP アドレスを取得します。

トラブルシューティングのヒント

設定を確認するために、 debug dhcp detail EXEC コマンドを使用して、送受信された DHCP パケットを表示できます。サーバ側の DHCP インタラクションを表示するには、 debug ip dhcp server packets コマンドを使用します。

次に、WAN インターフェイス上の DHCP クライアントについてのトラブルシューティングのヒントを示します。

ATM プライマリ インターフェイスは常にマルチポイントです。

ATM サブインターフェイスはマルチポイントまたはポイントツーポイントにできます。

ポイントツーポイント インターフェイスを使用する場合、いつパケットをインターフェイスに送信するかはルーティング テーブルによって判断されるため、ATM マップ エントリは不要です。このような場合、ATM マップ エントリを構築する Inverse ARP は不要です。

マルチポイント インターフェイスを使用する場合、接続のもう一方の側の IP アドレスを検出するために Inverse ARP を使用する必要があります。

Inverse ARP は protocol ip inarp インターフェイス コンフィギュレーション コマンドによって指定できます。Inverse ARP をサポートするカプセル化タイプは aal5snap だけであるため、Inverse ARP を使用するときはこのカプセル化タイプを使用する必要があります。

DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新

DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新を実行するには、次の作業を実行します。

DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新を行うと、次の 2 つの独立した操作を Command-Line Interface(CLI; コマンドライン インターフェイス)から EXEC モードで実行できます。

DHCP クライアントに対する DHCP リースをただちにリリースします。

DHCP クライアントに対する DHCP リースの更新を強制的に実行します。

この機能には、次の利点があります。

DHCP リースをリリースまたは更新するためにコンフィギュレーション モードに入ってルータを再設定する必要がなくなります。

DHCP リースのリリースおよび更新が簡単になります。

DHCP IP リリースおよび更新の設定作業を実行するために費やす時間が短縮されます。

DHCP リリースおよび更新の CLI 操作

DHCP リースのリリース

release dhcp コマンドによって、指定されたインターフェイスの DHCP リースをただちにリリースするプロセスが開始されます。リースがリリースされると、インターフェイス アドレスは設定解除されます。 release dhcp コマンドによって、インターフェイス用のコンフィギュレーション ファイル内で指定された ip address dhcp コマンドは設定解除されません。write memory または show running configuration file アクションの実行中や、ルータがリブートされるとき、 ip address dhcp コマンドが実行されて、インターフェイスの DHCP アドレスが取得されます。

インターフェイスの元の IP アドレスは DHCP サーバによって割り当てられている必要があります。DHCP サーバによってインターフェイスに IP アドレスが割り当てられていない場合、 release dhcp コマンドは失敗し、次のエラー メッセージが表示されます。

Interface does not have a DHCP originated address

DHCP リースの更新

renew dhcp コマンドによって DHCP リース タイマーは次のステージに進められ、その時点で次のいずれかが発生します。

リースが現在 BOUND ステートの場合、リースは RENEW ステートに進められ、DHCP RENEW 要求が送信されます。

リースが現在 RENEW ステートの場合、リースは REBIND ステートに進められ、DHCP REBIND 要求が送信されます。

RENEW 要求に対して応答がない場合、インターフェイスは RENEW ステートのままになります。この場合、リース タイマーは REBIND ステートに進められ、引き続き REBIND 要求が送信されます。

RENEW 要求の応答として NAK 応答が送信される場合、インターフェイスは設定解除されます。

インターフェイスの元の IP アドレスは DHCP サーバによって割り当てられている必要があります。DHCP サーバによってインターフェイスに IP アドレスが割り当てられていない場合、 renew dhcp コマンドは失敗し、次のエラー メッセージが表示されます。

Interface does not have a DHCP originated address

前提条件

DHCP クライアントは DHCP サーバによって IP アドレスが割り当てられている必要があります。

制約事項

DHCP サーバによって DHCP クライアントに IP アドレスが割り当てられていない場合、DHCP のリリースおよび更新の CLI コマンドは失敗します。

手順の概要

1. enable

2. release dhcp type number

3. renew dhcp type number

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

release dhcp type number

 

Router# release dhcp ethernet 3/1

インターフェイスの DHCP リースをただちにリリースし、インターフェイスの IP アドレスを設定解除します。

ステップ 3

renew dhcp type number

 

Router# renew dhcp ethernet 3/1

DHCP タイマーを次のステージに進め、その時点で後続のアクションが実行されます。つまり、リースの更新または再バインドのために DHCP REQUEST パケットが送信されます。

FORCERENEW メッセージ処理のイネーブル化

インターフェイス上の DHCP メッセージ内で使用する認証のタイプを指定し、要求の認証に使用するキー チェーンを指定し、認証がイネーブルのときに DHCP クライアント上で FORCERENEW メッセージ処理をイネーブルにするには、次の作業を実行します。

前提条件

クライアントとサーバの両方で設定する認証モード、秘密 ID および秘密値は、 key chain コマンドで設定されたものと同じである必要があります。

手順の概要

1. interface type number

2. ip dhcp client authentication key-chain name

3. ip dhcp client authentication mode type

4. exit

5. key chain name-of-chain

6. ip dhcp-client forcerenew

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

interface type number

 

Router(config)# interface Ethernet 1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp client authentication key-chain name

 

Router(config-if)# ip dhcp client authentication key-chain dhcp1

要求を認証するために使用するキー チェーンを指定します。

ステップ 3

ip dhcp client authentication mode type

 

Router(config-if)# ip dhcp client authentication mode md5

インターフェイス上の DHCP メッセージ内で使用する認証のタイプを指定します。

ステップ 4

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 5

key chain name-of-chain

 

Router(config)# key chain dhcp1

key 1234

key-string secret

キー チェーン コンフィギュレーション モードを開始し、名前付きキー チェーンに使用する認証ストリングを識別します。

ステップ 6

ip dhcp-client forcerenew

 

Router(config)# ip dhcp-client forcerenew

DHCP クライアント上の DHCP FORCERENEW メッセージ処理をイネーブルにします。

ステップ 7

end

Router(config)# end

(任意)グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

DHCP クライアントの設定例

ここでは、次の設定例について説明します。

「DHCP クライアントの設定:例」

「DHCP クライアントの設定のカスタマイズ:例」

「aal5snap カプセル化および Inverse ARP を使用した ATM プライマリ インターフェイス(マルチポイント)の設定:例」

「aa15snap カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例」

「aa15nlpid カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例」

「aa15mux PPP カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例」

「DHCP リースのリリース:例」

「DHCP リースの更新:例」

DHCP クライアントの設定:例

図 2 に、イーサネット LAN 上における DHCP クライアントの簡易ネットワーク図を示します。

図 2 イーサネット インターフェイスを持つ DHCP クライアントを示すトポロジ

 

DHCP サーバでの設定は、次のとおりです。

ip dhcp pool 1
network 10.1.1.0 255.255.255.0
lease 1 6
 

DHCP クライアントのインターフェイス E2 での設定は、次のとおりです。

interface Ethernet2
ip address dhcp
 

この設定によって、DHCP クライアントは DHCP サーバからイーサネット インターフェイス経由で IP アドレスを取得できます。

DHCP クライアントの設定のカスタマイズ:例

次に、イーサネット インターフェイス 1 上の DHCP クライアントの設定を、さまざまなオプションを使用してカスタマイズする例を示します。

interface Ethernet 1
ip dhcp client client-id ascii my-test1
ip dhcp client class-id my-class-id
ip dhcp client lease 0 1 0
ip dhcp client hostname sanfran
no ip dhcp client request tftp-server-address
ip address dhcp

aal5snap カプセル化および Inverse ARP を使用した ATM プライマリ インターフェイス(マルチポイント)の設定:例

次の例では、Permanent Virtual Circuit(PVC; 相手先固定接続)上のブロードキャスト フラグを認識する ATM マップ エントリが必要なため、 protocol ip 255.255.255.255 broadcast 設定が必要です。任意の ATM マップ エントリを使用できます。ATM Inverse ARP がインターフェイス上で動作できることで、DHCP によってアドレスが割り当てられたときに別の側のシステムにピングを実行できるようにするために、 protocol ip inarp の設定が必要です。

interface atm0
ip address dhcp
pvc 1/100
encapsulation aal5snap
broadcast
protocol ip 255.255.255.255 broadcast
protocol ip inarp

aa15snap カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

次に、aa15snap カプセル化を使用した ATM ポイントツーポイント サブインターフェイス コンフィギュレーションの例を示します。

interface atm0.1 point-to-point
ip address dhcp
pvc 1/100
encapsulation aal5snap
broadcast

aa15nlpid カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

次に、aa15nlpid カプセル化を使用した ATM ポイントツーポイント サブインターフェイス コンフィギュレーションの例を示します。

interface atm0.1 point-to-point
ip address dhcp
pvc 1/100
encapsulation aal5nlpid
broadcast

aa15mux PPP カプセル化を使用した ATM ポイントツーポイント サブインターフェイスの設定:例

次に、aa15mux PPP カプセル化を使用した ATM ポイントツーポイント サブインターフェイス コンフィギュレーションの例を示します。

interface atm0.1 point-to-point
pvc 1/100
encapsulation aal5mux ppp virtual-template1
broadcast
!
interface virtual-template1
ip address dhcp

DHCP リースのリリース:例

次の例では、最初に DHCP サーバによって IP アドレスが割り当てられたインターフェイス上で DHCP リリースが実行されます。

Router# release dhcp ethernet 3/1
 

次の例では、最初に DHCP サーバによって IP アドレスが割り当てられなかったインターフェイス上で DHCP リースをリリースしようとしています。

Router# release dhcp ethernet 3/1

Interface does not have a DHCP originated address

 

次の例では、 type および number 引数を指定せずに release dhcp コマンドが実行されています。

Router# release dhcp

Incomplete command.

DHCP リースの更新:例

次の例では、最初に DHCP サーバによって IP アドレスが割り当てられたインターフェイス上で DHCP リースが更新されます。

Router# renew dhcp ethernet 3/1
 

次の例では、最初に DHCP サーバによって IP アドレスが割り当てられなかったインターフェイス上で DHCP リースを更新しようとしています。

Router# renew dhcp ethernet 3/1

Interface does not have a DHCP originated address

 

次の例では、 type および number 引数を指定せずに renew dhcp コマンドが実行されています。

Router# renew dhcp

Incomplete command.

その他の関連資料

ここでは、DHCP クライアントに関する関連資料について説明します。

関連資料

関連項目
参照先

DHCP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

Cisco IOS IP Addressing Services Command Reference

DHCP の概念的な説明

DHCP Overview 」モジュール

DHCP サーバ設定

Configuring the Cisco IOS DHCP Server 」モジュール

DHCP サーバ オンデマンド アドレス プール

Configuring the DHCP Server On-Demand Address Pool Manager 」モジュール

DHCP リレー エージェントの設定

Configuring the Cisco IOS DHCP Relay Agent 」モジュール

DHCP の拡張機能

Configuring DHCP Services for Accounting and Security 」モジュール

エッジセッション管理用 DHCP 機能拡張

Configuring DHCP Enhancements for Edge-Session Management 」モジュール

規格

規格
タイトル

この機能によりサポートされた新規標準または改訂標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

プラットフォームおよび Cisco IOS リリースによりサポートされている MIB のリストを入手し、MIB モジュールをダウンロードするには、Cisco.com の次のシスコ MIB Web サイトの URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

RFC 2131

Dynamic Host Configuration Protocol

RFC 2132

DHCP Options and BOOTP Vendor Extensions

RFC 3118

Authentication for DHCP Messages

RFC 3203

DHCP reconfigure extension

RFC 3361

DHCP-for-IPv4 Option for SIP Servers

RFC 3442

Classless Static Route Option for DHCPv4

RFC 3925

Vendor-Identifying Vendor Options for DHCPv4

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト(http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。 http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

DHCP クライアントの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator により、どの Cisco IOS および Catalyst OS、Cisco IOS XE ソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 Cisco IOS DHCP クライアントの機能情報

機能名
リリース
機能設定情報

設定可能な DHCP クライアント

12.3(8)T
12.2(28)SB

設定可能な DHCP クライアント機能によって、DHCP クライアントにさまざまな設定オプションを組み込むための柔軟性が備わります。DHCP クライアントは、IP アドレスなどのコンフィギュレーション パラメータの取得に DHCP を使用しているインターネットのホストとして定義されます。

この機能に関する詳細については、次の各項を参照してください。

DHCP クライアントの設定

次のコマンドが導入されました。 ip dhcp client class-id ip dhcp client client-id ip dhcp client hostname ip dhcp client lease ip dhcp client request

CLI の EXEC モードでの DHCP リリースおよび更新

12.3(4)T
12.2(28)SB
12.2(33)SRC

この機能では、次の 2 つの独立した操作を CLI から実行できます。(1)DHCP クライアントに対する DHCP リースをただちにリリースすること。(2)DHCP クライアントに対する DHCP リースを強制的に更新すること。

この機能に関する詳細については、次の項を参照してください。

DHCP クライアントに対する DHCP リースの強制的なリリースまたは更新

次のコマンドが導入されました。 release dhcp および renew dhcp

WAN インターフェイス上の DHCP クライアント

12.2(8)T
12.2(28)SB

WAN インターフェイス上の DHCP クライアント機能では、DHCP クライアントが PPP over ATM(PPPoA)および一部の ATM インターフェイスを経由して IP アドレスを取得するよう DHCP を拡張します。

この機能に関する詳細については、次の項を参照してください。

WAN インターフェイス上の DHCP クライアント

この機能により導入または変更されたコマンドはありません。

Cisco DHCP FORCERENEW

12.4(22)YB
15.0(1)M

エンティティ認証およびメッセージ認証を提供することでセキュリティを高めます。

次のコマンドが導入または変更されました。 ip dhcp client authentication key-chain ip dhcp client authentication mode ip dhcp-client forcerenew ip dhcp client request