Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド
Cisco IOS ソフトウェアのためのダイナミッ ク DNS サポート
Cisco IOS ソフトウェアのためのダイナミック DNS サポート
発行日;2012/02/02 | 英語版ドキュメント(2011/09/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

Cisco IOS ソフトウェアのためのダイナミック DNS サポート

この章の構成

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの制約事項

Cisco IOS ソフトウェアのためのダイナミック DNS サポートについて

ドメイン ネーム システムおよびダイナミック アップデート

HTTP ベースのプロトコルについての DDNS アップデート

DDNS アップデートのための DHCP サポート

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの機能設計

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの設定方法

ホスト リストの設定

ホスト リスト設定の確認

DDNS アップデートのための DHCP サポートの設定

前提条件

制約事項

インターフェイス上での DDNS アップデート サポートの設定

前提条件

制約事項

DDNS アップデートをサポートするための DHCP サーバ プールの設定

前提条件

アップデート方式およびアップデート間隔の設定

前提条件

DDNS アップデートの確認

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの設定例

DHCP クライアントの設定:例

DHCP サーバの設定:例

HTTP アップデートの設定:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

Cisco IOS ソフトウェアのためのダイナミック DNS サポート

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能では、IP ホストの DNS 名がその IP アドレスと正しく関連付けられるようにするために、Cisco IOS ソフトウェア デバイスが Dynamic Domain Name System(DDNS; ダイナミック ドメイン ネーム システム)アップデートを実行できます。

これは DDNS の生成または実行のための 2 つのメカニズムを提供します。RFC 2136 で定義された IETF 標準と、さまざまな DNS サービスを使用する汎用 HTTP です。この機能を使用すると、アップデートを受信するホスト名および IP アドレスのリストを定義し、アップデート方式を指定し、Dynamic Host Configuration Protocol(DHCP)でトリガーされるアップデートの設定を指定できます。

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能の履歴

リリース
変更点

12.3(8)YA

この機能が導入されました。

12.3(14)T

この機能は、Cisco IOS Release 12.3(14)T に統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の入手方法

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明な場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの制約事項

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能をイネーブルにすると、DHCP クライアントのパフォーマンスが影響を受ける場合があります。これは、DDNS アップデート パケットの送信、サーバからの応答の待機(クライアントの REQUEST に対して ACK を送信する前)およびクライアントからの応答の待機(ACK を受信してインターフェイスにアドレスを割り当てた直後)が原因です。クライアントについてのデフォルトは、試行が 2 回で、試行と試行の間の待機時間が 5 秒です。

DHCP サーバは、DDNS の更新が完了するのを待つ間、DHCP クライアントの DISCOVER および REQUEST パケットの処理を続行します。クライアントに ACK を送信する前に更新が完了する場合でも、他の DHCP 要求の処理を遅延させません。DDNS アップデートのセットアップと処理の開始に時間とメモリが必要になるため、DHCP サーバに軽微な影響が出る可能性があります。

完了させる必要がある未処理の DDNS アップデートがあるなどの場合、システムのリロードに少し時間がかかることがあります。

Cisco IOS ソフトウェアのためのダイナミック DNS サポートについて

Cisco IOS ソフトウェアのためのダイナミック DNS サポートを設定するには、次の概念を理解する必要があります。

「ドメイン ネーム システムおよびダイナミック アップデート」

「HTTP ベースのプロトコルについての DDNS アップデート」

「DDNS アップデートのための DHCP サポート」

「Cisco IOS ソフトウェアのためのダイナミック DNS サポートの機能設計」

ドメイン ネーム システムおよびダイナミック アップデート

DNS は、スタティックに設定されたデータベースの照会をサポートするように設計されました。データは変更されても、変更は最小限だと想定されていました。すべての更新は、ゾーン マスター ファイルへの外部的な編集として実行されていました。ドメイン名は、ドメイン ネーム スペースのツリー構造内のノードを識別します。各ノードには Resource Record(RR; リソース レコード)のセット(場合によっては空)があります。同じ NAME、CLASS、および TYPE を持つすべての RR は、Resource Record Set(RRset)と呼ばれます。

アドレス(A)あるいは転送 RR と、ポインタ(PTR)あるいはリバース RR があります。DDNS アップデートでは、ホスト名および IP アドレスの追加または削除を指定できます。この情報を更新する 2 つのメカニズムには、DynDNS.org などの HTTP ベースのプロトコルを使用する方法と、IETF 標準を使用する方法があります。

HTTP ベースのプロトコルについての DDNS アップデート

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能では、独自の HTTP ベース プロトコルによって DDNS アップデートを生成または実行できる機能が提供されています。最も有名な HTTP ベースのプロトコルは DynDNS.org ですが、他にも多くが存在します。

これらの大半のプロトコルでは、ホスト名および IP アドレスなどのパラメータを、コマンドの URL 部分に指定する簡単な HTTP コマンドで構成されているため、この機能でも同様の汎用的な方式を使用しています。ホスト名および IP アドレスを URL に指定できます。更新と更新の間の最大間隔も設定できます。

DDNS アップデートのための DHCP サポート

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能が導入される前は、DHCP サーバは DHCP クライアントに IP アドレスを割り当て、すべての DNS 情報はスタティックでした。DHCP サーバを使用するネットワークでは、割り当てられる IP アドレスに DNS ホスト名を関連付けることが必要な場合が多くあります。DHCP 用に DNS をダイナミックに更新する方法として、Fully Qualified Domain Name(FQDN; 完全修飾ドメイン名)DHCP オプション(クライアントによってサポートされている場合)の情報を使用する方法が存在します。

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能では、DHCP サーバが新しい FQDN DHCP オプションをサポートできます。さらに、インターフェイス上のアドレスが設定されると、クライアントは新しい FQDN オプションをサーバに渡すことで、名前/アドレス間の変換を DHCP クライアントについても同様に更新できます。

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの機能設計

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能では、FQDN DHCP オプションの追跡をイネーブルにできます。ダイナミック アップデートが DHCP サーバに対してイネーブルになると、サーバは PTR RR を更新します。PTR RR は逆マッピング(アドレスから名前への変換)に使用されます。PTR はエイリアスでなく正式名を使用します。PTR レコード内の名前は、リバース名のローカル IP アドレス部分です。

クライアントからサーバに、A RR を更新することも要求すると、サーバは更新を実行しようとします。A RR は DNS ゾーンの名前/アドレス マッピングを提供します。サーバはクライアントの推奨を上書き指定し、PTR RR および A RR を常に更新するように設定できます。

DHCP クライアントは、ダイナミック アップデート(FQDN オプションを含む)を許可するかどうかを指定し、クライアントが A RR および PTR RR の両方を更新することを許可するようサーバに指示し(通常は、A RR だけがクライアントによって更新されます)、任意で、DNS 情報を更新しないようサーバに指示します(クライアントが両方を更新するか、または単にサーバがアップデートを実行することをクライアントが望まない場合)。

Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能には、次の 3 つの基本コンポーネントがあります。

ホスト名のグループを指定する新しいコマンドを使用してアップデートを受け取る、ホスト名リストおよび IP アドレスの定義。設定される各リストは、任意の数の IPv4 アドレスまたはホスト名で構成できます。ホスト名が設定される場合、名前は使用されるときに IPv4 アドレスに変換されます。

アップデート方式の指定。オプションは、HTTP、DDNS、または内部の Cisco IOS ネーム キャッシュです。HTTP オプションが指定されると、設定に URL が含まれます。ユーザ名およびパスワードを明示的に URL ストリングに書き込む必要があり、GET 動作を 1 行で指定する必要があります。指定はリンクされたリストに保存されます。アップデート方式が DDNS の場合、設定には IP アドレスのアップデートが含まれます。

アップデートをトリガーするイベントは次のものが可能です。

DHCP サーバによって IP デバイスに割り当てられる IP アドレス

DHCP クライアントを使用してルータに割り当てられる IP アドレス

ユーザの完全修飾ドメイン名(FQDN)またはルータ ホスト名の DHCP クライアントからサーバへの転送

ルータ インターフェイスの IP アドレスを取得する Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)/Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)

ルータ IP アドレスを確認するためのタイマーを使用する強制アップデート

各アップデート方式には、アップデートとアップデートの間の最大秒数を指定する値が関連付けられます。指定されない場合、アップデートはアドレスが変更されたときだけ実行されます。指定された場合、アップデートは最後のアップデートから指定された秒数が経過すると自動的に実行されます。

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの設定方法

ここでは、次の各手順について説明します。

「ホスト リストの設定」(任意)

「ホスト リスト設定の確認」(任意)

「DDNS アップデートのための DHCP サポートの設定」(任意)

「インターフェイス上での DDNS アップデート サポートの設定」(必須)

「DDNS アップデートをサポートするための DHCP サーバ プールの設定」(任意)

「アップデート方式およびアップデート間隔の設定」(必須)

「DDNS アップデートの確認」(任意)


) 内部の Cisco IOS ネーム キャッシュには、設定は不要です。


ホスト リストの設定

設定でホスト リストを使用する場合にホスト リストを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip host-list host-list-name

4. host [ vrf vrf-name] {host-ip-address | hostname}

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip host-list host-list-name

 

Router(config)# ip host-list abc

ホストのリストを指定し、ホスト リスト コンフィギュレーション モードを開始します。 host-list-name 引数は、ホストのリストに名前を割り当てます。

ステップ 4

host [ vrf vrf-name] {host-ip-address | hostname}

 
Router(host-list)# host 10.1.1.1 10.2.2.2 10.3.3.3 a.com b.com 10.4.4.4 10.5.5.5 d.com host 10.6.6.6 f.com host vrf abc a.com b.com c.com host vrf def 10.1.1.1 10.2.2.2 10.3.3.3

1 つ以上のホストを設定します。引数およびキーワードは次のとおりです。

vrf vrf-name:ホスト名を Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; 仮想ルーティングおよび転送)インスタンス名に関連付けます。

(注) vrf キーワードの後に指定されるすべてのホスト名および IP アドレスは、その VRF と関連付けられます。

host-ip-address :ホスト リスト内のホストに IP アドレスを指定します。この引数を使用してホスト名および IP アドレスを同じ行にリストすることによって、複数のホストを指定できます。

hostname :ホスト名を指定します。

ステップ 5

exit

 

Router(config) exit

グローバル コンフィギュレーション モードに戻ります。

次に、VRF を使用して複数のホストを設定する例を示します。

ip host-list abc
host 10.1.1.1 10.2.2.2 10.3.3.3 a.com b.com 10.4.4.4 10.5.5.5 d.com
host 10.6.6.6 f.com
host vrf abc a.com b.com c.com
host vrf def 10.1.1.1 10.2.2.2 10.3.3.3

ホスト リスト設定の確認

ホスト リスト設定を確認するには、次の手順を実行します。

手順の概要

1. show ip host-list

2. show running-config | inc host-list

3. show running-config | inc host

4. debug ip ddns update

手順の詳細


ステップ 1 show ip host-list

このコマンドを使用して、IP アドレスおよびホスト名がホスト リストに割り当てられていることを確認します。たとえば、次のようになります。

Router# show ip host-list abc
 
Host list: abc
ddns.abc
10.2.3.4
ddns2.abc
10.3.4.5
ddns3.com
10.3.3.3
d.org
e.org
1.org.2.org
3.com
10.2.2.2 (VRF: test)
10.5.5.5 (VRF: test)
a.net (VRF: test)
b.net (VRF: test)
 

ステップ 2 show running-config | inc host-list

このコマンドを使用して、ホスト リストの設定を確認します。たとえば、次のようになります。

Router# show running-config | inc host-list
 
ip host-list a
ip host-list b
ip host-list c
ip host-list abc
 

ステップ 3 show running-config | inc host

このコマンドを使用して、ホスト名の設定を確認します。たとえば、次のようになります。

Router# show running-config | inc host
 
hostname who
ip host who 10.0.0.2
ip host-list a
host 10.1.1.1 a.com b.com 10.2.2.3 10.2.2.2 c.com. 10.3.3.3 10.4.4.4
host d.com
host vrf abc 10.10.10.4 10.10.10.8
host vrf def 10.2.3.4 10.6.7.8
ip host-list b
host a.com b.com c.com 10.1.1.1 10.2.2.2 10.3.3.3
host vrf ppp 10.2.1.0
ip host-list c
host 10.1.1.1 10.2.2.2 10.3.3.3 a.com b.com 10.4.4.4 10.5.5.5 d.com
host 10.6.6.6 f.com
host vrf zero a.com b.com c.om
host vrf one 10.1.1.1 10.2.2.2 10.3.3.3
ip host-list unit-test
host ddns.unit.test 10.2.3.4 ddns2.unit.test 10.3.4.5 ddns3.com 10.3.3.3 d.org e.org
host 1.org.2.org 3.com
host vrf ZERO 10.2.2.2 10.5.5.5 a.net b.net
ip ddns update hostname use-this.host.name
ip ddns update this-method host 10.2.3.4
ip ddns update this-method host this-host
ip ddns update this-method host-group this-list
ip ddns update this-method host 10.3.4.5
ip ddns update test host 10.19.192.32
ip ddns update test host 10.19.192.32
ip ddns update a host-group a
ip ddns update a host-group ab
ip ddns update aa host-group ab
ip ddns update method host 10.33.44.55
 

ステップ 4 debug ip ddns update

次の設定に対して debug ip ddns update コマンドを使用して、ホストの設定を確認します。2 つのサーバがホスト リストに設定されています。DHCP クライアントは A および DNS RR の両方についての IETF DDNS アップデートが設定され、DHCP サーバはいずれも更新しないよう要求されます。DHCP クライアントは、DHCP サーバに A RR または PTR Resource Record を更新しないように指示する FQDN DHCP オプションを含むように設定されています。これはコマンドのインターフェイス バージョンを使用して設定されます。DHCP サーバは、DHCP クライアントが選択するすべての RR を DHCP クライアントが更新できるように設定されます。

!Configure the DHCP Client
 
ip host-list servers
host 10.19.192.32 10.0.0.1
 
ip ddns update method testing
ddns
 
interface Ethernet1
ip dhcp client update dns server none
ip ddns update testing host-group servers
ip address dhcp
end
 
!Configure the DHCP Server
 
ip dhcp pool test
network 10.0.0.0 255.0.0.0
update dns
 
!Enable Debugging
 
debug ip ddns update
 
!The update to the server 10.0.0.1 fails in this example
 
00:18:58:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.0.0.8, mask 255.0.0.0, hostname canada_reserved
00:18:58: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.8 server 10.19.192.32
00:18:58: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:19:01: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.8 server 10.19.192.32
00:19:01: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.8 server 10.0.0.1
00:19:01: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.8 server 10.0.0.1
00:19:01: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.8 server 10.0.0.1
00:19:01: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.8 server 10.0.0.1
00:19:01: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '10.in-addr.arpa'
00:19:01: DDNS: Using server 10.19.192.32
00:19:01: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:19:01: DDNS: Zone = 10.in-addr.arpa
00:19:01: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:19:01: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:19:01: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '10.in-addr.arpa'
00:19:01: DDNS: Using server 10.0.0.1
00:19:01: DDNS: Dynamic Update 1: (sending to server 10.0.0.1)
00:19:01: DDNS: Zone = 10.in-addr.arpa
00:19:01: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:19:01: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:19:01: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '10.in-addr.arpa'
00:19:01: DDNS: Using server 10.0.0.1
00:19:01: DDNS: Dynamic Update 1: (sending to server 10.0.0.1)
00:19:01: DDNS: Zone = 10.in-addr.arpa
00:19:01: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:19:01: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:19:01: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 6 (YXDOMAIN)
00:19:01: DDNS: Dynamic Update 2: (sending to server 10.19.192.32)
00:19:01: DDNS: Zone = 10.in-addr.arpa
00:19:01: DDNS: Update: delete 10.0.0.11.in-addr.arpa. all PTR RRs
00:19:01: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:19:01: DDNS: Dynamic DNS Update 2 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:01: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:19:01: DDNS: Using server 10.19.192.32
00:19:01: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:19:01: DDNS: Zone = hacks
00:19:01: DDNS: Prerequisite: canada_reserved.hacks not in use
00:19:01: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.8
00:19:01: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:01: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.8 finished
00:19:01: DYNDNSUPD: Another update completed (total outstanding=2)
00:19:11: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:11: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:11: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:19:11: DDNS: Using server 10.0.0.1
00:19:11: DDNS: Dynamic Update 1: (sending to server 10.0.0.1)
00:19:11: DDNS: Zone = hacks
00:19:11: DDNS: Prerequisite: canada_reserved.hacks not in use
00:19:11: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.8
00:19:11: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:19:11: DDNS: Using server 10.0.0.1
00:19:11: DDNS: Dynamic Update 1: (sending to server 10.0.0.1)
00:19:11: DDNS: Zone = hacks
00:19:11: DDNS: Prerequisite: canada_reserved.hacks not in use
00:19:11: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.8
00:19:21: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:21: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.8 failed
00:19:21: DYNDNSUPD: Another update completed (total outstanding=1)
00:19:21: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:19:21: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.8 failed
00:19:21: DYNDNSUPD: Another update completed (total outstanding=0)

DDNS アップデートのための DHCP サポートの設定

DDNS アップデートには、特定の IP アドレスについての A RR または転送 RR に関する情報が含まれています。IP アドレスはドット付き 10 進形式で、各ホスト アドレスについて少なくとも 1 つの A レコードが必要です。指定される名前は、FQDN(ns.example.com)として表現されるホスト名です。PTR RR またはリバース RR は、ドメイン名を別のドメイン名にマッピングし、逆マッピング(IP アドレスからドメイン名)に使用されます。

アップデートはメッセージを使用して実行されます。一般的に、DDNS アップデートは多くの場合、サーバから DHCP クライアントに ACK 応答を送信した 、サーバによって実行される必要があります。ACK 応答を送信する 前に DDNS アップデートを実行すると、クライアントへの応答が遅延します。どちらの方法もサポートされています。デフォルトは、応答を送信した 後で アップデートを実行することです。

アップデートに使用するクライアント ホスト名を探すとき、サーバはまず FQDN オプションからホスト名を取得します(存在する場合)。FQDN オプションが存在しない場合、サーバは HOSTNAME オプションを探し、そこから名前を取得します。

FQDN オプションまたは HOSTNAME オプションが後続の RENEWAL メッセージに含まれている場合、サーバはリースが更新されるたびに DDNS アップデートを実行しようとします。このプロセスによってクライアントは、リースが許可された後に指定される名前を変更し、サーバに適切なアップデートを実行させる機会が与えられます。サーバはこの機能を持っていますが、DHCP クライアントはリースの期間中ずっと同じホスト名が引き続き使用されます。

更新するサーバの IP アドレスは、更新するホスト名に関連付けられたレコードを探す DNS 照会を送信することによって検出されます。そのようなレコードが存在する場合、この情報からマスター DNS サーバのホスト名が抽出されます。そのようなレコードが存在しない場合、(応答に含まれる)レコードは、ホスト名が存在するゾーンの権威レコードとして使用されます。どちらの場合も、マスター DNS サーバ ホスト名が見つかると、このサーバの IP アドレスを検出するための A RR を探す別の照会が送信されます。結果の IP アドレスはアップデートの送信に使用されます。

DDNS アップデートを設定するには、次の作業を実行します。

前提条件

ユーザがサーバを設定していない場合に、DDNS アップデートで DNS サーバを検出するには、ip name-server コマンドを設定する必要があります。このネーム サーバはシステムから到達可能になっている必要があり、ip domain lookup コマンドを設定する必要があります(デフォルトで設定されています)。設定されたホスト名にピリオドが含まれていない場合、つまり完全修飾ドメイン名(FQDN)でない場合、IP ドメイン名を設定する必要があります。

制約事項


) DHCP サーバ プール コンフィギュレーション コマンドとインターフェイス コンフィギュレーションは、グローバル設定よりも優先されます。


手順の概要

1. enable

2. configure terminal

3. ip dhcp update dns [ both ] [ override ] [ before ]

4. ip dhcp-client update dns [ server { both | none }]

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp update dns [ both ] [ override ] [ before ]

 

Router(config)# ip dhcp update dns both override

プール単位の update dns コマンド(グローバル設定を上書きします)で設定されたものを除くすべてのアドレス プールについて、PTR RR の DDNS アップデートをイネーブルにします。キーワードは次のとおりです。

both :(任意)DHCP クライアントが FQDN オプション内で、DHCP サーバがアップデートを実行しないよう指定しない限り、DHCP サーバが A RR および PTR RR の DDNS アップデートを実行することをイネーブルにします。

override :(任意)DHCP クライアントが FQDN オプション内で、DHCP サーバがアップデートを実行しないよう指定した場合でも、DHCP サーバが PTR RR の DDNS アップデートを実行することをイネーブルにします。

キーワードを同時に指定した場合、DHCP クライアントが FQDN オプション内で反対に指定した内容を上書き指定する A RR および PTR RR の DDNS アップデートを DHCP サーバが実行することをイネーブルにします。

before :(任意)DHCP サーバが DHCP ACK をクライアントに送信する前に DDNS アップデートを実行することをイネーブルにします。デフォルトでは、DHCP ACK を送信した後にアップデートを実行します。

ステップ 4

ip dhcp-client update dns [server {both | none}]

 

Router(config)# ip dhcp-client update dns server both

PTR RR の DDNS アップデートをイネーブルにします。オプションの server キーワードは、サーバが A RR および PTR RR の DDNS アップデートを実行することをイネーブルにします。キーワードは次のとおりです。

both :DHCP クライアントが FQDN オプション内で、DHCP サーバがアップデートを実行しないよう指定しない限り、DHCP サーバが A RR および PTR RR の DDNS アップデートを実行することをイネーブルにします。

none :DHCP クライアントが DDNS アップデートを実行することをイネーブルにして、サーバはアップデートを実行しません。サーバはこのアクションを上書き指定できます。

コマンドでは、サーバにアップデートを実行しないよう指示します。これを実行するよう設定された場合、サーバはクライアントの指示を上書き指定できます。

コマンドでは、サーバに A RR および PTR RR の両方を更新するよう指示します。

ステップ 5

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

次に、サーバだけで実行される A RR および PTR RR のアップデートを設定する例を示します。

ip dhcp-client update dns server both

ip dhcp update dns both override

インターフェイス上での DDNS アップデート サポートの設定

インターフェイスを DDNS アップデート機能向けに設定するには、次の作業を実行します。


) インターフェイス コンフィギュレーションはグローバル コンフィギュレーションよりも優先されます。


前提条件

ユーザがサーバを設定していない場合に、DDNS アップデートで DNS サーバを検出するには、ip name-server コマンドを設定する必要があります。このネーム サーバはシステムから到達可能になっている必要があり、ip domain lookup コマンドを設定する必要があります(デフォルトで設定されています)。設定されたホスト名にピリオドが含まれていない場合、つまり完全修飾ドメイン名(FQDN)でない場合、IP ドメイン名を設定する必要があります。

制約事項

変更が有効になるのは、インターフェイス上の任意の現行リースがリリースされて、新しい DHCP DISCOVER パケットを使用する新しいリースが要求されてからです。つまり、 ip address dhcp コマンドを設定するか、 release dhcp EXEC コマンドを使用した後、 renew dhcp EXEC コマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. interface interface-type number

4. ip dhcp client update dns [server { both | none} ]

5. ip address dhcp

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface-type number

 

Router(config)# interface ethernet1

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip dhcp client update dns [server { both | none }]

 

Router(config-if)# ip dhcp client update dns server both

パケットを DHCP サーバに送信するとき FQDN オプションを含めるよう DHCP クライアントを設定します。キーワードは次のとおりです。

both:(任意)DHCP クライアントが FQDN オプション内で、DHCP サーバがアップデートを実行しないよう指定しない限り、DHCP サーバが A RR および PTR RR の DDNS アップデートを実行することをイネーブルにします。

none:(任意)DHCP クライアントが DDNS アップデートを実行することをイネーブルにして、サーバはアップデートを実行しません。サーバはこのアクションを上書き指定できます。

コマンドでは、サーバにアップデートを実行しないよう指示します。これを実行するよう設定された場合、サーバはクライアントの指示を上書き指定できます。

コマンドでは、サーバに A RR および PTR RR の両方を更新するよう指示します。

ステップ 5

ip address dhcp

 

Router(config-if)# ip address dhcp

インターフェイス上の任意の現行リースをリリースして、設定をイネーブルにします。

EXEC コマンドを使用しても、任意のリースをリリースできます。

ステップ 6

exit

 

Router(config-if)# exit

特権 EXEC モードに戻ります。

DDNS アップデートをサポートするための DHCP サーバ プールの設定

クライアント側での DDNS アップデート設定は、次の 2 つの部分で構成されます。最初に、DDNS スタイルのアップデートを指定する ip ddns update method コマンドがクライアント上で設定されている場合、クライアントは A アップデートを生成または実行しようとします。 ip ddns update method ddns both コマンドが設定されている場合、クライアントは A RR および PTR RR の両方を更新しようとします。

次に、クライアントで生成されるアップデートまたはサーバで生成されると予想されるアップデートに関してクライアントがサーバと通信するための唯一の方法は、サーバと通信するときに FQDN オプションを含めることです。このオプションが含まれるかどうかは、クライアント側のグローバル コンフィギュレーション モードでの ip dhcp-client update dns コマンドまたはインターフェイス コンフィギュレーション モードでの ip dhcp client update dns コマンドによって制御されます。

FQDN オプションが DHCP インタラクションに含まれる場合、クライアントはサーバに、「reverse」(デフォルト)、「both」、または「none」のアップデートを指示できます。 ip ddns update method コマンドが ddns および both キーワードで設定される場合は、FQDN オプション設定には、IP DHCP クライアントの DNS サーバ アップデート none が当然反映される必要がありますが、システムを正しく設定する必要があります。

最後に、サーバが両方とも更新するか両方を更新しないかをクライアントが指示した場合でも、サーバはクライアント要求を上書き指定でき、設定されていた動作を実行できます。上記のように、FQDN オプションが DHCP インタラクション内にある場合、サーバはクライアントに対してクライアントの指示が上書き指定されたことを通信できます。この場合、クライアントはサーバがアップデートを実行したことを認識するため、クライアントはアップデートを実行しません。ACK を送信した後にアップデートを実行するようサーバが設定された場合でも(デフォルト)、サーバはサーバで実行するアップデートを FQDN オプションを使用してクライアントに指示できるため、クライアントは同じタイプのアップデートを実行しません。

サーバが(キーワードの有無を問わず) update dns コマンドを使用して設定され、サーバが DHCP インタラクション内で FQDN オプションを認識しない場合、サーバはクライアントが DDNS を認識できないと想定し、クライアントに代わって A RR および PTR RR の両方を更新するように設定されたものとして自動的に動作します。

DDNS アップデートをサポートするために DHCP サーバ プールを設定するには、次の作業を実行します。

前提条件

ユーザがサーバを設定していない場合に、DDNS アップデートで DNS サーバを検出するには、ip name-server コマンドを設定する必要があります。このネーム サーバはシステムから到達可能になっている必要があり、ip domain lookup コマンドを設定する必要があります(デフォルトで設定されています)。設定されたホスト名にピリオドが含まれていない場合、つまり完全修飾ドメイン名(FQDN)でない場合、IP ドメイン名を設定する必要があります。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool pool-name

4. update dns [ both | never ] [ override ] [ before ]

5. exit

手順の詳細

 

 
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool pool-name

 

Router(config)# ip dhcp pool test

DHCP プールに名前を割り当て、DHCP コンフィギュレーション モードを開始します。

ステップ 4

update dns [ both | never ] [ override ] [ before ]

 

Router(dhcp-config)# update dns never

このアドレス プールから割り当てられる任意のアドレスについて、DHCP サーバ プールに対する DDNS アップデート機能をイネーブルにします。

サーバが(他のキーワードの有無を問わず)このコマンドを使用して設定され、サーバが DHCP インタラクション内で FQDN オプションを認識しない場合、サーバはクライアントが DDNS を認識できないと想定し、クライアントに代わって A RR および PTR RR の両方のレコードを更新するように設定されたものとして自動的に動作します。

キーワードは次のとおりです。

both :(任意)フォワード アップデートおよびリバース アップデートを実行します。オプションの before キーワードが both キーワードと一緒に指定された場合、サーバは ACK をクライアントに送信する前に DDNS アップデートを実行できます。

オプションの override キーワードが both キーワードと一緒に指定された場合、サーバはクライアントの指示を上書き指定して、転送 RR およびリバース RR を更新できます。

override キーワードとオプションの before キーワードが both キーワードと一緒に指定された場合、サーバはクライアントの指示を上書き指定して(フォワード アップデートおよびリバース アップデート)、ACK を送信する前にアップデートを実行できます。

never :(任意)このプールについてアップデートを実行しません。

override :(任意)クライアントの FQDN フラグを上書き指定します。オプションの before キーワードが指定されると、アップデートは ACK を送信する前に実行されます。

before :(任意)ACK を送信する前にアップデートを実行します。

ステップ 5

exit

 

Router(dhcp-config)# exit

グローバル コンフィギュレーション モードに戻ります。

次に、ACK を送信する前に A RR および PTR RR のアップデートを実行するよう DHCP サーバ プールを設定する例を示します。

ip dhcp pool test
update dns both before

アップデート方式およびアップデート間隔の設定

アップデート方式および最大間隔を指定するには、次の作業を実行します。

前提条件

ユーザがサーバを設定していない場合に、DDNS アップデートで DNS サーバを検出するには、ip name-server コマンドを設定する必要があります。このネーム サーバはシステムから到達可能になっている必要があり、ip domain lookup コマンドを設定する必要があります(デフォルトで設定されています)。設定されたホスト名にピリオドが含まれていない場合、つまり完全修飾ドメイン名(FQDN)でない場合、IP ドメイン名を設定する必要があります。

手順の概要

1. enable

2. configure terminal

3. ip ddns update method method-name

4. interval minimum days hours minutes seconds

5. interval maximum days hours minutes seconds

6. ddns [both]

7. internal

8. http

9. add url

10. remove url

11. exit

12. exit

13. interface interface-type number

14. ip ddns update hostname hostname

15. ip ddns update method-name

16. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip ddns update method method-name

 

Router(config)# ip ddns update method myupdate

アップデート方式の名前を指定し、DDNS アップデート方式コンフィギュレーション モードを開始します。

ステップ 4

interval minimum days hours minutes seconds

 

Router(DDNS-update-method)# interval minimum 1 0 0 0

最小アップデート間隔を設定します。引数は次のとおりです。

days:範囲は 0 ~ 365 です。

hours:範囲は 0 ~ 23 です。

minutes:範囲は 0 ~ 59 です。

seconds:範囲は 0 ~ 59 です。

ステップ 5

interval maximum days hours minutes seconds

 

Router(DDNS-update-method)# interval maximum 1 0 0 0

最大アップデート間隔を設定します。引数は次のとおりです。

days:範囲は 0 ~ 365 です。

hours:範囲は 0 ~ 24 です。

minutes:範囲は 0 ~ 60 です。

seconds:範囲は 0 ~ 60 です。

ステップ 6

ddns [both]

 

Router(DDNS-update-method)# ddns

アップデート方式として DDNS を設定します。both キーワードは A RR および PTR RR の両方が更新されることを指定します。

(注) DDNS または HTTP を指定できますが、1 回の手順で両方を指定できません。DDNS を指定した場合、HTTP を設定する前に no ddns コマンドを使用して DDNS をディセーブルにする必要があります。HTTP 設定については、ステップ 7、8、および 9 を参照してください。

ステップ 7

internal

 

Router(DDNS-update-method)# internal

アップデート方式として内部キャッシュを使用するよう指定します。

ステップ 8

http

 

Router(DDNS-update-method)# http

アップデート方式として HTTP を設定し、DDNS-HTTP コンフィギュレーション モードを開始します。

ステップ 9

add url

 

Router(DDNS-HTTP)# add http://test:test@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

ホスト名と IP アドレスの間のマッピングを追加または変更するために呼び出す必要がある URL を設定します。次に、DynDNS.org を使用してマッピング情報を追加または変更するために呼び出される URL を設定する例を示します。

http://userid:password@members.dyndns.org/nic/update?system = dyndns&hostname=<h>&myip=<a>

上記の URL ストリングを入力する必要があります。userid は使用するユーザ ID で、password は DynDNS.org Web サイトでのパスワードです。特殊文字のストリング <h> および <a> は、更新するホスト名と、そのホスト名が割り当てられる IP アドレスにそれぞれ置換されます。

(注) 疑問符(?)文字を入力する前に、キーボードの Ctrl キーと v キーを一緒に押します。これによって、ソフトウェアが ? をヘルプ照会と解釈せずに、? を入力できます。

ステップ 10

remove url

 

Router(DDNS-HTTP)# remove http://test:test@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

ホスト名と IP アドレスの間のマッピングを削除するために呼び出す必要がある URL を設定します。URL はステップ 8 の add キーワードと同じ形式になります。

ステップ 11

exit

 

Router(DDNS-HTTP)# exit

update-method コンフィギュレーション モードに戻ります。

ステップ 12

exit

 

Router(DDNS-update-method)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

interface interface-type number

 

Router(config)# interface ether1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

ip ddns update hosthame hostname

 

Router(config-if)# ip ddns update hostname abc.dyndns.org

アップデートに使用するホストを指定します。アップデートではこのホスト名が、インターフェイス上に設定された IP アドレスに関連付けられます。hostname 引数は、アップデートを受け取るホスト名を指定します(例:DynDNS.org)。

ステップ 15

ip ddns update name

 

Router(config-if) ip ddns update myupdate

このインターフェイス上でのアドレス変更に関連付けられたダイナミック DNS アップデートの送信に使用されるアップデート方式の名前を指定します。

ステップ 16

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

次に、アップデート方式、アップデートの最大間隔(グローバル)、およびインターフェイス上のホスト名を設定する例を示します。

ip ddns update method mytest
ddns
http
 
!Before entering the question mark (?) character in the add http CLI, press the control (Ctrl) key and the v key together on your keyboard. This will allow you to enter the ? without the software interpreting the ? as a help query.
 

add http://test:test@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 1 0 0 0
exit
interface ether1

ip ddns update hostname abc.dyndns.org

ip ddns update mytest

DDNS アップデートの確認

DDNS アップデートが実行されていることを確認するには、 debug ip ddns update コマンドを使用します。いくつかのサンプル設定と、そのシナリオで表示されるデバッグ出力を示します。

サンプル設定 #1

次のシナリオでは、クライアントが A DNS RR の IETF DDNS アップデート用に設定され、アップデート中に、DHCP サーバは PTR DNS RR を更新すると想定されています。更新するサーバの IP アドレスは指定されないため、DHCP クライアントは SOA RR ルックアップを使用して、更新する DNS サーバを検出します。DHCP クライアントは FQDN DHCP オプションを含むように設定され、A RR を更新することを DHCP サーバに通知します。

!Configure the DHCP Client
 
ip ddns update method testing
ddns
 
interface Ethernet1
ip dhcp client update dns
ip ddns update testing
ip address dhcp
end
 
!Configure the DHCP Server
 
ip dhcp pool test
network 10.0.0.0 255.0.0.0
update dns
 
!Enable Debugging
 
Router# debug ip ddns update
 
00:14:39:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.0.0.4, mask 255.0.0.0, hostname canada_reserved
00:14:39: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.4
00:14:39: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:14:42: DHCPC: Server performed PTR update
00:14:42: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.4
00:14:42: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:14:42: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:14:42: DDNS: Zone = hacks
00:14:42: DDNS: Prerequisite: canada_reserved.hacks not in use
00:14:42: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.4
00:14:42: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:14:42: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.4 finished
00:14:42: DYNDNSUPD: Another update completed (total outstanding=0)

サンプル設定 #2

次のシナリオでは、クライアントが A RR および DNS RR の両方の IETF DDNS アップデート用に設定され、DHCP サーバはいずれも更新しないことが要求されています。更新するサーバの IP アドレスは指定されないため、DHCP クライアントは SOA RR ルックアップを使用して、更新する DNS サーバを検出します。DHCP クライアントは、DHCP サーバに A RR または PTR RR を更新しないように指示する FQDN DHCP オプションを含むように設定されています。これはコマンドのグローバル バージョンを使用して設定されます。

!Configure the DHCP Client
 
ip dhcp-client update dns server none
 
ip ddns update method testing
ddns both
 
interface Ethernet1
ip ddns update testing
ip address dhcp
end
 
!Configure the DHCP Server
 
ip dhcp pool test
network 10.0.0.0 255.0.0.0
update dns
 
!Enable Debugging
 
Router# debug ip ddns update
 
00:15:33:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.0.0.5, mask 255.0.0.0, hostname canada_reserved
00:15:33: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.5
00:15:33: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:15:36: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.5
00:15:36: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '10.in-addr.arpa'
00:15:36: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:15:36: DDNS: Zone = 10.in-addr.arpa
00:15:36: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:15:36: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:15:36: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:15:36: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:15:36: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:15:36: DDNS: Zone = hacks
00:15:36: DDNS: Prerequisite: canada_reserved.hacks not in use
00:15:36: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.5
00:15:36: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:15:36: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.5 finished
00:15:36: DYNDNSUPD: Another update completed (total outstanding=0)

サンプル設定 #3

次のシナリオでは、クライアントが A RR および DNS RR の両方の IETF DDNS アップデート用に設定され、DHCP サーバはいずれも更新しないことが要求されています。DHCP クライアントは更新するサーバを明示的に指定しています。DHCP クライアントは、DHCP サーバに A RR または PTR RR を更新しないように指示する FQDN DHCP オプションを含むように設定されています。これはコマンドのグローバル バージョンを使用して設定されます。DHCP サーバはクライアント要求を上書き指定するよう設定され、A RR および PTR RR の両方を更新します。

!Configure the DHCP Client
 
ip dhcp client update dns server non
 
ip ddns update method testing
ddns both
 
interface Ethernet1
ip dhcp client update dns server none
ip ddns update testing
ip address dhcp
end
 
!Configure the DHCP Server
 
ip dhcp pool test
network 10.0.0.0 255.0.0.0
update dns both override
 
!Enable Debugging on the DHCP Client
 
Router# debug ip ddns update
 
00:16:30:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.0.0.6, mask 255.0.0.0, hostname canada_reserved
00:16:30: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.6
00:16:30: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:16:33: DHCPC: Server performed both updates

サンプル設定 #4

次のシナリオでは、クライアントが A RR および DNS RR の両方の IETF DDNS アップデート用に設定され、DHCP サーバはいずれも更新しないことが要求されています。DHCP クライアントは更新するサーバを明示的に指定しています。DHCP クライアントは、DHCP サーバに A RR または PTR RR を更新しないように指示する FQDN DHCP オプションを含むように設定されています。これはコマンドのグローバル バージョンを使用して設定されます。DHCP サーバは、クライアントが選択するすべての RR をクライアントが更新できるように設定されます。

!Configure the DHCP Client
 
ip dhcp client update dns server non
 
ip ddns update method testing
ddns both
 
interface Ethernet1
ip dhcp client update dns server none
ip ddns update testing host 172.19.192.32
ip address dhcp
end
 
!Configure the DHCP Server
 
ip dhcp pool test
network 10.0.0.0 255.0.0.0
update dns
 
!Enable Debugging on the DHCP Client
 
Router# debug ip ddns update
 
00:17:52:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.0.0.7, mask 255.0.0.0, hostname canada_reserved
00:17:52: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.6
00:17:52: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:17:55: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.7
00:17:55: DYNDNSUPD: Adding DNS mapping for canada_reserved.hacks <=> 10.0.0.7 server 10.19.192.32
00:17:55: DDNS: Enqueuing new DDNS update 'canada_reserved.hacks' <=> 10.0.0.7 server 10.19.192.32
00:17:55: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '11.in-addr.arpa'
00:17:55: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = 10.in-addr.arpa
00:17:55: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:17:55: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:17:55: DDNS: Zone name for '10.0.0.11.in-addr.arpa.' is '10.in-addr.arpa'
00:17:55: DDNS: Using server 10.19.192.32
00:17:55: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = 10.in-addr.arpa
00:17:55: DDNS: Prerequisite: 10.0.0.11.in-addr.arpa. not in use
00:17:55: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:17:55: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:17:55: DDNS: Dynamic DNS Update 1 (PTR) for host canada_reserved.hacks returned 6 (YXDOMAIN)
00:17:55: DDNS: Dynamic Update 2: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = 10.in-addr.arpa
00:17:55: DDNS: Update: delete 10.0.0.11.in-addr.arpa. all PTR RRs
00:17:55: DDNS: Update: add 10.0.0.11.in-addr.arpa. IN PTR canada_reserved.hacks
00:17:55: DDNS: Dynamic DNS Update 2 (PTR) for host canada_reserved.hacks returned 0 (NOERROR)
00:17:55: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:17:55: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = hacks
00:17:55: DDNS: Prerequisite: canada_reserved.hacks not in use
00:17:55: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.7
00:17:55: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:17:55: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.7 finished
00:17:55: DYNDNSUPD: Another update completed (total outstanding=1)
00:17:55: DDNS: Zone name for 'canada_reserved.hacks' is 'hacks'
00:17:55: DDNS: Using server 10.19.192.32
00:17:55: DDNS: Dynamic Update 1: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = hacks
00:17:55: DDNS: Prerequisite: canada_reserved.hacks not in use
00:17:55: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.7
00:17:55: DDNS: Dynamic DNS Update 1 (A) for host canada_reserved.hacks returned 6 (YXDOMAIN)
00:17:55: DDNS: Dynamic Update 2: (sending to server 10.19.192.32)
00:17:55: DDNS: Zone = hacks
00:17:55: DDNS: Update: delete canada_reserved.hacks all A RRs
00:17:55: DDNS: Update: add canada_reserved.hacks IN A 10.0.0.7
00:17:55: DDNS: Dynamic DNS Update 2 (A) for host canada_reserved.hacks returned 0 (NOERROR)
00:17:55: DDNS: Update of 'canada_reserved.hacks' <=> 10.0.0.7 finished
00:17:55: DYNDNSUPD: Another update completed (total outstanding=0)

サンプル設定 #5

次のシナリオでは、デバッグ出力は、デフォルト ドメイン名が「hacks」のときの内部ホスト テーブル アップデートを表示しています。「test」アップデート方式は、内部の Cisco IOS ホスト テーブルを更新する必要があることを指定しています。アップデート方式「test」の設定は、イーサネット 0/0 インターフェイス上のアドレスが変更するときに使用する必要があります。ホスト名は、このインターフェイス上のアップデートに対して設定されます。

ip domain name hacks
 
ip ddns update method test
internal
 
interface ethernet0/0
ip ddns update test hostname test2
ip addr dhcp
 
!Enable Debugging
 
Router# debug ip ddns update
 
*Jun 4 03:11:10.591:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet0/0 assigned DHCP address 10.0.0.5, mask 255.0.0.0, hostname test2
*Jun 4 03:11:10.591: DYNDNSUPD: Adding DNS mapping for test2.hacks <=> 10.0.0.5
*Jun 4 03:11:10.591: DYNDNSUPD: Adding internal mapping test2.hacks <=> 10.0.0.5
 

show hosts コマンドを使用すると、新しく追加されたホスト テーブル エントリが表示されます。

Router# show hosts
 
Default domain is hacks
Name/address lookup uses domain service
Name servers are 255.255.255.255
 
Codes: UN - unknown, EX - expired, OK - OK,?? - revalidate
temp - temporary, perm - permanent
NA - Not Applicable None - Not defined
 
Host Port Flags Age Type Address(es)
test2.hacks None (perm, OK) 0 IP 10.0.0.5
 

インターフェイスをシャットダウンすると、ホスト テーブル エントリが削除されます。

interface ethernet0/0
shutdown
 
*Jun 4 03:14:02.107: DYNDNSUPD: Removing DNS mapping for test2.hacks <=> 10.0.0.5
*Jun 4 03:14:02.107: DYNDNSUPD: Removing mapping test2.hacks <=> 10.0.0.5
 

show hosts コマンド出力では、エントリが削除されたことが示されています。

Router# show hosts
 
Default domain is hacks
Name/address lookup uses domain service
Name servers are 255.255.255.255
 
Codes: UN - unknown, EX - expired, OK - OK,?? - revalidate
temp - temporary, perm - permanent
NA - Not Applicable None - Not defined
 
Host Port Flags Age Type Address(es)

サンプル設定 #6

次のシナリオでは、デバッグ出力には HTTP スタイルの DDNS アップデートが示されています。サンプル設定では、アドレスを追加または変更するときに使用する URL を設定する、dyndns という名前の新しい IP DDNS アップデート方式が定義されます。アドレスを削除するときに使用する URL は、DynDNS.org でそのような URL を無料アカウントとして使用しないため、そのような URL は定義されていません。最大アップデート間隔が 28 日と設定されたため、アップデートの指定は少なくとも 28 日ごとに送信される必要があります。新しい dyndns アップデート方式の設定は、イーサネット インターフェイス用に使用する必要があります。


) 「add http」設定の update キーワードの後に疑問符(?)文字を入力する前に、キーボードから Ctrl キーおよび「v」キーを押す必要があります。これによって、ソフトウェアが ? をヘルプ照会と解釈せずに、? を入力できます。


!Configure the DHCP Client
 
ip ddns update method dyndns
http
add http://test:test@<s>/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval max 28 0 0 0
 
interface ethernet1
ip ddns update hostname test.dyndns.org
ip ddns update dyndns host members.dyndns.org
ip addr dhcp
 
!Enable Debugging
 
Router# debug ip ddns update
 
00:04:35:%DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP address 10.32.254.187, mask 255.255.255.240, hostname test.dyndns.org
00:04:35: DYNDNSUPD: Adding DNS mapping for test.dyndns.org <=> 10.32.254.187 server 10.208.196.94
00:04:35: DYNDNSUPD: Sleeping for 3 seconds waiting for interface Ethernet1 configuration to settle
00:04:38: HTTPDNS: Update add called for test.dyndns.org <=> 10.32.254.187
00:04:38: HTTPDNS: Update called for test.dyndns.org <=> 10.32.254.187
00:04:38: HTTPDNS: init
00:04:38: HTTPDNSUPD: Session ID = 0x7
00:04:38: HTTPDNSUPD: URL = 'http://test:test@10.208.196.94/nic/update?system=dyndns&hostname=test.dyndns.org&myip=10.32.254.187'
00:04:38: HTTPDNSUPD: Sending request
00:04:40: HTTPDNSUPD: Response for update test.dyndns.org <=> 10.32.254.187
00:04:40: HTTPDNSUPD: DATA START
good 10.32.254.187
00:04:40: HTTPDNSUPD: DATA END, Status is Response data received, successfully
00:04:40: HTTPDNSUPD: Call returned SUCCESS for update test.dyndns.org <=> 10.32.254.187
00:04:40: HTTPDNSUPD: Freeing response
00:04:40: DYNDNSUPD: Another update completed (outstanding=0, total=0)
00:04:40: HTTPDNSUPD: Clearing all session 7 info
 
!28 days later, the automatic update happens.
 
00:05:39: DYNDNSUPD: Adding DNS mapping for test.dyndns.org <=> 10.32.254.187 server 10.208.196.94
00:05:39: HTTPDNS: Update add called for test.dyndns.org <=> 10.32.254.187
00:05:39: HTTPDNS: Update called for test.dyndns.org <=> 10.32.254.187
00:05:39: HTTPDNS: init
00:05:39: HTTPDNSUPD: Session ID = 0x8
00:05:39: HTTPDNSUPD: URL = 'http://test:test@10.208.196.94/nic/update?system=dyndns&hostname=test.dyndns.org&myip=10.32.254.187'
00:05:39: HTTPDNSUPD: Sending request
00:05:39: HTTPDNSUPD: Response for update test.dyndns.org <=> 10.32.254.187
00:05:39: HTTPDNSUPD: DATA START
nochg 10.32.254.187
00:05:39: HTTPDNSUPD: DATA END, Status is Response data received, successfully
00:05:39: HTTPDNSUPD: Call returned SUCCESS for update test.dyndns.org <=> 10.32.254.187
00:05:39: HTTPDNSUPD: Freeing response
00:05:39: DYNDNSUPD: Another update completed (outstanding=0, total=0)
00:05:39: HTTPDNSUPD: Clearing all session 8 info

Cisco IOS ソフトウェアのためのダイナミック DNS サポートの設定例

ここでは、次の設定例について説明します。

「DHCP クライアントの設定:例」

「DHCP サーバの設定:例」

「HTTP アップデートの設定:例」

DHCP クライアントの設定:例

次に、アドレス プール「abc」から割り当てられたアドレスに対して DDNS アップデートが実行されない例を示します。アドレス プール「def」から割り当てられたアドレスには、フォワード(A)およびリバース(PTR)の両方のアップデートが実行されます。この設定は、グローバル サーバ設定よりも優先されます。

ip dhcp update dns both override
ip dhcp pool abc
network 10.1.0.0 255.255.0.0
!
update dns never
!
ip dhcp pool def
network 10.10.0.0 255.255.0.0

DHCP サーバの設定:例

次に、サーバだけで実行される A RR および PTR RR のアップデートを設定する例を示します。

ip dhcp-client update dns server both

ip dhcp update dns both override

HTTP アップデートの設定:例

次に、HTTP DDNS 用に PPPoE サーバを設定する例を示します。

!Username and Password for PPP Authentication Configuration
!
username user1 password 0 cisco
!
!DHCP Pool Configuration
 
ip dhcp pool mypool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
!VPDN configuration for PPPoE
 
vpdn enable
!
vpdn-group pppoe
accept-dialin
protocol pppoe
virtual-template 1
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
!Port used to connect to the Internet, it can be the same port that is under test, but to make the test clear and simple these two are separated.
!
interface FastEthernet0/0
ip address 10.0.58.71 255.255.255.0
!
!Port under test.
!
interface FastEthernet0/1
no ip address
pppoe enable
!
!Virtual template and address pool config for PPPoE.
 
interface Virtual-Template1
ip unnumbered Loopback0
ip mtu 1492
peer default ip address dhcp-pool mypool
ppp authentication chap
 

次に、IETF DDNS 用に DHCP クライアントを設定する例を示します。

!Default hostname of the router.
 
hostname mytest
!
!Default domain name on the router.
 
ip domain name test.com
!
!Port under test.
!
interface FastEthernet0/1
no ip address (configured to “ip address dhcp”)
 

次に、アップデートの方式およびアップデートの最大間隔(グローバル)を設定して、インターフェイス上のホスト名を設定する例を示します。


) 「add http」設定の update キーワードの後に疑問符(?)文字を入力する前に、キーボードから Ctrl キーおよび「v」キーを押す必要があります。これによって、ソフトウェアが ? をヘルプ照会と解釈せずに、? を入力できます。


ip ddns update method mytest
ddns
http

add http://test:test@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 1 0 0 0
exit
interface ether1

ip ddns update hostname abc.dyndns.org

ip ddns update mytest
 

次に、一部の HTTP DNS アップデート サービスの更新に使用できる URL の例を示します。これらの URL は、シスコで認識する限り正しいものですが、すべての事例がテストされているわけではありません。URL 内に示す「USERNAME:」という単語の場所では、HTTP サイトでのカスタマー アカウントのユーザ名を使用する必要があります。

URL 内に示す「PASSWORD」という単語の場所では、そのアカウントのカスタマー パスワードを使用する必要があります。


) 「add http」設定の update キーワードの後に疑問符(?)文字を入力する前に、キーボードから Ctrl キーおよび「v」キーを押す必要があります。これによって、ソフトウェアが ? をヘルプ照会と解釈せずに、? を入力できます。


DDNS

http://USERNAME:PASSWORD@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
!Requires “interval max 28 0 0 0" in the update method definition.

TZO

http://cgi.tzo.com/webclient/signedon.html?TZOName=<h>&Email=USERNAME&TZOKey=PASSWORD&IPAddress=<a>

EASYDNS

http://USERNAME:PASSWORD@members.easydns.com/dyn/ez-ipupdate.php?action=edit&myip=<a>&host_id=<h>

JUSTLINUX

http://USERNAME:PASSWORD@www.justlinux.com/bin/controlpanel/dyndns/jlc.pl?direst=1&username=USERNAME&password=PASSWORD&host=<h>&ip=<a>

DYNS

http://USERNAME:PASSWORD@www.dyns.cx/postscript.php?username=USERNAME&password=PASSWORD&host=<h>&ip=<a>

HN

http://USERNAME:PASSWORD@dup.hn.org/vanity/update?ver=1&IP=<a>

ZONEEDIT

http://USERNAME:PASSWORD@www.zoneedit.com/auth/dynamic.html?host=<h>&dnsto=<a>

) これらのサービスはそれぞれの会社によって提供されているため、URL が変更されることがあったり、サービスがいつでも切断される可能性があります。この情報の精度または利用について、シスコはいっさい責任を負いません。この URL は「ez-ipupdate」と呼ばれるアプリケーションを使用して取得されましたが、インターネット上で無料で利用できます。


その他の関連資料

ここでは、Cisco IOS ソフトウェアのためのダイナミック DNS サポート機能に関する関連資料について説明します。

関連資料

関連項目
参照先

DNS の設定作業

Configuring DNS 」モジュール

DNS コマンド:すべてのコマンド構文、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項および例

『Cisco IOS IP Addressing Services Command Reference』

規格

規格
タイトル

この機能によりサポートされた新規標準または改訂標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2136

Dynamic Updates in the Domain Name System (DNS Update)

RFC 3007

Secure Domain Name System (DNS) Dynamic Update

シスコのテクニカル サポート

説明
リンク

Technical Assistance Center(TAC)ホームページは、30,000 ページの技術コンテンツが検索可能で、製品、テクノロジー、ソリューション、技術的ヒント、およびツールへのリンクが含まれています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

コマンド リファレンス

次に示すコマンドは、このモジュールに記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS IP Addressing Command Reference 』( http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/iad_book.html )を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、または『 Cisco IOS Master Commands List 』を参照してください。

ddns(DDNS-update-method)

debug ip ddns update

host(host-list)

http(DDNS-update-method SLA)

internal(DDNS-update-method)

interval maximum

ip ddns update hostname

ip ddns update method

ip dhcp client update dns

ip dhcp-client update dns

ip dhcp update dns

ip host-list

show ip ddns update

show ip ddns update method

show ip host-list

update dns