Cisco Mobile Wireless Home Agent リリース 5.2 for Cisco IOS リリース 12.4(22)YD2
HA の冗長性
HA の冗長性
発行日;2012/02/02 | 英語版ドキュメント(2010/12/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

HA の冗長性

HA 冗長性の概要

HA セッション冗長性のインフラストラクチャ

HA セッション冗長性の制限

サポートされている冗長性イベント

バルク同期イベント

単一 IP の考慮事項

RADIUS ダウンロード プール名を使用した冗長性

HSRP グループ

HA 冗長性の動作方法

物理ネットワークのサポート

仮想ネットワーク

同じレルムの不連続 IP アドレス プールのサポート

ローカル プールのプライオリティ メトリック

ローカル プールのプライオリティ値の設定

HA 冗長性の設定

モバイル IP のイネーブル化

HSRP のイネーブル化

HSRP グループのアトリビュートの設定

物理ネットワークの HA 冗長性のイネーブル化

HA ロード バランシングの設定

HA 冗長性の設定例

ホットラインの冗長性サポート

QoS の冗長性サポート

コール アドミッション制御(CAC)の冗長性サポート

Framed-Pool 基準の冗長性サポート

ローカル プールのプライオリティ メトリックの冗長性サポート

モバイル IPv4 ホスト設定拡張の冗長性サポート

WiMAX AAA アトリビュートの冗長性サポート

SAMI 移行の冗長性サポート

HA の冗長性

この章では、Home Agent(HA)の冗長性、HA の冗長性の実現方法、および Cisco Mobile Wireless Home Agent に冗長性を設定する方法について説明します。

この章は、次の内容で構成されています。

「HA 冗長性の概要」

「HA セッション冗長性のインフラストラクチャ」

「HA セッション冗長性の制限」

「サポートされている冗長性イベント」

「バルク同期イベント」

「単一 IP の考慮事項」

「RADIUS ダウンロード プール名を使用した冗長性」

「HSRP グループ」

「HA 冗長性の動作方法」

「物理ネットワークのサポート」

「仮想ネットワーク」

「同じレルムの不連続 IP アドレス プールのサポート」

「ローカル プールのプライオリティ メトリック」

「HA 冗長性の設定」

「HA 冗長性の設定例」

HA 冗長性の概要

1:1 の冗長性を提供するようシスコ HA を設定できます。Cisco Hot Standby Routing Protocol(RFC 2281 の HSRP)に基づいて、2 つの HA はホットスタンバイ モードで設定されます。これにより、アクティブ HA をイネーブルにして、モバイル セッション関連の情報をスタンバイ HA に連続してコピーし、両方の HA で同期化されたステート情報を維持します。アクティブな HA に障害が発生した場合、スタンバイ HA はサービスを中断させることなく引き継ぎます。


) モバイル IP HA 冗長性機能の NAI サポートは、HA 冗長性に CDMA2000 固有の機能を提供します。CDMA2000 フレームワークは、NAI に基づいてアドレスを割り当て、ユーザ NAI ごとに複数のスタティック IP アドレスをサポートする必要があります。


HA 冗長性機能は、スタティック IP アドレスの割り当てと AAA による IP アドレスの割り当てでサポートされます。Release 2.0 以降、HA 冗長性機能は、ローカル IP アドレス プールを使用したダイナミック IP アドレスの割り当てと、プロキシ DHCP を使用したダイナミック IP アドレスの割り当てでサポートされます。

HA 冗長性にプロキシ DHCP を使用したダイナミック IP アドレスの割り当てが設定されている場合、バインディングがスタンバイ HA に同期化されても、バインディングの起動中は DHCP 情報はスタンバイとは同期化されません。ただし、スタンバイ HA がアクティブになると、この HA の DHCP 関連情報をアップデートするため、既存の各バインディングの DHCP 要求が DHCP サーバに送信されます。

モバイル IP 登録プロセス中、HA は、Mobile Node(MN; モバイル ノード)のホーム IP アドレスを現在の MN の Care-of Address(CoA; 気付アドレス)にマッピングするモビリティ バインディング テーブルを作成します。HA に障害が発生した場合、モビリティ バインディング テーブルが失われ、HA に登録されたすべての MN は接続を失います。HA の障害による影響を削減するため、Cisco IOS ソフトウェアは HA 冗長性機能をサポートします。


) Cisco 7600 シリーズ プラットフォームに基づいた設定では、バックアップ HA イメージはプライマリと異なる Service Application Module for IP(SAMI)カードに設定されます。


HA 冗長性の機能は、Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)のトップで動作します。HSRP はシスコが開発したプロトコルであり、ユーザ トラフィックがただちに透過的に障害から回復できる方法でネットワークの冗長性を提供します。


) Cisco Home Agent Release 5.0 以上でサポートされている冗長機能は、MIP-LAC、モバイル ルータ、VPN Routing and Forwarding(VRF; VPN ルーティングおよびフォワーディング)、L2TP Network Server(LNS; L2TP ネットワーク サーバ)としての Home Agent、および HA アカウンティング機能以外、Release 4.0 でサポートされているものと同じです。Change of Authorization 機能と Packet of Disconnect 機能は、アカウンティング機能から独立しているため、引き続きサポートされます。アクティブとスタンバイの冗長性の相互動作は、アクティブとスタンバイのサービス ブレードのコントロール プロセッサ間で行われます。このリリースでは、HA アカウンティング機能がサポートされないため、トラフィック間のプロセッサの冗長性は必要ありません。



) HA Release 5.0 以上は、シャーシ内とシャーシ間の冗長性をどちらもサポートします。


HA セッション冗長性のインフラストラクチャ

HA セッション冗長性の制限

リリース 4.0 までの HA ステートフル セッション冗長性は HSRP で実装されていました。この実装で、アクティブ HA とスタンバイの HA 間の転送はホーム エージェント アプリケーションによって実装されていました。UDP/IP ベースの転送実装には次の制限があります。

バルク同期シナリオの不整合。たとえば、バルク同期の実行中にアクティブでバインディングが削除されると、バルク同期完了時にアクティブおよびスタンバイでのバインディングの数が一貫しなくなります。

複数パケット同期データの同期不能。これは、ホットライニング ルールの同期時に見られます。ホットライニング ルールの数が多いと、同期に必要なデータの長さが 1 つのパケットに収まるよりも大きくなります。複数パケットに断片化されたこのようなデータを同期化する能力は、冗長転送で実装されているパケット シーケンシング、フラグメンテーション、およびデフラグメンテーションのサポートの欠如により一貫しません。

セッション冗長性インフラストラクチャ機能拡張では、以前に述べた制限が廃止されています。Home Agent 5.0 リリースで HA SR インフラストラクチャは Component Cluster Manager(CCM)で実装されています。CCM ソフトウェアは、Redundancy Framework(RF; 冗長フレームワーク)/RF-Interdev および Check-Pointing Facility(CF)/Stream Control Transport Protocol(SCTP)を含む IOS ハイ アベイラビリティ インフラストラクチャ上に構築されています。RF/RF-Interdev は冗長性コントロール シグナリングを処理し、CF/SCTP は転送メカニズムを提供します。この HA SR の改正は、堅牢な転送、シャーシ間とシャーシ内の冗長性のサポートなど、IOS ハイ アベイラビリティ機能の利点となります。

サポートされている冗長性イベント

次に、既存の HA 4.0 冗長性イベントについて説明します。5.0 機能に実装された新機能により発生する新しい冗長性イベントについては、その機能についての項で説明します。

ダイナミック同期イベント

バインディングの作成

この同期は、アクティブからスタンバイへの IPMOBILE_BINDUPDATE_REQ メッセージを使用して伝えられます。スタンバイは PMOBILE_BINDUPDATE_ACK を使用してバインディングの再作成に成功したことを確認応答します。

バインディングの削除

この同期は、アクティブからスタンバイへの IPMOBILE_BINDDELETE_REQ メッセージを使用して伝えられます。スタンバイはアクティブへの IPMOBILE_BINDDELETE_ACK メッセージを使用してバインディングの削除に成功したことを確認応答します。

バインディングのアップデート

ホットライン ステータスのアップデート結果としての CoA に起因します。バインディングのホットライン ステータスがアップデートされる CoA メッセージをアクティブ HA が受信すると、IPMOBILE_BINDINTERIM_REQ メッセージを使用して既存のバインディング日付のアップデートがスタンバイに伝えられます。スタンバイは上記のメッセージを受信し、既存のバインディングをアップデートして、IPMOBILE_BINDINTERIM_ACK を使用してアップデート ステータスを伝えます。

アカウンティング カウンタの同期化の結果としてのバインディングのアップデート

コールの継続時間中にアカウンティング カウンタがアップデートされると、すべてのアカウンティング アップデート メッセージが IPMOBILE_BINDSYNC_REQ メッセージをスタンバイに送ります。ここには、スタンバイへのアップデートされたカウンタが含まれます。スタンバイはバインディングのためにカウンタをアップデートし、IPMOBILE_BINDSYNC_ACK メッセージを使用してアップデートのステータスをアップデートします。

表 6-1 に、上記のダイナミック同期イベントのために実装された新しい同期イベントをまとめています。

表 6-1 ダイナミック同期イベント

現在のイベント名
新しいイベント名
コメント

IPMOBILE_BINDUPDATE_REQ、

IPMOBILE_BINDUPDATE_ACK

IPMOBILE_BIND_CREATE

バインディング作成の同期化のために使用します。

IPMOBILE_BINDINTERIM_REQ、

IPMOBILE_BINDINTERIM_ACK

IPMOBILE_BIND_HOTLINE_UPDATE

CoA 処理に起因するバインディング アップデートの同期化のために使用します。

IPMOBILE_BINDDELETE_REQ、

IPMOBILE_BINDDELETE_ACK

IPMOBILE_BIND_DELETE

このイベントは、De-Registration、Packet of Disconnect(PoD; パケット オブ ディスコネクト)、または Revocation の存在下で同期します。バインディングの削除は、このメッセージを使用して伝えられます。

IPMOBILE_BINDSYNC_ REQ、

IPMOBILE_BINDSYNC_ ACK

このリリースではサポートされていません

このイベントはアカウンティング カウンタの同期に使用されます。ただし、同期化された HA アカウンティング カウンタは 5.0 ではサポートされません。

IPMOBILE_BINDINTERIM_EXTND_REQ

サポートされていません

同期メッセージ サイズが大きく、複数のパケットで送信する必要がある場合に、同期にこの要求が使用されます。これは、新しい SR では必要ありません。

バルク同期イベント

ルータがスタンバイとしてアップすると、IPMOBILE_BINDINFO_REQ を既存のアクティブに送信し、既存のバインディングをすべて取得します。アクティブは IPMOBILE_BINDINFO_RSP メッセージで応答します。これにはバインディング情報が含まれています。スタンバイは IPMOBILE_BINDINFO_RSP メッセージを処理して、その上でバインディングを再作成し、IPMOBILE_BINDINFO_ACK メッセージで再作成のステータスをアクティブに応答します。アクティブがホストできるバインディングの数は、500K に上ります。このため、バルク同期プロセス中、複数の IPMOBILE_BINDINFO_RSP メッセージと IPMOBILE_BINDINFO_ACK メッセージがアクティブとスタンバイ間でやり取りされます。新しい実装中、アクティブは各バインディングの IPMOBILE_BIND_CREATE イベントをバインド同期情報を持つスタンバイと同期します。

CCM ソフトウェアは、アクティブからスタンバイへのバインディングの同期中に、バルク同期プロセスをバンドリング モードで実装します。このプロセスは、HA アプリケーションに対して完全に透過的です。バンドリング モードで、CCM は同期パケットごとに複数のバインディング情報をスタンバイ CCM に送ります。また、CCM は CLI を使用して、バルク同期プロセスをコントロールします。バルク同期プロセスが cpu を独占する場合、オペレータは CLI 冗長性レートを使用できます。

subscriber redundancy rate # of Sessions Per Unit Time

このコマンドはバルク同期プロセスをコントロールします。バルク同期プロセス中に同期するバインディングの数が多い場合、#Sessions Per Unit Time 以上は同期しません。このコマンドは、バルク同期プロセスによって CPU が過負荷にならないようにします。

同期イベントの動作

新しい SR インフラストラクチャで、スタンバイはアクティブからのイベントとメッセージのレシーバーとして動作します。スタンバイがステータスや確認応答メッセージをアクティブに送信して、アクティブからの同期イベントの処理ステータスを伝えることはありません。このため、スタンバイからの IPMOBILE_BINDUPDATE_ACK、IPMOBILE_BINDINTERIM_ACK、IPMOBILE_BINDDELETE_ACK メッセージを新しいフレームワークで使用し続けることができません。これは、HA 4.0 リリースからの大きな変更です。アクティブ HA は、スタンバイが同期メッセージを正常にデコードし、バインディングを再作成、アップデート、削除できることを前提としています。

単一 IP の考慮事項

HA 単一 IP アーキテクチャで、SAMI ブレードは Control Plane(CP; コントロール プレーン)と Traffic Plane(TP; トラフィック プレーン)という2 つの論理エンティティに分割されます。物理的に、CP 機能はSAMI ブレードの 6 PPC の最初にあり、後の 5 PPC は TP 処理を行います。トラフィック プレーン(TP)プロセッサが 5 つの PPC に分散されたトラフィックを処理する間に、CP プロセッサはコントロール シグナリング(バインディングすべてに関連した登録、登録解除、CoA、PoD など)をすべて処理します。

SR の観点から、冗長性コンテキストはアクティブとスタンバイの両方の CP 上にあります。このため、冗長性コントロール シグナリングと SCTP チャネルはアクティブとスタンバイの 2 つの CP 間で発生します。スタンバイ上の CP でバインディングの作成、アップデート、削除を動的に同期させるのは、アクティブ上の CP の役割です。同期メッセージを受信した場合、アクティブ CP がバインディングを TP に伝達するのと同じような方法で、TP 上のバインディングを伝達するのはスタンバイ上の CP の役割です。

単一 IP 機能は HA ソフトウェアに組み込まれていますが、これはアーキテクチャに関連付けられた、プラットフォーム固有の機能です。モバイル IP 冗長性設計は、アーキテクチャ固有部分に左右されません。

RADIUS ダウンロード プール名を使用した冗長性

Cisco Mobile Wireless HA は、アドレス割り当ての AAA ダウンロード可能プール名をサポートします。アドレス割り当ての access accept で戻された radius pool-name アトリビュートは、ダイナミック アドレス割り当ての "ip-pool" と、スタティック アドレス許可の "static-ip-pool" です。access accept で HA に戻されたプール名は、通常のバルク同期動作中にスタンバイ HA に同期化されます。これは、スタンバイ HA の同じプールからのアドレス割り当てもイネーブルにします。

HSRP グループ

HA 冗長性を設定する前に、HSRP グループの概念を理解しておく必要があります。

HSRP グループは、IP アドレスと Media Access Control(MAC; メディア アクセス制御)(レイヤ 2)アドレスを共有し、単一の仮想ルータとして機能する、複数のルータで構成されます。たとえば、モバイル IP トポロジには、1 つのアクティブ HA と、トポロジの残りが単一の仮想 HA として表示する 1 つまたは複数のスタンバイ HAを含めることができます。

モバイル IP が冗長性を実装できるように、HA のインターフェイスの所定の HSRP グループのアトリビュートを定義する必要があります。グループを使用して、グループ(物理ネットワーク)ネットワークまたは仮想ネットワークのどちらかのインターフェイス上にホーム リンクのある MN に冗長性を提供します。仮想ネットワークは、プログラミングされ、一般的な物理インフラストラクチャを共有する論理回線です。

HA 冗長性の動作方法

HA 冗長性機能を使用すると、1 つのアクティブ HA と1 つまたは複数のスタンバイ HA を設定できます。冗長グループの HA は、HA が物理ネットワークをサポートする場合はアクティブ HA/スタンバイ HA のロールに、仮想ネットワークをサポートする場合はピア HA/ピア HA ロールに設定できます。

物理ネットワークをサポートする場合、アクティブ HA は 中心的な HA ロールを想定し、スタンバイ HA を同期化します。仮想ネットワークをサポートする場合、ピア HA は中心的な HA ロールを共有し、互いに「アップデート」します。どちらかの HA が Registration Request(RRQ; 登録要求)を受信するので、ピア HA 設定では着信 RRQ のロード バランシングが可能になります。いずれのシナリオでも、冗長グループに参加する HA は同様に設定する必要があります。現在のサポート構造は 1:1 で、フェールオーバー時に最大のロバストネスと透過性を提供します。

HA 機能は、ルータが提供するサービスでインターフェイス固有ではありません。したがって、HA および MN は、MN が登録要求を送信する HA インターフェイスと、反対に HA が登録要求を受信する HA インターフェイスに同意する必要があります。この同意は次の 2 つのシナリオを考慮する必要があります。

MN には、MN と同じサブネット上にない HA インターフェイス(HA IP アドレス)があります。

MN は、MN と同じサブネット上に HA インターフェイスを配置する必要があります。つまり、HA と MN は同じホーム ネットワーク上にいる必要があります。

物理ネットワークの MN の場合、アクティブ HA は MN からの登録要求を受け入れ、バインディング アップデートをスタンバイ HA に送信します。このプロセスでは、同期化されたアクティブおよびスタンバイ HA でモビリティ バインディング テーブルが維持されます。

仮想ネットワークの MN の場合、アクティブおよびスタンバイ HA はピアです。どちらかの HA が MN からの登録要求を処理し、モビリティ バインディング テーブルをピア HA でアップデートできます。

スタンバイ HA がアップすると、アクティブ HA からすべてのモビリティ バインディング情報を要求する必要があります。アクティブ HA は、モビリティ バインディング テーブルをスタンバイ HA にダウンロードすることで応答します。スタンバイ HA は、要求したバインディング情報を受信したことを確認応答します。図 1 に、モビリティ バインディングをスタンバイ HA にダウンロードするアクティブ HA を示します。この段階のプロセスの懸念事項は、スタンバイ HA が適切なモビリティ バインディング テーブルを取得するのに使用する HA IP インターフェイスと、バインディング要求が送信されるスタンバイ HA のインターフェイスです。

図 1 HA 冗長性およびモビリティ バインディング プロセスの概要

 


) アクティブ HA/スタンバイ HA はピア HA/ピア HA 構成にすることもできます。


物理ネットワークのサポート

物理ネットワークの MN の場合、HA は図 2 および図 3 で示すアクティブ HA/スタンバイ HA 設定で設定されます。この物理ネットワークでサポートされる MN は、HA アドレスとして HSRP 仮想グループ アドレスで設定されます。したがって、HSRP 仮想グループ アドレスの所有者になるので、アクティブ HA だけが MN から RRQ を受信できます。認証された RRQ を受信すると、アクティブ HA はバインディング アップデートをスタンバイ HA に送信します。

アクティブ ステートである HA が 1 つだけで、スタンバイ ステートである HA が 1 つだけであっても、物理ネットワークの HA 冗長性は、冗長グループ内の複数の HA をサポートできます。たとえば、冗長グループに 4 つの HA があるシナリオを想定します(アクティブ HA が 1 つ、スタンバイ HA が 1 つ、リスニング ステートである HA が 2 つ)。アクティブ HA に障害が発生すると、スタンバイ HA がアクティブ HA になり、リスニング ステートで高いプライオリティのある HA がスタンバイ HA になります。

図 2 1 つの物理ネットワーク(ピア HA/ピア HA)を使用した仮想ネットワークのサポート

 

図 3 複数の物理ネットワーク(ピア HA/ピア HA)を使用した仮想ネットワークのサポート

 

仮想ネットワーク

各 MN の モバイル IP コールは、MN のホーム IP アドレスの割り当て元であるホーム ネットワークに関連付けられています。これは物理ネットワークを想定していますが、ほとんどの展開の場合、各 MN を物理ネットワークに接続する意味はありません。IOS モバイル IP は、仮想ネットワークと呼ばれるソフトウェア インターフェイスの作成をサポートします。仮想ネットワークは、ループバック インターフェイスと非常に類似していますが、モバイル IP プロセスが所有します。仮想ネットワークを使用すると、Interface Descriptor Block(IDB; インターフェイス記述ブロック)を保存し、パケットのドロップ方法についてモバイル IP 固有の制御を実行できます。仮想ネットワークを使用すると、モバイル ノードは必ずローミングと見なされ、ホーム ネットワークに接続できません。実際の展開では、これにより一部の問題が発生します。たとえば、セルラー展開では、ユーザはホーム コーリング エリアにいますが、モバイル IP の観点ではローミングします。

仮想ネットワークは、ネットワーク数とマスク ペアによって設定され、参照されます。冗長目的で、仮想ネットワークと HA アドレスを関連付けることもできます。次に、例を示します。

ip mobile virtual-network 10.0.0.0 255.255.255.0 address 192.168.100.1
ip mobile host 10.0.0.1 10.0.0.254 virtual-network 10.0.0.0 255.255.255.0
 

仮想ネットワーク ルートはモバイル IP ルーティング プロセスによって所有されているので、伝播するため他のルーティング プロトコルに再配信する必要があります。次に、例を示します。

router rip
redistribute mobile
 

同じレルムの不連続 IP アドレス プールのサポート

NAI を使用したモバイルが不連続 IP アドレス範囲のプールから割り当てられたホーム アドレスを持つことができるように、この機能では同じレルムの不連続 IP アドレス プールを指定できます。これにより、HA は同じホスト グループの複数の仮想ネットワークに属するモバイルを受け入れることができます。

これを実行するには、複数の仮想ネットワークの IP アドレス範囲をカバーした HA でローカル プールを設定し、所定のレルムのホーム ネットワークとして仮想ネットワークの 1 つを指定します。

次の設定を使用して、HA は同じホスト グループの複数の仮想ネットワークに属する MN を受け入れることができます。

ip local pool pool1 10.1.1.1 10.1.1.250
ip local pool pool1 10.1.2.1 10.1.2.250
 
ip mobile home-agent
ip mobile virtual-network 10.1.1.0 255.255.255.0
ip mobile virtual-network 10.1.2.0 255.255.255.0
ip mobile host nai @xyz.com address pool local pool1 virtual-network 10.1.1.0 255.255.255.0 aaa lifetime 65535
 

上記の設定では、2 つの仮想ネットワークが設定され、ローカル プール(pool1)は両方の仮想ネットワークの IP アドレスを含めるよう設定されます。ip mobile host コマンドで仮想ネットワークの 1 つとローカル プール名を指定することで、HA は同じレルムの両方のネットワークに属する MN を受け入れます。

ローカル プールのプライオリティ メトリック

アドレッシング スキームをダイナミックに変更する機能をサポートするには、ローカル アドレス プールのプライオリティ メトリックを設定します。これにより、新しいアドレス スキームのある高プライオリティ アドレス プールを作成します。新しいバインディングはこの新しいアドレス プールを使用します。既存のサブスクライバは切断されるまで、現在のアドレスを使用し続けます。再接続時、新しいプールからアドレスが割り当てられます。すべてのサブスクライバが古いアドレス プールをエージング アウトすると、プールは削除されます。

現在、異なるアドレッシング スキーム(アドレス範囲)が同じプール名の下に設定され、IP アドレスが設定順でプールから割り当てられます。まず、最初に設定されたアドレス範囲を使用して IP アドレスを割り当てます。すべてのアドレスを使用したら、以後の範囲を使用して IP アドレスを割り当てます。

上記のデフォルト動作を上書きし、異なるアドレス スキームを持つようサブスクライバを設定するには、プライオリティ値をプールに設定します。これにより、新しい登録要求が来たときに希望のプールから IP アドレスを割り当てることができるように、低いプライオリティ プールよりも高いプライオリティ プールを優先して使用できます。

デフォルトでは、プライオリティ値 255(高プライオリティ)が新しく作成されたローカル プールに割り当てられます。このプールのプライオリティ値は 1 ~ 255 です。0 は低いプライオリティで、255 は高いプライオリティです。

次に、例を示します。

ip local pool hapool 1.0.0.0 1.0.0.255
ip local pool hapool 2.0.0.0 2.0.0.255
 

この例では、プライオリティ 255 を持ったローカル プールを作成します。複数のアドレス スキームのプライオリティが同じである場合、IP アドレスは設定順に割り当てられます。まず、255 のホストすべてが最初のプールから割り当てられ、2 番目のプールは以後の要求に使用されます。

ip local pool hapool 1.0.0.0 1.0.0.255 priority 200
ip local pool hapool 2.0.0.0 2.0.0.255 priority 100
 

この例では、プライオリティ 255 を持ったローカル プールを作成します。この場合、IP アドレスはプライオリティ順に割り当てられます。まず、255 のホストすべてが 2 番目のプール(高プライオリティ 100)から割り当てられ、最初のプール(プライオリティ 200)は以後の要求に使用されます。

ローカル プールのプライオリティ値の設定

ローカル プールのプライオリティ値を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

Router(config)#ip local pool {default | poolname} [low-ip-address [high-ip-address]] [group group-name] [cache-size size] [priority 1-255] [theshold low-threshold high-threshold]

リモート ピアが point-to-point(p2p; ポイントツーポイント)インターフェイスに接続したときに使用され、プール使用率が上限または下限しきい値(パーセント単位)に達したときにトラップを生成するよう、IP アドレスのローカル プールを設定します。

新しいオプション priority 1-255 により、プライオリティを新しく作成されたプールに割り当てることができます。このプライオリティは IP アドレスの割り当てに使用されます。

HA 冗長性の設定

HA 冗長性の設定手順(モバイル IP に必須)

ルータにモバイル IP HA 冗長性を設定するには、次のセクションで説明する手順を実行します。

「モバイル IP のイネーブル化」(必須)

「HSRP のイネーブル化」(必須)

「HSRP グループのアトリビュートの設定」

「物理ネットワークの HA 冗長性のイネーブル化」(必須)

「HA ロード バランシングの設定」


) Cisco IOS Release 12.4(22)YD2 では、auto-sync all コマンドはデフォルトでディセーブルになっています。


モバイル IP のイネーブル化

ルータでモバイル IP をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

コマンド
目的

ステップ 1

Router(config)#router mobile

ルータでモバイル IP をイネーブルにします。

HSRP のイネーブル化

インターフェイスで HSRP をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)#standby [group-number] ip ip-address

 

HSRP をイネーブルにします。

HSRP グループのアトリビュートの設定

ローカル ルータの HSRP への参加方法に影響を与える HSRP グループのアトリビュートを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドのいずれかを使用します。

コマンド
目的

ステップ 1

Router(config-if)#standby [group-number] priority

priority [preempt [delay [minimum | sync] delay]]

or

 

Router(config-if)#standby [group-number] [priority

priority] preempt [delay [minimum | sync]

delay]

アクティブ ルータの選択に使用するホットスタンバイ プライオリティを設定します。デフォルトでは、後でアップするルータはスタンバイになります。1 つのルータがアクティブ HA として指定されると、プライオリティは HSRP グループで最高位に設定され、プリエンプションが設定されます。ルータがアクティブになる前にすべてのバインディングがルータにダウンロードされるよう、preempt delay min コマンドを設定します。すべてのバインディングがダウンロードされる、またはいずれか早い方のタイマーが期限切れになると、ルータはアクティブになります。

ステップ 2

Router(config-if)# standby group-number follow group-name

 

follow グループの番号と、follow および共有ステータスに対するプライマリ グループの名前を指定します。

指定したグループ番号とプライマリ グループ番号が同じであることを推奨します。

物理ネットワークの HA 冗長性のイネーブル化

物理ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)#standby [group-number] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name

スタンバイ グループの名前を設定します。

ステップ 3

Router(config)#ip mobile home-agent redundancy

HA の冗長性をイネーブルにします。

ステップ 4

Router(config)# redundancy inter-device

scheme standby hsrp-group-name

 

ipc zone default

association 1

no shutdown

protocol sctp

local-port local-port-no

local-ip local-ip-address

remote-port remote-port-no

remote-ip remote-ip-address

HA 上で RF-Interdev を設定します。HA 冗長性は RF-Interdev 上に構築されます。

HA ロード バランシングの設定

HA ロード バランシング機能をイネーブルにするには、次の手順を実行します。

コマンド
目的

ステップ 1

Router(config)# ip mobile home-agent dynamic-address ip address

登録応答パケットの Home Agent Address フィールドを設定します。Home Agent Address フィールドを ip address に設定します。

HA 冗長性の設定例

アクティブ HA の設定

 
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
boot-start-marker
boot-end-marker
!
!
redundancy inter-device
scheme standby cisco
!
!
!
redundancy
no keepalive-enable
logging message-counter syslog
!
!
ipc zone default
association 1
no shutdown
protocol sctp
local-port 5000
local-ip 10.0.0.2
remote-port 5000
remote-ip 10.0.0.3
!
!
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
no auto-sync all
!
ip subnet-zero
ip cef
!
interface GigabitEthernet0/0.10
description to PDSN/FA
encapsulation dot1Q 10
ip address 10.0.0.2 255.0.0.0
standby ip 10.0.0.4
standby priority 110
standby preempt delay min 100
standby name cisco
!
interface GigabitEthernet0/0.172
description to AAA
encapsulation dot1Q 172
ip address 172.16.1.8 255.255.0.0
!
router mobile
!
ip local pool ha-pool 10.0.0.1 10.0.0.254
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy
ip mobile host nai mwts-mip-np-user1@ispxyz.com static-address 40.0.0.1 interface Ethernet2/0 aaa
!
radius-server host 172.16.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!
end

 

スタンバイ HA の設定

~~~~~~~~~~~~~~~~~~~~
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
!
ip subnet-zero
ip cef
!
interface GigabitEthernet0/0.10
description to PDSN/FA
encapsulation dot1Q 10
ip address 10.0.0.2 255.0.0.0
standby ip 10.0.0.4
standby name cisco
!
interface Ethernet2/2
description to AAA
ip address 172.16.1.7 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex half
!
router mobile
!
ip local pool ha-pool 10.0.0.1 10.0.0.255
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy
ip mobile host nai mwts-mip-np-user1@ispxyz.com static-address 40.0.0.1 interface Ethernet2/0 aaa
prefix-suffix
!
radius-server host 172.16.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!
end
 

) HA Release 5.0 以上では、冗長性のために ip mobile secure home-agent コマンドを設定する必要はありません。


ホットラインの冗長性サポート


) Home Agent Release 5.1 は、3gpp2 バインディングと WiMax バインディングの両方のホットライニングに対する冗長性をサポートします。


QoS の冗長性サポート

Home Agent Release 4.0 以上では、アクティブ HA とスタンバイ HA の間のダイナミック実行時ポリシーマップ情報の連続したアップデートに関連する、フロー ベースの QoS(Quality of Service)ポリシングはサポートされません。HA は通常のバルク同期しかサポートしないので、ポリシング データまたはカウンタ統計情報の定期的なアップデートの正確度は低くなります。

コール アドミッション制御(CAC)の冗長性サポート

現在、Call admission control(CAC; コール アドミッション制御)の冗長性をサポートする必要はありません。ただし、バックアップ HA は自身のステートを維持します。

Framed-Pool 基準の冗長性サポート

冗長性はこの機能でサポートされます。追加コマンドをイネーブルにして、この機能をサポートする必要はありません。

ローカル プールのプライオリティ メトリックの冗長性サポート

冗長性はこの機能でサポートされます。追加コマンドをイネーブルにして、この機能をサポートする必要はありません。

モバイル IPv4 ホスト設定拡張の冗長性サポート

冗長性はこの機能でサポートされます。追加コマンドをイネーブルにして、この機能をサポートする必要はありません。

WiMAX AAA アトリビュートの冗長性サポート

冗長性はこの機能でサポートされます。追加コマンドをイネーブルにして、この機能をサポートする必要はありません。

HA 冗長性がイネーブルである場合、アクティブからのアクセス要求および Accounting メッセージに含まれるすべてのアトリビュートも、スイッチオーバー後のスタンバイからの対応するメッセージに含まれます。さらに、中間アカウンティング メッセージが、アクティブから送信されるのと同じインターバルでスタンバイから送信されます。これを実行するには、次のアトリビュートの値をスタンバイに同期化します。

Chargeable User Identity(89)

Acct-Multi-Session-Id(50)

Acct-Interim-Interval(85)

SAMI 移行の冗長性サポート

シームレス移行に冗長性を設定し、サービスの中断を避ける必要があります。SAMI プラットフォームへの移行の詳細については、「 Home Agent(HA)の設定プランニング」の「ユーザの移行」を参照してください。