Cisco GGSN リリース 9.2 コンフィギュレーション ガイド
GGSN でのロード バランシングの設定
GGSN でのロード バランシングの設定
発行日;2012/02/06 | 英語版ドキュメント(2011/01/03 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

GGSN でのロード バランシングの設定

GTP ロード バランシングの概要

Cisco IOS SLB の概要

GTP ロード バランシングの概要

サポートされる GTP ロード バランシング タイプ

GTP ロード バランシングでサポートされる Cisco IOS SLB アルゴリズム

Cisco IOS SLB の Dynamic Feedback Protocol

GTP IMSI スティッキ データベース サポート

GTP APN 認識ロード バランシング

GTP SLB の制約事項

GTP ロード バランシングの設定

GTP ロード バランシング設定の作業リスト

設定ガイドライン

GTP ロード バランシング用の Cisco IOS SLB の設定

サーバ ファームおよび実サーバの設定

仮想サーバの設定

GSN アイドル タイマーの設定

DFP サポートの設定

GTP APN 認識ロード バランシングの設定

Cisco IOS SLB 設定の確認

GTP ロード バランシング用の GGSN の設定

GTP SLB のループバック インターフェイスの設定

GGSN での DFP サポートの設定

GGSN から Cisco IOS SLB へのメッセージングの設定

Cisco IOS SLB 機能のモニタリングおよびメンテナンス

設定例

Cisco IOS SLB の設定例

GGSN1 の設定例

GGSN でのロード バランシングの設定

この章では、Cisco IOS ソフトウェアの Server Load Balancing(SLB; サーバ ロード バランシング)機能を使用して、ロード バランシング機能をサポートするように Gateway GPRS Support Node(GGSN; ゲートウェイ GPRS サポート ノード)を設定する方法について説明します。GPRS Tunneling Protocol(GTP; GPRS トンネリング プロトコル)ロード バランシングによって、General Packet Radio Service(GPRS; グローバル パケット ラジオ サービス)/Universal Mobile Telecommunication System(UMTS)ネットワークで複数の Cisco GGSN またはシスコ以外の GGSN を使用する場合の信頼性と可用性が向上します。

この章に記載されている GGSN コマンドの詳細については、使用している Cisco GGSN リリースの『 Cisco GGSN Command Reference 』を参照してください。この章に記載されている他の Cisco IOS SLB コマンドの詳細については、「 IOS Server Load Balancing 」フィーチャ モジュールを参照してください。

この章に記載されているその他のコマンドのマニュアルを参照するには、コマンド リファレンスのマスター インデックスを使用するか、またはオンラインで検索してください。

この章は、次の内容で構成されています。

「GTP ロード バランシングの概要」

「GTP ロード バランシングの設定」

「Cisco IOS SLB 機能のモニタリングおよびメンテナンス」

「設定例」

GTP ロード バランシングの概要

ここでは、Cisco IOS SLB 機能と GGSN での GTP ロード バランシング サポートの概要を示します。次の内容で構成されています。

「Cisco IOS SLB の概要」

「GTP ロード バランシングの概要」

「GTP SLB の制約事項」

Cisco IOS SLB の概要

Cisco SLB 機能は、IP サーバのロード バランシングを備えた IOS ベースのソリューションです。Cisco IOS SLB 機能を使用すると、ネットワーク サーバ クラスタ内の サーバ のグループを表す 仮想 サーバ を定義できます( サーバ ファーム と呼ばれます)。この環境では、クライアントは仮想サーバの IP アドレスに接続します。クライアントが仮想サーバへの接続を開始すると、Cisco IOS SLB 機能によって、設定されている ロード バランシング アルゴリズム に基づいて、接続用の実サーバが選択されます。

また、Cisco IOS SLB 機能には、 ファイアウォール のグループ間でフローを分散する、ファイアウォールのロード バランシングも備えられています( ファイアウォール ファーム と呼ばれます)。

図 13-1 に、単純な Cisco IOS SLB ネットワークの論理構成図を示します。

図 13-1 IOS SLB の論理構成図

 

GTP ロード バランシングの概要

Cisco IOS SLB によって、GGSN GTP ロード バランシングと GGSN の高度な信頼性および可用性がもたらされます。GGSN GTP ロード バランシングでは、Cisco IOS SLB 機能で使用可能なサーバ ロード バランシング機能全体のサブセットがサポートされています。したがって、グローバル パケット ラジオ サービス/Universal Mobile Telecommunication System(GPRS/UMTS)環境に、すべての範囲の Cisco IOS SLB 機能が適用されるわけではありません。サポートされない機能の詳細については、「GTP SLB の制約事項」を参照してください。

GTP ロード バランシングを設定する場合、GGSN プールが Cisco IOS SLB でサーバ ファームとして設定されます。これらの GGSN 全体で、GTP セッションをロード バランシングします。GGSN ファーム全体で GTP セッションをロード バランシングするために、Cisco IOS SLB で仮想サーバ インスタンスが設定されます。この仮想サーバは、Cisco IOS SLB で設定したサーバ ファームに関連付けられます。

GTP ロード バランシングを設定する場合、次の点に注意してください。

GTP ロード バランシングは、スーパーバイザ エンジン上の Cisco IOS SLB 機能を使用することによってサポートされます。

スーパーバイザ エンジン上の IOS SLB では、GGSN の仮想 IP アドレスに送信された Packet Data Protocol(PDP; パケット データ プロトコル)コンテキストの作成要求だけが処理されます。PDP コンテキストの作成要求が受信されると、その時点での負荷に基づいて実 GGSN が選択されます。PDP コンテキストが確立されたあと、PDP コンテキストに対応する後続のトランザクションすべてが、その GGSN と対応する Serving GPRS Support Node(SGSN; サービング GPRS サポート ノード)との間で直接発生し、スーパーバイザ エンジン上の Cisco IOS SLB がバイパスされます。

上記以外に、次の点に注意してください。

複数の仮想サーバがサポートされている。

ロード バランシングされた実サーバは Cisco 7600 シャーシ搭載のサーバまたはシャーシの外側に設置されたサーバの可能性がある。

各仮想サーバには、SGSN から到達可能な固有のパブリック IP アドレスがある必要がある。

各仮想サーバは 1 つまたは複数の Access Point Name(APN; アクセス ポイント ネーム)に対応付けできる。

SGSN が APN を GGSN の IP アドレスに解決する場合に使用する Domain Name Server(DNS; ドメイン ネーム サーバ)サーバは、GGSN の仮想 IP アドレスを使用する必要がある。

サポートされる GTP ロード バランシング タイプ

Cisco IOS SLB では、次の 2 つのタイプの GTP ロード バランシングがサポートされています。

「GTP 原因コード検査を使用しない GTP ロード バランシング」

「GTP 原因コード検査を使用する GTP ロード バランシング」

GTP 原因コード検査を使用しない GTP ロード バランシング

Cisco GGSN では、イネーブルにされた GTP 原因コード検査を 使用しない GTP ロード バランシングが推奨されます。次の特性があります。

dispatched モードまたは directed server Network Address Translation(NAT; ネットワーク アドレス変換)モードで動作できますが、directed client NAT モードでは動作できません。dispatched モードでは、GGSN は Cisco IOS SLB デバイスに隣接するレイヤ 2 である必要があります。

ステートフル バックアップをサポートしていません。

重み付けラウンドロビン ロード バランシング アルゴリズムを使用して、仮想 GGSN の IP アドレス宛てのトンネル作成メッセージを実 GGSN のいずれかに配信します。このアルゴリズムの詳細については、「重み付けラウンドロビン」を参照してください。

GTPv1 のセカンダリ PDP コンテキストに対応するには Dynamic Feedback Protocol(DFP)が必要です。

GTP 原因コード検査を使用する GTP ロード バランシング

イネーブルにされた GTP 原因コード検査を 使用する GTP ロード バランシングによって、Cisco IOS SLB は、サーバ ファームとの間で送受信されるすべての PDP コンテキスト シグナリング フローをモニタリングできます。これにより、Cisco IOS SLB では、GTP 障害原因コードをモニタリングし、Cisco GGSN およびシスコ以外の GGSN の両方においてシステムレベルの問題を検出できます。

表 13-1 に、PDP コンテキストの作成応答の原因コードとそれに対応する Cisco IOS SLB の処理のリストを示します。

 

表 13-1 PDP 作成応答の原因コードとそれに対応する Cisco IOS SLB の処理

原因コード
Cisco IOS SLB の処理

Request Accepted

セッションを確立する。

No Resource Available

現在の実サーバを破棄し、セッションを再割り当てして応答を廃棄する。

All dynamic addresses are occupied

現在の実サーバを破棄し、セッションを再割り当てして応答を廃棄する。

No memory is available

現在の実サーバを破棄し、セッションを再割り当てして応答を廃棄する。

System Failure

現在の実サーバを破棄し、セッションを再割り当てして応答を廃棄する。

Missing or Unknown APN

応答を転送する。

Unknown PDP Address or PDP type

応答を転送する。

User Authentication Failed

応答を転送する。

Semantic error in TFT operation

応答を転送する。

Syntactic error in TFT operation

応答を転送する。

Semantic error in packet filter

応答を転送する。

Syntactic error in packet filter

応答を転送する。

Mandatory IE incorrect

応答を転送する。

Mandatory IE missing

応答を転送する。

Optional IE incorrect

応答を転送する。

Invalid message format

応答を転送する。

Version not supported

応答を転送する。

PDP context without TFT already activated

現在の実サーバを破棄し、セッションを再割り当てして応答を廃棄する。

イネーブルにされた GTP 原因コード検査を 使用する GTP ロード バランシングには、次の特性があります。

directed server NAT モードで動作している必要があります。

ある特定の International Mobile Subscriber ID(IMSI)からの PDP コンテキストの作成を同じ GGSN に割り当てるか、GTP APN 認識ロード バランシングが設定されている場合は同じサーバ ファームに割り当てます。

ステートフル バックアップをサポートしています。

GGSN または APN それぞれについて、開いている PDP コンテキストの数を追跡します。これにより、サーバ ファームは GTP ロード バランシングに重み付け最小接続( leastconns )アルゴリズムを使用できるようになります。このアルゴリズムの詳細については、「重み付け最小接続」を参照してください。

Cisco IOS SLB は、要求元 IMSI のキャリア コードが指定の値に一致しない場合、仮想 GGSN へのアクセスを拒否できます。

Cisco IOS SLB は、DFP なしでもセカンダリ PDP コンテキストをサポートできます。

GTP ロード バランシングでサポートされる Cisco IOS SLB アルゴリズム

GTP ロード バランシングでは、次の 2 つの Cisco IOS SLB アルゴリズムがサポートされています。

「重み付けラウンドロビン」

「重み付け最小接続」

重み付けラウンドロビン

重み付けラウンドロビン アルゴリズムは、仮想サーバへの新しい接続に使用する実サーバを、サーキュラ方式でサーバ ファームから選択するように指定します。各実サーバに重み n が割り当てられます。n は、仮想サーバに関連付けられている他の実サーバと比較した、その実サーバによる接続処理容量を示しています。つまり、新しい接続は、n 回までは指定の実サーバに割り当てられ、そのあとはサーバ ファーム内の次の実サーバが選択されます。

たとえば、n = 3 の ServerA、n = 1 の ServerB、および n = 2 の ServerC の 3 つの実サーバで構成されるサーバ ファームがあるとします。仮想サーバへの最初の 3 回の接続は ServerA に割り当てられ、4 番めの接続は ServerB に割り当てられ、5 番めと 6 番めの接続は ServerC に割り当てられます。


) サーバ ファームのすべてのサーバに n = 1 の重みを割り当てると、Cisco IOS SLB デバイスは単純なラウンドロビン アルゴリズムを使用するように設定されます。

イネーブルにされた GTP 原因コード検査を使用しない GTP ロード バランシングには、重み付けラウンドロビン アルゴリズムが必要です。重み付け最小接続を使用するサーバ ファームは、イネーブルにされた GTP 原因コード検査を使用しない GTP ロード バランシングを備えた仮想サーバにバインドできますが、この仮想サーバを INSERVICE にはできません。INSERVICE にしようとすると、Cisco IOS SLB によってエラー メッセージが発行されます。


重み付け最小接続

GTP 原因コード検査がイネーブルにされている場合、GTP ロード バランシングでは、Cisco IOS SLB の重み付け最小接続アルゴリズムがサポートされます。

重み付け最小接続アルゴリズムは、仮想サーバへの新しい接続用に、サーバ ファームからアクティブな接続が最も少ない実サーバが次の実サーバとして選択されるよう指定します。このアルゴリズムの場合も、各実サーバに重みが割り当てられます。重みが割り当てられている場合、各サーバでのアクティブな接続数と各サーバの相対容量に基づいて、接続数が最も少ないサーバが判別されます。指定の実サーバの容量は、そのサーバの割り当て済み重みを、この仮想サーバに関連付けられているすべての実サーバの割り当て済み重みの合計で割って算出されます(つまり、n1/(n1+n2+n3...) となります)。

たとえば、n = 3 の ServerA、n = 1 の ServerB、および n = 2 の ServerC の 3 つの実サーバで構成されるサーバ ファームがあるとします。ServerA の計算済み容量 3/(3+1+2)(つまり、仮想サーバ上のすべてのアクティブな接続の 2 分の 1)、ServerB の計算済み容量はすべてのアクティブな接続の 6 分の 1、ServerC の場合はすべてのアクティブな接続の 3 分の 1 になります。任意の時点で、仮想サーバへの次の接続は、アクティブな接続の数が計算済み容量を最も下回る実サーバに割り当てられます。


) 重み n = 1 をサーバ ファームのすべてのサーバに割り当てると、Cisco IOS SLB デバイスは、単純な最小接続アルゴリズムを使用するように設定されます。

イネーブルにされた GTP 原因コード検査を使用しない GTP ロード バランシングでは、重み付け最小接続アルゴリズムはサポートされていません

GTP 原因コード検査を使用する GTP ロード バランシングでは、重み付け最小接続アルゴリズムがサポートされています


Cisco IOS SLB の Dynamic Feedback Protocol

GTP ロード バランシングでは、Cisco IOS SLB は、PDP コンテキストが確立されたことは検出しますが、PDP コンテキストがクリアされたことは検出しません。したがって、Cisco IOS SLB は、各 GGSN の開いている PDP コンテキストの数を判別できません。GPRS/UMTS ロード バランシングの重みを動的に計算するには、Cisco IOS SLB DFP を使用します。

Cisco IOS SLB DFP サポートによって、ロード バランシング環境の DFP マネージャ は、 DFP エージェント との TCP 接続を開始できます。接続を開始したあと、DFP エージェントは 1 つまたは複数の実ホスト サーバからステータス情報を収集し、情報を相対的な重みに変換して、その重みを DFP マネージャに報告します。DFP マネージャは、実サーバをロード バランシングするときに重みを計算に入れます。ユーザ定義の間隔での報告以外に、DFP エージェントでは、実サーバのステータスに突然変更が生じた場合に早期報告を送信します。

DFP によって計算された重みによって、 weight (server farm) コマンドを使用して定義したスタティックな重みが上書きされます。ネットワークから DFP が削除されると、重みは Cisco IOS SLB によってスタティックな重みに戻されます。

Cisco IOS SLB は、DFP マネージャまたは別の DFP マネージャ(DistributedDirector など)の DFP エージェント、あるいは同時にその両方として定義できます。このような設定では、Cisco IOS SLB は DistributedDirector に定期的な報告を送信し、DistributedDirector はその情報を使用して、新しい接続要求に最適なサーバ ファームを選択します。次に、Cisco IOS SLB は同じ情報を使用して、選択されたサーバ ファームから最適な実サーバを選択します。

また、DFP では、さまざまなクライアント サブシステム(Cisco IOS SLB、GPRS/UMTS など)からの複数の DFP エージェントの同時使用をサポートしています。

GTP ロード バランシングでは、Cisco IOS SLB を DFP マネージャとして定義し、サーバ ファームの各 GGSN に DFP エージェントを定義すると、その DFP エージェントは GGSN の重みを報告できます。DFP エージェントは、CPU 使用率、プロセッサ メモリ、および各 GGSN に対して開始できる PDP コンテキストの最大数に基づいて各 GGSN の重みを計算します。

各 GGSN の重みは、主に、許可されている PDP コンテキストの最大数に対する GGSN 上の既存の PDP コンテキストの比率に基づいています。

デフォルトでは、CPU 使用率およびメモリ使用率は、使用率が 85% を超えてからでないと DFP の重み計算に組み込まれません。 gprs dfp グローバル コンフィギュレーション コマンドに cpu-load および mem-load キーワード オプションを追加して使用すると、CPU とメモリの負荷を重み計算に組み込む使用率のパーセンテージをカスタマイズできます。


) 許可されている PDP コンテキストの最大数は GGSN の最大負荷と見なされるため、gprs maximum-pdp-context-allowed コマンドで値を設定する場合は注意が必要です(デフォルトは 10,000 個の PDP コンテキスト)。


GTP IMSI スティッキ データベース サポート

Cisco IOS SLB は、指定の International Mobile Subscriber ID(IMSI)に対して GGSN、または GTP APN 認識ロード バランシングが設定されている場合は APN を選択し、同じ IMSI からの後続のパケット データ プロトコル(PDP)の作成要求すべてを、選択した GGSN または APN に転送できます。

この機能をイネーブルにするために、Cisco IOS SLB では、そのセッション データベース以外に、各 IMSI を対応する実サーバにマッピングする GTP IMSI スティッキ データベースを使用します。

Cisco IOS SLB では、指定の IMSI に対する最初の PDP コンテキストの作成要求を処理するときにスティッキ データベース オブジェクトを作成します。Cisco IOS SLB では、実サーバからスティック オブジェクトを削除するように指示する通知を受信したときにスティッキ オブジェクトを削除します。または、スティッキ オブジェクトが非アクティブであるため、そのスティッキ オブジェクトを削除します。IMSI に属している最後の PDP が削除されると、GGSN はスティッキ オブジェクトを削除するよう Cisco IOS SLB に通知します。

スティッキ データベース サポートおよび GTP APN 認識ロード バランシング

スティッキ IMSI 機能によって、同じ APN に対する同じユーザからのセッションが別の GGSN に割り当てられなくなります。APN(APN 認識ロード バランシング)に基づいたサーバ ファームが選択されていると、スティッキ IMSI 機能によって、IMSI を発行できるようになる前に、スティッキ エントリが APN に基づいた同じサーバ ファームに対するものであることが保証されます。新しい PDP コンテキストの作成要求が別の APN に対するものの場合、GTP SLB ではスティッキ エントリが作成されているサーバ ファームとは別のサーバ ファームを選択することになりますが、このサーバ ファームの方が実サーバよりも重要視されます。これは、実サーバが別のサーバ ファームに属している場合、そのサーバ ファームでは APN がサポートされない可能性があるためです。

GTP APN 認識ロード バランシング

Cisco IOS ソフトウェア リリース 12.2(18) SRB 以降がスーパーバイザ エンジン上にインストールされている場合は、 GTP APN 認識 ロード バランシングを設定できます。

GTP APN 認識機能を使用すると、APN のセットを Cisco IOS SLB のサーバ ファームにマッピングできます。APN の異なるセットをそれぞれサポートする複数のサーバ ファームを作成できます。PDP コンテキストの作成要求は APN 全体に均等に分散されます。

GTP APN 認識ロード バランシングの設定の詳細については、「GTP APN 認識ロード バランシングの設定」を参照してください。

GTP SLB の制約事項

GTP ロード バランシングを設定する場合は、次の制約事項が適用されます。

イネーブルにされた GTP 原因コード検査を使用しない GTP ロード バランシングの場合:

dispatched モードまたは directed server NAT モードのいずれかでだけ動作します。

ネットワークにより開始された PDP コンテキストの要求はロード バランシングできません。

次の Cisco IOS SLB 機能はサポートされていません。

- ID のバインド

- クライアント割り当てのロード バランシング

- スロースタート

- ステートフル バックアップ(Cisco 7600 プラットフォームではサポートされない)

- 重み付け最小接続ロード バランシング アルゴリズム

イネーブルにされた GTP 原因コード検査を 使用する GTP ロード バランシングの場合:

directed server NAT モードでだけ動作します。

ネットワークにより開始された PDP コンテキストの要求はロード バランシングできません。

SGSN または GGSN のいずれかでそのピアをエコーする必要があります。

インバウンド トラフィックおよびアウトバウンド トラフィックは、Cisco IOS SLB 経由でルーティングされる必要があります。

次の Cisco IOS SLB 機能はサポートされていません。

- ID のバインド

- クライアント割り当てのロード バランシング

- スロースタート

- スティッキ接続

GTP ロード バランシングの設定

この項は、次の内容で構成されています。

「GTP ロード バランシング設定の作業リスト」

「設定ガイドライン」

GTP ロード バランシング設定の作業リスト

ここでは、GTP ロード バランシングの設定で実行する作業のリストを示します。詳細な設定情報は、このマニュアルや他のマニュアルで示される参照先の項に掲載されています。ここでは、必須の作業または任意の作業であるかが示されています。

1. Cisco IOS SLB で、次の作業を実行します。

a. 「サーバ ファームおよび実サーバの設定」(必須)

b. 「仮想サーバの設定」(必須)

c. 「GSN アイドル タイマーの設定」(GTP 原因コード検査がイネーブルにされている場合は任意)

d. 「DFP サポートの設定」(任意。ただし推奨)

e. 「GTP APN 認識ロード バランシングの設定」(任意)

2. GGSN で、次の作業を実行します。

a. 「GTP SLB のループバック インターフェイスの設定」(必須)

b. 「GGSN での DFP サポートの設定」(任意。ただし推奨)

c. 「GGSN から Cisco IOS SLB へのメッセージングの設定」(任意)

3. 関連付けられている各サービング GPRS サポート ノード(SGSN)に、各 GGSN をルーティングします(必須)。

ルートはスタティックとダイナミックのいずれにもできますが、GGSN が SGSN に到達できる必要があります。詳細については、「SGSN へのルートの設定」を参照してください。

4. SGSN で、関連付けられている各 GGSN 上の仮想テンプレート、および GGSN ロード バランシング仮想サーバに、各 SGSN をルーティングします(必須)。

設定ガイドライン

Cisco IOS SLB および GGSN によって共有されているネットワークを設定する場合は、次の考慮事項に注意してください。

レイヤ 2 情報が正しくかつ明白となるように、スタティック ルート( ip route コマンドを使用)および実サーバの IP アドレス( real コマンドを使用)を指定します。

SGSN から仮想サーバへのスタティック ルートを設定します。

次のいずれかの方法を使用して、サブネットを慎重に選択します。

仮想テンプレート アドレスのサブネットがオーバーラップしないようにする。

実サーバ上のインターフェイスへではなく、実サーバへのネクストホップ アドレスを指定する。

Cisco IOS SLB では、次の 2 つのタイプの GTP ロード バランシングがサポートされています。

「GTP 原因コード検査を使用しない GTP ロード バランシング」

「GTP 原因コード検査を使用する GTP ロード バランシング」

Cisco IOS SLB では、GTP v0 および GTP v1 の両方がサポートされています。GTP サポートによって Cisco IOS SLB を「GTP 認識」にし、Cisco IOS SLB でレイヤ 5 まで把握できるように拡張できます。

Cisco 7600 プラットフォームでは、次のことが適用されます。

複数の GTP 仮想サーバがサポートされている。

ロード バランシングされた実サーバは Cisco 7600 シャーシ搭載のサーバまたはシャーシの外側に設置されたサーバの可能性がある。

各 GTP 仮想サーバには、SGSN から到達可能な固有のパブリック IP アドレスがある必要がある。

各仮想サーバは 1 つまたは複数の APN に対応付けできる。

SGSN が APN を GGSN の IP アドレスに解決する場合に使用する DNS サーバは、GTP の仮想 IP アドレスを使用する必要がある。

GTP APN 認識ロード バランシングを設定する場合、次の点に注意してください。

スーパーバイザ エンジン上に Cisco IOS ソフトウェア リリース 12.2(18) SRB 以降、GGSN 上に Cisco GGSN リリース 7.0、Cisco IOS リリース 12.4(9)XG 以降が必要です。

イネーブルにされた GTP 原因コード検査を使用する GTP ロード バランシングはサポートされていません。

特定の IOS SLB GTP マップの場合は、最大で 100 個の apn コマンドを設定できますが、APN マップはパフォーマンスに影響を与える可能性があるため、vserver につき 10 個を超える APN マップを設定しないことを推奨します。

プライマリとバックアップの仮想サーバのマッピング ルールが同じである必要があります。

1 つの実サーバは、複数のサーバ ファームには設定できません。

GTP ロード バランシング用の Cisco IOS SLB の設定

GTP ロード バランシングを設定するには、Cisco IOS SLB で次の作業を実行する必要があります。

「サーバ ファームおよび実サーバの設定」(必須)

「仮想サーバの設定」(必須)

「GSN アイドル タイマーの設定」(任意)

「DFP サポートの設定」(任意。ただし推奨)

「GTP APN 認識ロード バランシングの設定」(任意)

「Cisco IOS SLB 設定の確認」(任意)

サーバ ファームおよび実サーバの設定

GTP ロード バランシング用に Cisco IOS SLB でサーバ ファームおよび実サーバを設定する場合は、次のガイドラインに従って正しく設定するようにしてください。

GTP 原因コード検査がイネーブルにされていない場合は、 predictor コマンドのデフォルト設定(重み付けラウンドロビン アルゴリズム)を受け入れます。

GTP 原因コード検査がイネーブルにされている場合は、重み付けラウンドロビン アルゴリズム( roundrobin )または重み付け最小接続アルゴリズム( leastconns )のいずれかを指定できます。

real コマンドを使用して、GGSN 機能を実行している実サーバの IP アドレス(Cisco GGSN の場合は仮想テンプレート アドレス)を指定します。

reassign コマンドを使用して、SGSN の N3-REQUESTS カウンタ値よりも小さい再割り当てしきい値を指定します。

Cisco IOS SLB サーバ ファームを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router-SLB(config)# ip slb serverfarm serverfarm-name
Router(config-slb-sfarm)#

Cisco IOS SLB 設定にサーバ ファーム定義を追加し、サーバ ファーム コンフィギュレーション モードを開始します。

ステップ 2

Router-SLB(config-slb-sfarm)# predictor [ roundrobin | leastconns ]

実サーバの選択方法を決定する場合に使用するアルゴリズムを指定します。

GTP ロード バランシングでは、デフォルト設定(重み付けラウンドロビン アルゴリズム)を受け入れる必要があります。

各アルゴリズムの詳細については、次の項を参照してください。

「重み付けラウンドロビン」

「重み付け最小接続」

ステップ 3

Router-SLB(config-slb-sfarm)# nat server

(GTP 原因コード検査がイネーブルにされている場合は必須、イネーブルにされた原因コード検査を 使用しない GTP ロード バランシングの場合は任意)サーバ ファームで、NAT サーバ アドレス変換モードを設定します。

ステップ 4

Router-SLB(config-slb-sfarm)# real ip-address [ port ]

GGSN の仮想テンプレート インターフェイスの IP アドレスを使用して、実 GGSN をサーバ ファームのメンバーとして指定し、実サーバ コンフィギュレーション モードを開始します。

ステップ 5

Router-SLB(config-slb-real)# faildetect numconns number-conns [ numclients number-clients ]

(任意)実サーバの失敗を構成する、接続の連続失敗回数と、任意で固有のクライアント接続の失敗回数を指定します。

ステップ 6

Router-SLB(config-slb-real)# maxconns number-conns

(任意)実サーバで一度に許可されるアクティブな接続の最大数を指定します。

コマンドで指定した期間よりも長く継続することがないため、このコマンドによる影響は最小限に抑えられます。

ステップ 7

Router-SLB(config-slb-real)# reassign threshold

(任意)連続した受信応答されない同期、または PDP コンテキストの作成要求のしきい値を指定します。このしきい値を超えると、別の実サーバへの接続が試行されます。

ステップ 8

Router-SLB(config-slb-real)# retry retry-value

(任意)サーバ障害の検出と障害の発生したサーバへの次の接続試行との間に待機する間隔を秒単位で指定します。

ステップ 9

Router-SLB(config-slb-real)# weight weighting-value

(任意)サーバ ファームの他のサーバと比較した、実サーバの作業負荷容量を指定します。

(注) DFP を使用する場合、weight (server farm) コマンドを使用して定義するスタティックな重みは、DFP によって計算される重みで上書きされます。ネットワークから DFP が削除されると、重みは Cisco IOS SLB によってスタティックな重みに戻されます。

ステップ 10

Router-SLB(config-slb-real)# inservice

Cisco IOS SLB で使用できるように実サーバをイネーブルにします。

仮想サーバの設定

GTP ロード バランシング用に Cisco IOS SLB で仮想サーバを設定する場合、次のガイドラインに従って正しく設定するようにしてください。

SGSN から仮想サーバへのスタティック ルートを設定します。

仮想 GGSN の IP アドレスを仮想サーバとして指定し、 udp キーワード オプションを使用します。

GTP v1 セッションをロード バランシングするには、GGSN および SGSN が European Telecommunications Standards Institute(ETSI; 欧州電気通信標準化機構)標準に準拠している場合はポート番号 2123 を指定し、全ポート仮想サーバ(すべてのポート宛てのフローを受け入れる仮想サーバ)を設定するにはポート番号 0 または any を指定します。

GTP v0 セッションをロード バランシングするには、GGSN および SGSN が European Telecommunications Standards Institute(ETSI)標準に準拠している場合はポート番号 3386 を指定し、全ポート仮想サーバを設定するにはポート番号 0 または any を指定します。

GTP 原因コード検査を 使用しない GTP ロード バランシングをイネーブルにするには、 service gtp キーワード オプションを指定します。

GTP 原因コード検査を 使用する GTP ロード バランシングをイネーブルにするには、 service gtp-inspect キーワード オプションを指定します。

イネーブルにされた GTP 原因コード検査を 使用しない GTP ロード バランシングでは、 idle コマンドを使用して GTP アイドル タイマーを設定するときに、SGSN での PDP コンテキストの要求間で許可されている最大間隔よりも大きい GTP アイドル タイマーを指定します。

Cisco IOS SLB 仮想サーバを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router-SLB(config)# ip slb vserver virtual_server-name

仮想サーバを識別し、仮想サーバ コンフィギュレーション モードを開始します。

ステップ 2

Router-SLB(config-slb-vserver)# virtual ip-addr [ netmask [ group ]] { esp | gre | protocol }
 

または

Router(config-slb-vserver)# virtual ip-addr [ netmask [ group ]] { tcp | udp } [ port | any ] [ service service ]

仮想サーバの IP アドレス、接続タイプ、任意の TCP または UDP ポート番号、Internet Key Exchange(IKE; インターネット キー エクスチェンジ)Internet Security Association and Key Management Protocol(ISAKMP)または Wireless Session Protocol(WSP)の設定、およびサービス カップリングを指定します。

(注) GTP ロード バランシングの場合:

仮想 GGSN の IP アドレスを仮想サーバとして指定し、 udp キーワード オプションを指定します。

GTP v1 セッションをロード バランシングするには、GGSN および SGSN が European Telecommunications Standards Institute(ETSI; 欧州電気通信標準化機構)標準に準拠している場合はポート番号 2123 を指定し、全ポート仮想サーバ(すべてのポート宛てのフローを受け入れる仮想サーバ)を設定するにはポート番号 0 または any を指定します。

GTP v0 セッションをロード バランシングするには、GGSN および SGSN が ETSI 標準に準拠している場合はポート番号 3386 を指定し、全ポート仮想サーバを設定するにはポート番号 0 または any を指定します。

GTP 原因コード検査を 使用しない GTP ロード バランシングをイネーブルにするには、 service gtp キーワード オプションを指定します。

GTP 原因コード検査を 使用する GTP ロード バランシングをイネーブルにするには、 service gtp-inspect キーワード オプションを指定します。

ステップ 3

Router-SLB(config-slb-vserver)# serverfarm primary-farm [ backup backup-farm [ sticky ]] [ map map-id priority priority ]

 

実サーバ ファームを仮想サーバに関連付けます。

backup :(任意)バックアップ サーバ ファームを設定します。

backup backup-farm [ sticky ]:(任意)バックアップ サーバ ファームを設定し、任意で、バックアップ サーバ ファームのスティッキ接続を使用するように指定します。

map map-id priority priority :(任意)GTP APN 認識ロード バランシング用に IOS SLB プロトコル マップをサーバ ファームに関連付け、このマップのプライオリティを定義します。マップはプライオリティを基準にして検索されます。数値が小さいほど、プライオリティが高くなります。

キーワード オプションなし)は、単一のインスタンスに制限されています。

(注) マップの設定を変更するには、仮想サーバをアウト オブ サービスにする必要があります。

(注) 各マップのプライマリ サーバ ファームとバックアップ サーバ ファームの NAT モードは一致している必要があります。

ステップ 4

Router-SLB(config-slb-vserver)# idle [ gtp request ] duration

(任意)Cisco IOS SLB がパケット アクティビティのないときに接続コンテキストを維持する最小時間を指定します。

gtp request キーワード オプションなしで指定された idle コマンドによって、イネーブルにされた原因コード検査を 使用しない GTP ロード バランシングの GTP アイドル タイマーが制御されます。 idle gtp request コマンドによって、イネーブルにされた原因コード検査を 使用しない GTP ロード バランシングと、イネーブルにされた原因コード検査を 使用する GTP ロード バランシングの両方の GTP アイドル タイマーが制御されます。推奨される設定は idle gtp request です。

GTP ロード バランシングでは、SGSN での PDP コンテキストの要求間で許可されている最大間隔よりも大きい GTP アイドル タイマーを指定します。

ステップ 5

Router-SLB(config-slb-vserver)# inservice

Cisco IOS SLB で使用できるよう仮想サーバをイネーブルにします。

ステップ 6

Router-SLB(config-slb-vserver)# client { ip-address network-mask [ exclude ] | gtp carrier-code [ code ]}

(任意)仮想サーバを使用できるクライアントを指定します。

オプションだけがサポートされます(GTP 原因コード検査がイネーブルにされている場合にだけ)。

ステップ 7

Router-SLB(config-slb-vserver)# replicate casa listen-ip remote-ip port [ interval ] [ password [ 0 | 7 ] password timeout ]

(任意)Cisco IOS SLB 決定テーブルのバックアップ スイッチへのステートフル バックアップを設定します。

GTP ロード バランシングでは、このコマンドはサポートされていません。

GSN アイドル タイマーの設定

GTP 原因コード検査がイネーブルにされている場合は、Cisco IOS SLB がアイドルの GGSN または SGSN との間のセッションを維持する時間を設定できます。

GSN アイドル タイマーを設定するには、Cisco IOS SLB で、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router-SLB(config)# ip slb timers gtp gsn duration

Cisco IOS SLB がアイドルの GGSN または SGSN との間のセッションを維持する時間を変更します。

DFP サポートの設定

Cisco IOS SLB は、DFP マネージャまたは別の DFP マネージャ(DistributedDirector など)の DFP エージェント、あるいは同時にその両方として定義できます。ネットワーク設定によっては、Cisco IOS SLB を DFP マネージャとして設定するためのコマンドと Cisco IOS SLB を DFP エージェントとして設定するコマンドを、同じデバイスまたは異なるデバイス上で入力することがあります。

Cisco IOS SLB を DFP マネージャとして設定し、Cisco IOS SLB が接続を開始できる DFP エージェントを識別するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router-SLB(config)# ip slb dfp [ password [ 0 | 7 ] password [ timeout ]]

DFP を設定し、任意のパスワードを指定して、DFP コンフィギュレーション モードを開始します。

ステップ 2

Router-SLB(config-slb-dfp)# agent ip_address port-number [ timeout [ retry_count [ retry_interval ]]]

Cisco IOS SLB の接続先となる DFP エージェントを識別します。

GTP APN 認識ロード バランシングの設定

GTP APN 認識ロード バランシングによって、APN 全体をロード バランシングできます。

GTP APN 認識ロード バランシングを実装する場合は、IOS SLB で作成された Cisco IOS SLB GTP マップに APN のセットが定義されている必要があります。次に、IOS SLB GTP マップを、IOS SLB の仮想テンプレートの下にあるサーバ ファームに関連付ける必要があります。

GTP APN 認識ロード バランシングを設定するには、次の項の作業を実行します。

「GTP APN 認識ロード バランシング用の Cisco IOS SLB GTP マップの設定」

「仮想サーバのサーバ ファームへの IOS SLB GTP マップの関連付け」

前提条件および制約事項

GTP APN 認識ロード バランシングを設定する場合、次の点に注意してください。

スーパーバイザ エンジン上に Cisco IOS ソフトウェア リリース 12.2(18) SRB 以降、GGSN 上に Cisco GGSN リリース 7.0、Cisco IOS リリース 12.4(9)XG 以降が必要です。

イネーブルにされた GTP 原因コード検査を使用する GTP ロード バランシングはサポートされていません。

特定の IOS SLB GTP マップの場合は、最大で 100 個の apn コマンドを設定できますが、APN マップはパフォーマンスに影響を与える可能性があるため、vserver につき 10 個を超える APN マップを設定しないことを推奨します。

プライマリとバックアップの仮想サーバのマッピング ルールが同じである必要があります。

1 つの実サーバは、複数のサーバ ファームには設定できません。

GTP APN 認識ロード バランシング用の Cisco IOS SLB GTP マップの設定

APN 認識ロード バランシングをイネーブルにするには、特定の APN をグループ化する IOS SLB GTP マップが設定されている必要があります。

APN 全体でのロード バランシング用の IOS SLB GTP マップを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router-SLB(config)# i p slb map map-id protocol

IOS SLB プロトコル マップを設定し、SLB マップ コンフィギュレーション モードを開始します。

map-id :IOS SLB プロトコル マップ ID。有効な範囲は 1 ~ 255 です。マップ ID はすべてのサービス タイプ全体でグローバルに固有である必要があります。

protocol :マップに関連付けられているプロトコル。vserver サービス タイプに一致する必要があります。

gtp :グローバル パケット ラジオ サービス(GPRS)ロード バランシングの場合、IOS SLB GPRS トンネリング プロトコル(GTP)マップを設定し、SLB GTP マップ コンフィギュレーション モードを開始します。

radius :Remote Authentication Dial-In User Service(RADIUS)ロード バランシングの場合、IOS SLB RADIUS マップを設定し、SLB RADIUS マップ コンフィギュレーション モードを開始します。

(注) このリリースでは、GTP マップがサポートされています。

ステップ 2

Router-SLB(config-slb-map)# apn string

グローバル パケット ラジオ サービス(GPRS)ロード バランシングのアクセス ポイント ネーム(APN)に一致させる ASCII 正規表現を設定します。

コマンドを設定できますが、APN マップはパフォーマンスに影響を与える可能性があるため、vserver につき 10 個を超える APN マップを設定しないことを推奨します。

仮想サーバのサーバ ファームへの IOS SLB GTP マップの関連付け

IOS SLB GTP マップを作成したあと、仮想サーバの設定時にその GTP マップをサーバ ファームに関連付ける必要があります。


) マップの設定を変更するには、仮想サーバをアウト オブ サービスにする必要があります。各マップのプライマリ サーバ ファームとバックアップ サーバ ファームの NAT モードは一致している必要があります。


サーバ ファームを仮想サーバに関連付けるときに IOS SLB GTP マップを指定するには、IOS SLB で、仮想サーバ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router-SLB(config-slb-vserver)# serverfarm primary-farm [ backup backup-farm [ sticky ]] [ map map-id priority priority ]

 

実サーバ ファームを仮想サーバに関連付けます。

backup :(任意)バックアップ サーバ ファームを設定します。

backup backup-farm [ sticky ]:(任意)バックアップ サーバ ファームを設定し、任意で、バックアップ サーバ ファームのスティッキ接続を使用するように指定します。

map map-id priority priority :(任意)GTP APN 認識ロード バランシング用に IOS SLB プロトコル マップをサーバ ファームに関連付け、このマップのプライオリティを定義します。マップはプライオリティを基準にして検索されます。数値が小さいほど、プライオリティが高くなります。

キーワード オプションなし)は、単一のインスタンスに制限されています。

(注) マップの設定を変更するには、仮想サーバをアウト オブ サービスにする必要があります。

(注) 各マップのプライマリ サーバ ファームとバックアップ サーバ ファームの NAT モードは一致している必要があります。

GTP APN 認識ロード バランシングの設定例

IOS SLB からの次の設定例は、IOS SLB GTP マップ設定と、仮想テンプレートの下のマップ/サーバ ファーム アソシエーションを示します。

!
/* server-farm configurations */
ip slb serverfarm farm1
real 10.0.0.1
inservice
real 10.0.0.2
inservice
ip slb serverfarm farm4
real 10.0.0.7
inservice
real 10.0.0.8
inservice
ip slb serverfarm farm5
real 10.0.0.9
inservice
real 10.0.0.10
inservice
!
/* GTP maps for GTP APN-aware SLB */
ip slb map 1 gtp
apn www.*.edu
ip slb map 4 gtp
apn abc.company1.com
apn xyz.company2.com
ip slb map 5 gtp
apn company3.com
!
/* associate the GTP map with server farm under virtual server */
ip slb vserver GGSN_SERVER
virtual 10.10.10.10 udp 0 service gtp
serverfarm farm1 map 1 priority 3
serverfarm farm2 backup farm4 map 1 priority 2
serverfarm farm4 map 4 priority 5
serverfarm farm5 map 5 priority 4
serverfarm farm6
 

Cisco IOS SLB 設定の確認

ここでは、Cisco IOS SLB 設定を確認する方法について説明します。内容は次のとおりです。

「仮想サーバの確認」

「サーバ ファームの確認」

「Cisco IOS SLB の接続の確認」

仮想サーバの確認

次の show ip slb vserver コマンドによって、仮想サーバ PUBLIC_HTTP と RESTRICTED_HTTP の設定が確認されます。

Router-SLB# show ip slb vserver
 
slb vserver prot virtual state conns
-------------------------------------------------------------------
PUBLIC_HTTP TCP 10.0.0.1:80 OPERATIONAL 0
RESTRICTED_HTTP TCP 10.0.0.2:80 OPERATIONAL 0
IOSSLB#

サーバ ファームの確認

次の show ip slb reals コマンドによって、サーバ ファーム PUBLIC と RESTRICTED のステータス、関連付けられている実サーバ、およびそのステータスが表示されます。

Router-SLB# show ip slb real
 
real farm name weight state conns
---------------------------------------------------------------------
10.1.1.1 PUBLIC 8 OPERATIONAL 0
10.1.1.2 PUBLIC 8 OPERATIONAL 0
10.1.1.3 PUBLIC 8 OPERATIONAL 0
10.1.1.20 RESTRICTED 8 OPERATIONAL 0
10.1.1.21 RESTRICTED 8 OPERATIONAL 0
IOSSLB#
 

次の show ip slb serverfarm コマンドによって、サーバ ファーム PUBLIC と RESTRICTED の設定およびステータスが表示されます。

Router-SLB# show ip slb serverfarm
 
server farm predictor nat reals bind id
---------------------------------------------------
PUBLIC ROUNDROBIN none 3 0
RESTRICTED ROUNDROBIN none 2 0
IOSSLB#

Cisco IOS SLB の接続の確認

Cisco IOS SLB 機能がインストールされ、正しく動作しているかどうかを確認するには、Cisco IOS SLB スイッチから実サーバに対して PING を実行し、次にクライアントから仮想サーバに対して PING を実行します。

次の show ip slb stats コマンドによって、Cisco IOS SLB ネットワーク ステータスに関する詳細が表示されます。
 
Router-SLB# show ip slb stats
Pkts via normal switching: 0
Pkts via special switching: 0
Pkts via slb routing: 0
Pkts Dropped: 0
Connections Created: 0
Connections Established: 0
Connections Destroyed: 0
Connections Reassigned: 0
Zombie Count: 0
Connections Reused: 0
Connection Flowcache Purges: 0
Failed Connection Allocs: 0
Failed Real Assignments: 0
RADIUS framed-ip Sticky Count:0
RADIUS username Sticky Count: 0
 

Cisco IOS SLB のネットワークおよび接続を確認する場合に使用される他のコマンドについては、「Cisco IOS SLB 機能のモニタリングおよびメンテナンス」を参照してください。

GTP ロード バランシング用の GGSN の設定

GGSN で GTP ロード バランシングを設定するには、次の項の作業を実行します。

「GTP SLB のループバック インターフェイスの設定」(イネーブルにされた GTP 原因コード検査を使用しない dispatched モードを使用している場合は必須)

「GGSN での DFP サポートの設定」(任意。ただし推奨)

GTP SLB のループバック インターフェイスの設定

GTP ロード バランシングをイネーブルにするには、ファーム内の各 GGSN 上の Cisco IOS SLB で、ループバック インターフェイスに仮想サーバと同じ IP アドレスが設定されている必要があります。

ループバック インターフェイスを作成するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router-GGSN(config)# interface loopback number

ループバック インターフェイスを作成します。ループバック インターフェイスは、常に稼動している仮想インターフェイスです。

ステップ 2

Router-GGSN(config-if)# ip address ip-address mask

ループバック インターフェイスに IP アドレスを割り当てます。

GGSN での DFP サポートの設定

GTP SLB の DFP サポートを設定するには、次の作業を実行する必要があります。

「DFP エージェントとしての GGSN の設定」

「GGSN の DFP 重みの設定」

「GGSN の PDP コンテキストの最大数の設定」

DFP エージェントとしての GGSN の設定

DFP エージェントの設定の詳細については、「 DFP Agent Subsystem 」フィーチャ モジュールを参照してください。

DFP マネージャ(この場合は Cisco IOS SLB)が DFP エージェントへの接続に使用するポート番号を定義するには、グローバル コンフィギュレーション モードで次のコマンドを示されている順序で使用します。

 

コマンド
説明

ステップ 1

Router-GGSN(config)# ip dfp agent gprs

DFP エージェント サブシステムを識別し、DFP エージェント コンフィギュレーション モードを開始します。

ステップ 2

Router-GGSN(config-dfp)# interval seconds

(任意)DFP エージェントの重み再計算間隔を設定します。

ステップ 3

Router-GGSN(config-dfp)# password [ 0 | 7 ] password [ timeout ]

(任意)Message-Digest Algorithm 5(MD5)認証用の DFP エージェントのパスワードを設定します。

ステップ 4

Router-GGSN(config-dfp)# port port-number

DFP マネージャが DFP エージェントへの接続に使用するポート番号を定義します。

ステップ 5

Router-GGSN(config-dfp)# inservice

DFP マネージャと通信できるよう DFP エージェントをイネーブルにします。DFP エージェントは、次の両方の条件が満たされるまで非アクティブです。

DFP エージェントが inservice (DFP agent) コマンドを使用してイネーブルにされている。

クライアント サブシステムによって DFP エージェントの状態がアクティブに変更されている。

GGSN の DFP 重みの設定

DFP を GTP ロード バランシングで使用する場合、DFP エージェントとして機能する各 GGSN には、DFP マネージャに送信できる最大の重みがあります。GGSN ごとに、デフォルトの最大の重み(85%)を受け入れるか、または最大の重みに別の値を指定できます。また、 cpu-load および mem-load キーワード オプションを使用して、CPU とメモリの負荷を重み計算に組み込む使用率のパーセンテージを設定することもできます。

GGSN の最大の重みを指定するには、GGSN で、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router-GGSN(config)# gprs dfp { max-weight max-weight | min-cpu-load min-cpu-load | mem-load min-mem-load }

DFP エージェントとして機能している GGSN の DFP 重みパラメータを指定します。

max-weight :DFP エージェントとして機能する GGSN から DFP マネージャに送信される最大の重みを指定します。有効な範囲は 1 ~ 100 です。デフォルトは 8 です。

min-cpu-load :CPU の負荷が DFP の重み計算に組み込まれる最小のパーセンテージを指定します。有効な範囲は 10 ~ 75% です。

mem-load :メモリの負荷が DFP の重み計算に組み込まれる最小のパーセンテージを指定します。有効な範囲は 10 ~ 75% です。

GGSN の PDP コンテキストの最大数の設定

DFP を GTP ロード バランシングで使用する場合、 gprs maximum-pdp-context-allowed コマンドを使用して、GGSN ごとの PDP コンテキストの最大数を指定する必要があります。PDP コンテキスト数のデフォルト値である 10,000 は使用 しないようにしてください 。デフォルト値の 10,000 を含め、値を大幅に小さくすると、GPRS/UMTS ロード バランシング環境のキャパシティに影響する可能性があります。


) DFP では、PPP PDP を IP PDP と比較します。1 つの PPP PDP は 8 つの IPv4 PDP と等価です。1 つの IPv6 PDP は、4 つの IPv4 PDP としてカウントされます。したがって、DFP を使用する場合は、設定された PDP コンテキストの最大数が GGSN の重みに影響を与えることに注意してください。他のパラメータがすべて同じままの場合は、PDP コンテキストの最大数が小さいほど、重みが小さくなります。


GGSN の PDP コンテキストの最大数を設定するには、GGSN で、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的
Router-GGSN(config)# gprs maximum-pdp-context-allowed [ pdp-contexts ]

GGSN で有効にできる PDP コンテキスト(モバイル セッション)の最大数を指定します。

GGSN から Cisco IOS SLB へのメッセージングの設定

GGSN-IOS SLB メッセージング機能を使用すると、Cisco IOS SLB によって転送されるセッションに影響を与える特定の条件が存在する場合に、Cisco IOS SLB に通知するように GGSN を設定できます。また、この通知によって、この条件に応答する方法が Cisco IOS SLB に指示されます。

gprs slb notify コマンドを使用して設定できる GGSN-IOS SLB 通知には、Call Admission Control(CAC; コール アドミッション制御)障害通知と削除通知(GTP IMSI のスティッキ データベース サポートの場合)の 2 つのタイプがあります。次の項では、それぞれのタイプを設定する方法について説明します。

「GGSN-IOS SLB メッセージング CAC 障害通知のサポートの設定」

「GGSN-IOS SLB メッセージング削除通知のサポート(GTP IMSI スティッキ データベース サポート)の設定」

GGSN-IOS SLB メッセージング CAC 障害通知のサポートの設定

GGSN は、UMTS QoS CAC 障害が原因で PDP コンテキストの作成要求が拒否された場合に Cisco IOS SLB に通知するよう設定できます。

GGSN によって送信される CAC 障害通知には、次の Information Elements(IE; 情報エレメント)が含まれます。

タイプ:通知タイプ(再割り当て)。

セッション ID:通知が属しているセッションを識別する、Cisco IOS SLB でのセッション キー。

作成応答:障害が発生したときに GGSN が SGSN に送信する作成応答。セッションを再割り当てできる代替の GGSN がない場合、または再割り当て試行の最大回数を超えている場合、Cisco IOS SLB ではこの情報を SGSN にリレーします。

CAC 障害通知のサポートを設定する方法は、Cisco IOS SLB が dispatched モードまたは directed server NAT モードのいずれで動作しているかによって異なります。それぞれの手順の詳細については、次の項を参照してください。

「Cisco IOS SLB が dispatched モードの場合の CAC 障害通知サポートの設定」

「Cisco IOS SLB が directed server NAT モードのときの CAC 障害通知サポートの設定」

Cisco IOS SLB が dispatched モードの場合の CAC 障害通知サポートの設定

Cisco IOS SLB が dispatched モードで機能している場合、PDP コンテキストの作成要求を GGSN に転送した仮想サーバが GGSN に対して既知であるため、GGSN では、CAC 障害通知を直接そのサーバに送信できます。

Cisco IOS SLB が dispatched モードのときに Cisco IOS SLB に CAC 障害通知を送信するよう GGSN を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router-GGSN(config)# gprs slb mode dispatched

GGSN-IOS SLB メッセージングの Cisco IOS SLB 動作モードとして dispatched を定義します。

(注) デフォルトは dispatched モードです。

ステップ 2

Router-GGSN(config)# gprs slb notify cac-failure
 

UMTS QoS CAC 障害が原因で PDP コンテキストの作成要求が拒否された場合に Cisco IOS SLB に通知できるよう GGSN をイネーブルにします。

Cisco IOS SLB で CAC 障害通知サポートをイネーブルにするには、仮想サーバ モードで次のコマンドを使用します。

 

コマンド
目的
Router-SLB(config-slb-vserver)# gtp notification cac count
 

GGSN-IOS SLB メッセージングの CAC 障害通知のサポートをイネーブルにし、拒否された PDP コンテキストの作成要求を新しい実 GGSN に再割り当てできる最大回数を設定します。デフォルトは 2 です(セッションごとに、初期送信を含め実 GGSN が 3 回選択されます)。

Cisco IOS SLB が directed server NAT モードのときの CAC 障害通知サポートの設定

Cisco IOS SLB が directed server NAT モードで機能している場合、仮想サーバは GGSN に対して既知ではありません。したがって、Cisco IOS SLB に CAC 障害通知を送信するよう GGSN を設定すること以外に、グローバル コンフィギュレーション モードで gprs slb vserver コマンドを使用して GGSN で仮想サーバのリストを定義し、グローバル コンフィギュレーション モードで gprs slb mode コマンドを使用して Cisco IOS SLB の動作モードを定義する必要があります。


) Cisco IOS SLB が directed server NAT モードで機能しているときに、Cisco IOS SLB の動作モードと仮想サーバが GGSN で定義されていない場合は、gprs slb notify cac-failure および gtp notification cac コマンドが設定されていても、CAC 障害通知のサポートはイネーブルにされません。


Cisco IOS SLB が directed server NAT モードのときに Cisco IOS SLB に CAC 障害通知を送信できるよう GGSN をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router-GGSN(config)# gprs slb mode directed

GGSN-IOS SLB メッセージングの Cisco IOS SLB 動作モードとして directed server NAT を定義します。

(注) デフォルトは dispatched モードです。

ステップ 2

Router-GGSN(config)# gprs slb notify cac-failure
 

UMTS QoS CAC 障害が原因で PDP コンテキストの作成要求が拒否された場合に Cisco IOS SLB に通知できるよう GGSN をイネーブルにします。

ステップ 3

Router-GGSN(config)# gprs slb vserver ip_address [ next-hop ip ip-address [ vrf name ]]
 

gprs slb notify コマンドを使用して定義した条件が発生したときに、GGSN が Cisco IOS SLB 仮想サーバに通知するよう設定します。

任意で、仮想サーバに到達するために使用できるネクストホップの IP アドレスも設定し、VPN ルーティング/転送インスタンスを指定します。

Cisco IOS SLB で CAC 障害通知サポートをイネーブルにするには、仮想サーバ モードで次のコマンドを使用します。

 

コマンド
目的
Router-SLB(config-slb-vserver)# gtp notification cac count
 

GGSN-IOS SLB メッセージングの CAC 障害通知のサポートをイネーブルにし、拒否された PDP コンテキストの作成要求を新しい実 GGSN に再割り当てできる最大回数を設定します。デフォルトは 2 です(セッションごとに、初期送信を含め実 GGSN が 3 回選択されます)。

GGSN-IOS SLB メッセージング削除通知のサポート(GTP IMSI スティッキ データベース サポート)の設定

GGSN および Cisco IOS SLB で削除通知のサポートが設定されている場合、加入者からの最初の PDP コンテキストの作成要求が受信されると、Cisco IOS SLB にスティッキ データベース エントリが作成されます。GGSN でその IMSI の最後の PDP コンテキストが削除されると、GGSN では、データベースからスティッキ エントリを削除するよう Cisco IOS SLB に指示する削除通知を送信します。


) このように設定するには、service gtp キーワードを指定して virtual 仮想サーバ コンフィギュレーション コマンドを設定する必要があります。



) 複数の vserver で sticky gtp imsi コマンドが設定されている場合は、グループ番号を設定することによって、同じ Mobile Station(MS; モバイル ステーション)が異なる vserver 経由で接続するときにスティッキ オブジェクトを共有できるようになります。スティッキ グループ番号が同じすべての vserver によって、ユーザのスティッキ IMSI エントリが共有されます。


GGSN で IMSI の最後の PDP コンテキストが削除されたときに、削除通知を Cisco IOS SLB に送信するよう GGSN を設定するには、グローバル コンフィギュレーション モードで次の作業を実行します。

 

コマンド
説明

ステップ 1

Router-GGSN(config)# gprs slb mode { dispatched | directed }

GGSN-IOS SLB メッセージングの Cisco IOS SLB 動作モードを定義します。デフォルトは dispatched モードです。

ステップ 2

Router-GGSN(config)# gprs slb notify session-deletion
 

IMSI に関連付けられている最後の PDP コンテキストが削除されたときに、削除通知メッセージを Cisco IOS SLB に送信するよう GGSN を設定します。

ステップ 3

Router-GGSN(config)# gprs slb vservers ip_address [ next-hop ip ip-address [ vrf name ]]
 

gprs slb notify コマンドを使用して定義した条件が発生したときに、GGSN が Cisco IOS SLB 仮想サーバに通知するよう設定します。

任意で、仮想サーバに到達するために使用できるネクストホップの IP アドレスも設定し、VPN ルーティング/転送インスタンスを指定します。

Cisco IOS SLB で GTP IMSI スティッキ データベース サポートを設定するには、仮想サーバ コンフィギュレーション モードで次の作業を実行します。

 

コマンド
目的
Router-SLB(config-slb-vserver)# sticky gtp imsi [ group number ]
 

特定の IMSI に関する以前の作成要求すべてを処理したのと同じ実サーバへの GTP PDP コンテキストの作成要求をロード バランシングできるように、Cisco IOS SLB をイネーブルにします。

Cisco IOS SLB 機能のモニタリングおよびメンテナンス

GGSN に関する GTP SLB 情報をクリア、取得、および表示するには、特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的
Router-GGSN# clear gprs slb statistics
 

Cisco IOS SLB 統計情報をクリアします。

Router-GGSN# show gprs slb detail
 

動作モード、GGSN-IOS SLB メッセージングの仮想サーバ アドレス、SLB 通知、統計情報など、Cisco IOS SLB 関連のすべての情報を表示します。

Router-GGSN# show gprs slb mode

Cisco IOS SLB の動作モードを表示します。

Router-GGSN# show gprs slb statistics
 

Cisco IOS SLB 統計情報を表示します。

Router-GGSN# show gprs slb vservers
 

GGSN-IOS SLB メッセージングの定義済み Cisco IOS SLB 仮想サーバのリストを表示します。

Cisco IOS SLB での GTP SLB に関する情報を取得および表示するには、Cisco IOS SLB で、特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的
Router-SLB# show ip slb conns [ vserver virtual_server-name | client ip-address | firewall firewallfarm-name ] [ detail ]

Cisco IOS SLB によって処理されるすべての接続を表示するか、または任意で、特定の仮想サーバかクライアントに関連付けられた接続だけを表示します。

Router-SLB# show ip slb dfp [ agent agent_ip_address port-number | manager manager_ip_address | detail | weights ]

DFP および DFP エージェントに関する情報、および実サーバに割り当てられている重みに関する情報を表示します。

Router-SLB# show ip slb gtp {gsn [ gsn-ip-address ] | nsapi [ nsapi-key ] [ detail ]

原因コード検査を使用する GTP ロード バランシングがイネーブルにされている場合の Cisco IOS SLB GTP 情報を表示します。

Router-SLB# show ip slb map [ id ]

 

Cisco IOS SLB プロトコル マップに関する情報を表示します。

Router-SLB# show ip slb reals [ sfarm server-farm ] [ detail ]

Cisco IOS SLB に定義されている実サーバに関する情報を表示します。

Router-SLB# show ip slb replicate

Cisco IOS SLB 複製設定に関する情報を表示します。

Router-SLB# show ip slb serverfarms [ name serverfarm-name ] [ detail ]

Cisco IOS SLB に定義されているサーバ ファームに関する情報を表示します。

Router-SLB show ip slb sessions [ gtp | gtp-inspect | radius ] [ vserver virtual-server ] [ client ip-addr netmask ] [ detail ]

Cisco IOS SLB によって処理されるセッションに関する情報を表示します。

コマンドを使用して指定した仮想サーバの GTP アイドル タイマーの期間よりも長く継続することはありません。

Router=SLB# show ip slb stats

Cisco IOS SLB 統計情報を表示します。

Router-SLB# show ip slb sticky gtp imsi [ id imsi ]

Cisco IOS SLB GTP IMSI スティッキ データベースに関連付けられている Cisco IOS SLB スティッキ データベースのエントリだけを表示し、ユーザがプライマリ PDP として使用したすべての Network Service Access Point Identifiers(NSAPI; ネットワーク サービス アクセス ポイント ID)を表示します。

任意で、指定した IMSI に関連付けられているスティッキ データベース エントリだけを表示します。

Router-SLB# show ip slb vserver [ name virtual_server ] [ redirect ] [ detail ]

Cisco IOS SLB に定義されている仮想サーバに関する情報を表示します。

設定例

ここでは、GGSN Cisco IOS SLB の例を示します。この項に記載されている GGSN コマンドの詳細については、『 Cisco GGSN Release Command Reference 』を参照してください。この項に記載されている Cisco IOS SLB コマンドの詳細については、「 IOS Server Load Balancing 」フィーチャ モジュール ドキュメントを参照してください。

ここでは、Cisco 7600 プラットフォーム上の GTP ロード バランシングおよび NAT が設定された Cisco IOS SLB の例を示します。

「Cisco IOS SLB の設定例」

「GGSN1 の設定例」

Cisco IOS SLB の設定例

hostname 7600-a
!
ip slb probe PINGPROBE ping
interval 3
faildetect 3
!
ip slb serverfarm SAMI1
nat server
probe PINGPROBE
!
real 9.9.9.72
reassign 4
faildetect numconns 255 numclients 8
inservice
!
real 9.9.9.73
reassign 4
faildetect numconns 255 numclients 8
inservice
!
real 9.9.9.74
reassign 4
faildetect numconns 255 numclients 8
inservice
!
real 9.9.9.75
reassign 4
faildetect numconns 255 numclients 8
inservice
!
real 9.9.9.76
reassign 4
faildetect numconns 255 numclients 8
inservice
!
ip slb vserver V0-GGSN
virtual 10.10.10.10 udp 3386 service gtp
serverfarm SAMI1
idle gtp request 100
inservice
!
ip slb vserver V1-GGSN
virtual 10.10.10.10 udp 2123 service gtp
serverfarm SAMI1
idle gtp request 100
inservice
!
ip slb dfp password ciscodfp 0
agent 9.9.9.72 1111 30 0 10
agent 9.9.9.73 1111 30 0 10
agent 9.9.9.74 1111 30 0 10
agent 9.9.9.75 1111 30 0 10
agent 9.9.9.76 1111 30 0 10
!
interface FastEthernet9/36
description TO SGSN
no ip address
switchport
switchport access vlan 302
!
interface Vlan101
description Vlan to GGSN for GN
ip address 10.1.1.1 255.255.255.0
!
interface Vlan302
ip address 40.0.2.1 255.255.255.0
!
router ospf 300
log-adjacency-changes
summary-address 9.9.9.0 255.255.255.0
redistribute static subnets route-map GGSN-routes
network 40.0.2.0 0.0.0.255 area 300
network 40.0.3.0 0.0.0.255 area 300
!
ip route 9.9.9.72 255.255.255.255 10.1.1.72
ip route 9.9.9.73 255.255.255.255 10.1.1.73
ip route 9.9.9.74 255.255.255.255 10.1.1.74
ip route 9.9.9.75 255.255.255.255 10.1.1.75
ip route 9.9.9.76 255.255.255.255 10.1.1.76
!
access-list 1 permit 9.9.9.0 0.0.0.255
!
route-map GGSN-routes permit 10
match ip address 1
!
!

GGSN1 の設定例

!
ip dfp agent gprs
port 1111
password ciscodfp 0
inservice
!
interface Loopback100
description GPRS GTP V-TEMPLATE IP ADDRESS
ip address 9.9.9.72 255.255.255.0
!
interface GigabitEthernet0/0.2
description Gn Interface
encapsulation dot1Q 101
ip address 10.1.1.72 255.255.255.0
no cdp enable
!
interface Virtual-Template1
description GTP v-access
ip unnumbered Loopback100
encapsulation gtp
gprs access-point-list gprs
!
! route to SGSNs
ip route 40.1.2.1 255.255.255.255 10.1.1.1
ip route 40.2.2.1 255.255.255.255 10.1.1.1