Cisco Mobile Wireless Home Agent 機能ガイド Cisco IOS Release 12.4(15)XM Cisco Mobile Wireless Home Agent 4.0
HA でのホーム アドレス割り当て
HA でのホーム アドレス割り当て
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

HA でのホーム アドレス割り当て

ホーム アドレス割り当て

スタティック IP アドレス

NAI を使用しないスタティック ホーム アドレッシング

NAI を使用するスタティック ホーム アドレッシング

ローカル認可

AAA の認可

ダイナミック HA 割り当て

ダイナミック IP アドレス

固定アドレッシング

ローカル プール割り当て

DHCP 割り当て

AAA からのダイナミック アドレッシング

ODAP

ODAP ベースのアドレス割り当ての設定

ODAP の制約事項

同一 NAI に複数のスタティック アドレスを使用する場合のアドレス割り当て

同一 NAI に異なるモバイル端末を使用する場合のアドレス割り当て

設定例

ODAP 冗長設定

DHCP プロキシ クライアント設定

HA でのホーム アドレス割り当て

この章では、Cisco Mobile Wireless Home Agent がモバイル ノードにホーム アドレスを割り当てる方法、各種アドレス タイプについて説明し、設定の詳細および設定例を示します。

この章の構成は、次のとおりです。

「ホーム アドレス割り当て」

「スタティック IP アドレス」

「ダイナミック HA 割り当て」

「ダイナミック IP アドレス」

「ODAP」

「ODAP ベースのアドレス割り当ての設定」

「設定例」

ホーム アドレス割り当て

Home Agent(HA)は、モバイル IP 登録時に受信したユーザ NAI に基づいて、モバイル ノードにホーム アドレスを割り当てます。モバイル ステーションには、スタティックまたはダイナミックに IP アドレスを割り当てることができます。HA は、スタティック割り当てかダイナミック割り当てかを問わず、同じ IP アドレスで異なる NAI を同時に登録することを認めません。

スタティック IP アドレス

スタティック IP アドレスは、モバイル ステーションに前もって割り当てられたアドレスであり、モバイル デバイスにすでに設定されていることもあります。HA はパブリック IP アドレスでも、プライベート ドメインのアドレスでも、スタティック アドレスをサポートします。


) モバイル IP サービスにプライベート アドレスを使用するには、PDSN/FA と HA 間にリバース トンネリングが必要です。


モバイル ユーザは登録要求メッセージで、設定済みアドレスまたは使用可能アドレスを非ゼロのホーム アドレスとして提案します。HA は、このアドレスを受け付けることもあれば、登録応答メッセージで別のアドレスを返すこともあります。HA は、ホーム AAA(認証、認可、アカウンティング)サーバまたは DHCP サーバにアクセスすることによって、IP アドレスを取得できます。ホーム AAA サーバは、ローカル プール名を返すこともあれば、単一の IP アドレスを返すこともあります。モバイル IP 登録が成功すると、ユーザはモバイル IP ベースのサービスを利用できるようになります。

NAI を使用しないスタティック ホーム アドレッシング

最初のモバイル IP 仕様でサポートしていたのは、モバイル ノードのスタティック アドレッシングだけでした。ホーム IP アドレスが認証の「ユーザ名」の部分として使用されていました。スタティック アドレッシングは、各デバイスがどこからネットワークに接続しようと、常に同じアドレスが維持されるので、便利な場合があります。この場合、ユーザは DNS をアップデートしたり、他の形式のアドレス形式を使用しなくても、モバイル終端サービスを実行できます。また、スタティック アドレッシングではホーム アドレスと HA が常に同じなので、MN の管理が容易です。しかし、スタティック アドレッシングの場合、アドレス割り当てを手動で処理し、HA と MN の両方をアップデートしなければならないので、プロビジョニングとメンテナンスははるかに困難になります。設定例を示します。

router (config)# ip mobile host 10.0.0.5 interface FastEthernet0/0
router (config)# ip mobile host 10.0.0.10 10.0.0.15 interface FastEthernet0/0
router (config)# ip mobile secure host 10.0.0.12 spi 100 key ascii secret
 

NAI を使用するスタティック ホーム アドレッシング

スタティック ホーム アドレッシングを NAI と組み合わせて使用することによって、NAI ベースの認証およびその他のサービスをサポートすることもできます。また、単一ユーザに同一デバイスまたは複数のデバイス上で複数のスタティック IP アドレスを使用させながら、なおかつ 1 つの AAA レコードとセキュリティのアソシエーションを維持することもできます。ユーザがアドレスを使用して認可を受けてからでなければ、登録は受け付けられません。アドレスはローカルで認可することも、AAA サーバを使用して認可することもできます。異なる NAI のバインディングとすでに関連付けられているアドレスを MN が要求した場合、HA はコマンドが設定されていないかぎり、プールに含まれている別のアドレスを返そうとします。

設定例を示します。

router (config)# ip mobile home-agent reject-static-addr

ローカル認可

スタティック アドレスの認可は、設定コマンドを使用して MN ベースで、またはレルムベースで行うことができます。MN ベースの設定には、user または user@realm の形式で具体的な NAI を定義する必要があります。レルムベースの設定には、@realm の形式で総称 NAI を定義する必要があります。ローカル プールの指定だけが認められます。

設定例を示します。

router (config)# ip local pool static-pool 10.0.0.5 10.0.0.10
router (config)# ip mobile host nai user@staticuser.com static-address 10.0.0.1 10.0.0.2
interface FastEthernet0/0
router (config)# ip mobile host nai user@staticuser.com static-address local-pool static-pool interface FastEthernet0/0
router (config)# ip mobile host nai @static.com static-address local-pool static-pool
interface FastEthernet0/0
 

AAA の認可

認可されたアドレスまたはローカル プール名を AAA サーバに保管することもできます。各ユーザには、AAA サーバで設定された static-ip-addresses アトリビュートまたは static-ip-pool アトリビュートが必要です。コマンドラインでスタティック アドレスを設定する場合と異なり、static-ip-addresses アトリビュートは返すことのできるアドレスの数に制限がありません。

設定例を示します。

HA の設定

router (config)# ip local pool static-pool 10.0.0.5 10.0.0.10
router (config)# ip mobile host nai user@staticuser.com interface FastEthernet0/0 aaa
router (config)# ip mobile host nai @static.com interface FastEthernet0/0 aaa
 

RADIUS のアトリビュート

Cisco-AVPair = "mobileip:static-ip-addresses=10.0.0.1 10.0.0.2 10.0.0.3"

Cisco-AVPair = "mobileip:static-ip-pool=static-pool"

ダイナミック HA 割り当て

次の条件が存在する場合、CDMA2000 ネットワークでは HA のダイナミック割り当てが可能です。

最初の条件は、HA が HA フィールドに 0.0.0.0 の値が指定されたモバイル IP 登録要求を受信することです。認証/認可時に、PDSN が HA の IP アドレスを取得します。PDSN はさらに、このアドレスを使用して HA に登録要求を転送します。ただし、登録要求の実際の HA アドレス フィールドはアップデートされません。

HA は登録応答を送信し、HAフィールドに専用の IP アドレスを格納します。この時点で受信する再登録要求は、HA フィールドに HA の IP アドレスが入ります。

第 2 の条件は、PDSN/FA の機能であり、それがここで含まれていないと完全ではありません。この場合、AAA サーバを使用してダイナミック HA 割り当て機能を実行します。ネットワーク トポロジに応じて、ローカル AAA サーバまたはホーム AAA サーバがこの機能を実行します。アクセス サービス プロバイダーが ISP でもある場合、HA はアクセス プロバイダーのネットワークに配置されます。このサービス環境では、ローカル AAA サーバが HA の割り当て機能を実行します。AAA サーバはアクセス要求メッセージで受け取ったユーザ NAI に基づいて、PDSN へのアクセス応答メッセージで選択した HA のアドレスを返します。

HA アドレス プールは通常、AAA サーバで設定されます。アクセス プロバイダーが ISP として機能する場合、ローカル AAA サーバで複数の HA プールを設定できますが、これはモバイル IP サービスまたはプロキシ モバイル IP サービスのサポート対象となるドメインのある SLA に依存します。ユーザ NAI 選択条件としてラウンドロビンまたはハッシュ アルゴリズムを使用すると、AAA サーバで HA 選択手順を設定できます。

PDSN/FA は HA に登録要求を送信しますが、MIP RRQ の HA フィールドに IP アドレスは含まれません(0.0.0.0)。PDSN は AAA から IP アドレスを受け取った時点で、MIP RRQ を更新せず、その RRQ を取得した HA アドレスに転送します。PDSN は MN-HA SPI およびキー値([Home Agent] フィールドで指定された HA の IP アドレスが含まれる)が不明なので、MIP RRQ を変更できません。ネットワーク トポロジに応じて、ローカル AAA サーバまたはホーム AAA サーバがこの機能を実行します。HA がアクセス プロバイダーのネットワークに配置されている場合、ローカル AAA サーバが HA の割り当て機能を実行します。さらに、モバイル IP サービスまたはプロキシ モバイル IP サービスのサポート対象となるドメインのある SLA に応じて、ローカル AAA サーバで複数の HA プールを設定できます。

ダイナミック IP アドレス

パケット データ サービスにアクセスするモバイル ステーションで、ホーム IP アドレスを設定する必要はありません。モバイル ユーザは、登録要求メッセージですべてゼロのホーム アドレスを提出することによって、ダイナミック割り当てのアドレスを要求できます。HA がホーム アドレスを割り当て、登録応答メッセージで MN に返します。HA はホーム AAA sバにアクセスすることによって IP アドレスを取得します。AAA サーバは、ローカル プール名または単一の IP アドレスを返します。登録が成功すると、ユーザはモバイル IP ベースのサービスを利用できるようになります。

固定アドレッシング

各 NAI に固定アドレスを指定して HA を設定できます。固定アドレスは、登録するたびに MN に割り当てられます。この場合、ユーザはスタティック アドレッシングのすべての利点を生かしながら、MN の設定を簡素化できます。固定アドレッシングは、大規模展開には推奨できません。全ユーザ メンテナンスを実行するために、HA 設定をアップデートしなければならないからです。

設定例を示します。

router# ip mobile host nai user@realm.com address 10.0.0.1 interface FastEthernet0/0

ローカル プール割り当て

ローカル プールを割り当てるには、HA 上で 1 つまたは複数のアドレス プールを設定する必要があります。HA は先着順方式で、プールからアドレスを割り当てます。MN は HA にアクティブ バインディングがあるかぎり、アドレスを維持します。MN は割り当てられたアドレスまたは 0.0.0.0 をホーム アドレスとした RRQ を送信することによって、バインディングをアップデートできます。バインディングが期限切れになると、ただちにアドレスがプールに返されます。


) 現在、ピアツーピア HA 冗長モデルでローカル プール割り当てを使用することはできません。設定できるローカル プール数を制限するものは、ルータ上で使用できるメモリだけです。


設定例を示します。

router (config)# ip local pool mippool 10.0.0.5 10.0.0.250
router (config)# ip mobile host nai @localpool.com address pool local mippool virtual-network 10.0.0.0 255.255.255.0

DHCP 割り当て

DHCP は、デスクトップ コンピュータの IP アドレス割り当てにすでに広く用いられている方式です。IOS モバイル IP は、IOS にすでにある DHCP プロキシ クライアントを活用して、DHCP サーバにホーム アドレスを割り当てさせます。NAI は Client-ID オプションで送信され、ダイナミック DNS サービスの提供に使用できます。

設定例を示します。

router(config)# ip mobile host nai @dhcppool.com address pool dhcp-proxy-client dhcp-server 10.1.2.3 interface FastEthernet 0/0
 

) 現在、ピアツーピア HA 冗長モデルで DHCP を使用することはできません。


AAA からのダイナミック アドレッシング

AAA からのダイナミック アドレッシングを使用すると、MN または HA でアドレッシングを維持する手間をかけなくても、MN の固定アドレッシング、セッション単位のアドレッシング、またはその両方をサポートできます。AAA サーバは特定のアドレス、ローカル プール名、または DHCP サーバ アドレスを返すことができます。AAA サーバを使用して特定のアドレスを返す場合は、RADIUS データベースの NAI エントリでアトリビュートとしてホーム アドレスを設定することも、または使用する AAA サーバの機能によっては、プールからホーム アドレスを割り当てることもできます。AAA サーバは、HA で設定されているローカル プールの名前または DHCP サーバの IP アドレスを返すこともできます。

設定例を示します。

HA 上:

router (config)# ip local pool dynamic-pool 10.0.0.5 10.0.0.10
router (config)# ip mobile host nai user@staticuser.com interface FastEthernet0/0 aaa
router (config)# ip mobile host nai @static.com interface FastEthernet0/0 aaa
 

AAA アドレス割り当て:
Cisco-AVPair = "mobileip:ip-address=65.0.0.71"

AAA ローカル プール アトリビュート:
Cisco-AVPair = "mobileip:ip-pool=dynamic-pool"

AAA DHCP サーバ アトリビュート:
Cisco-AVPair = "mobileip:dhcp-server=10.1.5.10"

ODAP

SAMI カードを使用して高密度 HA を実現する場合は、中央のソースから IP アドレスを割り当てることを選択できます。Cisco IOS ODAP(オンデマンド アドレス プール)がこの機能を提供します。ODAP によって HA の設定が簡素化されるので、HA コンフィギュレーションごとにローカル IP アドレス プールを設定する必要はありません。

ODAP を使用すると、大型アドレス プールの管理を中央に集中させ、大型ネットワークの設定を簡素化できます。ODAP 機能は次の 2 つのコンポーネントからなります。

DHCP ODAP サブネット アロケーション サーバ

ODAP マネージャ(各 HA に配置)

DHCP ODAP サブネット アロケーション サーバは、サブネット単位で IP アドレス スペースを作成して割り当てる場合に設定します。これらのプールのサイズは設定可能であり、これらのサブネットは HA 上の ODAP マネージャにリースされます。また、ODAP マネージャ が割り当てるためのサブネット アロケーション プールを提供します。DHCP ODAP サブネット アロケーション サーバ機能は、SAMI 上の HA インスタンスの 1 つに配置できます。DHCP ODAP サブネット アロケーション サーバ機能を別の外部 Cisco IOS ルータまたは外部 Cisco アクセス レジスタに配置することもできます。

ODAP マネージャ機能は、各 HA イメージに配置します。HA はローカル IP プールではなく、ODAP マネージャ機能を使用します。ODAP マネージャは、IP アドレスの需要と各 HA のサブネット アベイラビリティに基づいて、ODAP サブネット アロケーション サーバからサブネットをリースします。HA 上の ODAP マネージャは、これらのサブネットからクライアントにアドレスを割り当て、アドレスの使用状況に応じてサブネット プールのサイズをダイナミックに増減します。HA ODAP マネージャがサブネットをリースするときには、HA が受信するサブネットごとに、集約ルートが自動的に追加されます。このルートはスタティック ルートであり、ヌル インターフェイスに追加されます。

HA 上の ODAP マネージャがサブネットを割り当てると、ODAP サブネット アロケーション サーバがサブネット バインディングを作成します。このバインディングは、ODAP マネージャがアドレス スペースを必要とする間、DHCP データベースに保管されます。バインディングが破棄されて、サブネットがサブネット プールに返されるのは、アドレス スペースの使用率が下がり、HA ODAP マネージャがサブネットを解放するときだけです。

DHCP ODAP サブネット アロケーション サーバには、拡張 DHCP 機能があります。この機能は、単一の IP アドレスを返す代わりに、アドレスのサブネットを返します。ODAP マネージャは、HA 上でこの IP アドレス プールを管理します。この機能は、ルーティング プロトコルにとってより効率的なルート集約を行います。

ODAP ベースのアドレス割り当ての設定

HA が ODAP プールをサポートできるようにする手順は、次のとおりです。

コマンド
目的

ステップ 1

Router(config)# ip mobile host nai address pool dhcp-pool odap poolname

HA が ODAP アドレス プールをサポートできるようにします。

例を示します。

Router (config)#ip mobile host nai @ispbar2.com address pool dhcp-pool ha-dhcp-pool

ODAP の制約事項

ODAP 機能の制約事項は、次のとおりです。

ピアツーピアの冗長性を使用する ODAP はサポートされません。

ODAP サーバの最小サブネット リース時間は 10 分にする必要があります。

rf-interdev サポートを指定したプリエンプトは機能しません。

同一 NAI に複数のスタティック アドレスを使用する場合のアドレス割り当て

Cisco HA は、同じ NAI に複数のスタティック アドレスを使用する、マルチ モバイル IP 登録をサポートします。これは、ホーム AAA サーバまたは DHCP サーバで static-ip-address pool(複数可)を設定することによって実現されます。モバイル ユーザから登録要求メッセージを受信すると、HA はホーム AAA にアクセスして認証を行い、さらに通常は、IP アドレスを割り当てます。モバイル ユーザが提供したNAI はホーム AAA に送信されます。ホーム AAA サーバは、その NAI に対応するスタティック IP アドレスまたはスタティック IP プール名のリストを返します。

同一 NAI に異なるモバイル端末を使用する場合のアドレス割り当て

2 つの異なるモバイルから同じ NAI を使用して登録を行う場合、動作は次のようになります。

両方のケースでスタティック アドレス割り当てを使用する場合、それぞれ独立したケースとみなされます。

両方のケースでダイナミック アドレス割り当てを使用する場合、2 番めの登録が最初の登録に取って代わります。

最初の登録にスタティックを使用し、2 番めの登録にダイナミックを使用する場合、ダイナミック アドレス割り当てがスタティック アドレス割り当てに取って代わります。

最初の登録にダイナミックを使用し、2 番めにスタティックを使用する場合は、それぞれ独立したケースとみなされます。

さらに、2 つの異なる HA ながら、同じ NAI を使用する同じモバイルから発生した 2 つのフローは、別々のケースとみなされます。

設定例

ODAP 冗長設定

アクティブ HA の設定

 
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
redundancy inter-device
scheme standby cisco
!
ipc zone default
association 1
no shutdown
protocol sctp
local-port 500
local-ip 10.0.0.2
remote-port 500
remote-ip 10.0.0.3
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
!
ip dhcp ping packet 0
ip dhcp pool ha-dhcp-pool
origin dhcp subnet size initial /30 autogrow /30
ip subnet-zero
ip cef
!
interface Ethernet2/0
description to PDSN/FA
ip address 10.0.0.2 255.0.0.0
no ip route-cache
no ip mroute-cache
duplex half
standby ip 10.0.0.4
standby priority 110
standby preempt delay min 100
standby name cisco
!
interface Ethernet2/2
description to AAA
ip address 172.16.1.8 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex half
!
router mobile
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy cisco
ip mobile virtual-network 33.0.0.0 255.0.0.0
ip mobile host nai user14@cisco.com address pool dhcp-pool ha-dhcp-pool
virtual-network 10.0.0.0 255.0.0.0 aaa
ip mobile secure home-agent 10.0.0.3 spi 100 key ascii redundancy
algorithm md5 mode
prefix-suffix
!
radius-server host 172.16.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!
end
 
 

スタンバイ HA の設定

 
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
redundancy inter-device
scheme standby cisco
!
ipc zone default
association 1
no shutdown
protocol sctp
local-port 500
local-ip 10.0.0.3
remote-port 500
remote-ip 10.0.0.2
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
!
ip dhcp pool ha-dhcp-pool
origin dhcp subnet size initial /30 autogrow /30
ip subnet-zero
ip cef
!
interface Ethernet2/0
description to PDSN/FA
ip address 10.0.0.3 255.0.0.0
no ip route-cache
no ip mroute-cache
duplex half
standby ip 10.0.0.4
standby name cisco
!
 
interface Ethernet2/2
description to AAA
ip address 150.2.1.7 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex half
!
 
router mobile
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy cisco
ip mobile virtual-network 10.0.0.0 255.0.0.0
ip mobile host nai user14@cisco.com address pool dhcp-pool ha-dhcp-pool
virtual-network 10.0.0.0 255.0.0.0 aaa
ip mobile secure home-agent 10.0.0.2 spi 100 key ascii redundancy
algorithm md5 mode
prefix-suffix
!
radius-server host 172.16.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!
end

DHCP プロキシ クライアント設定

アクティブ HA の設定

 
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
!
ip subnet-zero
ip cef
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
interface Ethernet2/0
description to PDSN/FA
ip address 10.0.0.2 255.0.0.0
no ip route-cache
no ip mroute-cache
duplex half
standby ip 10.0.0.4
standby priority 110
standby preempt delay sync 100
standby name cisco
!
interface Ethernet2/2
description to AAA
ip address 172.16.1.8 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex half
!
router mobile
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy cisco
ip mobile virtual-network 10.0.0.0 255.0.0.0
ip mobile host nai user01@cisco.com address pool dhcp-proxy-client
dhcp-server 10.0.0.101 virtual-network 10.0.0.0 255.0.0.0
ip mobile secure home-agent 10.0.0.3 spi 100 key ascii redundancy
algorithm md5 mode
prefix-suffix
!
ip mobile virtual-network 10.0.0.0 255.0.0.0
ip mobile host nai user01@cisco.com address pool dhcp-proxy-client
dhcp-server 10.0.0.101 virtual-network 10.0.0.0 255.0.0.0
radius-server host 172.16.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!
end
 

スタンバイ HA の設定

 
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mwt10-7206b
!
aaa new-model
!
aaa authentication ppp default local group radius
aaa authorization config-commands
aaa authorization ipmobile default group radius
aaa authorization network default group radius
aaa session-id common
!
ip subnet-zero
ip cef
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
interface Ethernet2/0
description to PDSN/FA
ip address 10.0.0.3 255.0.0.0
no ip route-cache
no ip mroute-cache
duplex half
standby ip 10.0.0.4
standby name cisco
!
interface Ethernet2/2
description to AAA
ip address 172.16.1.7 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex half
!
router mobile
!
ip local pool ha-pool 10.0.0.1 10.0.0.255
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile home-agent redundancy cisco
ip mobile secure home-agent 10.0.0.2 spi 100 key ascii redundancy
algorithm md5 mode
prefix-suffix
ip mobile virtual-network 10.0.0.0 255.0.0.0
ip mobile host nai user01@cisco.com address pool dhcp-proxy-client
dhcp-server 10.0.0.101 virtual-network 10.0.0.0 255.0.0.0
!
radius-server host 150.2.0.2 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
line con 0
line aux 0
line vty 0 4
!

end